Microsoft.WindowsAPICodePack.DirectX Namespace

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Microsoft.WindowsAPICodePack.DirectX Namespace
Send Feedback
Root namespace for all DirectX types, include common DirectX types

Classes

 | Class | Description
Public class | DirectHelpers | This class provides a set of helper methods that can be used to extend the API, and wrap external natives interfaces.
Public class | DirectObject | Base for classes supporting an internal interface that is not an IUnknown
Public class | DirectUnknown | Base class for all classes supporting internal IUnknown interfaces
Public class | DirectXException | Base class for all DirectX exceptions.

Enumerations

 | Enumeration | Description
Public enumeration | ErrorCode | Error codes that can be returned by DXGI, Direct3D, Direct2D, DirectWrite or WIC

Copyright (c) Microsoft Corporation. All rights reserved.


DirectHelpers Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectHelpers Class
Members See Also Send Feedback
This class provides a set of helper methods that can be used to extend the API, and wrap external natives interfaces.

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public sealed class DirectHelpers
Visual Basic
Public NotInheritable Class DirectHelpers
Visual C++
public ref class DirectHelpers sealed

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectHelpers

See Also

DirectHelpers Members
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectHelpers Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectHelpers Members
DirectHelpers Class Methods See Also Send Feedback

The DirectHelpers type exposes the following members.

Methods

Name | Description
CreateInterfaceWrapper<(Of <<'(T>)>>) | Create a wrapper for a given native interface pointer that does not have an IUnknown. This method will not increase the ref count for the wrapped native interface. Also, when this class is disposed, the native interface will not be deleted or released. This method is mainly intended to wrap interfaces that do not inherit from IUnknown.
CreateIUnknownWrapper<(Of <<'(T>)>>) | Create a wrapper for a given native IUnknown interface pointer. This method will not increase the ref count for the wrapped native interface. However, when this class is disposed, the native interface will have Release() called. This method is mainly intended to wrap interfaces that inherit from IUnknown.
GetExceptionForErrorCode | Return an exception for a given ErrorCode
GetExceptionForHresult | Return an exception for a given HResult
ThrowExceptionForErrorCode | Throw an exception for a given ErrorCode. No exception will be thrown if the errorCode is Success.
ThrowExceptionForHresult | Throw an exception for a given HResult No exception will be thrown if the errorCode is Success.

See Also

DirectHelpers Class
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectHelpers Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectHelpers Methods
DirectHelpers Class See Also Send Feedback

The DirectHelpers type exposes the following members.

Methods

Name | Description
CreateInterfaceWrapper<(Of <<'(T>)>>) | Create a wrapper for a given native interface pointer that does not have an IUnknown. This method will not increase the ref count for the wrapped native interface. Also, when this class is disposed, the native interface will not be deleted or released. This method is mainly intended to wrap interfaces that do not inherit from IUnknown.
CreateIUnknownWrapper<(Of <<'(T>)>>) | Create a wrapper for a given native IUnknown interface pointer. This method will not increase the ref count for the wrapped native interface. However, when this class is disposed, the native interface will have Release() called. This method is mainly intended to wrap interfaces that inherit from IUnknown.
GetExceptionForErrorCode | Return an exception for a given ErrorCode
GetExceptionForHresult | Return an exception for a given HResult
ThrowExceptionForErrorCode | Throw an exception for a given ErrorCode. No exception will be thrown if the errorCode is Success.
ThrowExceptionForHresult | Throw an exception for a given HResult No exception will be thrown if the errorCode is Success.

See Also

DirectHelpers Class
Microsoft.WindowsAPICodePack.DirectX Namespace


CreateInterfaceWrapper(T) Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectHelpers..::..CreateInterfaceWrapper<(Of <(<'T>)>)> Method
DirectHelpers Class See Also Send Feedback
Create a wrapper for a given native interface pointer that does not have an IUnknown. This method will not increase the ref count for the wrapped native interface. Also, when this class is disposed, the native interface will not be deleted or released. This method is mainly intended to wrap interfaces that do not inherit from IUnknown.

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static T CreateInterfaceWrapper<T>(
    IntPtr nativeInterface
)
where T : DirectObject
Visual Basic
Public Shared Function CreateInterfaceWrapper(Of T As DirectObject) ( _
    nativeInterface As IntPtr _
) As T
Visual C++
public:
generic<typename T>
where T : DirectObject
static T CreateInterfaceWrapper(
    IntPtr nativeInterface
)

Parameters

nativeInterface
Type: System..::..IntPtr
The native pointer to the interface.

Type Parameters

T
The type of the object wrapper to create. Must inherit from DirectObject.

Return Value

A DirectObject wrapper.

See Also

DirectHelpers Class
Microsoft.WindowsAPICodePack.DirectX Namespace


CreateIUnknownWrapper(T) Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectHelpers..::..CreateIUnknownWrapper<(Of <(<'T>)>)> Method
DirectHelpers Class See Also Send Feedback
Create a wrapper for a given native IUnknown interface pointer. This method will not increase the ref count for the wrapped native interface. However, when this class is disposed, the native interface will have Release() called. This method is mainly intended to wrap interfaces that inherit from IUnknown.

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static T CreateIUnknownWrapper<T>(
    IntPtr nativeIUnknown
)
where T : DirectUnknown
Visual Basic
Public Shared Function CreateIUnknownWrapper(Of T As DirectUnknown) ( _
    nativeIUnknown As IntPtr _
) As T
Visual C++
public:
generic<typename T>
where T : DirectUnknown
static T CreateIUnknownWrapper(
    IntPtr nativeIUnknown
)

Parameters

nativeIUnknown
Type: System..::..IntPtr
The native pointer to the IUnknown interface.

Type Parameters

T
The type of the IUnknown wrapper to create. Must inherit from DirectUnknown.

Return Value

A DirectUnknown wrapper.

See Also

DirectHelpers Class
Microsoft.WindowsAPICodePack.DirectX Namespace


GetExceptionForErrorCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectHelpers..::..GetExceptionForErrorCode Method
DirectHelpers Class See Also Send Feedback
Return an exception for a given ErrorCode

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Exception GetExceptionForErrorCode(
    ErrorCode errorCode
)
Visual Basic
Public Shared Function GetExceptionForErrorCode ( _
    errorCode As ErrorCode _
) As Exception
Visual C++
public:
static Exception^ GetExceptionForErrorCode(
    ErrorCode errorCode
)

Parameters

errorCode
Type: Microsoft.WindowsAPICodePack.DirectX..::..ErrorCode
The ErrorCode value

Return Value

The equivalent exception

See Also

DirectHelpers Class
Microsoft.WindowsAPICodePack.DirectX Namespace


GetExceptionForHresult Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectHelpers..::..GetExceptionForHresult Method
DirectHelpers Class See Also Send Feedback
Return an exception for a given HResult

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Exception GetExceptionForHresult(
    int hresult
)
Visual Basic
Public Shared Function GetExceptionForHresult ( _
    hresult As Integer _
) As Exception
Visual C++
public:
static Exception^ GetExceptionForHresult(
    int hresult
)

Parameters

hresult
Type: System..::..Int32
The HResult value

Return Value

The equivalent exception

See Also

DirectHelpers Class
Microsoft.WindowsAPICodePack.DirectX Namespace


ThrowExceptionForErrorCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectHelpers..::..ThrowExceptionForErrorCode Method
DirectHelpers Class See Also Send Feedback
Throw an exception for a given ErrorCode. No exception will be thrown if the errorCode is Success.

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static void ThrowExceptionForErrorCode(
    ErrorCode errorCode
)
Visual Basic
Public Shared Sub ThrowExceptionForErrorCode ( _
    errorCode As ErrorCode _
)
Visual C++
public:
static void ThrowExceptionForErrorCode(
    ErrorCode errorCode
)

Parameters

errorCode
Type: Microsoft.WindowsAPICodePack.DirectX..::..ErrorCode
The ErrorCode value

See Also

DirectHelpers Class
Microsoft.WindowsAPICodePack.DirectX Namespace


ThrowExceptionForHresult Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectHelpers..::..ThrowExceptionForHresult Method
DirectHelpers Class See Also Send Feedback
Throw an exception for a given HResult No exception will be thrown if the errorCode is Success.

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static void ThrowExceptionForHresult(
    int hresult
)
Visual Basic
Public Shared Sub ThrowExceptionForHresult ( _
    hresult As Integer _
)
Visual C++
public:
static void ThrowExceptionForHresult(
    int hresult
)

Parameters

hresult
Type: System..::..Int32
The HResult value

See Also

DirectHelpers Class
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectObject Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectObject Class
Members See Also Send Feedback
Base for classes supporting an internal interface that is not an IUnknown

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public abstract class DirectObject : IDisposable
Visual Basic
Public MustInherit Class DirectObject _
    Implements IDisposable
Visual C++
public ref class DirectObject abstract : IDisposable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectPass
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectTechnique
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectType
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Include
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflectionConstantBuffer
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflectionType
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflectionVariable

See Also

DirectObject Members
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectObject Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectObject Members
DirectObject Class Properties See Also Send Feedback

The DirectObject type exposes the following members.

Properties

 | Name | Description
Public property | NativeObject | Get the internal native pointer for the wrapped native object

See Also

DirectObject Class
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectObject Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectObject Properties
DirectObject Class See Also Send Feedback

The DirectObject type exposes the following members.

Properties

 | Name | Description
Public property | NativeObject | Get the internal native pointer for the wrapped native object

See Also

DirectObject Class
Microsoft.WindowsAPICodePack.DirectX Namespace


NativeObject Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectObject..::..NativeObject Property
DirectObject Class See Also Send Feedback
Get the internal native pointer for the wrapped native object

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr NativeObject { get; }
Visual Basic
Public ReadOnly Property NativeObject As IntPtr
    Get
Visual C++
public:
property IntPtr NativeObject {
    IntPtr get ();
}

Return Value

A pointer to the wrapped native interfac.

See Also

DirectObject Class
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectUnknown Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectUnknown Class
Members See Also Send Feedback
Base class for all classes supporting internal IUnknown interfaces

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public abstract class DirectUnknown : IDisposable
Visual Basic
Public MustInherit Class DirectUnknown _
    Implements IDisposable
Visual C++
public ref class DirectUnknown abstract : IDisposable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DFactory
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GdiInteropRenderTarget
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SimplifiedGeometrySink
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..TessellationSink
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Blob
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDebug
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDevice
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Effect
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectPool
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InfoQueue
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Multithread
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflection
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflection1
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlock
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SwitchToRef
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DDebug
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DDevice
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InfoQueue
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SwitchToRef
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..DWriteFactory
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..Font
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFace
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamily
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamilyCollection
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..InlineObject
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..RenderingParams
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TypographySettingCollection
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapDecoder
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapFrameDecode
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSource
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..FormatConverter
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingBitmapLock
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingFactory

See Also

DirectUnknown Members
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectUnknown Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectUnknown Members
DirectUnknown Class Properties See Also Send Feedback

The DirectUnknown type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface

See Also

DirectUnknown Class
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectUnknown Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectUnknown Properties
DirectUnknown Class See Also Send Feedback

The DirectUnknown type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface

See Also

DirectUnknown Class
Microsoft.WindowsAPICodePack.DirectX Namespace


NativeInterface Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectUnknown..::..NativeInterface Property
DirectUnknown Class See Also Send Feedback
Get the internal native pointer for the wrapped IUnknown Interface

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr NativeInterface { get; }
Visual Basic
Public ReadOnly Property NativeInterface As IntPtr
    Get
Visual C++
public:
property IntPtr NativeInterface {
    IntPtr get ();
}

Return Value

A pointer to the wrapped native IUnknown.

See Also

DirectUnknown Class
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Class
Members See Also Send Feedback
Base class for all DirectX exceptions.

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DirectXException : Exception
Visual Basic
Public Class DirectXException _
    Inherits Exception
Visual C++
public ref class DirectXException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Microsoft.WindowsAPICodePack.DirectX..::..DirectXException
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Direct2DException
Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Direct3DException
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsException
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingException

See Also

DirectXException Members
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Members
DirectXException Class Constructors Properties See Also Send Feedback

The DirectXException type exposes the following members.

Constructors

 | Name | Description
Public method | DirectXException()()()() | Default constructor
Public method | DirectXException(Int32) |
Public method | DirectXException(String) |
Protected method | DirectXException(SerializationInfo, StreamingContext) |
Public method | DirectXException(String, Exception) |
Public method | DirectXException(String, Int32) |
Protected method | DirectXException(SerializationInfo, StreamingContext, Int32) |
Public method | DirectXException(String, Exception, Int32) |

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API

See Also

DirectXException Class
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Constructor
DirectXException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DirectXException()()()() | Default constructor
Public method | DirectXException(Int32) |
Public method | DirectXException(String) |
Protected method | DirectXException(SerializationInfo, StreamingContext) |
Public method | DirectXException(String, Exception) |
Public method | DirectXException(String, Int32) |
Protected method | DirectXException(SerializationInfo, StreamingContext, Int32) |
Public method | DirectXException(String, Exception, Int32) |

See Also

DirectXException Class
DirectXException Members
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Constructor
DirectXException Class See Also Send Feedback
Default constructor

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DirectXException()
Visual Basic
Public Sub New
Visual C++
public:
DirectXException()

See Also

DirectXException Class
DirectXException Overload
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Constructor (Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Constructor (Int32)
DirectXException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DirectXException(
    int hr
)
Visual Basic
Public Sub New ( _
    hr As Integer _
)
Visual C++
public:
DirectXException(
    int hr
)

Parameters

hr
Type: System..::..Int32

See Also

DirectXException Class
DirectXException Overload
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Constructor (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Constructor (String)
DirectXException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DirectXException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
DirectXException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

DirectXException Class
DirectXException Overload
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Constructor (SerializationInfo, StreamingContext)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Constructor (SerializationInfo, StreamingContext)
DirectXException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected DirectXException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
DirectXException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext

See Also

DirectXException Class
DirectXException Overload
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Constructor (String, Exception)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Constructor (String, Exception)
DirectXException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DirectXException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
DirectXException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception

See Also

DirectXException Class
DirectXException Overload
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Constructor (String, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Constructor (String, Int32)
DirectXException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DirectXException(
    string message,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    hr As Integer _
)
Visual C++
public:
DirectXException(
    String^ message,
    int hr
)

Parameters

message
Type: System..::..String
hr
Type: System..::..Int32

See Also

DirectXException Class
DirectXException Overload
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Constructor (SerializationInfo, StreamingContext, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Constructor (SerializationInfo, StreamingContext, Int32)
DirectXException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected DirectXException(
    SerializationInfo info,
    StreamingContext context,
    int hr
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext, _
    hr As Integer _
)
Visual C++
protected:
DirectXException(
    SerializationInfo^ info,
    StreamingContext context,
    int hr
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext
hr
Type: System..::..Int32

See Also

DirectXException Class
DirectXException Overload
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Constructor (String, Exception, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Constructor (String, Exception, Int32)
DirectXException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DirectXException(
    string message,
    Exception innerException,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception, _
    hr As Integer _
)
Visual C++
public:
DirectXException(
    String^ message,
    Exception^ innerException,
    int hr
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception
hr
Type: System..::..Int32

See Also

DirectXException Class
DirectXException Overload
Microsoft.WindowsAPICodePack.DirectX Namespace


DirectXException Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException Properties
DirectXException Class See Also Send Feedback

The DirectXException type exposes the following members.

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API

See Also

DirectXException Class
Microsoft.WindowsAPICodePack.DirectX Namespace


ErrorCode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DirectXException..::..ErrorCode Property
DirectXException Class See Also Send Feedback
The error code returned by a DirectX API

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int ErrorCode { get; }
Visual Basic
Public ReadOnly Property ErrorCode As Integer
    Get
Visual C++
public:
property int ErrorCode {
    int get ();
}

See Also

DirectXException Class
Microsoft.WindowsAPICodePack.DirectX Namespace


ErrorCode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ErrorCode Enumeration
See Also Send Feedback
Error codes that can be returned by DXGI, Direct3D, Direct2D, DirectWrite or WIC

Namespace: Microsoft.WindowsAPICodePack.DirectX
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ErrorCode
Visual Basic
Public Enumeration ErrorCode
Visual C++
public enum class ErrorCode

Members

Member name | Description
ImagingErrorWrongState |
ImagingErrorValueOverflow |
ImagingErrorValueOutOfRange |
ImagingErrorUnsupportedVersion |
ImagingErrorUnsupportedPixelFormat |
ImagingErrorUnsupportedOperation |
ImagingErrorUnexpectedSize |
ImagingErrorUnexpectedMetadataType |
ImagingErrorUnknownImageFormat |
ImagingErrorTooMuchMetadata |
ImagingErrorStreamNotAvailable |
ImagingErrorStreamRead |
ImagingErrorStreamWrite |
ImagingErrorSourceRectDoesNotMatchDimensions |
ImagingErrorRequestOnlyValidAtMetadataRoot |
ImagingErrorPropertyUnexpectedType |
ImagingErrorPropertySize |
ImagingErrorPropertyNotSupported |
ImagingErrorPropertyNotFound |
ImagingErrorPaletteUnavailable |
ImagingErrorNotInitialized |
ImagingErrorInvalidRegistration |
ImagingErrorInvalidQueryRequest |
ImagingErrorInvalidQueryCharacter |
ImagingErrorInternal |
ImagingErrorInsufficientBuffer |
ImagingErrorImageSizeOutOfRange |
ImagingErrorGeneric |
ImagingErrorFrameMissing |
ImagingErrorDuplicateMetadataPresent |
ImagingErrorComponentNotFound |
ImagingErrorComponentInitializeFailure |
ImagingErrorCodecTooManyScanLines |
ImagingErrorCodecPresent |
ImagingErrorCodecNoThumbnail |
ImagingErrorBadStreamData |
ImagingErrorBadMetadataHeader |
ImagingErrorBadImage |
ImagingErrorBadHeader |
ImagingErrorAlreadyLocked |
Direct2DErrorZeroVector |
Direct2DErrorWrongState |
Direct2DErrorWrongResourceDomain |
Direct2DErrorWrongFactory |
Direct2DErrorWin32Error |
Direct2DErrorUnsupportedVersion |
Direct2DErrorUnsupportedOperation |
Direct2DErrorTooManyShaderElements |
Direct2DErrorTextRendererNotReleased |
Direct2DErrorTextEffectIsWrongType |
Direct2DErrorTargetNotGdiCompatible |
Direct2DErrorShaderCompileFailed |
Direct2DErrorScreenAccessDenied |
Direct2DErrorScannerFailed |
Direct2DErrorRenderTargetHasLayerOrClipRect |
Direct2DErrorRecreateTarget |
Direct2DErrorPushPopUnbalanced |
Direct2DErrorPopCallDidNotMatchPush |
Direct2DErrorNotInitialized |
Direct2DErrorNoHardwareDevice |
Direct2DErrorMaxTextureSizeExceeded |
Direct2DErrorLayerAlreadyInUse |
Direct2DErrorInvalidCall |
Direct2DErrorInternalError |
Direct2DErrorInsufficientBuffer |
Direct2DErrorIncompatibleBrushTypes |
Direct2DErrorExceedsMaxBitmapSize |
Direct2DErrorDisplayStateInvalid |
Direct2DErrorDisplayFormatNotSupported |
Direct2DErrorBadNumber |
Direct3D10ErrorFileNotFound |
Direct3D10ErrorTooManyUniqueInstances |
Direct3D11ErrorTooManyUniqueInstances |
Direct3D11ErrorFileNotFound |
GraphicsErrorUnsupported |
GraphicsErrorWasStillDrawing |
GraphicsErrorRemoteOutOfMemory |
GraphicsErrorRemoteClientDisconnected |
GraphicsErrorNotFound |
GraphicsErrorNotCurrentlyAvailable |
GraphicsErrorNonexclusive |
GraphicsErrorMoreData |
GraphicsErrorInvalidCall |
GraphicsErrorGraphicsVideoPresentNetworkSourceInUse |
GraphicsErrorFrameStatisticsDisjoint |
GraphicsErrorDriverInternalError |
GraphicsErrorDeviceReset |
GraphicsErrorDeviceRemoved |
GraphicsErrorDeviceHung |
AccessDenied |
Aborted |
NotImplemented |
Fail |
OutOfMemory |
InvalidArgument |
FalseSuccess |
Success |

See Also

Microsoft.WindowsAPICodePack.DirectX Namespace


Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace
Send Feedback
Direct2D 1.0 APIs and Types.

Classes

 | Class | Description
Public class | BitmapBrush | A bitmap brush allows a bitmap to be used to fill a geometry. (Also see DirectX SDK: ID2D1BitmapBrush)
Public class | BitmapRenderTarget | Renders to an intermediate texture. This RenderTarget is created by CreateCompatibleRenderTarget()()()() or one of its overloads. (Also see DirectX SDK: ID2D1BitmapRenderTarget)
Public class | Brush | The root brush interface. All brushes can be used to fill or pen a geometry. (Also see DirectX SDK: ID2D1Brush)
Public class | D2DBitmap | Represents a bitmap that has been bound to a RenderTarget. (Also see DirectX SDK: ID2D1Bitmap)
Public class | D2DFactory | Creates Direct2D resources. (Also see DirectX SDK: ID2D1Factory)
Public class | D2DResource | The base class for all resources in Direct2D 1.0 (Also see DirectX SDK: ID2D1Resource)
Public class | DCRenderTarget | Issues drawing commands to a GDI device context. (Also see DirectX SDK: ID2D1DCRenderTarget)
Public class | Direct2DException | Base class for all Direct2D exceptions
Public class | DrawingStateBlock | Represents the drawing state of a render target: the antialiasing mode, transform, tags, and text-rendering options. (Also see DirectX SDK: ID2D1DrawingStateBlock)
Public class | EllipseGeometry | Represents an ellipse. (Also see DirectX SDK: ID2D1EllipseGeometry)
Public class | GdiInteropRenderTarget | Provides access to an device context that can accept GDI drawing commands. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget)
Public class | Geometry | Represents a geometry resource and defines a set of helper methods for manipulating and measuring geometric shapes. Classes that inherit from ID2D1Geometry define specific shapes. (Also see DirectX SDK: ID2D1Geometry)
Public class | GeometryGroup | Represents a composite geometry, composed of other Geometry objects. (Also see DirectX SDK: ID2D1GeometryGroup)
Public class | GeometrySink | Describes a geometric path that can contain lines, arcs, cubic Bezier curves, and quadratic Bezier curves. (Also see DirectX SDK: ID2D1GeometrySink)
Public class | GradientStopCollection | Represents a collection of GradientStop for either a linear or radial gradient brush. (Also see DirectX SDK: ID2D1GradientStopCollection)
Public class | HwndRenderTarget | Renders drawing instructions to a window. (Also see DirectX SDK: ID2D1HwndRenderTarget)
Public class | Layer | Represents the backing store required to render a layer. (Also see DirectX SDK: ID2D1Layer)
Public class | LinearGradientBrush | Paints an area with a linear gradient. (Also see DirectX SDK: ID2D1LinearGradientBrush)
Public class | Mesh | Represents a set of vertices that form a list of triangles. (Also see DirectX SDK: ID2D1Mesh)
Public class | PathGeometry | Represents a complex shape that may be composed of arcs, curves, and lines. (Also see DirectX SDK: ID2D1PathGeometry)
Public class | RadialGradientBrush | Paints an area with a radial gradient. (Also see DirectX SDK: ID2D1RadialGradientBrush)
Public class | RectangleGeometry | Describes a two-dimensional rectangle. (Also see DirectX SDK: ID2D1RectangleGeometry)
Public class | RenderTarget | Represents an object that can receive drawing commands. Interfaces that inherit from RenderTarget render the drawing commands they receive in different ways. (Also see DirectX SDK: ID2D1RenderTarget)
Public class | RoundedRectangleGeometry | Describes a rounded rectangle. (Also see DirectX SDK: ID2D1RoundedRectangleGeometry)
Public class | SimplifiedGeometrySink | Describes a geometric path that does not contain quadratic bezier curves or arcs. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink)
Public class | SolidColorBrush | Paints an area with a solid color. (Also see DirectX SDK: ID2D1SolidColorBrush)
Public class | StrokeStyle | Describes the caps, miter limit, line join, and dash information for a stroke. (Also see DirectX SDK: ID2D1StrokeStyle)
Public class | TessellationSink | Populates a Mesh object with triangles. (Also see DirectX SDK: ID2D1TessellationSink)
Public class | TransformedGeometry | Represents a geometry that has been transformed. (Also see DirectX SDK: ID2D1TransformedGeometry)

Structures

 | Structure | Description
Public structure | ArcSegment | Describes an elliptical arc between two points. (Also see DirectX SDK: D2D1_ARC_SEGMENT)
Public structure | BezierSegment | Represents a cubic bezier segment drawn between two points. (Also see DirectX SDK: D2D1_BEZIER_SEGMENT)
Public structure | BitmapBrushProperties | Describes the extend modes and the interpolation mode of a BitmapBrush. (Also see DirectX SDK: D2D1_BITMAP_BRUSH_PROPERTIES)
Public structure | BitmapProperties | Describes the pixel format and dpi of a bitmap. (Also see DirectX SDK: D2D1_BITMAP_PROPERTIES)
Public structure | BrushProperties | Describes the opacity and transformation of a brush. (Also see DirectX SDK: D2D1_BRUSH_PROPERTIES)
Public structure | ColorF | Describes the red, green, blue, and alpha components of a color. (Also see DirectX SDK: D2D1_COLOR_F)
Public structure | ColorI | Describes the red, green, blue, and alpha components of a color using integer values.
Public structure | DpiF | Define horizontal and vertical Dpi settings.
Public structure | DrawingStateDescription | Describes the drawing state of a render target. This also specifies the drawing state that is saved into a DrawingStateBlock object. (Also see DirectX SDK: D2D1_DRAWING_STATE_DESCRIPTION)
Public structure | Ellipse | Contains the center point, x-radius, and y-radius of an ellipse. (Also see DirectX SDK: D2D1_ELLIPSE)
Public structure | FactoryOptions | Allows additional parameters for factory creation. (Also see DirectX SDK: D2D1_FACTORY_OPTIONS)
Public structure | GradientStop | Contains the position and color of a gradient stop. (Also see DirectX SDK: D2D1_GRADIENT_STOP)
Public structure | HwndRenderTargetProperties | Contains the window handle, pixel size, and presentation options for an HwndRenderTarget. (Also see DirectX SDK: D2D1_HWND_RENDER_TARGET_PROPERTIES)
Public structure | LayerParameters | Contains the content bounds, mask information, opacity settings, and other options for a layer resource. (Also see DirectX SDK: D2D1_LAYER_PARAMETERS)
Public structure | LinearGradientBrushProperties | Contains the starting point and endpoint of the gradient axis for a LinearGradientBrush. (Also see DirectX SDK: D2D1_LINEAR_GRADIENT_BRUSH_PROPERTIES)
Public structure | Matrix3x2F | Represents a 3-by-2 matrix. (Also see DirectX SDK: D2D1_MATRIX_3X2_F)
Public structure | PixelFormat | Contains the data format and alpha mode for a bitmap or render target. (Also see DirectX SDK: D2D1_PIXEL_FORMAT)
Public structure | Point2F | Represents an x-coordinate and y-coordinate pair, expressed as floating-point values, in two-dimensional space. (Also see DirectX SDK: D2D1_POINT_2F)
Public structure | Point2U | Represents an x-coordinate and y-coordinate pair, expressed as an unsigned 32-bit integer value, in two-dimensional space. (Also see DirectX SDK: D2D1_POINT_2U)
Public structure | PointAndTangent |
Public structure | QuadraticBezierSegment | Contains the control point and end point for a quadratic Bezier segment. (Also see DirectX SDK: D2D1_QUADRATIC_BEZIER_SEGMENT)
Public structure | RadialGradientBrushProperties | Contains the gradient origin offset and the size and position of the gradient ellipse for a RadialGradientBrush. (Also see DirectX SDK: D2D1_RADIAL_GRADIENT_BRUSH_PROPERTIES)
Public structure | Rect | Represents a rectangle defined by the upper-left corner pair of coordinates (left,top) and the lower-right corner pair of coordinates (right, bottom). These coordinates are expressed as a 32-bit signed integer values.
Public structure | RectF | Represents a rectangle defined by the coordinates of the upper-left corner (left, top) and the coordinates of the lower-right corner (right, bottom). (Also see DirectX SDK: D2D1_RECT_F)
Public structure | RectU | Represents a rectangle defined by the upper-left corner pair of coordinates (left,top) and the lower-right corner pair of coordinates (right, bottom). These coordinates are expressed as a 32-bit unsigned integer values. (Also see DirectX SDK: D2D1_RECT_U)
Public structure | RenderTargetProperties | Contains rendering options (hardware or software), pixel format, DPI information, remoting options, and Direct3D support requirements for a render target. (Also see DirectX SDK: D2D1_RENDER_TARGET_PROPERTIES)
Public structure | RoundedRect | Contains the dimensions and corner radii of a rounded rectangle. (Also see DirectX SDK: D2D1_ROUNDED_RECT)
Public structure | SizeF | Stores an ordered pair of integers, typically the width and height of a rectangle. (Also see DirectX SDK: D2D1_SIZE_F)
Public structure | SizeU | Stores an ordered pair of integers, typically the width and height of a rectangle. (Also see DirectX SDK: D2D1_SIZE_U)
Public structure | StrokeStyleProperties | Properties, aside from the width, that allow geometric penning to be specified. (Also see DirectX SDK: D2D1_STROKE_STYLE_PROPERTIES)
Public structure | Tags | Defines a two-tag element, which contains two application-defined 64-bit unsigned integer values used to mark a set of rendering operations.
Public structure | Triangle | Contains the three vertices that describe a triangle. (Also see DirectX SDK: D2D1_TRIANGLE)

Interfaces

 | Interface | Description
Public interface | IGdiInteropRenderTarget | Provides access to an device context that can accept GDI drawing commands. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget)
Public interface | IGeometrySink | Describes a geometric path that can contain lines, arcs, cubic Bezier curves, and quadratic Bezier curves. Implement this interface when you want to read back the complete contents of a geometry. For other scenarios, use the implementation provided by Direct2D: GeometrySink (Also see DirectX SDK: ID2D1GeometrySink)
Public interface | ISimplifiedGeometrySink | Describes a geometric path that does not contain quadratic bezier curves or arcs. Implement this interface when you want to read back the complete contents of a geometry. For other scenarios, use the implementation provided by Direct2D: SimplifiedGeometrySink (Also see DirectX SDK: ID2D1SimplifiedGeometrySink)
Public interface | ITessellationSink | Populates a Mesh object with triangles. Implement this interface when you want to read back the results of the Tessellate method. For other scenarios, use the implementation provided by Direct2D: TessellationSink (Also see DirectX SDK: ID2D1TessellationSink)

Enumerations

 | Enumeration | Description
Public enumeration | AlphaMode | Specifies how the alpha value of a bitmap or render target should be treated. (Also see DirectX SDK: D2D1_ALPHA_MODE)
Public enumeration | AntiAliasMode | Describes how non-text primitives are rendered. (Also see DirectX SDK: D2D1_ANTIALIAS_MODE)
Public enumeration | ArcSize | Specifies whether an arc should be greater than 180 degrees. (Also see DirectX SDK: D2D1_ARC_SIZE)
Public enumeration | BitmapInterpolationMode | Specifies the algorithm that is used when images are scaled or rotated. (Also see DirectX SDK: D2D1_BITMAP_INTERPOLATION_MODE)
Public enumeration | CapStyle | Enum which descibes the drawing of the ends of a line. (Also see DirectX SDK: D2D1_CAP_STYLE)
Public enumeration | CombineMode | This enumeration describes the type of combine operation to be performed. (Also see DirectX SDK: D2D1_COMBINE_MODE)
Public enumeration | CompatibleRenderTargetOptions | Specifies additional features supportable by a compatible render target when it is created. This enumeration allows a bitwise combination of its member values. (Also see DirectX SDK: D2D1_COMPATIBLE_RENDER_TARGET_OPTIONS)
Public enumeration | D2DFactoryType | Specifies the threading model of the created factory and all of its derived resources. (Also see DirectX SDK: D2D1_FACTORY_TYPE)
Public enumeration | DashStyle | Describes the sequence of dashes and gaps in a stroke. (Also see DirectX SDK: D2D1_DASH_STYLE)
Public enumeration | DCInitializeMode | Specifies how a device context is initialized for GDI rendering when it is retrieved from the render target. (Also see DirectX SDK: D2D1_DC_INITIALIZE_MODE)
Public enumeration | DebugLevel | Indicates the type of information that Direct2D sends to the debug layer. (Also see DirectX SDK: D2D1_DEBUG_LEVEL)
Public enumeration | DrawTextOptions | Specifies whether text snapping is suppressed or clipping to the layout rectangle is enabled. This enumeration allows a bitwise combination of its member values. (Also see DirectX SDK: D2D1_DRAW_TEXT_OPTIONS)
Public enumeration | ExtendMode | Specifies how a brush paints areas outside of its normal content area. (Also see DirectX SDK: D2D1_EXTEND_MODE)
Public enumeration | FigureBegin | Indicates whether the given figure is filled or hollow. (Also see DirectX SDK: D2D1_FIGURE_BEGIN)
Public enumeration | FigureEnd | Indicates whether the figure is open or closed on its end point. (Also see DirectX SDK: D2D1_FIGURE_END)
Public enumeration | FillMode | Specifies how the intersecting areas of geometries are combined to form the area of the composite geometry. (Also see DirectX SDK: D2D1_FILL_MODE)
Public enumeration | Gamma | This determines what gamma is used for interpolation/blending. (Also see DirectX SDK: D2D1_GAMMA)
Public enumeration | GeometryRelation | (Also see DirectX SDK: D2D1_GEOMETRY_RELATION)
Public enumeration | GeometrySimplificationOption | Specifies how a geometry is simplified to a SimplifiedGeometrySink. (Also see DirectX SDK: D2D1_GEOMETRY_SIMPLIFICATION_OPTION)
Public enumeration | LayerOptions | Specified options that can be applied when a layer resource is applied to create a layer. (Also see DirectX SDK: D2D1_LAYER_OPTIONS)
Public enumeration | LineJoin | Describes the shape that joins two lines or segments. (Also see DirectX SDK: D2D1_LINE_JOIN)
Public enumeration | OpacityMaskContent | Describes whether an opacity mask contains graphics or text. Direct2D uses this information to determine which gamma space to use when blending the opacity mask. (Also see DirectX SDK: D2D1_OPACITY_MASK_CONTENT)
Public enumeration | PathSegmentOptions | Indicates whether the given segment should be stroked, or, if the join between this segment and the previous one should be smooth. (Also see DirectX SDK: D2D1_PATH_SEGMENT)
Public enumeration | PresentOptions | Describes how a render target behaves when it presents its content. This enumeration allows a bitwise combination of its member values. (Also see DirectX SDK: D2D1_PRESENT_OPTIONS)
Public enumeration | RenderTargetType | Describes whether a render target uses hardware or software rendering, or if Direct2D should select the rendering mode. (Also see DirectX SDK: D2D1_RENDER_TARGET_TYPE)
Public enumeration | RenderTargetUsages | Describes how a render target is remoted and whether it should be GDI-compatible. This enumeration allows a bitwise combination of its member values. (Also see DirectX SDK: D2D1_RENDER_TARGET_USAGE)
Public enumeration | SweepDirection | Defines the direction that an elliptical arc is drawn. (Also see DirectX SDK: D2D1_SWEEP_DIRECTION)
Public enumeration | TextAntiAliasMode | Describes the antialiasing mode used for drawing text. (Also see DirectX SDK: D2D1_TEXT_ANTIALIAS_MODE)
Public enumeration | WindowState | Describes whether a window is occluded. (Also see DirectX SDK: D2D1_WINDOW_STATE)


AlphaMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AlphaMode Enumeration
See Also Send Feedback
Specifies how the alpha value of a bitmap or render target should be treated.

(Also see DirectX SDK: D2D1_ALPHA_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum AlphaMode
Visual Basic
Public Enumeration AlphaMode
Visual C++
public enum class AlphaMode

Members

Member name | Description
Ignore |
Straight |
Premultiplied |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AntiAliasMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AntiAliasMode Enumeration
See Also Send Feedback
Describes how non-text primitives are rendered.

(Also see DirectX SDK: D2D1_ANTIALIAS_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum AntiAliasMode
Visual Basic
Public Enumeration AntiAliasMode
Visual C++
public enum class AntiAliasMode

Members

Member name | Description
Aliased |
PerPrimitive |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ArcSegment Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment Structure
Members See Also Send Feedback
Describes an elliptical arc between two points.

(Also see DirectX SDK: D2D1_ARC_SEGMENT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ArcSegment
Visual Basic
Public Structure ArcSegment
Visual C++
public value class ArcSegment

See Also

ArcSegment Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ArcSegment Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment Members
ArcSegment Structure Constructors Methods Operators Properties See Also Send Feedback

The ArcSegment type exposes the following members.

Constructors

 | Name | Description
Public method | ArcSegment | Constructor for the ArcSegment value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArcSize | A value that specifies whether the given arc is larger than 180 degrees.
Public property | Point | The end point of the arc.
Public property | RotationAngle | A value that specifies how many degrees in the clockwise direction the ellipse is rotated relative to the current coordinate system.
Public property | Size | The x-radius and y-radius of the arc.
Public property | SweepDirection | A value that specifies whether the arc sweep is clockwise or counterclockwise.

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ArcSegment Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment Constructor
ArcSegment Structure See Also Send Feedback
Constructor for the ArcSegment value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ArcSegment(
    Point2F point,
    SizeF size,
    float rotationAngle,
    SweepDirection sweepDirection,
    ArcSize arcSize
)
Visual Basic
Public Sub New ( _
    point As Point2F, _
    size As SizeF, _
    rotationAngle As Single, _
    sweepDirection As SweepDirection, _
    arcSize As ArcSize _
)
Visual C++
public:
ArcSegment(
    Point2F point,
    SizeF size,
    float rotationAngle,
    SweepDirection sweepDirection,
    ArcSize arcSize
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point property.
size
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
Initializes the Size property.
rotationAngle
Type: System..::..Single
Initializes the RotationAngle property.
sweepDirection
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SweepDirection
Initializes the SweepDirection property.
arcSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ArcSize
Initializes the ArcSize property.

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ArcSegment Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment Methods
ArcSegment Structure See Also Send Feedback

The ArcSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment..::..Equals Method
ArcSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment..::..GetHashCode Method
ArcSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ArcSegment Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment Operators
ArcSegment Structure See Also Send Feedback

The ArcSegment type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment..::..Equality Operator
ArcSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ArcSegment segment1,
    ArcSegment segment2
)
Visual Basic
Public Shared Operator = ( _
    segment1 As ArcSegment, _
    segment2 As ArcSegment _
) As Boolean
Visual C++
public:
static bool operator ==(
    ArcSegment segment1,
    ArcSegment segment2
)

Parameters

segment1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ArcSegment
segment2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ArcSegment

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment..::..Inequality Operator
ArcSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ArcSegment segment1,
    ArcSegment segment2
)
Visual Basic
Public Shared Operator <> ( _
    segment1 As ArcSegment, _
    segment2 As ArcSegment _
) As Boolean
Visual C++
public:
static bool operator !=(
    ArcSegment segment1,
    ArcSegment segment2
)

Parameters

segment1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ArcSegment
segment2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ArcSegment

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ArcSegment Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment Properties
ArcSegment Structure See Also Send Feedback

The ArcSegment type exposes the following members.

Properties

 | Name | Description
Public property | ArcSize | A value that specifies whether the given arc is larger than 180 degrees.
Public property | Point | The end point of the arc.
Public property | RotationAngle | A value that specifies how many degrees in the clockwise direction the ellipse is rotated relative to the current coordinate system.
Public property | Size | The x-radius and y-radius of the arc.
Public property | SweepDirection | A value that specifies whether the arc sweep is clockwise or counterclockwise.

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ArcSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment..::..ArcSize Property
ArcSegment Structure See Also Send Feedback
A value that specifies whether the given arc is larger than 180 degrees.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ArcSize ArcSize { get; set; }
Visual Basic
Public Property ArcSize As ArcSize
    Get
    Set
Visual C++
public:
property ArcSize ArcSize {
    ArcSize get ();
    void set (ArcSize value);
}

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment..::..Point Property
ArcSegment Structure See Also Send Feedback
The end point of the arc.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point { get; set; }
Visual Basic
Public Property Point As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point {
    Point2F get ();
    void set (Point2F value);
}

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RotationAngle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment..::..RotationAngle Property
ArcSegment Structure See Also Send Feedback
A value that specifies how many degrees in the clockwise direction the ellipse is rotated relative to the current coordinate system.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Single
    Get
    Set
Visual C++
public:
property float RotationAngle {
    float get ();
    void set (float value);
}

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Size Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment..::..Size Property
ArcSegment Structure See Also Send Feedback
The x-radius and y-radius of the arc.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SizeF Size { get; set; }
Visual Basic
Public Property Size As SizeF
    Get
    Set
Visual C++
public:
property SizeF Size {
    SizeF get ();
    void set (SizeF value);
}

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SweepDirection Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSegment..::..SweepDirection Property
ArcSegment Structure See Also Send Feedback
A value that specifies whether the arc sweep is clockwise or counterclockwise.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SweepDirection SweepDirection { get; set; }
Visual Basic
Public Property SweepDirection As SweepDirection
    Get
    Set
Visual C++
public:
property SweepDirection SweepDirection {
    SweepDirection get ();
    void set (SweepDirection value);
}

See Also

ArcSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ArcSize Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ArcSize Enumeration
See Also Send Feedback
Specifies whether an arc should be greater than 180 degrees.

(Also see DirectX SDK: D2D1_ARC_SIZE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ArcSize
Visual Basic
Public Enumeration ArcSize
Visual C++
public enum class ArcSize

Members

Member name | Description
Large |
Small |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BezierSegment Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment Structure
Members See Also Send Feedback
Represents a cubic bezier segment drawn between two points.

(Also see DirectX SDK: D2D1_BEZIER_SEGMENT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BezierSegment
Visual Basic
Public Structure BezierSegment
Visual C++
public value class BezierSegment

See Also

BezierSegment Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BezierSegment Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment Members
BezierSegment Structure Constructors Methods Operators Properties See Also Send Feedback

The BezierSegment type exposes the following members.

Constructors

 | Name | Description
Public method | BezierSegment | Constructor for the BezierSegment value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Point1 | The first control point for the Bezier segment.
Public property | Point2 | The second control point for the Bezier segment.
Public property | Point3 | The end point for the Bezier segment.

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BezierSegment Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment Constructor
BezierSegment Structure See Also Send Feedback
Constructor for the BezierSegment value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BezierSegment(
    Point2F point1,
    Point2F point2,
    Point2F point3
)
Visual Basic
Public Sub New ( _
    point1 As Point2F, _
    point2 As Point2F, _
    point3 As Point2F _
)
Visual C++
public:
BezierSegment(
    Point2F point1,
    Point2F point2,
    Point2F point3
)

Parameters

point1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point1 property.
point2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point2 property.
point3
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point3 property.

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BezierSegment Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment Methods
BezierSegment Structure See Also Send Feedback

The BezierSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment..::..Equals Method
BezierSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment..::..GetHashCode Method
BezierSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BezierSegment Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment Operators
BezierSegment Structure See Also Send Feedback

The BezierSegment type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment..::..Equality Operator
BezierSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BezierSegment segment1,
    BezierSegment segment2
)
Visual Basic
Public Shared Operator = ( _
    segment1 As BezierSegment, _
    segment2 As BezierSegment _
) As Boolean
Visual C++
public:
static bool operator ==(
    BezierSegment segment1,
    BezierSegment segment2
)

Parameters

segment1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BezierSegment
segment2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BezierSegment

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment..::..Inequality Operator
BezierSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BezierSegment segment1,
    BezierSegment segment2
)
Visual Basic
Public Shared Operator <> ( _
    segment1 As BezierSegment, _
    segment2 As BezierSegment _
) As Boolean
Visual C++
public:
static bool operator !=(
    BezierSegment segment1,
    BezierSegment segment2
)

Parameters

segment1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BezierSegment
segment2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BezierSegment

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BezierSegment Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment Properties
BezierSegment Structure See Also Send Feedback

The BezierSegment type exposes the following members.

Properties

 | Name | Description
Public property | Point1 | The first control point for the Bezier segment.
Public property | Point2 | The second control point for the Bezier segment.
Public property | Point3 | The end point for the Bezier segment.

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment..::..Point1 Property
BezierSegment Structure See Also Send Feedback
The first control point for the Bezier segment.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point1 { get; set; }
Visual Basic
Public Property Point1 As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point1 {
    Point2F get ();
    void set (Point2F value);
}

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment..::..Point2 Property
BezierSegment Structure See Also Send Feedback
The second control point for the Bezier segment.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point2 { get; set; }
Visual Basic
Public Property Point2 As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point2 {
    Point2F get ();
    void set (Point2F value);
}

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point3 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BezierSegment..::..Point3 Property
BezierSegment Structure See Also Send Feedback
The end point for the Bezier segment.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point3 { get; set; }
Visual Basic
Public Property Point3 As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point3 {
    Point2F get ();
    void set (Point2F value);
}

See Also

BezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapBrush Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrush Class
Members See Also Send Feedback
A bitmap brush allows a bitmap to be used to fill a geometry.

(Also see DirectX SDK: ID2D1BitmapBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class BitmapBrush : Brush
Visual Basic
Public Class BitmapBrush _
    Inherits Brush
Visual C++
public ref class BitmapBrush : public Brush

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapBrush

See Also

BitmapBrush Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapBrush Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrush Members
BitmapBrush Class Properties See Also Send Feedback

The BitmapBrush type exposes the following members.

Properties

 | Name | Description
Public property | Bitmap | Gets or sets the bitmap associated with this brush. (Also see DirectX SDK: ID2D1BitmapBrush::GetBitmap)
Public property | ExtendModeX | Gets or sets how the bitmap is to be treated outside of its natural extent on the X axis. (Also see DirectX SDK: ID2D1BitmapBrush::GetExtendModeX, ID2D1BitmapBrush::SetExtendModeX)
Public property | ExtendModeY | Gets or sets how the bitmap is to be treated outside of its natural extent on the Y axis. (Also see DirectX SDK: ID2D1BitmapBrush::GetExtendModeY, ID2D1BitmapBrush::SetExtendModeY)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | InterpolationMode | Sets the interpolation mode used when this brush is used. (Also see DirectX SDK: ID2D1BitmapBrush::GetInterpolationMode, ID2D1BitmapBrush::SetInterpolationMode)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity) (Inherited from Brush.)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform) (Inherited from Brush.)

See Also

BitmapBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapBrush Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrush Properties
BitmapBrush Class See Also Send Feedback

The BitmapBrush type exposes the following members.

Properties

 | Name | Description
Public property | Bitmap | Gets or sets the bitmap associated with this brush. (Also see DirectX SDK: ID2D1BitmapBrush::GetBitmap)
Public property | ExtendModeX | Gets or sets how the bitmap is to be treated outside of its natural extent on the X axis. (Also see DirectX SDK: ID2D1BitmapBrush::GetExtendModeX, ID2D1BitmapBrush::SetExtendModeX)
Public property | ExtendModeY | Gets or sets how the bitmap is to be treated outside of its natural extent on the Y axis. (Also see DirectX SDK: ID2D1BitmapBrush::GetExtendModeY, ID2D1BitmapBrush::SetExtendModeY)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | InterpolationMode | Sets the interpolation mode used when this brush is used. (Also see DirectX SDK: ID2D1BitmapBrush::GetInterpolationMode, ID2D1BitmapBrush::SetInterpolationMode)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity) (Inherited from Brush.)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform) (Inherited from Brush.)

See Also

BitmapBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Bitmap Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrush..::..Bitmap Property
BitmapBrush Class See Also Send Feedback
Gets or sets the bitmap associated with this brush.

(Also see DirectX SDK: ID2D1BitmapBrush::GetBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap Bitmap { get; set; }
Visual Basic
Public Property Bitmap As D2DBitmap
    Get
    Set
Visual C++
public:
property D2DBitmap^ Bitmap {
    D2DBitmap^ get ();
    void set (D2DBitmap^ value);
}

See Also

BitmapBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ExtendModeX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrush..::..ExtendModeX Property
BitmapBrush Class See Also Send Feedback
Gets or sets how the bitmap is to be treated outside of its natural extent on the X axis.

(Also see DirectX SDK: ID2D1BitmapBrush::GetExtendModeX, ID2D1BitmapBrush::SetExtendModeX)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExtendMode ExtendModeX { get; set; }
Visual Basic
Public Property ExtendModeX As ExtendMode
    Get
    Set
Visual C++
public:
property ExtendMode ExtendModeX {
    ExtendMode get ();
    void set (ExtendMode value);
}

See Also

BitmapBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ExtendModeY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrush..::..ExtendModeY Property
BitmapBrush Class See Also Send Feedback
Gets or sets how the bitmap is to be treated outside of its natural extent on the Y axis.

(Also see DirectX SDK: ID2D1BitmapBrush::GetExtendModeY, ID2D1BitmapBrush::SetExtendModeY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExtendMode ExtendModeY { get; set; }
Visual Basic
Public Property ExtendModeY As ExtendMode
    Get
    Set
Visual C++
public:
property ExtendMode ExtendModeY {
    ExtendMode get ();
    void set (ExtendMode value);
}

See Also

BitmapBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


InterpolationMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrush..::..InterpolationMode Property
BitmapBrush Class See Also Send Feedback
Sets the interpolation mode used when this brush is used.

(Also see DirectX SDK: ID2D1BitmapBrush::GetInterpolationMode, ID2D1BitmapBrush::SetInterpolationMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapInterpolationMode InterpolationMode { get; set; }
Visual Basic
Public Property InterpolationMode As BitmapInterpolationMode
    Get
    Set
Visual C++
public:
property BitmapInterpolationMode InterpolationMode {
    BitmapInterpolationMode get ();
    void set (BitmapInterpolationMode value);
}

See Also

BitmapBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapBrushProperties Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties Structure
Members See Also Send Feedback
Describes the extend modes and the interpolation mode of a BitmapBrush.

(Also see DirectX SDK: D2D1_BITMAP_BRUSH_PROPERTIES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BitmapBrushProperties
Visual Basic
Public Structure BitmapBrushProperties
Visual C++
public value class BitmapBrushProperties

See Also

BitmapBrushProperties Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapBrushProperties Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties Members
BitmapBrushProperties Structure Constructors Methods Operators Properties See Also Send Feedback

The BitmapBrushProperties type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapBrushProperties | Constructor for the BitmapBrushProperties value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ExtendModeX | A value that describes how the brush horizontally tiles those areas that extend past its bitmap.
Public property | ExtendModeY | A value that describes how the brush vertically tiles those areas that extend past its bitmap.
Public property | InterpolationMode | A value that specifies how the bitmap is interpolated when it is scaled or rotated.

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapBrushProperties Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties Constructor
BitmapBrushProperties Structure See Also Send Feedback
Constructor for the BitmapBrushProperties value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapBrushProperties(
    ExtendMode extendModeX,
    ExtendMode extendModeY,
    BitmapInterpolationMode interpolationMode
)
Visual Basic
Public Sub New ( _
    extendModeX As ExtendMode, _
    extendModeY As ExtendMode, _
    interpolationMode As BitmapInterpolationMode _
)
Visual C++
public:
BitmapBrushProperties(
    ExtendMode extendModeX,
    ExtendMode extendModeY,
    BitmapInterpolationMode interpolationMode
)

Parameters

extendModeX
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ExtendMode
Initializes the ExtendModeX property.
extendModeY
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ExtendMode
Initializes the ExtendModeY property.
interpolationMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapInterpolationMode
Initializes the InterpolationMode property.

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapBrushProperties Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties Methods
BitmapBrushProperties Structure See Also Send Feedback

The BitmapBrushProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties..::..Equals Method
BitmapBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties..::..GetHashCode Method
BitmapBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapBrushProperties Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties Operators
BitmapBrushProperties Structure See Also Send Feedback

The BitmapBrushProperties type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties..::..Equality Operator
BitmapBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BitmapBrushProperties bitmapBrushProperties1,
    BitmapBrushProperties bitmapBrushProperties2
)
Visual Basic
Public Shared Operator = ( _
    bitmapBrushProperties1 As BitmapBrushProperties, _
    bitmapBrushProperties2 As BitmapBrushProperties _
) As Boolean
Visual C++
public:
static bool operator ==(
    BitmapBrushProperties bitmapBrushProperties1,
    BitmapBrushProperties bitmapBrushProperties2
)

Parameters

bitmapBrushProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapBrushProperties
bitmapBrushProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapBrushProperties

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties..::..Inequality Operator
BitmapBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BitmapBrushProperties bitmapBrushProperties1,
    BitmapBrushProperties bitmapBrushProperties2
)
Visual Basic
Public Shared Operator <> ( _
    bitmapBrushProperties1 As BitmapBrushProperties, _
    bitmapBrushProperties2 As BitmapBrushProperties _
) As Boolean
Visual C++
public:
static bool operator !=(
    BitmapBrushProperties bitmapBrushProperties1,
    BitmapBrushProperties bitmapBrushProperties2
)

Parameters

bitmapBrushProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapBrushProperties
bitmapBrushProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapBrushProperties

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapBrushProperties Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties Properties
BitmapBrushProperties Structure See Also Send Feedback

The BitmapBrushProperties type exposes the following members.

Properties

 | Name | Description
Public property | ExtendModeX | A value that describes how the brush horizontally tiles those areas that extend past its bitmap.
Public property | ExtendModeY | A value that describes how the brush vertically tiles those areas that extend past its bitmap.
Public property | InterpolationMode | A value that specifies how the bitmap is interpolated when it is scaled or rotated.

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ExtendModeX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties..::..ExtendModeX Property
BitmapBrushProperties Structure See Also Send Feedback
A value that describes how the brush horizontally tiles those areas that extend past its bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExtendMode ExtendModeX { get; set; }
Visual Basic
Public Property ExtendModeX As ExtendMode
    Get
    Set
Visual C++
public:
property ExtendMode ExtendModeX {
    ExtendMode get ();
    void set (ExtendMode value);
}

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ExtendModeY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties..::..ExtendModeY Property
BitmapBrushProperties Structure See Also Send Feedback
A value that describes how the brush vertically tiles those areas that extend past its bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExtendMode ExtendModeY { get; set; }
Visual Basic
Public Property ExtendModeY As ExtendMode
    Get
    Set
Visual C++
public:
property ExtendMode ExtendModeY {
    ExtendMode get ();
    void set (ExtendMode value);
}

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


InterpolationMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapBrushProperties..::..InterpolationMode Property
BitmapBrushProperties Structure See Also Send Feedback
A value that specifies how the bitmap is interpolated when it is scaled or rotated.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapInterpolationMode InterpolationMode { get; set; }
Visual Basic
Public Property InterpolationMode As BitmapInterpolationMode
    Get
    Set
Visual C++
public:
property BitmapInterpolationMode InterpolationMode {
    BitmapInterpolationMode get ();
    void set (BitmapInterpolationMode value);
}

See Also

BitmapBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapInterpolationMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapInterpolationMode Enumeration
See Also Send Feedback
Specifies the algorithm that is used when images are scaled or rotated.

(Also see DirectX SDK: D2D1_BITMAP_INTERPOLATION_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum BitmapInterpolationMode
Visual Basic
Public Enumeration BitmapInterpolationMode
Visual C++
public enum class BitmapInterpolationMode

Members

Member name | Description
Linear |
NearestNeighbor |

Remarks

To stretch an image, each pixel in the original image must be mapped to a group of pixels in the larger image. To shrink an image, groups of pixels in the original image must be mapped to single pixels in the smaller image. The effectiveness of the algorithms that perform these mappings determines the quality of a scaled image. Algorithms that produce higher-quality scaled images tend to require more processing time. NearestNeighbor provides faster but lower-quality interpolation, while Linear provides higher-quality interpolation.

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapProperties Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties Structure
Members See Also Send Feedback
Describes the pixel format and dpi of a bitmap.

(Also see DirectX SDK: D2D1_BITMAP_PROPERTIES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BitmapProperties
Visual Basic
Public Structure BitmapProperties
Visual C++
public value class BitmapProperties

See Also

BitmapProperties Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapProperties Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties Members
BitmapProperties Structure Constructors Methods Operators Properties See Also Send Feedback

The BitmapProperties type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapProperties | Constructor for the BitmapProperties value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | DpiX | The horizontal dpi of the bitmap.
Public property | DpiY | The vertical dpi of the bitmap.
Public property | PixelFormat | The bitmap's pixel format and alpha mode.

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapProperties Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties Constructor
BitmapProperties Structure See Also Send Feedback
Constructor for the BitmapProperties value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapProperties(
    PixelFormat pixelFormat,
    float dpiX,
    float dpiY
)
Visual Basic
Public Sub New ( _
    pixelFormat As PixelFormat, _
    dpiX As Single, _
    dpiY As Single _
)
Visual C++
public:
BitmapProperties(
    PixelFormat pixelFormat,
    float dpiX,
    float dpiY
)

Parameters

pixelFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat
Initializes the PixelFormat property.
dpiX
Type: System..::..Single
Initializes the DpiX property.
dpiY
Type: System..::..Single
Initializes the DpiY property.

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapProperties Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties Methods
BitmapProperties Structure See Also Send Feedback

The BitmapProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties..::..Equals Method
BitmapProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties..::..GetHashCode Method
BitmapProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapProperties Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties Operators
BitmapProperties Structure See Also Send Feedback

The BitmapProperties type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties..::..Equality Operator
BitmapProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BitmapProperties bitmapProperties1,
    BitmapProperties bitmapProperties2
)
Visual Basic
Public Shared Operator = ( _
    bitmapProperties1 As BitmapProperties, _
    bitmapProperties2 As BitmapProperties _
) As Boolean
Visual C++
public:
static bool operator ==(
    BitmapProperties bitmapProperties1,
    BitmapProperties bitmapProperties2
)

Parameters

bitmapProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties
bitmapProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties..::..Inequality Operator
BitmapProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BitmapProperties bitmapProperties1,
    BitmapProperties bitmapProperties2
)
Visual Basic
Public Shared Operator <> ( _
    bitmapProperties1 As BitmapProperties, _
    bitmapProperties2 As BitmapProperties _
) As Boolean
Visual C++
public:
static bool operator !=(
    BitmapProperties bitmapProperties1,
    BitmapProperties bitmapProperties2
)

Parameters

bitmapProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties
bitmapProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapProperties Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties Properties
BitmapProperties Structure See Also Send Feedback

The BitmapProperties type exposes the following members.

Properties

 | Name | Description
Public property | DpiX | The horizontal dpi of the bitmap.
Public property | DpiY | The vertical dpi of the bitmap.
Public property | PixelFormat | The bitmap's pixel format and alpha mode.

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties..::..DpiX Property
BitmapProperties Structure See Also Send Feedback
The horizontal dpi of the bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float DpiX { get; set; }
Visual Basic
Public Property DpiX As Single
    Get
    Set
Visual C++
public:
property float DpiX {
    float get ();
    void set (float value);
}

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties..::..DpiY Property
BitmapProperties Structure See Also Send Feedback
The vertical dpi of the bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float DpiY { get; set; }
Visual Basic
Public Property DpiY As Single
    Get
    Set
Visual C++
public:
property float DpiY {
    float get ();
    void set (float value);
}

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapProperties..::..PixelFormat Property
BitmapProperties Structure See Also Send Feedback
The bitmap's pixel format and alpha mode.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelFormat PixelFormat { get; set; }
Visual Basic
Public Property PixelFormat As PixelFormat
    Get
    Set
Visual C++
public:
property PixelFormat PixelFormat {
    PixelFormat get ();
    void set (PixelFormat value);
}

See Also

BitmapProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapRenderTarget Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget Class
Members See Also Send Feedback
Renders to an intermediate texture. This RenderTarget is created by CreateCompatibleRenderTarget()()()() or one of its overloads.

(Also see DirectX SDK: ID2D1BitmapRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class BitmapRenderTarget : RenderTarget
Visual Basic
Public Class BitmapRenderTarget _
    Inherits RenderTarget
Visual C++
public ref class BitmapRenderTarget : public RenderTarget

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTarget
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapRenderTarget

See Also

BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapRenderTarget Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget Members
BitmapRenderTarget Class Methods Properties See Also Send Feedback

The BitmapRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | BeginDraw | Start drawing on this render target. Draw calls can only be issued between a BeginDraw and EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::BeginDraw) (Inherited from RenderTarget.)
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateGradientStopCollection | (Inherited from RenderTarget.)
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateMesh | Create a mesh that uses triangles to describe a shape. Create a D2D mesh. (Also see DirectX SDK: ID2D1RenderTarget::CreateMesh) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmapAtOrigin | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | EndDraw | Ends drawing on the render target. If an error occur while drawing, an exception will be thrown. To prevent exceptions, you can use the TryEndDraw() method instead. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | FillEllipse | Paints the interior of the specified ellipse. (Also see DirectX SDK: ID2D1RenderTarget::FillEllipse) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillMesh | Fill a mesh. Since meshes can only render aliased content, the render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillMesh) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMaskAtOrigin | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush uses the sourceRectangle area to draw at the orgin of the bitmap. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillRectangle | Paints the interior of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRectangle) (Inherited from RenderTarget.)
Public method | FillRoundedRectangle | Paints the interior of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRoundedRectangle) (Inherited from RenderTarget.)
Public method | Flush | Executes all pending drawing commands. This method will throw if an error occur during the operation. To prevent exceptions, TryFlush() can be used instead. (Also see DirectX SDK: ID2D1RenderTarget::Flush) (Inherited from RenderTarget.)
Public method | IsSupported | Returns true if the given properties are supported by this render target. The DPI is ignored. NOTE: If the render target type is software, then neither feature level 9 nor feature level 10 will be considered to be supported. (Also see DirectX SDK: ID2D1RenderTarget::IsSupported) (Inherited from RenderTarget.)
Public method | PopAxisAlignedClip | Removes the last axis-aligned clip from the render target. After this method is called, the clip is no longer applied to subsequent drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::PopAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PopLayer | Ends a layer that was defined with particular layer resources. (Also see DirectX SDK: ID2D1RenderTarget::PopLayer) (Inherited from RenderTarget.)
Public method | PushAxisAlignedClip | Pushes a clip. The clip can be antialiased. The clip must be axis aligned. If the current world transform is not axis preserving, then the bounding box of the transformed clip rect will be used. The clip will remain in effect until a PopAxisAligned clip call is made. (Also see DirectX SDK: ID2D1RenderTarget::PushAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PushLayer | Start a layer of drawing calls. The way in which the layer must be resolved is specified first as well as the logical resource that stores the layer parameters. The supplied layer resource might grow if the specified content cannot fit inside it. The layer will grow monitonically on each axis. (Also see DirectX SDK: ID2D1RenderTarget::PushLayer) (Inherited from RenderTarget.)
Public method | RestoreDrawingState | Copies the state stored in the block interface. (Also see DirectX SDK: ID2D1RenderTarget::RestoreDrawingState) (Inherited from RenderTarget.)
Public method | SaveDrawingState | Gets the current drawing state and saves it into the supplied IDrawingStatckBlock. (Also see DirectX SDK: ID2D1RenderTarget::SaveDrawingState) (Inherited from RenderTarget.)
Public method | TryEndDraw | Ends drawing on the render target, error results can be retrieved at this time, or when calling Flush() or TryFlush(). (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | TryFlush | Executes all pending drawing commands. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)

Properties

 | Name | Description
Public property | AntiAliasMode | The current antialiasing mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetAntiAliasMode, ID2D1RenderTarget::SetAntiAliasMode) (Inherited from RenderTarget.)
Public property | Bitmap | Retrieves the bitmap for this render target. The returned bitmap can be used for drawing operations. (Also see DirectX SDK: ID2D1BitmapRenderTarget::GetBitmap)
Public property | Dpi | The DPI on the render target. This results in the render target being interpretted to a different scale. Neither DPI can be negative. If zero is specified for both, the system DPI is chosen. If one is zero and the other unspecified, the DPI is not changed. (Also see DirectX SDK: ID2D1RenderTarget::GetDpi, ID2D1RenderTarget::SetDpi) (Inherited from RenderTarget.)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GdiInteropRenderTarget | Provide a GdiInteropRenderTarget version of this render target. (Inherited from RenderTarget.)
Public property | MaximumBitmapSize | Returns the maximum bitmap and render target size that is guaranteed to be supported by the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetMaximumBitmapSize) (Inherited from RenderTarget.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | The pixel format and alpha mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelFormat) (Inherited from RenderTarget.)
Public property | PixelSize | Returns the size of the render target in pixels. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelSize) (Inherited from RenderTarget.)
Public property | Size | Returns the size of the render target in DIPs. (Also see DirectX SDK: ID2D1RenderTarget::GetSize) (Inherited from RenderTarget.)
Public property | Tags | Get or Set a tag to labelto the succeeding drawing operations. If an error occurs while rendering a primtive, the tags can be returned from the Flush or EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::GetTags, ID2D1RenderTarget::SetTags) (Inherited from RenderTarget.)
Public property | TextAntiAliasMode | The current antialiasing mode for text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextAntiAliasMode, ID2D1RenderTarget::SetTextAntiAliasMode) (Inherited from RenderTarget.)
Public property | TextRenderingParams | Gets or set the render target's current text-rendering options. Text rendering options to apply to all text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextRenderingParams, ID2D1RenderTarget::SetTextRenderingParams) (Inherited from RenderTarget.)
Public property | Transform | The current transform of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetTransform, ID2D1RenderTarget::SetTransform) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapRenderTarget Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget Methods
BitmapRenderTarget Class See Also Send Feedback

The BitmapRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | BeginDraw | Start drawing on this render target. Draw calls can only be issued between a BeginDraw and EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::BeginDraw) (Inherited from RenderTarget.)
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateGradientStopCollection | (Inherited from RenderTarget.)
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateMesh | Create a mesh that uses triangles to describe a shape. Create a D2D mesh. (Also see DirectX SDK: ID2D1RenderTarget::CreateMesh) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmapAtOrigin | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | EndDraw | Ends drawing on the render target. If an error occur while drawing, an exception will be thrown. To prevent exceptions, you can use the TryEndDraw() method instead. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | FillEllipse | Paints the interior of the specified ellipse. (Also see DirectX SDK: ID2D1RenderTarget::FillEllipse) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillMesh | Fill a mesh. Since meshes can only render aliased content, the render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillMesh) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMaskAtOrigin | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush uses the sourceRectangle area to draw at the orgin of the bitmap. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillRectangle | Paints the interior of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRectangle) (Inherited from RenderTarget.)
Public method | FillRoundedRectangle | Paints the interior of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRoundedRectangle) (Inherited from RenderTarget.)
Public method | Flush | Executes all pending drawing commands. This method will throw if an error occur during the operation. To prevent exceptions, TryFlush() can be used instead. (Also see DirectX SDK: ID2D1RenderTarget::Flush) (Inherited from RenderTarget.)
Public method | IsSupported | Returns true if the given properties are supported by this render target. The DPI is ignored. NOTE: If the render target type is software, then neither feature level 9 nor feature level 10 will be considered to be supported. (Also see DirectX SDK: ID2D1RenderTarget::IsSupported) (Inherited from RenderTarget.)
Public method | PopAxisAlignedClip | Removes the last axis-aligned clip from the render target. After this method is called, the clip is no longer applied to subsequent drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::PopAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PopLayer | Ends a layer that was defined with particular layer resources. (Also see DirectX SDK: ID2D1RenderTarget::PopLayer) (Inherited from RenderTarget.)
Public method | PushAxisAlignedClip | Pushes a clip. The clip can be antialiased. The clip must be axis aligned. If the current world transform is not axis preserving, then the bounding box of the transformed clip rect will be used. The clip will remain in effect until a PopAxisAligned clip call is made. (Also see DirectX SDK: ID2D1RenderTarget::PushAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PushLayer | Start a layer of drawing calls. The way in which the layer must be resolved is specified first as well as the logical resource that stores the layer parameters. The supplied layer resource might grow if the specified content cannot fit inside it. The layer will grow monitonically on each axis. (Also see DirectX SDK: ID2D1RenderTarget::PushLayer) (Inherited from RenderTarget.)
Public method | RestoreDrawingState | Copies the state stored in the block interface. (Also see DirectX SDK: ID2D1RenderTarget::RestoreDrawingState) (Inherited from RenderTarget.)
Public method | SaveDrawingState | Gets the current drawing state and saves it into the supplied IDrawingStatckBlock. (Also see DirectX SDK: ID2D1RenderTarget::SaveDrawingState) (Inherited from RenderTarget.)
Public method | TryEndDraw | Ends drawing on the render target, error results can be retrieved at this time, or when calling Flush() or TryFlush(). (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | TryFlush | Executes all pending drawing commands. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Clear Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..Clear Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..CreateBitmap Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..CreateBitmapBrush Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapFromWicBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..CreateBitmapFromWicBitmap Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..CreateCompatibleRenderTarget Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLayer Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..CreateLayer Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLinearGradientBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..CreateLinearGradientBrush Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateRadialGradientBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..CreateRadialGradientBrush Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..CreateSharedBitmap Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSolidColorBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..CreateSolidColorBrush Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..DrawBitmap Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawEllipse Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..DrawEllipse Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..DrawGeometry Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGlyphRun Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..DrawGlyphRun Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawLine Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..DrawLine Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRectangle Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..DrawRectangle Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRoundedRectangle Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..DrawRoundedRectangle Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawText Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..DrawText Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawTextLayout Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..DrawTextLayout Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..FillGeometry Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillOpacityMask Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..FillOpacityMask Method
BitmapRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
BitmapRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BitmapRenderTarget Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget Properties
BitmapRenderTarget Class See Also Send Feedback

The BitmapRenderTarget type exposes the following members.

Properties

 | Name | Description
Public property | AntiAliasMode | The current antialiasing mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetAntiAliasMode, ID2D1RenderTarget::SetAntiAliasMode) (Inherited from RenderTarget.)
Public property | Bitmap | Retrieves the bitmap for this render target. The returned bitmap can be used for drawing operations. (Also see DirectX SDK: ID2D1BitmapRenderTarget::GetBitmap)
Public property | Dpi | The DPI on the render target. This results in the render target being interpretted to a different scale. Neither DPI can be negative. If zero is specified for both, the system DPI is chosen. If one is zero and the other unspecified, the DPI is not changed. (Also see DirectX SDK: ID2D1RenderTarget::GetDpi, ID2D1RenderTarget::SetDpi) (Inherited from RenderTarget.)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GdiInteropRenderTarget | Provide a GdiInteropRenderTarget version of this render target. (Inherited from RenderTarget.)
Public property | MaximumBitmapSize | Returns the maximum bitmap and render target size that is guaranteed to be supported by the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetMaximumBitmapSize) (Inherited from RenderTarget.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | The pixel format and alpha mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelFormat) (Inherited from RenderTarget.)
Public property | PixelSize | Returns the size of the render target in pixels. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelSize) (Inherited from RenderTarget.)
Public property | Size | Returns the size of the render target in DIPs. (Also see DirectX SDK: ID2D1RenderTarget::GetSize) (Inherited from RenderTarget.)
Public property | Tags | Get or Set a tag to labelto the succeeding drawing operations. If an error occurs while rendering a primtive, the tags can be returned from the Flush or EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::GetTags, ID2D1RenderTarget::SetTags) (Inherited from RenderTarget.)
Public property | TextAntiAliasMode | The current antialiasing mode for text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextAntiAliasMode, ID2D1RenderTarget::SetTextAntiAliasMode) (Inherited from RenderTarget.)
Public property | TextRenderingParams | Gets or set the render target's current text-rendering options. Text rendering options to apply to all text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextRenderingParams, ID2D1RenderTarget::SetTextRenderingParams) (Inherited from RenderTarget.)
Public property | Transform | The current transform of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetTransform, ID2D1RenderTarget::SetTransform) (Inherited from RenderTarget.)

See Also

BitmapRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Bitmap Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRenderTarget..::..Bitmap Property
BitmapRenderTarget Class See Also Send Feedback
Retrieves the bitmap for this render target. The returned bitmap can be used for drawing operations.

(Also see DirectX SDK: ID2D1BitmapRenderTarget::GetBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap Bitmap { get; }
Visual Basic
Public ReadOnly Property Bitmap As D2DBitmap
    Get
Visual C++
public:
property D2DBitmap^ Bitmap {
    D2DBitmap^ get ();
}

See Also

BitmapRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Brush Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Brush Class
Members See Also Send Feedback
The root brush interface. All brushes can be used to fill or pen a geometry.

(Also see DirectX SDK: ID2D1Brush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Brush : D2DResource
Visual Basic
Public Class Brush _
    Inherits D2DResource
Visual C++
public ref class Brush : public D2DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapBrush
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LinearGradientBrush
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RadialGradientBrush
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SolidColorBrush

See Also

Brush Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Brush Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Brush Members
Brush Class Properties See Also Send Feedback

The Brush type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform)

See Also

Brush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Brush Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Brush Properties
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform)

See Also

Brush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Opacity Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Brush..::..Opacity Property
Brush Class See Also Send Feedback
The opacity for when the brush is drawn over the entire fill of the brush.

(Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Opacity { get; set; }
Visual Basic
Public Property Opacity As Single
    Get
    Set
Visual C++
public:
property float Opacity {
    float get ();
    void set (float value);
}

See Also

Brush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Transform Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Brush..::..Transform Property
Brush Class See Also Send Feedback
The transform that applies to everything drawn by the brush.

(Also see DirectX SDK: ID2D1Brush::SetTransform)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix3x2F Transform { get; set; }
Visual Basic
Public Property Transform As Matrix3x2F
    Get
    Set
Visual C++
public:
property Matrix3x2F Transform {
    Matrix3x2F get ();
    void set (Matrix3x2F value);
}

See Also

Brush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BrushProperties Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties Structure
Members See Also Send Feedback
Describes the opacity and transformation of a brush.

(Also see DirectX SDK: D2D1_BRUSH_PROPERTIES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BrushProperties
Visual Basic
Public Structure BrushProperties
Visual C++
public value class BrushProperties

See Also

BrushProperties Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BrushProperties Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties Members
BrushProperties Structure Constructors Methods Operators Properties See Also Send Feedback

The BrushProperties type exposes the following members.

Constructors

 | Name | Description
Public method | BrushProperties | Constructor for the BrushProperties value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Opacity | A value between 0.0f and 1.0f, inclusive, that specifies the degree of opacity of the brush.
Public property | Transform | The transformation that is applied to the brush.

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BrushProperties Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties Constructor
BrushProperties Structure See Also Send Feedback
Constructor for the BrushProperties value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BrushProperties(
    float opacity,
    Matrix3x2F transform
)
Visual Basic
Public Sub New ( _
    opacity As Single, _
    transform As Matrix3x2F _
)
Visual C++
public:
BrushProperties(
    float opacity,
    Matrix3x2F transform
)

Parameters

opacity
Type: System..::..Single
Initializes the Opacity property.
transform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
Initializes the Transform property.

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BrushProperties Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties Methods
BrushProperties Structure See Also Send Feedback

The BrushProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties..::..Equals Method
BrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties..::..GetHashCode Method
BrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BrushProperties Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties Operators
BrushProperties Structure See Also Send Feedback

The BrushProperties type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties..::..Equality Operator
BrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BrushProperties brushProperties1,
    BrushProperties brushProperties2
)
Visual Basic
Public Shared Operator = ( _
    brushProperties1 As BrushProperties, _
    brushProperties2 As BrushProperties _
) As Boolean
Visual C++
public:
static bool operator ==(
    BrushProperties brushProperties1,
    BrushProperties brushProperties2
)

Parameters

brushProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BrushProperties
brushProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BrushProperties

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties..::..Inequality Operator
BrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BrushProperties brushProperties1,
    BrushProperties brushProperties2
)
Visual Basic
Public Shared Operator <> ( _
    brushProperties1 As BrushProperties, _
    brushProperties2 As BrushProperties _
) As Boolean
Visual C++
public:
static bool operator !=(
    BrushProperties brushProperties1,
    BrushProperties brushProperties2
)

Parameters

brushProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BrushProperties
brushProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BrushProperties

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BrushProperties Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties Properties
BrushProperties Structure See Also Send Feedback

The BrushProperties type exposes the following members.

Properties

 | Name | Description
Public property | Opacity | A value between 0.0f and 1.0f, inclusive, that specifies the degree of opacity of the brush.
Public property | Transform | The transformation that is applied to the brush.

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Opacity Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties..::..Opacity Property
BrushProperties Structure See Also Send Feedback
A value between 0.0f and 1.0f, inclusive, that specifies the degree of opacity of the brush.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Opacity { get; set; }
Visual Basic
Public Property Opacity As Single
    Get
    Set
Visual C++
public:
property float Opacity {
    float get ();
    void set (float value);
}

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Transform Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BrushProperties..::..Transform Property
BrushProperties Structure See Also Send Feedback
The transformation that is applied to the brush.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix3x2F Transform { get; set; }
Visual Basic
Public Property Transform As Matrix3x2F
    Get
    Set
Visual C++
public:
property Matrix3x2F Transform {
    Matrix3x2F get ();
    void set (Matrix3x2F value);
}

See Also

BrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CapStyle Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CapStyle Enumeration
See Also Send Feedback
Enum which descibes the drawing of the ends of a line.

(Also see DirectX SDK: D2D1_CAP_STYLE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum CapStyle
Visual Basic
Public Enumeration CapStyle
Visual C++
public enum class CapStyle

Members

Member name | Description
Triangle |
Square |
Flat |
Round |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Structure
Members See Also Send Feedback
Describes the red, green, blue, and alpha components of a color.

(Also see DirectX SDK: D2D1_COLOR_F)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ColorF
Visual Basic
Public Structure ColorF
Visual C++
public value class ColorF

See Also

ColorF Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Members
ColorF Structure Constructors Methods Operators Properties See Also Send Feedback

The ColorF type exposes the following members.

Constructors

 | Name | Description
Public method | ColorF(Int32) | Constructor for the ColorF value type
Public method | ColorF(array<Single>[]()[][]) | Constructor for the ColorF value type
Public method | ColorF(ColorI) | Constructor for the ColorF value type
Public method | ColorF(array<Single>[]()[][], Single) | Constructor for the ColorF value type
Public method | ColorF(Single, Single, Single) | Constructor for the ColorF value type
Public method | ColorF(Single, Single, Single, Single) | Constructor for the ColorF value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Alpha | Floating-point value specifying the alpha component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being completely transparent.
Public property | Blue | Floating-point value specifying the blue component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being black.
Public property | Green | Floating-point value specifying the green component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being black.
Public property | Red | Floating-point value specifying the red component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being black.

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Constructor
ColorF Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorF(Int32) | Constructor for the ColorF value type
Public method | ColorF(array<Single>[]()[][]) | Constructor for the ColorF value type
Public method | ColorF(ColorI) | Constructor for the ColorF value type
Public method | ColorF(array<Single>[]()[][], Single) | Constructor for the ColorF value type
Public method | ColorF(Single, Single, Single) | Constructor for the ColorF value type
Public method | ColorF(Single, Single, Single, Single) | Constructor for the ColorF value type

See Also

ColorF Structure
ColorF Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Constructor (Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Constructor (Int32)
ColorF Structure See Also Send Feedback
Constructor for the ColorF value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorF(
    int argb
)
Visual Basic
Public Sub New ( _
    argb As Integer _
)
Visual C++
public:
ColorF(
    int argb
)

Parameters

argb
Type: System..::..Int32
Packed 8-bit-per-channel color value; alpha channel is most-significant byte, blue is least-significant

See Also

ColorF Structure
ColorF Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Constructor (Single[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Constructor (array<Single>[]()[][])
ColorF Structure See Also Send Feedback
Constructor for the ColorF value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorF(
    float[] colorValues
)
Visual Basic
Public Sub New ( _
    colorValues As Single() _
)
Visual C++
public:
ColorF(
    array<float>^ colorValues
)

Parameters

colorValues
Type: array< System..::..Single >[]()[][]
An array containing red, green, blue, and (optionally) alpha values for the ColorF value

See Also

ColorF Structure
ColorF Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Constructor (ColorI)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Constructor (ColorI)
ColorF Structure See Also Send Feedback
Constructor for the ColorF value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorF(
    ColorI color
)
Visual Basic
Public Sub New ( _
    color As ColorI _
)
Visual C++
public:
ColorF(
    ColorI color
)

Parameters

color
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorI
ColorI value used to initialize the new ColorF value

See Also

ColorF Structure
ColorF Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Constructor (Single[], Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Constructor (array<Single>[]()[][], Single)
ColorF Structure See Also Send Feedback
Constructor for the ColorF value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorF(
    float[] colorValues,
    float alpha
)
Visual Basic
Public Sub New ( _
    colorValues As Single(), _
    alpha As Single _
)
Visual C++
public:
ColorF(
    array<float>^ colorValues,
    float alpha
)

Parameters

colorValues
Type: array< System..::..Single >[]()[][]
An array containing red, green, and blue values for the ColorF value
alpha
Type: System..::..Single
The alpha value for the ColorF value

See Also

ColorF Structure
ColorF Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Constructor (Single, Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Constructor (Single, Single, Single)
ColorF Structure See Also Send Feedback
Constructor for the ColorF value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorF(
    float red,
    float green,
    float blue
)
Visual Basic
Public Sub New ( _
    red As Single, _
    green As Single, _
    blue As Single _
)
Visual C++
public:
ColorF(
    float red,
    float green,
    float blue
)

Parameters

red
Type: System..::..Single
Initializes the Red property.
green
Type: System..::..Single
Initializes the Green property.
blue
Type: System..::..Single
Initializes the Blue property.

See Also

ColorF Structure
ColorF Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Constructor (Single, Single, Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Constructor (Single, Single, Single, Single)
ColorF Structure See Also Send Feedback
Constructor for the ColorF value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorF(
    float red,
    float green,
    float blue,
    float alpha
)
Visual Basic
Public Sub New ( _
    red As Single, _
    green As Single, _
    blue As Single, _
    alpha As Single _
)
Visual C++
public:
ColorF(
    float red,
    float green,
    float blue,
    float alpha
)

Parameters

red
Type: System..::..Single
Initializes the Red property.
green
Type: System..::..Single
Initializes the Green property.
blue
Type: System..::..Single
Initializes the Blue property.
alpha
Type: System..::..Single
Initializes the Alpha property.

See Also

ColorF Structure
ColorF Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Methods
ColorF Structure See Also Send Feedback

The ColorF type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF..::..Equals Method
ColorF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF..::..GetHashCode Method
ColorF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Operators
ColorF Structure See Also Send Feedback

The ColorF type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF..::..Equality Operator
ColorF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ColorF color1,
    ColorF color2
)
Visual Basic
Public Shared Operator = ( _
    color1 As ColorF, _
    color2 As ColorF _
) As Boolean
Visual C++
public:
static bool operator ==(
    ColorF color1,
    ColorF color2
)

Parameters

color1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF
color2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF..::..Inequality Operator
ColorF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ColorF color1,
    ColorF color2
)
Visual Basic
Public Shared Operator <> ( _
    color1 As ColorF, _
    color2 As ColorF _
) As Boolean
Visual C++
public:
static bool operator !=(
    ColorF color1,
    ColorF color2
)

Parameters

color1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF
color2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorF Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF Properties
ColorF Structure See Also Send Feedback

The ColorF type exposes the following members.

Properties

 | Name | Description
Public property | Alpha | Floating-point value specifying the alpha component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being completely transparent.
Public property | Blue | Floating-point value specifying the blue component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being black.
Public property | Green | Floating-point value specifying the green component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being black.
Public property | Red | Floating-point value specifying the red component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being black.

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Alpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF..::..Alpha Property
ColorF Structure See Also Send Feedback
Floating-point value specifying the alpha component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being completely transparent.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Alpha { get; set; }
Visual Basic
Public Property Alpha As Single
    Get
    Set
Visual C++
public:
property float Alpha {
    float get ();
    void set (float value);
}

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Blue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF..::..Blue Property
ColorF Structure See Also Send Feedback
Floating-point value specifying the blue component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being black.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Blue { get; set; }
Visual Basic
Public Property Blue As Single
    Get
    Set
Visual C++
public:
property float Blue {
    float get ();
    void set (float value);
}

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Green Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF..::..Green Property
ColorF Structure See Also Send Feedback
Floating-point value specifying the green component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being black.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Green { get; set; }
Visual Basic
Public Property Green As Single
    Get
    Set
Visual C++
public:
property float Green {
    float get ();
    void set (float value);
}

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Red Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorF..::..Red Property
ColorF Structure See Also Send Feedback
Floating-point value specifying the red component of a color. This value generally is in the range from 0.0 through 1.0, with 0.0 being black.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Red { get; set; }
Visual Basic
Public Property Red As Single
    Get
    Set
Visual C++
public:
property float Red {
    float get ();
    void set (float value);
}

See Also

ColorF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Structure
Members See Also Send Feedback
Describes the red, green, blue, and alpha components of a color using integer values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ColorI
Visual Basic
Public Structure ColorI
Visual C++
public value class ColorI

See Also

ColorI Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Members
ColorI Structure Constructors Methods Operators Properties See Also Send Feedback

The ColorI type exposes the following members.

Constructors

 | Name | Description
Public method | ColorI(Int32) | Constructor for the ColorI value type
Public method | ColorI(ColorF) | Constructor for the ColorI value type
Public method | ColorI(Int32, Int32, Int32) | Constructor for the ColorI value type
Public method | ColorI(Int32, Int32, Int32, Int32) | Constructor for the ColorI value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Alpha | Integer value specifying the alpha (transparency) component of a color. This value is in the range from 0 through 255, with 0 being black.
Public property | Blue | Integer value specifying the blue component of a color. This value is in the range from 0 through 255, with 0 being black.
Public property | Green | Integer value specifying the green component of a color. This value is in the range from 0 through 255, with 0 being black.
Public property | Red | Integer value specifying the red component of a color. This value is in the range from 0 through 255, with 0 being black.

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Constructor
ColorI Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorI(Int32) | Constructor for the ColorI value type
Public method | ColorI(ColorF) | Constructor for the ColorI value type
Public method | ColorI(Int32, Int32, Int32) | Constructor for the ColorI value type
Public method | ColorI(Int32, Int32, Int32, Int32) | Constructor for the ColorI value type

See Also

ColorI Structure
ColorI Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Constructor (Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Constructor (Int32)
ColorI Structure See Also Send Feedback
Constructor for the ColorI value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorI(
    int argb
)
Visual Basic
Public Sub New ( _
    argb As Integer _
)
Visual C++
public:
ColorI(
    int argb
)

Parameters

argb
Type: System..::..Int32
32-bit integer composed of the alpha, red, green, and blue color components, most significant byte to least, respectively.

See Also

ColorI Structure
ColorI Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Constructor (ColorF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Constructor (ColorF)
ColorI Structure See Also Send Feedback
Constructor for the ColorI value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorI(
    ColorF color
)
Visual Basic
Public Sub New ( _
    color As ColorF _
)
Visual C++
public:
ColorI(
    ColorF color
)

Parameters

color
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF
ColorF value used to initialize the new ColorI value

See Also

ColorI Structure
ColorI Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Constructor (Int32, Int32, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Constructor (Int32, Int32, Int32)
ColorI Structure See Also Send Feedback
Constructor for the ColorI value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorI(
    int red,
    int green,
    int blue
)
Visual Basic
Public Sub New ( _
    red As Integer, _
    green As Integer, _
    blue As Integer _
)
Visual C++
public:
ColorI(
    int red,
    int green,
    int blue
)

Parameters

red
Type: System..::..Int32
Initializes the Red property.
green
Type: System..::..Int32
Initializes the Green property.
blue
Type: System..::..Int32
Initializes the Blue property.

See Also

ColorI Structure
ColorI Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Constructor (Int32, Int32, Int32, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Constructor (Int32, Int32, Int32, Int32)
ColorI Structure See Also Send Feedback
Constructor for the ColorI value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorI(
    int red,
    int green,
    int blue,
    int alpha
)
Visual Basic
Public Sub New ( _
    red As Integer, _
    green As Integer, _
    blue As Integer, _
    alpha As Integer _
)
Visual C++
public:
ColorI(
    int red,
    int green,
    int blue,
    int alpha
)

Parameters

red
Type: System..::..Int32
Initializes the Red property.
green
Type: System..::..Int32
Initializes the Green property.
blue
Type: System..::..Int32
Initializes the Blue property.
alpha
Type: System..::..Int32
Initializes the Alpha property.

See Also

ColorI Structure
ColorI Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Methods
ColorI Structure See Also Send Feedback

The ColorI type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI..::..Equals Method
ColorI Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI..::..GetHashCode Method
ColorI Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Operators
ColorI Structure See Also Send Feedback

The ColorI type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI..::..Equality Operator
ColorI Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ColorI color1,
    ColorI color2
)
Visual Basic
Public Shared Operator = ( _
    color1 As ColorI, _
    color2 As ColorI _
) As Boolean
Visual C++
public:
static bool operator ==(
    ColorI color1,
    ColorI color2
)

Parameters

color1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorI
color2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorI

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI..::..Inequality Operator
ColorI Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ColorI color1,
    ColorI color2
)
Visual Basic
Public Shared Operator <> ( _
    color1 As ColorI, _
    color2 As ColorI _
) As Boolean
Visual C++
public:
static bool operator !=(
    ColorI color1,
    ColorI color2
)

Parameters

color1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorI
color2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorI

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorI Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI Properties
ColorI Structure See Also Send Feedback

The ColorI type exposes the following members.

Properties

 | Name | Description
Public property | Alpha | Integer value specifying the alpha (transparency) component of a color. This value is in the range from 0 through 255, with 0 being black.
Public property | Blue | Integer value specifying the blue component of a color. This value is in the range from 0 through 255, with 0 being black.
Public property | Green | Integer value specifying the green component of a color. This value is in the range from 0 through 255, with 0 being black.
Public property | Red | Integer value specifying the red component of a color. This value is in the range from 0 through 255, with 0 being black.

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Alpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI..::..Alpha Property
ColorI Structure See Also Send Feedback
Integer value specifying the alpha (transparency) component of a color. This value is in the range from 0 through 255, with 0 being black.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Alpha { get; set; }
Visual Basic
Public Property Alpha As Integer
    Get
    Set
Visual C++
public:
property int Alpha {
    int get ();
    void set (int value);
}

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Blue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI..::..Blue Property
ColorI Structure See Also Send Feedback
Integer value specifying the blue component of a color. This value is in the range from 0 through 255, with 0 being black.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Blue { get; set; }
Visual Basic
Public Property Blue As Integer
    Get
    Set
Visual C++
public:
property int Blue {
    int get ();
    void set (int value);
}

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Green Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI..::..Green Property
ColorI Structure See Also Send Feedback
Integer value specifying the green component of a color. This value is in the range from 0 through 255, with 0 being black.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Green { get; set; }
Visual Basic
Public Property Green As Integer
    Get
    Set
Visual C++
public:
property int Green {
    int get ();
    void set (int value);
}

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Red Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorI..::..Red Property
ColorI Structure See Also Send Feedback
Integer value specifying the red component of a color. This value is in the range from 0 through 255, with 0 being black.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Red { get; set; }
Visual Basic
Public Property Red As Integer
    Get
    Set
Visual C++
public:
property int Red {
    int get ();
    void set (int value);
}

See Also

ColorI Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CombineMode Enumeration
See Also Send Feedback
This enumeration describes the type of combine operation to be performed.

(Also see DirectX SDK: D2D1_COMBINE_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum CombineMode
Visual Basic
Public Enumeration CombineMode
Visual C++
public enum class CombineMode

Members

Member name | Description
Exclude |
Xor |
Intersect |
Union |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompatibleRenderTargetOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CompatibleRenderTargetOptions Enumeration
See Also Send Feedback
Specifies additional features supportable by a compatible render target when it is created. This enumeration allows a bitwise combination of its member values.

(Also see DirectX SDK: D2D1_COMPATIBLE_RENDER_TARGET_OPTIONS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum CompatibleRenderTargetOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration CompatibleRenderTargetOptions
Visual C++
[FlagsAttribute]
public enum class CompatibleRenderTargetOptions

Members

Member name | Description
GdiCompatible |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DBitmap Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap Class
Members See Also Send Feedback
Represents a bitmap that has been bound to a RenderTarget.

(Also see DirectX SDK: ID2D1Bitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D2DBitmap : D2DResource
Visual Basic
Public Class D2DBitmap _
    Inherits D2DResource
Visual C++
public ref class D2DBitmap : public D2DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap

See Also

D2DBitmap Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DBitmap Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap Members
D2DBitmap Class Methods Properties See Also Send Feedback

The D2DBitmap type exposes the following members.

Methods

 | Name | Description
Public method | CopyFromBitmap(D2DBitmap) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromBitmap(D2DBitmap, Point2U) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromBitmap(D2DBitmap, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromBitmap(D2DBitmap, Point2U, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromMemory(array<Byte>[]()[][], UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromMemory(IntPtr, UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromMemory(RectU, array<Byte>[]()[][], UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromMemory(RectU, IntPtr, UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromRenderTarget(RenderTarget) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)
Public method | CopyFromRenderTarget(RenderTarget, Point2U) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)
Public method | CopyFromRenderTarget(RenderTarget, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)
Public method | CopyFromRenderTarget(RenderTarget, Point2U, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)

Properties

 | Name | Description
Public property | Dpi | Return the DPI of the bitmap. (Also see DirectX SDK: ID2D1Bitmap::GetDpi)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Retrieve the format of the bitmap. (Also see DirectX SDK: ID2D1Bitmap::GetPixelFormat)
Public property | PixelSize | Returns the size of the bitmap in resolution dependent units (pixels). (Also see DirectX SDK: ID2D1Bitmap::GetPixelSize)
Public property | Size | Returns the size of the bitmap in resolution independent units. (Also see DirectX SDK: ID2D1Bitmap::GetSize)

See Also

D2DBitmap Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DBitmap Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap Methods
D2DBitmap Class See Also Send Feedback

Methods

 | Name | Description
Public method | CopyFromBitmap(D2DBitmap) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromBitmap(D2DBitmap, Point2U) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromBitmap(D2DBitmap, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromBitmap(D2DBitmap, Point2U, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromMemory(array<Byte>[]()[][], UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromMemory(IntPtr, UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromMemory(RectU, array<Byte>[]()[][], UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromMemory(RectU, IntPtr, UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromRenderTarget(RenderTarget) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)
Public method | CopyFromRenderTarget(RenderTarget, Point2U) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)
Public method | CopyFromRenderTarget(RenderTarget, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)
Public method | CopyFromRenderTarget(RenderTarget, Point2U, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)

See Also

D2DBitmap Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromBitmap Method
D2DBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyFromBitmap(D2DBitmap) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromBitmap(D2DBitmap, Point2U) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromBitmap(D2DBitmap, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)
Public method | CopyFromBitmap(D2DBitmap, Point2U, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)

See Also

D2DBitmap Class
D2DBitmap Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromBitmap Method (D2DBitmap)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromBitmap Method (D2DBitmap)
D2DBitmap Class See Also Send Feedback
Copies the specified region from the specified render target into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromBitmap(
    D2DBitmap bitmap
)
Visual Basic
Public Sub CopyFromBitmap ( _
    bitmap As D2DBitmap _
)
Visual C++
public:
void CopyFromBitmap(
    D2DBitmap^ bitmap
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.

See Also

D2DBitmap Class
CopyFromBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromBitmap Method (D2DBitmap, Point2U)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromBitmap Method (D2DBitmap, Point2U)
D2DBitmap Class See Also Send Feedback
Copies the specified region from the specified render target into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromBitmap(
    D2DBitmap bitmap,
    Point2U destinationPoint
)
Visual Basic
Public Sub CopyFromBitmap ( _
    bitmap As D2DBitmap, _
    destinationPoint As Point2U _
)
Visual C++
public:
void CopyFromBitmap(
    D2DBitmap^ bitmap,
    Point2U destinationPoint
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
destinationPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2U
The destinationPoint parameter.

See Also

D2DBitmap Class
CopyFromBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromBitmap Method (D2DBitmap, RectU)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromBitmap Method (D2DBitmap, RectU)
D2DBitmap Class See Also Send Feedback
Copies the specified region from the specified render target into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromBitmap(
    D2DBitmap bitmap,
    RectU sourceRect
)
Visual Basic
Public Sub CopyFromBitmap ( _
    bitmap As D2DBitmap, _
    sourceRect As RectU _
)
Visual C++
public:
void CopyFromBitmap(
    D2DBitmap^ bitmap,
    RectU sourceRect
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
sourceRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU
The sourceRect parameter.

See Also

D2DBitmap Class
CopyFromBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromBitmap Method (D2DBitmap, Point2U, RectU)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromBitmap Method (D2DBitmap, Point2U, RectU)
D2DBitmap Class See Also Send Feedback
Copies the specified region from the specified render target into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromBitmap(
    D2DBitmap bitmap,
    Point2U destinationPoint,
    RectU sourceRect
)
Visual Basic
Public Sub CopyFromBitmap ( _
    bitmap As D2DBitmap, _
    destinationPoint As Point2U, _
    sourceRect As RectU _
)
Visual C++
public:
void CopyFromBitmap(
    D2DBitmap^ bitmap,
    Point2U destinationPoint,
    RectU sourceRect
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
destinationPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2U
The destinationPoint parameter.
sourceRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU
The sourceRect parameter.

See Also

D2DBitmap Class
CopyFromBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromMemory Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromMemory Method
D2DBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyFromMemory(array<Byte>[]()[][], UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromMemory(IntPtr, UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromMemory(RectU, array<Byte>[]()[][], UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)
Public method | CopyFromMemory(RectU, IntPtr, UInt32) | Copies the specified region from memory into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)

See Also

D2DBitmap Class
D2DBitmap Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromMemory Method (Byte[], UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromMemory Method (array<Byte>[]()[][], UInt32)
D2DBitmap Class See Also Send Feedback
Copies the specified region from memory into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromMemory(
    byte[] byteArray,
    uint pitch
)
Visual Basic
Public Sub CopyFromMemory ( _
    byteArray As Byte(), _
    pitch As UInteger _
)
Visual C++
public:
void CopyFromMemory(
    array<unsigned char>^ byteArray,
    unsigned int pitch
)

Parameters

byteArray
Type: array< System..::..Byte >[]()[][]
The data to copy.
pitch
Type: System..::..UInt32
The stride, or pitch, of the source bitmap stored in sourceData. The stride is the byte count of a scanline (one row of pixels in memory). The stride can be computed from the following formula: pixel width * bytes per pixel + memory padding.

See Also

D2DBitmap Class
CopyFromMemory Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromMemory Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromMemory Method (IntPtr, UInt32)
D2DBitmap Class See Also Send Feedback
Copies the specified region from memory into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromMemory(
    IntPtr sourceData,
    uint pitch
)
Visual Basic
Public Sub CopyFromMemory ( _
    sourceData As IntPtr, _
    pitch As UInteger _
)
Visual C++
public:
void CopyFromMemory(
    IntPtr sourceData,
    unsigned int pitch
)

Parameters

sourceData
Type: System..::..IntPtr
The data to copy.
pitch
Type: System..::..UInt32
The stride, or pitch, of the source bitmap stored in sourceData. The stride is the byte count of a scanline (one row of pixels in memory). The stride can be computed from the following formula: pixel width * bytes per pixel + memory padding.

See Also

D2DBitmap Class
CopyFromMemory Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromMemory Method (RectU, Byte[], UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromMemory Method (RectU, array<Byte>[]()[][], UInt32)
D2DBitmap Class See Also Send Feedback
Copies the specified region from memory into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromMemory(
    RectU destinationRect,
    byte[] byteArray,
    uint pitch
)
Visual Basic
Public Sub CopyFromMemory ( _
    destinationRect As RectU, _
    byteArray As Byte(), _
    pitch As UInteger _
)
Visual C++
public:
void CopyFromMemory(
    RectU destinationRect,
    array<unsigned char>^ byteArray,
    unsigned int pitch
)

Parameters

destinationRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU
In the current bitmap, the upper-left corner of the area to which the region specified is copied.
byteArray
Type: array< System..::..Byte >[]()[][]
The data to copy.
pitch
Type: System..::..UInt32
The stride, or pitch, of the source bitmap stored in sourceData. The stride is the byte count of a scanline (one row of pixels in memory). The stride can be computed from the following formula: pixel width * bytes per pixel + memory padding.

See Also

D2DBitmap Class
CopyFromMemory Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromMemory Method (RectU, IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromMemory Method (RectU, IntPtr, UInt32)
D2DBitmap Class See Also Send Feedback
Copies the specified region from memory into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromMemory(
    RectU destinationRect,
    IntPtr sourceData,
    uint pitch
)
Visual Basic
Public Sub CopyFromMemory ( _
    destinationRect As RectU, _
    sourceData As IntPtr, _
    pitch As UInteger _
)
Visual C++
public:
void CopyFromMemory(
    RectU destinationRect,
    IntPtr sourceData,
    unsigned int pitch
)

Parameters

destinationRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU
In the current bitmap, the upper-left corner of the area to which the region specified is copied.
sourceData
Type: System..::..IntPtr
The data to copy.
pitch
Type: System..::..UInt32
The stride, or pitch, of the source bitmap stored in sourceData. The stride is the byte count of a scanline (one row of pixels in memory). The stride can be computed from the following formula: pixel width * bytes per pixel + memory padding.

See Also

D2DBitmap Class
CopyFromMemory Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromRenderTarget Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromRenderTarget Method
D2DBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyFromRenderTarget(RenderTarget) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)
Public method | CopyFromRenderTarget(RenderTarget, Point2U) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)
Public method | CopyFromRenderTarget(RenderTarget, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)
Public method | CopyFromRenderTarget(RenderTarget, Point2U, RectU) | Copies the specified region from the specified render target into the current bitmap. (Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)

See Also

D2DBitmap Class
D2DBitmap Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromRenderTarget Method (RenderTarget)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromRenderTarget Method (RenderTarget)
D2DBitmap Class See Also Send Feedback
Copies the specified region from the specified render target into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromRenderTarget(
    RenderTarget renderTarget
)
Visual Basic
Public Sub CopyFromRenderTarget ( _
    renderTarget As RenderTarget _
)
Visual C++
public:
void CopyFromRenderTarget(
    RenderTarget^ renderTarget
)

Parameters

renderTarget
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTarget
The renderTarget parameter.

See Also

D2DBitmap Class
CopyFromRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromRenderTarget Method (RenderTarget, Point2U)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromRenderTarget Method (RenderTarget, Point2U)
D2DBitmap Class See Also Send Feedback
Copies the specified region from the specified render target into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromRenderTarget(
    RenderTarget renderTarget,
    Point2U destinationPoint
)
Visual Basic
Public Sub CopyFromRenderTarget ( _
    renderTarget As RenderTarget, _
    destinationPoint As Point2U _
)
Visual C++
public:
void CopyFromRenderTarget(
    RenderTarget^ renderTarget,
    Point2U destinationPoint
)

Parameters

renderTarget
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTarget
The renderTarget parameter.
destinationPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2U
The destinationPoint parameter.

See Also

D2DBitmap Class
CopyFromRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromRenderTarget Method (RenderTarget, RectU)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromRenderTarget Method (RenderTarget, RectU)
D2DBitmap Class See Also Send Feedback
Copies the specified region from the specified render target into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromRenderTarget(
    RenderTarget renderTarget,
    RectU sourceRect
)
Visual Basic
Public Sub CopyFromRenderTarget ( _
    renderTarget As RenderTarget, _
    sourceRect As RectU _
)
Visual C++
public:
void CopyFromRenderTarget(
    RenderTarget^ renderTarget,
    RectU sourceRect
)

Parameters

renderTarget
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTarget
The renderTarget parameter.
sourceRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU
The sourceRect parameter.

See Also

D2DBitmap Class
CopyFromRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyFromRenderTarget Method (RenderTarget, Point2U, RectU)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..CopyFromRenderTarget Method (RenderTarget, Point2U, RectU)
D2DBitmap Class See Also Send Feedback
Copies the specified region from the specified render target into the current bitmap.

(Also see DirectX SDK: ID2D1Bitmap::CopyFromRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyFromRenderTarget(
    RenderTarget renderTarget,
    Point2U destinationPoint,
    RectU sourceRect
)
Visual Basic
Public Sub CopyFromRenderTarget ( _
    renderTarget As RenderTarget, _
    destinationPoint As Point2U, _
    sourceRect As RectU _
)
Visual C++
public:
void CopyFromRenderTarget(
    RenderTarget^ renderTarget,
    Point2U destinationPoint,
    RectU sourceRect
)

Parameters

renderTarget
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTarget
The renderTarget parameter.
destinationPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2U
The destinationPoint parameter.
sourceRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU
The sourceRect parameter.

See Also

D2DBitmap Class
CopyFromRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DBitmap Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap Properties
D2DBitmap Class See Also Send Feedback

The D2DBitmap type exposes the following members.

Properties

 | Name | Description
Public property | Dpi | Return the DPI of the bitmap. (Also see DirectX SDK: ID2D1Bitmap::GetDpi)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Retrieve the format of the bitmap. (Also see DirectX SDK: ID2D1Bitmap::GetPixelFormat)
Public property | PixelSize | Returns the size of the bitmap in resolution dependent units (pixels). (Also see DirectX SDK: ID2D1Bitmap::GetPixelSize)
Public property | Size | Returns the size of the bitmap in resolution independent units. (Also see DirectX SDK: ID2D1Bitmap::GetSize)

See Also

D2DBitmap Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Dpi Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..Dpi Property
D2DBitmap Class See Also Send Feedback
Return the DPI of the bitmap.

(Also see DirectX SDK: ID2D1Bitmap::GetDpi)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DpiF Dpi { get; }
Visual Basic
Public ReadOnly Property Dpi As DpiF
    Get
Visual C++
public:
property DpiF Dpi {
    DpiF get ();
}

See Also

D2DBitmap Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..PixelFormat Property
D2DBitmap Class See Also Send Feedback
Retrieve the format of the bitmap.

(Also see DirectX SDK: ID2D1Bitmap::GetPixelFormat)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelFormat PixelFormat { get; }
Visual Basic
Public ReadOnly Property PixelFormat As PixelFormat
    Get
Visual C++
public:
property PixelFormat PixelFormat {
    PixelFormat get ();
}

See Also

D2DBitmap Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..PixelSize Property
D2DBitmap Class See Also Send Feedback
Returns the size of the bitmap in resolution dependent units (pixels).

(Also see DirectX SDK: ID2D1Bitmap::GetPixelSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SizeU PixelSize { get; }
Visual Basic
Public ReadOnly Property PixelSize As SizeU
    Get
Visual C++
public:
property SizeU PixelSize {
    SizeU get ();
}

See Also

D2DBitmap Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Size Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DBitmap..::..Size Property
D2DBitmap Class See Also Send Feedback
Returns the size of the bitmap in resolution independent units.

(Also see DirectX SDK: ID2D1Bitmap::GetSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SizeF Size { get; }
Visual Basic
Public ReadOnly Property Size As SizeF
    Get
Visual C++
public:
property SizeF Size {
    SizeF get ();
}

See Also

D2DBitmap Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DFactory Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory Class
Members See Also Send Feedback
Creates Direct2D resources.

(Also see DirectX SDK: ID2D1Factory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D2DFactory : DirectUnknown
Visual Basic
Public Class D2DFactory _
    Inherits DirectUnknown
Visual C++
public ref class D2DFactory : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DFactory

See Also

D2DFactory Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DFactory Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory Members
D2DFactory Class Methods Properties See Also Send Feedback

The D2DFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateDCRenderTarget | Creates a render target that draws to a GDI device context. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateDrawingStateBlock()()()() | Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateDrawingStateBlock(DrawingStateDescription) | Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateDrawingStateBlock(DrawingStateDescription, RenderingParams) | Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateEllipseGeometry | (Also see DirectX SDK: ID2D1Factory::CreateEllipseGeometry)
 | CreateFactory()()()() | Creates a factory object that can be used to create Direct2D resources. (Also see DirectX SDK: D2D1CreateFactory)
 | CreateFactory(D2DFactoryType) | Creates a factory object that can be used to create Direct2D resources. (Also see DirectX SDK: D2D1CreateFactory)
 | CreateFactory(D2DFactoryType, FactoryOptions) | Creates a factory object that can be used to create Direct2D resources. (Also see DirectX SDK: D2D1CreateFactory)
Public method | CreateGeometryGroup |
Public method | CreateGraphicsSurfaceRenderTarget | Creates a render target that draws to a Graphics Surface. The device that owns the surface is used for rendering. (Also see DirectX SDK: ID2D1Factory::CreateDxgiSurfaceRenderTarget)
Public method | CreateHwndRenderTarget | Creates a render target that appears on the display. (Also see DirectX SDK: ID2D1Factory::CreateHwndRenderTarget)
Public method | CreatePathGeometry | Returns an initially empty path geometry interface. A geometry sink is created off the interface to populate it. (Also see DirectX SDK: ID2D1Factory::CreatePathGeometry)
Public method | CreateRectangleGeometry | (Also see DirectX SDK: ID2D1Factory::CreateRectangleGeometry)
Public method | CreateRoundedRectangleGeometry | (Also see DirectX SDK: ID2D1Factory::CreateRoundedRectangleGeometry)
Public method | CreateStrokeStyle(StrokeStyleProperties) | Allows a non-default stroke style to be specified for a given geometry at draw time. (Also see DirectX SDK: ID2D1Factory::CreateStrokeStyle)
Public method | CreateStrokeStyle(StrokeStyleProperties, array<Single>[]()[][]) | Allows a non-default stroke style to be specified for a given geometry at draw time. (Also see DirectX SDK: ID2D1Factory::CreateStrokeStyle)
Public method | CreateTransformedGeometry | (Also see DirectX SDK: ID2D1Factory::CreateTransformedGeometry)
Public method | CreateWicBitmapRenderTarget | Creates a render target which is a source of bitmaps. (Also see DirectX SDK: ID2D1Factory::CreateWicBitmapRenderTarget)
Public method | ReloadSystemMetrics | Cause the factory to refresh any system metrics that it might have been snapped on factory creation. (Also see DirectX SDK: ID2D1Factory::ReloadSystemMetrics)

Properties

 | Name | Description
Public property | DesktopDpi | The current desktop DPI. To refresh this, call ReloadSystemMetrics. (Also see DirectX SDK: ID2D1Factory::GetDesktopDpi)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DFactory Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory Methods
D2DFactory Class See Also Send Feedback

The D2DFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateDCRenderTarget | Creates a render target that draws to a GDI device context. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateDrawingStateBlock()()()() | Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateDrawingStateBlock(DrawingStateDescription) | Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateDrawingStateBlock(DrawingStateDescription, RenderingParams) | Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateEllipseGeometry | (Also see DirectX SDK: ID2D1Factory::CreateEllipseGeometry)
 | CreateFactory()()()() | Creates a factory object that can be used to create Direct2D resources. (Also see DirectX SDK: D2D1CreateFactory)
 | CreateFactory(D2DFactoryType) | Creates a factory object that can be used to create Direct2D resources. (Also see DirectX SDK: D2D1CreateFactory)
 | CreateFactory(D2DFactoryType, FactoryOptions) | Creates a factory object that can be used to create Direct2D resources. (Also see DirectX SDK: D2D1CreateFactory)
Public method | CreateGeometryGroup |
Public method | CreateGraphicsSurfaceRenderTarget | Creates a render target that draws to a Graphics Surface. The device that owns the surface is used for rendering. (Also see DirectX SDK: ID2D1Factory::CreateDxgiSurfaceRenderTarget)
Public method | CreateHwndRenderTarget | Creates a render target that appears on the display. (Also see DirectX SDK: ID2D1Factory::CreateHwndRenderTarget)
Public method | CreatePathGeometry | Returns an initially empty path geometry interface. A geometry sink is created off the interface to populate it. (Also see DirectX SDK: ID2D1Factory::CreatePathGeometry)
Public method | CreateRectangleGeometry | (Also see DirectX SDK: ID2D1Factory::CreateRectangleGeometry)
Public method | CreateRoundedRectangleGeometry | (Also see DirectX SDK: ID2D1Factory::CreateRoundedRectangleGeometry)
Public method | CreateStrokeStyle(StrokeStyleProperties) | Allows a non-default stroke style to be specified for a given geometry at draw time. (Also see DirectX SDK: ID2D1Factory::CreateStrokeStyle)
Public method | CreateStrokeStyle(StrokeStyleProperties, array<Single>[]()[][]) | Allows a non-default stroke style to be specified for a given geometry at draw time. (Also see DirectX SDK: ID2D1Factory::CreateStrokeStyle)
Public method | CreateTransformedGeometry | (Also see DirectX SDK: ID2D1Factory::CreateTransformedGeometry)
Public method | CreateWicBitmapRenderTarget | Creates a render target which is a source of bitmaps. (Also see DirectX SDK: ID2D1Factory::CreateWicBitmapRenderTarget)
Public method | ReloadSystemMetrics | Cause the factory to refresh any system metrics that it might have been snapped on factory creation. (Also see DirectX SDK: ID2D1Factory::ReloadSystemMetrics)

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateDCRenderTarget Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateDCRenderTarget Method
D2DFactory Class See Also Send Feedback
Creates a render target that draws to a GDI device context.

(Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DCRenderTarget CreateDCRenderTarget(
    RenderTargetProperties renderTargetProperties
)
Visual Basic
Public Function CreateDCRenderTarget ( _
    renderTargetProperties As RenderTargetProperties _
) As DCRenderTarget
Visual C++
public:
DCRenderTarget^ CreateDCRenderTarget(
    RenderTargetProperties renderTargetProperties
)

Parameters

renderTargetProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetProperties
The renderTargetProperties parameter.

Return Value

DCRenderTarget

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateDrawingStateBlock Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateDrawingStateBlock Method
D2DFactory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDrawingStateBlock()()()() | Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateDrawingStateBlock(DrawingStateDescription) | Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)
Public method | CreateDrawingStateBlock(DrawingStateDescription, RenderingParams) | Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget. (Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)

See Also

D2DFactory Class
D2DFactory Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateDrawingStateBlock Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateDrawingStateBlock Method
D2DFactory Class See Also Send Feedback
Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget.

(Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DrawingStateBlock CreateDrawingStateBlock()
Visual Basic
Public Function CreateDrawingStateBlock As DrawingStateBlock
Visual C++
public:
DrawingStateBlock^ CreateDrawingStateBlock()

Return Value

The new drawing state block created by this method.

See Also

D2DFactory Class
CreateDrawingStateBlock Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateDrawingStateBlock Method (DrawingStateDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateDrawingStateBlock Method (DrawingStateDescription)
D2DFactory Class See Also Send Feedback
Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget.

(Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DrawingStateBlock CreateDrawingStateBlock(
    DrawingStateDescription drawingStateDescription
)
Visual Basic
Public Function CreateDrawingStateBlock ( _
    drawingStateDescription As DrawingStateDescription _
) As DrawingStateBlock
Visual C++
public:
DrawingStateBlock^ CreateDrawingStateBlock(
    DrawingStateDescription drawingStateDescription
)

Parameters

drawingStateDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateDescription
A structure that contains antialiasing, transform, and tags information.

Return Value

The new drawing state block created by this method.

See Also

D2DFactory Class
CreateDrawingStateBlock Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateDrawingStateBlock Method (DrawingStateDescription, RenderingParams)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateDrawingStateBlock Method (DrawingStateDescription, RenderingParams)
D2DFactory Class See Also Send Feedback
Creates a DrawingStateBlock that can be used with the SaveDrawingState(DrawingStateBlock) and RestoreDrawingState(DrawingStateBlock) methods of a RenderTarget.

(Also see DirectX SDK: ID2D1Factory::CreateDCRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DrawingStateBlock CreateDrawingStateBlock(
    DrawingStateDescription drawingStateDescription,
    RenderingParams textRenderingParams
)
Visual Basic
Public Function CreateDrawingStateBlock ( _
    drawingStateDescription As DrawingStateDescription, _
    textRenderingParams As RenderingParams _
) As DrawingStateBlock
Visual C++
public:
DrawingStateBlock^ CreateDrawingStateBlock(
    DrawingStateDescription drawingStateDescription,
    RenderingParams^ textRenderingParams
)

Parameters

drawingStateDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateDescription
A structure that contains antialiasing, transform, and tags information.
textRenderingParams
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..RenderingParams
Text parameters that indicate how text should be rendered. this This parameter can be null.

Return Value

The new drawing state block created by this method.

See Also

D2DFactory Class
CreateDrawingStateBlock Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateEllipseGeometry Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateEllipseGeometry Method
D2DFactory Class See Also Send Feedback

(Also see DirectX SDK: ID2D1Factory::CreateEllipseGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EllipseGeometry CreateEllipseGeometry(
    Ellipse ellipse
)
Visual Basic
Public Function CreateEllipseGeometry ( _
    ellipse As Ellipse _
) As EllipseGeometry
Visual C++
public:
EllipseGeometry^ CreateEllipseGeometry(
    Ellipse ellipse
)

Parameters

ellipse
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Ellipse
The ellipse parameter.

Return Value

EllipseGeometry

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateFactory Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateFactory Method
D2DFactory Class See Also Send Feedback

Overload List

Name | Description
CreateFactory()()()() | Creates a factory object that can be used to create Direct2D resources. (Also see DirectX SDK: D2D1CreateFactory)
CreateFactory(D2DFactoryType) | Creates a factory object that can be used to create Direct2D resources. (Also see DirectX SDK: D2D1CreateFactory)
CreateFactory(D2DFactoryType, FactoryOptions) | Creates a factory object that can be used to create Direct2D resources. (Also see DirectX SDK: D2D1CreateFactory)

See Also

D2DFactory Class
D2DFactory Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateFactory Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateFactory Method
D2DFactory Class See Also Send Feedback
Creates a factory object that can be used to create Direct2D resources.

(Also see DirectX SDK: D2D1CreateFactory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D2DFactory CreateFactory()
Visual Basic
Public Shared Function CreateFactory As D2DFactory
Visual C++
public:
static D2DFactory^ CreateFactory()

Return Value

The new factory object.

See Also

D2DFactory Class
CreateFactory Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateFactory Method (D2DFactoryType)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateFactory Method (D2DFactoryType)
D2DFactory Class See Also Send Feedback
Creates a factory object that can be used to create Direct2D resources.

(Also see DirectX SDK: D2D1CreateFactory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D2DFactory CreateFactory(
    D2DFactoryType factoryType
)
Visual Basic
Public Shared Function CreateFactory ( _
    factoryType As D2DFactoryType _
) As D2DFactory
Visual C++
public:
static D2DFactory^ CreateFactory(
    D2DFactoryType factoryType
)

Parameters

factoryType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DFactoryType
The type of factory to create.

Return Value

The new factory object.

See Also

D2DFactory Class
CreateFactory Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateFactory Method (D2DFactoryType, FactoryOptions)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateFactory Method (D2DFactoryType, FactoryOptions)
D2DFactory Class See Also Send Feedback
Creates a factory object that can be used to create Direct2D resources.

(Also see DirectX SDK: D2D1CreateFactory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D2DFactory CreateFactory(
    D2DFactoryType factoryType,
    FactoryOptions factoryOptions
)
Visual Basic
Public Shared Function CreateFactory ( _
    factoryType As D2DFactoryType, _
    factoryOptions As FactoryOptions _
) As D2DFactory
Visual C++
public:
static D2DFactory^ CreateFactory(
    D2DFactoryType factoryType,
    FactoryOptions factoryOptions
)

Parameters

factoryType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DFactoryType
The type of factory to create.
factoryOptions
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FactoryOptions
Options defining the level of detail provided to the debugging layer.

Return Value

The new factory object.

See Also

D2DFactory Class
CreateFactory Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateGeometryGroup Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateGeometryGroup Method
D2DFactory Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryGroup CreateGeometryGroup(
    FillMode fillMode,
    IEnumerable<Geometry> geometries
)
Visual Basic
Public Function CreateGeometryGroup ( _
    fillMode As FillMode, _
    geometries As IEnumerable(Of Geometry) _
) As GeometryGroup
Visual C++
public:
GeometryGroup^ CreateGeometryGroup(
    FillMode fillMode,
    IEnumerable<Geometry^>^ geometries
)

Parameters

fillMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FillMode
geometries
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Geometry >)>)>

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateGraphicsSurfaceRenderTarget Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateGraphicsSurfaceRenderTarget Method
D2DFactory Class See Also Send Feedback
Creates a render target that draws to a Graphics Surface. The device that owns the surface is used for rendering.

(Also see DirectX SDK: ID2D1Factory::CreateDxgiSurfaceRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTarget CreateGraphicsSurfaceRenderTarget(
    Surface surface,
    RenderTargetProperties renderTargetProperties
)
Visual Basic
Public Function CreateGraphicsSurfaceRenderTarget ( _
    surface As Surface, _
    renderTargetProperties As RenderTargetProperties _
) As RenderTarget
Visual C++
public:
RenderTarget^ CreateGraphicsSurfaceRenderTarget(
    Surface^ surface,
    RenderTargetProperties renderTargetProperties
)

Parameters

surface
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface
The dxgiSurface parameter.
renderTargetProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetProperties
The renderTargetProperties parameter.

Return Value

RenderTarget

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateHwndRenderTarget Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateHwndRenderTarget Method
D2DFactory Class See Also Send Feedback
Creates a render target that appears on the display.

(Also see DirectX SDK: ID2D1Factory::CreateHwndRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HwndRenderTarget CreateHwndRenderTarget(
    RenderTargetProperties renderTargetProperties,
    HwndRenderTargetProperties hwndRenderTargetProperties
)
Visual Basic
Public Function CreateHwndRenderTarget ( _
    renderTargetProperties As RenderTargetProperties, _
    hwndRenderTargetProperties As HwndRenderTargetProperties _
) As HwndRenderTarget
Visual C++
public:
HwndRenderTarget^ CreateHwndRenderTarget(
    RenderTargetProperties renderTargetProperties,
    HwndRenderTargetProperties hwndRenderTargetProperties
)

Parameters

renderTargetProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetProperties
The renderTargetProperties parameter.
hwndRenderTargetProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..HwndRenderTargetProperties
The hwndRenderTargetProperties parameter.

Return Value

HwndRenderTarget

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreatePathGeometry Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreatePathGeometry Method
D2DFactory Class See Also Send Feedback
Returns an initially empty path geometry interface. A geometry sink is created off the interface to populate it.

(Also see DirectX SDK: ID2D1Factory::CreatePathGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PathGeometry CreatePathGeometry()
Visual Basic
Public Function CreatePathGeometry As PathGeometry
Visual C++
public:
PathGeometry^ CreatePathGeometry()

Return Value

PathGeometry

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateRectangleGeometry Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateRectangleGeometry Method
D2DFactory Class See Also Send Feedback

(Also see DirectX SDK: ID2D1Factory::CreateRectangleGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectangleGeometry CreateRectangleGeometry(
    RectF rectangle
)
Visual Basic
Public Function CreateRectangleGeometry ( _
    rectangle As RectF _
) As RectangleGeometry
Visual C++
public:
RectangleGeometry^ CreateRectangleGeometry(
    RectF rectangle
)

Parameters

rectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The rectangle parameter.

Return Value

RectangleGeometry

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateRoundedRectangleGeometry Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateRoundedRectangleGeometry Method
D2DFactory Class See Also Send Feedback

(Also see DirectX SDK: ID2D1Factory::CreateRoundedRectangleGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RoundedRectangleGeometry CreateRoundedRectangleGeometry(
    RoundedRect roundedRectangle
)
Visual Basic
Public Function CreateRoundedRectangleGeometry ( _
    roundedRectangle As RoundedRect _
) As RoundedRectangleGeometry
Visual C++
public:
RoundedRectangleGeometry^ CreateRoundedRectangleGeometry(
    RoundedRect roundedRectangle
)

Parameters

roundedRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRect
The roundedRectangle parameter.

Return Value

RoundedRectangleGeometry

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateStrokeStyle Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateStrokeStyle Method
D2DFactory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateStrokeStyle(StrokeStyleProperties) | Allows a non-default stroke style to be specified for a given geometry at draw time. (Also see DirectX SDK: ID2D1Factory::CreateStrokeStyle)
Public method | CreateStrokeStyle(StrokeStyleProperties, array<Single>[]()[][]) | Allows a non-default stroke style to be specified for a given geometry at draw time. (Also see DirectX SDK: ID2D1Factory::CreateStrokeStyle)

See Also

D2DFactory Class
D2DFactory Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateStrokeStyle Method (StrokeStyleProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateStrokeStyle Method (StrokeStyleProperties)
D2DFactory Class See Also Send Feedback
Allows a non-default stroke style to be specified for a given geometry at draw time.

(Also see DirectX SDK: ID2D1Factory::CreateStrokeStyle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StrokeStyle CreateStrokeStyle(
    StrokeStyleProperties strokeStyleProperties
)
Visual Basic
Public Function CreateStrokeStyle ( _
    strokeStyleProperties As StrokeStyleProperties _
) As StrokeStyle
Visual C++
public:
StrokeStyle^ CreateStrokeStyle(
    StrokeStyleProperties strokeStyleProperties
)

Parameters

strokeStyleProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyleProperties
The strokeStyleProperties parameter.

Return Value

StrokeStyle

See Also

D2DFactory Class
CreateStrokeStyle Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateStrokeStyle Method (StrokeStyleProperties, Single[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateStrokeStyle Method (StrokeStyleProperties, array<Single>[]()[][])
D2DFactory Class See Also Send Feedback
Allows a non-default stroke style to be specified for a given geometry at draw time.

(Also see DirectX SDK: ID2D1Factory::CreateStrokeStyle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StrokeStyle CreateStrokeStyle(
    StrokeStyleProperties strokeStyleProperties,
    float[] dashes
)
Visual Basic
Public Function CreateStrokeStyle ( _
    strokeStyleProperties As StrokeStyleProperties, _
    dashes As Single() _
) As StrokeStyle
Visual C++
public:
StrokeStyle^ CreateStrokeStyle(
    StrokeStyleProperties strokeStyleProperties,
    array<float>^ dashes
)

Parameters

strokeStyleProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyleProperties
The strokeStyleProperties parameter.
dashes
Type: array< System..::..Single >[]()[][]
The dashes parameter.

Return Value

StrokeStyle

See Also

D2DFactory Class
CreateStrokeStyle Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateTransformedGeometry Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateTransformedGeometry Method
D2DFactory Class See Also Send Feedback

(Also see DirectX SDK: ID2D1Factory::CreateTransformedGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TransformedGeometry CreateTransformedGeometry(
    Geometry sourceGeometry,
    Matrix3x2F transform
)
Visual Basic
Public Function CreateTransformedGeometry ( _
    sourceGeometry As Geometry, _
    transform As Matrix3x2F _
) As TransformedGeometry
Visual C++
public:
TransformedGeometry^ CreateTransformedGeometry(
    Geometry^ sourceGeometry,
    Matrix3x2F transform
)

Parameters

sourceGeometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The sourceGeometry parameter.
transform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform parameter.

Return Value

TransformedGeometry

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateWicBitmapRenderTarget Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..CreateWicBitmapRenderTarget Method
D2DFactory Class See Also Send Feedback
Creates a render target which is a source of bitmaps.

(Also see DirectX SDK: ID2D1Factory::CreateWicBitmapRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTarget CreateWicBitmapRenderTarget(
    ImagingBitmap target,
    RenderTargetProperties renderTargetProperties
)
Visual Basic
Public Function CreateWicBitmapRenderTarget ( _
    target As ImagingBitmap, _
    renderTargetProperties As RenderTargetProperties _
) As RenderTarget
Visual C++
public:
RenderTarget^ CreateWicBitmapRenderTarget(
    ImagingBitmap^ target,
    RenderTargetProperties renderTargetProperties
)

Parameters

target
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingBitmap
The target parameter.
renderTargetProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetProperties
The renderTargetProperties parameter.

Return Value

RenderTarget

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ReloadSystemMetrics Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..ReloadSystemMetrics Method
D2DFactory Class See Also Send Feedback
Cause the factory to refresh any system metrics that it might have been snapped on factory creation.

(Also see DirectX SDK: ID2D1Factory::ReloadSystemMetrics)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ReloadSystemMetrics()
Visual Basic
Public Sub ReloadSystemMetrics
Visual C++
public:
void ReloadSystemMetrics()

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DFactory Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory Properties
D2DFactory Class See Also Send Feedback

The D2DFactory type exposes the following members.

Properties

 | Name | Description
Public property | DesktopDpi | The current desktop DPI. To refresh this, call ReloadSystemMetrics. (Also see DirectX SDK: ID2D1Factory::GetDesktopDpi)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DesktopDpi Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactory..::..DesktopDpi Property
D2DFactory Class See Also Send Feedback
The current desktop DPI. To refresh this, call ReloadSystemMetrics.

(Also see DirectX SDK: ID2D1Factory::GetDesktopDpi)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DpiF DesktopDpi { get; }
Visual Basic
Public ReadOnly Property DesktopDpi As DpiF
    Get
Visual C++
public:
property DpiF DesktopDpi {
    DpiF get ();
}

See Also

D2DFactory Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DFactoryType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DFactoryType Enumeration
See Also Send Feedback
Specifies the threading model of the created factory and all of its derived resources.

(Also see DirectX SDK: D2D1_FACTORY_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum D2DFactoryType
Visual Basic
Public Enumeration D2DFactoryType
Visual C++
public enum class D2DFactoryType

Members

Member name | Description
SingleThreaded |
Multithreaded |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DResource Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DResource Class
Members See Also Send Feedback
The base class for all resources in Direct2D 1.0

(Also see DirectX SDK: ID2D1Resource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public abstract class D2DResource : DirectUnknown
Visual Basic
Public MustInherit Class D2DResource _
    Inherits DirectUnknown
Visual C++
public ref class D2DResource abstract : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateBlock
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStopCollection
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Layer
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Mesh
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTarget
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle

See Also

D2DResource Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DResource Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DResource Members
D2DResource Class Properties See Also Send Feedback

The D2DResource type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D2DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


D2DResource Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DResource Properties
D2DResource Class See Also Send Feedback

The D2DResource type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D2DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Factory Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D2DResource..::..Factory Property
D2DResource Class See Also Send Feedback
Retrieve the factory associated with this resource.

(Also see DirectX SDK: ID2D1Resource::GetFactory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DFactory Factory { get; }
Visual Basic
Public ReadOnly Property Factory As D2DFactory
    Get
Visual C++
public:
property D2DFactory^ Factory {
    D2DFactory^ get ();
}

See Also

D2DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DashStyle Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DashStyle Enumeration
See Also Send Feedback
Describes the sequence of dashes and gaps in a stroke.

(Also see DirectX SDK: D2D1_DASH_STYLE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DashStyle
Visual Basic
Public Enumeration DashStyle
Visual C++
public enum class DashStyle

Members

Member name | Description
Solid |
Custom |
DashDotDot |
DashDot |
Dash |
Dot |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DCInitializeMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCInitializeMode Enumeration
See Also Send Feedback
Specifies how a device context is initialized for GDI rendering when it is retrieved from the render target.

(Also see DirectX SDK: D2D1_DC_INITIALIZE_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DCInitializeMode
Visual Basic
Public Enumeration DCInitializeMode
Visual C++
public enum class DCInitializeMode

Members

Member name | Description
Clear |
Copy |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DCRenderTarget Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget Class
Members See Also Send Feedback
Issues drawing commands to a GDI device context.

(Also see DirectX SDK: ID2D1DCRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DCRenderTarget : RenderTarget
Visual Basic
Public Class DCRenderTarget _
    Inherits RenderTarget
Visual C++
public ref class DCRenderTarget : public RenderTarget

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTarget
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DCRenderTarget

See Also

DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DCRenderTarget Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget Members
DCRenderTarget Class Methods Properties See Also Send Feedback

The DCRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | BeginDraw | Start drawing on this render target. Draw calls can only be issued between a BeginDraw and EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::BeginDraw) (Inherited from RenderTarget.)
Public method | BindDC | Binds the render target to the device context to which it issues drawing commands. (Also see DirectX SDK: ID2D1DCRenderTarget::BindDC)
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateGradientStopCollection | (Inherited from RenderTarget.)
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateMesh | Create a mesh that uses triangles to describe a shape. Create a D2D mesh. (Also see DirectX SDK: ID2D1RenderTarget::CreateMesh) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmapAtOrigin | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | EndDraw | Ends drawing on the render target. If an error occur while drawing, an exception will be thrown. To prevent exceptions, you can use the TryEndDraw() method instead. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | FillEllipse | Paints the interior of the specified ellipse. (Also see DirectX SDK: ID2D1RenderTarget::FillEllipse) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillMesh | Fill a mesh. Since meshes can only render aliased content, the render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillMesh) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMaskAtOrigin | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush uses the sourceRectangle area to draw at the orgin of the bitmap. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillRectangle | Paints the interior of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRectangle) (Inherited from RenderTarget.)
Public method | FillRoundedRectangle | Paints the interior of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRoundedRectangle) (Inherited from RenderTarget.)
Public method | Flush | Executes all pending drawing commands. This method will throw if an error occur during the operation. To prevent exceptions, TryFlush() can be used instead. (Also see DirectX SDK: ID2D1RenderTarget::Flush) (Inherited from RenderTarget.)
Public method | IsSupported | Returns true if the given properties are supported by this render target. The DPI is ignored. NOTE: If the render target type is software, then neither feature level 9 nor feature level 10 will be considered to be supported. (Also see DirectX SDK: ID2D1RenderTarget::IsSupported) (Inherited from RenderTarget.)
Public method | PopAxisAlignedClip | Removes the last axis-aligned clip from the render target. After this method is called, the clip is no longer applied to subsequent drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::PopAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PopLayer | Ends a layer that was defined with particular layer resources. (Also see DirectX SDK: ID2D1RenderTarget::PopLayer) (Inherited from RenderTarget.)
Public method | PushAxisAlignedClip | Pushes a clip. The clip can be antialiased. The clip must be axis aligned. If the current world transform is not axis preserving, then the bounding box of the transformed clip rect will be used. The clip will remain in effect until a PopAxisAligned clip call is made. (Also see DirectX SDK: ID2D1RenderTarget::PushAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PushLayer | Start a layer of drawing calls. The way in which the layer must be resolved is specified first as well as the logical resource that stores the layer parameters. The supplied layer resource might grow if the specified content cannot fit inside it. The layer will grow monitonically on each axis. (Also see DirectX SDK: ID2D1RenderTarget::PushLayer) (Inherited from RenderTarget.)
Public method | RestoreDrawingState | Copies the state stored in the block interface. (Also see DirectX SDK: ID2D1RenderTarget::RestoreDrawingState) (Inherited from RenderTarget.)
Public method | SaveDrawingState | Gets the current drawing state and saves it into the supplied IDrawingStatckBlock. (Also see DirectX SDK: ID2D1RenderTarget::SaveDrawingState) (Inherited from RenderTarget.)
Public method | TryEndDraw | Ends drawing on the render target, error results can be retrieved at this time, or when calling Flush() or TryFlush(). (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | TryFlush | Executes all pending drawing commands. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)

Properties

 | Name | Description
Public property | AntiAliasMode | The current antialiasing mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetAntiAliasMode, ID2D1RenderTarget::SetAntiAliasMode) (Inherited from RenderTarget.)
Public property | Dpi | The DPI on the render target. This results in the render target being interpretted to a different scale. Neither DPI can be negative. If zero is specified for both, the system DPI is chosen. If one is zero and the other unspecified, the DPI is not changed. (Also see DirectX SDK: ID2D1RenderTarget::GetDpi, ID2D1RenderTarget::SetDpi) (Inherited from RenderTarget.)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GdiInteropRenderTarget | Provide a GdiInteropRenderTarget version of this render target. (Inherited from RenderTarget.)
Public property | MaximumBitmapSize | Returns the maximum bitmap and render target size that is guaranteed to be supported by the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetMaximumBitmapSize) (Inherited from RenderTarget.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | The pixel format and alpha mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelFormat) (Inherited from RenderTarget.)
Public property | PixelSize | Returns the size of the render target in pixels. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelSize) (Inherited from RenderTarget.)
Public property | Size | Returns the size of the render target in DIPs. (Also see DirectX SDK: ID2D1RenderTarget::GetSize) (Inherited from RenderTarget.)
Public property | Tags | Get or Set a tag to labelto the succeeding drawing operations. If an error occurs while rendering a primtive, the tags can be returned from the Flush or EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::GetTags, ID2D1RenderTarget::SetTags) (Inherited from RenderTarget.)
Public property | TextAntiAliasMode | The current antialiasing mode for text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextAntiAliasMode, ID2D1RenderTarget::SetTextAntiAliasMode) (Inherited from RenderTarget.)
Public property | TextRenderingParams | Gets or set the render target's current text-rendering options. Text rendering options to apply to all text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextRenderingParams, ID2D1RenderTarget::SetTextRenderingParams) (Inherited from RenderTarget.)
Public property | Transform | The current transform of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetTransform, ID2D1RenderTarget::SetTransform) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DCRenderTarget Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget Methods
DCRenderTarget Class See Also Send Feedback

The DCRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | BeginDraw | Start drawing on this render target. Draw calls can only be issued between a BeginDraw and EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::BeginDraw) (Inherited from RenderTarget.)
Public method | BindDC | Binds the render target to the device context to which it issues drawing commands. (Also see DirectX SDK: ID2D1DCRenderTarget::BindDC)
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateGradientStopCollection | (Inherited from RenderTarget.)
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateMesh | Create a mesh that uses triangles to describe a shape. Create a D2D mesh. (Also see DirectX SDK: ID2D1RenderTarget::CreateMesh) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmapAtOrigin | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | EndDraw | Ends drawing on the render target. If an error occur while drawing, an exception will be thrown. To prevent exceptions, you can use the TryEndDraw() method instead. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | FillEllipse | Paints the interior of the specified ellipse. (Also see DirectX SDK: ID2D1RenderTarget::FillEllipse) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillMesh | Fill a mesh. Since meshes can only render aliased content, the render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillMesh) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMaskAtOrigin | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush uses the sourceRectangle area to draw at the orgin of the bitmap. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillRectangle | Paints the interior of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRectangle) (Inherited from RenderTarget.)
Public method | FillRoundedRectangle | Paints the interior of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRoundedRectangle) (Inherited from RenderTarget.)
Public method | Flush | Executes all pending drawing commands. This method will throw if an error occur during the operation. To prevent exceptions, TryFlush() can be used instead. (Also see DirectX SDK: ID2D1RenderTarget::Flush) (Inherited from RenderTarget.)
Public method | IsSupported | Returns true if the given properties are supported by this render target. The DPI is ignored. NOTE: If the render target type is software, then neither feature level 9 nor feature level 10 will be considered to be supported. (Also see DirectX SDK: ID2D1RenderTarget::IsSupported) (Inherited from RenderTarget.)
Public method | PopAxisAlignedClip | Removes the last axis-aligned clip from the render target. After this method is called, the clip is no longer applied to subsequent drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::PopAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PopLayer | Ends a layer that was defined with particular layer resources. (Also see DirectX SDK: ID2D1RenderTarget::PopLayer) (Inherited from RenderTarget.)
Public method | PushAxisAlignedClip | Pushes a clip. The clip can be antialiased. The clip must be axis aligned. If the current world transform is not axis preserving, then the bounding box of the transformed clip rect will be used. The clip will remain in effect until a PopAxisAligned clip call is made. (Also see DirectX SDK: ID2D1RenderTarget::PushAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PushLayer | Start a layer of drawing calls. The way in which the layer must be resolved is specified first as well as the logical resource that stores the layer parameters. The supplied layer resource might grow if the specified content cannot fit inside it. The layer will grow monitonically on each axis. (Also see DirectX SDK: ID2D1RenderTarget::PushLayer) (Inherited from RenderTarget.)
Public method | RestoreDrawingState | Copies the state stored in the block interface. (Also see DirectX SDK: ID2D1RenderTarget::RestoreDrawingState) (Inherited from RenderTarget.)
Public method | SaveDrawingState | Gets the current drawing state and saves it into the supplied IDrawingStatckBlock. (Also see DirectX SDK: ID2D1RenderTarget::SaveDrawingState) (Inherited from RenderTarget.)
Public method | TryEndDraw | Ends drawing on the render target, error results can be retrieved at this time, or when calling Flush() or TryFlush(). (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | TryFlush | Executes all pending drawing commands. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BindDC Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..BindDC Method
DCRenderTarget Class See Also Send Feedback
Binds the render target to the device context to which it issues drawing commands.

(Also see DirectX SDK: ID2D1DCRenderTarget::BindDC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void BindDC(
    IntPtr deviceContextHandle,
    Rect subRect
)
Visual Basic
Public Sub BindDC ( _
    deviceContextHandle As IntPtr, _
    subRect As Rect _
)
Visual C++
public:
void BindDC(
    IntPtr deviceContextHandle,
    Rect subRect
)

Parameters

deviceContextHandle
Type: System..::..IntPtr
The device context to which the render target issues drawing commands.
subRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Rect
The dimensions of the handle to a device context (HDC) to which the render target is bound. When this rectangle changes, the render target updates its size to match.

See Also

DCRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Clear Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..Clear Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..CreateBitmap Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..CreateBitmapBrush Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapFromWicBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..CreateBitmapFromWicBitmap Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..CreateCompatibleRenderTarget Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLayer Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..CreateLayer Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLinearGradientBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..CreateLinearGradientBrush Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateRadialGradientBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..CreateRadialGradientBrush Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..CreateSharedBitmap Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSolidColorBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..CreateSolidColorBrush Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..DrawBitmap Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawEllipse Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..DrawEllipse Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..DrawGeometry Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGlyphRun Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..DrawGlyphRun Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawLine Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..DrawLine Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRectangle Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..DrawRectangle Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRoundedRectangle Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..DrawRoundedRectangle Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawText Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..DrawText Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawTextLayout Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..DrawTextLayout Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..FillGeometry Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillOpacityMask Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget..::..FillOpacityMask Method
DCRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
DCRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DCRenderTarget Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DCRenderTarget Properties
DCRenderTarget Class See Also Send Feedback

The DCRenderTarget type exposes the following members.

Properties

 | Name | Description
Public property | AntiAliasMode | The current antialiasing mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetAntiAliasMode, ID2D1RenderTarget::SetAntiAliasMode) (Inherited from RenderTarget.)
Public property | Dpi | The DPI on the render target. This results in the render target being interpretted to a different scale. Neither DPI can be negative. If zero is specified for both, the system DPI is chosen. If one is zero and the other unspecified, the DPI is not changed. (Also see DirectX SDK: ID2D1RenderTarget::GetDpi, ID2D1RenderTarget::SetDpi) (Inherited from RenderTarget.)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GdiInteropRenderTarget | Provide a GdiInteropRenderTarget version of this render target. (Inherited from RenderTarget.)
Public property | MaximumBitmapSize | Returns the maximum bitmap and render target size that is guaranteed to be supported by the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetMaximumBitmapSize) (Inherited from RenderTarget.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | The pixel format and alpha mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelFormat) (Inherited from RenderTarget.)
Public property | PixelSize | Returns the size of the render target in pixels. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelSize) (Inherited from RenderTarget.)
Public property | Size | Returns the size of the render target in DIPs. (Also see DirectX SDK: ID2D1RenderTarget::GetSize) (Inherited from RenderTarget.)
Public property | Tags | Get or Set a tag to labelto the succeeding drawing operations. If an error occurs while rendering a primtive, the tags can be returned from the Flush or EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::GetTags, ID2D1RenderTarget::SetTags) (Inherited from RenderTarget.)
Public property | TextAntiAliasMode | The current antialiasing mode for text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextAntiAliasMode, ID2D1RenderTarget::SetTextAntiAliasMode) (Inherited from RenderTarget.)
Public property | TextRenderingParams | Gets or set the render target's current text-rendering options. Text rendering options to apply to all text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextRenderingParams, ID2D1RenderTarget::SetTextRenderingParams) (Inherited from RenderTarget.)
Public property | Transform | The current transform of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetTransform, ID2D1RenderTarget::SetTransform) (Inherited from RenderTarget.)

See Also

DCRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DebugLevel Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DebugLevel Enumeration
See Also Send Feedback
Indicates the type of information that Direct2D sends to the debug layer.

(Also see DirectX SDK: D2D1_DEBUG_LEVEL)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DebugLevel
Visual Basic
Public Enumeration DebugLevel
Visual C++
public enum class DebugLevel

Members

Member name | Description
None |
Information |
Warning |
Error |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Class
Members See Also Send Feedback
Base class for all Direct2D exceptions

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Direct2DException : DirectXException
Visual Basic
Public Class Direct2DException _
    Inherits DirectXException
Visual C++
public ref class Direct2DException : public DirectXException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Microsoft.WindowsAPICodePack.DirectX..::..DirectXException
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Direct2DException

See Also

Direct2DException Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Members
Direct2DException Class Constructors Properties See Also Send Feedback

The Direct2DException type exposes the following members.

Constructors

 | Name | Description
Public method | Direct2DException()()()() |
Public method | Direct2DException(Int32) |
Public method | Direct2DException(String) |
Protected method | Direct2DException(SerializationInfo, StreamingContext) |
Public method | Direct2DException(String, Exception) |
Public method | Direct2DException(String, Int32) |
Protected method | Direct2DException(SerializationInfo, StreamingContext, Int32) |
Public method | Direct2DException(String, Exception, Int32) |

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API (Inherited from DirectXException.)

See Also

Direct2DException Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Constructor
Direct2DException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Direct2DException()()()() |
Public method | Direct2DException(Int32) |
Public method | Direct2DException(String) |
Protected method | Direct2DException(SerializationInfo, StreamingContext) |
Public method | Direct2DException(String, Exception) |
Public method | Direct2DException(String, Int32) |
Protected method | Direct2DException(SerializationInfo, StreamingContext, Int32) |
Public method | Direct2DException(String, Exception, Int32) |

See Also

Direct2DException Class
Direct2DException Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Constructor
Direct2DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct2DException()
Visual Basic
Public Sub New
Visual C++
public:
Direct2DException()

See Also

Direct2DException Class
Direct2DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Constructor (Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Constructor (Int32)
Direct2DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct2DException(
    int hr
)
Visual Basic
Public Sub New ( _
    hr As Integer _
)
Visual C++
public:
Direct2DException(
    int hr
)

Parameters

hr
Type: System..::..Int32

See Also

Direct2DException Class
Direct2DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Constructor (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Constructor (String)
Direct2DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct2DException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
Direct2DException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

Direct2DException Class
Direct2DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Constructor (SerializationInfo, StreamingContext)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Constructor (SerializationInfo, StreamingContext)
Direct2DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected Direct2DException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
Direct2DException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext

See Also

Direct2DException Class
Direct2DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Constructor (String, Exception)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Constructor (String, Exception)
Direct2DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct2DException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
Direct2DException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception

See Also

Direct2DException Class
Direct2DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Constructor (String, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Constructor (String, Int32)
Direct2DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct2DException(
    string message,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    hr As Integer _
)
Visual C++
public:
Direct2DException(
    String^ message,
    int hr
)

Parameters

message
Type: System..::..String
hr
Type: System..::..Int32

See Also

Direct2DException Class
Direct2DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Constructor (SerializationInfo, StreamingContext, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Constructor (SerializationInfo, StreamingContext, Int32)
Direct2DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected Direct2DException(
    SerializationInfo info,
    StreamingContext context,
    int hr
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext, _
    hr As Integer _
)
Visual C++
protected:
Direct2DException(
    SerializationInfo^ info,
    StreamingContext context,
    int hr
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext
hr
Type: System..::..Int32

See Also

Direct2DException Class
Direct2DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Constructor (String, Exception, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Constructor (String, Exception, Int32)
Direct2DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct2DException(
    string message,
    Exception innerException,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception, _
    hr As Integer _
)
Visual C++
public:
Direct2DException(
    String^ message,
    Exception^ innerException,
    int hr
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception
hr
Type: System..::..Int32

See Also

Direct2DException Class
Direct2DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Direct2DException Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct2DException Properties
Direct2DException Class See Also Send Feedback

The Direct2DException type exposes the following members.

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API (Inherited from DirectXException.)

See Also

Direct2DException Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiF Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF Structure
Members See Also Send Feedback
Define horizontal and vertical Dpi settings.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct DpiF
Visual Basic
Public Structure DpiF
Visual C++
public value class DpiF

See Also

DpiF Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiF Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF Members
DpiF Structure Constructors Methods Operators Properties See Also Send Feedback

The DpiF type exposes the following members.

Constructors

 | Name | Description
Public method | DpiF | Constructor for the DpiF value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | X | The horizontal Dpi setting.
Public property | Y | The vertical Dpi setting.

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiF Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF Constructor
DpiF Structure See Also Send Feedback
Constructor for the DpiF value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DpiF(
    float x,
    float y
)
Visual Basic
Public Sub New ( _
    x As Single, _
    y As Single _
)
Visual C++
public:
DpiF(
    float x,
    float y
)

Parameters

x
Type: System..::..Single
Initializes the X property.
y
Type: System..::..Single
Initializes the Y property.

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiF Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF Methods
DpiF Structure See Also Send Feedback

The DpiF type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF..::..Equals Method
DpiF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF..::..GetHashCode Method
DpiF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiF Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF Operators
DpiF Structure See Also Send Feedback

The DpiF type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF..::..Equality Operator
DpiF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    DpiF dpi1,
    DpiF dpi2
)
Visual Basic
Public Shared Operator = ( _
    dpi1 As DpiF, _
    dpi2 As DpiF _
) As Boolean
Visual C++
public:
static bool operator ==(
    DpiF dpi1,
    DpiF dpi2
)

Parameters

dpi1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DpiF
dpi2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DpiF

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF..::..Inequality Operator
DpiF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    DpiF dpi1,
    DpiF dpi2
)
Visual Basic
Public Shared Operator <> ( _
    dpi1 As DpiF, _
    dpi2 As DpiF _
) As Boolean
Visual C++
public:
static bool operator !=(
    DpiF dpi1,
    DpiF dpi2
)

Parameters

dpi1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DpiF
dpi2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DpiF

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiF Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF Properties
DpiF Structure See Also Send Feedback

The DpiF type exposes the following members.

Properties

 | Name | Description
Public property | X | The horizontal Dpi setting.
Public property | Y | The vertical Dpi setting.

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


X Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF..::..X Property
DpiF Structure See Also Send Feedback
The horizontal Dpi setting.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float X { get; set; }
Visual Basic
Public Property X As Single
    Get
    Set
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Y Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DpiF..::..Y Property
DpiF Structure See Also Send Feedback
The vertical Dpi setting.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Y { get; set; }
Visual Basic
Public Property Y As Single
    Get
    Set
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

DpiF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawingStateBlock Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateBlock Class
Members See Also Send Feedback
Represents the drawing state of a render target: the antialiasing mode, transform, tags, and text-rendering options.

(Also see DirectX SDK: ID2D1DrawingStateBlock)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DrawingStateBlock : D2DResource
Visual Basic
Public Class DrawingStateBlock _
    Inherits D2DResource
Visual C++
public ref class DrawingStateBlock : public D2DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateBlock

See Also

DrawingStateBlock Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawingStateBlock Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateBlock Members
DrawingStateBlock Class Properties See Also Send Feedback

The DrawingStateBlock type exposes the following members.

Properties

 | Name | Description
Public property | Description | The state currently contained within this state block resource. (Also see DirectX SDK: ID2D1DrawingStateBlock::GetDescription, ID2D1DrawingStateBlock::SetDescription)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | TextRenderingParams | Gets or set the text-rendering configuration of the drawing state. (Also see DirectX SDK: ID2D1DrawingStateBlock::GetTextRenderingParams, ID2D1DrawingStateBlock::SetTextRenderingParams)

See Also

DrawingStateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawingStateBlock Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateBlock Properties
DrawingStateBlock Class See Also Send Feedback

The DrawingStateBlock type exposes the following members.

Properties

 | Name | Description
Public property | Description | The state currently contained within this state block resource. (Also see DirectX SDK: ID2D1DrawingStateBlock::GetDescription, ID2D1DrawingStateBlock::SetDescription)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | TextRenderingParams | Gets or set the text-rendering configuration of the drawing state. (Also see DirectX SDK: ID2D1DrawingStateBlock::GetTextRenderingParams, ID2D1DrawingStateBlock::SetTextRenderingParams)

See Also

DrawingStateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateBlock..::..Description Property
DrawingStateBlock Class See Also Send Feedback
The state currently contained within this state block resource.

(Also see DirectX SDK: ID2D1DrawingStateBlock::GetDescription, ID2D1DrawingStateBlock::SetDescription)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DrawingStateDescription Description { get; set; }
Visual Basic
Public Property Description As DrawingStateDescription
    Get
    Set
Visual C++
public:
property DrawingStateDescription Description {
    DrawingStateDescription get ();
    void set (DrawingStateDescription value);
}

See Also

DrawingStateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TextRenderingParams Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateBlock..::..TextRenderingParams Property
DrawingStateBlock Class See Also Send Feedback
Gets or set the text-rendering configuration of the drawing state.

(Also see DirectX SDK: ID2D1DrawingStateBlock::GetTextRenderingParams, ID2D1DrawingStateBlock::SetTextRenderingParams)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderingParams TextRenderingParams { get; set; }
Visual Basic
Public Property TextRenderingParams As RenderingParams
    Get
    Set
Visual C++
public:
property RenderingParams^ TextRenderingParams {
    RenderingParams^ get ();
    void set (RenderingParams^ value);
}

See Also

DrawingStateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawingStateDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription Structure
Members See Also Send Feedback
Describes the drawing state of a render target. This also specifies the drawing state that is saved into a DrawingStateBlock object.

(Also see DirectX SDK: D2D1_DRAWING_STATE_DESCRIPTION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct DrawingStateDescription
Visual Basic
Public Structure DrawingStateDescription
Visual C++
public value class DrawingStateDescription

See Also

DrawingStateDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawingStateDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription Members
DrawingStateDescription Structure Constructors Methods Operators Properties See Also Send Feedback

The DrawingStateDescription type exposes the following members.

Constructors

 | Name | Description
Public method | DrawingStateDescription | Constructor for the DrawingStateDescription value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AntiAliasMode | The antialiasing mode for subsequent nontext drawing operations.
Public property | Tags | The tags for subsequent drawing operations.
Public property | TextAntiAliasMode | The antialiasing mode for subsequent text and glyph drawing operations.
Public property | Transform | The transformation to apply to subsequent drawing operations.

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawingStateDescription Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription Constructor
DrawingStateDescription Structure See Also Send Feedback
Constructor for the DrawingStateDescription value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DrawingStateDescription(
    AntiAliasMode antiAliasMode,
    TextAntiAliasMode textAntiAliasMode,
    Tags tags,
    Matrix3x2F transform
)
Visual Basic
Public Sub New ( _
    antiAliasMode As AntiAliasMode, _
    textAntiAliasMode As TextAntiAliasMode, _
    tags As Tags, _
    transform As Matrix3x2F _
)
Visual C++
public:
DrawingStateDescription(
    AntiAliasMode antiAliasMode,
    TextAntiAliasMode textAntiAliasMode,
    Tags tags,
    Matrix3x2F transform
)

Parameters

antiAliasMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..AntiAliasMode
Initializes the AntiAliasMode property.
textAntiAliasMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..TextAntiAliasMode
Initializes the TextAntiAliasMode property.
tags
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Tags
Initializes the Tags property.
transform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
Initializes the Transform property.

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawingStateDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription Methods
DrawingStateDescription Structure See Also Send Feedback

The DrawingStateDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription..::..Equals Method
DrawingStateDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription..::..GetHashCode Method
DrawingStateDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawingStateDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription Operators
DrawingStateDescription Structure See Also Send Feedback

The DrawingStateDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription..::..Equality Operator
DrawingStateDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    DrawingStateDescription drawingStateDescription1,
    DrawingStateDescription drawingStateDescription2
)
Visual Basic
Public Shared Operator = ( _
    drawingStateDescription1 As DrawingStateDescription, _
    drawingStateDescription2 As DrawingStateDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    DrawingStateDescription drawingStateDescription1,
    DrawingStateDescription drawingStateDescription2
)

Parameters

drawingStateDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateDescription
drawingStateDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateDescription

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription..::..Inequality Operator
DrawingStateDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    DrawingStateDescription drawingStateDescription1,
    DrawingStateDescription drawingStateDescription2
)
Visual Basic
Public Shared Operator <> ( _
    drawingStateDescription1 As DrawingStateDescription, _
    drawingStateDescription2 As DrawingStateDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    DrawingStateDescription drawingStateDescription1,
    DrawingStateDescription drawingStateDescription2
)

Parameters

drawingStateDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateDescription
drawingStateDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateDescription

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawingStateDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription Properties
DrawingStateDescription Structure See Also Send Feedback

The DrawingStateDescription type exposes the following members.

Properties

 | Name | Description
Public property | AntiAliasMode | The antialiasing mode for subsequent nontext drawing operations.
Public property | Tags | The tags for subsequent drawing operations.
Public property | TextAntiAliasMode | The antialiasing mode for subsequent text and glyph drawing operations.
Public property | Transform | The transformation to apply to subsequent drawing operations.

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AntiAliasMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription..::..AntiAliasMode Property
DrawingStateDescription Structure See Also Send Feedback
The antialiasing mode for subsequent nontext drawing operations.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public AntiAliasMode AntiAliasMode { get; set; }
Visual Basic
Public Property AntiAliasMode As AntiAliasMode
    Get
    Set
Visual C++
public:
property AntiAliasMode AntiAliasMode {
    AntiAliasMode get ();
    void set (AntiAliasMode value);
}

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tags Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription..::..Tags Property
DrawingStateDescription Structure See Also Send Feedback
The tags for subsequent drawing operations.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Tags Tags { get; set; }
Visual Basic
Public Property Tags As Tags
    Get
    Set
Visual C++
public:
property Tags Tags {
    Tags get ();
    void set (Tags value);
}

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TextAntiAliasMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription..::..TextAntiAliasMode Property
DrawingStateDescription Structure See Also Send Feedback
The antialiasing mode for subsequent text and glyph drawing operations.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextAntiAliasMode TextAntiAliasMode { get; set; }
Visual Basic
Public Property TextAntiAliasMode As TextAntiAliasMode
    Get
    Set
Visual C++
public:
property TextAntiAliasMode TextAntiAliasMode {
    TextAntiAliasMode get ();
    void set (TextAntiAliasMode value);
}

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Transform Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawingStateDescription..::..Transform Property
DrawingStateDescription Structure See Also Send Feedback
The transformation to apply to subsequent drawing operations.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix3x2F Transform { get; set; }
Visual Basic
Public Property Transform As Matrix3x2F
    Get
    Set
Visual C++
public:
property Matrix3x2F Transform {
    Matrix3x2F get ();
    void set (Matrix3x2F value);
}

See Also

DrawingStateDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawTextOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DrawTextOptions Enumeration
See Also Send Feedback
Specifies whether text snapping is suppressed or clipping to the layout rectangle is enabled. This enumeration allows a bitwise combination of its member values.

(Also see DirectX SDK: D2D1_DRAW_TEXT_OPTIONS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum DrawTextOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration DrawTextOptions
Visual C++
[FlagsAttribute]
public enum class DrawTextOptions

Members

Member name | Description
None |
Clip |
NoSnap |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Ellipse Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse Structure
Members See Also Send Feedback
Contains the center point, x-radius, and y-radius of an ellipse.

(Also see DirectX SDK: D2D1_ELLIPSE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Ellipse
Visual Basic
Public Structure Ellipse
Visual C++
public value class Ellipse

See Also

Ellipse Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Ellipse Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse Members
Ellipse Structure Constructors Methods Operators Properties See Also Send Feedback

The Ellipse type exposes the following members.

Constructors

 | Name | Description
Public method | Ellipse | Constructor for the Ellipse value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Point | The center point of the ellipse.
Public property | RadiusX | The X-radius of the ellipse.
Public property | RadiusY | The Y-radius of the ellipse.

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Ellipse Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse Constructor
Ellipse Structure See Also Send Feedback
Constructor for the Ellipse value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Ellipse(
    Point2F point,
    float radiusX,
    float radiusY
)
Visual Basic
Public Sub New ( _
    point As Point2F, _
    radiusX As Single, _
    radiusY As Single _
)
Visual C++
public:
Ellipse(
    Point2F point,
    float radiusX,
    float radiusY
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point property.
radiusX
Type: System..::..Single
Initializes the RadiusX property.
radiusY
Type: System..::..Single
Initializes the RadiusY property.

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Ellipse Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse Methods
Ellipse Structure See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse..::..Equals Method
Ellipse Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse..::..GetHashCode Method
Ellipse Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Ellipse Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse Operators
Ellipse Structure See Also Send Feedback

The Ellipse type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse..::..Equality Operator
Ellipse Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Ellipse ellipse1,
    Ellipse ellipse2
)
Visual Basic
Public Shared Operator = ( _
    ellipse1 As Ellipse, _
    ellipse2 As Ellipse _
) As Boolean
Visual C++
public:
static bool operator ==(
    Ellipse ellipse1,
    Ellipse ellipse2
)

Parameters

ellipse1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Ellipse
ellipse2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Ellipse

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse..::..Inequality Operator
Ellipse Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Ellipse ellipse1,
    Ellipse ellipse2
)
Visual Basic
Public Shared Operator <> ( _
    ellipse1 As Ellipse, _
    ellipse2 As Ellipse _
) As Boolean
Visual C++
public:
static bool operator !=(
    Ellipse ellipse1,
    Ellipse ellipse2
)

Parameters

ellipse1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Ellipse
ellipse2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Ellipse

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Ellipse Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse Properties
Ellipse Structure See Also Send Feedback

The Ellipse type exposes the following members.

Properties

 | Name | Description
Public property | Point | The center point of the ellipse.
Public property | RadiusX | The X-radius of the ellipse.
Public property | RadiusY | The Y-radius of the ellipse.

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse..::..Point Property
Ellipse Structure See Also Send Feedback
The center point of the ellipse.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point { get; set; }
Visual Basic
Public Property Point As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point {
    Point2F get ();
    void set (Point2F value);
}

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadiusX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse..::..RadiusX Property
Ellipse Structure See Also Send Feedback
The X-radius of the ellipse.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float RadiusX { get; set; }
Visual Basic
Public Property RadiusX As Single
    Get
    Set
Visual C++
public:
property float RadiusX {
    float get ();
    void set (float value);
}

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadiusY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Ellipse..::..RadiusY Property
Ellipse Structure See Also Send Feedback
The Y-radius of the ellipse.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float RadiusY { get; set; }
Visual Basic
Public Property RadiusY As Single
    Get
    Set
Visual C++
public:
property float RadiusY {
    float get ();
    void set (float value);
}

See Also

Ellipse Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EllipseGeometry Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry Class
Members See Also Send Feedback
Represents an ellipse.

(Also see DirectX SDK: ID2D1EllipseGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EllipseGeometry : Geometry
Visual Basic
Public Class EllipseGeometry _
    Inherits Geometry
Visual C++
public ref class EllipseGeometry : public Geometry

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..EllipseGeometry

See Also

EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EllipseGeometry Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry Members
EllipseGeometry Class Methods Properties See Also Send Feedback

The EllipseGeometry type exposes the following members.

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

Properties

 | Name | Description
Public property | Ellipse | Gets the Ellipse structure that describes this ellipse geometry. (Also see DirectX SDK: ID2D1EllipseGeometry::GetEllipse)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

EllipseGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EllipseGeometry Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry Methods
EllipseGeometry Class See Also Send Feedback

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

EllipseGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..CombineWithGeometry Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..CompareWithGeometry Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..ComputeArea Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..ComputeLength Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..ComputePointAtLength Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..FillContainsPoint Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..GetBounds Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..GetWidenedBounds Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..Outline Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..Simplify Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..StrokeContainsPoint Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..Tessellate Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..Widen Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

EllipseGeometry Class
EllipseGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EllipseGeometry Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry Properties
EllipseGeometry Class See Also Send Feedback

The EllipseGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Ellipse | Gets the Ellipse structure that describes this ellipse geometry. (Also see DirectX SDK: ID2D1EllipseGeometry::GetEllipse)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

EllipseGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Ellipse Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EllipseGeometry..::..Ellipse Property
EllipseGeometry Class See Also Send Feedback
Gets the Ellipse structure that describes this ellipse geometry.

(Also see DirectX SDK: ID2D1EllipseGeometry::GetEllipse)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Ellipse Ellipse { get; }
Visual Basic
Public ReadOnly Property Ellipse As Ellipse
    Get
Visual C++
public:
property Ellipse Ellipse {
    Ellipse get ();
}

See Also

EllipseGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ExtendMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendMode Enumeration
See Also Send Feedback
Specifies how a brush paints areas outside of its normal content area.

(Also see DirectX SDK: D2D1_EXTEND_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ExtendMode
Visual Basic
Public Enumeration ExtendMode
Visual C++
public enum class ExtendMode

Members

Member name | Description
Mirror |
Wrap |
Clamp |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FactoryOptions Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions Structure
Members See Also Send Feedback
Allows additional parameters for factory creation.

(Also see DirectX SDK: D2D1_FACTORY_OPTIONS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct FactoryOptions
Visual Basic
Public Structure FactoryOptions
Visual C++
public value class FactoryOptions

See Also

FactoryOptions Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FactoryOptions Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions Members
FactoryOptions Structure Constructors Methods Operators Properties See Also Send Feedback

The FactoryOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FactoryOptions | Constructor for the FactoryOptions value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | DebugLevel | Requests a certain level of debugging information from the debug layer. This parameter is ignored if the debug layer DLL is not present.

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FactoryOptions Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions Constructor
FactoryOptions Structure See Also Send Feedback
Constructor for the FactoryOptions value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FactoryOptions(
    DebugLevel debugLevel
)
Visual Basic
Public Sub New ( _
    debugLevel As DebugLevel _
)
Visual C++
public:
FactoryOptions(
    DebugLevel debugLevel
)

Parameters

debugLevel
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DebugLevel
Initializes the DebugLevel property.

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FactoryOptions Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions Methods
FactoryOptions Structure See Also Send Feedback

The FactoryOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions..::..Equals Method
FactoryOptions Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions..::..GetHashCode Method
FactoryOptions Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FactoryOptions Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions Operators
FactoryOptions Structure See Also Send Feedback

The FactoryOptions type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions..::..Equality Operator
FactoryOptions Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    FactoryOptions factoryOptions1,
    FactoryOptions factoryOptions2
)
Visual Basic
Public Shared Operator = ( _
    factoryOptions1 As FactoryOptions, _
    factoryOptions2 As FactoryOptions _
) As Boolean
Visual C++
public:
static bool operator ==(
    FactoryOptions factoryOptions1,
    FactoryOptions factoryOptions2
)

Parameters

factoryOptions1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FactoryOptions
factoryOptions2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FactoryOptions

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions..::..Inequality Operator
FactoryOptions Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    FactoryOptions factoryOptions1,
    FactoryOptions factoryOptions2
)
Visual Basic
Public Shared Operator <> ( _
    factoryOptions1 As FactoryOptions, _
    factoryOptions2 As FactoryOptions _
) As Boolean
Visual C++
public:
static bool operator !=(
    FactoryOptions factoryOptions1,
    FactoryOptions factoryOptions2
)

Parameters

factoryOptions1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FactoryOptions
factoryOptions2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FactoryOptions

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FactoryOptions Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions Properties
FactoryOptions Structure See Also Send Feedback

The FactoryOptions type exposes the following members.

Properties

 | Name | Description
Public property | DebugLevel | Requests a certain level of debugging information from the debug layer. This parameter is ignored if the debug layer DLL is not present.

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DebugLevel Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FactoryOptions..::..DebugLevel Property
FactoryOptions Structure See Also Send Feedback
Requests a certain level of debugging information from the debug layer. This parameter is ignored if the debug layer DLL is not present.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DebugLevel DebugLevel { get; set; }
Visual Basic
Public Property DebugLevel As DebugLevel
    Get
    Set
Visual C++
public:
property DebugLevel DebugLevel {
    DebugLevel get ();
    void set (DebugLevel value);
}

See Also

FactoryOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FigureBegin Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FigureBegin Enumeration
See Also Send Feedback
Indicates whether the given figure is filled or hollow.

(Also see DirectX SDK: D2D1_FIGURE_BEGIN)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FigureBegin
Visual Basic
Public Enumeration FigureBegin
Visual C++
public enum class FigureBegin

Members

Member name | Description
Hollow |
Filled |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FigureEnd Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FigureEnd Enumeration
See Also Send Feedback
Indicates whether the figure is open or closed on its end point.

(Also see DirectX SDK: D2D1_FIGURE_END)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FigureEnd
Visual Basic
Public Enumeration FigureEnd
Visual C++
public enum class FigureEnd

Members

Member name | Description
Closed |
Open |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FillMode Enumeration
See Also Send Feedback
Specifies how the intersecting areas of geometries are combined to form the area of the composite geometry.

(Also see DirectX SDK: D2D1_FILL_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FillMode
Visual Basic
Public Enumeration FillMode
Visual C++
public enum class FillMode

Members

Member name | Description
Winding |
Alternate |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Gamma Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Gamma Enumeration
See Also Send Feedback
This determines what gamma is used for interpolation/blending.

(Also see DirectX SDK: D2D1_GAMMA)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Gamma
Visual Basic
Public Enumeration Gamma
Visual C++
public enum class Gamma

Members

Member name | Description
Linear |
StandardRgb |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GdiInteropRenderTarget Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GdiInteropRenderTarget Class
Members See Also Send Feedback
Provides access to an device context that can accept GDI drawing commands.

(Also see DirectX SDK: ID2D1GdiInteropRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GdiInteropRenderTarget : DirectUnknown,
    IGdiInteropRenderTarget
Visual Basic
Public Class GdiInteropRenderTarget _
    Inherits DirectUnknown _
    Implements IGdiInteropRenderTarget
Visual C++
public ref class GdiInteropRenderTarget : public DirectUnknown,
    IGdiInteropRenderTarget

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GdiInteropRenderTarget

See Also

GdiInteropRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GdiInteropRenderTarget Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GdiInteropRenderTarget Members
GdiInteropRenderTarget Class Methods Properties See Also Send Feedback

The GdiInteropRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | GetDC | Retrieves the device context associated with this render target. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::GetDC)
Public method | ReleaseDC()()()() | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)
Public method | ReleaseDC(Rect) | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GdiInteropRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GdiInteropRenderTarget Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GdiInteropRenderTarget Methods
GdiInteropRenderTarget Class See Also Send Feedback

The GdiInteropRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | GetDC | Retrieves the device context associated with this render target. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::GetDC)
Public method | ReleaseDC()()()() | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)
Public method | ReleaseDC(Rect) | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

See Also

GdiInteropRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetDC Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GdiInteropRenderTarget..::..GetDC Method
GdiInteropRenderTarget Class See Also Send Feedback
Retrieves the device context associated with this render target.

(Also see DirectX SDK: ID2D1GdiInteropRenderTarget::GetDC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual IntPtr GetDC(
    DCInitializeMode mode
)
Visual Basic
Public Overridable Function GetDC ( _
    mode As DCInitializeMode _
) As IntPtr
Visual C++
public:
virtual IntPtr GetDC(
    DCInitializeMode mode
)

Parameters

mode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DCInitializeMode
The mode parameter.

Return Value

Device context handle.

Implements

IGdiInteropRenderTarget..::..GetDC(DCInitializeMode)

See Also

GdiInteropRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ReleaseDC Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GdiInteropRenderTarget..::..ReleaseDC Method
GdiInteropRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReleaseDC()()()() | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)
Public method | ReleaseDC(Rect) | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

See Also

GdiInteropRenderTarget Class
GdiInteropRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ReleaseDC Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GdiInteropRenderTarget..::..ReleaseDC Method
GdiInteropRenderTarget Class See Also Send Feedback
Indicates that drawing with the device context retrieved using the GetDC method is finished.

(Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void ReleaseDC()
Visual Basic
Public Overridable Sub ReleaseDC
Visual C++
public:
virtual void ReleaseDC()

Implements

IGdiInteropRenderTarget..::..ReleaseDC()()()()

See Also

GdiInteropRenderTarget Class
ReleaseDC Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ReleaseDC Method (Rect)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GdiInteropRenderTarget..::..ReleaseDC Method (Rect)
GdiInteropRenderTarget Class See Also Send Feedback
Indicates that drawing with the device context retrieved using the GetDC method is finished.

(Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void ReleaseDC(
    Rect updateRectangle
)
Visual Basic
Public Overridable Sub ReleaseDC ( _
    updateRectangle As Rect _
)
Visual C++
public:
virtual void ReleaseDC(
    Rect updateRectangle
)

Parameters

updateRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Rect
The update rectangle.

Implements

IGdiInteropRenderTarget..::..ReleaseDC(Rect)

See Also

GdiInteropRenderTarget Class
ReleaseDC Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GdiInteropRenderTarget Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GdiInteropRenderTarget Properties
GdiInteropRenderTarget Class See Also Send Feedback

The GdiInteropRenderTarget type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GdiInteropRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Geometry Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry Class
Members See Also Send Feedback
Represents a geometry resource and defines a set of helper methods for manipulating and measuring geometric shapes. Classes that inherit from ID2D1Geometry define specific shapes.

(Also see DirectX SDK: ID2D1Geometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Geometry : D2DResource
Visual Basic
Public Class Geometry _
    Inherits D2DResource
Visual C++
public ref class Geometry : public D2DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..EllipseGeometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GeometryGroup
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PathGeometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectangleGeometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRectangleGeometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..TransformedGeometry

See Also

Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Geometry Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry Members
Geometry Class Methods Properties See Also Send Feedback

The Geometry type exposes the following members.

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen)

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Geometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Geometry Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry Methods
Geometry Class See Also Send Feedback

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen)

See Also

Geometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..CombineWithGeometry Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method (Geometry, CombineMode, ISimplifiedGeometrySink)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..CombineWithGeometry Method (Geometry, CombineMode, ISimplifiedGeometrySink)
Geometry Class See Also Send Feedback
Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink.

(Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CombineWithGeometry(
    Geometry inputGeometry,
    CombineMode combineMode,
    ISimplifiedGeometrySink geometrySink
)
Visual Basic
Public Sub CombineWithGeometry ( _
    inputGeometry As Geometry, _
    combineMode As CombineMode, _
    geometrySink As ISimplifiedGeometrySink _
)
Visual C++
public:
void CombineWithGeometry(
    Geometry^ inputGeometry,
    CombineMode combineMode,
    ISimplifiedGeometrySink^ geometrySink
)

Parameters

inputGeometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry to combine with this instance.
combineMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CombineMode
The type of combine operation to perform.
geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The result of the combine operation.

See Also

Geometry Class
CombineWithGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method (Geometry, CombineMode, ISimplifiedGeometrySink, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..CombineWithGeometry Method (Geometry, CombineMode, ISimplifiedGeometrySink, Single)
Geometry Class See Also Send Feedback
Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink.

(Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CombineWithGeometry(
    Geometry inputGeometry,
    CombineMode combineMode,
    ISimplifiedGeometrySink geometrySink,
    float flatteningTolerance
)
Visual Basic
Public Sub CombineWithGeometry ( _
    inputGeometry As Geometry, _
    combineMode As CombineMode, _
    geometrySink As ISimplifiedGeometrySink, _
    flatteningTolerance As Single _
)
Visual C++
public:
void CombineWithGeometry(
    Geometry^ inputGeometry,
    CombineMode combineMode,
    ISimplifiedGeometrySink^ geometrySink,
    float flatteningTolerance
)

Parameters

inputGeometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry to combine with this instance.
combineMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CombineMode
The type of combine operation to perform.
geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The result of the combine operation.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometries. Smaller values produce more accurate results but cause slower execution.

See Also

Geometry Class
CombineWithGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method (Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..CombineWithGeometry Method (Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink.

(Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CombineWithGeometry(
    Geometry inputGeometry,
    CombineMode combineMode,
    ISimplifiedGeometrySink geometrySink,
    float flatteningTolerance,
    Matrix3x2F inputGeometryTransform
)
Visual Basic
Public Sub CombineWithGeometry ( _
    inputGeometry As Geometry, _
    combineMode As CombineMode, _
    geometrySink As ISimplifiedGeometrySink, _
    flatteningTolerance As Single, _
    inputGeometryTransform As Matrix3x2F _
)
Visual C++
public:
void CombineWithGeometry(
    Geometry^ inputGeometry,
    CombineMode combineMode,
    ISimplifiedGeometrySink^ geometrySink,
    float flatteningTolerance,
    Matrix3x2F inputGeometryTransform
)

Parameters

inputGeometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry to combine with this instance.
combineMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CombineMode
The type of combine operation to perform.
geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The result of the combine operation.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometries. Smaller values produce more accurate results but cause slower execution.
inputGeometryTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to inputGeometry before combining.

See Also

Geometry Class
CombineWithGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..CompareWithGeometry Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method (Geometry)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..CompareWithGeometry Method (Geometry)
Geometry Class See Also Send Feedback
Compare how one geometry intersects or contains another geometry.

(Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryRelation CompareWithGeometry(
    Geometry inputGeometry
)
Visual Basic
Public Function CompareWithGeometry ( _
    inputGeometry As Geometry _
) As GeometryRelation
Visual C++
public:
GeometryRelation CompareWithGeometry(
    Geometry^ inputGeometry
)

Parameters

inputGeometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry to test.

Return Value

GeometryRelation enumeration that that describes how this geometry is related to inputGeometry.

See Also

Geometry Class
CompareWithGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method (Geometry, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..CompareWithGeometry Method (Geometry, Single)
Geometry Class See Also Send Feedback
Compare how one geometry intersects or contains another geometry.

(Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryRelation CompareWithGeometry(
    Geometry inputGeometry,
    float flatteningTolerance
)
Visual Basic
Public Function CompareWithGeometry ( _
    inputGeometry As Geometry, _
    flatteningTolerance As Single _
) As GeometryRelation
Visual C++
public:
GeometryRelation CompareWithGeometry(
    Geometry^ inputGeometry,
    float flatteningTolerance
)

Parameters

inputGeometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry to test.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometries. Smaller values produce more accurate results but cause slower execution.

Return Value

GeometryRelation enumeration that that describes how this geometry is related to inputGeometry.

See Also

Geometry Class
CompareWithGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method (Geometry, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..CompareWithGeometry Method (Geometry, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Compare how one geometry intersects or contains another geometry.

(Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryRelation CompareWithGeometry(
    Geometry inputGeometry,
    float flatteningTolerance,
    Matrix3x2F inputGeometryTransform
)
Visual Basic
Public Function CompareWithGeometry ( _
    inputGeometry As Geometry, _
    flatteningTolerance As Single, _
    inputGeometryTransform As Matrix3x2F _
) As GeometryRelation
Visual C++
public:
GeometryRelation CompareWithGeometry(
    Geometry^ inputGeometry,
    float flatteningTolerance,
    Matrix3x2F inputGeometryTransform
)

Parameters

inputGeometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry to test.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometries. Smaller values produce more accurate results but cause slower execution.
inputGeometryTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to inputGeometry.

Return Value

GeometryRelation enumeration that that describes how this geometry is related to inputGeometry.

See Also

Geometry Class
CompareWithGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputeArea Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputeArea Method
Geometry Class See Also Send Feedback
Computes the area of the geometry.

(Also see DirectX SDK: ID2D1Geometry::ComputeArea)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float ComputeArea()
Visual Basic
Public Function ComputeArea As Single
Visual C++
public:
float ComputeArea()

Return Value

The area of the transformed, flattened version of this geometry.

See Also

Geometry Class
ComputeArea Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method (Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputeArea Method (Single)
Geometry Class See Also Send Feedback
Computes the area of the geometry.

(Also see DirectX SDK: ID2D1Geometry::ComputeArea)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float ComputeArea(
    float flatteningTolerance
)
Visual Basic
Public Function ComputeArea ( _
    flatteningTolerance As Single _
) As Single
Visual C++
public:
float ComputeArea(
    float flatteningTolerance
)

Parameters

flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.

Return Value

The area of the transformed, flattened version of this geometry.

See Also

Geometry Class
ComputeArea Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method (Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputeArea Method (Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance.

(Also see DirectX SDK: ID2D1Geometry::ComputeArea)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float ComputeArea(
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Function ComputeArea ( _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
) As Single
Visual C++
public:
float ComputeArea(
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to this geometry before computing its area.

Return Value

The area of the transformed, flattened version of this geometry.

See Also

Geometry Class
ComputeArea Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputeLength Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputeLength Method
Geometry Class See Also Send Feedback
Calculates the length of the geometry as though each segment were unrolled into a line.

(Also see DirectX SDK: ID2D1Geometry::ComputeLength)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float ComputeLength()
Visual Basic
Public Function ComputeLength As Single
Visual C++
public:
float ComputeLength()

Return Value

The length of the geometry. For closed geometries, the length includes an implicit closing segment.

See Also

Geometry Class
ComputeLength Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method (Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputeLength Method (Single)
Geometry Class See Also Send Feedback
Calculates the length of the geometry as though each segment were unrolled into a line.

(Also see DirectX SDK: ID2D1Geometry::ComputeLength)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float ComputeLength(
    float flatteningTolerance
)
Visual Basic
Public Function ComputeLength ( _
    flatteningTolerance As Single _
) As Single
Visual C++
public:
float ComputeLength(
    float flatteningTolerance
)

Parameters

flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.

Return Value

The length of the geometry. For closed geometries, the length includes an implicit closing segment.

See Also

Geometry Class
ComputeLength Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method (Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputeLength Method (Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Calculates the length of the geometry as though each segment were unrolled into a line.

(Also see DirectX SDK: ID2D1Geometry::ComputeLength)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float ComputeLength(
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Function ComputeLength ( _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
) As Single
Visual C++
public:
float ComputeLength(
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to the geometry before calculating its length.

Return Value

The length of the geometry. For closed geometries, the length includes an implicit closing segment.

See Also

Geometry Class
ComputeLength Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputePointAtLength Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method (Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputePointAtLength Method (Single)
Geometry Class See Also Send Feedback
Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance.

(Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PointAndTangent ComputePointAtLength(
    float length
)
Visual Basic
Public Function ComputePointAtLength ( _
    length As Single _
) As PointAndTangent
Visual C++
public:
PointAndTangent ComputePointAtLength(
    float length
)

Parameters

length
Type: System..::..Single
The distance along the geometry of the point and tangent to find. If this distance is less then 0, this method calculates the first point in the geometry. If this distance is greater than the length of the geometry, this method calculates the last point in the geometry.

Return Value

The location and tangent at the specified distance along the geometry. If the geometry is empty, these contain NaN as their x and y values.

See Also

Geometry Class
ComputePointAtLength Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method (Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputePointAtLength Method (Single, Single)
Geometry Class See Also Send Feedback
Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance.

(Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PointAndTangent ComputePointAtLength(
    float length,
    float flatteningTolerance
)
Visual Basic
Public Function ComputePointAtLength ( _
    length As Single, _
    flatteningTolerance As Single _
) As PointAndTangent
Visual C++
public:
PointAndTangent ComputePointAtLength(
    float length,
    float flatteningTolerance
)

Parameters

length
Type: System..::..Single
The distance along the geometry of the point and tangent to find. If this distance is less then 0, this method calculates the first point in the geometry. If this distance is greater than the length of the geometry, this method calculates the last point in the geometry.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.

Return Value

The location and tangent at the specified distance along the geometry. If the geometry is empty, these contain NaN as their x and y values.

See Also

Geometry Class
ComputePointAtLength Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method (Single, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..ComputePointAtLength Method (Single, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance.

(Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PointAndTangent ComputePointAtLength(
    float length,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Function ComputePointAtLength ( _
    length As Single, _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
) As PointAndTangent
Visual C++
public:
PointAndTangent ComputePointAtLength(
    float length,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

length
Type: System..::..Single
The distance along the geometry of the point and tangent to find. If this distance is less then 0, this method calculates the first point in the geometry. If this distance is greater than the length of the geometry, this method calculates the last point in the geometry.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to the geometry before calculating the specified point and tangent.

Return Value

The location and tangent at the specified distance along the geometry. If the geometry is empty, these contain NaN as their x and y values.

See Also

Geometry Class
ComputePointAtLength Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..FillContainsPoint Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method (Point2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..FillContainsPoint Method (Point2F)
Geometry Class See Also Send Feedback
Indicates whether the area filled by the geometry would contain the specified point.

(Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool FillContainsPoint(
    Point2F point
)
Visual Basic
Public Function FillContainsPoint ( _
    point As Point2F _
) As Boolean
Visual C++
public:
bool FillContainsPoint(
    Point2F point
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point to test.

Return Value

True if the area filled by the geometry contains point; otherwise, false.

See Also

Geometry Class
FillContainsPoint Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method (Point2F, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..FillContainsPoint Method (Point2F, Single)
Geometry Class See Also Send Feedback
Indicates whether the area filled by the geometry would contain the specified point.

(Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool FillContainsPoint(
    Point2F point,
    float flatteningTolerance
)
Visual Basic
Public Function FillContainsPoint ( _
    point As Point2F, _
    flatteningTolerance As Single _
) As Boolean
Visual C++
public:
bool FillContainsPoint(
    Point2F point,
    float flatteningTolerance
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point to test.
flatteningTolerance
Type: System..::..Single
The flatteningTolerance parameter.

Return Value

True if the area filled by the geometry contains point; otherwise, false.

See Also

Geometry Class
FillContainsPoint Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method (Point2F, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..FillContainsPoint Method (Point2F, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Indicates whether the area filled by the geometry would contain the specified point.

(Also see DirectX SDK: ID2D1Geometry::FillContainsPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool FillContainsPoint(
    Point2F point,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Function FillContainsPoint ( _
    point As Point2F, _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
) As Boolean
Visual C++
public:
bool FillContainsPoint(
    Point2F point,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point to test.
flatteningTolerance
Type: System..::..Single
The flatteningTolerance parameter.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The numeric accuracy with which the precise geometric path and path intersection is calculated. Points missing the fill by less than the tolerance are still considered inside. Smaller values produce more accurate results but cause slower execution.

Return Value

True if the area filled by the geometry contains point; otherwise, false.

See Also

Geometry Class
FillContainsPoint Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..GetBounds Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetBounds Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..GetBounds Method
Geometry Class See Also Send Feedback
Retrieve the bounds of this geometry.

(Also see DirectX SDK: ID2D1Geometry::GetBounds)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectF GetBounds()
Visual Basic
Public Function GetBounds As RectF
Visual C++
public:
RectF GetBounds()

Return Value

The bounds of this geometry. If the bounds are empty, the first value of the bounding box will be NaN.

See Also

Geometry Class
GetBounds Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetBounds Method (Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..GetBounds Method (Matrix3x2F)
Geometry Class See Also Send Feedback
Retrieve the bounds of this geometry, with an applied transform.

(Also see DirectX SDK: ID2D1Geometry::GetBounds)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectF GetBounds(
    Matrix3x2F worldTransform
)
Visual Basic
Public Function GetBounds ( _
    worldTransform As Matrix3x2F _
) As RectF
Visual C++
public:
RectF GetBounds(
    Matrix3x2F worldTransform
)

Parameters

worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to this geometry before calculating its bounds.

Return Value

The bounds of this geometry. If the bounds are empty, the first value of the bounding box will be NaN.

See Also

Geometry Class
GetBounds Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..GetWidenedBounds Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method (Single, StrokeStyle)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..GetWidenedBounds Method (Single, StrokeStyle)
Geometry Class See Also Send Feedback
Get the bounds of the corresponding geometry after it has been widened or have an optional style applied.

(Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectF GetWidenedBounds(
    float strokeWidth,
    StrokeStyle strokeStyle
)
Visual Basic
Public Function GetWidenedBounds ( _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle _
) As RectF
Visual C++
public:
RectF GetWidenedBounds(
    float strokeWidth,
    StrokeStyle^ strokeStyle
)

Parameters

strokeWidth
Type: System..::..Single
The amount by which to widen the geometry by stroking its outline.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The style of the stroke that widens the geometry.

Return Value

The bounds of the widened geometry.

See Also

Geometry Class
GetWidenedBounds Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method (Single, StrokeStyle, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..GetWidenedBounds Method (Single, StrokeStyle, Single)
Geometry Class See Also Send Feedback
Get the bounds of the corresponding geometry after it has been widened or have an optional style applied.

(Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectF GetWidenedBounds(
    float strokeWidth,
    StrokeStyle strokeStyle,
    float flatteningTolerance
)
Visual Basic
Public Function GetWidenedBounds ( _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle, _
    flatteningTolerance As Single _
) As RectF
Visual C++
public:
RectF GetWidenedBounds(
    float strokeWidth,
    StrokeStyle^ strokeStyle,
    float flatteningTolerance
)

Parameters

strokeWidth
Type: System..::..Single
The amount by which to widen the geometry by stroking its outline.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The style of the stroke that widens the geometry.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.

Return Value

The bounds of the widened geometry.

See Also

Geometry Class
GetWidenedBounds Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method (Single, StrokeStyle, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..GetWidenedBounds Method (Single, StrokeStyle, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Get the bounds of the corresponding geometry after it has been widened or have an optional style applied.

(Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectF GetWidenedBounds(
    float strokeWidth,
    StrokeStyle strokeStyle,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Function GetWidenedBounds ( _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle, _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
) As RectF
Visual C++
public:
RectF GetWidenedBounds(
    float strokeWidth,
    StrokeStyle^ strokeStyle,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

strokeWidth
Type: System..::..Single
The amount by which to widen the geometry by stroking its outline.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The style of the stroke that widens the geometry.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
A transform to apply to the geometry after the geometry is transformed and after the geometry has been stroked.

Return Value

The bounds of the widened geometry.

See Also

Geometry Class
GetWidenedBounds Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Outline Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method (ISimplifiedGeometrySink)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Outline Method (ISimplifiedGeometrySink)
Geometry Class See Also Send Feedback
Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink.

(Also see DirectX SDK: ID2D1Geometry::Outline)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Outline(
    ISimplifiedGeometrySink geometrySink
)
Visual Basic
Public Sub Outline ( _
    geometrySink As ISimplifiedGeometrySink _
)
Visual C++
public:
void Outline(
    ISimplifiedGeometrySink^ geometrySink
)

Parameters

geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The ISimplifiedGeometrySink to which the geometry's transformed outline is appended.

See Also

Geometry Class
Outline Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method (ISimplifiedGeometrySink, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Outline Method (ISimplifiedGeometrySink, Single)
Geometry Class See Also Send Feedback
Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink.

(Also see DirectX SDK: ID2D1Geometry::Outline)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Outline(
    ISimplifiedGeometrySink geometrySink,
    float flatteningTolerance
)
Visual Basic
Public Sub Outline ( _
    geometrySink As ISimplifiedGeometrySink, _
    flatteningTolerance As Single _
)
Visual C++
public:
void Outline(
    ISimplifiedGeometrySink^ geometrySink,
    float flatteningTolerance
)

Parameters

geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The ISimplifiedGeometrySink to which the geometry's transformed outline is appended.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.

See Also

Geometry Class
Outline Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method (ISimplifiedGeometrySink, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Outline Method (ISimplifiedGeometrySink, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink.

(Also see DirectX SDK: ID2D1Geometry::Outline)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Outline(
    ISimplifiedGeometrySink geometrySink,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Sub Outline ( _
    geometrySink As ISimplifiedGeometrySink, _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
)
Visual C++
public:
void Outline(
    ISimplifiedGeometrySink^ geometrySink,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The ISimplifiedGeometrySink to which the geometry's transformed outline is appended.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to the geometry outline.

See Also

Geometry Class
Outline Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Simplify Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method (GeometrySimplificationOption, ISimplifiedGeometrySink)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Simplify Method (GeometrySimplificationOption, ISimplifiedGeometrySink)
Geometry Class See Also Send Feedback
Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object.

(Also see DirectX SDK: ID2D1Geometry::Simplify)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Simplify(
    GeometrySimplificationOption simplificationOption,
    ISimplifiedGeometrySink geometrySink
)
Visual Basic
Public Sub Simplify ( _
    simplificationOption As GeometrySimplificationOption, _
    geometrySink As ISimplifiedGeometrySink _
)
Visual C++
public:
void Simplify(
    GeometrySimplificationOption simplificationOption,
    ISimplifiedGeometrySink^ geometrySink
)

Parameters

simplificationOption
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GeometrySimplificationOption
A value that specifies whether the simplified geometry should contain curves.
geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The geometry sink to which the simplified geometry is appended.

See Also

Geometry Class
Simplify Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method (GeometrySimplificationOption, ISimplifiedGeometrySink, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Simplify Method (GeometrySimplificationOption, ISimplifiedGeometrySink, Single)
Geometry Class See Also Send Feedback
Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object.

(Also see DirectX SDK: ID2D1Geometry::Simplify)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Simplify(
    GeometrySimplificationOption simplificationOption,
    ISimplifiedGeometrySink geometrySink,
    float flatteningTolerance
)
Visual Basic
Public Sub Simplify ( _
    simplificationOption As GeometrySimplificationOption, _
    geometrySink As ISimplifiedGeometrySink, _
    flatteningTolerance As Single _
)
Visual C++
public:
void Simplify(
    GeometrySimplificationOption simplificationOption,
    ISimplifiedGeometrySink^ geometrySink,
    float flatteningTolerance
)

Parameters

simplificationOption
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GeometrySimplificationOption
A value that specifies whether the simplified geometry should contain curves.
geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The geometry sink to which the simplified geometry is appended.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.

See Also

Geometry Class
Simplify Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method (GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Simplify Method (GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object.

(Also see DirectX SDK: ID2D1Geometry::Simplify)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Simplify(
    GeometrySimplificationOption simplificationOption,
    ISimplifiedGeometrySink geometrySink,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Sub Simplify ( _
    simplificationOption As GeometrySimplificationOption, _
    geometrySink As ISimplifiedGeometrySink, _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
)
Visual C++
public:
void Simplify(
    GeometrySimplificationOption simplificationOption,
    ISimplifiedGeometrySink^ geometrySink,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

simplificationOption
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GeometrySimplificationOption
A value that specifies whether the simplified geometry should contain curves.
geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The geometry sink to which the simplified geometry is appended.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to the simplified geometry.

See Also

Geometry Class
Simplify Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..StrokeContainsPoint Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method (Point2F, Single, StrokeStyle)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..StrokeContainsPoint Method (Point2F, Single, StrokeStyle)
Geometry Class See Also Send Feedback
Determines whether the geometry's stroke contains the specified point.

(Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool StrokeContainsPoint(
    Point2F point,
    float strokeWidth,
    StrokeStyle strokeStyle
)
Visual Basic
Public Function StrokeContainsPoint ( _
    point As Point2F, _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle _
) As Boolean
Visual C++
public:
bool StrokeContainsPoint(
    Point2F point,
    float strokeWidth,
    StrokeStyle^ strokeStyle
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point to test for containment.
strokeWidth
Type: System..::..Single
The thickness of the stroke to apply.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The style of stroke to apply.

Return Value

True if the geometry's stroke contains the specified point; otherwise, false.

See Also

Geometry Class
StrokeContainsPoint Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method (Point2F, Single, StrokeStyle, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..StrokeContainsPoint Method (Point2F, Single, StrokeStyle, Single)
Geometry Class See Also Send Feedback
Determines whether the geometry's stroke contains the specified point.

(Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool StrokeContainsPoint(
    Point2F point,
    float strokeWidth,
    StrokeStyle strokeStyle,
    float flatteningTolerance
)
Visual Basic
Public Function StrokeContainsPoint ( _
    point As Point2F, _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle, _
    flatteningTolerance As Single _
) As Boolean
Visual C++
public:
bool StrokeContainsPoint(
    Point2F point,
    float strokeWidth,
    StrokeStyle^ strokeStyle,
    float flatteningTolerance
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point to test for containment.
strokeWidth
Type: System..::..Single
The thickness of the stroke to apply.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The style of stroke to apply.
flatteningTolerance
Type: System..::..Single
The numeric accuracy with which the precise geometric path and path intersection is calculated. Points missing the stroke by less than the tolerance are still considered inside. Smaller values produce more accurate results but cause slower execution.

Return Value

True if the geometry's stroke contains the specified point; otherwise, false.

See Also

Geometry Class
StrokeContainsPoint Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method (Point2F, Single, StrokeStyle, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..StrokeContainsPoint Method (Point2F, Single, StrokeStyle, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Determines whether the geometry's stroke contains the specified point.

(Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool StrokeContainsPoint(
    Point2F point,
    float strokeWidth,
    StrokeStyle strokeStyle,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Function StrokeContainsPoint ( _
    point As Point2F, _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle, _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
) As Boolean
Visual C++
public:
bool StrokeContainsPoint(
    Point2F point,
    float strokeWidth,
    StrokeStyle^ strokeStyle,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point to test for containment.
strokeWidth
Type: System..::..Single
The thickness of the stroke to apply.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The style of stroke to apply.
flatteningTolerance
Type: System..::..Single
The numeric accuracy with which the precise geometric path and path intersection is calculated. Points missing the stroke by less than the tolerance are still considered inside. Smaller values produce more accurate results but cause slower execution.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to the stroked geometry.

Return Value

True if the geometry's stroke contains the specified point; otherwise, false.

See Also

Geometry Class
StrokeContainsPoint Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Tessellate Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method (ITessellationSink)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Tessellate Method (ITessellationSink)
Geometry Class See Also Send Feedback
Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance.

(Also see DirectX SDK: ID2D1Geometry::Tessellate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Tessellate(
    ITessellationSink tessellationSink
)
Visual Basic
Public Sub Tessellate ( _
    tessellationSink As ITessellationSink _
)
Visual C++
public:
void Tessellate(
    ITessellationSink^ tessellationSink
)

Parameters

tessellationSink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ITessellationSink
The ITessellationSink to which the tessellated is appended.

See Also

Geometry Class
Tessellate Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method (ITessellationSink, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Tessellate Method (ITessellationSink, Single)
Geometry Class See Also Send Feedback
Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance.

(Also see DirectX SDK: ID2D1Geometry::Tessellate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Tessellate(
    ITessellationSink tessellationSink,
    float flatteningTolerance
)
Visual Basic
Public Sub Tessellate ( _
    tessellationSink As ITessellationSink, _
    flatteningTolerance As Single _
)
Visual C++
public:
void Tessellate(
    ITessellationSink^ tessellationSink,
    float flatteningTolerance
)

Parameters

tessellationSink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ITessellationSink
The ITessellationSink to which the tessellated is appended.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.

See Also

Geometry Class
Tessellate Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method (ITessellationSink, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Tessellate Method (ITessellationSink, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance.

(Also see DirectX SDK: ID2D1Geometry::Tessellate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Tessellate(
    ITessellationSink tessellationSink,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Sub Tessellate ( _
    tessellationSink As ITessellationSink, _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
)
Visual C++
public:
void Tessellate(
    ITessellationSink^ tessellationSink,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

tessellationSink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ITessellationSink
The ITessellationSink to which the tessellated is appended.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to this geometry.

See Also

Geometry Class
Tessellate Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Widen Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen)

See Also

Geometry Class
Geometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method (Single, StrokeStyle, ISimplifiedGeometrySink)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Widen Method (Single, StrokeStyle, ISimplifiedGeometrySink)
Geometry Class See Also Send Feedback
Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink.

(Also see DirectX SDK: ID2D1Geometry::Widen)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Widen(
    float strokeWidth,
    StrokeStyle strokeStyle,
    ISimplifiedGeometrySink geometrySink
)
Visual Basic
Public Sub Widen ( _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle, _
    geometrySink As ISimplifiedGeometrySink _
)
Visual C++
public:
void Widen(
    float strokeWidth,
    StrokeStyle^ strokeStyle,
    ISimplifiedGeometrySink^ geometrySink
)

Parameters

strokeWidth
Type: System..::..Single
The amount by which to widen the geometry.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The style of stroke to apply to the geometry. Leave null for default stroke style.
geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The ISimplifiedGeometrySink to which the widened geometry is appended.

See Also

Geometry Class
Widen Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method (Single, StrokeStyle, ISimplifiedGeometrySink, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Widen Method (Single, StrokeStyle, ISimplifiedGeometrySink, Single)
Geometry Class See Also Send Feedback
Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink.

(Also see DirectX SDK: ID2D1Geometry::Widen)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Widen(
    float strokeWidth,
    StrokeStyle strokeStyle,
    ISimplifiedGeometrySink geometrySink,
    float flatteningTolerance
)
Visual Basic
Public Sub Widen ( _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle, _
    geometrySink As ISimplifiedGeometrySink, _
    flatteningTolerance As Single _
)
Visual C++
public:
void Widen(
    float strokeWidth,
    StrokeStyle^ strokeStyle,
    ISimplifiedGeometrySink^ geometrySink,
    float flatteningTolerance
)

Parameters

strokeWidth
Type: System..::..Single
The amount by which to widen the geometry.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The style of stroke to apply to the geometry. Leave null for default stroke style.
geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The ISimplifiedGeometrySink to which the widened geometry is appended.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.

See Also

Geometry Class
Widen Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method (Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry..::..Widen Method (Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F)
Geometry Class See Also Send Feedback
Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink.

(Also see DirectX SDK: ID2D1Geometry::Widen)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Widen(
    float strokeWidth,
    StrokeStyle strokeStyle,
    ISimplifiedGeometrySink geometrySink,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)
Visual Basic
Public Sub Widen ( _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle, _
    geometrySink As ISimplifiedGeometrySink, _
    flatteningTolerance As Single, _
    worldTransform As Matrix3x2F _
)
Visual C++
public:
void Widen(
    float strokeWidth,
    StrokeStyle^ strokeStyle,
    ISimplifiedGeometrySink^ geometrySink,
    float flatteningTolerance,
    Matrix3x2F worldTransform
)

Parameters

strokeWidth
Type: System..::..Single
The amount by which to widen the geometry.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The style of stroke to apply to the geometry. Leave null for default stroke style.
geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ISimplifiedGeometrySink
The ISimplifiedGeometrySink to which the widened geometry is appended.
flatteningTolerance
Type: System..::..Single
The maximum bounds on the distance between points in the polygonal approximation of the geometry. Smaller values produce more accurate results but cause slower execution.
worldTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
The transform to apply to the geometry after widening it.

See Also

Geometry Class
Widen Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Geometry Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Geometry Properties
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Geometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometryGroup Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup Class
Members See Also Send Feedback
Represents a composite geometry, composed of other Geometry objects.

(Also see DirectX SDK: ID2D1GeometryGroup)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GeometryGroup : Geometry
Visual Basic
Public Class GeometryGroup _
    Inherits Geometry
Visual C++
public ref class GeometryGroup : public Geometry

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GeometryGroup

See Also

GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometryGroup Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup Members
GeometryGroup Class Methods Properties See Also Send Feedback

The GeometryGroup type exposes the following members.

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | FillMode | Indicates how the intersecting areas of the geometries contained in this geometry group are combined. (Also see DirectX SDK: ID2D1GeometryGroup::GetFillMode)
Public property | Geometries | Retrieves the geometries in the geometry group. (Also see DirectX SDK: ID2D1GeometryGroup::GetSourceGeometries)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SourceGeometryCount | Indicates the number of geometry objects in the geometry group. (Also see DirectX SDK: ID2D1GeometryGroup::GetSourceGeometryCount)

See Also

GeometryGroup Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometryGroup Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup Methods
GeometryGroup Class See Also Send Feedback

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

GeometryGroup Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..CombineWithGeometry Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..CompareWithGeometry Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..ComputeArea Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..ComputeLength Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..ComputePointAtLength Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..FillContainsPoint Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..GetBounds Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..GetWidenedBounds Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..Outline Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..Simplify Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..StrokeContainsPoint Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..Tessellate Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..Widen Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

GeometryGroup Class
GeometryGroup Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometryGroup Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup Properties
GeometryGroup Class See Also Send Feedback

The GeometryGroup type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | FillMode | Indicates how the intersecting areas of the geometries contained in this geometry group are combined. (Also see DirectX SDK: ID2D1GeometryGroup::GetFillMode)
Public property | Geometries | Retrieves the geometries in the geometry group. (Also see DirectX SDK: ID2D1GeometryGroup::GetSourceGeometries)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SourceGeometryCount | Indicates the number of geometry objects in the geometry group. (Also see DirectX SDK: ID2D1GeometryGroup::GetSourceGeometryCount)

See Also

GeometryGroup Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..FillMode Property
GeometryGroup Class See Also Send Feedback
Indicates how the intersecting areas of the geometries contained in this geometry group are combined.

(Also see DirectX SDK: ID2D1GeometryGroup::GetFillMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FillMode FillMode { get; }
Visual Basic
Public ReadOnly Property FillMode As FillMode
    Get
Visual C++
public:
property FillMode FillMode {
    FillMode get ();
}

See Also

GeometryGroup Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Geometries Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..Geometries Property
GeometryGroup Class See Also Send Feedback
Retrieves the geometries in the geometry group.

(Also see DirectX SDK: ID2D1GeometryGroup::GetSourceGeometries)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<Geometry> Geometries { get; }
Visual Basic
Public ReadOnly Property Geometries As ReadOnlyCollection(Of Geometry)
    Get
Visual C++
public:
property ReadOnlyCollection<Geometry^>^ Geometries {
    ReadOnlyCollection<Geometry^>^ get ();
}

Return Value

A ReadOnlyCollection of Geometry objects.

See Also

GeometryGroup Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SourceGeometryCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryGroup..::..SourceGeometryCount Property
GeometryGroup Class See Also Send Feedback
Indicates the number of geometry objects in the geometry group.

(Also see DirectX SDK: ID2D1GeometryGroup::GetSourceGeometryCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SourceGeometryCount { get; }
Visual Basic
Public ReadOnly Property SourceGeometryCount As UInteger
    Get
Visual C++
public:
property unsigned int SourceGeometryCount {
    unsigned int get ();
}

See Also

GeometryGroup Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometryRelation Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryRelation Enumeration
See Also Send Feedback

(Also see DirectX SDK: D2D1_GEOMETRY_RELATION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum GeometryRelation
Visual Basic
Public Enumeration GeometryRelation
Visual C++
public enum class GeometryRelation

Members

Member name | Description
Overlap |
IsContained |
Contains |
Disjoint |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometrySimplificationOption Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySimplificationOption Enumeration
See Also Send Feedback
Specifies how a geometry is simplified to a SimplifiedGeometrySink.

(Also see DirectX SDK: D2D1_GEOMETRY_SIMPLIFICATION_OPTION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum GeometrySimplificationOption
Visual Basic
Public Enumeration GeometrySimplificationOption
Visual C++
public enum class GeometrySimplificationOption

Members

Member name | Description
Lines |
CubicsAndLines |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometrySink Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySink Class
Members See Also Send Feedback
Describes a geometric path that can contain lines, arcs, cubic Bezier curves, and quadratic Bezier curves.

(Also see DirectX SDK: ID2D1GeometrySink)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GeometrySink : SimplifiedGeometrySink,
    IGeometrySink
Visual Basic
Public Class GeometrySink _
    Inherits SimplifiedGeometrySink _
    Implements IGeometrySink
Visual C++
public ref class GeometrySink : public SimplifiedGeometrySink,
    IGeometrySink

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SimplifiedGeometrySink
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GeometrySink

See Also

GeometrySink Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometrySink Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySink Members
GeometrySink Class Methods Properties See Also Send Feedback

The GeometrySink type exposes the following members.

Methods

 | Name | Description
Public method | AddArc | Creates a single arc and adds it to the path geometry. (Also see DirectX SDK: ID2D1GeometrySink::AddArc)
Public method | AddBezier | Creates a cubic Bezier curve between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddBezier)
Public method | AddBeziers | (Inherited from SimplifiedGeometrySink.)
Public method | AddLine | Creates a line segment between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddLine)
Public method | AddLines | (Inherited from SimplifiedGeometrySink.)
Public method | AddQuadraticBezier | Creates a quadratic Bezier curve between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddQuadraticBezier)
Public method | AddQuadraticBeziers |
Public method | BeginFigure | Starts a new figure at the specified point. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure) (Inherited from SimplifiedGeometrySink.)
Public method | Close | Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close) (Inherited from SimplifiedGeometrySink.)
Public method | EndFigure | Ends the current figure; optionally, closes it. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure) (Inherited from SimplifiedGeometrySink.)
Public method | SetFillMode | Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode) (Inherited from SimplifiedGeometrySink.)
Public method | SetSegmentFlags | Specifies stroke and join options to be applied to new segments added to the geometry sink. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags) (Inherited from SimplifiedGeometrySink.)

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometrySink Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySink Methods
GeometrySink Class See Also Send Feedback

The GeometrySink type exposes the following members.

Methods

 | Name | Description
Public method | AddArc | Creates a single arc and adds it to the path geometry. (Also see DirectX SDK: ID2D1GeometrySink::AddArc)
Public method | AddBezier | Creates a cubic Bezier curve between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddBezier)
Public method | AddBeziers | (Inherited from SimplifiedGeometrySink.)
Public method | AddLine | Creates a line segment between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddLine)
Public method | AddLines | (Inherited from SimplifiedGeometrySink.)
Public method | AddQuadraticBezier | Creates a quadratic Bezier curve between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddQuadraticBezier)
Public method | AddQuadraticBeziers |
Public method | BeginFigure | Starts a new figure at the specified point. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure) (Inherited from SimplifiedGeometrySink.)
Public method | Close | Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close) (Inherited from SimplifiedGeometrySink.)
Public method | EndFigure | Ends the current figure; optionally, closes it. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure) (Inherited from SimplifiedGeometrySink.)
Public method | SetFillMode | Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode) (Inherited from SimplifiedGeometrySink.)
Public method | SetSegmentFlags | Specifies stroke and join options to be applied to new segments added to the geometry sink. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags) (Inherited from SimplifiedGeometrySink.)

See Also

GeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddArc Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySink..::..AddArc Method
GeometrySink Class See Also Send Feedback
Creates a single arc and adds it to the path geometry.

(Also see DirectX SDK: ID2D1GeometrySink::AddArc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void AddArc(
    ArcSegment arc
)
Visual Basic
Public Overridable Sub AddArc ( _
    arc As ArcSegment _
)
Visual C++
public:
virtual void AddArc(
    ArcSegment arc
)

Parameters

arc
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ArcSegment
The arc to add.

Implements

IGeometrySink..::..AddArc(ArcSegment)

See Also

GeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddBezier Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySink..::..AddBezier Method
GeometrySink Class See Also Send Feedback
Creates a cubic Bezier curve between the current point and the specified end point and adds it to the geometry sink.

(Also see DirectX SDK: ID2D1GeometrySink::AddBezier)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void AddBezier(
    BezierSegment bezier
)
Visual Basic
Public Overridable Sub AddBezier ( _
    bezier As BezierSegment _
)
Visual C++
public:
virtual void AddBezier(
    BezierSegment bezier
)

Parameters

bezier
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BezierSegment
The Bezier curve to add.

Implements

IGeometrySink..::..AddBezier(BezierSegment)

See Also

GeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddLine Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySink..::..AddLine Method
GeometrySink Class See Also Send Feedback
Creates a line segment between the current point and the specified end point and adds it to the geometry sink.

(Also see DirectX SDK: ID2D1GeometrySink::AddLine)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void AddLine(
    Point2F point
)
Visual Basic
Public Overridable Sub AddLine ( _
    point As Point2F _
)
Visual C++
public:
virtual void AddLine(
    Point2F point
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The end point of the line to draw.

Implements

IGeometrySink..::..AddLine(Point2F)

See Also

GeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddQuadraticBezier Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySink..::..AddQuadraticBezier Method
GeometrySink Class See Also Send Feedback
Creates a quadratic Bezier curve between the current point and the specified end point and adds it to the geometry sink.

(Also see DirectX SDK: ID2D1GeometrySink::AddQuadraticBezier)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void AddQuadraticBezier(
    QuadraticBezierSegment bezier
)
Visual Basic
Public Overridable Sub AddQuadraticBezier ( _
    bezier As QuadraticBezierSegment _
)
Visual C++
public:
virtual void AddQuadraticBezier(
    QuadraticBezierSegment bezier
)

Parameters

bezier
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..QuadraticBezierSegment
The quadratic Bezier curve to add.

Implements

IGeometrySink..::..AddQuadraticBezier(QuadraticBezierSegment)

See Also

GeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddQuadraticBeziers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySink..::..AddQuadraticBeziers Method
GeometrySink Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void AddQuadraticBeziers(
    IEnumerable<QuadraticBezierSegment> beziers
)
Visual Basic
Public Overridable Sub AddQuadraticBeziers ( _
    beziers As IEnumerable(Of QuadraticBezierSegment) _
)
Visual C++
public:
virtual void AddQuadraticBeziers(
    IEnumerable<QuadraticBezierSegment>^ beziers
)

Parameters

beziers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' QuadraticBezierSegment >)>)>

Implements

IGeometrySink..::..AddQuadraticBeziers(IEnumerable<(Of <<'(QuadraticBezierSegment>)>>))

See Also

GeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometrySink Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometrySink Properties
GeometrySink Class See Also Send Feedback

The GeometrySink type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStop Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop Structure
Members See Also Send Feedback
Contains the position and color of a gradient stop.

(Also see DirectX SDK: D2D1_GRADIENT_STOP)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct GradientStop
Visual Basic
Public Structure GradientStop
Visual C++
public value class GradientStop

Remarks

Gradient stops can be specified in any order if they are at different positions. Two stops may share a position. In this case, the first stop specified is treated as the "low" stop (nearer 0.0f) and subsequent stops are treated as "higher" (nearer 1.0f). This behavior is useful if a caller wants an instant transition in the middle of a stop.

Typically, there are at least two points in a collection, although creation with only one stop is permitted. For example, one point is at position 0.0f, another point is at position 1.0f, and additional points are distributed in the [0, 1] range. Where the gradient progression is beyond the range of [0, 1], the stops are stored, but may affect the gradient.

When drawn, the [0, 1] range of positions is mapped to the brush, in a brush-dependent way.

Gradient stops with a position outside the [0, 1] range can not be seen explicitly, but they can still affect the colors produced in the [0, 1] range. For example, a two-stop gradient {{0.0f, Black}, {2.0f, White}} is indistinguishable visually from {{0.0f, Black}, {1.0f, Mid-level gray}}. Also, the colors are clamped before interpolation.

See Also

GradientStop Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStop Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop Members
GradientStop Structure Constructors Methods Operators Properties See Also Send Feedback

The GradientStop type exposes the following members.

Constructors

 | Name | Description
Public method | GradientStop | Constructor for the GradientStop value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Color | The color of the gradient stop.
Public property | Position | A value that indicates the relative position of the gradient stop in the brush. This value must be in the [0.0f, 1.0f] range if the gradient stop is to be seen explicitly.

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStop Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop Constructor
GradientStop Structure See Also Send Feedback
Constructor for the GradientStop value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GradientStop(
    float position,
    ColorF color
)
Visual Basic
Public Sub New ( _
    position As Single, _
    color As ColorF _
)
Visual C++
public:
GradientStop(
    float position,
    ColorF color
)

Parameters

position
Type: System..::..Single
Initializes the Position property.
color
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF
Initializes the Color property.

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStop Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop Methods
GradientStop Structure See Also Send Feedback

The GradientStop type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop..::..Equals Method
GradientStop Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop..::..GetHashCode Method
GradientStop Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStop Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop Operators
GradientStop Structure See Also Send Feedback

The GradientStop type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop..::..Equality Operator
GradientStop Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    GradientStop gradientStop1,
    GradientStop gradientStop2
)
Visual Basic
Public Shared Operator = ( _
    gradientStop1 As GradientStop, _
    gradientStop2 As GradientStop _
) As Boolean
Visual C++
public:
static bool operator ==(
    GradientStop gradientStop1,
    GradientStop gradientStop2
)

Parameters

gradientStop1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop
gradientStop2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop..::..Inequality Operator
GradientStop Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    GradientStop gradientStop1,
    GradientStop gradientStop2
)
Visual Basic
Public Shared Operator <> ( _
    gradientStop1 As GradientStop, _
    gradientStop2 As GradientStop _
) As Boolean
Visual C++
public:
static bool operator !=(
    GradientStop gradientStop1,
    GradientStop gradientStop2
)

Parameters

gradientStop1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop
gradientStop2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStop Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop Properties
GradientStop Structure See Also Send Feedback

The GradientStop type exposes the following members.

Properties

 | Name | Description
Public property | Color | The color of the gradient stop.
Public property | Position | A value that indicates the relative position of the gradient stop in the brush. This value must be in the [0.0f, 1.0f] range if the gradient stop is to be seen explicitly.

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Color Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop..::..Color Property
GradientStop Structure See Also Send Feedback
The color of the gradient stop.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorF Color { get; set; }
Visual Basic
Public Property Color As ColorF
    Get
    Set
Visual C++
public:
property ColorF Color {
    ColorF get ();
    void set (ColorF value);
}

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Position Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStop..::..Position Property
GradientStop Structure See Also Send Feedback
A value that indicates the relative position of the gradient stop in the brush. This value must be in the [0.0f, 1.0f] range if the gradient stop is to be seen explicitly.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Position { get; set; }
Visual Basic
Public Property Position As Single
    Get
    Set
Visual C++
public:
property float Position {
    float get ();
    void set (float value);
}

See Also

GradientStop Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStopCollection Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection Class
Members See Also Send Feedback
Represents a collection of GradientStop for either a linear or radial gradient brush.

(Also see DirectX SDK: ID2D1GradientStopCollection)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GradientStopCollection : D2DResource,
    IList<GradientStop>
Visual Basic
Public Class GradientStopCollection _
    Inherits D2DResource _
    Implements IList(Of GradientStop)
Visual C++
public ref class GradientStopCollection : public D2DResource,
    IList<GradientStop>

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStopCollection

See Also

GradientStopCollection Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStopCollection Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection Members
GradientStopCollection Class Methods Properties See Also Send Feedback

The GradientStopCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | GetEnumerator |
Public method | GetNonGenericEnumerator |
Public method | IndexOf |
Public method | Insert |
Public method | Remove |
Public method | RemoveAt |

Properties

 | Name | Description
Public property | ColorInterpolationGamma | Returns whether the interpolation occurs with 1.0 or 2.2 gamma. (Also see DirectX SDK: ID2D1GradientStopCollection::GetColorInterpolationGamma)
Public property | Count | Returns the number of stops in the gradient. (Also see DirectX SDK: ID2D1GradientStopCollection::GetGradientStopCount)
Public property | ExtendMode | Indicates the behavior of the gradient outside the normalized gradient range. (Also see DirectX SDK: ID2D1GradientStopCollection::GetExtendMode)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | IsReadOnly |
Public property | Item |
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStopCollection Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection Methods
GradientStopCollection Class See Also Send Feedback

The GradientStopCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | GetEnumerator |
Public method | GetNonGenericEnumerator |
Public method | IndexOf |
Public method | Insert |
Public method | Remove |
Public method | RemoveAt |

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Add Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..Add Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void Add(
    GradientStop
)
Visual Basic
Public Overridable Sub Add ( _
     As GradientStop _
)
Visual C++
public:
virtual void Add(
    GradientStop
)

Parameters

Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Clear Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..Clear Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Contains Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..Contains Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual bool Contains(
    GradientStop item
)
Visual Basic
Public Overridable Function Contains ( _
    item As GradientStop _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GradientStop item
)

Parameters

item
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CopyTo Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..CopyTo Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void CopyTo(
    GradientStop[] destinationArray,
    int arrayIndex
)
Visual Basic
Public Overridable Sub CopyTo ( _
    destinationArray As GradientStop(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<GradientStop>^ destinationArray,
    int arrayIndex
)

Parameters

destinationArray
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop >[]()[][]
arrayIndex
Type: System..::..Int32

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetEnumerator Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..GetEnumerator Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual IEnumerator<GradientStop> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of GradientStop)
Visual C++
public:
virtual IEnumerator<GradientStop>^ GetEnumerator()

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetNonGenericEnumerator Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..GetNonGenericEnumerator Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual IEnumerator GetNonGenericEnumerator()
Visual Basic
Public Overridable Function GetNonGenericEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetNonGenericEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IndexOf Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..IndexOf Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual int IndexOf(
    GradientStop item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As GradientStop _
) As Integer
Visual C++
public:
virtual int IndexOf(
    GradientStop item
)

Parameters

item
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Insert Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..Insert Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void Insert(
    int ,
    GradientStop
)
Visual Basic
Public Overridable Sub Insert ( _
     As Integer, _
     As GradientStop _
)
Visual C++
public:
virtual void Insert(
    int ,
    GradientStop
)

Parameters

Type: System..::..Int32
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Remove Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..Remove Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual bool Remove(
    GradientStop
)
Visual Basic
Public Overridable Function Remove ( _
     As GradientStop _
) As Boolean
Visual C++
public:
virtual bool Remove(
    GradientStop
)

Parameters

Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStop

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RemoveAt Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..RemoveAt Method
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void RemoveAt(
    int
)
Visual Basic
Public Overridable Sub RemoveAt ( _
     As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int
)

Parameters

Type: System..::..Int32

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStopCollection Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection Properties
GradientStopCollection Class See Also Send Feedback

The GradientStopCollection type exposes the following members.

Properties

 | Name | Description
Public property | ColorInterpolationGamma | Returns whether the interpolation occurs with 1.0 or 2.2 gamma. (Also see DirectX SDK: ID2D1GradientStopCollection::GetColorInterpolationGamma)
Public property | Count | Returns the number of stops in the gradient. (Also see DirectX SDK: ID2D1GradientStopCollection::GetGradientStopCount)
Public property | ExtendMode | Indicates the behavior of the gradient outside the normalized gradient range. (Also see DirectX SDK: ID2D1GradientStopCollection::GetExtendMode)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | IsReadOnly |
Public property | Item |
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ColorInterpolationGamma Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..ColorInterpolationGamma Property
GradientStopCollection Class See Also Send Feedback
Returns whether the interpolation occurs with 1.0 or 2.2 gamma.

(Also see DirectX SDK: ID2D1GradientStopCollection::GetColorInterpolationGamma)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Gamma ColorInterpolationGamma { get; }
Visual Basic
Public ReadOnly Property ColorInterpolationGamma As Gamma
    Get
Visual C++
public:
property Gamma ColorInterpolationGamma {
    Gamma get ();
}

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Count Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..Count Property
GradientStopCollection Class See Also Send Feedback
Returns the number of stops in the gradient.

(Also see DirectX SDK: ID2D1GradientStopCollection::GetGradientStopCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ExtendMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..ExtendMode Property
GradientStopCollection Class See Also Send Feedback
Indicates the behavior of the gradient outside the normalized gradient range.

(Also see DirectX SDK: ID2D1GradientStopCollection::GetExtendMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExtendMode ExtendMode { get; }
Visual Basic
Public ReadOnly Property ExtendMode As ExtendMode
    Get
Visual C++
public:
property ExtendMode ExtendMode {
    ExtendMode get ();
}

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IsReadOnly Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..IsReadOnly Property
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Item Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GradientStopCollection..::..Item Property
GradientStopCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual GradientStop this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As GradientStop
    Get
    Set
Visual C++
public:
virtual property GradientStop default[int index] {
    GradientStop get (int index);
    void set (int index, GradientStop value);
}

Parameters

index
Type: System..::..Int32

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

GradientStopCollection Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


HwndRenderTarget Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget Class
Members See Also Send Feedback
Renders drawing instructions to a window.

(Also see DirectX SDK: ID2D1HwndRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class HwndRenderTarget : RenderTarget
Visual Basic
Public Class HwndRenderTarget _
    Inherits RenderTarget
Visual C++
public ref class HwndRenderTarget : public RenderTarget

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTarget
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..HwndRenderTarget

See Also

HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


HwndRenderTarget Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget Members
HwndRenderTarget Class Methods Properties See Also Send Feedback

The HwndRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | BeginDraw | Start drawing on this render target. Draw calls can only be issued between a BeginDraw and EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::BeginDraw) (Inherited from RenderTarget.)
Public method | CheckWindowState | Check the current WindowState. (Also see DirectX SDK: ID2D1HwndRenderTarget::CheckWindowState)
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateGradientStopCollection | (Inherited from RenderTarget.)
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateMesh | Create a mesh that uses triangles to describe a shape. Create a D2D mesh. (Also see DirectX SDK: ID2D1RenderTarget::CreateMesh) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmapAtOrigin | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | EndDraw | Ends drawing on the render target. If an error occur while drawing, an exception will be thrown. To prevent exceptions, you can use the TryEndDraw() method instead. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | FillEllipse | Paints the interior of the specified ellipse. (Also see DirectX SDK: ID2D1RenderTarget::FillEllipse) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillMesh | Fill a mesh. Since meshes can only render aliased content, the render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillMesh) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMaskAtOrigin | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush uses the sourceRectangle area to draw at the orgin of the bitmap. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillRectangle | Paints the interior of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRectangle) (Inherited from RenderTarget.)
Public method | FillRoundedRectangle | Paints the interior of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRoundedRectangle) (Inherited from RenderTarget.)
Public method | Flush | Executes all pending drawing commands. This method will throw if an error occur during the operation. To prevent exceptions, TryFlush() can be used instead. (Also see DirectX SDK: ID2D1RenderTarget::Flush) (Inherited from RenderTarget.)
Public method | IsSupported | Returns true if the given properties are supported by this render target. The DPI is ignored. NOTE: If the render target type is software, then neither feature level 9 nor feature level 10 will be considered to be supported. (Also see DirectX SDK: ID2D1RenderTarget::IsSupported) (Inherited from RenderTarget.)
Public method | PopAxisAlignedClip | Removes the last axis-aligned clip from the render target. After this method is called, the clip is no longer applied to subsequent drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::PopAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PopLayer | Ends a layer that was defined with particular layer resources. (Also see DirectX SDK: ID2D1RenderTarget::PopLayer) (Inherited from RenderTarget.)
Public method | PushAxisAlignedClip | Pushes a clip. The clip can be antialiased. The clip must be axis aligned. If the current world transform is not axis preserving, then the bounding box of the transformed clip rect will be used. The clip will remain in effect until a PopAxisAligned clip call is made. (Also see DirectX SDK: ID2D1RenderTarget::PushAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PushLayer | Start a layer of drawing calls. The way in which the layer must be resolved is specified first as well as the logical resource that stores the layer parameters. The supplied layer resource might grow if the specified content cannot fit inside it. The layer will grow monitonically on each axis. (Also see DirectX SDK: ID2D1RenderTarget::PushLayer) (Inherited from RenderTarget.)
Public method | Resize | Resize the buffer underlying the render target to the specified device pixel size. (Also see DirectX SDK: ID2D1HwndRenderTarget::Resize)
Public method | RestoreDrawingState | Copies the state stored in the block interface. (Also see DirectX SDK: ID2D1RenderTarget::RestoreDrawingState) (Inherited from RenderTarget.)
Public method | SaveDrawingState | Gets the current drawing state and saves it into the supplied IDrawingStatckBlock. (Also see DirectX SDK: ID2D1RenderTarget::SaveDrawingState) (Inherited from RenderTarget.)
Public method | TryEndDraw | Ends drawing on the render target, error results can be retrieved at this time, or when calling Flush() or TryFlush(). (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | TryFlush | Executes all pending drawing commands. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)

Properties

 | Name | Description
Public property | AntiAliasMode | The current antialiasing mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetAntiAliasMode, ID2D1RenderTarget::SetAntiAliasMode) (Inherited from RenderTarget.)
Public property | Dpi | The DPI on the render target. This results in the render target being interpretted to a different scale. Neither DPI can be negative. If zero is specified for both, the system DPI is chosen. If one is zero and the other unspecified, the DPI is not changed. (Also see DirectX SDK: ID2D1RenderTarget::GetDpi, ID2D1RenderTarget::SetDpi) (Inherited from RenderTarget.)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GdiInteropRenderTarget | Provide a GdiInteropRenderTarget version of this render target. (Inherited from RenderTarget.)
Public property | IsOccluded | Indicates whether the HWND associated with this render target is occluded. (Also see DirectX SDK: ID2D1HwndRenderTarget::CheckWindowState)
Public property | MaximumBitmapSize | Returns the maximum bitmap and render target size that is guaranteed to be supported by the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetMaximumBitmapSize) (Inherited from RenderTarget.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | The pixel format and alpha mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelFormat) (Inherited from RenderTarget.)
Public property | PixelSize | Returns the size of the render target in pixels. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelSize) (Inherited from RenderTarget.)
Public property | Size | Returns the size of the render target in DIPs. (Also see DirectX SDK: ID2D1RenderTarget::GetSize) (Inherited from RenderTarget.)
Public property | Tags | Get or Set a tag to labelto the succeeding drawing operations. If an error occurs while rendering a primtive, the tags can be returned from the Flush or EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::GetTags, ID2D1RenderTarget::SetTags) (Inherited from RenderTarget.)
Public property | TextAntiAliasMode | The current antialiasing mode for text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextAntiAliasMode, ID2D1RenderTarget::SetTextAntiAliasMode) (Inherited from RenderTarget.)
Public property | TextRenderingParams | Gets or set the render target's current text-rendering options. Text rendering options to apply to all text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextRenderingParams, ID2D1RenderTarget::SetTextRenderingParams) (Inherited from RenderTarget.)
Public property | Transform | The current transform of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetTransform, ID2D1RenderTarget::SetTransform) (Inherited from RenderTarget.)
Public property | WindowHandle | Get the handle to the window associated with this render target. (Also see DirectX SDK: ID2D1HwndRenderTarget::GetHwnd)

See Also

HwndRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


HwndRenderTarget Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget Methods
HwndRenderTarget Class See Also Send Feedback

The HwndRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | BeginDraw | Start drawing on this render target. Draw calls can only be issued between a BeginDraw and EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::BeginDraw) (Inherited from RenderTarget.)
Public method | CheckWindowState | Check the current WindowState. (Also see DirectX SDK: ID2D1HwndRenderTarget::CheckWindowState)
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateGradientStopCollection | (Inherited from RenderTarget.)
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateMesh | Create a mesh that uses triangles to describe a shape. Create a D2D mesh. (Also see DirectX SDK: ID2D1RenderTarget::CreateMesh) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmapAtOrigin | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | EndDraw | Ends drawing on the render target. If an error occur while drawing, an exception will be thrown. To prevent exceptions, you can use the TryEndDraw() method instead. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | FillEllipse | Paints the interior of the specified ellipse. (Also see DirectX SDK: ID2D1RenderTarget::FillEllipse) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillMesh | Fill a mesh. Since meshes can only render aliased content, the render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillMesh) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMaskAtOrigin | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush uses the sourceRectangle area to draw at the orgin of the bitmap. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillRectangle | Paints the interior of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRectangle) (Inherited from RenderTarget.)
Public method | FillRoundedRectangle | Paints the interior of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRoundedRectangle) (Inherited from RenderTarget.)
Public method | Flush | Executes all pending drawing commands. This method will throw if an error occur during the operation. To prevent exceptions, TryFlush() can be used instead. (Also see DirectX SDK: ID2D1RenderTarget::Flush) (Inherited from RenderTarget.)
Public method | IsSupported | Returns true if the given properties are supported by this render target. The DPI is ignored. NOTE: If the render target type is software, then neither feature level 9 nor feature level 10 will be considered to be supported. (Also see DirectX SDK: ID2D1RenderTarget::IsSupported) (Inherited from RenderTarget.)
Public method | PopAxisAlignedClip | Removes the last axis-aligned clip from the render target. After this method is called, the clip is no longer applied to subsequent drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::PopAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PopLayer | Ends a layer that was defined with particular layer resources. (Also see DirectX SDK: ID2D1RenderTarget::PopLayer) (Inherited from RenderTarget.)
Public method | PushAxisAlignedClip | Pushes a clip. The clip can be antialiased. The clip must be axis aligned. If the current world transform is not axis preserving, then the bounding box of the transformed clip rect will be used. The clip will remain in effect until a PopAxisAligned clip call is made. (Also see DirectX SDK: ID2D1RenderTarget::PushAxisAlignedClip) (Inherited from RenderTarget.)
Public method | PushLayer | Start a layer of drawing calls. The way in which the layer must be resolved is specified first as well as the logical resource that stores the layer parameters. The supplied layer resource might grow if the specified content cannot fit inside it. The layer will grow monitonically on each axis. (Also see DirectX SDK: ID2D1RenderTarget::PushLayer) (Inherited from RenderTarget.)
Public method | Resize | Resize the buffer underlying the render target to the specified device pixel size. (Also see DirectX SDK: ID2D1HwndRenderTarget::Resize)
Public method | RestoreDrawingState | Copies the state stored in the block interface. (Also see DirectX SDK: ID2D1RenderTarget::RestoreDrawingState) (Inherited from RenderTarget.)
Public method | SaveDrawingState | Gets the current drawing state and saves it into the supplied IDrawingStatckBlock. (Also see DirectX SDK: ID2D1RenderTarget::SaveDrawingState) (Inherited from RenderTarget.)
Public method | TryEndDraw | Ends drawing on the render target, error results can be retrieved at this time, or when calling Flush() or TryFlush(). (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)
Public method | TryFlush | Executes all pending drawing commands. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CheckWindowState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CheckWindowState Method
HwndRenderTarget Class See Also Send Feedback
Check the current WindowState.

(Also see DirectX SDK: ID2D1HwndRenderTarget::CheckWindowState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public WindowState CheckWindowState()
Visual Basic
Public Function CheckWindowState As WindowState
Visual C++
public:
WindowState CheckWindowState()

Return Value

The current WindowState

See Also

HwndRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Clear Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..Clear Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CreateBitmap Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CreateBitmapBrush Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapFromWicBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CreateBitmapFromWicBitmap Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CreateCompatibleRenderTarget Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLayer Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CreateLayer Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLinearGradientBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CreateLinearGradientBrush Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateRadialGradientBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CreateRadialGradientBrush Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CreateSharedBitmap Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSolidColorBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..CreateSolidColorBrush Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..DrawBitmap Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawEllipse Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..DrawEllipse Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..DrawGeometry Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGlyphRun Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..DrawGlyphRun Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawLine Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..DrawLine Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRectangle Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..DrawRectangle Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRoundedRectangle Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..DrawRoundedRectangle Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawText Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..DrawText Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawTextLayout Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..DrawTextLayout Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout ) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..FillGeometry Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillOpacityMask Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..FillOpacityMask Method
HwndRenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask) (Inherited from RenderTarget.)

See Also

HwndRenderTarget Class
HwndRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Resize Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..Resize Method
HwndRenderTarget Class See Also Send Feedback
Resize the buffer underlying the render target to the specified device pixel size.

(Also see DirectX SDK: ID2D1HwndRenderTarget::Resize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Resize(
    SizeU pixelSize
)
Visual Basic
Public Sub Resize ( _
    pixelSize As SizeU _
)
Visual C++
public:
void Resize(
    SizeU pixelSize
)

Parameters

pixelSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
The new pixel size.

Remarks

This operation might fail if there is insufficent video memory or system memory, or if the render target is resized beyond the maximum bitmap size. If the method fails, the render target will be placed in a zombie state and an exception will be thrown when EndDraw is called. In addition an appropriate exception will be thrown from Resize.

See Also

HwndRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


HwndRenderTarget Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget Properties
HwndRenderTarget Class See Also Send Feedback

The HwndRenderTarget type exposes the following members.

Properties

 | Name | Description
Public property | AntiAliasMode | The current antialiasing mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetAntiAliasMode, ID2D1RenderTarget::SetAntiAliasMode) (Inherited from RenderTarget.)
Public property | Dpi | The DPI on the render target. This results in the render target being interpretted to a different scale. Neither DPI can be negative. If zero is specified for both, the system DPI is chosen. If one is zero and the other unspecified, the DPI is not changed. (Also see DirectX SDK: ID2D1RenderTarget::GetDpi, ID2D1RenderTarget::SetDpi) (Inherited from RenderTarget.)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GdiInteropRenderTarget | Provide a GdiInteropRenderTarget version of this render target. (Inherited from RenderTarget.)
Public property | IsOccluded | Indicates whether the HWND associated with this render target is occluded. (Also see DirectX SDK: ID2D1HwndRenderTarget::CheckWindowState)
Public property | MaximumBitmapSize | Returns the maximum bitmap and render target size that is guaranteed to be supported by the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetMaximumBitmapSize) (Inherited from RenderTarget.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | The pixel format and alpha mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelFormat) (Inherited from RenderTarget.)
Public property | PixelSize | Returns the size of the render target in pixels. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelSize) (Inherited from RenderTarget.)
Public property | Size | Returns the size of the render target in DIPs. (Also see DirectX SDK: ID2D1RenderTarget::GetSize) (Inherited from RenderTarget.)
Public property | Tags | Get or Set a tag to labelto the succeeding drawing operations. If an error occurs while rendering a primtive, the tags can be returned from the Flush or EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::GetTags, ID2D1RenderTarget::SetTags) (Inherited from RenderTarget.)
Public property | TextAntiAliasMode | The current antialiasing mode for text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextAntiAliasMode, ID2D1RenderTarget::SetTextAntiAliasMode) (Inherited from RenderTarget.)
Public property | TextRenderingParams | Gets or set the render target's current text-rendering options. Text rendering options to apply to all text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextRenderingParams, ID2D1RenderTarget::SetTextRenderingParams) (Inherited from RenderTarget.)
Public property | Transform | The current transform of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetTransform, ID2D1RenderTarget::SetTransform) (Inherited from RenderTarget.)
Public property | WindowHandle | Get the handle to the window associated with this render target. (Also see DirectX SDK: ID2D1HwndRenderTarget::GetHwnd)

See Also

HwndRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IsOccluded Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..IsOccluded Property
HwndRenderTarget Class See Also Send Feedback
Indicates whether the HWND associated with this render target is occluded.

(Also see DirectX SDK: ID2D1HwndRenderTarget::CheckWindowState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsOccluded { get; }
Visual Basic
Public ReadOnly Property IsOccluded As Boolean
    Get
Visual C++
public:
property bool IsOccluded {
    bool get ();
}

See Also

HwndRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


WindowHandle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTarget..::..WindowHandle Property
HwndRenderTarget Class See Also Send Feedback
Get the handle to the window associated with this render target.

(Also see DirectX SDK: ID2D1HwndRenderTarget::GetHwnd)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr WindowHandle { get; }
Visual Basic
Public ReadOnly Property WindowHandle As IntPtr
    Get
Visual C++
public:
property IntPtr WindowHandle {
    IntPtr get ();
}

See Also

HwndRenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


HwndRenderTargetProperties Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTargetProperties Structure
Members See Also Send Feedback
Contains the window handle, pixel size, and presentation options for an HwndRenderTarget.

(Also see DirectX SDK: D2D1_HWND_RENDER_TARGET_PROPERTIES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct HwndRenderTargetProperties
Visual Basic
Public Structure HwndRenderTargetProperties
Visual C++
public value class HwndRenderTargetProperties

See Also

HwndRenderTargetProperties Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


HwndRenderTargetProperties Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTargetProperties Members
HwndRenderTargetProperties Structure Constructors Properties See Also Send Feedback

The HwndRenderTargetProperties type exposes the following members.

Constructors

 | Name | Description
Public method | HwndRenderTargetProperties | Constructor for the HwndRenderTargetProperties value type

Properties

 | Name | Description
Public property | PixelSize | The size of the render target, in pixels.
Public property | PresentOptions | A value that specifies whether the render target retains the frame after it is presented and whether the render target waits for the device to refresh before presenting.
Public property | WindowHandle | A handle to the windows to which the render target issues the output from its drawing commands.

See Also

HwndRenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


HwndRenderTargetProperties Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTargetProperties Constructor
HwndRenderTargetProperties Structure See Also Send Feedback
Constructor for the HwndRenderTargetProperties value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HwndRenderTargetProperties(
    IntPtr windowHandle,
    SizeU pixelSize,
    PresentOptions presentOptions
)
Visual Basic
Public Sub New ( _
    windowHandle As IntPtr, _
    pixelSize As SizeU, _
    presentOptions As PresentOptions _
)
Visual C++
public:
HwndRenderTargetProperties(
    IntPtr windowHandle,
    SizeU pixelSize,
    PresentOptions presentOptions
)

Parameters

windowHandle
Type: System..::..IntPtr
Initializes the WindowHandle property.
pixelSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
Initializes the PixelSize property.
presentOptions
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PresentOptions
Initializes the PresentOptions property.

See Also

HwndRenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


HwndRenderTargetProperties Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTargetProperties Properties
HwndRenderTargetProperties Structure See Also Send Feedback

The HwndRenderTargetProperties type exposes the following members.

Properties

 | Name | Description
Public property | PixelSize | The size of the render target, in pixels.
Public property | PresentOptions | A value that specifies whether the render target retains the frame after it is presented and whether the render target waits for the device to refresh before presenting.
Public property | WindowHandle | A handle to the windows to which the render target issues the output from its drawing commands.

See Also

HwndRenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTargetProperties..::..PixelSize Property
HwndRenderTargetProperties Structure See Also Send Feedback
The size of the render target, in pixels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SizeU PixelSize { get; set; }
Visual Basic
Public Property PixelSize As SizeU
    Get
    Set
Visual C++
public:
property SizeU PixelSize {
    SizeU get ();
    void set (SizeU value);
}

See Also

HwndRenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PresentOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTargetProperties..::..PresentOptions Property
HwndRenderTargetProperties Structure See Also Send Feedback
A value that specifies whether the render target retains the frame after it is presented and whether the render target waits for the device to refresh before presenting.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PresentOptions PresentOptions { get; set; }
Visual Basic
Public Property PresentOptions As PresentOptions
    Get
    Set
Visual C++
public:
property PresentOptions PresentOptions {
    PresentOptions get ();
    void set (PresentOptions value);
}

See Also

HwndRenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


WindowHandle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HwndRenderTargetProperties..::..WindowHandle Property
HwndRenderTargetProperties Structure See Also Send Feedback
A handle to the windows to which the render target issues the output from its drawing commands.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr WindowHandle { get; set; }
Visual Basic
Public Property WindowHandle As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr WindowHandle {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

HwndRenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IGdiInteropRenderTarget Interface

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGdiInteropRenderTarget Interface
Members See Also Send Feedback
Provides access to an device context that can accept GDI drawing commands.

(Also see DirectX SDK: ID2D1GdiInteropRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public interface IGdiInteropRenderTarget
Visual Basic
Public Interface IGdiInteropRenderTarget
Visual C++
public interface class IGdiInteropRenderTarget

See Also

IGdiInteropRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IGdiInteropRenderTarget Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGdiInteropRenderTarget Members
IGdiInteropRenderTarget Interface Methods See Also Send Feedback

The IGdiInteropRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | GetDC | Retrieves the device context associated with this render target. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::GetDC)
Public method | ReleaseDC()()()() | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)
Public method | ReleaseDC(Rect) | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

See Also

IGdiInteropRenderTarget Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IGdiInteropRenderTarget Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGdiInteropRenderTarget Methods
IGdiInteropRenderTarget Interface See Also Send Feedback

The IGdiInteropRenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | GetDC | Retrieves the device context associated with this render target. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::GetDC)
Public method | ReleaseDC()()()() | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)
Public method | ReleaseDC(Rect) | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

See Also

IGdiInteropRenderTarget Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetDC Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGdiInteropRenderTarget..::..GetDC Method
IGdiInteropRenderTarget Interface See Also Send Feedback
Retrieves the device context associated with this render target.

(Also see DirectX SDK: ID2D1GdiInteropRenderTarget::GetDC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
IntPtr GetDC(
    DCInitializeMode mode
)
Visual Basic
Function GetDC ( _
    mode As DCInitializeMode _
) As IntPtr
Visual C++
IntPtr GetDC(
    DCInitializeMode mode
)

Parameters

mode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DCInitializeMode
The mode parameter.

Return Value

Device context handle.

See Also

IGdiInteropRenderTarget Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ReleaseDC Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGdiInteropRenderTarget..::..ReleaseDC Method
IGdiInteropRenderTarget Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | ReleaseDC()()()() | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)
Public method | ReleaseDC(Rect) | Indicates that drawing with the device context retrieved using the GetDC method is finished. (Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

See Also

IGdiInteropRenderTarget Interface
IGdiInteropRenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ReleaseDC Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGdiInteropRenderTarget..::..ReleaseDC Method
IGdiInteropRenderTarget Interface See Also Send Feedback
Indicates that drawing with the device context retrieved using the GetDC method is finished.

(Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void ReleaseDC()
Visual Basic
Sub ReleaseDC
Visual C++
void ReleaseDC()

See Also

IGdiInteropRenderTarget Interface
ReleaseDC Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ReleaseDC Method (Rect)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGdiInteropRenderTarget..::..ReleaseDC Method (Rect)
IGdiInteropRenderTarget Interface See Also Send Feedback
Indicates that drawing with the device context retrieved using the GetDC method is finished.

(Also see DirectX SDK: ID2D1GdiInteropRenderTarget::ReleaseDC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void ReleaseDC(
    Rect updateRectangle
)
Visual Basic
Sub ReleaseDC ( _
    updateRectangle As Rect _
)
Visual C++
void ReleaseDC(
    Rect updateRectangle
)

Parameters

updateRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Rect
The update rectantgle.

See Also

IGdiInteropRenderTarget Interface
ReleaseDC Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IGeometrySink Interface

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGeometrySink Interface
Members See Also Send Feedback
Describes a geometric path that can contain lines, arcs, cubic Bezier curves, and quadratic Bezier curves. Implement this interface when you want to read back the complete contents of a geometry. For other scenarios, use the implementation provided by Direct2D: GeometrySink

(Also see DirectX SDK: ID2D1GeometrySink)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public interface IGeometrySink : ISimplifiedGeometrySink
Visual Basic
Public Interface IGeometrySink _
    Inherits ISimplifiedGeometrySink
Visual C++
public interface class IGeometrySink : ISimplifiedGeometrySink

See Also

IGeometrySink Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IGeometrySink Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGeometrySink Members
IGeometrySink Interface Methods See Also Send Feedback

The IGeometrySink type exposes the following members.

Methods

 | Name | Description
Public method | AddArc | Creates a single arc and adds it to the path geometry. (Also see DirectX SDK: ID2D1GeometrySink::AddArc)
Public method | AddBezier | Creates a cubic Bezier curve between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddBezier)
Public method | AddBeziers | (Inherited from ISimplifiedGeometrySink.)
Public method | AddLine | Creates a line segment between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddLine)
Public method | AddLines | (Inherited from ISimplifiedGeometrySink.)
Public method | AddQuadraticBezier | Creates a quadratic Bezier curve between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddQuadraticBezier)
Public method | AddQuadraticBeziers |
Public method | BeginFigure | Starts a new figure at the specified point. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure) (Inherited from ISimplifiedGeometrySink.)
Public method | Close | Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close) (Inherited from ISimplifiedGeometrySink.)
Public method | EndFigure | Ends the current figure; optionally, closes it. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure) (Inherited from ISimplifiedGeometrySink.)
Public method | SetFillMode | Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode) (Inherited from ISimplifiedGeometrySink.)
Public method | SetSegmentFlags | Specifies stroke and join options to be applied to new segments added to the geometry sink. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags) (Inherited from ISimplifiedGeometrySink.)

See Also

IGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IGeometrySink Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGeometrySink Methods
IGeometrySink Interface See Also Send Feedback

The IGeometrySink type exposes the following members.

Methods

 | Name | Description
Public method | AddArc | Creates a single arc and adds it to the path geometry. (Also see DirectX SDK: ID2D1GeometrySink::AddArc)
Public method | AddBezier | Creates a cubic Bezier curve between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddBezier)
Public method | AddBeziers | (Inherited from ISimplifiedGeometrySink.)
Public method | AddLine | Creates a line segment between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddLine)
Public method | AddLines | (Inherited from ISimplifiedGeometrySink.)
Public method | AddQuadraticBezier | Creates a quadratic Bezier curve between the current point and the specified end point and adds it to the geometry sink. (Also see DirectX SDK: ID2D1GeometrySink::AddQuadraticBezier)
Public method | AddQuadraticBeziers |
Public method | BeginFigure | Starts a new figure at the specified point. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure) (Inherited from ISimplifiedGeometrySink.)
Public method | Close | Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close) (Inherited from ISimplifiedGeometrySink.)
Public method | EndFigure | Ends the current figure; optionally, closes it. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure) (Inherited from ISimplifiedGeometrySink.)
Public method | SetFillMode | Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode) (Inherited from ISimplifiedGeometrySink.)
Public method | SetSegmentFlags | Specifies stroke and join options to be applied to new segments added to the geometry sink. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags) (Inherited from ISimplifiedGeometrySink.)

See Also

IGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddArc Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGeometrySink..::..AddArc Method
IGeometrySink Interface See Also Send Feedback
Creates a single arc and adds it to the path geometry.

(Also see DirectX SDK: ID2D1GeometrySink::AddArc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void AddArc(
    ArcSegment arc
)
Visual Basic
Sub AddArc ( _
    arc As ArcSegment _
)
Visual C++
void AddArc(
    ArcSegment arc
)

Parameters

arc
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ArcSegment
The arc to add.

See Also

IGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddBezier Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGeometrySink..::..AddBezier Method
IGeometrySink Interface See Also Send Feedback
Creates a cubic Bezier curve between the current point and the specified end point and adds it to the geometry sink.

(Also see DirectX SDK: ID2D1GeometrySink::AddBezier)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void AddBezier(
    BezierSegment bezier
)
Visual Basic
Sub AddBezier ( _
    bezier As BezierSegment _
)
Visual C++
void AddBezier(
    BezierSegment bezier
)

Parameters

bezier
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BezierSegment
The Bezier curve to add.

See Also

IGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddLine Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGeometrySink..::..AddLine Method
IGeometrySink Interface See Also Send Feedback
Creates a line segment between the current point and the specified end point and adds it to the geometry sink.

(Also see DirectX SDK: ID2D1GeometrySink::AddLine)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void AddLine(
    Point2F point
)
Visual Basic
Sub AddLine ( _
    point As Point2F _
)
Visual C++
void AddLine(
    Point2F point
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The end point of the line to draw.

See Also

IGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddQuadraticBezier Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGeometrySink..::..AddQuadraticBezier Method
IGeometrySink Interface See Also Send Feedback
Creates a quadratic Bezier curve between the current point and the specified end point and adds it to the geometry sink.

(Also see DirectX SDK: ID2D1GeometrySink::AddQuadraticBezier)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void AddQuadraticBezier(
    QuadraticBezierSegment bezier
)
Visual Basic
Sub AddQuadraticBezier ( _
    bezier As QuadraticBezierSegment _
)
Visual C++
void AddQuadraticBezier(
    QuadraticBezierSegment bezier
)

Parameters

bezier
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..QuadraticBezierSegment
The quadratic Bezier curve to add.

See Also

IGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddQuadraticBeziers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IGeometrySink..::..AddQuadraticBeziers Method
IGeometrySink Interface See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void AddQuadraticBeziers(
    IEnumerable<QuadraticBezierSegment> beziers
)
Visual Basic
Sub AddQuadraticBeziers ( _
    beziers As IEnumerable(Of QuadraticBezierSegment) _
)
Visual C++
void AddQuadraticBeziers(
    IEnumerable<QuadraticBezierSegment>^ beziers
)

Parameters

beziers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' QuadraticBezierSegment >)>)>

See Also

IGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ISimplifiedGeometrySink Interface

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink Interface
Members See Also Send Feedback
Describes a geometric path that does not contain quadratic bezier curves or arcs. Implement this interface when you want to read back the complete contents of a geometry. For other scenarios, use the implementation provided by Direct2D: SimplifiedGeometrySink

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public interface ISimplifiedGeometrySink
Visual Basic
Public Interface ISimplifiedGeometrySink
Visual C++
public interface class ISimplifiedGeometrySink

See Also

ISimplifiedGeometrySink Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ISimplifiedGeometrySink Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink Members
ISimplifiedGeometrySink Interface Methods See Also Send Feedback

The ISimplifiedGeometrySink type exposes the following members.

Methods

 | Name | Description
Public method | AddBeziers |
Public method | AddLines |
Public method | BeginFigure | Starts a new figure at the specified point. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure)
Public method | Close | Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close)
Public method | EndFigure | Ends the current figure; optionally, closes it. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure)
Public method | SetFillMode | Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode)
Public method | SetSegmentFlags | Specifies stroke and join options to be applied to new segments added to the geometry sink. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags)

See Also

ISimplifiedGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ISimplifiedGeometrySink Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink Methods
ISimplifiedGeometrySink Interface See Also Send Feedback

The ISimplifiedGeometrySink type exposes the following members.

Methods

 | Name | Description
Public method | AddBeziers |
Public method | AddLines |
Public method | BeginFigure | Starts a new figure at the specified point. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure)
Public method | Close | Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close)
Public method | EndFigure | Ends the current figure; optionally, closes it. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure)
Public method | SetFillMode | Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode)
Public method | SetSegmentFlags | Specifies stroke and join options to be applied to new segments added to the geometry sink. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags)

See Also

ISimplifiedGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddBeziers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink..::..AddBeziers Method
ISimplifiedGeometrySink Interface See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void AddBeziers(
    IEnumerable<BezierSegment> beziers
)
Visual Basic
Sub AddBeziers ( _
    beziers As IEnumerable(Of BezierSegment) _
)
Visual C++
void AddBeziers(
    IEnumerable<BezierSegment>^ beziers
)

Parameters

beziers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BezierSegment >)>)>

See Also

ISimplifiedGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddLines Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink..::..AddLines Method
ISimplifiedGeometrySink Interface See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void AddLines(
    IEnumerable<Point2F> points
)
Visual Basic
Sub AddLines ( _
    points As IEnumerable(Of Point2F) _
)
Visual C++
void AddLines(
    IEnumerable<Point2F>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Point2F >)>)>

See Also

ISimplifiedGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BeginFigure Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink..::..BeginFigure Method
ISimplifiedGeometrySink Interface See Also Send Feedback
Starts a new figure at the specified point.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void BeginFigure(
    Point2F startPoint,
    FigureBegin figureBegin
)
Visual Basic
Sub BeginFigure ( _
    startPoint As Point2F, _
    figureBegin As FigureBegin _
)
Visual C++
void BeginFigure(
    Point2F startPoint,
    FigureBegin figureBegin
)

Parameters

startPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point at which to begin the new figure.
figureBegin
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FigureBegin
Whether the new figure should be hollow or filled.

See Also

ISimplifiedGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Close Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink..::..Close Method
ISimplifiedGeometrySink Interface See Also Send Feedback
Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void Close()
Visual Basic
Sub Close
Visual C++
void Close()

See Also

ISimplifiedGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EndFigure Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink..::..EndFigure Method
ISimplifiedGeometrySink Interface See Also Send Feedback
Ends the current figure; optionally, closes it.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void EndFigure(
    FigureEnd figureEnd
)
Visual Basic
Sub EndFigure ( _
    figureEnd As FigureEnd _
)
Visual C++
void EndFigure(
    FigureEnd figureEnd
)

Parameters

figureEnd
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FigureEnd
A value that indicates whether the current figure is closed. If the figure is closed, a line is drawn between the current point and the start point specified by BeginFigure.

See Also

ISimplifiedGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SetFillMode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink..::..SetFillMode Method
ISimplifiedGeometrySink Interface See Also Send Feedback
Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void SetFillMode(
    FillMode fillMode
)
Visual Basic
Sub SetFillMode ( _
    fillMode As FillMode _
)
Visual C++
void SetFillMode(
    FillMode fillMode
)

Parameters

fillMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FillMode
The method used to determine whether a given point is part of the geometry.

See Also

ISimplifiedGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SetSegmentFlags Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ISimplifiedGeometrySink..::..SetSegmentFlags Method
ISimplifiedGeometrySink Interface See Also Send Feedback
Specifies stroke and join options to be applied to new segments added to the geometry sink.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void SetSegmentFlags(
    PathSegmentOptions vertexOptions
)
Visual Basic
Sub SetSegmentFlags ( _
    vertexOptions As PathSegmentOptions _
)
Visual C++
void SetSegmentFlags(
    PathSegmentOptions vertexOptions
)

Parameters

vertexOptions
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PathSegmentOptions
Stroke and join options to be applied to new segments added to the geometry sink.

See Also

ISimplifiedGeometrySink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ITessellationSink Interface

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ITessellationSink Interface
Members See Also Send Feedback
Populates a Mesh object with triangles. Implement this interface when you want to read back the results of the Tessellate method. For other scenarios, use the implementation provided by Direct2D: TessellationSink

(Also see DirectX SDK: ID2D1TessellationSink)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public interface ITessellationSink
Visual Basic
Public Interface ITessellationSink
Visual C++
public interface class ITessellationSink

See Also

ITessellationSink Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ITessellationSink Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ITessellationSink Members
ITessellationSink Interface Methods See Also Send Feedback

The ITessellationSink type exposes the following members.

Methods

 | Name | Description
Public method | AddTriangles |
Public method | Close | Closes the sink. (Also see DirectX SDK: ID2D1TessellationSink::Close)

See Also

ITessellationSink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ITessellationSink Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ITessellationSink Methods
ITessellationSink Interface See Also Send Feedback

The ITessellationSink type exposes the following members.

Methods

 | Name | Description
Public method | AddTriangles |
Public method | Close | Closes the sink. (Also see DirectX SDK: ID2D1TessellationSink::Close)

See Also

ITessellationSink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddTriangles Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ITessellationSink..::..AddTriangles Method
ITessellationSink Interface See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void AddTriangles(
    IEnumerable<Triangle> triangles
)
Visual Basic
Sub AddTriangles ( _
    triangles As IEnumerable(Of Triangle) _
)
Visual C++
void AddTriangles(
    IEnumerable<Triangle>^ triangles
)

Parameters

triangles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Triangle >)>)>

See Also

ITessellationSink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Close Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ITessellationSink..::..Close Method
ITessellationSink Interface See Also Send Feedback
Closes the sink.

(Also see DirectX SDK: ID2D1TessellationSink::Close)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void Close()
Visual Basic
Sub Close
Visual C++
void Close()

See Also

ITessellationSink Interface
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Layer Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Layer Class
Members See Also Send Feedback
Represents the backing store required to render a layer.

(Also see DirectX SDK: ID2D1Layer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Layer : D2DResource
Visual Basic
Public Class Layer _
    Inherits D2DResource
Visual C++
public ref class Layer : public D2DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Layer

See Also

Layer Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Layer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Layer Members
Layer Class Properties See Also Send Feedback

The Layer type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Size | The size of the layer in device-independent pixels. (Also see DirectX SDK: ID2D1Layer::GetSize)

See Also

Layer Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Layer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Layer Properties
Layer Class See Also Send Feedback

The Layer type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Size | The size of the layer in device-independent pixels. (Also see DirectX SDK: ID2D1Layer::GetSize)

See Also

Layer Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Size Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Layer..::..Size Property
Layer Class See Also Send Feedback
The size of the layer in device-independent pixels.

(Also see DirectX SDK: ID2D1Layer::GetSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SizeF Size { get; }
Visual Basic
Public ReadOnly Property Size As SizeF
    Get
Visual C++
public:
property SizeF Size {
    SizeF get ();
}

See Also

Layer Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LayerOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerOptions Enumeration
See Also Send Feedback
Specified options that can be applied when a layer resource is applied to create a layer.

(Also see DirectX SDK: D2D1_LAYER_OPTIONS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum LayerOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration LayerOptions
Visual C++
[FlagsAttribute]
public enum class LayerOptions

Members

Member name | Description
None |
InitializeForClearType |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LayerParameters Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters Structure
Members See Also Send Feedback
Contains the content bounds, mask information, opacity settings, and other options for a layer resource.

(Also see DirectX SDK: D2D1_LAYER_PARAMETERS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct LayerParameters
Visual Basic
Public Structure LayerParameters
Visual C++
public value class LayerParameters

See Also

LayerParameters Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LayerParameters Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters Members
LayerParameters Structure Constructors Properties See Also Send Feedback

The LayerParameters type exposes the following members.

Constructors

 | Name | Description
Public method | LayerParameters | Constructor for the LayerParameters value type

Properties

 | Name | Description
Public property | ContentBounds | The rectangular clip that will be applied to the layer. The clip is affected by the world transform. Content outside these bounds is not guaranteed to render.
Public property | GeometricMask | The geometric mask specifies the area of the layer that is composited into the render target.
Public property | MaskAntiAliasMode | A value that specifies the antialiasing mode for the geometricMask.
Public property | MaskTransform | A value that specifies the transform that is applied to the geometric mask when composing the layer.
Public property | Opacity | An opacity value that is applied uniformly to all resources in the layer when compositing to the target.
Public property | OpacityBrush | A brush that is used to modify the opacity of the layer. The brush is mapped to the layer, and the alpha channel of each mapped brush pixel is multiplied against the corresponding layer pixel.
Public property | Options | A value that specifies whether the layer intends to render text with ClearType antialiasing

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LayerParameters Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters Constructor
LayerParameters Structure See Also Send Feedback
Constructor for the LayerParameters value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LayerParameters(
    RectF contentBounds,
    Geometry geometricMask,
    AntiAliasMode maskAntiAliasMode,
    Matrix3x2F maskTransform,
    float opacity,
    Brush opacityBrush,
    LayerOptions layerOptions
)
Visual Basic
Public Sub New ( _
    contentBounds As RectF, _
    geometricMask As Geometry, _
    maskAntiAliasMode As AntiAliasMode, _
    maskTransform As Matrix3x2F, _
    opacity As Single, _
    opacityBrush As Brush, _
    layerOptions As LayerOptions _
)
Visual C++
public:
LayerParameters(
    RectF contentBounds,
    Geometry^ geometricMask,
    AntiAliasMode maskAntiAliasMode,
    Matrix3x2F maskTransform,
    float opacity,
    Brush^ opacityBrush,
    LayerOptions layerOptions
)

Parameters

contentBounds
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
Initializes the ContentBounds property.
geometricMask
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
Initializes the GeometricMask property.
maskAntiAliasMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..AntiAliasMode
Initializes the MaskAntiAliasMode property.
maskTransform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
Initializes the MaskTransform property.
opacity
Type: System..::..Single
Initializes the Opacity property.
opacityBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
Initializes the OpacityBrush property.
layerOptions
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LayerOptions
Initializes the LayerOptions property.

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LayerParameters Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters Properties
LayerParameters Structure See Also Send Feedback

The LayerParameters type exposes the following members.

Properties

 | Name | Description
Public property | ContentBounds | The rectangular clip that will be applied to the layer. The clip is affected by the world transform. Content outside these bounds is not guaranteed to render.
Public property | GeometricMask | The geometric mask specifies the area of the layer that is composited into the render target.
Public property | MaskAntiAliasMode | A value that specifies the antialiasing mode for the geometricMask.
Public property | MaskTransform | A value that specifies the transform that is applied to the geometric mask when composing the layer.
Public property | Opacity | An opacity value that is applied uniformly to all resources in the layer when compositing to the target.
Public property | OpacityBrush | A brush that is used to modify the opacity of the layer. The brush is mapped to the layer, and the alpha channel of each mapped brush pixel is multiplied against the corresponding layer pixel.
Public property | Options | A value that specifies whether the layer intends to render text with ClearType antialiasing

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ContentBounds Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters..::..ContentBounds Property
LayerParameters Structure See Also Send Feedback
The rectangular clip that will be applied to the layer. The clip is affected by the world transform. Content outside these bounds is not guaranteed to render.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectF ContentBounds { get; set; }
Visual Basic
Public Property ContentBounds As RectF
    Get
    Set
Visual C++
public:
property RectF ContentBounds {
    RectF get ();
    void set (RectF value);
}

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GeometricMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters..::..GeometricMask Property
LayerParameters Structure See Also Send Feedback
The geometric mask specifies the area of the layer that is composited into the render target.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Geometry GeometricMask { get; set; }
Visual Basic
Public Property GeometricMask As Geometry
    Get
    Set
Visual C++
public:
property Geometry^ GeometricMask {
    Geometry^ get ();
    void set (Geometry^ value);
}

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


MaskAntiAliasMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters..::..MaskAntiAliasMode Property
LayerParameters Structure See Also Send Feedback
A value that specifies the antialiasing mode for the geometricMask.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public AntiAliasMode MaskAntiAliasMode { get; set; }
Visual Basic
Public Property MaskAntiAliasMode As AntiAliasMode
    Get
    Set
Visual C++
public:
property AntiAliasMode MaskAntiAliasMode {
    AntiAliasMode get ();
    void set (AntiAliasMode value);
}

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


MaskTransform Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters..::..MaskTransform Property
LayerParameters Structure See Also Send Feedback
A value that specifies the transform that is applied to the geometric mask when composing the layer.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix3x2F MaskTransform { get; set; }
Visual Basic
Public Property MaskTransform As Matrix3x2F
    Get
    Set
Visual C++
public:
property Matrix3x2F MaskTransform {
    Matrix3x2F get ();
    void set (Matrix3x2F value);
}

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Opacity Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters..::..Opacity Property
LayerParameters Structure See Also Send Feedback
An opacity value that is applied uniformly to all resources in the layer when compositing to the target.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Opacity { get; set; }
Visual Basic
Public Property Opacity As Single
    Get
    Set
Visual C++
public:
property float Opacity {
    float get ();
    void set (float value);
}

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


OpacityBrush Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters..::..OpacityBrush Property
LayerParameters Structure See Also Send Feedback
A brush that is used to modify the opacity of the layer. The brush is mapped to the layer, and the alpha channel of each mapped brush pixel is multiplied against the corresponding layer pixel.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Brush OpacityBrush { get; set; }
Visual Basic
Public Property OpacityBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ OpacityBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Options Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LayerParameters..::..Options Property
LayerParameters Structure See Also Send Feedback
A value that specifies whether the layer intends to render text with ClearType antialiasing

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LayerOptions Options { get; set; }
Visual Basic
Public Property Options As LayerOptions
    Get
    Set
Visual C++
public:
property LayerOptions Options {
    LayerOptions get ();
    void set (LayerOptions value);
}

See Also

LayerParameters Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LinearGradientBrush Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrush Class
Members See Also Send Feedback
Paints an area with a linear gradient.

(Also see DirectX SDK: ID2D1LinearGradientBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class LinearGradientBrush : Brush
Visual Basic
Public Class LinearGradientBrush _
    Inherits Brush
Visual C++
public ref class LinearGradientBrush : public Brush

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LinearGradientBrush

See Also

LinearGradientBrush Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LinearGradientBrush Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrush Members
LinearGradientBrush Class Properties See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | EndPoint | The end point of the gradient in local coordinate space. This is not influenced by the geometry being filled. (Also see DirectX SDK: ID2D1LinearGradientBrush::GetEndPoint, ID2D1LinearGradientBrush::SetEndPoint)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GradientStops | Retrieves the GradientStopCollection associated with this linear gradient brush. (Also see DirectX SDK: ID2D1LinearGradientBrush::GetGradientStopCollection)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity) (Inherited from Brush.)
Public property | StartPoint | The start point of the gradient in local coordinate space. (Also see DirectX SDK: ID2D1LinearGradientBrush::GetStartPoint, ID2D1LinearGradientBrush::SetStartPoint)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform) (Inherited from Brush.)

See Also

LinearGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LinearGradientBrush Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrush Properties
LinearGradientBrush Class See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | EndPoint | The end point of the gradient in local coordinate space. This is not influenced by the geometry being filled. (Also see DirectX SDK: ID2D1LinearGradientBrush::GetEndPoint, ID2D1LinearGradientBrush::SetEndPoint)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GradientStops | Retrieves the GradientStopCollection associated with this linear gradient brush. (Also see DirectX SDK: ID2D1LinearGradientBrush::GetGradientStopCollection)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity) (Inherited from Brush.)
Public property | StartPoint | The start point of the gradient in local coordinate space. (Also see DirectX SDK: ID2D1LinearGradientBrush::GetStartPoint, ID2D1LinearGradientBrush::SetStartPoint)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform) (Inherited from Brush.)

See Also

LinearGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EndPoint Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrush..::..EndPoint Property
LinearGradientBrush Class See Also Send Feedback
The end point of the gradient in local coordinate space. This is not influenced by the geometry being filled.

(Also see DirectX SDK: ID2D1LinearGradientBrush::GetEndPoint, ID2D1LinearGradientBrush::SetEndPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F EndPoint { get; set; }
Visual Basic
Public Property EndPoint As Point2F
    Get
    Set
Visual C++
public:
property Point2F EndPoint {
    Point2F get ();
    void set (Point2F value);
}

See Also

LinearGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStops Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrush..::..GradientStops Property
LinearGradientBrush Class See Also Send Feedback
Retrieves the GradientStopCollection associated with this linear gradient brush.

(Also see DirectX SDK: ID2D1LinearGradientBrush::GetGradientStopCollection)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GradientStopCollection GradientStops { get; }
Visual Basic
Public ReadOnly Property GradientStops As GradientStopCollection
    Get
Visual C++
public:
property GradientStopCollection^ GradientStops {
    GradientStopCollection^ get ();
}

Return Value

GradientStopCollection

See Also

LinearGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StartPoint Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrush..::..StartPoint Property
LinearGradientBrush Class See Also Send Feedback
The start point of the gradient in local coordinate space.

(Also see DirectX SDK: ID2D1LinearGradientBrush::GetStartPoint, ID2D1LinearGradientBrush::SetStartPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F StartPoint { get; set; }
Visual Basic
Public Property StartPoint As Point2F
    Get
    Set
Visual C++
public:
property Point2F StartPoint {
    Point2F get ();
    void set (Point2F value);
}

See Also

LinearGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LinearGradientBrushProperties Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties Structure
Members See Also Send Feedback
Contains the starting point and endpoint of the gradient axis for a LinearGradientBrush.

(Also see DirectX SDK: D2D1_LINEAR_GRADIENT_BRUSH_PROPERTIES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct LinearGradientBrushProperties
Visual Basic
Public Structure LinearGradientBrushProperties
Visual C++
public value class LinearGradientBrushProperties

See Also

LinearGradientBrushProperties Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LinearGradientBrushProperties Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties Members
LinearGradientBrushProperties Structure Constructors Methods Operators Properties See Also Send Feedback

The LinearGradientBrushProperties type exposes the following members.

Constructors

 | Name | Description
Public method | LinearGradientBrushProperties | Constructor for the LinearGradientBrushProperties value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | EndPoint | In the brush's coordinate space, the endpoint of the gradient axis.
Public property | StartPoint | In the brush's coordinate space, the starting point of the gradient axis.

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LinearGradientBrushProperties Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties Constructor
LinearGradientBrushProperties Structure See Also Send Feedback
Constructor for the LinearGradientBrushProperties value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LinearGradientBrushProperties(
    Point2F startPoint,
    Point2F endPoint
)
Visual Basic
Public Sub New ( _
    startPoint As Point2F, _
    endPoint As Point2F _
)
Visual C++
public:
LinearGradientBrushProperties(
    Point2F startPoint,
    Point2F endPoint
)

Parameters

startPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the StartPoint property.
endPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the EndPoint property.

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LinearGradientBrushProperties Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties Methods
LinearGradientBrushProperties Structure See Also Send Feedback

The LinearGradientBrushProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties..::..Equals Method
LinearGradientBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties..::..GetHashCode Method
LinearGradientBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LinearGradientBrushProperties Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties Operators
LinearGradientBrushProperties Structure See Also Send Feedback

The LinearGradientBrushProperties type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties..::..Equality Operator
LinearGradientBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    LinearGradientBrushProperties linearGradientBrushProperties1,
    LinearGradientBrushProperties linearGradientBrushProperties2
)
Visual Basic
Public Shared Operator = ( _
    linearGradientBrushProperties1 As LinearGradientBrushProperties, _
    linearGradientBrushProperties2 As LinearGradientBrushProperties _
) As Boolean
Visual C++
public:
static bool operator ==(
    LinearGradientBrushProperties linearGradientBrushProperties1,
    LinearGradientBrushProperties linearGradientBrushProperties2
)

Parameters

linearGradientBrushProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LinearGradientBrushProperties
linearGradientBrushProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LinearGradientBrushProperties

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties..::..Inequality Operator
LinearGradientBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    LinearGradientBrushProperties linearGradientBrushProperties1,
    LinearGradientBrushProperties linearGradientBrushProperties2
)
Visual Basic
Public Shared Operator <> ( _
    linearGradientBrushProperties1 As LinearGradientBrushProperties, _
    linearGradientBrushProperties2 As LinearGradientBrushProperties _
) As Boolean
Visual C++
public:
static bool operator !=(
    LinearGradientBrushProperties linearGradientBrushProperties1,
    LinearGradientBrushProperties linearGradientBrushProperties2
)

Parameters

linearGradientBrushProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LinearGradientBrushProperties
linearGradientBrushProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LinearGradientBrushProperties

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LinearGradientBrushProperties Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties Properties
LinearGradientBrushProperties Structure See Also Send Feedback

The LinearGradientBrushProperties type exposes the following members.

Properties

 | Name | Description
Public property | EndPoint | In the brush's coordinate space, the endpoint of the gradient axis.
Public property | StartPoint | In the brush's coordinate space, the starting point of the gradient axis.

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EndPoint Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties..::..EndPoint Property
LinearGradientBrushProperties Structure See Also Send Feedback
In the brush's coordinate space, the endpoint of the gradient axis.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F EndPoint { get; set; }
Visual Basic
Public Property EndPoint As Point2F
    Get
    Set
Visual C++
public:
property Point2F EndPoint {
    Point2F get ();
    void set (Point2F value);
}

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StartPoint Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LinearGradientBrushProperties..::..StartPoint Property
LinearGradientBrushProperties Structure See Also Send Feedback
In the brush's coordinate space, the starting point of the gradient axis.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F StartPoint { get; set; }
Visual Basic
Public Property StartPoint As Point2F
    Get
    Set
Visual C++
public:
property Point2F StartPoint {
    Point2F get ();
    void set (Point2F value);
}

See Also

LinearGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LineJoin Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineJoin Enumeration
See Also Send Feedback
Describes the shape that joins two lines or segments.

(Also see DirectX SDK: D2D1_LINE_JOIN)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum LineJoin
Visual Basic
Public Enumeration LineJoin
Visual C++
public enum class LineJoin

Members

Member name | Description
MiterOrBevel |
Bevel |
Miter |
Round |

Remarks

A miter limit affects how sharp miter joins are allowed to be. If the line join style MiterOrBevel, then the join will be mitered with regular angular vertices if it doesn't extend beyond the miter limit; otherwise, the line join will be beveled.

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Matrix3x2F Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F Structure
Members See Also Send Feedback
Represents a 3-by-2 matrix.

(Also see DirectX SDK: D2D1_MATRIX_3X2_F)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Matrix3x2F
Visual Basic
Public Structure Matrix3x2F
Visual C++
public value class Matrix3x2F

See Also

Matrix3x2F Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Matrix3x2F Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F Members
Matrix3x2F Structure Constructors Methods Operators Properties See Also Send Feedback

The Matrix3x2F type exposes the following members.

Constructors

 | Name | Description
Public method | Matrix3x2F | Constructor for the Matrix3x2F value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
 | Rotation(Single) | Creates a rotation transformation that has the specified angle and rotates around Point (0, 0).
 | Rotation(Single, Point2F) | Creates a rotation transformation that has the specified angle and center point.
 | Scale(SizeF) | Creates a scale transformation that has the specified scale factors at point (0, 0).
 | Scale(Single, Single) | Creates a scale transformation that has the specified scale factors at point (0, 0).
 | Scale(SizeF, Point2F) | Creates a scale transformation that has the specified scale factors and center point.
 | Scale(Single, Single, Point2F) | Creates a scale transformation that has the specified scale factors and center point.
 | Skew(Single, Single) | Creates a skew transformation that has the specified x-axis and y-axis values at point (0, 0).
 | Skew(Single, Single, Point2F) | Creates a skew transformation that has the specified x-axis and y-axis values and center point.
 | Translation(SizeF) | Creates a translation transformation that has the specified displacement.
 | Translation(Single, Single) | Creates a translation transformation that has the specified x and y displacements.

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
 | Identity | The Idenitity Matrix
Public property | IsIdentity | Indicates whether this matrix is the identity matrix.
Public property | M11 | The value in the first row and first column of the matrix.
Public property | M12 | The value in the first row and second column of the matrix.
Public property | M21 | The value in the second row and first column of the matrix.
Public property | M22 | The value in the second row and second column of the matrix.
Public property | M31 | The value in the third row and first column of the matrix.
Public property | M32 | The value in the third row and second column of the matrix.

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Matrix3x2F Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F Constructor
Matrix3x2F Structure See Also Send Feedback
Constructor for the Matrix3x2F value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix3x2F(
    float m11,
    float m12,
    float m21,
    float m22,
    float m31,
    float m32
)
Visual Basic
Public Sub New ( _
    m11 As Single, _
    m12 As Single, _
    m21 As Single, _
    m22 As Single, _
    m31 As Single, _
    m32 As Single _
)
Visual C++
public:
Matrix3x2F(
    float m11,
    float m12,
    float m21,
    float m22,
    float m31,
    float m32
)

Parameters

m11
Type: System..::..Single
Initializes the _11 property.
m12
Type: System..::..Single
Initializes the _12 property.
m21
Type: System..::..Single
Initializes the _21 property.
m22
Type: System..::..Single
Initializes the _22 property.
m31
Type: System..::..Single
Initializes the _31 property.
m32
Type: System..::..Single
Initializes the _32 property.

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Matrix3x2F Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F Methods
Matrix3x2F Structure See Also Send Feedback

The Matrix3x2F type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
 | Rotation(Single) | Creates a rotation transformation that has the specified angle and rotates around Point (0, 0).
 | Rotation(Single, Point2F) | Creates a rotation transformation that has the specified angle and center point.
 | Scale(SizeF) | Creates a scale transformation that has the specified scale factors at point (0, 0).
 | Scale(Single, Single) | Creates a scale transformation that has the specified scale factors at point (0, 0).
 | Scale(SizeF, Point2F) | Creates a scale transformation that has the specified scale factors and center point.
 | Scale(Single, Single, Point2F) | Creates a scale transformation that has the specified scale factors and center point.
 | Skew(Single, Single) | Creates a skew transformation that has the specified x-axis and y-axis values at point (0, 0).
 | Skew(Single, Single, Point2F) | Creates a skew transformation that has the specified x-axis and y-axis values and center point.
 | Translation(SizeF) | Creates a translation transformation that has the specified displacement.
 | Translation(Single, Single) | Creates a translation transformation that has the specified x and y displacements.

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Equals Method
Matrix3x2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..GetHashCode Method
Matrix3x2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rotation Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Rotation Method
Matrix3x2F Structure See Also Send Feedback

Overload List

Name | Description
Rotation(Single) | Creates a rotation transformation that has the specified angle and rotates around Point (0, 0).
Rotation(Single, Point2F) | Creates a rotation transformation that has the specified angle and center point.

See Also

Matrix3x2F Structure
Matrix3x2F Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rotation Method (Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Rotation Method (Single)
Matrix3x2F Structure See Also Send Feedback
Creates a rotation transformation that has the specified angle and rotates around Point (0, 0).

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Rotation(
    float angle
)
Visual Basic
Public Shared Function Rotation ( _
    angle As Single _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Rotation(
    float angle
)

Parameters

angle
Type: System..::..Single
The rotation angle in degrees. A positive angle creates a clockwise rotation, and a negative angle creates a counterclockwise rotation.

Return Value

The new rotation transformation.

See Also

Matrix3x2F Structure
Rotation Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rotation Method (Single, Point2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Rotation Method (Single, Point2F)
Matrix3x2F Structure See Also Send Feedback
Creates a rotation transformation that has the specified angle and center point.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Rotation(
    float angle,
    Point2F center
)
Visual Basic
Public Shared Function Rotation ( _
    angle As Single, _
    center As Point2F _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Rotation(
    float angle,
    Point2F center
)

Parameters

angle
Type: System..::..Single
The rotation angle in degrees. A positive angle creates a clockwise rotation, and a negative angle creates a counterclockwise rotation.
center
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point about which the rotation is performed.

Return Value

The new rotation transformation.

See Also

Matrix3x2F Structure
Rotation Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Scale Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Scale Method
Matrix3x2F Structure See Also Send Feedback

Overload List

Name | Description
Scale(SizeF) | Creates a scale transformation that has the specified scale factors at point (0, 0).
Scale(Single, Single) | Creates a scale transformation that has the specified scale factors at point (0, 0).
Scale(SizeF, Point2F) | Creates a scale transformation that has the specified scale factors and center point.
Scale(Single, Single, Point2F) | Creates a scale transformation that has the specified scale factors and center point.

See Also

Matrix3x2F Structure
Matrix3x2F Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Scale Method (SizeF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Scale Method (SizeF)
Matrix3x2F Structure See Also Send Feedback
Creates a scale transformation that has the specified scale factors at point (0, 0).

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Scale(
    SizeF size
)
Visual Basic
Public Shared Function Scale ( _
    size As SizeF _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Scale(
    SizeF size
)

Parameters

size
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
Contains the x and y factors of scale transformation.

Return Value

The new scale transformation.

See Also

Matrix3x2F Structure
Scale Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Scale Method (Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Scale Method (Single, Single)
Matrix3x2F Structure See Also Send Feedback
Creates a scale transformation that has the specified scale factors at point (0, 0).

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Scale(
    float x,
    float y
)
Visual Basic
Public Shared Function Scale ( _
    x As Single, _
    y As Single _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Scale(
    float x,
    float y
)

Parameters

x
Type: System..::..Single
The x-axis scale factor of the scale transformation.
y
Type: System..::..Single
The y-axis scale factor of the scale transformation.

Return Value

The new scale transformation.

See Also

Matrix3x2F Structure
Scale Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Scale Method (SizeF, Point2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Scale Method (SizeF, Point2F)
Matrix3x2F Structure See Also Send Feedback
Creates a scale transformation that has the specified scale factors and center point.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Scale(
    SizeF size,
    Point2F center
)
Visual Basic
Public Shared Function Scale ( _
    size As SizeF, _
    center As Point2F _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Scale(
    SizeF size,
    Point2F center
)

Parameters

size
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
Contains the x and y factors of scale transformation.
center
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point about which the scale is performed.

Return Value

The new scale transformation.

See Also

Matrix3x2F Structure
Scale Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Scale Method (Single, Single, Point2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Scale Method (Single, Single, Point2F)
Matrix3x2F Structure See Also Send Feedback
Creates a scale transformation that has the specified scale factors and center point.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Scale(
    float x,
    float y,
    Point2F center
)
Visual Basic
Public Shared Function Scale ( _
    x As Single, _
    y As Single, _
    center As Point2F _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Scale(
    float x,
    float y,
    Point2F center
)

Parameters

x
Type: System..::..Single
The x-axis scale factor of the scale transformation.
y
Type: System..::..Single
The y-axis scale factor of the scale transformation.
center
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point about which the scale is performed.

Return Value

The new scale transformation.

See Also

Matrix3x2F Structure
Scale Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Skew Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Skew Method
Matrix3x2F Structure See Also Send Feedback

Overload List

Name | Description
Skew(Single, Single) | Creates a skew transformation that has the specified x-axis and y-axis values at point (0, 0).
Skew(Single, Single, Point2F) | Creates a skew transformation that has the specified x-axis and y-axis values and center point.

See Also

Matrix3x2F Structure
Matrix3x2F Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Skew Method (Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Skew Method (Single, Single)
Matrix3x2F Structure See Also Send Feedback
Creates a skew transformation that has the specified x-axis and y-axis values at point (0, 0).

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Skew(
    float angleX,
    float angleY
)
Visual Basic
Public Shared Function Skew ( _
    angleX As Single, _
    angleY As Single _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Skew(
    float angleX,
    float angleY
)

Parameters

angleX
Type: System..::..Single
The x-axis skew angle, which is measured in degrees counterclockwise from the y-axis.
angleY
Type: System..::..Single
The y-axis skew angle, which is measured in degrees clockwise from the x-axis.

Return Value

The new skew transformation.

See Also

Matrix3x2F Structure
Skew Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Skew Method (Single, Single, Point2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Skew Method (Single, Single, Point2F)
Matrix3x2F Structure See Also Send Feedback
Creates a skew transformation that has the specified x-axis and y-axis values and center point.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Skew(
    float angleX,
    float angleY,
    Point2F center
)
Visual Basic
Public Shared Function Skew ( _
    angleX As Single, _
    angleY As Single, _
    center As Point2F _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Skew(
    float angleX,
    float angleY,
    Point2F center
)

Parameters

angleX
Type: System..::..Single
The x-axis skew angle, which is measured in degrees counterclockwise from the y-axis.
angleY
Type: System..::..Single
The y-axis skew angle, which is measured in degrees clockwise from the x-axis.
center
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point about which the skew is performed.

Return Value

The new skew transformation.

See Also

Matrix3x2F Structure
Skew Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Translation Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Translation Method
Matrix3x2F Structure See Also Send Feedback

Overload List

Name | Description
Translation(SizeF) | Creates a translation transformation that has the specified displacement.
Translation(Single, Single) | Creates a translation transformation that has the specified x and y displacements.

See Also

Matrix3x2F Structure
Matrix3x2F Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Translation Method (SizeF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Translation Method (SizeF)
Matrix3x2F Structure See Also Send Feedback
Creates a translation transformation that has the specified displacement.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Translation(
    SizeF size
)
Visual Basic
Public Shared Function Translation ( _
    size As SizeF _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Translation(
    SizeF size
)

Parameters

size
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
Contains the x and y displacements.

Return Value

A transformation matrix that translates an object the specified horizontal and vertical distance.

See Also

Matrix3x2F Structure
Translation Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Translation Method (Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Translation Method (Single, Single)
Matrix3x2F Structure See Also Send Feedback
Creates a translation transformation that has the specified x and y displacements.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Translation(
    float x,
    float y
)
Visual Basic
Public Shared Function Translation ( _
    x As Single, _
    y As Single _
) As Matrix3x2F
Visual C++
public:
static Matrix3x2F Translation(
    float x,
    float y
)

Parameters

x
Type: System..::..Single
The distance to translate along the x-axis.
y
Type: System..::..Single
The distance to translate along the y-axis.

Return Value

A transformation matrix that translates an object the specified horizontal and vertical distance.

See Also

Matrix3x2F Structure
Translation Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Matrix3x2F Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F Operators
Matrix3x2F Structure See Also Send Feedback

The Matrix3x2F type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Equality Operator
Matrix3x2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Matrix3x2F matrix1,
    Matrix3x2F matrix2
)
Visual Basic
Public Shared Operator = ( _
    matrix1 As Matrix3x2F, _
    matrix2 As Matrix3x2F _
) As Boolean
Visual C++
public:
static bool operator ==(
    Matrix3x2F matrix1,
    Matrix3x2F matrix2
)

Parameters

matrix1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
matrix2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Inequality Operator
Matrix3x2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Matrix3x2F matrix1,
    Matrix3x2F matrix2
)
Visual Basic
Public Shared Operator <> ( _
    matrix1 As Matrix3x2F, _
    matrix2 As Matrix3x2F _
) As Boolean
Visual C++
public:
static bool operator !=(
    Matrix3x2F matrix1,
    Matrix3x2F matrix2
)

Parameters

matrix1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
matrix2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Matrix3x2F Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F Properties
Matrix3x2F Structure See Also Send Feedback

The Matrix3x2F type exposes the following members.

Properties

 | Name | Description
 | Identity | The Idenitity Matrix
Public property | IsIdentity | Indicates whether this matrix is the identity matrix.
Public property | M11 | The value in the first row and first column of the matrix.
Public property | M12 | The value in the first row and second column of the matrix.
Public property | M21 | The value in the second row and first column of the matrix.
Public property | M22 | The value in the second row and second column of the matrix.
Public property | M31 | The value in the third row and first column of the matrix.
Public property | M32 | The value in the third row and second column of the matrix.

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Identity Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..Identity Property
Matrix3x2F Structure See Also Send Feedback
The Idenitity Matrix

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix3x2F Identity { get; }
Visual Basic
Public Shared ReadOnly Property Identity As Matrix3x2F
    Get
Visual C++
public:
static property Matrix3x2F Identity {
    Matrix3x2F get ();
}

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IsIdentity Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..IsIdentity Property
Matrix3x2F Structure See Also Send Feedback
Indicates whether this matrix is the identity matrix.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsIdentity { get; }
Visual Basic
Public ReadOnly Property IsIdentity As Boolean
    Get
Visual C++
public:
property bool IsIdentity {
    bool get ();
}

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


M11 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..M11 Property
Matrix3x2F Structure See Also Send Feedback
The value in the first row and first column of the matrix.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M11 { get; set; }
Visual Basic
Public Property M11 As Single
    Get
    Set
Visual C++
public:
property float M11 {
    float get ();
    void set (float value);
}

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


M12 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..M12 Property
Matrix3x2F Structure See Also Send Feedback
The value in the first row and second column of the matrix.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M12 { get; set; }
Visual Basic
Public Property M12 As Single
    Get
    Set
Visual C++
public:
property float M12 {
    float get ();
    void set (float value);
}

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


M21 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..M21 Property
Matrix3x2F Structure See Also Send Feedback
The value in the second row and first column of the matrix.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M21 { get; set; }
Visual Basic
Public Property M21 As Single
    Get
    Set
Visual C++
public:
property float M21 {
    float get ();
    void set (float value);
}

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


M22 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..M22 Property
Matrix3x2F Structure See Also Send Feedback
The value in the second row and second column of the matrix.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M22 { get; set; }
Visual Basic
Public Property M22 As Single
    Get
    Set
Visual C++
public:
property float M22 {
    float get ();
    void set (float value);
}

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


M31 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..M31 Property
Matrix3x2F Structure See Also Send Feedback
The value in the third row and first column of the matrix.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M31 { get; set; }
Visual Basic
Public Property M31 As Single
    Get
    Set
Visual C++
public:
property float M31 {
    float get ();
    void set (float value);
}

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


M32 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix3x2F..::..M32 Property
Matrix3x2F Structure See Also Send Feedback
The value in the third row and second column of the matrix.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M32 { get; set; }
Visual Basic
Public Property M32 As Single
    Get
    Set
Visual C++
public:
property float M32 {
    float get ();
    void set (float value);
}

See Also

Matrix3x2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Mesh Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Mesh Class
Members See Also Send Feedback
Represents a set of vertices that form a list of triangles.

(Also see DirectX SDK: ID2D1Mesh)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Mesh : D2DResource
Visual Basic
Public Class Mesh _
    Inherits D2DResource
Visual C++
public ref class Mesh : public D2DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Mesh

See Also

Mesh Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Mesh Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Mesh Members
Mesh Class Methods Properties See Also Send Feedback

The Mesh type exposes the following members.

Methods

 | Name | Description
Public method | Open | Opens the mesh for population. (Also see DirectX SDK: ID2D1Mesh::Open)

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Mesh Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Mesh Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Mesh Methods
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Methods

 | Name | Description
Public method | Open | Opens the mesh for population. (Also see DirectX SDK: ID2D1Mesh::Open)

See Also

Mesh Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Open Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Mesh..::..Open Method
Mesh Class See Also Send Feedback
Opens the mesh for population.

(Also see DirectX SDK: ID2D1Mesh::Open)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TessellationSink Open()
Visual Basic
Public Function Open As TessellationSink
Visual C++
public:
TessellationSink^ Open()

Return Value

TessellationSink

See Also

Mesh Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Mesh Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Mesh Properties
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Mesh Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


OpacityMaskContent Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OpacityMaskContent Enumeration
See Also Send Feedback
Describes whether an opacity mask contains graphics or text. Direct2D uses this information to determine which gamma space to use when blending the opacity mask.

(Also see DirectX SDK: D2D1_OPACITY_MASK_CONTENT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum OpacityMaskContent
Visual Basic
Public Enumeration OpacityMaskContent
Visual C++
public enum class OpacityMaskContent

Members

Member name | Description
Graphics |
TextGdiCompatible |
TextNatural |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PathGeometry Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry Class
Members See Also Send Feedback
Represents a complex shape that may be composed of arcs, curves, and lines.

(Also see DirectX SDK: ID2D1PathGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class PathGeometry : Geometry
Visual Basic
Public Class PathGeometry _
    Inherits Geometry
Visual C++
public ref class PathGeometry : public Geometry

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PathGeometry

See Also

PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PathGeometry Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry Members
PathGeometry Class Methods Properties See Also Send Feedback

The PathGeometry type exposes the following members.

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Open | Opens a geometry sink that will be used to create this path geometry. (Also see DirectX SDK: ID2D1PathGeometry::Open)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Stream | Copies the contents of the path geometry to the specified IGeometrySink. (Also see DirectX SDK: ID2D1PathGeometry::Stream)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | FigureCount | The number of figures in the path geometry. (Also see DirectX SDK: ID2D1PathGeometry::GetFigureCount)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SegmentCount | The number of segments in the path geometry. (Also see DirectX SDK: ID2D1PathGeometry::GetSegmentCount)

See Also

PathGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PathGeometry Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry Methods
PathGeometry Class See Also Send Feedback

The PathGeometry type exposes the following members.

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Open | Opens a geometry sink that will be used to create this path geometry. (Also see DirectX SDK: ID2D1PathGeometry::Open)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Stream | Copies the contents of the path geometry to the specified IGeometrySink. (Also see DirectX SDK: ID2D1PathGeometry::Stream)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

PathGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..CombineWithGeometry Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..CompareWithGeometry Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..ComputeArea Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..ComputeLength Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..ComputePointAtLength Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..FillContainsPoint Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..GetBounds Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..GetWidenedBounds Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Open Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..Open Method
PathGeometry Class See Also Send Feedback
Opens a geometry sink that will be used to create this path geometry.

(Also see DirectX SDK: ID2D1PathGeometry::Open)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometrySink Open()
Visual Basic
Public Function Open As GeometrySink
Visual C++
public:
GeometrySink^ Open()

Return Value

Returns the geometry sink that is used to populate the path geometry with figures and segments.

Remarks

Because path geometries are immutable and can only be populated once, it is an error to call Open on a path geometry more than once.

Note that the fill mode defaults to Alternate. To set the fill mode, call SetFillMode before the first call to BeginFigure. Failure to do so will put the geometry sink in an error state.

See Also

PathGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..Outline Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..Simplify Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Stream Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..Stream Method
PathGeometry Class See Also Send Feedback
Copies the contents of the path geometry to the specified IGeometrySink.

(Also see DirectX SDK: ID2D1PathGeometry::Stream)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Stream(
    IGeometrySink geometrySink
)
Visual Basic
Public Sub Stream ( _
    geometrySink As IGeometrySink _
)
Visual C++
public:
void Stream(
    IGeometrySink^ geometrySink
)

Parameters

geometrySink
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..IGeometrySink
The sink to which the path geometry's contents are copied. Modifying this sink does not change the contents of this path geometry.

See Also

PathGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..StrokeContainsPoint Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..Tessellate Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..Widen Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

PathGeometry Class
PathGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PathGeometry Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry Properties
PathGeometry Class See Also Send Feedback

The PathGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | FigureCount | The number of figures in the path geometry. (Also see DirectX SDK: ID2D1PathGeometry::GetFigureCount)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SegmentCount | The number of segments in the path geometry. (Also see DirectX SDK: ID2D1PathGeometry::GetSegmentCount)

See Also

PathGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FigureCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..FigureCount Property
PathGeometry Class See Also Send Feedback
The number of figures in the path geometry.

(Also see DirectX SDK: ID2D1PathGeometry::GetFigureCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FigureCount { get; }
Visual Basic
Public ReadOnly Property FigureCount As UInteger
    Get
Visual C++
public:
property unsigned int FigureCount {
    unsigned int get ();
}

See Also

PathGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SegmentCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathGeometry..::..SegmentCount Property
PathGeometry Class See Also Send Feedback
The number of segments in the path geometry.

(Also see DirectX SDK: ID2D1PathGeometry::GetSegmentCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SegmentCount { get; }
Visual Basic
Public ReadOnly Property SegmentCount As UInteger
    Get
Visual C++
public:
property unsigned int SegmentCount {
    unsigned int get ();
}

See Also

PathGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PathSegmentOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PathSegmentOptions Enumeration
See Also Send Feedback
Indicates whether the given segment should be stroked, or, if the join between this segment and the previous one should be smooth.

(Also see DirectX SDK: D2D1_PATH_SEGMENT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum PathSegmentOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration PathSegmentOptions
Visual C++
[FlagsAttribute]
public enum class PathSegmentOptions

Members

Member name | Description
None |
ForceRoundLineJoin |
ForceUnstroked |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat Structure
Members See Also Send Feedback
Contains the data format and alpha mode for a bitmap or render target.

(Also see DirectX SDK: D2D1_PIXEL_FORMAT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct PixelFormat
Visual Basic
Public Structure PixelFormat
Visual C++
public value class PixelFormat

See Also

PixelFormat Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat Members
PixelFormat Structure Constructors Methods Operators Properties See Also Send Feedback

The PixelFormat type exposes the following members.

Constructors

 | Name | Description
Public method | PixelFormat | Constructor for the PixelFormat value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AlphaMode | A value that specifies whether the alpha channel is using pre-multiplied alpha, straight alpha, whether it should be ignored and considered opaque, or whether it is unknown.
Public property | Format | A value that specifies the size and arrangement of channels in each pixel.

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat Constructor
PixelFormat Structure See Also Send Feedback
Constructor for the PixelFormat value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelFormat(
    Format format,
    AlphaMode alphaMode
)
Visual Basic
Public Sub New ( _
    format As Format, _
    alphaMode As AlphaMode _
)
Visual C++
public:
PixelFormat(
    Format format,
    AlphaMode alphaMode
)

Parameters

format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
Initializes the Format property.
alphaMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..AlphaMode
Initializes the AlphaMode property.

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat Methods
PixelFormat Structure See Also Send Feedback

The PixelFormat type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat..::..Equals Method
PixelFormat Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat..::..GetHashCode Method
PixelFormat Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat Operators
PixelFormat Structure See Also Send Feedback

The PixelFormat type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat..::..Equality Operator
PixelFormat Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    PixelFormat pixelFormat1,
    PixelFormat pixelFormat2
)
Visual Basic
Public Shared Operator = ( _
    pixelFormat1 As PixelFormat, _
    pixelFormat2 As PixelFormat _
) As Boolean
Visual C++
public:
static bool operator ==(
    PixelFormat pixelFormat1,
    PixelFormat pixelFormat2
)

Parameters

pixelFormat1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat
pixelFormat2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat..::..Inequality Operator
PixelFormat Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    PixelFormat pixelFormat1,
    PixelFormat pixelFormat2
)
Visual Basic
Public Shared Operator <> ( _
    pixelFormat1 As PixelFormat, _
    pixelFormat2 As PixelFormat _
) As Boolean
Visual C++
public:
static bool operator !=(
    PixelFormat pixelFormat1,
    PixelFormat pixelFormat2
)

Parameters

pixelFormat1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat
pixelFormat2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat Properties
PixelFormat Structure See Also Send Feedback

The PixelFormat type exposes the following members.

Properties

 | Name | Description
Public property | AlphaMode | A value that specifies whether the alpha channel is using pre-multiplied alpha, straight alpha, whether it should be ignored and considered opaque, or whether it is unknown.
Public property | Format | A value that specifies the size and arrangement of channels in each pixel.

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AlphaMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat..::..AlphaMode Property
PixelFormat Structure See Also Send Feedback
A value that specifies whether the alpha channel is using pre-multiplied alpha, straight alpha, whether it should be ignored and considered opaque, or whether it is unknown.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public AlphaMode AlphaMode { get; set; }
Visual Basic
Public Property AlphaMode As AlphaMode
    Get
    Set
Visual C++
public:
property AlphaMode AlphaMode {
    AlphaMode get ();
    void set (AlphaMode value);
}

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormat..::..Format Property
PixelFormat Structure See Also Send Feedback
A value that specifies the size and arrangement of channels in each pixel.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

PixelFormat Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2F Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F Structure
Members See Also Send Feedback
Represents an x-coordinate and y-coordinate pair, expressed as floating-point values, in two-dimensional space.

(Also see DirectX SDK: D2D1_POINT_2F)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Point2F
Visual Basic
Public Structure Point2F
Visual C++
public value class Point2F

See Also

Point2F Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2F Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F Members
Point2F Structure Constructors Methods Operators Properties See Also Send Feedback

The Point2F type exposes the following members.

Constructors

 | Name | Description
Public method | Point2F | Constructor for the Point2F value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | X | The x-coordinate of the point.
Public property | Y | The y-coordinate of the point.

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2F Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F Constructor
Point2F Structure See Also Send Feedback
Constructor for the Point2F value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F(
    float x,
    float y
)
Visual Basic
Public Sub New ( _
    x As Single, _
    y As Single _
)
Visual C++
public:
Point2F(
    float x,
    float y
)

Parameters

x
Type: System..::..Single
Initializes the X property.
y
Type: System..::..Single
Initializes the Y property.

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2F Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F Methods
Point2F Structure See Also Send Feedback

The Point2F type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F..::..Equals Method
Point2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F..::..GetHashCode Method
Point2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2F Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F Operators
Point2F Structure See Also Send Feedback

The Point2F type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F..::..Equality Operator
Point2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Point2F point1,
    Point2F point2
)
Visual Basic
Public Shared Operator = ( _
    point1 As Point2F, _
    point2 As Point2F _
) As Boolean
Visual C++
public:
static bool operator ==(
    Point2F point1,
    Point2F point2
)

Parameters

point1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
point2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F..::..Inequality Operator
Point2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Point2F point1,
    Point2F point2
)
Visual Basic
Public Shared Operator <> ( _
    point1 As Point2F, _
    point2 As Point2F _
) As Boolean
Visual C++
public:
static bool operator !=(
    Point2F point1,
    Point2F point2
)

Parameters

point1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
point2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2F Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F Properties
Point2F Structure See Also Send Feedback

The Point2F type exposes the following members.

Properties

 | Name | Description
Public property | X | The x-coordinate of the point.
Public property | Y | The y-coordinate of the point.

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


X Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F..::..X Property
Point2F Structure See Also Send Feedback
The x-coordinate of the point.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float X { get; set; }
Visual Basic
Public Property X As Single
    Get
    Set
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Y Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2F..::..Y Property
Point2F Structure See Also Send Feedback
The y-coordinate of the point.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Y { get; set; }
Visual Basic
Public Property Y As Single
    Get
    Set
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

Point2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2U Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U Structure
Members See Also Send Feedback
Represents an x-coordinate and y-coordinate pair, expressed as an unsigned 32-bit integer value, in two-dimensional space.

(Also see DirectX SDK: D2D1_POINT_2U)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Point2U
Visual Basic
Public Structure Point2U
Visual C++
public value class Point2U

See Also

Point2U Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2U Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U Members
Point2U Structure Constructors Methods Operators Properties See Also Send Feedback

The Point2U type exposes the following members.

Constructors

 | Name | Description
Public method | Point2U | Constructor for the Point2U value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | X | The x-coordinate value of the point.
Public property | Y | The y-coordinate value of the point.

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2U Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U Constructor
Point2U Structure See Also Send Feedback
Constructor for the Point2U value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2U(
    uint x,
    uint y
)
Visual Basic
Public Sub New ( _
    x As UInteger, _
    y As UInteger _
)
Visual C++
public:
Point2U(
    unsigned int x,
    unsigned int y
)

Parameters

x
Type: System..::..UInt32
Initializes the X property.
y
Type: System..::..UInt32
Initializes the Y property.

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2U Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U Methods
Point2U Structure See Also Send Feedback

The Point2U type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U..::..Equals Method
Point2U Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U..::..GetHashCode Method
Point2U Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2U Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U Operators
Point2U Structure See Also Send Feedback

The Point2U type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U..::..Equality Operator
Point2U Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Point2U point1,
    Point2U point2
)
Visual Basic
Public Shared Operator = ( _
    point1 As Point2U, _
    point2 As Point2U _
) As Boolean
Visual C++
public:
static bool operator ==(
    Point2U point1,
    Point2U point2
)

Parameters

point1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2U
point2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2U

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U..::..Inequality Operator
Point2U Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Point2U point1,
    Point2U point2
)
Visual Basic
Public Shared Operator <> ( _
    point1 As Point2U, _
    point2 As Point2U _
) As Boolean
Visual C++
public:
static bool operator !=(
    Point2U point1,
    Point2U point2
)

Parameters

point1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2U
point2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2U

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2U Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U Properties
Point2U Structure See Also Send Feedback

The Point2U type exposes the following members.

Properties

 | Name | Description
Public property | X | The x-coordinate value of the point.
Public property | Y | The y-coordinate value of the point.

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


X Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U..::..X Property
Point2U Structure See Also Send Feedback
The x-coordinate value of the point.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint X { get; set; }
Visual Basic
Public Property X As UInteger
    Get
    Set
Visual C++
public:
property unsigned int X {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Y Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Point2U..::..Y Property
Point2U Structure See Also Send Feedback
The y-coordinate value of the point.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Y { get; set; }
Visual Basic
Public Property Y As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Y {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Point2U Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PointAndTangent Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent Structure
Members See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct PointAndTangent
Visual Basic
Public Structure PointAndTangent
Visual C++
public value class PointAndTangent

See Also

PointAndTangent Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PointAndTangent Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent Members
PointAndTangent Structure Constructors Methods Operators Properties See Also Send Feedback

The PointAndTangent type exposes the following members.

Constructors

 | Name | Description
Public method | PointAndTangent |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Point |
Public property | Tangent |

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PointAndTangent Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent Constructor
PointAndTangent Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PointAndTangent(
    Point2F point,
    Point2F tangent
)
Visual Basic
Public Sub New ( _
    point As Point2F, _
    tangent As Point2F _
)
Visual C++
public:
PointAndTangent(
    Point2F point,
    Point2F tangent
)

Parameters

point
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
tangent
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PointAndTangent Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent Methods
PointAndTangent Structure See Also Send Feedback

The PointAndTangent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent..::..Equals Method
PointAndTangent Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent..::..GetHashCode Method
PointAndTangent Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PointAndTangent Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent Operators
PointAndTangent Structure See Also Send Feedback

The PointAndTangent type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent..::..Equality Operator
PointAndTangent Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    PointAndTangent pointAndTangent1,
    PointAndTangent pointAndTangent2
)
Visual Basic
Public Shared Operator = ( _
    pointAndTangent1 As PointAndTangent, _
    pointAndTangent2 As PointAndTangent _
) As Boolean
Visual C++
public:
static bool operator ==(
    PointAndTangent pointAndTangent1,
    PointAndTangent pointAndTangent2
)

Parameters

pointAndTangent1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PointAndTangent
pointAndTangent2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PointAndTangent

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent..::..Inequality Operator
PointAndTangent Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    PointAndTangent pointAndTangent1,
    PointAndTangent pointAndTangent2
)
Visual Basic
Public Shared Operator <> ( _
    pointAndTangent1 As PointAndTangent, _
    pointAndTangent2 As PointAndTangent _
) As Boolean
Visual C++
public:
static bool operator !=(
    PointAndTangent pointAndTangent1,
    PointAndTangent pointAndTangent2
)

Parameters

pointAndTangent1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PointAndTangent
pointAndTangent2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PointAndTangent

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PointAndTangent Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent Properties
PointAndTangent Structure See Also Send Feedback

The PointAndTangent type exposes the following members.

Properties

 | Name | Description
Public property | Point |
Public property | Tangent |

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent..::..Point Property
PointAndTangent Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point { get; }
Visual Basic
Public ReadOnly Property Point As Point2F
    Get
Visual C++
public:
property Point2F Point {
    Point2F get ();
}

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tangent Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PointAndTangent..::..Tangent Property
PointAndTangent Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Tangent { get; }
Visual Basic
Public ReadOnly Property Tangent As Point2F
    Get
Visual C++
public:
property Point2F Tangent {
    Point2F get ();
}

See Also

PointAndTangent Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PresentOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PresentOptions Enumeration
See Also Send Feedback
Describes how a render target behaves when it presents its content. This enumeration allows a bitwise combination of its member values.

(Also see DirectX SDK: D2D1_PRESENT_OPTIONS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum PresentOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration PresentOptions
Visual C++
[FlagsAttribute]
public enum class PresentOptions

Members

Member name | Description
None |
Immediately |
RetainContents |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


QuadraticBezierSegment Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment Structure
Members See Also Send Feedback
Contains the control point and end point for a quadratic Bezier segment.

(Also see DirectX SDK: D2D1_QUADRATIC_BEZIER_SEGMENT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct QuadraticBezierSegment
Visual Basic
Public Structure QuadraticBezierSegment
Visual C++
public value class QuadraticBezierSegment

See Also

QuadraticBezierSegment Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


QuadraticBezierSegment Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment Members
QuadraticBezierSegment Structure Constructors Methods Operators Properties See Also Send Feedback

The QuadraticBezierSegment type exposes the following members.

Constructors

 | Name | Description
Public method | QuadraticBezierSegment | Constructor for the QuadraticBezierSegment value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Point1 | The control point of the quadratic Bezier segment.
Public property | Point2 | The end point of the quadratic Bezier segment.

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


QuadraticBezierSegment Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment Constructor
QuadraticBezierSegment Structure See Also Send Feedback
Constructor for the QuadraticBezierSegment value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public QuadraticBezierSegment(
    Point2F point1,
    Point2F point2
)
Visual Basic
Public Sub New ( _
    point1 As Point2F, _
    point2 As Point2F _
)
Visual C++
public:
QuadraticBezierSegment(
    Point2F point1,
    Point2F point2
)

Parameters

point1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point1 property.
point2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point2 property.

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


QuadraticBezierSegment Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment Methods
QuadraticBezierSegment Structure See Also Send Feedback

The QuadraticBezierSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment..::..Equals Method
QuadraticBezierSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment..::..GetHashCode Method
QuadraticBezierSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


QuadraticBezierSegment Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment Operators
QuadraticBezierSegment Structure See Also Send Feedback

The QuadraticBezierSegment type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment..::..Equality Operator
QuadraticBezierSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    QuadraticBezierSegment segment1,
    QuadraticBezierSegment segment2
)
Visual Basic
Public Shared Operator = ( _
    segment1 As QuadraticBezierSegment, _
    segment2 As QuadraticBezierSegment _
) As Boolean
Visual C++
public:
static bool operator ==(
    QuadraticBezierSegment segment1,
    QuadraticBezierSegment segment2
)

Parameters

segment1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..QuadraticBezierSegment
segment2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..QuadraticBezierSegment

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment..::..Inequality Operator
QuadraticBezierSegment Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    QuadraticBezierSegment segment1,
    QuadraticBezierSegment segment2
)
Visual Basic
Public Shared Operator <> ( _
    segment1 As QuadraticBezierSegment, _
    segment2 As QuadraticBezierSegment _
) As Boolean
Visual C++
public:
static bool operator !=(
    QuadraticBezierSegment segment1,
    QuadraticBezierSegment segment2
)

Parameters

segment1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..QuadraticBezierSegment
segment2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..QuadraticBezierSegment

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


QuadraticBezierSegment Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment Properties
QuadraticBezierSegment Structure See Also Send Feedback

The QuadraticBezierSegment type exposes the following members.

Properties

 | Name | Description
Public property | Point1 | The control point of the quadratic Bezier segment.
Public property | Point2 | The end point of the quadratic Bezier segment.

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment..::..Point1 Property
QuadraticBezierSegment Structure See Also Send Feedback
The control point of the quadratic Bezier segment.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point1 { get; set; }
Visual Basic
Public Property Point1 As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point1 {
    Point2F get ();
    void set (Point2F value);
}

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QuadraticBezierSegment..::..Point2 Property
QuadraticBezierSegment Structure See Also Send Feedback
The end point of the quadratic Bezier segment.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point2 { get; set; }
Visual Basic
Public Property Point2 As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point2 {
    Point2F get ();
    void set (Point2F value);
}

See Also

QuadraticBezierSegment Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadialGradientBrush Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrush Class
Members See Also Send Feedback
Paints an area with a radial gradient.

(Also see DirectX SDK: ID2D1RadialGradientBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RadialGradientBrush : Brush
Visual Basic
Public Class RadialGradientBrush _
    Inherits Brush
Visual C++
public ref class RadialGradientBrush : public Brush

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RadialGradientBrush

See Also

RadialGradientBrush Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadialGradientBrush Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrush Members
RadialGradientBrush Class Properties See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | Center | The center of the radial gradient. This will be in local coordinates and will not depend on the geometry being filled. (Also see DirectX SDK: ID2D1RadialGradientBrush::GetCenter, ID2D1RadialGradientBrush::SetCenter)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GradientOriginOffset | the offset of the origin relative to the radial gradient center. (Also see DirectX SDK: ID2D1RadialGradientBrush::SetGradientOriginOffset, ID2D1RadialGradientBrush::GetGradientOriginOffset)
Public property | GradientStops | Retrieves the GradientStopCollection associated with this radial gradient brush. (Also see DirectX SDK: ID2D1RadialGradientBrush::GetGradientStopCollection)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity) (Inherited from Brush.)
Public property | RadiusX | The x-radius of the gradient ellipse. (Also see DirectX SDK: ID2D1RadialGradientBrush::GetRadiusX, ID2D1RadialGradientBrush::SetRadiusX)
Public property | RadiusY | The y-radius of the gradient ellipse. (Also see DirectX SDK: ID2D1RadialGradientBrush::GetRadiusY, ID2D1RadialGradientBrush::SetRadiusY)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform) (Inherited from Brush.)

See Also

RadialGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadialGradientBrush Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrush Properties
RadialGradientBrush Class See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | Center | The center of the radial gradient. This will be in local coordinates and will not depend on the geometry being filled. (Also see DirectX SDK: ID2D1RadialGradientBrush::GetCenter, ID2D1RadialGradientBrush::SetCenter)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GradientOriginOffset | the offset of the origin relative to the radial gradient center. (Also see DirectX SDK: ID2D1RadialGradientBrush::SetGradientOriginOffset, ID2D1RadialGradientBrush::GetGradientOriginOffset)
Public property | GradientStops | Retrieves the GradientStopCollection associated with this radial gradient brush. (Also see DirectX SDK: ID2D1RadialGradientBrush::GetGradientStopCollection)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity) (Inherited from Brush.)
Public property | RadiusX | The x-radius of the gradient ellipse. (Also see DirectX SDK: ID2D1RadialGradientBrush::GetRadiusX, ID2D1RadialGradientBrush::SetRadiusX)
Public property | RadiusY | The y-radius of the gradient ellipse. (Also see DirectX SDK: ID2D1RadialGradientBrush::GetRadiusY, ID2D1RadialGradientBrush::SetRadiusY)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform) (Inherited from Brush.)

See Also

RadialGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Center Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrush..::..Center Property
RadialGradientBrush Class See Also Send Feedback
The center of the radial gradient. This will be in local coordinates and will not depend on the geometry being filled.

(Also see DirectX SDK: ID2D1RadialGradientBrush::GetCenter, ID2D1RadialGradientBrush::SetCenter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Center { get; set; }
Visual Basic
Public Property Center As Point2F
    Get
    Set
Visual C++
public:
property Point2F Center {
    Point2F get ();
    void set (Point2F value);
}

See Also

RadialGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientOriginOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrush..::..GradientOriginOffset Property
RadialGradientBrush Class See Also Send Feedback
the offset of the origin relative to the radial gradient center.

(Also see DirectX SDK: ID2D1RadialGradientBrush::SetGradientOriginOffset, ID2D1RadialGradientBrush::GetGradientOriginOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F GradientOriginOffset { get; set; }
Visual Basic
Public Property GradientOriginOffset As Point2F
    Get
    Set
Visual C++
public:
property Point2F GradientOriginOffset {
    Point2F get ();
    void set (Point2F value);
}

See Also

RadialGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientStops Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrush..::..GradientStops Property
RadialGradientBrush Class See Also Send Feedback
Retrieves the GradientStopCollection associated with this radial gradient brush.

(Also see DirectX SDK: ID2D1RadialGradientBrush::GetGradientStopCollection)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GradientStopCollection GradientStops { get; }
Visual Basic
Public ReadOnly Property GradientStops As GradientStopCollection
    Get
Visual C++
public:
property GradientStopCollection^ GradientStops {
    GradientStopCollection^ get ();
}

Return Value

GradientStopCollection

See Also

RadialGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadiusX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrush..::..RadiusX Property
RadialGradientBrush Class See Also Send Feedback
The x-radius of the gradient ellipse.

(Also see DirectX SDK: ID2D1RadialGradientBrush::GetRadiusX, ID2D1RadialGradientBrush::SetRadiusX)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float RadiusX { get; set; }
Visual Basic
Public Property RadiusX As Single
    Get
    Set
Visual C++
public:
property float RadiusX {
    float get ();
    void set (float value);
}

See Also

RadialGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadiusY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrush..::..RadiusY Property
RadialGradientBrush Class See Also Send Feedback
The y-radius of the gradient ellipse.

(Also see DirectX SDK: ID2D1RadialGradientBrush::GetRadiusY, ID2D1RadialGradientBrush::SetRadiusY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float RadiusY { get; set; }
Visual Basic
Public Property RadiusY As Single
    Get
    Set
Visual C++
public:
property float RadiusY {
    float get ();
    void set (float value);
}

See Also

RadialGradientBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadialGradientBrushProperties Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties Structure
Members See Also Send Feedback
Contains the gradient origin offset and the size and position of the gradient ellipse for a RadialGradientBrush.

(Also see DirectX SDK: D2D1_RADIAL_GRADIENT_BRUSH_PROPERTIES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RadialGradientBrushProperties
Visual Basic
Public Structure RadialGradientBrushProperties
Visual C++
public value class RadialGradientBrushProperties

See Also

RadialGradientBrushProperties Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadialGradientBrushProperties Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties Members
RadialGradientBrushProperties Structure Constructors Methods Operators Properties See Also Send Feedback

The RadialGradientBrushProperties type exposes the following members.

Constructors

 | Name | Description
Public method | RadialGradientBrushProperties | Constructor for the RadialGradientBrushProperties value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Center | In the brush's coordinate space, the center of the gradient ellipse.
Public property | GradientOriginOffset | In the brush's coordinate space, the offset of the gradient origin relative to the gradient ellipse's center.
Public property | RadiusX | In the brush's coordinate space, the x-radius of the gradient ellipse.
Public property | RadiusY | In the brush's coordinate space, the y-radius of the gradient ellipse.

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadialGradientBrushProperties Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties Constructor
RadialGradientBrushProperties Structure See Also Send Feedback
Constructor for the RadialGradientBrushProperties value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RadialGradientBrushProperties(
    Point2F center,
    Point2F gradientOriginOffset,
    float radiusX,
    float radiusY
)
Visual Basic
Public Sub New ( _
    center As Point2F, _
    gradientOriginOffset As Point2F, _
    radiusX As Single, _
    radiusY As Single _
)
Visual C++
public:
RadialGradientBrushProperties(
    Point2F center,
    Point2F gradientOriginOffset,
    float radiusX,
    float radiusY
)

Parameters

center
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Center property.
gradientOriginOffset
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the GradientOriginOffset property.
radiusX
Type: System..::..Single
Initializes the RadiusX property.
radiusY
Type: System..::..Single
Initializes the RadiusY property.

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadialGradientBrushProperties Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties Methods
RadialGradientBrushProperties Structure See Also Send Feedback

The RadialGradientBrushProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties..::..Equals Method
RadialGradientBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties..::..GetHashCode Method
RadialGradientBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadialGradientBrushProperties Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties Operators
RadialGradientBrushProperties Structure See Also Send Feedback

The RadialGradientBrushProperties type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties..::..Equality Operator
RadialGradientBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    RadialGradientBrushProperties radialGradientBrushProperties1,
    RadialGradientBrushProperties radialGradientBrushProperties2
)
Visual Basic
Public Shared Operator = ( _
    radialGradientBrushProperties1 As RadialGradientBrushProperties, _
    radialGradientBrushProperties2 As RadialGradientBrushProperties _
) As Boolean
Visual C++
public:
static bool operator ==(
    RadialGradientBrushProperties radialGradientBrushProperties1,
    RadialGradientBrushProperties radialGradientBrushProperties2
)

Parameters

radialGradientBrushProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RadialGradientBrushProperties
radialGradientBrushProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RadialGradientBrushProperties

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties..::..Inequality Operator
RadialGradientBrushProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    RadialGradientBrushProperties radialGradientBrushProperties1,
    RadialGradientBrushProperties radialGradientBrushProperties2
)
Visual Basic
Public Shared Operator <> ( _
    radialGradientBrushProperties1 As RadialGradientBrushProperties, _
    radialGradientBrushProperties2 As RadialGradientBrushProperties _
) As Boolean
Visual C++
public:
static bool operator !=(
    RadialGradientBrushProperties radialGradientBrushProperties1,
    RadialGradientBrushProperties radialGradientBrushProperties2
)

Parameters

radialGradientBrushProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RadialGradientBrushProperties
radialGradientBrushProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RadialGradientBrushProperties

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadialGradientBrushProperties Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties Properties
RadialGradientBrushProperties Structure See Also Send Feedback

The RadialGradientBrushProperties type exposes the following members.

Properties

 | Name | Description
Public property | Center | In the brush's coordinate space, the center of the gradient ellipse.
Public property | GradientOriginOffset | In the brush's coordinate space, the offset of the gradient origin relative to the gradient ellipse's center.
Public property | RadiusX | In the brush's coordinate space, the x-radius of the gradient ellipse.
Public property | RadiusY | In the brush's coordinate space, the y-radius of the gradient ellipse.

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Center Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties..::..Center Property
RadialGradientBrushProperties Structure See Also Send Feedback
In the brush's coordinate space, the center of the gradient ellipse.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Center { get; set; }
Visual Basic
Public Property Center As Point2F
    Get
    Set
Visual C++
public:
property Point2F Center {
    Point2F get ();
    void set (Point2F value);
}

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GradientOriginOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties..::..GradientOriginOffset Property
RadialGradientBrushProperties Structure See Also Send Feedback
In the brush's coordinate space, the offset of the gradient origin relative to the gradient ellipse's center.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F GradientOriginOffset { get; set; }
Visual Basic
Public Property GradientOriginOffset As Point2F
    Get
    Set
Visual C++
public:
property Point2F GradientOriginOffset {
    Point2F get ();
    void set (Point2F value);
}

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadiusX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties..::..RadiusX Property
RadialGradientBrushProperties Structure See Also Send Feedback
In the brush's coordinate space, the x-radius of the gradient ellipse.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float RadiusX { get; set; }
Visual Basic
Public Property RadiusX As Single
    Get
    Set
Visual C++
public:
property float RadiusX {
    float get ();
    void set (float value);
}

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadiusY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RadialGradientBrushProperties..::..RadiusY Property
RadialGradientBrushProperties Structure See Also Send Feedback
In the brush's coordinate space, the y-radius of the gradient ellipse.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float RadiusY { get; set; }
Visual Basic
Public Property RadiusY As Single
    Get
    Set
Visual C++
public:
property float RadiusY {
    float get ();
    void set (float value);
}

See Also

RadialGradientBrushProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rect Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect Structure
Members See Also Send Feedback
Represents a rectangle defined by the upper-left corner pair of coordinates (left,top) and the lower-right corner pair of coordinates (right, bottom). These coordinates are expressed as a 32-bit signed integer values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Rect
Visual Basic
Public Structure Rect
Visual C++
public value class Rect

See Also

Rect Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rect Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect Members
Rect Structure Constructors Methods Operators Properties See Also Send Feedback

The Rect type exposes the following members.

Constructors

 | Name | Description
Public method | Rect | Constructor for the Rect value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Bottom | The y-coordinate of the lower-right corner of the rectangle.
Public property | Height | The height of this rectangle.
Public property | Left | The x-coordinate of the upper-left corner of the rectangle.
Public property | Right | The x-coordinate of the lower-right corner of the rectangle.
Public property | Top | The y-coordinate of the upper-left corner of the rectangle.
Public property | Width | Retrieve the width of this rectangle.

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rect Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect Constructor
Rect Structure See Also Send Feedback
Constructor for the Rect value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Rect(
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic
Public Sub New ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
)
Visual C++
public:
Rect(
    int left,
    int top,
    int right,
    int bottom
)

Parameters

left
Type: System..::..Int32
Initializes the Left property.
top
Type: System..::..Int32
Initializes the Top property.
right
Type: System..::..Int32
Initializes the Right property.
bottom
Type: System..::..Int32
Initializes the Bottom property.

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rect Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect Methods
Rect Structure See Also Send Feedback

The Rect type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..Equals Method
Rect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..GetHashCode Method
Rect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rect Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect Operators
Rect Structure See Also Send Feedback

The Rect type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..Equality Operator
Rect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Rect rect1,
    Rect rect2
)
Visual Basic
Public Shared Operator = ( _
    rect1 As Rect, _
    rect2 As Rect _
) As Boolean
Visual C++
public:
static bool operator ==(
    Rect rect1,
    Rect rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Rect
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Rect

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..Inequality Operator
Rect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Rect rect1,
    Rect rect2
)
Visual Basic
Public Shared Operator <> ( _
    rect1 As Rect, _
    rect2 As Rect _
) As Boolean
Visual C++
public:
static bool operator !=(
    Rect rect1,
    Rect rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Rect
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Rect

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rect Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect Properties
Rect Structure See Also Send Feedback

The Rect type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | The y-coordinate of the lower-right corner of the rectangle.
Public property | Height | The height of this rectangle.
Public property | Left | The x-coordinate of the upper-left corner of the rectangle.
Public property | Right | The x-coordinate of the lower-right corner of the rectangle.
Public property | Top | The y-coordinate of the upper-left corner of the rectangle.
Public property | Width | Retrieve the width of this rectangle.

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Bottom Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..Bottom Property
Rect Structure See Also Send Feedback
The y-coordinate of the lower-right corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Bottom { get; set; }
Visual Basic
Public Property Bottom As Integer
    Get
    Set
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..Height Property
Rect Structure See Also Send Feedback
The height of this rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Remarks

Changing the Height property will also cause a change in the Bottom value.

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Left Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..Left Property
Rect Structure See Also Send Feedback
The x-coordinate of the upper-left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Left { get; set; }
Visual Basic
Public Property Left As Integer
    Get
    Set
Visual C++
public:
property int Left {
    int get ();
    void set (int value);
}

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Right Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..Right Property
Rect Structure See Also Send Feedback
The x-coordinate of the lower-right corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Right { get; set; }
Visual Basic
Public Property Right As Integer
    Get
    Set
Visual C++
public:
property int Right {
    int get ();
    void set (int value);
}

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Top Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..Top Property
Rect Structure See Also Send Feedback
The y-coordinate of the upper-left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Top { get; set; }
Visual Basic
Public Property Top As Integer
    Get
    Set
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rect..::..Width Property
Rect Structure See Also Send Feedback
Retrieve the width of this rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Remarks

Changing the Width property will also cause a change in the Right value.

See Also

Rect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectangleGeometry Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry Class
Members See Also Send Feedback
Describes a two-dimensional rectangle.

(Also see DirectX SDK: ID2D1RectangleGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RectangleGeometry : Geometry
Visual Basic
Public Class RectangleGeometry _
    Inherits Geometry
Visual C++
public ref class RectangleGeometry : public Geometry

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectangleGeometry

See Also

RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectangleGeometry Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry Members
RectangleGeometry Class Methods Properties See Also Send Feedback

The RectangleGeometry type exposes the following members.

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Rectangle | Retrieves the rectangle that describes the rectangle geometry's dimensions. (Also see DirectX SDK: ID2D1RectangleGeometry::GetRect)

See Also

RectangleGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectangleGeometry Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry Methods
RectangleGeometry Class See Also Send Feedback

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

RectangleGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..CombineWithGeometry Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..CompareWithGeometry Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..ComputeArea Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..ComputeLength Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..ComputePointAtLength Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..FillContainsPoint Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..GetBounds Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..GetWidenedBounds Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..Outline Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..Simplify Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..StrokeContainsPoint Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..Tessellate Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..Widen Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

RectangleGeometry Class
RectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectangleGeometry Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry Properties
RectangleGeometry Class See Also Send Feedback

The RectangleGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Rectangle | Retrieves the rectangle that describes the rectangle geometry's dimensions. (Also see DirectX SDK: ID2D1RectangleGeometry::GetRect)

See Also

RectangleGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rectangle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectangleGeometry..::..Rectangle Property
RectangleGeometry Class See Also Send Feedback
Retrieves the rectangle that describes the rectangle geometry's dimensions.

(Also see DirectX SDK: ID2D1RectangleGeometry::GetRect)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectF Rectangle { get; }
Visual Basic
Public ReadOnly Property Rectangle As RectF
    Get
Visual C++
public:
property RectF Rectangle {
    RectF get ();
}

See Also

RectangleGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectF Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF Structure
Members See Also Send Feedback
Represents a rectangle defined by the coordinates of the upper-left corner (left, top) and the coordinates of the lower-right corner (right, bottom).

(Also see DirectX SDK: D2D1_RECT_F)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RectF
Visual Basic
Public Structure RectF
Visual C++
public value class RectF

See Also

RectF Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectF Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF Members
RectF Structure Constructors Methods Operators Properties See Also Send Feedback

The RectF type exposes the following members.

Constructors

 | Name | Description
Public method | RectF | Constructor for the RectF value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Bottom | The y-coordinate of the lower-right corner of the rectangle.
Public property | Height | The height of this rectangle.
Public property | Left | The x-coordinate of the upper-left corner of the rectangle.
Public property | Right | The x-coordinate of the lower-right corner of the rectangle.
Public property | Top | The y-coordinate of the upper-left corner of the rectangle.
Public property | Width | Retrieve the width of this rectangle.

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectF Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF Constructor
RectF Structure See Also Send Feedback
Constructor for the RectF value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectF(
    float left,
    float top,
    float right,
    float bottom
)
Visual Basic
Public Sub New ( _
    left As Single, _
    top As Single, _
    right As Single, _
    bottom As Single _
)
Visual C++
public:
RectF(
    float left,
    float top,
    float right,
    float bottom
)

Parameters

left
Type: System..::..Single
Initializes the Left property.
top
Type: System..::..Single
Initializes the Top property.
right
Type: System..::..Single
Initializes the Right property.
bottom
Type: System..::..Single
Initializes the Bottom property.

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectF Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF Methods
RectF Structure See Also Send Feedback

The RectF type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..Equals Method
RectF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..GetHashCode Method
RectF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectF Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF Operators
RectF Structure See Also Send Feedback

The RectF type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..Equality Operator
RectF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    RectF rect1,
    RectF rect2
)
Visual Basic
Public Shared Operator = ( _
    rect1 As RectF, _
    rect2 As RectF _
) As Boolean
Visual C++
public:
static bool operator ==(
    RectF rect1,
    RectF rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..Inequality Operator
RectF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    RectF rect1,
    RectF rect2
)
Visual Basic
Public Shared Operator <> ( _
    rect1 As RectF, _
    rect2 As RectF _
) As Boolean
Visual C++
public:
static bool operator !=(
    RectF rect1,
    RectF rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectF Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF Properties
RectF Structure See Also Send Feedback

The RectF type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | The y-coordinate of the lower-right corner of the rectangle.
Public property | Height | The height of this rectangle.
Public property | Left | The x-coordinate of the upper-left corner of the rectangle.
Public property | Right | The x-coordinate of the lower-right corner of the rectangle.
Public property | Top | The y-coordinate of the upper-left corner of the rectangle.
Public property | Width | Retrieve the width of this rectangle.

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Bottom Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..Bottom Property
RectF Structure See Also Send Feedback
The y-coordinate of the lower-right corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Bottom { get; set; }
Visual Basic
Public Property Bottom As Single
    Get
    Set
Visual C++
public:
property float Bottom {
    float get ();
    void set (float value);
}

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..Height Property
RectF Structure See Also Send Feedback
The height of this rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

Remarks

Changing the Height property will also cause a change in the Bottom value.

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Left Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..Left Property
RectF Structure See Also Send Feedback
The x-coordinate of the upper-left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Left { get; set; }
Visual Basic
Public Property Left As Single
    Get
    Set
Visual C++
public:
property float Left {
    float get ();
    void set (float value);
}

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Right Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..Right Property
RectF Structure See Also Send Feedback
The x-coordinate of the lower-right corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Right { get; set; }
Visual Basic
Public Property Right As Single
    Get
    Set
Visual C++
public:
property float Right {
    float get ();
    void set (float value);
}

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Top Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..Top Property
RectF Structure See Also Send Feedback
The y-coordinate of the upper-left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Top { get; set; }
Visual Basic
Public Property Top As Single
    Get
    Set
Visual C++
public:
property float Top {
    float get ();
    void set (float value);
}

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectF..::..Width Property
RectF Structure See Also Send Feedback
Retrieve the width of this rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

Remarks

Changing the Width property will also cause a change in the Right value.

See Also

RectF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectU Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU Structure
Members See Also Send Feedback
Represents a rectangle defined by the upper-left corner pair of coordinates (left,top) and the lower-right corner pair of coordinates (right, bottom). These coordinates are expressed as a 32-bit unsigned integer values.

(Also see DirectX SDK: D2D1_RECT_U)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RectU
Visual Basic
Public Structure RectU
Visual C++
public value class RectU

See Also

RectU Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectU Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU Members
RectU Structure Constructors Methods Operators Properties See Also Send Feedback

The RectU type exposes the following members.

Constructors

 | Name | Description
Public method | RectU | Constructor for the RectU value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Bottom | The y-coordinate of the lower-right corner of the rectangle.
Public property | Height | The height of this rectangle.
Public property | Left | The x-coordinate of the upper-left corner of the rectangle.
Public property | Right | The x-coordinate of the lower-right corner of the rectangle.
Public property | Top | The y-coordinate of the upper-left corner of the rectangle.
Public property | Width | Retrieve the width of this rectangle.

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectU Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU Constructor
RectU Structure See Also Send Feedback
Constructor for the RectU value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectU(
    uint left,
    uint top,
    uint right,
    uint bottom
)
Visual Basic
Public Sub New ( _
    left As UInteger, _
    top As UInteger, _
    right As UInteger, _
    bottom As UInteger _
)
Visual C++
public:
RectU(
    unsigned int left,
    unsigned int top,
    unsigned int right,
    unsigned int bottom
)

Parameters

left
Type: System..::..UInt32
Initializes the Left property.
top
Type: System..::..UInt32
Initializes the Top property.
right
Type: System..::..UInt32
Initializes the Right property.
bottom
Type: System..::..UInt32
Initializes the Bottom property.

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectU Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU Methods
RectU Structure See Also Send Feedback

The RectU type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..Equals Method
RectU Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..GetHashCode Method
RectU Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectU Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU Operators
RectU Structure See Also Send Feedback

The RectU type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..Equality Operator
RectU Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    RectU rect1,
    RectU rect2
)
Visual Basic
Public Shared Operator = ( _
    rect1 As RectU, _
    rect2 As RectU _
) As Boolean
Visual C++
public:
static bool operator ==(
    RectU rect1,
    RectU rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..Inequality Operator
RectU Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    RectU rect1,
    RectU rect2
)
Visual Basic
Public Shared Operator <> ( _
    rect1 As RectU, _
    rect2 As RectU _
) As Boolean
Visual C++
public:
static bool operator !=(
    RectU rect1,
    RectU rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectU

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RectU Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU Properties
RectU Structure See Also Send Feedback

The RectU type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | The y-coordinate of the lower-right corner of the rectangle.
Public property | Height | The height of this rectangle.
Public property | Left | The x-coordinate of the upper-left corner of the rectangle.
Public property | Right | The x-coordinate of the lower-right corner of the rectangle.
Public property | Top | The y-coordinate of the upper-left corner of the rectangle.
Public property | Width | Retrieve the width of this rectangle.

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Bottom Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..Bottom Property
RectU Structure See Also Send Feedback
The y-coordinate of the lower-right corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Bottom { get; set; }
Visual Basic
Public Property Bottom As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Bottom {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..Height Property
RectU Structure See Also Send Feedback
The height of this rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Changing the Height property will also cause a change in the Bottom value.

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Left Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..Left Property
RectU Structure See Also Send Feedback
The x-coordinate of the upper-left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Left { get; set; }
Visual Basic
Public Property Left As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Left {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Right Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..Right Property
RectU Structure See Also Send Feedback
The x-coordinate of the lower-right corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Right { get; set; }
Visual Basic
Public Property Right As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Right {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Top Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..Top Property
RectU Structure See Also Send Feedback
The y-coordinate of the upper-left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Top { get; set; }
Visual Basic
Public Property Top As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Top {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RectU..::..Width Property
RectU Structure See Also Send Feedback
Retrieve the width of this rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Changing the Width property will also cause a change in the Right value.

See Also

RectU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTarget Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget Class
Members See Also Send Feedback
Represents an object that can receive drawing commands. Interfaces that inherit from RenderTarget render the drawing commands they receive in different ways.

(Also see DirectX SDK: ID2D1RenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RenderTarget : D2DResource
Visual Basic
Public Class RenderTarget _
    Inherits D2DResource
Visual C++
public ref class RenderTarget : public D2DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTarget
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapRenderTarget
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DCRenderTarget
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..HwndRenderTarget

See Also

RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTarget Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget Members
RenderTarget Class Methods Properties See Also Send Feedback

The RenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | BeginDraw | Start drawing on this render target. Draw calls can only be issued between a BeginDraw and EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::BeginDraw)
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear)
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap)
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateGradientStopCollection |
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush)
Public method | CreateMesh | Create a mesh that uses triangles to describe a shape. Create a D2D mesh. (Also see DirectX SDK: ID2D1RenderTarget::CreateMesh)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush)
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush)
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmapAtOrigin | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse)
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun)
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine)
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle)
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout )
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout )
Public method | EndDraw | Ends drawing on the render target. If an error occur while drawing, an exception will be thrown. To prevent exceptions, you can use the TryEndDraw() method instead. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw)
Public method | FillEllipse | Paints the interior of the specified ellipse. (Also see DirectX SDK: ID2D1RenderTarget::FillEllipse)
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry)
Public method | FillMesh | Fill a mesh. Since meshes can only render aliased content, the render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillMesh)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillOpacityMaskAtOrigin | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush uses the sourceRectangle area to draw at the orgin of the bitmap. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillRectangle | Paints the interior of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRectangle)
Public method | FillRoundedRectangle | Paints the interior of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRoundedRectangle)
Public method | Flush | Executes all pending drawing commands. This method will throw if an error occur during the operation. To prevent exceptions, TryFlush() can be used instead. (Also see DirectX SDK: ID2D1RenderTarget::Flush)
Public method | IsSupported | Returns true if the given properties are supported by this render target. The DPI is ignored. NOTE: If the render target type is software, then neither feature level 9 nor feature level 10 will be considered to be supported. (Also see DirectX SDK: ID2D1RenderTarget::IsSupported)
Public method | PopAxisAlignedClip | Removes the last axis-aligned clip from the render target. After this method is called, the clip is no longer applied to subsequent drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::PopAxisAlignedClip)
Public method | PopLayer | Ends a layer that was defined with particular layer resources. (Also see DirectX SDK: ID2D1RenderTarget::PopLayer)
Public method | PushAxisAlignedClip | Pushes a clip. The clip can be antialiased. The clip must be axis aligned. If the current world transform is not axis preserving, then the bounding box of the transformed clip rect will be used. The clip will remain in effect until a PopAxisAligned clip call is made. (Also see DirectX SDK: ID2D1RenderTarget::PushAxisAlignedClip)
Public method | PushLayer | Start a layer of drawing calls. The way in which the layer must be resolved is specified first as well as the logical resource that stores the layer parameters. The supplied layer resource might grow if the specified content cannot fit inside it. The layer will grow monitonically on each axis. (Also see DirectX SDK: ID2D1RenderTarget::PushLayer)
Public method | RestoreDrawingState | Copies the state stored in the block interface. (Also see DirectX SDK: ID2D1RenderTarget::RestoreDrawingState)
Public method | SaveDrawingState | Gets the current drawing state and saves it into the supplied IDrawingStatckBlock. (Also see DirectX SDK: ID2D1RenderTarget::SaveDrawingState)
Public method | TryEndDraw | Ends drawing on the render target, error results can be retrieved at this time, or when calling Flush() or TryFlush(). (Also see DirectX SDK: ID2D1RenderTarget::EndDraw)
Public method | TryFlush | Executes all pending drawing commands. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw)

Properties

 | Name | Description
Public property | AntiAliasMode | The current antialiasing mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetAntiAliasMode, ID2D1RenderTarget::SetAntiAliasMode)
Public property | Dpi | The DPI on the render target. This results in the render target being interpretted to a different scale. Neither DPI can be negative. If zero is specified for both, the system DPI is chosen. If one is zero and the other unspecified, the DPI is not changed. (Also see DirectX SDK: ID2D1RenderTarget::GetDpi, ID2D1RenderTarget::SetDpi)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GdiInteropRenderTarget | Provide a GdiInteropRenderTarget version of this render target.
Public property | MaximumBitmapSize | Returns the maximum bitmap and render target size that is guaranteed to be supported by the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetMaximumBitmapSize)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | The pixel format and alpha mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelFormat)
Public property | PixelSize | Returns the size of the render target in pixels. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelSize)
Public property | Size | Returns the size of the render target in DIPs. (Also see DirectX SDK: ID2D1RenderTarget::GetSize)
Public property | Tags | Get or Set a tag to labelto the succeeding drawing operations. If an error occurs while rendering a primtive, the tags can be returned from the Flush or EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::GetTags, ID2D1RenderTarget::SetTags)
Public property | TextAntiAliasMode | The current antialiasing mode for text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextAntiAliasMode, ID2D1RenderTarget::SetTextAntiAliasMode)
Public property | TextRenderingParams | Gets or set the render target's current text-rendering options. Text rendering options to apply to all text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextRenderingParams, ID2D1RenderTarget::SetTextRenderingParams)
Public property | Transform | The current transform of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetTransform, ID2D1RenderTarget::SetTransform)

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTarget Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget Methods
RenderTarget Class See Also Send Feedback

The RenderTarget type exposes the following members.

Methods

 | Name | Description
Public method | BeginDraw | Start drawing on this render target. Draw calls can only be issued between a BeginDraw and EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::BeginDraw)
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear)
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap)
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateGradientStopCollection |
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush)
Public method | CreateMesh | Create a mesh that uses triangles to describe a shape. Create a D2D mesh. (Also see DirectX SDK: ID2D1RenderTarget::CreateMesh)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush)
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush)
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmapAtOrigin | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse)
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun)
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine)
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle)
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout )
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout )
Public method | EndDraw | Ends drawing on the render target. If an error occur while drawing, an exception will be thrown. To prevent exceptions, you can use the TryEndDraw() method instead. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw)
Public method | FillEllipse | Paints the interior of the specified ellipse. (Also see DirectX SDK: ID2D1RenderTarget::FillEllipse)
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry)
Public method | FillMesh | Fill a mesh. Since meshes can only render aliased content, the render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillMesh)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillOpacityMaskAtOrigin | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush uses the sourceRectangle area to draw at the orgin of the bitmap. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillRectangle | Paints the interior of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRectangle)
Public method | FillRoundedRectangle | Paints the interior of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::FillRoundedRectangle)
Public method | Flush | Executes all pending drawing commands. This method will throw if an error occur during the operation. To prevent exceptions, TryFlush() can be used instead. (Also see DirectX SDK: ID2D1RenderTarget::Flush)
Public method | IsSupported | Returns true if the given properties are supported by this render target. The DPI is ignored. NOTE: If the render target type is software, then neither feature level 9 nor feature level 10 will be considered to be supported. (Also see DirectX SDK: ID2D1RenderTarget::IsSupported)
Public method | PopAxisAlignedClip | Removes the last axis-aligned clip from the render target. After this method is called, the clip is no longer applied to subsequent drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::PopAxisAlignedClip)
Public method | PopLayer | Ends a layer that was defined with particular layer resources. (Also see DirectX SDK: ID2D1RenderTarget::PopLayer)
Public method | PushAxisAlignedClip | Pushes a clip. The clip can be antialiased. The clip must be axis aligned. If the current world transform is not axis preserving, then the bounding box of the transformed clip rect will be used. The clip will remain in effect until a PopAxisAligned clip call is made. (Also see DirectX SDK: ID2D1RenderTarget::PushAxisAlignedClip)
Public method | PushLayer | Start a layer of drawing calls. The way in which the layer must be resolved is specified first as well as the logical resource that stores the layer parameters. The supplied layer resource might grow if the specified content cannot fit inside it. The layer will grow monitonically on each axis. (Also see DirectX SDK: ID2D1RenderTarget::PushLayer)
Public method | RestoreDrawingState | Copies the state stored in the block interface. (Also see DirectX SDK: ID2D1RenderTarget::RestoreDrawingState)
Public method | SaveDrawingState | Gets the current drawing state and saves it into the supplied IDrawingStatckBlock. (Also see DirectX SDK: ID2D1RenderTarget::SaveDrawingState)
Public method | TryEndDraw | Ends drawing on the render target, error results can be retrieved at this time, or when calling Flush() or TryFlush(). (Also see DirectX SDK: ID2D1RenderTarget::EndDraw)
Public method | TryFlush | Executes all pending drawing commands. (Also see DirectX SDK: ID2D1RenderTarget::EndDraw)

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BeginDraw Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..BeginDraw Method
RenderTarget Class See Also Send Feedback
Start drawing on this render target. Draw calls can only be issued between a BeginDraw and EndDraw call.

(Also see DirectX SDK: ID2D1RenderTarget::BeginDraw)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void BeginDraw()
Visual Basic
Public Sub BeginDraw
Visual C++
public:
void BeginDraw()

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Clear Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..Clear Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear()()()() | Clears the drawing area to transparent black. (Also see DirectX SDK: ID2D1RenderTarget::Clear)
Public method | Clear(ColorF) | Clears the drawing area to the specified color. (Also see DirectX SDK: ID2D1RenderTarget::Clear)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Clear Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..Clear Method
RenderTarget Class See Also Send Feedback
Clears the drawing area to transparent black.

(Also see DirectX SDK: ID2D1RenderTarget::Clear)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

RenderTarget Class
Clear Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Clear Method (ColorF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..Clear Method (ColorF)
RenderTarget Class See Also Send Feedback
Clears the drawing area to the specified color.

(Also see DirectX SDK: ID2D1RenderTarget::Clear)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Clear(
    ColorF clearColor
)
Visual Basic
Public Sub Clear ( _
    clearColor As ColorF _
)
Visual C++
public:
void Clear(
    ColorF clearColor
)

Parameters

clearColor
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF
The clearColor parameter.

Remarks

For render targets that support alpha, the clearColor is treated as straight alpha, regardless of whether the alpha mode is straight alpha or premultiplied alpha. For targets that ignore alpha, the alpha of the clear color is interpreted as fully opaque. If the render target has an active clip (specified by PushAxisAlignedClip), the clear command is only applied to the area within the clip region.

See Also

RenderTarget Class
Clear Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmap Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmap(SizeU, BitmapProperties) | Create an uninitialized bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)
Public method | CreateBitmap(SizeU, array<Byte>[]()[][], UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)
Public method | CreateBitmap(SizeU, IntPtr, UInt32, BitmapProperties) | Create a bitmap by copying from memory (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmap Method (SizeU, BitmapProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmap Method (SizeU, BitmapProperties)
RenderTarget Class See Also Send Feedback
Create an uninitialized bitmap.

(Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateBitmap(
    SizeU size,
    BitmapProperties bitmapProperties
)
Visual Basic
Public Function CreateBitmap ( _
    size As SizeU, _
    bitmapProperties As BitmapProperties _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateBitmap(
    SizeU size,
    BitmapProperties bitmapProperties
)

Parameters

size
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
The dimension of the bitmap to create in pixels.
bitmapProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties
The pixel format and dots per inch (DPI) of the bitmap to create.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmap Method (SizeU, Byte[], UInt32, BitmapProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmap Method (SizeU, array<Byte>[]()[][], UInt32, BitmapProperties)
RenderTarget Class See Also Send Feedback
Create a bitmap by copying from memory

(Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateBitmap(
    SizeU size,
    byte[] source,
    uint pitch,
    BitmapProperties bitmapProperties
)
Visual Basic
Public Function CreateBitmap ( _
    size As SizeU, _
    source As Byte(), _
    pitch As UInteger, _
    bitmapProperties As BitmapProperties _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateBitmap(
    SizeU size,
    array<unsigned char>^ source,
    unsigned int pitch,
    BitmapProperties bitmapProperties
)

Parameters

size
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
The dimension of the bitmap to create in pixels.
source
Type: array< System..::..Byte >[]()[][]
An array of bytes holding the image data.
pitch
Type: System..::..UInt32
The byte count of each scanline, which is equal to (the image width in pixels * the number of bytes per pixel) + memory padding. (Note that pitch is also sometimes called stride.)
bitmapProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties
The pixel format and dots per inch (DPI) of the bitmap to create.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmap Method (SizeU, IntPtr, UInt32, BitmapProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmap Method (SizeU, IntPtr, UInt32, BitmapProperties)
RenderTarget Class See Also Send Feedback
Create a bitmap by copying from memory

(Also see DirectX SDK: ID2D1RenderTarget::CreateBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateBitmap(
    SizeU size,
    IntPtr sourceData,
    uint pitch,
    BitmapProperties bitmapProperties
)
Visual Basic
Public Function CreateBitmap ( _
    size As SizeU, _
    sourceData As IntPtr, _
    pitch As UInteger, _
    bitmapProperties As BitmapProperties _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateBitmap(
    SizeU size,
    IntPtr sourceData,
    unsigned int pitch,
    BitmapProperties bitmapProperties
)

Parameters

size
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
The dimension of the bitmap to create in pixels.
sourceData
Type: System..::..IntPtr
A pointer to the memory location of the image data.
pitch
Type: System..::..UInt32
The byte count of each scanline, which is equal to (the image width in pixels * the number of bytes per pixel) + memory padding. (Note that pitch is also sometimes called stride.)
bitmapProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties
The pixel format and dots per inch (DPI) of the bitmap to create.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmapBrush Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmapBrush(D2DBitmap) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapBrush(D2DBitmap, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)
Public method | CreateBitmapBrush(D2DBitmap, BitmapBrushProperties, BrushProperties) | Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapBrush Method (D2DBitmap)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmapBrush Method (D2DBitmap)
RenderTarget Class See Also Send Feedback
Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry.

(Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapBrush CreateBitmapBrush(
    D2DBitmap bitmap
)
Visual Basic
Public Function CreateBitmapBrush ( _
    bitmap As D2DBitmap _
) As BitmapBrush
Visual C++
public:
BitmapBrush^ CreateBitmapBrush(
    D2DBitmap^ bitmap
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.

Return Value

BitmapBrush

See Also

RenderTarget Class
CreateBitmapBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapBrush Method (D2DBitmap, BitmapBrushProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmapBrush Method (D2DBitmap, BitmapBrushProperties)
RenderTarget Class See Also Send Feedback
Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry.

(Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapBrush CreateBitmapBrush(
    D2DBitmap bitmap,
    BitmapBrushProperties bitmapBrushProperties
)
Visual Basic
Public Function CreateBitmapBrush ( _
    bitmap As D2DBitmap, _
    bitmapBrushProperties As BitmapBrushProperties _
) As BitmapBrush
Visual C++
public:
BitmapBrush^ CreateBitmapBrush(
    D2DBitmap^ bitmap,
    BitmapBrushProperties bitmapBrushProperties
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
bitmapBrushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapBrushProperties
The bitmapBrushProperties parameter.

Return Value

BitmapBrush

See Also

RenderTarget Class
CreateBitmapBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapBrush Method (D2DBitmap, BrushProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmapBrush Method (D2DBitmap, BrushProperties)
RenderTarget Class See Also Send Feedback
Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry.

(Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapBrush CreateBitmapBrush(
    D2DBitmap bitmap,
    BrushProperties brushProperties
)
Visual Basic
Public Function CreateBitmapBrush ( _
    bitmap As D2DBitmap, _
    brushProperties As BrushProperties _
) As BitmapBrush
Visual C++
public:
BitmapBrush^ CreateBitmapBrush(
    D2DBitmap^ bitmap,
    BrushProperties brushProperties
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
brushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BrushProperties
The brushProperties parameter.

Return Value

BitmapBrush

See Also

RenderTarget Class
CreateBitmapBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapBrush Method (D2DBitmap, BitmapBrushProperties, BrushProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmapBrush Method (D2DBitmap, BitmapBrushProperties, BrushProperties)
RenderTarget Class See Also Send Feedback
Creates a bitmap brush. The bitmap is scaled, rotated, skewed or tiled to fill or pen a geometry.

(Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapBrush CreateBitmapBrush(
    D2DBitmap bitmap,
    BitmapBrushProperties bitmapBrushProperties,
    BrushProperties brushProperties
)
Visual Basic
Public Function CreateBitmapBrush ( _
    bitmap As D2DBitmap, _
    bitmapBrushProperties As BitmapBrushProperties, _
    brushProperties As BrushProperties _
) As BitmapBrush
Visual C++
public:
BitmapBrush^ CreateBitmapBrush(
    D2DBitmap^ bitmap,
    BitmapBrushProperties bitmapBrushProperties,
    BrushProperties brushProperties
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
bitmapBrushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapBrushProperties
The bitmapBrushProperties parameter.
brushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BrushProperties
The brushProperties parameter.

Return Value

BitmapBrush

See Also

RenderTarget Class
CreateBitmapBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapFromWicBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmapFromWicBitmap Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBitmapFromWicBitmap(BitmapSource) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap)
Public method | CreateBitmapFromWicBitmap(BitmapSource, BitmapProperties) | Create a D2D bitmap by copying a WIC bitmap. (Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapFromWicBitmap Method (BitmapSource)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmapFromWicBitmap Method (BitmapSource)
RenderTarget Class See Also Send Feedback
Create a D2D bitmap by copying a WIC bitmap.

(Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateBitmapFromWicBitmap(
    BitmapSource wicBitmapSource
)
Visual Basic
Public Function CreateBitmapFromWicBitmap ( _
    wicBitmapSource As BitmapSource _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateBitmapFromWicBitmap(
    BitmapSource^ wicBitmapSource
)

Parameters

wicBitmapSource
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSource
The wicBitmapSource parameter.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateBitmapFromWicBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateBitmapFromWicBitmap Method (BitmapSource, BitmapProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateBitmapFromWicBitmap Method (BitmapSource, BitmapProperties)
RenderTarget Class See Also Send Feedback
Create a D2D bitmap by copying a WIC bitmap.

(Also see DirectX SDK: ID2D1RenderTarget::CreateBitmapFromWicBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateBitmapFromWicBitmap(
    BitmapSource wicBitmapSource,
    BitmapProperties bitmapProperties
)
Visual Basic
Public Function CreateBitmapFromWicBitmap ( _
    wicBitmapSource As BitmapSource, _
    bitmapProperties As BitmapProperties _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateBitmapFromWicBitmap(
    BitmapSource^ wicBitmapSource,
    BitmapProperties bitmapProperties
)

Parameters

wicBitmapSource
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSource
The wicBitmapSource parameter.
bitmapProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties
The bitmapProperties parameter.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateBitmapFromWicBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCompatibleRenderTarget()()()() | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)
Public method | CreateCompatibleRenderTarget(CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU) | Creates a bitmap render target whose bitmap can be used as a source for rendering in the API. (Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method
RenderTarget Class See Also Send Feedback
Creates a bitmap render target whose bitmap can be used as a source for rendering in the API.

(Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRenderTarget CreateCompatibleRenderTarget()
Visual Basic
Public Function CreateCompatibleRenderTarget As BitmapRenderTarget
Visual C++
public:
BitmapRenderTarget^ CreateCompatibleRenderTarget()

Return Value

A bitmap render target.

See Also

RenderTarget Class
CreateCompatibleRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions)
RenderTarget Class See Also Send Feedback
Creates a bitmap render target whose bitmap can be used as a source for rendering in the API.

(Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRenderTarget CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options
)
Visual Basic
Public Function CreateCompatibleRenderTarget ( _
    options As CompatibleRenderTargetOptions _
) As BitmapRenderTarget
Visual C++
public:
BitmapRenderTarget^ CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options
)

Parameters

options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CompatibleRenderTargetOptions
Allows the caller to retrieve a GDI compatible render target.

Return Value

A bitmap render target.

See Also

RenderTarget Class
CreateCompatibleRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, PixelFormat)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, PixelFormat)
RenderTarget Class See Also Send Feedback
Creates a bitmap render target whose bitmap can be used as a source for rendering in the API.

(Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRenderTarget CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    PixelFormat desiredFormat
)
Visual Basic
Public Function CreateCompatibleRenderTarget ( _
    options As CompatibleRenderTargetOptions, _
    desiredFormat As PixelFormat _
) As BitmapRenderTarget
Visual C++
public:
BitmapRenderTarget^ CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    PixelFormat desiredFormat
)

Parameters

options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CompatibleRenderTargetOptions
Allows the caller to retrieve a GDI compatible render target.
desiredFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat
The desired pixel format. The format must be compatible with the parent render target type. If the format is not specified, it will be inherited from the parent render target.

Return Value

A bitmap render target.

See Also

RenderTarget Class
CreateCompatibleRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, SizeF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, SizeF)
RenderTarget Class See Also Send Feedback
Creates a bitmap render target whose bitmap can be used as a source for rendering in the API.

(Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRenderTarget CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    SizeF desiredSize
)
Visual Basic
Public Function CreateCompatibleRenderTarget ( _
    options As CompatibleRenderTargetOptions, _
    desiredSize As SizeF _
) As BitmapRenderTarget
Visual C++
public:
BitmapRenderTarget^ CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    SizeF desiredSize
)

Parameters

options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CompatibleRenderTargetOptions
Allows the caller to retrieve a GDI compatible render target.
desiredSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
The requested size of the target in DIPs. If the pixel size is not specified, the DPI is inherited from the parent target. However, the render target will never contain a fractional number of pixels.

Return Value

A bitmap render target.

See Also

RenderTarget Class
CreateCompatibleRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, SizeU)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, SizeU)
RenderTarget Class See Also Send Feedback
Creates a bitmap render target whose bitmap can be used as a source for rendering in the API.

(Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRenderTarget CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    SizeU desiredPixelSize
)
Visual Basic
Public Function CreateCompatibleRenderTarget ( _
    options As CompatibleRenderTargetOptions, _
    desiredPixelSize As SizeU _
) As BitmapRenderTarget
Visual C++
public:
BitmapRenderTarget^ CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    SizeU desiredPixelSize
)

Parameters

options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CompatibleRenderTargetOptions
Allows the caller to retrieve a GDI compatible render target.
desiredPixelSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
The requested size of the render target in pixels. If the DIP size is also specified, the DPI is calculated from these two values. If the desired size is not specified, the DPI is inherited from the parent render target. If neither value is specified, the compatible render target will be the same size and have the same DPI as the parent target.

Return Value

A bitmap render target.

See Also

RenderTarget Class
CreateCompatibleRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, PixelFormat, SizeF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, PixelFormat, SizeF)
RenderTarget Class See Also Send Feedback
Creates a bitmap render target whose bitmap can be used as a source for rendering in the API.

(Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRenderTarget CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    PixelFormat desiredFormat,
    SizeF desiredSize
)
Visual Basic
Public Function CreateCompatibleRenderTarget ( _
    options As CompatibleRenderTargetOptions, _
    desiredFormat As PixelFormat, _
    desiredSize As SizeF _
) As BitmapRenderTarget
Visual C++
public:
BitmapRenderTarget^ CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    PixelFormat desiredFormat,
    SizeF desiredSize
)

Parameters

options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CompatibleRenderTargetOptions
Allows the caller to retrieve a GDI compatible render target.
desiredFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat
The desired pixel format. The format must be compatible with the parent render target type. If the format is not specified, it will be inherited from the parent render target.
desiredSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
The requested size of the target in DIPs. If the pixel size is not specified, the DPI is inherited from the parent target. However, the render target will never contain a fractional number of pixels.

Return Value

A bitmap render target.

See Also

RenderTarget Class
CreateCompatibleRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, PixelFormat, SizeU)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, PixelFormat, SizeU)
RenderTarget Class See Also Send Feedback
Creates a bitmap render target whose bitmap can be used as a source for rendering in the API.

(Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRenderTarget CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    PixelFormat desiredFormat,
    SizeU desiredPixelSize
)
Visual Basic
Public Function CreateCompatibleRenderTarget ( _
    options As CompatibleRenderTargetOptions, _
    desiredFormat As PixelFormat, _
    desiredPixelSize As SizeU _
) As BitmapRenderTarget
Visual C++
public:
BitmapRenderTarget^ CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    PixelFormat desiredFormat,
    SizeU desiredPixelSize
)

Parameters

options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CompatibleRenderTargetOptions
Allows the caller to retrieve a GDI compatible render target.
desiredFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat
The desired pixel format. The format must be compatible with the parent render target type. If the format is not specified, it will be inherited from the parent render target.
desiredPixelSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
The requested size of the render target in pixels. If the DIP size is also specified, the DPI is calculated from these two values. If the desired size is not specified, the DPI is inherited from the parent render target. If neither value is specified, the compatible render target will be the same size and have the same DPI as the parent target.

Return Value

A bitmap render target.

See Also

RenderTarget Class
CreateCompatibleRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, SizeF, SizeU)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, SizeF, SizeU)
RenderTarget Class See Also Send Feedback
Creates a bitmap render target whose bitmap can be used as a source for rendering in the API.

(Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRenderTarget CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    SizeF desiredSize,
    SizeU desiredPixelSize
)
Visual Basic
Public Function CreateCompatibleRenderTarget ( _
    options As CompatibleRenderTargetOptions, _
    desiredSize As SizeF, _
    desiredPixelSize As SizeU _
) As BitmapRenderTarget
Visual C++
public:
BitmapRenderTarget^ CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    SizeF desiredSize,
    SizeU desiredPixelSize
)

Parameters

options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CompatibleRenderTargetOptions
Allows the caller to retrieve a GDI compatible render target.
desiredSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
The requested size of the target in DIPs. If the pixel size is not specified, the DPI is inherited from the parent target. However, the render target will never contain a fractional number of pixels.
desiredPixelSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
The requested size of the render target in pixels. If the DIP size is also specified, the DPI is calculated from these two values. If the desired size is not specified, the DPI is inherited from the parent render target. If neither value is specified, the compatible render target will be the same size and have the same DPI as the parent target.

Return Value

A bitmap render target.

See Also

RenderTarget Class
CreateCompatibleRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateCompatibleRenderTarget Method (CompatibleRenderTargetOptions, PixelFormat, SizeF, SizeU)
RenderTarget Class See Also Send Feedback
Creates a bitmap render target whose bitmap can be used as a source for rendering in the API.

(Also see DirectX SDK: ID2D1RenderTarget::CreateCompatibleRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRenderTarget CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    PixelFormat desiredFormat,
    SizeF desiredSize,
    SizeU desiredPixelSize
)
Visual Basic
Public Function CreateCompatibleRenderTarget ( _
    options As CompatibleRenderTargetOptions, _
    desiredFormat As PixelFormat, _
    desiredSize As SizeF, _
    desiredPixelSize As SizeU _
) As BitmapRenderTarget
Visual C++
public:
BitmapRenderTarget^ CreateCompatibleRenderTarget(
    CompatibleRenderTargetOptions options,
    PixelFormat desiredFormat,
    SizeF desiredSize,
    SizeU desiredPixelSize
)

Parameters

options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CompatibleRenderTargetOptions
Allows the caller to retrieve a GDI compatible render target.
desiredFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat
The desired pixel format. The format must be compatible with the parent render target type. If the format is not specified, it will be inherited from the parent render target.
desiredSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
The requested size of the target in DIPs. If the pixel size is not specified, the DPI is inherited from the parent target. However, the render target will never contain a fractional number of pixels.
desiredPixelSize
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
The requested size of the render target in pixels. If the DIP size is also specified, the DPI is calculated from these two values. If the desired size is not specified, the DPI is inherited from the parent render target. If neither value is specified, the compatible render target will be the same size and have the same DPI as the parent target.

Return Value

A bitmap render target.

See Also

RenderTarget Class
CreateCompatibleRenderTarget Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateGradientStopCollection Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateGradientStopCollection Method
RenderTarget Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GradientStopCollection CreateGradientStopCollection(
    IEnumerable<GradientStop> gradientStops,
    Gamma colorInterpolationGamma,
    ExtendMode extendMode
)
Visual Basic
Public Function CreateGradientStopCollection ( _
    gradientStops As IEnumerable(Of GradientStop), _
    colorInterpolationGamma As Gamma, _
    extendMode As ExtendMode _
) As GradientStopCollection
Visual C++
public:
GradientStopCollection^ CreateGradientStopCollection(
    IEnumerable<GradientStop>^ gradientStops,
    Gamma colorInterpolationGamma,
    ExtendMode extendMode
)

Parameters

gradientStops
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' GradientStop >)>)>
colorInterpolationGamma
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Gamma
extendMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ExtendMode

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLayer Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateLayer Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLayer()()()() | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer)
Public method | CreateLayer(SizeF) | Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform. (Also see DirectX SDK: ID2D1RenderTarget::CreateLayer)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLayer Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateLayer Method
RenderTarget Class See Also Send Feedback
Creates a layer resource that can be used on any target and which will resize under the covers if necessary. The size will be unspecified so the returned resource is a placeholder and the backing store will be allocated to be the minimum size that can hold the content when the layer is pushed.

(Also see DirectX SDK: ID2D1RenderTarget::CreateLayer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Layer CreateLayer()
Visual Basic
Public Function CreateLayer As Layer
Visual C++
public:
Layer^ CreateLayer()

Return Value

Layer

See Also

RenderTarget Class
CreateLayer Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLayer Method (SizeF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateLayer Method (SizeF)
RenderTarget Class See Also Send Feedback
Creates a layer resource that can be used on any target and which will resize under the covers if necessary. Use this overload to prevent unwanted reallocation of the layer backing store. The size is in DIPs, but, it is unaffected by the current world transform.

(Also see DirectX SDK: ID2D1RenderTarget::CreateLayer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Layer CreateLayer(
    SizeF size
)
Visual Basic
Public Function CreateLayer ( _
    size As SizeF _
) As Layer
Visual C++
public:
Layer^ CreateLayer(
    SizeF size
)

Parameters

size
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
The resolution independent minimum size hint for the layer resource.

Return Value

Layer

See Also

RenderTarget Class
CreateLayer Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLinearGradientBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateLinearGradientBrush Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush)
Public method | CreateLinearGradientBrush(LinearGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLinearGradientBrush Method (LinearGradientBrushProperties, GradientStopCollection)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateLinearGradientBrush Method (LinearGradientBrushProperties, GradientStopCollection)
RenderTarget Class See Also Send Feedback
Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient.

(Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LinearGradientBrush CreateLinearGradientBrush(
    LinearGradientBrushProperties linearGradientBrushProperties,
    GradientStopCollection gradientStopCollection
)
Visual Basic
Public Function CreateLinearGradientBrush ( _
    linearGradientBrushProperties As LinearGradientBrushProperties, _
    gradientStopCollection As GradientStopCollection _
) As LinearGradientBrush
Visual C++
public:
LinearGradientBrush^ CreateLinearGradientBrush(
    LinearGradientBrushProperties linearGradientBrushProperties,
    GradientStopCollection^ gradientStopCollection
)

Parameters

linearGradientBrushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LinearGradientBrushProperties
The linearGradientBrushProperties parameter.
gradientStopCollection
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStopCollection
The gradientStopCollection parameter.

Return Value

LinearGradientBrush

See Also

RenderTarget Class
CreateLinearGradientBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateLinearGradientBrush Method (LinearGradientBrushProperties, GradientStopCollection, BrushProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateLinearGradientBrush Method (LinearGradientBrushProperties, GradientStopCollection, BrushProperties)
RenderTarget Class See Also Send Feedback
Creates a new LinearGradientBrush that can be used to paint areas with a linear gradient.

(Also see DirectX SDK: ID2D1RenderTarget::CreateLinearGradientBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LinearGradientBrush CreateLinearGradientBrush(
    LinearGradientBrushProperties linearGradientBrushProperties,
    GradientStopCollection gradientStopCollection,
    BrushProperties brushProperties
)
Visual Basic
Public Function CreateLinearGradientBrush ( _
    linearGradientBrushProperties As LinearGradientBrushProperties, _
    gradientStopCollection As GradientStopCollection, _
    brushProperties As BrushProperties _
) As LinearGradientBrush
Visual C++
public:
LinearGradientBrush^ CreateLinearGradientBrush(
    LinearGradientBrushProperties linearGradientBrushProperties,
    GradientStopCollection^ gradientStopCollection,
    BrushProperties brushProperties
)

Parameters

linearGradientBrushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LinearGradientBrushProperties
The linearGradientBrushProperties parameter.
gradientStopCollection
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStopCollection
The gradientStopCollection parameter.
brushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BrushProperties
The brushProperties parameter.

Return Value

LinearGradientBrush

See Also

RenderTarget Class
CreateLinearGradientBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateMesh Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateMesh Method
RenderTarget Class See Also Send Feedback
Create a mesh that uses triangles to describe a shape. Create a D2D mesh.

(Also see DirectX SDK: ID2D1RenderTarget::CreateMesh)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Mesh CreateMesh()
Visual Basic
Public Function CreateMesh As Mesh
Visual C++
public:
Mesh^ CreateMesh()

Return Value

Mesh

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateRadialGradientBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateRadialGradientBrush Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush)
Public method | CreateRadialGradientBrush(RadialGradientBrushProperties, GradientStopCollection, BrushProperties) | Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient. (Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateRadialGradientBrush Method (RadialGradientBrushProperties, GradientStopCollection)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateRadialGradientBrush Method (RadialGradientBrushProperties, GradientStopCollection)
RenderTarget Class See Also Send Feedback
Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient.

(Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RadialGradientBrush CreateRadialGradientBrush(
    RadialGradientBrushProperties radialGradientBrushProperties,
    GradientStopCollection gradientStopCollection
)
Visual Basic
Public Function CreateRadialGradientBrush ( _
    radialGradientBrushProperties As RadialGradientBrushProperties, _
    gradientStopCollection As GradientStopCollection _
) As RadialGradientBrush
Visual C++
public:
RadialGradientBrush^ CreateRadialGradientBrush(
    RadialGradientBrushProperties radialGradientBrushProperties,
    GradientStopCollection^ gradientStopCollection
)

Parameters

radialGradientBrushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RadialGradientBrushProperties
The radialGradientBrushProperties parameter.
gradientStopCollection
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStopCollection
The gradientStopCollection parameter.

Return Value

RadialGradientBrush

See Also

RenderTarget Class
CreateRadialGradientBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateRadialGradientBrush Method (RadialGradientBrushProperties, GradientStopCollection, BrushProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateRadialGradientBrush Method (RadialGradientBrushProperties, GradientStopCollection, BrushProperties)
RenderTarget Class See Also Send Feedback
Creates a new RadialGradientBrush that can be used to paint areas with a radial gradient.

(Also see DirectX SDK: ID2D1RenderTarget::CreateRadialGradientBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RadialGradientBrush CreateRadialGradientBrush(
    RadialGradientBrushProperties radialGradientBrushProperties,
    GradientStopCollection gradientStopCollection,
    BrushProperties brushProperties
)
Visual Basic
Public Function CreateRadialGradientBrush ( _
    radialGradientBrushProperties As RadialGradientBrushProperties, _
    gradientStopCollection As GradientStopCollection, _
    brushProperties As BrushProperties _
) As RadialGradientBrush
Visual C++
public:
RadialGradientBrush^ CreateRadialGradientBrush(
    RadialGradientBrushProperties radialGradientBrushProperties,
    GradientStopCollection^ gradientStopCollection,
    BrushProperties brushProperties
)

Parameters

radialGradientBrushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RadialGradientBrushProperties
The radialGradientBrushProperties parameter.
gradientStopCollection
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GradientStopCollection
The gradientStopCollection parameter.
brushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BrushProperties
The brushProperties parameter.

Return Value

RadialGradientBrush

See Also

RenderTarget Class
CreateRadialGradientBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSharedBitmap Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSharedBitmap(D2DBitmap) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(ImagingBitmapLock) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(Surface) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(D2DBitmap, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(ImagingBitmapLock, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)
Public method | CreateSharedBitmap(Surface, BitmapProperties) | Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target. (Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method (D2DBitmap)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSharedBitmap Method (D2DBitmap)
RenderTarget Class See Also Send Feedback
Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target.

(Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateSharedBitmap(
    D2DBitmap bitmap
)
Visual Basic
Public Function CreateSharedBitmap ( _
    bitmap As D2DBitmap _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateSharedBitmap(
    D2DBitmap^ bitmap
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The Bitmap.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateSharedBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method (ImagingBitmapLock)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSharedBitmap Method (ImagingBitmapLock)
RenderTarget Class See Also Send Feedback
Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target.

(Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateSharedBitmap(
    ImagingBitmapLock wicBitmap
)
Visual Basic
Public Function CreateSharedBitmap ( _
    wicBitmap As ImagingBitmapLock _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateSharedBitmap(
    ImagingBitmapLock^ wicBitmap
)

Parameters

wicBitmap
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingBitmapLock
The wicBitmap.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateSharedBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method (Surface)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSharedBitmap Method (Surface)
RenderTarget Class See Also Send Feedback
Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target.

(Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateSharedBitmap(
    Surface surface
)
Visual Basic
Public Function CreateSharedBitmap ( _
    surface As Surface _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateSharedBitmap(
    Surface^ surface
)

Parameters

surface
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface
The Graphics Surface.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateSharedBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method (D2DBitmap, BitmapProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSharedBitmap Method (D2DBitmap, BitmapProperties)
RenderTarget Class See Also Send Feedback
Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target.

(Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateSharedBitmap(
    D2DBitmap bitmap,
    BitmapProperties bitmapProperties
)
Visual Basic
Public Function CreateSharedBitmap ( _
    bitmap As D2DBitmap, _
    bitmapProperties As BitmapProperties _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateSharedBitmap(
    D2DBitmap^ bitmap,
    BitmapProperties bitmapProperties
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The Bitmap.
bitmapProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties
The bitmap properties.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateSharedBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method (ImagingBitmapLock, BitmapProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSharedBitmap Method (ImagingBitmapLock, BitmapProperties)
RenderTarget Class See Also Send Feedback
Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target.

(Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateSharedBitmap(
    ImagingBitmapLock wicBitmap,
    BitmapProperties bitmapProperties
)
Visual Basic
Public Function CreateSharedBitmap ( _
    wicBitmap As ImagingBitmapLock, _
    bitmapProperties As BitmapProperties _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateSharedBitmap(
    ImagingBitmapLock^ wicBitmap,
    BitmapProperties bitmapProperties
)

Parameters

wicBitmap
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingBitmapLock
The wicBitmap.
bitmapProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties
The bitmap properties.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateSharedBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSharedBitmap Method (Surface, BitmapProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSharedBitmap Method (Surface, BitmapProperties)
RenderTarget Class See Also Send Feedback
Create a D2D bitmap by sharing bits from another resource. The bitmap must be compatible with the render target for the call to succeed. For example, a ImagingBitmapLock can be shared with a software target, or a Graphics surface can be shared with a Graphics render target.

(Also see DirectX SDK: ID2D1RenderTarget::CreateSharedBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D2DBitmap CreateSharedBitmap(
    Surface surface,
    BitmapProperties bitmapProperties
)
Visual Basic
Public Function CreateSharedBitmap ( _
    surface As Surface, _
    bitmapProperties As BitmapProperties _
) As D2DBitmap
Visual C++
public:
D2DBitmap^ CreateSharedBitmap(
    Surface^ surface,
    BitmapProperties bitmapProperties
)

Parameters

surface
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface
The Graphics Surface.
bitmapProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapProperties
The bitmap properties.

Return Value

D2DBitmap

See Also

RenderTarget Class
CreateSharedBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSolidColorBrush Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSolidColorBrush Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSolidColorBrush(ColorF) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush)
Public method | CreateSolidColorBrush(ColorF, BrushProperties) | Creates a new SolidColorBrush that can be used to paint areas with a solid color. (Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSolidColorBrush Method (ColorF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSolidColorBrush Method (ColorF)
RenderTarget Class See Also Send Feedback
Creates a new SolidColorBrush that can be used to paint areas with a solid color.

(Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SolidColorBrush CreateSolidColorBrush(
    ColorF color
)
Visual Basic
Public Function CreateSolidColorBrush ( _
    color As ColorF _
) As SolidColorBrush
Visual C++
public:
SolidColorBrush^ CreateSolidColorBrush(
    ColorF color
)

Parameters

color
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF
The color parameter.

Return Value

SolidColorBrush

See Also

RenderTarget Class
CreateSolidColorBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CreateSolidColorBrush Method (ColorF, BrushProperties)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..CreateSolidColorBrush Method (ColorF, BrushProperties)
RenderTarget Class See Also Send Feedback
Creates a new SolidColorBrush that can be used to paint areas with a solid color.

(Also see DirectX SDK: ID2D1RenderTarget::CreateSolidColorBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SolidColorBrush CreateSolidColorBrush(
    ColorF color,
    BrushProperties brushProperties
)
Visual Basic
Public Function CreateSolidColorBrush ( _
    color As ColorF, _
    brushProperties As BrushProperties _
) As SolidColorBrush
Visual C++
public:
SolidColorBrush^ CreateSolidColorBrush(
    ColorF color,
    BrushProperties brushProperties
)

Parameters

color
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF
The color parameter.
brushProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BrushProperties
The brushProperties parameter.

Return Value

SolidColorBrush

See Also

RenderTarget Class
CreateSolidColorBrush Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawBitmap Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawBitmap Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawBitmap(D2DBitmap) | Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF) | Draws the entire specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)
Public method | DrawBitmap(D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF) | Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawBitmap Method (D2DBitmap)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawBitmap Method (D2DBitmap)
RenderTarget Class See Also Send Feedback
Draws the specified bitmap at the origin with no scaling and applying nearest neighbor filtering if needed.

(Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawBitmap(
    D2DBitmap bitmap
)
Visual Basic
Public Sub DrawBitmap ( _
    bitmap As D2DBitmap _
)
Visual C++
public:
void DrawBitmap(
    D2DBitmap^ bitmap
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap

See Also

RenderTarget Class
DrawBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawBitmap Method (D2DBitmap, Single, BitmapInterpolationMode)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawBitmap Method (D2DBitmap, Single, BitmapInterpolationMode)
RenderTarget Class See Also Send Feedback
Draws the entire specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target.

(Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawBitmap(
    D2DBitmap bitmap,
    float opacity,
    BitmapInterpolationMode interpolationMode
)
Visual Basic
Public Sub DrawBitmap ( _
    bitmap As D2DBitmap, _
    opacity As Single, _
    interpolationMode As BitmapInterpolationMode _
)
Visual C++
public:
void DrawBitmap(
    D2DBitmap^ bitmap,
    float opacity,
    BitmapInterpolationMode interpolationMode
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
opacity
Type: System..::..Single
The opacity parameter.
interpolationMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapInterpolationMode
The interpolationMode parameter.

See Also

RenderTarget Class
DrawBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawBitmap Method (D2DBitmap, Single, BitmapInterpolationMode, RectF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawBitmap Method (D2DBitmap, Single, BitmapInterpolationMode, RectF)
RenderTarget Class See Also Send Feedback
Draws the entire specified bitmap after scaling it to the size of the specified rectangle.

(Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawBitmap(
    D2DBitmap bitmap,
    float opacity,
    BitmapInterpolationMode interpolationMode,
    RectF destinationRectangle
)
Visual Basic
Public Sub DrawBitmap ( _
    bitmap As D2DBitmap, _
    opacity As Single, _
    interpolationMode As BitmapInterpolationMode, _
    destinationRectangle As RectF _
)
Visual C++
public:
void DrawBitmap(
    D2DBitmap^ bitmap,
    float opacity,
    BitmapInterpolationMode interpolationMode,
    RectF destinationRectangle
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
opacity
Type: System..::..Single
The opacity parameter.
interpolationMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapInterpolationMode
The interpolationMode parameter.
destinationRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The destinationRectangle parameter.

See Also

RenderTarget Class
DrawBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawBitmap Method (D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawBitmap Method (D2DBitmap, Single, BitmapInterpolationMode, RectF, RectF)
RenderTarget Class See Also Send Feedback
Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle.

(Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawBitmap(
    D2DBitmap bitmap,
    float opacity,
    BitmapInterpolationMode interpolationMode,
    RectF destinationRectangle,
    RectF sourceRectangle
)
Visual Basic
Public Sub DrawBitmap ( _
    bitmap As D2DBitmap, _
    opacity As Single, _
    interpolationMode As BitmapInterpolationMode, _
    destinationRectangle As RectF, _
    sourceRectangle As RectF _
)
Visual C++
public:
void DrawBitmap(
    D2DBitmap^ bitmap,
    float opacity,
    BitmapInterpolationMode interpolationMode,
    RectF destinationRectangle,
    RectF sourceRectangle
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
opacity
Type: System..::..Single
The opacity parameter.
interpolationMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapInterpolationMode
The interpolationMode parameter.
destinationRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The destinationRectangle parameter.
sourceRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The sourceRectangle parameter.

See Also

RenderTarget Class
DrawBitmap Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawBitmapAtOrigin Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawBitmapAtOrigin Method
RenderTarget Class See Also Send Feedback
Draws a portion of the specified bitmap after scaling it to the size of the specified rectangle. The selected portion of the bitmap will be drawn at the origin of the render target.

(Also see DirectX SDK: ID2D1RenderTarget::DrawBitmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawBitmapAtOrigin(
    D2DBitmap bitmap,
    float opacity,
    BitmapInterpolationMode interpolationMode,
    RectF sourceRectangle
)
Visual Basic
Public Sub DrawBitmapAtOrigin ( _
    bitmap As D2DBitmap, _
    opacity As Single, _
    interpolationMode As BitmapInterpolationMode, _
    sourceRectangle As RectF _
)
Visual C++
public:
void DrawBitmapAtOrigin(
    D2DBitmap^ bitmap,
    float opacity,
    BitmapInterpolationMode interpolationMode,
    RectF sourceRectangle
)

Parameters

bitmap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The bitmap parameter.
opacity
Type: System..::..Single
The opacity parameter.
interpolationMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..BitmapInterpolationMode
The interpolationMode parameter.
sourceRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The sourceRectangle parameter.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawEllipse Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawEllipse Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawEllipse(Ellipse, Brush, Single) | Draws the outline of an ellipse with the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse)
Public method | DrawEllipse(Ellipse, Brush, Single, StrokeStyle) | Draws the outline of an ellipse with the specified dimensions and stroke. (Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawEllipse Method (Ellipse, Brush, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawEllipse Method (Ellipse, Brush, Single)
RenderTarget Class See Also Send Feedback
Draws the outline of an ellipse with the specified dimensions and stroke width.

(Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawEllipse(
    Ellipse ellipse,
    Brush brush,
    float strokeWidth
)
Visual Basic
Public Sub DrawEllipse ( _
    ellipse As Ellipse, _
    brush As Brush, _
    strokeWidth As Single _
)
Visual C++
public:
void DrawEllipse(
    Ellipse ellipse,
    Brush^ brush,
    float strokeWidth
)

Parameters

ellipse
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Ellipse
The ellipse parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.

See Also

RenderTarget Class
DrawEllipse Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawEllipse Method (Ellipse, Brush, Single, StrokeStyle)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawEllipse Method (Ellipse, Brush, Single, StrokeStyle)
RenderTarget Class See Also Send Feedback
Draws the outline of an ellipse with the specified dimensions and stroke.

(Also see DirectX SDK: ID2D1RenderTarget::DrawEllipse)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawEllipse(
    Ellipse ellipse,
    Brush brush,
    float strokeWidth,
    StrokeStyle strokeStyle
)
Visual Basic
Public Sub DrawEllipse ( _
    ellipse As Ellipse, _
    brush As Brush, _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle _
)
Visual C++
public:
void DrawEllipse(
    Ellipse ellipse,
    Brush^ brush,
    float strokeWidth,
    StrokeStyle^ strokeStyle
)

Parameters

ellipse
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Ellipse
The ellipse parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The strokeStyle parameter.

See Also

RenderTarget Class
DrawEllipse Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawGeometry Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawGeometry(Geometry, Brush, Single) | Draws the outline of the specified geometry using the specified stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry)
Public method | DrawGeometry(Geometry, Brush, Single, StrokeStyle) | Draws the outline of the specified geometry using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGeometry Method (Geometry, Brush, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawGeometry Method (Geometry, Brush, Single)
RenderTarget Class See Also Send Feedback
Draws the outline of the specified geometry using the specified stroke width.

(Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawGeometry(
    Geometry geometry,
    Brush brush,
    float strokeWidth
)
Visual Basic
Public Sub DrawGeometry ( _
    geometry As Geometry, _
    brush As Brush, _
    strokeWidth As Single _
)
Visual C++
public:
void DrawGeometry(
    Geometry^ geometry,
    Brush^ brush,
    float strokeWidth
)

Parameters

geometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.

See Also

RenderTarget Class
DrawGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGeometry Method (Geometry, Brush, Single, StrokeStyle)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawGeometry Method (Geometry, Brush, Single, StrokeStyle)
RenderTarget Class See Also Send Feedback
Draws the outline of the specified geometry using the specified stroke style.

(Also see DirectX SDK: ID2D1RenderTarget::DrawGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawGeometry(
    Geometry geometry,
    Brush brush,
    float strokeWidth,
    StrokeStyle strokeStyle
)
Visual Basic
Public Sub DrawGeometry ( _
    geometry As Geometry, _
    brush As Brush, _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle _
)
Visual C++
public:
void DrawGeometry(
    Geometry^ geometry,
    Brush^ brush,
    float strokeWidth,
    StrokeStyle^ strokeStyle
)

Parameters

geometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The strokeStyle parameter.

See Also

RenderTarget Class
DrawGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGlyphRun Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawGlyphRun Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun)
Public method | DrawGlyphRun(Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode) | Draws the specified glyphs. (Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGlyphRun Method (Point2F, GlyphRun[], Brush)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawGlyphRun Method (Point2F, array<GlyphRun>[]()[][], Brush)
RenderTarget Class See Also Send Feedback
Draws the specified glyphs.

(Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawGlyphRun(
    Point2F baselineOrigin,
    GlyphRun[] glyphRun,
    Brush foregroundBrush
)
Visual Basic
Public Sub DrawGlyphRun ( _
    baselineOrigin As Point2F, _
    glyphRun As GlyphRun(), _
    foregroundBrush As Brush _
)
Visual C++
public:
void DrawGlyphRun(
    Point2F baselineOrigin,
    array<GlyphRun>^ glyphRun,
    Brush^ foregroundBrush
)

Parameters

baselineOrigin
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The origin, in device-independent pixels, of the glyphs' baseline.
glyphRun
Type: array< Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphRun >[]()[][]
The glyphs to render.
foregroundBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the specified glyphs.

See Also

RenderTarget Class
DrawGlyphRun Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawGlyphRun Method (Point2F, GlyphRun[], Brush, MeasuringMode)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawGlyphRun Method (Point2F, array<GlyphRun>[]()[][], Brush, MeasuringMode)
RenderTarget Class See Also Send Feedback
Draws the specified glyphs.

(Also see DirectX SDK: ID2D1RenderTarget::DrawGlyphRun)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawGlyphRun(
    Point2F baselineOrigin,
    GlyphRun[] glyphRun,
    Brush foregroundBrush,
    MeasuringMode measuringMode
)
Visual Basic
Public Sub DrawGlyphRun ( _
    baselineOrigin As Point2F, _
    glyphRun As GlyphRun(), _
    foregroundBrush As Brush, _
    measuringMode As MeasuringMode _
)
Visual C++
public:
void DrawGlyphRun(
    Point2F baselineOrigin,
    array<GlyphRun>^ glyphRun,
    Brush^ foregroundBrush,
    MeasuringMode measuringMode
)

Parameters

baselineOrigin
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The origin, in device-independent pixels, of the glyphs' baseline.
glyphRun
Type: array< Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphRun >[]()[][]
The glyphs to render.
foregroundBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the specified glyphs.
measuringMode
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..MeasuringMode
A value that indicates how glyph metrics are used to measure text when it is formatted. The default value is Natural.

See Also

RenderTarget Class
DrawGlyphRun Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawLine Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawLine Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawLine(Point2F, Point2F, Brush, Single) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine)
Public method | DrawLine(Point2F, Point2F, Brush, Single, StrokeStyle) | Draws a line between the specified points using the specified stroke style. (Also see DirectX SDK: ID2D1RenderTarget::DrawLine)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawLine Method (Point2F, Point2F, Brush, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawLine Method (Point2F, Point2F, Brush, Single)
RenderTarget Class See Also Send Feedback
Draws a line between the specified points using the specified stroke style.

(Also see DirectX SDK: ID2D1RenderTarget::DrawLine)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawLine(
    Point2F firstPoint,
    Point2F secondPoint,
    Brush brush,
    float strokeWidth
)
Visual Basic
Public Sub DrawLine ( _
    firstPoint As Point2F, _
    secondPoint As Point2F, _
    brush As Brush, _
    strokeWidth As Single _
)
Visual C++
public:
void DrawLine(
    Point2F firstPoint,
    Point2F secondPoint,
    Brush^ brush,
    float strokeWidth
)

Parameters

firstPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The first point.
secondPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The second point.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.

See Also

RenderTarget Class
DrawLine Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawLine Method (Point2F, Point2F, Brush, Single, StrokeStyle)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawLine Method (Point2F, Point2F, Brush, Single, StrokeStyle)
RenderTarget Class See Also Send Feedback
Draws a line between the specified points using the specified stroke style.

(Also see DirectX SDK: ID2D1RenderTarget::DrawLine)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawLine(
    Point2F firstPoint,
    Point2F secondPoint,
    Brush brush,
    float strokeWidth,
    StrokeStyle strokeStyle
)
Visual Basic
Public Sub DrawLine ( _
    firstPoint As Point2F, _
    secondPoint As Point2F, _
    brush As Brush, _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle _
)
Visual C++
public:
void DrawLine(
    Point2F firstPoint,
    Point2F secondPoint,
    Brush^ brush,
    float strokeWidth,
    StrokeStyle^ strokeStyle
)

Parameters

firstPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The first point.
secondPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The second point.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The strokeStyle parameter.

See Also

RenderTarget Class
DrawLine Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRectangle Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawRectangle Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRectangle(RectF, Brush, Single) | Draws the outline of a rectangle that has the specified dimensions and stroke width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle)
Public method | DrawRectangle(RectF, Brush, Single, StrokeStyle) | Draws the outline of a rectangle that has the specified dimensions and stroke style and width. (Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRectangle Method (RectF, Brush, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawRectangle Method (RectF, Brush, Single)
RenderTarget Class See Also Send Feedback
Draws the outline of a rectangle that has the specified dimensions and stroke width.

(Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawRectangle(
    RectF rect,
    Brush brush,
    float strokeWidth
)
Visual Basic
Public Sub DrawRectangle ( _
    rect As RectF, _
    brush As Brush, _
    strokeWidth As Single _
)
Visual C++
public:
void DrawRectangle(
    RectF rect,
    Brush^ brush,
    float strokeWidth
)

Parameters

rect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The rect parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.

See Also

RenderTarget Class
DrawRectangle Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRectangle Method (RectF, Brush, Single, StrokeStyle)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawRectangle Method (RectF, Brush, Single, StrokeStyle)
RenderTarget Class See Also Send Feedback
Draws the outline of a rectangle that has the specified dimensions and stroke style and width.

(Also see DirectX SDK: ID2D1RenderTarget::DrawRectangle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawRectangle(
    RectF rect,
    Brush brush,
    float strokeWidth,
    StrokeStyle strokeStyle
)
Visual Basic
Public Sub DrawRectangle ( _
    rect As RectF, _
    brush As Brush, _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle _
)
Visual C++
public:
void DrawRectangle(
    RectF rect,
    Brush^ brush,
    float strokeWidth,
    StrokeStyle^ strokeStyle
)

Parameters

rect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The rect parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The strokeStyle parameter.

See Also

RenderTarget Class
DrawRectangle Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRoundedRectangle Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawRoundedRectangle Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle)
Public method | DrawRoundedRectangle(RoundedRect, Brush, Single, StrokeStyle) | Draws the outline of the specified rounded rectangle. (Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRoundedRectangle Method (RoundedRect, Brush, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawRoundedRectangle Method (RoundedRect, Brush, Single)
RenderTarget Class See Also Send Feedback
Draws the outline of the specified rounded rectangle.

(Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawRoundedRectangle(
    RoundedRect roundedRect,
    Brush brush,
    float strokeWidth
)
Visual Basic
Public Sub DrawRoundedRectangle ( _
    roundedRect As RoundedRect, _
    brush As Brush, _
    strokeWidth As Single _
)
Visual C++
public:
void DrawRoundedRectangle(
    RoundedRect roundedRect,
    Brush^ brush,
    float strokeWidth
)

Parameters

roundedRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRect
The roundedRect parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.

See Also

RenderTarget Class
DrawRoundedRectangle Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawRoundedRectangle Method (RoundedRect, Brush, Single, StrokeStyle)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawRoundedRectangle Method (RoundedRect, Brush, Single, StrokeStyle)
RenderTarget Class See Also Send Feedback
Draws the outline of the specified rounded rectangle.

(Also see DirectX SDK: ID2D1RenderTarget::DrawRoundedRectangle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawRoundedRectangle(
    RoundedRect roundedRect,
    Brush brush,
    float strokeWidth,
    StrokeStyle strokeStyle
)
Visual Basic
Public Sub DrawRoundedRectangle ( _
    roundedRect As RoundedRect, _
    brush As Brush, _
    strokeWidth As Single, _
    strokeStyle As StrokeStyle _
)
Visual C++
public:
void DrawRoundedRectangle(
    RoundedRect roundedRect,
    Brush^ brush,
    float strokeWidth,
    StrokeStyle^ strokeStyle
)

Parameters

roundedRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRect
The roundedRect parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
strokeWidth
Type: System..::..Single
The strokeWidth parameter.
strokeStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle
The strokeStyle parameter.

See Also

RenderTarget Class
DrawRoundedRectangle Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawText Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawText Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawText(String, TextFormat, RectF, Brush) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawText(String, TextFormat, RectF, Brush, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)
Public method | DrawText(String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode) | Draws the specified text using the format information provided by a DWrite TextFormat object. (Also see DirectX SDK: ID2D1RenderTarget::DrawText)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawText Method (String, TextFormat, RectF, Brush)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawText Method (String, TextFormat, RectF, Brush)
RenderTarget Class See Also Send Feedback
Draws the specified text using the format information provided by a DWrite TextFormat object.

(Also see DirectX SDK: ID2D1RenderTarget::DrawText)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawText(
    string text,
    TextFormat textFormat,
    RectF layoutRect,
    Brush defaultForegroundBrush
)
Visual Basic
Public Sub DrawText ( _
    text As String, _
    textFormat As TextFormat, _
    layoutRect As RectF, _
    defaultForegroundBrush As Brush _
)
Visual C++
public:
void DrawText(
    String^ text,
    TextFormat^ textFormat,
    RectF layoutRect,
    Brush^ defaultForegroundBrush
)

Parameters

text
Type: System..::..String
Characters to draw.
textFormat
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
An object that describes formatting details of the text to draw, such as the font, the font size, and flow direction.
layoutRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The size and position of the area in which the text is drawn.
defaultForegroundBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the text.

See Also

RenderTarget Class
DrawText Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawText Method (String, TextFormat, RectF, Brush, DrawTextOptions)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawText Method (String, TextFormat, RectF, Brush, DrawTextOptions)
RenderTarget Class See Also Send Feedback
Draws the specified text using the format information provided by a DWrite TextFormat object.

(Also see DirectX SDK: ID2D1RenderTarget::DrawText)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawText(
    string text,
    TextFormat textFormat,
    RectF layoutRect,
    Brush defaultForegroundBrush,
    DrawTextOptions options
)
Visual Basic
Public Sub DrawText ( _
    text As String, _
    textFormat As TextFormat, _
    layoutRect As RectF, _
    defaultForegroundBrush As Brush, _
    options As DrawTextOptions _
)
Visual C++
public:
void DrawText(
    String^ text,
    TextFormat^ textFormat,
    RectF layoutRect,
    Brush^ defaultForegroundBrush,
    DrawTextOptions options
)

Parameters

text
Type: System..::..String
Characters to draw.
textFormat
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
An object that describes formatting details of the text to draw, such as the font, the font size, and flow direction.
layoutRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The size and position of the area in which the text is drawn.
defaultForegroundBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the text.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawTextOptions
A value that indicates whether the text should be snapped to pixel boundaries and whether the text should be clipped to the layout rectangle. The default value is None, which indicates that text should be snapped to pixel boundaries and it should be clipped to the layout rectangle.

See Also

RenderTarget Class
DrawText Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawText Method (String, TextFormat, RectF, Brush, MeasuringMode)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawText Method (String, TextFormat, RectF, Brush, MeasuringMode)
RenderTarget Class See Also Send Feedback
Draws the specified text using the format information provided by a DWrite TextFormat object.

(Also see DirectX SDK: ID2D1RenderTarget::DrawText)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawText(
    string text,
    TextFormat textFormat,
    RectF layoutRect,
    Brush defaultForegroundBrush,
    MeasuringMode measuringMode
)
Visual Basic
Public Sub DrawText ( _
    text As String, _
    textFormat As TextFormat, _
    layoutRect As RectF, _
    defaultForegroundBrush As Brush, _
    measuringMode As MeasuringMode _
)
Visual C++
public:
void DrawText(
    String^ text,
    TextFormat^ textFormat,
    RectF layoutRect,
    Brush^ defaultForegroundBrush,
    MeasuringMode measuringMode
)

Parameters

text
Type: System..::..String
Characters to draw.
textFormat
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
An object that describes formatting details of the text to draw, such as the font, the font size, and flow direction.
layoutRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The size and position of the area in which the text is drawn.
defaultForegroundBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the text.
measuringMode
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..MeasuringMode
A value that indicates how glyph metrics are used to measure text when it is formatted. The default value is Natural mode.

See Also

RenderTarget Class
DrawText Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawText Method (String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawText Method (String, TextFormat, RectF, Brush, DrawTextOptions, MeasuringMode)
RenderTarget Class See Also Send Feedback
Draws the specified text using the format information provided by a DWrite TextFormat object.

(Also see DirectX SDK: ID2D1RenderTarget::DrawText)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawText(
    string text,
    TextFormat textFormat,
    RectF layoutRect,
    Brush defaultForegroundBrush,
    DrawTextOptions options,
    MeasuringMode measuringMode
)
Visual Basic
Public Sub DrawText ( _
    text As String, _
    textFormat As TextFormat, _
    layoutRect As RectF, _
    defaultForegroundBrush As Brush, _
    options As DrawTextOptions, _
    measuringMode As MeasuringMode _
)
Visual C++
public:
void DrawText(
    String^ text,
    TextFormat^ textFormat,
    RectF layoutRect,
    Brush^ defaultForegroundBrush,
    DrawTextOptions options,
    MeasuringMode measuringMode
)

Parameters

text
Type: System..::..String
Characters to draw.
textFormat
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
An object that describes formatting details of the text to draw, such as the font, the font size, and flow direction.
layoutRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The size and position of the area in which the text is drawn.
defaultForegroundBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the text.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawTextOptions
A value that indicates whether the text should be snapped to pixel boundaries and whether the text should be clipped to the layout rectangle. The default value is None, which indicates that text should be snapped to pixel boundaries and it should be clipped to the layout rectangle.
measuringMode
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..MeasuringMode
A value that indicates how glyph metrics are used to measure text when it is formatted. The default value is Natural mode.

See Also

RenderTarget Class
DrawText Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawTextLayout Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawTextLayout Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DrawTextLayout(Point2F, TextLayout, Brush) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout )
Public method | DrawTextLayout(Point2F, TextLayout, Brush, DrawTextOptions) | Draws the formatted text described by the specified IDWriteTextLayout object. (Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout )

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawTextLayout Method (Point2F, TextLayout, Brush)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawTextLayout Method (Point2F, TextLayout, Brush)
RenderTarget Class See Also Send Feedback
Draws the formatted text described by the specified IDWriteTextLayout object.

(Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout )

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawTextLayout(
    Point2F origin,
    TextLayout textLayout,
    Brush defaultForegroundBrush
)
Visual Basic
Public Sub DrawTextLayout ( _
    origin As Point2F, _
    textLayout As TextLayout, _
    defaultForegroundBrush As Brush _
)
Visual C++
public:
void DrawTextLayout(
    Point2F origin,
    TextLayout^ textLayout,
    Brush^ defaultForegroundBrush
)

Parameters

origin
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point, described in device-independent pixels, at which the upper-left corner of the text described by textLayout is drawn.
textLayout
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextLayout
The formatted text to draw.
defaultForegroundBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint any text in textLayout that does not already have a brush associated with it.

See Also

RenderTarget Class
DrawTextLayout Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DrawTextLayout Method (Point2F, TextLayout, Brush, DrawTextOptions)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..DrawTextLayout Method (Point2F, TextLayout, Brush, DrawTextOptions)
RenderTarget Class See Also Send Feedback
Draws the formatted text described by the specified IDWriteTextLayout object.

(Also see DirectX SDK: ID2D1RenderTarget::DrawTextLayout )

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawTextLayout(
    Point2F origin,
    TextLayout textLayout,
    Brush defaultForegroundBrush,
    DrawTextOptions options
)
Visual Basic
Public Sub DrawTextLayout ( _
    origin As Point2F, _
    textLayout As TextLayout, _
    defaultForegroundBrush As Brush, _
    options As DrawTextOptions _
)
Visual C++
public:
void DrawTextLayout(
    Point2F origin,
    TextLayout^ textLayout,
    Brush^ defaultForegroundBrush,
    DrawTextOptions options
)

Parameters

origin
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point, described in device-independent pixels, at which the upper-left corner of the text described by textLayout is drawn.
textLayout
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextLayout
The formatted text to draw.
defaultForegroundBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint any text in textLayout that does not already have a brush associated with it.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawTextOptions
A value that indicates whether the text should be snapped to pixel boundaries and whether the text should be clipped to the layout rectangle. The default value is None, which indicates that text should be snapped to pixel boundaries and it should be clipped to the layout rectangle.

See Also

RenderTarget Class
DrawTextLayout Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EndDraw Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..EndDraw Method
RenderTarget Class See Also Send Feedback
Ends drawing on the render target. If an error occur while drawing, an exception will be thrown. To prevent exceptions, you can use the TryEndDraw() method instead.

(Also see DirectX SDK: ID2D1RenderTarget::EndDraw)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Tags EndDraw()
Visual Basic
Public Function EndDraw As Tags
Visual C++
public:
Tags EndDraw()

Return Value

The associated tags.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillEllipse Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillEllipse Method
RenderTarget Class See Also Send Feedback
Paints the interior of the specified ellipse.

(Also see DirectX SDK: ID2D1RenderTarget::FillEllipse)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillEllipse(
    Ellipse ellipse,
    Brush brush
)
Visual Basic
Public Sub FillEllipse ( _
    ellipse As Ellipse, _
    brush As Brush _
)
Visual C++
public:
void FillEllipse(
    Ellipse ellipse,
    Brush^ brush
)

Parameters

ellipse
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Ellipse
The ellipse parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillGeometry Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillGeometry(Geometry, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry)
Public method | FillGeometry(Geometry, Brush, Brush) | Paints the interior of the specified geometry. (Also see DirectX SDK: ID2D1RenderTarget::FillGeometry)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillGeometry Method (Geometry, Brush)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillGeometry Method (Geometry, Brush)
RenderTarget Class See Also Send Feedback
Paints the interior of the specified geometry.

(Also see DirectX SDK: ID2D1RenderTarget::FillGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillGeometry(
    Geometry geometry,
    Brush brush
)
Visual Basic
Public Sub FillGeometry ( _
    geometry As Geometry, _
    brush As Brush _
)
Visual C++
public:
void FillGeometry(
    Geometry^ geometry,
    Brush^ brush
)

Parameters

geometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.

See Also

RenderTarget Class
FillGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillGeometry Method (Geometry, Brush, Brush)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillGeometry Method (Geometry, Brush, Brush)
RenderTarget Class See Also Send Feedback
Paints the interior of the specified geometry.

(Also see DirectX SDK: ID2D1RenderTarget::FillGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillGeometry(
    Geometry geometry,
    Brush brush,
    Brush opacityBrush
)
Visual Basic
Public Sub FillGeometry ( _
    geometry As Geometry, _
    brush As Brush, _
    opacityBrush As Brush _
)
Visual C++
public:
void FillGeometry(
    Geometry^ geometry,
    Brush^ brush,
    Brush^ opacityBrush
)

Parameters

geometry
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
The geometry parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.
opacityBrush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
An optionally specified opacity brush. Only the alpha channel of the corresponding brush will be sampled and will be applied to the entire fill of the geometry. If this brush is specified, the fill brush must be a bitmap brush with an extend mode of D2D1_EXTEND_MODE_CLAMP.

See Also

RenderTarget Class
FillGeometry Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillMesh Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillMesh Method
RenderTarget Class See Also Send Feedback
Fill a mesh. Since meshes can only render aliased content, the render target antialiasing mode must be set to aliased.

(Also see DirectX SDK: ID2D1RenderTarget::FillMesh)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillMesh(
    Mesh mesh,
    Brush brush
)
Visual Basic
Public Sub FillMesh ( _
    mesh As Mesh, _
    brush As Brush _
)
Visual C++
public:
void FillMesh(
    Mesh^ mesh,
    Brush^ brush
)

Parameters

mesh
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Mesh
The mesh parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillOpacityMask Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillOpacityMask Method
RenderTarget Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)
Public method | FillOpacityMask(D2DBitmap, Brush, OpacityMaskContent, RectF, RectF) | Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. (Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)

See Also

RenderTarget Class
RenderTarget Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillOpacityMask Method (D2DBitmap, Brush, OpacityMaskContent)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillOpacityMask Method (D2DBitmap, Brush, OpacityMaskContent)
RenderTarget Class See Also Send Feedback
Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush paints a rectangle the same size as the opacityMask bitmap and positioned on the origin.

(Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillOpacityMask(
    D2DBitmap opacityMask,
    Brush brush,
    OpacityMaskContent content
)
Visual Basic
Public Sub FillOpacityMask ( _
    opacityMask As D2DBitmap, _
    brush As Brush, _
    content As OpacityMaskContent _
)
Visual C++
public:
void FillOpacityMask(
    D2DBitmap^ opacityMask,
    Brush^ brush,
    OpacityMaskContent content
)

Parameters

opacityMask
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The opacity mask to apply to the brush. The alpha value of each pixel in the region specified by sourceRectangle is multiplied with the alpha value of the brush after the brush has been mapped to the area defined by destinationRectangle.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the region of the render target specified by destinationRectangle.
content
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..OpacityMaskContent
The type of contain the opacity mask contains. The value is used to determine the color space in which the opacity mask is blended.

See Also

RenderTarget Class
FillOpacityMask Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillOpacityMask Method (D2DBitmap, Brush, OpacityMaskContent, RectF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillOpacityMask Method (D2DBitmap, Brush, OpacityMaskContent, RectF)
RenderTarget Class See Also Send Feedback
Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased.

(Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillOpacityMask(
    D2DBitmap opacityMask,
    Brush brush,
    OpacityMaskContent content,
    RectF destinationRectangle
)
Visual Basic
Public Sub FillOpacityMask ( _
    opacityMask As D2DBitmap, _
    brush As Brush, _
    content As OpacityMaskContent, _
    destinationRectangle As RectF _
)
Visual C++
public:
void FillOpacityMask(
    D2DBitmap^ opacityMask,
    Brush^ brush,
    OpacityMaskContent content,
    RectF destinationRectangle
)

Parameters

opacityMask
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The opacity mask to apply to the brush. The alpha value of each pixel in the region specified by sourceRectangle is multiplied with the alpha value of the brush after the brush has been mapped to the area defined by destinationRectangle.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the region of the render target specified by destinationRectangle.
content
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..OpacityMaskContent
The type of contain the opacity mask contains. The value is used to determine the color space in which the opacity mask is blended.
destinationRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The dimensions of the area of the render target to paint, in device-independent pixels.

See Also

RenderTarget Class
FillOpacityMask Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillOpacityMask Method (D2DBitmap, Brush, OpacityMaskContent, RectF, RectF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillOpacityMask Method (D2DBitmap, Brush, OpacityMaskContent, RectF, RectF)
RenderTarget Class See Also Send Feedback
Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased.

(Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillOpacityMask(
    D2DBitmap opacityMask,
    Brush brush,
    OpacityMaskContent content,
    RectF destinationRectangle,
    RectF sourceRectangle
)
Visual Basic
Public Sub FillOpacityMask ( _
    opacityMask As D2DBitmap, _
    brush As Brush, _
    content As OpacityMaskContent, _
    destinationRectangle As RectF, _
    sourceRectangle As RectF _
)
Visual C++
public:
void FillOpacityMask(
    D2DBitmap^ opacityMask,
    Brush^ brush,
    OpacityMaskContent content,
    RectF destinationRectangle,
    RectF sourceRectangle
)

Parameters

opacityMask
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The opacity mask to apply to the brush. The alpha value of each pixel in the region specified by sourceRectangle is multiplied with the alpha value of the brush after the brush has been mapped to the area defined by destinationRectangle.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the region of the render target specified by destinationRectangle.
content
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..OpacityMaskContent
The type of contain the opacity mask contains. The value is used to determine the color space in which the opacity mask is blended.
destinationRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The dimensions of the area of the render target to paint, in device-independent pixels.
sourceRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The dimensions of the area of the bitmap to use as the opacity mask, in device-independent pixels.

See Also

RenderTarget Class
FillOpacityMask Overload
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillOpacityMaskAtOrigin Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillOpacityMaskAtOrigin Method
RenderTarget Class See Also Send Feedback
Fill using the opacity channel of the supplied bitmap as a mask. The alpha channel of the bitmap is used to represent the coverage of the geometry at each pixel, and this is filled appropriately with the brush. The render target antialiasing mode must be set to aliased. The brush uses the sourceRectangle area to draw at the orgin of the bitmap.

(Also see DirectX SDK: ID2D1RenderTarget::FillOpacityMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillOpacityMaskAtOrigin(
    D2DBitmap opacityMask,
    Brush brush,
    OpacityMaskContent content,
    RectF sourceRectangle
)
Visual Basic
Public Sub FillOpacityMaskAtOrigin ( _
    opacityMask As D2DBitmap, _
    brush As Brush, _
    content As OpacityMaskContent, _
    sourceRectangle As RectF _
)
Visual C++
public:
void FillOpacityMaskAtOrigin(
    D2DBitmap^ opacityMask,
    Brush^ brush,
    OpacityMaskContent content,
    RectF sourceRectangle
)

Parameters

opacityMask
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DBitmap
The opacity mask to apply to the brush. The alpha value of each pixel in the region specified by sourceRectangle is multiplied with the alpha value of the brush after the brush has been mapped to the area defined by destinationRectangle.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush used to paint the region of the render target specified by destinationRectangle.
content
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..OpacityMaskContent
The type of contain the opacity mask contains. The value is used to determine the color space in which the opacity mask is blended.
sourceRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The dimensions of the area of the bitmap to use as the opacity mask, in device-independent pixels.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillRectangle Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillRectangle Method
RenderTarget Class See Also Send Feedback
Paints the interior of the specified rectangle.

(Also see DirectX SDK: ID2D1RenderTarget::FillRectangle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillRectangle(
    RectF rect,
    Brush brush
)
Visual Basic
Public Sub FillRectangle ( _
    rect As RectF, _
    brush As Brush _
)
Visual C++
public:
void FillRectangle(
    RectF rect,
    Brush^ brush
)

Parameters

rect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The rect parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillRoundedRectangle Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..FillRoundedRectangle Method
RenderTarget Class See Also Send Feedback
Paints the interior of the specified rounded rectangle.

(Also see DirectX SDK: ID2D1RenderTarget::FillRoundedRectangle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void FillRoundedRectangle(
    RoundedRect roundedRect,
    Brush brush
)
Visual Basic
Public Sub FillRoundedRectangle ( _
    roundedRect As RoundedRect, _
    brush As Brush _
)
Visual C++
public:
void FillRoundedRectangle(
    RoundedRect roundedRect,
    Brush^ brush
)

Parameters

roundedRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRect
The roundedRect parameter.
brush
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The brush parameter.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Flush Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..Flush Method
RenderTarget Class See Also Send Feedback
Executes all pending drawing commands. This method will throw if an error occur during the operation. To prevent exceptions, TryFlush() can be used instead.

(Also see DirectX SDK: ID2D1RenderTarget::Flush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Tags Flush()
Visual Basic
Public Function Flush As Tags
Visual C++
public:
Tags Flush()

Return Value

The associated tags.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


IsSupported Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..IsSupported Method
RenderTarget Class See Also Send Feedback
Returns true if the given properties are supported by this render target. The DPI is ignored. NOTE: If the render target type is software, then neither feature level 9 nor feature level 10 will be considered to be supported.

(Also see DirectX SDK: ID2D1RenderTarget::IsSupported)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsSupported(
    RenderTargetProperties renderTargetProperties
)
Visual Basic
Public Function IsSupported ( _
    renderTargetProperties As RenderTargetProperties _
) As Boolean
Visual C++
public:
bool IsSupported(
    RenderTargetProperties renderTargetProperties
)

Parameters

renderTargetProperties
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetProperties
The renderTargetProperties parameter.

Return Value

True if supported; otherwise false.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PopAxisAlignedClip Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..PopAxisAlignedClip Method
RenderTarget Class See Also Send Feedback
Removes the last axis-aligned clip from the render target. After this method is called, the clip is no longer applied to subsequent drawing operations.

(Also see DirectX SDK: ID2D1RenderTarget::PopAxisAlignedClip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void PopAxisAlignedClip()
Visual Basic
Public Sub PopAxisAlignedClip
Visual C++
public:
void PopAxisAlignedClip()

Remarks

A PushAxisAlignedClip/PopAxisAlignedClip pair can occur around or within a PushLayer/PopLayer pair, but may not overlap. For example, a PushAxisAlignedClip, PushLayer, PopLayer, PopAxisAlignedClip sequence is valid, but a PushAxisAlignedClip, PushLayer, PopAxisAlignedClip, PopLayer sequence is not. PopAxisAlignedClip must be called once for every call to PushAxisAlignedClip.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PopLayer Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..PopLayer Method
RenderTarget Class See Also Send Feedback
Ends a layer that was defined with particular layer resources.

(Also see DirectX SDK: ID2D1RenderTarget::PopLayer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void PopLayer()
Visual Basic
Public Sub PopLayer
Visual C++
public:
void PopLayer()

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PushAxisAlignedClip Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..PushAxisAlignedClip Method
RenderTarget Class See Also Send Feedback
Pushes a clip. The clip can be antialiased. The clip must be axis aligned. If the current world transform is not axis preserving, then the bounding box of the transformed clip rect will be used. The clip will remain in effect until a PopAxisAligned clip call is made.

(Also see DirectX SDK: ID2D1RenderTarget::PushAxisAlignedClip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void PushAxisAlignedClip(
    RectF clipRect,
    AntiAliasMode antiAliasMode
)
Visual Basic
Public Sub PushAxisAlignedClip ( _
    clipRect As RectF, _
    antiAliasMode As AntiAliasMode _
)
Visual C++
public:
void PushAxisAlignedClip(
    RectF clipRect,
    AntiAliasMode antiAliasMode
)

Parameters

clipRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
The clipRect parameter.
antiAliasMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..AntiAliasMode
The antiAliasMode parameter.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PushLayer Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..PushLayer Method
RenderTarget Class See Also Send Feedback
Start a layer of drawing calls. The way in which the layer must be resolved is specified first as well as the logical resource that stores the layer parameters. The supplied layer resource might grow if the specified content cannot fit inside it. The layer will grow monitonically on each axis.

(Also see DirectX SDK: ID2D1RenderTarget::PushLayer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void PushLayer(
    LayerParameters layerParameters,
    Layer layer
)
Visual Basic
Public Sub PushLayer ( _
    layerParameters As LayerParameters, _
    layer As Layer _
)
Visual C++
public:
void PushLayer(
    LayerParameters layerParameters,
    Layer^ layer
)

Parameters

layerParameters
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LayerParameters
The layerParameters parameter.
layer
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Layer
The layer parameter.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RestoreDrawingState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..RestoreDrawingState Method
RenderTarget Class See Also Send Feedback
Copies the state stored in the block interface.

(Also see DirectX SDK: ID2D1RenderTarget::RestoreDrawingState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void RestoreDrawingState(
    DrawingStateBlock drawingStateBlock
)
Visual Basic
Public Sub RestoreDrawingState ( _
    drawingStateBlock As DrawingStateBlock _
)
Visual C++
public:
void RestoreDrawingState(
    DrawingStateBlock^ drawingStateBlock
)

Parameters

drawingStateBlock
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateBlock
The drawingStateBlock parameter.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SaveDrawingState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..SaveDrawingState Method
RenderTarget Class See Also Send Feedback
Gets the current drawing state and saves it into the supplied IDrawingStatckBlock.

(Also see DirectX SDK: ID2D1RenderTarget::SaveDrawingState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SaveDrawingState(
    DrawingStateBlock drawingStateBlock
)
Visual Basic
Public Sub SaveDrawingState ( _
    drawingStateBlock As DrawingStateBlock _
)
Visual C++
public:
void SaveDrawingState(
    DrawingStateBlock^ drawingStateBlock
)

Parameters

drawingStateBlock
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DrawingStateBlock
The drawingStateBlock parameter.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TryEndDraw Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..TryEndDraw Method
RenderTarget Class See Also Send Feedback
Ends drawing on the render target, error results can be retrieved at this time, or when calling Flush() or TryFlush().

(Also see DirectX SDK: ID2D1RenderTarget::EndDraw)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool TryEndDraw(
    out Tags tags,
    out ErrorCode errorCode
)
Visual Basic
Public Function TryEndDraw ( _
    <OutAttribute> ByRef tags As Tags, _
    <OutAttribute> ByRef errorCode As ErrorCode _
) As Boolean
Visual C++
public:
bool TryEndDraw(
    [OutAttribute] Tags% tags,
    [OutAttribute] ErrorCode% errorCode
)

Parameters

tags
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Tags %
The associated tags.
errorCode
Type: Microsoft.WindowsAPICodePack.DirectX..::..ErrorCode %
The associated tags.

Return Value

True if successful; False otherwise. If unsuccessful, the tags and errorCode parameters should be used to find out which operation has failed.

Remarks

This method does not throw Direct2D exceptions if a drawing error occur while rendering shapes.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TryFlush Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..TryFlush Method
RenderTarget Class See Also Send Feedback
Executes all pending drawing commands.

(Also see DirectX SDK: ID2D1RenderTarget::EndDraw)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool TryFlush(
    out Tags tags,
    out ErrorCode errorCode
)
Visual Basic
Public Function TryFlush ( _
    <OutAttribute> ByRef tags As Tags, _
    <OutAttribute> ByRef errorCode As ErrorCode _
) As Boolean
Visual C++
public:
bool TryFlush(
    [OutAttribute] Tags% tags,
    [OutAttribute] ErrorCode% errorCode
)

Parameters

tags
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Tags %
The associated tags.
errorCode
Type: Microsoft.WindowsAPICodePack.DirectX..::..ErrorCode %
The associated tags.

Return Value

True if successful; False otherwise. If unsuccessful, the tags and errorCode parameters should be used to find out which operation has failed.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTarget Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget Properties
RenderTarget Class See Also Send Feedback

The RenderTarget type exposes the following members.

Properties

 | Name | Description
Public property | AntiAliasMode | The current antialiasing mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetAntiAliasMode, ID2D1RenderTarget::SetAntiAliasMode)
Public property | Dpi | The DPI on the render target. This results in the render target being interpretted to a different scale. Neither DPI can be negative. If zero is specified for both, the system DPI is chosen. If one is zero and the other unspecified, the DPI is not changed. (Also see DirectX SDK: ID2D1RenderTarget::GetDpi, ID2D1RenderTarget::SetDpi)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | GdiInteropRenderTarget | Provide a GdiInteropRenderTarget version of this render target.
Public property | MaximumBitmapSize | Returns the maximum bitmap and render target size that is guaranteed to be supported by the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetMaximumBitmapSize)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | The pixel format and alpha mode of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelFormat)
Public property | PixelSize | Returns the size of the render target in pixels. (Also see DirectX SDK: ID2D1RenderTarget::GetPixelSize)
Public property | Size | Returns the size of the render target in DIPs. (Also see DirectX SDK: ID2D1RenderTarget::GetSize)
Public property | Tags | Get or Set a tag to labelto the succeeding drawing operations. If an error occurs while rendering a primtive, the tags can be returned from the Flush or EndDraw call. (Also see DirectX SDK: ID2D1RenderTarget::GetTags, ID2D1RenderTarget::SetTags)
Public property | TextAntiAliasMode | The current antialiasing mode for text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextAntiAliasMode, ID2D1RenderTarget::SetTextAntiAliasMode)
Public property | TextRenderingParams | Gets or set the render target's current text-rendering options. Text rendering options to apply to all text and glyph drawing operations. (Also see DirectX SDK: ID2D1RenderTarget::GetTextRenderingParams, ID2D1RenderTarget::SetTextRenderingParams)
Public property | Transform | The current transform of the render target. (Also see DirectX SDK: ID2D1RenderTarget::GetTransform, ID2D1RenderTarget::SetTransform)

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AntiAliasMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..AntiAliasMode Property
RenderTarget Class See Also Send Feedback
The current antialiasing mode of the render target.

(Also see DirectX SDK: ID2D1RenderTarget::GetAntiAliasMode, ID2D1RenderTarget::SetAntiAliasMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public AntiAliasMode AntiAliasMode { get; set; }
Visual Basic
Public Property AntiAliasMode As AntiAliasMode
    Get
    Set
Visual C++
public:
property AntiAliasMode AntiAliasMode {
    AntiAliasMode get ();
    void set (AntiAliasMode value);
}

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Dpi Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..Dpi Property
RenderTarget Class See Also Send Feedback
The DPI on the render target. This results in the render target being interpretted to a different scale. Neither DPI can be negative. If zero is specified for both, the system DPI is chosen. If one is zero and the other unspecified, the DPI is not changed.

(Also see DirectX SDK: ID2D1RenderTarget::GetDpi, ID2D1RenderTarget::SetDpi)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DpiF Dpi { get; set; }
Visual Basic
Public Property Dpi As DpiF
    Get
    Set
Visual C++
public:
property DpiF Dpi {
    DpiF get ();
    void set (DpiF value);
}

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GdiInteropRenderTarget Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..GdiInteropRenderTarget Property
RenderTarget Class See Also Send Feedback
Provide a GdiInteropRenderTarget version of this render target.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GdiInteropRenderTarget GdiInteropRenderTarget { get; }
Visual Basic
Public ReadOnly Property GdiInteropRenderTarget As GdiInteropRenderTarget
    Get
Visual C++
public:
property GdiInteropRenderTarget^ GdiInteropRenderTarget {
    GdiInteropRenderTarget^ get ();
}

Remarks

Not all render targets support GdiInteropRenderTarget. The render target must be GDI-compatible (the RenderTargetUsages.GdiCompatible flag was specified when creating the render target), use the Graphics's Format.B8G8R8A8UNorm pixel format, and use the AlphaMode.Premultiplied or AlphaMode.Ignore alpha mode. Note that this method always succeeds; if the render target doesn't support the GdiInteropRenderTarget interface, calling GetDC will fail. (For render targets created through the CreateCompatibleRenderTarget method, the render target that created it must have these settings.) To test whether a given render target supports GdiInteropRenderTarget, create a RenderTargetProperties that specifies GDI compatibility and the appropriate pixel format, then call the render target's IsSupported property to see whether the render target is GDI-compatible.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


MaximumBitmapSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..MaximumBitmapSize Property
RenderTarget Class See Also Send Feedback
Returns the maximum bitmap and render target size that is guaranteed to be supported by the render target.

(Also see DirectX SDK: ID2D1RenderTarget::GetMaximumBitmapSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MaximumBitmapSize { get; }
Visual Basic
Public ReadOnly Property MaximumBitmapSize As UInteger
    Get
Visual C++
public:
property unsigned int MaximumBitmapSize {
    unsigned int get ();
}

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..PixelFormat Property
RenderTarget Class See Also Send Feedback
The pixel format and alpha mode of the render target.

(Also see DirectX SDK: ID2D1RenderTarget::GetPixelFormat)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelFormat PixelFormat { get; }
Visual Basic
Public ReadOnly Property PixelFormat As PixelFormat
    Get
Visual C++
public:
property PixelFormat PixelFormat {
    PixelFormat get ();
}

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..PixelSize Property
RenderTarget Class See Also Send Feedback
Returns the size of the render target in pixels.

(Also see DirectX SDK: ID2D1RenderTarget::GetPixelSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SizeU PixelSize { get; }
Visual Basic
Public ReadOnly Property PixelSize As SizeU
    Get
Visual C++
public:
property SizeU PixelSize {
    SizeU get ();
}

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Size Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..Size Property
RenderTarget Class See Also Send Feedback
Returns the size of the render target in DIPs.

(Also see DirectX SDK: ID2D1RenderTarget::GetSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SizeF Size { get; }
Visual Basic
Public ReadOnly Property Size As SizeF
    Get
Visual C++
public:
property SizeF Size {
    SizeF get ();
}

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tags Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..Tags Property
RenderTarget Class See Also Send Feedback
Get or Set a tag to labelto the succeeding drawing operations. If an error occurs while rendering a primtive, the tags can be returned from the Flush or EndDraw call.

(Also see DirectX SDK: ID2D1RenderTarget::GetTags, ID2D1RenderTarget::SetTags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Tags Tags { get; set; }
Visual Basic
Public Property Tags As Tags
    Get
    Set
Visual C++
public:
property Tags Tags {
    Tags get ();
    void set (Tags value);
}

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TextAntiAliasMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..TextAntiAliasMode Property
RenderTarget Class See Also Send Feedback
The current antialiasing mode for text and glyph drawing operations.

(Also see DirectX SDK: ID2D1RenderTarget::GetTextAntiAliasMode, ID2D1RenderTarget::SetTextAntiAliasMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextAntiAliasMode TextAntiAliasMode { get; set; }
Visual Basic
Public Property TextAntiAliasMode As TextAntiAliasMode
    Get
    Set
Visual C++
public:
property TextAntiAliasMode TextAntiAliasMode {
    TextAntiAliasMode get ();
    void set (TextAntiAliasMode value);
}

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TextRenderingParams Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..TextRenderingParams Property
RenderTarget Class See Also Send Feedback
Gets or set the render target's current text-rendering options. Text rendering options to apply to all text and glyph drawing operations.

(Also see DirectX SDK: ID2D1RenderTarget::GetTextRenderingParams, ID2D1RenderTarget::SetTextRenderingParams)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderingParams TextRenderingParams { get; set; }
Visual Basic
Public Property TextRenderingParams As RenderingParams
    Get
    Set
Visual C++
public:
property RenderingParams^ TextRenderingParams {
    RenderingParams^ get ();
    void set (RenderingParams^ value);
}

Remarks

Note that the render target's text antialiasing mode overrides any antialiasing mode specified by the RenderingParams object.

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Transform Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTarget..::..Transform Property
RenderTarget Class See Also Send Feedback
The current transform of the render target.

(Also see DirectX SDK: ID2D1RenderTarget::GetTransform, ID2D1RenderTarget::SetTransform)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix3x2F Transform { get; set; }
Visual Basic
Public Property Transform As Matrix3x2F
    Get
    Set
Visual C++
public:
property Matrix3x2F Transform {
    Matrix3x2F get ();
    void set (Matrix3x2F value);
}

See Also

RenderTarget Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTargetProperties Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties Structure
Members See Also Send Feedback
Contains rendering options (hardware or software), pixel format, DPI information, remoting options, and Direct3D support requirements for a render target.

(Also see DirectX SDK: D2D1_RENDER_TARGET_PROPERTIES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RenderTargetProperties
Visual Basic
Public Structure RenderTargetProperties
Visual C++
public value class RenderTargetProperties

See Also

RenderTargetProperties Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTargetProperties Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties Members
RenderTargetProperties Structure Constructors Methods Operators Properties See Also Send Feedback

The RenderTargetProperties type exposes the following members.

Constructors

 | Name | Description
Public method | RenderTargetProperties | Constructor for the RenderTargetProperties value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | DpiX | The horizontal DPI of the render target. To use the default DPI, set dpiX and dpiY to 0.
Public property | DpiY | The verical DPI of the render target. To use the default DPI, set dpiX and dpiY to 0.
Public property | MinLevel | A value that specifies the minimum Direct3D feature level required for hardware rendering. If the specified minimum level is not available, the render target uses software rendering if the type member is set to Default; if type is set to to Hardware, render target creation fails. A value of Default indicates that Direct2D should determine whether the Direct3D feature level of the device is adequate. This property is used only when creating HwndRenderTarget and DCRenderTarget objects.
Public property | PixelFormat | The pixel format and alpha mode of the render target.
Public property | RenderTargetType | A value that specifies whether the render target should force hardware or software rendering. A value of Default specifies that the render target should use hardware rendering if it is available; otherwise, it uses software rendering. Note that WIC bitmap render targets do not support hardware rendering.
Public property | Usage | A value that specifies how the render target is remoted and whether it should be GDI-compatible. Set to None to create a render target that is not compatible with GDI and uses Direct3D command-stream remoting if it is available.

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTargetProperties Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties Constructor
RenderTargetProperties Structure See Also Send Feedback
Constructor for the RenderTargetProperties value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetProperties(
    RenderTargetType type,
    PixelFormat pixelFormat,
    float dpiX,
    float dpiY,
    RenderTargetUsages usage,
    FeatureLevel minLevel
)
Visual Basic
Public Sub New ( _
    type As RenderTargetType, _
    pixelFormat As PixelFormat, _
    dpiX As Single, _
    dpiY As Single, _
    usage As RenderTargetUsages, _
    minLevel As FeatureLevel _
)
Visual C++
public:
RenderTargetProperties(
    RenderTargetType type,
    PixelFormat pixelFormat,
    float dpiX,
    float dpiY,
    RenderTargetUsages usage,
    FeatureLevel minLevel
)

Parameters

type
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetType
Initializes the Type property.
pixelFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PixelFormat
Initializes the PixelFormat property.
dpiX
Type: System..::..Single
Initializes the DpiX property.
dpiY
Type: System..::..Single
Initializes the DpiY property.
usage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetUsages
Initializes the Usage property.
minLevel
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..FeatureLevel
Initializes the MinLevel property.

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTargetProperties Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties Methods
RenderTargetProperties Structure See Also Send Feedback

The RenderTargetProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..Equals Method
RenderTargetProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..GetHashCode Method
RenderTargetProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTargetProperties Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties Operators
RenderTargetProperties Structure See Also Send Feedback

The RenderTargetProperties type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..Equality Operator
RenderTargetProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    RenderTargetProperties renderTargetProperties1,
    RenderTargetProperties renderTargetProperties2
)
Visual Basic
Public Shared Operator = ( _
    renderTargetProperties1 As RenderTargetProperties, _
    renderTargetProperties2 As RenderTargetProperties _
) As Boolean
Visual C++
public:
static bool operator ==(
    RenderTargetProperties renderTargetProperties1,
    RenderTargetProperties renderTargetProperties2
)

Parameters

renderTargetProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetProperties
renderTargetProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetProperties

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..Inequality Operator
RenderTargetProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    RenderTargetProperties renderTargetProperties1,
    RenderTargetProperties renderTargetProperties2
)
Visual Basic
Public Shared Operator <> ( _
    renderTargetProperties1 As RenderTargetProperties, _
    renderTargetProperties2 As RenderTargetProperties _
) As Boolean
Visual C++
public:
static bool operator !=(
    RenderTargetProperties renderTargetProperties1,
    RenderTargetProperties renderTargetProperties2
)

Parameters

renderTargetProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetProperties
renderTargetProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RenderTargetProperties

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTargetProperties Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties Properties
RenderTargetProperties Structure See Also Send Feedback

The RenderTargetProperties type exposes the following members.

Properties

 | Name | Description
Public property | DpiX | The horizontal DPI of the render target. To use the default DPI, set dpiX and dpiY to 0.
Public property | DpiY | The verical DPI of the render target. To use the default DPI, set dpiX and dpiY to 0.
Public property | MinLevel | A value that specifies the minimum Direct3D feature level required for hardware rendering. If the specified minimum level is not available, the render target uses software rendering if the type member is set to Default; if type is set to to Hardware, render target creation fails. A value of Default indicates that Direct2D should determine whether the Direct3D feature level of the device is adequate. This property is used only when creating HwndRenderTarget and DCRenderTarget objects.
Public property | PixelFormat | The pixel format and alpha mode of the render target.
Public property | RenderTargetType | A value that specifies whether the render target should force hardware or software rendering. A value of Default specifies that the render target should use hardware rendering if it is available; otherwise, it uses software rendering. Note that WIC bitmap render targets do not support hardware rendering.
Public property | Usage | A value that specifies how the render target is remoted and whether it should be GDI-compatible. Set to None to create a render target that is not compatible with GDI and uses Direct3D command-stream remoting if it is available.

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..DpiX Property
RenderTargetProperties Structure See Also Send Feedback
The horizontal DPI of the render target. To use the default DPI, set dpiX and dpiY to 0.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float DpiX { get; set; }
Visual Basic
Public Property DpiX As Single
    Get
    Set
Visual C++
public:
property float DpiX {
    float get ();
    void set (float value);
}

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DpiY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..DpiY Property
RenderTargetProperties Structure See Also Send Feedback
The verical DPI of the render target. To use the default DPI, set dpiX and dpiY to 0.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float DpiY { get; set; }
Visual Basic
Public Property DpiY As Single
    Get
    Set
Visual C++
public:
property float DpiY {
    float get ();
    void set (float value);
}

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


MinLevel Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..MinLevel Property
RenderTargetProperties Structure See Also Send Feedback
A value that specifies the minimum Direct3D feature level required for hardware rendering. If the specified minimum level is not available, the render target uses software rendering if the type member is set to Default; if type is set to to Hardware, render target creation fails. A value of Default indicates that Direct2D should determine whether the Direct3D feature level of the device is adequate. This property is used only when creating HwndRenderTarget and DCRenderTarget objects.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FeatureLevel MinLevel { get; set; }
Visual Basic
Public Property MinLevel As FeatureLevel
    Get
    Set
Visual C++
public:
property FeatureLevel MinLevel {
    FeatureLevel get ();
    void set (FeatureLevel value);
}

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


PixelFormat Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..PixelFormat Property
RenderTargetProperties Structure See Also Send Feedback
The pixel format and alpha mode of the render target.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelFormat PixelFormat { get; set; }
Visual Basic
Public Property PixelFormat As PixelFormat
    Get
    Set
Visual C++
public:
property PixelFormat PixelFormat {
    PixelFormat get ();
    void set (PixelFormat value);
}

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTargetType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..RenderTargetType Property
RenderTargetProperties Structure See Also Send Feedback
A value that specifies whether the render target should force hardware or software rendering. A value of Default specifies that the render target should use hardware rendering if it is available; otherwise, it uses software rendering. Note that WIC bitmap render targets do not support hardware rendering.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetType RenderTargetType { get; set; }
Visual Basic
Public Property RenderTargetType As RenderTargetType
    Get
    Set
Visual C++
public:
property RenderTargetType RenderTargetType {
    RenderTargetType get ();
    void set (RenderTargetType value);
}

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Usage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetProperties..::..Usage Property
RenderTargetProperties Structure See Also Send Feedback
A value that specifies how the render target is remoted and whether it should be GDI-compatible. Set to None to create a render target that is not compatible with GDI and uses Direct3D command-stream remoting if it is available.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetUsages Usage { get; set; }
Visual Basic
Public Property Usage As RenderTargetUsages
    Get
    Set
Visual C++
public:
property RenderTargetUsages Usage {
    RenderTargetUsages get ();
    void set (RenderTargetUsages value);
}

See Also

RenderTargetProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTargetType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetType Enumeration
See Also Send Feedback
Describes whether a render target uses hardware or software rendering, or if Direct2D should select the rendering mode.

(Also see DirectX SDK: D2D1_RENDER_TARGET_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum RenderTargetType
Visual Basic
Public Enumeration RenderTargetType
Visual C++
public enum class RenderTargetType

Members

Member name | Description
Hardware |
Software |
Default |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RenderTargetUsages Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetUsages Enumeration
See Also Send Feedback
Describes how a render target is remoted and whether it should be GDI-compatible. This enumeration allows a bitwise combination of its member values.

(Also see DirectX SDK: D2D1_RENDER_TARGET_USAGE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum RenderTargetUsages
Visual Basic
<FlagsAttribute> _
Public Enumeration RenderTargetUsages
Visual C++
[FlagsAttribute]
public enum class RenderTargetUsages

Members

Member name | Description
GdiCompatible |
None |
ForceBitmapRemoting |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRect Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect Structure
Members See Also Send Feedback
Contains the dimensions and corner radii of a rounded rectangle.

(Also see DirectX SDK: D2D1_ROUNDED_RECT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RoundedRect
Visual Basic
Public Structure RoundedRect
Visual C++
public value class RoundedRect

See Also

RoundedRect Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRect Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect Members
RoundedRect Structure Constructors Methods Operators Properties See Also Send Feedback

The RoundedRect type exposes the following members.

Constructors

 | Name | Description
Public method | RoundedRect | Constructor for the RoundedRect value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | RadiusX | The x-radius for the quarter ellipse that is drawn to replace every corner of the rectangle.
Public property | RadiusY | The y-radius for the quarter ellipse that is drawn to replace every corner of the rectangle.
Public property | Rect | The coordinates of the rectangle.

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRect Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect Constructor
RoundedRect Structure See Also Send Feedback
Constructor for the RoundedRect value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RoundedRect(
    RectF rect,
    float radiusX,
    float radiusY
)
Visual Basic
Public Sub New ( _
    rect As RectF, _
    radiusX As Single, _
    radiusY As Single _
)
Visual C++
public:
RoundedRect(
    RectF rect,
    float radiusX,
    float radiusY
)

Parameters

rect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RectF
Initializes the Rect property.
radiusX
Type: System..::..Single
Initializes the RadiusX property.
radiusY
Type: System..::..Single
Initializes the RadiusY property.

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRect Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect Methods
RoundedRect Structure See Also Send Feedback

The RoundedRect type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect..::..Equals Method
RoundedRect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect..::..GetHashCode Method
RoundedRect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRect Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect Operators
RoundedRect Structure See Also Send Feedback

The RoundedRect type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect..::..Equality Operator
RoundedRect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    RoundedRect rect1,
    RoundedRect rect2
)
Visual Basic
Public Shared Operator = ( _
    rect1 As RoundedRect, _
    rect2 As RoundedRect _
) As Boolean
Visual C++
public:
static bool operator ==(
    RoundedRect rect1,
    RoundedRect rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRect
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRect

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect..::..Inequality Operator
RoundedRect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    RoundedRect rect1,
    RoundedRect rect2
)
Visual Basic
Public Shared Operator <> ( _
    rect1 As RoundedRect, _
    rect2 As RoundedRect _
) As Boolean
Visual C++
public:
static bool operator !=(
    RoundedRect rect1,
    RoundedRect rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRect
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRect

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRect Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect Properties
RoundedRect Structure See Also Send Feedback

The RoundedRect type exposes the following members.

Properties

 | Name | Description
Public property | RadiusX | The x-radius for the quarter ellipse that is drawn to replace every corner of the rectangle.
Public property | RadiusY | The y-radius for the quarter ellipse that is drawn to replace every corner of the rectangle.
Public property | Rect | The coordinates of the rectangle.

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadiusX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect..::..RadiusX Property
RoundedRect Structure See Also Send Feedback
The x-radius for the quarter ellipse that is drawn to replace every corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float RadiusX { get; set; }
Visual Basic
Public Property RadiusX As Single
    Get
    Set
Visual C++
public:
property float RadiusX {
    float get ();
    void set (float value);
}

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RadiusY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect..::..RadiusY Property
RoundedRect Structure See Also Send Feedback
The y-radius for the quarter ellipse that is drawn to replace every corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float RadiusY { get; set; }
Visual Basic
Public Property RadiusY As Single
    Get
    Set
Visual C++
public:
property float RadiusY {
    float get ();
    void set (float value);
}

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Rect Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRect..::..Rect Property
RoundedRect Structure See Also Send Feedback
The coordinates of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RectF Rect { get; set; }
Visual Basic
Public Property Rect As RectF
    Get
    Set
Visual C++
public:
property RectF Rect {
    RectF get ();
    void set (RectF value);
}

See Also

RoundedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRectangleGeometry Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry Class
Members See Also Send Feedback
Describes a rounded rectangle.

(Also see DirectX SDK: ID2D1RoundedRectangleGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RoundedRectangleGeometry : Geometry
Visual Basic
Public Class RoundedRectangleGeometry _
    Inherits Geometry
Visual C++
public ref class RoundedRectangleGeometry : public Geometry

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..RoundedRectangleGeometry

See Also

RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRectangleGeometry Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry Members
RoundedRectangleGeometry Class Methods Properties See Also Send Feedback

The RoundedRectangleGeometry type exposes the following members.

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | RoundedRectangle | Retrieves a rounded rectangle that describes this rounded rectangle geometry. (Also see DirectX SDK: ID2D1RoundedRectangleGeometry::GetRoundedRect)

See Also

RoundedRectangleGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRectangleGeometry Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry Methods
RoundedRectangleGeometry Class See Also Send Feedback

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..CombineWithGeometry Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..CompareWithGeometry Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..ComputeArea Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..ComputeLength Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..ComputePointAtLength Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..FillContainsPoint Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..GetBounds Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..GetWidenedBounds Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..Outline Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..Simplify Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..StrokeContainsPoint Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..Tessellate Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..Widen Method
RoundedRectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

RoundedRectangleGeometry Class
RoundedRectangleGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRectangleGeometry Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry Properties
RoundedRectangleGeometry Class See Also Send Feedback

The RoundedRectangleGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | RoundedRectangle | Retrieves a rounded rectangle that describes this rounded rectangle geometry. (Also see DirectX SDK: ID2D1RoundedRectangleGeometry::GetRoundedRect)

See Also

RoundedRectangleGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


RoundedRectangle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RoundedRectangleGeometry..::..RoundedRectangle Property
RoundedRectangleGeometry Class See Also Send Feedback
Retrieves a rounded rectangle that describes this rounded rectangle geometry.

(Also see DirectX SDK: ID2D1RoundedRectangleGeometry::GetRoundedRect)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RoundedRect RoundedRectangle { get; }
Visual Basic
Public ReadOnly Property RoundedRectangle As RoundedRect
    Get
Visual C++
public:
property RoundedRect RoundedRectangle {
    RoundedRect get ();
}

See Also

RoundedRectangleGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SimplifiedGeometrySink Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink Class
Members See Also Send Feedback
Describes a geometric path that does not contain quadratic bezier curves or arcs.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class SimplifiedGeometrySink : DirectUnknown,
    ISimplifiedGeometrySink
Visual Basic
Public Class SimplifiedGeometrySink _
    Inherits DirectUnknown _
    Implements ISimplifiedGeometrySink
Visual C++
public ref class SimplifiedGeometrySink : public DirectUnknown,
    ISimplifiedGeometrySink

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SimplifiedGeometrySink
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..GeometrySink

See Also

SimplifiedGeometrySink Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SimplifiedGeometrySink Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink Members
SimplifiedGeometrySink Class Methods Properties See Also Send Feedback

The SimplifiedGeometrySink type exposes the following members.

Methods

 | Name | Description
Public method | AddBeziers |
Public method | AddLines |
Public method | BeginFigure | Starts a new figure at the specified point. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure)
Public method | Close | Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close)
Public method | EndFigure | Ends the current figure; optionally, closes it. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure)
Public method | SetFillMode | Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode)
Public method | SetSegmentFlags | Specifies stroke and join options to be applied to new segments added to the geometry sink. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags)

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SimplifiedGeometrySink Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink Methods
SimplifiedGeometrySink Class See Also Send Feedback

The SimplifiedGeometrySink type exposes the following members.

Methods

 | Name | Description
Public method | AddBeziers |
Public method | AddLines |
Public method | BeginFigure | Starts a new figure at the specified point. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure)
Public method | Close | Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close)
Public method | EndFigure | Ends the current figure; optionally, closes it. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure)
Public method | SetFillMode | Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode)
Public method | SetSegmentFlags | Specifies stroke and join options to be applied to new segments added to the geometry sink. (Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags)

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddBeziers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink..::..AddBeziers Method
SimplifiedGeometrySink Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void AddBeziers(
    IEnumerable<BezierSegment> beziers
)
Visual Basic
Public Overridable Sub AddBeziers ( _
    beziers As IEnumerable(Of BezierSegment) _
)
Visual C++
public:
virtual void AddBeziers(
    IEnumerable<BezierSegment>^ beziers
)

Parameters

beziers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BezierSegment >)>)>

Implements

ISimplifiedGeometrySink..::..AddBeziers(IEnumerable<(Of <<'(BezierSegment>)>>))

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddLines Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink..::..AddLines Method
SimplifiedGeometrySink Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void AddLines(
    IEnumerable<Point2F> points
)
Visual Basic
Public Overridable Sub AddLines ( _
    points As IEnumerable(Of Point2F) _
)
Visual C++
public:
virtual void AddLines(
    IEnumerable<Point2F>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Point2F >)>)>

Implements

ISimplifiedGeometrySink..::..AddLines(IEnumerable<(Of <<'(Point2F>)>>))

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


BeginFigure Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink..::..BeginFigure Method
SimplifiedGeometrySink Class See Also Send Feedback
Starts a new figure at the specified point.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::BeginFigure)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void BeginFigure(
    Point2F startPoint,
    FigureBegin figureBegin
)
Visual Basic
Public Overridable Sub BeginFigure ( _
    startPoint As Point2F, _
    figureBegin As FigureBegin _
)
Visual C++
public:
virtual void BeginFigure(
    Point2F startPoint,
    FigureBegin figureBegin
)

Parameters

startPoint
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The point at which to begin the new figure.
figureBegin
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FigureBegin
Whether the new figure should be hollow or filled.

Implements

ISimplifiedGeometrySink..::..BeginFigure(Point2F, FigureBegin)

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Close Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink..::..Close Method
SimplifiedGeometrySink Class See Also Send Feedback
Closes the geometry sink, throwing an exception if is in an error state, and resets the sink's error state.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::Close)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

Implements

ISimplifiedGeometrySink..::..Close()()()()

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EndFigure Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink..::..EndFigure Method
SimplifiedGeometrySink Class See Also Send Feedback
Ends the current figure; optionally, closes it.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::EndFigure)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void EndFigure(
    FigureEnd figureEnd
)
Visual Basic
Public Overridable Sub EndFigure ( _
    figureEnd As FigureEnd _
)
Visual C++
public:
virtual void EndFigure(
    FigureEnd figureEnd
)

Parameters

figureEnd
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FigureEnd
A value that indicates whether the current figure is closed. If the figure is closed, a line is drawn between the current point and the start point specified by BeginFigure.

Implements

ISimplifiedGeometrySink..::..EndFigure(FigureEnd)

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SetFillMode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink..::..SetFillMode Method
SimplifiedGeometrySink Class See Also Send Feedback
Specifies the method used to determine which points are inside the geometry described by this geometry sink and which points are outside.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetFillMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void SetFillMode(
    FillMode fillMode
)
Visual Basic
Public Overridable Sub SetFillMode ( _
    fillMode As FillMode _
)
Visual C++
public:
virtual void SetFillMode(
    FillMode fillMode
)

Parameters

fillMode
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..FillMode
The method used to determine whether a given point is part of the geometry.

Implements

ISimplifiedGeometrySink..::..SetFillMode(FillMode)

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SetSegmentFlags Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink..::..SetSegmentFlags Method
SimplifiedGeometrySink Class See Also Send Feedback
Specifies stroke and join options to be applied to new segments added to the geometry sink.

(Also see DirectX SDK: ID2D1SimplifiedGeometrySink::SetSegmentFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void SetSegmentFlags(
    PathSegmentOptions vertexOptions
)
Visual Basic
Public Overridable Sub SetSegmentFlags ( _
    vertexOptions As PathSegmentOptions _
)
Visual C++
public:
virtual void SetSegmentFlags(
    PathSegmentOptions vertexOptions
)

Parameters

vertexOptions
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..PathSegmentOptions
Stroke and join options to be applied to new segments added to the geometry sink.

Implements

ISimplifiedGeometrySink..::..SetSegmentFlags(PathSegmentOptions)

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SimplifiedGeometrySink Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SimplifiedGeometrySink Properties
SimplifiedGeometrySink Class See Also Send Feedback

The SimplifiedGeometrySink type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

SimplifiedGeometrySink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeF Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF Structure
Members See Also Send Feedback
Stores an ordered pair of integers, typically the width and height of a rectangle.

(Also see DirectX SDK: D2D1_SIZE_F)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SizeF
Visual Basic
Public Structure SizeF
Visual C++
public value class SizeF

See Also

SizeF Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeF Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF Members
SizeF Structure Constructors Methods Operators Properties See Also Send Feedback

The SizeF type exposes the following members.

Constructors

 | Name | Description
Public method | SizeF | Constructor for the SizeF value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Height | The vertical component of this size.
Public property | Width | The horizontal component of this size.

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeF Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF Constructor
SizeF Structure See Also Send Feedback
Constructor for the SizeF value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SizeF(
    float width,
    float height
)
Visual Basic
Public Sub New ( _
    width As Single, _
    height As Single _
)
Visual C++
public:
SizeF(
    float width,
    float height
)

Parameters

width
Type: System..::..Single
Initializes the Width property.
height
Type: System..::..Single
Initializes the Height property.

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeF Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF Methods
SizeF Structure See Also Send Feedback

The SizeF type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF..::..Equals Method
SizeF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF..::..GetHashCode Method
SizeF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeF Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF Operators
SizeF Structure See Also Send Feedback

The SizeF type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF..::..Equality Operator
SizeF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    SizeF size1,
    SizeF size2
)
Visual Basic
Public Shared Operator = ( _
    size1 As SizeF, _
    size2 As SizeF _
) As Boolean
Visual C++
public:
static bool operator ==(
    SizeF size1,
    SizeF size2
)

Parameters

size1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
size2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF..::..Inequality Operator
SizeF Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    SizeF size1,
    SizeF size2
)
Visual Basic
Public Shared Operator <> ( _
    size1 As SizeF, _
    size2 As SizeF _
) As Boolean
Visual C++
public:
static bool operator !=(
    SizeF size1,
    SizeF size2
)

Parameters

size1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF
size2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeF

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeF Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF Properties
SizeF Structure See Also Send Feedback

The SizeF type exposes the following members.

Properties

 | Name | Description
Public property | Height | The vertical component of this size.
Public property | Width | The horizontal component of this size.

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF..::..Height Property
SizeF Structure See Also Send Feedback
The vertical component of this size.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeF..::..Width Property
SizeF Structure See Also Send Feedback
The horizontal component of this size.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

SizeF Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeU Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU Structure
Members See Also Send Feedback
Stores an ordered pair of integers, typically the width and height of a rectangle.

(Also see DirectX SDK: D2D1_SIZE_U)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SizeU
Visual Basic
Public Structure SizeU
Visual C++
public value class SizeU

See Also

SizeU Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeU Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU Members
SizeU Structure Constructors Methods Operators Properties See Also Send Feedback

The SizeU type exposes the following members.

Constructors

 | Name | Description
Public method | SizeU | Constructor for the SizeU value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Height | The vertical component of this size.
Public property | Width | The horizontal component of this size.

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeU Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU Constructor
SizeU Structure See Also Send Feedback
Constructor for the SizeU value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SizeU(
    uint width,
    uint height
)
Visual Basic
Public Sub New ( _
    width As UInteger, _
    height As UInteger _
)
Visual C++
public:
SizeU(
    unsigned int width,
    unsigned int height
)

Parameters

width
Type: System..::..UInt32
Initializes the Width property.
height
Type: System..::..UInt32
Initializes the Height property.

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeU Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU Methods
SizeU Structure See Also Send Feedback

The SizeU type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU..::..Equals Method
SizeU Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU..::..GetHashCode Method
SizeU Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeU Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU Operators
SizeU Structure See Also Send Feedback

The SizeU type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU..::..Equality Operator
SizeU Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    SizeU size1,
    SizeU size2
)
Visual Basic
Public Shared Operator = ( _
    size1 As SizeU, _
    size2 As SizeU _
) As Boolean
Visual C++
public:
static bool operator ==(
    SizeU size1,
    SizeU size2
)

Parameters

size1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
size2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU..::..Inequality Operator
SizeU Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    SizeU size1,
    SizeU size2
)
Visual Basic
Public Shared Operator <> ( _
    size1 As SizeU, _
    size2 As SizeU _
) As Boolean
Visual C++
public:
static bool operator !=(
    SizeU size1,
    SizeU size2
)

Parameters

size1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU
size2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SizeU

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SizeU Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU Properties
SizeU Structure See Also Send Feedback

The SizeU type exposes the following members.

Properties

 | Name | Description
Public property | Height | The vertical component of this size.
Public property | Width | The horizontal component of this size.

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU..::..Height Property
SizeU Structure See Also Send Feedback
The vertical component of this size.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SizeU..::..Width Property
SizeU Structure See Also Send Feedback
The horizontal component of this size.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SizeU Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SolidColorBrush Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SolidColorBrush Class
Members See Also Send Feedback
Paints an area with a solid color.

(Also see DirectX SDK: ID2D1SolidColorBrush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class SolidColorBrush : Brush
Visual Basic
Public Class SolidColorBrush _
    Inherits Brush
Visual C++
public ref class SolidColorBrush : public Brush

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..SolidColorBrush

See Also

SolidColorBrush Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SolidColorBrush Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SolidColorBrush Members
SolidColorBrush Class Properties See Also Send Feedback

The SolidColorBrush type exposes the following members.

Properties

 | Name | Description
Public property | Color | The color of the solid color brush. (Also see DirectX SDK: ID2D1SolidColorBrush::GetColor, ID2D1SolidColorBrush::SetColor)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity) (Inherited from Brush.)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform) (Inherited from Brush.)

See Also

SolidColorBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SolidColorBrush Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SolidColorBrush Properties
SolidColorBrush Class See Also Send Feedback

The SolidColorBrush type exposes the following members.

Properties

 | Name | Description
Public property | Color | The color of the solid color brush. (Also see DirectX SDK: ID2D1SolidColorBrush::GetColor, ID2D1SolidColorBrush::SetColor)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Opacity | The opacity for when the brush is drawn over the entire fill of the brush. (Also see DirectX SDK: ID2D1Brush::SetOpacity, ID2D1Brush::GetOpacity) (Inherited from Brush.)
Public property | Transform | The transform that applies to everything drawn by the brush. (Also see DirectX SDK: ID2D1Brush::SetTransform) (Inherited from Brush.)

See Also

SolidColorBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Color Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SolidColorBrush..::..Color Property
SolidColorBrush Class See Also Send Feedback
The color of the solid color brush.

(Also see DirectX SDK: ID2D1SolidColorBrush::GetColor, ID2D1SolidColorBrush::SetColor)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorF Color { get; set; }
Visual Basic
Public Property Color As ColorF
    Get
    Set
Visual C++
public:
property ColorF Color {
    ColorF get ();
    void set (ColorF value);
}

See Also

SolidColorBrush Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeStyle Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle Class
Members See Also Send Feedback
Describes the caps, miter limit, line join, and dash information for a stroke.

(Also see DirectX SDK: ID2D1StrokeStyle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class StrokeStyle : D2DResource
Visual Basic
Public Class StrokeStyle _
    Inherits D2DResource
Visual C++
public ref class StrokeStyle : public D2DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyle

See Also

StrokeStyle Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeStyle Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle Members
StrokeStyle Class Properties See Also Send Feedback

The StrokeStyle type exposes the following members.

Properties

 | Name | Description
Public property | DashCap | Gets a value that specifies how the ends of each dash are drawn. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashCap)
Public property | Dashes | Returns the dashes from the object into an array. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashes)
Public property | DashesCount | Retrieves the number of entries in the dashes array. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashesCount)
Public property | DashOffset | Retrieves a value that specifies how far in the dash sequence the stroke will start. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashOffset)
Public property | DashStyle | Gets a value that describes the stroke's dash pattern. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashStyle)
Public property | EndCap | Retrieves the type of shape used at the end of a stroke. (Also see DirectX SDK: ID2D1StrokeStyle::GetEndCap)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | LineJoin | Retrieves the type of joint used at the vertices of a shape's outline. (Also see DirectX SDK: ID2D1StrokeStyle::GetLineJoin)
Public property | MiterLimit | Retrieves the limit on the ratio of the miter length to half the stroke's thickness. (Also see DirectX SDK: ID2D1StrokeStyle::GetMiterLimit)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | StartCap | Retrieves the type of shape used at the beginning of a stroke. (Also see DirectX SDK: ID2D1StrokeStyle::GetStartCap)

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeStyle Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle Properties
StrokeStyle Class See Also Send Feedback

The StrokeStyle type exposes the following members.

Properties

 | Name | Description
Public property | DashCap | Gets a value that specifies how the ends of each dash are drawn. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashCap)
Public property | Dashes | Returns the dashes from the object into an array. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashes)
Public property | DashesCount | Retrieves the number of entries in the dashes array. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashesCount)
Public property | DashOffset | Retrieves a value that specifies how far in the dash sequence the stroke will start. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashOffset)
Public property | DashStyle | Gets a value that describes the stroke's dash pattern. (Also see DirectX SDK: ID2D1StrokeStyle::GetDashStyle)
Public property | EndCap | Retrieves the type of shape used at the end of a stroke. (Also see DirectX SDK: ID2D1StrokeStyle::GetEndCap)
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | LineJoin | Retrieves the type of joint used at the vertices of a shape's outline. (Also see DirectX SDK: ID2D1StrokeStyle::GetLineJoin)
Public property | MiterLimit | Retrieves the limit on the ratio of the miter length to half the stroke's thickness. (Also see DirectX SDK: ID2D1StrokeStyle::GetMiterLimit)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | StartCap | Retrieves the type of shape used at the beginning of a stroke. (Also see DirectX SDK: ID2D1StrokeStyle::GetStartCap)

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DashCap Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle..::..DashCap Property
StrokeStyle Class See Also Send Feedback
Gets a value that specifies how the ends of each dash are drawn.

(Also see DirectX SDK: ID2D1StrokeStyle::GetDashCap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CapStyle DashCap { get; }
Visual Basic
Public ReadOnly Property DashCap As CapStyle
    Get
Visual C++
public:
property CapStyle DashCap {
    CapStyle get ();
}

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Dashes Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle..::..Dashes Property
StrokeStyle Class See Also Send Feedback
Returns the dashes from the object into an array.

(Also see DirectX SDK: ID2D1StrokeStyle::GetDashes)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<float> Dashes { get; }
Visual Basic
Public ReadOnly Property Dashes As IEnumerable(Of Single)
    Get
Visual C++
public:
property IEnumerable<float>^ Dashes {
    IEnumerable<float>^ get ();
}

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DashesCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle..::..DashesCount Property
StrokeStyle Class See Also Send Feedback
Retrieves the number of entries in the dashes array.

(Also see DirectX SDK: ID2D1StrokeStyle::GetDashesCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DashesCount { get; }
Visual Basic
Public ReadOnly Property DashesCount As UInteger
    Get
Visual C++
public:
property unsigned int DashesCount {
    unsigned int get ();
}

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DashOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle..::..DashOffset Property
StrokeStyle Class See Also Send Feedback
Retrieves a value that specifies how far in the dash sequence the stroke will start.

(Also see DirectX SDK: ID2D1StrokeStyle::GetDashOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float DashOffset { get; }
Visual Basic
Public ReadOnly Property DashOffset As Single
    Get
Visual C++
public:
property float DashOffset {
    float get ();
}

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DashStyle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle..::..DashStyle Property
StrokeStyle Class See Also Send Feedback
Gets a value that describes the stroke's dash pattern.

(Also see DirectX SDK: ID2D1StrokeStyle::GetDashStyle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DashStyle DashStyle { get; }
Visual Basic
Public ReadOnly Property DashStyle As DashStyle
    Get
Visual C++
public:
property DashStyle DashStyle {
    DashStyle get ();
}

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EndCap Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle..::..EndCap Property
StrokeStyle Class See Also Send Feedback
Retrieves the type of shape used at the end of a stroke.

(Also see DirectX SDK: ID2D1StrokeStyle::GetEndCap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CapStyle EndCap { get; }
Visual Basic
Public ReadOnly Property EndCap As CapStyle
    Get
Visual C++
public:
property CapStyle EndCap {
    CapStyle get ();
}

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LineJoin Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle..::..LineJoin Property
StrokeStyle Class See Also Send Feedback
Retrieves the type of joint used at the vertices of a shape's outline.

(Also see DirectX SDK: ID2D1StrokeStyle::GetLineJoin)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LineJoin LineJoin { get; }
Visual Basic
Public ReadOnly Property LineJoin As LineJoin
    Get
Visual C++
public:
property LineJoin LineJoin {
    LineJoin get ();
}

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


MiterLimit Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle..::..MiterLimit Property
StrokeStyle Class See Also Send Feedback
Retrieves the limit on the ratio of the miter length to half the stroke's thickness.

(Also see DirectX SDK: ID2D1StrokeStyle::GetMiterLimit)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MiterLimit { get; }
Visual Basic
Public ReadOnly Property MiterLimit As Single
    Get
Visual C++
public:
property float MiterLimit {
    float get ();
}

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StartCap Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyle..::..StartCap Property
StrokeStyle Class See Also Send Feedback
Retrieves the type of shape used at the beginning of a stroke.

(Also see DirectX SDK: ID2D1StrokeStyle::GetStartCap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CapStyle StartCap { get; }
Visual Basic
Public ReadOnly Property StartCap As CapStyle
    Get
Visual C++
public:
property CapStyle StartCap {
    CapStyle get ();
}

See Also

StrokeStyle Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeStyleProperties Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties Structure
Members See Also Send Feedback
Properties, aside from the width, that allow geometric penning to be specified.

(Also see DirectX SDK: D2D1_STROKE_STYLE_PROPERTIES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct StrokeStyleProperties
Visual Basic
Public Structure StrokeStyleProperties
Visual C++
public value class StrokeStyleProperties

See Also

StrokeStyleProperties Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeStyleProperties Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties Members
StrokeStyleProperties Structure Constructors Methods Operators Properties See Also Send Feedback

The StrokeStyleProperties type exposes the following members.

Constructors

 | Name | Description
Public method | StrokeStyleProperties | Constructor for the StrokeStyleProperties value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | DashCap | The shape at either end of each dash segment.
Public property | DashOffset | A value that specifies an offset in the dash sequence. A positive dash offset value shifts the dash pattern, in units of stroke width, toward the start of the stroked geometry. A negative dash offset value shifts the dash pattern, in units of stroke width, toward the end of the stroked geometry.
Public property | DashStyle | A value that specifies whether the stroke has a dash pattern and, if so, the dash style.
Public property | EndCap | The cap applied to the end of all the open figures in a stroked geometry.
Public property | LineJoin | A value that describes how segments are joined. This value is ignored for a vertex if the segment flags specify that the segment should have a smooth join.
Public property | MiterLimit | The limit of the thickness of the join on a mitered corner. This value is always treated as though it is greater than or equal to 1.0f.
Public property | StartCap | The cap applied to the start of all the open figures in a stroked geometry.

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeStyleProperties Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties Constructor
StrokeStyleProperties Structure See Also Send Feedback
Constructor for the StrokeStyleProperties value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StrokeStyleProperties(
    CapStyle startCap,
    CapStyle endCap,
    CapStyle dashCap,
    LineJoin lineJoin,
    float miterLimit,
    DashStyle dashStyle,
    float dashOffset
)
Visual Basic
Public Sub New ( _
    startCap As CapStyle, _
    endCap As CapStyle, _
    dashCap As CapStyle, _
    lineJoin As LineJoin, _
    miterLimit As Single, _
    dashStyle As DashStyle, _
    dashOffset As Single _
)
Visual C++
public:
StrokeStyleProperties(
    CapStyle startCap,
    CapStyle endCap,
    CapStyle dashCap,
    LineJoin lineJoin,
    float miterLimit,
    DashStyle dashStyle,
    float dashOffset
)

Parameters

startCap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CapStyle
Initializes the StartCap property.
endCap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CapStyle
Initializes the EndCap property.
dashCap
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..CapStyle
Initializes the DashCap property.
lineJoin
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..LineJoin
Initializes the LineJoin property.
miterLimit
Type: System..::..Single
Initializes the MiterLimit property.
dashStyle
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..DashStyle
Initializes the DashStyle property.
dashOffset
Type: System..::..Single
Initializes the DashOffset property.

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeStyleProperties Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties Methods
StrokeStyleProperties Structure See Also Send Feedback

The StrokeStyleProperties type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..Equals Method
StrokeStyleProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..GetHashCode Method
StrokeStyleProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeStyleProperties Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties Operators
StrokeStyleProperties Structure See Also Send Feedback

The StrokeStyleProperties type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..Equality Operator
StrokeStyleProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    StrokeStyleProperties strokeStyleProperties1,
    StrokeStyleProperties strokeStyleProperties2
)
Visual Basic
Public Shared Operator = ( _
    strokeStyleProperties1 As StrokeStyleProperties, _
    strokeStyleProperties2 As StrokeStyleProperties _
) As Boolean
Visual C++
public:
static bool operator ==(
    StrokeStyleProperties strokeStyleProperties1,
    StrokeStyleProperties strokeStyleProperties2
)

Parameters

strokeStyleProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyleProperties
strokeStyleProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyleProperties

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..Inequality Operator
StrokeStyleProperties Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    StrokeStyleProperties strokeStyleProperties1,
    StrokeStyleProperties strokeStyleProperties2
)
Visual Basic
Public Shared Operator <> ( _
    strokeStyleProperties1 As StrokeStyleProperties, _
    strokeStyleProperties2 As StrokeStyleProperties _
) As Boolean
Visual C++
public:
static bool operator !=(
    StrokeStyleProperties strokeStyleProperties1,
    StrokeStyleProperties strokeStyleProperties2
)

Parameters

strokeStyleProperties1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyleProperties
strokeStyleProperties2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..StrokeStyleProperties

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeStyleProperties Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties Properties
StrokeStyleProperties Structure See Also Send Feedback

The StrokeStyleProperties type exposes the following members.

Properties

 | Name | Description
Public property | DashCap | The shape at either end of each dash segment.
Public property | DashOffset | A value that specifies an offset in the dash sequence. A positive dash offset value shifts the dash pattern, in units of stroke width, toward the start of the stroked geometry. A negative dash offset value shifts the dash pattern, in units of stroke width, toward the end of the stroked geometry.
Public property | DashStyle | A value that specifies whether the stroke has a dash pattern and, if so, the dash style.
Public property | EndCap | The cap applied to the end of all the open figures in a stroked geometry.
Public property | LineJoin | A value that describes how segments are joined. This value is ignored for a vertex if the segment flags specify that the segment should have a smooth join.
Public property | MiterLimit | The limit of the thickness of the join on a mitered corner. This value is always treated as though it is greater than or equal to 1.0f.
Public property | StartCap | The cap applied to the start of all the open figures in a stroked geometry.

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DashCap Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..DashCap Property
StrokeStyleProperties Structure See Also Send Feedback
The shape at either end of each dash segment.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CapStyle DashCap { get; set; }
Visual Basic
Public Property DashCap As CapStyle
    Get
    Set
Visual C++
public:
property CapStyle DashCap {
    CapStyle get ();
    void set (CapStyle value);
}

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DashOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..DashOffset Property
StrokeStyleProperties Structure See Also Send Feedback
A value that specifies an offset in the dash sequence. A positive dash offset value shifts the dash pattern, in units of stroke width, toward the start of the stroked geometry. A negative dash offset value shifts the dash pattern, in units of stroke width, toward the end of the stroked geometry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float DashOffset { get; set; }
Visual Basic
Public Property DashOffset As Single
    Get
    Set
Visual C++
public:
property float DashOffset {
    float get ();
    void set (float value);
}

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


DashStyle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..DashStyle Property
StrokeStyleProperties Structure See Also Send Feedback
A value that specifies whether the stroke has a dash pattern and, if so, the dash style.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DashStyle DashStyle { get; set; }
Visual Basic
Public Property DashStyle As DashStyle
    Get
    Set
Visual C++
public:
property DashStyle DashStyle {
    DashStyle get ();
    void set (DashStyle value);
}

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


EndCap Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..EndCap Property
StrokeStyleProperties Structure See Also Send Feedback
The cap applied to the end of all the open figures in a stroked geometry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CapStyle EndCap { get; set; }
Visual Basic
Public Property EndCap As CapStyle
    Get
    Set
Visual C++
public:
property CapStyle EndCap {
    CapStyle get ();
    void set (CapStyle value);
}

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


LineJoin Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..LineJoin Property
StrokeStyleProperties Structure See Also Send Feedback
A value that describes how segments are joined. This value is ignored for a vertex if the segment flags specify that the segment should have a smooth join.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LineJoin LineJoin { get; set; }
Visual Basic
Public Property LineJoin As LineJoin
    Get
    Set
Visual C++
public:
property LineJoin LineJoin {
    LineJoin get ();
    void set (LineJoin value);
}

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


MiterLimit Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..MiterLimit Property
StrokeStyleProperties Structure See Also Send Feedback
The limit of the thickness of the join on a mitered corner. This value is always treated as though it is greater than or equal to 1.0f.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MiterLimit { get; set; }
Visual Basic
Public Property MiterLimit As Single
    Get
    Set
Visual C++
public:
property float MiterLimit {
    float get ();
    void set (float value);
}

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StartCap Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StrokeStyleProperties..::..StartCap Property
StrokeStyleProperties Structure See Also Send Feedback
The cap applied to the start of all the open figures in a stroked geometry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CapStyle StartCap { get; set; }
Visual Basic
Public Property StartCap As CapStyle
    Get
    Set
Visual C++
public:
property CapStyle StartCap {
    CapStyle get ();
    void set (CapStyle value);
}

See Also

StrokeStyleProperties Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


SweepDirection Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SweepDirection Enumeration
See Also Send Feedback
Defines the direction that an elliptical arc is drawn.

(Also see DirectX SDK: D2D1_SWEEP_DIRECTION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum SweepDirection
Visual Basic
Public Enumeration SweepDirection
Visual C++
public enum class SweepDirection

Members

Member name | Description
Clockwise |
Counterclockwise |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tags Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags Structure
Members See Also Send Feedback
Defines a two-tag element, which contains two application-defined 64-bit unsigned integer values used to mark a set of rendering operations.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Tags
Visual Basic
Public Structure Tags
Visual C++
public value class Tags

See Also

Tags Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tags Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags Members
Tags Structure Constructors Methods Operators Properties See Also Send Feedback

The Tags type exposes the following members.

Constructors

 | Name | Description
Public method | Tags | Constructor for the Tags struct.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Tag1 | First tag element.
Public property | Tag2 | Second tag element.

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tags Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags Constructor
Tags Structure See Also Send Feedback
Constructor for the Tags struct.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Tags(
    ulong tag1,
    ulong tag2
)
Visual Basic
Public Sub New ( _
    tag1 As ULong, _
    tag2 As ULong _
)
Visual C++
public:
Tags(
    unsigned long long tag1,
    unsigned long long tag2
)

Parameters

tag1
Type: System..::..UInt64
Initializes the first tag element.
tag2
Type: System..::..UInt64
Initializes the second tag element.

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tags Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags Methods
Tags Structure See Also Send Feedback

The Tags type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags..::..Equals Method
Tags Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags..::..GetHashCode Method
Tags Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tags Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags Operators
Tags Structure See Also Send Feedback

The Tags type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags..::..Equality Operator
Tags Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Tags tags1,
    Tags tags2
)
Visual Basic
Public Shared Operator = ( _
    tags1 As Tags, _
    tags2 As Tags _
) As Boolean
Visual C++
public:
static bool operator ==(
    Tags tags1,
    Tags tags2
)

Parameters

tags1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Tags
tags2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Tags

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags..::..Inequality Operator
Tags Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Tags tags1,
    Tags tags2
)
Visual Basic
Public Shared Operator <> ( _
    tags1 As Tags, _
    tags2 As Tags _
) As Boolean
Visual C++
public:
static bool operator !=(
    Tags tags1,
    Tags tags2
)

Parameters

tags1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Tags
tags2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Tags

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tags Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags Properties
Tags Structure See Also Send Feedback

The Tags type exposes the following members.

Properties

 | Name | Description
Public property | Tag1 | First tag element.
Public property | Tag2 | Second tag element.

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tag1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags..::..Tag1 Property
Tags Structure See Also Send Feedback
First tag element.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong Tag1 { get; set; }
Visual Basic
Public Property Tag1 As ULong
    Get
    Set
Visual C++
public:
property unsigned long long Tag1 {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tag2 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Tags..::..Tag2 Property
Tags Structure See Also Send Feedback
Second tag element.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong Tag2 { get; set; }
Visual Basic
Public Property Tag2 As ULong
    Get
    Set
Visual C++
public:
property unsigned long long Tag2 {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

Tags Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TessellationSink Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TessellationSink Class
Members See Also Send Feedback
Populates a Mesh object with triangles.

(Also see DirectX SDK: ID2D1TessellationSink)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class TessellationSink : DirectUnknown,
    ITessellationSink
Visual Basic
Public Class TessellationSink _
    Inherits DirectUnknown _
    Implements ITessellationSink
Visual C++
public ref class TessellationSink : public DirectUnknown,
    ITessellationSink

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..TessellationSink

See Also

TessellationSink Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TessellationSink Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TessellationSink Members
TessellationSink Class Methods Properties See Also Send Feedback

The TessellationSink type exposes the following members.

Methods

 | Name | Description
Public method | AddTriangles |
Public method | Close | Closes the sink. (Also see DirectX SDK: ID2D1TessellationSink::Close)

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

TessellationSink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TessellationSink Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TessellationSink Methods
TessellationSink Class See Also Send Feedback

The TessellationSink type exposes the following members.

Methods

 | Name | Description
Public method | AddTriangles |
Public method | Close | Closes the sink. (Also see DirectX SDK: ID2D1TessellationSink::Close)

See Also

TessellationSink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


AddTriangles Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TessellationSink..::..AddTriangles Method
TessellationSink Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void AddTriangles(
    IEnumerable<Triangle> triangles
)
Visual Basic
Public Overridable Sub AddTriangles ( _
    triangles As IEnumerable(Of Triangle) _
)
Visual C++
public:
virtual void AddTriangles(
    IEnumerable<Triangle>^ triangles
)

Parameters

triangles
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Triangle >)>)>

Implements

ITessellationSink..::..AddTriangles(IEnumerable<(Of <<'(Triangle>)>>))

See Also

TessellationSink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Close Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TessellationSink..::..Close Method
TessellationSink Class See Also Send Feedback
Closes the sink.

(Also see DirectX SDK: ID2D1TessellationSink::Close)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

Implements

ITessellationSink..::..Close()()()()

See Also

TessellationSink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TessellationSink Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TessellationSink Properties
TessellationSink Class See Also Send Feedback

The TessellationSink type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

TessellationSink Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TextAntiAliasMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextAntiAliasMode Enumeration
See Also Send Feedback
Describes the antialiasing mode used for drawing text.

(Also see DirectX SDK: D2D1_TEXT_ANTIALIAS_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum TextAntiAliasMode
Visual Basic
Public Enumeration TextAntiAliasMode
Visual C++
public enum class TextAntiAliasMode

Members

Member name | Description
Aliased |
Grayscale |
ClearType |
Default |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TransformedGeometry Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry Class
Members See Also Send Feedback
Represents a geometry that has been transformed.

(Also see DirectX SDK: ID2D1TransformedGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class TransformedGeometry : Geometry
Visual Basic
Public Class TransformedGeometry _
    Inherits Geometry
Visual C++
public ref class TransformedGeometry : public Geometry

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..D2DResource
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Geometry
Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..TransformedGeometry

See Also

TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TransformedGeometry Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry Members
TransformedGeometry Class Methods Properties See Also Send Feedback

The TransformedGeometry type exposes the following members.

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Source | Retrieves the source Geometry of this transformed geometry object. (Also see DirectX SDK: ID2D1TransformedGeometry::GetSourceGeometry)
Public property | Transform | The matrix used to transform the TransformedGeometry object's source geometry. (Also see DirectX SDK: ID2D1TransformedGeometry::GetTransform)

See Also

TransformedGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TransformedGeometry Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry Methods
TransformedGeometry Class See Also Send Feedback

Methods

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

TransformedGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CombineWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..CombineWithGeometry Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)
Public method | CombineWithGeometry(Geometry, CombineMode, ISimplifiedGeometrySink, Single, Matrix3x2F) | Combines this geometry with the specified geometry and stores the result in an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::CombineWithGeometry) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


CompareWithGeometry Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..CompareWithGeometry Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompareWithGeometry(Geometry) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)
Public method | CompareWithGeometry(Geometry, Single, Matrix3x2F) | Compare how one geometry intersects or contains another geometry. (Also see DirectX SDK: ID2D1Geometry::CompareWithGeometry) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeArea Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..ComputeArea Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeArea()()()() | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single) | Computes the area of the geometry. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)
Public method | ComputeArea(Single, Matrix3x2F) | Computes the area of the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputeArea) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputeLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..ComputeLength Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputeLength()()()() | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)
Public method | ComputeLength(Single, Matrix3x2F) | Calculates the length of the geometry as though each segment were unrolled into a line. (Also see DirectX SDK: ID2D1Geometry::ComputeLength) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


ComputePointAtLength Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..ComputePointAtLength Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ComputePointAtLength(Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)
Public method | ComputePointAtLength(Single, Single, Matrix3x2F) | Calculates the point and tangent vector at the specified distance along the geometry after it has been transformed by the specified matrix and flattened using the default tolerance. (Also see DirectX SDK: ID2D1Geometry::ComputePointAtLength) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


FillContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..FillContainsPoint Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillContainsPoint(Point2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)
Public method | FillContainsPoint(Point2F, Single, Matrix3x2F) | Indicates whether the area filled by the geometry would contain the specified point. (Also see DirectX SDK: ID2D1Geometry::FillContainsPoint) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..GetBounds Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBounds()()()() | Retrieve the bounds of this geometry. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)
Public method | GetBounds(Matrix3x2F) | Retrieve the bounds of this geometry, with an applied transform. (Also see DirectX SDK: ID2D1Geometry::GetBounds) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetWidenedBounds Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..GetWidenedBounds Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWidenedBounds(Single, StrokeStyle) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)
Public method | GetWidenedBounds(Single, StrokeStyle, Single, Matrix3x2F) | Get the bounds of the corresponding geometry after it has been widened or have an optional style applied. (Also see DirectX SDK: ID2D1Geometry::GetWidenedBounds) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Outline Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..Outline Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Outline(ISimplifiedGeometrySink) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)
Public method | Outline(ISimplifiedGeometrySink, Single, Matrix3x2F) | Computes the outline of the geometry and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Outline) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Simplify Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..Simplify Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)
Public method | Simplify(GeometrySimplificationOption, ISimplifiedGeometrySink, Single, Matrix3x2F) | Creates a simplified version of the geometry that contains only lines and (optionally) cubic Bezier curves and writes the result to an ISimplifiedGeometrySink object. (Also see DirectX SDK: ID2D1Geometry::Simplify) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


StrokeContainsPoint Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..StrokeContainsPoint Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)
Public method | StrokeContainsPoint(Point2F, Single, StrokeStyle, Single, Matrix3x2F) | Determines whether the geometry's stroke contains the specified point. (Also see DirectX SDK: ID2D1Geometry::StrokeContainsPoint) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Tessellate Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..Tessellate Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Tessellate(ITessellationSink) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)
Public method | Tessellate(ITessellationSink, Single, Matrix3x2F) | Creates a set of clockwise-wound triangles that cover the geometry after it has been transformed using the specified matrix and flattened using the specified tolerance. (Also see DirectX SDK: ID2D1Geometry::Tessellate) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Widen Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..Widen Method
TransformedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)
Public method | Widen(Single, StrokeStyle, ISimplifiedGeometrySink, Single, Matrix3x2F) | Widens the geometry by the specified stroke and writes the result to an ISimplifiedGeometrySink. (Also see DirectX SDK: ID2D1Geometry::Widen) (Inherited from Geometry.)

See Also

TransformedGeometry Class
TransformedGeometry Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


TransformedGeometry Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry Properties
TransformedGeometry Class See Also Send Feedback

The TransformedGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Factory | Retrieve the factory associated with this resource. (Also see DirectX SDK: ID2D1Resource::GetFactory) (Inherited from D2DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Source | Retrieves the source Geometry of this transformed geometry object. (Also see DirectX SDK: ID2D1TransformedGeometry::GetSourceGeometry)
Public property | Transform | The matrix used to transform the TransformedGeometry object's source geometry. (Also see DirectX SDK: ID2D1TransformedGeometry::GetTransform)

See Also

TransformedGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Source Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..Source Property
TransformedGeometry Class See Also Send Feedback
Retrieves the source Geometry of this transformed geometry object.

(Also see DirectX SDK: ID2D1TransformedGeometry::GetSourceGeometry)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Geometry Source { get; }
Visual Basic
Public ReadOnly Property Source As Geometry
    Get
Visual C++
public:
property Geometry^ Source {
    Geometry^ get ();
}

See Also

TransformedGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Transform Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TransformedGeometry..::..Transform Property
TransformedGeometry Class See Also Send Feedback
The matrix used to transform the TransformedGeometry object's source geometry.

(Also see DirectX SDK: ID2D1TransformedGeometry::GetTransform)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix3x2F Transform { get; }
Visual Basic
Public ReadOnly Property Transform As Matrix3x2F
    Get
Visual C++
public:
property Matrix3x2F Transform {
    Matrix3x2F get ();
}

See Also

TransformedGeometry Class
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Triangle Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle Structure
Members See Also Send Feedback
Contains the three vertices that describe a triangle.

(Also see DirectX SDK: D2D1_TRIANGLE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Triangle
Visual Basic
Public Structure Triangle
Visual C++
public value class Triangle

See Also

Triangle Members
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Triangle Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle Members
Triangle Structure Constructors Methods Operators Properties See Also Send Feedback

The Triangle type exposes the following members.

Constructors

 | Name | Description
Public method | Triangle | Constructor for the Triangle value type

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Point1 | The first vertex of a triangle.
Public property | Point2 | The second vertex of a triangle.
Public property | Point3 | The third vertex of a triangle.

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Triangle Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle Constructor
Triangle Structure See Also Send Feedback
Constructor for the Triangle value type

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Triangle(
    Point2F point1,
    Point2F point2,
    Point2F point3
)
Visual Basic
Public Sub New ( _
    point1 As Point2F, _
    point2 As Point2F, _
    point3 As Point2F _
)
Visual C++
public:
Triangle(
    Point2F point1,
    Point2F point2,
    Point2F point3
)

Parameters

point1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point1 property.
point2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point2 property.
point3
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
Initializes the Point3 property.

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Triangle Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle Methods
Triangle Structure See Also Send Feedback

The Triangle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle..::..Equals Method
Triangle Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle..::..GetHashCode Method
Triangle Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Triangle Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle Operators
Triangle Structure See Also Send Feedback

The Triangle type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle..::..Equality Operator
Triangle Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Triangle triangle1,
    Triangle triangle2
)
Visual Basic
Public Shared Operator = ( _
    triangle1 As Triangle, _
    triangle2 As Triangle _
) As Boolean
Visual C++
public:
static bool operator ==(
    Triangle triangle1,
    Triangle triangle2
)

Parameters

triangle1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Triangle
triangle2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Triangle

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle..::..Inequality Operator
Triangle Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Triangle triangle1,
    Triangle triangle2
)
Visual Basic
Public Shared Operator <> ( _
    triangle1 As Triangle, _
    triangle2 As Triangle _
) As Boolean
Visual C++
public:
static bool operator !=(
    Triangle triangle1,
    Triangle triangle2
)

Parameters

triangle1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Triangle
triangle2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Triangle

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Triangle Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle Properties
Triangle Structure See Also Send Feedback

The Triangle type exposes the following members.

Properties

 | Name | Description
Public property | Point1 | The first vertex of a triangle.
Public property | Point2 | The second vertex of a triangle.
Public property | Point3 | The third vertex of a triangle.

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle..::..Point1 Property
Triangle Structure See Also Send Feedback
The first vertex of a triangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point1 { get; set; }
Visual Basic
Public Property Point1 As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point1 {
    Point2F get ();
    void set (Point2F value);
}

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point2 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle..::..Point2 Property
Triangle Structure See Also Send Feedback
The second vertex of a triangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point2 { get; set; }
Visual Basic
Public Property Point2 As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point2 {
    Point2F get ();
    void set (Point2F value);
}

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Point3 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Triangle..::..Point3 Property
Triangle Structure See Also Send Feedback
The third vertex of a triangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Point3 { get; set; }
Visual Basic
Public Property Point3 As Point2F
    Get
    Set
Visual C++
public:
property Point2F Point3 {
    Point2F get ();
    void set (Point2F value);
}

See Also

Triangle Structure
Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


WindowState Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
WindowState Enumeration
See Also Send Feedback
Describes whether a window is occluded.

(Also see DirectX SDK: D2D1_WINDOW_STATE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct2D1
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum WindowState
Visual Basic
Public Enumeration WindowState
Visual C++
public enum class WindowState

Members

Member name | Description
None |
Occluded |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct2D1 Namespace


Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace
Send Feedback
Common Direct3D 10.0, 10.1 and 11.0 types.

Classes

 | Class | Description
Public class | Direct3DException | An exception thrown by Direct3D.

Structures

 | Structure | Description
Public structure | D3DRect | This structure defines the coordinates of the upper-left and lower-right corners of a rectangle.
Public structure | Matrix4x4F | This structure defines a 4 x 4 matrix using floats.
Public structure | Vector2F | This structure defines a 2 component float vector.
Public structure | Vector3F | This structure defines a 3 component float vector.
Public structure | Vector4B | This structure defines a 4 component Boolean vector.
Public structure | Vector4F | This structure defines a 4 component float vector.
Public structure | Vector4I | This structure defines a 4 component int vector.

Enumerations

 | Enumeration | Description
Public enumeration | DeviceType | Direct3D Devices supported by this library.
Public enumeration | FeatureLevel | Describes the set of features targeted by a Direct3D device. (Also see DirectX SDK: D3D_FEATURE_LEVEL) (Also see DirectX SDK: D2D1_FEATURE_LEVEL)


D3DRect Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect Structure
Members See Also Send Feedback
This structure defines the coordinates of the upper-left and lower-right corners of a rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct D3DRect
Visual Basic
Public Structure D3DRect
Visual C++
public value class D3DRect

See Also

D3DRect Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


D3DRect Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect Members
D3DRect Structure Constructors Methods Operators Properties See Also Send Feedback

The D3DRect type exposes the following members.

Constructors

 | Name | Description
Public method | D3DRect | Explicit constructor.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality | The equality operator.
Inequality | The inequality operator.

Properties

 | Name | Description
Public property | Bottom | Specifies the y-coordinate of the lower-right corner of the rectangle.
Public property | Left | Specifies the x-coordinate of the upper-left corner of the rectangle.
Public property | Right | Specifies the x-coordinate of the lower-right corner of the rectangle.
Public property | Top | Specifies the y-coordinate of the upper-left corner of the rectangle.

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


D3DRect Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect Constructor
D3DRect Structure See Also Send Feedback
Explicit constructor.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DRect(
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic
Public Sub New ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
)
Visual C++
public:
D3DRect(
    int left,
    int top,
    int right,
    int bottom
)

Parameters

left
Type: System..::..Int32
Specifies the x-coordinate of the upper-left corner of the rectangle.
top
Type: System..::..Int32
Specifies the y-coordinate of the upper-left corner of the rectangle.
right
Type: System..::..Int32
Specifies the x-coordinate of the lower-right corner of the rectangle.
bottom
Type: System..::..Int32
Specifies the y-coordinate of the lower-right corner of the rectangle.

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


D3DRect Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect Methods
D3DRect Structure See Also Send Feedback

The D3DRect type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect..::..Equals Method
D3DRect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect..::..GetHashCode Method
D3DRect Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


D3DRect Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect Operators
D3DRect Structure See Also Send Feedback

The D3DRect type exposes the following members.

Operators

Name | Description
Equality | The equality operator.
Inequality | The inequality operator.

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect..::..Equality Operator
D3DRect Structure See Also Send Feedback
The equality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    D3DRect rect1,
    D3DRect rect2
)
Visual Basic
Public Shared Operator = ( _
    rect1 As D3DRect, _
    rect2 As D3DRect _
) As Boolean
Visual C++
public:
static bool operator ==(
    D3DRect rect1,
    D3DRect rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..D3DRect
The first rectangle.
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..D3DRect
The second second rectangle.

Return Value

True if the rectangles are equal.

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect..::..Inequality Operator
D3DRect Structure See Also Send Feedback
The inequality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    D3DRect rect1,
    D3DRect rect2
)
Visual Basic
Public Shared Operator <> ( _
    rect1 As D3DRect, _
    rect2 As D3DRect _
) As Boolean
Visual C++
public:
static bool operator !=(
    D3DRect rect1,
    D3DRect rect2
)

Parameters

rect1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..D3DRect
The first rectangle.
rect2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..D3DRect
The second second rectangle.

Return Value

True if the rectangles are not equal.

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


D3DRect Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect Properties
D3DRect Structure See Also Send Feedback

The D3DRect type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | Specifies the y-coordinate of the lower-right corner of the rectangle.
Public property | Left | Specifies the x-coordinate of the upper-left corner of the rectangle.
Public property | Right | Specifies the x-coordinate of the lower-right corner of the rectangle.
Public property | Top | Specifies the y-coordinate of the upper-left corner of the rectangle.

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Bottom Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect..::..Bottom Property
D3DRect Structure See Also Send Feedback
Specifies the y-coordinate of the lower-right corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Bottom { get; set; }
Visual Basic
Public Property Bottom As Integer
    Get
    Set
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Left Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect..::..Left Property
D3DRect Structure See Also Send Feedback
Specifies the x-coordinate of the upper-left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Left { get; set; }
Visual Basic
Public Property Left As Integer
    Get
    Set
Visual C++
public:
property int Left {
    int get ();
    void set (int value);
}

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Right Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect..::..Right Property
D3DRect Structure See Also Send Feedback
Specifies the x-coordinate of the lower-right corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Right { get; set; }
Visual Basic
Public Property Right As Integer
    Get
    Set
Visual C++
public:
property int Right {
    int get ();
    void set (int value);
}

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Top Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DRect..::..Top Property
D3DRect Structure See Also Send Feedback
Specifies the y-coordinate of the upper-left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Top { get; set; }
Visual Basic
Public Property Top As Integer
    Get
    Set
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

D3DRect Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


DeviceType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceType Enumeration
See Also Send Feedback
Direct3D Devices supported by this library.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DeviceType
Visual Basic
Public Enumeration DeviceType
Visual C++
public enum class DeviceType

Members

Member name | Description
Direct3D11 |
Direct3D10Point1 |
Direct3D10 |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Class
Members See Also Send Feedback
An exception thrown by Direct3D.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Direct3DException : DirectXException
Visual Basic
Public Class Direct3DException _
    Inherits DirectXException
Visual C++
public ref class Direct3DException : public DirectXException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Microsoft.WindowsAPICodePack.DirectX..::..DirectXException
Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Direct3DException

See Also

Direct3DException Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Members
Direct3DException Class Constructors Properties See Also Send Feedback

The Direct3DException type exposes the following members.

Constructors

 | Name | Description
Public method | Direct3DException()()()() |
Public method | Direct3DException(Int32) |
Public method | Direct3DException(String) |
Protected method | Direct3DException(SerializationInfo, StreamingContext) |
Public method | Direct3DException(String, Exception) |
Public method | Direct3DException(String, Int32) |
Protected method | Direct3DException(SerializationInfo, StreamingContext, Int32) |
Public method | Direct3DException(String, Exception, Int32) |

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API (Inherited from DirectXException.)

See Also

Direct3DException Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Constructor
Direct3DException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Direct3DException()()()() |
Public method | Direct3DException(Int32) |
Public method | Direct3DException(String) |
Protected method | Direct3DException(SerializationInfo, StreamingContext) |
Public method | Direct3DException(String, Exception) |
Public method | Direct3DException(String, Int32) |
Protected method | Direct3DException(SerializationInfo, StreamingContext, Int32) |
Public method | Direct3DException(String, Exception, Int32) |

See Also

Direct3DException Class
Direct3DException Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Constructor
Direct3DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct3DException()
Visual Basic
Public Sub New
Visual C++
public:
Direct3DException()

See Also

Direct3DException Class
Direct3DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Constructor (Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Constructor (Int32)
Direct3DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct3DException(
    int hr
)
Visual Basic
Public Sub New ( _
    hr As Integer _
)
Visual C++
public:
Direct3DException(
    int hr
)

Parameters

hr
Type: System..::..Int32

See Also

Direct3DException Class
Direct3DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Constructor (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Constructor (String)
Direct3DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct3DException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
Direct3DException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

Direct3DException Class
Direct3DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Constructor (SerializationInfo, StreamingContext)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Constructor (SerializationInfo, StreamingContext)
Direct3DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected Direct3DException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
Direct3DException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext

See Also

Direct3DException Class
Direct3DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Constructor (String, Exception)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Constructor (String, Exception)
Direct3DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct3DException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
Direct3DException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception

See Also

Direct3DException Class
Direct3DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Constructor (String, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Constructor (String, Int32)
Direct3DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct3DException(
    string message,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    hr As Integer _
)
Visual C++
public:
Direct3DException(
    String^ message,
    int hr
)

Parameters

message
Type: System..::..String
hr
Type: System..::..Int32

See Also

Direct3DException Class
Direct3DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Constructor (SerializationInfo, StreamingContext, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Constructor (SerializationInfo, StreamingContext, Int32)
Direct3DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected Direct3DException(
    SerializationInfo info,
    StreamingContext context,
    int hr
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext, _
    hr As Integer _
)
Visual C++
protected:
Direct3DException(
    SerializationInfo^ info,
    StreamingContext context,
    int hr
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext
hr
Type: System..::..Int32

See Also

Direct3DException Class
Direct3DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Constructor (String, Exception, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Constructor (String, Exception, Int32)
Direct3DException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Direct3DException(
    string message,
    Exception innerException,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception, _
    hr As Integer _
)
Visual C++
public:
Direct3DException(
    String^ message,
    Exception^ innerException,
    int hr
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception
hr
Type: System..::..Int32

See Also

Direct3DException Class
Direct3DException Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Direct3DException Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Direct3DException Properties
Direct3DException Class See Also Send Feedback

The Direct3DException type exposes the following members.

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API (Inherited from DirectXException.)

See Also

Direct3DException Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


FeatureLevel Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureLevel Enumeration
See Also Send Feedback
Describes the set of features targeted by a Direct3D device.

(Also see DirectX SDK: D3D_FEATURE_LEVEL)

(Also see DirectX SDK: D2D1_FEATURE_LEVEL)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FeatureLevel
Visual Basic
Public Enumeration FeatureLevel
Visual C++
public enum class FeatureLevel

Members

Member name | Description
Eleven |
TenPointOne |
Ten |
NinePointThree |
NinePointTwo |
NinePointOne |
Default |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Matrix4x4F Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F Structure
Members See Also Send Feedback
This structure defines a 4 x 4 matrix using floats.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Matrix4x4F
Visual Basic
Public Structure Matrix4x4F
Visual C++
public value class Matrix4x4F

See Also

Matrix4x4F Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Matrix4x4F Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F Members
Matrix4x4F Structure Constructors Methods Operators Properties See Also Send Feedback

The Matrix4x4F type exposes the following members.

Constructors

 | Name | Description
Public method | Matrix4x4F(array<Single>[]()[][]) | Initializes the matrix from an array.
Public method | Matrix4x4F(Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single) | Initializes the matrix from a set of values.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
 | Multiply | The matrix multiplication operator (linear transformation composition).

Operators

Name | Description
Equality | The matrix equality operator.
Inequality | The matrix inequality operator.
Multiply | The matrix multiplication operator (linear transformation composition).

Properties

 | Name | Description
 | Identity | Returns an identity matrix.
Public property | M11 | Specifies the value of the matrix at a particular row and column.
Public property | M12 | Specifies the value of the matrix at a particular row and column.
Public property | M13 | Specifies the value of the matrix at a particular row and column.
Public property | M14 | Specifies the value of the matrix at a particular row and column.
Public property | M21 | Specifies the value of the matrix at a particular row and column.
Public property | M22 | Specifies the value of the matrix at a particular row and column.
Public property | M23 | Specifies the value of the matrix at a particular row and column.
Public property | M24 | Specifies the value of the matrix at a particular row and column.
Public property | M31 | Specifies the value of the matrix at a particular row and column.
Public property | M32 | Specifies the value of the matrix at a particular row and column.
Public property | M33 | Specifies the value of the matrix at a particular row and column.
Public property | M34 | Specifies the value of the matrix at a particular row and column.
Public property | M41 | Specifies the value of the matrix at a particular row and column.
Public property | M42 | Specifies the value of the matrix at a particular row and column.
Public property | M43 | Specifies the value of the matrix at a particular row and column.
Public property | M44 | Specifies the value of the matrix at a particular row and column.

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Matrix4x4F Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F Constructor
Matrix4x4F Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Matrix4x4F(array<Single>[]()[][]) | Initializes the matrix from an array.
Public method | Matrix4x4F(Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single) | Initializes the matrix from a set of values.

See Also

Matrix4x4F Structure
Matrix4x4F Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Matrix4x4F Constructor (Single[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F Constructor (array<Single>[]()[][])
Matrix4x4F Structure See Also Send Feedback
Initializes the matrix from an array.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix4x4F(
    float[] dataSource
)
Visual Basic
Public Sub New ( _
    dataSource As Single() _
)
Visual C++
public:
Matrix4x4F(
    array<float>^ dataSource
)

Parameters

dataSource
Type: array< System..::..Single >[]()[][]
The matrix data as an array of floats.

See Also

Matrix4x4F Structure
Matrix4x4F Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Matrix4x4F Constructor (Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F Constructor (Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single, Single)
Matrix4x4F Structure See Also Send Feedback
Initializes the matrix from a set of values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix4x4F(
    float m11,
    float m12,
    float m13,
    float m14,
    float m21,
    float m22,
    float m23,
    float m24,
    float m31,
    float m32,
    float m33,
    float m34,
    float m41,
    float m42,
    float m43,
    float m44
)
Visual Basic
Public Sub New ( _
    m11 As Single, _
    m12 As Single, _
    m13 As Single, _
    m14 As Single, _
    m21 As Single, _
    m22 As Single, _
    m23 As Single, _
    m24 As Single, _
    m31 As Single, _
    m32 As Single, _
    m33 As Single, _
    m34 As Single, _
    m41 As Single, _
    m42 As Single, _
    m43 As Single, _
    m44 As Single _
)
Visual C++
public:
Matrix4x4F(
    float m11,
    float m12,
    float m13,
    float m14,
    float m21,
    float m22,
    float m23,
    float m24,
    float m31,
    float m32,
    float m33,
    float m34,
    float m41,
    float m42,
    float m43,
    float m44
)

Parameters

m11
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m12
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m13
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m14
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m21
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m22
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m23
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m24
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m31
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m32
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m33
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m34
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m41
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m42
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m43
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.
m44
Type: System..::..Single
Specifies the value of the matrix at a particular row and column.

See Also

Matrix4x4F Structure
Matrix4x4F Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Matrix4x4F Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F Methods
Matrix4x4F Structure See Also Send Feedback

The Matrix4x4F type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
 | Multiply | The matrix multiplication operator (linear transformation composition).

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..Equals Method
Matrix4x4F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..GetHashCode Method
Matrix4x4F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Multiply Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..Multiply Method
Matrix4x4F Structure See Also Send Feedback
The matrix multiplication operator (linear transformation composition).

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix4x4F Multiply(
    Matrix4x4F matrix1,
    Matrix4x4F matrix2
)
Visual Basic
Public Shared Function Multiply ( _
    matrix1 As Matrix4x4F, _
    matrix2 As Matrix4x4F _
) As Matrix4x4F
Visual C++
public:
static Matrix4x4F Multiply(
    Matrix4x4F matrix1,
    Matrix4x4F matrix2
)

Parameters

matrix1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F
The first factor.
matrix2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F
The second factor.

Return Value

The product of the matricies.

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Matrix4x4F Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F Operators
Matrix4x4F Structure See Also Send Feedback

The Matrix4x4F type exposes the following members.

Operators

Name | Description
Equality | The matrix equality operator.
Inequality | The matrix inequality operator.
Multiply | The matrix multiplication operator (linear transformation composition).

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..Equality Operator
Matrix4x4F Structure See Also Send Feedback
The matrix equality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Matrix4x4F matrix1,
    Matrix4x4F matrix2
)
Visual Basic
Public Shared Operator = ( _
    matrix1 As Matrix4x4F, _
    matrix2 As Matrix4x4F _
) As Boolean
Visual C++
public:
static bool operator ==(
    Matrix4x4F matrix1,
    Matrix4x4F matrix2
)

Parameters

matrix1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F
The first matrix.
matrix2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F
The second matrix.

Return Value

True if the matricies are equal.

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..Inequality Operator
Matrix4x4F Structure See Also Send Feedback
The matrix inequality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Matrix4x4F matrix1,
    Matrix4x4F matrix2
)
Visual Basic
Public Shared Operator <> ( _
    matrix1 As Matrix4x4F, _
    matrix2 As Matrix4x4F _
) As Boolean
Visual C++
public:
static bool operator !=(
    Matrix4x4F matrix1,
    Matrix4x4F matrix2
)

Parameters

matrix1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F
The first matrix.
matrix2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F
The second second matrix.

Return Value

True if the matricies are not equal.

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Multiply Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..Multiply Operator
Matrix4x4F Structure See Also Send Feedback
The matrix multiplication operator (linear transformation composition).

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix4x4F operator *(
    Matrix4x4F matrix1,
    Matrix4x4F matrix2
)
Visual Basic
Public Shared Operator * ( _
    matrix1 As Matrix4x4F, _
    matrix2 As Matrix4x4F _
) As Matrix4x4F
Visual C++
public:
static Matrix4x4F operator *(
    Matrix4x4F matrix1,
    Matrix4x4F matrix2
)

Parameters

matrix1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F
The first factor.
matrix2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F
The second factor.

Return Value

The product of the matricies.

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Matrix4x4F Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F Properties
Matrix4x4F Structure See Also Send Feedback

The Matrix4x4F type exposes the following members.

Properties

 | Name | Description
 | Identity | Returns an identity matrix.
Public property | M11 | Specifies the value of the matrix at a particular row and column.
Public property | M12 | Specifies the value of the matrix at a particular row and column.
Public property | M13 | Specifies the value of the matrix at a particular row and column.
Public property | M14 | Specifies the value of the matrix at a particular row and column.
Public property | M21 | Specifies the value of the matrix at a particular row and column.
Public property | M22 | Specifies the value of the matrix at a particular row and column.
Public property | M23 | Specifies the value of the matrix at a particular row and column.
Public property | M24 | Specifies the value of the matrix at a particular row and column.
Public property | M31 | Specifies the value of the matrix at a particular row and column.
Public property | M32 | Specifies the value of the matrix at a particular row and column.
Public property | M33 | Specifies the value of the matrix at a particular row and column.
Public property | M34 | Specifies the value of the matrix at a particular row and column.
Public property | M41 | Specifies the value of the matrix at a particular row and column.
Public property | M42 | Specifies the value of the matrix at a particular row and column.
Public property | M43 | Specifies the value of the matrix at a particular row and column.
Public property | M44 | Specifies the value of the matrix at a particular row and column.

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Identity Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..Identity Property
Matrix4x4F Structure See Also Send Feedback
Returns an identity matrix.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Matrix4x4F Identity { get; }
Visual Basic
Public Shared ReadOnly Property Identity As Matrix4x4F
    Get
Visual C++
public:
static property Matrix4x4F Identity {
    Matrix4x4F get ();
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M11 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M11 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M11 { get; set; }
Visual Basic
Public Property M11 As Single
    Get
    Set
Visual C++
public:
property float M11 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M12 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M12 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M12 { get; set; }
Visual Basic
Public Property M12 As Single
    Get
    Set
Visual C++
public:
property float M12 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M13 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M13 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M13 { get; set; }
Visual Basic
Public Property M13 As Single
    Get
    Set
Visual C++
public:
property float M13 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M14 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M14 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M14 { get; set; }
Visual Basic
Public Property M14 As Single
    Get
    Set
Visual C++
public:
property float M14 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M21 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M21 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M21 { get; set; }
Visual Basic
Public Property M21 As Single
    Get
    Set
Visual C++
public:
property float M21 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M22 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M22 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M22 { get; set; }
Visual Basic
Public Property M22 As Single
    Get
    Set
Visual C++
public:
property float M22 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M23 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M23 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M23 { get; set; }
Visual Basic
Public Property M23 As Single
    Get
    Set
Visual C++
public:
property float M23 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M24 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M24 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M24 { get; set; }
Visual Basic
Public Property M24 As Single
    Get
    Set
Visual C++
public:
property float M24 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M31 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M31 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M31 { get; set; }
Visual Basic
Public Property M31 As Single
    Get
    Set
Visual C++
public:
property float M31 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M32 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M32 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M32 { get; set; }
Visual Basic
Public Property M32 As Single
    Get
    Set
Visual C++
public:
property float M32 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M33 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M33 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M33 { get; set; }
Visual Basic
Public Property M33 As Single
    Get
    Set
Visual C++
public:
property float M33 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M34 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M34 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M34 { get; set; }
Visual Basic
Public Property M34 As Single
    Get
    Set
Visual C++
public:
property float M34 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M41 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M41 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M41 { get; set; }
Visual Basic
Public Property M41 As Single
    Get
    Set
Visual C++
public:
property float M41 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M42 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M42 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M42 { get; set; }
Visual Basic
Public Property M42 As Single
    Get
    Set
Visual C++
public:
property float M42 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M43 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M43 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M43 { get; set; }
Visual Basic
Public Property M43 As Single
    Get
    Set
Visual C++
public:
property float M43 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


M44 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Matrix4x4F..::..M44 Property
Matrix4x4F Structure See Also Send Feedback
Specifies the value of the matrix at a particular row and column.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float M44 { get; set; }
Visual Basic
Public Property M44 As Single
    Get
    Set
Visual C++
public:
property float M44 {
    float get ();
    void set (float value);
}

See Also

Matrix4x4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector2F Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F Structure
Members See Also Send Feedback
This structure defines a 2 component float vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Vector2F
Visual Basic
Public Structure Vector2F
Visual C++
public value class Vector2F

See Also

Vector2F Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector2F Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F Members
Vector2F Structure Constructors Methods Operators Properties See Also Send Feedback

The Vector2F type exposes the following members.

Constructors

 | Name | Description
Public method | Vector2F(array<Single>[]()[][]) | Initializes the vector from an array.
Public method | Vector2F(Single, Single) | Initializes the vector from a set of values.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality | The vector equality operator.
Inequality | The vector inequality operator.

Properties

 | Name | Description
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector2F Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F Constructor
Vector2F Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Vector2F(array<Single>[]()[][]) | Initializes the vector from an array.
Public method | Vector2F(Single, Single) | Initializes the vector from a set of values.

See Also

Vector2F Structure
Vector2F Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector2F Constructor (Single[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F Constructor (array<Single>[]()[][])
Vector2F Structure See Also Send Feedback
Initializes the vector from an array.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector2F(
    float[] dataSource
)
Visual Basic
Public Sub New ( _
    dataSource As Single() _
)
Visual C++
public:
Vector2F(
    array<float>^ dataSource
)

Parameters

dataSource
Type: array< System..::..Single >[]()[][]
The vector data as an array of floats.

See Also

Vector2F Structure
Vector2F Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector2F Constructor (Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F Constructor (Single, Single)
Vector2F Structure See Also Send Feedback
Initializes the vector from a set of values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector2F(
    float x,
    float y
)
Visual Basic
Public Sub New ( _
    x As Single, _
    y As Single _
)
Visual C++
public:
Vector2F(
    float x,
    float y
)

Parameters

x
Type: System..::..Single
Specifies value of x.
y
Type: System..::..Single
Specifies value of y.

See Also

Vector2F Structure
Vector2F Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector2F Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F Methods
Vector2F Structure See Also Send Feedback

The Vector2F type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F..::..Equals Method
Vector2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F..::..GetHashCode Method
Vector2F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector2F Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F Operators
Vector2F Structure See Also Send Feedback

The Vector2F type exposes the following members.

Operators

Name | Description
Equality | The vector equality operator.
Inequality | The vector inequality operator.

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F..::..Equality Operator
Vector2F Structure See Also Send Feedback
The vector equality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Vector2F vector1,
    Vector2F vector2
)
Visual Basic
Public Shared Operator = ( _
    vector1 As Vector2F, _
    vector2 As Vector2F _
) As Boolean
Visual C++
public:
static bool operator ==(
    Vector2F vector1,
    Vector2F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector2F
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector2F
The second vector.

Return Value

True if the vectors are equal.

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F..::..Inequality Operator
Vector2F Structure See Also Send Feedback
The vector inequality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Vector2F vector1,
    Vector2F vector2
)
Visual Basic
Public Shared Operator <> ( _
    vector1 As Vector2F, _
    vector2 As Vector2F _
) As Boolean
Visual C++
public:
static bool operator !=(
    Vector2F vector1,
    Vector2F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector2F
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector2F
The second vector.

Return Value

True if the vectors are not equal.

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector2F Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F Properties
Vector2F Structure See Also Send Feedback

The Vector2F type exposes the following members.

Properties

 | Name | Description
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


X Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F..::..X Property
Vector2F Structure See Also Send Feedback
Specifies the first element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float X { get; set; }
Visual Basic
Public Property X As Single
    Get
    Set
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Y Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector2F..::..Y Property
Vector2F Structure See Also Send Feedback
Specifies the second element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Y { get; set; }
Visual Basic
Public Property Y As Single
    Get
    Set
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

Vector2F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector3F Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F Structure
Members See Also Send Feedback
This structure defines a 3 component float vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Vector3F
Visual Basic
Public Structure Vector3F
Visual C++
public value class Vector3F

See Also

Vector3F Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector3F Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F Members
Vector3F Structure Constructors Methods Operators Properties See Also Send Feedback

The Vector3F type exposes the following members.

Constructors

 | Name | Description
Public method | Vector3F(array<Single>[]()[][]) | Initializes the vector from an array.
Public method | Vector3F(Single, Single, Single) | Initializes the vector from a set of values.

Methods

 | Name | Description
 | Add | Adds vector2 to vector1.
 | Cross | Compute the cross product of the given vectors.
 | Dot | Compute the dot (scalar) product of the given vectors.
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | Normalize | Normalize the vector, returning a new one.
Public method | NormalizeInPlace | Normalize the vector.
 | Subtract | Subtracts vector2 from vector1.

Operators

Name | Description
Addition | Adds vector2 to vector1.
Equality | The vector equality operator.
Inequality | The vector inequality operator.
Subtraction | Subtracts vector2 from vector1.

Properties

 | Name | Description
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.
Public property | Z | Specifies the third element of the vector.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector3F Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F Constructor
Vector3F Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Vector3F(array<Single>[]()[][]) | Initializes the vector from an array.
Public method | Vector3F(Single, Single, Single) | Initializes the vector from a set of values.

See Also

Vector3F Structure
Vector3F Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector3F Constructor (Single[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F Constructor (array<Single>[]()[][])
Vector3F Structure See Also Send Feedback
Initializes the vector from an array.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector3F(
    float[] dataSource
)
Visual Basic
Public Sub New ( _
    dataSource As Single() _
)
Visual C++
public:
Vector3F(
    array<float>^ dataSource
)

Parameters

dataSource
Type: array< System..::..Single >[]()[][]
The vector data as an array of floats.

See Also

Vector3F Structure
Vector3F Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector3F Constructor (Single, Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F Constructor (Single, Single, Single)
Vector3F Structure See Also Send Feedback
Initializes the vector from a set of values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector3F(
    float x,
    float y,
    float z
)
Visual Basic
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single _
)
Visual C++
public:
Vector3F(
    float x,
    float y,
    float z
)

Parameters

x
Type: System..::..Single
Specifies value of x.
y
Type: System..::..Single
Specifies value of y.
z
Type: System..::..Single
Specifies value of z.

See Also

Vector3F Structure
Vector3F Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector3F Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F Methods
Vector3F Structure See Also Send Feedback

The Vector3F type exposes the following members.

Methods

 | Name | Description
 | Add | Adds vector2 to vector1.
 | Cross | Compute the cross product of the given vectors.
 | Dot | Compute the dot (scalar) product of the given vectors.
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | Normalize | Normalize the vector, returning a new one.
Public method | NormalizeInPlace | Normalize the vector.
 | Subtract | Subtracts vector2 from vector1.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Add Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Add Method
Vector3F Structure See Also Send Feedback
Adds vector2 to vector1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Vector3F Add(
    Vector3F vector1,
    Vector3F vector2
)
Visual Basic
Public Shared Function Add ( _
    vector1 As Vector3F, _
    vector2 As Vector3F _
) As Vector3F
Visual C++
public:
static Vector3F Add(
    Vector3F vector1,
    Vector3F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The first vector to add.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The second vector to add.

Return Value

The addition resultant vector.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Cross Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Cross Method
Vector3F Structure See Also Send Feedback
Compute the cross product of the given vectors.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Vector3F Cross(
    Vector3F vector1,
    Vector3F vector2
)
Visual Basic
Public Shared Function Cross ( _
    vector1 As Vector3F, _
    vector2 As Vector3F _
) As Vector3F
Visual C++
public:
static Vector3F Cross(
    Vector3F vector1,
    Vector3F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The first vector for the cross product.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The second vector for the cross product.

Return Value

The cross prodcut vector.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Dot Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Dot Method
Vector3F Structure See Also Send Feedback
Compute the dot (scalar) product of the given vectors.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static float Dot(
    Vector3F vector1,
    Vector3F vector2
)
Visual Basic
Public Shared Function Dot ( _
    vector1 As Vector3F, _
    vector2 As Vector3F _
) As Single
Visual C++
public:
static float Dot(
    Vector3F vector1,
    Vector3F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The first vector for the dot product.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The second vector for the dot product.

Return Value

The dot prodcut.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Equals Method
Vector3F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..GetHashCode Method
Vector3F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Normalize Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Normalize Method
Vector3F Structure See Also Send Feedback
Normalize the vector, returning a new one.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector3F Normalize()
Visual Basic
Public Function Normalize As Vector3F
Visual C++
public:
Vector3F Normalize()

Return Value

The normalized vector

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


NormalizeInPlace Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..NormalizeInPlace Method
Vector3F Structure See Also Send Feedback
Normalize the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void NormalizeInPlace()
Visual Basic
Public Sub NormalizeInPlace
Visual C++
public:
void NormalizeInPlace()

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Subtract Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Subtract Method
Vector3F Structure See Also Send Feedback
Subtracts vector2 from vector1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Vector3F Subtract(
    Vector3F vector1,
    Vector3F vector2
)
Visual Basic
Public Shared Function Subtract ( _
    vector1 As Vector3F, _
    vector2 As Vector3F _
) As Vector3F
Visual C++
public:
static Vector3F Subtract(
    Vector3F vector1,
    Vector3F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The vector from which to subtract.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The vector to subtract.

Return Value

The subtraction resultant vector.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector3F Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F Operators
Vector3F Structure See Also Send Feedback

The Vector3F type exposes the following members.

Operators

Name | Description
Addition | Adds vector2 to vector1.
Equality | The vector equality operator.
Inequality | The vector inequality operator.
Subtraction | Subtracts vector2 from vector1.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Addition Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Addition Operator
Vector3F Structure See Also Send Feedback
Adds vector2 to vector1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Vector3F operator +(
    Vector3F vector1,
    Vector3F vector2
)
Visual Basic
Public Shared Operator + ( _
    vector1 As Vector3F, _
    vector2 As Vector3F _
) As Vector3F
Visual C++
public:
static Vector3F operator +(
    Vector3F vector1,
    Vector3F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The first vector to add.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The second vector to add.

Return Value

The addition resultant vector.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Equality Operator
Vector3F Structure See Also Send Feedback
The vector equality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Vector3F vector1,
    Vector3F vector2
)
Visual Basic
Public Shared Operator = ( _
    vector1 As Vector3F, _
    vector2 As Vector3F _
) As Boolean
Visual C++
public:
static bool operator ==(
    Vector3F vector1,
    Vector3F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The second vector.

Return Value

True if the vectors are equal.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Inequality Operator
Vector3F Structure See Also Send Feedback
The vector inequality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Vector3F vector1,
    Vector3F vector2
)
Visual Basic
Public Shared Operator <> ( _
    vector1 As Vector3F, _
    vector2 As Vector3F _
) As Boolean
Visual C++
public:
static bool operator !=(
    Vector3F vector1,
    Vector3F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The second vector.

Return Value

True if the vectors are not equal.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Subtraction Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Subtraction Operator
Vector3F Structure See Also Send Feedback
Subtracts vector2 from vector1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Vector3F operator -(
    Vector3F vector1,
    Vector3F vector2
)
Visual Basic
Public Shared Operator - ( _
    vector1 As Vector3F, _
    vector2 As Vector3F _
) As Vector3F
Visual C++
public:
static Vector3F operator -(
    Vector3F vector1,
    Vector3F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The vector from which to subtract.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector3F
The vector to subtract.

Return Value

The subtraction resultant vector.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector3F Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F Properties
Vector3F Structure See Also Send Feedback

The Vector3F type exposes the following members.

Properties

 | Name | Description
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.
Public property | Z | Specifies the third element of the vector.

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


X Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..X Property
Vector3F Structure See Also Send Feedback
Specifies the first element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float X { get; set; }
Visual Basic
Public Property X As Single
    Get
    Set
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Y Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Y Property
Vector3F Structure See Also Send Feedback
Specifies the second element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Y { get; set; }
Visual Basic
Public Property Y As Single
    Get
    Set
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Z Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector3F..::..Z Property
Vector3F Structure See Also Send Feedback
Specifies the third element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Z { get; set; }
Visual Basic
Public Property Z As Single
    Get
    Set
Visual C++
public:
property float Z {
    float get ();
    void set (float value);
}

See Also

Vector3F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4B Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B Structure
Members See Also Send Feedback
This structure defines a 4 component Boolean vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Vector4B
Visual Basic
Public Structure Vector4B
Visual C++
public value class Vector4B

See Also

Vector4B Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4B Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B Members
Vector4B Structure Constructors Methods Operators Properties See Also Send Feedback

The Vector4B type exposes the following members.

Constructors

 | Name | Description
Public method | Vector4B(array<Boolean>[]()[][]) | Initializes the vector from an array.
Public method | Vector4B(Boolean, Boolean, Boolean, Boolean) | Initializes the vector from a set of values.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality | The vector equality operator.
Inequality | The vector inequality operator.

Properties

 | Name | Description
Public property | W | Specifies the fourth element of the vector.
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.
Public property | Z | Specifies the third element of the vector.

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4B Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B Constructor
Vector4B Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Vector4B(array<Boolean>[]()[][]) | Initializes the vector from an array.
Public method | Vector4B(Boolean, Boolean, Boolean, Boolean) | Initializes the vector from a set of values.

See Also

Vector4B Structure
Vector4B Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4B Constructor (Boolean[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B Constructor (array<Boolean>[]()[][])
Vector4B Structure See Also Send Feedback
Initializes the vector from an array.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4B(
    bool[] dataSource
)
Visual Basic
Public Sub New ( _
    dataSource As Boolean() _
)
Visual C++
public:
Vector4B(
    array<bool>^ dataSource
)

Parameters

dataSource
Type: array< System..::..Boolean >[]()[][]
The vector data as an array of floats.

See Also

Vector4B Structure
Vector4B Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4B Constructor (Boolean, Boolean, Boolean, Boolean)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B Constructor (Boolean, Boolean, Boolean, Boolean)
Vector4B Structure See Also Send Feedback
Initializes the vector from a set of values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4B(
    bool x,
    bool y,
    bool z,
    bool w
)
Visual Basic
Public Sub New ( _
    x As Boolean, _
    y As Boolean, _
    z As Boolean, _
    w As Boolean _
)
Visual C++
public:
Vector4B(
    bool x,
    bool y,
    bool z,
    bool w
)

Parameters

x
Type: System..::..Boolean
Specifies value of x.
y
Type: System..::..Boolean
Specifies value of y.
z
Type: System..::..Boolean
Specifies value of z.
w
Type: System..::..Boolean
Specifies value of w.

See Also

Vector4B Structure
Vector4B Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4B Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B Methods
Vector4B Structure See Also Send Feedback

The Vector4B type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B..::..Equals Method
Vector4B Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B..::..GetHashCode Method
Vector4B Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4B Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B Operators
Vector4B Structure See Also Send Feedback

The Vector4B type exposes the following members.

Operators

Name | Description
Equality | The vector equality operator.
Inequality | The vector inequality operator.

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B..::..Equality Operator
Vector4B Structure See Also Send Feedback
The vector equality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Vector4B vector1,
    Vector4B vector2
)
Visual Basic
Public Shared Operator = ( _
    vector1 As Vector4B, _
    vector2 As Vector4B _
) As Boolean
Visual C++
public:
static bool operator ==(
    Vector4B vector1,
    Vector4B vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4B
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4B
The second vector.

Return Value

True if the vectors are equal.

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B..::..Inequality Operator
Vector4B Structure See Also Send Feedback
The vector inequality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Vector4B vector1,
    Vector4B vector2
)
Visual Basic
Public Shared Operator <> ( _
    vector1 As Vector4B, _
    vector2 As Vector4B _
) As Boolean
Visual C++
public:
static bool operator !=(
    Vector4B vector1,
    Vector4B vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4B
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4B
The second vector.

Return Value

True if the vectors are not equal.

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4B Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B Properties
Vector4B Structure See Also Send Feedback

The Vector4B type exposes the following members.

Properties

 | Name | Description
Public property | W | Specifies the fourth element of the vector.
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.
Public property | Z | Specifies the third element of the vector.

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


W Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B..::..W Property
Vector4B Structure See Also Send Feedback
Specifies the fourth element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool W { get; set; }
Visual Basic
Public Property W As Boolean
    Get
    Set
Visual C++
public:
property bool W {
    bool get ();
    void set (bool value);
}

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


X Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B..::..X Property
Vector4B Structure See Also Send Feedback
Specifies the first element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool X { get; set; }
Visual Basic
Public Property X As Boolean
    Get
    Set
Visual C++
public:
property bool X {
    bool get ();
    void set (bool value);
}

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Y Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B..::..Y Property
Vector4B Structure See Also Send Feedback
Specifies the second element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool Y { get; set; }
Visual Basic
Public Property Y As Boolean
    Get
    Set
Visual C++
public:
property bool Y {
    bool get ();
    void set (bool value);
}

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Z Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4B..::..Z Property
Vector4B Structure See Also Send Feedback
Specifies the third element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool Z { get; set; }
Visual Basic
Public Property Z As Boolean
    Get
    Set
Visual C++
public:
property bool Z {
    bool get ();
    void set (bool value);
}

See Also

Vector4B Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4F Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F Structure
Members See Also Send Feedback
This structure defines a 4 component float vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Vector4F
Visual Basic
Public Structure Vector4F
Visual C++
public value class Vector4F

See Also

Vector4F Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4F Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F Members
Vector4F Structure Constructors Methods Operators Properties See Also Send Feedback

The Vector4F type exposes the following members.

Constructors

 | Name | Description
Public method | Vector4F(array<Single>[]()[][]) | Initializes the vector from an array.
Public method | Vector4F(Single, Single, Single, Single) | Initializes the vector from a set of values.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality | The vector equality operator.
Inequality | The vector inequality operator.

Properties

 | Name | Description
Public property | W | Specifies the fourth element of the vector.
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.
Public property | Z | Specifies the third element of the vector.

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4F Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F Constructor
Vector4F Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Vector4F(array<Single>[]()[][]) | Initializes the vector from an array.
Public method | Vector4F(Single, Single, Single, Single) | Initializes the vector from a set of values.

See Also

Vector4F Structure
Vector4F Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4F Constructor (Single[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F Constructor (array<Single>[]()[][])
Vector4F Structure See Also Send Feedback
Initializes the vector from an array.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4F(
    float[] dataSource
)
Visual Basic
Public Sub New ( _
    dataSource As Single() _
)
Visual C++
public:
Vector4F(
    array<float>^ dataSource
)

Parameters

dataSource
Type: array< System..::..Single >[]()[][]
The vector data as an array of floats.

See Also

Vector4F Structure
Vector4F Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4F Constructor (Single, Single, Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F Constructor (Single, Single, Single, Single)
Vector4F Structure See Also Send Feedback
Initializes the vector from a set of values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4F(
    float x,
    float y,
    float z,
    float w
)
Visual Basic
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single, _
    w As Single _
)
Visual C++
public:
Vector4F(
    float x,
    float y,
    float z,
    float w
)

Parameters

x
Type: System..::..Single
Specifies value of x.
y
Type: System..::..Single
Specifies value of y.
z
Type: System..::..Single
Specifies value of z.
w
Type: System..::..Single
Specifies value of w.

See Also

Vector4F Structure
Vector4F Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4F Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F Methods
Vector4F Structure See Also Send Feedback

The Vector4F type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F..::..Equals Method
Vector4F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F..::..GetHashCode Method
Vector4F Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4F Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F Operators
Vector4F Structure See Also Send Feedback

The Vector4F type exposes the following members.

Operators

Name | Description
Equality | The vector equality operator.
Inequality | The vector inequality operator.

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F..::..Equality Operator
Vector4F Structure See Also Send Feedback
The vector equality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Vector4F vector1,
    Vector4F vector2
)
Visual Basic
Public Shared Operator = ( _
    vector1 As Vector4F, _
    vector2 As Vector4F _
) As Boolean
Visual C++
public:
static bool operator ==(
    Vector4F vector1,
    Vector4F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4F
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4F
The second vector.

Return Value

True if the vectors are equal.

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F..::..Inequality Operator
Vector4F Structure See Also Send Feedback
The vector inequality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Vector4F vector1,
    Vector4F vector2
)
Visual Basic
Public Shared Operator <> ( _
    vector1 As Vector4F, _
    vector2 As Vector4F _
) As Boolean
Visual C++
public:
static bool operator !=(
    Vector4F vector1,
    Vector4F vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4F
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4F
The second vector.

Return Value

True if the vectors are not equal.

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4F Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F Properties
Vector4F Structure See Also Send Feedback

The Vector4F type exposes the following members.

Properties

 | Name | Description
Public property | W | Specifies the fourth element of the vector.
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.
Public property | Z | Specifies the third element of the vector.

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


W Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F..::..W Property
Vector4F Structure See Also Send Feedback
Specifies the fourth element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float W { get; set; }
Visual Basic
Public Property W As Single
    Get
    Set
Visual C++
public:
property float W {
    float get ();
    void set (float value);
}

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


X Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F..::..X Property
Vector4F Structure See Also Send Feedback
Specifies the first element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float X { get; set; }
Visual Basic
Public Property X As Single
    Get
    Set
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Y Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F..::..Y Property
Vector4F Structure See Also Send Feedback
Specifies the second element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Y { get; set; }
Visual Basic
Public Property Y As Single
    Get
    Set
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Z Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4F..::..Z Property
Vector4F Structure See Also Send Feedback
Specifies the third element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Z { get; set; }
Visual Basic
Public Property Z As Single
    Get
    Set
Visual C++
public:
property float Z {
    float get ();
    void set (float value);
}

See Also

Vector4F Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4I Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I Structure
Members See Also Send Feedback
This structure defines a 4 component int vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Vector4I
Visual Basic
Public Structure Vector4I
Visual C++
public value class Vector4I

See Also

Vector4I Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4I Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I Members
Vector4I Structure Constructors Methods Operators Properties See Also Send Feedback

The Vector4I type exposes the following members.

Constructors

 | Name | Description
Public method | Vector4I(array<Int32>[]()[][]) | Initializes the vector from an array.
Public method | Vector4I(Int32, Int32, Int32, Int32) | Initializes the vector from a set of values.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality | The vector equality operator.
Inequality | The vector inequality operator.

Properties

 | Name | Description
Public property | W | Specifies the fourth element of the vector.
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.
Public property | Z | Specifies the third element of the vector.

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4I Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I Constructor
Vector4I Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | Vector4I(array<Int32>[]()[][]) | Initializes the vector from an array.
Public method | Vector4I(Int32, Int32, Int32, Int32) | Initializes the vector from a set of values.

See Also

Vector4I Structure
Vector4I Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4I Constructor (Int32[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I Constructor (array<Int32>[]()[][])
Vector4I Structure See Also Send Feedback
Initializes the vector from an array.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4I(
    int[] dataSource
)
Visual Basic
Public Sub New ( _
    dataSource As Integer() _
)
Visual C++
public:
Vector4I(
    array<int>^ dataSource
)

Parameters

dataSource
Type: array< System..::..Int32 >[]()[][]
The vector data as an array of floats.

See Also

Vector4I Structure
Vector4I Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4I Constructor (Int32, Int32, Int32, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I Constructor (Int32, Int32, Int32, Int32)
Vector4I Structure See Also Send Feedback
Initializes the vector from a set of values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4I(
    int x,
    int y,
    int z,
    int w
)
Visual Basic
Public Sub New ( _
    x As Integer, _
    y As Integer, _
    z As Integer, _
    w As Integer _
)
Visual C++
public:
Vector4I(
    int x,
    int y,
    int z,
    int w
)

Parameters

x
Type: System..::..Int32
Specifies value of x.
y
Type: System..::..Int32
Specifies value of y.
z
Type: System..::..Int32
Specifies value of z.
w
Type: System..::..Int32
Specifies value of w.

See Also

Vector4I Structure
Vector4I Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4I Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I Methods
Vector4I Structure See Also Send Feedback

The Vector4I type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I..::..Equals Method
Vector4I Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I..::..GetHashCode Method
Vector4I Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4I Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I Operators
Vector4I Structure See Also Send Feedback

The Vector4I type exposes the following members.

Operators

Name | Description
Equality | The vector equality operator.
Inequality | The vector inequality operator.

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I..::..Equality Operator
Vector4I Structure See Also Send Feedback
The vector equality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Vector4I vector1,
    Vector4I vector2
)
Visual Basic
Public Shared Operator = ( _
    vector1 As Vector4I, _
    vector2 As Vector4I _
) As Boolean
Visual C++
public:
static bool operator ==(
    Vector4I vector1,
    Vector4I vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4I
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4I
The second vector.

Return Value

True if the vectors are equal.

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I..::..Inequality Operator
Vector4I Structure See Also Send Feedback
The vector inequality operator.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Vector4I vector1,
    Vector4I vector2
)
Visual Basic
Public Shared Operator <> ( _
    vector1 As Vector4I, _
    vector2 As Vector4I _
) As Boolean
Visual C++
public:
static bool operator !=(
    Vector4I vector1,
    Vector4I vector2
)

Parameters

vector1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4I
The first vector.
vector2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4I
The second vector.

Return Value

True if the vectors are not equal.

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Vector4I Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I Properties
Vector4I Structure See Also Send Feedback

The Vector4I type exposes the following members.

Properties

 | Name | Description
Public property | W | Specifies the fourth element of the vector.
Public property | X | Specifies the first element of the vector.
Public property | Y | Specifies the second element of the vector.
Public property | Z | Specifies the third element of the vector.

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


W Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I..::..W Property
Vector4I Structure See Also Send Feedback
Specifies the fourth element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int W { get; set; }
Visual Basic
Public Property W As Integer
    Get
    Set
Visual C++
public:
property int W {
    int get ();
    void set (int value);
}

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


X Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I..::..X Property
Vector4I Structure See Also Send Feedback
Specifies the first element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int X { get; set; }
Visual Basic
Public Property X As Integer
    Get
    Set
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Y Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I..::..Y Property
Vector4I Structure See Also Send Feedback
Specifies the second element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Y { get; set; }
Visual Basic
Public Property Y As Integer
    Get
    Set
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Z Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Vector4I..::..Z Property
Vector4I Structure See Also Send Feedback
Specifies the third element of the vector.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Z { get; set; }
Visual Basic
Public Property Z As Integer
    Get
    Set
Visual C++
public:
property int Z {
    int get ();
    void set (int value);
}

See Also

Vector4I Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D Namespace


Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Send Feedback
Direct3D 10.0 and 10.1 APIs and Types.

Classes

 | Class | Description
Public class | Asynchronous | This class encapsulates methods for retrieving data from the GPU asynchronously. (Also see DirectX SDK: ID3D10Asynchronous)
Public class | BlendState | This blend-state interface accesses blending state for a Direct3D 10.0 device for the output-merger stage. (Also see DirectX SDK: ID3D10BlendState)
Public class | BlendState1 | This blend-state interface accesses blending state for a Direct3D 10.1 device for the output-merger stage. (Also see DirectX SDK: ID3D10BlendState1)
Public class | Blob | This class is used to return arbitrary length data. (Also see DirectX SDK: ID3D10Blob)
Public class | CounterData | This class encapsulates the data returned by the D3DDevice.CheckCounter method. (Also see DirectX SDK: ID3D10Device.CheckCounter)
Public class | D3DBuffer | A buffer interface accesses a buffer resource, which is unstructured memory. Buffers typically store vertex or index data. (Also see DirectX SDK: ID3D10Buffer)
Public class | D3DCounter | This class encapsulates methods for measuring GPU performance. (Also see DirectX SDK: ID3D10Counter)
Public class | D3DDebug | A debug interface controls debug settings, validates pipeline state and can only be used if the debug layer is turned on. (Also see DirectX SDK: ID3D10Debug)
Public class | D3DDevice | The device interface represents a virtual adapter for Direct3D 10.0; it is used to perform rendering and create Direct3D resources. To create a D3DDevice instance, use one of the static factory method overloads: CreateDevice() or CreateDeviceAndSwapChain(). (Also see DirectX SDK: ID3D10Device)
Public class | D3DDevice1 | The device interface represents a virtual adapter for Direct3D 10.1; it is used to perform rendering and create Direct3D resources. To create a D3DDevice1 instance, use one of the static factory method overloads: CreateDevice1() or CreateDeviceAndSwapChain1(). (Also see DirectX SDK: ID3D10Device1)
Public class | D3DPredicate | A predicate interface determines whether geometry should be processed depending on the results of a previous draw call. (Also see DirectX SDK: ID3D10Predicate)
Public class | D3DQuery | A query interface queries information from the GPU. (Also see DirectX SDK: ID3D10Query)
Public class | D3DResource | A resource interface provides common actions on all resources. (Also see DirectX SDK: ID3D10Resource)
Public class | DepthStencilState | A depth-stencil-state interface accesses depth-stencil state which sets up the depth-stencil test for the output-merger stage. (Also see DirectX SDK: ID3D10DepthStencilState)
Public class | DepthStencilView | A depth-stencil-view interface accesses a texture resource during depth-stencil testing. (Also see DirectX SDK: ID3D10DepthStencilView)
Public class | DeviceChild | A device-child interface accesses data used by a device. (Also see DirectX SDK: ID3D10DeviceChild)
Public class | Effect | An Effect interface manages a set of state objects, resources and shaders for implementing a rendering effect. (Also see DirectX SDK: ID3D10Effect)
Public class | EffectBlendVariable | The blend-variable interface accesses blend state. (Also see DirectX SDK: ID3D10EffectBlendVariable)
Public class | EffectConstantBuffer | A constant-buffer interface accesses constant buffers or texture buffers. (Also see DirectX SDK: ID3D10EffectConstantBuffer)
Public class | EffectDepthStencilVariable | A depth-stencil-variable interface accesses depth-stencil state. (Also see DirectX SDK: ID3D10EffectDepthStencilVariable)
Public class | EffectDepthStencilViewVariable | A depth-stencil-view-variable interface accesses a depth-stencil view. (Also see DirectX SDK: ID3D10EffectDepthStencilViewVariable)
Public class | EffectMatrixVariable | A matrix-variable interface accesses a matrix. (Also see DirectX SDK: ID3D10EffectMatrixVariable)
Public class | EffectPass | A pass interface encapsulates state assignments within a technique. (Also see DirectX SDK: ID3D10EffectPass)
Public class | EffectPool | A pool interface represents a common memory space (or pool) for sharing variables between effects. (Also see DirectX SDK: ID3D10EffectPool)
Public class | EffectRasterizerVariable | A rasterizer-variable interface accesses rasterizer state. (Also see DirectX SDK: ID3D10EffectRasterizerVariable)
Public class | EffectRenderTargetViewVariable | A render-target-view interface accesses a render target. (Also see DirectX SDK: ID3D10EffectRenderTargetViewVariable)
Public class | EffectSamplerVariable | A sampler interface accesses sampler state. (Also see DirectX SDK: ID3D10EffectSamplerVariable)
Public class | EffectScalarVariable | An effect-scalar-variable interface accesses scalar values. (Also see DirectX SDK: ID3D10EffectScalarVariable)
Public class | EffectShaderResourceVariable | A shader-resource interface accesses a shader resource. (Also see DirectX SDK: ID3D10EffectShaderResourceVariable)
Public class | EffectShaderVariable | A shader-variable interface accesses a shader variable. (Also see DirectX SDK: ID3D10EffectShaderVariable)
Public class | EffectStringVariable | A string-variable interface accesses a string variable. (Also see DirectX SDK: ID3D10EffectStringVariable)
Public class | EffectTechnique | An EffectTechnique interface is a collection of passes. (Also see DirectX SDK: ID3D10EffectTechnique)
Public class | EffectType | The EffectType interface accesses effect variables by type. (Also see DirectX SDK: ID3D10EffectType)
Public class | EffectVariable | The EffectVariable interface is the base class for all effect variables. (Also see DirectX SDK: ID3D10EffectVariable)
Public class | EffectVectorVariable | A vector-variable interface accesses a four-component vector. (Also see DirectX SDK: ID3D10EffectVectorVariable)
Public class | GeometryShader | A geometry-shader interface manages an executable program (a geometry shader) that controls the geometry-shader stage. (Also see DirectX SDK: ID3D10GeometryShader)
Public class | GeometryShaderPipelineStage | Geometry Shader pipeline stage.
Public class | Include | An include interface allows an application to create user-overridable methods for opening and closing files when loading an effect from memory. This class does not inherit from anything, but does declare the following methods: (Also see DirectX SDK: ID3D10Include)
Public class | InfoQueue | An information-queue interface stores, retrieves, and filters debug messages. The queue consists of a message queue, an optional storage filter stack, and a optional retrieval filter stack. (Also see DirectX SDK: ID3D10InfoQueue)
Public class | InputAssemblerPipelineStage | InputAssembler pipeline stage.
Public class | InputLayout | An input-layout interface accesses the input data for the input-assembler stage. (Also see DirectX SDK: ID3D10InputLayout)
Public class | Multithread | A multithread interface accesses multithread settings and can only be used if the thread-safe layer is turned on. (Also see DirectX SDK: ID3D10Multithread)
Public class | OutputMergerBlendState | Stores the blend state, including blend factors and mask, for the merger pipeline stage
Public class | OutputMergerPipelineStage | OutputMerger pipeline stage.
Public class | OutputMergerRenderTargets | Stores the render targets for a merger pipeline stage
Public class | PipelineStage | A pipeline stage. base class for all pipline stage related classes.
Public class | PixelShader | A pixel-shader interface manages an executable program (a pixel shader) that controls the pixel-shader stage. (Also see DirectX SDK: ID3D10PixelShader)
Public class | PixelShaderPipelineStage | Pixel Shader pipeline stage.
Public class | RasterizerPipelineStage | Rasterizer pipeline stage.
Public class | RasterizerState | A rasterizer-state interface accesses rasterizer state for the rasterizer stage. (Also see DirectX SDK: ID3D10RasterizerState)
Public class | RenderTargetView | A render-target-view interface identifies the render-target subresources that can be accessed during rendering. (Also see DirectX SDK: ID3D10RenderTargetView)
Public class | SamplerState | A sampler-state interface accesses sampler state for a texture. (Also see DirectX SDK: ID3D10SamplerState)
Public class | ShaderReflection | A shader-reflection interface accesses shader information. (Also see DirectX SDK: ID3D10ShaderReflection)
Public class | ShaderReflection1 | A shader-reflection interface accesses shader information. (Also see DirectX SDK: ID3D10ShaderReflection1)
Public class | ShaderReflectionConstantBuffer | This shader-reflection interface provides access to a constant buffer. This class does not inherit from anything, but does declare the following methods: (Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer)
Public class | ShaderReflectionType | This shader-reflection interface provides access to variable type. This class does not inherit from anything, but does declare the following methods: (Also see DirectX SDK: ID3D10ShaderReflectionType)
Public class | ShaderReflectionVariable | This shader-reflection interface provides access to a variable. This class does not inherit from anything, but does declare the following methods: (Also see DirectX SDK: ID3D10ShaderReflectionVariable)
Public class | ShaderResourceView | A shader-resource-view interface specifies the subresources a shader can access during rendering. Examples of shader resources include a constant buffer, a texture buffer, a texture or a sampler. (Also see DirectX SDK: ID3D10ShaderResourceView)
Public class | ShaderResourceView1 | A shader-resource-view interface specifies the subresources a shader can access during rendering. Examples of shader resources include a constant buffer, a texture buffer, a texture or a sampler. (Also see DirectX SDK: ID3D10ShaderResourceView1)
Public class | StateBlock | A state-block interface encapsulates render states. (Also see DirectX SDK: ID3D10StateBlock)
Public class | StateBlockMask | Indicates the device state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK)
Public class | StreamOutputPipelineStage | StreamOutput pipeline stage.
Public class | SwitchToRef | A swith-to-reference interface (see the switch-to-reference layer) enables an application to switch between a hardware and software device. (Also see DirectX SDK: ID3D10SwitchToRef)
Public class | Texture1D | A 1D texture interface accesses texel data, which is structured memory. (Also see DirectX SDK: ID3D10Texture1D)
Public class | Texture2D | A 2D texture interface manages texel data, which is structured memory. (Also see DirectX SDK: ID3D10Texture2D)
Public class | Texture3D | A 3D texture interface accesses texel data, which is structured memory. (Also see DirectX SDK: ID3D10Texture3D)
Public class | VertexShader | A vertex-shader interface manages an executable program (a vertex shader) that controls the vertex-shader stage. (Also see DirectX SDK: ID3D10VertexShader)
Public class | VertexShaderPipelineStage | Vertex Shader pipeline stage.
Public class | View | A view interface specifies the parts of a resource the pipeline can access during rendering. (Also see DirectX SDK: ID3D10View)

Structures

 | Structure | Description
Public structure | BlendDescription | Describes the blend state. (Also see DirectX SDK: D3D10_BLEND_DESC)
Public structure | BlendDescription1 | Describes the blend state for a Direct3D 10.1 device. (Also see DirectX SDK: D3D10_BLEND_DESC1)
Public structure | Box | Defines a 3D box. (Also see DirectX SDK: D3D10_BOX)
Public structure | BufferDescription | Describes a buffer resource. (Also see DirectX SDK: D3D10_BUFFER_DESC)
Public structure | BufferRenderTargetView | Specifies the elements from a buffer resource to use in a render-target view. (Also see DirectX SDK: D3D10_BUFFER_RTV)
Public structure | BufferShaderResourceView | Specifies the elements in a buffer resource to use in a shader-resource view. (Also see DirectX SDK: D3D10_BUFFER_SRV)
Public structure | CounterDescription | Describes a counter. (Also see DirectX SDK: D3D10_COUNTER_DESC)
Public structure | CounterInformation | Information about the video card's performance counter capabilities. (Also see DirectX SDK: D3D10_COUNTER_INFO)
Public structure | DepthStencilDescription | Describes depth-stencil state. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC)
Public structure | DepthStencilOperationDescription | Describes the stencil operations that can be performed based on the results of stencil test. (Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC)
Public structure | DepthStencilViewDescription | Specifies the subresource(s) from a texture that are accessible using a depth-stencil view. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC)
Public structure | EffectDescription | Describes an effect. (Also see DirectX SDK: D3D10_EFFECT_DESC)
Public structure | EffectShaderDescription | Describes an effect shader. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC)
Public structure | EffectTypeDescription | Describes an effect-variable type. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC)
Public structure | EffectVariableDescription | Describes an effect variable. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC)
Public structure | IncludeData |
Public structure | IndexBuffer | Stores the parameters required to get or set the current index buffer for a device.
Public structure | InputElementDescription | A description of a single element for the input-assembler stage. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC)
Public structure | MappedTexture2D | Provides access to subresource data in a 2D texture. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE2D)
Public structure | MappedTexture3D | Provides access to subresource data in a 3D texture. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D)
Public structure | Message | A debug message in the Information Queue. (Also see DirectX SDK: D3D10_MESSAGE)
Public structure | OutputBuffer |
Public structure | PassDescription | Describes an effect pass, which contains pipeline state. (Also see DirectX SDK: D3D10_PASS_DESC)
Public structure | PassShaderDescription | Describes an effect variable that contains a shader. (Also see DirectX SDK: D3D10_PASS_SHADER_DESC)
Public structure | QueryDataPipelineStatistics | Query information about graphics-pipeline activity in between calls to Asynchronous.Begin and Asynchronous.End. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS)
Public structure | QueryDataStreamOutputStatistics | Query information about the amount of data streamed out to the stream-output buffers in between Asynchronous.Begin and Asynchronous.End. (Also see DirectX SDK: D3D10_QUERY_DATA_SO_STATISTICS)
Public structure | QueryDataTimestampDisjoint | Query information about the reliability of a timestamp query. (Also see DirectX SDK: D3D10_QUERY_DATA_TIMESTAMP_DISJOINT)
Public structure | QueryDescription | Describes a query. (Also see DirectX SDK: D3D10_QUERY_DESC)
Public structure | RasterizerDescription | Describes the rasterizer state. (Also see DirectX SDK: D3D10_RASTERIZER_DESC)
Public structure | RenderTargetBlendDescription1 | Describes the blend state for a render target for a Direct3D 10.1 device (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1)
Public structure | RenderTargetViewDescription | Specifies the subresource(s) from a resource that are accessible using a render-target view. (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC)
Public structure | SamplerDescription | Describes a sampler state. (Also see DirectX SDK: D3D10_SAMPLER_DESC)
Public structure | ShaderBufferDescription | Describes a shader constant-buffer. (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC)
Public structure | ShaderDescription | Describes a shader. (Also see DirectX SDK: D3D10_SHADER_DESC)
Public structure | ShaderInputBindDescription | Describes how a shader resource is bound to a shader input. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC)
Public structure | ShaderResourceViewDescription | Describes a shader-resource view. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC)
Public structure | ShaderResourceViewDescription1 | Describes a shader-resource view. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1)
Public structure | ShaderTypeDescription | Describes a shader-variable type. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC)
Public structure | ShaderVariableDescription | Describes a shader variable. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC)
Public structure | SignatureParameterDescription | Describes a shader signature. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC)
Public structure | StreamOutputDeclarationEntry | Description of a vertex element in a vertex buffer in an output slot. (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY)
Public structure | SubresourceData | Specifies data for initializing a subresource. (Also see DirectX SDK: D3D10_SUBRESOURCE_DATA)
Public structure | TechniqueDescription | Describes an effect technique. (Also see DirectX SDK: D3D10_TECHNIQUE_DESC)
Public structure | Texture1DArrayDepthStencilView | Specifies the subresource(s) from an array of 1D textures to use in a depth-stencil view. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV)
Public structure | Texture1DArrayRenderTargetView | Specifies the subresource(s) from an array of 1D textures to use in a render-target view. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV)
Public structure | Texture1DArrayShaderResourceView | Specifies the subresource(s) from an array of 1D textures to use in a shader-resource view. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV)
Public structure | Texture1DDepthStencilView | Specifies the subresource from a 1D texture that is accessable to a depth-stencil view. (Also see DirectX SDK: D3D10_TEX1D_DSV)
Public structure | Texture1DDescription | Describes a 1D texture. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC)
Public structure | Texture1DRenderTargetView | Specifies the subresource from a 1D texture to use in a render-target view. (Also see DirectX SDK: D3D10_TEX1D_RTV)
Public structure | Texture1DShaderResourceView | Specifies the subresource from a 1D texture to use in a shader-resource view. (Also see DirectX SDK: D3D10_TEX1D_SRV)
Public structure | Texture2DArrayDepthStencilView | Specifies the subresource(s) from an array 2D textures that are accessable to a depth-stencil view. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV)
Public structure | Texture2DArrayRenderTargetView | Specifies the subresource(s) from an array of 2D textures to use in a render-target view. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV)
Public structure | Texture2DArrayShaderResourceView | Specifies the subresource(s) from an array of 2D textures to use in a shader-resource view. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV)
Public structure | Texture2DDepthStencilView | Specifies the subresource from a 2D texture that is accessable to a depth-stencil view. (Also see DirectX SDK: D3D10_TEX2D_DSV)
Public structure | Texture2DDescription | Describes a 2D texture. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC)
Public structure | Texture2DMultisampleArrayDepthStencilView | Specifies the subresource(s) from an array of multisampled 2D textures for a depth-stencil view. (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_DSV)
Public structure | Texture2DMultisampleArrayRenderTargetView | Specifies the subresource(s) from a an array of multisampled 2D textures to use in a render-target view. (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_RTV)
Public structure | Texture2DMultisampleArrayShaderResourceView | Specifies the subresource(s) from an array of multisampled 2D textures to use in a shader-resource view. (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_SRV)
Public structure | Texture2DMultisampleDepthStencilView | Specifies the subresource from a multisampled 2D texture that is accessable to a depth-stencil view. (Also see DirectX SDK: D3D10_TEX2DMS_DSV)
Public structure | Texture2DMultisampleRenderTargetView | Specifies the subresource from a multisampled 2D texture to use in a render-target view. (Also see DirectX SDK: D3D10_TEX2DMS_RTV)
Public structure | Texture2DMultisampleShaderResourceView | Specifies the subresource(s) from a multisampled 2D texture to use in a shader-resource view. (Also see DirectX SDK: D3D10_TEX2DMS_SRV)
Public structure | Texture2DRenderTargetView | Specifies the subresource from a 2D texture to use in a render-target view. (Also see DirectX SDK: D3D10_TEX2D_RTV)
Public structure | Texture2DShaderResourceView | Specifies the subresource from a 2D texture to use in a shader-resource view. (Also see DirectX SDK: D3D10_TEX2D_SRV)
Public structure | Texture3DDescription | Describes a 3D texture. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC)
Public structure | Texture3DRenderTargetView | Specifies the subresource(s) from a 3D texture to use in a render-target view. (Also see DirectX SDK: D3D10_TEX3D_RTV)
Public structure | Texture3DShaderResourceView | Specifies the subresource(s) from a 3D texture to use in a shader-resource view. (Also see DirectX SDK: D3D10_TEX3D_SRV)
Public structure | TextureCubeArrayShaderResourceView1 | Specifies the subresource(s) from an array of cube textures to use in a shader-resource view. (Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1)
Public structure | TextureCubeShaderResourceView | Specifies the subresource from a cube texture to use in a shader-resource view. (Also see DirectX SDK: D3D10_TEXCUBE_SRV)
Public structure | VertexBuffer | Stores the parameters required to get or set a vertex buffer for a device.
Public structure | Viewport | Defines the dimensions of a viewport. (Also see DirectX SDK: D3D10_VIEWPORT)

Enumerations

 | Enumeration | Description
Public enumeration | AsyncGetDataOptions | Optional flags that control the behavior of Asynchronous.GetData. (Also see DirectX SDK: D3D10_ASYNC_GETDATA_FLAG)
Public enumeration | BindingOptions | Identifies how to bind a resource to the pipeline. (Also see DirectX SDK: D3D10_BIND_FLAG)
Public enumeration | Blend | Blend options. A blend option identifies the data source and an optional pre-blend operation. (Also see DirectX SDK: D3D10_BLEND)
Public enumeration | BlendOperation | RGB or alpha blending operation. (Also see DirectX SDK: D3D10_BLEND_OP)
Public enumeration | ClearOptions | Specifies the parts of the depth stencil to clear. Usually used with Device.ClearDepthStencilView. (Also see DirectX SDK: D3D10_CLEAR_FLAG)
Public enumeration | ColorWriteEnableComponents | Identify which components of each pixel of a render target are writable during blending. (Also see DirectX SDK: D3D10_COLOR_WRITE_ENABLE)
Public enumeration | ComparisonFunction | Comparison options. (Also see DirectX SDK: D3D10_COMPARISON_FUNC)
Public enumeration | ConstantBufferType | These flags identify constant-buffer-data types. (Also see DirectX SDK: D3D10_CBUFFER_TYPE)
Public enumeration | Counter | Performance counter types. (Also see DirectX SDK: D3D10_COUNTER)
Public enumeration | CounterType | Data type of a performance counter. (Also see DirectX SDK: D3D10_COUNTER_TYPE)
Public enumeration | CpuAccessOptions | Specifies the types of CPU access allowed for a resource. (Also see DirectX SDK: D3D10_CPU_ACCESS_FLAG)
Public enumeration | CreateDeviceOptions | Device creation flags. (Also see DirectX SDK: D3D10_CREATE_DEVICE_FLAG)
Public enumeration | CullMode | Indicates triangles facing a particular direction are not drawn. (Also see DirectX SDK: D3D10_CULL_MODE)
Public enumeration | DebugFeatures | Setting a feature-mask flag will cause a rendering-operation method to do some extra task when called.
Public enumeration | DepthStencilViewDimension | Specifies how to access a resource used in a depth-stencil view. (Also see DirectX SDK: D3D10_DSV_DIMENSION)
Public enumeration | DepthWriteMask | Identify the portion of a depth-stencil buffer for writing depth data. (Also see DirectX SDK: D3D10_DEPTH_WRITE_MASK)
Public enumeration | DeviceStateType | Effect device-state types. (Also see DirectX SDK: D3D10_DEVICE_STATE_TYPES)
Public enumeration | DriverType | The device-driver type. (Also see DirectX SDK: D3D10_DRIVER_TYPE)
Public enumeration | ExceptionErrors | Option(s) for raising an error to a non-continuable exception. (Also see DirectX SDK: D3D10_RAISE_FLAG)
Public enumeration | FillMode | Determines the fill mode to use when rendering triangles. (Also see DirectX SDK: D3D10_FILL_MODE)
Public enumeration | Filter | Filtering options during texture sampling. (Also see DirectX SDK: D3D10_FILTER)
Public enumeration | FilterType | Types of magnification or minification sampler filters. (Also see DirectX SDK: D3D10_FILTER_TYPE)
Public enumeration | FormatSupportOptions | Which resources are supported for a given format and given device. (Also see DirectX SDK: D3D10_FORMAT_SUPPORT)
Public enumeration | IncludeType | Flags for indicating the location of an include file. (Also see DirectX SDK: D3D10_INCLUDE_TYPE)
Public enumeration | InputClassification | Type of data contained in an input slot. (Also see DirectX SDK: D3D10_INPUT_CLASSIFICATION)
Public enumeration | Map | Identifies a resource to be accessed for reading and writing by the CPU. Applications may combine one or more of these flags. (Also see DirectX SDK: D3D10_MAP)
Public enumeration | MapOptions | Specifies how the CPU should respond when Map is called on a resource being used by the GPU. (Also see DirectX SDK: D3D10_MAP_FLAG)
Public enumeration | MessageCategory | Categories of debug messages. This will identify the category of a message when retrieving a message with InfoQueue.GetMessage and when adding a message with InfoQueue.AddMessage. When creating an info queue filter, these values can be used to allow or deny any categories of messages to pass through the storage and retrieval filters. (Also see DirectX SDK: D3D10_MESSAGE_CATEGORY)
Public enumeration | MessageId | Debug messages for setting up an info-queue filter; use these messages to allow or deny message categories to pass through the storage and retrieval filters. These IDs are used by methods such as InfoQueue.GetMessage or InfoQueue.AddMessage. (Also see DirectX SDK: D3D10_MESSAGE_ID)
Public enumeration | MessageSeverity | Debug message severity levels for an information queue. (Also see DirectX SDK: D3D10_MESSAGE_SEVERITY)
Public enumeration | MiscellaneousQueryOptions | Flags that describe miscellaneous query behavior. (Also see DirectX SDK: D3D10_QUERY_MISC_FLAG)
Public enumeration | MiscellaneousResourceOptions | Identifies other, less common options for resources. (Also see DirectX SDK: D3D10_RESOURCE_MISC_FLAG)
Public enumeration | Name | These values identify shader parameters that use system-value semantics. (Also see DirectX SDK: D3D10_NAME)
Public enumeration | Primitive | Primitive type, which determines how the data that makes up object geometry is organized. (Also see DirectX SDK: D3D10_PRIMITIVE)
Public enumeration | PrimitiveTopology | How the pipeline interprets vertex data that is bound to the input-assembler stage. These primitive types determine how the vertex data is rendered on screen. (Also see DirectX SDK: D3D10_PRIMITIVE_TOPOLOGY)
Public enumeration | Query | Query types. (Also see DirectX SDK: D3D10_QUERY)
Public enumeration | RegisterComponentType | The register component types, usually used in SignatureParameterDescription. (Also see DirectX SDK: D3D10_REGISTER_COMPONENT_TYPE)
Public enumeration | RenderTargetViewDimension | Specifies how to access a resource used in a render-target view. (Also see DirectX SDK: D3D10_RTV_DIMENSION)
Public enumeration | ResourceDimension | Identifies the type of resource being used. (Also see DirectX SDK: D3D10_RESOURCE_DIMENSION)
Public enumeration | ResourceReturnType | The return type of a resource. See ShaderInputBindDescription. (Also see DirectX SDK: D3D10_RESOURCE_RETURN_TYPE)
Public enumeration | ShaderConstantBufferProperties | These flags identify constant-buffer properties. (Also see DirectX SDK: D3D10_SHADER_CBUFFER_FLAGS)
Public enumeration | ShaderDebugRegisterType | Shader register types. (Also see DirectX SDK: D3D10_SHADER_DEBUG_REGTYPE)
Public enumeration | ShaderDebugScopeType | Scope types. (Also see DirectX SDK: D3D10_SHADER_DEBUG_SCOPETYPE)
Public enumeration | ShaderDebugVariantType | TBD (Also see DirectX SDK: D3D10_SHADER_DEBUG_VARTYPE)
Public enumeration | ShaderInputOptions | These flags identify shader-input options. (Also see DirectX SDK: D3D10_SHADER_INPUT_FLAGS)
Public enumeration | ShaderInputType | These flags identify a shader-resource type. (Also see DirectX SDK: D3D10_SHADER_INPUT_TYPE)
Public enumeration | ShaderResourceViewDimension | These flags identify the type of resource that will be viewed. (Also see DirectX SDK: D3D10_SRV_DIMENSION)
Public enumeration | ShaderResourceViewDimension1 | These flags identify the type of resource that will be viewed. (Also see DirectX SDK: D3D10_SRV_DIMENSION1)
Public enumeration | ShaderVariableClass | These flags identify the shader-variable class. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_CLASS)
Public enumeration | ShaderVariableProperties | Flags that indicate information about a shader variable; these flags are returned using a reflection object. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_FLAGS)
Public enumeration | ShaderVariableType | These values identify the shader-variable type. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_TYPE)
Public enumeration | StencilOperation | The stencil operations that can be performed during depth-stencil testing. (Also see DirectX SDK: D3D10_STENCIL_OP)
Public enumeration | StencilReadMask | A value that identifies a portion of the depth-stencil buffer for reading stencil data.
Public enumeration | StencilWriteMask | A value that identifies a portion of the depth-stencil buffer for writing stencil data.
Public enumeration | TextureAddressMode | Identify a technique for resolving texture coordinates that are outside of the boundaries of a texture. (Also see DirectX SDK: D3D10_TEXTURE_ADDRESS_MODE)
Public enumeration | TextureCubeFace | The different faces of a cube texture. (Also see DirectX SDK: D3D10_TEXTURECUBE_FACE)
Public enumeration | Usage | Identifies expected resource use during rendering. The usage directly reflects whether a resource is accessible by the CPU and/or the GPU. (Also see DirectX SDK: D3D10_USAGE)


AsyncGetDataOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AsyncGetDataOptions Enumeration
See Also Send Feedback
Optional flags that control the behavior of Asynchronous.GetData.

(Also see DirectX SDK: D3D10_ASYNC_GETDATA_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum AsyncGetDataOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration AsyncGetDataOptions
Visual C++
[FlagsAttribute]
public enum class AsyncGetDataOptions

Members

Member name | Description
DoNotFlush |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Asynchronous Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous Class
Members See Also Send Feedback
This class encapsulates methods for retrieving data from the GPU asynchronously.

(Also see DirectX SDK: ID3D10Asynchronous)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Asynchronous : DeviceChild
Visual Basic
Public Class Asynchronous _
    Inherits DeviceChild
Visual C++
public ref class Asynchronous : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DCounter
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DQuery

See Also

Asynchronous Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Asynchronous Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous Members
Asynchronous Class Methods Properties See Also Send Feedback

The Asynchronous type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Starts the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::Begin)
Public method | End | Ends the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::End)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D10Asynchronous::GetData)

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling Asynchronous.GetData. (Also see DirectX SDK: ID3D10Asynchronous::GetDataSize)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Asynchronous Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous Methods
Asynchronous Class See Also Send Feedback

The Asynchronous type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Starts the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::Begin)
Public method | End | Ends the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::End)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D10Asynchronous::GetData)

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Begin Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous..::..Begin Method
Asynchronous Class See Also Send Feedback
Starts the collection of GPU data.

(Also see DirectX SDK: ID3D10Asynchronous::Begin)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Begin()
Visual Basic
Public Sub Begin
Visual C++
public:
void Begin()

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


End Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous..::..End Method
Asynchronous Class See Also Send Feedback
Ends the collection of GPU data.

(Also see DirectX SDK: ID3D10Asynchronous::End)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void End()
Visual Basic
Public Sub End
Visual C++
public:
void End()

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetData Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous..::..GetData Method
Asynchronous Class See Also Send Feedback
Get data from the GPU asynchronously.

(Also see DirectX SDK: ID3D10Asynchronous::GetData)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void GetData(
    IntPtr data,
    uint dataSize,
    AsyncGetDataOptions options
)
Visual Basic
Public Sub GetData ( _
    data As IntPtr, _
    dataSize As UInteger, _
    options As AsyncGetDataOptions _
)
Visual C++
public:
void GetData(
    IntPtr data,
    unsigned int dataSize,
    AsyncGetDataOptions options
)

Parameters

data
Type: System..::..IntPtr
Address of memory that will receive the data. If NULL, GetData will be used only to check status. The type of data output depends on the type of asynchronous object. See Remarks.
dataSize
Type: System..::..UInt32
Size of the data to retrieve or 0. This value can be obtained with Asynchronous.GetDataSize. Must be 0 when pData is NULL.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..AsyncGetDataOptions
Optional flags. Can be 0 or any combination of the flags enumerated by AsyncGetDataOptions.

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Asynchronous Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous Properties
Asynchronous Class See Also Send Feedback

The Asynchronous type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling Asynchronous.GetData. (Also see DirectX SDK: ID3D10Asynchronous::GetDataSize)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DataSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous..::..DataSize Property
Asynchronous Class See Also Send Feedback
Get the size of the data (in bytes) that is output when calling Asynchronous.GetData.

(Also see DirectX SDK: ID3D10Asynchronous::GetDataSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DataSize { get; }
Visual Basic
Public ReadOnly Property DataSize As UInteger
    Get
Visual C++
public:
property unsigned int DataSize {
    unsigned int get ();
}

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BindingOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BindingOptions Enumeration
See Also Send Feedback
Identifies how to bind a resource to the pipeline.

(Also see DirectX SDK: D3D10_BIND_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum BindingOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration BindingOptions
Visual C++
[FlagsAttribute]
public enum class BindingOptions

Members

Member name | Description
DepthStencil |
RenderTarget |
StreamOutput |
ShaderResource |
IndexBuffer |
VertexBuffer |
None |
ConstantBuffer |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Blend Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Blend Enumeration
See Also Send Feedback
Blend options. A blend option identifies the data source and an optional pre-blend operation.

(Also see DirectX SDK: D3D10_BLEND)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Blend
Visual Basic
Public Enumeration Blend
Visual C++
public enum class Blend

Members

Member name | Description
InverseSource1Alpha |
Source1Alpha |
InverseSource1Color |
Source1Color |
InverseBlendFactor |
SourceAlphaSat |
InverseDestinationColor |
DestinationColor |
InverseDestinationAlpha |
DestinationAlpha |
InverseSourceAlpha |
SourceAlpha |
InverseSourceColor |
SourceColor |
One |
Zero |
BlendFactor |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription Structure
Members See Also Send Feedback
Describes the blend state.

(Also see DirectX SDK: D3D10_BLEND_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BlendDescription
Visual Basic
Public Structure BlendDescription
Visual C++
public value class BlendDescription

See Also

BlendDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription Members
BlendDescription Structure Properties See Also Send Feedback

The BlendDescription type exposes the following members.

Properties

 | Name | Description
Public property | AlphaToCoverageEnable | Determines whether or not to use alpha-to-coverage as a multisampling technique when setting a pixel to a rendertarget. (Also see DirectX SDK: D3D10_BLEND_DESC.AlphaToCoverageEnable)
Public property | BlendEnable | Enable (or disable) blending. There are eight elements in this array; these correspond to the eight rendertargets that can be set to output-merger stage at one time. (Also see DirectX SDK: D3D10_BLEND_DESC.BlendEnable)
Public property | BlendOperation | This blend operation defines how to combine the RGB data sources. (Also see DirectX SDK: D3D10_BLEND_DESC.BlendOp)
Public property | BlendOperationAlpha | This blend operation defines how to combine the alpha data sources. (Also see DirectX SDK: D3D10_BLEND_DESC.BlendOpAlpha)
Public property | DestinationBlend | This blend option specifies the second RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D10_BLEND_DESC.DestBlend)
Public property | DestinationBlendAlpha | This blend option specifies the second alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D10_BLEND_DESC.DestBlendAlpha)
Public property | RenderTargetWriteMask | A per-pixel write mask that allows control over which components can be written (see ColorWriteEnableComponents). (Also see DirectX SDK: D3D10_BLEND_DESC.RenderTargetWriteMask)
Public property | SourceBlend | This blend option specifies the first RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D10_BLEND_DESC.SrcBlend)
Public property | SourceBlendAlpha | This blend option specifies the first alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D10_BLEND_DESC.SrcBlendAlpha)

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription Properties
BlendDescription Structure See Also Send Feedback

The BlendDescription type exposes the following members.

Properties

 | Name | Description
Public property | AlphaToCoverageEnable | Determines whether or not to use alpha-to-coverage as a multisampling technique when setting a pixel to a rendertarget. (Also see DirectX SDK: D3D10_BLEND_DESC.AlphaToCoverageEnable)
Public property | BlendEnable | Enable (or disable) blending. There are eight elements in this array; these correspond to the eight rendertargets that can be set to output-merger stage at one time. (Also see DirectX SDK: D3D10_BLEND_DESC.BlendEnable)
Public property | BlendOperation | This blend operation defines how to combine the RGB data sources. (Also see DirectX SDK: D3D10_BLEND_DESC.BlendOp)
Public property | BlendOperationAlpha | This blend operation defines how to combine the alpha data sources. (Also see DirectX SDK: D3D10_BLEND_DESC.BlendOpAlpha)
Public property | DestinationBlend | This blend option specifies the second RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D10_BLEND_DESC.DestBlend)
Public property | DestinationBlendAlpha | This blend option specifies the second alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D10_BLEND_DESC.DestBlendAlpha)
Public property | RenderTargetWriteMask | A per-pixel write mask that allows control over which components can be written (see ColorWriteEnableComponents). (Also see DirectX SDK: D3D10_BLEND_DESC.RenderTargetWriteMask)
Public property | SourceBlend | This blend option specifies the first RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D10_BLEND_DESC.SrcBlend)
Public property | SourceBlendAlpha | This blend option specifies the first alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D10_BLEND_DESC.SrcBlendAlpha)

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AlphaToCoverageEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..AlphaToCoverageEnable Property
BlendDescription Structure See Also Send Feedback
Determines whether or not to use alpha-to-coverage as a multisampling technique when setting a pixel to a rendertarget.

(Also see DirectX SDK: D3D10_BLEND_DESC.AlphaToCoverageEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool AlphaToCoverageEnable { get; set; }
Visual Basic
Public Property AlphaToCoverageEnable As Boolean
    Get
    Set
Visual C++
public:
property bool AlphaToCoverageEnable {
    bool get ();
    void set (bool value);
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..BlendEnable Property
BlendDescription Structure See Also Send Feedback
Enable (or disable) blending. There are eight elements in this array; these correspond to the eight rendertargets that can be set to output-merger stage at one time.

(Also see DirectX SDK: D3D10_BLEND_DESC.BlendEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<bool> BlendEnable { get; }
Visual Basic
Public ReadOnly Property BlendEnable As ReadOnlyCollection(Of Boolean)
    Get
Visual C++
public:
property ReadOnlyCollection<bool>^ BlendEnable {
    ReadOnlyCollection<bool>^ get ();
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendOperation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..BlendOperation Property
BlendDescription Structure See Also Send Feedback
This blend operation defines how to combine the RGB data sources.

(Also see DirectX SDK: D3D10_BLEND_DESC.BlendOp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendOperation BlendOperation { get; set; }
Visual Basic
Public Property BlendOperation As BlendOperation
    Get
    Set
Visual C++
public:
property BlendOperation BlendOperation {
    BlendOperation get ();
    void set (BlendOperation value);
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendOperationAlpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..BlendOperationAlpha Property
BlendDescription Structure See Also Send Feedback
This blend operation defines how to combine the alpha data sources.

(Also see DirectX SDK: D3D10_BLEND_DESC.BlendOpAlpha)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendOperation BlendOperationAlpha { get; set; }
Visual Basic
Public Property BlendOperationAlpha As BlendOperation
    Get
    Set
Visual C++
public:
property BlendOperation BlendOperationAlpha {
    BlendOperation get ();
    void set (BlendOperation value);
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DestinationBlend Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..DestinationBlend Property
BlendDescription Structure See Also Send Feedback
This blend option specifies the second RGB data source and includes an optional pre-blend operation.

(Also see DirectX SDK: D3D10_BLEND_DESC.DestBlend)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend DestinationBlend { get; set; }
Visual Basic
Public Property DestinationBlend As Blend
    Get
    Set
Visual C++
public:
property Blend DestinationBlend {
    Blend get ();
    void set (Blend value);
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DestinationBlendAlpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..DestinationBlendAlpha Property
BlendDescription Structure See Also Send Feedback
This blend option specifies the second alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed.

(Also see DirectX SDK: D3D10_BLEND_DESC.DestBlendAlpha)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend DestinationBlendAlpha { get; set; }
Visual Basic
Public Property DestinationBlendAlpha As Blend
    Get
    Set
Visual C++
public:
property Blend DestinationBlendAlpha {
    Blend get ();
    void set (Blend value);
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetWriteMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..RenderTargetWriteMask Property
BlendDescription Structure See Also Send Feedback
A per-pixel write mask that allows control over which components can be written (see ColorWriteEnableComponents).

(Also see DirectX SDK: D3D10_BLEND_DESC.RenderTargetWriteMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ColorWriteEnableComponents> RenderTargetWriteMask { get; }
Visual Basic
Public ReadOnly Property RenderTargetWriteMask As ReadOnlyCollection(Of ColorWriteEnableComponents)
    Get
Visual C++
public:
property ReadOnlyCollection<ColorWriteEnableComponents>^ RenderTargetWriteMask {
    ReadOnlyCollection<ColorWriteEnableComponents>^ get ();
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ColorWriteEnableComponents


SourceBlend Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..SourceBlend Property
BlendDescription Structure See Also Send Feedback
This blend option specifies the first RGB data source and includes an optional pre-blend operation.

(Also see DirectX SDK: D3D10_BLEND_DESC.SrcBlend)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend SourceBlend { get; set; }
Visual Basic
Public Property SourceBlend As Blend
    Get
    Set
Visual C++
public:
property Blend SourceBlend {
    Blend get ();
    void set (Blend value);
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SourceBlendAlpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..SourceBlendAlpha Property
BlendDescription Structure See Also Send Feedback
This blend option specifies the first alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed.

(Also see DirectX SDK: D3D10_BLEND_DESC.SrcBlendAlpha)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend SourceBlendAlpha { get; set; }
Visual Basic
Public Property SourceBlendAlpha As Blend
    Get
    Set
Visual C++
public:
property Blend SourceBlendAlpha {
    Blend get ();
    void set (Blend value);
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendDescription1 Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription1 Structure
Members See Also Send Feedback
Describes the blend state for a Direct3D 10.1 device.

(Also see DirectX SDK: D3D10_BLEND_DESC1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BlendDescription1
Visual Basic
Public Structure BlendDescription1
Visual C++
public value class BlendDescription1

See Also

BlendDescription1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendDescription1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription1 Members
BlendDescription1 Structure Properties See Also Send Feedback

The BlendDescription1 type exposes the following members.

Properties

 | Name | Description
Public property | AlphaToCoverageEnable | Determines whether or not to use the alpha-to-coverage multisampling technique when setting a render-target pixel. (Also see DirectX SDK: D3D10_BLEND_DESC1.AlphaToCoverageEnable)
Public property | IndependentBlendEnable | Set to TRUE to enable independent blending in simultaneous render targets. (Also see DirectX SDK: D3D10_BLEND_DESC1.IndependentBlendEnable)
Public property | RenderTarget | An array of render-target-blend descriptions (see RenderTargetBlendDescription1); these correspond to the eight rendertargets that can be set to the output-merger stage at one time. (Also see DirectX SDK: D3D10_BLEND_DESC1.RenderTarget)

See Also

BlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendDescription1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription1 Properties
BlendDescription1 Structure See Also Send Feedback

The BlendDescription1 type exposes the following members.

Properties

 | Name | Description
Public property | AlphaToCoverageEnable | Determines whether or not to use the alpha-to-coverage multisampling technique when setting a render-target pixel. (Also see DirectX SDK: D3D10_BLEND_DESC1.AlphaToCoverageEnable)
Public property | IndependentBlendEnable | Set to TRUE to enable independent blending in simultaneous render targets. (Also see DirectX SDK: D3D10_BLEND_DESC1.IndependentBlendEnable)
Public property | RenderTarget | An array of render-target-blend descriptions (see RenderTargetBlendDescription1); these correspond to the eight rendertargets that can be set to the output-merger stage at one time. (Also see DirectX SDK: D3D10_BLEND_DESC1.RenderTarget)

See Also

BlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AlphaToCoverageEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription1..::..AlphaToCoverageEnable Property
BlendDescription1 Structure See Also Send Feedback
Determines whether or not to use the alpha-to-coverage multisampling technique when setting a render-target pixel.

(Also see DirectX SDK: D3D10_BLEND_DESC1.AlphaToCoverageEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool AlphaToCoverageEnable { get; set; }
Visual Basic
Public Property AlphaToCoverageEnable As Boolean
    Get
    Set
Visual C++
public:
property bool AlphaToCoverageEnable {
    bool get ();
    void set (bool value);
}

See Also

BlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IndependentBlendEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription1..::..IndependentBlendEnable Property
BlendDescription1 Structure See Also Send Feedback
Set to TRUE to enable independent blending in simultaneous render targets.

(Also see DirectX SDK: D3D10_BLEND_DESC1.IndependentBlendEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IndependentBlendEnable { get; set; }
Visual Basic
Public Property IndependentBlendEnable As Boolean
    Get
    Set
Visual C++
public:
property bool IndependentBlendEnable {
    bool get ();
    void set (bool value);
}

See Also

BlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTarget Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription1..::..RenderTarget Property
BlendDescription1 Structure See Also Send Feedback
An array of render-target-blend descriptions (see RenderTargetBlendDescription1); these correspond to the eight rendertargets that can be set to the output-merger stage at one time.

(Also see DirectX SDK: D3D10_BLEND_DESC1.RenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<RenderTargetBlendDescription1> RenderTarget { get; }
Visual Basic
Public ReadOnly Property RenderTarget As ReadOnlyCollection(Of RenderTargetBlendDescription1)
    Get
Visual C++
public:
property ReadOnlyCollection<RenderTargetBlendDescription1>^ RenderTarget {
    ReadOnlyCollection<RenderTargetBlendDescription1>^ get ();
}

See Also

BlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetBlendDescription1


BlendOperation Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendOperation Enumeration
See Also Send Feedback
RGB or alpha blending operation.

(Also see DirectX SDK: D3D10_BLEND_OP)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum BlendOperation
Visual Basic
Public Enumeration BlendOperation
Visual C++
public enum class BlendOperation

Members

Member name | Description
ReverseSubtract |
Max |
Min |
Subtract |
Add |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState Class
Members See Also Send Feedback
This blend-state interface accesses blending state for a Direct3D 10.0 device for the output-merger stage.

(Also see DirectX SDK: ID3D10BlendState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class BlendState : DeviceChild
Visual Basic
Public Class BlendState _
    Inherits DeviceChild
Visual C++
public ref class BlendState : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendState
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendState1

See Also

BlendState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState Members
BlendState Class Properties See Also Send Feedback

The BlendState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the blend state description. (Also see DirectX SDK: ID3D10BlendState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState Properties
BlendState Class See Also Send Feedback

The BlendState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the blend state description. (Also see DirectX SDK: ID3D10BlendState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState..::..Description Property
BlendState Class See Also Send Feedback
Get the blend state description.

(Also see DirectX SDK: ID3D10BlendState::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As BlendDescription
    Get
Visual C++
public:
property BlendDescription Description {
    BlendDescription get ();
}

See Also

BlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendState1 Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState1 Class
Members See Also Send Feedback
This blend-state interface accesses blending state for a Direct3D 10.1 device for the output-merger stage.

(Also see DirectX SDK: ID3D10BlendState1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class BlendState1 : BlendState
Visual Basic
Public Class BlendState1 _
    Inherits BlendState
Visual C++
public ref class BlendState1 : public BlendState

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendState
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendState1

See Also

BlendState1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendState1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState1 Members
BlendState1 Class Properties See Also Send Feedback

The BlendState1 type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the blend state description. (Also see DirectX SDK: ID3D10BlendState::GetDesc) (Inherited from BlendState.)
Public property | Description1 | Get the blend state. (Also see DirectX SDK: ID3D10BlendState1::GetDesc1)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BlendState1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendState1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState1 Properties
BlendState1 Class See Also Send Feedback

The BlendState1 type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the blend state description. (Also see DirectX SDK: ID3D10BlendState::GetDesc) (Inherited from BlendState.)
Public property | Description1 | Get the blend state. (Also see DirectX SDK: ID3D10BlendState1::GetDesc1)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BlendState1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState1..::..Description1 Property
BlendState1 Class See Also Send Feedback
Get the blend state.

(Also see DirectX SDK: ID3D10BlendState1::GetDesc1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendDescription1 Description1 { get; }
Visual Basic
Public ReadOnly Property Description1 As BlendDescription1
    Get
Visual C++
public:
property BlendDescription1 Description1 {
    BlendDescription1 get ();
}

See Also

BlendState1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Blob Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Blob Class
Members See Also Send Feedback
This class is used to return arbitrary length data.

(Also see DirectX SDK: ID3D10Blob)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Blob : DirectUnknown
Visual Basic
Public Class Blob _
    Inherits DirectUnknown
Visual C++
public ref class Blob : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Blob

See Also

Blob Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Blob Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Blob Members
Blob Class Methods Properties See Also Send Feedback

The Blob type exposes the following members.

Methods

Name | Description
Create | Creates a Blob instance of the given size.

Properties

 | Name | Description
Public property | BufferPointer | Get the data. (Also see DirectX SDK: ID3D10Blob::GetBufferPointer)
Public property | BufferSize | Get the size. (Also see DirectX SDK: ID3D10Blob::GetBufferSize)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Blob Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Blob Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Blob Methods
Blob Class See Also Send Feedback

The Blob type exposes the following members.

Methods

Name | Description
Create | Creates a Blob instance of the given size.

See Also

Blob Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Create Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Blob..::..Create Method
Blob Class See Also Send Feedback
Creates a Blob instance of the given size.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Blob Create(
    long size
)
Visual Basic
Public Shared Function Create ( _
    size As Long _
) As Blob
Visual C++
public:
static Blob^ Create(
    long long size
)

Parameters

size
Type: System..::..Int64

Remarks

See Also

Blob Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Blob Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Blob Properties
Blob Class See Also Send Feedback

The Blob type exposes the following members.

Properties

 | Name | Description
Public property | BufferPointer | Get the data. (Also see DirectX SDK: ID3D10Blob::GetBufferPointer)
Public property | BufferSize | Get the size. (Also see DirectX SDK: ID3D10Blob::GetBufferSize)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Blob Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferPointer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Blob..::..BufferPointer Property
Blob Class See Also Send Feedback
Get the data.

(Also see DirectX SDK: ID3D10Blob::GetBufferPointer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr BufferPointer { get; }
Visual Basic
Public ReadOnly Property BufferPointer As IntPtr
    Get
Visual C++
public:
property IntPtr BufferPointer {
    IntPtr get ();
}

See Also

Blob Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Blob..::..BufferSize Property
Blob Class See Also Send Feedback
Get the size.

(Also see DirectX SDK: ID3D10Blob::GetBufferSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BufferSize { get; }
Visual Basic
Public ReadOnly Property BufferSize As UInteger
    Get
Visual C++
public:
property unsigned int BufferSize {
    unsigned int get ();
}

See Also

Blob Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Box Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Structure
Members See Also Send Feedback
Defines a 3D box.

(Also see DirectX SDK: D3D10_BOX)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Box
Visual Basic
Public Structure Box
Visual C++
public value class Box

See Also

Box Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Box Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Members
Box Structure Methods Operators Properties See Also Send Feedback

The Box type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Back | The z position of the back of the box. (Also see DirectX SDK: D3D10_BOX.back)
Public property | Bottom | The y position of the bottom of the box. (Also see DirectX SDK: D3D10_BOX.bottom)
Public property | Front | The z position of the front of the box. (Also see DirectX SDK: D3D10_BOX.front)
Public property | Left | The x position of the left hand side of the box. (Also see DirectX SDK: D3D10_BOX.left)
Public property | Right | The x position of the right hand side of the box. (Also see DirectX SDK: D3D10_BOX.right)
Public property | Top | The y position of the top of the box. (Also see DirectX SDK: D3D10_BOX.top)

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Box Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Methods
Box Structure See Also Send Feedback

The Box type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Equals Method
Box Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..GetHashCode Method
Box Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Box Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Operators
Box Structure See Also Send Feedback

The Box type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Equality Operator
Box Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Box box1,
    Box box2
)
Visual Basic
Public Shared Operator = ( _
    box1 As Box, _
    box2 As Box _
) As Boolean
Visual C++
public:
static bool operator ==(
    Box box1,
    Box box2
)

Parameters

box1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Box
box2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Box

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Inequality Operator
Box Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Box box1,
    Box box2
)
Visual Basic
Public Shared Operator <> ( _
    box1 As Box, _
    box2 As Box _
) As Boolean
Visual C++
public:
static bool operator !=(
    Box box1,
    Box box2
)

Parameters

box1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Box
box2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Box

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Box Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Properties
Box Structure See Also Send Feedback

The Box type exposes the following members.

Properties

 | Name | Description
Public property | Back | The z position of the back of the box. (Also see DirectX SDK: D3D10_BOX.back)
Public property | Bottom | The y position of the bottom of the box. (Also see DirectX SDK: D3D10_BOX.bottom)
Public property | Front | The z position of the front of the box. (Also see DirectX SDK: D3D10_BOX.front)
Public property | Left | The x position of the left hand side of the box. (Also see DirectX SDK: D3D10_BOX.left)
Public property | Right | The x position of the right hand side of the box. (Also see DirectX SDK: D3D10_BOX.right)
Public property | Top | The y position of the top of the box. (Also see DirectX SDK: D3D10_BOX.top)

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Back Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Back Property
Box Structure See Also Send Feedback
The z position of the back of the box.

(Also see DirectX SDK: D3D10_BOX.back)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Back { get; set; }
Visual Basic
Public Property Back As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Back {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Bottom Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Bottom Property
Box Structure See Also Send Feedback
The y position of the bottom of the box.

(Also see DirectX SDK: D3D10_BOX.bottom)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Bottom { get; set; }
Visual Basic
Public Property Bottom As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Bottom {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Front Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Front Property
Box Structure See Also Send Feedback
The z position of the front of the box.

(Also see DirectX SDK: D3D10_BOX.front)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Front { get; set; }
Visual Basic
Public Property Front As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Front {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Left Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Left Property
Box Structure See Also Send Feedback
The x position of the left hand side of the box.

(Also see DirectX SDK: D3D10_BOX.left)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Left { get; set; }
Visual Basic
Public Property Left As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Left {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Right Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Right Property
Box Structure See Also Send Feedback
The x position of the right hand side of the box.

(Also see DirectX SDK: D3D10_BOX.right)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Right { get; set; }
Visual Basic
Public Property Right As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Right {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Top Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Top Property
Box Structure See Also Send Feedback
The y position of the top of the box.

(Also see DirectX SDK: D3D10_BOX.top)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Top { get; set; }
Visual Basic
Public Property Top As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Top {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Structure
Members See Also Send Feedback
Describes a buffer resource.

(Also see DirectX SDK: D3D10_BUFFER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BufferDescription
Visual Basic
Public Structure BufferDescription
Visual C++
public value class BufferDescription

See Also

BufferDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Members
BufferDescription Structure Methods Operators Properties See Also Send Feedback

The BufferDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BindingOptions | Identify how the buffer will be bound to the pipeline. Applications can logicaly OR flags together (see BindingOptions) to indicate that the buffer can be accessed in different ways. (Also see DirectX SDK: D3D10_BUFFER_DESC.BindFlags)
Public property | ByteWidth | Size of the buffer in bytes. (Also see DirectX SDK: D3D10_BUFFER_DESC.ByteWidth)
Public property | CpuAccessOptions | CPU access flags (see CpuAccessOptions) or 0 if no CPU access is necessary. Applications can logicaly OR flags together. (Also see DirectX SDK: D3D10_BUFFER_DESC.CPUAccessFlags)
Public property | MiscellaneousResourceOptions | Miscellaneous flags (see MiscellaneousResourceOptions) or 0 if unused. Applications can logically OR flags together. (Also see DirectX SDK: D3D10_BUFFER_DESC.MiscFlags)
Public property | Usage | Identify how the buffer is expected to be read from and written to. Frequency of update is a key factor. The most common value is typically Usage_DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D10_BUFFER_DESC.Usage)

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Methods
BufferDescription Structure See Also Send Feedback

The BufferDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..Equals Method
BufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..GetHashCode Method
BufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Operators
BufferDescription Structure See Also Send Feedback

The BufferDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..Equality Operator
BufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BufferDescription bufferDescription1,
    BufferDescription bufferDescription2
)
Visual Basic
Public Shared Operator = ( _
    bufferDescription1 As BufferDescription, _
    bufferDescription2 As BufferDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    BufferDescription bufferDescription1,
    BufferDescription bufferDescription2
)

Parameters

bufferDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferDescription
bufferDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferDescription

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..Inequality Operator
BufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BufferDescription bufferDescription1,
    BufferDescription bufferDescription2
)
Visual Basic
Public Shared Operator <> ( _
    bufferDescription1 As BufferDescription, _
    bufferDescription2 As BufferDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    BufferDescription bufferDescription1,
    BufferDescription bufferDescription2
)

Parameters

bufferDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferDescription
bufferDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferDescription

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Properties
BufferDescription Structure See Also Send Feedback

The BufferDescription type exposes the following members.

Properties

 | Name | Description
Public property | BindingOptions | Identify how the buffer will be bound to the pipeline. Applications can logicaly OR flags together (see BindingOptions) to indicate that the buffer can be accessed in different ways. (Also see DirectX SDK: D3D10_BUFFER_DESC.BindFlags)
Public property | ByteWidth | Size of the buffer in bytes. (Also see DirectX SDK: D3D10_BUFFER_DESC.ByteWidth)
Public property | CpuAccessOptions | CPU access flags (see CpuAccessOptions) or 0 if no CPU access is necessary. Applications can logicaly OR flags together. (Also see DirectX SDK: D3D10_BUFFER_DESC.CPUAccessFlags)
Public property | MiscellaneousResourceOptions | Miscellaneous flags (see MiscellaneousResourceOptions) or 0 if unused. Applications can logically OR flags together. (Also see DirectX SDK: D3D10_BUFFER_DESC.MiscFlags)
Public property | Usage | Identify how the buffer is expected to be read from and written to. Frequency of update is a key factor. The most common value is typically Usage_DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D10_BUFFER_DESC.Usage)

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BindingOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..BindingOptions Property
BufferDescription Structure See Also Send Feedback
Identify how the buffer will be bound to the pipeline. Applications can logicaly OR flags together (see BindingOptions) to indicate that the buffer can be accessed in different ways.

(Also see DirectX SDK: D3D10_BUFFER_DESC.BindFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BindingOptions BindingOptions { get; set; }
Visual Basic
Public Property BindingOptions As BindingOptions
    Get
    Set
Visual C++
public:
property BindingOptions BindingOptions {
    BindingOptions get ();
    void set (BindingOptions value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BindingOptions


ByteWidth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..ByteWidth Property
BufferDescription Structure See Also Send Feedback
Size of the buffer in bytes.

(Also see DirectX SDK: D3D10_BUFFER_DESC.ByteWidth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ByteWidth { get; set; }
Visual Basic
Public Property ByteWidth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ByteWidth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CpuAccessOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..CpuAccessOptions Property
BufferDescription Structure See Also Send Feedback
CPU access flags (see CpuAccessOptions) or 0 if no CPU access is necessary. Applications can logicaly OR flags together.

(Also see DirectX SDK: D3D10_BUFFER_DESC.CPUAccessFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CpuAccessOptions CpuAccessOptions { get; set; }
Visual Basic
Public Property CpuAccessOptions As CpuAccessOptions
    Get
    Set
Visual C++
public:
property CpuAccessOptions CpuAccessOptions {
    CpuAccessOptions get ();
    void set (CpuAccessOptions value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
BufferDescription..::..CpuAccessOptions


MiscellaneousResourceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..MiscellaneousResourceOptions Property
BufferDescription Structure See Also Send Feedback
Miscellaneous flags (see MiscellaneousResourceOptions) or 0 if unused. Applications can logically OR flags together.

(Also see DirectX SDK: D3D10_BUFFER_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousResourceOptions MiscellaneousResourceOptions { get; set; }
Visual Basic
Public Property MiscellaneousResourceOptions As MiscellaneousResourceOptions
    Get
    Set
Visual C++
public:
property MiscellaneousResourceOptions MiscellaneousResourceOptions {
    MiscellaneousResourceOptions get ();
    void set (MiscellaneousResourceOptions value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
BufferDescription..::..MiscellaneousResourceOptions


Usage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..Usage Property
BufferDescription Structure See Also Send Feedback
Identify how the buffer is expected to be read from and written to. Frequency of update is a key factor. The most common value is typically Usage_DEFAULT; see Usage for all possible values.

(Also see DirectX SDK: D3D10_BUFFER_DESC.Usage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Usage Usage { get; set; }
Visual Basic
Public Property Usage As Usage
    Get
    Set
Visual C++
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Structure
Members See Also Send Feedback
Specifies the elements from a buffer resource to use in a render-target view.

(Also see DirectX SDK: D3D10_BUFFER_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BufferRenderTargetView
Visual Basic
Public Structure BufferRenderTargetView
Visual C++
public value class BufferRenderTargetView

See Also

BufferRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Members
BufferRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The BufferRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ElementOffset | The offset (that is, the number of elements) between the beginning of the buffer and the first element that is to be used in the view, starting at 0. (Also see DirectX SDK: D3D10_BUFFER_RTV.ElementOffset)
Public property | ElementWidth | The number of elements in the view. (Also see DirectX SDK: D3D10_BUFFER_RTV.ElementWidth)

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Methods
BufferRenderTargetView Structure See Also Send Feedback

The BufferRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..Equals Method
BufferRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..GetHashCode Method
BufferRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Operators
BufferRenderTargetView Structure See Also Send Feedback

The BufferRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..Equality Operator
BufferRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BufferRenderTargetView bufferRenderTargetView1,
    BufferRenderTargetView bufferRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    bufferRenderTargetView1 As BufferRenderTargetView, _
    bufferRenderTargetView2 As BufferRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    BufferRenderTargetView bufferRenderTargetView1,
    BufferRenderTargetView bufferRenderTargetView2
)

Parameters

bufferRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferRenderTargetView
bufferRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferRenderTargetView

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..Inequality Operator
BufferRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BufferRenderTargetView bufferRenderTargetView1,
    BufferRenderTargetView bufferRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    bufferRenderTargetView1 As BufferRenderTargetView, _
    bufferRenderTargetView2 As BufferRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    BufferRenderTargetView bufferRenderTargetView1,
    BufferRenderTargetView bufferRenderTargetView2
)

Parameters

bufferRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferRenderTargetView
bufferRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferRenderTargetView

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Properties
BufferRenderTargetView Structure See Also Send Feedback

The BufferRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | ElementOffset | The offset (that is, the number of elements) between the beginning of the buffer and the first element that is to be used in the view, starting at 0. (Also see DirectX SDK: D3D10_BUFFER_RTV.ElementOffset)
Public property | ElementWidth | The number of elements in the view. (Also see DirectX SDK: D3D10_BUFFER_RTV.ElementWidth)

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ElementOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..ElementOffset Property
BufferRenderTargetView Structure See Also Send Feedback
The offset (that is, the number of elements) between the beginning of the buffer and the first element that is to be used in the view, starting at 0.

(Also see DirectX SDK: D3D10_BUFFER_RTV.ElementOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementOffset { get; set; }
Visual Basic
Public Property ElementOffset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ElementWidth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..ElementWidth Property
BufferRenderTargetView Structure See Also Send Feedback
The number of elements in the view.

(Also see DirectX SDK: D3D10_BUFFER_RTV.ElementWidth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementWidth { get; set; }
Visual Basic
Public Property ElementWidth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementWidth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Structure
Members See Also Send Feedback
Specifies the elements in a buffer resource to use in a shader-resource view.

(Also see DirectX SDK: D3D10_BUFFER_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BufferShaderResourceView
Visual Basic
Public Structure BufferShaderResourceView
Visual C++
public value class BufferShaderResourceView

See Also

BufferShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Members
BufferShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The BufferShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ElementOffset | The offset of the first element in the view to access, relative to element 0. (Also see DirectX SDK: D3D10_BUFFER_SRV.ElementOffset)
Public property | ElementWidth | The total number of elements in the view. (Also see DirectX SDK: D3D10_BUFFER_SRV.ElementWidth)

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Methods
BufferShaderResourceView Structure See Also Send Feedback

The BufferShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..Equals Method
BufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..GetHashCode Method
BufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Operators
BufferShaderResourceView Structure See Also Send Feedback

The BufferShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..Equality Operator
BufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BufferShaderResourceView bufferShaderResourceView1,
    BufferShaderResourceView bufferShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    bufferShaderResourceView1 As BufferShaderResourceView, _
    bufferShaderResourceView2 As BufferShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    BufferShaderResourceView bufferShaderResourceView1,
    BufferShaderResourceView bufferShaderResourceView2
)

Parameters

bufferShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferShaderResourceView
bufferShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferShaderResourceView

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..Inequality Operator
BufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BufferShaderResourceView bufferShaderResourceView1,
    BufferShaderResourceView bufferShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    bufferShaderResourceView1 As BufferShaderResourceView, _
    bufferShaderResourceView2 As BufferShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    BufferShaderResourceView bufferShaderResourceView1,
    BufferShaderResourceView bufferShaderResourceView2
)

Parameters

bufferShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferShaderResourceView
bufferShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferShaderResourceView

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Properties
BufferShaderResourceView Structure See Also Send Feedback

The BufferShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | ElementOffset | The offset of the first element in the view to access, relative to element 0. (Also see DirectX SDK: D3D10_BUFFER_SRV.ElementOffset)
Public property | ElementWidth | The total number of elements in the view. (Also see DirectX SDK: D3D10_BUFFER_SRV.ElementWidth)

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ElementOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..ElementOffset Property
BufferShaderResourceView Structure See Also Send Feedback
The offset of the first element in the view to access, relative to element 0.

(Also see DirectX SDK: D3D10_BUFFER_SRV.ElementOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementOffset { get; set; }
Visual Basic
Public Property ElementOffset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ElementWidth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..ElementWidth Property
BufferShaderResourceView Structure See Also Send Feedback
The total number of elements in the view.

(Also see DirectX SDK: D3D10_BUFFER_SRV.ElementWidth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementWidth { get; set; }
Visual Basic
Public Property ElementWidth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementWidth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ClearOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClearOptions Enumeration
See Also Send Feedback
Specifies the parts of the depth stencil to clear. Usually used with Device.ClearDepthStencilView.

(Also see DirectX SDK: D3D10_CLEAR_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ClearOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration ClearOptions
Visual C++
[FlagsAttribute]
public enum class ClearOptions

Members

Member name | Description
Depth |
None |
Stencil |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ColorWriteEnableComponents Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorWriteEnableComponents Enumeration
See Also Send Feedback
Identify which components of each pixel of a render target are writable during blending.

(Also see DirectX SDK: D3D10_COLOR_WRITE_ENABLE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ColorWriteEnableComponents
Visual Basic
<FlagsAttribute> _
Public Enumeration ColorWriteEnableComponents
Visual C++
[FlagsAttribute]
public enum class ColorWriteEnableComponents

Members

Member name | Description
None |
All |
Alpha |
Blue |
Green |
Red |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ComparisonFunction Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComparisonFunction Enumeration
See Also Send Feedback
Comparison options.

(Also see DirectX SDK: D3D10_COMPARISON_FUNC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ComparisonFunction
Visual Basic
Public Enumeration ComparisonFunction
Visual C++
public enum class ComparisonFunction

Members

Member name | Description
Always |
GreaterEqual |
NotEqual |
Greater |
LessEqual |
Equal |
Less |
Never |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ConstantBufferType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ConstantBufferType Enumeration
See Also Send Feedback
These flags identify constant-buffer-data types.

(Also see DirectX SDK: D3D10_CBUFFER_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ConstantBufferType
Visual Basic
Public Enumeration ConstantBufferType
Visual C++
public enum class ConstantBufferType

Members

Member name | Description
ConstantBuffer |
TextureBuffer |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Counter Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Counter Enumeration
See Also Send Feedback
Performance counter types.

(Also see DirectX SDK: D3D10_COUNTER)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Counter
Visual Basic
Public Enumeration Counter
Visual C++
public enum class Counter

Members

Member name | Description
DeviceDependent0 |
TextureCacheHitRate |
PostTransformCacheHitRate |
PixelShaderComputationLimited |
PixelShaderMemoryLimited |
GeometryShaderComputationLimited |
GeometryShaderMemoryLimited |
VertexShaderComputationLimited |
VertexShaderMemoryLimited |
FillRateThroughputUtilization |
TriangleSetupThroughputUtilization |
VertexThroughputUtilization |
LocalVidmemBandwidthUtilization |
HostAdapterBandwidthUtilization |
OtherGpuProcessing |
PixelProcessing |
GeometryProcessing |
VertexProcessing |
GpuIdle |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterData Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData Class
Members See Also Send Feedback
This class encapsulates the data returned by the D3DDevice.CheckCounter method.

(Also see DirectX SDK: ID3D10Device.CheckCounter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class CounterData
Visual Basic
Public Class CounterData
Visual C++
public ref class CounterData

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterData

See Also

CounterData Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterData Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData Members
CounterData Class Properties See Also Send Feedback

The CounterData type exposes the following members.

Properties

 | Name | Description
Public property | ActiveCounterCount |
Public property | CounterType |
Public property | Description |
Public property | Name |
Public property | Units |

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterData Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData Properties
CounterData Class See Also Send Feedback

The CounterData type exposes the following members.

Properties

 | Name | Description
Public property | ActiveCounterCount |
Public property | CounterType |
Public property | Description |
Public property | Name |
Public property | Units |

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ActiveCounterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..ActiveCounterCount Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int ActiveCounterCount { get; }
Visual Basic
Public ReadOnly Property ActiveCounterCount As Integer
    Get
Visual C++
public:
property int ActiveCounterCount {
    int get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..CounterType Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CounterType CounterType { get; }
Visual Basic
Public ReadOnly Property CounterType As CounterType
    Get
Visual C++
public:
property CounterType CounterType {
    CounterType get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..Description Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Name Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..Name Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Units Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..Units Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Units { get; }
Visual Basic
Public ReadOnly Property Units As String
    Get
Visual C++
public:
property String^ Units {
    String^ get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Structure
Members See Also Send Feedback
Describes a counter.

(Also see DirectX SDK: D3D10_COUNTER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct CounterDescription
Visual Basic
Public Structure CounterDescription
Visual C++
public value class CounterDescription

See Also

CounterDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Members
CounterDescription Structure Methods Operators Properties See Also Send Feedback

The CounterDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Counter | Type of counter (see Counter). (Also see DirectX SDK: D3D10_COUNTER_DESC.Counter)
Public property | ReservedOptions | Reserved. (Also see DirectX SDK: D3D10_COUNTER_DESC.MiscFlags)

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Methods
CounterDescription Structure See Also Send Feedback

The CounterDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..Equals Method
CounterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..GetHashCode Method
CounterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Operators
CounterDescription Structure See Also Send Feedback

The CounterDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..Equality Operator
CounterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    CounterDescription counterDescription1,
    CounterDescription counterDescription2
)
Visual Basic
Public Shared Operator = ( _
    counterDescription1 As CounterDescription, _
    counterDescription2 As CounterDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    CounterDescription counterDescription1,
    CounterDescription counterDescription2
)

Parameters

counterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterDescription
counterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterDescription

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..Inequality Operator
CounterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    CounterDescription counterDescription1,
    CounterDescription counterDescription2
)
Visual Basic
Public Shared Operator <> ( _
    counterDescription1 As CounterDescription, _
    counterDescription2 As CounterDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    CounterDescription counterDescription1,
    CounterDescription counterDescription2
)

Parameters

counterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterDescription
counterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterDescription

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Properties
CounterDescription Structure See Also Send Feedback

The CounterDescription type exposes the following members.

Properties

 | Name | Description
Public property | Counter | Type of counter (see Counter). (Also see DirectX SDK: D3D10_COUNTER_DESC.Counter)
Public property | ReservedOptions | Reserved. (Also see DirectX SDK: D3D10_COUNTER_DESC.MiscFlags)

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Counter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..Counter Property
CounterDescription Structure See Also Send Feedback
Type of counter (see Counter).

(Also see DirectX SDK: D3D10_COUNTER_DESC.Counter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Counter Counter { get; set; }
Visual Basic
Public Property Counter As Counter
    Get
    Set
Visual C++
public:
property Counter Counter {
    Counter get ();
    void set (Counter value);
}

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
CounterDescription..::..Counter


ReservedOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..ReservedOptions Property
CounterDescription Structure See Also Send Feedback
Reserved.

(Also see DirectX SDK: D3D10_COUNTER_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ReservedOptions { get; set; }
Visual Basic
Public Property ReservedOptions As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ReservedOptions {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterInformation Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Structure
Members See Also Send Feedback
Information about the video card's performance counter capabilities.

(Also see DirectX SDK: D3D10_COUNTER_INFO)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct CounterInformation
Visual Basic
Public Structure CounterInformation
Visual C++
public value class CounterInformation

See Also

CounterInformation Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterInformation Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Members
CounterInformation Structure Methods Operators Properties See Also Send Feedback

The CounterInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | DetectableParallelUnitCount | Number of detectable parallel units that the counter is able to discern. Values are 1 ~ 4. Use DetectableParallelUnitCount to interpret the values of the VERTEX_PROCESSING, GEOMETRY_PROCESSING, PIXEL_PROCESSING, and OTHER_GPU_PROCESSING counters. See Asynchronous.GetData for an equation. (Also see DirectX SDK: D3D10_COUNTER_INFO.NumDetectableParallelUnits)
Public property | LastDeviceDependentCounter | Largest device-dependent counter ID that the device supports. If none are supported, this value will be 0. Otherwise it will be greater than or equal to DeviceDependent0. See Counter. (Also see DirectX SDK: D3D10_COUNTER_INFO.LastDeviceDependentCounter)
Public property | SimultaneousCounterCount | Number of counters that can be simultaneously supported. (Also see DirectX SDK: D3D10_COUNTER_INFO.NumSimultaneousCounters)

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterInformation Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Methods
CounterInformation Structure See Also Send Feedback

The CounterInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..Equals Method
CounterInformation Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..GetHashCode Method
CounterInformation Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterInformation Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Operators
CounterInformation Structure See Also Send Feedback

The CounterInformation type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..Equality Operator
CounterInformation Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    CounterInformation counterInformation1,
    CounterInformation counterInformation2
)
Visual Basic
Public Shared Operator = ( _
    counterInformation1 As CounterInformation, _
    counterInformation2 As CounterInformation _
) As Boolean
Visual C++
public:
static bool operator ==(
    CounterInformation counterInformation1,
    CounterInformation counterInformation2
)

Parameters

counterInformation1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterInformation
counterInformation2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterInformation

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..Inequality Operator
CounterInformation Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    CounterInformation counterInformation1,
    CounterInformation counterInformation2
)
Visual Basic
Public Shared Operator <> ( _
    counterInformation1 As CounterInformation, _
    counterInformation2 As CounterInformation _
) As Boolean
Visual C++
public:
static bool operator !=(
    CounterInformation counterInformation1,
    CounterInformation counterInformation2
)

Parameters

counterInformation1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterInformation
counterInformation2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterInformation

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterInformation Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Properties
CounterInformation Structure See Also Send Feedback

The CounterInformation type exposes the following members.

Properties

 | Name | Description
Public property | DetectableParallelUnitCount | Number of detectable parallel units that the counter is able to discern. Values are 1 ~ 4. Use DetectableParallelUnitCount to interpret the values of the VERTEX_PROCESSING, GEOMETRY_PROCESSING, PIXEL_PROCESSING, and OTHER_GPU_PROCESSING counters. See Asynchronous.GetData for an equation. (Also see DirectX SDK: D3D10_COUNTER_INFO.NumDetectableParallelUnits)
Public property | LastDeviceDependentCounter | Largest device-dependent counter ID that the device supports. If none are supported, this value will be 0. Otherwise it will be greater than or equal to DeviceDependent0. See Counter. (Also see DirectX SDK: D3D10_COUNTER_INFO.LastDeviceDependentCounter)
Public property | SimultaneousCounterCount | Number of counters that can be simultaneously supported. (Also see DirectX SDK: D3D10_COUNTER_INFO.NumSimultaneousCounters)

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DetectableParallelUnitCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..DetectableParallelUnitCount Property
CounterInformation Structure See Also Send Feedback
Number of detectable parallel units that the counter is able to discern. Values are 1 ~ 4. Use DetectableParallelUnitCount to interpret the values of the VERTEX_PROCESSING, GEOMETRY_PROCESSING, PIXEL_PROCESSING, and OTHER_GPU_PROCESSING counters. See Asynchronous.GetData for an equation.

(Also see DirectX SDK: D3D10_COUNTER_INFO.NumDetectableParallelUnits)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte DetectableParallelUnitCount { get; set; }
Visual Basic
Public Property DetectableParallelUnitCount As Byte
    Get
    Set
Visual C++
public:
property unsigned char DetectableParallelUnitCount {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


LastDeviceDependentCounter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..LastDeviceDependentCounter Property
CounterInformation Structure See Also Send Feedback
Largest device-dependent counter ID that the device supports. If none are supported, this value will be 0. Otherwise it will be greater than or equal to DeviceDependent0. See Counter.

(Also see DirectX SDK: D3D10_COUNTER_INFO.LastDeviceDependentCounter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Counter LastDeviceDependentCounter { get; set; }
Visual Basic
Public Property LastDeviceDependentCounter As Counter
    Get
    Set
Visual C++
public:
property Counter LastDeviceDependentCounter {
    Counter get ();
    void set (Counter value);
}

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SimultaneousCounterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..SimultaneousCounterCount Property
CounterInformation Structure See Also Send Feedback
Number of counters that can be simultaneously supported.

(Also see DirectX SDK: D3D10_COUNTER_INFO.NumSimultaneousCounters)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SimultaneousCounterCount { get; set; }
Visual Basic
Public Property SimultaneousCounterCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SimultaneousCounterCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterType Enumeration
See Also Send Feedback
Data type of a performance counter.

(Also see DirectX SDK: D3D10_COUNTER_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum CounterType
Visual Basic
Public Enumeration CounterType
Visual C++
public enum class CounterType

Members

Member name | Description
Float32 |
UInt64 |
UInt32 |
UInt16 |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CpuAccessOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CpuAccessOptions Enumeration
See Also Send Feedback
Specifies the types of CPU access allowed for a resource.

(Also see DirectX SDK: D3D10_CPU_ACCESS_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum CpuAccessOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration CpuAccessOptions
Visual C++
[FlagsAttribute]
public enum class CpuAccessOptions

Members

Member name | Description
None |
Read |
Write |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDeviceOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CreateDeviceOptions Enumeration
See Also Send Feedback
Device creation flags.

(Also see DirectX SDK: D3D10_CREATE_DEVICE_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum CreateDeviceOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration CreateDeviceOptions
Visual C++
[FlagsAttribute]
public enum class CreateDeviceOptions

Members

Member name | Description
SupportBgra |
PreventInternalThreadingOptimizations |
SwitchToRef |
SingleThreaded |
None |
AllowNullFromMap |
Debug |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CullMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CullMode Enumeration
See Also Send Feedback
Indicates triangles facing a particular direction are not drawn.

(Also see DirectX SDK: D3D10_CULL_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum CullMode
Visual Basic
Public Enumeration CullMode
Visual C++
public enum class CullMode

Members

Member name | Description
Back |
Front |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DBuffer Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer Class
Members See Also Send Feedback
A buffer interface accesses a buffer resource, which is unstructured memory. Buffers typically store vertex or index data.

(Also see DirectX SDK: ID3D10Buffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DBuffer : D3DResource
Visual Basic
Public Class D3DBuffer _
    Inherits D3DResource
Visual C++
public ref class D3DBuffer : public D3DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DBuffer

See Also

D3DBuffer Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DBuffer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer Members
D3DBuffer Class Methods Properties See Also Send Feedback

The D3DBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Map | Get the data contained in the resource and deny GPU access to the resource. (Also see DirectX SDK: ID3D10Buffer::Map)
Public method | Unmap | Invalidate the pointer to the resource retrieved by D3DBuffer.Map and reenable GPU access to the resource. (Also see DirectX SDK: ID3D10Buffer::Unmap)

Properties

 | Name | Description
Public property | Description | Get the properties of a buffer resource. (Also see DirectX SDK: ID3D10Buffer::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType) (Inherited from D3DResource.)

See Also

D3DBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DBuffer Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer Methods
D3DBuffer Class See Also Send Feedback

The D3DBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Map | Get the data contained in the resource and deny GPU access to the resource. (Also see DirectX SDK: ID3D10Buffer::Map)
Public method | Unmap | Invalidate the pointer to the resource retrieved by D3DBuffer.Map and reenable GPU access to the resource. (Also see DirectX SDK: ID3D10Buffer::Unmap)

See Also

D3DBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Map Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer..::..Map Method
D3DBuffer Class See Also Send Feedback
Get the data contained in the resource and deny GPU access to the resource.

(Also see DirectX SDK: ID3D10Buffer::Map)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr Map(
    Map type,
    MapOptions options
)
Visual Basic
Public Function Map ( _
    type As Map, _
    options As MapOptions _
) As IntPtr
Visual C++
public:
IntPtr Map(
    Map type,
    MapOptions options
)

Parameters

type
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Map
Flag that specifies the CPU's permissions for the reading and writing of a resource. For possible values, see Map.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MapOptions
Flag that specifies what the CPU should do when the GPU is busy (see MapOptions). This flag is optional.

Return Value

Pointer to the buffer resource data.

See Also

D3DBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MapOptions


Unmap Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer..::..Unmap Method
D3DBuffer Class See Also Send Feedback
Invalidate the pointer to the resource retrieved by D3DBuffer.Map and reenable GPU access to the resource.

(Also see DirectX SDK: ID3D10Buffer::Unmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Unmap()
Visual Basic
Public Sub Unmap
Visual C++
public:
void Unmap()

See Also

D3DBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DBuffer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer Properties
D3DBuffer Class See Also Send Feedback

The D3DBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a buffer resource. (Also see DirectX SDK: ID3D10Buffer::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType) (Inherited from D3DResource.)

See Also

D3DBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer..::..Description Property
D3DBuffer Class See Also Send Feedback
Get the properties of a buffer resource.

(Also see DirectX SDK: ID3D10Buffer::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BufferDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As BufferDescription
    Get
Visual C++
public:
property BufferDescription Description {
    BufferDescription get ();
}

See Also

D3DBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DCounter Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DCounter Class
Members See Also Send Feedback
This class encapsulates methods for measuring GPU performance.

(Also see DirectX SDK: ID3D10Counter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DCounter : Asynchronous
Visual Basic
Public Class D3DCounter _
    Inherits Asynchronous
Visual C++
public ref class D3DCounter : public Asynchronous

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DCounter

See Also

D3DCounter Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DCounter Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DCounter Members
D3DCounter Class Methods Properties See Also Send Feedback

The D3DCounter type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Starts the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::Begin) (Inherited from Asynchronous.)
Public method | End | Ends the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::End) (Inherited from Asynchronous.)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D10Asynchronous::GetData) (Inherited from Asynchronous.)

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling Asynchronous.GetData. (Also see DirectX SDK: ID3D10Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a counter description. (Also see DirectX SDK: ID3D10Counter::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D3DCounter Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DCounter Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DCounter Methods
D3DCounter Class See Also Send Feedback

The D3DCounter type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Starts the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::Begin) (Inherited from Asynchronous.)
Public method | End | Ends the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::End) (Inherited from Asynchronous.)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D10Asynchronous::GetData) (Inherited from Asynchronous.)

See Also

D3DCounter Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DCounter Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DCounter Properties
D3DCounter Class See Also Send Feedback

The D3DCounter type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling Asynchronous.GetData. (Also see DirectX SDK: ID3D10Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a counter description. (Also see DirectX SDK: ID3D10Counter::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D3DCounter Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DCounter..::..Description Property
D3DCounter Class See Also Send Feedback
Get a counter description.

(Also see DirectX SDK: ID3D10Counter::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CounterDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As CounterDescription
    Get
Visual C++
public:
property CounterDescription Description {
    CounterDescription get ();
}

See Also

D3DCounter Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDebug Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug Class
Members See Also Send Feedback
A debug interface controls debug settings, validates pipeline state and can only be used if the debug layer is turned on.

(Also see DirectX SDK: ID3D10Debug)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DDebug : DirectUnknown
Visual Basic
Public Class D3DDebug _
    Inherits DirectUnknown
Visual C++
public ref class D3DDebug : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDebug

See Also

D3DDebug Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDebug Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug Members
D3DDebug Class Methods Properties See Also Send Feedback

The D3DDebug type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Check the validity of pipeline state. (Also see DirectX SDK: ID3D10Debug::Validate)

Properties

 | Name | Description
Public property | FeatureMask | Gets or sets a bitfield of flags that indicates which debug features are on or off. (Also see DirectX SDK: ID3D10Debug::GetFeatureMask)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PresentPerRenderOperationDelay | Gets or sets the number of milliseconds to sleep after SwapChain.Present is called. (Also see DirectX SDK: ID3D10Debug::GetPresentPerRenderOpDelay)
Public property | RuntimeSwapChain | Get the swap chain that the runtime will use for automatically calling SwapChain.Present. (Also see DirectX SDK: ID3D10Debug::GetSwapChain)

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDebug Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug Methods
D3DDebug Class See Also Send Feedback

The D3DDebug type exposes the following members.

Methods

 | Name | Description
Public method | Validate | Check the validity of pipeline state. (Also see DirectX SDK: ID3D10Debug::Validate)

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Validate Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug..::..Validate Method
D3DDebug Class See Also Send Feedback
Check the validity of pipeline state.

(Also see DirectX SDK: ID3D10Debug::Validate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Validate()
Visual Basic
Public Sub Validate
Visual C++
public:
void Validate()

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDebug Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug Properties
D3DDebug Class See Also Send Feedback

The D3DDebug type exposes the following members.

Properties

 | Name | Description
Public property | FeatureMask | Gets or sets a bitfield of flags that indicates which debug features are on or off. (Also see DirectX SDK: ID3D10Debug::GetFeatureMask)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PresentPerRenderOperationDelay | Gets or sets the number of milliseconds to sleep after SwapChain.Present is called. (Also see DirectX SDK: ID3D10Debug::GetPresentPerRenderOpDelay)
Public property | RuntimeSwapChain | Get the swap chain that the runtime will use for automatically calling SwapChain.Present. (Also see DirectX SDK: ID3D10Debug::GetSwapChain)

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FeatureMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug..::..FeatureMask Property
D3DDebug Class See Also Send Feedback
Gets or sets a bitfield of flags that indicates which debug features are on or off.

(Also see DirectX SDK: ID3D10Debug::GetFeatureMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DebugFeatures FeatureMask { get; set; }
Visual Basic
Public Property FeatureMask As DebugFeatures
    Get
    Set
Visual C++
public:
property DebugFeatures FeatureMask {
    DebugFeatures get ();
    void set (DebugFeatures value);
}

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PresentPerRenderOperationDelay Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug..::..PresentPerRenderOperationDelay Property
D3DDebug Class See Also Send Feedback
Gets or sets the number of milliseconds to sleep after SwapChain.Present is called.

(Also see DirectX SDK: ID3D10Debug::GetPresentPerRenderOpDelay)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint PresentPerRenderOperationDelay { get; set; }
Visual Basic
Public Property PresentPerRenderOperationDelay As UInteger
    Get
    Set
Visual C++
public:
property unsigned int PresentPerRenderOperationDelay {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RuntimeSwapChain Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug..::..RuntimeSwapChain Property
D3DDebug Class See Also Send Feedback
Get the swap chain that the runtime will use for automatically calling SwapChain.Present.

(Also see DirectX SDK: ID3D10Debug::GetSwapChain)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwapChain RuntimeSwapChain { get; set; }
Visual Basic
Public Property RuntimeSwapChain As SwapChain
    Get
    Set
Visual C++
public:
property SwapChain^ RuntimeSwapChain {
    SwapChain^ get ();
    void set (SwapChain^ value);
}

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDevice Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice Class
Members See Also Send Feedback
The device interface represents a virtual adapter for Direct3D 10.0; it is used to perform rendering and create Direct3D resources.

To create a D3DDevice instance, use one of the static factory method overloads: CreateDevice() or CreateDeviceAndSwapChain().

(Also see DirectX SDK: ID3D10Device)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DDevice : DirectUnknown
Visual Basic
Public Class D3DDevice _
    Inherits DirectUnknown
Visual C++
public ref class D3DDevice : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDevice
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDevice1

See Also

D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDevice Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice Members
D3DDevice Class Methods Properties See Also Send Feedback

The D3DDevice type exposes the following members.

Methods

 | Name | Description
Public method | ClearDepthStencilView | Clears the depth-stencil resource. (Also see DirectX SDK: ID3D10Device::ClearDepthStencilView)
Public method | ClearRenderTargetView | Set all the elements in a render target to one value. (Also see DirectX SDK: ID3D10DeviceContext::ClearRenderTargetView)
Public method | ClearState | Restore all default device settings; return the device to the state it was in when it was created. This will set all set all input/output resource slots, shaders, input layouts, predications, scissor rectangles, depth-stencil state, rasterizer state, blend state, sampler state, and viewports to NULL. The primitive topology will be set to UNDEFINED. (Also see DirectX SDK: ID3D10Device::ClearState)
Public method | CopyResource | Copy the entire contents of the source resource to the destination resource using the GPU. (Also see DirectX SDK: ID3D10Device::CopyResource)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32) | Copy a region from a source resource to a destination resource. The entire source subresource is copied. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box) | Copy a region from a source resource to a destination resource. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion)
Public method | CreateBlendState | Create a blend-state object that encapsules blend state for the output-merger stage. (Also see DirectX SDK: ID3D10Device::CreateBlendState)
Public method | CreateBuffer(BufferDescription) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer) with no initial data. (Also see DirectX SDK: ID3D10Device::CreateBuffer)
Public method | CreateBuffer(BufferDescription, array<SubresourceData>[]()[][]) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). (Also see DirectX SDK: ID3D10Device::CreateBuffer)
Public method | CreateCounter | Create a counter object for measuring GPU performance. (Also see DirectX SDK: ID3D10Device::CreateCounter)
Public method | CreateDepthStencilState | Create a depth-stencil state object that encapsulates depth-stencil test information for the output-merger stage. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilState)
Public method | CreateDepthStencilView(D3DResource) | Create a depth-stencil view for accessing resource data. This method creates a view that accesses mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView)
Public method | CreateDepthStencilView(D3DResource, DepthStencilViewDescription) | Create a depth-stencil view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView)
 | CreateDevice()()()() | Create a Direct3D 10.0 device using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDevice() function)
 | CreateDevice(Adapter, DriverType, String, CreateDeviceOptions) | Create a Direct3D 10.0 device. (Also see DirectX SDK: D3D10CreateDevice() function)
 | CreateDeviceAndSwapChain(IntPtr) | Create a Direct3D 10.0 device and a swap chain using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain() function)
 | CreateDeviceAndSwapChain(Adapter, DriverType, String, CreateDeviceOptions, SwapChainDescription) | Create a Direct3D 10.0 device and a swap chain. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain() function)
Public method | CreateEffectFromCompiledBinary(BinaryReader) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function)
Public method | CreateEffectFromCompiledBinary(Stream) | Loads a precompiled effect from a binary data stream.
Public method | CreateEffectFromCompiledBinary(String) | Loads a precompiled effect from a file. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function)
Public method | CreateEffectFromCompiledBinary(BinaryReader, Int32, EffectPool) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function)
Public method | CreateEffectFromCompiledBinary(Stream, Int32, EffectPool) | Loads a precompiled effect from a binary data stream.
Public method | CreateGeometryShader(Stream) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader)
Public method | CreateGeometryShader(IntPtr, UInt32) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader)
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) |
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) |
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), Stream) |
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), IntPtr, UInt32) |
Public method | CreatePixelShader(Stream) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader)
Public method | CreatePixelShader(IntPtr, UInt32) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader)
Public method | CreatePredicate | Creates a predicate. (Also see DirectX SDK: ID3D10Device::CreatePredicate)
Public method | CreateQuery | This class encapsulates methods for querying information from the GPU. (Also see DirectX SDK: ID3D10Device::CreateQuery)
Public method | CreateRasterizerState | Create a rasterizer state object that tells the rasterizer stage how to behave. (Also see DirectX SDK: ID3D10Device::CreateRasterizerState)
Public method | CreateRenderTargetView(D3DResource) | Create a render-target view for accessing resource data in mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView)
Public method | CreateRenderTargetView(D3DResource, RenderTargetViewDescription) | Create a render-target view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView)
Public method | CreateSamplerState | Create a sampler-state object that encapsulates sampling information for a texture. (Also see DirectX SDK: ID3D10Device::CreateSamplerState)
Public method | CreateShaderResourceView(D3DResource) | Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView)
Public method | CreateShaderResourceView(D3DResource, ShaderResourceViewDescription) | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView)
Public method | CreateStateBlock | Create a state block.
Public method | CreateTexture1D(Texture1DDescription) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D)
Public method | CreateTexture1D(Texture1DDescription, array<SubresourceData>[]()[][]) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D)
Public method | CreateTexture2D(Texture2DDescription) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D)
Public method | CreateTexture2D(Texture2DDescription, array<SubresourceData>[]()[][]) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D)
Public method | CreateTexture3D(Texture3DDescription) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D)
Public method | CreateTexture3D(Texture3DDescription, array<SubresourceData>[]()[][]) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D)
Public method | CreateVertexShader(Stream) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader)
Public method | CreateVertexShader(IntPtr, UInt32) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader)
Public method | Draw | Draw non-indexed, non-instanced primitives. (Also see DirectX SDK: ID3D10Device::Draw)
Public method | DrawAuto | Draw geometry of an unknown size that was created by the geometry shader stage. (Also see DirectX SDK: ID3D10Device::DrawAuto)
Public method | DrawIndexed | Draw indexed, non-instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawIndexed)
Public method | DrawIndexedInstanced | Draw indexed, instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawIndexedInstanced)
Public method | DrawInstanced | Draw non-indexed, instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawInstanced)
Public method | Flush | Send queued-up commands in the command buffer to the GPU. (Also see DirectX SDK: ID3D10Device::Flush)
Public method | GenerateMips | Generate mipmaps for the given shader resource. (Also see DirectX SDK: ID3D10Device::GenerateMips)
Public method | GetCounterData | Get the type, name, units of measure, and a description of an existing counter. (Also see DirectX SDK: ID3D10Device::CheckCounter)
Public method | GetFormatSupport | Get the support of a given format on the installed video device. (Also see DirectX SDK: ID3D10Device::CheckFormatSupport)
Public method | GetMultisampleQualityLevels | Get the number of quality levels available during multisampling. (Also see DirectX SDK: ID3D10Device::CheckMultisampleQualityLevels)
Public method | OpenSharedResource<(Of <<'(T>)>>) | Give a device access to a shared resource created on a different device. (Also see DirectX SDK: ID3D10Device::OpenSharedResource)
Public method | ResolveSubresource | Copy a multisampled resource into a non-multisampled resource. This API is most useful when re-using the resulting rendertarget of one render pass as an input to a second render pass. (Also see DirectX SDK: ID3D10Device::ResolveSubresource)
Public method | SetPredication | Set a rendering predicate. (Also see DirectX SDK: ID3D10Device::SetPredication)
Protected method | SetSwapChain |
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32) | The CPU copies data from memory to a subresource created in non-mappable memory. Because no destination box is defined, the data is written to the destination subresource with no offset. (Also see DirectX SDK: ID3D10Device::UpdateSubresource)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32, Box) | The CPU copies data from memory to a subresource created in non-mappable memory. (Also see DirectX SDK: ID3D10Device::UpdateSubresource)

Properties

 | Name | Description
Public property | CounterInformation | Gets information about the device's performance counter capabilities (Also see DirectX SDK: ID3D10Device::CheckCounterInfo)
Public property | CreateDeviceOptions | Get the flags used during the call to create the device. (Also see DirectX SDK: ID3D10Device::GetCreationFlags)
Public property | Debug |
Public property | DeviceRemovedReason | Get the reason why the device was removed. (Also see DirectX SDK: ID3D10Device::GetDeviceRemovedReason)
Public property | ExceptionMode | Gets or sets the exception-mode flags. (Also see DirectX SDK: ID3D10Device::GetExceptionMode, ID3D10Device::SetExceptionMode)
Public property | GraphicsDevice | Gets the Graphics Device object for this device
Public property | GraphicsDevice1 |
Public property | GS | Get the associated geometry shader pipeline stage object.
Public property | IA | Get the associated input assembler pipeline stage object.
Public property | InfoQueue | Gets an information queue object that can retrieve, store and filter debug messages.
Public property | Multithread |
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | OM | Get the associated output merger pipeline stage object.
Public property | Predication | Get the rendering predicate state. (Also see DirectX SDK: ID3D10Device::GetPredication)
Public property | PS | Get the associated pixel shader pipeline stage object.
Public property | RS | Get the associated rasterizer pipeline stage object.
Public property | SO | Get the associated stream output pipeline stage object.
Public property | SwapChain |
Public property | SwitchToRef | Gets a switch-to-reference object that enables an application to switch between a hardware and software device.
Public property | VS | Get the associated vertex shader pipeline stage object.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDevice Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice Methods
D3DDevice Class See Also Send Feedback

The D3DDevice type exposes the following members.

Methods

 | Name | Description
Public method | ClearDepthStencilView | Clears the depth-stencil resource. (Also see DirectX SDK: ID3D10Device::ClearDepthStencilView)
Public method | ClearRenderTargetView | Set all the elements in a render target to one value. (Also see DirectX SDK: ID3D10DeviceContext::ClearRenderTargetView)
Public method | ClearState | Restore all default device settings; return the device to the state it was in when it was created. This will set all set all input/output resource slots, shaders, input layouts, predications, scissor rectangles, depth-stencil state, rasterizer state, blend state, sampler state, and viewports to NULL. The primitive topology will be set to UNDEFINED. (Also see DirectX SDK: ID3D10Device::ClearState)
Public method | CopyResource | Copy the entire contents of the source resource to the destination resource using the GPU. (Also see DirectX SDK: ID3D10Device::CopyResource)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32) | Copy a region from a source resource to a destination resource. The entire source subresource is copied. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box) | Copy a region from a source resource to a destination resource. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion)
Public method | CreateBlendState | Create a blend-state object that encapsules blend state for the output-merger stage. (Also see DirectX SDK: ID3D10Device::CreateBlendState)
Public method | CreateBuffer(BufferDescription) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer) with no initial data. (Also see DirectX SDK: ID3D10Device::CreateBuffer)
Public method | CreateBuffer(BufferDescription, array<SubresourceData>[]()[][]) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). (Also see DirectX SDK: ID3D10Device::CreateBuffer)
Public method | CreateCounter | Create a counter object for measuring GPU performance. (Also see DirectX SDK: ID3D10Device::CreateCounter)
Public method | CreateDepthStencilState | Create a depth-stencil state object that encapsulates depth-stencil test information for the output-merger stage. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilState)
Public method | CreateDepthStencilView(D3DResource) | Create a depth-stencil view for accessing resource data. This method creates a view that accesses mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView)
Public method | CreateDepthStencilView(D3DResource, DepthStencilViewDescription) | Create a depth-stencil view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView)
 | CreateDevice()()()() | Create a Direct3D 10.0 device using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDevice() function)
 | CreateDevice(Adapter, DriverType, String, CreateDeviceOptions) | Create a Direct3D 10.0 device. (Also see DirectX SDK: D3D10CreateDevice() function)
 | CreateDeviceAndSwapChain(IntPtr) | Create a Direct3D 10.0 device and a swap chain using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain() function)
 | CreateDeviceAndSwapChain(Adapter, DriverType, String, CreateDeviceOptions, SwapChainDescription) | Create a Direct3D 10.0 device and a swap chain. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain() function)
Public method | CreateEffectFromCompiledBinary(BinaryReader) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function)
Public method | CreateEffectFromCompiledBinary(Stream) | Loads a precompiled effect from a binary data stream.
Public method | CreateEffectFromCompiledBinary(String) | Loads a precompiled effect from a file. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function)
Public method | CreateEffectFromCompiledBinary(BinaryReader, Int32, EffectPool) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function)
Public method | CreateEffectFromCompiledBinary(Stream, Int32, EffectPool) | Loads a precompiled effect from a binary data stream.
Public method | CreateGeometryShader(Stream) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader)
Public method | CreateGeometryShader(IntPtr, UInt32) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader)
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) |
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) |
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), Stream) |
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), IntPtr, UInt32) |
Public method | CreatePixelShader(Stream) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader)
Public method | CreatePixelShader(IntPtr, UInt32) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader)
Public method | CreatePredicate | Creates a predicate. (Also see DirectX SDK: ID3D10Device::CreatePredicate)
Public method | CreateQuery | This class encapsulates methods for querying information from the GPU. (Also see DirectX SDK: ID3D10Device::CreateQuery)
Public method | CreateRasterizerState | Create a rasterizer state object that tells the rasterizer stage how to behave. (Also see DirectX SDK: ID3D10Device::CreateRasterizerState)
Public method | CreateRenderTargetView(D3DResource) | Create a render-target view for accessing resource data in mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView)
Public method | CreateRenderTargetView(D3DResource, RenderTargetViewDescription) | Create a render-target view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView)
Public method | CreateSamplerState | Create a sampler-state object that encapsulates sampling information for a texture. (Also see DirectX SDK: ID3D10Device::CreateSamplerState)
Public method | CreateShaderResourceView(D3DResource) | Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView)
Public method | CreateShaderResourceView(D3DResource, ShaderResourceViewDescription) | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView)
Public method | CreateStateBlock | Create a state block.
Public method | CreateTexture1D(Texture1DDescription) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D)
Public method | CreateTexture1D(Texture1DDescription, array<SubresourceData>[]()[][]) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D)
Public method | CreateTexture2D(Texture2DDescription) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D)
Public method | CreateTexture2D(Texture2DDescription, array<SubresourceData>[]()[][]) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D)
Public method | CreateTexture3D(Texture3DDescription) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D)
Public method | CreateTexture3D(Texture3DDescription, array<SubresourceData>[]()[][]) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D)
Public method | CreateVertexShader(Stream) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader)
Public method | CreateVertexShader(IntPtr, UInt32) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader)
Public method | Draw | Draw non-indexed, non-instanced primitives. (Also see DirectX SDK: ID3D10Device::Draw)
Public method | DrawAuto | Draw geometry of an unknown size that was created by the geometry shader stage. (Also see DirectX SDK: ID3D10Device::DrawAuto)
Public method | DrawIndexed | Draw indexed, non-instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawIndexed)
Public method | DrawIndexedInstanced | Draw indexed, instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawIndexedInstanced)
Public method | DrawInstanced | Draw non-indexed, instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawInstanced)
Public method | Flush | Send queued-up commands in the command buffer to the GPU. (Also see DirectX SDK: ID3D10Device::Flush)
Public method | GenerateMips | Generate mipmaps for the given shader resource. (Also see DirectX SDK: ID3D10Device::GenerateMips)
Public method | GetCounterData | Get the type, name, units of measure, and a description of an existing counter. (Also see DirectX SDK: ID3D10Device::CheckCounter)
Public method | GetFormatSupport | Get the support of a given format on the installed video device. (Also see DirectX SDK: ID3D10Device::CheckFormatSupport)
Public method | GetMultisampleQualityLevels | Get the number of quality levels available during multisampling. (Also see DirectX SDK: ID3D10Device::CheckMultisampleQualityLevels)
Public method | OpenSharedResource<(Of <<'(T>)>>) | Give a device access to a shared resource created on a different device. (Also see DirectX SDK: ID3D10Device::OpenSharedResource)
Public method | ResolveSubresource | Copy a multisampled resource into a non-multisampled resource. This API is most useful when re-using the resulting rendertarget of one render pass as an input to a second render pass. (Also see DirectX SDK: ID3D10Device::ResolveSubresource)
Public method | SetPredication | Set a rendering predicate. (Also see DirectX SDK: ID3D10Device::SetPredication)
Protected method | SetSwapChain |
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32) | The CPU copies data from memory to a subresource created in non-mappable memory. Because no destination box is defined, the data is written to the destination subresource with no offset. (Also see DirectX SDK: ID3D10Device::UpdateSubresource)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32, Box) | The CPU copies data from memory to a subresource created in non-mappable memory. (Also see DirectX SDK: ID3D10Device::UpdateSubresource)

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ClearDepthStencilView Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..ClearDepthStencilView Method
D3DDevice Class See Also Send Feedback
Clears the depth-stencil resource.

(Also see DirectX SDK: ID3D10Device::ClearDepthStencilView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearDepthStencilView(
    DepthStencilView depthStencilView,
    ClearOptions options,
    float depth,
    byte stencil
)
Visual Basic
Public Sub ClearDepthStencilView ( _
    depthStencilView As DepthStencilView, _
    options As ClearOptions, _
    depth As Single, _
    stencil As Byte _
)
Visual C++
public:
void ClearDepthStencilView(
    DepthStencilView^ depthStencilView,
    ClearOptions options,
    float depth,
    unsigned char stencil
)

Parameters

depthStencilView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilView
Pointer to the depth stencil to be cleared.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ClearOptions
Which parts of the buffer to clear. See ClearOptions.
depth
Type: System..::..Single
Clear the depth buffer with this value. This value will be clamped between 0 and 1.
stencil
Type: System..::..Byte
Clear the stencil buffer with this value.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ClearRenderTargetView Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..ClearRenderTargetView Method
D3DDevice Class See Also Send Feedback
Set all the elements in a render target to one value.

(Also see DirectX SDK: ID3D10DeviceContext::ClearRenderTargetView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearRenderTargetView(
    RenderTargetView renderTargetView,
    ColorRgba colorRgba
)
Visual Basic
Public Sub ClearRenderTargetView ( _
    renderTargetView As RenderTargetView, _
    colorRgba As ColorRgba _
)
Visual C++
public:
void ClearRenderTargetView(
    RenderTargetView^ renderTargetView,
    ColorRgba colorRgba
)

Parameters

renderTargetView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetView
Pointer to the rendertarget.
colorRgba
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgba
The color to fill the render target with.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ClearState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..ClearState Method
D3DDevice Class See Also Send Feedback
Restore all default device settings; return the device to the state it was in when it was created. This will set all set all input/output resource slots, shaders, input layouts, predications, scissor rectangles, depth-stencil state, rasterizer state, blend state, sampler state, and viewports to NULL. The primitive topology will be set to UNDEFINED.

(Also see DirectX SDK: ID3D10Device::ClearState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearState()
Visual Basic
Public Sub ClearState
Visual C++
public:
void ClearState()

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CopyResource Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CopyResource Method
D3DDevice Class See Also Send Feedback
Copy the entire contents of the source resource to the destination resource using the GPU.

(Also see DirectX SDK: ID3D10Device::CopyResource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyResource(
    D3DResource destinationResource,
    D3DResource sourceResource
)
Visual Basic
Public Sub CopyResource ( _
    destinationResource As D3DResource, _
    sourceResource As D3DResource _
)
Visual C++
public:
void CopyResource(
    D3DResource^ destinationResource,
    D3DResource^ sourceResource
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The destination resource (see D3DResource).
sourceResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The source resource (see D3DResource).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource


CopySubresourceRegion Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CopySubresourceRegion Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32) | Copy a region from a source resource to a destination resource. The entire source subresource is copied. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box) | Copy a region from a source resource to a destination resource. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CopySubresourceRegion Method (D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CopySubresourceRegion Method (D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32)
D3DDevice Class See Also Send Feedback
Copy a region from a source resource to a destination resource. The entire source subresource is copied.

(Also see DirectX SDK: ID3D10Device::CopySubresourceRegion)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopySubresourceRegion(
    D3DResource destinationResource,
    uint destinationSubresource,
    uint destinationX,
    uint destinationY,
    uint destinationZ,
    D3DResource sourceResource,
    uint sourceSubresourceIndex
)
Visual Basic
Public Sub CopySubresourceRegion ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    destinationX As UInteger, _
    destinationY As UInteger, _
    destinationZ As UInteger, _
    sourceResource As D3DResource, _
    sourceSubresourceIndex As UInteger _
)
Visual C++
public:
void CopySubresourceRegion(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    unsigned int destinationX,
    unsigned int destinationY,
    unsigned int destinationZ,
    D3DResource^ sourceResource,
    unsigned int sourceSubresourceIndex
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The destination resource (see D3DResource).
destinationSubresource
Type: System..::..UInt32
Destination subresource index.
destinationX
Type: System..::..UInt32
The x coordinate of the upper left corner of the destination region.
destinationY
Type: System..::..UInt32
The y coordinate of the upper left corner of the destination region.
destinationZ
Type: System..::..UInt32
The z coordinate of the upper left corner of the destination region. For a 1D or 2D subresource, this must be zero.
sourceResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The source resource (see D3DResource).
sourceSubresourceIndex
Type: System..::..UInt32
Source subresource index.

See Also

D3DDevice Class
CopySubresourceRegion Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource


CopySubresourceRegion Method (D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CopySubresourceRegion Method (D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box)
D3DDevice Class See Also Send Feedback
Copy a region from a source resource to a destination resource.

(Also see DirectX SDK: ID3D10Device::CopySubresourceRegion)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopySubresourceRegion(
    D3DResource destinationResource,
    uint destinationSubresource,
    uint destinationX,
    uint destinationY,
    uint destinationZ,
    D3DResource sourceResource,
    uint sourceSubresourceIndex,
    Box sourceBox
)
Visual Basic
Public Sub CopySubresourceRegion ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    destinationX As UInteger, _
    destinationY As UInteger, _
    destinationZ As UInteger, _
    sourceResource As D3DResource, _
    sourceSubresourceIndex As UInteger, _
    sourceBox As Box _
)
Visual C++
public:
void CopySubresourceRegion(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    unsigned int destinationX,
    unsigned int destinationY,
    unsigned int destinationZ,
    D3DResource^ sourceResource,
    unsigned int sourceSubresourceIndex,
    Box sourceBox
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The destination resource (see D3DResource).
destinationSubresource
Type: System..::..UInt32
Destination subresource index.
destinationX
Type: System..::..UInt32
The x coordinate of the upper left corner of the destination region.
destinationY
Type: System..::..UInt32
The y coordinate of the upper left corner of the destination region.
destinationZ
Type: System..::..UInt32
The z coordinate of the upper left corner of the destination region. For a 1D or 2D subresource, this must be zero.
sourceResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The source resource (see D3DResource).
sourceSubresourceIndex
Type: System..::..UInt32
Source subresource index.
sourceBox
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Box
A 3D box (see Box) that defines the source subresources that can be copied. The box must fit within the source resource.

See Also

D3DDevice Class
CopySubresourceRegion Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Box


CreateBlendState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateBlendState Method
D3DDevice Class See Also Send Feedback
Create a blend-state object that encapsules blend state for the output-merger stage.

(Also see DirectX SDK: ID3D10Device::CreateBlendState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendState CreateBlendState(
    BlendDescription blendStateDescription
)
Visual Basic
Public Function CreateBlendState ( _
    blendStateDescription As BlendDescription _
) As BlendState
Visual C++
public:
BlendState^ CreateBlendState(
    BlendDescription blendStateDescription
)

Parameters

blendStateDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendDescription
A blend-state description (see BlendDescription).

Return Value

The blend-state object created (see BlendState Object).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendDescription


CreateBuffer Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateBuffer Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBuffer(BufferDescription) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer) with no initial data. (Also see DirectX SDK: ID3D10Device::CreateBuffer)
Public method | CreateBuffer(BufferDescription, array<SubresourceData>[]()[][]) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). (Also see DirectX SDK: ID3D10Device::CreateBuffer)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateBuffer Method (BufferDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateBuffer Method (BufferDescription)
D3DDevice Class See Also Send Feedback
Create a buffer (vertex buffer, index buffer, or shader-constant buffer) with no initial data.

(Also see DirectX SDK: ID3D10Device::CreateBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer CreateBuffer(
    BufferDescription description
)
Visual Basic
Public Function CreateBuffer ( _
    description As BufferDescription _
) As D3DBuffer
Visual C++
public:
D3DBuffer^ CreateBuffer(
    BufferDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferDescription
A buffer description (see BufferDescription).

Return Value

The buffer created (see D3DBuffer Object).

See Also

D3DDevice Class
CreateBuffer Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferDescription


CreateBuffer Method (BufferDescription, SubresourceData[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateBuffer Method (BufferDescription, array<SubresourceData>[]()[][])
D3DDevice Class See Also Send Feedback
Create a buffer (vertex buffer, index buffer, or shader-constant buffer).

(Also see DirectX SDK: ID3D10Device::CreateBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer CreateBuffer(
    BufferDescription description,
    params SubresourceData[] initialData
)
Visual Basic
Public Function CreateBuffer ( _
    description As BufferDescription, _
    ParamArray initialData As SubresourceData() _
) As D3DBuffer
Visual C++
public:
D3DBuffer^ CreateBuffer(
    BufferDescription description,
    ... array<SubresourceData>^ initialData
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferDescription
A buffer description (see BufferDescription).
initialData
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SubresourceData >[]()[][]
Pointer to the initialization data (see SubresourceData); use NULL to allocate space only.

Return Value

The buffer created (see D3DBuffer Object).

See Also

D3DDevice Class
CreateBuffer Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SubresourceData


CreateCounter Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateCounter Method
D3DDevice Class See Also Send Feedback
Create a counter object for measuring GPU performance.

(Also see DirectX SDK: ID3D10Device::CreateCounter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DCounter CreateCounter(
    CounterDescription description
)
Visual Basic
Public Function CreateCounter ( _
    description As CounterDescription _
) As D3DCounter
Visual C++
public:
D3DCounter^ CreateCounter(
    CounterDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterDescription
A counter description (see CounterDescription).

Return Value

A counter (see D3DCounter).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterDescription


CreateDepthStencilState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDepthStencilState Method
D3DDevice Class See Also Send Feedback
Create a depth-stencil state object that encapsulates depth-stencil test information for the output-merger stage.

(Also see DirectX SDK: ID3D10Device::CreateDepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilState CreateDepthStencilState(
    DepthStencilDescription description
)
Visual Basic
Public Function CreateDepthStencilState ( _
    description As DepthStencilDescription _
) As DepthStencilState
Visual C++
public:
DepthStencilState^ CreateDepthStencilState(
    DepthStencilDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilDescription
A depth-stencil state description (see DepthStencilDescription).

Return Value

The depth-stencil state object created (see DepthStencilState Object).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilDescription


CreateDepthStencilView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDepthStencilView Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDepthStencilView(D3DResource) | Create a depth-stencil view for accessing resource data. This method creates a view that accesses mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView)
Public method | CreateDepthStencilView(D3DResource, DepthStencilViewDescription) | Create a depth-stencil view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDepthStencilView Method (D3DResource)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDepthStencilView Method (D3DResource)
D3DDevice Class See Also Send Feedback
Create a depth-stencil view for accessing resource data. This method creates a view that accesses mipmap level 0 of the entire resource (using the format the resource was created with).

(Also see DirectX SDK: ID3D10Device::CreateDepthStencilView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilView CreateDepthStencilView(
    D3DResource resource
)
Visual Basic
Public Function CreateDepthStencilView ( _
    resource As D3DResource _
) As DepthStencilView
Visual C++
public:
DepthStencilView^ CreateDepthStencilView(
    D3DResource^ resource
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The resource that will serve as the depth-stencil surface. This resource must have been created with the DepthStencil flag.

Return Value

A DepthStencilView.

See Also

D3DDevice Class
CreateDepthStencilView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDepthStencilView Method (D3DResource, DepthStencilViewDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDepthStencilView Method (D3DResource, DepthStencilViewDescription)
D3DDevice Class See Also Send Feedback
Create a depth-stencil view for accessing resource data.

(Also see DirectX SDK: ID3D10Device::CreateDepthStencilView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilView CreateDepthStencilView(
    D3DResource resource,
    DepthStencilViewDescription description
)
Visual Basic
Public Function CreateDepthStencilView ( _
    resource As D3DResource, _
    description As DepthStencilViewDescription _
) As DepthStencilView
Visual C++
public:
DepthStencilView^ CreateDepthStencilView(
    D3DResource^ resource,
    DepthStencilViewDescription description
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The resource that will serve as the depth-stencil surface. This resource must have been created with the DepthStencil flag.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilViewDescription
A depth-stencil-view description (see DepthStencilViewDescription).

Return Value

A DepthStencilView.

See Also

D3DDevice Class
CreateDepthStencilView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilViewDescription


CreateDevice Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDevice Method
D3DDevice Class See Also Send Feedback

Overload List

Name | Description
CreateDevice()()()() | Create a Direct3D 10.0 device using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDevice() function)
CreateDevice(Adapter, DriverType, String, CreateDeviceOptions) | Create a Direct3D 10.0 device. (Also see DirectX SDK: D3D10CreateDevice() function)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDevice Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDevice Method
D3DDevice Class See Also Send Feedback
Create a Direct3D 10.0 device using the default hardware adapter and the most common settings.

(Also see DirectX SDK: D3D10CreateDevice() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice CreateDevice()
Visual Basic
Public Shared Function CreateDevice As D3DDevice
Visual C++
public:
static D3DDevice^ CreateDevice()

Return Value

The created Direct3D 10.0 Device

Remarks

If DirectX SDK environment variable is found, and the build is a Debug one, this method will attempt to use CreateDeviceOptions.Debug flag. This should allow using the InfoQueue object.

See Also

D3DDevice Class
CreateDevice Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDevice Method (Adapter, DriverType, String, CreateDeviceOptions)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDevice Method (Adapter, DriverType, String, CreateDeviceOptions)
D3DDevice Class See Also Send Feedback
Create a Direct3D 10.0 device.

(Also see DirectX SDK: D3D10CreateDevice() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice CreateDevice(
    Adapter adapter,
    DriverType driverType,
    string softwareRasterizerLibrary,
    CreateDeviceOptions options
)
Visual Basic
Public Shared Function CreateDevice ( _
    adapter As Adapter, _
    driverType As DriverType, _
    softwareRasterizerLibrary As String, _
    options As CreateDeviceOptions _
) As D3DDevice
Visual C++
public:
static D3DDevice^ CreateDevice(
    Adapter^ adapter,
    DriverType driverType,
    String^ softwareRasterizerLibrary,
    CreateDeviceOptions options
)

Parameters

adapter
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter
An Adapter object. Can be null.
driverType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DriverType
The type of driver for the device.
softwareRasterizerLibrary
Type: System..::..String
A path the DLL that implements a software rasterizer. Must be NULL if driverType is non-software.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CreateDeviceOptions
Device creation flags that enable API layers. These flags can be bitwise OR'd together.

Return Value

The created Direct3D 10.0 Device

Remarks

By default, all Direct3D 10 calls are handled in a thread-safe way. By creating a single-threaded device (using CreateDeviceOptions.SingleThreaded, you disable thread-safe calling.

See Also

D3DDevice Class
CreateDevice Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDeviceAndSwapChain Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDeviceAndSwapChain Method
D3DDevice Class See Also Send Feedback

Overload List

Name | Description
CreateDeviceAndSwapChain(IntPtr) | Create a Direct3D 10.0 device and a swap chain using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain() function)
CreateDeviceAndSwapChain(Adapter, DriverType, String, CreateDeviceOptions, SwapChainDescription) | Create a Direct3D 10.0 device and a swap chain. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain() function)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDeviceAndSwapChain Method (IntPtr)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDeviceAndSwapChain Method (IntPtr)
D3DDevice Class See Also Send Feedback
Create a Direct3D 10.0 device and a swap chain using the default hardware adapter and the most common settings.

(Also see DirectX SDK: D3D10CreateDeviceAndSwapChain() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice CreateDeviceAndSwapChain(
    IntPtr windowHandle
)
Visual Basic
Public Shared Function CreateDeviceAndSwapChain ( _
    windowHandle As IntPtr _
) As D3DDevice
Visual C++
public:
static D3DDevice^ CreateDeviceAndSwapChain(
    IntPtr windowHandle
)

Parameters

windowHandle
Type: System..::..IntPtr
The window handle to the output window.

Return Value

The created Direct3D 10.0 Device

Remarks

The swap chain created can be retrieved from the SwapChain property. If DirectX SDK environment variable is found, and the build is a Debug one, this method will attempt to use CreateDeviceOptions.Debug flag. This should allow using the InfoQueue object.

See Also

D3DDevice Class
CreateDeviceAndSwapChain Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDeviceAndSwapChain Method (Adapter, DriverType, String, CreateDeviceOptions, SwapChainDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDeviceAndSwapChain Method (Adapter, DriverType, String, CreateDeviceOptions, SwapChainDescription)
D3DDevice Class See Also Send Feedback
Create a Direct3D 10.0 device and a swap chain.

(Also see DirectX SDK: D3D10CreateDeviceAndSwapChain() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice CreateDeviceAndSwapChain(
    Adapter adapter,
    DriverType driverType,
    string softwareRasterizerLibrary,
    CreateDeviceOptions options,
    SwapChainDescription swapChainDescription
)
Visual Basic
Public Shared Function CreateDeviceAndSwapChain ( _
    adapter As Adapter, _
    driverType As DriverType, _
    softwareRasterizerLibrary As String, _
    options As CreateDeviceOptions, _
    swapChainDescription As SwapChainDescription _
) As D3DDevice
Visual C++
public:
static D3DDevice^ CreateDeviceAndSwapChain(
    Adapter^ adapter,
    DriverType driverType,
    String^ softwareRasterizerLibrary,
    CreateDeviceOptions options,
    SwapChainDescription swapChainDescription
)

Parameters

adapter
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter
An Adapter object. Can be null.
driverType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DriverType
The type of driver for the device.
softwareRasterizerLibrary
Type: System..::..String
A path the DLL that implements a software rasterizer. Must be NULL if driverType is non-software.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CreateDeviceOptions
Device creation flags that enable API layers. These flags can be bitwise OR'd together.
swapChainDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChainDescription
Description of the swap chain.

Return Value

The created Direct3D 10.0 Device

Remarks

The swap chain created can be retrieved from the SwapChain property. By default, all Direct3D 10 calls are handled in a thread-safe way. By creating a single-threaded device (using CreateDeviceOptions.SingleThreaded, you disable thread-safe calling.

See Also

D3DDevice Class
CreateDeviceAndSwapChain Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateEffectFromCompiledBinary Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateEffectFromCompiledBinary Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateEffectFromCompiledBinary(BinaryReader) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function)
Public method | CreateEffectFromCompiledBinary(Stream) | Loads a precompiled effect from a binary data stream.
Public method | CreateEffectFromCompiledBinary(String) | Loads a precompiled effect from a file. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function)
Public method | CreateEffectFromCompiledBinary(BinaryReader, Int32, EffectPool) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function)
Public method | CreateEffectFromCompiledBinary(Stream, Int32, EffectPool) | Loads a precompiled effect from a binary data stream.

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateEffectFromCompiledBinary Method (BinaryReader)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateEffectFromCompiledBinary Method (BinaryReader)
D3DDevice Class See Also Send Feedback
Loads a precompiled effect from a binary data stream.

(Also see DirectX SDK: D3D10CreateEffectFromMemory() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Effect CreateEffectFromCompiledBinary(
    BinaryReader binaryEffect
)
Visual Basic
Public Function CreateEffectFromCompiledBinary ( _
    binaryEffect As BinaryReader _
) As Effect
Visual C++
public:
Effect^ CreateEffectFromCompiledBinary(
    BinaryReader^ binaryEffect
)

Parameters

binaryEffect
Type: System.IO..::..BinaryReader
The binary data stream.

See Also

D3DDevice Class
CreateEffectFromCompiledBinary Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateEffectFromCompiledBinary Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateEffectFromCompiledBinary Method (Stream)
D3DDevice Class See Also Send Feedback
Loads a precompiled effect from a binary data stream.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Effect CreateEffectFromCompiledBinary(
    Stream inputStream
)
Visual Basic
Public Function CreateEffectFromCompiledBinary ( _
    inputStream As Stream _
) As Effect
Visual C++
public:
Effect^ CreateEffectFromCompiledBinary(
    Stream^ inputStream
)

Parameters

inputStream
Type: System.IO..::..Stream
The input data stream.

See Also

D3DDevice Class
CreateEffectFromCompiledBinary Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateEffectFromCompiledBinary Method (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateEffectFromCompiledBinary Method (String)
D3DDevice Class See Also Send Feedback
Loads a precompiled effect from a file.

(Also see DirectX SDK: D3D10CreateEffectFromMemory() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Effect CreateEffectFromCompiledBinary(
    string path
)
Visual Basic
Public Function CreateEffectFromCompiledBinary ( _
    path As String _
) As Effect
Visual C++
public:
Effect^ CreateEffectFromCompiledBinary(
    String^ path
)

Parameters

path
Type: System..::..String
The path to the file that contains the compiled effect.

See Also

D3DDevice Class
CreateEffectFromCompiledBinary Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateEffectFromCompiledBinary Method (BinaryReader, Int32, EffectPool)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateEffectFromCompiledBinary Method (BinaryReader, Int32, EffectPool)
D3DDevice Class See Also Send Feedback
Loads a precompiled effect from a binary data stream.

(Also see DirectX SDK: D3D10CreateEffectFromMemory() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual Effect CreateEffectFromCompiledBinary(
    BinaryReader binaryEffect,
    int effectCompileOptions,
    EffectPool effectPool
)
Visual Basic
Public Overridable Function CreateEffectFromCompiledBinary ( _
    binaryEffect As BinaryReader, _
    effectCompileOptions As Integer, _
    effectPool As EffectPool _
) As Effect
Visual C++
public:
virtual Effect^ CreateEffectFromCompiledBinary(
    BinaryReader^ binaryEffect,
    int effectCompileOptions,
    EffectPool^ effectPool
)

Parameters

binaryEffect
Type: System.IO..::..BinaryReader
The binary data stream.
effectCompileOptions
Type: System..::..Int32
Effect compile options
effectPool
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectPool
A memory space for effect variables shared across effects.

See Also

D3DDevice Class
CreateEffectFromCompiledBinary Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateEffectFromCompiledBinary Method (Stream, Int32, EffectPool)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateEffectFromCompiledBinary Method (Stream, Int32, EffectPool)
D3DDevice Class See Also Send Feedback
Loads a precompiled effect from a binary data stream.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Effect CreateEffectFromCompiledBinary(
    Stream inputStream,
    int effectCompileOptions,
    EffectPool effectPool
)
Visual Basic
Public Function CreateEffectFromCompiledBinary ( _
    inputStream As Stream, _
    effectCompileOptions As Integer, _
    effectPool As EffectPool _
) As Effect
Visual C++
public:
Effect^ CreateEffectFromCompiledBinary(
    Stream^ inputStream,
    int effectCompileOptions,
    EffectPool^ effectPool
)

Parameters

inputStream
Type: System.IO..::..Stream
The input data stream.
effectCompileOptions
Type: System..::..Int32
Effect compile options
effectPool
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectPool
A memory space for effect variables shared across effects.

See Also

D3DDevice Class
CreateEffectFromCompiledBinary Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateGeometryShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShader Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateGeometryShader(Stream) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader)
Public method | CreateGeometryShader(IntPtr, UInt32) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateGeometryShader Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShader Method (Stream)
D3DDevice Class See Also Send Feedback
Create a geometry shader.

(Also see DirectX SDK: ID3D10Device::CreateGeometryShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShader(
    Stream shaderBytecodeStream
)
Visual Basic
Public Function CreateGeometryShader ( _
    shaderBytecodeStream As Stream _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShader(
    Stream^ shaderBytecodeStream
)

Parameters

shaderBytecodeStream
Type: System.IO..::..Stream
The stream to read the compiled shader shader data from. To get this object see Getting a A Compiled Shader in DX SDK.

Return Value

A GeometryShader Object. If this is NULL, all other parameters will be validated, and if all parameters pass validation this API will return S_FALSE instead of S_OK.

See Also

D3DDevice Class
CreateGeometryShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateGeometryShader Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShader Method (IntPtr, UInt32)
D3DDevice Class See Also Send Feedback
Create a geometry shader.

(Also see DirectX SDK: ID3D10Device::CreateGeometryShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength
)
Visual Basic
Public Function CreateGeometryShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength
)

Parameters

shaderBytecode
Type: System..::..IntPtr
The compiled shader. To get this object see Getting a A Compiled Shader in DX SDK.
shaderBytecodeLength
Type: System..::..UInt32
Size of the compiled geometry shader.

Return Value

A GeometryShader Object. If this is NULL, all other parameters will be validated, and if all parameters pass validation this API will return S_FALSE instead of S_OK.

See Also

D3DDevice Class
CreateGeometryShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateGeometryShaderWithStreamOutput Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShaderWithStreamOutput Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) |
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) |

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateGeometryShaderWithStreamOutput Method (Stream, IEnumerable(StreamOutputDeclarationEntry), UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShaderWithStreamOutput Method (Stream, IEnumerable<(Of <(<'StreamOutputDeclarationEntry>)>)>, UInt32)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShaderWithStreamOutput(
    Stream shaderBytecodeStream,
    IEnumerable<StreamOutputDeclarationEntry> streamOutputDeclarations,
    uint outputStreamStride
)
Visual Basic
Public Function CreateGeometryShaderWithStreamOutput ( _
    shaderBytecodeStream As Stream, _
    streamOutputDeclarations As IEnumerable(Of StreamOutputDeclarationEntry), _
    outputStreamStride As UInteger _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShaderWithStreamOutput(
    Stream^ shaderBytecodeStream,
    IEnumerable<StreamOutputDeclarationEntry>^ streamOutputDeclarations,
    unsigned int outputStreamStride
)

Parameters

shaderBytecodeStream
Type: System.IO..::..Stream
streamOutputDeclarations
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' StreamOutputDeclarationEntry >)>)>
outputStreamStride
Type: System..::..UInt32

See Also

D3DDevice Class
CreateGeometryShaderWithStreamOutput Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateGeometryShaderWithStreamOutput Method (IntPtr, UInt32, IEnumerable(StreamOutputDeclarationEntry), UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShaderWithStreamOutput Method (IntPtr, UInt32, IEnumerable<(Of <(<'StreamOutputDeclarationEntry>)>)>, UInt32)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShaderWithStreamOutput(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength,
    IEnumerable<StreamOutputDeclarationEntry> streamOutputDeclarations,
    uint outputStreamStride
)
Visual Basic
Public Function CreateGeometryShaderWithStreamOutput ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger, _
    streamOutputDeclarations As IEnumerable(Of StreamOutputDeclarationEntry), _
    outputStreamStride As UInteger _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShaderWithStreamOutput(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength,
    IEnumerable<StreamOutputDeclarationEntry>^ streamOutputDeclarations,
    unsigned int outputStreamStride
)

Parameters

shaderBytecode
Type: System..::..IntPtr
shaderBytecodeLength
Type: System..::..UInt32
streamOutputDeclarations
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' StreamOutputDeclarationEntry >)>)>
outputStreamStride
Type: System..::..UInt32

See Also

D3DDevice Class
CreateGeometryShaderWithStreamOutput Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateInputLayout Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateInputLayout Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), Stream) |
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), IntPtr, UInt32) |

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateInputLayout Method (IEnumerable(InputElementDescription), Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateInputLayout Method (IEnumerable<(Of <(<'InputElementDescription>)>)>, Stream)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputLayout CreateInputLayout(
    IEnumerable<InputElementDescription> inputElementDescriptions,
    Stream shaderBytecodeWithInputSignatureStream
)
Visual Basic
Public Function CreateInputLayout ( _
    inputElementDescriptions As IEnumerable(Of InputElementDescription), _
    shaderBytecodeWithInputSignatureStream As Stream _
) As InputLayout
Visual C++
public:
InputLayout^ CreateInputLayout(
    IEnumerable<InputElementDescription>^ inputElementDescriptions,
    Stream^ shaderBytecodeWithInputSignatureStream
)

Parameters

inputElementDescriptions
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' InputElementDescription >)>)>
shaderBytecodeWithInputSignatureStream
Type: System.IO..::..Stream

See Also

D3DDevice Class
CreateInputLayout Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateInputLayout Method (IEnumerable(InputElementDescription), IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateInputLayout Method (IEnumerable<(Of <(<'InputElementDescription>)>)>, IntPtr, UInt32)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputLayout CreateInputLayout(
    IEnumerable<InputElementDescription> inputElementDescriptions,
    IntPtr shaderBytecodeWithInputSignature,
    uint shaderBytecodeWithInputSignatureSize
)
Visual Basic
Public Function CreateInputLayout ( _
    inputElementDescriptions As IEnumerable(Of InputElementDescription), _
    shaderBytecodeWithInputSignature As IntPtr, _
    shaderBytecodeWithInputSignatureSize As UInteger _
) As InputLayout
Visual C++
public:
InputLayout^ CreateInputLayout(
    IEnumerable<InputElementDescription>^ inputElementDescriptions,
    IntPtr shaderBytecodeWithInputSignature,
    unsigned int shaderBytecodeWithInputSignatureSize
)

Parameters

inputElementDescriptions
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' InputElementDescription >)>)>
shaderBytecodeWithInputSignature
Type: System..::..IntPtr
shaderBytecodeWithInputSignatureSize
Type: System..::..UInt32

See Also

D3DDevice Class
CreateInputLayout Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreatePixelShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePixelShader Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreatePixelShader(Stream) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader)
Public method | CreatePixelShader(IntPtr, UInt32) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreatePixelShader Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePixelShader Method (Stream)
D3DDevice Class See Also Send Feedback
Create a pixel shader.

(Also see DirectX SDK: ID3D10Device::CreatePixelShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShader CreatePixelShader(
    Stream shaderBytecodeStream
)
Visual Basic
Public Function CreatePixelShader ( _
    shaderBytecodeStream As Stream _
) As PixelShader
Visual C++
public:
PixelShader^ CreatePixelShader(
    Stream^ shaderBytecodeStream
)

Parameters

shaderBytecodeStream
Type: System.IO..::..Stream
The compiled shader stream. To get this object see Getting a A Compiled Shader.

Return Value

A PixelShader Object.

See Also

D3DDevice Class
CreatePixelShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreatePixelShader Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePixelShader Method (IntPtr, UInt32)
D3DDevice Class See Also Send Feedback
Create a pixel shader.

(Also see DirectX SDK: ID3D10Device::CreatePixelShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShader CreatePixelShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength
)
Visual Basic
Public Function CreatePixelShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger _
) As PixelShader
Visual C++
public:
PixelShader^ CreatePixelShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength
)

Parameters

shaderBytecode
Type: System..::..IntPtr
The compiled shader. To get this object see Getting a A Compiled Shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of the compiled pixel shader.

Return Value

A PixelShader Object.

See Also

D3DDevice Class
CreatePixelShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreatePredicate Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePredicate Method
D3DDevice Class See Also Send Feedback
Creates a predicate.

(Also see DirectX SDK: ID3D10Device::CreatePredicate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DPredicate CreatePredicate(
    QueryDescription predicateDescription
)
Visual Basic
Public Function CreatePredicate ( _
    predicateDescription As QueryDescription _
) As D3DPredicate
Visual C++
public:
D3DPredicate^ CreatePredicate(
    QueryDescription predicateDescription
)

Parameters

predicateDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDescription
A query description where the type of query must be a StreamOutputOverflowPredicate or OcclusionPredicate (see QueryDescription).

Return Value

A predicate (see D3DPredicate Object).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDescription


CreateQuery Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateQuery Method
D3DDevice Class See Also Send Feedback
This class encapsulates methods for querying information from the GPU.

(Also see DirectX SDK: ID3D10Device::CreateQuery)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DQuery CreateQuery(
    QueryDescription description
)
Visual Basic
Public Function CreateQuery ( _
    description As QueryDescription _
) As D3DQuery
Visual C++
public:
D3DQuery^ CreateQuery(
    QueryDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDescription
A query description (see QueryDescription).

Return Value

The query object created (see D3DQuery Object).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDescription


CreateRasterizerState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateRasterizerState Method
D3DDevice Class See Also Send Feedback
Create a rasterizer state object that tells the rasterizer stage how to behave.

(Also see DirectX SDK: ID3D10Device::CreateRasterizerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerState CreateRasterizerState(
    RasterizerDescription description
)
Visual Basic
Public Function CreateRasterizerState ( _
    description As RasterizerDescription _
) As RasterizerState
Visual C++
public:
RasterizerState^ CreateRasterizerState(
    RasterizerDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerDescription
A rasterizer state description (see RasterizerDescription).

Return Value

The rasterizer state object created (see RasterizerState Object).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerDescription


CreateRenderTargetView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateRenderTargetView Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRenderTargetView(D3DResource) | Create a render-target view for accessing resource data in mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView)
Public method | CreateRenderTargetView(D3DResource, RenderTargetViewDescription) | Create a render-target view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateRenderTargetView Method (D3DResource)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateRenderTargetView Method (D3DResource)
D3DDevice Class See Also Send Feedback
Create a render-target view for accessing resource data in mipmap level 0 of the entire resource (using the format the resource was created with).

(Also see DirectX SDK: ID3D10Device::CreateRenderTargetView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetView CreateRenderTargetView(
    D3DResource resource
)
Visual Basic
Public Function CreateRenderTargetView ( _
    resource As D3DResource _
) As RenderTargetView
Visual C++
public:
RenderTargetView^ CreateRenderTargetView(
    D3DResource^ resource
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Pointer to the resource that will serve as the render target. This resource must have been created with the RenderTarget flag.

Return Value

A RenderTargetView.

See Also

D3DDevice Class
CreateRenderTargetView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateRenderTargetView Method (D3DResource, RenderTargetViewDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateRenderTargetView Method (D3DResource, RenderTargetViewDescription)
D3DDevice Class See Also Send Feedback
Create a render-target view for accessing resource data.

(Also see DirectX SDK: ID3D10Device::CreateRenderTargetView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetView CreateRenderTargetView(
    D3DResource resource,
    RenderTargetViewDescription description
)
Visual Basic
Public Function CreateRenderTargetView ( _
    resource As D3DResource, _
    description As RenderTargetViewDescription _
) As RenderTargetView
Visual C++
public:
RenderTargetView^ CreateRenderTargetView(
    D3DResource^ resource,
    RenderTargetViewDescription description
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Pointer to the resource that will serve as the render target. This resource must have been created with the RenderTarget flag.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetViewDescription
A render-target-view description (see RenderTargetViewDescription). Set this parameter to NULL to create a view that accesses mipmap level 0 of the entire resource (using the format the resource was created with).

Return Value

A RenderTargetView.

See Also

D3DDevice Class
CreateRenderTargetView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetViewDescription


CreateSamplerState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateSamplerState Method
D3DDevice Class See Also Send Feedback
Create a sampler-state object that encapsulates sampling information for a texture.

(Also see DirectX SDK: ID3D10Device::CreateSamplerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SamplerState CreateSamplerState(
    SamplerDescription description
)
Visual Basic
Public Function CreateSamplerState ( _
    description As SamplerDescription _
) As SamplerState
Visual C++
public:
SamplerState^ CreateSamplerState(
    SamplerDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerDescription
A sampler state description (see SamplerDescription).

Return Value

The sampler state object created (see SamplerState Object).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerDescription


CreateShaderResourceView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateShaderResourceView Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateShaderResourceView(D3DResource) | Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView)
Public method | CreateShaderResourceView(D3DResource, ShaderResourceViewDescription) | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateShaderResourceView Method (D3DResource)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateShaderResourceView Method (D3DResource)
D3DDevice Class See Also Send Feedback
Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with).

(Also see DirectX SDK: ID3D10Device::CreateShaderResourceView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceView CreateShaderResourceView(
    D3DResource resource
)
Visual Basic
Public Function CreateShaderResourceView ( _
    resource As D3DResource _
) As ShaderResourceView
Visual C++
public:
ShaderResourceView^ CreateShaderResourceView(
    D3DResource^ resource
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Pointer to the resource that will serve as input to a shader. This resource must have been created with the ShaderResource flag.

Return Value

A ShaderResourceView.

See Also

D3DDevice Class
CreateShaderResourceView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateShaderResourceView Method (D3DResource, ShaderResourceViewDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateShaderResourceView Method (D3DResource, ShaderResourceViewDescription)
D3DDevice Class See Also Send Feedback
Create a shader-resource view for accessing data in a resource.

(Also see DirectX SDK: ID3D10Device::CreateShaderResourceView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceView CreateShaderResourceView(
    D3DResource resource,
    ShaderResourceViewDescription description
)
Visual Basic
Public Function CreateShaderResourceView ( _
    resource As D3DResource, _
    description As ShaderResourceViewDescription _
) As ShaderResourceView
Visual C++
public:
ShaderResourceView^ CreateShaderResourceView(
    D3DResource^ resource,
    ShaderResourceViewDescription description
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Pointer to the resource that will serve as input to a shader. This resource must have been created with the ShaderResource flag.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceViewDescription
A shader-resource-view description (see ShaderResourceViewDescription). Set this parameter to NULL to create a view that accesses the entire resource (using the format the resource was created with).

Return Value

A ShaderResourceView.

See Also

D3DDevice Class
CreateShaderResourceView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceViewDescription


CreateStateBlock Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateStateBlock Method
D3DDevice Class See Also Send Feedback
Create a state block.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlock CreateStateBlock(
    StateBlockMask stateBlockMask
)
Visual Basic
Public Function CreateStateBlock ( _
    stateBlockMask As StateBlockMask _
) As StateBlock
Visual C++
public:
StateBlock^ CreateStateBlock(
    StateBlockMask^ stateBlockMask
)

Parameters

stateBlockMask
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask
Indicates which parts of the device state will be captured when calling StateBlock.Capture and reapplied when calling StateBlock.Capture

Return Value

The StateBlock object that was created

Remarks

A state block is a collection of device state, and is used for saving and restoring device state. Use a state-block mask to enable subsets of state for saving and restoring. The StateBlockMask object can be filled by using any of its public members. A state block mask can also be obtained by calling EffectTechnique.ComputeStateBlockMask or EffectPass.ComputeStateBlockMask.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateTexture1D Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture1D Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTexture1D(Texture1DDescription) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D)
Public method | CreateTexture1D(Texture1DDescription, array<SubresourceData>[]()[][]) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateTexture1D Method (Texture1DDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture1D Method (Texture1DDescription)
D3DDevice Class See Also Send Feedback
Create an array of 1D textures.

(Also see DirectX SDK: ID3D10Device::CreateTexture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1D CreateTexture1D(
    Texture1DDescription description
)
Visual Basic
Public Function CreateTexture1D ( _
    description As Texture1DDescription _
) As Texture1D
Visual C++
public:
Texture1D^ CreateTexture1D(
    Texture1DDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDescription
A 1D texture description (see Texture1DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.

Return Value

The created texture (see Texture1D).

See Also

D3DDevice Class
CreateTexture1D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1D


CreateTexture1D Method (Texture1DDescription, SubresourceData[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture1D Method (Texture1DDescription, array<SubresourceData>[]()[][])
D3DDevice Class See Also Send Feedback
Create an array of 1D textures.

(Also see DirectX SDK: ID3D10Device::CreateTexture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1D CreateTexture1D(
    Texture1DDescription description,
    params SubresourceData[] initialData
)
Visual Basic
Public Function CreateTexture1D ( _
    description As Texture1DDescription, _
    ParamArray initialData As SubresourceData() _
) As Texture1D
Visual C++
public:
Texture1D^ CreateTexture1D(
    Texture1DDescription description,
    ... array<SubresourceData>^ initialData
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDescription
A 1D texture description (see Texture1DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.
initialData
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SubresourceData >[]()[][]
Subresource descriptions (see SubresourceData); one for each subresource. Applications may not specify NULL for initialData when creating IMMUTABLE resources (see Usage). If the resource is multisampled, pInitialData must be NULL because multisampled resources cannot be initialized with data when they are created.

Return Value

The created texture (see Texture1D).

See Also

D3DDevice Class
CreateTexture1D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SubresourceData
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1D


CreateTexture2D Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture2D Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTexture2D(Texture2DDescription) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D)
Public method | CreateTexture2D(Texture2DDescription, array<SubresourceData>[]()[][]) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateTexture2D Method (Texture2DDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture2D Method (Texture2DDescription)
D3DDevice Class See Also Send Feedback
Create an array of 2D textures.

(Also see DirectX SDK: ID3D10Device::CreateTexture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2D CreateTexture2D(
    Texture2DDescription description
)
Visual Basic
Public Function CreateTexture2D ( _
    description As Texture2DDescription _
) As Texture2D
Visual C++
public:
Texture2D^ CreateTexture2D(
    Texture2DDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDescription
A 2D texture description (see Texture2DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.

Return Value

The created texture (see Texture2D).

See Also

D3DDevice Class
CreateTexture2D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2D


CreateTexture2D Method (Texture2DDescription, SubresourceData[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture2D Method (Texture2DDescription, array<SubresourceData>[]()[][])
D3DDevice Class See Also Send Feedback
Create an array of 2D textures.

(Also see DirectX SDK: ID3D10Device::CreateTexture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2D CreateTexture2D(
    Texture2DDescription description,
    params SubresourceData[] initialData
)
Visual Basic
Public Function CreateTexture2D ( _
    description As Texture2DDescription, _
    ParamArray initialData As SubresourceData() _
) As Texture2D
Visual C++
public:
Texture2D^ CreateTexture2D(
    Texture2DDescription description,
    ... array<SubresourceData>^ initialData
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDescription
A 2D texture description (see Texture2DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.
initialData
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SubresourceData >[]()[][]
Subresource descriptions (see SubresourceData); one for each subresource. Applications may not specify NULL for pInitialData when creating IMMUTABLE resources (see Usage). If the resource is multisampled, pInitialData must be NULL because multisampled resources cannot be initialized with data when they are created.

Return Value

The created texture (see Texture2D).

See Also

D3DDevice Class
CreateTexture2D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SubresourceData
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2D


CreateTexture3D Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture3D Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTexture3D(Texture3DDescription) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D)
Public method | CreateTexture3D(Texture3DDescription, array<SubresourceData>[]()[][]) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateTexture3D Method (Texture3DDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture3D Method (Texture3DDescription)
D3DDevice Class See Also Send Feedback
Create a single 3D texture.

(Also see DirectX SDK: ID3D10Device::CreateTexture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3D CreateTexture3D(
    Texture3DDescription description
)
Visual Basic
Public Function CreateTexture3D ( _
    description As Texture3DDescription _
) As Texture3D
Visual C++
public:
Texture3D^ CreateTexture3D(
    Texture3DDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DDescription
A 3D texture description (see Texture3DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.

Return Value

The created texture (see Texture3D).

See Also

D3DDevice Class
CreateTexture3D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3D


CreateTexture3D Method (Texture3DDescription, SubresourceData[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture3D Method (Texture3DDescription, array<SubresourceData>[]()[][])
D3DDevice Class See Also Send Feedback
Create a single 3D texture.

(Also see DirectX SDK: ID3D10Device::CreateTexture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3D CreateTexture3D(
    Texture3DDescription description,
    params SubresourceData[] initialData
)
Visual Basic
Public Function CreateTexture3D ( _
    description As Texture3DDescription, _
    ParamArray initialData As SubresourceData() _
) As Texture3D
Visual C++
public:
Texture3D^ CreateTexture3D(
    Texture3DDescription description,
    ... array<SubresourceData>^ initialData
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DDescription
A 3D texture description (see Texture3DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.
initialData
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SubresourceData >[]()[][]
Subresource descriptions (see SubresourceData); one for each subresource. Applications may not specify NULL for pInitialData when creating IMMUTABLE resources (see Usage). If the resource is multisampled, pInitialData must be NULL because multisampled resources cannot be initialized with data when they are created.

Return Value

The created texture (see Texture3D).

See Also

D3DDevice Class
CreateTexture3D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SubresourceData
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3D


CreateVertexShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateVertexShader Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateVertexShader(Stream) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader)
Public method | CreateVertexShader(IntPtr, UInt32) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateVertexShader Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateVertexShader Method (Stream)
D3DDevice Class See Also Send Feedback
Create a vertex-shader object from a compiled shader.

(Also see DirectX SDK: ID3D10Device::CreateVertexShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShader CreateVertexShader(
    Stream shaderBytecodeStream
)
Visual Basic
Public Function CreateVertexShader ( _
    shaderBytecodeStream As Stream _
) As VertexShader
Visual C++
public:
VertexShader^ CreateVertexShader(
    Stream^ shaderBytecodeStream
)

Parameters

shaderBytecodeStream
Type: System.IO..::..Stream
The compiled shader stream. To get this object see Getting a A Compiled Shader.

Return Value

A VertexShader Object.

See Also

D3DDevice Class
CreateVertexShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateVertexShader Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateVertexShader Method (IntPtr, UInt32)
D3DDevice Class See Also Send Feedback
Create a vertex-shader object from a compiled shader.

(Also see DirectX SDK: ID3D10Device::CreateVertexShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShader CreateVertexShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength
)
Visual Basic
Public Function CreateVertexShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger _
) As VertexShader
Visual C++
public:
VertexShader^ CreateVertexShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength
)

Parameters

shaderBytecode
Type: System..::..IntPtr
The compiled shader. To get this object see Getting a A Compiled Shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of the compiled vertex shader.

Return Value

A VertexShader Object.

See Also

D3DDevice Class
CreateVertexShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Draw Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..Draw Method
D3DDevice Class See Also Send Feedback
Draw non-indexed, non-instanced primitives.

(Also see DirectX SDK: ID3D10Device::Draw)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Draw(
    uint vertexCount,
    uint startVertexLocation
)
Visual Basic
Public Sub Draw ( _
    vertexCount As UInteger, _
    startVertexLocation As UInteger _
)
Visual C++
public:
void Draw(
    unsigned int vertexCount,
    unsigned int startVertexLocation
)

Parameters

vertexCount
Type: System..::..UInt32
Number of vertices to draw.
startVertexLocation
Type: System..::..UInt32
Index of the first vertex, which is usually an offset in a vertex buffer; it could also be used as the first vertex id generated for a shader parameter marked with the SV_TargetId system-value semantic.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DrawAuto Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..DrawAuto Method
D3DDevice Class See Also Send Feedback
Draw geometry of an unknown size that was created by the geometry shader stage.

(Also see DirectX SDK: ID3D10Device::DrawAuto)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawAuto()
Visual Basic
Public Sub DrawAuto
Visual C++
public:
void DrawAuto()

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DrawIndexed Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..DrawIndexed Method
D3DDevice Class See Also Send Feedback
Draw indexed, non-instanced primitives.

(Also see DirectX SDK: ID3D10Device::DrawIndexed)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawIndexed(
    uint indexCount,
    uint startIndexLocation,
    int baseVertexLocation
)
Visual Basic
Public Sub DrawIndexed ( _
    indexCount As UInteger, _
    startIndexLocation As UInteger, _
    baseVertexLocation As Integer _
)
Visual C++
public:
void DrawIndexed(
    unsigned int indexCount,
    unsigned int startIndexLocation,
    int baseVertexLocation
)

Parameters

indexCount
Type: System..::..UInt32
Number of indices to draw.
startIndexLocation
Type: System..::..UInt32
Index of the first index to use when accesssing the vertex buffer; begin at startIndexLocation to index vertices from the vertex buffer.
baseVertexLocation
Type: System..::..Int32
Offset from the start of the vertex buffer to the first vertex.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DrawIndexedInstanced Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..DrawIndexedInstanced Method
D3DDevice Class See Also Send Feedback
Draw indexed, instanced primitives.

(Also see DirectX SDK: ID3D10Device::DrawIndexedInstanced)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawIndexedInstanced(
    uint indexCountPerInstance,
    uint instanceCount,
    uint startIndexLocation,
    int baseVertexLocation,
    uint startInstanceLocation
)
Visual Basic
Public Sub DrawIndexedInstanced ( _
    indexCountPerInstance As UInteger, _
    instanceCount As UInteger, _
    startIndexLocation As UInteger, _
    baseVertexLocation As Integer, _
    startInstanceLocation As UInteger _
)
Visual C++
public:
void DrawIndexedInstanced(
    unsigned int indexCountPerInstance,
    unsigned int instanceCount,
    unsigned int startIndexLocation,
    int baseVertexLocation,
    unsigned int startInstanceLocation
)

Parameters

indexCountPerInstance
Type: System..::..UInt32
Size of the index buffer used in each instance.
instanceCount
Type: System..::..UInt32
Number of instances to draw.
startIndexLocation
Type: System..::..UInt32
Index of the first index.
baseVertexLocation
Type: System..::..Int32
Index of the first vertex. The index is signed, which allows a negative index. If the negative index plus the index value from the index buffer are less than 0, the result is undefined.
startInstanceLocation
Type: System..::..UInt32
Index of the first instance.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DrawInstanced Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..DrawInstanced Method
D3DDevice Class See Also Send Feedback
Draw non-indexed, instanced primitives.

(Also see DirectX SDK: ID3D10Device::DrawInstanced)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawInstanced(
    uint vertexCountPerInstance,
    uint instanceCount,
    uint startVertexLocation,
    uint startInstanceLocation
)
Visual Basic
Public Sub DrawInstanced ( _
    vertexCountPerInstance As UInteger, _
    instanceCount As UInteger, _
    startVertexLocation As UInteger, _
    startInstanceLocation As UInteger _
)
Visual C++
public:
void DrawInstanced(
    unsigned int vertexCountPerInstance,
    unsigned int instanceCount,
    unsigned int startVertexLocation,
    unsigned int startInstanceLocation
)

Parameters

vertexCountPerInstance
Type: System..::..UInt32
Number of vertices to draw.
instanceCount
Type: System..::..UInt32
Number of instances to draw.
startVertexLocation
Type: System..::..UInt32
Index of the first vertex.
startInstanceLocation
Type: System..::..UInt32
Index of the first instance.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Flush Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..Flush Method
D3DDevice Class See Also Send Feedback
Send queued-up commands in the command buffer to the GPU.

(Also see DirectX SDK: ID3D10Device::Flush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Flush()
Visual Basic
Public Sub Flush
Visual C++
public:
void Flush()

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GenerateMips Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GenerateMips Method
D3DDevice Class See Also Send Feedback
Generate mipmaps for the given shader resource.

(Also see DirectX SDK: ID3D10Device::GenerateMips)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void GenerateMips(
    ShaderResourceView shaderResourceView
)
Visual Basic
Public Sub GenerateMips ( _
    shaderResourceView As ShaderResourceView _
)
Visual C++
public:
void GenerateMips(
    ShaderResourceView^ shaderResourceView
)

Parameters

shaderResourceView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceView
An ShaderResourceView Object. The mipmaps will be generated for this shader resource.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetCounterData Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GetCounterData Method
D3DDevice Class See Also Send Feedback
Get the type, name, units of measure, and a description of an existing counter.

(Also see DirectX SDK: ID3D10Device::CheckCounter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CounterData GetCounterData(
    CounterDescription counterDescription
)
Visual Basic
Public Function GetCounterData ( _
    counterDescription As CounterDescription _
) As CounterData
Visual C++
public:
CounterData^ GetCounterData(
    CounterDescription counterDescription
)

Parameters

counterDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterDescription
A counter description (see CounterDescription). Specifies which counter information is to be retrieved about.

Return Value

A CheckCounterData object containing the values associated with the counter

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CounterDescription


GetFormatSupport Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GetFormatSupport Method
D3DDevice Class See Also Send Feedback
Get the support of a given format on the installed video device.

(Also see DirectX SDK: ID3D10Device::CheckFormatSupport)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FormatSupportOptions GetFormatSupport(
    Format format
)
Visual Basic
Public Function GetFormatSupport ( _
    format As Format _
) As FormatSupportOptions
Visual C++
public:
FormatSupportOptions GetFormatSupport(
    Format format
)

Parameters

format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
A Format enumeration that describes a format for which to check for support.

Return Value

A FormatSupportOptions enumeration values describing how the specified format is supported on the installed device. The values are ORed together.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMultisampleQualityLevels Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GetMultisampleQualityLevels Method
D3DDevice Class See Also Send Feedback
Get the number of quality levels available during multisampling.

(Also see DirectX SDK: ID3D10Device::CheckMultisampleQualityLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint GetMultisampleQualityLevels(
    Format format,
    uint sampleCount
)
Visual Basic
Public Function GetMultisampleQualityLevels ( _
    format As Format, _
    sampleCount As UInteger _
) As UInteger
Visual C++
public:
unsigned int GetMultisampleQualityLevels(
    Format format,
    unsigned int sampleCount
)

Parameters

format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
The texture format. See Format.
sampleCount
Type: System..::..UInt32
The number of samples during multisampling.

Return Value

Number of quality levels supported by the adapter.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OpenSharedResource(T) Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..OpenSharedResource<(Of <(<'T>)>)> Method
D3DDevice Class See Also Send Feedback
Give a device access to a shared resource created on a different device.

(Also see DirectX SDK: ID3D10Device::OpenSharedResource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public T OpenSharedResource<T>(
    IntPtr resource
)
where T : DirectUnknown
Visual Basic
Public Function OpenSharedResource(Of T As DirectUnknown) ( _
    resource As IntPtr _
) As T
Visual C++
public:
generic<typename T>
where T : DirectUnknown
T OpenSharedResource(
    IntPtr resource
)

Parameters

resource
Type: System..::..IntPtr
The resource handle.

Type Parameters

T
The type of this shared resource. Must be GraphicsObject

Return Value

The requested resource using the given type.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ResolveSubresource Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..ResolveSubresource Method
D3DDevice Class See Also Send Feedback
Copy a multisampled resource into a non-multisampled resource. This API is most useful when re-using the resulting rendertarget of one render pass as an input to a second render pass.

(Also see DirectX SDK: ID3D10Device::ResolveSubresource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ResolveSubresource(
    D3DResource destinationResource,
    uint destinationSubresource,
    D3DResource sourceResource,
    uint sourceSubresource,
    Format format
)
Visual Basic
Public Sub ResolveSubresource ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    sourceResource As D3DResource, _
    sourceSubresource As UInteger, _
    format As Format _
)
Visual C++
public:
void ResolveSubresource(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    D3DResource^ sourceResource,
    unsigned int sourceSubresource,
    Format format
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Destination resource. Must be a created with the Default flag and be single-sampled. See D3DResource.
destinationSubresource
Type: System..::..UInt32
A zero-based index, that identifies the destination subresource. See D3D10CalcSubresource for more details.
sourceResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Source resource. Must be multisampled.
sourceSubresource
Type: System..::..UInt32
The source subresource of the source resource.
format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
Format that indicates how the multisampled resource will be resolved to a single-sampled resource.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetPredication Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..SetPredication Method
D3DDevice Class See Also Send Feedback
Set a rendering predicate.

(Also see DirectX SDK: ID3D10Device::SetPredication)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetPredication(
    D3DPredicate predicate,
    bool predicateValue
)
Visual Basic
Public Sub SetPredication ( _
    predicate As D3DPredicate, _
    predicateValue As Boolean _
)
Visual C++
public:
void SetPredication(
    D3DPredicate^ predicate,
    bool predicateValue
)

Parameters

predicate
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DPredicate
A predicate (see D3DPredicate). A NULL value indicates "no" predication; in this case, the value of PredicateValue is irrelevent but will be preserved for Device.GetPredication.
predicateValue
Type: System..::..Boolean
If TRUE, rendering will be affected by when the predicate's conditions are met. If FALSE, rendering will be affected when the conditions are not met.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DPredicate


SetSwapChain Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..SetSwapChain Method
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected void SetSwapChain(
    SwapChain newSwapChain
)
Visual Basic
Protected Sub SetSwapChain ( _
    newSwapChain As SwapChain _
)
Visual C++
protected:
void SetSwapChain(
    SwapChain^ newSwapChain
)

Parameters

newSwapChain
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChain

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UpdateSubresource Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..UpdateSubresource Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32) | The CPU copies data from memory to a subresource created in non-mappable memory. Because no destination box is defined, the data is written to the destination subresource with no offset. (Also see DirectX SDK: ID3D10Device::UpdateSubresource)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32, Box) | The CPU copies data from memory to a subresource created in non-mappable memory. (Also see DirectX SDK: ID3D10Device::UpdateSubresource)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UpdateSubresource Method (D3DResource, UInt32, IntPtr, UInt32, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..UpdateSubresource Method (D3DResource, UInt32, IntPtr, UInt32, UInt32)
D3DDevice Class See Also Send Feedback
The CPU copies data from memory to a subresource created in non-mappable memory. Because no destination box is defined, the data is written to the destination subresource with no offset.

(Also see DirectX SDK: ID3D10Device::UpdateSubresource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void UpdateSubresource(
    D3DResource destinationResource,
    uint destinationSubresource,
    IntPtr sourceData,
    uint sourceRowPitch,
    uint sourceDepthPitch
)
Visual Basic
Public Sub UpdateSubresource ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    sourceData As IntPtr, _
    sourceRowPitch As UInteger, _
    sourceDepthPitch As UInteger _
)
Visual C++
public:
void UpdateSubresource(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    IntPtr sourceData,
    unsigned int sourceRowPitch,
    unsigned int sourceDepthPitch
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The destination resource (see D3DResource Object).
destinationSubresource
Type: System..::..UInt32
A zero-based index, that identifies the destination subresource. See D3D10CalcSubresource for more details.
sourceData
Type: System..::..IntPtr
The source data in memory.
sourceRowPitch
Type: System..::..UInt32
The size of one row of the source data.
sourceDepthPitch
Type: System..::..UInt32
The size of one depth slice of source data.

See Also

D3DDevice Class
UpdateSubresource Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UpdateSubresource Method (D3DResource, UInt32, IntPtr, UInt32, UInt32, Box)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..UpdateSubresource Method (D3DResource, UInt32, IntPtr, UInt32, UInt32, Box)
D3DDevice Class See Also Send Feedback
The CPU copies data from memory to a subresource created in non-mappable memory.

(Also see DirectX SDK: ID3D10Device::UpdateSubresource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void UpdateSubresource(
    D3DResource destinationResource,
    uint destinationSubresource,
    IntPtr sourceData,
    uint sourceRowPitch,
    uint sourceDepthPitch,
    Box destinationBox
)
Visual Basic
Public Sub UpdateSubresource ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    sourceData As IntPtr, _
    sourceRowPitch As UInteger, _
    sourceDepthPitch As UInteger, _
    destinationBox As Box _
)
Visual C++
public:
void UpdateSubresource(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    IntPtr sourceData,
    unsigned int sourceRowPitch,
    unsigned int sourceDepthPitch,
    Box destinationBox
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
The destination resource (see D3DResource Object).
destinationSubresource
Type: System..::..UInt32
A zero-based index, that identifies the destination subresource. See D3D10CalcSubresource for more details.
sourceData
Type: System..::..IntPtr
The source data in memory.
sourceRowPitch
Type: System..::..UInt32
The size of one row of the source data.
sourceDepthPitch
Type: System..::..UInt32
The size of one depth slice of source data.
destinationBox
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Box
A box that defines the portion of the destination subresource to copy the resource data into. Coordinates are in bytes for buffers and in texels for textures. The dimensions of the source must fit the destination (see Box).

See Also

D3DDevice Class
UpdateSubresource Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Box


D3DDevice Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice Properties
D3DDevice Class See Also Send Feedback

The D3DDevice type exposes the following members.

Properties

 | Name | Description
Public property | CounterInformation | Gets information about the device's performance counter capabilities (Also see DirectX SDK: ID3D10Device::CheckCounterInfo)
Public property | CreateDeviceOptions | Get the flags used during the call to create the device. (Also see DirectX SDK: ID3D10Device::GetCreationFlags)
Public property | Debug |
Public property | DeviceRemovedReason | Get the reason why the device was removed. (Also see DirectX SDK: ID3D10Device::GetDeviceRemovedReason)
Public property | ExceptionMode | Gets or sets the exception-mode flags. (Also see DirectX SDK: ID3D10Device::GetExceptionMode, ID3D10Device::SetExceptionMode)
Public property | GraphicsDevice | Gets the Graphics Device object for this device
Public property | GraphicsDevice1 |
Public property | GS | Get the associated geometry shader pipeline stage object.
Public property | IA | Get the associated input assembler pipeline stage object.
Public property | InfoQueue | Gets an information queue object that can retrieve, store and filter debug messages.
Public property | Multithread |
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | OM | Get the associated output merger pipeline stage object.
Public property | Predication | Get the rendering predicate state. (Also see DirectX SDK: ID3D10Device::GetPredication)
Public property | PS | Get the associated pixel shader pipeline stage object.
Public property | RS | Get the associated rasterizer pipeline stage object.
Public property | SO | Get the associated stream output pipeline stage object.
Public property | SwapChain |
Public property | SwitchToRef | Gets a switch-to-reference object that enables an application to switch between a hardware and software device.
Public property | VS | Get the associated vertex shader pipeline stage object.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CounterInformation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CounterInformation Property
D3DDevice Class See Also Send Feedback
Gets information about the device's performance counter capabilities

(Also see DirectX SDK: ID3D10Device::CheckCounterInfo)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CounterInformation CounterInformation { get; }
Visual Basic
Public ReadOnly Property CounterInformation As CounterInformation
    Get
Visual C++
public:
property CounterInformation CounterInformation {
    CounterInformation get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDeviceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDeviceOptions Property
D3DDevice Class See Also Send Feedback
Get the flags used during the call to create the device.

(Also see DirectX SDK: ID3D10Device::GetCreationFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CreateDeviceOptions CreateDeviceOptions { get; }
Visual Basic
Public ReadOnly Property CreateDeviceOptions As CreateDeviceOptions
    Get
Visual C++
public:
property CreateDeviceOptions CreateDeviceOptions {
    CreateDeviceOptions get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Debug Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..Debug Property
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DDebug Debug { get; }
Visual Basic
Public ReadOnly Property Debug As D3DDebug
    Get
Visual C++
public:
property D3DDebug^ Debug {
    D3DDebug^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DeviceRemovedReason Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..DeviceRemovedReason Property
D3DDevice Class See Also Send Feedback
Get the reason why the device was removed.

(Also see DirectX SDK: ID3D10Device::GetDeviceRemovedReason)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ErrorCode DeviceRemovedReason { get; }
Visual Basic
Public ReadOnly Property DeviceRemovedReason As ErrorCode
    Get
Visual C++
public:
property ErrorCode DeviceRemovedReason {
    ErrorCode get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ExceptionMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..ExceptionMode Property
D3DDevice Class See Also Send Feedback
Gets or sets the exception-mode flags.

(Also see DirectX SDK: ID3D10Device::GetExceptionMode, ID3D10Device::SetExceptionMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExceptionErrors ExceptionMode { get; set; }
Visual Basic
Public Property ExceptionMode As ExceptionErrors
    Get
    Set
Visual C++
public:
property ExceptionErrors ExceptionMode {
    ExceptionErrors get ();
    void set (ExceptionErrors value);
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GraphicsDevice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GraphicsDevice Property
D3DDevice Class See Also Send Feedback
Gets the Graphics Device object for this device

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Device GraphicsDevice { get; }
Visual Basic
Public ReadOnly Property GraphicsDevice As Device
    Get
Visual C++
public:
property Device^ GraphicsDevice {
    Device^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GraphicsDevice1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GraphicsDevice1 Property
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Device1 GraphicsDevice1 { get; }
Visual Basic
Public ReadOnly Property GraphicsDevice1 As Device1
    Get
Visual C++
public:
property Device1^ GraphicsDevice1 {
    Device1^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GS Property
D3DDevice Class See Also Send Feedback
Get the associated geometry shader pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShaderPipelineStage GS { get; }
Visual Basic
Public ReadOnly Property GS As GeometryShaderPipelineStage
    Get
Visual C++
public:
property GeometryShaderPipelineStage^ GS {
    GeometryShaderPipelineStage^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IA Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..IA Property
D3DDevice Class See Also Send Feedback
Get the associated input assembler pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputAssemblerPipelineStage IA { get; }
Visual Basic
Public ReadOnly Property IA As InputAssemblerPipelineStage
    Get
Visual C++
public:
property InputAssemblerPipelineStage^ IA {
    InputAssemblerPipelineStage^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InfoQueue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..InfoQueue Property
D3DDevice Class See Also Send Feedback
Gets an information queue object that can retrieve, store and filter debug messages.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InfoQueue InfoQueue { get; }
Visual Basic
Public ReadOnly Property InfoQueue As InfoQueue
    Get
Visual C++
public:
property InfoQueue^ InfoQueue {
    InfoQueue^ get ();
}

Return Value

An InfoQueue (information queue) object.

Remarks

Can only be obtained if the device was created using CreateDeviceOptions.Debug flag. Otherwise, throws an exception.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Multithread Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..Multithread Property
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Multithread Multithread { get; }
Visual Basic
Public ReadOnly Property Multithread As Multithread
    Get
Visual C++
public:
property Multithread^ Multithread {
    Multithread^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OM Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..OM Property
D3DDevice Class See Also Send Feedback
Get the associated output merger pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerPipelineStage OM { get; }
Visual Basic
Public ReadOnly Property OM As OutputMergerPipelineStage
    Get
Visual C++
public:
property OutputMergerPipelineStage^ OM {
    OutputMergerPipelineStage^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Predication Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..Predication Property
D3DDevice Class See Also Send Feedback
Get the rendering predicate state.

(Also see DirectX SDK: ID3D10Device::GetPredication)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DPredicate Predication { get; set; }
Visual Basic
Public Property Predication As D3DPredicate
    Get
    Set
Visual C++
public:
property D3DPredicate^ Predication {
    D3DPredicate^ get ();
    void set (D3DPredicate^ value);
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..PS Property
D3DDevice Class See Also Send Feedback
Get the associated pixel shader pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShaderPipelineStage PS { get; }
Visual Basic
Public ReadOnly Property PS As PixelShaderPipelineStage
    Get
Visual C++
public:
property PixelShaderPipelineStage^ PS {
    PixelShaderPipelineStage^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..RS Property
D3DDevice Class See Also Send Feedback
Get the associated rasterizer pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerPipelineStage RS { get; }
Visual Basic
Public ReadOnly Property RS As RasterizerPipelineStage
    Get
Visual C++
public:
property RasterizerPipelineStage^ RS {
    RasterizerPipelineStage^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SO Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..SO Property
D3DDevice Class See Also Send Feedback
Get the associated stream output pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StreamOutputPipelineStage SO { get; }
Visual Basic
Public ReadOnly Property SO As StreamOutputPipelineStage
    Get
Visual C++
public:
property StreamOutputPipelineStage^ SO {
    StreamOutputPipelineStage^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SwapChain Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..SwapChain Property
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwapChain SwapChain { get; }
Visual Basic
Public ReadOnly Property SwapChain As SwapChain
    Get
Visual C++
public:
property SwapChain^ SwapChain {
    SwapChain^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SwitchToRef Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..SwitchToRef Property
D3DDevice Class See Also Send Feedback
Gets a switch-to-reference object that enables an application to switch between a hardware and software device.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwitchToRef SwitchToRef { get; }
Visual Basic
Public ReadOnly Property SwitchToRef As SwitchToRef
    Get
Visual C++
public:
property SwitchToRef^ SwitchToRef {
    SwitchToRef^ get ();
}

Return Value

A SwitchToRef (switch-to-reference) object.

Remarks

Can only be obtained if the device was created using CreateDeviceOptions.SwitchToRef flag. Otherwise, throws an exception.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..VS Property
D3DDevice Class See Also Send Feedback
Get the associated vertex shader pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShaderPipelineStage VS { get; }
Visual Basic
Public ReadOnly Property VS As VertexShaderPipelineStage
    Get
Visual C++
public:
property VertexShaderPipelineStage^ VS {
    VertexShaderPipelineStage^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDevice1 Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1 Class
Members See Also Send Feedback
The device interface represents a virtual adapter for Direct3D 10.1; it is used to perform rendering and create Direct3D resources.

To create a D3DDevice1 instance, use one of the static factory method overloads: CreateDevice1() or CreateDeviceAndSwapChain1().

(Also see DirectX SDK: ID3D10Device1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DDevice1 : D3DDevice
Visual Basic
Public Class D3DDevice1 _
    Inherits D3DDevice
Visual C++
public ref class D3DDevice1 : public D3DDevice

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDevice
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDevice1

See Also

D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDevice1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1 Members
D3DDevice1 Class Methods Properties See Also Send Feedback

The D3DDevice1 type exposes the following members.

Methods

 | Name | Description
Public method | ClearDepthStencilView | Clears the depth-stencil resource. (Also see DirectX SDK: ID3D10Device::ClearDepthStencilView) (Inherited from D3DDevice.)
Public method | ClearRenderTargetView | Set all the elements in a render target to one value. (Also see DirectX SDK: ID3D10DeviceContext::ClearRenderTargetView) (Inherited from D3DDevice.)
Public method | ClearState | Restore all default device settings; return the device to the state it was in when it was created. This will set all set all input/output resource slots, shaders, input layouts, predications, scissor rectangles, depth-stencil state, rasterizer state, blend state, sampler state, and viewports to NULL. The primitive topology will be set to UNDEFINED. (Also see DirectX SDK: ID3D10Device::ClearState) (Inherited from D3DDevice.)
Public method | CopyResource | Copy the entire contents of the source resource to the destination resource using the GPU. (Also see DirectX SDK: ID3D10Device::CopyResource) (Inherited from D3DDevice.)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32) | Copy a region from a source resource to a destination resource. The entire source subresource is copied. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion) (Inherited from D3DDevice.)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box) | Copy a region from a source resource to a destination resource. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion) (Inherited from D3DDevice.)
Public method | CreateBlendState | Create a blend-state object that encapsules blend state for the output-merger stage. (Also see DirectX SDK: ID3D10Device::CreateBlendState) (Inherited from D3DDevice.)
Public method | CreateBlendState1 | Create a blend-state object that encapsules blend state for the output-merger stage. (Also see DirectX SDK: ID3D10Device1::CreateBlendState1)
Public method | CreateBuffer(BufferDescription) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer) with no initial data. (Also see DirectX SDK: ID3D10Device::CreateBuffer) (Inherited from D3DDevice.)
Public method | CreateBuffer(BufferDescription, array<SubresourceData>[]()[][]) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). (Also see DirectX SDK: ID3D10Device::CreateBuffer) (Inherited from D3DDevice.)
Public method | CreateCounter | Create a counter object for measuring GPU performance. (Also see DirectX SDK: ID3D10Device::CreateCounter) (Inherited from D3DDevice.)
Public method | CreateDepthStencilState | Create a depth-stencil state object that encapsulates depth-stencil test information for the output-merger stage. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilState) (Inherited from D3DDevice.)
Public method | CreateDepthStencilView(D3DResource) | Create a depth-stencil view for accessing resource data. This method creates a view that accesses mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView) (Inherited from D3DDevice.)
Public method | CreateDepthStencilView(D3DResource, DepthStencilViewDescription) | Create a depth-stencil view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView) (Inherited from D3DDevice.)
 | CreateDevice1()()()() | Create a Direct3D 10.1 device using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDevice1() function)
 | CreateDevice1(Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel) | Create a Direct3D 10.1 device. (Also see DirectX SDK: D3D10CreateDevice1() function)
 | CreateDeviceAndSwapChain1(IntPtr) | Create a Direct3D 10.1 device and a swap chain using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain1() function)
 | CreateDeviceAndSwapChain1(Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel, SwapChainDescription) | Create a Direct3D 10.1 device and a swap chain. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain1() function)
Public method | CreateEffectFromCompiledBinary(BinaryReader) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function) (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(Stream) | Loads a precompiled effect from a binary data stream. (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(String) | Loads a precompiled effect from a file. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function) (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(Stream, Int32, EffectPool) | Loads a precompiled effect from a binary data stream. (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(BinaryReader, Int32, EffectPool) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function) (Overrides D3DDevice..::..CreateEffectFromCompiledBinary(BinaryReader, Int32, EffectPool).)
Public method | CreateGeometryShader(Stream) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader) (Inherited from D3DDevice.)
Public method | CreateGeometryShader(IntPtr, UInt32) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader) (Inherited from D3DDevice.)
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) | (Inherited from D3DDevice.)
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) | (Inherited from D3DDevice.)
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), Stream) | (Inherited from D3DDevice.)
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), IntPtr, UInt32) | (Inherited from D3DDevice.)
Public method | CreatePixelShader(Stream) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader) (Inherited from D3DDevice.)
Public method | CreatePixelShader(IntPtr, UInt32) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader) (Inherited from D3DDevice.)
Public method | CreatePredicate | Creates a predicate. (Also see DirectX SDK: ID3D10Device::CreatePredicate) (Inherited from D3DDevice.)
Public method | CreateQuery | This class encapsulates methods for querying information from the GPU. (Also see DirectX SDK: ID3D10Device::CreateQuery) (Inherited from D3DDevice.)
Public method | CreateRasterizerState | Create a rasterizer state object that tells the rasterizer stage how to behave. (Also see DirectX SDK: ID3D10Device::CreateRasterizerState) (Inherited from D3DDevice.)
Public method | CreateRenderTargetView(D3DResource) | Create a render-target view for accessing resource data in mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView) (Inherited from D3DDevice.)
Public method | CreateRenderTargetView(D3DResource, RenderTargetViewDescription) | Create a render-target view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView) (Inherited from D3DDevice.)
Public method | CreateSamplerState | Create a sampler-state object that encapsulates sampling information for a texture. (Also see DirectX SDK: ID3D10Device::CreateSamplerState) (Inherited from D3DDevice.)
Public method | CreateShaderResourceView(D3DResource) | Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView) (Inherited from D3DDevice.)
Public method | CreateShaderResourceView(D3DResource, ShaderResourceViewDescription) | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView) (Inherited from D3DDevice.)
Public method | CreateShaderResourceView1 | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D10Device1::CreateShaderResourceView1)
Public method | CreateStateBlock | Create a state block. (Inherited from D3DDevice.)
Public method | CreateTexture1D(Texture1DDescription) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D) (Inherited from D3DDevice.)
Public method | CreateTexture1D(Texture1DDescription, array<SubresourceData>[]()[][]) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D) (Inherited from D3DDevice.)
Public method | CreateTexture2D(Texture2DDescription) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D) (Inherited from D3DDevice.)
Public method | CreateTexture2D(Texture2DDescription, array<SubresourceData>[]()[][]) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D) (Inherited from D3DDevice.)
Public method | CreateTexture3D(Texture3DDescription) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D) (Inherited from D3DDevice.)
Public method | CreateTexture3D(Texture3DDescription, array<SubresourceData>[]()[][]) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D) (Inherited from D3DDevice.)
Public method | CreateVertexShader(Stream) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader) (Inherited from D3DDevice.)
Public method | CreateVertexShader(IntPtr, UInt32) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader) (Inherited from D3DDevice.)
Public method | Draw | Draw non-indexed, non-instanced primitives. (Also see DirectX SDK: ID3D10Device::Draw) (Inherited from D3DDevice.)
Public method | DrawAuto | Draw geometry of an unknown size that was created by the geometry shader stage. (Also see DirectX SDK: ID3D10Device::DrawAuto) (Inherited from D3DDevice.)
Public method | DrawIndexed | Draw indexed, non-instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawIndexed) (Inherited from D3DDevice.)
Public method | DrawIndexedInstanced | Draw indexed, instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawIndexedInstanced) (Inherited from D3DDevice.)
Public method | DrawInstanced | Draw non-indexed, instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawInstanced) (Inherited from D3DDevice.)
Public method | Flush | Send queued-up commands in the command buffer to the GPU. (Also see DirectX SDK: ID3D10Device::Flush) (Inherited from D3DDevice.)
Public method | GenerateMips | Generate mipmaps for the given shader resource. (Also see DirectX SDK: ID3D10Device::GenerateMips) (Inherited from D3DDevice.)
Public method | GetCounterData | Get the type, name, units of measure, and a description of an existing counter. (Also see DirectX SDK: ID3D10Device::CheckCounter) (Inherited from D3DDevice.)
Public method | GetFormatSupport | Get the support of a given format on the installed video device. (Also see DirectX SDK: ID3D10Device::CheckFormatSupport) (Inherited from D3DDevice.)
Public method | GetMultisampleQualityLevels | Get the number of quality levels available during multisampling. (Also see DirectX SDK: ID3D10Device::CheckMultisampleQualityLevels) (Inherited from D3DDevice.)
Public method | OpenSharedResource<(Of <<'(T>)>>) | Give a device access to a shared resource created on a different device. (Also see DirectX SDK: ID3D10Device::OpenSharedResource) (Inherited from D3DDevice.)
Public method | ResolveSubresource | Copy a multisampled resource into a non-multisampled resource. This API is most useful when re-using the resulting rendertarget of one render pass as an input to a second render pass. (Also see DirectX SDK: ID3D10Device::ResolveSubresource) (Inherited from D3DDevice.)
Public method | SetPredication | Set a rendering predicate. (Also see DirectX SDK: ID3D10Device::SetPredication) (Inherited from D3DDevice.)
Protected method | SetSwapChain | (Inherited from D3DDevice.)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32) | The CPU copies data from memory to a subresource created in non-mappable memory. Because no destination box is defined, the data is written to the destination subresource with no offset. (Also see DirectX SDK: ID3D10Device::UpdateSubresource) (Inherited from D3DDevice.)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32, Box) | The CPU copies data from memory to a subresource created in non-mappable memory. (Also see DirectX SDK: ID3D10Device::UpdateSubresource) (Inherited from D3DDevice.)

Properties

 | Name | Description
Public property | CounterInformation | Gets information about the device's performance counter capabilities (Also see DirectX SDK: ID3D10Device::CheckCounterInfo) (Inherited from D3DDevice.)
Public property | CreateDeviceOptions | Get the flags used during the call to create the device. (Also see DirectX SDK: ID3D10Device::GetCreationFlags) (Inherited from D3DDevice.)
Public property | Debug | (Inherited from D3DDevice.)
Public property | DeviceFeatureLevel | Gets the feature level of the hardware device.
Public property | DeviceRemovedReason | Get the reason why the device was removed. (Also see DirectX SDK: ID3D10Device::GetDeviceRemovedReason) (Inherited from D3DDevice.)
Public property | ExceptionMode | Gets or sets the exception-mode flags. (Also see DirectX SDK: ID3D10Device::GetExceptionMode, ID3D10Device::SetExceptionMode) (Inherited from D3DDevice.)
Public property | GraphicsDevice | Gets the Graphics Device object for this device (Inherited from D3DDevice.)
Public property | GraphicsDevice1 | (Inherited from D3DDevice.)
Public property | GS | Get the associated geometry shader pipeline stage object. (Inherited from D3DDevice.)
Public property | IA | Get the associated input assembler pipeline stage object. (Inherited from D3DDevice.)
Public property | InfoQueue | Gets an information queue object that can retrieve, store and filter debug messages. (Inherited from D3DDevice.)
Public property | Multithread | (Inherited from D3DDevice.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | OM | Get the associated output merger pipeline stage object. (Inherited from D3DDevice.)
Public property | Predication | Get the rendering predicate state. (Also see DirectX SDK: ID3D10Device::GetPredication) (Inherited from D3DDevice.)
Public property | PS | Get the associated pixel shader pipeline stage object. (Inherited from D3DDevice.)
Public property | RS | Get the associated rasterizer pipeline stage object. (Inherited from D3DDevice.)
Public property | SO | Get the associated stream output pipeline stage object. (Inherited from D3DDevice.)
Public property | SwapChain | (Inherited from D3DDevice.)
Public property | SwitchToRef | Gets a switch-to-reference object that enables an application to switch between a hardware and software device. (Inherited from D3DDevice.)
Public property | VS | Get the associated vertex shader pipeline stage object. (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDevice1 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1 Methods
D3DDevice1 Class See Also Send Feedback

The D3DDevice1 type exposes the following members.

Methods

 | Name | Description
Public method | ClearDepthStencilView | Clears the depth-stencil resource. (Also see DirectX SDK: ID3D10Device::ClearDepthStencilView) (Inherited from D3DDevice.)
Public method | ClearRenderTargetView | Set all the elements in a render target to one value. (Also see DirectX SDK: ID3D10DeviceContext::ClearRenderTargetView) (Inherited from D3DDevice.)
Public method | ClearState | Restore all default device settings; return the device to the state it was in when it was created. This will set all set all input/output resource slots, shaders, input layouts, predications, scissor rectangles, depth-stencil state, rasterizer state, blend state, sampler state, and viewports to NULL. The primitive topology will be set to UNDEFINED. (Also see DirectX SDK: ID3D10Device::ClearState) (Inherited from D3DDevice.)
Public method | CopyResource | Copy the entire contents of the source resource to the destination resource using the GPU. (Also see DirectX SDK: ID3D10Device::CopyResource) (Inherited from D3DDevice.)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32) | Copy a region from a source resource to a destination resource. The entire source subresource is copied. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion) (Inherited from D3DDevice.)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box) | Copy a region from a source resource to a destination resource. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion) (Inherited from D3DDevice.)
Public method | CreateBlendState | Create a blend-state object that encapsules blend state for the output-merger stage. (Also see DirectX SDK: ID3D10Device::CreateBlendState) (Inherited from D3DDevice.)
Public method | CreateBlendState1 | Create a blend-state object that encapsules blend state for the output-merger stage. (Also see DirectX SDK: ID3D10Device1::CreateBlendState1)
Public method | CreateBuffer(BufferDescription) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer) with no initial data. (Also see DirectX SDK: ID3D10Device::CreateBuffer) (Inherited from D3DDevice.)
Public method | CreateBuffer(BufferDescription, array<SubresourceData>[]()[][]) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). (Also see DirectX SDK: ID3D10Device::CreateBuffer) (Inherited from D3DDevice.)
Public method | CreateCounter | Create a counter object for measuring GPU performance. (Also see DirectX SDK: ID3D10Device::CreateCounter) (Inherited from D3DDevice.)
Public method | CreateDepthStencilState | Create a depth-stencil state object that encapsulates depth-stencil test information for the output-merger stage. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilState) (Inherited from D3DDevice.)
Public method | CreateDepthStencilView(D3DResource) | Create a depth-stencil view for accessing resource data. This method creates a view that accesses mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView) (Inherited from D3DDevice.)
Public method | CreateDepthStencilView(D3DResource, DepthStencilViewDescription) | Create a depth-stencil view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView) (Inherited from D3DDevice.)
 | CreateDevice1()()()() | Create a Direct3D 10.1 device using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDevice1() function)
 | CreateDevice1(Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel) | Create a Direct3D 10.1 device. (Also see DirectX SDK: D3D10CreateDevice1() function)
 | CreateDeviceAndSwapChain1(IntPtr) | Create a Direct3D 10.1 device and a swap chain using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain1() function)
 | CreateDeviceAndSwapChain1(Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel, SwapChainDescription) | Create a Direct3D 10.1 device and a swap chain. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain1() function)
Public method | CreateEffectFromCompiledBinary(BinaryReader) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function) (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(Stream) | Loads a precompiled effect from a binary data stream. (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(String) | Loads a precompiled effect from a file. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function) (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(Stream, Int32, EffectPool) | Loads a precompiled effect from a binary data stream. (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(BinaryReader, Int32, EffectPool) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function) (Overrides D3DDevice..::..CreateEffectFromCompiledBinary(BinaryReader, Int32, EffectPool).)
Public method | CreateGeometryShader(Stream) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader) (Inherited from D3DDevice.)
Public method | CreateGeometryShader(IntPtr, UInt32) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader) (Inherited from D3DDevice.)
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) | (Inherited from D3DDevice.)
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) | (Inherited from D3DDevice.)
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), Stream) | (Inherited from D3DDevice.)
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), IntPtr, UInt32) | (Inherited from D3DDevice.)
Public method | CreatePixelShader(Stream) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader) (Inherited from D3DDevice.)
Public method | CreatePixelShader(IntPtr, UInt32) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader) (Inherited from D3DDevice.)
Public method | CreatePredicate | Creates a predicate. (Also see DirectX SDK: ID3D10Device::CreatePredicate) (Inherited from D3DDevice.)
Public method | CreateQuery | This class encapsulates methods for querying information from the GPU. (Also see DirectX SDK: ID3D10Device::CreateQuery) (Inherited from D3DDevice.)
Public method | CreateRasterizerState | Create a rasterizer state object that tells the rasterizer stage how to behave. (Also see DirectX SDK: ID3D10Device::CreateRasterizerState) (Inherited from D3DDevice.)
Public method | CreateRenderTargetView(D3DResource) | Create a render-target view for accessing resource data in mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView) (Inherited from D3DDevice.)
Public method | CreateRenderTargetView(D3DResource, RenderTargetViewDescription) | Create a render-target view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView) (Inherited from D3DDevice.)
Public method | CreateSamplerState | Create a sampler-state object that encapsulates sampling information for a texture. (Also see DirectX SDK: ID3D10Device::CreateSamplerState) (Inherited from D3DDevice.)
Public method | CreateShaderResourceView(D3DResource) | Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView) (Inherited from D3DDevice.)
Public method | CreateShaderResourceView(D3DResource, ShaderResourceViewDescription) | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView) (Inherited from D3DDevice.)
Public method | CreateShaderResourceView1 | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D10Device1::CreateShaderResourceView1)
Public method | CreateStateBlock | Create a state block. (Inherited from D3DDevice.)
Public method | CreateTexture1D(Texture1DDescription) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D) (Inherited from D3DDevice.)
Public method | CreateTexture1D(Texture1DDescription, array<SubresourceData>[]()[][]) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D) (Inherited from D3DDevice.)
Public method | CreateTexture2D(Texture2DDescription) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D) (Inherited from D3DDevice.)
Public method | CreateTexture2D(Texture2DDescription, array<SubresourceData>[]()[][]) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D) (Inherited from D3DDevice.)
Public method | CreateTexture3D(Texture3DDescription) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D) (Inherited from D3DDevice.)
Public method | CreateTexture3D(Texture3DDescription, array<SubresourceData>[]()[][]) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D) (Inherited from D3DDevice.)
Public method | CreateVertexShader(Stream) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader) (Inherited from D3DDevice.)
Public method | CreateVertexShader(IntPtr, UInt32) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader) (Inherited from D3DDevice.)
Public method | Draw | Draw non-indexed, non-instanced primitives. (Also see DirectX SDK: ID3D10Device::Draw) (Inherited from D3DDevice.)
Public method | DrawAuto | Draw geometry of an unknown size that was created by the geometry shader stage. (Also see DirectX SDK: ID3D10Device::DrawAuto) (Inherited from D3DDevice.)
Public method | DrawIndexed | Draw indexed, non-instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawIndexed) (Inherited from D3DDevice.)
Public method | DrawIndexedInstanced | Draw indexed, instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawIndexedInstanced) (Inherited from D3DDevice.)
Public method | DrawInstanced | Draw non-indexed, instanced primitives. (Also see DirectX SDK: ID3D10Device::DrawInstanced) (Inherited from D3DDevice.)
Public method | Flush | Send queued-up commands in the command buffer to the GPU. (Also see DirectX SDK: ID3D10Device::Flush) (Inherited from D3DDevice.)
Public method | GenerateMips | Generate mipmaps for the given shader resource. (Also see DirectX SDK: ID3D10Device::GenerateMips) (Inherited from D3DDevice.)
Public method | GetCounterData | Get the type, name, units of measure, and a description of an existing counter. (Also see DirectX SDK: ID3D10Device::CheckCounter) (Inherited from D3DDevice.)
Public method | GetFormatSupport | Get the support of a given format on the installed video device. (Also see DirectX SDK: ID3D10Device::CheckFormatSupport) (Inherited from D3DDevice.)
Public method | GetMultisampleQualityLevels | Get the number of quality levels available during multisampling. (Also see DirectX SDK: ID3D10Device::CheckMultisampleQualityLevels) (Inherited from D3DDevice.)
Public method | OpenSharedResource<(Of <<'(T>)>>) | Give a device access to a shared resource created on a different device. (Also see DirectX SDK: ID3D10Device::OpenSharedResource) (Inherited from D3DDevice.)
Public method | ResolveSubresource | Copy a multisampled resource into a non-multisampled resource. This API is most useful when re-using the resulting rendertarget of one render pass as an input to a second render pass. (Also see DirectX SDK: ID3D10Device::ResolveSubresource) (Inherited from D3DDevice.)
Public method | SetPredication | Set a rendering predicate. (Also see DirectX SDK: ID3D10Device::SetPredication) (Inherited from D3DDevice.)
Protected method | SetSwapChain | (Inherited from D3DDevice.)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32) | The CPU copies data from memory to a subresource created in non-mappable memory. Because no destination box is defined, the data is written to the destination subresource with no offset. (Also see DirectX SDK: ID3D10Device::UpdateSubresource) (Inherited from D3DDevice.)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32, Box) | The CPU copies data from memory to a subresource created in non-mappable memory. (Also see DirectX SDK: ID3D10Device::UpdateSubresource) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CopySubresourceRegion Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CopySubresourceRegion Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32) | Copy a region from a source resource to a destination resource. The entire source subresource is copied. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion) (Inherited from D3DDevice.)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box) | Copy a region from a source resource to a destination resource. (Also see DirectX SDK: ID3D10Device::CopySubresourceRegion) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateBlendState1 Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateBlendState1 Method
D3DDevice1 Class See Also Send Feedback
Create a blend-state object that encapsules blend state for the output-merger stage.

(Also see DirectX SDK: ID3D10Device1::CreateBlendState1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendState1 CreateBlendState1(
    BlendDescription1 blendStateDescription
)
Visual Basic
Public Function CreateBlendState1 ( _
    blendStateDescription As BlendDescription1 _
) As BlendState1
Visual C++
public:
BlendState1^ CreateBlendState1(
    BlendDescription1 blendStateDescription
)

Parameters

blendStateDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendDescription1
A blend-state description (see BlendDescription1).

Return Value

A blend-state object created (see BlendState1 Object).

See Also

D3DDevice1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendDescription1


CreateBuffer Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateBuffer Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBuffer(BufferDescription) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer) with no initial data. (Also see DirectX SDK: ID3D10Device::CreateBuffer) (Inherited from D3DDevice.)
Public method | CreateBuffer(BufferDescription, array<SubresourceData>[]()[][]) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). (Also see DirectX SDK: ID3D10Device::CreateBuffer) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDepthStencilView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateDepthStencilView Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDepthStencilView(D3DResource) | Create a depth-stencil view for accessing resource data. This method creates a view that accesses mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView) (Inherited from D3DDevice.)
Public method | CreateDepthStencilView(D3DResource, DepthStencilViewDescription) | Create a depth-stencil view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateDepthStencilView) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDevice1 Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateDevice1 Method
D3DDevice1 Class See Also Send Feedback

Overload List

Name | Description
CreateDevice1()()()() | Create a Direct3D 10.1 device using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDevice1() function)
CreateDevice1(Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel) | Create a Direct3D 10.1 device. (Also see DirectX SDK: D3D10CreateDevice1() function)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDevice1 Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateDevice1 Method
D3DDevice1 Class See Also Send Feedback
Create a Direct3D 10.1 device using the default hardware adapter and the most common settings.

(Also see DirectX SDK: D3D10CreateDevice1() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice1 CreateDevice1()
Visual Basic
Public Shared Function CreateDevice1 As D3DDevice1
Visual C++
public:
static D3DDevice1^ CreateDevice1()

Return Value

The created Direct3D 10.1 Device

Remarks

If DirectX SDK environment variable is found, and the build is a Debug one, this method will attempt to use CreateDeviceOptions.Debug flag. This should allow using the InfoQueue object.

See Also

D3DDevice1 Class
CreateDevice1 Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDevice1 Method (Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateDevice1 Method (Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel)
D3DDevice1 Class See Also Send Feedback
Create a Direct3D 10.1 device.

(Also see DirectX SDK: D3D10CreateDevice1() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice1 CreateDevice1(
    Adapter adapter,
    DriverType driverType,
    string softwareRasterizerLibrary,
    CreateDeviceOptions options,
    FeatureLevel hardwareLevel
)
Visual Basic
Public Shared Function CreateDevice1 ( _
    adapter As Adapter, _
    driverType As DriverType, _
    softwareRasterizerLibrary As String, _
    options As CreateDeviceOptions, _
    hardwareLevel As FeatureLevel _
) As D3DDevice1
Visual C++
public:
static D3DDevice1^ CreateDevice1(
    Adapter^ adapter,
    DriverType driverType,
    String^ softwareRasterizerLibrary,
    CreateDeviceOptions options,
    FeatureLevel hardwareLevel
)

Parameters

adapter
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter
An Adapter object. Can be null.
driverType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DriverType
The type of driver for the device.
softwareRasterizerLibrary
Type: System..::..String
A path the DLL that implements a software rasterizer. Must be NULL if driverType is non-software.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CreateDeviceOptions
Device creation flags that enable API layers. These flags can be bitwise OR'd together.
hardwareLevel
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..FeatureLevel
The highest hardware feature level supported by this device.

Return Value

The created Direct3D 10.1 Device

Remarks

By default, all Direct3D 10 calls are handled in a thread-safe way. By creating a single-threaded device (using CreateDeviceOptions.SingleThreaded), you disable thread-safe calling.

See Also

D3DDevice1 Class
CreateDevice1 Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDeviceAndSwapChain1 Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateDeviceAndSwapChain1 Method
D3DDevice1 Class See Also Send Feedback

Overload List

Name | Description
CreateDeviceAndSwapChain1(IntPtr) | Create a Direct3D 10.1 device and a swap chain using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain1() function)
CreateDeviceAndSwapChain1(Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel, SwapChainDescription) | Create a Direct3D 10.1 device and a swap chain. (Also see DirectX SDK: D3D10CreateDeviceAndSwapChain1() function)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDeviceAndSwapChain1 Method (IntPtr)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateDeviceAndSwapChain1 Method (IntPtr)
D3DDevice1 Class See Also Send Feedback
Create a Direct3D 10.1 device and a swap chain using the default hardware adapter and the most common settings.

(Also see DirectX SDK: D3D10CreateDeviceAndSwapChain1() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice1 CreateDeviceAndSwapChain1(
    IntPtr windowHandle
)
Visual Basic
Public Shared Function CreateDeviceAndSwapChain1 ( _
    windowHandle As IntPtr _
) As D3DDevice1
Visual C++
public:
static D3DDevice1^ CreateDeviceAndSwapChain1(
    IntPtr windowHandle
)

Parameters

windowHandle
Type: System..::..IntPtr
The window handle to the output window.

Return Value

The created Direct3D 10.1 Device

Remarks

The swap chain created can be retrieved from the SwapChain property. If DirectX SDK environment variable is found, and the build is a Debug one, this method will attempt to use CreateDeviceOptions.Debug flag. This should allow using the InfoQueue object.

See Also

D3DDevice1 Class
CreateDeviceAndSwapChain1 Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateDeviceAndSwapChain1 Method (Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel, SwapChainDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateDeviceAndSwapChain1 Method (Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel, SwapChainDescription)
D3DDevice1 Class See Also Send Feedback
Create a Direct3D 10.1 device and a swap chain.

(Also see DirectX SDK: D3D10CreateDeviceAndSwapChain1() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice1 CreateDeviceAndSwapChain1(
    Adapter adapter,
    DriverType driverType,
    string softwareRasterizerLibrary,
    CreateDeviceOptions options,
    FeatureLevel hardwareLevel,
    SwapChainDescription swapChainDescription
)
Visual Basic
Public Shared Function CreateDeviceAndSwapChain1 ( _
    adapter As Adapter, _
    driverType As DriverType, _
    softwareRasterizerLibrary As String, _
    options As CreateDeviceOptions, _
    hardwareLevel As FeatureLevel, _
    swapChainDescription As SwapChainDescription _
) As D3DDevice1
Visual C++
public:
static D3DDevice1^ CreateDeviceAndSwapChain1(
    Adapter^ adapter,
    DriverType driverType,
    String^ softwareRasterizerLibrary,
    CreateDeviceOptions options,
    FeatureLevel hardwareLevel,
    SwapChainDescription swapChainDescription
)

Parameters

adapter
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter
An Adapter object. Can be null.
driverType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DriverType
The type of driver for the device.
softwareRasterizerLibrary
Type: System..::..String
A path the DLL that implements a software rasterizer. Must be NULL if driverType is non-software.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..CreateDeviceOptions
Device creation flags that enable API layers. These flags can be bitwise OR'd together.
hardwareLevel
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..FeatureLevel
The feature level supported by this device.
swapChainDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChainDescription
Description of the swap chain.

Return Value

The created Direct3D 10.1 Device

Remarks

The swap chain created can be retrieved from the SwapChain property. By default, all Direct3D 10 calls are handled in a thread-safe way. By creating a single-threaded device (using CreateDeviceOptions.SingleThreaded), you disable thread-safe calling.

See Also

D3DDevice1 Class
CreateDeviceAndSwapChain1 Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateEffectFromCompiledBinary Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateEffectFromCompiledBinary Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateEffectFromCompiledBinary(BinaryReader) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function) (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(Stream) | Loads a precompiled effect from a binary data stream. (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(String) | Loads a precompiled effect from a file. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function) (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(Stream, Int32, EffectPool) | Loads a precompiled effect from a binary data stream. (Inherited from D3DDevice.)
Public method | CreateEffectFromCompiledBinary(BinaryReader, Int32, EffectPool) | Loads a precompiled effect from a binary data stream. (Also see DirectX SDK: D3D10CreateEffectFromMemory() function) (Overrides D3DDevice..::..CreateEffectFromCompiledBinary(BinaryReader, Int32, EffectPool).)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateEffectFromCompiledBinary Method (BinaryReader, Int32, EffectPool)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateEffectFromCompiledBinary Method (BinaryReader, Int32, EffectPool)
D3DDevice1 Class See Also Send Feedback
Loads a precompiled effect from a binary data stream.

(Also see DirectX SDK: D3D10CreateEffectFromMemory() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override Effect CreateEffectFromCompiledBinary(
    BinaryReader binaryEffect,
    int effectCompileOptions,
    EffectPool effectPool
)
Visual Basic
Public Overrides Function CreateEffectFromCompiledBinary ( _
    binaryEffect As BinaryReader, _
    effectCompileOptions As Integer, _
    effectPool As EffectPool _
) As Effect
Visual C++
public:
virtual Effect^ CreateEffectFromCompiledBinary(
    BinaryReader^ binaryEffect,
    int effectCompileOptions,
    EffectPool^ effectPool
) override

Parameters

binaryEffect
Type: System.IO..::..BinaryReader
The binary data stream.
effectCompileOptions
Type: System..::..Int32
Effect compile options
effectPool
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectPool
A memory space for effect variables shared across effects.

See Also

D3DDevice1 Class
CreateEffectFromCompiledBinary Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateGeometryShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateGeometryShader Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateGeometryShader(Stream) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader) (Inherited from D3DDevice.)
Public method | CreateGeometryShader(IntPtr, UInt32) | Create a geometry shader. (Also see DirectX SDK: ID3D10Device::CreateGeometryShader) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateGeometryShaderWithStreamOutput Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateGeometryShaderWithStreamOutput Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) | (Inherited from D3DDevice.)
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), UInt32) | (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateInputLayout Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateInputLayout Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), Stream) | (Inherited from D3DDevice.)
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), IntPtr, UInt32) | (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreatePixelShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreatePixelShader Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreatePixelShader(Stream) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader) (Inherited from D3DDevice.)
Public method | CreatePixelShader(IntPtr, UInt32) | Create a pixel shader. (Also see DirectX SDK: ID3D10Device::CreatePixelShader) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateRenderTargetView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateRenderTargetView Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRenderTargetView(D3DResource) | Create a render-target view for accessing resource data in mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView) (Inherited from D3DDevice.)
Public method | CreateRenderTargetView(D3DResource, RenderTargetViewDescription) | Create a render-target view for accessing resource data. (Also see DirectX SDK: ID3D10Device::CreateRenderTargetView) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateShaderResourceView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateShaderResourceView Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateShaderResourceView(D3DResource) | Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView) (Inherited from D3DDevice.)
Public method | CreateShaderResourceView(D3DResource, ShaderResourceViewDescription) | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D10Device::CreateShaderResourceView) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateShaderResourceView1 Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateShaderResourceView1 Method
D3DDevice1 Class See Also Send Feedback
Create a shader-resource view for accessing data in a resource.

(Also see DirectX SDK: ID3D10Device1::CreateShaderResourceView1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceView1 CreateShaderResourceView1(
    D3DResource resource,
    ShaderResourceViewDescription1 description
)
Visual Basic
Public Function CreateShaderResourceView1 ( _
    resource As D3DResource, _
    description As ShaderResourceViewDescription1 _
) As ShaderResourceView1
Visual C++
public:
ShaderResourceView1^ CreateShaderResourceView1(
    D3DResource^ resource,
    ShaderResourceViewDescription1 description
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Pointer to the resource that will serve as input to a shader. This resource must have been created with the ShaderResource flag.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceViewDescription1
A shader-resource-view description (see ShaderResourceViewDescription1). Set this parameter to NULL to create a view that accesses the entire resource (using the format the resource was created with).

Return Value

A shader-resource view (see ShaderResourceView1)

See Also

D3DDevice1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceViewDescription1


CreateTexture1D Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateTexture1D Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTexture1D(Texture1DDescription) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D) (Inherited from D3DDevice.)
Public method | CreateTexture1D(Texture1DDescription, array<SubresourceData>[]()[][]) | Create an array of 1D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture1D) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateTexture2D Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateTexture2D Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTexture2D(Texture2DDescription) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D) (Inherited from D3DDevice.)
Public method | CreateTexture2D(Texture2DDescription, array<SubresourceData>[]()[][]) | Create an array of 2D textures. (Also see DirectX SDK: ID3D10Device::CreateTexture2D) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateTexture3D Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateTexture3D Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTexture3D(Texture3DDescription) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D) (Inherited from D3DDevice.)
Public method | CreateTexture3D(Texture3DDescription, array<SubresourceData>[]()[][]) | Create a single 3D texture. (Also see DirectX SDK: ID3D10Device::CreateTexture3D) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CreateVertexShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..CreateVertexShader Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateVertexShader(Stream) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader) (Inherited from D3DDevice.)
Public method | CreateVertexShader(IntPtr, UInt32) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D10Device::CreateVertexShader) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UpdateSubresource Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..UpdateSubresource Method
D3DDevice1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32) | The CPU copies data from memory to a subresource created in non-mappable memory. Because no destination box is defined, the data is written to the destination subresource with no offset. (Also see DirectX SDK: ID3D10Device::UpdateSubresource) (Inherited from D3DDevice.)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32, Box) | The CPU copies data from memory to a subresource created in non-mappable memory. (Also see DirectX SDK: ID3D10Device::UpdateSubresource) (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
D3DDevice1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DDevice1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1 Properties
D3DDevice1 Class See Also Send Feedback

The D3DDevice1 type exposes the following members.

Properties

 | Name | Description
Public property | CounterInformation | Gets information about the device's performance counter capabilities (Also see DirectX SDK: ID3D10Device::CheckCounterInfo) (Inherited from D3DDevice.)
Public property | CreateDeviceOptions | Get the flags used during the call to create the device. (Also see DirectX SDK: ID3D10Device::GetCreationFlags) (Inherited from D3DDevice.)
Public property | Debug | (Inherited from D3DDevice.)
Public property | DeviceFeatureLevel | Gets the feature level of the hardware device.
Public property | DeviceRemovedReason | Get the reason why the device was removed. (Also see DirectX SDK: ID3D10Device::GetDeviceRemovedReason) (Inherited from D3DDevice.)
Public property | ExceptionMode | Gets or sets the exception-mode flags. (Also see DirectX SDK: ID3D10Device::GetExceptionMode, ID3D10Device::SetExceptionMode) (Inherited from D3DDevice.)
Public property | GraphicsDevice | Gets the Graphics Device object for this device (Inherited from D3DDevice.)
Public property | GraphicsDevice1 | (Inherited from D3DDevice.)
Public property | GS | Get the associated geometry shader pipeline stage object. (Inherited from D3DDevice.)
Public property | IA | Get the associated input assembler pipeline stage object. (Inherited from D3DDevice.)
Public property | InfoQueue | Gets an information queue object that can retrieve, store and filter debug messages. (Inherited from D3DDevice.)
Public property | Multithread | (Inherited from D3DDevice.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | OM | Get the associated output merger pipeline stage object. (Inherited from D3DDevice.)
Public property | Predication | Get the rendering predicate state. (Also see DirectX SDK: ID3D10Device::GetPredication) (Inherited from D3DDevice.)
Public property | PS | Get the associated pixel shader pipeline stage object. (Inherited from D3DDevice.)
Public property | RS | Get the associated rasterizer pipeline stage object. (Inherited from D3DDevice.)
Public property | SO | Get the associated stream output pipeline stage object. (Inherited from D3DDevice.)
Public property | SwapChain | (Inherited from D3DDevice.)
Public property | SwitchToRef | Gets a switch-to-reference object that enables an application to switch between a hardware and software device. (Inherited from D3DDevice.)
Public property | VS | Get the associated vertex shader pipeline stage object. (Inherited from D3DDevice.)

See Also

D3DDevice1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DeviceFeatureLevel Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice1..::..DeviceFeatureLevel Property
D3DDevice1 Class See Also Send Feedback
Gets the feature level of the hardware device.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FeatureLevel DeviceFeatureLevel { get; }
Visual Basic
Public ReadOnly Property DeviceFeatureLevel As FeatureLevel
    Get
Visual C++
public:
property FeatureLevel DeviceFeatureLevel {
    FeatureLevel get ();
}

See Also

D3DDevice1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DPredicate Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate Class
Members See Also Send Feedback
A predicate interface determines whether geometry should be processed depending on the results of a previous draw call.

(Also see DirectX SDK: ID3D10Predicate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DPredicate : D3DQuery
Visual Basic
Public Class D3DPredicate _
    Inherits D3DQuery
Visual C++
public ref class D3DPredicate : public D3DQuery

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DQuery
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DPredicate

See Also

D3DPredicate Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DPredicate Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate Members
D3DPredicate Class Methods Properties See Also Send Feedback

The D3DPredicate type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Starts the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::Begin) (Inherited from Asynchronous.)
Public method | End | Ends the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::End) (Inherited from Asynchronous.)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D10Asynchronous::GetData) (Inherited from Asynchronous.)

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling Asynchronous.GetData. (Also see DirectX SDK: ID3D10Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a query description. (Also see DirectX SDK: ID3D10Query::GetDesc) (Inherited from D3DQuery.)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | WhenTrue |

See Also

D3DPredicate Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DPredicate Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate Methods
D3DPredicate Class See Also Send Feedback

The D3DPredicate type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Starts the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::Begin) (Inherited from Asynchronous.)
Public method | End | Ends the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::End) (Inherited from Asynchronous.)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D10Asynchronous::GetData) (Inherited from Asynchronous.)

See Also

D3DPredicate Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DPredicate Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate Properties
D3DPredicate Class See Also Send Feedback

The D3DPredicate type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling Asynchronous.GetData. (Also see DirectX SDK: ID3D10Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a query description. (Also see DirectX SDK: ID3D10Query::GetDesc) (Inherited from D3DQuery.)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | WhenTrue |

See Also

D3DPredicate Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


WhenTrue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate..::..WhenTrue Property
D3DPredicate Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool WhenTrue { get; set; }
Visual Basic
Public Property WhenTrue As Boolean
    Get
    Set
Visual C++
public:
property bool WhenTrue {
    bool get ();
    void set (bool value);
}

See Also

D3DPredicate Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DQuery Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DQuery Class
Members See Also Send Feedback
A query interface queries information from the GPU.

(Also see DirectX SDK: ID3D10Query)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DQuery : Asynchronous
Visual Basic
Public Class D3DQuery _
    Inherits Asynchronous
Visual C++
public ref class D3DQuery : public Asynchronous

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DQuery
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DPredicate

See Also

D3DQuery Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DQuery Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DQuery Members
D3DQuery Class Methods Properties See Also Send Feedback

The D3DQuery type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Starts the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::Begin) (Inherited from Asynchronous.)
Public method | End | Ends the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::End) (Inherited from Asynchronous.)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D10Asynchronous::GetData) (Inherited from Asynchronous.)

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling Asynchronous.GetData. (Also see DirectX SDK: ID3D10Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a query description. (Also see DirectX SDK: ID3D10Query::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D3DQuery Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DQuery Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DQuery Methods
D3DQuery Class See Also Send Feedback

The D3DQuery type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Starts the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::Begin) (Inherited from Asynchronous.)
Public method | End | Ends the collection of GPU data. (Also see DirectX SDK: ID3D10Asynchronous::End) (Inherited from Asynchronous.)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D10Asynchronous::GetData) (Inherited from Asynchronous.)

See Also

D3DQuery Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DQuery Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DQuery Properties
D3DQuery Class See Also Send Feedback

The D3DQuery type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling Asynchronous.GetData. (Also see DirectX SDK: ID3D10Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a query description. (Also see DirectX SDK: ID3D10Query::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D3DQuery Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DQuery..::..Description Property
D3DQuery Class See Also Send Feedback
Get a query description.

(Also see DirectX SDK: ID3D10Query::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public QueryDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As QueryDescription
    Get
Visual C++
public:
property QueryDescription Description {
    QueryDescription get ();
}

See Also

D3DQuery Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DResource Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource Class
Members See Also Send Feedback
A resource interface provides common actions on all resources.

(Also see DirectX SDK: ID3D10Resource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DResource : DeviceChild
Visual Basic
Public Class D3DResource _
    Inherits DeviceChild
Visual C++
public ref class D3DResource : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DBuffer
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1D
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2D
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3D

See Also

D3DResource Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DResource Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource Members
D3DResource Class Properties See Also Send Feedback

The D3DResource type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException.
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType)

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


D3DResource Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource Properties
D3DResource Class See Also Send Feedback

The D3DResource type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException.
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType)

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EvictionPriority Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource..::..EvictionPriority Property
D3DResource Class See Also Send Feedback
Get or set the eviction priority of a resource.

(Also see DirectX SDK: ID3D10Resource::GetEvictionPriority)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint EvictionPriority { get; set; }
Visual Basic
Public Property EvictionPriority As UInteger
    Get
    Set
Visual C++
public:
property unsigned int EvictionPriority {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GraphicsSurface Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource..::..GraphicsSurface Property
D3DResource Class See Also Send Feedback
Get associated Graphics surface. If none is associated - throw an InvalidCastException.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Surface GraphicsSurface { get; }
Visual Basic
Public ReadOnly Property GraphicsSurface As Surface
    Get
Visual C++
public:
property Surface^ GraphicsSurface {
    Surface^ get ();
}

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GraphicsSurface1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource..::..GraphicsSurface1 Property
D3DResource Class See Also Send Feedback
Get associated Graphics surface. If none is associated - throw an InvalidCastException.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Surface1 GraphicsSurface1 { get; }
Visual Basic
Public ReadOnly Property GraphicsSurface1 As Surface1
    Get
Visual C++
public:
property Surface1^ GraphicsSurface1 {
    Surface1^ get ();
}

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ResourceDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource..::..ResourceDimension Property
D3DResource Class See Also Send Feedback
Get the type of the resource.

(Also see DirectX SDK: ID3D10Resource::GetType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ResourceDimension ResourceDimension { get; }
Visual Basic
Public ReadOnly Property ResourceDimension As ResourceDimension
    Get
Visual C++
public:
property ResourceDimension ResourceDimension {
    ResourceDimension get ();
}

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DebugFeatures Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DebugFeatures Enumeration
See Also Send Feedback
Setting a feature-mask flag will cause a rendering-operation method to do some extra task when called.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum DebugFeatures
Visual Basic
<FlagsAttribute> _
Public Enumeration DebugFeatures
Visual C++
[FlagsAttribute]
public enum class DebugFeatures

Members

Member name | Description
PresentPerRenderOperation |
FlushPerRenderOperation |
FinishPerRenderOperation |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Structure
Members See Also Send Feedback
Describes depth-stencil state.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct DepthStencilDescription
Visual Basic
Public Structure DepthStencilDescription
Visual C++
public value class DepthStencilDescription

See Also

DepthStencilDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Members
DepthStencilDescription Structure Methods Operators Properties See Also Send Feedback

The DepthStencilDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BackFace | A DepthStencilOperationDescription structure that identifies how to use the results of the depth test and the stencil test for pixels whose surface normal is facing away from the camera. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.BackFace)
Public property | DepthEnable | A Boolean value that enables depth testing. The default value is TRUE. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.DepthEnable)
Public property | DepthFunction | A member of the ComparisonFunction enumerated type that defines how depth data is compared against existing depth data. The default value is Less (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.DepthFunc)
Public property | DepthWriteMask | A member of the DepthWriteMask enumerated type that identifies a portion of the depth-stencil buffer that can be modified by depth data. The default value is DepthWriteMask_ALL. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.DepthWriteMask)
Public property | FrontFace | A DepthStencilOperationDescription structure that identifies how to use the results of the depth test and the stencil test for pixels whose surface normal is facing toward the camera. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.FrontFace)
Public property | StencilEnable | A Boolean value that enables stencil testing. The default value is FALSE. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.StencilEnable)
Public property | StencilReadMask | A value that identifies a portion of the depth-stencil buffer for reading stencil data. The default value is Default. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.StencilReadMask)
Public property | StencilWriteMask | A value that identifies a portion of the depth-stencil buffer for writing stencil data. The default value is Default. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.StencilWriteMask)

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Methods
DepthStencilDescription Structure See Also Send Feedback

The DepthStencilDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..Equals Method
DepthStencilDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..GetHashCode Method
DepthStencilDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Operators
DepthStencilDescription Structure See Also Send Feedback

The DepthStencilDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..Equality Operator
DepthStencilDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    DepthStencilDescription depthStencilDescription1,
    DepthStencilDescription depthStencilDescription2
)
Visual Basic
Public Shared Operator = ( _
    depthStencilDescription1 As DepthStencilDescription, _
    depthStencilDescription2 As DepthStencilDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    DepthStencilDescription depthStencilDescription1,
    DepthStencilDescription depthStencilDescription2
)

Parameters

depthStencilDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilDescription
depthStencilDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilDescription

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..Inequality Operator
DepthStencilDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    DepthStencilDescription depthStencilDescription1,
    DepthStencilDescription depthStencilDescription2
)
Visual Basic
Public Shared Operator <> ( _
    depthStencilDescription1 As DepthStencilDescription, _
    depthStencilDescription2 As DepthStencilDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    DepthStencilDescription depthStencilDescription1,
    DepthStencilDescription depthStencilDescription2
)

Parameters

depthStencilDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilDescription
depthStencilDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilDescription

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Properties
DepthStencilDescription Structure See Also Send Feedback

The DepthStencilDescription type exposes the following members.

Properties

 | Name | Description
Public property | BackFace | A DepthStencilOperationDescription structure that identifies how to use the results of the depth test and the stencil test for pixels whose surface normal is facing away from the camera. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.BackFace)
Public property | DepthEnable | A Boolean value that enables depth testing. The default value is TRUE. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.DepthEnable)
Public property | DepthFunction | A member of the ComparisonFunction enumerated type that defines how depth data is compared against existing depth data. The default value is Less (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.DepthFunc)
Public property | DepthWriteMask | A member of the DepthWriteMask enumerated type that identifies a portion of the depth-stencil buffer that can be modified by depth data. The default value is DepthWriteMask_ALL. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.DepthWriteMask)
Public property | FrontFace | A DepthStencilOperationDescription structure that identifies how to use the results of the depth test and the stencil test for pixels whose surface normal is facing toward the camera. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.FrontFace)
Public property | StencilEnable | A Boolean value that enables stencil testing. The default value is FALSE. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.StencilEnable)
Public property | StencilReadMask | A value that identifies a portion of the depth-stencil buffer for reading stencil data. The default value is Default. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.StencilReadMask)
Public property | StencilWriteMask | A value that identifies a portion of the depth-stencil buffer for writing stencil data. The default value is Default. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.StencilWriteMask)

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BackFace Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..BackFace Property
DepthStencilDescription Structure See Also Send Feedback
A DepthStencilOperationDescription structure that identifies how to use the results of the depth test and the stencil test for pixels whose surface normal is facing away from the camera.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.BackFace)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilOperationDescription BackFace { get; set; }
Visual Basic
Public Property BackFace As DepthStencilOperationDescription
    Get
    Set
Visual C++
public:
property DepthStencilOperationDescription BackFace {
    DepthStencilOperationDescription get ();
    void set (DepthStencilOperationDescription value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..DepthEnable Property
DepthStencilDescription Structure See Also Send Feedback
A Boolean value that enables depth testing. The default value is TRUE.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.DepthEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool DepthEnable { get; set; }
Visual Basic
Public Property DepthEnable As Boolean
    Get
    Set
Visual C++
public:
property bool DepthEnable {
    bool get ();
    void set (bool value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthFunction Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..DepthFunction Property
DepthStencilDescription Structure See Also Send Feedback
A member of the ComparisonFunction enumerated type that defines how depth data is compared against existing depth data. The default value is Less

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.DepthFunc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComparisonFunction DepthFunction { get; set; }
Visual Basic
Public Property DepthFunction As ComparisonFunction
    Get
    Set
Visual C++
public:
property ComparisonFunction DepthFunction {
    ComparisonFunction get ();
    void set (ComparisonFunction value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthWriteMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..DepthWriteMask Property
DepthStencilDescription Structure See Also Send Feedback
A member of the DepthWriteMask enumerated type that identifies a portion of the depth-stencil buffer that can be modified by depth data. The default value is DepthWriteMask_ALL.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.DepthWriteMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthWriteMask DepthWriteMask { get; set; }
Visual Basic
Public Property DepthWriteMask As DepthWriteMask
    Get
    Set
Visual C++
public:
property DepthWriteMask DepthWriteMask {
    DepthWriteMask get ();
    void set (DepthWriteMask value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FrontFace Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..FrontFace Property
DepthStencilDescription Structure See Also Send Feedback
A DepthStencilOperationDescription structure that identifies how to use the results of the depth test and the stencil test for pixels whose surface normal is facing toward the camera.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.FrontFace)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilOperationDescription FrontFace { get; set; }
Visual Basic
Public Property FrontFace As DepthStencilOperationDescription
    Get
    Set
Visual C++
public:
property DepthStencilOperationDescription FrontFace {
    DepthStencilOperationDescription get ();
    void set (DepthStencilOperationDescription value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..StencilEnable Property
DepthStencilDescription Structure See Also Send Feedback
A Boolean value that enables stencil testing. The default value is FALSE.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.StencilEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool StencilEnable { get; set; }
Visual Basic
Public Property StencilEnable As Boolean
    Get
    Set
Visual C++
public:
property bool StencilEnable {
    bool get ();
    void set (bool value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilReadMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..StencilReadMask Property
DepthStencilDescription Structure See Also Send Feedback
A value that identifies a portion of the depth-stencil buffer for reading stencil data. The default value is Default.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.StencilReadMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilReadMask StencilReadMask { get; set; }
Visual Basic
Public Property StencilReadMask As StencilReadMask
    Get
    Set
Visual C++
public:
property StencilReadMask StencilReadMask {
    StencilReadMask get ();
    void set (StencilReadMask value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilWriteMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..StencilWriteMask Property
DepthStencilDescription Structure See Also Send Feedback
A value that identifies a portion of the depth-stencil buffer for writing stencil data. The default value is Default.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_DESC.StencilWriteMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilWriteMask StencilWriteMask { get; set; }
Visual Basic
Public Property StencilWriteMask As StencilWriteMask
    Get
    Set
Visual C++
public:
property StencilWriteMask StencilWriteMask {
    StencilWriteMask get ();
    void set (StencilWriteMask value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilOperationDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Structure
Members See Also Send Feedback
Describes the stencil operations that can be performed based on the results of stencil test.

(Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct DepthStencilOperationDescription
Visual Basic
Public Structure DepthStencilOperationDescription
Visual C++
public value class DepthStencilOperationDescription

See Also

DepthStencilOperationDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilOperationDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Members
DepthStencilOperationDescription Structure Constructors Methods Operators Properties See Also Send Feedback

The DepthStencilOperationDescription type exposes the following members.

Constructors

 | Name | Description
Public method | DepthStencilOperationDescription |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | StencilDepthFailOperation | A member of the StencilOperation enumerated type that describes the stencil operation to perform when stencil testing passes and depth testing fails. The default value is StencilOperation_KEEP. (Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilDepthFailOp)
Public property | StencilFailOperation | A member of the StencilOperation enumerated type that describes the stencil operation to perform when stencil testing fails. The default value is StencilOperation_KEEP. (Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilFailOp)
Public property | StencilFunction | A member of the ComparisonFunction enumerated type that describes how stencil data is compared against existing stencil data. The default value is Always. (Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilFunc)
Public property | StencilPassOperation | A member of the StencilOperation enumerated type that describes the stencil operation to perform when stencil testing and depth testing both pass. The default value is StencilOperation_KEEP. (Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilPassOp)

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilOperationDescription Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Constructor
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilOperationDescription(
    D3D10_DEPTH_STENCILOP_DESC* desc
)
Visual Basic
Visual Basic does not support APIs that consume or return unsafe types.
Visual C++
public:
DepthStencilOperationDescription(
    D3D10_DEPTH_STENCILOP_DESC* desc
)

Parameters

desc
Type: D3D10_DEPTH_STENCILOP_DESC IsImplicitlyDereferenced*

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilOperationDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Methods
DepthStencilOperationDescription Structure See Also Send Feedback

The DepthStencilOperationDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..Equals Method
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..GetHashCode Method
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilOperationDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Operators
DepthStencilOperationDescription Structure See Also Send Feedback

The DepthStencilOperationDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..Equality Operator
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    DepthStencilOperationDescription depthStencilOperationDescription1,
    DepthStencilOperationDescription depthStencilOperationDescription2
)
Visual Basic
Public Shared Operator = ( _
    depthStencilOperationDescription1 As DepthStencilOperationDescription, _
    depthStencilOperationDescription2 As DepthStencilOperationDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    DepthStencilOperationDescription depthStencilOperationDescription1,
    DepthStencilOperationDescription depthStencilOperationDescription2
)

Parameters

depthStencilOperationDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilOperationDescription
depthStencilOperationDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilOperationDescription

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..Inequality Operator
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    DepthStencilOperationDescription depthStencilOperationDescription1,
    DepthStencilOperationDescription depthStencilOperationDescription2
)
Visual Basic
Public Shared Operator <> ( _
    depthStencilOperationDescription1 As DepthStencilOperationDescription, _
    depthStencilOperationDescription2 As DepthStencilOperationDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    DepthStencilOperationDescription depthStencilOperationDescription1,
    DepthStencilOperationDescription depthStencilOperationDescription2
)

Parameters

depthStencilOperationDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilOperationDescription
depthStencilOperationDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilOperationDescription

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilOperationDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Properties
DepthStencilOperationDescription Structure See Also Send Feedback

The DepthStencilOperationDescription type exposes the following members.

Properties

 | Name | Description
Public property | StencilDepthFailOperation | A member of the StencilOperation enumerated type that describes the stencil operation to perform when stencil testing passes and depth testing fails. The default value is StencilOperation_KEEP. (Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilDepthFailOp)
Public property | StencilFailOperation | A member of the StencilOperation enumerated type that describes the stencil operation to perform when stencil testing fails. The default value is StencilOperation_KEEP. (Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilFailOp)
Public property | StencilFunction | A member of the ComparisonFunction enumerated type that describes how stencil data is compared against existing stencil data. The default value is Always. (Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilFunc)
Public property | StencilPassOperation | A member of the StencilOperation enumerated type that describes the stencil operation to perform when stencil testing and depth testing both pass. The default value is StencilOperation_KEEP. (Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilPassOp)

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilDepthFailOperation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..StencilDepthFailOperation Property
DepthStencilOperationDescription Structure See Also Send Feedback
A member of the StencilOperation enumerated type that describes the stencil operation to perform when stencil testing passes and depth testing fails. The default value is StencilOperation_KEEP.

(Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilDepthFailOp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilOperation StencilDepthFailOperation { get; set; }
Visual Basic
Public Property StencilDepthFailOperation As StencilOperation
    Get
    Set
Visual C++
public:
property StencilOperation StencilDepthFailOperation {
    StencilOperation get ();
    void set (StencilOperation value);
}

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilFailOperation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..StencilFailOperation Property
DepthStencilOperationDescription Structure See Also Send Feedback
A member of the StencilOperation enumerated type that describes the stencil operation to perform when stencil testing fails. The default value is StencilOperation_KEEP.

(Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilFailOp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilOperation StencilFailOperation { get; set; }
Visual Basic
Public Property StencilFailOperation As StencilOperation
    Get
    Set
Visual C++
public:
property StencilOperation StencilFailOperation {
    StencilOperation get ();
    void set (StencilOperation value);
}

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilFunction Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..StencilFunction Property
DepthStencilOperationDescription Structure See Also Send Feedback
A member of the ComparisonFunction enumerated type that describes how stencil data is compared against existing stencil data. The default value is Always.

(Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilFunc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComparisonFunction StencilFunction { get; set; }
Visual Basic
Public Property StencilFunction As ComparisonFunction
    Get
    Set
Visual C++
public:
property ComparisonFunction StencilFunction {
    ComparisonFunction get ();
    void set (ComparisonFunction value);
}

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilPassOperation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..StencilPassOperation Property
DepthStencilOperationDescription Structure See Also Send Feedback
A member of the StencilOperation enumerated type that describes the stencil operation to perform when stencil testing and depth testing both pass. The default value is StencilOperation_KEEP.

(Also see DirectX SDK: D3D10_DEPTH_STENCILOP_DESC.StencilPassOp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilOperation StencilPassOperation { get; set; }
Visual Basic
Public Property StencilPassOperation As StencilOperation
    Get
    Set
Visual C++
public:
property StencilOperation StencilPassOperation {
    StencilOperation get ();
    void set (StencilOperation value);
}

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilState Class
Members See Also Send Feedback
A depth-stencil-state interface accesses depth-stencil state which sets up the depth-stencil test for the output-merger stage.

(Also see DirectX SDK: ID3D10DepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DepthStencilState : DeviceChild
Visual Basic
Public Class DepthStencilState _
    Inherits DeviceChild
Visual C++
public ref class DepthStencilState : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilState

See Also

DepthStencilState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilState Members
DepthStencilState Class Properties See Also Send Feedback

The DepthStencilState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the depth-stencil state. (Also see DirectX SDK: ID3D10DepthStencilState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DepthStencilState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilState Properties
DepthStencilState Class See Also Send Feedback

The DepthStencilState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the depth-stencil state. (Also see DirectX SDK: ID3D10DepthStencilState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DepthStencilState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilState..::..Description Property
DepthStencilState Class See Also Send Feedback
Get the depth-stencil state.

(Also see DirectX SDK: ID3D10DepthStencilState::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As DepthStencilDescription
    Get
Visual C++
public:
property DepthStencilDescription Description {
    DepthStencilDescription get ();
}

See Also

DepthStencilState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilView Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilView Class
Members See Also Send Feedback
A depth-stencil-view interface accesses a texture resource during depth-stencil testing.

(Also see DirectX SDK: ID3D10DepthStencilView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DepthStencilView : View
Visual Basic
Public Class DepthStencilView _
    Inherits View
Visual C++
public ref class DepthStencilView : public View

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilView

See Also

DepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilView Members
DepthStencilView Class Properties See Also Send Feedback

The DepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the depth-stencil view description. (Also see DirectX SDK: ID3D10DepthStencilView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource) (Inherited from View.)

See Also

DepthStencilView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilView Properties
DepthStencilView Class See Also Send Feedback

The DepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the depth-stencil view description. (Also see DirectX SDK: ID3D10DepthStencilView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource) (Inherited from View.)

See Also

DepthStencilView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilView..::..Description Property
DepthStencilView Class See Also Send Feedback
Get the depth-stencil view description.

(Also see DirectX SDK: ID3D10DepthStencilView::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilViewDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As DepthStencilViewDescription
    Get
Visual C++
public:
property DepthStencilViewDescription Description {
    DepthStencilViewDescription get ();
}

See Also

DepthStencilView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilViewDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription Structure
Members See Also Send Feedback
Specifies the subresource(s) from a texture that are accessible using a depth-stencil view.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct DepthStencilViewDescription
Visual Basic
Public Structure DepthStencilViewDescription
Visual C++
public value class DepthStencilViewDescription

See Also

DepthStencilViewDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilViewDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription Members
DepthStencilViewDescription Structure Properties See Also Send Feedback

The DepthStencilViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Format | format (see Format). See remarks for allowable formats. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Format)
Public property | Texture1D | Specifies a 1D texture subresource (see Texture1DDepthStencilView). (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies an array of 1D texture subresources (see Texture1DArrayDepthStencilView). (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies a 2D texture subresource (see Texture2DDepthStencilView). (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies an array of 2D texture subresources (see Texture2DArrayDepthStencilView). (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | Unused -- a multisampled 2D texture contains a single subresource. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2DMultisample)
Public property | Texture2DMultisampleArray | Unused -- a multisampled 2D texture contains a single subresource per texture. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2DMSArray)
Public property | ViewDimension | Type of resource (see DepthStencilViewDimension). Specifies how a depth-stencil resource will be accessed; the value is stored in the union in this structure. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.ViewDimension)

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilViewDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription Properties
DepthStencilViewDescription Structure See Also Send Feedback

The DepthStencilViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Format | format (see Format). See remarks for allowable formats. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Format)
Public property | Texture1D | Specifies a 1D texture subresource (see Texture1DDepthStencilView). (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies an array of 1D texture subresources (see Texture1DArrayDepthStencilView). (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies a 2D texture subresource (see Texture2DDepthStencilView). (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies an array of 2D texture subresources (see Texture2DArrayDepthStencilView). (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | Unused -- a multisampled 2D texture contains a single subresource. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2DMultisample)
Public property | Texture2DMultisampleArray | Unused -- a multisampled 2D texture contains a single subresource per texture. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2DMSArray)
Public property | ViewDimension | Type of resource (see DepthStencilViewDimension). Specifies how a depth-stencil resource will be accessed; the value is stored in the union in this structure. (Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.ViewDimension)

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Format Property
DepthStencilViewDescription Structure See Also Send Feedback
format (see Format). See remarks for allowable formats.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
DepthStencilViewDescription..::..Format


Texture1D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture1D Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies a 1D texture subresource (see Texture1DDepthStencilView).

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DDepthStencilView Texture1D { get; set; }
Visual Basic
Public Property Texture1D As Texture1DDepthStencilView
    Get
    Set
Visual C++
public:
property Texture1DDepthStencilView Texture1D {
    Texture1DDepthStencilView get ();
    void set (Texture1DDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDepthStencilView


Texture1DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture1DArray Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies an array of 1D texture subresources (see Texture1DArrayDepthStencilView).

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture1DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DArrayDepthStencilView Texture1DArray { get; set; }
Visual Basic
Public Property Texture1DArray As Texture1DArrayDepthStencilView
    Get
    Set
Visual C++
public:
property Texture1DArrayDepthStencilView Texture1DArray {
    Texture1DArrayDepthStencilView get ();
    void set (Texture1DArrayDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayDepthStencilView


Texture2D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture2D Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies a 2D texture subresource (see Texture2DDepthStencilView).

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DDepthStencilView Texture2D { get; set; }
Visual Basic
Public Property Texture2D As Texture2DDepthStencilView
    Get
    Set
Visual C++
public:
property Texture2DDepthStencilView Texture2D {
    Texture2DDepthStencilView get ();
    void set (Texture2DDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDepthStencilView


Texture2DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture2DArray Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies an array of 2D texture subresources (see Texture2DArrayDepthStencilView).

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DArrayDepthStencilView Texture2DArray { get; set; }
Visual Basic
Public Property Texture2DArray As Texture2DArrayDepthStencilView
    Get
    Set
Visual C++
public:
property Texture2DArrayDepthStencilView Texture2DArray {
    Texture2DArrayDepthStencilView get ();
    void set (Texture2DArrayDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayDepthStencilView


Texture2DMultisample Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture2DMultisample Property
DepthStencilViewDescription Structure See Also Send Feedback
Unused -- a multisampled 2D texture contains a single subresource.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2DMultisample)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleDepthStencilView Texture2DMultisample { get; set; }
Visual Basic
Public Property Texture2DMultisample As Texture2DMultisampleDepthStencilView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleDepthStencilView Texture2DMultisample {
    Texture2DMultisampleDepthStencilView get ();
    void set (Texture2DMultisampleDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture2DMultisampleArray Property
DepthStencilViewDescription Structure See Also Send Feedback
Unused -- a multisampled 2D texture contains a single subresource per texture.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.Texture2DMSArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleArrayDepthStencilView Texture2DMultisampleArray { get; set; }
Visual Basic
Public Property Texture2DMultisampleArray As Texture2DMultisampleArrayDepthStencilView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleArrayDepthStencilView Texture2DMultisampleArray {
    Texture2DMultisampleArrayDepthStencilView get ();
    void set (Texture2DMultisampleArrayDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ViewDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..ViewDimension Property
DepthStencilViewDescription Structure See Also Send Feedback
Type of resource (see DepthStencilViewDimension). Specifies how a depth-stencil resource will be accessed; the value is stored in the union in this structure.

(Also see DirectX SDK: D3D10_DEPTH_STENCIL_VIEW_DESC.ViewDimension)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilViewDimension ViewDimension { get; set; }
Visual Basic
Public Property ViewDimension As DepthStencilViewDimension
    Get
    Set
Visual C++
public:
property DepthStencilViewDimension ViewDimension {
    DepthStencilViewDimension get ();
    void set (DepthStencilViewDimension value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilViewDimension


DepthStencilViewDimension Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDimension Enumeration
See Also Send Feedback
Specifies how to access a resource used in a depth-stencil view.

(Also see DirectX SDK: D3D10_DSV_DIMENSION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DepthStencilViewDimension
Visual Basic
Public Enumeration DepthStencilViewDimension
Visual C++
public enum class DepthStencilViewDimension

Members

Member name | Description
Texture2DMultisampleArray |
Texture2DMultisample |
Texture2DArray |
Texture2D |
Texture1DArray |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthWriteMask Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthWriteMask Enumeration
See Also Send Feedback
Identify the portion of a depth-stencil buffer for writing depth data.

(Also see DirectX SDK: D3D10_DEPTH_WRITE_MASK)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DepthWriteMask
Visual Basic
Public Enumeration DepthWriteMask
Visual C++
public enum class DepthWriteMask

Members

Member name | Description
None |
Enabled |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DeviceChild Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceChild Class
Members See Also Send Feedback
A device-child interface accesses data used by a device.

(Also see DirectX SDK: ID3D10DeviceChild)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DeviceChild : DirectUnknown
Visual Basic
Public Class DeviceChild _
    Inherits DirectUnknown
Visual C++
public ref class DeviceChild : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendState
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilState
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..GeometryShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InputLayout
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PixelShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerState
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerState
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..VertexShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..View

See Also

DeviceChild Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DeviceChild Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceChild Members
DeviceChild Class Properties See Also Send Feedback

The DeviceChild type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DeviceChild Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DeviceChild Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceChild Properties
DeviceChild Class See Also Send Feedback

The DeviceChild type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DeviceChild Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Device Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceChild..::..Device Property
DeviceChild Class See Also Send Feedback
Get the device that created this object.

(Also see DirectX SDK: ID3D10DeviceChild::GetDevice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DDevice Device { get; }
Visual Basic
Public ReadOnly Property Device As D3DDevice
    Get
Visual C++
public:
property D3DDevice^ Device {
    D3DDevice^ get ();
}

See Also

DeviceChild Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DeviceStateType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceStateType Enumeration
See Also Send Feedback
Effect device-state types.

(Also see DirectX SDK: D3D10_DEVICE_STATE_TYPES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DeviceStateType
Visual Basic
Public Enumeration DeviceStateType
Visual C++
public enum class DeviceStateType

Members

Member name | Description
Predication |
InputAssemblerIndexBuffer |
RasterizerState |
RasterizerStateScissorRects |
RasterizerStateViewports |
InputAssemblerPrimitiveTopology |
InputAssemblerInputLayout |
InputAssemblerVertexBuffers |
PixelShaderConstantBuffers |
PixelShaderResources |
PixelShaderSamplers |
PixelShader |
GeometryShaderConstantBuffers |
GeometryShaderShaderResources |
GeometryShaderSamplers |
GeometryShader |
VertexShaderConstantBuffers |
VertexShaderShaderResources |
VertexShaderSamplers |
VertexShader |
OutputMergerBlendState |
OutputMergerDepthStencilState |
OutputMergerRenderTargets |
StreamOutputBuffers |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DriverType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DriverType Enumeration
See Also Send Feedback
The device-driver type.

(Also see DirectX SDK: D3D10_DRIVER_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DriverType
Visual Basic
Public Enumeration DriverType
Visual C++
public enum class DriverType

Members

Member name | Description
Reference |
Hardware |
Software |
Null |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Effect Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect Class
Members See Also Send Feedback
An Effect interface manages a set of state objects, resources and shaders for implementing a rendering effect.

(Also see DirectX SDK: ID3D10Effect)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Effect : DirectUnknown
Visual Basic
Public Class Effect _
    Inherits DirectUnknown
Visual C++
public ref class Effect : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Effect

See Also

Effect Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Effect Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect Members
Effect Class Methods Properties See Also Send Feedback

The Effect type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBufferByIndex | Get a constant buffer by index. (Also see DirectX SDK: ID3D10Effect::GetConstantBufferByIndex)
Public method | GetConstantBufferByName | Get a constant buffer by name. (Also see DirectX SDK: ID3D10Effect::GetConstantBufferByName)
Public method | GetTechniqueByIndex | Get a technique by index. (Also see DirectX SDK: ID3D10Effect::GetTechniqueByIndex)
Public method | GetTechniqueByName | Get a technique by name. (Also see DirectX SDK: ID3D10Effect::GetTechniqueByName)
Public method | GetVariableByIndex | Get a variable by index. (Also see DirectX SDK: ID3D10Effect::GetVariableByIndex)
Public method | GetVariableByName | Get a variable by name. (Also see DirectX SDK: ID3D10Effect::GetVariableByName)
Public method | GetVariableBySemantic | Get a variable by semantic. (Also see DirectX SDK: ID3D10Effect::GetVariableBySemantic)
Public method | Optimize | Minimize the amount of memory required for an effect. (Also see DirectX SDK: ID3D10Effect::Optimize)

Properties

 | Name | Description
Public property | Description | Get an effect description. (Also see DirectX SDK: ID3D10Effect::GetDesc)
Public property | Device | Get the device that created the effect as 10.0 device. (Also see DirectX SDK: ID3D10Effect::GetDevice)
Public property | IsOptimized | Test an effect to see if the reflection metadata has been removed from memory. (Also see DirectX SDK: ID3D10Effect::IsOptimized)
Public property | IsPool | Test an effect to see if it is part of a memory pool. (Also see DirectX SDK: ID3D10Effect::IsPool)
Public property | IsValid | Test an effect to see if it contains valid syntax. (Also see DirectX SDK: ID3D10Effect::IsValid)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Effect Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect Methods
Effect Class See Also Send Feedback

The Effect type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBufferByIndex | Get a constant buffer by index. (Also see DirectX SDK: ID3D10Effect::GetConstantBufferByIndex)
Public method | GetConstantBufferByName | Get a constant buffer by name. (Also see DirectX SDK: ID3D10Effect::GetConstantBufferByName)
Public method | GetTechniqueByIndex | Get a technique by index. (Also see DirectX SDK: ID3D10Effect::GetTechniqueByIndex)
Public method | GetTechniqueByName | Get a technique by name. (Also see DirectX SDK: ID3D10Effect::GetTechniqueByName)
Public method | GetVariableByIndex | Get a variable by index. (Also see DirectX SDK: ID3D10Effect::GetVariableByIndex)
Public method | GetVariableByName | Get a variable by name. (Also see DirectX SDK: ID3D10Effect::GetVariableByName)
Public method | GetVariableBySemantic | Get a variable by semantic. (Also see DirectX SDK: ID3D10Effect::GetVariableBySemantic)
Public method | Optimize | Minimize the amount of memory required for an effect. (Also see DirectX SDK: ID3D10Effect::Optimize)

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetConstantBufferByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..GetConstantBufferByIndex Method
Effect Class See Also Send Feedback
Get a constant buffer by index.

(Also see DirectX SDK: ID3D10Effect::GetConstantBufferByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectConstantBuffer GetConstantBufferByIndex(
    uint index
)
Visual Basic
Public Function GetConstantBufferByIndex ( _
    index As UInteger _
) As EffectConstantBuffer
Visual C++
public:
EffectConstantBuffer^ GetConstantBufferByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetConstantBufferByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..GetConstantBufferByName Method
Effect Class See Also Send Feedback
Get a constant buffer by name.

(Also see DirectX SDK: ID3D10Effect::GetConstantBufferByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectConstantBuffer GetConstantBufferByName(
    string name
)
Visual Basic
Public Function GetConstantBufferByName ( _
    name As String _
) As EffectConstantBuffer
Visual C++
public:
EffectConstantBuffer^ GetConstantBufferByName(
    String^ name
)

Parameters

name
Type: System..::..String
The constant-buffer name.

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetTechniqueByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..GetTechniqueByIndex Method
Effect Class See Also Send Feedback
Get a technique by index.

(Also see DirectX SDK: ID3D10Effect::GetTechniqueByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectTechnique GetTechniqueByIndex(
    uint index
)
Visual Basic
Public Function GetTechniqueByIndex ( _
    index As UInteger _
) As EffectTechnique
Visual C++
public:
EffectTechnique^ GetTechniqueByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetTechniqueByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..GetTechniqueByName Method
Effect Class See Also Send Feedback
Get a technique by name.

(Also see DirectX SDK: ID3D10Effect::GetTechniqueByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectTechnique GetTechniqueByName(
    string name
)
Visual Basic
Public Function GetTechniqueByName ( _
    name As String _
) As EffectTechnique
Visual C++
public:
EffectTechnique^ GetTechniqueByName(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the technique.

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetVariableByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..GetVariableByIndex Method
Effect Class See Also Send Feedback
Get a variable by index.

(Also see DirectX SDK: ID3D10Effect::GetVariableByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetVariableByIndex(
    uint index
)
Visual Basic
Public Function GetVariableByIndex ( _
    index As UInteger _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetVariableByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetVariableByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..GetVariableByName Method
Effect Class See Also Send Feedback
Get a variable by name.

(Also see DirectX SDK: ID3D10Effect::GetVariableByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetVariableByName(
    string name
)
Visual Basic
Public Function GetVariableByName ( _
    name As String _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetVariableByName(
    String^ name
)

Parameters

name
Type: System..::..String
The variable name.

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetVariableBySemantic Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..GetVariableBySemantic Method
Effect Class See Also Send Feedback
Get a variable by semantic.

(Also see DirectX SDK: ID3D10Effect::GetVariableBySemantic)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetVariableBySemantic(
    string semantic
)
Visual Basic
Public Function GetVariableBySemantic ( _
    semantic As String _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetVariableBySemantic(
    String^ semantic
)

Parameters

semantic
Type: System..::..String
The semantic name.

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Optimize Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..Optimize Method
Effect Class See Also Send Feedback
Minimize the amount of memory required for an effect.

(Also see DirectX SDK: ID3D10Effect::Optimize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Optimize()
Visual Basic
Public Sub Optimize
Visual C++
public:
void Optimize()

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Effect Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect Properties
Effect Class See Also Send Feedback

The Effect type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get an effect description. (Also see DirectX SDK: ID3D10Effect::GetDesc)
Public property | Device | Get the device that created the effect as 10.0 device. (Also see DirectX SDK: ID3D10Effect::GetDevice)
Public property | IsOptimized | Test an effect to see if the reflection metadata has been removed from memory. (Also see DirectX SDK: ID3D10Effect::IsOptimized)
Public property | IsPool | Test an effect to see if it is part of a memory pool. (Also see DirectX SDK: ID3D10Effect::IsPool)
Public property | IsValid | Test an effect to see if it contains valid syntax. (Also see DirectX SDK: ID3D10Effect::IsValid)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..Description Property
Effect Class See Also Send Feedback
Get an effect description.

(Also see DirectX SDK: ID3D10Effect::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As EffectDescription
    Get
Visual C++
public:
property EffectDescription Description {
    EffectDescription get ();
}

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Device Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..Device Property
Effect Class See Also Send Feedback
Get the device that created the effect as 10.0 device.

(Also see DirectX SDK: ID3D10Effect::GetDevice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DDevice Device { get; }
Visual Basic
Public ReadOnly Property Device As D3DDevice
    Get
Visual C++
public:
property D3DDevice^ Device {
    D3DDevice^ get ();
}

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsOptimized Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..IsOptimized Property
Effect Class See Also Send Feedback
Test an effect to see if the reflection metadata has been removed from memory.

(Also see DirectX SDK: ID3D10Effect::IsOptimized)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsOptimized { get; }
Visual Basic
Public ReadOnly Property IsOptimized As Boolean
    Get
Visual C++
public:
property bool IsOptimized {
    bool get ();
}

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsPool Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..IsPool Property
Effect Class See Also Send Feedback
Test an effect to see if it is part of a memory pool.

(Also see DirectX SDK: ID3D10Effect::IsPool)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsPool { get; }
Visual Basic
Public ReadOnly Property IsPool As Boolean
    Get
Visual C++
public:
property bool IsPool {
    bool get ();
}

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsValid Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Effect..::..IsValid Property
Effect Class See Also Send Feedback
Test an effect to see if it contains valid syntax.

(Also see DirectX SDK: ID3D10Effect::IsValid)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

Effect Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectBlendVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectBlendVariable Class
Members See Also Send Feedback
The blend-variable interface accesses blend state.

(Also see DirectX SDK: ID3D10EffectBlendVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectBlendVariable : EffectVariable
Visual Basic
Public Class EffectBlendVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectBlendVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectBlendVariable

See Also

EffectBlendVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectBlendVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectBlendVariable Members
EffectBlendVariable Class Methods Properties See Also Send Feedback

The EffectBlendVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBackingStore | Get a blend-state variable. (Also see DirectX SDK: ID3D10EffectBlendVariable::GetBackingStore)
Public method | GetBlendState | Get a blend-state object. (Also see DirectX SDK: ID3D10EffectBlendVariable::GetBlendState)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectBlendVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectBlendVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectBlendVariable Methods
EffectBlendVariable Class See Also Send Feedback

The EffectBlendVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBackingStore | Get a blend-state variable. (Also see DirectX SDK: ID3D10EffectBlendVariable::GetBackingStore)
Public method | GetBlendState | Get a blend-state object. (Also see DirectX SDK: ID3D10EffectBlendVariable::GetBlendState)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectBlendVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetBackingStore Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectBlendVariable..::..GetBackingStore Method
EffectBlendVariable Class See Also Send Feedback
Get a blend-state variable.

(Also see DirectX SDK: ID3D10EffectBlendVariable::GetBackingStore)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendDescription GetBackingStore(
    uint index
)
Visual Basic
Public Function GetBackingStore ( _
    index As UInteger _
) As BlendDescription
Visual C++
public:
BlendDescription GetBackingStore(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Index into an array of blend-state descriptions. If there is only one blend-state variable in the effect, use 0.

Return Value

A blend-state description (see BlendDescription).

See Also

EffectBlendVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendDescription


GetBlendState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectBlendVariable..::..GetBlendState Method
EffectBlendVariable Class See Also Send Feedback
Get a blend-state object.

(Also see DirectX SDK: ID3D10EffectBlendVariable::GetBlendState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendState GetBlendState(
    uint index
)
Visual Basic
Public Function GetBlendState ( _
    index As UInteger _
) As BlendState
Visual C++
public:
BlendState^ GetBlendState(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
index into an array of blend-state interfaces. If there is only one blend-state interface, use 0.

Return Value

A blend-state interface (see BlendState Object).

See Also

EffectBlendVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectBlendVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectBlendVariable Properties
EffectBlendVariable Class See Also Send Feedback

The EffectBlendVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectBlendVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectConstantBuffer Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectConstantBuffer Class
Members See Also Send Feedback
A constant-buffer interface accesses constant buffers or texture buffers.

(Also see DirectX SDK: ID3D10EffectConstantBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectConstantBuffer : EffectVariable
Visual Basic
Public Class EffectConstantBuffer _
    Inherits EffectVariable
Visual C++
public ref class EffectConstantBuffer : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectConstantBuffer

See Also

EffectConstantBuffer Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectConstantBuffer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectConstantBuffer Members
EffectConstantBuffer Class Methods Properties See Also Send Feedback

The EffectConstantBuffer type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | ConstantBuffer | Gets or sets a constant-buffer. (Also see DirectX SDK: ID3D10EffectConstantBuffer::GetConstantBuffer, ID3D10EffectConstantBuffer::SetConstantBuffer)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)
Public property | TextureBuffer | Gets or sets a texture-buffer. (Also see DirectX SDK: ID3D10EffectConstantBuffer::GetTextureBuffer, ID3D10EffectConstantBuffer::SetTextureBuffer)

See Also

EffectConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectConstantBuffer Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectConstantBuffer Methods
EffectConstantBuffer Class See Also Send Feedback

The EffectConstantBuffer type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectConstantBuffer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectConstantBuffer Properties
EffectConstantBuffer Class See Also Send Feedback

The EffectConstantBuffer type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | ConstantBuffer | Gets or sets a constant-buffer. (Also see DirectX SDK: ID3D10EffectConstantBuffer::GetConstantBuffer, ID3D10EffectConstantBuffer::SetConstantBuffer)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)
Public property | TextureBuffer | Gets or sets a texture-buffer. (Also see DirectX SDK: ID3D10EffectConstantBuffer::GetTextureBuffer, ID3D10EffectConstantBuffer::SetTextureBuffer)

See Also

EffectConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ConstantBuffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectConstantBuffer..::..ConstantBuffer Property
EffectConstantBuffer Class See Also Send Feedback
Gets or sets a constant-buffer.

(Also see DirectX SDK: ID3D10EffectConstantBuffer::GetConstantBuffer, ID3D10EffectConstantBuffer::SetConstantBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer ConstantBuffer { get; set; }
Visual Basic
Public Property ConstantBuffer As D3DBuffer
    Get
    Set
Visual C++
public:
property D3DBuffer^ ConstantBuffer {
    D3DBuffer^ get ();
    void set (D3DBuffer^ value);
}

See Also

EffectConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureBuffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectConstantBuffer..::..TextureBuffer Property
EffectConstantBuffer Class See Also Send Feedback
Gets or sets a texture-buffer.

(Also see DirectX SDK: ID3D10EffectConstantBuffer::GetTextureBuffer, ID3D10EffectConstantBuffer::SetTextureBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceView TextureBuffer { get; set; }
Visual Basic
Public Property TextureBuffer As ShaderResourceView
    Get
    Set
Visual C++
public:
property ShaderResourceView^ TextureBuffer {
    ShaderResourceView^ get ();
    void set (ShaderResourceView^ value);
}

See Also

EffectConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDepthStencilVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilVariable Class
Members See Also Send Feedback
A depth-stencil-variable interface accesses depth-stencil state.

(Also see DirectX SDK: ID3D10EffectDepthStencilVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectDepthStencilVariable : EffectVariable
Visual Basic
Public Class EffectDepthStencilVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectDepthStencilVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectDepthStencilVariable

See Also

EffectDepthStencilVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDepthStencilVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilVariable Members
EffectDepthStencilVariable Class Methods Properties See Also Send Feedback

The EffectDepthStencilVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBackingStore | Get a variable that contains depth-stencil state. (Also see DirectX SDK: ID3D10EffectDepthStencilVariable::GetBackingStore)
Public method | GetDepthStencilState | Get a depth-stencil object. (Also see DirectX SDK: ID3D10EffectDepthStencilVariable::GetDepthStencilState)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectDepthStencilVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDepthStencilVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilVariable Methods
EffectDepthStencilVariable Class See Also Send Feedback

The EffectDepthStencilVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBackingStore | Get a variable that contains depth-stencil state. (Also see DirectX SDK: ID3D10EffectDepthStencilVariable::GetBackingStore)
Public method | GetDepthStencilState | Get a depth-stencil object. (Also see DirectX SDK: ID3D10EffectDepthStencilVariable::GetDepthStencilState)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectDepthStencilVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetBackingStore Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilVariable..::..GetBackingStore Method
EffectDepthStencilVariable Class See Also Send Feedback
Get a variable that contains depth-stencil state.

(Also see DirectX SDK: ID3D10EffectDepthStencilVariable::GetBackingStore)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilDescription GetBackingStore(
    uint index
)
Visual Basic
Public Function GetBackingStore ( _
    index As UInteger _
) As DepthStencilDescription
Visual C++
public:
DepthStencilDescription GetBackingStore(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Index into an array of depth-stencil-state descriptions. If there is only one depth-stencil variable in the effect, use 0.

Return Value

A depth-stencil-state description (see DepthStencilDescription).

See Also

EffectDepthStencilVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilDescription


GetDepthStencilState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilVariable..::..GetDepthStencilState Method
EffectDepthStencilVariable Class See Also Send Feedback
Get a depth-stencil object.

(Also see DirectX SDK: ID3D10EffectDepthStencilVariable::GetDepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilState GetDepthStencilState(
    uint index
)
Visual Basic
Public Function GetDepthStencilState ( _
    index As UInteger _
) As DepthStencilState
Visual C++
public:
DepthStencilState^ GetDepthStencilState(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Index into an array of depth-stencil interfaces. If there is only one depth-stencil interface, use 0.

Return Value

A blend-state interface (see DepthStencilState Object).

See Also

EffectDepthStencilVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDepthStencilVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilVariable Properties
EffectDepthStencilVariable Class See Also Send Feedback

The EffectDepthStencilVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectDepthStencilVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDepthStencilViewVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilViewVariable Class
Members See Also Send Feedback
A depth-stencil-view-variable interface accesses a depth-stencil view.

(Also see DirectX SDK: ID3D10EffectDepthStencilViewVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectDepthStencilViewVariable : EffectVariable
Visual Basic
Public Class EffectDepthStencilViewVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectDepthStencilViewVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectDepthStencilViewVariable

See Also

EffectDepthStencilViewVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDepthStencilViewVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilViewVariable Members
EffectDepthStencilViewVariable Class Methods Properties See Also Send Feedback

The EffectDepthStencilViewVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetDepthStencilArray | Get a collection of depth-stencil-view resources. (Also see DirectX SDK: ID3D10EffectDepthStencilViewVariable::GetDepthStencilArray)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetDepthStencilArray |
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | DepthStencil | Gets or sets a depth-stencil-view resource. (Also see DirectX SDK: ID3D10EffectDepthStencilViewVariable::GetDepthStencil, ID3D10EffectDepthStencilViewVariable::SetDepthStencil)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectDepthStencilViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDepthStencilViewVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilViewVariable Methods
EffectDepthStencilViewVariable Class See Also Send Feedback

The EffectDepthStencilViewVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetDepthStencilArray | Get a collection of depth-stencil-view resources. (Also see DirectX SDK: ID3D10EffectDepthStencilViewVariable::GetDepthStencilArray)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetDepthStencilArray |
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectDepthStencilViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetDepthStencilArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilViewVariable..::..GetDepthStencilArray Method
EffectDepthStencilViewVariable Class See Also Send Feedback
Get a collection of depth-stencil-view resources.

(Also see DirectX SDK: ID3D10EffectDepthStencilViewVariable::GetDepthStencilArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<DepthStencilView> GetDepthStencilArray(
    uint offset,
    uint count
)
Visual Basic
Public Function GetDepthStencilArray ( _
    offset As UInteger, _
    count As UInteger _
) As ReadOnlyCollection(Of DepthStencilView)
Visual C++
public:
ReadOnlyCollection<DepthStencilView^>^ GetDepthStencilArray(
    unsigned int offset,
    unsigned int count
)

Parameters

offset
Type: System..::..UInt32
The zero-based array index to get the first object.
count
Type: System..::..UInt32
The number of elements requested in the collection.

Return Value

A collection of depth-stencil-view interfaces.

See Also

EffectDepthStencilViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetDepthStencilArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilViewVariable..::..SetDepthStencilArray Method
EffectDepthStencilViewVariable Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetDepthStencilArray(
    IEnumerable<DepthStencilView> resources,
    uint offset
)
Visual Basic
Public Sub SetDepthStencilArray ( _
    resources As IEnumerable(Of DepthStencilView), _
    offset As UInteger _
)
Visual C++
public:
void SetDepthStencilArray(
    IEnumerable<DepthStencilView^>^ resources,
    unsigned int offset
)

Parameters

resources
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' DepthStencilView >)>)>
offset
Type: System..::..UInt32

See Also

EffectDepthStencilViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDepthStencilViewVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilViewVariable Properties
EffectDepthStencilViewVariable Class See Also Send Feedback

The EffectDepthStencilViewVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | DepthStencil | Gets or sets a depth-stencil-view resource. (Also see DirectX SDK: ID3D10EffectDepthStencilViewVariable::GetDepthStencil, ID3D10EffectDepthStencilViewVariable::SetDepthStencil)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectDepthStencilViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencil Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDepthStencilViewVariable..::..DepthStencil Property
EffectDepthStencilViewVariable Class See Also Send Feedback
Gets or sets a depth-stencil-view resource.

(Also see DirectX SDK: ID3D10EffectDepthStencilViewVariable::GetDepthStencil, ID3D10EffectDepthStencilViewVariable::SetDepthStencil)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilView DepthStencil { get; set; }
Visual Basic
Public Property DepthStencil As DepthStencilView
    Get
    Set
Visual C++
public:
property DepthStencilView^ DepthStencil {
    DepthStencilView^ get ();
    void set (DepthStencilView^ value);
}

See Also

EffectDepthStencilViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription Structure
Members See Also Send Feedback
Describes an effect.

(Also see DirectX SDK: D3D10_EFFECT_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct EffectDescription
Visual Basic
Public Structure EffectDescription
Visual C++
public value class EffectDescription

See Also

EffectDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription Members
EffectDescription Structure Methods Operators Properties See Also Send Feedback

The EffectDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ConstantBuffers | The number of constant buffers. (Also see DirectX SDK: D3D10_EFFECT_DESC.ConstantBuffers)
Public property | GlobalVariables | The number of global variables. (Also see DirectX SDK: D3D10_EFFECT_DESC.GlobalVariables)
Public property | IsChildEffect | TRUE if the effect is a child effect; otherwise FALSE. (Also see DirectX SDK: D3D10_EFFECT_DESC.IsChildEffect)
Public property | SharedConstantBuffers | The number of constant buffers shared in an effect pool. (Also see DirectX SDK: D3D10_EFFECT_DESC.SharedConstantBuffers)
Public property | SharedGlobalVariables | The number of global variables shared in an effect pool. (Also see DirectX SDK: D3D10_EFFECT_DESC.SharedGlobalVariables)
Public property | Techniques | The number of techniques. (Also see DirectX SDK: D3D10_EFFECT_DESC.Techniques)

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription Methods
EffectDescription Structure See Also Send Feedback

The EffectDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..Equals Method
EffectDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..GetHashCode Method
EffectDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription Operators
EffectDescription Structure See Also Send Feedback

The EffectDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..Equality Operator
EffectDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    EffectDescription effectDescription1,
    EffectDescription effectDescription2
)
Visual Basic
Public Shared Operator = ( _
    effectDescription1 As EffectDescription, _
    effectDescription2 As EffectDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    EffectDescription effectDescription1,
    EffectDescription effectDescription2
)

Parameters

effectDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectDescription
effectDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectDescription

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..Inequality Operator
EffectDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    EffectDescription effectDescription1,
    EffectDescription effectDescription2
)
Visual Basic
Public Shared Operator <> ( _
    effectDescription1 As EffectDescription, _
    effectDescription2 As EffectDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    EffectDescription effectDescription1,
    EffectDescription effectDescription2
)

Parameters

effectDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectDescription
effectDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectDescription

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription Properties
EffectDescription Structure See Also Send Feedback

The EffectDescription type exposes the following members.

Properties

 | Name | Description
Public property | ConstantBuffers | The number of constant buffers. (Also see DirectX SDK: D3D10_EFFECT_DESC.ConstantBuffers)
Public property | GlobalVariables | The number of global variables. (Also see DirectX SDK: D3D10_EFFECT_DESC.GlobalVariables)
Public property | IsChildEffect | TRUE if the effect is a child effect; otherwise FALSE. (Also see DirectX SDK: D3D10_EFFECT_DESC.IsChildEffect)
Public property | SharedConstantBuffers | The number of constant buffers shared in an effect pool. (Also see DirectX SDK: D3D10_EFFECT_DESC.SharedConstantBuffers)
Public property | SharedGlobalVariables | The number of global variables shared in an effect pool. (Also see DirectX SDK: D3D10_EFFECT_DESC.SharedGlobalVariables)
Public property | Techniques | The number of techniques. (Also see DirectX SDK: D3D10_EFFECT_DESC.Techniques)

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ConstantBuffers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..ConstantBuffers Property
EffectDescription Structure See Also Send Feedback
The number of constant buffers.

(Also see DirectX SDK: D3D10_EFFECT_DESC.ConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ConstantBuffers { get; set; }
Visual Basic
Public Property ConstantBuffers As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ConstantBuffers {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GlobalVariables Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..GlobalVariables Property
EffectDescription Structure See Also Send Feedback
The number of global variables.

(Also see DirectX SDK: D3D10_EFFECT_DESC.GlobalVariables)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint GlobalVariables { get; set; }
Visual Basic
Public Property GlobalVariables As UInteger
    Get
    Set
Visual C++
public:
property unsigned int GlobalVariables {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsChildEffect Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..IsChildEffect Property
EffectDescription Structure See Also Send Feedback
TRUE if the effect is a child effect; otherwise FALSE.

(Also see DirectX SDK: D3D10_EFFECT_DESC.IsChildEffect)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsChildEffect { get; set; }
Visual Basic
Public Property IsChildEffect As Boolean
    Get
    Set
Visual C++
public:
property bool IsChildEffect {
    bool get ();
    void set (bool value);
}

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SharedConstantBuffers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..SharedConstantBuffers Property
EffectDescription Structure See Also Send Feedback
The number of constant buffers shared in an effect pool.

(Also see DirectX SDK: D3D10_EFFECT_DESC.SharedConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SharedConstantBuffers { get; set; }
Visual Basic
Public Property SharedConstantBuffers As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SharedConstantBuffers {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SharedGlobalVariables Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..SharedGlobalVariables Property
EffectDescription Structure See Also Send Feedback
The number of global variables shared in an effect pool.

(Also see DirectX SDK: D3D10_EFFECT_DESC.SharedGlobalVariables)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SharedGlobalVariables { get; set; }
Visual Basic
Public Property SharedGlobalVariables As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SharedGlobalVariables {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Techniques Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectDescription..::..Techniques Property
EffectDescription Structure See Also Send Feedback
The number of techniques.

(Also see DirectX SDK: D3D10_EFFECT_DESC.Techniques)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Techniques { get; set; }
Visual Basic
Public Property Techniques As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Techniques {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectMatrixVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable Class
Members See Also Send Feedback
A matrix-variable interface accesses a matrix.

(Also see DirectX SDK: ID3D10EffectMatrixVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectMatrixVariable : EffectVariable
Visual Basic
Public Class EffectMatrixVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectMatrixVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectMatrixVariable

See Also

EffectMatrixVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectMatrixVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable Members
EffectMatrixVariable Class Methods Properties See Also Send Feedback

The EffectMatrixVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMatrixArray | Get an array of 4x4 matrices. (Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrixArray)
Public method | GetMatrixTransposeArray | Transpose and get an array of 4x4 floating-point matrices. (Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrixTransposeArray)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetMatrixArray | Set an array of 4x4 floating-point matrices. (Also see DirectX SDK: ID3D10EffectMatrixVariable::SetMatrixArray)
Public method | SetMatrixTransposeArray | Transpose and set an array of 4x4 floating-point matrices. (Also see DirectX SDK: ID3D10EffectMatrixVariable::SetMatrixTransposeArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | Matrix | Get a 4x4 floating point matrix. (Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrix, ID3D10EffectMatrixVariable::SetMatrix)
Public property | MatrixTranspose | Set or get a 4x4 floating point matrix transpose. (Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrixTranspose, ID3D10EffectMatrixVariable::SetMatrixTranspose)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectMatrixVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectMatrixVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable Methods
EffectMatrixVariable Class See Also Send Feedback

The EffectMatrixVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMatrixArray | Get an array of 4x4 matrices. (Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrixArray)
Public method | GetMatrixTransposeArray | Transpose and get an array of 4x4 floating-point matrices. (Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrixTransposeArray)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetMatrixArray | Set an array of 4x4 floating-point matrices. (Also see DirectX SDK: ID3D10EffectMatrixVariable::SetMatrixArray)
Public method | SetMatrixTransposeArray | Transpose and set an array of 4x4 floating-point matrices. (Also see DirectX SDK: ID3D10EffectMatrixVariable::SetMatrixTransposeArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectMatrixVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMatrixArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable..::..GetMatrixArray Method
EffectMatrixVariable Class See Also Send Feedback
Get an array of 4x4 matrices.

(Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrixArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix4x4F[] GetMatrixArray(
    uint offset,
    uint count
)
Visual Basic
Public Function GetMatrixArray ( _
    offset As UInteger, _
    count As UInteger _
) As Matrix4x4F()
Visual C++
public:
array<Matrix4x4F>^ GetMatrixArray(
    unsigned int offset,
    unsigned int count
)

Parameters

offset
Type: System..::..UInt32
The offset (in number of matrices) between the start of the array and the first matrix returned.
count
Type: System..::..UInt32
The number of matrices requested in the returned collection.

Return Value

A two dimentional array of matrices.

See Also

EffectMatrixVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMatrixTransposeArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable..::..GetMatrixTransposeArray Method
EffectMatrixVariable Class See Also Send Feedback
Transpose and get an array of 4x4 floating-point matrices.

(Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrixTransposeArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix4x4F[] GetMatrixTransposeArray(
    uint offset,
    uint count
)
Visual Basic
Public Function GetMatrixTransposeArray ( _
    offset As UInteger, _
    count As UInteger _
) As Matrix4x4F()
Visual C++
public:
array<Matrix4x4F>^ GetMatrixTransposeArray(
    unsigned int offset,
    unsigned int count
)

Parameters

offset
Type: System..::..UInt32
The offset (in number of matrices) between the start of the array and the first matrix to get.
count
Type: System..::..UInt32
The number of matrices in the array to get.

Return Value

A two dimentional array of tranposed matrices.

See Also

EffectMatrixVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetMatrixArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable..::..SetMatrixArray Method
EffectMatrixVariable Class See Also Send Feedback
Set an array of 4x4 floating-point matrices.

(Also see DirectX SDK: ID3D10EffectMatrixVariable::SetMatrixArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetMatrixArray(
    Matrix4x4F[] data,
    uint offset
)
Visual Basic
Public Sub SetMatrixArray ( _
    data As Matrix4x4F(), _
    offset As UInteger _
)
Visual C++
public:
void SetMatrixArray(
    array<Matrix4x4F>^ data,
    unsigned int offset
)

Parameters

data
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F >[]()[][]
The matrix two dimentional array.
offset
Type: System..::..UInt32
The number of matrix elements to skip from the start of the array.

See Also

EffectMatrixVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetMatrixTransposeArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable..::..SetMatrixTransposeArray Method
EffectMatrixVariable Class See Also Send Feedback
Transpose and set an array of 4x4 floating-point matrices.

(Also see DirectX SDK: ID3D10EffectMatrixVariable::SetMatrixTransposeArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetMatrixTransposeArray(
    Matrix4x4F[] data,
    uint offset
)
Visual Basic
Public Sub SetMatrixTransposeArray ( _
    data As Matrix4x4F(), _
    offset As UInteger _
)
Visual C++
public:
void SetMatrixTransposeArray(
    array<Matrix4x4F>^ data,
    unsigned int offset
)

Parameters

data
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Matrix4x4F >[]()[][]
A two dimentional array of matrices.
offset
Type: System..::..UInt32
The offset (in number of matrices) between the start of the array and the first matrix to set.

See Also

EffectMatrixVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectMatrixVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable Properties
EffectMatrixVariable Class See Also Send Feedback

The EffectMatrixVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | Matrix | Get a 4x4 floating point matrix. (Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrix, ID3D10EffectMatrixVariable::SetMatrix)
Public property | MatrixTranspose | Set or get a 4x4 floating point matrix transpose. (Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrixTranspose, ID3D10EffectMatrixVariable::SetMatrixTranspose)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectMatrixVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Matrix Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable..::..Matrix Property
EffectMatrixVariable Class See Also Send Feedback
Get a 4x4 floating point matrix.

(Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrix, ID3D10EffectMatrixVariable::SetMatrix)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix4x4F Matrix { get; set; }
Visual Basic
Public Property Matrix As Matrix4x4F
    Get
    Set
Visual C++
public:
property Matrix4x4F Matrix {
    Matrix4x4F get ();
    void set (Matrix4x4F value);
}

See Also

EffectMatrixVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MatrixTranspose Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectMatrixVariable..::..MatrixTranspose Property
EffectMatrixVariable Class See Also Send Feedback
Set or get a 4x4 floating point matrix transpose.

(Also see DirectX SDK: ID3D10EffectMatrixVariable::GetMatrixTranspose, ID3D10EffectMatrixVariable::SetMatrixTranspose)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Matrix4x4F MatrixTranspose { get; set; }
Visual Basic
Public Property MatrixTranspose As Matrix4x4F
    Get
    Set
Visual C++
public:
property Matrix4x4F MatrixTranspose {
    Matrix4x4F get ();
    void set (Matrix4x4F value);
}

See Also

EffectMatrixVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectPass Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass Class
Members See Also Send Feedback
A pass interface encapsulates state assignments within a technique.

(Also see DirectX SDK: ID3D10EffectPass)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectPass : DirectObject
Visual Basic
Public Class EffectPass _
    Inherits DirectObject
Visual C++
public ref class EffectPass : public DirectObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectPass

See Also

EffectPass Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectPass Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass Members
EffectPass Class Methods Properties See Also Send Feedback

The EffectPass type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Set the state contained in a pass to the device. (Also see DirectX SDK: ID3D10EffectPass::Apply)
Public method | ComputeStateBlockMask | Generate a mask for allowing/preventing state changes. (Also see DirectX SDK: ID3D10EffectPass::ComputeStateBlockMask)
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectPass::GetAnnotationByIndex)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectPass::GetAnnotationByName)

Properties

 | Name | Description
Public property | Description | Get a pass description. (Also see DirectX SDK: ID3D10EffectPass::GetDesc)
Public property | GeometryShaderDescription | Get a geometry-shader description. (Also see DirectX SDK: ID3D10EffectPass::GetGeometryShaderDesc)
Public property | IsValid | Test a pass to see if it contains valid syntax. (Also see DirectX SDK: ID3D10EffectPass::IsValid)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | PixelShaderDescription | Get a pixel-shader description. (Also see DirectX SDK: ID3D10EffectPass::GetPixelShaderDesc)
Public property | VertexShaderDescription | Get a vertex-shader description. (Also see DirectX SDK: ID3D10EffectPass::GetVertexShaderDesc)

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectPass Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass Methods
EffectPass Class See Also Send Feedback

The EffectPass type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Set the state contained in a pass to the device. (Also see DirectX SDK: ID3D10EffectPass::Apply)
Public method | ComputeStateBlockMask | Generate a mask for allowing/preventing state changes. (Also see DirectX SDK: ID3D10EffectPass::ComputeStateBlockMask)
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectPass::GetAnnotationByIndex)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectPass::GetAnnotationByName)

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Apply Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass..::..Apply Method
EffectPass Class See Also Send Feedback
Set the state contained in a pass to the device.

(Also see DirectX SDK: ID3D10EffectPass::Apply)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Apply()
Visual Basic
Public Sub Apply
Visual C++
public:
void Apply()

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ComputeStateBlockMask Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass..::..ComputeStateBlockMask Method
EffectPass Class See Also Send Feedback
Generate a mask for allowing/preventing state changes.

(Also see DirectX SDK: ID3D10EffectPass::ComputeStateBlockMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask ComputeStateBlockMask()
Visual Basic
Public Function ComputeStateBlockMask As StateBlockMask
Visual C++
public:
StateBlockMask^ ComputeStateBlockMask()

Return Value

A state-block mask (see StateBlockMask).

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask


GetAnnotationByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass..::..GetAnnotationByIndex Method
EffectPass Class See Also Send Feedback
Get an annotation by index.

(Also see DirectX SDK: ID3D10EffectPass::GetAnnotationByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetAnnotationByIndex(
    uint index
)
Visual Basic
Public Function GetAnnotationByIndex ( _
    index As UInteger _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetAnnotationByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

Return Value

An EffectVariable instance.

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetAnnotationByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass..::..GetAnnotationByName Method
EffectPass Class See Also Send Feedback
Get an annotation by name.

(Also see DirectX SDK: ID3D10EffectPass::GetAnnotationByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetAnnotationByName(
    string name
)
Visual Basic
Public Function GetAnnotationByName ( _
    name As String _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetAnnotationByName(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the annotation.

Return Value

An EffectVariable instance.

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectPass Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass Properties
EffectPass Class See Also Send Feedback

The EffectPass type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get a pass description. (Also see DirectX SDK: ID3D10EffectPass::GetDesc)
Public property | GeometryShaderDescription | Get a geometry-shader description. (Also see DirectX SDK: ID3D10EffectPass::GetGeometryShaderDesc)
Public property | IsValid | Test a pass to see if it contains valid syntax. (Also see DirectX SDK: ID3D10EffectPass::IsValid)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | PixelShaderDescription | Get a pixel-shader description. (Also see DirectX SDK: ID3D10EffectPass::GetPixelShaderDesc)
Public property | VertexShaderDescription | Get a vertex-shader description. (Also see DirectX SDK: ID3D10EffectPass::GetVertexShaderDesc)

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass..::..Description Property
EffectPass Class See Also Send Feedback
Get a pass description.

(Also see DirectX SDK: ID3D10EffectPass::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PassDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As PassDescription
    Get
Visual C++
public:
property PassDescription Description {
    PassDescription get ();
}

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderDescription Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass..::..GeometryShaderDescription Property
EffectPass Class See Also Send Feedback
Get a geometry-shader description.

(Also see DirectX SDK: ID3D10EffectPass::GetGeometryShaderDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PassShaderDescription GeometryShaderDescription { get; }
Visual Basic
Public ReadOnly Property GeometryShaderDescription As PassShaderDescription
    Get
Visual C++
public:
property PassShaderDescription GeometryShaderDescription {
    PassShaderDescription get ();
}

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsValid Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass..::..IsValid Property
EffectPass Class See Also Send Feedback
Test a pass to see if it contains valid syntax.

(Also see DirectX SDK: ID3D10EffectPass::IsValid)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderDescription Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass..::..PixelShaderDescription Property
EffectPass Class See Also Send Feedback
Get a pixel-shader description.

(Also see DirectX SDK: ID3D10EffectPass::GetPixelShaderDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PassShaderDescription PixelShaderDescription { get; }
Visual Basic
Public ReadOnly Property PixelShaderDescription As PassShaderDescription
    Get
Visual C++
public:
property PassShaderDescription PixelShaderDescription {
    PassShaderDescription get ();
}

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderDescription Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPass..::..VertexShaderDescription Property
EffectPass Class See Also Send Feedback
Get a vertex-shader description.

(Also see DirectX SDK: ID3D10EffectPass::GetVertexShaderDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PassShaderDescription VertexShaderDescription { get; }
Visual Basic
Public ReadOnly Property VertexShaderDescription As PassShaderDescription
    Get
Visual C++
public:
property PassShaderDescription VertexShaderDescription {
    PassShaderDescription get ();
}

See Also

EffectPass Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectPool Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPool Class
Members See Also Send Feedback
A pool interface represents a common memory space (or pool) for sharing variables between effects.

(Also see DirectX SDK: ID3D10EffectPool)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectPool : DirectUnknown
Visual Basic
Public Class EffectPool _
    Inherits DirectUnknown
Visual C++
public ref class EffectPool : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectPool

See Also

EffectPool Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectPool Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPool Members
EffectPool Class Properties See Also Send Feedback

The EffectPool type exposes the following members.

Properties

 | Name | Description
Public property | AsEffect | Get the effect that created the effect pool. (Also see DirectX SDK: ID3D10EffectPool::AsEffect)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

EffectPool Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectPool Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPool Properties
EffectPool Class See Also Send Feedback

The EffectPool type exposes the following members.

Properties

 | Name | Description
Public property | AsEffect | Get the effect that created the effect pool. (Also see DirectX SDK: ID3D10EffectPool::AsEffect)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

EffectPool Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsEffect Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectPool..::..AsEffect Property
EffectPool Class See Also Send Feedback
Get the effect that created the effect pool.

(Also see DirectX SDK: ID3D10EffectPool::AsEffect)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Effect AsEffect { get; }
Visual Basic
Public ReadOnly Property AsEffect As Effect
    Get
Visual C++
public:
property Effect^ AsEffect {
    Effect^ get ();
}

See Also

EffectPool Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectRasterizerVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRasterizerVariable Class
Members See Also Send Feedback
A rasterizer-variable interface accesses rasterizer state.

(Also see DirectX SDK: ID3D10EffectRasterizerVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectRasterizerVariable : EffectVariable
Visual Basic
Public Class EffectRasterizerVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectRasterizerVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectRasterizerVariable

See Also

EffectRasterizerVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectRasterizerVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRasterizerVariable Members
EffectRasterizerVariable Class Methods Properties See Also Send Feedback

The EffectRasterizerVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBackingStore | Get a variable that contains rasteriser state. (Also see DirectX SDK: ID3D10EffectRasterizerVariable::GetBackingStore)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRasterizerState | Get a rasterizer object. (Also see DirectX SDK: ID3D10EffectRasterizerVariable::GetRasterizerState)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectRasterizerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectRasterizerVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRasterizerVariable Methods
EffectRasterizerVariable Class See Also Send Feedback

The EffectRasterizerVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBackingStore | Get a variable that contains rasteriser state. (Also see DirectX SDK: ID3D10EffectRasterizerVariable::GetBackingStore)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRasterizerState | Get a rasterizer object. (Also see DirectX SDK: ID3D10EffectRasterizerVariable::GetRasterizerState)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectRasterizerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetBackingStore Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRasterizerVariable..::..GetBackingStore Method
EffectRasterizerVariable Class See Also Send Feedback
Get a variable that contains rasteriser state.

(Also see DirectX SDK: ID3D10EffectRasterizerVariable::GetBackingStore)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerDescription GetBackingStore(
    uint index
)
Visual Basic
Public Function GetBackingStore ( _
    index As UInteger _
) As RasterizerDescription
Visual C++
public:
RasterizerDescription GetBackingStore(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Index into an array of rasteriser-state descriptions. If there is only one rasteriser variable in the effect, use 0.

Return Value

A rasteriser-state description (see RasterizerDescription).

See Also

EffectRasterizerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerDescription


GetRasterizerState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRasterizerVariable..::..GetRasterizerState Method
EffectRasterizerVariable Class See Also Send Feedback
Get a rasterizer object.

(Also see DirectX SDK: ID3D10EffectRasterizerVariable::GetRasterizerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerState GetRasterizerState(
    uint index
)
Visual Basic
Public Function GetRasterizerState ( _
    index As UInteger _
) As RasterizerState
Visual C++
public:
RasterizerState^ GetRasterizerState(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Index into an array of rasterizer interfaces. If there is only one rasterizer interface, use 0.

Return Value

A rasterizer interface (see RasterizerState Object).

See Also

EffectRasterizerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectRasterizerVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRasterizerVariable Properties
EffectRasterizerVariable Class See Also Send Feedback

The EffectRasterizerVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectRasterizerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectRenderTargetViewVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRenderTargetViewVariable Class
Members See Also Send Feedback
A render-target-view interface accesses a render target.

(Also see DirectX SDK: ID3D10EffectRenderTargetViewVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectRenderTargetViewVariable : EffectVariable
Visual Basic
Public Class EffectRenderTargetViewVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectRenderTargetViewVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectRenderTargetViewVariable

See Also

EffectRenderTargetViewVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectRenderTargetViewVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRenderTargetViewVariable Members
EffectRenderTargetViewVariable Class Methods Properties See Also Send Feedback

The EffectRenderTargetViewVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetRenderTargetCollection | Get a collection array of render-targets. (Also see DirectX SDK: ID3D10EffectRenderTargetViewVariable::GetRenderTargetArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)
Public method | SetRenderTargetCollection |

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)
Public property | RenderTarget | Gets or sets a render-target. (Also see DirectX SDK: ID3D10EffectRenderTargetViewVariable::GetRenderTarget, ID3D10EffectRenderTargetViewVariable::SetRenderTarget)

See Also

EffectRenderTargetViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectRenderTargetViewVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRenderTargetViewVariable Methods
EffectRenderTargetViewVariable Class See Also Send Feedback

The EffectRenderTargetViewVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetRenderTargetCollection | Get a collection array of render-targets. (Also see DirectX SDK: ID3D10EffectRenderTargetViewVariable::GetRenderTargetArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)
Public method | SetRenderTargetCollection |

See Also

EffectRenderTargetViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetRenderTargetCollection Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRenderTargetViewVariable..::..GetRenderTargetCollection Method
EffectRenderTargetViewVariable Class See Also Send Feedback
Get a collection array of render-targets.

(Also see DirectX SDK: ID3D10EffectRenderTargetViewVariable::GetRenderTargetArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<RenderTargetView> GetRenderTargetCollection(
    uint offset,
    uint count
)
Visual Basic
Public Function GetRenderTargetCollection ( _
    offset As UInteger, _
    count As UInteger _
) As ReadOnlyCollection(Of RenderTargetView)
Visual C++
public:
ReadOnlyCollection<RenderTargetView^>^ GetRenderTargetCollection(
    unsigned int offset,
    unsigned int count
)

Parameters

offset
Type: System..::..UInt32
The zero-based collection index to get the first object.
count
Type: System..::..UInt32
The number of elements requested in the collection.

Return Value

A collection of render-target-view interfaces. See RenderTargetView Object.

See Also

EffectRenderTargetViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetRenderTargetCollection Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRenderTargetViewVariable..::..SetRenderTargetCollection Method
EffectRenderTargetViewVariable Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetRenderTargetCollection(
    IEnumerable<RenderTargetView> resources,
    uint offset
)
Visual Basic
Public Sub SetRenderTargetCollection ( _
    resources As IEnumerable(Of RenderTargetView), _
    offset As UInteger _
)
Visual C++
public:
void SetRenderTargetCollection(
    IEnumerable<RenderTargetView^>^ resources,
    unsigned int offset
)

Parameters

resources
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RenderTargetView >)>)>
offset
Type: System..::..UInt32

See Also

EffectRenderTargetViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectRenderTargetViewVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRenderTargetViewVariable Properties
EffectRenderTargetViewVariable Class See Also Send Feedback

The EffectRenderTargetViewVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)
Public property | RenderTarget | Gets or sets a render-target. (Also see DirectX SDK: ID3D10EffectRenderTargetViewVariable::GetRenderTarget, ID3D10EffectRenderTargetViewVariable::SetRenderTarget)

See Also

EffectRenderTargetViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTarget Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectRenderTargetViewVariable..::..RenderTarget Property
EffectRenderTargetViewVariable Class See Also Send Feedback
Gets or sets a render-target.

(Also see DirectX SDK: ID3D10EffectRenderTargetViewVariable::GetRenderTarget, ID3D10EffectRenderTargetViewVariable::SetRenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetView RenderTarget { get; set; }
Visual Basic
Public Property RenderTarget As RenderTargetView
    Get
    Set
Visual C++
public:
property RenderTargetView^ RenderTarget {
    RenderTargetView^ get ();
    void set (RenderTargetView^ value);
}

See Also

EffectRenderTargetViewVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectSamplerVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectSamplerVariable Class
Members See Also Send Feedback
A sampler interface accesses sampler state.

(Also see DirectX SDK: ID3D10EffectSamplerVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectSamplerVariable : EffectVariable
Visual Basic
Public Class EffectSamplerVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectSamplerVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectSamplerVariable

See Also

EffectSamplerVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectSamplerVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectSamplerVariable Members
EffectSamplerVariable Class Methods Properties See Also Send Feedback

The EffectSamplerVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBackingStore | Get a variable that contains sampler state. (Also see DirectX SDK: ID3D10EffectSamplerVariable::GetBackingStore)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetSampler | Get a sampler object. (Also see DirectX SDK: ID3D10EffectSamplerVariable::GetSampler)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectSamplerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectSamplerVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectSamplerVariable Methods
EffectSamplerVariable Class See Also Send Feedback

The EffectSamplerVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBackingStore | Get a variable that contains sampler state. (Also see DirectX SDK: ID3D10EffectSamplerVariable::GetBackingStore)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetSampler | Get a sampler object. (Also see DirectX SDK: ID3D10EffectSamplerVariable::GetSampler)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectSamplerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetBackingStore Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectSamplerVariable..::..GetBackingStore Method
EffectSamplerVariable Class See Also Send Feedback
Get a variable that contains sampler state.

(Also see DirectX SDK: ID3D10EffectSamplerVariable::GetBackingStore)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SamplerDescription GetBackingStore(
    uint index
)
Visual Basic
Public Function GetBackingStore ( _
    index As UInteger _
) As SamplerDescription
Visual C++
public:
SamplerDescription GetBackingStore(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Index into an array of sampler descriptions. If there is only one sampler variable in the effect, use 0.

Return Value

A sampler description (see SamplerDescription).

See Also

EffectSamplerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerDescription


GetSampler Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectSamplerVariable..::..GetSampler Method
EffectSamplerVariable Class See Also Send Feedback
Get a sampler object.

(Also see DirectX SDK: ID3D10EffectSamplerVariable::GetSampler)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SamplerState GetSampler(
    uint index
)
Visual Basic
Public Function GetSampler ( _
    index As UInteger _
) As SamplerState
Visual C++
public:
SamplerState^ GetSampler(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Index into an array of sampler interfaces. If there is only one sampler interface, use 0.

Return Value

A sampler interface (see SamplerState).

See Also

EffectSamplerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectSamplerVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectSamplerVariable Properties
EffectSamplerVariable Class See Also Send Feedback

The EffectSamplerVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectSamplerVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectScalarVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable Class
Members See Also Send Feedback
An effect-scalar-variable interface accesses scalar values.

(Also see DirectX SDK: ID3D10EffectScalarVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectScalarVariable : EffectVariable
Visual Basic
Public Class EffectScalarVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectScalarVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectScalarVariable

See Also

EffectScalarVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectScalarVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable Members
EffectScalarVariable Class Methods Properties See Also Send Feedback

The EffectScalarVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBooleanArray | Get an array of boolean variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetBoolArray)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetInt32Array | Get an array of integer variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetIntArray)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetSingleArray | Get an array of floating-point variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetFloatArray)
Public method | SetBooleanArray | Set an array of boolean variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::SetBoolArray)
Public method | SetInt32Array | Set an array of integer variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::SetIntArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)
Public method | SetSingleArray | Set an array of floating-point variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::SetFloatArray)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsBoolean | Get or set a boolean variable. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetBool, ID3D10EffectScalarVariable::SetBool)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsInt32 | Get or set an integer variable. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetInt, ID3D10EffectScalarVariable::SetInt)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsSingle | Get or set a floating-point variable. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetFloat, ID3D10EffectScalarVariable::SetFloat)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectScalarVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable Methods
EffectScalarVariable Class See Also Send Feedback

The EffectScalarVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBooleanArray | Get an array of boolean variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetBoolArray)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetInt32Array | Get an array of integer variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetIntArray)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetSingleArray | Get an array of floating-point variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetFloatArray)
Public method | SetBooleanArray | Set an array of boolean variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::SetBoolArray)
Public method | SetInt32Array | Set an array of integer variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::SetIntArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)
Public method | SetSingleArray | Set an array of floating-point variables. (Also see DirectX SDK: ID3D10EffectScalarVariable::SetFloatArray)

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetBooleanArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable..::..GetBooleanArray Method
EffectScalarVariable Class See Also Send Feedback
Get an array of boolean variables.

(Also see DirectX SDK: ID3D10EffectScalarVariable::GetBoolArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool[] GetBooleanArray(
    uint count
)
Visual Basic
Public Function GetBooleanArray ( _
    count As UInteger _
) As Boolean()
Visual C++
public:
array<bool>^ GetBooleanArray(
    unsigned int count
)

Parameters

count
Type: System..::..UInt32
The number of array elements to get.

Return Value

The array of boolean variables.

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetInt32Array Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable..::..GetInt32Array Method
EffectScalarVariable Class See Also Send Feedback
Get an array of integer variables.

(Also see DirectX SDK: ID3D10EffectScalarVariable::GetIntArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int[] GetInt32Array(
    uint count
)
Visual Basic
Public Function GetInt32Array ( _
    count As UInteger _
) As Integer()
Visual C++
public:
array<int>^ GetInt32Array(
    unsigned int count
)

Parameters

count
Type: System..::..UInt32
The number of array elements to get.

Return Value

The array of integer variables.

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetSingleArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable..::..GetSingleArray Method
EffectScalarVariable Class See Also Send Feedback
Get an array of floating-point variables.

(Also see DirectX SDK: ID3D10EffectScalarVariable::GetFloatArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float[] GetSingleArray(
    uint count
)
Visual Basic
Public Function GetSingleArray ( _
    count As UInteger _
) As Single()
Visual C++
public:
array<float>^ GetSingleArray(
    unsigned int count
)

Parameters

count
Type: System..::..UInt32
The number of array elements to get.

Return Value

The array of floating-point variables.

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetBooleanArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable..::..SetBooleanArray Method
EffectScalarVariable Class See Also Send Feedback
Set an array of boolean variables.

(Also see DirectX SDK: ID3D10EffectScalarVariable::SetBoolArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetBooleanArray(
    bool[] data
)
Visual Basic
Public Sub SetBooleanArray ( _
    data As Boolean() _
)
Visual C++
public:
void SetBooleanArray(
    array<bool>^ data
)

Parameters

data
Type: array< System..::..Boolean >[]()[][]
The array of variables to set.

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetInt32Array Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable..::..SetInt32Array Method
EffectScalarVariable Class See Also Send Feedback
Set an array of integer variables.

(Also see DirectX SDK: ID3D10EffectScalarVariable::SetIntArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetInt32Array(
    int[] data
)
Visual Basic
Public Sub SetInt32Array ( _
    data As Integer() _
)
Visual C++
public:
void SetInt32Array(
    array<int>^ data
)

Parameters

data
Type: array< System..::..Int32 >[]()[][]
The array of variables to set.

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetSingleArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable..::..SetSingleArray Method
EffectScalarVariable Class See Also Send Feedback
Set an array of floating-point variables.

(Also see DirectX SDK: ID3D10EffectScalarVariable::SetFloatArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSingleArray(
    float[] data
)
Visual Basic
Public Sub SetSingleArray ( _
    data As Single() _
)
Visual C++
public:
void SetSingleArray(
    array<float>^ data
)

Parameters

data
Type: array< System..::..Single >[]()[][]
The array of variables to set.

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectScalarVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable Properties
EffectScalarVariable Class See Also Send Feedback

The EffectScalarVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsBoolean | Get or set a boolean variable. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetBool, ID3D10EffectScalarVariable::SetBool)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsInt32 | Get or set an integer variable. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetInt, ID3D10EffectScalarVariable::SetInt)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsSingle | Get or set a floating-point variable. (Also see DirectX SDK: ID3D10EffectScalarVariable::GetFloat, ID3D10EffectScalarVariable::SetFloat)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsBoolean Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable..::..AsBoolean Property
EffectScalarVariable Class See Also Send Feedback
Get or set a boolean variable.

(Also see DirectX SDK: ID3D10EffectScalarVariable::GetBool, ID3D10EffectScalarVariable::SetBool)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool AsBoolean { get; set; }
Visual Basic
Public Property AsBoolean As Boolean
    Get
    Set
Visual C++
public:
property bool AsBoolean {
    bool get ();
    void set (bool value);
}

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsInt32 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable..::..AsInt32 Property
EffectScalarVariable Class See Also Send Feedback
Get or set an integer variable.

(Also see DirectX SDK: ID3D10EffectScalarVariable::GetInt, ID3D10EffectScalarVariable::SetInt)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int AsInt32 { get; set; }
Visual Basic
Public Property AsInt32 As Integer
    Get
    Set
Visual C++
public:
property int AsInt32 {
    int get ();
    void set (int value);
}

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsSingle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectScalarVariable..::..AsSingle Property
EffectScalarVariable Class See Also Send Feedback
Get or set a floating-point variable.

(Also see DirectX SDK: ID3D10EffectScalarVariable::GetFloat, ID3D10EffectScalarVariable::SetFloat)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float AsSingle { get; set; }
Visual Basic
Public Property AsSingle As Single
    Get
    Set
Visual C++
public:
property float AsSingle {
    float get ();
    void set (float value);
}

See Also

EffectScalarVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription Structure
Members See Also Send Feedback
Describes an effect shader.

(Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct EffectShaderDescription
Visual Basic
Public Structure EffectShaderDescription
Visual C++
public value class EffectShaderDescription

See Also

EffectShaderDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription Members
EffectShaderDescription Structure Properties See Also Send Feedback

The EffectShaderDescription type exposes the following members.

Properties

 | Name | Description
Public property | Bytecode | The compiled shader. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.pBytecode)
Public property | BytecodeLength | The length of pBytecode. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.BytecodeLength)
Public property | InputSignature | Passed into CreateInputLayout. Only valid on a vertex shader or geometry shader. See ID3D10Device_CreateInputLayout. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.pInputSignature)
Public property | InputSignatureEntryCount | The number of entries in the input signature. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.NumInputSignatureEntries)
Public property | IsInline | TRUE is the shader is defined inline; otherwise FALSE. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.IsInline)
Public property | OutputSignatureEntryCount | The number of entries in the output signature. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.NumOutputSignatureEntries)
Public property | StreamOutputDeclaration | A string that constains a declaration of the stream output from a geometry shader. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.SODecl)

See Also

EffectShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription Properties
EffectShaderDescription Structure See Also Send Feedback

The EffectShaderDescription type exposes the following members.

Properties

 | Name | Description
Public property | Bytecode | The compiled shader. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.pBytecode)
Public property | BytecodeLength | The length of pBytecode. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.BytecodeLength)
Public property | InputSignature | Passed into CreateInputLayout. Only valid on a vertex shader or geometry shader. See ID3D10Device_CreateInputLayout. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.pInputSignature)
Public property | InputSignatureEntryCount | The number of entries in the input signature. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.NumInputSignatureEntries)
Public property | IsInline | TRUE is the shader is defined inline; otherwise FALSE. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.IsInline)
Public property | OutputSignatureEntryCount | The number of entries in the output signature. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.NumOutputSignatureEntries)
Public property | StreamOutputDeclaration | A string that constains a declaration of the stream output from a geometry shader. (Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.SODecl)

See Also

EffectShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Bytecode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription..::..Bytecode Property
EffectShaderDescription Structure See Also Send Feedback
The compiled shader.

(Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.pBytecode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr Bytecode { get; set; }
Visual Basic
Public Property Bytecode As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr Bytecode {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

EffectShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BytecodeLength Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription..::..BytecodeLength Property
EffectShaderDescription Structure See Also Send Feedback
The length of pBytecode.

(Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.BytecodeLength)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BytecodeLength { get; set; }
Visual Basic
Public Property BytecodeLength As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BytecodeLength {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputSignature Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription..::..InputSignature Property
EffectShaderDescription Structure See Also Send Feedback
Passed into CreateInputLayout. Only valid on a vertex shader or geometry shader. See ID3D10Device_CreateInputLayout.

(Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.pInputSignature)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr InputSignature { get; set; }
Visual Basic
Public Property InputSignature As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr InputSignature {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

EffectShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputSignatureEntryCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription..::..InputSignatureEntryCount Property
EffectShaderDescription Structure See Also Send Feedback
The number of entries in the input signature.

(Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.NumInputSignatureEntries)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InputSignatureEntryCount { get; set; }
Visual Basic
Public Property InputSignatureEntryCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InputSignatureEntryCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsInline Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription..::..IsInline Property
EffectShaderDescription Structure See Also Send Feedback
TRUE is the shader is defined inline; otherwise FALSE.

(Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.IsInline)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsInline { get; set; }
Visual Basic
Public Property IsInline As Boolean
    Get
    Set
Visual C++
public:
property bool IsInline {
    bool get ();
    void set (bool value);
}

See Also

EffectShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputSignatureEntryCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription..::..OutputSignatureEntryCount Property
EffectShaderDescription Structure See Also Send Feedback
The number of entries in the output signature.

(Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.NumOutputSignatureEntries)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint OutputSignatureEntryCount { get; set; }
Visual Basic
Public Property OutputSignatureEntryCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int OutputSignatureEntryCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputDeclaration Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderDescription..::..StreamOutputDeclaration Property
EffectShaderDescription Structure See Also Send Feedback
A string that constains a declaration of the stream output from a geometry shader.

(Also see DirectX SDK: D3D10_EFFECT_SHADER_DESC.SODecl)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string StreamOutputDeclaration { get; set; }
Visual Basic
Public Property StreamOutputDeclaration As String
    Get
    Set
Visual C++
public:
property String^ StreamOutputDeclaration {
    String^ get ();
    void set (String^ value);
}

See Also

EffectShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderResourceVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderResourceVariable Class
Members See Also Send Feedback
A shader-resource interface accesses a shader resource.

(Also see DirectX SDK: ID3D10EffectShaderResourceVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectShaderResourceVariable : EffectVariable
Visual Basic
Public Class EffectShaderResourceVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectShaderResourceVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectShaderResourceVariable

See Also

EffectShaderResourceVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderResourceVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderResourceVariable Members
EffectShaderResourceVariable Class Methods Properties See Also Send Feedback

The EffectShaderResourceVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetResourceArray | Get a collection of shader resources. (Also see DirectX SDK: ID3D10EffectShaderResourceVariable::GetResourceArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)
Public method | SetResourceArray |

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)
Public property | Resource | Gets or sets a shader resource. (Also see DirectX SDK: ID3D10EffectShaderResourceVariable::SetResource, ID3D10EffectShaderResourceVariable::GetResource)

See Also

EffectShaderResourceVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderResourceVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderResourceVariable Methods
EffectShaderResourceVariable Class See Also Send Feedback

The EffectShaderResourceVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetResourceArray | Get a collection of shader resources. (Also see DirectX SDK: ID3D10EffectShaderResourceVariable::GetResourceArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)
Public method | SetResourceArray |

See Also

EffectShaderResourceVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetResourceArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderResourceVariable..::..GetResourceArray Method
EffectShaderResourceVariable Class See Also Send Feedback
Get a collection of shader resources.

(Also see DirectX SDK: ID3D10EffectShaderResourceVariable::GetResourceArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetResourceArray(
    uint offset,
    uint count
)
Visual Basic
Public Function GetResourceArray ( _
    offset As UInteger, _
    count As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetResourceArray(
    unsigned int offset,
    unsigned int count
)

Parameters

offset
Type: System..::..UInt32
The zero-based array index to get the first object.
count
Type: System..::..UInt32
The number of requested elements in the array.

Return Value

A collection of shader-resource-view interfaces. See ShaderResourceView Object.

See Also

EffectShaderResourceVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetResourceArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderResourceVariable..::..SetResourceArray Method
EffectShaderResourceVariable Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetResourceArray(
    IEnumerable<ShaderResourceView> resources,
    uint offset
)
Visual Basic
Public Sub SetResourceArray ( _
    resources As IEnumerable(Of ShaderResourceView), _
    offset As UInteger _
)
Visual C++
public:
void SetResourceArray(
    IEnumerable<ShaderResourceView^>^ resources,
    unsigned int offset
)

Parameters

resources
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>
offset
Type: System..::..UInt32

See Also

EffectShaderResourceVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderResourceVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderResourceVariable Properties
EffectShaderResourceVariable Class See Also Send Feedback

The EffectShaderResourceVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)
Public property | Resource | Gets or sets a shader resource. (Also see DirectX SDK: ID3D10EffectShaderResourceVariable::SetResource, ID3D10EffectShaderResourceVariable::GetResource)

See Also

EffectShaderResourceVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Resource Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderResourceVariable..::..Resource Property
EffectShaderResourceVariable Class See Also Send Feedback
Gets or sets a shader resource.

(Also see DirectX SDK: ID3D10EffectShaderResourceVariable::SetResource, ID3D10EffectShaderResourceVariable::GetResource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceView Resource { get; set; }
Visual Basic
Public Property Resource As ShaderResourceView
    Get
    Set
Visual C++
public:
property ShaderResourceView^ Resource {
    ShaderResourceView^ get ();
    void set (ShaderResourceView^ value);
}

See Also

EffectShaderResourceVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable Class
Members See Also Send Feedback
A shader-variable interface accesses a shader variable.

(Also see DirectX SDK: ID3D10EffectShaderVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectShaderVariable : EffectVariable
Visual Basic
Public Class EffectShaderVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectShaderVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectShaderVariable

See Also

EffectShaderVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable Members
EffectShaderVariable Class Methods Properties See Also Send Feedback

The EffectShaderVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetGeometryShader | Get a geometry shader. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetGeometryShader)
Public method | GetInputSignatureElementDescription | Get an input-signature description. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetInputSignatureElementDesc)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetOutputSignatureElementDescription | Get an output-signature description. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetOutputSignatureElementDesc)
Public method | GetPixelShader | Get a pixel shader. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetPixelShader)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetShaderDescription | Get a shader description. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetShaderDesc)
Public method | GetVertexShader | Get a vertex shader. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetVertexShader)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectShaderVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable Methods
EffectShaderVariable Class See Also Send Feedback

The EffectShaderVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetGeometryShader | Get a geometry shader. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetGeometryShader)
Public method | GetInputSignatureElementDescription | Get an input-signature description. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetInputSignatureElementDesc)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetOutputSignatureElementDescription | Get an output-signature description. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetOutputSignatureElementDesc)
Public method | GetPixelShader | Get a pixel shader. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetPixelShader)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetShaderDescription | Get a shader description. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetShaderDesc)
Public method | GetVertexShader | Get a vertex shader. (Also see DirectX SDK: ID3D10EffectShaderVariable::GetVertexShader)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectShaderVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetGeometryShader Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable..::..GetGeometryShader Method
EffectShaderVariable Class See Also Send Feedback
Get a geometry shader.

(Also see DirectX SDK: ID3D10EffectShaderVariable::GetGeometryShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader GetGeometryShader(
    uint shaderIndex
)
Visual Basic
Public Function GetGeometryShader ( _
    shaderIndex As UInteger _
) As GeometryShader
Visual C++
public:
GeometryShader^ GetGeometryShader(
    unsigned int shaderIndex
)

Parameters

shaderIndex
Type: System..::..UInt32
A zero-based index.

Return Value

A GeometryShader Object.

See Also

EffectShaderVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetInputSignatureElementDescription Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable..::..GetInputSignatureElementDescription Method
EffectShaderVariable Class See Also Send Feedback
Get an input-signature description.

(Also see DirectX SDK: ID3D10EffectShaderVariable::GetInputSignatureElementDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SignatureParameterDescription GetInputSignatureElementDescription(
    uint shaderIndex,
    uint elementIndex
)
Visual Basic
Public Function GetInputSignatureElementDescription ( _
    shaderIndex As UInteger, _
    elementIndex As UInteger _
) As SignatureParameterDescription
Visual C++
public:
SignatureParameterDescription GetInputSignatureElementDescription(
    unsigned int shaderIndex,
    unsigned int elementIndex
)

Parameters

shaderIndex
Type: System..::..UInt32
A zero-based shader index.
elementIndex
Type: System..::..UInt32
A zero-based shader-element index.

Return Value

A parameter description (see SignatureParameterDescription).

See Also

EffectShaderVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SignatureParameterDescription


GetOutputSignatureElementDescription Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable..::..GetOutputSignatureElementDescription Method
EffectShaderVariable Class See Also Send Feedback
Get an output-signature description.

(Also see DirectX SDK: ID3D10EffectShaderVariable::GetOutputSignatureElementDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SignatureParameterDescription GetOutputSignatureElementDescription(
    uint shaderIndex,
    uint elementIndex
)
Visual Basic
Public Function GetOutputSignatureElementDescription ( _
    shaderIndex As UInteger, _
    elementIndex As UInteger _
) As SignatureParameterDescription
Visual C++
public:
SignatureParameterDescription GetOutputSignatureElementDescription(
    unsigned int shaderIndex,
    unsigned int elementIndex
)

Parameters

shaderIndex
Type: System..::..UInt32
A zero-based shader index.
elementIndex
Type: System..::..UInt32
A zero-based element index.

Return Value

A parameter description (see SignatureParameterDescription).

See Also

EffectShaderVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SignatureParameterDescription


GetPixelShader Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable..::..GetPixelShader Method
EffectShaderVariable Class See Also Send Feedback
Get a pixel shader.

(Also see DirectX SDK: ID3D10EffectShaderVariable::GetPixelShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShader GetPixelShader(
    uint shaderIndex
)
Visual Basic
Public Function GetPixelShader ( _
    shaderIndex As UInteger _
) As PixelShader
Visual C++
public:
PixelShader^ GetPixelShader(
    unsigned int shaderIndex
)

Parameters

shaderIndex
Type: System..::..UInt32
A zero-based index.

Return Value

A PixelShader Object.

See Also

EffectShaderVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetShaderDescription Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable..::..GetShaderDescription Method
EffectShaderVariable Class See Also Send Feedback
Get a shader description.

(Also see DirectX SDK: ID3D10EffectShaderVariable::GetShaderDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectShaderDescription GetShaderDescription(
    uint shaderIndex
)
Visual Basic
Public Function GetShaderDescription ( _
    shaderIndex As UInteger _
) As EffectShaderDescription
Visual C++
public:
EffectShaderDescription GetShaderDescription(
    unsigned int shaderIndex
)

Parameters

shaderIndex
Type: System..::..UInt32
A zero-based index.

Return Value

A shader description (see EffectShaderDescription).

See Also

EffectShaderVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectShaderDescription


GetVertexShader Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable..::..GetVertexShader Method
EffectShaderVariable Class See Also Send Feedback
Get a vertex shader.

(Also see DirectX SDK: ID3D10EffectShaderVariable::GetVertexShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShader GetVertexShader(
    uint shaderIndex
)
Visual Basic
Public Function GetVertexShader ( _
    shaderIndex As UInteger _
) As VertexShader
Visual C++
public:
VertexShader^ GetVertexShader(
    unsigned int shaderIndex
)

Parameters

shaderIndex
Type: System..::..UInt32
A zero-based index.

Return Value

A VertexShader Object.

See Also

EffectShaderVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectShaderVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectShaderVariable Properties
EffectShaderVariable Class See Also Send Feedback

The EffectShaderVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectShaderVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectStringVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectStringVariable Class
Members See Also Send Feedback
A string-variable interface accesses a string variable.

(Also see DirectX SDK: ID3D10EffectStringVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectStringVariable : EffectVariable
Visual Basic
Public Class EffectStringVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectStringVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectStringVariable

See Also

EffectStringVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectStringVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectStringVariable Members
EffectStringVariable Class Methods Properties See Also Send Feedback

The EffectStringVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetStringArray | Get an array of strings. (Also see DirectX SDK: ID3D10EffectStringVariable::GetStringArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)
Public property | StringValue | Get the string. (Also see DirectX SDK: ID3D10EffectStringVariable::GetString)

See Also

EffectStringVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectStringVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectStringVariable Methods
EffectStringVariable Class See Also Send Feedback

The EffectStringVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | GetStringArray | Get an array of strings. (Also see DirectX SDK: ID3D10EffectStringVariable::GetStringArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectStringVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetStringArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectStringVariable..::..GetStringArray Method
EffectStringVariable Class See Also Send Feedback
Get an array of strings.

(Also see DirectX SDK: ID3D10EffectStringVariable::GetStringArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string[] GetStringArray(
    uint offset,
    uint count
)
Visual Basic
Public Function GetStringArray ( _
    offset As UInteger, _
    count As UInteger _
) As String()
Visual C++
public:
array<String^>^ GetStringArray(
    unsigned int offset,
    unsigned int count
)

Parameters

offset
Type: System..::..UInt32
The offset (in number of strings) between the start of the array and the first string to get.
count
Type: System..::..UInt32
The number of strings requested in the returned array.

Return Value

The string array.

See Also

EffectStringVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectStringVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectStringVariable Properties
EffectStringVariable Class See Also Send Feedback

The EffectStringVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)
Public property | StringValue | Get the string. (Also see DirectX SDK: ID3D10EffectStringVariable::GetString)

See Also

EffectStringVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StringValue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectStringVariable..::..StringValue Property
EffectStringVariable Class See Also Send Feedback
Get the string.

(Also see DirectX SDK: ID3D10EffectStringVariable::GetString)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string StringValue { get; }
Visual Basic
Public ReadOnly Property StringValue As String
    Get
Visual C++
public:
property String^ StringValue {
    String^ get ();
}

See Also

EffectStringVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectTechnique Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique Class
Members See Also Send Feedback
An EffectTechnique interface is a collection of passes.

(Also see DirectX SDK: ID3D10EffectTechnique)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectTechnique : DirectObject
Visual Basic
Public Class EffectTechnique _
    Inherits DirectObject
Visual C++
public ref class EffectTechnique : public DirectObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectTechnique

See Also

EffectTechnique Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectTechnique Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique Members
EffectTechnique Class Methods Properties See Also Send Feedback

The EffectTechnique type exposes the following members.

Methods

 | Name | Description
Public method | ComputeStateBlockMask | Compute a state-block mask to allow/prevent state changes. (Also see DirectX SDK: ID3D10EffectTechnique::ComputeStateBlockMask)
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectTechnique::GetAnnotationByIndex)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectTechnique::GetAnnotationByName)
Public method | GetPassByIndex | Get a pass by index. (Also see DirectX SDK: ID3D10EffectTechnique::GetPassByIndex)
Public method | GetPassByName | Get a pass by name. (Also see DirectX SDK: ID3D10EffectTechnique::GetPassByName)

Properties

 | Name | Description
Public property | Description | Get a technique description. (Also see DirectX SDK: ID3D10EffectTechnique::GetDesc)
Public property | IsValid | Test a technique to see if it contains valid syntax. (Also see DirectX SDK: ID3D10EffectTechnique::IsValid)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectTechnique Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique Methods
EffectTechnique Class See Also Send Feedback

The EffectTechnique type exposes the following members.

Methods

 | Name | Description
Public method | ComputeStateBlockMask | Compute a state-block mask to allow/prevent state changes. (Also see DirectX SDK: ID3D10EffectTechnique::ComputeStateBlockMask)
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectTechnique::GetAnnotationByIndex)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectTechnique::GetAnnotationByName)
Public method | GetPassByIndex | Get a pass by index. (Also see DirectX SDK: ID3D10EffectTechnique::GetPassByIndex)
Public method | GetPassByName | Get a pass by name. (Also see DirectX SDK: ID3D10EffectTechnique::GetPassByName)

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ComputeStateBlockMask Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique..::..ComputeStateBlockMask Method
EffectTechnique Class See Also Send Feedback
Compute a state-block mask to allow/prevent state changes.

(Also see DirectX SDK: ID3D10EffectTechnique::ComputeStateBlockMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask ComputeStateBlockMask()
Visual Basic
Public Function ComputeStateBlockMask As StateBlockMask
Visual C++
public:
StateBlockMask^ ComputeStateBlockMask()

Return Value

A state-block mask (see StateBlockMask).

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask


GetAnnotationByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique..::..GetAnnotationByIndex Method
EffectTechnique Class See Also Send Feedback
Get an annotation by index.

(Also see DirectX SDK: ID3D10EffectTechnique::GetAnnotationByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetAnnotationByIndex(
    uint index
)
Visual Basic
Public Function GetAnnotationByIndex ( _
    index As UInteger _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetAnnotationByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
The zero-based index of the interface pointer.

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetAnnotationByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique..::..GetAnnotationByName Method
EffectTechnique Class See Also Send Feedback
Get an annotation by name.

(Also see DirectX SDK: ID3D10EffectTechnique::GetAnnotationByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetAnnotationByName(
    string name
)
Visual Basic
Public Function GetAnnotationByName ( _
    name As String _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetAnnotationByName(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the annotation.

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetPassByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique..::..GetPassByIndex Method
EffectTechnique Class See Also Send Feedback
Get a pass by index.

(Also see DirectX SDK: ID3D10EffectTechnique::GetPassByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectPass GetPassByIndex(
    uint index
)
Visual Basic
Public Function GetPassByIndex ( _
    index As UInteger _
) As EffectPass
Visual C++
public:
EffectPass^ GetPassByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetPassByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique..::..GetPassByName Method
EffectTechnique Class See Also Send Feedback
Get a pass by name.

(Also see DirectX SDK: ID3D10EffectTechnique::GetPassByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectPass GetPassByName(
    string name
)
Visual Basic
Public Function GetPassByName ( _
    name As String _
) As EffectPass
Visual C++
public:
EffectPass^ GetPassByName(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the pass.

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectTechnique Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique Properties
EffectTechnique Class See Also Send Feedback

The EffectTechnique type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get a technique description. (Also see DirectX SDK: ID3D10EffectTechnique::GetDesc)
Public property | IsValid | Test a technique to see if it contains valid syntax. (Also see DirectX SDK: ID3D10EffectTechnique::IsValid)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique..::..Description Property
EffectTechnique Class See Also Send Feedback
Get a technique description.

(Also see DirectX SDK: ID3D10EffectTechnique::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TechniqueDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As TechniqueDescription
    Get
Visual C++
public:
property TechniqueDescription Description {
    TechniqueDescription get ();
}

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsValid Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTechnique..::..IsValid Property
EffectTechnique Class See Also Send Feedback
Test a technique to see if it contains valid syntax.

(Also see DirectX SDK: ID3D10EffectTechnique::IsValid)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

EffectTechnique Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectType Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType Class
Members See Also Send Feedback
The EffectType interface accesses effect variables by type.

(Also see DirectX SDK: ID3D10EffectType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectType : DirectObject
Visual Basic
Public Class EffectType _
    Inherits DirectObject
Visual C++
public ref class EffectType : public DirectObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectType

See Also

EffectType Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectType Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType Members
EffectType Class Methods Properties See Also Send Feedback

The EffectType type exposes the following members.

Methods

 | Name | Description
Public method | GetMemberName | Get the name of a member. (Also see DirectX SDK: ID3D10EffectType::GetMemberName)
Public method | GetMemberSemantic | Get the semantic attached to a member. (Also see DirectX SDK: ID3D10EffectType::GetMemberSemantic)
Public method | GetMemberTypeByIndex | Get a member type by index. (Also see DirectX SDK: ID3D10EffectType::GetMemberTypeByIndex)
Public method | GetMemberTypeByName | Get an member type by name. (Also see DirectX SDK: ID3D10EffectType::GetMemberTypeByName)
Public method | GetMemberTypeBySemantic | Get a member type by semantic. (Also see DirectX SDK: ID3D10EffectType::GetMemberTypeBySemantic)

Properties

 | Name | Description
Public property | Description | Get an effect-type description. (Also see DirectX SDK: ID3D10EffectType::GetDesc)
Public property | IsValid | Tests that the effect type is valid. (Also see DirectX SDK: ID3D10EffectType::IsValid)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectType Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType Methods
EffectType Class See Also Send Feedback

The EffectType type exposes the following members.

Methods

 | Name | Description
Public method | GetMemberName | Get the name of a member. (Also see DirectX SDK: ID3D10EffectType::GetMemberName)
Public method | GetMemberSemantic | Get the semantic attached to a member. (Also see DirectX SDK: ID3D10EffectType::GetMemberSemantic)
Public method | GetMemberTypeByIndex | Get a member type by index. (Also see DirectX SDK: ID3D10EffectType::GetMemberTypeByIndex)
Public method | GetMemberTypeByName | Get an member type by name. (Also see DirectX SDK: ID3D10EffectType::GetMemberTypeByName)
Public method | GetMemberTypeBySemantic | Get a member type by semantic. (Also see DirectX SDK: ID3D10EffectType::GetMemberTypeBySemantic)

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType..::..GetMemberName Method
EffectType Class See Also Send Feedback
Get the name of a member.

(Also see DirectX SDK: ID3D10EffectType::GetMemberName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string GetMemberName(
    uint index
)
Visual Basic
Public Function GetMemberName ( _
    index As UInteger _
) As String
Visual C++
public:
String^ GetMemberName(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberSemantic Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType..::..GetMemberSemantic Method
EffectType Class See Also Send Feedback
Get the semantic attached to a member.

(Also see DirectX SDK: ID3D10EffectType::GetMemberSemantic)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string GetMemberSemantic(
    uint index
)
Visual Basic
Public Function GetMemberSemantic ( _
    index As UInteger _
) As String
Visual C++
public:
String^ GetMemberSemantic(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberTypeByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType..::..GetMemberTypeByIndex Method
EffectType Class See Also Send Feedback
Get a member type by index.

(Also see DirectX SDK: ID3D10EffectType::GetMemberTypeByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectType GetMemberTypeByIndex(
    uint index
)
Visual Basic
Public Function GetMemberTypeByIndex ( _
    index As UInteger _
) As EffectType
Visual C++
public:
EffectType^ GetMemberTypeByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberTypeByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType..::..GetMemberTypeByName Method
EffectType Class See Also Send Feedback
Get an member type by name.

(Also see DirectX SDK: ID3D10EffectType::GetMemberTypeByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectType GetMemberTypeByName(
    string name
)
Visual Basic
Public Function GetMemberTypeByName ( _
    name As String _
) As EffectType
Visual C++
public:
EffectType^ GetMemberTypeByName(
    String^ name
)

Parameters

name
Type: System..::..String
A member's name.

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberTypeBySemantic Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType..::..GetMemberTypeBySemantic Method
EffectType Class See Also Send Feedback
Get a member type by semantic.

(Also see DirectX SDK: ID3D10EffectType::GetMemberTypeBySemantic)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectType GetMemberTypeBySemantic(
    string semantic
)
Visual Basic
Public Function GetMemberTypeBySemantic ( _
    semantic As String _
) As EffectType
Visual C++
public:
EffectType^ GetMemberTypeBySemantic(
    String^ semantic
)

Parameters

semantic
Type: System..::..String
A semantic.

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectType Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType Properties
EffectType Class See Also Send Feedback

The EffectType type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get an effect-type description. (Also see DirectX SDK: ID3D10EffectType::GetDesc)
Public property | IsValid | Tests that the effect type is valid. (Also see DirectX SDK: ID3D10EffectType::IsValid)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType..::..Description Property
EffectType Class See Also Send Feedback
Get an effect-type description.

(Also see DirectX SDK: ID3D10EffectType::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectTypeDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As EffectTypeDescription
    Get
Visual C++
public:
property EffectTypeDescription Description {
    EffectTypeDescription get ();
}

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsValid Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectType..::..IsValid Property
EffectType Class See Also Send Feedback
Tests that the effect type is valid.

(Also see DirectX SDK: ID3D10EffectType::IsValid)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

EffectType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectTypeDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription Structure
Members See Also Send Feedback
Describes an effect-variable type.

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct EffectTypeDescription
Visual Basic
Public Structure EffectTypeDescription
Visual C++
public value class EffectTypeDescription

See Also

EffectTypeDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectTypeDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription Members
EffectTypeDescription Structure Methods Operators Properties See Also Send Feedback

The EffectTypeDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Columns | The number of columns if the variable is a matrix; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Columns)
Public property | Elements | The number of elements if the variable is an array; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Elements)
Public property | Members | The number of members if the variable is a structure; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Members)
Public property | PackedSize | The number of bytes that the variable consumes when it is packed tightly by the compiler. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.PackedSize)
Public property | Rows | The number of rows if the variable is a matrix; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Rows)
Public property | ShaderVariableClass | The variable class (see ShaderVariableClass). (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Class)
Public property | ShaderVariableType | The variable type (see ShaderVariableType). (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Type)
Public property | Stride | The number of bytes between elements. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Stride)
Public property | TypeName | A string that contains the variable name. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.TypeName)
Public property | UnpackedSize | The number of bytes that the variable consumes before it is packed by the compiler. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.UnpackedSize)

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectTypeDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription Methods
EffectTypeDescription Structure See Also Send Feedback

The EffectTypeDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..Equals Method
EffectTypeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..GetHashCode Method
EffectTypeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectTypeDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription Operators
EffectTypeDescription Structure See Also Send Feedback

The EffectTypeDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..Equality Operator
EffectTypeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    EffectTypeDescription effectTypeDescription1,
    EffectTypeDescription effectTypeDescription2
)
Visual Basic
Public Shared Operator = ( _
    effectTypeDescription1 As EffectTypeDescription, _
    effectTypeDescription2 As EffectTypeDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    EffectTypeDescription effectTypeDescription1,
    EffectTypeDescription effectTypeDescription2
)

Parameters

effectTypeDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectTypeDescription
effectTypeDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectTypeDescription

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..Inequality Operator
EffectTypeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    EffectTypeDescription effectTypeDescription1,
    EffectTypeDescription effectTypeDescription2
)
Visual Basic
Public Shared Operator <> ( _
    effectTypeDescription1 As EffectTypeDescription, _
    effectTypeDescription2 As EffectTypeDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    EffectTypeDescription effectTypeDescription1,
    EffectTypeDescription effectTypeDescription2
)

Parameters

effectTypeDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectTypeDescription
effectTypeDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectTypeDescription

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectTypeDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription Properties
EffectTypeDescription Structure See Also Send Feedback

The EffectTypeDescription type exposes the following members.

Properties

 | Name | Description
Public property | Columns | The number of columns if the variable is a matrix; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Columns)
Public property | Elements | The number of elements if the variable is an array; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Elements)
Public property | Members | The number of members if the variable is a structure; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Members)
Public property | PackedSize | The number of bytes that the variable consumes when it is packed tightly by the compiler. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.PackedSize)
Public property | Rows | The number of rows if the variable is a matrix; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Rows)
Public property | ShaderVariableClass | The variable class (see ShaderVariableClass). (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Class)
Public property | ShaderVariableType | The variable type (see ShaderVariableType). (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Type)
Public property | Stride | The number of bytes between elements. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Stride)
Public property | TypeName | A string that contains the variable name. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.TypeName)
Public property | UnpackedSize | The number of bytes that the variable consumes before it is packed by the compiler. (Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.UnpackedSize)

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Columns Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..Columns Property
EffectTypeDescription Structure See Also Send Feedback
The number of columns if the variable is a matrix; otherwise 0.

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Columns)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Columns { get; set; }
Visual Basic
Public Property Columns As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Columns {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Elements Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..Elements Property
EffectTypeDescription Structure See Also Send Feedback
The number of elements if the variable is an array; otherwise 0.

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Elements)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Elements { get; set; }
Visual Basic
Public Property Elements As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Elements {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Members Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..Members Property
EffectTypeDescription Structure See Also Send Feedback
The number of members if the variable is a structure; otherwise 0.

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Members)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Members { get; set; }
Visual Basic
Public Property Members As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Members {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PackedSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..PackedSize Property
EffectTypeDescription Structure See Also Send Feedback
The number of bytes that the variable consumes when it is packed tightly by the compiler.

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.PackedSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint PackedSize { get; set; }
Visual Basic
Public Property PackedSize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int PackedSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Rows Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..Rows Property
EffectTypeDescription Structure See Also Send Feedback
The number of rows if the variable is a matrix; otherwise 0.

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Rows)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Rows { get; set; }
Visual Basic
Public Property Rows As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Rows {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableClass Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..ShaderVariableClass Property
EffectTypeDescription Structure See Also Send Feedback
The variable class (see ShaderVariableClass).

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Class)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderVariableClass ShaderVariableClass { get; set; }
Visual Basic
Public Property ShaderVariableClass As ShaderVariableClass
    Get
    Set
Visual C++
public:
property ShaderVariableClass ShaderVariableClass {
    ShaderVariableClass get ();
    void set (ShaderVariableClass value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
EffectTypeDescription..::..ShaderVariableClass


ShaderVariableType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..ShaderVariableType Property
EffectTypeDescription Structure See Also Send Feedback
The variable type (see ShaderVariableType).

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Type)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderVariableType ShaderVariableType { get; set; }
Visual Basic
Public Property ShaderVariableType As ShaderVariableType
    Get
    Set
Visual C++
public:
property ShaderVariableType ShaderVariableType {
    ShaderVariableType get ();
    void set (ShaderVariableType value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
EffectTypeDescription..::..ShaderVariableType


Stride Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..Stride Property
EffectTypeDescription Structure See Also Send Feedback
The number of bytes between elements.

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.Stride)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Stride { get; set; }
Visual Basic
Public Property Stride As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Stride {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TypeName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..TypeName Property
EffectTypeDescription Structure See Also Send Feedback
A string that contains the variable name.

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.TypeName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UnpackedSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectTypeDescription..::..UnpackedSize Property
EffectTypeDescription Structure See Also Send Feedback
The number of bytes that the variable consumes before it is packed by the compiler.

(Also see DirectX SDK: D3D10_EFFECT_TYPE_DESC.UnpackedSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint UnpackedSize { get; set; }
Visual Basic
Public Property UnpackedSize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int UnpackedSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable Class
Members See Also Send Feedback
The EffectVariable interface is the base class for all effect variables.

(Also see DirectX SDK: ID3D10EffectVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectVariable : DirectObject
Visual Basic
Public Class EffectVariable _
    Inherits DirectObject
Visual C++
public ref class EffectVariable : public DirectObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectBlendVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectConstantBuffer
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectDepthStencilVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectDepthStencilViewVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectMatrixVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectRasterizerVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectRenderTargetViewVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectSamplerVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectScalarVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectShaderResourceVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectShaderVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectStringVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVectorVariable

See Also

EffectVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable Members
EffectVariable Class Methods Properties See Also Send Feedback

The EffectVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer)

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable Methods
EffectVariable Class See Also Send Feedback

The EffectVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue)

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetAnnotationByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..GetAnnotationByIndex Method
EffectVariable Class See Also Send Feedback
Get an annotation by index.

(Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetAnnotationByIndex(
    uint index
)
Visual Basic
Public Function GetAnnotationByIndex ( _
    index As UInteger _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetAnnotationByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetAnnotationByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..GetAnnotationByName Method
EffectVariable Class See Also Send Feedback
Get an annotation by name.

(Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetAnnotationByName(
    string name
)
Visual Basic
Public Function GetAnnotationByName ( _
    name As String _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetAnnotationByName(
    String^ name
)

Parameters

name
Type: System..::..String
The annotation name.

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetElement Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..GetElement Method
EffectVariable Class See Also Send Feedback
Get an array element.

(Also see DirectX SDK: ID3D10EffectVariable::GetElement)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetElement(
    uint index
)
Visual Basic
Public Function GetElement ( _
    index As UInteger _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetElement(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index; otherwise 0.

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..GetMemberByIndex Method
EffectVariable Class See Also Send Feedback
Get a structure member by index.

(Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetMemberByIndex(
    uint index
)
Visual Basic
Public Function GetMemberByIndex ( _
    index As UInteger _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetMemberByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
A zero-based index.

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..GetMemberByName Method
EffectVariable Class See Also Send Feedback
Get a structure member by name.

(Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetMemberByName(
    string name
)
Visual Basic
Public Function GetMemberByName ( _
    name As String _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetMemberByName(
    String^ name
)

Parameters

name
Type: System..::..String
Member name.

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberBySemantic Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..GetMemberBySemantic Method
EffectVariable Class See Also Send Feedback
Get a structure member by semantic.

(Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariable GetMemberBySemantic(
    string semantic
)
Visual Basic
Public Function GetMemberBySemantic ( _
    semantic As String _
) As EffectVariable
Visual C++
public:
EffectVariable^ GetMemberBySemantic(
    String^ semantic
)

Parameters

semantic
Type: System..::..String
The semantic.

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetRawValue Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..GetRawValue Method
EffectVariable Class See Also Send Feedback
Get data.

(Also see DirectX SDK: ID3D10EffectVariable::GetRawValue)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte[] GetRawValue(
    uint size
)
Visual Basic
Public Function GetRawValue ( _
    size As UInteger _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetRawValue(
    unsigned int size
)

Parameters

size
Type: System..::..UInt32
The number of bytes to get.

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetRawValue Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..SetRawValue Method
EffectVariable Class See Also Send Feedback
Set data.

(Also see DirectX SDK: ID3D10EffectVariable::SetRawValue)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetRawValue(
    byte[] data
)
Visual Basic
Public Sub SetRawValue ( _
    data As Byte() _
)
Visual C++
public:
void SetRawValue(
    array<unsigned char>^ data
)

Parameters

data
Type: array< System..::..Byte >[]()[][]
The variable to set.

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable Properties
EffectVariable Class See Also Send Feedback

The EffectVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer)

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsBlend Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsBlend Property
EffectVariable Class See Also Send Feedback
Get a effect-blend variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsBlend)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectBlendVariable AsBlend { get; }
Visual Basic
Public ReadOnly Property AsBlend As EffectBlendVariable
    Get
Visual C++
public:
property EffectBlendVariable^ AsBlend {
    EffectBlendVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsConstantBuffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsConstantBuffer Property
EffectVariable Class See Also Send Feedback
Get a constant buffer.

(Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectConstantBuffer AsConstantBuffer { get; }
Visual Basic
Public ReadOnly Property AsConstantBuffer As EffectConstantBuffer
    Get
Visual C++
public:
property EffectConstantBuffer^ AsConstantBuffer {
    EffectConstantBuffer^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsDepthStencil Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsDepthStencil Property
EffectVariable Class See Also Send Feedback
Get a depth-stencil variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectDepthStencilVariable AsDepthStencil { get; }
Visual Basic
Public ReadOnly Property AsDepthStencil As EffectDepthStencilVariable
    Get
Visual C++
public:
property EffectDepthStencilVariable^ AsDepthStencil {
    EffectDepthStencilVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsDepthStencilView Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsDepthStencilView Property
EffectVariable Class See Also Send Feedback
Get a depth-stencil-view variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectDepthStencilViewVariable AsDepthStencilView { get; }
Visual Basic
Public ReadOnly Property AsDepthStencilView As EffectDepthStencilViewVariable
    Get
Visual C++
public:
property EffectDepthStencilViewVariable^ AsDepthStencilView {
    EffectDepthStencilViewVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsMatrix Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsMatrix Property
EffectVariable Class See Also Send Feedback
Get a matrix variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsMatrix)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectMatrixVariable AsMatrix { get; }
Visual Basic
Public ReadOnly Property AsMatrix As EffectMatrixVariable
    Get
Visual C++
public:
property EffectMatrixVariable^ AsMatrix {
    EffectMatrixVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsRasterizer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsRasterizer Property
EffectVariable Class See Also Send Feedback
Get a rasterizer variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectRasterizerVariable AsRasterizer { get; }
Visual Basic
Public ReadOnly Property AsRasterizer As EffectRasterizerVariable
    Get
Visual C++
public:
property EffectRasterizerVariable^ AsRasterizer {
    EffectRasterizerVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsRenderTargetView Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsRenderTargetView Property
EffectVariable Class See Also Send Feedback
Get a render-target-view variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectRenderTargetViewVariable AsRenderTargetView { get; }
Visual Basic
Public ReadOnly Property AsRenderTargetView As EffectRenderTargetViewVariable
    Get
Visual C++
public:
property EffectRenderTargetViewVariable^ AsRenderTargetView {
    EffectRenderTargetViewVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsSampler Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsSampler Property
EffectVariable Class See Also Send Feedback
Get a sampler variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsSampler)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectSamplerVariable AsSampler { get; }
Visual Basic
Public ReadOnly Property AsSampler As EffectSamplerVariable
    Get
Visual C++
public:
property EffectSamplerVariable^ AsSampler {
    EffectSamplerVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsScalar Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsScalar Property
EffectVariable Class See Also Send Feedback
Get a scalar variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsScalar)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectScalarVariable AsScalar { get; }
Visual Basic
Public ReadOnly Property AsScalar As EffectScalarVariable
    Get
Visual C++
public:
property EffectScalarVariable^ AsScalar {
    EffectScalarVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsShader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsShader Property
EffectVariable Class See Also Send Feedback
Get a shader variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectShaderVariable AsShader { get; }
Visual Basic
Public ReadOnly Property AsShader As EffectShaderVariable
    Get
Visual C++
public:
property EffectShaderVariable^ AsShader {
    EffectShaderVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsShaderResource Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsShaderResource Property
EffectVariable Class See Also Send Feedback
Get a shader-resource variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectShaderResourceVariable AsShaderResource { get; }
Visual Basic
Public ReadOnly Property AsShaderResource As EffectShaderResourceVariable
    Get
Visual C++
public:
property EffectShaderResourceVariable^ AsShaderResource {
    EffectShaderResourceVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsString Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsString Property
EffectVariable Class See Also Send Feedback
Get a string variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsString)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectStringVariable AsString { get; }
Visual Basic
Public ReadOnly Property AsString As EffectStringVariable
    Get
Visual C++
public:
property EffectStringVariable^ AsString {
    EffectStringVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AsVector Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..AsVector Property
EffectVariable Class See Also Send Feedback
Get a vector variable.

(Also see DirectX SDK: ID3D10EffectVariable::AsVector)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVectorVariable AsVector { get; }
Visual Basic
Public ReadOnly Property AsVector As EffectVectorVariable
    Get
Visual C++
public:
property EffectVectorVariable^ AsVector {
    EffectVectorVariable^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..Description Property
EffectVariable Class See Also Send Feedback
Get a description.

(Also see DirectX SDK: ID3D10EffectVariable::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectVariableDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As EffectVariableDescription
    Get
Visual C++
public:
property EffectVariableDescription Description {
    EffectVariableDescription get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..EffectType Property
EffectVariable Class See Also Send Feedback
Get type information.

(Also see DirectX SDK: ID3D10EffectVariable::GetType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectType EffectType { get; }
Visual Basic
Public ReadOnly Property EffectType As EffectType
    Get
Visual C++
public:
property EffectType^ EffectType {
    EffectType^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsValid Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..IsValid Property
EffectVariable Class See Also Send Feedback
Compare the data type with the data stored.

(Also see DirectX SDK: ID3D10EffectVariable::IsValid)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ParentConstantBuffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariable..::..ParentConstantBuffer Property
EffectVariable Class See Also Send Feedback
Get a constant buffer.

(Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectConstantBuffer ParentConstantBuffer { get; }
Visual Basic
Public ReadOnly Property ParentConstantBuffer As EffectConstantBuffer
    Get
Visual C++
public:
property EffectConstantBuffer^ ParentConstantBuffer {
    EffectConstantBuffer^ get ();
}

See Also

EffectVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVariableDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription Structure
Members See Also Send Feedback
Describes an effect variable.

(Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct EffectVariableDescription
Visual Basic
Public Structure EffectVariableDescription
Visual C++
public value class EffectVariableDescription

See Also

EffectVariableDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVariableDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription Members
EffectVariableDescription Structure Methods Operators Properties See Also Send Feedback

The EffectVariableDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Annotations | The number of annotations; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Annotations)
Public property | BufferOffset | The offset between the begining of the constant buffer and this variable; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.BufferOffset)
Public property | ExplicitBindPoint | The register that this variable is bound to. To bind a variable explicitly use the D3D10_EFFECT_VARIABLE_EXPLICIT_BIND_POINT flag. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.ExplicitBindPoint)
Public property | Name | A string that contains the variable name. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Name)
Public property | Options | Optional flags for effect variables. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Flags)
Public property | Semantic | The semantic attached to the variable; otherwise NULL. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Semantic)

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVariableDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription Methods
EffectVariableDescription Structure See Also Send Feedback

The EffectVariableDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..Equals Method
EffectVariableDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..GetHashCode Method
EffectVariableDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVariableDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription Operators
EffectVariableDescription Structure See Also Send Feedback

The EffectVariableDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..Equality Operator
EffectVariableDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    EffectVariableDescription effectVariableDescription1,
    EffectVariableDescription effectVariableDescription2
)
Visual Basic
Public Shared Operator = ( _
    effectVariableDescription1 As EffectVariableDescription, _
    effectVariableDescription2 As EffectVariableDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    EffectVariableDescription effectVariableDescription1,
    EffectVariableDescription effectVariableDescription2
)

Parameters

effectVariableDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariableDescription
effectVariableDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariableDescription

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..Inequality Operator
EffectVariableDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    EffectVariableDescription effectVariableDescription1,
    EffectVariableDescription effectVariableDescription2
)
Visual Basic
Public Shared Operator <> ( _
    effectVariableDescription1 As EffectVariableDescription, _
    effectVariableDescription2 As EffectVariableDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    EffectVariableDescription effectVariableDescription1,
    EffectVariableDescription effectVariableDescription2
)

Parameters

effectVariableDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariableDescription
effectVariableDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariableDescription

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVariableDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription Properties
EffectVariableDescription Structure See Also Send Feedback

The EffectVariableDescription type exposes the following members.

Properties

 | Name | Description
Public property | Annotations | The number of annotations; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Annotations)
Public property | BufferOffset | The offset between the begining of the constant buffer and this variable; otherwise 0. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.BufferOffset)
Public property | ExplicitBindPoint | The register that this variable is bound to. To bind a variable explicitly use the D3D10_EFFECT_VARIABLE_EXPLICIT_BIND_POINT flag. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.ExplicitBindPoint)
Public property | Name | A string that contains the variable name. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Name)
Public property | Options | Optional flags for effect variables. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Flags)
Public property | Semantic | The semantic attached to the variable; otherwise NULL. (Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Semantic)

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Annotations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..Annotations Property
EffectVariableDescription Structure See Also Send Feedback
The number of annotations; otherwise 0.

(Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Annotations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Annotations { get; set; }
Visual Basic
Public Property Annotations As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Annotations {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BufferOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..BufferOffset Property
EffectVariableDescription Structure See Also Send Feedback
The offset between the begining of the constant buffer and this variable; otherwise 0.

(Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.BufferOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BufferOffset { get; set; }
Visual Basic
Public Property BufferOffset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BufferOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ExplicitBindPoint Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..ExplicitBindPoint Property
EffectVariableDescription Structure See Also Send Feedback
The register that this variable is bound to. To bind a variable explicitly use the D3D10_EFFECT_VARIABLE_EXPLICIT_BIND_POINT flag.

(Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.ExplicitBindPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ExplicitBindPoint { get; set; }
Visual Basic
Public Property ExplicitBindPoint As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ExplicitBindPoint {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Name Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..Name Property
EffectVariableDescription Structure See Also Send Feedback
A string that contains the variable name.

(Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Name)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Options Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..Options Property
EffectVariableDescription Structure See Also Send Feedback
Optional flags for effect variables.

(Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Flags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Options { get; set; }
Visual Basic
Public Property Options As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Options {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Semantic Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVariableDescription..::..Semantic Property
EffectVariableDescription Structure See Also Send Feedback
The semantic attached to the variable; otherwise NULL.

(Also see DirectX SDK: D3D10_EFFECT_VARIABLE_DESC.Semantic)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Semantic { get; set; }
Visual Basic
Public Property Semantic As String
    Get
    Set
Visual C++
public:
property String^ Semantic {
    String^ get ();
    void set (String^ value);
}

See Also

EffectVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVectorVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable Class
Members See Also Send Feedback
A vector-variable interface accesses a four-component vector.

(Also see DirectX SDK: ID3D10EffectVectorVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class EffectVectorVariable : EffectVariable
Visual Basic
Public Class EffectVectorVariable _
    Inherits EffectVariable
Visual C++
public ref class EffectVectorVariable : public EffectVariable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVariable
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..EffectVectorVariable

See Also

EffectVectorVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVectorVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable Members
EffectVectorVariable Class Methods Properties See Also Send Feedback

The EffectVectorVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBoolVectorArray | Get an array of four-component vectors that contain boolean data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetBoolVectorArray)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetFloatVectorArray | Get an array of four-component vectors that contain floating-point data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetFloatVectorArray)
Public method | GetIntVectorArray | Get an array of four-component vectors that contain integer data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetIntVectorArray)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetBoolVectorArray | Set an array of four-component vectors that contain boolean data. (Also see DirectX SDK: ID3D10EffectVectorVariable::SetBoolVectorArray)
Public method | SetFloatVectorArray | Set an array of four-component vectors that contain floating-point data. (Also see DirectX SDK: ID3D10EffectVectorVariable::SetFloatVectorArray)
Public method | SetIntVectorArray | Set an array of four-component vectors that contain integer data. (Also see DirectX SDK: ID3D10EffectVectorVariable::SetIntVectorArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | BoolVector | Get or set a four-component vector that contains boolean data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetBoolVector, ID3D10EffectVectorVariable::SetBoolVector)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | FloatVector | Get or set a four-component vector that contains floating-point data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetFloatVector, ID3D10EffectVectorVariable::SetFloatVector)
Public property | IntVector | Get or set a four-component vector that contains integer data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetIntVector, ID3D10EffectVectorVariable::SetIntVector)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVectorVariable Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable Methods
EffectVectorVariable Class See Also Send Feedback

The EffectVectorVariable type exposes the following members.

Methods

 | Name | Description
Public method | GetAnnotationByIndex | Get an annotation by index. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByIndex) (Inherited from EffectVariable.)
Public method | GetAnnotationByName | Get an annotation by name. (Also see DirectX SDK: ID3D10EffectVariable::GetAnnotationByName) (Inherited from EffectVariable.)
Public method | GetBoolVectorArray | Get an array of four-component vectors that contain boolean data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetBoolVectorArray)
Public method | GetElement | Get an array element. (Also see DirectX SDK: ID3D10EffectVariable::GetElement) (Inherited from EffectVariable.)
Public method | GetFloatVectorArray | Get an array of four-component vectors that contain floating-point data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetFloatVectorArray)
Public method | GetIntVectorArray | Get an array of four-component vectors that contain integer data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetIntVectorArray)
Public method | GetMemberByIndex | Get a structure member by index. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByIndex) (Inherited from EffectVariable.)
Public method | GetMemberByName | Get a structure member by name. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberByName) (Inherited from EffectVariable.)
Public method | GetMemberBySemantic | Get a structure member by semantic. (Also see DirectX SDK: ID3D10EffectVariable::GetMemberBySemantic) (Inherited from EffectVariable.)
Public method | GetRawValue | Get data. (Also see DirectX SDK: ID3D10EffectVariable::GetRawValue) (Inherited from EffectVariable.)
Public method | SetBoolVectorArray | Set an array of four-component vectors that contain boolean data. (Also see DirectX SDK: ID3D10EffectVectorVariable::SetBoolVectorArray)
Public method | SetFloatVectorArray | Set an array of four-component vectors that contain floating-point data. (Also see DirectX SDK: ID3D10EffectVectorVariable::SetFloatVectorArray)
Public method | SetIntVectorArray | Set an array of four-component vectors that contain integer data. (Also see DirectX SDK: ID3D10EffectVectorVariable::SetIntVectorArray)
Public method | SetRawValue | Set data. (Also see DirectX SDK: ID3D10EffectVariable::SetRawValue) (Inherited from EffectVariable.)

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetBoolVectorArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable..::..GetBoolVectorArray Method
EffectVectorVariable Class See Also Send Feedback
Get an array of four-component vectors that contain boolean data.

(Also see DirectX SDK: ID3D10EffectVectorVariable::GetBoolVectorArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4B[] GetBoolVectorArray(
    uint count
)
Visual Basic
Public Function GetBoolVectorArray ( _
    count As UInteger _
) As Vector4B()
Visual C++
public:
array<Vector4B>^ GetBoolVectorArray(
    unsigned int count
)

Parameters

count
Type: System..::..UInt32
The number of requested array elements to get.

Return Value

An array of boolean vectors as 4-components arrays.

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetFloatVectorArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable..::..GetFloatVectorArray Method
EffectVectorVariable Class See Also Send Feedback
Get an array of four-component vectors that contain floating-point data.

(Also see DirectX SDK: ID3D10EffectVectorVariable::GetFloatVectorArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4F[] GetFloatVectorArray(
    uint count
)
Visual Basic
Public Function GetFloatVectorArray ( _
    count As UInteger _
) As Vector4F()
Visual C++
public:
array<Vector4F>^ GetFloatVectorArray(
    unsigned int count
)

Parameters

count
Type: System..::..UInt32
The number of requested array elements to get.

Return Value

An array of floating-point vectors as 4-components arrays.

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetIntVectorArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable..::..GetIntVectorArray Method
EffectVectorVariable Class See Also Send Feedback
Get an array of four-component vectors that contain integer data.

(Also see DirectX SDK: ID3D10EffectVectorVariable::GetIntVectorArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4I[] GetIntVectorArray(
    uint count
)
Visual Basic
Public Function GetIntVectorArray ( _
    count As UInteger _
) As Vector4I()
Visual C++
public:
array<Vector4I>^ GetIntVectorArray(
    unsigned int count
)

Parameters

count
Type: System..::..UInt32
The number of requested array elements to get.

Return Value

An array of integer value vectors as 4-components arrays.

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetBoolVectorArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable..::..SetBoolVectorArray Method
EffectVectorVariable Class See Also Send Feedback
Set an array of four-component vectors that contain boolean data.

(Also see DirectX SDK: ID3D10EffectVectorVariable::SetBoolVectorArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetBoolVectorArray(
    Vector4B[] data
)
Visual Basic
Public Sub SetBoolVectorArray ( _
    data As Vector4B() _
)
Visual C++
public:
void SetBoolVectorArray(
    array<Vector4B>^ data
)

Parameters

data
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4B >[]()[][]
An array of boolean vectors as 4-components arrays.

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetFloatVectorArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable..::..SetFloatVectorArray Method
EffectVectorVariable Class See Also Send Feedback
Set an array of four-component vectors that contain floating-point data.

(Also see DirectX SDK: ID3D10EffectVectorVariable::SetFloatVectorArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetFloatVectorArray(
    Vector4F[] data
)
Visual Basic
Public Sub SetFloatVectorArray ( _
    data As Vector4F() _
)
Visual C++
public:
void SetFloatVectorArray(
    array<Vector4F>^ data
)

Parameters

data
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4F >[]()[][]
An array of floating-point vectors as 4-components arrays.

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetIntVectorArray Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable..::..SetIntVectorArray Method
EffectVectorVariable Class See Also Send Feedback
Set an array of four-component vectors that contain integer data.

(Also see DirectX SDK: ID3D10EffectVectorVariable::SetIntVectorArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetIntVectorArray(
    Vector4I[] data
)
Visual Basic
Public Sub SetIntVectorArray ( _
    data As Vector4I() _
)
Visual C++
public:
void SetIntVectorArray(
    array<Vector4I>^ data
)

Parameters

data
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..Vector4I >[]()[][]
An array of integer data vectors as 4-components arrays.

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EffectVectorVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable Properties
EffectVectorVariable Class See Also Send Feedback

The EffectVectorVariable type exposes the following members.

Properties

 | Name | Description
Public property | AsBlend | Get a effect-blend variable. (Also see DirectX SDK: ID3D10EffectVariable::AsBlend) (Inherited from EffectVariable.)
Public property | AsConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::AsConstantBuffer) (Inherited from EffectVariable.)
Public property | AsDepthStencil | Get a depth-stencil variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencil) (Inherited from EffectVariable.)
Public property | AsDepthStencilView | Get a depth-stencil-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsDepthStencilView) (Inherited from EffectVariable.)
Public property | AsMatrix | Get a matrix variable. (Also see DirectX SDK: ID3D10EffectVariable::AsMatrix) (Inherited from EffectVariable.)
Public property | AsRasterizer | Get a rasterizer variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRasterizer) (Inherited from EffectVariable.)
Public property | AsRenderTargetView | Get a render-target-view variable. (Also see DirectX SDK: ID3D10EffectVariable::AsRenderTargetView) (Inherited from EffectVariable.)
Public property | AsSampler | Get a sampler variable. (Also see DirectX SDK: ID3D10EffectVariable::AsSampler) (Inherited from EffectVariable.)
Public property | AsScalar | Get a scalar variable. (Also see DirectX SDK: ID3D10EffectVariable::AsScalar) (Inherited from EffectVariable.)
Public property | AsShader | Get a shader variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShader) (Inherited from EffectVariable.)
Public property | AsShaderResource | Get a shader-resource variable. (Also see DirectX SDK: ID3D10EffectVariable::AsShaderResource) (Inherited from EffectVariable.)
Public property | AsString | Get a string variable. (Also see DirectX SDK: ID3D10EffectVariable::AsString) (Inherited from EffectVariable.)
Public property | AsVector | Get a vector variable. (Also see DirectX SDK: ID3D10EffectVariable::AsVector) (Inherited from EffectVariable.)
Public property | BoolVector | Get or set a four-component vector that contains boolean data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetBoolVector, ID3D10EffectVectorVariable::SetBoolVector)
Public property | Description | Get a description. (Also see DirectX SDK: ID3D10EffectVariable::GetDesc) (Inherited from EffectVariable.)
Public property | EffectType | Get type information. (Also see DirectX SDK: ID3D10EffectVariable::GetType) (Inherited from EffectVariable.)
Public property | FloatVector | Get or set a four-component vector that contains floating-point data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetFloatVector, ID3D10EffectVectorVariable::SetFloatVector)
Public property | IntVector | Get or set a four-component vector that contains integer data. (Also see DirectX SDK: ID3D10EffectVectorVariable::GetIntVector, ID3D10EffectVectorVariable::SetIntVector)
Public property | IsValid | Compare the data type with the data stored. (Also see DirectX SDK: ID3D10EffectVariable::IsValid) (Inherited from EffectVariable.)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ParentConstantBuffer | Get a constant buffer. (Also see DirectX SDK: ID3D10EffectVariable::GetParentConstantBuffer) (Inherited from EffectVariable.)

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BoolVector Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable..::..BoolVector Property
EffectVectorVariable Class See Also Send Feedback
Get or set a four-component vector that contains boolean data.

(Also see DirectX SDK: ID3D10EffectVectorVariable::GetBoolVector, ID3D10EffectVectorVariable::SetBoolVector)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4B BoolVector { get; set; }
Visual Basic
Public Property BoolVector As Vector4B
    Get
    Set
Visual C++
public:
property Vector4B BoolVector {
    Vector4B get ();
    void set (Vector4B value);
}

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FloatVector Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable..::..FloatVector Property
EffectVectorVariable Class See Also Send Feedback
Get or set a four-component vector that contains floating-point data.

(Also see DirectX SDK: ID3D10EffectVectorVariable::GetFloatVector, ID3D10EffectVectorVariable::SetFloatVector)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4F FloatVector { get; set; }
Visual Basic
Public Property FloatVector As Vector4F
    Get
    Set
Visual C++
public:
property Vector4F FloatVector {
    Vector4F get ();
    void set (Vector4F value);
}

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IntVector Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
EffectVectorVariable..::..IntVector Property
EffectVectorVariable Class See Also Send Feedback
Get or set a four-component vector that contains integer data.

(Also see DirectX SDK: ID3D10EffectVectorVariable::GetIntVector, ID3D10EffectVectorVariable::SetIntVector)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Vector4I IntVector { get; set; }
Visual Basic
Public Property IntVector As Vector4I
    Get
    Set
Visual C++
public:
property Vector4I IntVector {
    Vector4I get ();
    void set (Vector4I value);
}

See Also

EffectVectorVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ExceptionErrors Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExceptionErrors Enumeration
See Also Send Feedback
Option(s) for raising an error to a non-continuable exception.

(Also see DirectX SDK: D3D10_RAISE_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ExceptionErrors
Visual Basic
<FlagsAttribute> _
Public Enumeration ExceptionErrors
Visual C++
[FlagsAttribute]
public enum class ExceptionErrors

Members

Member name | Description
None |
DriverInternalError |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FillMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FillMode Enumeration
See Also Send Feedback
Determines the fill mode to use when rendering triangles.

(Also see DirectX SDK: D3D10_FILL_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FillMode
Visual Basic
Public Enumeration FillMode
Visual C++
public enum class FillMode

Members

Member name | Description
Solid |
Wireframe |
Undefined |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Filter Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Filter Enumeration
See Also Send Feedback
Filtering options during texture sampling.

(Also see DirectX SDK: D3D10_FILTER)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Filter
Visual Basic
Public Enumeration Filter
Visual C++
public enum class Filter

Members

Member name | Description
ComparisonAnisotropic |
ComparisonMinMagMipLinear |
ComparisonMinMagLinearMipPoint |
ComparisonMinLinearMagPointMipLinear |
ComparisonMinLinearMagMipPoint |
ComparisonMinPointMagMipLinear |
ComparisonMinPointMagLinearMipPoint |
ComparisonMinMagPointMipLinear |
ComparisonMinMagMipPoint |
Anisotropic |
MinMagMipLinear |
MinMagLinearMipPoint |
MinLinearMagPointMipLinear |
MinLinearMagMipPoint |
MinPointMagMipLinear |
MinPointMagLinearMipPoint |
MinMagPointMipLinear |
MinMagMipPoint |
OneBitTexture |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FilterType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FilterType Enumeration
See Also Send Feedback
Types of magnification or minification sampler filters.

(Also see DirectX SDK: D3D10_FILTER_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FilterType
Visual Basic
Public Enumeration FilterType
Visual C++
public enum class FilterType

Members

Member name | Description
Linear |
Point |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FormatSupportOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatSupportOptions Enumeration
See Also Send Feedback
Which resources are supported for a given format and given device.

(Also see DirectX SDK: D3D10_FORMAT_SUPPORT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum FormatSupportOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration FormatSupportOptions
Visual C++
[FlagsAttribute]
public enum class FormatSupportOptions

Members

Member name | Description
ShaderGather |
MultisampleLoad |
MultisampleRenderTarget |
CastWithinBitLayout |
Display |
MultisampleResolve |
CpuLockable |
DepthStencil |
Blendable |
RenderTarget |
MipMapAutoGeneration |
MipMap |
ShaderSampleMonoText |
ShaderSampleComparison |
ShaderSample |
ShaderLoad |
StreamOutputBuffer |
InputAssemblerIndexBuffer |
InputAssemblerVertexBuffer |
Buffer |
TextureCube |
Texture3D |
Texture2D |
Texture1D |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShader Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShader Class
Members See Also Send Feedback
A geometry-shader interface manages an executable program (a geometry shader) that controls the geometry-shader stage.

(Also see DirectX SDK: ID3D10GeometryShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GeometryShader : DeviceChild
Visual Basic
Public Class GeometryShader _
    Inherits DeviceChild
Visual C++
public ref class GeometryShader : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..GeometryShader

See Also

GeometryShader Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShader Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShader Members
GeometryShader Class Properties See Also Send Feedback

The GeometryShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GeometryShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShader Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShader Properties
GeometryShader Class See Also Send Feedback

The GeometryShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GeometryShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage Class
Members See Also Send Feedback
Geometry Shader pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GeometryShaderPipelineStage : PipelineStage
Visual Basic
Public Class GeometryShaderPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class GeometryShaderPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..GeometryShaderPipelineStage

See Also

GeometryShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage Members
GeometryShaderPipelineStage Class Methods Properties See Also Send Feedback

The GeometryShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the geometry shader pipeline stage. (Also see DirectX SDK: ID3D10Device::GSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the geometry shader pipeline stage. (Also see DirectX SDK: ID3D10Device::GSGetSamplers)
Public method | GetShaderResources | Get the geometry shader resources. (Also see DirectX SDK: ID3D10Device::GSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShaderResources |

Properties

 | Name | Description
Public property | Shader | Gets or sets the geometry shader currently set on the device. (Also see DirectX SDK: ID3D10Device::GSGetShader, ID3D10Device::GSSetShader)

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage Methods
GeometryShaderPipelineStage Class See Also Send Feedback

The GeometryShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the geometry shader pipeline stage. (Also see DirectX SDK: ID3D10Device::GSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the geometry shader pipeline stage. (Also see DirectX SDK: ID3D10Device::GSGetSamplers)
Public method | GetShaderResources | Get the geometry shader resources. (Also see DirectX SDK: ID3D10Device::GSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShaderResources |

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..GetConstantBuffers Method
GeometryShaderPipelineStage Class See Also Send Feedback
Get the constant buffers used by the geometry shader pipeline stage.

(Also see DirectX SDK: ID3D10Device::GSGetConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetConstantBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetConstantBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetConstantBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin retrieving constant buffers from (ranges from 0 to D3D10_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - 1).
bufferCount
Type: System..::..UInt32
Number of buffers to retrieve (ranges from 0 to D3D10_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - startSlot).

Return Value

A collection of constant buffer objects (see D3DBuffer) to be returned by the method.

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DBuffer


GetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..GetSamplers Method
GeometryShaderPipelineStage Class See Also Send Feedback
Get an array of sampler state objects from the geometry shader pipeline stage.

(Also see DirectX SDK: ID3D10Device::GSGetSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<SamplerState> GetSamplers(
    uint startSlot,
    uint samplerCount
)
Visual Basic
Public Function GetSamplers ( _
    startSlot As UInteger, _
    samplerCount As UInteger _
) As ReadOnlyCollection(Of SamplerState)
Visual C++
public:
ReadOnlyCollection<SamplerState^>^ GetSamplers(
    unsigned int startSlot,
    unsigned int samplerCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into a zero-based array to begin getting samplers from (ranges from 0 to D3D10_COMMONSHADER_SAMPLER_SLOT_COUNT - 1).
samplerCount
Type: System..::..UInt32
Number of samplers to get from a device context. Each pipeline stage has a total of 16 sampler slots available (ranges from 0 to D3D10_COMMONSHADER_SAMPLER_SLOT_COUNT - startSlot).

Return Value

A collection of sampler-state objects (see SamplerState).

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerState


GetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..GetShaderResources Method
GeometryShaderPipelineStage Class See Also Send Feedback
Get the geometry shader resources.

(Also see DirectX SDK: ID3D10Device::GSGetShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetShaderResources(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetShaderResources ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetShaderResources(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin getting shader resources from (ranges from 0 to D3D10_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - 1).
viewCount
Type: System..::..UInt32
The number of resources to request from the device. Up to a maximum of 128 slots are available for shader resources (ranges from 0 to D3D10_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - startSlot).

Return Value

Collection of shader resource view objects to be returned by the device.

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..SetConstantBuffers Method
GeometryShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetConstantBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> constantBuffers
)
Visual Basic
Public Sub SetConstantBuffers ( _
    startSlot As UInteger, _
    constantBuffers As IEnumerable(Of D3DBuffer) _
)
Visual C++
public:
void SetConstantBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ constantBuffers
)

Parameters

startSlot
Type: System..::..UInt32
constantBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..SetSamplers Method
GeometryShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSamplers(
    uint startSlot,
    IEnumerable<SamplerState> samplers
)
Visual Basic
Public Sub SetSamplers ( _
    startSlot As UInteger, _
    samplers As IEnumerable(Of SamplerState) _
)
Visual C++
public:
void SetSamplers(
    unsigned int startSlot,
    IEnumerable<SamplerState^>^ samplers
)

Parameters

startSlot
Type: System..::..UInt32
samplers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SamplerState >)>)>

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..SetShaderResources Method
GeometryShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShaderResources(
    uint startSlot,
    IEnumerable<ShaderResourceView> shaderResourceViews
)
Visual Basic
Public Sub SetShaderResources ( _
    startSlot As UInteger, _
    shaderResourceViews As IEnumerable(Of ShaderResourceView) _
)
Visual C++
public:
void SetShaderResources(
    unsigned int startSlot,
    IEnumerable<ShaderResourceView^>^ shaderResourceViews
)

Parameters

startSlot
Type: System..::..UInt32
shaderResourceViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage Properties
GeometryShaderPipelineStage Class See Also Send Feedback

The GeometryShaderPipelineStage type exposes the following members.

Properties

 | Name | Description
Public property | Shader | Gets or sets the geometry shader currently set on the device. (Also see DirectX SDK: ID3D10Device::GSGetShader, ID3D10Device::GSSetShader)

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..Shader Property
GeometryShaderPipelineStage Class See Also Send Feedback
Gets or sets the geometry shader currently set on the device.

(Also see DirectX SDK: ID3D10Device::GSGetShader, ID3D10Device::GSSetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader Shader { get; set; }
Visual Basic
Public Property Shader As GeometryShader
    Get
    Set
Visual C++
public:
property GeometryShader^ Shader {
    GeometryShader^ get ();
    void set (GeometryShader^ value);
}

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Include Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Include Class
Members See Also Send Feedback
An include interface allows an application to create user-overridable methods for opening and closing files when loading an effect from memory. This class does not inherit from anything, but does declare the following methods:

(Also see DirectX SDK: ID3D10Include)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Include : DirectObject
Visual Basic
Public Class Include _
    Inherits DirectObject
Visual C++
public ref class Include : public DirectObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Include

See Also

Include Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Include Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Include Members
Include Class Constructors Methods Properties See Also Send Feedback

The Include type exposes the following members.

Constructors

 | Name | Description
Public method | Include | Public constructor to allow client code to create managed sub-classes that implement the interface.

Methods

 | Name | Description
Public method | Close | A user-implemented method for closing a shader #include file. (Also see DirectX SDK: ID3D10Include::Close)
Public method | Open | A user-implemented method for opening and reading the contents of a shader #include file. (Also see DirectX SDK: ID3D10Include::Open)

Properties

 | Name | Description
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

Include Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Include Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Include Constructor
Include Class See Also Send Feedback
Public constructor to allow client code to create managed sub-classes that implement the interface.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Include(
    IntPtr nativeInterface
)
Visual Basic
Public Sub New ( _
    nativeInterface As IntPtr _
)
Visual C++
public:
Include(
    IntPtr nativeInterface
)

Parameters

nativeInterface
Type: System..::..IntPtr
The unmanaged interface pointer for the client's implementation

See Also

Include Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Include Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Include Methods
Include Class See Also Send Feedback

The Include type exposes the following members.

Methods

 | Name | Description
Public method | Close | A user-implemented method for closing a shader #include file. (Also see DirectX SDK: ID3D10Include::Close)
Public method | Open | A user-implemented method for opening and reading the contents of a shader #include file. (Also see DirectX SDK: ID3D10Include::Open)

See Also

Include Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Close Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Include..::..Close Method
Include Class See Also Send Feedback
A user-implemented method for closing a shader #include file.

(Also see DirectX SDK: ID3D10Include::Close)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Close(
    IncludeData data
)
Visual Basic
Public Sub Close ( _
    data As IncludeData _
)
Visual C++
public:
void Close(
    IncludeData data
)

Parameters

data
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IncludeData
Pointer to the returned buffer that contains the include directives. This is the pointer that was returned by the corresponding Include.Open call.

See Also

Include Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Open Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Include..::..Open Method
Include Class See Also Send Feedback
A user-implemented method for opening and reading the contents of a shader #include file.

(Also see DirectX SDK: ID3D10Include::Open)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IncludeData Open(
    IncludeType includeType,
    string fileName,
    IntPtr parentData
)
Visual Basic
Public Function Open ( _
    includeType As IncludeType, _
    fileName As String, _
    parentData As IntPtr _
) As IncludeData
Visual C++
public:
IncludeData Open(
    IncludeType includeType,
    String^ fileName,
    IntPtr parentData
)

Parameters

includeType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IncludeType
The location of the #include file. See IncludeType.
fileName
Type: System..::..String
Name of the #include file.
parentData
Type: System..::..IntPtr
Pointer to the container that includes the #include file.

Return Value

The data that contains the include directives. This data remains valid until Include.Close() is called.

See Also

Include Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Include Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Include Properties
Include Class See Also Send Feedback

The Include type exposes the following members.

Properties

 | Name | Description
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

Include Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IncludeData Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData Structure
Members See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct IncludeData
Visual Basic
Public Structure IncludeData
Visual C++
public value class IncludeData

See Also

IncludeData Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IncludeData Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData Members
IncludeData Structure Methods Operators Properties See Also Send Feedback

The IncludeData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Length |
Public property | Pointer |

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IncludeData Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData Methods
IncludeData Structure See Also Send Feedback

The IncludeData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData..::..Equals Method
IncludeData Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData..::..GetHashCode Method
IncludeData Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IncludeData Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData Operators
IncludeData Structure See Also Send Feedback

The IncludeData type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData..::..Equality Operator
IncludeData Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    IncludeData data1,
    IncludeData data2
)
Visual Basic
Public Shared Operator = ( _
    data1 As IncludeData, _
    data2 As IncludeData _
) As Boolean
Visual C++
public:
static bool operator ==(
    IncludeData data1,
    IncludeData data2
)

Parameters

data1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IncludeData
data2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IncludeData

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData..::..Inequality Operator
IncludeData Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    IncludeData data1,
    IncludeData data2
)
Visual Basic
Public Shared Operator <> ( _
    data1 As IncludeData, _
    data2 As IncludeData _
) As Boolean
Visual C++
public:
static bool operator !=(
    IncludeData data1,
    IncludeData data2
)

Parameters

data1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IncludeData
data2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IncludeData

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IncludeData Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData Properties
IncludeData Structure See Also Send Feedback

The IncludeData type exposes the following members.

Properties

 | Name | Description
Public property | Length |
Public property | Pointer |

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Length Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData..::..Length Property
IncludeData Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Length { get; }
Visual Basic
Public ReadOnly Property Length As UInteger
    Get
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
}

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Pointer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeData..::..Pointer Property
IncludeData Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr Pointer { get; }
Visual Basic
Public ReadOnly Property Pointer As IntPtr
    Get
Visual C++
public:
property IntPtr Pointer {
    IntPtr get ();
}

See Also

IncludeData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IncludeType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IncludeType Enumeration
See Also Send Feedback
Flags for indicating the location of an include file.

(Also see DirectX SDK: D3D10_INCLUDE_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum IncludeType
Visual Basic
Public Enumeration IncludeType
Visual C++
public enum class IncludeType

Members

Member name | Description
System |
Local |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IndexBuffer Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Structure
Members See Also Send Feedback
Stores the parameters required to get or set the current index buffer for a device.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct IndexBuffer
Visual Basic
Public Structure IndexBuffer
Visual C++
public value class IndexBuffer

See Also

IndexBuffer Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IndexBuffer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Members
IndexBuffer Structure Constructors Methods Operators Properties See Also Send Feedback

The IndexBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | IndexBuffer | Constructor.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Buffer |
Public property | Format |
Public property | Offset |

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IndexBuffer Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Constructor
IndexBuffer Structure See Also Send Feedback
Constructor.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IndexBuffer(
    D3DBuffer buffer,
    Format format,
    uint offset
)
Visual Basic
Public Sub New ( _
    buffer As D3DBuffer, _
    format As Format, _
    offset As UInteger _
)
Visual C++
public:
IndexBuffer(
    D3DBuffer^ buffer,
    Format format,
    unsigned int offset
)

Parameters

buffer
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DBuffer
A D3DBuffer object, that contains indices. The index buffer must have been created with the indexBuffer flag.
format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
A Format that specifies the format of the data in the index buffer. The only formats allowed for index buffer data are 16-bit (Format_R16_UINT) and 32-bit (Format_R32_UINT) integers.
offset
Type: System..::..UInt32
Offset (in bytes) from the start of the index buffer to the first index to use.

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IndexBuffer Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Methods
IndexBuffer Structure See Also Send Feedback

The IndexBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Equals Method
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..GetHashCode Method
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IndexBuffer Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Operators
IndexBuffer Structure See Also Send Feedback

The IndexBuffer type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Equality Operator
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    IndexBuffer buffer1,
    IndexBuffer buffer2
)
Visual Basic
Public Shared Operator = ( _
    buffer1 As IndexBuffer, _
    buffer2 As IndexBuffer _
) As Boolean
Visual C++
public:
static bool operator ==(
    IndexBuffer buffer1,
    IndexBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IndexBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IndexBuffer

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Inequality Operator
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    IndexBuffer buffer1,
    IndexBuffer buffer2
)
Visual Basic
Public Shared Operator <> ( _
    buffer1 As IndexBuffer, _
    buffer2 As IndexBuffer _
) As Boolean
Visual C++
public:
static bool operator !=(
    IndexBuffer buffer1,
    IndexBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IndexBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..IndexBuffer

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IndexBuffer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Properties
IndexBuffer Structure See Also Send Feedback

The IndexBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Buffer |
Public property | Format |
Public property | Offset |

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Buffer Property
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer Buffer { get; }
Visual Basic
Public ReadOnly Property Buffer As D3DBuffer
    Get
Visual C++
public:
property D3DBuffer^ Buffer {
    D3DBuffer^ get ();
}

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Format Property
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; }
Visual Basic
Public ReadOnly Property Format As Format
    Get
Visual C++
public:
property Format Format {
    Format get ();
}

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Offset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Offset Property
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Offset { get; }
Visual Basic
Public ReadOnly Property Offset As UInteger
    Get
Visual C++
public:
property unsigned int Offset {
    unsigned int get ();
}

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InfoQueue Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue Class
Members See Also Send Feedback
An information-queue interface stores, retrieves, and filters debug messages. The queue consists of a message queue, an optional storage filter stack, and a optional retrieval filter stack.

(Also see DirectX SDK: ID3D10InfoQueue)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class InfoQueue : DirectUnknown
Visual Basic
Public Class InfoQueue _
    Inherits DirectUnknown
Visual C++
public ref class InfoQueue : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InfoQueue

See Also

InfoQueue Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InfoQueue Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue Members
InfoQueue Class Methods Properties See Also Send Feedback

The InfoQueue type exposes the following members.

Methods

 | Name | Description
Public method | AddApplicationMessage | Add a user-defined message to the message queue and send that message to debug output. (Also see DirectX SDK: ID3D10InfoQueue::AddApplicationMessage)
Public method | AddMessage | Add a Direct3D 10 debug message to the message queue and send that message to debug output. (Also see DirectX SDK: ID3D10InfoQueue::AddMessage)
Public method | ClearStoredMessages | Clear all messages from the message queue. (Also see DirectX SDK: ID3D10InfoQueue::ClearStoredMessages)
Public method | GetBreakOnCategory | Get a message category to break on when a message with that category passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetBreakOnCategory)
Public method | GetBreakOnId | Get a message identifier to break on when a message with that identifier passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetBreakOnID)
Public method | GetBreakOnSeverity | Get a message severity level to break on when a message with that severity level passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetBreakOnSeverity)
Public method | GetMessage | Get a message from the message queue. (Also see DirectX SDK: ID3D10InfoQueue::GetMessage)
Public method | SetBreakOnCategory | Set a message category to break on when a message with that category passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::SetBreakOnCategory)
Public method | SetBreakOnId | Set a message identifier to break on when a message with that identifier passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::SetBreakOnID)
Public method | SetBreakOnSeverity | Set a message severity level to break on when a message with that severity level passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::SetBreakOnSeverity)
Public method | TryGetMessage | Try to get a message from the message queue. (Also see DirectX SDK: ID3D10InfoQueue::GetMessage)

Properties

 | Name | Description
Public property | AllowedByStorageFilterCount | Get the number of messages that were allowed to pass through a storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetNumMessagesAllowedByStorageFilter)
Public property | DeniedByStorageFilterCount | Get the number of messages that were denied passage through a storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetNumMessagesDeniedByStorageFilter)
Public property | DiscardedByMessageCountLimitCount | Get the number of messages that were discarded due to the message count limit. (Also see DirectX SDK: ID3D10InfoQueue::GetNumMessagesDiscardedByMessageCountLimit)
Public property | MessageCountLimit | Get or set the maximum number of messages that can be added to the message queue. (Also see DirectX SDK: ID3D10InfoQueue::GetMessageCountLimit)
Public property | MuteDebugOutput | Get or set a boolean that turns the debug output on or off. (Also see DirectX SDK: ID3D10InfoQueue::GetMuteDebugOutput)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | StoredAllowedByRetrievalFilterCount | Get the number of messages that are able to pass through a retrieval filter. (Also see DirectX SDK: ID3D10InfoQueue::GetNumStoredMessagesAllowedByRetrievalFilter)
Public property | StoredCount | Get the number of messages currently stored in the message queue. (Also see DirectX SDK: ID3D10InfoQueue::GetNumStoredMessages)

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InfoQueue Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue Methods
InfoQueue Class See Also Send Feedback

The InfoQueue type exposes the following members.

Methods

 | Name | Description
Public method | AddApplicationMessage | Add a user-defined message to the message queue and send that message to debug output. (Also see DirectX SDK: ID3D10InfoQueue::AddApplicationMessage)
Public method | AddMessage | Add a Direct3D 10 debug message to the message queue and send that message to debug output. (Also see DirectX SDK: ID3D10InfoQueue::AddMessage)
Public method | ClearStoredMessages | Clear all messages from the message queue. (Also see DirectX SDK: ID3D10InfoQueue::ClearStoredMessages)
Public method | GetBreakOnCategory | Get a message category to break on when a message with that category passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetBreakOnCategory)
Public method | GetBreakOnId | Get a message identifier to break on when a message with that identifier passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetBreakOnID)
Public method | GetBreakOnSeverity | Get a message severity level to break on when a message with that severity level passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetBreakOnSeverity)
Public method | GetMessage | Get a message from the message queue. (Also see DirectX SDK: ID3D10InfoQueue::GetMessage)
Public method | SetBreakOnCategory | Set a message category to break on when a message with that category passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::SetBreakOnCategory)
Public method | SetBreakOnId | Set a message identifier to break on when a message with that identifier passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::SetBreakOnID)
Public method | SetBreakOnSeverity | Set a message severity level to break on when a message with that severity level passes through the storage filter. (Also see DirectX SDK: ID3D10InfoQueue::SetBreakOnSeverity)
Public method | TryGetMessage | Try to get a message from the message queue. (Also see DirectX SDK: ID3D10InfoQueue::GetMessage)

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AddApplicationMessage Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..AddApplicationMessage Method
InfoQueue Class See Also Send Feedback
Add a user-defined message to the message queue and send that message to debug output.

(Also see DirectX SDK: ID3D10InfoQueue::AddApplicationMessage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void AddApplicationMessage(
    MessageSeverity severity,
    string description
)
Visual Basic
Public Sub AddApplicationMessage ( _
    severity As MessageSeverity, _
    description As String _
)
Visual C++
public:
void AddApplicationMessage(
    MessageSeverity severity,
    String^ description
)

Parameters

severity
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageSeverity
Severity of a message (see MessageSeverity).
description
Type: System..::..String
Message string.

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageSeverity


AddMessage Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..AddMessage Method
InfoQueue Class See Also Send Feedback
Add a Direct3D 10 debug message to the message queue and send that message to debug output.

(Also see DirectX SDK: ID3D10InfoQueue::AddMessage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void AddMessage(
    MessageCategory category,
    MessageSeverity severity,
    MessageId id,
    string description
)
Visual Basic
Public Sub AddMessage ( _
    category As MessageCategory, _
    severity As MessageSeverity, _
    id As MessageId, _
    description As String _
)
Visual C++
public:
void AddMessage(
    MessageCategory category,
    MessageSeverity severity,
    MessageId id,
    String^ description
)

Parameters

category
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageCategory
Category of a message (see MessageCategory).
severity
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageSeverity
Severity of a message (see MessageSeverity).
id
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageId
Unique identifier of a message (see MessageId).
description
Type: System..::..String
User-defined message.

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageCategory
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageSeverity
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageId


ClearStoredMessages Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..ClearStoredMessages Method
InfoQueue Class See Also Send Feedback
Clear all messages from the message queue.

(Also see DirectX SDK: ID3D10InfoQueue::ClearStoredMessages)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearStoredMessages()
Visual Basic
Public Sub ClearStoredMessages
Visual C++
public:
void ClearStoredMessages()

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetBreakOnCategory Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..GetBreakOnCategory Method
InfoQueue Class See Also Send Feedback
Get a message category to break on when a message with that category passes through the storage filter.

(Also see DirectX SDK: ID3D10InfoQueue::GetBreakOnCategory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool GetBreakOnCategory(
    MessageCategory category
)
Visual Basic
Public Function GetBreakOnCategory ( _
    category As MessageCategory _
) As Boolean
Visual C++
public:
bool GetBreakOnCategory(
    MessageCategory category
)

Parameters

category
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageCategory
Message category to break on (see MessageCategory).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageCategory


GetBreakOnId Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..GetBreakOnId Method
InfoQueue Class See Also Send Feedback
Get a message identifier to break on when a message with that identifier passes through the storage filter.

(Also see DirectX SDK: ID3D10InfoQueue::GetBreakOnID)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool GetBreakOnId(
    MessageId id
)
Visual Basic
Public Function GetBreakOnId ( _
    id As MessageId _
) As Boolean
Visual C++
public:
bool GetBreakOnId(
    MessageId id
)

Parameters

id
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageId
Message identifier to break on (see MessageId).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageId


GetBreakOnSeverity Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..GetBreakOnSeverity Method
InfoQueue Class See Also Send Feedback
Get a message severity level to break on when a message with that severity level passes through the storage filter.

(Also see DirectX SDK: ID3D10InfoQueue::GetBreakOnSeverity)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool GetBreakOnSeverity(
    MessageSeverity severity
)
Visual Basic
Public Function GetBreakOnSeverity ( _
    severity As MessageSeverity _
) As Boolean
Visual C++
public:
bool GetBreakOnSeverity(
    MessageSeverity severity
)

Parameters

severity
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageSeverity
Message severity level to break on (see MessageSeverity).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageSeverity


GetMessage Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..GetMessage Method
InfoQueue Class See Also Send Feedback
Get a message from the message queue.

(Also see DirectX SDK: ID3D10InfoQueue::GetMessage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Message GetMessage(
    ulong messageIndex
)
Visual Basic
Public Function GetMessage ( _
    messageIndex As ULong _
) As Message
Visual C++
public:
Message GetMessage(
    unsigned long long messageIndex
)

Parameters

messageIndex
Type: System..::..UInt64
Index into message queue after an optional retrieval filter has been applied. This can be between 0 and the number of messages in the message queue that pass through the retrieval filter (which can be obtained with GetNumStoredMessagesAllowedByRetrievalFilter(). 0 is the message at the front of the message queue.

Return Value

Returned message (see Message).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Message


SetBreakOnCategory Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..SetBreakOnCategory Method
InfoQueue Class See Also Send Feedback
Set a message category to break on when a message with that category passes through the storage filter.

(Also see DirectX SDK: ID3D10InfoQueue::SetBreakOnCategory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetBreakOnCategory(
    MessageCategory category,
    bool enable
)
Visual Basic
Public Sub SetBreakOnCategory ( _
    category As MessageCategory, _
    enable As Boolean _
)
Visual C++
public:
void SetBreakOnCategory(
    MessageCategory category,
    bool enable
)

Parameters

category
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageCategory
Message category to break on (see MessageCategory).
enable
Type: System..::..Boolean
Turns this breaking condition on or off (true for on, false for off).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageCategory


SetBreakOnId Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..SetBreakOnId Method
InfoQueue Class See Also Send Feedback
Set a message identifier to break on when a message with that identifier passes through the storage filter.

(Also see DirectX SDK: ID3D10InfoQueue::SetBreakOnID)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetBreakOnId(
    MessageId id,
    bool enable
)
Visual Basic
Public Sub SetBreakOnId ( _
    id As MessageId, _
    enable As Boolean _
)
Visual C++
public:
void SetBreakOnId(
    MessageId id,
    bool enable
)

Parameters

id
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageId
Message identifier to break on (see MessageId).
enable
Type: System..::..Boolean
Turns this breaking condition on or off (true for on, false for off).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageId


SetBreakOnSeverity Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..SetBreakOnSeverity Method
InfoQueue Class See Also Send Feedback
Set a message severity level to break on when a message with that severity level passes through the storage filter.

(Also see DirectX SDK: ID3D10InfoQueue::SetBreakOnSeverity)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetBreakOnSeverity(
    MessageSeverity severity,
    bool enable
)
Visual Basic
Public Sub SetBreakOnSeverity ( _
    severity As MessageSeverity, _
    enable As Boolean _
)
Visual C++
public:
void SetBreakOnSeverity(
    MessageSeverity severity,
    bool enable
)

Parameters

severity
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageSeverity
Message severity level to break on (see MessageSeverity).
enable
Type: System..::..Boolean
Turns this breaking condition on or off (true for on, false for off).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MessageSeverity


TryGetMessage Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..TryGetMessage Method
InfoQueue Class See Also Send Feedback
Try to get a message from the message queue.

(Also see DirectX SDK: ID3D10InfoQueue::GetMessage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool TryGetMessage(
    ulong messageIndex,
    out Message message
)
Visual Basic
Public Function TryGetMessage ( _
    messageIndex As ULong, _
    <OutAttribute> ByRef message As Message _
) As Boolean
Visual C++
public:
bool TryGetMessage(
    unsigned long long messageIndex,
    [OutAttribute] Message% message
)

Parameters

messageIndex
Type: System..::..UInt64
Index into message queue after an optional retrieval filter has been applied. This can be between 0 and the number of messages in the message queue that pass through the retrieval filter (which can be obtained with StoredAllowedByRetrievalFilterCount property. Index 0 is the message at the front of the message queue.
message
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Message %
Returned message (see Message).

Return Value

True if successful; false otherwise.

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Message


InfoQueue Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue Properties
InfoQueue Class See Also Send Feedback

The InfoQueue type exposes the following members.

Properties

 | Name | Description
Public property | AllowedByStorageFilterCount | Get the number of messages that were allowed to pass through a storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetNumMessagesAllowedByStorageFilter)
Public property | DeniedByStorageFilterCount | Get the number of messages that were denied passage through a storage filter. (Also see DirectX SDK: ID3D10InfoQueue::GetNumMessagesDeniedByStorageFilter)
Public property | DiscardedByMessageCountLimitCount | Get the number of messages that were discarded due to the message count limit. (Also see DirectX SDK: ID3D10InfoQueue::GetNumMessagesDiscardedByMessageCountLimit)
Public property | MessageCountLimit | Get or set the maximum number of messages that can be added to the message queue. (Also see DirectX SDK: ID3D10InfoQueue::GetMessageCountLimit)
Public property | MuteDebugOutput | Get or set a boolean that turns the debug output on or off. (Also see DirectX SDK: ID3D10InfoQueue::GetMuteDebugOutput)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | StoredAllowedByRetrievalFilterCount | Get the number of messages that are able to pass through a retrieval filter. (Also see DirectX SDK: ID3D10InfoQueue::GetNumStoredMessagesAllowedByRetrievalFilter)
Public property | StoredCount | Get the number of messages currently stored in the message queue. (Also see DirectX SDK: ID3D10InfoQueue::GetNumStoredMessages)

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AllowedByStorageFilterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..AllowedByStorageFilterCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages that were allowed to pass through a storage filter.

(Also see DirectX SDK: ID3D10InfoQueue::GetNumMessagesAllowedByStorageFilter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong AllowedByStorageFilterCount { get; }
Visual Basic
Public ReadOnly Property AllowedByStorageFilterCount As ULong
    Get
Visual C++
public:
property unsigned long long AllowedByStorageFilterCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DeniedByStorageFilterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..DeniedByStorageFilterCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages that were denied passage through a storage filter.

(Also see DirectX SDK: ID3D10InfoQueue::GetNumMessagesDeniedByStorageFilter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong DeniedByStorageFilterCount { get; }
Visual Basic
Public ReadOnly Property DeniedByStorageFilterCount As ULong
    Get
Visual C++
public:
property unsigned long long DeniedByStorageFilterCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DiscardedByMessageCountLimitCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..DiscardedByMessageCountLimitCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages that were discarded due to the message count limit.

(Also see DirectX SDK: ID3D10InfoQueue::GetNumMessagesDiscardedByMessageCountLimit)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong DiscardedByMessageCountLimitCount { get; }
Visual Basic
Public ReadOnly Property DiscardedByMessageCountLimitCount As ULong
    Get
Visual C++
public:
property unsigned long long DiscardedByMessageCountLimitCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MessageCountLimit Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..MessageCountLimit Property
InfoQueue Class See Also Send Feedback
Get or set the maximum number of messages that can be added to the message queue.

(Also see DirectX SDK: ID3D10InfoQueue::GetMessageCountLimit)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong MessageCountLimit { get; set; }
Visual Basic
Public Property MessageCountLimit As ULong
    Get
    Set
Visual C++
public:
property unsigned long long MessageCountLimit {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MuteDebugOutput Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..MuteDebugOutput Property
InfoQueue Class See Also Send Feedback
Get or set a boolean that turns the debug output on or off.

(Also see DirectX SDK: ID3D10InfoQueue::GetMuteDebugOutput)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool MuteDebugOutput { get; set; }
Visual Basic
Public Property MuteDebugOutput As Boolean
    Get
    Set
Visual C++
public:
property bool MuteDebugOutput {
    bool get ();
    void set (bool value);
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StoredAllowedByRetrievalFilterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..StoredAllowedByRetrievalFilterCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages that are able to pass through a retrieval filter.

(Also see DirectX SDK: ID3D10InfoQueue::GetNumStoredMessagesAllowedByRetrievalFilter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong StoredAllowedByRetrievalFilterCount { get; }
Visual Basic
Public ReadOnly Property StoredAllowedByRetrievalFilterCount As ULong
    Get
Visual C++
public:
property unsigned long long StoredAllowedByRetrievalFilterCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StoredCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..StoredCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages currently stored in the message queue.

(Also see DirectX SDK: ID3D10InfoQueue::GetNumStoredMessages)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong StoredCount { get; }
Visual Basic
Public ReadOnly Property StoredCount As ULong
    Get
Visual C++
public:
property unsigned long long StoredCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage Class
Members See Also Send Feedback
InputAssembler pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class InputAssemblerPipelineStage : PipelineStage
Visual Basic
Public Class InputAssemblerPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class InputAssemblerPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InputAssemblerPipelineStage

See Also

InputAssemblerPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage Members
InputAssemblerPipelineStage Class Methods Properties See Also Send Feedback

The InputAssemblerPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetVertexBuffers | Get the vertex buffers bound to the input-assembler stage. (Also see DirectX SDK: ID3D10Device::IAGetVertexBuffers)
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(VertexBuffer>)>>)) |
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(D3DBuffer>)>>), array<UInt32>[]()[][], array<UInt32>[]()[][]) |

Properties

 | Name | Description
Public property | IndexBuffer | Get or sets the index buffer that is bound to the input-assembler stage. (see IndexBuffer) (Also see DirectX SDK: ID3D10Device::IAGetIndexBuffer, ID3D10Device::IASetIndexBuffer)
Public property | InputLayout | Gets or sets the input-layout object that is bound to the input-assembler stage. (Also see DirectX SDK: ID3D10Device::IAGetInputLayout, ID3D10Device::IASetInputLayout)
Public property | PrimitiveTopology | Gets or sets information about the primitive type, and data order that describes input data for the input assembler stage. (Also see DirectX SDK: ID3D10Device::IAGetPrimitiveTopology, ID3D10Device::IASetPrimitiveTopology)

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage Methods
InputAssemblerPipelineStage Class See Also Send Feedback

The InputAssemblerPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetVertexBuffers | Get the vertex buffers bound to the input-assembler stage. (Also see DirectX SDK: ID3D10Device::IAGetVertexBuffers)
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(VertexBuffer>)>>)) |
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(D3DBuffer>)>>), array<UInt32>[]()[][], array<UInt32>[]()[][]) |

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetVertexBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..GetVertexBuffers Method
InputAssemblerPipelineStage Class See Also Send Feedback
Get the vertex buffers bound to the input-assembler stage.

(Also see DirectX SDK: ID3D10Device::IAGetVertexBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<VertexBuffer> GetVertexBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetVertexBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of VertexBuffer)
Visual C++
public:
ReadOnlyCollection<VertexBuffer>^ GetVertexBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
The input slot of the first vertex buffer to get. The first vertex buffer is explicitly bound to the start slot; this causes each additional vertex buffer in the array to be implicitly bound to each subsequent input slot. There are 16 input slots.
bufferCount
Type: System..::..UInt32
The number of vertex buffers to get starting at the offset. The number of buffers (plus the starting slot) cannot exceed the total number of IA-stage input slots.

Return Value

A collection of vertex buffers returned by the method (see VertexBuffer).

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..VertexBuffer


SetVertexBuffers Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..SetVertexBuffers Method
InputAssemblerPipelineStage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(VertexBuffer>)>>)) |
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(D3DBuffer>)>>), array<UInt32>[]()[][], array<UInt32>[]()[][]) |

See Also

InputAssemblerPipelineStage Class
InputAssemblerPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetVertexBuffers Method (UInt32, IEnumerable(VertexBuffer))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..SetVertexBuffers Method (UInt32, IEnumerable<(Of <(<'VertexBuffer>)>)>)
InputAssemblerPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetVertexBuffers(
    uint startSlot,
    IEnumerable<VertexBuffer> vertexBuffers
)
Visual Basic
Public Sub SetVertexBuffers ( _
    startSlot As UInteger, _
    vertexBuffers As IEnumerable(Of VertexBuffer) _
)
Visual C++
public:
void SetVertexBuffers(
    unsigned int startSlot,
    IEnumerable<VertexBuffer>^ vertexBuffers
)

Parameters

startSlot
Type: System..::..UInt32
vertexBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' VertexBuffer >)>)>

See Also

InputAssemblerPipelineStage Class
SetVertexBuffers Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetVertexBuffers Method (UInt32, IEnumerable(D3DBuffer), UInt32[], UInt32[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..SetVertexBuffers Method (UInt32, IEnumerable<(Of <(<'D3DBuffer>)>)>, array<UInt32>[]()[][], array<UInt32>[]()[][])
InputAssemblerPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetVertexBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> vertexBuffers,
    uint[] strides,
    uint[] offsets
)
Visual Basic
Public Sub SetVertexBuffers ( _
    startSlot As UInteger, _
    vertexBuffers As IEnumerable(Of D3DBuffer), _
    strides As UInteger(), _
    offsets As UInteger() _
)
Visual C++
public:
void SetVertexBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ vertexBuffers,
    array<unsigned int>^ strides,
    array<unsigned int>^ offsets
)

Parameters

startSlot
Type: System..::..UInt32
vertexBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>
strides
Type: array< System..::..UInt32 >[]()[][]
offsets
Type: array< System..::..UInt32 >[]()[][]

See Also

InputAssemblerPipelineStage Class
SetVertexBuffers Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage Properties
InputAssemblerPipelineStage Class See Also Send Feedback

The InputAssemblerPipelineStage type exposes the following members.

Properties

 | Name | Description
Public property | IndexBuffer | Get or sets the index buffer that is bound to the input-assembler stage. (see IndexBuffer) (Also see DirectX SDK: ID3D10Device::IAGetIndexBuffer, ID3D10Device::IASetIndexBuffer)
Public property | InputLayout | Gets or sets the input-layout object that is bound to the input-assembler stage. (Also see DirectX SDK: ID3D10Device::IAGetInputLayout, ID3D10Device::IASetInputLayout)
Public property | PrimitiveTopology | Gets or sets information about the primitive type, and data order that describes input data for the input assembler stage. (Also see DirectX SDK: ID3D10Device::IAGetPrimitiveTopology, ID3D10Device::IASetPrimitiveTopology)

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IndexBuffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..IndexBuffer Property
InputAssemblerPipelineStage Class See Also Send Feedback
Get or sets the index buffer that is bound to the input-assembler stage. (see IndexBuffer)

(Also see DirectX SDK: ID3D10Device::IAGetIndexBuffer, ID3D10Device::IASetIndexBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IndexBuffer IndexBuffer { get; set; }
Visual Basic
Public Property IndexBuffer As IndexBuffer
    Get
    Set
Visual C++
public:
property IndexBuffer IndexBuffer {
    IndexBuffer get ();
    void set (IndexBuffer value);
}

Remarks

Calling this method using a buffer that is currently bound for writing (i.e. bound to the stream output pipeline stage) will effectively bind null instead because a buffer cannot be bound as both an input and an output at the same time.

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
InputAssemblerPipelineStage..::..IndexBuffer


InputLayout Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..InputLayout Property
InputAssemblerPipelineStage Class See Also Send Feedback
Gets or sets the input-layout object that is bound to the input-assembler stage.

(Also see DirectX SDK: ID3D10Device::IAGetInputLayout, ID3D10Device::IASetInputLayout)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputLayout InputLayout { get; set; }
Visual Basic
Public Property InputLayout As InputLayout
    Get
    Set
Visual C++
public:
property InputLayout^ InputLayout {
    InputLayout^ get ();
    void set (InputLayout^ value);
}

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PrimitiveTopology Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..PrimitiveTopology Property
InputAssemblerPipelineStage Class See Also Send Feedback
Gets or sets information about the primitive type, and data order that describes input data for the input assembler stage.

(Also see DirectX SDK: ID3D10Device::IAGetPrimitiveTopology, ID3D10Device::IASetPrimitiveTopology)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PrimitiveTopology PrimitiveTopology { get; set; }
Visual Basic
Public Property PrimitiveTopology As PrimitiveTopology
    Get
    Set
Visual C++
public:
property PrimitiveTopology PrimitiveTopology {
    PrimitiveTopology get ();
    void set (PrimitiveTopology value);
}

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputClassification Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputClassification Enumeration
See Also Send Feedback
Type of data contained in an input slot.

(Also see DirectX SDK: D3D10_INPUT_CLASSIFICATION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum InputClassification
Visual Basic
Public Enumeration InputClassification
Visual C++
public enum class InputClassification

Members

Member name | Description
PerInstanceData |
PerVertexData |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputElementDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Structure
Members See Also Send Feedback
A description of a single element for the input-assembler stage.

(Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct InputElementDescription
Visual Basic
Public Structure InputElementDescription
Visual C++
public value class InputElementDescription

See Also

InputElementDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputElementDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Members
InputElementDescription Structure Methods Operators Properties See Also Send Feedback

The InputElementDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AlignedByteOffset | Optional. Offset (in bytes) between each element. Use D3D10_APPEND_ALIGNED_ELEMENT for convenience to define the current element directly after the previous one, including any packing if necessary. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.AlignedByteOffset)
Public property | Format | The data type of the element data. See Format. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.Format)
Public property | InputSlot | An integer value that identifies the input-assembler (see input slot). Valid values are between 0 and 15, defined in D3D10.h. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.InputSlot)
Public property | InputSlotClass | Identifies the input data class for a single input slot (see InputClassification). (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.InputSlotClass)
Public property | InstanceDataStepRate | The number of instances to draw before stepping one unit forward in a vertex buffer filled with instance data. Can be any unsigned integer value (0 means do not step) when the slot class is D3D10_INPUT_PER_INSTANCE_DATA; must be 0 when the slot class is PerVertexData. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.InstanceDataStepRate)
Public property | SemanticIndex | The semantic index for the element. A semantic index modifies a semantic, with an integer index number. A semantic index is only needed in a case where there is more than one element with the same semantic. For example, a 4x4 matrix would have four components each with the semantic name matrix, however each of the four component would have different semantic indices (0, 1, 2, and 3). (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.SemanticIndex)
Public property | SemanticName | The HLSL semantic associated with this element in a shader input-signature. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.SemanticName)

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputElementDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Methods
InputElementDescription Structure See Also Send Feedback

The InputElementDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..Equals Method
InputElementDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..GetHashCode Method
InputElementDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputElementDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Operators
InputElementDescription Structure See Also Send Feedback

The InputElementDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..Equality Operator
InputElementDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    InputElementDescription inputElementDescription1,
    InputElementDescription inputElementDescription2
)
Visual Basic
Public Shared Operator = ( _
    inputElementDescription1 As InputElementDescription, _
    inputElementDescription2 As InputElementDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    InputElementDescription inputElementDescription1,
    InputElementDescription inputElementDescription2
)

Parameters

inputElementDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InputElementDescription
inputElementDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InputElementDescription

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..Inequality Operator
InputElementDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    InputElementDescription inputElementDescription1,
    InputElementDescription inputElementDescription2
)
Visual Basic
Public Shared Operator <> ( _
    inputElementDescription1 As InputElementDescription, _
    inputElementDescription2 As InputElementDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    InputElementDescription inputElementDescription1,
    InputElementDescription inputElementDescription2
)

Parameters

inputElementDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InputElementDescription
inputElementDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InputElementDescription

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputElementDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Properties
InputElementDescription Structure See Also Send Feedback

The InputElementDescription type exposes the following members.

Properties

 | Name | Description
Public property | AlignedByteOffset | Optional. Offset (in bytes) between each element. Use D3D10_APPEND_ALIGNED_ELEMENT for convenience to define the current element directly after the previous one, including any packing if necessary. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.AlignedByteOffset)
Public property | Format | The data type of the element data. See Format. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.Format)
Public property | InputSlot | An integer value that identifies the input-assembler (see input slot). Valid values are between 0 and 15, defined in D3D10.h. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.InputSlot)
Public property | InputSlotClass | Identifies the input data class for a single input slot (see InputClassification). (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.InputSlotClass)
Public property | InstanceDataStepRate | The number of instances to draw before stepping one unit forward in a vertex buffer filled with instance data. Can be any unsigned integer value (0 means do not step) when the slot class is D3D10_INPUT_PER_INSTANCE_DATA; must be 0 when the slot class is PerVertexData. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.InstanceDataStepRate)
Public property | SemanticIndex | The semantic index for the element. A semantic index modifies a semantic, with an integer index number. A semantic index is only needed in a case where there is more than one element with the same semantic. For example, a 4x4 matrix would have four components each with the semantic name matrix, however each of the four component would have different semantic indices (0, 1, 2, and 3). (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.SemanticIndex)
Public property | SemanticName | The HLSL semantic associated with this element in a shader input-signature. (Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.SemanticName)

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AlignedByteOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..AlignedByteOffset Property
InputElementDescription Structure See Also Send Feedback
Optional. Offset (in bytes) between each element. Use D3D10_APPEND_ALIGNED_ELEMENT for convenience to define the current element directly after the previous one, including any packing if necessary.

(Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.AlignedByteOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint AlignedByteOffset { get; set; }
Visual Basic
Public Property AlignedByteOffset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int AlignedByteOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..Format Property
InputElementDescription Structure See Also Send Feedback
The data type of the element data. See Format.

(Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputSlot Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..InputSlot Property
InputElementDescription Structure See Also Send Feedback
An integer value that identifies the input-assembler (see input slot). Valid values are between 0 and 15, defined in D3D10.h.

(Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.InputSlot)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InputSlot { get; set; }
Visual Basic
Public Property InputSlot As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InputSlot {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputSlotClass Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..InputSlotClass Property
InputElementDescription Structure See Also Send Feedback
Identifies the input data class for a single input slot (see InputClassification).

(Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.InputSlotClass)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputClassification InputSlotClass { get; set; }
Visual Basic
Public Property InputSlotClass As InputClassification
    Get
    Set
Visual C++
public:
property InputClassification InputSlotClass {
    InputClassification get ();
    void set (InputClassification value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InputClassification


InstanceDataStepRate Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..InstanceDataStepRate Property
InputElementDescription Structure See Also Send Feedback
The number of instances to draw before stepping one unit forward in a vertex buffer filled with instance data. Can be any unsigned integer value (0 means do not step) when the slot class is D3D10_INPUT_PER_INSTANCE_DATA; must be 0 when the slot class is PerVertexData.

(Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.InstanceDataStepRate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InstanceDataStepRate { get; set; }
Visual Basic
Public Property InstanceDataStepRate As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InstanceDataStepRate {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SemanticIndex Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..SemanticIndex Property
InputElementDescription Structure See Also Send Feedback
The semantic index for the element. A semantic index modifies a semantic, with an integer index number. A semantic index is only needed in a case where there is more than one element with the same semantic. For example, a 4x4 matrix would have four components each with the semantic name matrix, however each of the four component would have different semantic indices (0, 1, 2, and 3).

(Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.SemanticIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SemanticIndex { get; set; }
Visual Basic
Public Property SemanticIndex As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SemanticIndex {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SemanticName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..SemanticName Property
InputElementDescription Structure See Also Send Feedback
The HLSL semantic associated with this element in a shader input-signature.

(Also see DirectX SDK: D3D10_INPUT_ELEMENT_DESC.SemanticName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string SemanticName { get; set; }
Visual Basic
Public Property SemanticName As String
    Get
    Set
Visual C++
public:
property String^ SemanticName {
    String^ get ();
    void set (String^ value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputLayout Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputLayout Class
Members See Also Send Feedback
An input-layout interface accesses the input data for the input-assembler stage.

(Also see DirectX SDK: ID3D10InputLayout)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class InputLayout : DeviceChild
Visual Basic
Public Class InputLayout _
    Inherits DeviceChild
Visual C++
public ref class InputLayout : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InputLayout

See Also

InputLayout Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputLayout Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputLayout Members
InputLayout Class Properties See Also Send Feedback

The InputLayout type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

InputLayout Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputLayout Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputLayout Properties
InputLayout Class See Also Send Feedback

The InputLayout type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

InputLayout Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Map Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Map Enumeration
See Also Send Feedback
Identifies a resource to be accessed for reading and writing by the CPU. Applications may combine one or more of these flags.

(Also see DirectX SDK: D3D10_MAP)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Map
Visual Basic
Public Enumeration Map
Visual C++
public enum class Map

Members

Member name | Description
WriteNoOverwrite |
WriteDiscard |
ReadWrite |
Write |
Read |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MapOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MapOptions Enumeration
See Also Send Feedback
Specifies how the CPU should respond when Map is called on a resource being used by the GPU.

(Also see DirectX SDK: D3D10_MAP_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum MapOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration MapOptions
Visual C++
[FlagsAttribute]
public enum class MapOptions

Members

Member name | Description
DoNotWait |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MappedTexture2D Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture2D Structure
Members See Also Send Feedback
Provides access to subresource data in a 2D texture.

(Also see DirectX SDK: D3D10_MAPPED_TEXTURE2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct MappedTexture2D
Visual Basic
Public Structure MappedTexture2D
Visual C++
public value class MappedTexture2D

See Also

MappedTexture2D Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MappedTexture2D Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture2D Members
MappedTexture2D Structure Properties See Also Send Feedback

The MappedTexture2D type exposes the following members.

Properties

 | Name | Description
Public property | Data | Pointer to the data. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE2D.pData)
Public property | RowPitch | The pitch, or width, or physical size (in bytes), of one row of an uncompressed texture. A block-compressed texture is encoded in 4x4 blocks (see virtual size vs physical size) ; therefore, RowPitch is the number of bytes in a block of 4x4 texels. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE2D.RowPitch)

See Also

MappedTexture2D Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MappedTexture2D Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture2D Properties
MappedTexture2D Structure See Also Send Feedback

The MappedTexture2D type exposes the following members.

Properties

 | Name | Description
Public property | Data | Pointer to the data. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE2D.pData)
Public property | RowPitch | The pitch, or width, or physical size (in bytes), of one row of an uncompressed texture. A block-compressed texture is encoded in 4x4 blocks (see virtual size vs physical size) ; therefore, RowPitch is the number of bytes in a block of 4x4 texels. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE2D.RowPitch)

See Also

MappedTexture2D Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Data Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture2D..::..Data Property
MappedTexture2D Structure See Also Send Feedback
Pointer to the data.

(Also see DirectX SDK: D3D10_MAPPED_TEXTURE2D.pData)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr Data { get; set; }
Visual Basic
Public Property Data As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr Data {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

MappedTexture2D Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RowPitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture2D..::..RowPitch Property
MappedTexture2D Structure See Also Send Feedback
The pitch, or width, or physical size (in bytes), of one row of an uncompressed texture. A block-compressed texture is encoded in 4x4 blocks (see virtual size vs physical size) ; therefore, RowPitch is the number of bytes in a block of 4x4 texels.

(Also see DirectX SDK: D3D10_MAPPED_TEXTURE2D.RowPitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint RowPitch { get; set; }
Visual Basic
Public Property RowPitch As UInteger
    Get
    Set
Visual C++
public:
property unsigned int RowPitch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

MappedTexture2D Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MappedTexture3D Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture3D Structure
Members See Also Send Feedback
Provides access to subresource data in a 3D texture.

(Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct MappedTexture3D
Visual Basic
Public Structure MappedTexture3D
Visual C++
public value class MappedTexture3D

See Also

MappedTexture3D Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MappedTexture3D Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture3D Members
MappedTexture3D Structure Properties See Also Send Feedback

The MappedTexture3D type exposes the following members.

Properties

 | Name | Description
Public property | Data | Pointer to the data. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D.pData)
Public property | DepthPitch | The pitch or number of bytes in all rows for a single depth. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D.DepthPitch)
Public property | RowPitch | The pitch, or width, or physical size (in bytes) of one row of an uncompressed texture. Since a block-compressed texture is encoded in 4x4 blocks, the RowPitch for a compressed texture is the number of bytes in a block of 4x4 texels. See virtual size vs physical size for more information on block compression. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D.RowPitch)

See Also

MappedTexture3D Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MappedTexture3D Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture3D Properties
MappedTexture3D Structure See Also Send Feedback

The MappedTexture3D type exposes the following members.

Properties

 | Name | Description
Public property | Data | Pointer to the data. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D.pData)
Public property | DepthPitch | The pitch or number of bytes in all rows for a single depth. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D.DepthPitch)
Public property | RowPitch | The pitch, or width, or physical size (in bytes) of one row of an uncompressed texture. Since a block-compressed texture is encoded in 4x4 blocks, the RowPitch for a compressed texture is the number of bytes in a block of 4x4 texels. See virtual size vs physical size for more information on block compression. (Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D.RowPitch)

See Also

MappedTexture3D Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Data Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture3D..::..Data Property
MappedTexture3D Structure See Also Send Feedback
Pointer to the data.

(Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D.pData)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr Data { get; set; }
Visual Basic
Public Property Data As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr Data {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

MappedTexture3D Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthPitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture3D..::..DepthPitch Property
MappedTexture3D Structure See Also Send Feedback
The pitch or number of bytes in all rows for a single depth.

(Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D.DepthPitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DepthPitch { get; set; }
Visual Basic
Public Property DepthPitch As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DepthPitch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

MappedTexture3D Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RowPitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedTexture3D..::..RowPitch Property
MappedTexture3D Structure See Also Send Feedback
The pitch, or width, or physical size (in bytes) of one row of an uncompressed texture. Since a block-compressed texture is encoded in 4x4 blocks, the RowPitch for a compressed texture is the number of bytes in a block of 4x4 texels. See virtual size vs physical size for more information on block compression.

(Also see DirectX SDK: D3D10_MAPPED_TEXTURE3D.RowPitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint RowPitch { get; set; }
Visual Basic
Public Property RowPitch As UInteger
    Get
    Set
Visual C++
public:
property unsigned int RowPitch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

MappedTexture3D Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Message Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Structure
Members See Also Send Feedback
A debug message in the Information Queue.

(Also see DirectX SDK: D3D10_MESSAGE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Message
Visual Basic
Public Structure Message
Visual C++
public value class Message

See Also

Message Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Message Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Members
Message Structure Methods Operators Properties See Also Send Feedback

The Message type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Category | The category of the message. See MessageCategory. (Also see DirectX SDK: D3D10_MESSAGE.Category)
Public property | Description | The message description string. (Also see DirectX SDK: D3D10_MESSAGE.pDescription)
Public property | Id | The ID of the message. See MessageId. (Also see DirectX SDK: D3D10_MESSAGE.ID)
Public property | Severity | The severity of the message. See MessageSeverity. (Also see DirectX SDK: D3D10_MESSAGE.Severity)

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Message Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Methods
Message Structure See Also Send Feedback

The Message type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Equals Method
Message Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..GetHashCode Method
Message Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Message Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Operators
Message Structure See Also Send Feedback

The Message type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Equality Operator
Message Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Message message1,
    Message message2
)
Visual Basic
Public Shared Operator = ( _
    message1 As Message, _
    message2 As Message _
) As Boolean
Visual C++
public:
static bool operator ==(
    Message message1,
    Message message2
)

Parameters

message1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Message
message2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Message

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Inequality Operator
Message Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Message message1,
    Message message2
)
Visual Basic
Public Shared Operator <> ( _
    message1 As Message, _
    message2 As Message _
) As Boolean
Visual C++
public:
static bool operator !=(
    Message message1,
    Message message2
)

Parameters

message1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Message
message2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Message

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Message Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Properties
Message Structure See Also Send Feedback

The Message type exposes the following members.

Properties

 | Name | Description
Public property | Category | The category of the message. See MessageCategory. (Also see DirectX SDK: D3D10_MESSAGE.Category)
Public property | Description | The message description string. (Also see DirectX SDK: D3D10_MESSAGE.pDescription)
Public property | Id | The ID of the message. See MessageId. (Also see DirectX SDK: D3D10_MESSAGE.ID)
Public property | Severity | The severity of the message. See MessageSeverity. (Also see DirectX SDK: D3D10_MESSAGE.Severity)

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Category Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Category Property
Message Structure See Also Send Feedback
The category of the message. See MessageCategory.

(Also see DirectX SDK: D3D10_MESSAGE.Category)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MessageCategory Category { get; set; }
Visual Basic
Public Property Category As MessageCategory
    Get
    Set
Visual C++
public:
property MessageCategory Category {
    MessageCategory get ();
    void set (MessageCategory value);
}

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Description Property
Message Structure See Also Send Feedback
The message description string.

(Also see DirectX SDK: D3D10_MESSAGE.pDescription)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Id Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Id Property
Message Structure See Also Send Feedback
The ID of the message. See MessageId.

(Also see DirectX SDK: D3D10_MESSAGE.ID)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MessageId Id { get; set; }
Visual Basic
Public Property Id As MessageId
    Get
    Set
Visual C++
public:
property MessageId Id {
    MessageId get ();
    void set (MessageId value);
}

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Severity Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Severity Property
Message Structure See Also Send Feedback
The severity of the message. See MessageSeverity.

(Also see DirectX SDK: D3D10_MESSAGE.Severity)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MessageSeverity Severity { get; set; }
Visual Basic
Public Property Severity As MessageSeverity
    Get
    Set
Visual C++
public:
property MessageSeverity Severity {
    MessageSeverity get ();
    void set (MessageSeverity value);
}

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MessageCategory Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MessageCategory Enumeration
See Also Send Feedback
Categories of debug messages. This will identify the category of a message when retrieving a message with InfoQueue.GetMessage and when adding a message with InfoQueue.AddMessage. When creating an info queue filter, these values can be used to allow or deny any categories of messages to pass through the storage and retrieval filters.

(Also see DirectX SDK: D3D10_MESSAGE_CATEGORY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum MessageCategory
Visual Basic
Public Enumeration MessageCategory
Visual C++
public enum class MessageCategory

Members

Member name | Description
Execution |
ResourceManipulation |
StateGetting |
StateSetting |
StateCreation |
Compilation |
Cleanup |
Initialization |
Miscellaneous |
ApplicationDefined |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MessageId Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MessageId Enumeration
See Also Send Feedback
Debug messages for setting up an info-queue filter; use these messages to allow or deny message categories to pass through the storage and retrieval filters. These IDs are used by methods such as InfoQueue.GetMessage or InfoQueue.AddMessage.

(Also see DirectX SDK: D3D10_MESSAGE_ID)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum MessageId
Visual Basic
Public Enumeration MessageId
Visual C++
public enum class MessageId

Members

Member name | Description
CreateInputLayoutTooManyElements |
CreateInputLayoutOutOfMemory |
CreateDepthStencilViewOutOfMemoryReturn |
CreateDepthStencilViewInvalidArgReturn |
CreateDepthStencilViewTooManyObjects |
CreateDepthStencilViewInvalidResource |
CreateDepthStencilViewInvalidDimensions |
CreateDepthStencilViewInvalidFormat |
CreateDepthStencilViewInvalidDesc |
CreateDepthStencilViewUnrecognizedFormat |
CreateRenderTargetViewOutOfMemoryReturn |
CreateRenderTargetViewInvalidArgReturn |
CreateRenderTargetViewTooManyObjects |
CreateRenderTargetViewInvalidResource |
CreateRenderTargetViewInvalidDimensions |
CreateRenderTargetViewInvalidFormat |
CreateRenderTargetViewInvalidDesc |
CreateRenderTargetViewUnsupportedFormat |
CreateRenderTargetViewUnrecognizedFormat |
CreateShaderResourceViewOutOfMemoryReturn |
CreateShaderResourceViewInvalidArgReturn |
CreateShaderResourceViewTooManyObjects |
CreateShaderResourceViewInvalidResource |
CreateShaderResourceViewInvalidDimensions |
CreateShaderResourceViewInvalidFormat |
CreateShaderResourceViewInvalidDesc |
CreateShaderResourceViewUnrecognizedFormat |
CreateTexture3DLargeAllocation |
CreateTexture3DNullDesc |
CreateTexture3DOutOfMemoryReturn |
CreateTexture3DInvalidArgReturn |
CreateTexture3DInvalidMiscFlags |
CreateTexture3DInvalidMipLevels |
CreateTexture3DInvalidDimensions |
CreateTexture3DInvalidInitialData |
CreateTexture3DInvalidBindFlags |
CreateTexture3DInvalidCpuAccessFlags |
CreateTexture3DUnrecognizedMiscFlags |
CreateTexture3DUnrecognizedCpuAccessFlags |
CreateTexture3DUnrecognizedBindFlags |
CreateTexture3DUnrecognizedUsage |
CreateTexture3DInvalidSamples |
CreateTexture3DUnsupportedFormat |
CreateTexture3DUnrecognizedFormat |
CreateTexture2DLargeAllocation |
CreateTexture2DNullDesc |
CreateTexture2DOutOfMemoryReturn |
CreateTexture2DInvalidArgReturn |
CreateTexture2DInvalidMiscFlags |
CreateTexture2DInvalidMipLevels |
CreateTexture2DInvalidDimensions |
CreateTexture2DInvalidInitialData |
CreateTexture2DInvalidBindFlags |
CreateTexture2DInvalidCpuAccessFlags |
CreateTexture2DUnrecognizedMiscFlags |
CreateTexture2DUnrecognizedCpuAccessFlags |
CreateTexture2DUnrecognizedBindFlags |
CreateTexture2DUnrecognizedUsage |
CreateTexture2DInvalidSamples |
CreateTexture2DUnsupportedFormat |
CreateTexture2DUnrecognizedFormat |
CreateTexture1DLargeAllocation |
CreateTexture1DNullDesc |
CreateTexture1DOutOfMemoryReturn |
CreateTexture1DInvalidArgReturn |
CreateTexture1DInvalidMiscFlags |
CreateTexture1DInvalidMipLevels |
CreateTexture1DInvalidDimensions |
CreateTexture1DInvalidInitialData |
CreateTexture1DInvalidBindFlags |
CreateTexture1DInvalidCpuAccessFlags |
CreateTexture1DUnrecognizedMiscFlags |
CreateTexture1DUnrecognizedCpuAccessFlags |
CreateTexture1DUnrecognizedBindFlags |
CreateTexture1DUnrecognizedUsage |
CreateTexture1DInvalidSamples |
CreateTexture1DUnsupportedFormat |
CreateTexture1DUnrecognizedFormat |
CreateBufferLargeAllocation |
CreateBufferInvalidConstantBufferBindings |
CreateBufferNullDesc |
CreateBufferOutOfMemoryReturn |
CreateBufferInvalidArgReturn |
CreateBufferInvalidMiscFlags |
CreateBufferInvalidMipLevels |
CreateBufferInvalidDimensions |
CreateBufferInvalidInitialData |
CreateBufferInvalidBindFlags |
CreateBufferInvalidCpuAccessFlags |
CreateBufferUnrecognizedMiscFlags |
CreateBufferUnrecognizedCpuAccessFlags |
CreateBufferUnrecognizedBindFlags |
CreateBufferUnrecognizedUsage |
CreateBufferInvalidSamples |
CreateBufferUnrecognizedFormat |
SetPrivateDataOutOfMemory |
SetPrivateDataChangingParams |
SetPrivateDataInvalidFlags |
SetPrivateDataInvalidIUnknown |
SetPrivateDataInvalidFreeData |
GetPrivateDataMoreData |
SetPredicationUnbindDeletingObject |
OMSetRenderTargetsUnbindDeletingObject |
OMSetDepthStencilStateUnbindDeletingObject |
OMSetBlendStateUnbindDeletingObject |
RSSetStateUnbindDeletingObject |
PSSetSamplersUnbindDeletingObject |
PSSetConstantBuffersUnbindDeletingObject |
PSSetShaderResourcesUnbindDeletingObject |
PSSetShaderUnbindDeletingObject |
SOSetTargetsUnbindDeletingObject |
GSSetSamplersUnbindDeletingObject |
GSSetConstantBuffersUnbindDeletingObject |
GSSetShaderResourcesUnbindDeletingObject |
GSSetShaderUnbindDeletingObject |
VSSetSamplersUnbindDeletingObject |
VSSetConstantBuffersUnbindDeletingObject |
VSSetShaderResourcesUnbindDeletingObject |
VSSetShaderUnbindDeletingObject |
IASetIndexBufferUnbindDeletingObject |
IASetVertexBuffersUnbindDeletingObject |
IASetInputLayoutUnbindDeletingObject |
MessageReportingOutOfMemory |
CorruptedMultithreading |
CorruptedParameter15 |
CorruptedParameter14 |
CorruptedParameter13 |
CorruptedParameter12 |
CorruptedParameter11 |
CorruptedParameter10 |
CorruptedParameter9 |
CorruptedParameter8 |
CorruptedParameter7 |
CorruptedParameter6 |
CorruptedParameter5 |
CorruptedParameter4 |
CorruptedParameter3 |
CorruptedParameter2 |
CorruptedParameter1 |
CorruptedThis |
StringFromApplication |
DeviceSOSetTargetsHazard |
DeviceOMSetRenderTargetsHazard |
DevicePSSetConstantBuffersHazard |
DevicePSSetShaderResourcesHazard |
DeviceGSSetConstantBuffersHazard |
DeviceGSSetShaderResourcesHazard |
DeviceVSSetConstantBuffersHazard |
DeviceVSSetShaderResourcesHazard |
DeviceIASetIndexBufferHazard |
DeviceIASetVertexBuffersHazard |
DeviceDrawResourceFormatGatherUnsupported |
DeviceDrawPSOutputTypeMismatch |
QueryGetDataInvalidCall |
QueryGetDataInvalidFlags |
QueryGetDataInvalidDataSize |
QueryEndWithoutBegin |
QueryEndAbandoningPreviousResults |
PredicateEndDuringPredication |
QueryBeginAbandoningPreviousResults |
QueryBeginDuplicate |
PredicateBeginDuringPredication |
QueryBeginUnsupported |
SetPredicationInvalidPredicateState |
CheckCounterUnsupportedWellKnownCounter |
CheckCounterOutOfRangeCounter |
CreateCounterNullDesc |
CreateCounterNonexclusiveReturn |
CreateCounterOutOfMemoryReturn |
CreateCounterUnsupportedWellKnownCounter |
CreateCounterSimultaneousActiveCountersExhausted |
CreateCounterOutOfRangeCounter |
CreatePredicateOutOfMemoryReturn |
CreateQueryOutOfMemoryReturn |
ShaderResourceViewGetDescLegacy |
BlendStateGetDescLegacy |
CreateInputLayoutTypeMismatch |
DeviceDrawSamplerMismatch |
DeviceSetTextFilterSizeInvalidDimensions |
OMSetRenderTargetsInvalidView |
DeviceRSSetViewportsDenormFlush |
CreateGeometryShaderWithStreamOutputTrailingDigitInSemantic |
CreateInputLayoutTrailingDigitInSemantic |
DeviceDrawViewportNotSet |
DeviceOpenSharedResourceBadInterfaceReturn |
DeviceOpenSharedResourceOutOfMemoryReturn |
DeviceOpenSharedResourceInvalidArgReturn |
DeviceRemovalProcessNotAtFault |
DeviceRemovalProcessPossiblyAtFault |
DeviceRemovalProcessAtFault |
DeviceDrawOMDualSourceBlendingCanOnlyHaveRenderTargetZero |
DeviceDrawOMRenderTargetDoesNotSupportBlending |
DeviceDrawSoStrideLargerThanBuffer |
DeviceDrawSoTargetsBoundWithoutSource |
DeviceDrawResourceMultisampleUnsupported |
DeviceDrawResourceFormatSampleCUnsupported |
DeviceDrawResourceFormatSampleUnsupported |
DeviceDrawResourceFormatLDUnsupported |
DeviceDrawOutputStreamOffsetUnaligned |
DeviceDrawIndexOffsetUnaligned |
DeviceDrawVertexStrideUnaligned |
DeviceDrawVertexOffsetUnaligned |
DeviceDrawInvalidPrimitiveTopology |
DeviceDrawBoundResourceMapped |
DeviceDrawOutputStreamNotSet |
DeviceDrawPositionNotPresent |
DeviceDrawResourceReturnTypeMismatch |
DeviceDrawGSInputPrimitiveMismatch |
DeviceDrawIndexBufferTooSmall |
DeviceDrawIndexBufferFormatInvalid |
DeviceDrawIndexBufferNotSet |
DeviceDrawVertexBufferTooSmall |
DeviceDrawVertexBufferStrideTooSmall |
DeviceDrawViewDimensionMismatch |
DeviceDrawShaderResourceViewNotSet |
DeviceDrawSamplerNotSet |
DeviceDrawConstantBufferTooSmall |
DeviceDrawConstantBufferNotSet |
DeviceDrawInputLayoutNotSet |
DeviceDrawVertexBufferNotSet |
DeviceShaderLinkageNeverWrittenAlwaysReads |
DeviceShaderLinkageSystemValue |
DeviceShaderLinkageRegisterMask |
DeviceShaderLinkageComponentType |
DeviceShaderLinkageRegisterIndex |
DeviceShaderLinkageSemanticNameNotFound |
DeviceDrawVertexShaderNotSet |
DeviceDrawIndexedInstancedIndexPosOverflow |
DeviceDrawIndexedInstancedInstancePosOverflow |
DeviceDrawInstancedInstancePosOverflow |
DeviceDrawInstancedVertexPosOverflow |
DeviceDrawIndexedIndexPosOverflow |
DeviceDrawVertexPosOverflow |
RefInfo |
RefOutOfMemory |
RefProblemParsingShader |
RefAccessingIndexableTempOutOfRange |
RefHardwareException |
RefKernelModeDriverException |
RefUserModeDriverException |
RefThreadingMode |
RefSimulatingInfinitelyFastHardware |
SetExceptionModeDeviceRemovedReturn |
SetExceptionModeInvalidArgReturn |
SetExceptionModeUnrecognizedFlags |
CheckMultisampleQualityLevelsFormatDeprecated |
CheckFormatSupportFormatDeprecated |
Texture3DUnmapNotMapped |
Texture3DUnmapInvalidSubresource |
Texture3DMapDeviceRemovedReturn |
Texture3DMapAlreadyMapped |
Texture3DMapInvalidFlags |
Texture3DMapInvalidSubresource |
Texture3DMapInvalidMapType |
Texture2DUnmapNotMapped |
Texture2DUnmapInvalidSubresource |
Texture2DMapDeviceRemovedReturn |
Texture2DMapAlreadyMapped |
Texture2DMapInvalidFlags |
Texture2DMapInvalidSubresource |
Texture2DMapInvalidMapType |
Texture1DUnmapNotMapped |
Texture1DUnmapInvalidSubresource |
Texture1DMapDeviceRemovedReturn |
Texture1DMapAlreadyMapped |
Texture1DMapInvalidFlags |
Texture1DMapInvalidSubresource |
Texture1DMapInvalidMapType |
BufferUnmapNotMapped |
BufferMapDeviceRemovedReturn |
BufferMapAlreadyMapped |
BufferMapInvalidFlags |
BufferMapInvalidMapType |
DeviceResolveSubresourceFormatInvalid |
DeviceResolveSubresourceSourceSubresourceInvalid |
DeviceResolveSubresourceSourceInvalid |
DeviceResolveSubresourceDestinationSubresourceInvalid |
DeviceResolveSubresourceDestinationInvalid |
UpdateSubresourceInvalidDestinationState |
UpdateSubresourceInvalidDestinationBox |
UpdateSubresourceInvalidDestinationSubresource |
CopyResourceInvalidSourceState |
CopyResourceInvalidDestinationState |
CopyResourceInvalidSource |
CopySubresourceRegionInvalidSourceState |
CopySubresourceRegionInvalidDestinationState |
CopySubresourceRegionInvalidSource |
CopySubresourceRegionInvalidSourceBox |
CopySubresourceRegionInvalidSourceSubresource |
CopySubresourceRegionInvalidDestinationSubresource |
DeviceGenerateMipsResourceInvalid |
DeviceRSGetScissorRectsRectsEmpty |
DeviceRSGetViewportsViewportsEmpty |
DevicePSGetSamplersSamplersEmpty |
DevicePSGetConstantBuffersBuffersEmpty |
DevicePSGetShaderResourcesViewsEmpty |
DeviceSoGetTargetsBuffersEmpty |
DeviceGSGetSamplersSamplersEmpty |
DeviceGSGetConstantBuffersBuffersEmpty |
DeviceGSGetShaderResourcesViewsEmpty |
DeviceVSGetSamplersSamplersEmpty |
DeviceVSGetConstantBuffersBuffersEmpty |
DeviceVSGetShaderResourcesViewsEmpty |
DeviceIAGetVertexBuffersBuffersEmpty |
ClearDepthStencilViewInvalid |
ClearDepthStencilViewDenormFlush |
ClearRenderTargetViewDenormFlush |
DeviceRSSetScissorRectsInvalidScissor |
DeviceRSSetViewportsInvalidViewport |
DevicePSSetSamplersSamplersEmpty |
DevicePSSetConstantBuffersBuffersEmpty |
PSSetConstantBuffersInvalidBuffer |
DevicePSSetShaderResourcesViewsEmpty |
DeviceSoSetTargetsOffsetUnaligned |
SoSetTargetsInvalidBuffer |
DeviceGSSetSamplersSamplersEmpty |
DeviceGSSetConstantBuffersBuffersEmpty |
GSSetConstantBuffersInvalidBuffer |
DeviceGSSetShaderResourcesViewsEmpty |
DeviceVSSetSamplersSamplersEmpty |
DeviceVSSetConstantBuffersBuffersEmpty |
VSSetConstantBuffersInvalidBuffer |
DeviceVSSetShaderResourcesViewsEmpty |
DeviceIASetIndexBufferOffsetUnaligned |
DeviceIASetIndexBufferOffsetTooLarge |
DeviceIASetIndexBufferFormatInvalid |
IASetIndexBufferInvalidBuffer |
DeviceIASetVertexBuffersBuffersEmpty |
DeviceIASetVertexBuffersOffsetTooLarge |
IASetVertexBuffersInvalidBuffer |
DeviceIASetPrimitiveTopologyTopologyUndefined |
DeviceIASetPrimitiveTopologyTopologyUnrecognized |
CreateQueryOrPredicateNullDesc |
CreateQueryOrPredicateUnexpectedMiscFlag |
CreateQueryOrPredicateInvalidMiscFlags |
CreateQueryOrPredicateInvalidQuery |
CreateSamplerStateNullDesc |
CreateSamplerStateTooManyObjects |
CreateSamplerStateInvalidMaxLod |
CreateSamplerStateInvalidMinLod |
CreateSamplerStateInvalidComparisonFunc |
CreateSamplerStateInvalidMaxAnisotropy |
CreateSamplerStateInvalidMipLodBias |
CreateSamplerStateInvalidAddressW |
CreateSamplerStateInvalidAddressV |
CreateSamplerStateInvalidAddressU |
CreateSamplerStateInvalidFilter |
CreateBlendStateNullDesc |
CreateBlendStateTooManyObjects |
CreateBlendStateInvalidRenderTargetWriteMask |
CreateBlendStateInvalidBlendOperationAlpha |
CreateBlendStateInvalidDestinationBlendAlpha |
CreateBlendStateInvalidSourceBlendAlpha |
CreateBlendStateInvalidBlendOperation |
CreateBlendStateInvalidDestinationBlend |
CreateBlendStateInvalidSourceBlend |
CreateDepthStencilStateNullDesc |
CreateDepthStencilStateTooManyObjects |
CreateDepthStencilStateInvalidBackFaceStencilFunc |
CreateDepthStencilStateInvalidBackFaceStencilPassOperation |
CreateDepthStencilStateInvalidBackFaceStencilZFailOperation |
CreateDepthStencilStateInvalidBackFaceStencilFailOperation |
CreateDepthStencilStateInvalidFrontFaceStencilFunc |
CreateDepthStencilStateInvalidFrontFaceStencilPassOperation |
CreateDepthStencilStateInvalidFrontFaceStencilZFailOperation |
CreateDepthStencilStateInvalidFrontFaceStencilFailOperation |
CreateDepthStencilStateInvalidDepthFunc |
CreateDepthStencilStateInvalidDepthWriteMask |
CreateRasterizerStateNullDesc |
CreateRasterizerStateTooManyObjects |
CreateRasterizerStateInvalidSlopeScaledDepthBias |
CreateRasterizerStateInvalidDepthBiasClamp |
CreateRasterizerStateInvalidCullMode |
CreateRasterizerStateInvalidFillMode |
CreatePixelShaderInvalidShaderType |
CreatePixelShaderInvalidShaderBytecode |
CreatePixelShaderOutOfMemory |
CreateGeometryShaderWithStreamOutputMissingOutputSignature |
CreateGeometryShaderWithStreamOutputDeclTooComplex |
CreateGeometryShaderWithStreamOutputCannotHaveOnlyGaps |
CreateGeometryShaderWithStreamOutputMaskMismatch |
CreateGeometryShaderWithStreamOutputMissingSemantic |
CreateGeometryShaderWithStreamOutputInvalidOutputStreamStride |
CreateGeometryShaderWithStreamOutputRepeatedOutput |
CreateGeometryShaderWithStreamOutputInvalidGapDefinition |
CreateGeometryShaderWithStreamOutputInvalidStartComponentAndComponentCount |
CreateGeometryShaderWithStreamOutputInvalidComponentCount |
CreateGeometryShaderWithStreamOutputOnlyOneElementPerSlot |
CreateGeometryShaderWithStreamOutputInvalidOutputSlot |
CreateGeometryShaderWithStreamOutputOutputSlot0Expected |
CreateGeometryShaderWithStreamOutputExpectedDecl |
CreateGeometryShaderWithStreamOutputUnexpectedDecl |
CreateGeometryShaderWithStreamOutputOutputStreamStrideUnused |
CreateGeometryShaderWithStreamOutputInvalidNumEntries |
CreateGeometryShaderWithStreamOutputInvalidShaderType |
CreateGeometryShaderWithStreamOutputInvalidShaderBytecode |
CreateGeometryShaderWithStreamOutputOutOfMemory |
CreateGeometryShaderInvalidShaderType |
CreateGeometryShaderInvalidShaderBytecode |
CreateGeometryShaderOutOfMemory |
CreateVertexShaderInvalidShaderType |
CreateVertexShaderInvalidShaderBytecode |
CreateVertexShaderOutOfMemory |
CreateInputLayoutNullDesc |
CreateInputLayoutMissingElement |
CreateInputLayoutNullSemantic |
CreateInputLayoutUnparsableInputSignature |
CreateInputLayoutDuplicateSemantic |
CreateInputLayoutInvalidAlignment |
CreateInputLayoutInvalidStepRateChange |
CreateInputLayoutInvalidSlotClassChange |
CreateInputLayoutStepRateSlotClassMismatch |
CreateInputLayoutInvalidInputSlotClass |
CreateInputLayoutInvalidSlot |
CreateInputLayoutIncompatibleFormat |
CreateInputLayoutInvalidFormat |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MessageSeverity Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MessageSeverity Enumeration
See Also Send Feedback
Debug message severity levels for an information queue.

(Also see DirectX SDK: D3D10_MESSAGE_SEVERITY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum MessageSeverity
Visual Basic
Public Enumeration MessageSeverity
Visual C++
public enum class MessageSeverity

Members

Member name | Description
Info |
Warning |
Error |
Corruption |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MiscellaneousQueryOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MiscellaneousQueryOptions Enumeration
See Also Send Feedback
Flags that describe miscellaneous query behavior.

(Also see DirectX SDK: D3D10_QUERY_MISC_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum MiscellaneousQueryOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration MiscellaneousQueryOptions
Visual C++
[FlagsAttribute]
public enum class MiscellaneousQueryOptions

Members

Member name | Description
None |
PredicateHint |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MiscellaneousResourceOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MiscellaneousResourceOptions Enumeration
See Also Send Feedback
Identifies other, less common options for resources.

(Also see DirectX SDK: D3D10_RESOURCE_MISC_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum MiscellaneousResourceOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration MiscellaneousResourceOptions
Visual C++
[FlagsAttribute]
public enum class MiscellaneousResourceOptions

Members

Member name | Description
GdiCompatible |
None |
SharedKeyedMutex |
TextureCube |
Shared |
GenerateMips |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Multithread Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Multithread Class
Members See Also Send Feedback
A multithread interface accesses multithread settings and can only be used if the thread-safe layer is turned on.

(Also see DirectX SDK: ID3D10Multithread)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Multithread : DirectUnknown
Visual Basic
Public Class Multithread _
    Inherits DirectUnknown
Visual C++
public ref class Multithread : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Multithread

See Also

Multithread Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Multithread Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Multithread Members
Multithread Class Methods Properties See Also Send Feedback

The Multithread type exposes the following members.

Methods

 | Name | Description
Public method | Enter | Enter a device's critical section. (Also see DirectX SDK: ID3D10Multithread::Enter)
Public method | Leave | Leave a device's critical section. (Also see DirectX SDK: ID3D10Multithread::Leave)

Properties

 | Name | Description
Public property | IsMultithreadProtected | Find out if multithreading is turned on or not. (Also see DirectX SDK: ID3D10Multithread::GetMultithreadProtected, ID3D10Multithread::SetMultithreadProtected)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Multithread Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Multithread Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Multithread Methods
Multithread Class See Also Send Feedback

The Multithread type exposes the following members.

Methods

 | Name | Description
Public method | Enter | Enter a device's critical section. (Also see DirectX SDK: ID3D10Multithread::Enter)
Public method | Leave | Leave a device's critical section. (Also see DirectX SDK: ID3D10Multithread::Leave)

See Also

Multithread Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Enter Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Multithread..::..Enter Method
Multithread Class See Also Send Feedback
Enter a device's critical section.

(Also see DirectX SDK: ID3D10Multithread::Enter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Enter()
Visual Basic
Public Sub Enter
Visual C++
public:
void Enter()

See Also

Multithread Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Leave Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Multithread..::..Leave Method
Multithread Class See Also Send Feedback
Leave a device's critical section.

(Also see DirectX SDK: ID3D10Multithread::Leave)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Leave()
Visual Basic
Public Sub Leave
Visual C++
public:
void Leave()

See Also

Multithread Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Multithread Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Multithread Properties
Multithread Class See Also Send Feedback

The Multithread type exposes the following members.

Properties

 | Name | Description
Public property | IsMultithreadProtected | Find out if multithreading is turned on or not. (Also see DirectX SDK: ID3D10Multithread::GetMultithreadProtected, ID3D10Multithread::SetMultithreadProtected)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Multithread Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsMultithreadProtected Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Multithread..::..IsMultithreadProtected Property
Multithread Class See Also Send Feedback
Find out if multithreading is turned on or not.

(Also see DirectX SDK: ID3D10Multithread::GetMultithreadProtected, ID3D10Multithread::SetMultithreadProtected)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsMultithreadProtected { get; set; }
Visual Basic
Public Property IsMultithreadProtected As Boolean
    Get
    Set
Visual C++
public:
property bool IsMultithreadProtected {
    bool get ();
    void set (bool value);
}

See Also

Multithread Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Name Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Name Enumeration
See Also Send Feedback
These values identify shader parameters that use system-value semantics.

(Also see DirectX SDK: D3D10_NAME)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Name
Visual Basic
Public Enumeration Name
Visual C++
public enum class Name

Members

Member name | Description
Depth |
Undefined |
Target |
InstanceId |
Coverage |
SampleIndex |
IsFrontFace |
PrimitiveId |
VertexId |
ViewportArrayIndex |
RenderTargetArrayIndex |
CullDistance |
ClipDistance |
Position |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputBuffer Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer Structure
Members See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct OutputBuffer
Visual Basic
Public Structure OutputBuffer
Visual C++
public value class OutputBuffer

See Also

OutputBuffer Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputBuffer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer Members
OutputBuffer Structure Constructors Methods Operators Properties See Also Send Feedback

The OutputBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | OutputBuffer | Constructor.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Buffer |
Public property | Offset |

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputBuffer Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer Constructor
OutputBuffer Structure See Also Send Feedback
Constructor.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputBuffer(
    D3DBuffer buffer,
    uint offset
)
Visual Basic
Public Sub New ( _
    buffer As D3DBuffer, _
    offset As UInteger _
)
Visual C++
public:
OutputBuffer(
    D3DBuffer^ buffer,
    unsigned int offset
)

Parameters

buffer
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DBuffer
The buffers must have been created with the BindingOptions .StreamOutput flag.
offset
Type: System..::..UInt32
Offset in bytes to the start of the buffer position to use. -1 indicates that output should continue after the last location written to the buffer in a previous stream output pass.

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputBuffer Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer Methods
OutputBuffer Structure See Also Send Feedback

The OutputBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer..::..Equals Method
OutputBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer..::..GetHashCode Method
OutputBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputBuffer Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer Operators
OutputBuffer Structure See Also Send Feedback

The OutputBuffer type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer..::..Equality Operator
OutputBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    OutputBuffer buffer1,
    OutputBuffer buffer2
)
Visual Basic
Public Shared Operator = ( _
    buffer1 As OutputBuffer, _
    buffer2 As OutputBuffer _
) As Boolean
Visual C++
public:
static bool operator ==(
    OutputBuffer buffer1,
    OutputBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..OutputBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..OutputBuffer

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer..::..Inequality Operator
OutputBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    OutputBuffer buffer1,
    OutputBuffer buffer2
)
Visual Basic
Public Shared Operator <> ( _
    buffer1 As OutputBuffer, _
    buffer2 As OutputBuffer _
) As Boolean
Visual C++
public:
static bool operator !=(
    OutputBuffer buffer1,
    OutputBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..OutputBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..OutputBuffer

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputBuffer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer Properties
OutputBuffer Structure See Also Send Feedback

The OutputBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Buffer |
Public property | Offset |

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer..::..Buffer Property
OutputBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer Buffer { get; }
Visual Basic
Public ReadOnly Property Buffer As D3DBuffer
    Get
Visual C++
public:
property D3DBuffer^ Buffer {
    D3DBuffer^ get ();
}

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Offset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputBuffer..::..Offset Property
OutputBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Offset { get; }
Visual Basic
Public ReadOnly Property Offset As UInteger
    Get
Visual C++
public:
property unsigned int Offset {
    unsigned int get ();
}

See Also

OutputBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerBlendState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Class
Members See Also Send Feedback
Stores the blend state, including blend factors and mask, for the merger pipeline stage

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class OutputMergerBlendState
Visual Basic
Public Class OutputMergerBlendState
Visual C++
public ref class OutputMergerBlendState

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..OutputMergerBlendState

See Also

OutputMergerBlendState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerBlendState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Members
OutputMergerBlendState Class Constructors Properties See Also Send Feedback

The OutputMergerBlendState type exposes the following members.

Constructors

 | Name | Description
Public method | OutputMergerBlendState()()()() |
Public method | OutputMergerBlendState(BlendState) |
Public method | OutputMergerBlendState(BlendState, ColorRgba, UInt32) |

Properties

 | Name | Description
Public property | BlendFactor | Gets the blend factors for this merger pipeline stage blend state
Public property | BlendState | Gets the BlendState object for this merger pipeline stage blend state
Public property | SampleMask | Gets the sample mask for this merger pipeline stage blend state

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerBlendState Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Constructor
OutputMergerBlendState Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OutputMergerBlendState()()()() |
Public method | OutputMergerBlendState(BlendState) |
Public method | OutputMergerBlendState(BlendState, ColorRgba, UInt32) |

See Also

OutputMergerBlendState Class
OutputMergerBlendState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerBlendState Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Constructor
OutputMergerBlendState Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerBlendState()
Visual Basic
Public Sub New
Visual C++
public:
OutputMergerBlendState()

See Also

OutputMergerBlendState Class
OutputMergerBlendState Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerBlendState Constructor (BlendState)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Constructor (BlendState)
OutputMergerBlendState Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerBlendState(
    BlendState blendState
)
Visual Basic
Public Sub New ( _
    blendState As BlendState _
)
Visual C++
public:
OutputMergerBlendState(
    BlendState^ blendState
)

Parameters

blendState
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendState

See Also

OutputMergerBlendState Class
OutputMergerBlendState Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerBlendState Constructor (BlendState, ColorRgba, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Constructor (BlendState, ColorRgba, UInt32)
OutputMergerBlendState Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerBlendState(
    BlendState blendState,
    ColorRgba blendFactor,
    uint sampleMask
)
Visual Basic
Public Sub New ( _
    blendState As BlendState, _
    blendFactor As ColorRgba, _
    sampleMask As UInteger _
)
Visual C++
public:
OutputMergerBlendState(
    BlendState^ blendState,
    ColorRgba blendFactor,
    unsigned int sampleMask
)

Parameters

blendState
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BlendState
blendFactor
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgba
sampleMask
Type: System..::..UInt32

See Also

OutputMergerBlendState Class
OutputMergerBlendState Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerBlendState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Properties
OutputMergerBlendState Class See Also Send Feedback

The OutputMergerBlendState type exposes the following members.

Properties

 | Name | Description
Public property | BlendFactor | Gets the blend factors for this merger pipeline stage blend state
Public property | BlendState | Gets the BlendState object for this merger pipeline stage blend state
Public property | SampleMask | Gets the sample mask for this merger pipeline stage blend state

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendFactor Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState..::..BlendFactor Property
OutputMergerBlendState Class See Also Send Feedback
Gets the blend factors for this merger pipeline stage blend state

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgba BlendFactor { get; }
Visual Basic
Public ReadOnly Property BlendFactor As ColorRgba
    Get
Visual C++
public:
property ColorRgba BlendFactor {
    ColorRgba get ();
}

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendState Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState..::..BlendState Property
OutputMergerBlendState Class See Also Send Feedback
Gets the BlendState object for this merger pipeline stage blend state

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendState BlendState { get; }
Visual Basic
Public ReadOnly Property BlendState As BlendState
    Get
Visual C++
public:
property BlendState^ BlendState {
    BlendState^ get ();
}

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SampleMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState..::..SampleMask Property
OutputMergerBlendState Class See Also Send Feedback
Gets the sample mask for this merger pipeline stage blend state

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SampleMask { get; }
Visual Basic
Public ReadOnly Property SampleMask As UInteger
    Get
Visual C++
public:
property unsigned int SampleMask {
    unsigned int get ();
}

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage Class
Members See Also Send Feedback
OutputMerger pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class OutputMergerPipelineStage : PipelineStage
Visual Basic
Public Class OutputMergerPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class OutputMergerPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..OutputMergerPipelineStage

See Also

OutputMergerPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage Members
OutputMergerPipelineStage Class Methods Properties See Also Send Feedback

The OutputMergerPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetDepthStencilStateAndReferenceValue | Gets the depth-stencil state of the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetDepthStencilState)
Public method | SetDepthStencilStateAndReferenceValue | Sets the depth-stencil state of the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMSetDepthStencilState)

Properties

 | Name | Description
Public property | BlendState | Get or sets the blend state of the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetBlendState, ID3D10Device::OMSetBlendState)
Public property | DepthStencilView | Get the depth stencil view bound to the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetRenderTargets)
Public property | RenderTargets | Get or sets render targets and depth-stencil buffer bound to the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetRenderTargets, ID3D10Device::OMSetRenderTargets)

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage Methods
OutputMergerPipelineStage Class See Also Send Feedback

The OutputMergerPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetDepthStencilStateAndReferenceValue | Gets the depth-stencil state of the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetDepthStencilState)
Public method | SetDepthStencilStateAndReferenceValue | Sets the depth-stencil state of the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMSetDepthStencilState)

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetDepthStencilStateAndReferenceValue Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..GetDepthStencilStateAndReferenceValue Method
OutputMergerPipelineStage Class See Also Send Feedback
Gets the depth-stencil state of the output-merger stage.

(Also see DirectX SDK: ID3D10Device::OMGetDepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilState GetDepthStencilStateAndReferenceValue(
    out uint stencilRef
)
Visual Basic
Public Function GetDepthStencilStateAndReferenceValue ( _
    <OutAttribute> ByRef stencilRef As UInteger _
) As DepthStencilState
Visual C++
public:
DepthStencilState^ GetDepthStencilStateAndReferenceValue(
    [OutAttribute] unsigned int% stencilRef
)

Parameters

stencilRef
Type: System..::..UInt32 %
The stencil reference value used in the depth-stencil test.

Return Value

A depth-stencil state object (see DepthStencilState) to be filled with information from the device.

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilState


SetDepthStencilStateAndReferenceValue Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..SetDepthStencilStateAndReferenceValue Method
OutputMergerPipelineStage Class See Also Send Feedback
Sets the depth-stencil state of the output-merger stage.

(Also see DirectX SDK: ID3D10Device::OMSetDepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetDepthStencilStateAndReferenceValue(
    DepthStencilState depthStencilState,
    uint stencilRef
)
Visual Basic
Public Sub SetDepthStencilStateAndReferenceValue ( _
    depthStencilState As DepthStencilState, _
    stencilRef As UInteger _
)
Visual C++
public:
void SetDepthStencilStateAndReferenceValue(
    DepthStencilState^ depthStencilState,
    unsigned int stencilRef
)

Parameters

depthStencilState
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilState
A depth-stencil state interface (see DepthStencilState) to bind to the device. Set this to NULL to use the default state listed in DepthStencilDescription.
stencilRef
Type: System..::..UInt32
Reference value to perform against when doing a depth-stencil test.

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilState


OutputMergerPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage Properties
OutputMergerPipelineStage Class See Also Send Feedback

The OutputMergerPipelineStage type exposes the following members.

Properties

 | Name | Description
Public property | BlendState | Get or sets the blend state of the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetBlendState, ID3D10Device::OMSetBlendState)
Public property | DepthStencilView | Get the depth stencil view bound to the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetRenderTargets)
Public property | RenderTargets | Get or sets render targets and depth-stencil buffer bound to the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetRenderTargets, ID3D10Device::OMSetRenderTargets)

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendState Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..BlendState Property
OutputMergerPipelineStage Class See Also Send Feedback
Get or sets the blend state of the output-merger stage.

(Also see DirectX SDK: ID3D10Device::OMGetBlendState, ID3D10Device::OMSetBlendState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerBlendState BlendState { get; set; }
Visual Basic
Public Property BlendState As OutputMergerBlendState
    Get
    Set
Visual C++
public:
property OutputMergerBlendState^ BlendState {
    OutputMergerBlendState^ get ();
    void set (OutputMergerBlendState^ value);
}

Remarks

If OutputMergerBlendState.BlendState is null, the default blending state will be set. See the DX SDK (ID3D10Device::OMSetBlendState) for more details about the default blending state.

A sample mask determines which samples get updated in all the active render targets. The mapping of bits in a sample mask to samples in a multisample render target is the responsibility of an individual application. A sample mask is always applied; it is independent of whether multisampling is enabled, and does not depend on whether an application uses multisample render targets.

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilView Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..DepthStencilView Property
OutputMergerPipelineStage Class See Also Send Feedback
Get the depth stencil view bound to the output-merger stage.

(Also see DirectX SDK: ID3D10Device::OMGetRenderTargets)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilView DepthStencilView { get; }
Visual Basic
Public ReadOnly Property DepthStencilView As DepthStencilView
    Get
Visual C++
public:
property DepthStencilView^ DepthStencilView {
    DepthStencilView^ get ();
}

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargets Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..RenderTargets Property
OutputMergerPipelineStage Class See Also Send Feedback
Get or sets render targets and depth-stencil buffer bound to the output-merger stage.

(Also see DirectX SDK: ID3D10Device::OMGetRenderTargets, ID3D10Device::OMSetRenderTargets)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets RenderTargets { get; set; }
Visual Basic
Public Property RenderTargets As OutputMergerRenderTargets
    Get
    Set
Visual C++
public:
property OutputMergerRenderTargets^ RenderTargets {
    OutputMergerRenderTargets^ get ();
    void set (OutputMergerRenderTargets^ value);
}

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerRenderTargets Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Class
Members See Also Send Feedback
Stores the render targets for a merger pipeline stage

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class OutputMergerRenderTargets
Visual Basic
Public Class OutputMergerRenderTargets
Visual C++
public ref class OutputMergerRenderTargets

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..OutputMergerRenderTargets

See Also

OutputMergerRenderTargets Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerRenderTargets Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Members
OutputMergerRenderTargets Class Constructors Properties See Also Send Feedback

The OutputMergerRenderTargets type exposes the following members.

Constructors

 | Name | Description
Public method | OutputMergerRenderTargets(DepthStencilView) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>)) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>), DepthStencilView) |

Properties

 | Name | Description
Public property | DepthStencilView |
Public property | RenderTargetViews |

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerRenderTargets Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor
OutputMergerRenderTargets Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OutputMergerRenderTargets(DepthStencilView) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>)) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>), DepthStencilView) |

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerRenderTargets Constructor (DepthStencilView)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor (DepthStencilView)
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets(
    DepthStencilView depthStencilView
)
Visual Basic
Public Sub New ( _
    depthStencilView As DepthStencilView _
)
Visual C++
public:
OutputMergerRenderTargets(
    DepthStencilView^ depthStencilView
)

Parameters

depthStencilView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilView

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerRenderTargets Constructor (IEnumerable(RenderTargetView))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor (IEnumerable<(Of <(<'RenderTargetView>)>)>)
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets(
    IEnumerable<RenderTargetView> renderTargetViews
)
Visual Basic
Public Sub New ( _
    renderTargetViews As IEnumerable(Of RenderTargetView) _
)
Visual C++
public:
OutputMergerRenderTargets(
    IEnumerable<RenderTargetView^>^ renderTargetViews
)

Parameters

renderTargetViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RenderTargetView >)>)>

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerRenderTargets Constructor (IEnumerable(RenderTargetView), DepthStencilView)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor (IEnumerable<(Of <(<'RenderTargetView>)>)>, DepthStencilView)
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets(
    IEnumerable<RenderTargetView> renderTargetViews,
    DepthStencilView depthStencilView
)
Visual Basic
Public Sub New ( _
    renderTargetViews As IEnumerable(Of RenderTargetView), _
    depthStencilView As DepthStencilView _
)
Visual C++
public:
OutputMergerRenderTargets(
    IEnumerable<RenderTargetView^>^ renderTargetViews,
    DepthStencilView^ depthStencilView
)

Parameters

renderTargetViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RenderTargetView >)>)>
depthStencilView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilView

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerRenderTargets Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Properties
OutputMergerRenderTargets Class See Also Send Feedback

The OutputMergerRenderTargets type exposes the following members.

Properties

 | Name | Description
Public property | DepthStencilView |
Public property | RenderTargetViews |

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthStencilView Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets..::..DepthStencilView Property
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilView DepthStencilView { get; }
Visual Basic
Public ReadOnly Property DepthStencilView As DepthStencilView
    Get
Visual C++
public:
property DepthStencilView^ DepthStencilView {
    DepthStencilView^ get ();
}

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetViews Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets..::..RenderTargetViews Property
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<RenderTargetView> RenderTargetViews { get; }
Visual Basic
Public ReadOnly Property RenderTargetViews As ReadOnlyCollection(Of RenderTargetView)
    Get
Visual C++
public:
property ReadOnlyCollection<RenderTargetView^>^ RenderTargetViews {
    ReadOnlyCollection<RenderTargetView^>^ get ();
}

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PassDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription Structure
Members See Also Send Feedback
Describes an effect pass, which contains pipeline state.

(Also see DirectX SDK: D3D10_PASS_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct PassDescription
Visual Basic
Public Structure PassDescription
Visual C++
public value class PassDescription

See Also

PassDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PassDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription Members
PassDescription Structure Properties See Also Send Feedback

The PassDescription type exposes the following members.

Properties

 | Name | Description
Public property | Annotations | The number of annotations. (Also see DirectX SDK: D3D10_PASS_DESC.Annotations)
Public property | BlendFactor | The per-component blend factors (RGBA) for the blend state (see Configuring Blending Functionality (Direct3D 10)). (Also see DirectX SDK: D3D10_PASS_DESC.BlendFactor)
Public property | InputAssemblerInputSignature | The input signature or the vertex shader; otherwise NULL. (Also see DirectX SDK: D3D10_PASS_DESC.pIAInputSignature)
Public property | InputAssemblerInputSignatureSize | The size of the input signature (in bytes). (Also see DirectX SDK: D3D10_PASS_DESC.IAInputSignatureSize)
Public property | Name | A string that contains the name of the pass; otherwise NULL. (Also see DirectX SDK: D3D10_PASS_DESC.Name)
Public property | SampleMask | The sample mask for the blend state (see Configuring Blending Functionality (Direct3D 10)). (Also see DirectX SDK: D3D10_PASS_DESC.SampleMask)
Public property | StencilRef | The stencil-reference value used in the depth-stencil state (see Configuring Depth-Stencil Functionality (Direct3D 10)). (Also see DirectX SDK: D3D10_PASS_DESC.StencilRef)

See Also

PassDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PassDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription Properties
PassDescription Structure See Also Send Feedback

The PassDescription type exposes the following members.

Properties

 | Name | Description
Public property | Annotations | The number of annotations. (Also see DirectX SDK: D3D10_PASS_DESC.Annotations)
Public property | BlendFactor | The per-component blend factors (RGBA) for the blend state (see Configuring Blending Functionality (Direct3D 10)). (Also see DirectX SDK: D3D10_PASS_DESC.BlendFactor)
Public property | InputAssemblerInputSignature | The input signature or the vertex shader; otherwise NULL. (Also see DirectX SDK: D3D10_PASS_DESC.pIAInputSignature)
Public property | InputAssemblerInputSignatureSize | The size of the input signature (in bytes). (Also see DirectX SDK: D3D10_PASS_DESC.IAInputSignatureSize)
Public property | Name | A string that contains the name of the pass; otherwise NULL. (Also see DirectX SDK: D3D10_PASS_DESC.Name)
Public property | SampleMask | The sample mask for the blend state (see Configuring Blending Functionality (Direct3D 10)). (Also see DirectX SDK: D3D10_PASS_DESC.SampleMask)
Public property | StencilRef | The stencil-reference value used in the depth-stencil state (see Configuring Depth-Stencil Functionality (Direct3D 10)). (Also see DirectX SDK: D3D10_PASS_DESC.StencilRef)

See Also

PassDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Annotations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription..::..Annotations Property
PassDescription Structure See Also Send Feedback
The number of annotations.

(Also see DirectX SDK: D3D10_PASS_DESC.Annotations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Annotations { get; set; }
Visual Basic
Public Property Annotations As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Annotations {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

PassDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendFactor Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription..::..BlendFactor Property
PassDescription Structure See Also Send Feedback
The per-component blend factors (RGBA) for the blend state (see Configuring Blending Functionality (Direct3D 10)).

(Also see DirectX SDK: D3D10_PASS_DESC.BlendFactor)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<float> BlendFactor { get; }
Visual Basic
Public ReadOnly Property BlendFactor As ReadOnlyCollection(Of Single)
    Get
Visual C++
public:
property ReadOnlyCollection<float>^ BlendFactor {
    ReadOnlyCollection<float>^ get ();
}

See Also

PassDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerInputSignature Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription..::..InputAssemblerInputSignature Property
PassDescription Structure See Also Send Feedback
The input signature or the vertex shader; otherwise NULL.

(Also see DirectX SDK: D3D10_PASS_DESC.pIAInputSignature)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr InputAssemblerInputSignature { get; set; }
Visual Basic
Public Property InputAssemblerInputSignature As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr InputAssemblerInputSignature {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

PassDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerInputSignatureSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription..::..InputAssemblerInputSignatureSize Property
PassDescription Structure See Also Send Feedback
The size of the input signature (in bytes).

(Also see DirectX SDK: D3D10_PASS_DESC.IAInputSignatureSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InputAssemblerInputSignatureSize { get; set; }
Visual Basic
Public Property InputAssemblerInputSignatureSize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InputAssemblerInputSignatureSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

PassDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Name Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription..::..Name Property
PassDescription Structure See Also Send Feedback
A string that contains the name of the pass; otherwise NULL.

(Also see DirectX SDK: D3D10_PASS_DESC.Name)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

PassDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SampleMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription..::..SampleMask Property
PassDescription Structure See Also Send Feedback
The sample mask for the blend state (see Configuring Blending Functionality (Direct3D 10)).

(Also see DirectX SDK: D3D10_PASS_DESC.SampleMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SampleMask { get; set; }
Visual Basic
Public Property SampleMask As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SampleMask {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

PassDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilRef Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassDescription..::..StencilRef Property
PassDescription Structure See Also Send Feedback
The stencil-reference value used in the depth-stencil state (see Configuring Depth-Stencil Functionality (Direct3D 10)).

(Also see DirectX SDK: D3D10_PASS_DESC.StencilRef)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint StencilRef { get; set; }
Visual Basic
Public Property StencilRef As UInteger
    Get
    Set
Visual C++
public:
property unsigned int StencilRef {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

PassDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PassShaderDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassShaderDescription Structure
Members See Also Send Feedback
Describes an effect variable that contains a shader.

(Also see DirectX SDK: D3D10_PASS_SHADER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct PassShaderDescription
Visual Basic
Public Structure PassShaderDescription
Visual C++
public value class PassShaderDescription

See Also

PassShaderDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PassShaderDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassShaderDescription Members
PassShaderDescription Structure Properties See Also Send Feedback

The PassShaderDescription type exposes the following members.

Properties

 | Name | Description
Public property | ShaderIndex | A zero-based array index; otherwise 0. (Also see DirectX SDK: D3D10_PASS_SHADER_DESC.ShaderIndex)
Public property | ShaderVariable | The variable that the shader came from. If it is an inline shader assignment, the returned interface will be an anonymous shader variable, which is not retrievable any other way. Its name in the variable description will be "$Anonymous". If there is no assignment of this type in the pass block, this will point to a shader variable that returns false when IsValid is called. (Also see DirectX SDK: D3D10_PASS_SHADER_DESC.pShaderVariable)

See Also

PassShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PassShaderDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassShaderDescription Properties
PassShaderDescription Structure See Also Send Feedback

The PassShaderDescription type exposes the following members.

Properties

 | Name | Description
Public property | ShaderIndex | A zero-based array index; otherwise 0. (Also see DirectX SDK: D3D10_PASS_SHADER_DESC.ShaderIndex)
Public property | ShaderVariable | The variable that the shader came from. If it is an inline shader assignment, the returned interface will be an anonymous shader variable, which is not retrievable any other way. Its name in the variable description will be "$Anonymous". If there is no assignment of this type in the pass block, this will point to a shader variable that returns false when IsValid is called. (Also see DirectX SDK: D3D10_PASS_SHADER_DESC.pShaderVariable)

See Also

PassShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderIndex Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassShaderDescription..::..ShaderIndex Property
PassShaderDescription Structure See Also Send Feedback
A zero-based array index; otherwise 0.

(Also see DirectX SDK: D3D10_PASS_SHADER_DESC.ShaderIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ShaderIndex { get; set; }
Visual Basic
Public Property ShaderIndex As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ShaderIndex {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

PassShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PassShaderDescription..::..ShaderVariable Property
PassShaderDescription Structure See Also Send Feedback
The variable that the shader came from. If it is an inline shader assignment, the returned interface will be an anonymous shader variable, which is not retrievable any other way. Its name in the variable description will be "$Anonymous". If there is no assignment of this type in the pass block, this will point to a shader variable that returns false when IsValid is called.

(Also see DirectX SDK: D3D10_PASS_SHADER_DESC.pShaderVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public EffectShaderVariable ShaderVariable { get; set; }
Visual Basic
Public Property ShaderVariable As EffectShaderVariable
    Get
    Set
Visual C++
public:
property EffectShaderVariable^ ShaderVariable {
    EffectShaderVariable^ get ();
    void set (EffectShaderVariable^ value);
}

See Also

PassShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PipelineStage Class
See Also Send Feedback
A pipeline stage. base class for all pipline stage related classes.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public abstract class PipelineStage
Visual Basic
Public MustInherit Class PipelineStage
Visual C++
public ref class PipelineStage abstract

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..GeometryShaderPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..InputAssemblerPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..OutputMergerPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PixelShaderPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StreamOutputPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..VertexShaderPipelineStage

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShader Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShader Class
Members See Also Send Feedback
A pixel-shader interface manages an executable program (a pixel shader) that controls the pixel-shader stage.

(Also see DirectX SDK: ID3D10PixelShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class PixelShader : DeviceChild
Visual Basic
Public Class PixelShader _
    Inherits DeviceChild
Visual C++
public ref class PixelShader : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PixelShader

See Also

PixelShader Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShader Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShader Members
PixelShader Class Properties See Also Send Feedback

The PixelShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

PixelShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShader Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShader Properties
PixelShader Class See Also Send Feedback

The PixelShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

PixelShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Class
Members See Also Send Feedback
Pixel Shader pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class PixelShaderPipelineStage : PipelineStage
Visual Basic
Public Class PixelShaderPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class PixelShaderPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PixelShaderPipelineStage

See Also

PixelShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Members
PixelShaderPipelineStage Class Constructors Methods Properties See Also Send Feedback

The PixelShaderPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | PixelShaderPipelineStage |

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the pixel shader pipeline stage. (Also see DirectX SDK: ID3D10Device::PSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler states from the pixel shader pipeline stage. (Also see DirectX SDK: ID3D10Device::PSGetSamplers)
Public method | GetShaderResources | Get the pixel shader resources. (Also see DirectX SDK: ID3D10Device::PSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShaderResources |

Properties

 | Name | Description
Public property | Shader | Gets or sets the pixel shader currently set on the device. Setting to null disables the shader for this pipeline stage. (Also see DirectX SDK: ID3D10Device::PSGetShader, ID3D10Device::PSSetShader)

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Constructor
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected PixelShaderPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
PixelShaderPipelineStage()

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Methods
PixelShaderPipelineStage Class See Also Send Feedback

The PixelShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the pixel shader pipeline stage. (Also see DirectX SDK: ID3D10Device::PSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler states from the pixel shader pipeline stage. (Also see DirectX SDK: ID3D10Device::PSGetSamplers)
Public method | GetShaderResources | Get the pixel shader resources. (Also see DirectX SDK: ID3D10Device::PSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShaderResources |

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..GetConstantBuffers Method
PixelShaderPipelineStage Class See Also Send Feedback
Get the constant buffers used by the pixel shader pipeline stage.

(Also see DirectX SDK: ID3D10Device::PSGetConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetConstantBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetConstantBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetConstantBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin retrieving constant buffers from (ranges from 0 to D3D10_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - 1).
bufferCount
Type: System..::..UInt32
Number of buffers to retrieve (ranges from 0 to D3D10_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - startSlot).

Return Value

Collection of constant buffer objects (see D3DBuffer) to be returned by the method.

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DBuffer


GetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..GetSamplers Method
PixelShaderPipelineStage Class See Also Send Feedback
Get an array of sampler states from the pixel shader pipeline stage.

(Also see DirectX SDK: ID3D10Device::PSGetSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<SamplerState> GetSamplers(
    uint startSlot,
    uint samplerCount
)
Visual Basic
Public Function GetSamplers ( _
    startSlot As UInteger, _
    samplerCount As UInteger _
) As ReadOnlyCollection(Of SamplerState)
Visual C++
public:
ReadOnlyCollection<SamplerState^>^ GetSamplers(
    unsigned int startSlot,
    unsigned int samplerCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into a zero-based array to begin getting samplers from (ranges from 0 to D3D10_COMMONSHADER_SAMPLER_SLOT_COUNT - 1).
samplerCount
Type: System..::..UInt32
Number of samplers to get from a device context. Each pipeline stage has a total of 16 sampler slots available (ranges from 0 to D3D10_COMMONSHADER_SAMPLER_SLOT_COUNT - startSlot).

Return Value

Collection of sampler-state objects (see SamplerState) to be returned by the device.

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerState


GetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..GetShaderResources Method
PixelShaderPipelineStage Class See Also Send Feedback
Get the pixel shader resources.

(Also see DirectX SDK: ID3D10Device::PSGetShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetShaderResources(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetShaderResources ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetShaderResources(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin getting shader resources from (ranges from 0 to D3D10_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - 1).
viewCount
Type: System..::..UInt32
The number of resources to get from the device. Up to a maximum of 128 slots are available for shader resources (ranges from 0 to D3D10_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - startSlot).

Return Value

Collection of shader resource view objects to be returned by the device.

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..SetConstantBuffers Method
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetConstantBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> constantBuffers
)
Visual Basic
Public Sub SetConstantBuffers ( _
    startSlot As UInteger, _
    constantBuffers As IEnumerable(Of D3DBuffer) _
)
Visual C++
public:
void SetConstantBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ constantBuffers
)

Parameters

startSlot
Type: System..::..UInt32
constantBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..SetSamplers Method
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSamplers(
    uint startSlot,
    IEnumerable<SamplerState> samplers
)
Visual Basic
Public Sub SetSamplers ( _
    startSlot As UInteger, _
    samplers As IEnumerable(Of SamplerState) _
)
Visual C++
public:
void SetSamplers(
    unsigned int startSlot,
    IEnumerable<SamplerState^>^ samplers
)

Parameters

startSlot
Type: System..::..UInt32
samplers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SamplerState >)>)>

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..SetShaderResources Method
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShaderResources(
    uint startSlot,
    IEnumerable<ShaderResourceView> shaderResourceViews
)
Visual Basic
Public Sub SetShaderResources ( _
    startSlot As UInteger, _
    shaderResourceViews As IEnumerable(Of ShaderResourceView) _
)
Visual C++
public:
void SetShaderResources(
    unsigned int startSlot,
    IEnumerable<ShaderResourceView^>^ shaderResourceViews
)

Parameters

startSlot
Type: System..::..UInt32
shaderResourceViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Properties
PixelShaderPipelineStage Class See Also Send Feedback

The PixelShaderPipelineStage type exposes the following members.

Properties

 | Name | Description
Public property | Shader | Gets or sets the pixel shader currently set on the device. Setting to null disables the shader for this pipeline stage. (Also see DirectX SDK: ID3D10Device::PSGetShader, ID3D10Device::PSSetShader)

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..Shader Property
PixelShaderPipelineStage Class See Also Send Feedback
Gets or sets the pixel shader currently set on the device. Setting to null disables the shader for this pipeline stage.

(Also see DirectX SDK: ID3D10Device::PSGetShader, ID3D10Device::PSSetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShader Shader { get; set; }
Visual Basic
Public Property Shader As PixelShader
    Get
    Set
Visual C++
public:
property PixelShader^ Shader {
    PixelShader^ get ();
    void set (PixelShader^ value);
}

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Primitive Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Primitive Enumeration
See Also Send Feedback
Primitive type, which determines how the data that makes up object geometry is organized.

(Also see DirectX SDK: D3D10_PRIMITIVE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Primitive
Visual Basic
Public Enumeration Primitive
Visual C++
public enum class Primitive

Members

Member name | Description
TriangleAdjacency |
LineAdjacency |
Triangle |
Undefined |
Point |
Line |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PrimitiveTopology Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PrimitiveTopology Enumeration
See Also Send Feedback
How the pipeline interprets vertex data that is bound to the input-assembler stage. These primitive types determine how the vertex data is rendered on screen.

(Also see DirectX SDK: D3D10_PRIMITIVE_TOPOLOGY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum PrimitiveTopology
Visual Basic
Public Enumeration PrimitiveTopology
Visual C++
public enum class PrimitiveTopology

Members

Member name | Description
Undefined |
TriangleStripAdjacency |
TriangleListAdjacency |
LineStripAdjacency |
LineListAdjacency |
TriangleStrip |
TriangleList |
LineStrip |
LineList |
PointList |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Query Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Query Enumeration
See Also Send Feedback
Query types.

(Also see DirectX SDK: D3D10_QUERY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Query
Visual Basic
Public Enumeration Query
Visual C++
public enum class Query

Members

Member name | Description
StreamOutputOverflowPredicate |
StreamOutputStatistics |
OcclusionPredicate |
PipelineStatistics |
TimestampDisjoint |
Timestamp |
Occlusion |
Event |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataPipelineStatistics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Structure
Members See Also Send Feedback
Query information about graphics-pipeline activity in between calls to Asynchronous.Begin and Asynchronous.End.

(Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct QueryDataPipelineStatistics
Visual Basic
Public Structure QueryDataPipelineStatistics
Visual C++
public value class QueryDataPipelineStatistics

See Also

QueryDataPipelineStatistics Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataPipelineStatistics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Members
QueryDataPipelineStatistics Structure Methods Operators Properties See Also Send Feedback

The QueryDataPipelineStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | CInvocations | Number of primitives that were sent to the rasterizer. When the rasterizer is disabled, this will not increment. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.CInvocations)
Public property | CPrimitives | Number of primitives that were rendered. This may be larger or smaller than CInvocations because after a primitive is clipped sometimes it is either broken up into more than one primitive or completely culled. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.CPrimitives)
Public property | GeometryShaderInvocations | Number of times a geometry shader was invoked. When the geometry shader is set to NULL, this statistic may or may not increment depending on the hardware manufacturer. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.GSInvocations)
Public property | GeometryShaderPrimitives | Number of primitives output by a geometry shader. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.GSPrimitives)
Public property | InputAssemblerPrimitives | Number of primitives read by the input assembler. This number can be different depending on the primitive topology used. For example, a triangle strip with 6 vertices will produce 4 triangles, however a triangle list with 6 vertices will produce 2 triangles. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.IAPrimitives)
Public property | InputAssemblerVertices | Number of vertices read by input assembler. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.IAVertices)
Public property | PixelShaderInvocations | Number of times a pixel shader was invoked. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.PSInvocations)
Public property | VertexShaderInvocations | Number of times a vertex shader was invoked. Direct3D invokes the vertex shader once per vertex. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.VSInvocations)

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataPipelineStatistics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Methods
QueryDataPipelineStatistics Structure See Also Send Feedback

The QueryDataPipelineStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..Equals Method
QueryDataPipelineStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..GetHashCode Method
QueryDataPipelineStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataPipelineStatistics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Operators
QueryDataPipelineStatistics Structure See Also Send Feedback

The QueryDataPipelineStatistics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..Equality Operator
QueryDataPipelineStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    QueryDataPipelineStatistics queryDataPipelineStatistics1,
    QueryDataPipelineStatistics queryDataPipelineStatistics2
)
Visual Basic
Public Shared Operator = ( _
    queryDataPipelineStatistics1 As QueryDataPipelineStatistics, _
    queryDataPipelineStatistics2 As QueryDataPipelineStatistics _
) As Boolean
Visual C++
public:
static bool operator ==(
    QueryDataPipelineStatistics queryDataPipelineStatistics1,
    QueryDataPipelineStatistics queryDataPipelineStatistics2
)

Parameters

queryDataPipelineStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataPipelineStatistics
queryDataPipelineStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataPipelineStatistics

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..Inequality Operator
QueryDataPipelineStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    QueryDataPipelineStatistics queryDataPipelineStatistics1,
    QueryDataPipelineStatistics queryDataPipelineStatistics2
)
Visual Basic
Public Shared Operator <> ( _
    queryDataPipelineStatistics1 As QueryDataPipelineStatistics, _
    queryDataPipelineStatistics2 As QueryDataPipelineStatistics _
) As Boolean
Visual C++
public:
static bool operator !=(
    QueryDataPipelineStatistics queryDataPipelineStatistics1,
    QueryDataPipelineStatistics queryDataPipelineStatistics2
)

Parameters

queryDataPipelineStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataPipelineStatistics
queryDataPipelineStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataPipelineStatistics

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataPipelineStatistics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Properties
QueryDataPipelineStatistics Structure See Also Send Feedback

The QueryDataPipelineStatistics type exposes the following members.

Properties

 | Name | Description
Public property | CInvocations | Number of primitives that were sent to the rasterizer. When the rasterizer is disabled, this will not increment. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.CInvocations)
Public property | CPrimitives | Number of primitives that were rendered. This may be larger or smaller than CInvocations because after a primitive is clipped sometimes it is either broken up into more than one primitive or completely culled. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.CPrimitives)
Public property | GeometryShaderInvocations | Number of times a geometry shader was invoked. When the geometry shader is set to NULL, this statistic may or may not increment depending on the hardware manufacturer. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.GSInvocations)
Public property | GeometryShaderPrimitives | Number of primitives output by a geometry shader. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.GSPrimitives)
Public property | InputAssemblerPrimitives | Number of primitives read by the input assembler. This number can be different depending on the primitive topology used. For example, a triangle strip with 6 vertices will produce 4 triangles, however a triangle list with 6 vertices will produce 2 triangles. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.IAPrimitives)
Public property | InputAssemblerVertices | Number of vertices read by input assembler. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.IAVertices)
Public property | PixelShaderInvocations | Number of times a pixel shader was invoked. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.PSInvocations)
Public property | VertexShaderInvocations | Number of times a vertex shader was invoked. Direct3D invokes the vertex shader once per vertex. (Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.VSInvocations)

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..CInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of primitives that were sent to the rasterizer. When the rasterizer is disabled, this will not increment.

(Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.CInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong CInvocations { get; set; }
Visual Basic
Public Property CInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long CInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CPrimitives Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..CPrimitives Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of primitives that were rendered. This may be larger or smaller than CInvocations because after a primitive is clipped sometimes it is either broken up into more than one primitive or completely culled.

(Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.CPrimitives)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong CPrimitives { get; set; }
Visual Basic
Public Property CPrimitives As ULong
    Get
    Set
Visual C++
public:
property unsigned long long CPrimitives {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..GeometryShaderInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of times a geometry shader was invoked. When the geometry shader is set to NULL, this statistic may or may not increment depending on the hardware manufacturer.

(Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.GSInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong GeometryShaderInvocations { get; set; }
Visual Basic
Public Property GeometryShaderInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long GeometryShaderInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderPrimitives Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..GeometryShaderPrimitives Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of primitives output by a geometry shader.

(Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.GSPrimitives)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong GeometryShaderPrimitives { get; set; }
Visual Basic
Public Property GeometryShaderPrimitives As ULong
    Get
    Set
Visual C++
public:
property unsigned long long GeometryShaderPrimitives {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerPrimitives Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..InputAssemblerPrimitives Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of primitives read by the input assembler. This number can be different depending on the primitive topology used. For example, a triangle strip with 6 vertices will produce 4 triangles, however a triangle list with 6 vertices will produce 2 triangles.

(Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.IAPrimitives)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong InputAssemblerPrimitives { get; set; }
Visual Basic
Public Property InputAssemblerPrimitives As ULong
    Get
    Set
Visual C++
public:
property unsigned long long InputAssemblerPrimitives {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerVertices Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..InputAssemblerVertices Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of vertices read by input assembler.

(Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.IAVertices)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong InputAssemblerVertices { get; set; }
Visual Basic
Public Property InputAssemblerVertices As ULong
    Get
    Set
Visual C++
public:
property unsigned long long InputAssemblerVertices {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..PixelShaderInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of times a pixel shader was invoked.

(Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.PSInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong PixelShaderInvocations { get; set; }
Visual Basic
Public Property PixelShaderInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long PixelShaderInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..VertexShaderInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of times a vertex shader was invoked. Direct3D invokes the vertex shader once per vertex.

(Also see DirectX SDK: D3D10_QUERY_DATA_PIPELINE_STATISTICS.VSInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong VertexShaderInvocations { get; set; }
Visual Basic
Public Property VertexShaderInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long VertexShaderInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataStreamOutputStatistics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Structure
Members See Also Send Feedback
Query information about the amount of data streamed out to the stream-output buffers in between Asynchronous.Begin and Asynchronous.End.

(Also see DirectX SDK: D3D10_QUERY_DATA_SO_STATISTICS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct QueryDataStreamOutputStatistics
Visual Basic
Public Structure QueryDataStreamOutputStatistics
Visual C++
public value class QueryDataStreamOutputStatistics

See Also

QueryDataStreamOutputStatistics Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataStreamOutputStatistics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Members
QueryDataStreamOutputStatistics Structure Methods Operators Properties See Also Send Feedback

The QueryDataStreamOutputStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | PrimitivesStorageNeeded | Number of primitives that would have been written to the stream-output buffers if there had been enough space for them all. (Also see DirectX SDK: D3D10_QUERY_DATA_SO_STATISTICS.PrimitivesStorageNeeded)
Public property | PrimitiveWrittenCount | Number of primitives (that is, points, lines, and triangles) written to the stream-output buffers. (Also see DirectX SDK: D3D10_QUERY_DATA_SO_STATISTICS.NumPrimitivesWritten)

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataStreamOutputStatistics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Methods
QueryDataStreamOutputStatistics Structure See Also Send Feedback

The QueryDataStreamOutputStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..Equals Method
QueryDataStreamOutputStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..GetHashCode Method
QueryDataStreamOutputStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataStreamOutputStatistics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Operators
QueryDataStreamOutputStatistics Structure See Also Send Feedback

The QueryDataStreamOutputStatistics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..Equality Operator
QueryDataStreamOutputStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics1,
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics2
)
Visual Basic
Public Shared Operator = ( _
    queryDataStreamOutputStatistics1 As QueryDataStreamOutputStatistics, _
    queryDataStreamOutputStatistics2 As QueryDataStreamOutputStatistics _
) As Boolean
Visual C++
public:
static bool operator ==(
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics1,
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics2
)

Parameters

queryDataStreamOutputStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataStreamOutputStatistics
queryDataStreamOutputStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataStreamOutputStatistics

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..Inequality Operator
QueryDataStreamOutputStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics1,
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics2
)
Visual Basic
Public Shared Operator <> ( _
    queryDataStreamOutputStatistics1 As QueryDataStreamOutputStatistics, _
    queryDataStreamOutputStatistics2 As QueryDataStreamOutputStatistics _
) As Boolean
Visual C++
public:
static bool operator !=(
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics1,
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics2
)

Parameters

queryDataStreamOutputStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataStreamOutputStatistics
queryDataStreamOutputStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataStreamOutputStatistics

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataStreamOutputStatistics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Properties
QueryDataStreamOutputStatistics Structure See Also Send Feedback

The QueryDataStreamOutputStatistics type exposes the following members.

Properties

 | Name | Description
Public property | PrimitivesStorageNeeded | Number of primitives that would have been written to the stream-output buffers if there had been enough space for them all. (Also see DirectX SDK: D3D10_QUERY_DATA_SO_STATISTICS.PrimitivesStorageNeeded)
Public property | PrimitiveWrittenCount | Number of primitives (that is, points, lines, and triangles) written to the stream-output buffers. (Also see DirectX SDK: D3D10_QUERY_DATA_SO_STATISTICS.NumPrimitivesWritten)

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PrimitivesStorageNeeded Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..PrimitivesStorageNeeded Property
QueryDataStreamOutputStatistics Structure See Also Send Feedback
Number of primitives that would have been written to the stream-output buffers if there had been enough space for them all.

(Also see DirectX SDK: D3D10_QUERY_DATA_SO_STATISTICS.PrimitivesStorageNeeded)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong PrimitivesStorageNeeded { get; set; }
Visual Basic
Public Property PrimitivesStorageNeeded As ULong
    Get
    Set
Visual C++
public:
property unsigned long long PrimitivesStorageNeeded {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PrimitiveWrittenCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..PrimitiveWrittenCount Property
QueryDataStreamOutputStatistics Structure See Also Send Feedback
Number of primitives (that is, points, lines, and triangles) written to the stream-output buffers.

(Also see DirectX SDK: D3D10_QUERY_DATA_SO_STATISTICS.NumPrimitivesWritten)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong PrimitiveWrittenCount { get; set; }
Visual Basic
Public Property PrimitiveWrittenCount As ULong
    Get
    Set
Visual C++
public:
property unsigned long long PrimitiveWrittenCount {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataTimestampDisjoint Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Structure
Members See Also Send Feedback
Query information about the reliability of a timestamp query.

(Also see DirectX SDK: D3D10_QUERY_DATA_TIMESTAMP_DISJOINT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct QueryDataTimestampDisjoint
Visual Basic
Public Structure QueryDataTimestampDisjoint
Visual C++
public value class QueryDataTimestampDisjoint

See Also

QueryDataTimestampDisjoint Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataTimestampDisjoint Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Members
QueryDataTimestampDisjoint Structure Methods Operators Properties See Also Send Feedback

The QueryDataTimestampDisjoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Disjoint | If this is TRUE, something occurred in between the query's Asynchronous.Begin and Asynchronous.End calls that caused the timestamp counter to become discontinuous or disjoint, such as unplugging the AC chord on a laptop, overheating, or throttling up/down due to laptop savings events. The timestamp returned by Asynchronous.GetData for a timestamp query is only reliable if Disjoint is FALSE. (Also see DirectX SDK: D3D10_QUERY_DATA_TIMESTAMP_DISJOINT.Disjoint)
Public property | Frequency | How frequently the GPU counter increments in Hz. (Also see DirectX SDK: D3D10_QUERY_DATA_TIMESTAMP_DISJOINT.Frequency)

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataTimestampDisjoint Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Methods
QueryDataTimestampDisjoint Structure See Also Send Feedback

The QueryDataTimestampDisjoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Equals Method
QueryDataTimestampDisjoint Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..GetHashCode Method
QueryDataTimestampDisjoint Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataTimestampDisjoint Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Operators
QueryDataTimestampDisjoint Structure See Also Send Feedback

The QueryDataTimestampDisjoint type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Equality Operator
QueryDataTimestampDisjoint Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    QueryDataTimestampDisjoint queryDataTimestampDisjoint1,
    QueryDataTimestampDisjoint queryDataTimestampDisjoint2
)
Visual Basic
Public Shared Operator = ( _
    queryDataTimestampDisjoint1 As QueryDataTimestampDisjoint, _
    queryDataTimestampDisjoint2 As QueryDataTimestampDisjoint _
) As Boolean
Visual C++
public:
static bool operator ==(
    QueryDataTimestampDisjoint queryDataTimestampDisjoint1,
    QueryDataTimestampDisjoint queryDataTimestampDisjoint2
)

Parameters

queryDataTimestampDisjoint1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataTimestampDisjoint
queryDataTimestampDisjoint2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataTimestampDisjoint

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Inequality Operator
QueryDataTimestampDisjoint Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    QueryDataTimestampDisjoint queryDataTimestampDisjoint1,
    QueryDataTimestampDisjoint queryDataTimestampDisjoint2
)
Visual Basic
Public Shared Operator <> ( _
    queryDataTimestampDisjoint1 As QueryDataTimestampDisjoint, _
    queryDataTimestampDisjoint2 As QueryDataTimestampDisjoint _
) As Boolean
Visual C++
public:
static bool operator !=(
    QueryDataTimestampDisjoint queryDataTimestampDisjoint1,
    QueryDataTimestampDisjoint queryDataTimestampDisjoint2
)

Parameters

queryDataTimestampDisjoint1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataTimestampDisjoint
queryDataTimestampDisjoint2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDataTimestampDisjoint

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDataTimestampDisjoint Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Properties
QueryDataTimestampDisjoint Structure See Also Send Feedback

The QueryDataTimestampDisjoint type exposes the following members.

Properties

 | Name | Description
Public property | Disjoint | If this is TRUE, something occurred in between the query's Asynchronous.Begin and Asynchronous.End calls that caused the timestamp counter to become discontinuous or disjoint, such as unplugging the AC chord on a laptop, overheating, or throttling up/down due to laptop savings events. The timestamp returned by Asynchronous.GetData for a timestamp query is only reliable if Disjoint is FALSE. (Also see DirectX SDK: D3D10_QUERY_DATA_TIMESTAMP_DISJOINT.Disjoint)
Public property | Frequency | How frequently the GPU counter increments in Hz. (Also see DirectX SDK: D3D10_QUERY_DATA_TIMESTAMP_DISJOINT.Frequency)

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Disjoint Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Disjoint Property
QueryDataTimestampDisjoint Structure See Also Send Feedback
If this is TRUE, something occurred in between the query's Asynchronous.Begin and Asynchronous.End calls that caused the timestamp counter to become discontinuous or disjoint, such as unplugging the AC chord on a laptop, overheating, or throttling up/down due to laptop savings events. The timestamp returned by Asynchronous.GetData for a timestamp query is only reliable if Disjoint is FALSE.

(Also see DirectX SDK: D3D10_QUERY_DATA_TIMESTAMP_DISJOINT.Disjoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool Disjoint { get; set; }
Visual Basic
Public Property Disjoint As Boolean
    Get
    Set
Visual C++
public:
property bool Disjoint {
    bool get ();
    void set (bool value);
}

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Frequency Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Frequency Property
QueryDataTimestampDisjoint Structure See Also Send Feedback
How frequently the GPU counter increments in Hz.

(Also see DirectX SDK: D3D10_QUERY_DATA_TIMESTAMP_DISJOINT.Frequency)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong Frequency { get; set; }
Visual Basic
Public Property Frequency As ULong
    Get
    Set
Visual C++
public:
property unsigned long long Frequency {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Structure
Members See Also Send Feedback
Describes a query.

(Also see DirectX SDK: D3D10_QUERY_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct QueryDescription
Visual Basic
Public Structure QueryDescription
Visual C++
public value class QueryDescription

See Also

QueryDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Members
QueryDescription Structure Methods Operators Properties See Also Send Feedback

The QueryDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MiscellaneousQueryOptions | Miscellaneous flags (see MiscellaneousQueryOptions). (Also see DirectX SDK: D3D10_QUERY_DESC.MiscFlags)
Public property | Query | Type of query. (Also see DirectX SDK: D3D10_QUERY_DESC.D3DQuery)

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Methods
QueryDescription Structure See Also Send Feedback

The QueryDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..Equals Method
QueryDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..GetHashCode Method
QueryDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Operators
QueryDescription Structure See Also Send Feedback

The QueryDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..Equality Operator
QueryDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    QueryDescription queryDescription1,
    QueryDescription queryDescription2
)
Visual Basic
Public Shared Operator = ( _
    queryDescription1 As QueryDescription, _
    queryDescription2 As QueryDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    QueryDescription queryDescription1,
    QueryDescription queryDescription2
)

Parameters

queryDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDescription
queryDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDescription

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..Inequality Operator
QueryDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    QueryDescription queryDescription1,
    QueryDescription queryDescription2
)
Visual Basic
Public Shared Operator <> ( _
    queryDescription1 As QueryDescription, _
    queryDescription2 As QueryDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    QueryDescription queryDescription1,
    QueryDescription queryDescription2
)

Parameters

queryDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDescription
queryDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..QueryDescription

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


QueryDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Properties
QueryDescription Structure See Also Send Feedback

The QueryDescription type exposes the following members.

Properties

 | Name | Description
Public property | MiscellaneousQueryOptions | Miscellaneous flags (see MiscellaneousQueryOptions). (Also see DirectX SDK: D3D10_QUERY_DESC.MiscFlags)
Public property | Query | Type of query. (Also see DirectX SDK: D3D10_QUERY_DESC.D3DQuery)

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MiscellaneousQueryOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..MiscellaneousQueryOptions Property
QueryDescription Structure See Also Send Feedback
Miscellaneous flags (see MiscellaneousQueryOptions).

(Also see DirectX SDK: D3D10_QUERY_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousQueryOptions MiscellaneousQueryOptions { get; set; }
Visual Basic
Public Property MiscellaneousQueryOptions As MiscellaneousQueryOptions
    Get
    Set
Visual C++
public:
property MiscellaneousQueryOptions MiscellaneousQueryOptions {
    MiscellaneousQueryOptions get ();
    void set (MiscellaneousQueryOptions value);
}

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
QueryDescription..::..MiscellaneousQueryOptions


Query Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..Query Property
QueryDescription Structure See Also Send Feedback
Type of query.

(Also see DirectX SDK: D3D10_QUERY_DESC.D3DQuery)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Query Query { get; set; }
Visual Basic
Public Property Query As Query
    Get
    Set
Visual C++
public:
property Query Query {
    Query get ();
    void set (Query value);
}

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Structure
Members See Also Send Feedback
Describes the rasterizer state.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RasterizerDescription
Visual Basic
Public Structure RasterizerDescription
Visual C++
public value class RasterizerDescription

See Also

RasterizerDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Members
RasterizerDescription Structure Methods Operators Properties See Also Send Feedback

The RasterizerDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AntiAliasedLineEnable | Enable or disables line antialiasing. Note that this option only applies when alpha blending is enabled, you are drawing lines, and the MultisampleEnable member is FALSE. The default value is FALSE. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.AntialiasedLineEnable)
Public property | CullMode | A member of the CullMode enumerated type that indicates whether triangles facing the specified direction are drawn. The default value is Back. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.CullMode)
Public property | DepthBias | Specifies the depth value added to a given pixel. The default value is 0. For more information, see Depth Bias. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.DepthBias)
Public property | DepthBiasClamp | Specifies the maximum depth bias of a pixel. The default value is 0.0f. For more information, see Depth Bias. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.DepthBiasClamp)
Public property | DepthClipEnable | Enables or disables clipping based on distance. The default value is TRUE. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.DepthClipEnable)
Public property | FillMode | A member of the FillMode enumerated type that determines the fill mode to use when rendering. The default value is Solid. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.FillMode)
Public property | FrontCounterclockwise | Determines if a triangle is front-facing or back-facing. If this parameter is TRUE, then a triangle is considered front-facing if its vertices are counter-clockwise on the render target, and considered back-facing if they are clockwise. If this parameter is FALSE, then the opposite is true. The default value is FALSE. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.FrontCounterClockwise)
Public property | MultisampleEnable | Enables or disables multisample antialiasing. The default value is FALSE. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.MultisampleEnable)
Public property | ScissorEnable | Enable or disables scissor-rectangle culling. All pixels outside an active scissor rectangle are culled. The default value is FALSE. For more information, see Set the Scissor Rectangle. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.ScissorEnable)
Public property | SlopeScaledDepthBias | Specifies a scalar on a given pixel's slope. The default value is 0.0f. For more information, see Depth Bias. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.SlopeScaledDepthBias)

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Methods
RasterizerDescription Structure See Also Send Feedback

The RasterizerDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..Equals Method
RasterizerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..GetHashCode Method
RasterizerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Operators
RasterizerDescription Structure See Also Send Feedback

The RasterizerDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..Equality Operator
RasterizerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    RasterizerDescription rasterizerDescription1,
    RasterizerDescription rasterizerDescription2
)
Visual Basic
Public Shared Operator = ( _
    rasterizerDescription1 As RasterizerDescription, _
    rasterizerDescription2 As RasterizerDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    RasterizerDescription rasterizerDescription1,
    RasterizerDescription rasterizerDescription2
)

Parameters

rasterizerDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerDescription
rasterizerDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerDescription

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..Inequality Operator
RasterizerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    RasterizerDescription rasterizerDescription1,
    RasterizerDescription rasterizerDescription2
)
Visual Basic
Public Shared Operator <> ( _
    rasterizerDescription1 As RasterizerDescription, _
    rasterizerDescription2 As RasterizerDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    RasterizerDescription rasterizerDescription1,
    RasterizerDescription rasterizerDescription2
)

Parameters

rasterizerDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerDescription
rasterizerDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerDescription

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Properties
RasterizerDescription Structure See Also Send Feedback

The RasterizerDescription type exposes the following members.

Properties

 | Name | Description
Public property | AntiAliasedLineEnable | Enable or disables line antialiasing. Note that this option only applies when alpha blending is enabled, you are drawing lines, and the MultisampleEnable member is FALSE. The default value is FALSE. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.AntialiasedLineEnable)
Public property | CullMode | A member of the CullMode enumerated type that indicates whether triangles facing the specified direction are drawn. The default value is Back. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.CullMode)
Public property | DepthBias | Specifies the depth value added to a given pixel. The default value is 0. For more information, see Depth Bias. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.DepthBias)
Public property | DepthBiasClamp | Specifies the maximum depth bias of a pixel. The default value is 0.0f. For more information, see Depth Bias. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.DepthBiasClamp)
Public property | DepthClipEnable | Enables or disables clipping based on distance. The default value is TRUE. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.DepthClipEnable)
Public property | FillMode | A member of the FillMode enumerated type that determines the fill mode to use when rendering. The default value is Solid. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.FillMode)
Public property | FrontCounterclockwise | Determines if a triangle is front-facing or back-facing. If this parameter is TRUE, then a triangle is considered front-facing if its vertices are counter-clockwise on the render target, and considered back-facing if they are clockwise. If this parameter is FALSE, then the opposite is true. The default value is FALSE. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.FrontCounterClockwise)
Public property | MultisampleEnable | Enables or disables multisample antialiasing. The default value is FALSE. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.MultisampleEnable)
Public property | ScissorEnable | Enable or disables scissor-rectangle culling. All pixels outside an active scissor rectangle are culled. The default value is FALSE. For more information, see Set the Scissor Rectangle. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.ScissorEnable)
Public property | SlopeScaledDepthBias | Specifies a scalar on a given pixel's slope. The default value is 0.0f. For more information, see Depth Bias. (Also see DirectX SDK: D3D10_RASTERIZER_DESC.SlopeScaledDepthBias)

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AntiAliasedLineEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..AntiAliasedLineEnable Property
RasterizerDescription Structure See Also Send Feedback
Enable or disables line antialiasing. Note that this option only applies when alpha blending is enabled, you are drawing lines, and the MultisampleEnable member is FALSE. The default value is FALSE.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.AntialiasedLineEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool AntiAliasedLineEnable { get; set; }
Visual Basic
Public Property AntiAliasedLineEnable As Boolean
    Get
    Set
Visual C++
public:
property bool AntiAliasedLineEnable {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CullMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..CullMode Property
RasterizerDescription Structure See Also Send Feedback
A member of the CullMode enumerated type that indicates whether triangles facing the specified direction are drawn. The default value is Back.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.CullMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CullMode CullMode { get; set; }
Visual Basic
Public Property CullMode As CullMode
    Get
    Set
Visual C++
public:
property CullMode CullMode {
    CullMode get ();
    void set (CullMode value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthBias Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..DepthBias Property
RasterizerDescription Structure See Also Send Feedback
Specifies the depth value added to a given pixel. The default value is 0. For more information, see Depth Bias.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.DepthBias)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int DepthBias { get; set; }
Visual Basic
Public Property DepthBias As Integer
    Get
    Set
Visual C++
public:
property int DepthBias {
    int get ();
    void set (int value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthBiasClamp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..DepthBiasClamp Property
RasterizerDescription Structure See Also Send Feedback
Specifies the maximum depth bias of a pixel. The default value is 0.0f. For more information, see Depth Bias.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.DepthBiasClamp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float DepthBiasClamp { get; set; }
Visual Basic
Public Property DepthBiasClamp As Single
    Get
    Set
Visual C++
public:
property float DepthBiasClamp {
    float get ();
    void set (float value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DepthClipEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..DepthClipEnable Property
RasterizerDescription Structure See Also Send Feedback
Enables or disables clipping based on distance. The default value is TRUE.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.DepthClipEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool DepthClipEnable { get; set; }
Visual Basic
Public Property DepthClipEnable As Boolean
    Get
    Set
Visual C++
public:
property bool DepthClipEnable {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FillMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..FillMode Property
RasterizerDescription Structure See Also Send Feedback
A member of the FillMode enumerated type that determines the fill mode to use when rendering. The default value is Solid.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.FillMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FillMode FillMode { get; set; }
Visual Basic
Public Property FillMode As FillMode
    Get
    Set
Visual C++
public:
property FillMode FillMode {
    FillMode get ();
    void set (FillMode value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FrontCounterclockwise Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..FrontCounterclockwise Property
RasterizerDescription Structure See Also Send Feedback
Determines if a triangle is front-facing or back-facing. If this parameter is TRUE, then a triangle is considered front-facing if its vertices are counter-clockwise on the render target, and considered back-facing if they are clockwise. If this parameter is FALSE, then the opposite is true. The default value is FALSE.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.FrontCounterClockwise)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool FrontCounterclockwise { get; set; }
Visual Basic
Public Property FrontCounterclockwise As Boolean
    Get
    Set
Visual C++
public:
property bool FrontCounterclockwise {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MultisampleEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..MultisampleEnable Property
RasterizerDescription Structure See Also Send Feedback
Enables or disables multisample antialiasing. The default value is FALSE.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.MultisampleEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool MultisampleEnable { get; set; }
Visual Basic
Public Property MultisampleEnable As Boolean
    Get
    Set
Visual C++
public:
property bool MultisampleEnable {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ScissorEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..ScissorEnable Property
RasterizerDescription Structure See Also Send Feedback
Enable or disables scissor-rectangle culling. All pixels outside an active scissor rectangle are culled. The default value is FALSE. For more information, see Set the Scissor Rectangle.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.ScissorEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool ScissorEnable { get; set; }
Visual Basic
Public Property ScissorEnable As Boolean
    Get
    Set
Visual C++
public:
property bool ScissorEnable {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SlopeScaledDepthBias Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..SlopeScaledDepthBias Property
RasterizerDescription Structure See Also Send Feedback
Specifies a scalar on a given pixel's slope. The default value is 0.0f. For more information, see Depth Bias.

(Also see DirectX SDK: D3D10_RASTERIZER_DESC.SlopeScaledDepthBias)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float SlopeScaledDepthBias { get; set; }
Visual Basic
Public Property SlopeScaledDepthBias As Single
    Get
    Set
Visual C++
public:
property float SlopeScaledDepthBias {
    float get ();
    void set (float value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Class
Members See Also Send Feedback
Rasterizer pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RasterizerPipelineStage : PipelineStage
Visual Basic
Public Class RasterizerPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class RasterizerPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerPipelineStage

See Also

RasterizerPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Members
RasterizerPipelineStage Class Constructors Methods Properties See Also Send Feedback

The RasterizerPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | RasterizerPipelineStage |

Methods

 | Name | Description
Public method | BoundedGetScissorRects | Get the collection of scissor rectangles bound to the rasterizer stage. (Also see DirectX SDK: ID3D10Device::RSGetScissorRects)
Public method | BoundedGetViewports | Get the array of viewports bound to the rasterizer stage (Also see DirectX SDK: ID3D10Device::RSGetViewports)

Properties

 | Name | Description
Public property | ScissorRects | Bind an array of scissor rectangles to the rasterizer stage. (Also see DirectX SDK: ID3D10Device::RSSetScissorRects)
Public property | State | Gets or sets the rasterizer state from the rasterizer stage of the pipeline. (Also see DirectX SDK: ID3D10Device::RSGetState, ID3D10Device::RSSetState)
Public property | Viewports | Bind an array of viewports to the rasterizer stage of the pipeline. (Also see DirectX SDK: ID3D10Device::RSSetViewports)

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Constructor
RasterizerPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected RasterizerPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
RasterizerPipelineStage()

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Methods
RasterizerPipelineStage Class See Also Send Feedback

The RasterizerPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | BoundedGetScissorRects | Get the collection of scissor rectangles bound to the rasterizer stage. (Also see DirectX SDK: ID3D10Device::RSGetScissorRects)
Public method | BoundedGetViewports | Get the array of viewports bound to the rasterizer stage (Also see DirectX SDK: ID3D10Device::RSGetViewports)

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BoundedGetScissorRects Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..BoundedGetScissorRects Method
RasterizerPipelineStage Class See Also Send Feedback
Get the collection of scissor rectangles bound to the rasterizer stage.

(Also see DirectX SDK: ID3D10Device::RSGetScissorRects)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<D3DRect> BoundedGetScissorRects(
    uint maxNumberOfRects
)
Visual Basic
Public Function BoundedGetScissorRects ( _
    maxNumberOfRects As UInteger _
) As IEnumerable(Of D3DRect)
Visual C++
public:
IEnumerable<D3DRect>^ BoundedGetScissorRects(
    unsigned int maxNumberOfRects
)

Parameters

maxNumberOfRects
Type: System..::..UInt32

Return Value

A collection of scissor rectangles (see D3DRect). If maximumNumberOfRects is greater than the number of scissor rects currently bound, then the collection will be trimmed to contain only the currently bound.

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..D3DRect


BoundedGetViewports Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..BoundedGetViewports Method
RasterizerPipelineStage Class See Also Send Feedback
Get the array of viewports bound to the rasterizer stage

(Also see DirectX SDK: ID3D10Device::RSGetViewports)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<Viewport> BoundedGetViewports(
    uint maxNumberOfViewports
)
Visual Basic
Public Function BoundedGetViewports ( _
    maxNumberOfViewports As UInteger _
) As IEnumerable(Of Viewport)
Visual C++
public:
IEnumerable<Viewport>^ BoundedGetViewports(
    unsigned int maxNumberOfViewports
)

Parameters

maxNumberOfViewports
Type: System..::..UInt32
The input specifies the maximum number of viewports (ranges from 0 to D3D10_VIEWPORT_AND_SCISSORRECT_OBJECT_COUNT_PER_PIPELINE) to retrieve, the output contains the actual number of viewports returned.

Return Value

A collection of Viewport structures that are bound to the device. If the number of viewports (in maxNumberOfViewports) is greater than the actual number of viewports currently bound, then the collection will be trimmed to contain only the currently bound.

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Properties
RasterizerPipelineStage Class See Also Send Feedback

The RasterizerPipelineStage type exposes the following members.

Properties

 | Name | Description
Public property | ScissorRects | Bind an array of scissor rectangles to the rasterizer stage. (Also see DirectX SDK: ID3D10Device::RSSetScissorRects)
Public property | State | Gets or sets the rasterizer state from the rasterizer stage of the pipeline. (Also see DirectX SDK: ID3D10Device::RSGetState, ID3D10Device::RSSetState)
Public property | Viewports | Bind an array of viewports to the rasterizer stage of the pipeline. (Also see DirectX SDK: ID3D10Device::RSSetViewports)

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ScissorRects Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..ScissorRects Property
RasterizerPipelineStage Class See Also Send Feedback
Bind an array of scissor rectangles to the rasterizer stage.

(Also see DirectX SDK: ID3D10Device::RSSetScissorRects)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<D3DRect> ScissorRects { get; set; }
Visual Basic
Public Property ScissorRects As IEnumerable(Of D3DRect)
    Get
    Set
Visual C++
public:
property IEnumerable<D3DRect>^ ScissorRects {
    IEnumerable<D3DRect>^ get ();
    void set (IEnumerable<D3DRect>^ value);
}

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..D3DRect


State Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..State Property
RasterizerPipelineStage Class See Also Send Feedback
Gets or sets the rasterizer state from the rasterizer stage of the pipeline.

(Also see DirectX SDK: ID3D10Device::RSGetState, ID3D10Device::RSSetState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerState State { get; set; }
Visual Basic
Public Property State As RasterizerState
    Get
    Set
Visual C++
public:
property RasterizerState^ State {
    RasterizerState^ get ();
    void set (RasterizerState^ value);
}

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Viewports Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..Viewports Property
RasterizerPipelineStage Class See Also Send Feedback
Bind an array of viewports to the rasterizer stage of the pipeline.

(Also see DirectX SDK: ID3D10Device::RSSetViewports)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<Viewport> Viewports { get; set; }
Visual Basic
Public Property Viewports As IEnumerable(Of Viewport)
    Get
    Set
Visual C++
public:
property IEnumerable<Viewport>^ Viewports {
    IEnumerable<Viewport>^ get ();
    void set (IEnumerable<Viewport>^ value);
}

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerState Class
Members See Also Send Feedback
A rasterizer-state interface accesses rasterizer state for the rasterizer stage.

(Also see DirectX SDK: ID3D10RasterizerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RasterizerState : DeviceChild
Visual Basic
Public Class RasterizerState _
    Inherits DeviceChild
Visual C++
public ref class RasterizerState : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RasterizerState

See Also

RasterizerState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerState Members
RasterizerState Class Properties See Also Send Feedback

The RasterizerState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a rasterizer-state object. (Also see DirectX SDK: ID3D10RasterizerState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

RasterizerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerState Properties
RasterizerState Class See Also Send Feedback

The RasterizerState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a rasterizer-state object. (Also see DirectX SDK: ID3D10RasterizerState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

RasterizerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerState..::..Description Property
RasterizerState Class See Also Send Feedback
Get the properties of a rasterizer-state object.

(Also see DirectX SDK: ID3D10RasterizerState::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As RasterizerDescription
    Get
Visual C++
public:
property RasterizerDescription Description {
    RasterizerDescription get ();
}

See Also

RasterizerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RegisterComponentType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RegisterComponentType Enumeration
See Also Send Feedback
The register component types, usually used in SignatureParameterDescription.

(Also see DirectX SDK: D3D10_REGISTER_COMPONENT_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum RegisterComponentType
Visual Basic
Public Enumeration RegisterComponentType
Visual C++
public enum class RegisterComponentType

Members

Member name | Description
Float32 |
UInt32 |
SInt32 |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetBlendDescription1 Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1 Structure
Members See Also Send Feedback
Describes the blend state for a render target for a Direct3D 10.1 device

(Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RenderTargetBlendDescription1
Visual Basic
Public Structure RenderTargetBlendDescription1
Visual C++
public value class RenderTargetBlendDescription1

See Also

RenderTargetBlendDescription1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetBlendDescription1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1 Members
RenderTargetBlendDescription1 Structure Methods Operators Properties See Also Send Feedback

The RenderTargetBlendDescription1 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BlendEnable | Enable (or disable) blending. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.BlendEnable)
Public property | BlendOperation | This blend operation defines how to combine the RGB data sources. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.BlendOp)
Public property | BlendOperationAlpha | This blend operation defines how to combine the alpha data sources. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.BlendOpAlpha)
Public property | DestinationBlend | This blend option specifies the second RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.DestBlend)
Public property | DestinationBlendAlpha | This blend option specifies the second alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.DestBlendAlpha)
Public property | RenderTargetWriteMask | A write mask. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.RenderTargetWriteMask)
Public property | SourceBlend | This blend option specifies the first RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.SrcBlend)
Public property | SourceBlendAlpha | This blend option specifies the first alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.SrcBlendAlpha)

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetBlendDescription1 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1 Methods
RenderTargetBlendDescription1 Structure See Also Send Feedback

The RenderTargetBlendDescription1 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..Equals Method
RenderTargetBlendDescription1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..GetHashCode Method
RenderTargetBlendDescription1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetBlendDescription1 Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1 Operators
RenderTargetBlendDescription1 Structure See Also Send Feedback

The RenderTargetBlendDescription1 type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..Equality Operator
RenderTargetBlendDescription1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    RenderTargetBlendDescription1 renderTargetBlendDescription1,
    RenderTargetBlendDescription1 renderTargetBlendDescription2
)
Visual Basic
Public Shared Operator = ( _
    renderTargetBlendDescription1 As RenderTargetBlendDescription1, _
    renderTargetBlendDescription2 As RenderTargetBlendDescription1 _
) As Boolean
Visual C++
public:
static bool operator ==(
    RenderTargetBlendDescription1 renderTargetBlendDescription1,
    RenderTargetBlendDescription1 renderTargetBlendDescription2
)

Parameters

renderTargetBlendDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetBlendDescription1
renderTargetBlendDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetBlendDescription1

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..Inequality Operator
RenderTargetBlendDescription1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    RenderTargetBlendDescription1 renderTargetBlendDescription1,
    RenderTargetBlendDescription1 renderTargetBlendDescription2
)
Visual Basic
Public Shared Operator <> ( _
    renderTargetBlendDescription1 As RenderTargetBlendDescription1, _
    renderTargetBlendDescription2 As RenderTargetBlendDescription1 _
) As Boolean
Visual C++
public:
static bool operator !=(
    RenderTargetBlendDescription1 renderTargetBlendDescription1,
    RenderTargetBlendDescription1 renderTargetBlendDescription2
)

Parameters

renderTargetBlendDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetBlendDescription1
renderTargetBlendDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetBlendDescription1

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetBlendDescription1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1 Properties
RenderTargetBlendDescription1 Structure See Also Send Feedback

The RenderTargetBlendDescription1 type exposes the following members.

Properties

 | Name | Description
Public property | BlendEnable | Enable (or disable) blending. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.BlendEnable)
Public property | BlendOperation | This blend operation defines how to combine the RGB data sources. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.BlendOp)
Public property | BlendOperationAlpha | This blend operation defines how to combine the alpha data sources. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.BlendOpAlpha)
Public property | DestinationBlend | This blend option specifies the second RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.DestBlend)
Public property | DestinationBlendAlpha | This blend option specifies the second alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.DestBlendAlpha)
Public property | RenderTargetWriteMask | A write mask. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.RenderTargetWriteMask)
Public property | SourceBlend | This blend option specifies the first RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.SrcBlend)
Public property | SourceBlendAlpha | This blend option specifies the first alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.SrcBlendAlpha)

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..BlendEnable Property
RenderTargetBlendDescription1 Structure See Also Send Feedback
Enable (or disable) blending.

(Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.BlendEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool BlendEnable { get; set; }
Visual Basic
Public Property BlendEnable As Boolean
    Get
    Set
Visual C++
public:
property bool BlendEnable {
    bool get ();
    void set (bool value);
}

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendOperation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..BlendOperation Property
RenderTargetBlendDescription1 Structure See Also Send Feedback
This blend operation defines how to combine the RGB data sources.

(Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.BlendOp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendOperation BlendOperation { get; set; }
Visual Basic
Public Property BlendOperation As BlendOperation
    Get
    Set
Visual C++
public:
property BlendOperation BlendOperation {
    BlendOperation get ();
    void set (BlendOperation value);
}

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BlendOperationAlpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..BlendOperationAlpha Property
RenderTargetBlendDescription1 Structure See Also Send Feedback
This blend operation defines how to combine the alpha data sources.

(Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.BlendOpAlpha)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendOperation BlendOperationAlpha { get; set; }
Visual Basic
Public Property BlendOperationAlpha As BlendOperation
    Get
    Set
Visual C++
public:
property BlendOperation BlendOperationAlpha {
    BlendOperation get ();
    void set (BlendOperation value);
}

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DestinationBlend Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..DestinationBlend Property
RenderTargetBlendDescription1 Structure See Also Send Feedback
This blend option specifies the second RGB data source and includes an optional pre-blend operation.

(Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.DestBlend)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend DestinationBlend { get; set; }
Visual Basic
Public Property DestinationBlend As Blend
    Get
    Set
Visual C++
public:
property Blend DestinationBlend {
    Blend get ();
    void set (Blend value);
}

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DestinationBlendAlpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..DestinationBlendAlpha Property
RenderTargetBlendDescription1 Structure See Also Send Feedback
This blend option specifies the second alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed.

(Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.DestBlendAlpha)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend DestinationBlendAlpha { get; set; }
Visual Basic
Public Property DestinationBlendAlpha As Blend
    Get
    Set
Visual C++
public:
property Blend DestinationBlendAlpha {
    Blend get ();
    void set (Blend value);
}

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetWriteMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..RenderTargetWriteMask Property
RenderTargetBlendDescription1 Structure See Also Send Feedback
A write mask.

(Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.RenderTargetWriteMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorWriteEnableComponents RenderTargetWriteMask { get; set; }
Visual Basic
Public Property RenderTargetWriteMask As ColorWriteEnableComponents
    Get
    Set
Visual C++
public:
property ColorWriteEnableComponents RenderTargetWriteMask {
    ColorWriteEnableComponents get ();
    void set (ColorWriteEnableComponents value);
}

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SourceBlend Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..SourceBlend Property
RenderTargetBlendDescription1 Structure See Also Send Feedback
This blend option specifies the first RGB data source and includes an optional pre-blend operation.

(Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.SrcBlend)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend SourceBlend { get; set; }
Visual Basic
Public Property SourceBlend As Blend
    Get
    Set
Visual C++
public:
property Blend SourceBlend {
    Blend get ();
    void set (Blend value);
}

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SourceBlendAlpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription1..::..SourceBlendAlpha Property
RenderTargetBlendDescription1 Structure See Also Send Feedback
This blend option specifies the first alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed.

(Also see DirectX SDK: D3D10_RENDER_TARGET_BLEND_DESC1.SrcBlendAlpha)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend SourceBlendAlpha { get; set; }
Visual Basic
Public Property SourceBlendAlpha As Blend
    Get
    Set
Visual C++
public:
property Blend SourceBlendAlpha {
    Blend get ();
    void set (Blend value);
}

See Also

RenderTargetBlendDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetView Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetView Class
Members See Also Send Feedback
A render-target-view interface identifies the render-target subresources that can be accessed during rendering.

(Also see DirectX SDK: ID3D10RenderTargetView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RenderTargetView : View
Visual Basic
Public Class RenderTargetView _
    Inherits View
Visual C++
public ref class RenderTargetView : public View

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetView

See Also

RenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetView Members
RenderTargetView Class Properties See Also Send Feedback

The RenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a render target view. (Also see DirectX SDK: ID3D10RenderTargetView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource) (Inherited from View.)

See Also

RenderTargetView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetView Properties
RenderTargetView Class See Also Send Feedback

The RenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a render target view. (Also see DirectX SDK: ID3D10RenderTargetView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource) (Inherited from View.)

See Also

RenderTargetView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetView..::..Description Property
RenderTargetView Class See Also Send Feedback
Get the properties of a render target view.

(Also see DirectX SDK: ID3D10RenderTargetView::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetViewDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As RenderTargetViewDescription
    Get
Visual C++
public:
property RenderTargetViewDescription Description {
    RenderTargetViewDescription get ();
}

See Also

RenderTargetView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetViewDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription Structure
Members See Also Send Feedback
Specifies the subresource(s) from a resource that are accessible using a render-target view.

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RenderTargetViewDescription
Visual Basic
Public Structure RenderTargetViewDescription
Visual C++
public value class RenderTargetViewDescription

See Also

RenderTargetViewDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetViewDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription Members
RenderTargetViewDescription Structure Properties See Also Send Feedback

The RenderTargetViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | Specifies which buffer elements can be accessed (see BufferRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Buffer)
Public property | Format | The data format (see Format). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Format)
Public property | Texture1D | Specifies the subresources in a 1D texture that can be accessed (see Texture1DRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies the subresources in a 1D texture array that can be accessed (see Texture1DArrayRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies the subresources in a 2D texture that can be accessed (see Texture2DRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies the subresources in a 2D texture array that can be accessed (see Texture2DArrayRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | Specifies a single subresource because a multisampled 2D texture only contains one subresource (see Texture2DMultisampleRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2DMultisample)
Public property | Texture2DMultisampleArray | Specifies the subresources in a multisampled 2D texture array that can be accessed (see Texture2DMultisampleArrayRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2DMSArray)
Public property | Texture3D | Specifies subresources in a 3D texture that can be accessed (see Texture3DRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture3D)
Public property | ViewDimension | The resource type (see RenderTargetViewDimension), which specifies how the render-target resource will be accessed. (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.ViewDimension)

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RenderTargetViewDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription Properties
RenderTargetViewDescription Structure See Also Send Feedback

The RenderTargetViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | Specifies which buffer elements can be accessed (see BufferRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Buffer)
Public property | Format | The data format (see Format). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Format)
Public property | Texture1D | Specifies the subresources in a 1D texture that can be accessed (see Texture1DRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies the subresources in a 1D texture array that can be accessed (see Texture1DArrayRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies the subresources in a 2D texture that can be accessed (see Texture2DRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies the subresources in a 2D texture array that can be accessed (see Texture2DArrayRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | Specifies a single subresource because a multisampled 2D texture only contains one subresource (see Texture2DMultisampleRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2DMultisample)
Public property | Texture2DMultisampleArray | Specifies the subresources in a multisampled 2D texture array that can be accessed (see Texture2DMultisampleArrayRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2DMSArray)
Public property | Texture3D | Specifies subresources in a 3D texture that can be accessed (see Texture3DRenderTargetView). (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture3D)
Public property | ViewDimension | The resource type (see RenderTargetViewDimension), which specifies how the render-target resource will be accessed. (Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.ViewDimension)

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Buffer Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies which buffer elements can be accessed (see BufferRenderTargetView).

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Buffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BufferRenderTargetView Buffer { get; set; }
Visual Basic
Public Property Buffer As BufferRenderTargetView
    Get
    Set
Visual C++
public:
property BufferRenderTargetView Buffer {
    BufferRenderTargetView get ();
    void set (BufferRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferRenderTargetView


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Format Property
RenderTargetViewDescription Structure See Also Send Feedback
The data format (see Format).

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
RenderTargetViewDescription..::..Format


Texture1D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture1D Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a 1D texture that can be accessed (see Texture1DRenderTargetView).

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DRenderTargetView Texture1D { get; set; }
Visual Basic
Public Property Texture1D As Texture1DRenderTargetView
    Get
    Set
Visual C++
public:
property Texture1DRenderTargetView Texture1D {
    Texture1DRenderTargetView get ();
    void set (Texture1DRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DRenderTargetView


Texture1DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture1DArray Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a 1D texture array that can be accessed (see Texture1DArrayRenderTargetView).

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture1DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DArrayRenderTargetView Texture1DArray { get; set; }
Visual Basic
Public Property Texture1DArray As Texture1DArrayRenderTargetView
    Get
    Set
Visual C++
public:
property Texture1DArrayRenderTargetView Texture1DArray {
    Texture1DArrayRenderTargetView get ();
    void set (Texture1DArrayRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayRenderTargetView


Texture2D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture2D Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a 2D texture that can be accessed (see Texture2DRenderTargetView).

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DRenderTargetView Texture2D { get; set; }
Visual Basic
Public Property Texture2D As Texture2DRenderTargetView
    Get
    Set
Visual C++
public:
property Texture2DRenderTargetView Texture2D {
    Texture2DRenderTargetView get ();
    void set (Texture2DRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DRenderTargetView


Texture2DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture2DArray Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a 2D texture array that can be accessed (see Texture2DArrayRenderTargetView).

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DArrayRenderTargetView Texture2DArray { get; set; }
Visual Basic
Public Property Texture2DArray As Texture2DArrayRenderTargetView
    Get
    Set
Visual C++
public:
property Texture2DArrayRenderTargetView Texture2DArray {
    Texture2DArrayRenderTargetView get ();
    void set (Texture2DArrayRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayRenderTargetView


Texture2DMultisample Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture2DMultisample Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies a single subresource because a multisampled 2D texture only contains one subresource (see Texture2DMultisampleRenderTargetView).

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2DMultisample)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleRenderTargetView Texture2DMultisample { get; set; }
Visual Basic
Public Property Texture2DMultisample As Texture2DMultisampleRenderTargetView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleRenderTargetView Texture2DMultisample {
    Texture2DMultisampleRenderTargetView get ();
    void set (Texture2DMultisampleRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleRenderTargetView


Texture2DMultisampleArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture2DMultisampleArray Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a multisampled 2D texture array that can be accessed (see Texture2DMultisampleArrayRenderTargetView).

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture2DMSArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleArrayRenderTargetView Texture2DMultisampleArray { get; set; }
Visual Basic
Public Property Texture2DMultisampleArray As Texture2DMultisampleArrayRenderTargetView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleArrayRenderTargetView Texture2DMultisampleArray {
    Texture2DMultisampleArrayRenderTargetView get ();
    void set (Texture2DMultisampleArrayRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayRenderTargetView


Texture3D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture3D Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies subresources in a 3D texture that can be accessed (see Texture3DRenderTargetView).

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.Texture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3DRenderTargetView Texture3D { get; set; }
Visual Basic
Public Property Texture3D As Texture3DRenderTargetView
    Get
    Set
Visual C++
public:
property Texture3DRenderTargetView Texture3D {
    Texture3DRenderTargetView get ();
    void set (Texture3DRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DRenderTargetView


ViewDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..ViewDimension Property
RenderTargetViewDescription Structure See Also Send Feedback
The resource type (see RenderTargetViewDimension), which specifies how the render-target resource will be accessed.

(Also see DirectX SDK: D3D10_RENDER_TARGET_VIEW_DESC.ViewDimension)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetViewDimension ViewDimension { get; set; }
Visual Basic
Public Property ViewDimension As RenderTargetViewDimension
    Get
    Set
Visual C++
public:
property RenderTargetViewDimension ViewDimension {
    RenderTargetViewDimension get ();
    void set (RenderTargetViewDimension value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetViewDimension


RenderTargetViewDimension Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDimension Enumeration
See Also Send Feedback
Specifies how to access a resource used in a render-target view.

(Also see DirectX SDK: D3D10_RTV_DIMENSION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum RenderTargetViewDimension
Visual Basic
Public Enumeration RenderTargetViewDimension
Visual C++
public enum class RenderTargetViewDimension

Members

Member name | Description
Texture2DMultisampleArray |
Texture2DMultisample |
Buffer |
Texture3D |
Texture2DArray |
Texture2D |
Texture1DArray |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ResourceDimension Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ResourceDimension Enumeration
See Also Send Feedback
Identifies the type of resource being used.

(Also see DirectX SDK: D3D10_RESOURCE_DIMENSION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ResourceDimension
Visual Basic
Public Enumeration ResourceDimension
Visual C++
public enum class ResourceDimension

Members

Member name | Description
Buffer |
Texture3D |
Texture2D |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ResourceReturnType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ResourceReturnType Enumeration
See Also Send Feedback
The return type of a resource. See ShaderInputBindDescription.

(Also see DirectX SDK: D3D10_RESOURCE_RETURN_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ResourceReturnType
Visual Basic
Public Enumeration ResourceReturnType
Visual C++
public enum class ResourceReturnType

Members

Member name | Description
Mixed |
Float |
UInt |
SInt |
SNorm |
UNorm |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SamplerDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Structure
Members See Also Send Feedback
Describes a sampler state.

(Also see DirectX SDK: D3D10_SAMPLER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SamplerDescription
Visual Basic
Public Structure SamplerDescription
Visual C++
public value class SamplerDescription

See Also

SamplerDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SamplerDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Members
SamplerDescription Structure Methods Operators Properties See Also Send Feedback

The SamplerDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AddressU | Method to use for resolving a u texture coordinate that is outside the 0 to 1 range (see TextureAddressMode). (Also see DirectX SDK: D3D10_SAMPLER_DESC.AddressU)
Public property | AddressV | Method to use for resolving a v texture coordinate that is outside the 0 to 1 range. (Also see DirectX SDK: D3D10_SAMPLER_DESC.AddressV)
Public property | AddressW | Method to use for resolving a w texture coordinate that is outside the 0 to 1 range. (Also see DirectX SDK: D3D10_SAMPLER_DESC.AddressW)
Public property | BorderColor | Border color to use if Border is specified for AddressU, AddressV, or AddressW. Range must be between 0.0 and 1.0 inclusive. (Also see DirectX SDK: D3D10_SAMPLER_DESC.BorderColor)
Public property | ComparisonFunction | A function that compares sampled data against existing sampled data. The function options are listed in ComparisonFunction. (Also see DirectX SDK: D3D10_SAMPLER_DESC.ComparisonFunc)
Public property | Filter | Filtering method to use when sampling a texture (see Filter). (Also see DirectX SDK: D3D10_SAMPLER_DESC.Filter)
Public property | MaxAnisotropy | Clamping value used if Anisotropic or ComparisonAnisotropic is specified in Filter. Valid values are between 1 and 16. (Also see DirectX SDK: D3D10_SAMPLER_DESC.MaxAnisotropy)
Public property | MaximumLevelOfDetail | Upper end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. This value must be greater than or equal to MinimumLevelOfDetail. To have no upper limit on LOD set this to a large value such as D3D10_FLOAT32_MAX. (Also see DirectX SDK: D3D10_SAMPLER_DESC.MaxLOD)
Public property | MinimumLevelOfDetail | Lower end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. (Also see DirectX SDK: D3D10_SAMPLER_DESC.MinLOD)
Public property | MipLevelOfDetailBias | Offset from the calculated mipmap level. For example, if Direct3D calculates that a texture should be sampled at mipmap level 3 and MipLevelOfDetailBias is 2, then the texture will be sampled at mipmap level 5. (Also see DirectX SDK: D3D10_SAMPLER_DESC.MipLODBias)

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SamplerDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Methods
SamplerDescription Structure See Also Send Feedback

The SamplerDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..Equals Method
SamplerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..GetHashCode Method
SamplerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SamplerDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Operators
SamplerDescription Structure See Also Send Feedback

The SamplerDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..Equality Operator
SamplerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    SamplerDescription samplerDescription1,
    SamplerDescription samplerDescription2
)
Visual Basic
Public Shared Operator = ( _
    samplerDescription1 As SamplerDescription, _
    samplerDescription2 As SamplerDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    SamplerDescription samplerDescription1,
    SamplerDescription samplerDescription2
)

Parameters

samplerDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerDescription
samplerDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerDescription

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..Inequality Operator
SamplerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    SamplerDescription samplerDescription1,
    SamplerDescription samplerDescription2
)
Visual Basic
Public Shared Operator <> ( _
    samplerDescription1 As SamplerDescription, _
    samplerDescription2 As SamplerDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    SamplerDescription samplerDescription1,
    SamplerDescription samplerDescription2
)

Parameters

samplerDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerDescription
samplerDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerDescription

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SamplerDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Properties
SamplerDescription Structure See Also Send Feedback

The SamplerDescription type exposes the following members.

Properties

 | Name | Description
Public property | AddressU | Method to use for resolving a u texture coordinate that is outside the 0 to 1 range (see TextureAddressMode). (Also see DirectX SDK: D3D10_SAMPLER_DESC.AddressU)
Public property | AddressV | Method to use for resolving a v texture coordinate that is outside the 0 to 1 range. (Also see DirectX SDK: D3D10_SAMPLER_DESC.AddressV)
Public property | AddressW | Method to use for resolving a w texture coordinate that is outside the 0 to 1 range. (Also see DirectX SDK: D3D10_SAMPLER_DESC.AddressW)
Public property | BorderColor | Border color to use if Border is specified for AddressU, AddressV, or AddressW. Range must be between 0.0 and 1.0 inclusive. (Also see DirectX SDK: D3D10_SAMPLER_DESC.BorderColor)
Public property | ComparisonFunction | A function that compares sampled data against existing sampled data. The function options are listed in ComparisonFunction. (Also see DirectX SDK: D3D10_SAMPLER_DESC.ComparisonFunc)
Public property | Filter | Filtering method to use when sampling a texture (see Filter). (Also see DirectX SDK: D3D10_SAMPLER_DESC.Filter)
Public property | MaxAnisotropy | Clamping value used if Anisotropic or ComparisonAnisotropic is specified in Filter. Valid values are between 1 and 16. (Also see DirectX SDK: D3D10_SAMPLER_DESC.MaxAnisotropy)
Public property | MaximumLevelOfDetail | Upper end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. This value must be greater than or equal to MinimumLevelOfDetail. To have no upper limit on LOD set this to a large value such as D3D10_FLOAT32_MAX. (Also see DirectX SDK: D3D10_SAMPLER_DESC.MaxLOD)
Public property | MinimumLevelOfDetail | Lower end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. (Also see DirectX SDK: D3D10_SAMPLER_DESC.MinLOD)
Public property | MipLevelOfDetailBias | Offset from the calculated mipmap level. For example, if Direct3D calculates that a texture should be sampled at mipmap level 3 and MipLevelOfDetailBias is 2, then the texture will be sampled at mipmap level 5. (Also see DirectX SDK: D3D10_SAMPLER_DESC.MipLODBias)

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AddressU Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..AddressU Property
SamplerDescription Structure See Also Send Feedback
Method to use for resolving a u texture coordinate that is outside the 0 to 1 range (see TextureAddressMode).

(Also see DirectX SDK: D3D10_SAMPLER_DESC.AddressU)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureAddressMode AddressU { get; set; }
Visual Basic
Public Property AddressU As TextureAddressMode
    Get
    Set
Visual C++
public:
property TextureAddressMode AddressU {
    TextureAddressMode get ();
    void set (TextureAddressMode value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureAddressMode


AddressV Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..AddressV Property
SamplerDescription Structure See Also Send Feedback
Method to use for resolving a v texture coordinate that is outside the 0 to 1 range.

(Also see DirectX SDK: D3D10_SAMPLER_DESC.AddressV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureAddressMode AddressV { get; set; }
Visual Basic
Public Property AddressV As TextureAddressMode
    Get
    Set
Visual C++
public:
property TextureAddressMode AddressV {
    TextureAddressMode get ();
    void set (TextureAddressMode value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


AddressW Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..AddressW Property
SamplerDescription Structure See Also Send Feedback
Method to use for resolving a w texture coordinate that is outside the 0 to 1 range.

(Also see DirectX SDK: D3D10_SAMPLER_DESC.AddressW)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureAddressMode AddressW { get; set; }
Visual Basic
Public Property AddressW As TextureAddressMode
    Get
    Set
Visual C++
public:
property TextureAddressMode AddressW {
    TextureAddressMode get ();
    void set (TextureAddressMode value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BorderColor Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..BorderColor Property
SamplerDescription Structure See Also Send Feedback
Border color to use if Border is specified for AddressU, AddressV, or AddressW. Range must be between 0.0 and 1.0 inclusive.

(Also see DirectX SDK: D3D10_SAMPLER_DESC.BorderColor)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgba BorderColor { get; set; }
Visual Basic
Public Property BorderColor As ColorRgba
    Get
    Set
Visual C++
public:
property ColorRgba BorderColor {
    ColorRgba get ();
    void set (ColorRgba value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ComparisonFunction Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..ComparisonFunction Property
SamplerDescription Structure See Also Send Feedback
A function that compares sampled data against existing sampled data. The function options are listed in ComparisonFunction.

(Also see DirectX SDK: D3D10_SAMPLER_DESC.ComparisonFunc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComparisonFunction ComparisonFunction { get; set; }
Visual Basic
Public Property ComparisonFunction As ComparisonFunction
    Get
    Set
Visual C++
public:
property ComparisonFunction ComparisonFunction {
    ComparisonFunction get ();
    void set (ComparisonFunction value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Filter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..Filter Property
SamplerDescription Structure See Also Send Feedback
Filtering method to use when sampling a texture (see Filter).

(Also see DirectX SDK: D3D10_SAMPLER_DESC.Filter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Filter Filter { get; set; }
Visual Basic
Public Property Filter As Filter
    Get
    Set
Visual C++
public:
property Filter Filter {
    Filter get ();
    void set (Filter value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
SamplerDescription..::..Filter


MaxAnisotropy Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..MaxAnisotropy Property
SamplerDescription Structure See Also Send Feedback
Clamping value used if Anisotropic or ComparisonAnisotropic is specified in Filter. Valid values are between 1 and 16.

(Also see DirectX SDK: D3D10_SAMPLER_DESC.MaxAnisotropy)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MaxAnisotropy { get; set; }
Visual Basic
Public Property MaxAnisotropy As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MaxAnisotropy {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MaximumLevelOfDetail Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..MaximumLevelOfDetail Property
SamplerDescription Structure See Also Send Feedback
Upper end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. This value must be greater than or equal to MinimumLevelOfDetail. To have no upper limit on LOD set this to a large value such as D3D10_FLOAT32_MAX.

(Also see DirectX SDK: D3D10_SAMPLER_DESC.MaxLOD)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MaximumLevelOfDetail { get; set; }
Visual Basic
Public Property MaximumLevelOfDetail As Single
    Get
    Set
Visual C++
public:
property float MaximumLevelOfDetail {
    float get ();
    void set (float value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MinimumLevelOfDetail Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..MinimumLevelOfDetail Property
SamplerDescription Structure See Also Send Feedback
Lower end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed.

(Also see DirectX SDK: D3D10_SAMPLER_DESC.MinLOD)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MinimumLevelOfDetail { get; set; }
Visual Basic
Public Property MinimumLevelOfDetail As Single
    Get
    Set
Visual C++
public:
property float MinimumLevelOfDetail {
    float get ();
    void set (float value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevelOfDetailBias Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..MipLevelOfDetailBias Property
SamplerDescription Structure See Also Send Feedback
Offset from the calculated mipmap level. For example, if Direct3D calculates that a texture should be sampled at mipmap level 3 and MipLevelOfDetailBias is 2, then the texture will be sampled at mipmap level 5.

(Also see DirectX SDK: D3D10_SAMPLER_DESC.MipLODBias)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MipLevelOfDetailBias { get; set; }
Visual Basic
Public Property MipLevelOfDetailBias As Single
    Get
    Set
Visual C++
public:
property float MipLevelOfDetailBias {
    float get ();
    void set (float value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SamplerState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerState Class
Members See Also Send Feedback
A sampler-state interface accesses sampler state for a texture.

(Also see DirectX SDK: ID3D10SamplerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class SamplerState : DeviceChild
Visual Basic
Public Class SamplerState _
    Inherits DeviceChild
Visual C++
public ref class SamplerState : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerState

See Also

SamplerState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SamplerState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerState Members
SamplerState Class Properties See Also Send Feedback

The SamplerState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the sampler state. (Also see DirectX SDK: ID3D10SamplerState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

SamplerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SamplerState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerState Properties
SamplerState Class See Also Send Feedback

The SamplerState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the sampler state. (Also see DirectX SDK: ID3D10SamplerState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

SamplerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerState..::..Description Property
SamplerState Class See Also Send Feedback
Get the sampler state.

(Also see DirectX SDK: ID3D10SamplerState::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SamplerDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As SamplerDescription
    Get
Visual C++
public:
property SamplerDescription Description {
    SamplerDescription get ();
}

See Also

SamplerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderBufferDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription Structure
Members See Also Send Feedback
Describes a shader constant-buffer.

(Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ShaderBufferDescription
Visual Basic
Public Structure ShaderBufferDescription
Visual C++
public value class ShaderBufferDescription

See Also

ShaderBufferDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderBufferDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription Members
ShaderBufferDescription Structure Methods Operators Properties See Also Send Feedback

The ShaderBufferDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ConstantBufferType | The intended use of the constant data. See ConstantBufferType. (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Type)
Public property | Name | The name of the buffer. (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Name)
Public property | Options | Shader buffer properties. See ShaderConstantBufferFlags. (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.uFlags)
Public property | Size | Buffer size (in bytes). (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Size)
Public property | Variables | The number of unique variables. (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Variables)

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderBufferDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription Methods
ShaderBufferDescription Structure See Also Send Feedback

The ShaderBufferDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription..::..Equals Method
ShaderBufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription..::..GetHashCode Method
ShaderBufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderBufferDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription Operators
ShaderBufferDescription Structure See Also Send Feedback

The ShaderBufferDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription..::..Equality Operator
ShaderBufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ShaderBufferDescription shaderBufferDescription1,
    ShaderBufferDescription shaderBufferDescription2
)
Visual Basic
Public Shared Operator = ( _
    shaderBufferDescription1 As ShaderBufferDescription, _
    shaderBufferDescription2 As ShaderBufferDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    ShaderBufferDescription shaderBufferDescription1,
    ShaderBufferDescription shaderBufferDescription2
)

Parameters

shaderBufferDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderBufferDescription
shaderBufferDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderBufferDescription

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription..::..Inequality Operator
ShaderBufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ShaderBufferDescription shaderBufferDescription1,
    ShaderBufferDescription shaderBufferDescription2
)
Visual Basic
Public Shared Operator <> ( _
    shaderBufferDescription1 As ShaderBufferDescription, _
    shaderBufferDescription2 As ShaderBufferDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    ShaderBufferDescription shaderBufferDescription1,
    ShaderBufferDescription shaderBufferDescription2
)

Parameters

shaderBufferDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderBufferDescription
shaderBufferDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderBufferDescription

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderBufferDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription Properties
ShaderBufferDescription Structure See Also Send Feedback

The ShaderBufferDescription type exposes the following members.

Properties

 | Name | Description
Public property | ConstantBufferType | The intended use of the constant data. See ConstantBufferType. (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Type)
Public property | Name | The name of the buffer. (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Name)
Public property | Options | Shader buffer properties. See ShaderConstantBufferFlags. (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.uFlags)
Public property | Size | Buffer size (in bytes). (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Size)
Public property | Variables | The number of unique variables. (Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Variables)

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ConstantBufferType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription..::..ConstantBufferType Property
ShaderBufferDescription Structure See Also Send Feedback
The intended use of the constant data. See ConstantBufferType.

(Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Type)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ConstantBufferType ConstantBufferType { get; set; }
Visual Basic
Public Property ConstantBufferType As ConstantBufferType
    Get
    Set
Visual C++
public:
property ConstantBufferType ConstantBufferType {
    ConstantBufferType get ();
    void set (ConstantBufferType value);
}

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Name Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription..::..Name Property
ShaderBufferDescription Structure See Also Send Feedback
The name of the buffer.

(Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Name)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Options Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription..::..Options Property
ShaderBufferDescription Structure See Also Send Feedback
Shader buffer properties. See ShaderConstantBufferFlags.

(Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.uFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Options { get; set; }
Visual Basic
Public Property Options As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Options {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Size Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription..::..Size Property
ShaderBufferDescription Structure See Also Send Feedback
Buffer size (in bytes).

(Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Size)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Size { get; set; }
Visual Basic
Public Property Size As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Size {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Variables Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderBufferDescription..::..Variables Property
ShaderBufferDescription Structure See Also Send Feedback
The number of unique variables.

(Also see DirectX SDK: D3D10_SHADER_BUFFER_DESC.Variables)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Variables { get; set; }
Visual Basic
Public Property Variables As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Variables {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderBufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderConstantBufferProperties Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderConstantBufferProperties Enumeration
See Also Send Feedback
These flags identify constant-buffer properties.

(Also see DirectX SDK: D3D10_SHADER_CBUFFER_FLAGS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ShaderConstantBufferProperties
Visual Basic
<FlagsAttribute> _
Public Enumeration ShaderConstantBufferProperties
Visual C++
[FlagsAttribute]
public enum class ShaderConstantBufferProperties

Members

Member name | Description
None |
UserPacked |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderDebugRegisterType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDebugRegisterType Enumeration
See Also Send Feedback
Shader register types.

(Also see DirectX SDK: D3D10_SHADER_DEBUG_REGTYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ShaderDebugRegisterType
Visual Basic
Public Enumeration ShaderDebugRegisterType
Visual C++
public enum class ShaderDebugRegisterType

Members

Member name | Description
Unused |
ConstantBuffer |
Literal |
ImmediateConstantBuffer |
Sampler |
Texture |
TempArray |
Temp |
TextureBuffer |
Output |
Input |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderDebugScopeType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDebugScopeType Enumeration
See Also Send Feedback
Scope types.

(Also see DirectX SDK: D3D10_SHADER_DEBUG_SCOPETYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ShaderDebugScopeType
Visual Basic
Public Enumeration ShaderDebugScopeType
Visual C++
public enum class ShaderDebugScopeType

Members

Member name | Description
Namespace |
Block |
Annotation |
StateBlock |
FuncParams |
Struct |
ForLoop |
Global |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderDebugVariantType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDebugVariantType Enumeration
See Also Send Feedback
TBD

(Also see DirectX SDK: D3D10_SHADER_DEBUG_VARTYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ShaderDebugVariantType
Visual Basic
Public Enumeration ShaderDebugVariantType
Visual C++
public enum class ShaderDebugVariantType

Members

Member name | Description
Function |
Variable |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription Structure
Members See Also Send Feedback
Describes a shader.

(Also see DirectX SDK: D3D10_SHADER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ShaderDescription
Visual Basic
Public Structure ShaderDescription
Visual C++
public value class ShaderDescription

See Also

ShaderDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription Members
ShaderDescription Structure Methods Operators Properties See Also Send Feedback

The ShaderDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArrayInstructionCount | Number of array instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.ArrayInstructionCount)
Public property | BoundResources | The number of resource (textures and buffers) bound to a shader. (Also see DirectX SDK: D3D10_SHADER_DESC.BoundResources)
Public property | ConstantBuffers | The number of shader-constant buffers. (Also see DirectX SDK: D3D10_SHADER_DESC.ConstantBuffers)
Public property | Creator | The name of the originator of the shader. (Also see DirectX SDK: D3D10_SHADER_DESC.Creator)
Public property | CutInstructionCount | Number of cut instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.CutInstructionCount)
Public property | DeclarationCount | Number of declarations (input + output). (Also see DirectX SDK: D3D10_SHADER_DESC.DclCount)
Public property | DefCount | Number of constant defines. (Also see DirectX SDK: D3D10_SHADER_DESC.DefCount)
Public property | DynamicFlowControlCount | Number of dynamic flow control instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.DynamicFlowControlCount)
Public property | EmitInstructionCount | Number of emit instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.EmitInstructionCount)
Public property | FloatInstructionCount | Number of floating point arithmetic instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.FloatInstructionCount)
Public property | GeometryShaderMaxOutputVertexCount | Geometry shader maximum output vertex count. (Also see DirectX SDK: D3D10_SHADER_DESC.GSMaxOutputVertexCount)
Public property | GeometryShaderOutputTopology | Geometry shader output topology. (Also see DirectX SDK: D3D10_SHADER_DESC.GSOutputTopology)
Public property | InputParameters | The number of parameters in the input signature. (Also see DirectX SDK: D3D10_SHADER_DESC.InputParameters)
Public property | InstructionCount | The number of intermediate-language instructions in the compiled shader. (Also see DirectX SDK: D3D10_SHADER_DESC.InstructionCount)
Public property | IntegerInstructionCount | Number of signed integer arithmetic instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.IntInstructionCount)
Public property | MacroInstructionCount | Number of macro instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.MacroInstructionCount)
Public property | Options | Shader compilation/parse flags. (Also see DirectX SDK: D3D10_SHADER_DESC.Flags)
Public property | OutputParameters | The number of parameters in the output signature. (Also see DirectX SDK: D3D10_SHADER_DESC.OutputParameters)
Public property | StaticFlowControlCount | Number of static flow control instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.StaticFlowControlCount)
Public property | TempArrayCount | Number of temporary arrays used. (Also see DirectX SDK: D3D10_SHADER_DESC.TempArrayCount)
Public property | TempRegisterCount | The number of temporary registers in the compiled shader. (Also see DirectX SDK: D3D10_SHADER_DESC.TempRegisterCount)
Public property | TextureBiasInstructions | Number of texture bias instructions (Also see DirectX SDK: D3D10_SHADER_DESC.TextureBiasInstructions)
Public property | TextureCompInstructions | Number of texture comparison instructions (Also see DirectX SDK: D3D10_SHADER_DESC.TextureCompInstructions)
Public property | TextureGradientInstructions | Number of texture gradient instructions. (Also see DirectX SDK: D3D10_SHADER_DESC.TextureGradientInstructions)
Public property | TextureLoadInstructions | Number of texture load instructions (Also see DirectX SDK: D3D10_SHADER_DESC.TextureLoadInstructions)
Public property | TextureNormalInstructions | Number of non-categorized texture instructions. (Also see DirectX SDK: D3D10_SHADER_DESC.TextureNormalInstructions)
Public property | UnsignedIntegerInstructionCount | Number of unsigned integer arithmetic instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.UintInstructionCount)
Public property | Version | Shader version. (Also see DirectX SDK: D3D10_SHADER_DESC.Version)

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription Methods
ShaderDescription Structure See Also Send Feedback

The ShaderDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..Equals Method
ShaderDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..GetHashCode Method
ShaderDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription Operators
ShaderDescription Structure See Also Send Feedback

The ShaderDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..Equality Operator
ShaderDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ShaderDescription shaderDescription1,
    ShaderDescription shaderDescription2
)
Visual Basic
Public Shared Operator = ( _
    shaderDescription1 As ShaderDescription, _
    shaderDescription2 As ShaderDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    ShaderDescription shaderDescription1,
    ShaderDescription shaderDescription2
)

Parameters

shaderDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderDescription
shaderDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderDescription

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..Inequality Operator
ShaderDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ShaderDescription shaderDescription1,
    ShaderDescription shaderDescription2
)
Visual Basic
Public Shared Operator <> ( _
    shaderDescription1 As ShaderDescription, _
    shaderDescription2 As ShaderDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    ShaderDescription shaderDescription1,
    ShaderDescription shaderDescription2
)

Parameters

shaderDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderDescription
shaderDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderDescription

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription Properties
ShaderDescription Structure See Also Send Feedback

The ShaderDescription type exposes the following members.

Properties

 | Name | Description
Public property | ArrayInstructionCount | Number of array instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.ArrayInstructionCount)
Public property | BoundResources | The number of resource (textures and buffers) bound to a shader. (Also see DirectX SDK: D3D10_SHADER_DESC.BoundResources)
Public property | ConstantBuffers | The number of shader-constant buffers. (Also see DirectX SDK: D3D10_SHADER_DESC.ConstantBuffers)
Public property | Creator | The name of the originator of the shader. (Also see DirectX SDK: D3D10_SHADER_DESC.Creator)
Public property | CutInstructionCount | Number of cut instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.CutInstructionCount)
Public property | DeclarationCount | Number of declarations (input + output). (Also see DirectX SDK: D3D10_SHADER_DESC.DclCount)
Public property | DefCount | Number of constant defines. (Also see DirectX SDK: D3D10_SHADER_DESC.DefCount)
Public property | DynamicFlowControlCount | Number of dynamic flow control instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.DynamicFlowControlCount)
Public property | EmitInstructionCount | Number of emit instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.EmitInstructionCount)
Public property | FloatInstructionCount | Number of floating point arithmetic instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.FloatInstructionCount)
Public property | GeometryShaderMaxOutputVertexCount | Geometry shader maximum output vertex count. (Also see DirectX SDK: D3D10_SHADER_DESC.GSMaxOutputVertexCount)
Public property | GeometryShaderOutputTopology | Geometry shader output topology. (Also see DirectX SDK: D3D10_SHADER_DESC.GSOutputTopology)
Public property | InputParameters | The number of parameters in the input signature. (Also see DirectX SDK: D3D10_SHADER_DESC.InputParameters)
Public property | InstructionCount | The number of intermediate-language instructions in the compiled shader. (Also see DirectX SDK: D3D10_SHADER_DESC.InstructionCount)
Public property | IntegerInstructionCount | Number of signed integer arithmetic instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.IntInstructionCount)
Public property | MacroInstructionCount | Number of macro instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.MacroInstructionCount)
Public property | Options | Shader compilation/parse flags. (Also see DirectX SDK: D3D10_SHADER_DESC.Flags)
Public property | OutputParameters | The number of parameters in the output signature. (Also see DirectX SDK: D3D10_SHADER_DESC.OutputParameters)
Public property | StaticFlowControlCount | Number of static flow control instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.StaticFlowControlCount)
Public property | TempArrayCount | Number of temporary arrays used. (Also see DirectX SDK: D3D10_SHADER_DESC.TempArrayCount)
Public property | TempRegisterCount | The number of temporary registers in the compiled shader. (Also see DirectX SDK: D3D10_SHADER_DESC.TempRegisterCount)
Public property | TextureBiasInstructions | Number of texture bias instructions (Also see DirectX SDK: D3D10_SHADER_DESC.TextureBiasInstructions)
Public property | TextureCompInstructions | Number of texture comparison instructions (Also see DirectX SDK: D3D10_SHADER_DESC.TextureCompInstructions)
Public property | TextureGradientInstructions | Number of texture gradient instructions. (Also see DirectX SDK: D3D10_SHADER_DESC.TextureGradientInstructions)
Public property | TextureLoadInstructions | Number of texture load instructions (Also see DirectX SDK: D3D10_SHADER_DESC.TextureLoadInstructions)
Public property | TextureNormalInstructions | Number of non-categorized texture instructions. (Also see DirectX SDK: D3D10_SHADER_DESC.TextureNormalInstructions)
Public property | UnsignedIntegerInstructionCount | Number of unsigned integer arithmetic instructions used. (Also see DirectX SDK: D3D10_SHADER_DESC.UintInstructionCount)
Public property | Version | Shader version. (Also see DirectX SDK: D3D10_SHADER_DESC.Version)

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArrayInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..ArrayInstructionCount Property
ShaderDescription Structure See Also Send Feedback
Number of array instructions used.

(Also see DirectX SDK: D3D10_SHADER_DESC.ArrayInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArrayInstructionCount { get; set; }
Visual Basic
Public Property ArrayInstructionCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArrayInstructionCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BoundResources Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..BoundResources Property
ShaderDescription Structure See Also Send Feedback
The number of resource (textures and buffers) bound to a shader.

(Also see DirectX SDK: D3D10_SHADER_DESC.BoundResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BoundResources { get; set; }
Visual Basic
Public Property BoundResources As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BoundResources {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ConstantBuffers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..ConstantBuffers Property
ShaderDescription Structure See Also Send Feedback
The number of shader-constant buffers.

(Also see DirectX SDK: D3D10_SHADER_DESC.ConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ConstantBuffers { get; set; }
Visual Basic
Public Property ConstantBuffers As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ConstantBuffers {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Creator Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..Creator Property
ShaderDescription Structure See Also Send Feedback
The name of the originator of the shader.

(Also see DirectX SDK: D3D10_SHADER_DESC.Creator)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Creator { get; set; }
Visual Basic
Public Property Creator As String
    Get
    Set
Visual C++
public:
property String^ Creator {
    String^ get ();
    void set (String^ value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CutInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..CutInstructionCount Property
ShaderDescription Structure See Also Send Feedback
Number of cut instructions used.

(Also see DirectX SDK: D3D10_SHADER_DESC.CutInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint CutInstructionCount { get; set; }
Visual Basic
Public Property CutInstructionCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int CutInstructionCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DeclarationCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..DeclarationCount Property
ShaderDescription Structure See Also Send Feedback
Number of declarations (input + output).

(Also see DirectX SDK: D3D10_SHADER_DESC.DclCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DeclarationCount { get; set; }
Visual Basic
Public Property DeclarationCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DeclarationCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DefCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..DefCount Property
ShaderDescription Structure See Also Send Feedback
Number of constant defines.

(Also see DirectX SDK: D3D10_SHADER_DESC.DefCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DefCount { get; set; }
Visual Basic
Public Property DefCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DefCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DynamicFlowControlCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..DynamicFlowControlCount Property
ShaderDescription Structure See Also Send Feedback
Number of dynamic flow control instructions used.

(Also see DirectX SDK: D3D10_SHADER_DESC.DynamicFlowControlCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DynamicFlowControlCount { get; set; }
Visual Basic
Public Property DynamicFlowControlCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DynamicFlowControlCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EmitInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..EmitInstructionCount Property
ShaderDescription Structure See Also Send Feedback
Number of emit instructions used.

(Also see DirectX SDK: D3D10_SHADER_DESC.EmitInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint EmitInstructionCount { get; set; }
Visual Basic
Public Property EmitInstructionCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int EmitInstructionCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FloatInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..FloatInstructionCount Property
ShaderDescription Structure See Also Send Feedback
Number of floating point arithmetic instructions used.

(Also see DirectX SDK: D3D10_SHADER_DESC.FloatInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FloatInstructionCount { get; set; }
Visual Basic
Public Property FloatInstructionCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FloatInstructionCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderMaxOutputVertexCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..GeometryShaderMaxOutputVertexCount Property
ShaderDescription Structure See Also Send Feedback
Geometry shader maximum output vertex count.

(Also see DirectX SDK: D3D10_SHADER_DESC.GSMaxOutputVertexCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint GeometryShaderMaxOutputVertexCount { get; set; }
Visual Basic
Public Property GeometryShaderMaxOutputVertexCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int GeometryShaderMaxOutputVertexCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderOutputTopology Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..GeometryShaderOutputTopology Property
ShaderDescription Structure See Also Send Feedback
Geometry shader output topology.

(Also see DirectX SDK: D3D10_SHADER_DESC.GSOutputTopology)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PrimitiveTopology GeometryShaderOutputTopology { get; set; }
Visual Basic
Public Property GeometryShaderOutputTopology As PrimitiveTopology
    Get
    Set
Visual C++
public:
property PrimitiveTopology GeometryShaderOutputTopology {
    PrimitiveTopology get ();
    void set (PrimitiveTopology value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputParameters Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..InputParameters Property
ShaderDescription Structure See Also Send Feedback
The number of parameters in the input signature.

(Also see DirectX SDK: D3D10_SHADER_DESC.InputParameters)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InputParameters { get; set; }
Visual Basic
Public Property InputParameters As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InputParameters {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..InstructionCount Property
ShaderDescription Structure See Also Send Feedback
The number of intermediate-language instructions in the compiled shader.

(Also see DirectX SDK: D3D10_SHADER_DESC.InstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InstructionCount { get; set; }
Visual Basic
Public Property InstructionCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InstructionCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IntegerInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..IntegerInstructionCount Property
ShaderDescription Structure See Also Send Feedback
Number of signed integer arithmetic instructions used.

(Also see DirectX SDK: D3D10_SHADER_DESC.IntInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint IntegerInstructionCount { get; set; }
Visual Basic
Public Property IntegerInstructionCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int IntegerInstructionCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MacroInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..MacroInstructionCount Property
ShaderDescription Structure See Also Send Feedback
Number of macro instructions used.

(Also see DirectX SDK: D3D10_SHADER_DESC.MacroInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MacroInstructionCount { get; set; }
Visual Basic
Public Property MacroInstructionCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MacroInstructionCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Options Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..Options Property
ShaderDescription Structure See Also Send Feedback
Shader compilation/parse flags.

(Also see DirectX SDK: D3D10_SHADER_DESC.Flags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Options { get; set; }
Visual Basic
Public Property Options As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Options {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputParameters Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..OutputParameters Property
ShaderDescription Structure See Also Send Feedback
The number of parameters in the output signature.

(Also see DirectX SDK: D3D10_SHADER_DESC.OutputParameters)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint OutputParameters { get; set; }
Visual Basic
Public Property OutputParameters As UInteger
    Get
    Set
Visual C++
public:
property unsigned int OutputParameters {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StaticFlowControlCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..StaticFlowControlCount Property
ShaderDescription Structure See Also Send Feedback
Number of static flow control instructions used.

(Also see DirectX SDK: D3D10_SHADER_DESC.StaticFlowControlCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint StaticFlowControlCount { get; set; }
Visual Basic
Public Property StaticFlowControlCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int StaticFlowControlCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TempArrayCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..TempArrayCount Property
ShaderDescription Structure See Also Send Feedback
Number of temporary arrays used.

(Also see DirectX SDK: D3D10_SHADER_DESC.TempArrayCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TempArrayCount { get; set; }
Visual Basic
Public Property TempArrayCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TempArrayCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TempRegisterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..TempRegisterCount Property
ShaderDescription Structure See Also Send Feedback
The number of temporary registers in the compiled shader.

(Also see DirectX SDK: D3D10_SHADER_DESC.TempRegisterCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TempRegisterCount { get; set; }
Visual Basic
Public Property TempRegisterCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TempRegisterCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureBiasInstructions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..TextureBiasInstructions Property
ShaderDescription Structure See Also Send Feedback
Number of texture bias instructions

(Also see DirectX SDK: D3D10_SHADER_DESC.TextureBiasInstructions)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TextureBiasInstructions { get; set; }
Visual Basic
Public Property TextureBiasInstructions As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TextureBiasInstructions {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCompInstructions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..TextureCompInstructions Property
ShaderDescription Structure See Also Send Feedback
Number of texture comparison instructions

(Also see DirectX SDK: D3D10_SHADER_DESC.TextureCompInstructions)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TextureCompInstructions { get; set; }
Visual Basic
Public Property TextureCompInstructions As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TextureCompInstructions {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureGradientInstructions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..TextureGradientInstructions Property
ShaderDescription Structure See Also Send Feedback
Number of texture gradient instructions.

(Also see DirectX SDK: D3D10_SHADER_DESC.TextureGradientInstructions)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TextureGradientInstructions { get; set; }
Visual Basic
Public Property TextureGradientInstructions As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TextureGradientInstructions {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureLoadInstructions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..TextureLoadInstructions Property
ShaderDescription Structure See Also Send Feedback
Number of texture load instructions

(Also see DirectX SDK: D3D10_SHADER_DESC.TextureLoadInstructions)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TextureLoadInstructions { get; set; }
Visual Basic
Public Property TextureLoadInstructions As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TextureLoadInstructions {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureNormalInstructions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..TextureNormalInstructions Property
ShaderDescription Structure See Also Send Feedback
Number of non-categorized texture instructions.

(Also see DirectX SDK: D3D10_SHADER_DESC.TextureNormalInstructions)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TextureNormalInstructions { get; set; }
Visual Basic
Public Property TextureNormalInstructions As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TextureNormalInstructions {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UnsignedIntegerInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..UnsignedIntegerInstructionCount Property
ShaderDescription Structure See Also Send Feedback
Number of unsigned integer arithmetic instructions used.

(Also see DirectX SDK: D3D10_SHADER_DESC.UintInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint UnsignedIntegerInstructionCount { get; set; }
Visual Basic
Public Property UnsignedIntegerInstructionCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int UnsignedIntegerInstructionCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Version Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderDescription..::..Version Property
ShaderDescription Structure See Also Send Feedback
Shader version.

(Also see DirectX SDK: D3D10_SHADER_DESC.Version)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Version { get; set; }
Visual Basic
Public Property Version As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Version {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderInputBindDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription Structure
Members See Also Send Feedback
Describes how a shader resource is bound to a shader input.

(Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ShaderInputBindDescription
Visual Basic
Public Structure ShaderInputBindDescription
Visual C++
public value class ShaderInputBindDescription

See Also

ShaderInputBindDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderInputBindDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription Members
ShaderInputBindDescription Structure Methods Operators Properties See Also Send Feedback

The ShaderInputBindDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BindCount | Number of contiguous bind points for arrays. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.BindCount)
Public property | BindPoint | Starting bind point. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.BindPoint)
Public property | Dimension | Identifies the amount of data in the resource. See ShaderResourceViewDimension. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.Dimension)
Public property | Name | Name of the shader resource. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.Name)
Public property | ReturnType | If the input is a texture, the return type. See ResourceReturnType. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.ReturnType)
Public property | SampleCount | The number of samples for a multisampled texture; otherwise 0. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.NumSamples)
Public property | ShaderInputOptions | Shader input-parameter options. See ShaderInputOptions. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.uFlags)
Public property | ShaderInputType | Identifies the type of data in the resource. See ShaderInputType. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.Type)

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderInputBindDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription Methods
ShaderInputBindDescription Structure See Also Send Feedback

The ShaderInputBindDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..Equals Method
ShaderInputBindDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..GetHashCode Method
ShaderInputBindDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderInputBindDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription Operators
ShaderInputBindDescription Structure See Also Send Feedback

The ShaderInputBindDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..Equality Operator
ShaderInputBindDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ShaderInputBindDescription shaderInputBindDescription1,
    ShaderInputBindDescription shaderInputBindDescription2
)
Visual Basic
Public Shared Operator = ( _
    shaderInputBindDescription1 As ShaderInputBindDescription, _
    shaderInputBindDescription2 As ShaderInputBindDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    ShaderInputBindDescription shaderInputBindDescription1,
    ShaderInputBindDescription shaderInputBindDescription2
)

Parameters

shaderInputBindDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderInputBindDescription
shaderInputBindDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderInputBindDescription

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..Inequality Operator
ShaderInputBindDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ShaderInputBindDescription shaderInputBindDescription1,
    ShaderInputBindDescription shaderInputBindDescription2
)
Visual Basic
Public Shared Operator <> ( _
    shaderInputBindDescription1 As ShaderInputBindDescription, _
    shaderInputBindDescription2 As ShaderInputBindDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    ShaderInputBindDescription shaderInputBindDescription1,
    ShaderInputBindDescription shaderInputBindDescription2
)

Parameters

shaderInputBindDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderInputBindDescription
shaderInputBindDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderInputBindDescription

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderInputBindDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription Properties
ShaderInputBindDescription Structure See Also Send Feedback

The ShaderInputBindDescription type exposes the following members.

Properties

 | Name | Description
Public property | BindCount | Number of contiguous bind points for arrays. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.BindCount)
Public property | BindPoint | Starting bind point. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.BindPoint)
Public property | Dimension | Identifies the amount of data in the resource. See ShaderResourceViewDimension. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.Dimension)
Public property | Name | Name of the shader resource. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.Name)
Public property | ReturnType | If the input is a texture, the return type. See ResourceReturnType. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.ReturnType)
Public property | SampleCount | The number of samples for a multisampled texture; otherwise 0. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.NumSamples)
Public property | ShaderInputOptions | Shader input-parameter options. See ShaderInputOptions. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.uFlags)
Public property | ShaderInputType | Identifies the type of data in the resource. See ShaderInputType. (Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.Type)

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BindCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..BindCount Property
ShaderInputBindDescription Structure See Also Send Feedback
Number of contiguous bind points for arrays.

(Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.BindCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BindCount { get; set; }
Visual Basic
Public Property BindCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BindCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BindPoint Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..BindPoint Property
ShaderInputBindDescription Structure See Also Send Feedback
Starting bind point.

(Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.BindPoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BindPoint { get; set; }
Visual Basic
Public Property BindPoint As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BindPoint {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Dimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..Dimension Property
ShaderInputBindDescription Structure See Also Send Feedback
Identifies the amount of data in the resource. See ShaderResourceViewDimension.

(Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.Dimension)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceViewDimension Dimension { get; set; }
Visual Basic
Public Property Dimension As ShaderResourceViewDimension
    Get
    Set
Visual C++
public:
property ShaderResourceViewDimension Dimension {
    ShaderResourceViewDimension get ();
    void set (ShaderResourceViewDimension value);
}

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Name Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..Name Property
ShaderInputBindDescription Structure See Also Send Feedback
Name of the shader resource.

(Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.Name)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ReturnType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..ReturnType Property
ShaderInputBindDescription Structure See Also Send Feedback
If the input is a texture, the return type. See ResourceReturnType.

(Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.ReturnType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ResourceReturnType ReturnType { get; set; }
Visual Basic
Public Property ReturnType As ResourceReturnType
    Get
    Set
Visual C++
public:
property ResourceReturnType ReturnType {
    ResourceReturnType get ();
    void set (ResourceReturnType value);
}

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SampleCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..SampleCount Property
ShaderInputBindDescription Structure See Also Send Feedback
The number of samples for a multisampled texture; otherwise 0.

(Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.NumSamples)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SampleCount { get; set; }
Visual Basic
Public Property SampleCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SampleCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderInputOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..ShaderInputOptions Property
ShaderInputBindDescription Structure See Also Send Feedback
Shader input-parameter options. See ShaderInputOptions.

(Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.uFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderInputOptions ShaderInputOptions { get; set; }
Visual Basic
Public Property ShaderInputOptions As ShaderInputOptions
    Get
    Set
Visual C++
public:
property ShaderInputOptions ShaderInputOptions {
    ShaderInputOptions get ();
    void set (ShaderInputOptions value);
}

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderInputType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputBindDescription..::..ShaderInputType Property
ShaderInputBindDescription Structure See Also Send Feedback
Identifies the type of data in the resource. See ShaderInputType.

(Also see DirectX SDK: D3D10_SHADER_INPUT_BIND_DESC.Type)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderInputType ShaderInputType { get; set; }
Visual Basic
Public Property ShaderInputType As ShaderInputType
    Get
    Set
Visual C++
public:
property ShaderInputType ShaderInputType {
    ShaderInputType get ();
    void set (ShaderInputType value);
}

See Also

ShaderInputBindDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderInputOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputOptions Enumeration
See Also Send Feedback
These flags identify shader-input options.

(Also see DirectX SDK: D3D10_SHADER_INPUT_FLAGS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ShaderInputOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration ShaderInputOptions
Visual C++
[FlagsAttribute]
public enum class ShaderInputOptions

Members

Member name | Description
TextureComponents |
TextureComponent1 |
TextureComponent0 |
ComparisonSampler |
UserPacked |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderInputType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderInputType Enumeration
See Also Send Feedback
These flags identify a shader-resource type.

(Also see DirectX SDK: D3D10_SHADER_INPUT_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ShaderInputType
Visual Basic
Public Enumeration ShaderInputType
Visual C++
public enum class ShaderInputType

Members

Member name | Description
ConstantBuffer |
Sampler |
Texture |
TextureBuffer |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflection Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection Class
Members See Also Send Feedback
A shader-reflection interface accesses shader information.

(Also see DirectX SDK: ID3D10ShaderReflection)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ShaderReflection : DirectUnknown
Visual Basic
Public Class ShaderReflection _
    Inherits DirectUnknown
Visual C++
public ref class ShaderReflection : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflection

See Also

ShaderReflection Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflection Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection Members
ShaderReflection Class Methods Properties See Also Send Feedback

The ShaderReflection type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBufferByIndex | Get a constant buffer by index. (Also see DirectX SDK: ID3D10ShaderReflection::GetConstantBufferByIndex)
Public method | GetConstantBufferByName | Get a constant buffer by name. (Also see DirectX SDK: ID3D10ShaderReflection::GetConstantBufferByName)
Public method | GetInputParameterDescription | Get an input-parameter description for a shader. (Also see DirectX SDK: ID3D10ShaderReflection::GetInputParameterDesc)
Public method | GetOutputParameterDescription | Get an output-parameter description for a shader. (Also see DirectX SDK: ID3D10ShaderReflection::GetOutputParameterDesc)
Public method | GetResourceBindingDescription | Get a description of the resources bound to a shader. (Also see DirectX SDK: ID3D10ShaderReflection::GetResourceBindingDesc)

Properties

 | Name | Description
Public property | Description | Get a shader description. (Also see DirectX SDK: ID3D10ShaderReflection::GetDesc)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ShaderReflection Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflection Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection Methods
ShaderReflection Class See Also Send Feedback

The ShaderReflection type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBufferByIndex | Get a constant buffer by index. (Also see DirectX SDK: ID3D10ShaderReflection::GetConstantBufferByIndex)
Public method | GetConstantBufferByName | Get a constant buffer by name. (Also see DirectX SDK: ID3D10ShaderReflection::GetConstantBufferByName)
Public method | GetInputParameterDescription | Get an input-parameter description for a shader. (Also see DirectX SDK: ID3D10ShaderReflection::GetInputParameterDesc)
Public method | GetOutputParameterDescription | Get an output-parameter description for a shader. (Also see DirectX SDK: ID3D10ShaderReflection::GetOutputParameterDesc)
Public method | GetResourceBindingDescription | Get a description of the resources bound to a shader. (Also see DirectX SDK: ID3D10ShaderReflection::GetResourceBindingDesc)

See Also

ShaderReflection Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetConstantBufferByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection..::..GetConstantBufferByIndex Method
ShaderReflection Class See Also Send Feedback
Get a constant buffer by index.

(Also see DirectX SDK: ID3D10ShaderReflection::GetConstantBufferByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderReflectionConstantBuffer GetConstantBufferByIndex(
    uint index
)
Visual Basic
Public Function GetConstantBufferByIndex ( _
    index As UInteger _
) As ShaderReflectionConstantBuffer
Visual C++
public:
ShaderReflectionConstantBuffer^ GetConstantBufferByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Zero-based index.

Return Value

A shader reflection constant bufer.

See Also

ShaderReflection Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetConstantBufferByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection..::..GetConstantBufferByName Method
ShaderReflection Class See Also Send Feedback
Get a constant buffer by name.

(Also see DirectX SDK: ID3D10ShaderReflection::GetConstantBufferByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderReflectionConstantBuffer GetConstantBufferByName(
    string name
)
Visual Basic
Public Function GetConstantBufferByName ( _
    name As String _
) As ShaderReflectionConstantBuffer
Visual C++
public:
ShaderReflectionConstantBuffer^ GetConstantBufferByName(
    String^ name
)

Parameters

name
Type: System..::..String
The constant-buffer name.

Return Value

A shader reflection constant bufer.

See Also

ShaderReflection Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetInputParameterDescription Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection..::..GetInputParameterDescription Method
ShaderReflection Class See Also Send Feedback
Get an input-parameter description for a shader.

(Also see DirectX SDK: ID3D10ShaderReflection::GetInputParameterDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SignatureParameterDescription GetInputParameterDescription(
    uint parameterIndex
)
Visual Basic
Public Function GetInputParameterDescription ( _
    parameterIndex As UInteger _
) As SignatureParameterDescription
Visual C++
public:
SignatureParameterDescription GetInputParameterDescription(
    unsigned int parameterIndex
)

Parameters

parameterIndex
Type: System..::..UInt32
A zero-based parameter index.

Return Value

A shader-input-signature description. See SignatureParameterDescription.

See Also

ShaderReflection Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetOutputParameterDescription Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection..::..GetOutputParameterDescription Method
ShaderReflection Class See Also Send Feedback
Get an output-parameter description for a shader.

(Also see DirectX SDK: ID3D10ShaderReflection::GetOutputParameterDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SignatureParameterDescription GetOutputParameterDescription(
    uint parameterIndex
)
Visual Basic
Public Function GetOutputParameterDescription ( _
    parameterIndex As UInteger _
) As SignatureParameterDescription
Visual C++
public:
SignatureParameterDescription GetOutputParameterDescription(
    unsigned int parameterIndex
)

Parameters

parameterIndex
Type: System..::..UInt32
A zero-based parameter index.

Return Value

A shader-output-parameter description. See SignatureParameterDescription.

See Also

ShaderReflection Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetResourceBindingDescription Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection..::..GetResourceBindingDescription Method
ShaderReflection Class See Also Send Feedback
Get a description of the resources bound to a shader.

(Also see DirectX SDK: ID3D10ShaderReflection::GetResourceBindingDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderInputBindDescription GetResourceBindingDescription(
    uint resourceIndex
)
Visual Basic
Public Function GetResourceBindingDescription ( _
    resourceIndex As UInteger _
) As ShaderInputBindDescription
Visual C++
public:
ShaderInputBindDescription GetResourceBindingDescription(
    unsigned int resourceIndex
)

Parameters

resourceIndex
Type: System..::..UInt32
A zero-based resource index.

Return Value

A input-binding description. See ShaderInputBindDescription.

See Also

ShaderReflection Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflection Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection Properties
ShaderReflection Class See Also Send Feedback

The ShaderReflection type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get a shader description. (Also see DirectX SDK: ID3D10ShaderReflection::GetDesc)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ShaderReflection Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection..::..Description Property
ShaderReflection Class See Also Send Feedback
Get a shader description.

(Also see DirectX SDK: ID3D10ShaderReflection::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As ShaderDescription
    Get
Visual C++
public:
property ShaderDescription Description {
    ShaderDescription get ();
}

See Also

ShaderReflection Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflection1 Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1 Class
Members See Also Send Feedback
A shader-reflection interface accesses shader information.

(Also see DirectX SDK: ID3D10ShaderReflection1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ShaderReflection1 : DirectUnknown
Visual Basic
Public Class ShaderReflection1 _
    Inherits DirectUnknown
Visual C++
public ref class ShaderReflection1 : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflection1

See Also

ShaderReflection1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflection1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1 Members
ShaderReflection1 Class Methods Properties See Also Send Feedback

The ShaderReflection1 type exposes the following members.

Methods

 | Name | Description
Public method | GetResourceBindingDescriptionByName | Gets a variable by name. (Also see DirectX SDK: ID3D10ShaderReflection1::GetResourceBindingDescByName)
Public method | GetVariableByName | Gets a variable by name. (Also see DirectX SDK: ID3D10ShaderReflection1::GetVariableByName)

Properties

 | Name | Description
Public property | BitwiseInstructionCount | Gets the number of bitwise instructions. (Also see DirectX SDK: ID3D10ShaderReflection1::GetBitwiseInstructionCount)
Public property | ConversionInstructionCount | Gets the number of Conversion instructions. (Also see DirectX SDK: ID3D10ShaderReflection1::GetConversionInstructionCount)
Public property | GSInputPrimitive | Gets the geometry-shader input-primitive description. (Also see DirectX SDK: ID3D10ShaderReflection1::GetGSInputPrimitive)
Public property | IsLevel9Shader | Is Level9 Shader (Also see DirectX SDK: ID3D10ShaderReflection1::IsLevel9Shader)
Public property | IsSampleFrequencyShader | TBD (Also see DirectX SDK: ID3D10ShaderReflection1::IsSampleFrequencyShader)
Public property | MovcInstructionCount | Gets the number of Movc instructions. (Also see DirectX SDK: ID3D10ShaderReflection1::GetMovcInstructionCount)
Public property | MovInstructionCount | Gets the number of Mov instructions. (Also see DirectX SDK: ID3D10ShaderReflection1::GetMovInstructionCount)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflection1 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1 Methods
ShaderReflection1 Class See Also Send Feedback

The ShaderReflection1 type exposes the following members.

Methods

 | Name | Description
Public method | GetResourceBindingDescriptionByName | Gets a variable by name. (Also see DirectX SDK: ID3D10ShaderReflection1::GetResourceBindingDescByName)
Public method | GetVariableByName | Gets a variable by name. (Also see DirectX SDK: ID3D10ShaderReflection1::GetVariableByName)

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetResourceBindingDescriptionByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1..::..GetResourceBindingDescriptionByName Method
ShaderReflection1 Class See Also Send Feedback
Gets a variable by name.

(Also see DirectX SDK: ID3D10ShaderReflection1::GetResourceBindingDescByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderInputBindDescription GetResourceBindingDescriptionByName(
    string name
)
Visual Basic
Public Function GetResourceBindingDescriptionByName ( _
    name As String _
) As ShaderInputBindDescription
Visual C++
public:
ShaderInputBindDescription GetResourceBindingDescriptionByName(
    String^ name
)

Parameters

name
Type: System..::..String
A string containing the variable name.

Return Value

ShaderInputBindDescription object.

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetVariableByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1..::..GetVariableByName Method
ShaderReflection1 Class See Also Send Feedback
Gets a variable by name.

(Also see DirectX SDK: ID3D10ShaderReflection1::GetVariableByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderReflectionVariable GetVariableByName(
    string name
)
Visual Basic
Public Function GetVariableByName ( _
    name As String _
) As ShaderReflectionVariable
Visual C++
public:
ShaderReflectionVariable^ GetVariableByName(
    String^ name
)

Parameters

name
Type: System..::..String
A string containing the variable name.

Return Value

ShaderReflectionVariable object.

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflection1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1 Properties
ShaderReflection1 Class See Also Send Feedback

The ShaderReflection1 type exposes the following members.

Properties

 | Name | Description
Public property | BitwiseInstructionCount | Gets the number of bitwise instructions. (Also see DirectX SDK: ID3D10ShaderReflection1::GetBitwiseInstructionCount)
Public property | ConversionInstructionCount | Gets the number of Conversion instructions. (Also see DirectX SDK: ID3D10ShaderReflection1::GetConversionInstructionCount)
Public property | GSInputPrimitive | Gets the geometry-shader input-primitive description. (Also see DirectX SDK: ID3D10ShaderReflection1::GetGSInputPrimitive)
Public property | IsLevel9Shader | Is Level9 Shader (Also see DirectX SDK: ID3D10ShaderReflection1::IsLevel9Shader)
Public property | IsSampleFrequencyShader | TBD (Also see DirectX SDK: ID3D10ShaderReflection1::IsSampleFrequencyShader)
Public property | MovcInstructionCount | Gets the number of Movc instructions. (Also see DirectX SDK: ID3D10ShaderReflection1::GetMovcInstructionCount)
Public property | MovInstructionCount | Gets the number of Mov instructions. (Also see DirectX SDK: ID3D10ShaderReflection1::GetMovInstructionCount)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BitwiseInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1..::..BitwiseInstructionCount Property
ShaderReflection1 Class See Also Send Feedback
Gets the number of bitwise instructions.

(Also see DirectX SDK: ID3D10ShaderReflection1::GetBitwiseInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BitwiseInstructionCount { get; }
Visual Basic
Public ReadOnly Property BitwiseInstructionCount As UInteger
    Get
Visual C++
public:
property unsigned int BitwiseInstructionCount {
    unsigned int get ();
}

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ConversionInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1..::..ConversionInstructionCount Property
ShaderReflection1 Class See Also Send Feedback
Gets the number of Conversion instructions.

(Also see DirectX SDK: ID3D10ShaderReflection1::GetConversionInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ConversionInstructionCount { get; }
Visual Basic
Public ReadOnly Property ConversionInstructionCount As UInteger
    Get
Visual C++
public:
property unsigned int ConversionInstructionCount {
    unsigned int get ();
}

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GSInputPrimitive Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1..::..GSInputPrimitive Property
ShaderReflection1 Class See Also Send Feedback
Gets the geometry-shader input-primitive description.

(Also see DirectX SDK: ID3D10ShaderReflection1::GetGSInputPrimitive)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Primitive GSInputPrimitive { get; }
Visual Basic
Public ReadOnly Property GSInputPrimitive As Primitive
    Get
Visual C++
public:
property Primitive GSInputPrimitive {
    Primitive get ();
}

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsLevel9Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1..::..IsLevel9Shader Property
ShaderReflection1 Class See Also Send Feedback
Is Level9 Shader

(Also see DirectX SDK: ID3D10ShaderReflection1::IsLevel9Shader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsLevel9Shader { get; }
Visual Basic
Public ReadOnly Property IsLevel9Shader As Boolean
    Get
Visual C++
public:
property bool IsLevel9Shader {
    bool get ();
}

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


IsSampleFrequencyShader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1..::..IsSampleFrequencyShader Property
ShaderReflection1 Class See Also Send Feedback
TBD

(Also see DirectX SDK: ID3D10ShaderReflection1::IsSampleFrequencyShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsSampleFrequencyShader { get; }
Visual Basic
Public ReadOnly Property IsSampleFrequencyShader As Boolean
    Get
Visual C++
public:
property bool IsSampleFrequencyShader {
    bool get ();
}

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MovcInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1..::..MovcInstructionCount Property
ShaderReflection1 Class See Also Send Feedback
Gets the number of Movc instructions.

(Also see DirectX SDK: ID3D10ShaderReflection1::GetMovcInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MovcInstructionCount { get; }
Visual Basic
Public ReadOnly Property MovcInstructionCount As UInteger
    Get
Visual C++
public:
property unsigned int MovcInstructionCount {
    unsigned int get ();
}

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MovInstructionCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflection1..::..MovInstructionCount Property
ShaderReflection1 Class See Also Send Feedback
Gets the number of Mov instructions.

(Also see DirectX SDK: ID3D10ShaderReflection1::GetMovInstructionCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MovInstructionCount { get; }
Visual Basic
Public ReadOnly Property MovInstructionCount As UInteger
    Get
Visual C++
public:
property unsigned int MovInstructionCount {
    unsigned int get ();
}

See Also

ShaderReflection1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionConstantBuffer Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionConstantBuffer Class
Members See Also Send Feedback
This shader-reflection interface provides access to a constant buffer. This class does not inherit from anything, but does declare the following methods:

(Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ShaderReflectionConstantBuffer : DirectObject
Visual Basic
Public Class ShaderReflectionConstantBuffer _
    Inherits DirectObject
Visual C++
public ref class ShaderReflectionConstantBuffer : public DirectObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflectionConstantBuffer

See Also

ShaderReflectionConstantBuffer Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionConstantBuffer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionConstantBuffer Members
ShaderReflectionConstantBuffer Class Methods Properties See Also Send Feedback

The ShaderReflectionConstantBuffer type exposes the following members.

Methods

 | Name | Description
Public method | GetVariableByIndex | Get a shader-reflection variable by index. (Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer::GetVariableByIndex)
Public method | GetVariableByName | Get a shader-reflection variable by name. (Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer::GetVariableByName)

Properties

 | Name | Description
Public property | Description | Get a constant-buffer description. (Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer::GetDesc)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

ShaderReflectionConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionConstantBuffer Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionConstantBuffer Methods
ShaderReflectionConstantBuffer Class See Also Send Feedback

The ShaderReflectionConstantBuffer type exposes the following members.

Methods

 | Name | Description
Public method | GetVariableByIndex | Get a shader-reflection variable by index. (Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer::GetVariableByIndex)
Public method | GetVariableByName | Get a shader-reflection variable by name. (Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer::GetVariableByName)

See Also

ShaderReflectionConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetVariableByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionConstantBuffer..::..GetVariableByIndex Method
ShaderReflectionConstantBuffer Class See Also Send Feedback
Get a shader-reflection variable by index.

(Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer::GetVariableByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderReflectionVariable GetVariableByIndex(
    uint index
)
Visual Basic
Public Function GetVariableByIndex ( _
    index As UInteger _
) As ShaderReflectionVariable
Visual C++
public:
ShaderReflectionVariable^ GetVariableByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Zero-based index.

See Also

ShaderReflectionConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetVariableByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionConstantBuffer..::..GetVariableByName Method
ShaderReflectionConstantBuffer Class See Also Send Feedback
Get a shader-reflection variable by name.

(Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer::GetVariableByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderReflectionVariable GetVariableByName(
    string name
)
Visual Basic
Public Function GetVariableByName ( _
    name As String _
) As ShaderReflectionVariable
Visual C++
public:
ShaderReflectionVariable^ GetVariableByName(
    String^ name
)

Parameters

name
Type: System..::..String
Variable name.

See Also

ShaderReflectionConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionConstantBuffer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionConstantBuffer Properties
ShaderReflectionConstantBuffer Class See Also Send Feedback

The ShaderReflectionConstantBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get a constant-buffer description. (Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer::GetDesc)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

ShaderReflectionConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionConstantBuffer..::..Description Property
ShaderReflectionConstantBuffer Class See Also Send Feedback
Get a constant-buffer description.

(Also see DirectX SDK: ID3D10ShaderReflectionConstantBuffer::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderBufferDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As ShaderBufferDescription
    Get
Visual C++
public:
property ShaderBufferDescription Description {
    ShaderBufferDescription get ();
}

See Also

ShaderReflectionConstantBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionType Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionType Class
Members See Also Send Feedback
This shader-reflection interface provides access to variable type. This class does not inherit from anything, but does declare the following methods:

(Also see DirectX SDK: ID3D10ShaderReflectionType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ShaderReflectionType : DirectObject
Visual Basic
Public Class ShaderReflectionType _
    Inherits DirectObject
Visual C++
public ref class ShaderReflectionType : public DirectObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflectionType

See Also

ShaderReflectionType Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionType Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionType Members
ShaderReflectionType Class Methods Properties See Also Send Feedback

The ShaderReflectionType type exposes the following members.

Methods

 | Name | Description
Public method | GetMemberTypeByIndex | Get a shader-reflection-variable type by index. (Also see DirectX SDK: ID3D10ShaderReflectionType::GetMemberTypeByIndex)
Public method | GetMemberTypeByName | Get a shader-reflection-variable type by name. (Also see DirectX SDK: ID3D10ShaderReflectionType::GetMemberTypeByName)
Public method | GetMemberTypeName | Get a shader-reflection-variable type. (Also see DirectX SDK: ID3D10ShaderReflectionType::GetMemberTypeName)

Properties

 | Name | Description
Public property | Description | Get the description of a shader-reflection-variable type. (Also see DirectX SDK: ID3D10ShaderReflectionType::GetDesc)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

ShaderReflectionType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionType Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionType Methods
ShaderReflectionType Class See Also Send Feedback

The ShaderReflectionType type exposes the following members.

Methods

 | Name | Description
Public method | GetMemberTypeByIndex | Get a shader-reflection-variable type by index. (Also see DirectX SDK: ID3D10ShaderReflectionType::GetMemberTypeByIndex)
Public method | GetMemberTypeByName | Get a shader-reflection-variable type by name. (Also see DirectX SDK: ID3D10ShaderReflectionType::GetMemberTypeByName)
Public method | GetMemberTypeName | Get a shader-reflection-variable type. (Also see DirectX SDK: ID3D10ShaderReflectionType::GetMemberTypeName)

See Also

ShaderReflectionType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberTypeByIndex Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionType..::..GetMemberTypeByIndex Method
ShaderReflectionType Class See Also Send Feedback
Get a shader-reflection-variable type by index.

(Also see DirectX SDK: ID3D10ShaderReflectionType::GetMemberTypeByIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderReflectionType GetMemberTypeByIndex(
    uint index
)
Visual Basic
Public Function GetMemberTypeByIndex ( _
    index As UInteger _
) As ShaderReflectionType
Visual C++
public:
ShaderReflectionType^ GetMemberTypeByIndex(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Zero-based index.

See Also

ShaderReflectionType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberTypeByName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionType..::..GetMemberTypeByName Method
ShaderReflectionType Class See Also Send Feedback
Get a shader-reflection-variable type by name.

(Also see DirectX SDK: ID3D10ShaderReflectionType::GetMemberTypeByName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderReflectionType GetMemberTypeByName(
    string name
)
Visual Basic
Public Function GetMemberTypeByName ( _
    name As String _
) As ShaderReflectionType
Visual C++
public:
ShaderReflectionType^ GetMemberTypeByName(
    String^ name
)

Parameters

name
Type: System..::..String
Member name.

See Also

ShaderReflectionType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetMemberTypeName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionType..::..GetMemberTypeName Method
ShaderReflectionType Class See Also Send Feedback
Get a shader-reflection-variable type.

(Also see DirectX SDK: ID3D10ShaderReflectionType::GetMemberTypeName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string GetMemberTypeName(
    uint index
)
Visual Basic
Public Function GetMemberTypeName ( _
    index As UInteger _
) As String
Visual C++
public:
String^ GetMemberTypeName(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
Zero-based index.

See Also

ShaderReflectionType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionType Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionType Properties
ShaderReflectionType Class See Also Send Feedback

The ShaderReflectionType type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the description of a shader-reflection-variable type. (Also see DirectX SDK: ID3D10ShaderReflectionType::GetDesc)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)

See Also

ShaderReflectionType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionType..::..Description Property
ShaderReflectionType Class See Also Send Feedback
Get the description of a shader-reflection-variable type.

(Also see DirectX SDK: ID3D10ShaderReflectionType::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderTypeDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As ShaderTypeDescription
    Get
Visual C++
public:
property ShaderTypeDescription Description {
    ShaderTypeDescription get ();
}

See Also

ShaderReflectionType Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionVariable Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionVariable Class
Members See Also Send Feedback
This shader-reflection interface provides access to a variable. This class does not inherit from anything, but does declare the following methods:

(Also see DirectX SDK: ID3D10ShaderReflectionVariable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ShaderReflectionVariable : DirectObject
Visual Basic
Public Class ShaderReflectionVariable _
    Inherits DirectObject
Visual C++
public ref class ShaderReflectionVariable : public DirectObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectObject
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderReflectionVariable

See Also

ShaderReflectionVariable Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionVariable Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionVariable Members
ShaderReflectionVariable Class Properties See Also Send Feedback

The ShaderReflectionVariable type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get a shader-variable description. (Also see DirectX SDK: ID3D10ShaderReflectionVariable::GetDesc)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ShaderReflectionType | Get a shader-variable type. (Also see DirectX SDK: ID3D10ShaderReflectionVariable::GetType)

See Also

ShaderReflectionVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionVariable Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionVariable Properties
ShaderReflectionVariable Class See Also Send Feedback

The ShaderReflectionVariable type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get a shader-variable description. (Also see DirectX SDK: ID3D10ShaderReflectionVariable::GetDesc)
Public property | NativeObject | Get the internal native pointer for the wrapped native object (Inherited from DirectObject.)
Public property | ShaderReflectionType | Get a shader-variable type. (Also see DirectX SDK: ID3D10ShaderReflectionVariable::GetType)

See Also

ShaderReflectionVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionVariable..::..Description Property
ShaderReflectionVariable Class See Also Send Feedback
Get a shader-variable description.

(Also see DirectX SDK: ID3D10ShaderReflectionVariable::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderVariableDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As ShaderVariableDescription
    Get
Visual C++
public:
property ShaderVariableDescription Description {
    ShaderVariableDescription get ();
}

See Also

ShaderReflectionVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderReflectionType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderReflectionVariable..::..ShaderReflectionType Property
ShaderReflectionVariable Class See Also Send Feedback
Get a shader-variable type.

(Also see DirectX SDK: ID3D10ShaderReflectionVariable::GetType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderReflectionType ShaderReflectionType { get; }
Visual Basic
Public ReadOnly Property ShaderReflectionType As ShaderReflectionType
    Get
Visual C++
public:
property ShaderReflectionType^ ShaderReflectionType {
    ShaderReflectionType^ get ();
}

See Also

ShaderReflectionVariable Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceView Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView Class
Members See Also Send Feedback
A shader-resource-view interface specifies the subresources a shader can access during rendering. Examples of shader resources include a constant buffer, a texture buffer, a texture or a sampler.

(Also see DirectX SDK: ID3D10ShaderResourceView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ShaderResourceView : View
Visual Basic
Public Class ShaderResourceView _
    Inherits View
Visual C++
public ref class ShaderResourceView : public View

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceView
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceView1

See Also

ShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView Members
ShaderResourceView Class Properties See Also Send Feedback

The ShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the shader resource view's description. (Also see DirectX SDK: ID3D10ShaderResourceView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource) (Inherited from View.)

See Also

ShaderResourceView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView Properties
ShaderResourceView Class See Also Send Feedback

The ShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the shader resource view's description. (Also see DirectX SDK: ID3D10ShaderResourceView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource) (Inherited from View.)

See Also

ShaderResourceView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView..::..Description Property
ShaderResourceView Class See Also Send Feedback
Get the shader resource view's description.

(Also see DirectX SDK: ID3D10ShaderResourceView::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceViewDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As ShaderResourceViewDescription
    Get
Visual C++
public:
property ShaderResourceViewDescription Description {
    ShaderResourceViewDescription get ();
}

See Also

ShaderResourceView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceView1 Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView1 Class
Members See Also Send Feedback
A shader-resource-view interface specifies the subresources a shader can access during rendering. Examples of shader resources include a constant buffer, a texture buffer, a texture or a sampler.

(Also see DirectX SDK: ID3D10ShaderResourceView1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ShaderResourceView1 : ShaderResourceView
Visual Basic
Public Class ShaderResourceView1 _
    Inherits ShaderResourceView
Visual C++
public ref class ShaderResourceView1 : public ShaderResourceView

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceView
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceView1

See Also

ShaderResourceView1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceView1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView1 Members
ShaderResourceView1 Class Properties See Also Send Feedback

The ShaderResourceView1 type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the shader resource view's description. (Also see DirectX SDK: ID3D10ShaderResourceView::GetDesc) (Inherited from ShaderResourceView.)
Public property | Description1 | Get the shader resource view's description. (Also see DirectX SDK: ID3D10ShaderResourceView1::GetDesc1)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource) (Inherited from View.)

See Also

ShaderResourceView1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceView1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView1 Properties
ShaderResourceView1 Class See Also Send Feedback

The ShaderResourceView1 type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the shader resource view's description. (Also see DirectX SDK: ID3D10ShaderResourceView::GetDesc) (Inherited from ShaderResourceView.)
Public property | Description1 | Get the shader resource view's description. (Also see DirectX SDK: ID3D10ShaderResourceView1::GetDesc1)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource) (Inherited from View.)

See Also

ShaderResourceView1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView1..::..Description1 Property
ShaderResourceView1 Class See Also Send Feedback
Get the shader resource view's description.

(Also see DirectX SDK: ID3D10ShaderResourceView1::GetDesc1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceViewDescription1 Description1 { get; }
Visual Basic
Public ReadOnly Property Description1 As ShaderResourceViewDescription1
    Get
Visual C++
public:
property ShaderResourceViewDescription1 Description1 {
    ShaderResourceViewDescription1 get ();
}

See Also

ShaderResourceView1 Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceViewDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription Structure
Members See Also Send Feedback
Describes a shader-resource view.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ShaderResourceViewDescription
Visual Basic
Public Structure ShaderResourceViewDescription
Visual C++
public value class ShaderResourceViewDescription

See Also

ShaderResourceViewDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceViewDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription Members
ShaderResourceViewDescription Structure Properties See Also Send Feedback

The ShaderResourceViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | View the resource as a buffer using information from a shader-resource view (see BufferShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Buffer)
Public property | Format | The viewing format. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Format)
Public property | Texture1D | View the resource as a 1D texture using information from a shader-resource view (see Texture1DShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture1D)
Public property | Texture1DArray | View the resource as a 1D-texture array using information from a shader-resource view (see Texture1DArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture1DArray)
Public property | Texture2D | View the resource as a 2D-texture using information from a shader-resource view (see Texture2DShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2D)
Public property | Texture2DArray | View the resource as a 2D-texture array using information from a shader-resource view (see Texture2DArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | View the resource as a 2D-multisampled texture using information from a shader-resource view (see Texture2DMultisampleShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2DMultisample)
Public property | Texture2DMultisampleArray | View the resource as a 2D-multisampled-texture array using information from a shader-resource view (see Texture2DMultisampleArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2DMSArray)
Public property | Texture3D | View the resource as a 3D texture using information from a shader-resource view (see Texture3DShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture3D)
Public property | TextureCube | View the resource as a 3D-cube texture using information from a shader-resource view (see TextureCubeShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.TextureCube)
Public property | ViewDimension | The resource type of the view. See ShaderResourceViewDimension. This should be the same as the resource type of the underlying resource. This parameter also determines which _SRV to use in the union below. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.ViewDimension)

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceViewDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription Properties
ShaderResourceViewDescription Structure See Also Send Feedback

The ShaderResourceViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | View the resource as a buffer using information from a shader-resource view (see BufferShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Buffer)
Public property | Format | The viewing format. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Format)
Public property | Texture1D | View the resource as a 1D texture using information from a shader-resource view (see Texture1DShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture1D)
Public property | Texture1DArray | View the resource as a 1D-texture array using information from a shader-resource view (see Texture1DArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture1DArray)
Public property | Texture2D | View the resource as a 2D-texture using information from a shader-resource view (see Texture2DShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2D)
Public property | Texture2DArray | View the resource as a 2D-texture array using information from a shader-resource view (see Texture2DArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | View the resource as a 2D-multisampled texture using information from a shader-resource view (see Texture2DMultisampleShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2DMultisample)
Public property | Texture2DMultisampleArray | View the resource as a 2D-multisampled-texture array using information from a shader-resource view (see Texture2DMultisampleArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2DMSArray)
Public property | Texture3D | View the resource as a 3D texture using information from a shader-resource view (see Texture3DShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture3D)
Public property | TextureCube | View the resource as a 3D-cube texture using information from a shader-resource view (see TextureCubeShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.TextureCube)
Public property | ViewDimension | The resource type of the view. See ShaderResourceViewDimension. This should be the same as the resource type of the underlying resource. This parameter also determines which _SRV to use in the union below. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.ViewDimension)

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Buffer Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a buffer using information from a shader-resource view (see BufferShaderResourceView).

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Buffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BufferShaderResourceView Buffer { get; set; }
Visual Basic
Public Property Buffer As BufferShaderResourceView
    Get
    Set
Visual C++
public:
property BufferShaderResourceView Buffer {
    BufferShaderResourceView get ();
    void set (BufferShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferShaderResourceView


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Format Property
ShaderResourceViewDescription Structure See Also Send Feedback
The viewing format.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture1D Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 1D texture using information from a shader-resource view (see Texture1DShaderResourceView).

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DShaderResourceView Texture1D { get; set; }
Visual Basic
Public Property Texture1D As Texture1DShaderResourceView
    Get
    Set
Visual C++
public:
property Texture1DShaderResourceView Texture1D {
    Texture1DShaderResourceView get ();
    void set (Texture1DShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DShaderResourceView


Texture1DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture1DArray Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 1D-texture array using information from a shader-resource view (see Texture1DArrayShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture1DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DArrayShaderResourceView Texture1DArray { get; set; }
Visual Basic
Public Property Texture1DArray As Texture1DArrayShaderResourceView
    Get
    Set
Visual C++
public:
property Texture1DArrayShaderResourceView Texture1DArray {
    Texture1DArrayShaderResourceView get ();
    void set (Texture1DArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture2D Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 2D-texture using information from a shader-resource view (see Texture2DShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DShaderResourceView Texture2D { get; set; }
Visual Basic
Public Property Texture2D As Texture2DShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DShaderResourceView Texture2D {
    Texture2DShaderResourceView get ();
    void set (Texture2DShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture2DArray Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 2D-texture array using information from a shader-resource view (see Texture2DArrayShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DArrayShaderResourceView Texture2DArray { get; set; }
Visual Basic
Public Property Texture2DArray As Texture2DArrayShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DArrayShaderResourceView Texture2DArray {
    Texture2DArrayShaderResourceView get ();
    void set (Texture2DArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisample Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture2DMultisample Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 2D-multisampled texture using information from a shader-resource view (see Texture2DMultisampleShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2DMultisample)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleShaderResourceView Texture2DMultisample { get; set; }
Visual Basic
Public Property Texture2DMultisample As Texture2DMultisampleShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleShaderResourceView Texture2DMultisample {
    Texture2DMultisampleShaderResourceView get ();
    void set (Texture2DMultisampleShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture2DMultisampleArray Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 2D-multisampled-texture array using information from a shader-resource view (see Texture2DMultisampleArrayShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture2DMSArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleArrayShaderResourceView Texture2DMultisampleArray { get; set; }
Visual Basic
Public Property Texture2DMultisampleArray As Texture2DMultisampleArrayShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleArrayShaderResourceView Texture2DMultisampleArray {
    Texture2DMultisampleArrayShaderResourceView get ();
    void set (Texture2DMultisampleArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture3D Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 3D texture using information from a shader-resource view (see Texture3DShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.Texture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3DShaderResourceView Texture3D { get; set; }
Visual Basic
Public Property Texture3D As Texture3DShaderResourceView
    Get
    Set
Visual C++
public:
property Texture3DShaderResourceView Texture3D {
    Texture3DShaderResourceView get ();
    void set (Texture3DShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCube Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..TextureCube Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 3D-cube texture using information from a shader-resource view (see TextureCubeShaderResourceView).

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.TextureCube)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureCubeShaderResourceView TextureCube { get; set; }
Visual Basic
Public Property TextureCube As TextureCubeShaderResourceView
    Get
    Set
Visual C++
public:
property TextureCubeShaderResourceView TextureCube {
    TextureCubeShaderResourceView get ();
    void set (TextureCubeShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeShaderResourceView


ViewDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..ViewDimension Property
ShaderResourceViewDescription Structure See Also Send Feedback
The resource type of the view. See ShaderResourceViewDimension. This should be the same as the resource type of the underlying resource. This parameter also determines which _SRV to use in the union below.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC.ViewDimension)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceViewDimension ViewDimension { get; set; }
Visual Basic
Public Property ViewDimension As ShaderResourceViewDimension
    Get
    Set
Visual C++
public:
property ShaderResourceViewDimension ViewDimension {
    ShaderResourceViewDimension get ();
    void set (ShaderResourceViewDimension value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceViewDescription1 Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1 Structure
Members See Also Send Feedback
Describes a shader-resource view.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ShaderResourceViewDescription1
Visual Basic
Public Structure ShaderResourceViewDescription1
Visual C++
public value class ShaderResourceViewDescription1

See Also

ShaderResourceViewDescription1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceViewDescription1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1 Members
ShaderResourceViewDescription1 Structure Properties See Also Send Feedback

The ShaderResourceViewDescription1 type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | View the resource as a buffer using information from a shader-resource view (see BufferShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Buffer)
Public property | Format | The viewing format. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Format)
Public property | Texture1D | View the resource as a 1D texture using information from a shader-resource view (see Texture1DShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture1D)
Public property | Texture1DArray | View the resource as a 1D-texture array using information from a shader-resource view (see Texture1DArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture1DArray)
Public property | Texture2D | View the resource as a 2D-texture using information from a shader-resource view (see Texture2DShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2D)
Public property | Texture2DArray | View the resource as a 2D-texture array using information from a shader-resource view (see Texture2DArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2DArray)
Public property | Texture2DMultisample | View the resource as a 2D-multisampled texture using information from a shader-resource view (see Texture2DMultisampleShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2DMultisample)
Public property | Texture2DMultisampleArray | View the resource as a 2D-multisampled-texture array using information from a shader-resource view (see Texture2DMultisampleArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2DMSArray)
Public property | Texture3D | View the resource as a 3D texture using information from a shader-resource view (see Texture3DShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture3D)
Public property | TextureCube | View the resource as a 3D-cube texture using information from a shader-resource view (see TextureCubeShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.TextureCube)
Public property | TextureCubeArray | View the resource as an array of cube textures using information from a shader-resource view (see TextureCubeArrayShaderResourceView1). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.TextureCubeArray)
Public property | ViewDimension | The resource type of the view. See ShaderResourceViewDimension1. This should be the same as the resource type of the underlying resource. This parameter also determines which _SRV to use in the union below. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.ViewDimension)

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceViewDescription1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1 Properties
ShaderResourceViewDescription1 Structure See Also Send Feedback

The ShaderResourceViewDescription1 type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | View the resource as a buffer using information from a shader-resource view (see BufferShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Buffer)
Public property | Format | The viewing format. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Format)
Public property | Texture1D | View the resource as a 1D texture using information from a shader-resource view (see Texture1DShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture1D)
Public property | Texture1DArray | View the resource as a 1D-texture array using information from a shader-resource view (see Texture1DArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture1DArray)
Public property | Texture2D | View the resource as a 2D-texture using information from a shader-resource view (see Texture2DShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2D)
Public property | Texture2DArray | View the resource as a 2D-texture array using information from a shader-resource view (see Texture2DArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2DArray)
Public property | Texture2DMultisample | View the resource as a 2D-multisampled texture using information from a shader-resource view (see Texture2DMultisampleShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2DMultisample)
Public property | Texture2DMultisampleArray | View the resource as a 2D-multisampled-texture array using information from a shader-resource view (see Texture2DMultisampleArrayShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2DMSArray)
Public property | Texture3D | View the resource as a 3D texture using information from a shader-resource view (see Texture3DShaderResourceView. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture3D)
Public property | TextureCube | View the resource as a 3D-cube texture using information from a shader-resource view (see TextureCubeShaderResourceView). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.TextureCube)
Public property | TextureCubeArray | View the resource as an array of cube textures using information from a shader-resource view (see TextureCubeArrayShaderResourceView1). (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.TextureCubeArray)
Public property | ViewDimension | The resource type of the view. See ShaderResourceViewDimension1. This should be the same as the resource type of the underlying resource. This parameter also determines which _SRV to use in the union below. (Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.ViewDimension)

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..Buffer Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as a buffer using information from a shader-resource view (see BufferShaderResourceView).

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Buffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BufferShaderResourceView Buffer { get; set; }
Visual Basic
Public Property Buffer As BufferShaderResourceView
    Get
    Set
Visual C++
public:
property BufferShaderResourceView Buffer {
    BufferShaderResourceView get ();
    void set (BufferShaderResourceView value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BufferShaderResourceView


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..Format Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
The viewing format.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..Texture1D Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as a 1D texture using information from a shader-resource view (see Texture1DShaderResourceView).

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DShaderResourceView Texture1D { get; set; }
Visual Basic
Public Property Texture1D As Texture1DShaderResourceView
    Get
    Set
Visual C++
public:
property Texture1DShaderResourceView Texture1D {
    Texture1DShaderResourceView get ();
    void set (Texture1DShaderResourceView value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DShaderResourceView


Texture1DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..Texture1DArray Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as a 1D-texture array using information from a shader-resource view (see Texture1DArrayShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture1DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DArrayShaderResourceView Texture1DArray { get; set; }
Visual Basic
Public Property Texture1DArray As Texture1DArrayShaderResourceView
    Get
    Set
Visual C++
public:
property Texture1DArrayShaderResourceView Texture1DArray {
    Texture1DArrayShaderResourceView get ();
    void set (Texture1DArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..Texture2D Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as a 2D-texture using information from a shader-resource view (see Texture2DShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DShaderResourceView Texture2D { get; set; }
Visual Basic
Public Property Texture2D As Texture2DShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DShaderResourceView Texture2D {
    Texture2DShaderResourceView get ();
    void set (Texture2DShaderResourceView value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..Texture2DArray Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as a 2D-texture array using information from a shader-resource view (see Texture2DArrayShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DArrayShaderResourceView Texture2DArray { get; set; }
Visual Basic
Public Property Texture2DArray As Texture2DArrayShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DArrayShaderResourceView Texture2DArray {
    Texture2DArrayShaderResourceView get ();
    void set (Texture2DArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisample Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..Texture2DMultisample Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as a 2D-multisampled texture using information from a shader-resource view (see Texture2DMultisampleShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2DMultisample)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleShaderResourceView Texture2DMultisample { get; set; }
Visual Basic
Public Property Texture2DMultisample As Texture2DMultisampleShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleShaderResourceView Texture2DMultisample {
    Texture2DMultisampleShaderResourceView get ();
    void set (Texture2DMultisampleShaderResourceView value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..Texture2DMultisampleArray Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as a 2D-multisampled-texture array using information from a shader-resource view (see Texture2DMultisampleArrayShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture2DMSArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleArrayShaderResourceView Texture2DMultisampleArray { get; set; }
Visual Basic
Public Property Texture2DMultisampleArray As Texture2DMultisampleArrayShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleArrayShaderResourceView Texture2DMultisampleArray {
    Texture2DMultisampleArrayShaderResourceView get ();
    void set (Texture2DMultisampleArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..Texture3D Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as a 3D texture using information from a shader-resource view (see Texture3DShaderResourceView.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.Texture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3DShaderResourceView Texture3D { get; set; }
Visual Basic
Public Property Texture3D As Texture3DShaderResourceView
    Get
    Set
Visual C++
public:
property Texture3DShaderResourceView Texture3D {
    Texture3DShaderResourceView get ();
    void set (Texture3DShaderResourceView value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCube Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..TextureCube Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as a 3D-cube texture using information from a shader-resource view (see TextureCubeShaderResourceView).

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.TextureCube)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureCubeShaderResourceView TextureCube { get; set; }
Visual Basic
Public Property TextureCube As TextureCubeShaderResourceView
    Get
    Set
Visual C++
public:
property TextureCubeShaderResourceView TextureCube {
    TextureCubeShaderResourceView get ();
    void set (TextureCubeShaderResourceView value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeShaderResourceView


TextureCubeArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..TextureCubeArray Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
View the resource as an array of cube textures using information from a shader-resource view (see TextureCubeArrayShaderResourceView1).

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.TextureCubeArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureCubeArrayShaderResourceView1 TextureCubeArray { get; set; }
Visual Basic
Public Property TextureCubeArray As TextureCubeArrayShaderResourceView1
    Get
    Set
Visual C++
public:
property TextureCubeArrayShaderResourceView1 TextureCubeArray {
    TextureCubeArrayShaderResourceView1 get ();
    void set (TextureCubeArrayShaderResourceView1 value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeArrayShaderResourceView1


ViewDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription1..::..ViewDimension Property
ShaderResourceViewDescription1 Structure See Also Send Feedback
The resource type of the view. See ShaderResourceViewDimension1. This should be the same as the resource type of the underlying resource. This parameter also determines which _SRV to use in the union below.

(Also see DirectX SDK: D3D10_SHADER_RESOURCE_VIEW_DESC1.ViewDimension)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceViewDimension1 ViewDimension { get; set; }
Visual Basic
Public Property ViewDimension As ShaderResourceViewDimension1
    Get
    Set
Visual C++
public:
property ShaderResourceViewDimension1 ViewDimension {
    ShaderResourceViewDimension1 get ();
    void set (ShaderResourceViewDimension1 value);
}

See Also

ShaderResourceViewDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceViewDimension Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDimension Enumeration
See Also Send Feedback
These flags identify the type of resource that will be viewed.

(Also see DirectX SDK: D3D10_SRV_DIMENSION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ShaderResourceViewDimension
Visual Basic
Public Enumeration ShaderResourceViewDimension
Visual C++
public enum class ShaderResourceViewDimension

Members

Member name | Description
Texture2DMultisampleArray |
Texture2DMultisample |
Buffer |
TextureCube |
Texture3D |
Texture2DArray |
Texture2D |
Texture1DArray |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderResourceViewDimension1 Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDimension1 Enumeration
See Also Send Feedback
These flags identify the type of resource that will be viewed.

(Also see DirectX SDK: D3D10_SRV_DIMENSION1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ShaderResourceViewDimension1
Visual Basic
Public Enumeration ShaderResourceViewDimension1
Visual C++
public enum class ShaderResourceViewDimension1

Members

Member name | Description
Texture2DMultisampleArray |
Texture2DMultisample |
TextureCubeArray |
Buffer |
TextureCube |
Texture3D |
Texture2DArray |
Texture2D |
Texture1DArray |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderTypeDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription Structure
Members See Also Send Feedback
Describes a shader-variable type.

(Also see DirectX SDK: D3D10_SHADER_TYPE_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ShaderTypeDescription
Visual Basic
Public Structure ShaderTypeDescription
Visual C++
public value class ShaderTypeDescription

See Also

ShaderTypeDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderTypeDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription Members
ShaderTypeDescription Structure Methods Operators Properties See Also Send Feedback

The ShaderTypeDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Class | Identifies the variable class as one of scalar, vector, matrix or object. See ShaderVariableClass. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Class)
Public property | Columns | Number of columns in a matrix. Otherwise a numeric type returns 1, any other type returns 0. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Columns)
Public property | Elements | Number of elements in an array; otherwise 0. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Elements)
Public property | Members | Number of members in the structure; otherwise 0. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Members)
Public property | Offset | Offset, in bytes, between the start of the parent structure and this variable. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Offset)
Public property | Rows | Number of rows in a matrix. Otherwise a numeric type returns 1, any other type returns 0. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Rows)
Public property | ShaderVariableType | The variable type. See ShaderVariableType. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Type)

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderTypeDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription Methods
ShaderTypeDescription Structure See Also Send Feedback

The ShaderTypeDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..Equals Method
ShaderTypeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..GetHashCode Method
ShaderTypeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderTypeDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription Operators
ShaderTypeDescription Structure See Also Send Feedback

The ShaderTypeDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..Equality Operator
ShaderTypeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ShaderTypeDescription shaderTypeDescription1,
    ShaderTypeDescription shaderTypeDescription2
)
Visual Basic
Public Shared Operator = ( _
    shaderTypeDescription1 As ShaderTypeDescription, _
    shaderTypeDescription2 As ShaderTypeDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    ShaderTypeDescription shaderTypeDescription1,
    ShaderTypeDescription shaderTypeDescription2
)

Parameters

shaderTypeDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderTypeDescription
shaderTypeDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderTypeDescription

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..Inequality Operator
ShaderTypeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ShaderTypeDescription shaderTypeDescription1,
    ShaderTypeDescription shaderTypeDescription2
)
Visual Basic
Public Shared Operator <> ( _
    shaderTypeDescription1 As ShaderTypeDescription, _
    shaderTypeDescription2 As ShaderTypeDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    ShaderTypeDescription shaderTypeDescription1,
    ShaderTypeDescription shaderTypeDescription2
)

Parameters

shaderTypeDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderTypeDescription
shaderTypeDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderTypeDescription

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderTypeDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription Properties
ShaderTypeDescription Structure See Also Send Feedback

The ShaderTypeDescription type exposes the following members.

Properties

 | Name | Description
Public property | Class | Identifies the variable class as one of scalar, vector, matrix or object. See ShaderVariableClass. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Class)
Public property | Columns | Number of columns in a matrix. Otherwise a numeric type returns 1, any other type returns 0. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Columns)
Public property | Elements | Number of elements in an array; otherwise 0. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Elements)
Public property | Members | Number of members in the structure; otherwise 0. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Members)
Public property | Offset | Offset, in bytes, between the start of the parent structure and this variable. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Offset)
Public property | Rows | Number of rows in a matrix. Otherwise a numeric type returns 1, any other type returns 0. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Rows)
Public property | ShaderVariableType | The variable type. See ShaderVariableType. (Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Type)

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Class Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..Class Property
ShaderTypeDescription Structure See Also Send Feedback
Identifies the variable class as one of scalar, vector, matrix or object. See ShaderVariableClass.

(Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Class)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderVariableClass Class { get; set; }
Visual Basic
Public Property Class As ShaderVariableClass
    Get
    Set
Visual C++
public:
property ShaderVariableClass Class {
    ShaderVariableClass get ();
    void set (ShaderVariableClass value);
}

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Columns Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..Columns Property
ShaderTypeDescription Structure See Also Send Feedback
Number of columns in a matrix. Otherwise a numeric type returns 1, any other type returns 0.

(Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Columns)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Columns { get; set; }
Visual Basic
Public Property Columns As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Columns {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Elements Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..Elements Property
ShaderTypeDescription Structure See Also Send Feedback
Number of elements in an array; otherwise 0.

(Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Elements)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Elements { get; set; }
Visual Basic
Public Property Elements As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Elements {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Members Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..Members Property
ShaderTypeDescription Structure See Also Send Feedback
Number of members in the structure; otherwise 0.

(Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Members)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Members { get; set; }
Visual Basic
Public Property Members As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Members {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Offset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..Offset Property
ShaderTypeDescription Structure See Also Send Feedback
Offset, in bytes, between the start of the parent structure and this variable.

(Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Offset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Offset { get; set; }
Visual Basic
Public Property Offset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Offset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Rows Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..Rows Property
ShaderTypeDescription Structure See Also Send Feedback
Number of rows in a matrix. Otherwise a numeric type returns 1, any other type returns 0.

(Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Rows)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Rows { get; set; }
Visual Basic
Public Property Rows As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Rows {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderTypeDescription..::..ShaderVariableType Property
ShaderTypeDescription Structure See Also Send Feedback
The variable type. See ShaderVariableType.

(Also see DirectX SDK: D3D10_SHADER_TYPE_DESC.Type)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderVariableType ShaderVariableType { get; set; }
Visual Basic
Public Property ShaderVariableType As ShaderVariableType
    Get
    Set
Visual C++
public:
property ShaderVariableType ShaderVariableType {
    ShaderVariableType get ();
    void set (ShaderVariableType value);
}

See Also

ShaderTypeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableClass Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableClass Enumeration
See Also Send Feedback
These flags identify the shader-variable class.

(Also see DirectX SDK: D3D10_SHADER_VARIABLE_CLASS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ShaderVariableClass
Visual Basic
Public Enumeration ShaderVariableClass
Visual C++
public enum class ShaderVariableClass

Members

Member name | Description
Object |
Struct |
MatrixColumns |
MatrixRows |
Vector |
Scalar |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription Structure
Members See Also Send Feedback
Describes a shader variable.

(Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ShaderVariableDescription
Visual Basic
Public Structure ShaderVariableDescription
Visual C++
public value class ShaderVariableDescription

See Also

ShaderVariableDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription Members
ShaderVariableDescription Structure Methods Properties See Also Send Feedback

The ShaderVariableDescription type exposes the following members.

Methods

 | Name | Description
Public method | SetDefaultValue |

Properties

 | Name | Description
Public property | DefaultValue | The default value for initializing the variable. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.DefaultValue)
Public property | Name | The variable name. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.Name)
Public property | ShaderVariableProperties | Flags, which identify shader-variable properties (see ShaderVariableProperties). (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.uFlags)
Public property | Size | Size of the variable (in bytes). (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.Size)
Public property | StartOffset | Offset from the start of the parent structure, to the beginning of the variable. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.StartOffset)

See Also

ShaderVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription Methods
ShaderVariableDescription Structure See Also Send Feedback

The ShaderVariableDescription type exposes the following members.

Methods

 | Name | Description
Public method | SetDefaultValue |

See Also

ShaderVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetDefaultValue Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription..::..SetDefaultValue Method
ShaderVariableDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetDefaultValue(
    IEnumerable<byte> newDefaultValue
)
Visual Basic
Public Sub SetDefaultValue ( _
    newDefaultValue As IEnumerable(Of Byte) _
)
Visual C++
public:
void SetDefaultValue(
    IEnumerable<unsigned char>^ newDefaultValue
)

Parameters

newDefaultValue
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Byte >)>)>

See Also

ShaderVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription Properties
ShaderVariableDescription Structure See Also Send Feedback

The ShaderVariableDescription type exposes the following members.

Properties

 | Name | Description
Public property | DefaultValue | The default value for initializing the variable. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.DefaultValue)
Public property | Name | The variable name. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.Name)
Public property | ShaderVariableProperties | Flags, which identify shader-variable properties (see ShaderVariableProperties). (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.uFlags)
Public property | Size | Size of the variable (in bytes). (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.Size)
Public property | StartOffset | Offset from the start of the parent structure, to the beginning of the variable. (Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.StartOffset)

See Also

ShaderVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DefaultValue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription..::..DefaultValue Property
ShaderVariableDescription Structure See Also Send Feedback
The default value for initializing the variable.

(Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.DefaultValue)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> DefaultValue { get; }
Visual Basic
Public ReadOnly Property DefaultValue As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ DefaultValue {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

ShaderVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Name Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription..::..Name Property
ShaderVariableDescription Structure See Also Send Feedback
The variable name.

(Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.Name)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ShaderVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableProperties Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription..::..ShaderVariableProperties Property
ShaderVariableDescription Structure See Also Send Feedback
Flags, which identify shader-variable properties (see ShaderVariableProperties).

(Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.uFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderVariableProperties ShaderVariableProperties { get; set; }
Visual Basic
Public Property ShaderVariableProperties As ShaderVariableProperties
    Get
    Set
Visual C++
public:
property ShaderVariableProperties ShaderVariableProperties {
    ShaderVariableProperties get ();
    void set (ShaderVariableProperties value);
}

See Also

ShaderVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
ShaderVariableDescription..::..ShaderVariableProperties


Size Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription..::..Size Property
ShaderVariableDescription Structure See Also Send Feedback
Size of the variable (in bytes).

(Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.Size)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Size { get; set; }
Visual Basic
Public Property Size As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Size {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StartOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableDescription..::..StartOffset Property
ShaderVariableDescription Structure See Also Send Feedback
Offset from the start of the parent structure, to the beginning of the variable.

(Also see DirectX SDK: D3D10_SHADER_VARIABLE_DESC.StartOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint StartOffset { get; set; }
Visual Basic
Public Property StartOffset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int StartOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ShaderVariableDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableProperties Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableProperties Enumeration
See Also Send Feedback
Flags that indicate information about a shader variable; these flags are returned using a reflection object.

(Also see DirectX SDK: D3D10_SHADER_VARIABLE_FLAGS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ShaderVariableProperties
Visual Basic
<FlagsAttribute> _
Public Enumeration ShaderVariableProperties
Visual C++
[FlagsAttribute]
public enum class ShaderVariableProperties

Members

Member name | Description
None |
Used |
UserPacked |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ShaderVariableType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderVariableType Enumeration
See Also Send Feedback
These values identify the shader-variable type.

(Also see DirectX SDK: D3D10_SHADER_VARIABLE_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ShaderVariableType
Visual Basic
Public Enumeration ShaderVariableType
Visual C++
public enum class ShaderVariableType

Members

Member name | Description
Texture2DMultisampleArray |
Texture2DMultisample |
Blend |
DepthStencil |
TextureCubeArray |
ConstantBuffer |
Buffer |
String |
Void |
DepthStencilView |
RenderTargetView |
Texture2DArray |
Texture1DArray |
TextureBuffer |
Rasterizer |
GeometryShader |
UInt8 |
UInt |
VertexShader |
PixelShader |
Sampler |
TextureCube |
Texture3D |
Texture2D |
Texture1D |
Texture |
Float |
Int |
Bool |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SignatureParameterDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription Structure
Members See Also Send Feedback
Describes a shader signature.

(Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SignatureParameterDescription
Visual Basic
Public Structure SignatureParameterDescription
Visual C++
public value class SignatureParameterDescription

See Also

SignatureParameterDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SignatureParameterDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription Members
SignatureParameterDescription Structure Methods Operators Properties See Also Send Feedback

The SignatureParameterDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ComponentType | The per-component-data type that is stored in a register. See RegisterComponentType. Each register can store up to four-components of data. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.ComponentType)
Public property | Mask | Mask which indicates which components of a register are used. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.Mask)
Public property | ReadWriteMask | Mask which indicates whether a given component is never written (if the signature is an output signature) or always read (if the signature is an input signature). The mask is a combination of RegisterComponentType values. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.ReadWriteMask)
Public property | RegisterNumber | The register that will contain this variable's data. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.Register)
Public property | SemanticIndex | Semantic index that modifies the semantic. Used to differentiate different parameters that use the same semantic. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.SemanticIndex)
Public property | SemanticName | A per-parameter string that identifies how the data will be used. See Semantics (DirectX HLSL). (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.SemanticName)
Public property | SystemValueType | A predefined string that determines the functionality of certain pipeline stages. See Name. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.SystemValueType)

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SignatureParameterDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription Methods
SignatureParameterDescription Structure See Also Send Feedback

The SignatureParameterDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..Equals Method
SignatureParameterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..GetHashCode Method
SignatureParameterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SignatureParameterDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription Operators
SignatureParameterDescription Structure See Also Send Feedback

The SignatureParameterDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..Equality Operator
SignatureParameterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    SignatureParameterDescription signatureParameterDescription1,
    SignatureParameterDescription signatureParameterDescription2
)
Visual Basic
Public Shared Operator = ( _
    signatureParameterDescription1 As SignatureParameterDescription, _
    signatureParameterDescription2 As SignatureParameterDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    SignatureParameterDescription signatureParameterDescription1,
    SignatureParameterDescription signatureParameterDescription2
)

Parameters

signatureParameterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SignatureParameterDescription
signatureParameterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SignatureParameterDescription

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..Inequality Operator
SignatureParameterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    SignatureParameterDescription signatureParameterDescription1,
    SignatureParameterDescription signatureParameterDescription2
)
Visual Basic
Public Shared Operator <> ( _
    signatureParameterDescription1 As SignatureParameterDescription, _
    signatureParameterDescription2 As SignatureParameterDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    SignatureParameterDescription signatureParameterDescription1,
    SignatureParameterDescription signatureParameterDescription2
)

Parameters

signatureParameterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SignatureParameterDescription
signatureParameterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SignatureParameterDescription

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SignatureParameterDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription Properties
SignatureParameterDescription Structure See Also Send Feedback

The SignatureParameterDescription type exposes the following members.

Properties

 | Name | Description
Public property | ComponentType | The per-component-data type that is stored in a register. See RegisterComponentType. Each register can store up to four-components of data. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.ComponentType)
Public property | Mask | Mask which indicates which components of a register are used. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.Mask)
Public property | ReadWriteMask | Mask which indicates whether a given component is never written (if the signature is an output signature) or always read (if the signature is an input signature). The mask is a combination of RegisterComponentType values. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.ReadWriteMask)
Public property | RegisterNumber | The register that will contain this variable's data. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.Register)
Public property | SemanticIndex | Semantic index that modifies the semantic. Used to differentiate different parameters that use the same semantic. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.SemanticIndex)
Public property | SemanticName | A per-parameter string that identifies how the data will be used. See Semantics (DirectX HLSL). (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.SemanticName)
Public property | SystemValueType | A predefined string that determines the functionality of certain pipeline stages. See Name. (Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.SystemValueType)

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ComponentType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..ComponentType Property
SignatureParameterDescription Structure See Also Send Feedback
The per-component-data type that is stored in a register. See RegisterComponentType. Each register can store up to four-components of data.

(Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.ComponentType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RegisterComponentType ComponentType { get; set; }
Visual Basic
Public Property ComponentType As RegisterComponentType
    Get
    Set
Visual C++
public:
property RegisterComponentType ComponentType {
    RegisterComponentType get ();
    void set (RegisterComponentType value);
}

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Mask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..Mask Property
SignatureParameterDescription Structure See Also Send Feedback
Mask which indicates which components of a register are used.

(Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.Mask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte Mask { get; set; }
Visual Basic
Public Property Mask As Byte
    Get
    Set
Visual C++
public:
property unsigned char Mask {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ReadWriteMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..ReadWriteMask Property
SignatureParameterDescription Structure See Also Send Feedback
Mask which indicates whether a given component is never written (if the signature is an output signature) or always read (if the signature is an input signature). The mask is a combination of RegisterComponentType values.

(Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.ReadWriteMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte ReadWriteMask { get; set; }
Visual Basic
Public Property ReadWriteMask As Byte
    Get
    Set
Visual C++
public:
property unsigned char ReadWriteMask {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RegisterNumber Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..RegisterNumber Property
SignatureParameterDescription Structure See Also Send Feedback
The register that will contain this variable's data.

(Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.Register)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint RegisterNumber { get; set; }
Visual Basic
Public Property RegisterNumber As UInteger
    Get
    Set
Visual C++
public:
property unsigned int RegisterNumber {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SemanticIndex Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..SemanticIndex Property
SignatureParameterDescription Structure See Also Send Feedback
Semantic index that modifies the semantic. Used to differentiate different parameters that use the same semantic.

(Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.SemanticIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SemanticIndex { get; set; }
Visual Basic
Public Property SemanticIndex As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SemanticIndex {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SemanticName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..SemanticName Property
SignatureParameterDescription Structure See Also Send Feedback
A per-parameter string that identifies how the data will be used. See Semantics (DirectX HLSL).

(Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.SemanticName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string SemanticName { get; set; }
Visual Basic
Public Property SemanticName As String
    Get
    Set
Visual C++
public:
property String^ SemanticName {
    String^ get ();
    void set (String^ value);
}

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SystemValueType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SignatureParameterDescription..::..SystemValueType Property
SignatureParameterDescription Structure See Also Send Feedback
A predefined string that determines the functionality of certain pipeline stages. See Name.

(Also see DirectX SDK: D3D10_SIGNATURE_PARAMETER_DESC.SystemValueType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Name SystemValueType { get; set; }
Visual Basic
Public Property SystemValueType As Name
    Get
    Set
Visual C++
public:
property Name SystemValueType {
    Name get ();
    void set (Name value);
}

See Also

SignatureParameterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlock Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlock Class
Members See Also Send Feedback
A state-block interface encapsulates render states.

(Also see DirectX SDK: ID3D10StateBlock)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class StateBlock : DirectUnknown
Visual Basic
Public Class StateBlock _
    Inherits DirectUnknown
Visual C++
public ref class StateBlock : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlock

See Also

StateBlock Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlock Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlock Members
StateBlock Class Methods Properties See Also Send Feedback

The StateBlock type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Apply the state block to the current device state. (Also see DirectX SDK: ID3D10StateBlock::Apply)
Public method | Capture | Capture the current value of states that are included in a stateblock. (Also see DirectX SDK: ID3D10StateBlock::Capture)
Public method | ReleaseAllDeviceObjects | Release all references to device objects. (Also see DirectX SDK: ID3D10StateBlock::ReleaseAllDeviceObjects)

Properties

 | Name | Description
Public property | Device | Get the device. (Also see DirectX SDK: ID3D10StateBlock::GetDevice)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

StateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlock Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlock Methods
StateBlock Class See Also Send Feedback

The StateBlock type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Apply the state block to the current device state. (Also see DirectX SDK: ID3D10StateBlock::Apply)
Public method | Capture | Capture the current value of states that are included in a stateblock. (Also see DirectX SDK: ID3D10StateBlock::Capture)
Public method | ReleaseAllDeviceObjects | Release all references to device objects. (Also see DirectX SDK: ID3D10StateBlock::ReleaseAllDeviceObjects)

See Also

StateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Apply Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlock..::..Apply Method
StateBlock Class See Also Send Feedback
Apply the state block to the current device state.

(Also see DirectX SDK: ID3D10StateBlock::Apply)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Apply()
Visual Basic
Public Sub Apply
Visual C++
public:
void Apply()

See Also

StateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Capture Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlock..::..Capture Method
StateBlock Class See Also Send Feedback
Capture the current value of states that are included in a stateblock.

(Also see DirectX SDK: ID3D10StateBlock::Capture)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Capture()
Visual Basic
Public Sub Capture
Visual C++
public:
void Capture()

See Also

StateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ReleaseAllDeviceObjects Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlock..::..ReleaseAllDeviceObjects Method
StateBlock Class See Also Send Feedback
Release all references to device objects.

(Also see DirectX SDK: ID3D10StateBlock::ReleaseAllDeviceObjects)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ReleaseAllDeviceObjects()
Visual Basic
Public Sub ReleaseAllDeviceObjects
Visual C++
public:
void ReleaseAllDeviceObjects()

See Also

StateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlock Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlock Properties
StateBlock Class See Also Send Feedback

The StateBlock type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device. (Also see DirectX SDK: ID3D10StateBlock::GetDevice)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

StateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Device Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlock..::..Device Property
StateBlock Class See Also Send Feedback
Get the device.

(Also see DirectX SDK: ID3D10StateBlock::GetDevice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DDevice Device { get; }
Visual Basic
Public ReadOnly Property Device As D3DDevice
    Get
Visual C++
public:
property D3DDevice^ Device {
    D3DDevice^ get ();
}

See Also

StateBlock Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlockMask Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask Class
Members See Also Send Feedback
Indicates the device state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class StateBlockMask : IDisposable
Visual Basic
Public Class StateBlockMask _
    Implements IDisposable
Visual C++
public ref class StateBlockMask : IDisposable

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask

See Also

StateBlockMask Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlockMask Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask Members
StateBlockMask Class Constructors Methods Operators Properties See Also Send Feedback

The StateBlockMask type exposes the following members.

Constructors

 | Name | Description
Public method | StateBlockMask |

Methods

 | Name | Description
Public method | ~StateBlockMask |
Public method | BitwiseAnd |
Public method | BitwiseOr |
Public method | DisableAll |
Public method | DisableCapture |
Public method | Dispose()()()() |
Protected method | Dispose(Boolean) |
Public method | EnableAll |
Public method | EnableCapture |
Public method | Xor |

Operators

Name | Description
BitwiseAnd |
BitwiseOr |
ExclusiveOr |

Properties

 | Name | Description
Public property | GeometryShader | Boolean value indicating whether to save the geometry shader state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GS)
Public property | GeometryShaderConstantBuffers | Array of geometry-shader constant buffers. The array is a multi-byte bitmask where each bit represents one buffer slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GSConstantBuffers)
Public property | GeometryShaderSamplers | Array of geometry-shader samplers. The array is a multi-byte bitmask where each bit represents one sampler slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GSSamplers)
Public property | GeometryShaderShaderResources | Array of geometry-shader resources. The array is a multi-byte bitmask where each bit represents one resource slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GSShaderResources)
Public property | InputAssemblerIndexBuffer | Boolean value indicating whether to save the index buffer state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAIndexBuffer)
Public property | InputAssemblerInputLayout | Boolean value indicating whether to save the input layout state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAInputLayout)
Public property | InputAssemblerPrimitiveTopology | Boolean value indicating whether to save the primitive topology state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAPrimitiveTopology)
Public property | InputAssemblerVertexBuffers | Array of vertex buffers. The array is a multi-byte bitmask where each bit represents one resource slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAVertexBuffers)
Public property | OutputMergerBlendState | Boolean value indicating whether to save the blend state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.OMBlendState)
Public property | OutputMergerDepthStencilState | Boolean value indicating whether to save the depth-stencil state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.OMDepthStencilState)
Public property | OutputMergerRenderTargets | Boolean value indicating whether to save the render targets states. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.OMRenderTargets)
Public property | PixelShader | Boolean value indicating whether to save the pixel shader state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PS)
Public property | PixelShaderConstantBuffers | Array of pixel-shader constant buffers. The array is a multi-byte bitmask where each bit represents one constant buffer slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PSConstantBuffers)
Public property | PixelShaderSamplers | Array of pixel-shader samplers. The array is a multi-byte bitmask where each bit represents one sampler slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PSSamplers)
Public property | PixelShaderShaderResources | Array of pixel-shader resources. The array is a multi-byte bitmask where each bit represents one resource slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PSShaderResources)
Public property | Predication | Boolean value indicating whether to save the predication state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.Predication)
Public property | RasterizerScissorRectangles | Boolean value indicating whether to save the scissor rectangles states. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.RSScissorRects)
Public property | RasterizerState | Boolean value indicating whether to save the rasterizer state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.RSRasterizerState)
Public property | RasterizerViewports | Boolean value indicating whether to save the viewports states. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.RSViewports)
Public property | StreamOutputBuffers | Boolean value indicating whether to save the stream-out buffers states. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.SOBuffers)
Public property | VertexShader | Boolean value indicating whether to save the vertex shader state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VS)
Public property | VertexShaderConstantBuffers | Array of vertex-shader constant buffers. The array is a multi-byte bitmask where each bit represents one constant buffer slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VSConstantBuffers)
Public property | VertexShaderSamplers | Array of vertex-shader samplers. The array is a multi-byte bitmask where each bit represents one sampler slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VSSamplers)
Public property | VertexShaderShaderResources | Array of vertex-shader resources. The array is a multi-byte bitmask where each bit represents one resource slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VSShaderResources)

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlockMask Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask Constructor
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask()
Visual Basic
Public Sub New
Visual C++
public:
StateBlockMask()

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlockMask Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask Methods
StateBlockMask Class See Also Send Feedback

The StateBlockMask type exposes the following members.

Methods

 | Name | Description
Public method | ~StateBlockMask |
Public method | BitwiseAnd |
Public method | BitwiseOr |
Public method | DisableAll |
Public method | DisableCapture |
Public method | Dispose()()()() |
Protected method | Dispose(Boolean) |
Public method | EnableAll |
Public method | EnableCapture |
Public method | Xor |

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


~StateBlockMask Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..~StateBlockMask Method
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ~StateBlockMask()
Visual Basic
Public Sub ~StateBlockMask
Visual C++
public:
void ~StateBlockMask()

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BitwiseAnd Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..BitwiseAnd Method
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask BitwiseAnd(
    StateBlockMask otherMask
)
Visual Basic
Public Function BitwiseAnd ( _
    otherMask As StateBlockMask _
) As StateBlockMask
Visual C++
public:
StateBlockMask^ BitwiseAnd(
    StateBlockMask^ otherMask
)

Parameters

otherMask
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BitwiseOr Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..BitwiseOr Method
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask BitwiseOr(
    StateBlockMask otherMask
)
Visual Basic
Public Function BitwiseOr ( _
    otherMask As StateBlockMask _
) As StateBlockMask
Visual C++
public:
StateBlockMask^ BitwiseOr(
    StateBlockMask^ otherMask
)

Parameters

otherMask
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DisableAll Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..DisableAll Method
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask DisableAll()
Visual Basic
Public Function DisableAll As StateBlockMask
Visual C++
public:
StateBlockMask^ DisableAll()

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


DisableCapture Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..DisableCapture Method
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask DisableCapture(
    DeviceStateType type,
    int start,
    int length
)
Visual Basic
Public Function DisableCapture ( _
    type As DeviceStateType, _
    start As Integer, _
    length As Integer _
) As StateBlockMask
Visual C++
public:
StateBlockMask^ DisableCapture(
    DeviceStateType type,
    int start,
    int length
)

Parameters

type
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceStateType
start
Type: System..::..Int32
length
Type: System..::..Int32

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Dispose Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..Dispose Method
StateBlockMask Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() |
Protected method | Dispose(Boolean) |

See Also

StateBlockMask Class
StateBlockMask Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Dispose Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..Dispose Method
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

StateBlockMask Class
Dispose Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Dispose Method (Boolean)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..Dispose Method (Boolean)
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Dispose(
    bool
)
Visual Basic
Protected Overridable Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool
)

Parameters

Type: System..::..Boolean

See Also

StateBlockMask Class
Dispose Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EnableAll Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..EnableAll Method
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask EnableAll()
Visual Basic
Public Function EnableAll As StateBlockMask
Visual C++
public:
StateBlockMask^ EnableAll()

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


EnableCapture Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..EnableCapture Method
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask EnableCapture(
    DeviceStateType type,
    int start,
    int length
)
Visual Basic
Public Function EnableCapture ( _
    type As DeviceStateType, _
    start As Integer, _
    length As Integer _
) As StateBlockMask
Visual C++
public:
StateBlockMask^ EnableCapture(
    DeviceStateType type,
    int start,
    int length
)

Parameters

type
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceStateType
start
Type: System..::..Int32
length
Type: System..::..Int32

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Xor Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..Xor Method
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StateBlockMask Xor(
    StateBlockMask otherMask
)
Visual Basic
Public Function Xor ( _
    otherMask As StateBlockMask _
) As StateBlockMask
Visual C++
public:
StateBlockMask^ Xor(
    StateBlockMask^ otherMask
)

Parameters

otherMask
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlockMask Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask Operators
StateBlockMask Class See Also Send Feedback

The StateBlockMask type exposes the following members.

Operators

Name | Description
BitwiseAnd |
BitwiseOr |
ExclusiveOr |

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BitwiseAnd Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..BitwiseAnd Operator
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static StateBlockMask operator &(
    StateBlockMask mask1,
    StateBlockMask mask2
)
Visual Basic
Public Shared Operator And ( _
    mask1 As StateBlockMask, _
    mask2 As StateBlockMask _
) As StateBlockMask
Visual C++
public:
static StateBlockMask^ operator &(
    StateBlockMask^ mask1,
    StateBlockMask^ mask2
)

Parameters

mask1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask
mask2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BitwiseOr Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..BitwiseOr Operator
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static StateBlockMask operator |(
    StateBlockMask mask1,
    StateBlockMask mask2
)
Visual Basic
Public Shared Operator Or ( _
    mask1 As StateBlockMask, _
    mask2 As StateBlockMask _
) As StateBlockMask
Visual C++
public:
static StateBlockMask^ operator |(
    StateBlockMask^ mask1,
    StateBlockMask^ mask2
)

Parameters

mask1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask
mask2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ExclusiveOr Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..ExclusiveOr Operator
StateBlockMask Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static StateBlockMask operator ^(
    StateBlockMask mask1,
    StateBlockMask mask2
)
Visual Basic
Public Shared Operator Xor ( _
    mask1 As StateBlockMask, _
    mask2 As StateBlockMask _
) As StateBlockMask
Visual C++
public:
static StateBlockMask^ operator ^(
    StateBlockMask^ mask1,
    StateBlockMask^ mask2
)

Parameters

mask1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask
mask2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StateBlockMask

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StateBlockMask Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask Properties
StateBlockMask Class See Also Send Feedback

The StateBlockMask type exposes the following members.

Properties

 | Name | Description
Public property | GeometryShader | Boolean value indicating whether to save the geometry shader state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GS)
Public property | GeometryShaderConstantBuffers | Array of geometry-shader constant buffers. The array is a multi-byte bitmask where each bit represents one buffer slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GSConstantBuffers)
Public property | GeometryShaderSamplers | Array of geometry-shader samplers. The array is a multi-byte bitmask where each bit represents one sampler slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GSSamplers)
Public property | GeometryShaderShaderResources | Array of geometry-shader resources. The array is a multi-byte bitmask where each bit represents one resource slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GSShaderResources)
Public property | InputAssemblerIndexBuffer | Boolean value indicating whether to save the index buffer state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAIndexBuffer)
Public property | InputAssemblerInputLayout | Boolean value indicating whether to save the input layout state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAInputLayout)
Public property | InputAssemblerPrimitiveTopology | Boolean value indicating whether to save the primitive topology state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAPrimitiveTopology)
Public property | InputAssemblerVertexBuffers | Array of vertex buffers. The array is a multi-byte bitmask where each bit represents one resource slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAVertexBuffers)
Public property | OutputMergerBlendState | Boolean value indicating whether to save the blend state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.OMBlendState)
Public property | OutputMergerDepthStencilState | Boolean value indicating whether to save the depth-stencil state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.OMDepthStencilState)
Public property | OutputMergerRenderTargets | Boolean value indicating whether to save the render targets states. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.OMRenderTargets)
Public property | PixelShader | Boolean value indicating whether to save the pixel shader state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PS)
Public property | PixelShaderConstantBuffers | Array of pixel-shader constant buffers. The array is a multi-byte bitmask where each bit represents one constant buffer slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PSConstantBuffers)
Public property | PixelShaderSamplers | Array of pixel-shader samplers. The array is a multi-byte bitmask where each bit represents one sampler slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PSSamplers)
Public property | PixelShaderShaderResources | Array of pixel-shader resources. The array is a multi-byte bitmask where each bit represents one resource slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PSShaderResources)
Public property | Predication | Boolean value indicating whether to save the predication state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.Predication)
Public property | RasterizerScissorRectangles | Boolean value indicating whether to save the scissor rectangles states. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.RSScissorRects)
Public property | RasterizerState | Boolean value indicating whether to save the rasterizer state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.RSRasterizerState)
Public property | RasterizerViewports | Boolean value indicating whether to save the viewports states. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.RSViewports)
Public property | StreamOutputBuffers | Boolean value indicating whether to save the stream-out buffers states. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.SOBuffers)
Public property | VertexShader | Boolean value indicating whether to save the vertex shader state. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VS)
Public property | VertexShaderConstantBuffers | Array of vertex-shader constant buffers. The array is a multi-byte bitmask where each bit represents one constant buffer slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VSConstantBuffers)
Public property | VertexShaderSamplers | Array of vertex-shader samplers. The array is a multi-byte bitmask where each bit represents one sampler slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VSSamplers)
Public property | VertexShaderShaderResources | Array of vertex-shader resources. The array is a multi-byte bitmask where each bit represents one resource slot. (Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VSShaderResources)

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..GeometryShader Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the geometry shader state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool GeometryShader { get; }
Visual Basic
Public ReadOnly Property GeometryShader As Boolean
    Get
Visual C++
public:
property bool GeometryShader {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderConstantBuffers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..GeometryShaderConstantBuffers Property
StateBlockMask Class See Also Send Feedback
Array of geometry-shader constant buffers. The array is a multi-byte bitmask where each bit represents one buffer slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GSConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> GeometryShaderConstantBuffers { get; }
Visual Basic
Public ReadOnly Property GeometryShaderConstantBuffers As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ GeometryShaderConstantBuffers {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderSamplers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..GeometryShaderSamplers Property
StateBlockMask Class See Also Send Feedback
Array of geometry-shader samplers. The array is a multi-byte bitmask where each bit represents one sampler slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GSSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> GeometryShaderSamplers { get; }
Visual Basic
Public ReadOnly Property GeometryShaderSamplers As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ GeometryShaderSamplers {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GeometryShaderShaderResources Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..GeometryShaderShaderResources Property
StateBlockMask Class See Also Send Feedback
Array of geometry-shader resources. The array is a multi-byte bitmask where each bit represents one resource slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.GSShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> GeometryShaderShaderResources { get; }
Visual Basic
Public ReadOnly Property GeometryShaderShaderResources As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ GeometryShaderShaderResources {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerIndexBuffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..InputAssemblerIndexBuffer Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the index buffer state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAIndexBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool InputAssemblerIndexBuffer { get; }
Visual Basic
Public ReadOnly Property InputAssemblerIndexBuffer As Boolean
    Get
Visual C++
public:
property bool InputAssemblerIndexBuffer {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerInputLayout Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..InputAssemblerInputLayout Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the input layout state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAInputLayout)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool InputAssemblerInputLayout { get; }
Visual Basic
Public ReadOnly Property InputAssemblerInputLayout As Boolean
    Get
Visual C++
public:
property bool InputAssemblerInputLayout {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerPrimitiveTopology Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..InputAssemblerPrimitiveTopology Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the primitive topology state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAPrimitiveTopology)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool InputAssemblerPrimitiveTopology { get; }
Visual Basic
Public ReadOnly Property InputAssemblerPrimitiveTopology As Boolean
    Get
Visual C++
public:
property bool InputAssemblerPrimitiveTopology {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


InputAssemblerVertexBuffers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..InputAssemblerVertexBuffers Property
StateBlockMask Class See Also Send Feedback
Array of vertex buffers. The array is a multi-byte bitmask where each bit represents one resource slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.IAVertexBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> InputAssemblerVertexBuffers { get; }
Visual Basic
Public ReadOnly Property InputAssemblerVertexBuffers As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ InputAssemblerVertexBuffers {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerBlendState Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..OutputMergerBlendState Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the blend state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.OMBlendState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool OutputMergerBlendState { get; }
Visual Basic
Public ReadOnly Property OutputMergerBlendState As Boolean
    Get
Visual C++
public:
property bool OutputMergerBlendState {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerDepthStencilState Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..OutputMergerDepthStencilState Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the depth-stencil state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.OMDepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool OutputMergerDepthStencilState { get; }
Visual Basic
Public ReadOnly Property OutputMergerDepthStencilState As Boolean
    Get
Visual C++
public:
property bool OutputMergerDepthStencilState {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputMergerRenderTargets Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..OutputMergerRenderTargets Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the render targets states.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.OMRenderTargets)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool OutputMergerRenderTargets { get; }
Visual Basic
Public ReadOnly Property OutputMergerRenderTargets As Boolean
    Get
Visual C++
public:
property bool OutputMergerRenderTargets {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..PixelShader Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the pixel shader state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool PixelShader { get; }
Visual Basic
Public ReadOnly Property PixelShader As Boolean
    Get
Visual C++
public:
property bool PixelShader {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderConstantBuffers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..PixelShaderConstantBuffers Property
StateBlockMask Class See Also Send Feedback
Array of pixel-shader constant buffers. The array is a multi-byte bitmask where each bit represents one constant buffer slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PSConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> PixelShaderConstantBuffers { get; }
Visual Basic
Public ReadOnly Property PixelShaderConstantBuffers As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ PixelShaderConstantBuffers {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderSamplers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..PixelShaderSamplers Property
StateBlockMask Class See Also Send Feedback
Array of pixel-shader samplers. The array is a multi-byte bitmask where each bit represents one sampler slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PSSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> PixelShaderSamplers { get; }
Visual Basic
Public ReadOnly Property PixelShaderSamplers As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ PixelShaderSamplers {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


PixelShaderShaderResources Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..PixelShaderShaderResources Property
StateBlockMask Class See Also Send Feedback
Array of pixel-shader resources. The array is a multi-byte bitmask where each bit represents one resource slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.PSShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> PixelShaderShaderResources { get; }
Visual Basic
Public ReadOnly Property PixelShaderShaderResources As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ PixelShaderShaderResources {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Predication Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..Predication Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the predication state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.Predication)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool Predication { get; }
Visual Basic
Public ReadOnly Property Predication As Boolean
    Get
Visual C++
public:
property bool Predication {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerScissorRectangles Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..RasterizerScissorRectangles Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the scissor rectangles states.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.RSScissorRects)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool RasterizerScissorRectangles { get; }
Visual Basic
Public ReadOnly Property RasterizerScissorRectangles As Boolean
    Get
Visual C++
public:
property bool RasterizerScissorRectangles {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerState Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..RasterizerState Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the rasterizer state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.RSRasterizerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool RasterizerState { get; }
Visual Basic
Public ReadOnly Property RasterizerState As Boolean
    Get
Visual C++
public:
property bool RasterizerState {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


RasterizerViewports Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..RasterizerViewports Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the viewports states.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.RSViewports)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool RasterizerViewports { get; }
Visual Basic
Public ReadOnly Property RasterizerViewports As Boolean
    Get
Visual C++
public:
property bool RasterizerViewports {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputBuffers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..StreamOutputBuffers Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the stream-out buffers states.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.SOBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool StreamOutputBuffers { get; }
Visual Basic
Public ReadOnly Property StreamOutputBuffers As Boolean
    Get
Visual C++
public:
property bool StreamOutputBuffers {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..VertexShader Property
StateBlockMask Class See Also Send Feedback
Boolean value indicating whether to save the vertex shader state.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool VertexShader { get; }
Visual Basic
Public ReadOnly Property VertexShader As Boolean
    Get
Visual C++
public:
property bool VertexShader {
    bool get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderConstantBuffers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..VertexShaderConstantBuffers Property
StateBlockMask Class See Also Send Feedback
Array of vertex-shader constant buffers. The array is a multi-byte bitmask where each bit represents one constant buffer slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VSConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> VertexShaderConstantBuffers { get; }
Visual Basic
Public ReadOnly Property VertexShaderConstantBuffers As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ VertexShaderConstantBuffers {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderSamplers Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..VertexShaderSamplers Property
StateBlockMask Class See Also Send Feedback
Array of vertex-shader samplers. The array is a multi-byte bitmask where each bit represents one sampler slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VSSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> VertexShaderSamplers { get; }
Visual Basic
Public ReadOnly Property VertexShaderSamplers As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ VertexShaderSamplers {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderShaderResources Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StateBlockMask..::..VertexShaderShaderResources Property
StateBlockMask Class See Also Send Feedback
Array of vertex-shader resources. The array is a multi-byte bitmask where each bit represents one resource slot.

(Also see DirectX SDK: D3D10_STATE_BLOCK_MASK.VSShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<byte> VertexShaderShaderResources { get; }
Visual Basic
Public ReadOnly Property VertexShaderShaderResources As ReadOnlyCollection(Of Byte)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned char>^ VertexShaderShaderResources {
    ReadOnlyCollection<unsigned char>^ get ();
}

See Also

StateBlockMask Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilOperation Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StencilOperation Enumeration
See Also Send Feedback
The stencil operations that can be performed during depth-stencil testing.

(Also see DirectX SDK: D3D10_STENCIL_OP)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum StencilOperation
Visual Basic
Public Enumeration StencilOperation
Visual C++
public enum class StencilOperation

Members

Member name | Description
Invert |
Replace |
Zero |
Decrement |
Increment |
DecrementSat |
IncrementSat |
Keep |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilReadMask Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StencilReadMask Enumeration
See Also Send Feedback
A value that identifies a portion of the depth-stencil buffer for reading stencil data.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum StencilReadMask
Visual Basic
Public Enumeration StencilReadMask
Visual C++
public enum class StencilReadMask

Members

Member name | Description
None |
All |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StencilWriteMask Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StencilWriteMask Enumeration
See Also Send Feedback
A value that identifies a portion of the depth-stencil buffer for writing stencil data.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum StencilWriteMask
Visual Basic
Public Enumeration StencilWriteMask
Visual C++
public enum class StencilWriteMask

Members

Member name | Description
None |
All |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputDeclarationEntry Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Structure
Members See Also Send Feedback
Description of a vertex element in a vertex buffer in an output slot.

(Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct StreamOutputDeclarationEntry
Visual Basic
Public Structure StreamOutputDeclarationEntry
Visual C++
public value class StreamOutputDeclarationEntry

See Also

StreamOutputDeclarationEntry Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputDeclarationEntry Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Members
StreamOutputDeclarationEntry Structure Methods Operators Properties See Also Send Feedback

The StreamOutputDeclarationEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ComponentCount | The number of components of the entry to write out to. Valid values are 1 ~ 4. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2. (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.ComponentCount)
Public property | OutputSlot | The output slot that contains the vertex buffer that contains this output entry. (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.OutputSlot)
Public property | SemanticIndex | Output element's zero-based index. Should be used if, for example, you have more than one texture coordinate stored in each vertex. (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.SemanticIndex)
Public property | SemanticName | Type of output element. Possible values: "POSITION", "NORMAL", or "TEXCOORD0". (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.SemanticName)
Public property | StartComponent | Which component of the entry to begin writing out to. Valid values are 0 ~ 3. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2. (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.StartComponent)

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputDeclarationEntry Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Methods
StreamOutputDeclarationEntry Structure See Also Send Feedback

The StreamOutputDeclarationEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..Equals Method
StreamOutputDeclarationEntry Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..GetHashCode Method
StreamOutputDeclarationEntry Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputDeclarationEntry Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Operators
StreamOutputDeclarationEntry Structure See Also Send Feedback

The StreamOutputDeclarationEntry type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..Equality Operator
StreamOutputDeclarationEntry Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    StreamOutputDeclarationEntry streamOutputDeclarationEntry1,
    StreamOutputDeclarationEntry streamOutputDeclarationEntry2
)
Visual Basic
Public Shared Operator = ( _
    streamOutputDeclarationEntry1 As StreamOutputDeclarationEntry, _
    streamOutputDeclarationEntry2 As StreamOutputDeclarationEntry _
) As Boolean
Visual C++
public:
static bool operator ==(
    StreamOutputDeclarationEntry streamOutputDeclarationEntry1,
    StreamOutputDeclarationEntry streamOutputDeclarationEntry2
)

Parameters

streamOutputDeclarationEntry1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StreamOutputDeclarationEntry
streamOutputDeclarationEntry2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StreamOutputDeclarationEntry

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..Inequality Operator
StreamOutputDeclarationEntry Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    StreamOutputDeclarationEntry streamOutputDeclarationEntry1,
    StreamOutputDeclarationEntry streamOutputDeclarationEntry2
)
Visual Basic
Public Shared Operator <> ( _
    streamOutputDeclarationEntry1 As StreamOutputDeclarationEntry, _
    streamOutputDeclarationEntry2 As StreamOutputDeclarationEntry _
) As Boolean
Visual C++
public:
static bool operator !=(
    StreamOutputDeclarationEntry streamOutputDeclarationEntry1,
    StreamOutputDeclarationEntry streamOutputDeclarationEntry2
)

Parameters

streamOutputDeclarationEntry1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StreamOutputDeclarationEntry
streamOutputDeclarationEntry2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StreamOutputDeclarationEntry

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputDeclarationEntry Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Properties
StreamOutputDeclarationEntry Structure See Also Send Feedback

The StreamOutputDeclarationEntry type exposes the following members.

Properties

 | Name | Description
Public property | ComponentCount | The number of components of the entry to write out to. Valid values are 1 ~ 4. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2. (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.ComponentCount)
Public property | OutputSlot | The output slot that contains the vertex buffer that contains this output entry. (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.OutputSlot)
Public property | SemanticIndex | Output element's zero-based index. Should be used if, for example, you have more than one texture coordinate stored in each vertex. (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.SemanticIndex)
Public property | SemanticName | Type of output element. Possible values: "POSITION", "NORMAL", or "TEXCOORD0". (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.SemanticName)
Public property | StartComponent | Which component of the entry to begin writing out to. Valid values are 0 ~ 3. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2. (Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.StartComponent)

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ComponentCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..ComponentCount Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
The number of components of the entry to write out to. Valid values are 1 ~ 4. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2.

(Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.ComponentCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte ComponentCount { get; set; }
Visual Basic
Public Property ComponentCount As Byte
    Get
    Set
Visual C++
public:
property unsigned char ComponentCount {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


OutputSlot Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..OutputSlot Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
The output slot that contains the vertex buffer that contains this output entry.

(Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.OutputSlot)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte OutputSlot { get; set; }
Visual Basic
Public Property OutputSlot As Byte
    Get
    Set
Visual C++
public:
property unsigned char OutputSlot {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SemanticIndex Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..SemanticIndex Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
Output element's zero-based index. Should be used if, for example, you have more than one texture coordinate stored in each vertex.

(Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.SemanticIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SemanticIndex { get; set; }
Visual Basic
Public Property SemanticIndex As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SemanticIndex {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SemanticName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..SemanticName Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
Type of output element. Possible values: "POSITION", "NORMAL", or "TEXCOORD0".

(Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.SemanticName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string SemanticName { get; set; }
Visual Basic
Public Property SemanticName As String
    Get
    Set
Visual C++
public:
property String^ SemanticName {
    String^ get ();
    void set (String^ value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StartComponent Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..StartComponent Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
Which component of the entry to begin writing out to. Valid values are 0 ~ 3. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2.

(Also see DirectX SDK: D3D10_SO_DECLARATION_ENTRY.StartComponent)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte StartComponent { get; set; }
Visual Basic
Public Property StartComponent As Byte
    Get
    Set
Visual C++
public:
property unsigned char StartComponent {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage Class
Members See Also Send Feedback
StreamOutput pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class StreamOutputPipelineStage : PipelineStage
Visual Basic
Public Class StreamOutputPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class StreamOutputPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..StreamOutputPipelineStage

See Also

StreamOutputPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage Members
StreamOutputPipelineStage Class Constructors Properties See Also Send Feedback

The StreamOutputPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | StreamOutputPipelineStage |

Properties

 | Name | Description
Public property | Targets | Gets or sets the target output buffers for the stream-output stage of the pipeline. See OutputBuffer. (Also see DirectX SDK: ID3D10Device::SOGetTargets, ID3D10Device::SOSetTargets)

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage Constructor
StreamOutputPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected StreamOutputPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
StreamOutputPipelineStage()

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


StreamOutputPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage Properties
StreamOutputPipelineStage Class See Also Send Feedback

The StreamOutputPipelineStage type exposes the following members.

Properties

 | Name | Description
Public property | Targets | Gets or sets the target output buffers for the stream-output stage of the pipeline. See OutputBuffer. (Also see DirectX SDK: ID3D10Device::SOGetTargets, ID3D10Device::SOSetTargets)

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Targets Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage..::..Targets Property
StreamOutputPipelineStage Class See Also Send Feedback
Gets or sets the target output buffers for the stream-output stage of the pipeline. See OutputBuffer.

(Also see DirectX SDK: ID3D10Device::SOGetTargets, ID3D10Device::SOSetTargets)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<OutputBuffer> Targets { get; set; }
Visual Basic
Public Property Targets As IEnumerable(Of OutputBuffer)
    Get
    Set
Visual C++
public:
property IEnumerable<OutputBuffer>^ Targets {
    IEnumerable<OutputBuffer>^ get ();
    void set (IEnumerable<OutputBuffer>^ value);
}

Remarks

Always returns four targets. It may be set with fewer than four, in which case the remaining targets will be set to null.

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SubresourceData Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData Structure
Members See Also Send Feedback
Specifies data for initializing a subresource.

(Also see DirectX SDK: D3D10_SUBRESOURCE_DATA)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SubresourceData
Visual Basic
Public Structure SubresourceData
Visual C++
public value class SubresourceData

See Also

SubresourceData Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SubresourceData Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData Members
SubresourceData Structure Properties See Also Send Feedback

The SubresourceData type exposes the following members.

Properties

 | Name | Description
Public property | SystemMemory | Pointer to the initialization data. (Also see DirectX SDK: D3D10_SUBRESOURCE_DATA.pSysMem)
Public property | SystemMemoryPitch | Pitch of the memory (in bytes). System-memory pitch is used only for 2D and 3D texture data as it is has no meaning for the other resource types. (Also see DirectX SDK: D3D10_SUBRESOURCE_DATA.SysMemPitch)
Public property | SystemMemorySlicePitch | Size of one depth level (in bytes). System-memory-slice pitch is only used for 3D texture data as it has no meaning for the other resource types. (Also see DirectX SDK: D3D10_SUBRESOURCE_DATA.SysMemSlicePitch)

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SubresourceData Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData Properties
SubresourceData Structure See Also Send Feedback

The SubresourceData type exposes the following members.

Properties

 | Name | Description
Public property | SystemMemory | Pointer to the initialization data. (Also see DirectX SDK: D3D10_SUBRESOURCE_DATA.pSysMem)
Public property | SystemMemoryPitch | Pitch of the memory (in bytes). System-memory pitch is used only for 2D and 3D texture data as it is has no meaning for the other resource types. (Also see DirectX SDK: D3D10_SUBRESOURCE_DATA.SysMemPitch)
Public property | SystemMemorySlicePitch | Size of one depth level (in bytes). System-memory-slice pitch is only used for 3D texture data as it has no meaning for the other resource types. (Also see DirectX SDK: D3D10_SUBRESOURCE_DATA.SysMemSlicePitch)

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SystemMemory Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData..::..SystemMemory Property
SubresourceData Structure See Also Send Feedback
Pointer to the initialization data.

(Also see DirectX SDK: D3D10_SUBRESOURCE_DATA.pSysMem)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr SystemMemory { get; set; }
Visual Basic
Public Property SystemMemory As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr SystemMemory {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SystemMemoryPitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData..::..SystemMemoryPitch Property
SubresourceData Structure See Also Send Feedback
Pitch of the memory (in bytes). System-memory pitch is used only for 2D and 3D texture data as it is has no meaning for the other resource types.

(Also see DirectX SDK: D3D10_SUBRESOURCE_DATA.SysMemPitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SystemMemoryPitch { get; set; }
Visual Basic
Public Property SystemMemoryPitch As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SystemMemoryPitch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SystemMemorySlicePitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData..::..SystemMemorySlicePitch Property
SubresourceData Structure See Also Send Feedback
Size of one depth level (in bytes). System-memory-slice pitch is only used for 3D texture data as it has no meaning for the other resource types.

(Also see DirectX SDK: D3D10_SUBRESOURCE_DATA.SysMemSlicePitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SystemMemorySlicePitch { get; set; }
Visual Basic
Public Property SystemMemorySlicePitch As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SystemMemorySlicePitch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SwitchToRef Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwitchToRef Class
Members See Also Send Feedback
A swith-to-reference interface (see the switch-to-reference layer) enables an application to switch between a hardware and software device.

(Also see DirectX SDK: ID3D10SwitchToRef)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class SwitchToRef : DirectUnknown
Visual Basic
Public Class SwitchToRef _
    Inherits DirectUnknown
Visual C++
public ref class SwitchToRef : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SwitchToRef

See Also

SwitchToRef Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SwitchToRef Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwitchToRef Members
SwitchToRef Class Properties See Also Send Feedback

The SwitchToRef type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | UseRef | Get or set a boolean value that indicates the type of device being used. Set this to True to change to a software device, set this to False to change to a hardware device. (Also see DirectX SDK: ID3D10SwitchToRef::GetUseRef, ID3D10SwitchToRef::SetUseRef)

See Also

SwitchToRef Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SwitchToRef Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwitchToRef Properties
SwitchToRef Class See Also Send Feedback

The SwitchToRef type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | UseRef | Get or set a boolean value that indicates the type of device being used. Set this to True to change to a software device, set this to False to change to a hardware device. (Also see DirectX SDK: ID3D10SwitchToRef::GetUseRef, ID3D10SwitchToRef::SetUseRef)

See Also

SwitchToRef Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UseRef Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwitchToRef..::..UseRef Property
SwitchToRef Class See Also Send Feedback
Get or set a boolean value that indicates the type of device being used. Set this to True to change to a software device, set this to False to change to a hardware device.

(Also see DirectX SDK: ID3D10SwitchToRef::GetUseRef, ID3D10SwitchToRef::SetUseRef)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool UseRef { get; set; }
Visual Basic
Public Property UseRef As Boolean
    Get
    Set
Visual C++
public:
property bool UseRef {
    bool get ();
    void set (bool value);
}

See Also

SwitchToRef Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TechniqueDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription Structure
Members See Also Send Feedback
Describes an effect technique.

(Also see DirectX SDK: D3D10_TECHNIQUE_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct TechniqueDescription
Visual Basic
Public Structure TechniqueDescription
Visual C++
public value class TechniqueDescription

See Also

TechniqueDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TechniqueDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription Members
TechniqueDescription Structure Methods Operators Properties See Also Send Feedback

The TechniqueDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Annotations | The number of annotations. (Also see DirectX SDK: D3D10_TECHNIQUE_DESC.Annotations)
Public property | Name | A string that contains the technique name; otherwise NULL. (Also see DirectX SDK: D3D10_TECHNIQUE_DESC.Name)
Public property | Passes | The number of passes in the technique. (Also see DirectX SDK: D3D10_TECHNIQUE_DESC.Passes)

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TechniqueDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription Methods
TechniqueDescription Structure See Also Send Feedback

The TechniqueDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription..::..Equals Method
TechniqueDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription..::..GetHashCode Method
TechniqueDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TechniqueDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription Operators
TechniqueDescription Structure See Also Send Feedback

The TechniqueDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription..::..Equality Operator
TechniqueDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    TechniqueDescription techniqueDescription1,
    TechniqueDescription techniqueDescription2
)
Visual Basic
Public Shared Operator = ( _
    techniqueDescription1 As TechniqueDescription, _
    techniqueDescription2 As TechniqueDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    TechniqueDescription techniqueDescription1,
    TechniqueDescription techniqueDescription2
)

Parameters

techniqueDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TechniqueDescription
techniqueDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TechniqueDescription

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription..::..Inequality Operator
TechniqueDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    TechniqueDescription techniqueDescription1,
    TechniqueDescription techniqueDescription2
)
Visual Basic
Public Shared Operator <> ( _
    techniqueDescription1 As TechniqueDescription, _
    techniqueDescription2 As TechniqueDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    TechniqueDescription techniqueDescription1,
    TechniqueDescription techniqueDescription2
)

Parameters

techniqueDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TechniqueDescription
techniqueDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TechniqueDescription

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TechniqueDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription Properties
TechniqueDescription Structure See Also Send Feedback

The TechniqueDescription type exposes the following members.

Properties

 | Name | Description
Public property | Annotations | The number of annotations. (Also see DirectX SDK: D3D10_TECHNIQUE_DESC.Annotations)
Public property | Name | A string that contains the technique name; otherwise NULL. (Also see DirectX SDK: D3D10_TECHNIQUE_DESC.Name)
Public property | Passes | The number of passes in the technique. (Also see DirectX SDK: D3D10_TECHNIQUE_DESC.Passes)

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Annotations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription..::..Annotations Property
TechniqueDescription Structure See Also Send Feedback
The number of annotations.

(Also see DirectX SDK: D3D10_TECHNIQUE_DESC.Annotations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Annotations { get; set; }
Visual Basic
Public Property Annotations As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Annotations {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Name Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription..::..Name Property
TechniqueDescription Structure See Also Send Feedback
A string that contains the technique name; otherwise NULL.

(Also see DirectX SDK: D3D10_TECHNIQUE_DESC.Name)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Passes Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TechniqueDescription..::..Passes Property
TechniqueDescription Structure See Also Send Feedback
The number of passes in the technique.

(Also see DirectX SDK: D3D10_TECHNIQUE_DESC.Passes)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Passes { get; set; }
Visual Basic
Public Property Passes As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Passes {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TechniqueDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1D Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D Class
Members See Also Send Feedback
A 1D texture interface accesses texel data, which is structured memory.

(Also see DirectX SDK: ID3D10Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Texture1D : D3DResource
Visual Basic
Public Class Texture1D _
    Inherits D3DResource
Visual C++
public ref class Texture1D : public D3DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1D

See Also

Texture1D Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1D Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D Members
Texture1D Class Methods Properties See Also Send Feedback

The Texture1D type exposes the following members.

Methods

 | Name | Description
Public method | Map | Get the data contained in a subresource, and deny the GPU access to that subresource. (Also see DirectX SDK: ID3D10Texture1D::Map)
Public method | Unmap | Invalidate the resource that was retrieved by Texture1D.Map, and re-enable the GPU's access to that resource. (Also see DirectX SDK: ID3D10Texture1D::Unmap)

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D10Texture1D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType) (Inherited from D3DResource.)

See Also

Texture1D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1D Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D Methods
Texture1D Class See Also Send Feedback

The Texture1D type exposes the following members.

Methods

 | Name | Description
Public method | Map | Get the data contained in a subresource, and deny the GPU access to that subresource. (Also see DirectX SDK: ID3D10Texture1D::Map)
Public method | Unmap | Invalidate the resource that was retrieved by Texture1D.Map, and re-enable the GPU's access to that resource. (Also see DirectX SDK: ID3D10Texture1D::Unmap)

See Also

Texture1D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Map Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D..::..Map Method
Texture1D Class See Also Send Feedback
Get the data contained in a subresource, and deny the GPU access to that subresource.

(Also see DirectX SDK: ID3D10Texture1D::Map)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr Map(
    uint subresourceIndex,
    Map type,
    MapOptions options
)
Visual Basic
Public Function Map ( _
    subresourceIndex As UInteger, _
    type As Map, _
    options As MapOptions _
) As IntPtr
Visual C++
public:
IntPtr Map(
    unsigned int subresourceIndex,
    Map type,
    MapOptions options
)

Parameters

subresourceIndex
Type: System..::..UInt32
Index number of the subresource. See D3D10CalcSubresource for more details.
type
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Map
Specifies the CPU's read and write permissions for a resource. For possible values, see Map.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MapOptions
Flag that specifies what the CPU should do when the GPU is busy. This flag is optional.

Return Value

Pointer to the texture resource data.

See Also

Texture1D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Unmap Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D..::..Unmap Method
Texture1D Class See Also Send Feedback
Invalidate the resource that was retrieved by Texture1D.Map, and re-enable the GPU's access to that resource.

(Also see DirectX SDK: ID3D10Texture1D::Unmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Unmap(
    uint subresourceIndex
)
Visual Basic
Public Sub Unmap ( _
    subresourceIndex As UInteger _
)
Visual C++
public:
void Unmap(
    unsigned int subresourceIndex
)

Parameters

subresourceIndex
Type: System..::..UInt32
Subresource to be unmapped. See D3D10CalcSubresource for more details.

See Also

Texture1D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1D Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D Properties
Texture1D Class See Also Send Feedback

The Texture1D type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D10Texture1D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType) (Inherited from D3DResource.)

See Also

Texture1D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D..::..Description Property
Texture1D Class See Also Send Feedback
Get the properties of the texture resource.

(Also see DirectX SDK: ID3D10Texture1D::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As Texture1DDescription
    Get
Visual C++
public:
property Texture1DDescription Description {
    Texture1DDescription get ();
}

See Also

Texture1D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresource(s) from an array of 1D textures to use in a depth-stencil view.

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DArrayDepthStencilView
Visual Basic
Public Structure Texture1DArrayDepthStencilView
Visual C++
public value class Texture1DArrayDepthStencilView

See Also

Texture1DArrayDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Members
Texture1DArrayDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture1DArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV.FirstArraySlice)
Public property | MipSlice | The index of the first mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV.MipSlice)

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Methods
Texture1DArrayDepthStencilView Structure See Also Send Feedback

The Texture1DArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..Equals Method
Texture1DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..GetHashCode Method
Texture1DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Operators
Texture1DArrayDepthStencilView Structure See Also Send Feedback

The Texture1DArrayDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..Equality Operator
Texture1DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture1DArrayDepthStencilView textureArrayDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayDepthStencilView1 As Texture1DArrayDepthStencilView, _
    textureArrayDepthStencilView2 As Texture1DArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture1DArrayDepthStencilView textureArrayDepthStencilView2
)

Parameters

textureArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayDepthStencilView
textureArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayDepthStencilView

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..Inequality Operator
Texture1DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture1DArrayDepthStencilView textureArrayDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayDepthStencilView1 As Texture1DArrayDepthStencilView, _
    textureArrayDepthStencilView2 As Texture1DArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture1DArrayDepthStencilView textureArrayDepthStencilView2
)

Parameters

textureArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayDepthStencilView
textureArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayDepthStencilView

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Properties
Texture1DArrayDepthStencilView Structure See Also Send Feedback

The Texture1DArrayDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV.FirstArraySlice)
Public property | MipSlice | The index of the first mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV.MipSlice)

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..ArraySize Property
Texture1DArrayDepthStencilView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..FirstArraySlice Property
Texture1DArrayDepthStencilView Structure See Also Send Feedback
The index of the first texture to use in an array of textures (see array slice)

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..MipSlice Property
Texture1DArrayDepthStencilView Structure See Also Send Feedback
The index of the first mipmap level to use (see mip slice).

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_DSV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource(s) from an array of 1D textures to use in a render-target view.

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DArrayRenderTargetView
Visual Basic
Public Structure Texture1DArrayRenderTargetView
Visual C++
public value class Texture1DArrayRenderTargetView

See Also

Texture1DArrayRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Members
Texture1DArrayRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture1DArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV.FirstArraySlice)
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV.MipSlice)

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Methods
Texture1DArrayRenderTargetView Structure See Also Send Feedback

The Texture1DArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..Equals Method
Texture1DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..GetHashCode Method
Texture1DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Operators
Texture1DArrayRenderTargetView Structure See Also Send Feedback

The Texture1DArrayRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..Equality Operator
Texture1DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture1DArrayRenderTargetView textureArrayRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayRenderTargetView1 As Texture1DArrayRenderTargetView, _
    textureArrayRenderTargetView2 As Texture1DArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture1DArrayRenderTargetView textureArrayRenderTargetView2
)

Parameters

textureArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayRenderTargetView
textureArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayRenderTargetView

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..Inequality Operator
Texture1DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture1DArrayRenderTargetView textureArrayRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayRenderTargetView1 As Texture1DArrayRenderTargetView, _
    textureArrayRenderTargetView2 As Texture1DArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture1DArrayRenderTargetView textureArrayRenderTargetView2
)

Parameters

textureArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayRenderTargetView
textureArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayRenderTargetView

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Properties
Texture1DArrayRenderTargetView Structure See Also Send Feedback

The Texture1DArrayRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV.FirstArraySlice)
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV.MipSlice)

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..ArraySize Property
Texture1DArrayRenderTargetView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..FirstArraySlice Property
Texture1DArrayRenderTargetView Structure See Also Send Feedback
The index of the first texture to use in an array of textures (see array slice)

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..MipSlice Property
Texture1DArrayRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use (see mip slice).

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource(s) from an array of 1D textures to use in a shader-resource view.

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DArrayShaderResourceView
Visual Basic
Public Structure Texture1DArrayShaderResourceView
Visual C++
public value class Texture1DArrayShaderResourceView

See Also

Texture1DArrayShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Members
Texture1DArrayShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture1DArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.FirstArraySlice)
Public property | MipLevels | Number of subtextures to access. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.MostDetailedMip)

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Methods
Texture1DArrayShaderResourceView Structure See Also Send Feedback

The Texture1DArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..Equals Method
Texture1DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..GetHashCode Method
Texture1DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Operators
Texture1DArrayShaderResourceView Structure See Also Send Feedback

The Texture1DArrayShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..Equality Operator
Texture1DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture1DArrayShaderResourceView textureArrayShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayShaderResourceView1 As Texture1DArrayShaderResourceView, _
    textureArrayShaderResourceView2 As Texture1DArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture1DArrayShaderResourceView textureArrayShaderResourceView2
)

Parameters

textureArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayShaderResourceView
textureArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayShaderResourceView

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..Inequality Operator
Texture1DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture1DArrayShaderResourceView textureArrayShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayShaderResourceView1 As Texture1DArrayShaderResourceView, _
    textureArrayShaderResourceView2 As Texture1DArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture1DArrayShaderResourceView textureArrayShaderResourceView2
)

Parameters

textureArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayShaderResourceView
textureArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DArrayShaderResourceView

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DArrayShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Properties
Texture1DArrayShaderResourceView Structure See Also Send Feedback

The Texture1DArrayShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.FirstArraySlice)
Public property | MipLevels | Number of subtextures to access. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.MostDetailedMip)

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..ArraySize Property
Texture1DArrayShaderResourceView Structure See Also Send Feedback
Number of textures in the array.

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..FirstArraySlice Property
Texture1DArrayShaderResourceView Structure See Also Send Feedback
The index of the first texture to use in an array of textures (see array slice)

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..MipLevels Property
Texture1DArrayShaderResourceView Structure See Also Send Feedback
Number of subtextures to access.

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..MostDetailedMip Property
Texture1DArrayShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D10_TEX1D_ARRAY_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresource from a 1D texture that is accessable to a depth-stencil view.

(Also see DirectX SDK: D3D10_TEX1D_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DDepthStencilView
Visual Basic
Public Structure Texture1DDepthStencilView
Visual C++
public value class Texture1DDepthStencilView

See Also

Texture1DDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Members
Texture1DDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture1DDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The index of the first mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX1D_DSV.MipSlice)

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Methods
Texture1DDepthStencilView Structure See Also Send Feedback

The Texture1DDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..Equals Method
Texture1DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..GetHashCode Method
Texture1DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Operators
Texture1DDepthStencilView Structure See Also Send Feedback

The Texture1DDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..Equality Operator
Texture1DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DDepthStencilView textureDepthStencilView1,
    Texture1DDepthStencilView textureDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureDepthStencilView1 As Texture1DDepthStencilView, _
    textureDepthStencilView2 As Texture1DDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DDepthStencilView textureDepthStencilView1,
    Texture1DDepthStencilView textureDepthStencilView2
)

Parameters

textureDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDepthStencilView
textureDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDepthStencilView

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..Inequality Operator
Texture1DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DDepthStencilView textureDepthStencilView1,
    Texture1DDepthStencilView textureDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureDepthStencilView1 As Texture1DDepthStencilView, _
    textureDepthStencilView2 As Texture1DDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DDepthStencilView textureDepthStencilView1,
    Texture1DDepthStencilView textureDepthStencilView2
)

Parameters

textureDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDepthStencilView
textureDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDepthStencilView

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Properties
Texture1DDepthStencilView Structure See Also Send Feedback

The Texture1DDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The index of the first mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX1D_DSV.MipSlice)

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..MipSlice Property
Texture1DDepthStencilView Structure See Also Send Feedback
The index of the first mipmap level to use (see mip slice).

(Also see DirectX SDK: D3D10_TEX1D_DSV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Structure
Members See Also Send Feedback
Describes a 1D texture.

(Also see DirectX SDK: D3D10_TEXTURE1D_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DDescription
Visual Basic
Public Structure Texture1DDescription
Visual C++
public value class Texture1DDescription

See Also

Texture1DDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Members
Texture1DDescription Structure Methods Operators Properties See Also Send Feedback

The Texture1DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.ArraySize)
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.CPUAccessFlags)
Public property | Format | Texture format (see Format). (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.Format)
Public property | MipLevels | Number of subtextures (also called mipmap levels). Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.MiscFlags)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.Usage)
Public property | Width | Texture width (in texels). (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.Width)

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Methods
Texture1DDescription Structure See Also Send Feedback

The Texture1DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Equals Method
Texture1DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..GetHashCode Method
Texture1DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Operators
Texture1DDescription Structure See Also Send Feedback

The Texture1DDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Equality Operator
Texture1DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DDescription textureDescription1,
    Texture1DDescription textureDescription2
)
Visual Basic
Public Shared Operator = ( _
    textureDescription1 As Texture1DDescription, _
    textureDescription2 As Texture1DDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DDescription textureDescription1,
    Texture1DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDescription

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Inequality Operator
Texture1DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DDescription textureDescription1,
    Texture1DDescription textureDescription2
)
Visual Basic
Public Shared Operator <> ( _
    textureDescription1 As Texture1DDescription, _
    textureDescription2 As Texture1DDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DDescription textureDescription1,
    Texture1DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DDescription

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Properties
Texture1DDescription Structure See Also Send Feedback

The Texture1DDescription type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.ArraySize)
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.CPUAccessFlags)
Public property | Format | Texture format (see Format). (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.Format)
Public property | MipLevels | Number of subtextures (also called mipmap levels). Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.MiscFlags)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.Usage)
Public property | Width | Texture width (in texels). (Also see DirectX SDK: D3D10_TEXTURE1D_DESC.Width)

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..ArraySize Property
Texture1DDescription Structure See Also Send Feedback
Number of textures in the array.

(Also see DirectX SDK: D3D10_TEXTURE1D_DESC.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BindingOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..BindingOptions Property
Texture1DDescription Structure See Also Send Feedback
Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR.

(Also see DirectX SDK: D3D10_TEXTURE1D_DESC.BindFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BindingOptions BindingOptions { get; set; }
Visual Basic
Public Property BindingOptions As BindingOptions
    Get
    Set
Visual C++
public:
property BindingOptions BindingOptions {
    BindingOptions get ();
    void set (BindingOptions value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BindingOptions


CpuAccessOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..CpuAccessOptions Property
Texture1DDescription Structure See Also Send Feedback
Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D10_TEXTURE1D_DESC.CPUAccessFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CpuAccessOptions CpuAccessOptions { get; set; }
Visual Basic
Public Property CpuAccessOptions As CpuAccessOptions
    Get
    Set
Visual C++
public:
property CpuAccessOptions CpuAccessOptions {
    CpuAccessOptions get ();
    void set (CpuAccessOptions value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Texture1DDescription..::..CpuAccessOptions


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Format Property
Texture1DDescription Structure See Also Send Feedback
Texture format (see Format).

(Also see DirectX SDK: D3D10_TEXTURE1D_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Texture1DDescription..::..Format


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..MipLevels Property
Texture1DDescription Structure See Also Send Feedback
Number of subtextures (also called mipmap levels). Use 1 for a multisampled texture; or 0 to generate a full set of subtextures.

(Also see DirectX SDK: D3D10_TEXTURE1D_DESC.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MiscellaneousResourceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..MiscellaneousResourceOptions Property
Texture1DDescription Structure See Also Send Feedback
Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D10_TEXTURE1D_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousResourceOptions MiscellaneousResourceOptions { get; set; }
Visual Basic
Public Property MiscellaneousResourceOptions As MiscellaneousResourceOptions
    Get
    Set
Visual C++
public:
property MiscellaneousResourceOptions MiscellaneousResourceOptions {
    MiscellaneousResourceOptions get ();
    void set (MiscellaneousResourceOptions value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Texture1DDescription..::..MiscellaneousResourceOptions


Usage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Usage Property
Texture1DDescription Structure See Also Send Feedback
Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values.

(Also see DirectX SDK: D3D10_TEXTURE1D_DESC.Usage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Usage Usage { get; set; }
Visual Basic
Public Property Usage As Usage
    Get
    Set
Visual C++
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Width Property
Texture1DDescription Structure See Also Send Feedback
Texture width (in texels).

(Also see DirectX SDK: D3D10_TEXTURE1D_DESC.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource from a 1D texture to use in a render-target view.

(Also see DirectX SDK: D3D10_TEX1D_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DRenderTargetView
Visual Basic
Public Structure Texture1DRenderTargetView
Visual C++
public value class Texture1DRenderTargetView

See Also

Texture1DRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Members
Texture1DRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture1DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX1D_RTV.MipSlice)

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Methods
Texture1DRenderTargetView Structure See Also Send Feedback

The Texture1DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..Equals Method
Texture1DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..GetHashCode Method
Texture1DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Operators
Texture1DRenderTargetView Structure See Also Send Feedback

The Texture1DRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..Equality Operator
Texture1DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DRenderTargetView textureRenderTargetView1,
    Texture1DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureRenderTargetView1 As Texture1DRenderTargetView, _
    textureRenderTargetView2 As Texture1DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DRenderTargetView textureRenderTargetView1,
    Texture1DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DRenderTargetView

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..Inequality Operator
Texture1DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DRenderTargetView textureRenderTargetView1,
    Texture1DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureRenderTargetView1 As Texture1DRenderTargetView, _
    textureRenderTargetView2 As Texture1DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DRenderTargetView textureRenderTargetView1,
    Texture1DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DRenderTargetView

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Properties
Texture1DRenderTargetView Structure See Also Send Feedback

The Texture1DRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX1D_RTV.MipSlice)

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..MipSlice Property
Texture1DRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use (see mip slice).

(Also see DirectX SDK: D3D10_TEX1D_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource from a 1D texture to use in a shader-resource view.

(Also see DirectX SDK: D3D10_TEX1D_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DShaderResourceView
Visual Basic
Public Structure Texture1DShaderResourceView
Visual C++
public value class Texture1DShaderResourceView

See Also

Texture1DShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Members
Texture1DShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture1DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEX1D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX1D_SRV.MostDetailedMip)

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Methods
Texture1DShaderResourceView Structure See Also Send Feedback

The Texture1DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..Equals Method
Texture1DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..GetHashCode Method
Texture1DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Operators
Texture1DShaderResourceView Structure See Also Send Feedback

The Texture1DShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..Equality Operator
Texture1DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DShaderResourceView textureShaderResourceView1,
    Texture1DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureShaderResourceView1 As Texture1DShaderResourceView, _
    textureShaderResourceView2 As Texture1DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DShaderResourceView textureShaderResourceView1,
    Texture1DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DShaderResourceView

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..Inequality Operator
Texture1DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DShaderResourceView textureShaderResourceView1,
    Texture1DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureShaderResourceView1 As Texture1DShaderResourceView, _
    textureShaderResourceView2 As Texture1DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DShaderResourceView textureShaderResourceView1,
    Texture1DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture1DShaderResourceView

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture1DShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Properties
Texture1DShaderResourceView Structure See Also Send Feedback

The Texture1DShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEX1D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX1D_SRV.MostDetailedMip)

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..MipLevels Property
Texture1DShaderResourceView Structure See Also Send Feedback
Number of mipmap levels to use.

(Also see DirectX SDK: D3D10_TEX1D_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..MostDetailedMip Property
Texture1DShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D10_TEX1D_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2D Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D Class
Members See Also Send Feedback
A 2D texture interface manages texel data, which is structured memory.

(Also see DirectX SDK: ID3D10Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Texture2D : D3DResource
Visual Basic
Public Class Texture2D _
    Inherits D3DResource
Visual C++
public ref class Texture2D : public D3DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2D

See Also

Texture2D Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2D Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D Members
Texture2D Class Methods Properties See Also Send Feedback

The Texture2D type exposes the following members.

Methods

 | Name | Description
Public method | Map | Get the data contained in a subresource, and deny the GPU access to that subresource. (Also see DirectX SDK: ID3D10Texture2D::Map)
Public method | Unmap | Invalidate the pointer to the resource that was retrieved by Texture2D.Map, and re-enable GPU access to the resource. (Also see DirectX SDK: ID3D10Texture2D::Unmap)

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D10Texture2D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType) (Inherited from D3DResource.)

See Also

Texture2D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2D Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D Methods
Texture2D Class See Also Send Feedback

The Texture2D type exposes the following members.

Methods

 | Name | Description
Public method | Map | Get the data contained in a subresource, and deny the GPU access to that subresource. (Also see DirectX SDK: ID3D10Texture2D::Map)
Public method | Unmap | Invalidate the pointer to the resource that was retrieved by Texture2D.Map, and re-enable GPU access to the resource. (Also see DirectX SDK: ID3D10Texture2D::Unmap)

See Also

Texture2D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Map Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D..::..Map Method
Texture2D Class See Also Send Feedback
Get the data contained in a subresource, and deny the GPU access to that subresource.

(Also see DirectX SDK: ID3D10Texture2D::Map)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MappedTexture2D Map(
    uint subresourceIndex,
    Map type,
    MapOptions options
)
Visual Basic
Public Function Map ( _
    subresourceIndex As UInteger, _
    type As Map, _
    options As MapOptions _
) As MappedTexture2D
Visual C++
public:
MappedTexture2D Map(
    unsigned int subresourceIndex,
    Map type,
    MapOptions options
)

Parameters

subresourceIndex
Type: System..::..UInt32
Index number of the subresource. See D3D10CalcSubresource for more details.
type
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Map
Specifies the CPU's read and write permissions for a resource. For possible values, see Map.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MapOptions
Flag that specifies what the CPU should do when the GPU is busy. This flag is optional.

Return Value

Pointer to the texture resource data.

See Also

Texture2D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Unmap Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D..::..Unmap Method
Texture2D Class See Also Send Feedback
Invalidate the pointer to the resource that was retrieved by Texture2D.Map, and re-enable GPU access to the resource.

(Also see DirectX SDK: ID3D10Texture2D::Unmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Unmap(
    uint subresourceIndex
)
Visual Basic
Public Sub Unmap ( _
    subresourceIndex As UInteger _
)
Visual C++
public:
void Unmap(
    unsigned int subresourceIndex
)

Parameters

subresourceIndex
Type: System..::..UInt32
Subresource to be unmapped. See D3D10CalcSubresource for more details.

See Also

Texture2D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2D Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D Properties
Texture2D Class See Also Send Feedback

The Texture2D type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D10Texture2D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType) (Inherited from D3DResource.)

See Also

Texture2D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D..::..Description Property
Texture2D Class See Also Send Feedback
Get the properties of the texture resource.

(Also see DirectX SDK: ID3D10Texture2D::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As Texture2DDescription
    Get
Visual C++
public:
property Texture2DDescription Description {
    Texture2DDescription get ();
}

See Also

Texture2D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresource(s) from an array 2D textures that are accessable to a depth-stencil view.

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DArrayDepthStencilView
Visual Basic
Public Structure Texture2DArrayDepthStencilView
Visual C++
public value class Texture2DArrayDepthStencilView

See Also

Texture2DArrayDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Members
Texture2DArrayDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture2DArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV.FirstArraySlice)
Public property | MipSlice | The index of the first mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV.MipSlice)

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Methods
Texture2DArrayDepthStencilView Structure See Also Send Feedback

The Texture2DArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..Equals Method
Texture2DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..GetHashCode Method
Texture2DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Operators
Texture2DArrayDepthStencilView Structure See Also Send Feedback

The Texture2DArrayDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..Equality Operator
Texture2DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture2DArrayDepthStencilView textureArrayDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayDepthStencilView1 As Texture2DArrayDepthStencilView, _
    textureArrayDepthStencilView2 As Texture2DArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture2DArrayDepthStencilView textureArrayDepthStencilView2
)

Parameters

textureArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayDepthStencilView
textureArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayDepthStencilView

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..Inequality Operator
Texture2DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture2DArrayDepthStencilView textureArrayDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayDepthStencilView1 As Texture2DArrayDepthStencilView, _
    textureArrayDepthStencilView2 As Texture2DArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture2DArrayDepthStencilView textureArrayDepthStencilView2
)

Parameters

textureArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayDepthStencilView
textureArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayDepthStencilView

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Properties
Texture2DArrayDepthStencilView Structure See Also Send Feedback

The Texture2DArrayDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV.FirstArraySlice)
Public property | MipSlice | The index of the first mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV.MipSlice)

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..ArraySize Property
Texture2DArrayDepthStencilView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..FirstArraySlice Property
Texture2DArrayDepthStencilView Structure See Also Send Feedback
The index of the first texture to use in an array of textures (see array slice)

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..MipSlice Property
Texture2DArrayDepthStencilView Structure See Also Send Feedback
The index of the first mipmap level to use (see mip slice).

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_DSV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource(s) from an array of 2D textures to use in a render-target view.

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DArrayRenderTargetView
Visual Basic
Public Structure Texture2DArrayRenderTargetView
Visual C++
public value class Texture2DArrayRenderTargetView

See Also

Texture2DArrayRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Members
Texture2DArrayRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture2DArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array to use in the render target view, starting from FirstArraySlice. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV.FirstArraySlice)
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV.MipSlice)

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Methods
Texture2DArrayRenderTargetView Structure See Also Send Feedback

The Texture2DArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..Equals Method
Texture2DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..GetHashCode Method
Texture2DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Operators
Texture2DArrayRenderTargetView Structure See Also Send Feedback

The Texture2DArrayRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..Equality Operator
Texture2DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture2DArrayRenderTargetView textureArrayRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayRenderTargetView1 As Texture2DArrayRenderTargetView, _
    textureArrayRenderTargetView2 As Texture2DArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture2DArrayRenderTargetView textureArrayRenderTargetView2
)

Parameters

textureArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayRenderTargetView
textureArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayRenderTargetView

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..Inequality Operator
Texture2DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture2DArrayRenderTargetView textureArrayRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayRenderTargetView1 As Texture2DArrayRenderTargetView, _
    textureArrayRenderTargetView2 As Texture2DArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture2DArrayRenderTargetView textureArrayRenderTargetView2
)

Parameters

textureArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayRenderTargetView
textureArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayRenderTargetView

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Properties
Texture2DArrayRenderTargetView Structure See Also Send Feedback

The Texture2DArrayRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array to use in the render target view, starting from FirstArraySlice. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV.FirstArraySlice)
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV.MipSlice)

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..ArraySize Property
Texture2DArrayRenderTargetView Structure See Also Send Feedback
Number of textures in the array to use in the render target view, starting from FirstArraySlice.

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..FirstArraySlice Property
Texture2DArrayRenderTargetView Structure See Also Send Feedback
The index of the first texture to use in an array of textures (see array slice)

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..MipSlice Property
Texture2DArrayRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use (see mip slice).

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource(s) from an array of 2D textures to use in a shader-resource view.

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DArrayShaderResourceView
Visual Basic
Public Structure Texture2DArrayShaderResourceView
Visual C++
public value class Texture2DArrayShaderResourceView

See Also

Texture2DArrayShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Members
Texture2DArrayShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture2DArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.FirstArraySlice)
Public property | MipLevels | Number of subtextures to access. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.MostDetailedMip)

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Methods
Texture2DArrayShaderResourceView Structure See Also Send Feedback

The Texture2DArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..Equals Method
Texture2DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..GetHashCode Method
Texture2DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Operators
Texture2DArrayShaderResourceView Structure See Also Send Feedback

The Texture2DArrayShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..Equality Operator
Texture2DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture2DArrayShaderResourceView textureArrayShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayShaderResourceView1 As Texture2DArrayShaderResourceView, _
    textureArrayShaderResourceView2 As Texture2DArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture2DArrayShaderResourceView textureArrayShaderResourceView2
)

Parameters

textureArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayShaderResourceView
textureArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayShaderResourceView

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..Inequality Operator
Texture2DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture2DArrayShaderResourceView textureArrayShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayShaderResourceView1 As Texture2DArrayShaderResourceView, _
    textureArrayShaderResourceView2 As Texture2DArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture2DArrayShaderResourceView textureArrayShaderResourceView2
)

Parameters

textureArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayShaderResourceView
textureArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DArrayShaderResourceView

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DArrayShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Properties
Texture2DArrayShaderResourceView Structure See Also Send Feedback

The Texture2DArrayShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.FirstArraySlice)
Public property | MipLevels | Number of subtextures to access. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.MostDetailedMip)

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..ArraySize Property
Texture2DArrayShaderResourceView Structure See Also Send Feedback
Number of textures in the array.

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..FirstArraySlice Property
Texture2DArrayShaderResourceView Structure See Also Send Feedback
The index of the first texture to use in an array of textures (see array slice)

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..MipLevels Property
Texture2DArrayShaderResourceView Structure See Also Send Feedback
Number of subtextures to access.

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..MostDetailedMip Property
Texture2DArrayShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D10_TEX2D_ARRAY_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresource from a 2D texture that is accessable to a depth-stencil view.

(Also see DirectX SDK: D3D10_TEX2D_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DDepthStencilView
Visual Basic
Public Structure Texture2DDepthStencilView
Visual C++
public value class Texture2DDepthStencilView

See Also

Texture2DDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Members
Texture2DDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture2DDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The index of the first mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX2D_DSV.MipSlice)

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Methods
Texture2DDepthStencilView Structure See Also Send Feedback

The Texture2DDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..Equals Method
Texture2DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..GetHashCode Method
Texture2DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Operators
Texture2DDepthStencilView Structure See Also Send Feedback

The Texture2DDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..Equality Operator
Texture2DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DDepthStencilView textureDepthStencilView1,
    Texture2DDepthStencilView textureDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureDepthStencilView1 As Texture2DDepthStencilView, _
    textureDepthStencilView2 As Texture2DDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DDepthStencilView textureDepthStencilView1,
    Texture2DDepthStencilView textureDepthStencilView2
)

Parameters

textureDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDepthStencilView
textureDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDepthStencilView

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..Inequality Operator
Texture2DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DDepthStencilView textureDepthStencilView1,
    Texture2DDepthStencilView textureDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureDepthStencilView1 As Texture2DDepthStencilView, _
    textureDepthStencilView2 As Texture2DDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DDepthStencilView textureDepthStencilView1,
    Texture2DDepthStencilView textureDepthStencilView2
)

Parameters

textureDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDepthStencilView
textureDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDepthStencilView

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Properties
Texture2DDepthStencilView Structure See Also Send Feedback

The Texture2DDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The index of the first mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX2D_DSV.MipSlice)

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..MipSlice Property
Texture2DDepthStencilView Structure See Also Send Feedback
The index of the first mipmap level to use (see mip slice).

(Also see DirectX SDK: D3D10_TEX2D_DSV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Structure
Members See Also Send Feedback
Describes a 2D texture.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DDescription
Visual Basic
Public Structure Texture2DDescription
Visual C++
public value class Texture2DDescription

See Also

Texture2DDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Members
Texture2DDescription Structure Methods Operators Properties See Also Send Feedback

The Texture2DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the texture array. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.ArraySize)
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.CPUAccessFlags)
Public property | Format | format (see Format). (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Format)
Public property | Height | Texture height (in texels). See Remarks. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Height)
Public property | MipLevels | Number of subtextures (also called mipmap levels). Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.MiscFlags)
Public property | SampleDescription | Structure that specifies multisampling parameters for the texture. See SampleDescription. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.SampleDesc)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Usage)
Public property | Width | Texture width (in texels). See Remarks. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Width)

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Methods
Texture2DDescription Structure See Also Send Feedback

The Texture2DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Equals Method
Texture2DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..GetHashCode Method
Texture2DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Operators
Texture2DDescription Structure See Also Send Feedback

The Texture2DDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Equality Operator
Texture2DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DDescription textureDescription1,
    Texture2DDescription textureDescription2
)
Visual Basic
Public Shared Operator = ( _
    textureDescription1 As Texture2DDescription, _
    textureDescription2 As Texture2DDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DDescription textureDescription1,
    Texture2DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDescription

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Inequality Operator
Texture2DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DDescription textureDescription1,
    Texture2DDescription textureDescription2
)
Visual Basic
Public Shared Operator <> ( _
    textureDescription1 As Texture2DDescription, _
    textureDescription2 As Texture2DDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DDescription textureDescription1,
    Texture2DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DDescription

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Properties
Texture2DDescription Structure See Also Send Feedback

The Texture2DDescription type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the texture array. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.ArraySize)
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.CPUAccessFlags)
Public property | Format | format (see Format). (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Format)
Public property | Height | Texture height (in texels). See Remarks. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Height)
Public property | MipLevels | Number of subtextures (also called mipmap levels). Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.MiscFlags)
Public property | SampleDescription | Structure that specifies multisampling parameters for the texture. See SampleDescription. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.SampleDesc)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Usage)
Public property | Width | Texture width (in texels). See Remarks. (Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Width)

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..ArraySize Property
Texture2DDescription Structure See Also Send Feedback
Number of textures in the texture array.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BindingOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..BindingOptions Property
Texture2DDescription Structure See Also Send Feedback
Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.BindFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BindingOptions BindingOptions { get; set; }
Visual Basic
Public Property BindingOptions As BindingOptions
    Get
    Set
Visual C++
public:
property BindingOptions BindingOptions {
    BindingOptions get ();
    void set (BindingOptions value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BindingOptions


CpuAccessOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..CpuAccessOptions Property
Texture2DDescription Structure See Also Send Feedback
Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.CPUAccessFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CpuAccessOptions CpuAccessOptions { get; set; }
Visual Basic
Public Property CpuAccessOptions As CpuAccessOptions
    Get
    Set
Visual C++
public:
property CpuAccessOptions CpuAccessOptions {
    CpuAccessOptions get ();
    void set (CpuAccessOptions value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Texture2DDescription..::..CpuAccessOptions


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Format Property
Texture2DDescription Structure See Also Send Feedback
format (see Format).

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Texture2DDescription..::..Format


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Height Property
Texture2DDescription Structure See Also Send Feedback
Texture height (in texels). See Remarks.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Height)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..MipLevels Property
Texture2DDescription Structure See Also Send Feedback
Number of subtextures (also called mipmap levels). Use 1 for a multisampled texture; or 0 to generate a full set of subtextures.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MiscellaneousResourceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..MiscellaneousResourceOptions Property
Texture2DDescription Structure See Also Send Feedback
Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousResourceOptions MiscellaneousResourceOptions { get; set; }
Visual Basic
Public Property MiscellaneousResourceOptions As MiscellaneousResourceOptions
    Get
    Set
Visual C++
public:
property MiscellaneousResourceOptions MiscellaneousResourceOptions {
    MiscellaneousResourceOptions get ();
    void set (MiscellaneousResourceOptions value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Texture2DDescription..::..MiscellaneousResourceOptions


SampleDescription Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..SampleDescription Property
Texture2DDescription Structure See Also Send Feedback
Structure that specifies multisampling parameters for the texture. See SampleDescription.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.SampleDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SampleDescription SampleDescription { get; set; }
Visual Basic
Public Property SampleDescription As SampleDescription
    Get
    Set
Visual C++
public:
property SampleDescription SampleDescription {
    SampleDescription get ();
    void set (SampleDescription value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Usage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Usage Property
Texture2DDescription Structure See Also Send Feedback
Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Usage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Usage Usage { get; set; }
Visual Basic
Public Property Usage As Usage
    Get
    Set
Visual C++
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Width Property
Texture2DDescription Structure See Also Send Feedback
Texture width (in texels). See Remarks.

(Also see DirectX SDK: D3D10_TEXTURE2D_DESC.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresource(s) from an array of multisampled 2D textures for a depth-stencil view.

(Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleArrayDepthStencilView
Visual Basic
Public Structure Texture2DMultisampleArrayDepthStencilView
Visual C++
public value class Texture2DMultisampleArrayDepthStencilView

See Also

Texture2DMultisampleArrayDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Members
Texture2DMultisampleArrayDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_DSV.FirstArraySlice)

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Methods
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..Equals Method
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..GetHashCode Method
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Operators
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleArrayDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..Equality Operator
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView1,
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleArrayDepthStencilView1 As Texture2DMultisampleArrayDepthStencilView, _
    textureMultisampleArrayDepthStencilView2 As Texture2DMultisampleArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView1,
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView2
)

Parameters

textureMultisampleArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayDepthStencilView
textureMultisampleArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayDepthStencilView

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..Inequality Operator
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView1,
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleArrayDepthStencilView1 As Texture2DMultisampleArrayDepthStencilView, _
    textureMultisampleArrayDepthStencilView2 As Texture2DMultisampleArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView1,
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView2
)

Parameters

textureMultisampleArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayDepthStencilView
textureMultisampleArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayDepthStencilView

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Properties
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleArrayDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_DSV.FirstArraySlice)

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..ArraySize Property
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_DSV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..FirstArraySlice Property
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback
The index of the first texture to use in an array of textures (see array slice)

(Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_DSV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource(s) from a an array of multisampled 2D textures to use in a render-target view.

(Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleArrayRenderTargetView
Visual Basic
Public Structure Texture2DMultisampleArrayRenderTargetView
Visual C++
public value class Texture2DMultisampleArrayRenderTargetView

See Also

Texture2DMultisampleArrayRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Members
Texture2DMultisampleArrayRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_RTV.FirstArraySlice)

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Methods
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..Equals Method
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..GetHashCode Method
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Operators
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleArrayRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..Equality Operator
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView1,
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleArrayRenderTargetView1 As Texture2DMultisampleArrayRenderTargetView, _
    textureMultisampleArrayRenderTargetView2 As Texture2DMultisampleArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView1,
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView2
)

Parameters

textureMultisampleArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayRenderTargetView
textureMultisampleArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayRenderTargetView

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..Inequality Operator
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView1,
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleArrayRenderTargetView1 As Texture2DMultisampleArrayRenderTargetView, _
    textureMultisampleArrayRenderTargetView2 As Texture2DMultisampleArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView1,
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView2
)

Parameters

textureMultisampleArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayRenderTargetView
textureMultisampleArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayRenderTargetView

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Properties
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleArrayRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_RTV.FirstArraySlice)

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..ArraySize Property
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_RTV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..FirstArraySlice Property
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback
The index of the first texture to use in an array of textures (see array slice)

(Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_RTV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource(s) from an array of multisampled 2D textures to use in a shader-resource view.

(Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleArrayShaderResourceView
Visual Basic
Public Structure Texture2DMultisampleArrayShaderResourceView
Visual C++
public value class Texture2DMultisampleArrayShaderResourceView

See Also

Texture2DMultisampleArrayShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Members
Texture2DMultisampleArrayShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_SRV.FirstArraySlice)

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Methods
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..Equals Method
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..GetHashCode Method
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Operators
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleArrayShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..Equality Operator
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView1,
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleArrayShaderResourceView1 As Texture2DMultisampleArrayShaderResourceView, _
    textureMultisampleArrayShaderResourceView2 As Texture2DMultisampleArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView1,
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView2
)

Parameters

textureMultisampleArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayShaderResourceView
textureMultisampleArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayShaderResourceView

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..Inequality Operator
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView1,
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleArrayShaderResourceView1 As Texture2DMultisampleArrayShaderResourceView, _
    textureMultisampleArrayShaderResourceView2 As Texture2DMultisampleArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView1,
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView2
)

Parameters

textureMultisampleArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayShaderResourceView
textureMultisampleArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleArrayShaderResourceView

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleArrayShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Properties
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleArrayShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures (see array slice) (Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_SRV.FirstArraySlice)

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..ArraySize Property
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_SRV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..FirstArraySlice Property
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback
The index of the first texture to use in an array of textures (see array slice)

(Also see DirectX SDK: D3D10_TEX2DMS_ARRAY_SRV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresource from a multisampled 2D texture that is accessable to a depth-stencil view.

(Also see DirectX SDK: D3D10_TEX2DMS_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleDepthStencilView
Visual Basic
Public Structure Texture2DMultisampleDepthStencilView
Visual C++
public value class Texture2DMultisampleDepthStencilView

See Also

Texture2DMultisampleDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Members
Texture2DMultisampleDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | UnusedField | Unused Field;

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Methods
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..Equals Method
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..GetHashCode Method
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Operators
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..Equality Operator
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView1,
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleDepthStencilView1 As Texture2DMultisampleDepthStencilView, _
    textureMultisampleDepthStencilView2 As Texture2DMultisampleDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView1,
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView2
)

Parameters

textureMultisampleDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleDepthStencilView
textureMultisampleDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleDepthStencilView

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..Inequality Operator
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView1,
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleDepthStencilView1 As Texture2DMultisampleDepthStencilView, _
    textureMultisampleDepthStencilView2 As Texture2DMultisampleDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView1,
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView2
)

Parameters

textureMultisampleDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleDepthStencilView
textureMultisampleDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleDepthStencilView

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Properties
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | UnusedField | Unused Field;

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UnusedField Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..UnusedField Property
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback
Unused Field;

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint UnusedField { get; set; }
Visual Basic
Public Property UnusedField As UInteger
    Get
    Set
Visual C++
public:
property unsigned int UnusedField {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource from a multisampled 2D texture to use in a render-target view.

(Also see DirectX SDK: D3D10_TEX2DMS_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleRenderTargetView
Visual Basic
Public Structure Texture2DMultisampleRenderTargetView
Visual C++
public value class Texture2DMultisampleRenderTargetView

See Also

Texture2DMultisampleRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Members
Texture2DMultisampleRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | UnusedField | Unused Field;

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Methods
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..Equals Method
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..GetHashCode Method
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Operators
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..Equality Operator
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView1,
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleRenderTargetView1 As Texture2DMultisampleRenderTargetView, _
    textureMultisampleRenderTargetView2 As Texture2DMultisampleRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView1,
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView2
)

Parameters

textureMultisampleRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleRenderTargetView
textureMultisampleRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleRenderTargetView

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..Inequality Operator
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView1,
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleRenderTargetView1 As Texture2DMultisampleRenderTargetView, _
    textureMultisampleRenderTargetView2 As Texture2DMultisampleRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView1,
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView2
)

Parameters

textureMultisampleRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleRenderTargetView
textureMultisampleRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleRenderTargetView

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Properties
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | UnusedField | Unused Field;

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UnusedField Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..UnusedField Property
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback
Unused Field;

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint UnusedField { get; set; }
Visual Basic
Public Property UnusedField As UInteger
    Get
    Set
Visual C++
public:
property unsigned int UnusedField {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource(s) from a multisampled 2D texture to use in a shader-resource view.

(Also see DirectX SDK: D3D10_TEX2DMS_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleShaderResourceView
Visual Basic
Public Structure Texture2DMultisampleShaderResourceView
Visual C++
public value class Texture2DMultisampleShaderResourceView

See Also

Texture2DMultisampleShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Members
Texture2DMultisampleShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | UnusedField | Unused Field;

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Methods
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..Equals Method
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..GetHashCode Method
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Operators
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..Equality Operator
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView1,
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleShaderResourceView1 As Texture2DMultisampleShaderResourceView, _
    textureMultisampleShaderResourceView2 As Texture2DMultisampleShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView1,
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView2
)

Parameters

textureMultisampleShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleShaderResourceView
textureMultisampleShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleShaderResourceView

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..Inequality Operator
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView1,
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleShaderResourceView1 As Texture2DMultisampleShaderResourceView, _
    textureMultisampleShaderResourceView2 As Texture2DMultisampleShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView1,
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView2
)

Parameters

textureMultisampleShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleShaderResourceView
textureMultisampleShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DMultisampleShaderResourceView

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DMultisampleShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Properties
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | UnusedField | Unused Field;

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


UnusedField Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..UnusedField Property
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback
Unused Field;

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint UnusedField { get; set; }
Visual Basic
Public Property UnusedField As UInteger
    Get
    Set
Visual C++
public:
property unsigned int UnusedField {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource from a 2D texture to use in a render-target view.

(Also see DirectX SDK: D3D10_TEX2D_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DRenderTargetView
Visual Basic
Public Structure Texture2DRenderTargetView
Visual C++
public value class Texture2DRenderTargetView

See Also

Texture2DRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Members
Texture2DRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture2DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX2D_RTV.MipSlice)

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Methods
Texture2DRenderTargetView Structure See Also Send Feedback

The Texture2DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..Equals Method
Texture2DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..GetHashCode Method
Texture2DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Operators
Texture2DRenderTargetView Structure See Also Send Feedback

The Texture2DRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..Equality Operator
Texture2DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DRenderTargetView textureRenderTargetView1,
    Texture2DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureRenderTargetView1 As Texture2DRenderTargetView, _
    textureRenderTargetView2 As Texture2DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DRenderTargetView textureRenderTargetView1,
    Texture2DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DRenderTargetView

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..Inequality Operator
Texture2DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DRenderTargetView textureRenderTargetView1,
    Texture2DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureRenderTargetView1 As Texture2DRenderTargetView, _
    textureRenderTargetView2 As Texture2DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DRenderTargetView textureRenderTargetView1,
    Texture2DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DRenderTargetView

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Properties
Texture2DRenderTargetView Structure See Also Send Feedback

The Texture2DRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX2D_RTV.MipSlice)

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..MipSlice Property
Texture2DRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use (see mip slice).

(Also see DirectX SDK: D3D10_TEX2D_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource from a 2D texture to use in a shader-resource view.

(Also see DirectX SDK: D3D10_TEX2D_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DShaderResourceView
Visual Basic
Public Structure Texture2DShaderResourceView
Visual C++
public value class Texture2DShaderResourceView

See Also

Texture2DShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Members
Texture2DShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture2DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEX2D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX2D_SRV.MostDetailedMip)

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Methods
Texture2DShaderResourceView Structure See Also Send Feedback

The Texture2DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..Equals Method
Texture2DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..GetHashCode Method
Texture2DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Operators
Texture2DShaderResourceView Structure See Also Send Feedback

The Texture2DShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..Equality Operator
Texture2DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DShaderResourceView textureShaderResourceView1,
    Texture2DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureShaderResourceView1 As Texture2DShaderResourceView, _
    textureShaderResourceView2 As Texture2DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DShaderResourceView textureShaderResourceView1,
    Texture2DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DShaderResourceView

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..Inequality Operator
Texture2DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DShaderResourceView textureShaderResourceView1,
    Texture2DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureShaderResourceView1 As Texture2DShaderResourceView, _
    textureShaderResourceView2 As Texture2DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DShaderResourceView textureShaderResourceView1,
    Texture2DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture2DShaderResourceView

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture2DShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Properties
Texture2DShaderResourceView Structure See Also Send Feedback

The Texture2DShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEX2D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX2D_SRV.MostDetailedMip)

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..MipLevels Property
Texture2DShaderResourceView Structure See Also Send Feedback
Number of mipmap levels to use.

(Also see DirectX SDK: D3D10_TEX2D_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..MostDetailedMip Property
Texture2DShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D10_TEX2D_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3D Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D Class
Members See Also Send Feedback
A 3D texture interface accesses texel data, which is structured memory.

(Also see DirectX SDK: ID3D10Texture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Texture3D : D3DResource
Visual Basic
Public Class Texture3D _
    Inherits D3DResource
Visual C++
public ref class Texture3D : public D3DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3D

See Also

Texture3D Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3D Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D Members
Texture3D Class Methods Properties See Also Send Feedback

The Texture3D type exposes the following members.

Methods

 | Name | Description
Public method | Map | Get the data contained in a subresource, and deny the GPU access to that subresource. (Also see DirectX SDK: ID3D10Texture3D::Map)
Public method | Unmap | Invalidate the pointer to the resource retrieved by Texture3D.Map, and re-enable the GPU's access to the resource. (Also see DirectX SDK: ID3D10Texture3D::Unmap)

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D10Texture3D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType) (Inherited from D3DResource.)

See Also

Texture3D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3D Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D Methods
Texture3D Class See Also Send Feedback

The Texture3D type exposes the following members.

Methods

 | Name | Description
Public method | Map | Get the data contained in a subresource, and deny the GPU access to that subresource. (Also see DirectX SDK: ID3D10Texture3D::Map)
Public method | Unmap | Invalidate the pointer to the resource retrieved by Texture3D.Map, and re-enable the GPU's access to the resource. (Also see DirectX SDK: ID3D10Texture3D::Unmap)

See Also

Texture3D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Map Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D..::..Map Method
Texture3D Class See Also Send Feedback
Get the data contained in a subresource, and deny the GPU access to that subresource.

(Also see DirectX SDK: ID3D10Texture3D::Map)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MappedTexture3D Map(
    uint subresourceIndex,
    Map type,
    MapOptions options
)
Visual Basic
Public Function Map ( _
    subresourceIndex As UInteger, _
    type As Map, _
    options As MapOptions _
) As MappedTexture3D
Visual C++
public:
MappedTexture3D Map(
    unsigned int subresourceIndex,
    Map type,
    MapOptions options
)

Parameters

subresourceIndex
Type: System..::..UInt32
Index number of the subresource. See D3D10CalcSubresource for more details.
type
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Map
Specifies the CPU's read and write permissions for a resource. For possible values, see Map.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..MapOptions
Flag that specifies what the CPU should do when the GPU is busy. This flag is optional.

Return Value

Pointer to the texture resource data.

See Also

Texture3D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Unmap Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D..::..Unmap Method
Texture3D Class See Also Send Feedback
Invalidate the pointer to the resource retrieved by Texture3D.Map, and re-enable the GPU's access to the resource.

(Also see DirectX SDK: ID3D10Texture3D::Unmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Unmap(
    uint subresourceIndex
)
Visual Basic
Public Sub Unmap ( _
    subresourceIndex As UInteger _
)
Visual C++
public:
void Unmap(
    unsigned int subresourceIndex
)

Parameters

subresourceIndex
Type: System..::..UInt32
Subresource to be unmapped. See D3D10CalcSubresource for more details.

See Also

Texture3D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3D Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D Properties
Texture3D Class See Also Send Feedback

The Texture3D type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D10Texture3D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Get or set the eviction priority of a resource. (Also see DirectX SDK: ID3D10Resource::GetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics surface. If none is associated - throw an InvalidCastException. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D10Resource::GetType) (Inherited from D3DResource.)

See Also

Texture3D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D..::..Description Property
Texture3D Class See Also Send Feedback
Get the properties of the texture resource.

(Also see DirectX SDK: ID3D10Texture3D::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3DDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As Texture3DDescription
    Get
Visual C++
public:
property Texture3DDescription Description {
    Texture3DDescription get ();
}

See Also

Texture3D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Structure
Members See Also Send Feedback
Describes a 3D texture.

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture3DDescription
Visual Basic
Public Structure Texture3DDescription
Visual C++
public value class Texture3DDescription

See Also

Texture3DDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Members
Texture3DDescription Structure Methods Operators Properties See Also Send Feedback

The Texture3DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.CPUAccessFlags)
Public property | Depth | Texture depth (in texels) (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Depth)
Public property | Format | format (see Format). (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Format)
Public property | Height | Texture height (in texels). See Remarks. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Height)
Public property | MipLevels | Number of subtextures (also called mipmap levels). Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.MiscFlags)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Usage)
Public property | Width | Texture width (in texels). See Remarks. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Width)

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Methods
Texture3DDescription Structure See Also Send Feedback

The Texture3DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Equals Method
Texture3DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..GetHashCode Method
Texture3DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Operators
Texture3DDescription Structure See Also Send Feedback

The Texture3DDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Equality Operator
Texture3DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture3DDescription textureDescription1,
    Texture3DDescription textureDescription2
)
Visual Basic
Public Shared Operator = ( _
    textureDescription1 As Texture3DDescription, _
    textureDescription2 As Texture3DDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture3DDescription textureDescription1,
    Texture3DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DDescription

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Inequality Operator
Texture3DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture3DDescription textureDescription1,
    Texture3DDescription textureDescription2
)
Visual Basic
Public Shared Operator <> ( _
    textureDescription1 As Texture3DDescription, _
    textureDescription2 As Texture3DDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture3DDescription textureDescription1,
    Texture3DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DDescription

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Properties
Texture3DDescription Structure See Also Send Feedback

The Texture3DDescription type exposes the following members.

Properties

 | Name | Description
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.CPUAccessFlags)
Public property | Depth | Texture depth (in texels) (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Depth)
Public property | Format | format (see Format). (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Format)
Public property | Height | Texture height (in texels). See Remarks. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Height)
Public property | MipLevels | Number of subtextures (also called mipmap levels). Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.MiscFlags)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Usage)
Public property | Width | Texture width (in texels). See Remarks. (Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Width)

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


BindingOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..BindingOptions Property
Texture3DDescription Structure See Also Send Feedback
Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR.

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC.BindFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BindingOptions BindingOptions { get; set; }
Visual Basic
Public Property BindingOptions As BindingOptions
    Get
    Set
Visual C++
public:
property BindingOptions BindingOptions {
    BindingOptions get ();
    void set (BindingOptions value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..BindingOptions


CpuAccessOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..CpuAccessOptions Property
Texture3DDescription Structure See Also Send Feedback
Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC.CPUAccessFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CpuAccessOptions CpuAccessOptions { get; set; }
Visual Basic
Public Property CpuAccessOptions As CpuAccessOptions
    Get
    Set
Visual C++
public:
property CpuAccessOptions CpuAccessOptions {
    CpuAccessOptions get ();
    void set (CpuAccessOptions value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Texture3DDescription..::..CpuAccessOptions


Depth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Depth Property
Texture3DDescription Structure See Also Send Feedback
Texture depth (in texels)

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Depth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Depth { get; set; }
Visual Basic
Public Property Depth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Depth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Format Property
Texture3DDescription Structure See Also Send Feedback
format (see Format).

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Texture3DDescription..::..Format


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Height Property
Texture3DDescription Structure See Also Send Feedback
Texture height (in texels). See Remarks.

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Height)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..MipLevels Property
Texture3DDescription Structure See Also Send Feedback
Number of subtextures (also called mipmap levels). Use 1 for a multisampled texture; or 0 to generate a full set of subtextures.

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MiscellaneousResourceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..MiscellaneousResourceOptions Property
Texture3DDescription Structure See Also Send Feedback
Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousResourceOptions MiscellaneousResourceOptions { get; set; }
Visual Basic
Public Property MiscellaneousResourceOptions As MiscellaneousResourceOptions
    Get
    Set
Visual C++
public:
property MiscellaneousResourceOptions MiscellaneousResourceOptions {
    MiscellaneousResourceOptions get ();
    void set (MiscellaneousResourceOptions value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Texture3DDescription..::..MiscellaneousResourceOptions


Usage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Usage Property
Texture3DDescription Structure See Also Send Feedback
Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values.

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Usage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Usage Usage { get; set; }
Visual Basic
Public Property Usage As Usage
    Get
    Set
Visual C++
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Width Property
Texture3DDescription Structure See Also Send Feedback
Texture width (in texels). See Remarks.

(Also see DirectX SDK: D3D10_TEXTURE3D_DESC.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource(s) from a 3D texture to use in a render-target view.

(Also see DirectX SDK: D3D10_TEX3D_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture3DRenderTargetView
Visual Basic
Public Structure Texture3DRenderTargetView
Visual C++
public value class Texture3DRenderTargetView

See Also

Texture3DRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Members
Texture3DRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture3DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | FirstWSlice | First depth level to use. (Also see DirectX SDK: D3D10_TEX3D_RTV.FirstWSlice)
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX3D_RTV.MipSlice)
Public property | WSize | Number of depth levels to use in the render-target view, starting from FirstWSlice. A value of -1 indicates all of the slices along the w axis, starting from FirstWSlice. (Also see DirectX SDK: D3D10_TEX3D_RTV.WSize)

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Methods
Texture3DRenderTargetView Structure See Also Send Feedback

The Texture3DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..Equals Method
Texture3DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..GetHashCode Method
Texture3DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Operators
Texture3DRenderTargetView Structure See Also Send Feedback

The Texture3DRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..Equality Operator
Texture3DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture3DRenderTargetView textureRenderTargetView1,
    Texture3DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureRenderTargetView1 As Texture3DRenderTargetView, _
    textureRenderTargetView2 As Texture3DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture3DRenderTargetView textureRenderTargetView1,
    Texture3DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DRenderTargetView

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..Inequality Operator
Texture3DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture3DRenderTargetView textureRenderTargetView1,
    Texture3DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureRenderTargetView1 As Texture3DRenderTargetView, _
    textureRenderTargetView2 As Texture3DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture3DRenderTargetView textureRenderTargetView1,
    Texture3DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DRenderTargetView

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Properties
Texture3DRenderTargetView Structure See Also Send Feedback

The Texture3DRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | FirstWSlice | First depth level to use. (Also see DirectX SDK: D3D10_TEX3D_RTV.FirstWSlice)
Public property | MipSlice | The index of the mipmap level to use (see mip slice). (Also see DirectX SDK: D3D10_TEX3D_RTV.MipSlice)
Public property | WSize | Number of depth levels to use in the render-target view, starting from FirstWSlice. A value of -1 indicates all of the slices along the w axis, starting from FirstWSlice. (Also see DirectX SDK: D3D10_TEX3D_RTV.WSize)

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


FirstWSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..FirstWSlice Property
Texture3DRenderTargetView Structure See Also Send Feedback
First depth level to use.

(Also see DirectX SDK: D3D10_TEX3D_RTV.FirstWSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstWSlice { get; set; }
Visual Basic
Public Property FirstWSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstWSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..MipSlice Property
Texture3DRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use (see mip slice).

(Also see DirectX SDK: D3D10_TEX3D_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


WSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..WSize Property
Texture3DRenderTargetView Structure See Also Send Feedback
Number of depth levels to use in the render-target view, starting from FirstWSlice. A value of -1 indicates all of the slices along the w axis, starting from FirstWSlice.

(Also see DirectX SDK: D3D10_TEX3D_RTV.WSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint WSize { get; set; }
Visual Basic
Public Property WSize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int WSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource(s) from a 3D texture to use in a shader-resource view.

(Also see DirectX SDK: D3D10_TEX3D_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture3DShaderResourceView
Visual Basic
Public Structure Texture3DShaderResourceView
Visual C++
public value class Texture3DShaderResourceView

See Also

Texture3DShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Members
Texture3DShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture3DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEX3D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX3D_SRV.MostDetailedMip)

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Methods
Texture3DShaderResourceView Structure See Also Send Feedback

The Texture3DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..Equals Method
Texture3DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..GetHashCode Method
Texture3DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Operators
Texture3DShaderResourceView Structure See Also Send Feedback

The Texture3DShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..Equality Operator
Texture3DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture3DShaderResourceView textureShaderResourceView1,
    Texture3DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureShaderResourceView1 As Texture3DShaderResourceView, _
    textureShaderResourceView2 As Texture3DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture3DShaderResourceView textureShaderResourceView1,
    Texture3DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DShaderResourceView

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..Inequality Operator
Texture3DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture3DShaderResourceView textureShaderResourceView1,
    Texture3DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureShaderResourceView1 As Texture3DShaderResourceView, _
    textureShaderResourceView2 As Texture3DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture3DShaderResourceView textureShaderResourceView1,
    Texture3DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Texture3DShaderResourceView

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Texture3DShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Properties
Texture3DShaderResourceView Structure See Also Send Feedback

The Texture3DShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEX3D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEX3D_SRV.MostDetailedMip)

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..MipLevels Property
Texture3DShaderResourceView Structure See Also Send Feedback
Number of mipmap levels to use.

(Also see DirectX SDK: D3D10_TEX3D_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..MostDetailedMip Property
Texture3DShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D10_TEX3D_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureAddressMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureAddressMode Enumeration
See Also Send Feedback
Identify a technique for resolving texture coordinates that are outside of the boundaries of a texture.

(Also see DirectX SDK: D3D10_TEXTURE_ADDRESS_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum TextureAddressMode
Visual Basic
Public Enumeration TextureAddressMode
Visual C++
public enum class TextureAddressMode

Members

Member name | Description
MirrorOnce |
Border |
Clamp |
Mirror |
Wrap |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeArrayShaderResourceView1 Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1 Structure
Members See Also Send Feedback
Specifies the subresource(s) from an array of cube textures to use in a shader-resource view.

(Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct TextureCubeArrayShaderResourceView1
Visual Basic
Public Structure TextureCubeArrayShaderResourceView1
Visual C++
public value class TextureCubeArrayShaderResourceView1

See Also

TextureCubeArrayShaderResourceView1 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeArrayShaderResourceView1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1 Members
TextureCubeArrayShaderResourceView1 Structure Methods Operators Properties See Also Send Feedback

The TextureCubeArrayShaderResourceView1 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | CubeCount | Number of cube textures in the array. (Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.NumCubes)
Public property | First2DArrayFace | Index of the first 2D texture to use. (Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.First2DArrayFace)
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.MostDetailedMip)

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeArrayShaderResourceView1 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1 Methods
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback

The TextureCubeArrayShaderResourceView1 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1..::..Equals Method
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1..::..GetHashCode Method
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeArrayShaderResourceView1 Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1 Operators
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback

The TextureCubeArrayShaderResourceView1 type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1..::..Equality Operator
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    TextureCubeArrayShaderResourceView1 textureCubeArrayShaderResourceView1,
    TextureCubeArrayShaderResourceView1 textureCubeArrayShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureCubeArrayShaderResourceView1 As TextureCubeArrayShaderResourceView1, _
    textureCubeArrayShaderResourceView2 As TextureCubeArrayShaderResourceView1 _
) As Boolean
Visual C++
public:
static bool operator ==(
    TextureCubeArrayShaderResourceView1 textureCubeArrayShaderResourceView1,
    TextureCubeArrayShaderResourceView1 textureCubeArrayShaderResourceView2
)

Parameters

textureCubeArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeArrayShaderResourceView1
textureCubeArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeArrayShaderResourceView1

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1..::..Inequality Operator
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    TextureCubeArrayShaderResourceView1 textureCubeArrayShaderResourceView1,
    TextureCubeArrayShaderResourceView1 textureCubeArrayShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureCubeArrayShaderResourceView1 As TextureCubeArrayShaderResourceView1, _
    textureCubeArrayShaderResourceView2 As TextureCubeArrayShaderResourceView1 _
) As Boolean
Visual C++
public:
static bool operator !=(
    TextureCubeArrayShaderResourceView1 textureCubeArrayShaderResourceView1,
    TextureCubeArrayShaderResourceView1 textureCubeArrayShaderResourceView2
)

Parameters

textureCubeArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeArrayShaderResourceView1
textureCubeArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeArrayShaderResourceView1

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeArrayShaderResourceView1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1 Properties
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback

The TextureCubeArrayShaderResourceView1 type exposes the following members.

Properties

 | Name | Description
Public property | CubeCount | Number of cube textures in the array. (Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.NumCubes)
Public property | First2DArrayFace | Index of the first 2D texture to use. (Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.First2DArrayFace)
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.MostDetailedMip)

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


CubeCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1..::..CubeCount Property
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback
Number of cube textures in the array.

(Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.NumCubes)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint CubeCount { get; set; }
Visual Basic
Public Property CubeCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int CubeCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


First2DArrayFace Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1..::..First2DArrayFace Property
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback
Index of the first 2D texture to use.

(Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.First2DArrayFace)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint First2DArrayFace { get; set; }
Visual Basic
Public Property First2DArrayFace As UInteger
    Get
    Set
Visual C++
public:
property unsigned int First2DArrayFace {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1..::..MipLevels Property
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback
Number of mipmap levels to use.

(Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView1..::..MostDetailedMip Property
TextureCubeArrayShaderResourceView1 Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D10_TEXCUBE_ARRAY_SRV1.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeArrayShaderResourceView1 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeFace Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeFace Enumeration
See Also Send Feedback
The different faces of a cube texture.

(Also see DirectX SDK: D3D10_TEXTURECUBE_FACE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum TextureCubeFace
Visual Basic
Public Enumeration TextureCubeFace
Visual C++
public enum class TextureCubeFace

Members

Member name | Description
NegativeZ |
PositiveZ |
NegativeY |
PositiveY |
NegativeX |
PositiveX |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource from a cube texture to use in a shader-resource view.

(Also see DirectX SDK: D3D10_TEXCUBE_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct TextureCubeShaderResourceView
Visual Basic
Public Structure TextureCubeShaderResourceView
Visual C++
public value class TextureCubeShaderResourceView

See Also

TextureCubeShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Members
TextureCubeShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The TextureCubeShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEXCUBE_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEXCUBE_SRV.MostDetailedMip)

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Methods
TextureCubeShaderResourceView Structure See Also Send Feedback

The TextureCubeShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..Equals Method
TextureCubeShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..GetHashCode Method
TextureCubeShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Operators
TextureCubeShaderResourceView Structure See Also Send Feedback

The TextureCubeShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..Equality Operator
TextureCubeShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    TextureCubeShaderResourceView textureCubeShaderResourceView1,
    TextureCubeShaderResourceView textureCubeShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureCubeShaderResourceView1 As TextureCubeShaderResourceView, _
    textureCubeShaderResourceView2 As TextureCubeShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    TextureCubeShaderResourceView textureCubeShaderResourceView1,
    TextureCubeShaderResourceView textureCubeShaderResourceView2
)

Parameters

textureCubeShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeShaderResourceView
textureCubeShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeShaderResourceView

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..Inequality Operator
TextureCubeShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    TextureCubeShaderResourceView textureCubeShaderResourceView1,
    TextureCubeShaderResourceView textureCubeShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureCubeShaderResourceView1 As TextureCubeShaderResourceView, _
    textureCubeShaderResourceView2 As TextureCubeShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    TextureCubeShaderResourceView textureCubeShaderResourceView1,
    TextureCubeShaderResourceView textureCubeShaderResourceView2
)

Parameters

textureCubeShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeShaderResourceView
textureCubeShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..TextureCubeShaderResourceView

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TextureCubeShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Properties
TextureCubeShaderResourceView Structure See Also Send Feedback

The TextureCubeShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | MipLevels | Number of mipmap levels to use. (Also see DirectX SDK: D3D10_TEXCUBE_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D10_TEXCUBE_SRV.MostDetailedMip)

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..MipLevels Property
TextureCubeShaderResourceView Structure See Also Send Feedback
Number of mipmap levels to use.

(Also see DirectX SDK: D3D10_TEXCUBE_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..MostDetailedMip Property
TextureCubeShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D10_TEXCUBE_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Usage Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Usage Enumeration
See Also Send Feedback
Identifies expected resource use during rendering. The usage directly reflects whether a resource is accessible by the CPU and/or the GPU.

(Also see DirectX SDK: D3D10_USAGE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Usage
Visual Basic
Public Enumeration Usage
Visual C++
public enum class Usage

Members

Member name | Description
Staging |
Dynamic |
Immutable |
Default |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexBuffer Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Structure
Members See Also Send Feedback
Stores the parameters required to get or set a vertex buffer for a device.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct VertexBuffer
Visual Basic
Public Structure VertexBuffer
Visual C++
public value class VertexBuffer

See Also

VertexBuffer Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexBuffer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Members
VertexBuffer Structure Constructors Methods Operators Properties See Also Send Feedback

The VertexBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | VertexBuffer |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Buffer |
Public property | Offset |
Public property | Stride |

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexBuffer Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Constructor
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexBuffer(
    D3DBuffer buffer,
    uint stride,
    uint offset
)
Visual Basic
Public Sub New ( _
    buffer As D3DBuffer, _
    stride As UInteger, _
    offset As UInteger _
)
Visual C++
public:
VertexBuffer(
    D3DBuffer^ buffer,
    unsigned int stride,
    unsigned int offset
)

Parameters

buffer
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DBuffer
A vertex buffer (see D3DBuffer). The vertex buffer must have been created with the VertexBuffer flag.
stride
Type: System..::..UInt32
The stride value. This is the size (in bytes) of the elements that are to be used from the vertex buffer.
offset
Type: System..::..UInt32
The offset value. This is the number of bytes between the first element of the vertex buffer and the first element that will be used.

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DBuffer


VertexBuffer Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Methods
VertexBuffer Structure See Also Send Feedback

The VertexBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Equals Method
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..GetHashCode Method
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexBuffer Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Operators
VertexBuffer Structure See Also Send Feedback

The VertexBuffer type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Equality Operator
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    VertexBuffer buffer1,
    VertexBuffer buffer2
)
Visual Basic
Public Shared Operator = ( _
    buffer1 As VertexBuffer, _
    buffer2 As VertexBuffer _
) As Boolean
Visual C++
public:
static bool operator ==(
    VertexBuffer buffer1,
    VertexBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..VertexBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..VertexBuffer

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Inequality Operator
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    VertexBuffer buffer1,
    VertexBuffer buffer2
)
Visual Basic
Public Shared Operator <> ( _
    buffer1 As VertexBuffer, _
    buffer2 As VertexBuffer _
) As Boolean
Visual C++
public:
static bool operator !=(
    VertexBuffer buffer1,
    VertexBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..VertexBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..VertexBuffer

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexBuffer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Properties
VertexBuffer Structure See Also Send Feedback

The VertexBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Buffer |
Public property | Offset |
Public property | Stride |

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Buffer Property
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer Buffer { get; }
Visual Basic
Public ReadOnly Property Buffer As D3DBuffer
    Get
Visual C++
public:
property D3DBuffer^ Buffer {
    D3DBuffer^ get ();
}

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Offset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Offset Property
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Offset { get; }
Visual Basic
Public ReadOnly Property Offset As UInteger
    Get
Visual C++
public:
property unsigned int Offset {
    unsigned int get ();
}

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Stride Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Stride Property
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Stride { get; }
Visual Basic
Public ReadOnly Property Stride As UInteger
    Get
Visual C++
public:
property unsigned int Stride {
    unsigned int get ();
}

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShader Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShader Class
Members See Also Send Feedback
A vertex-shader interface manages an executable program (a vertex shader) that controls the vertex-shader stage.

(Also see DirectX SDK: ID3D10VertexShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class VertexShader : DeviceChild
Visual Basic
Public Class VertexShader _
    Inherits DeviceChild
Visual C++
public ref class VertexShader : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..VertexShader

See Also

VertexShader Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShader Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShader Members
VertexShader Class Properties See Also Send Feedback

The VertexShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

VertexShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShader Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShader Properties
VertexShader Class See Also Send Feedback

The VertexShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

VertexShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Class
Members See Also Send Feedback
Vertex Shader pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class VertexShaderPipelineStage : PipelineStage
Visual Basic
Public Class VertexShaderPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class VertexShaderPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..VertexShaderPipelineStage

See Also

VertexShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Members
VertexShaderPipelineStage Class Constructors Methods Properties See Also Send Feedback

The VertexShaderPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | VertexShaderPipelineStage |

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the vertex shader pipeline stage. (Also see DirectX SDK: ID3D10Device::VSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler states from the vertex shader pipeline stage. (Also see DirectX SDK: ID3D10Device::VSGetSamplers)
Public method | GetShaderResources | Get the vertex shader resources. (Also see DirectX SDK: ID3D10Device::VSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShaderResources |

Properties

 | Name | Description
Public property | Shader | Gets or sets the vertex shader currently set on the device. Passing in null disables the shader for this pipeline stage. (Also see DirectX SDK: ID3D10Device::VSGetShader, ID3D10Device::VSSetShader)

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Constructor
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected VertexShaderPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
VertexShaderPipelineStage()

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Methods
VertexShaderPipelineStage Class See Also Send Feedback

The VertexShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the vertex shader pipeline stage. (Also see DirectX SDK: ID3D10Device::VSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler states from the vertex shader pipeline stage. (Also see DirectX SDK: ID3D10Device::VSGetSamplers)
Public method | GetShaderResources | Get the vertex shader resources. (Also see DirectX SDK: ID3D10Device::VSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShaderResources |

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..GetConstantBuffers Method
VertexShaderPipelineStage Class See Also Send Feedback
Get the constant buffers used by the vertex shader pipeline stage.

(Also see DirectX SDK: ID3D10Device::VSGetConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetConstantBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetConstantBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetConstantBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin retrieving constant buffers from (ranges from 0 to D3D10_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - 1).
bufferCount
Type: System..::..UInt32
Number of buffers to retrieve (ranges from 0 to D3D10_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - startSlot).

Return Value

Collection of constant buffer objects (see D3DBuffer) to be returned by the method.

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DBuffer


GetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..GetSamplers Method
VertexShaderPipelineStage Class See Also Send Feedback
Get an array of sampler states from the vertex shader pipeline stage.

(Also see DirectX SDK: ID3D10Device::VSGetSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<SamplerState> GetSamplers(
    uint startSlot,
    uint samplerCount
)
Visual Basic
Public Function GetSamplers ( _
    startSlot As UInteger, _
    samplerCount As UInteger _
) As ReadOnlyCollection(Of SamplerState)
Visual C++
public:
ReadOnlyCollection<SamplerState^>^ GetSamplers(
    unsigned int startSlot,
    unsigned int samplerCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into a zero-based array to begin getting samplers from (ranges from 0 to D3D10_COMMONSHADER_SAMPLER_SLOT_COUNT - 1).
samplerCount
Type: System..::..UInt32
Number of samplers to get from a device context. Each pipeline stage has a total of 16 sampler slots available (ranges from 0 to D3D10_COMMONSHADER_SAMPLER_SLOT_COUNT - startSlot).

Return Value

Collection of sampler-state objects (see SamplerState) to be returned by the device.

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..SamplerState


GetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..GetShaderResources Method
VertexShaderPipelineStage Class See Also Send Feedback
Get the vertex shader resources.

(Also see DirectX SDK: ID3D10Device::VSGetShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetShaderResources(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetShaderResources ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetShaderResources(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin getting shader resources from (ranges from 0 to D3D10_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - 1).
viewCount
Type: System..::..UInt32
The number of resources to get from the device. Up to a maximum of 128 slots are available for shader resources (ranges from 0 to D3D10_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - startSlot).

Return Value

Collection of shader resource views to be returned by the device.

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..SetConstantBuffers Method
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetConstantBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> constantBuffers
)
Visual Basic
Public Sub SetConstantBuffers ( _
    startSlot As UInteger, _
    constantBuffers As IEnumerable(Of D3DBuffer) _
)
Visual C++
public:
void SetConstantBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ constantBuffers
)

Parameters

startSlot
Type: System..::..UInt32
constantBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..SetSamplers Method
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSamplers(
    uint startSlot,
    IEnumerable<SamplerState> samplers
)
Visual Basic
Public Sub SetSamplers ( _
    startSlot As UInteger, _
    samplers As IEnumerable(Of SamplerState) _
)
Visual C++
public:
void SetSamplers(
    unsigned int startSlot,
    IEnumerable<SamplerState^>^ samplers
)

Parameters

startSlot
Type: System..::..UInt32
samplers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SamplerState >)>)>

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


SetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..SetShaderResources Method
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShaderResources(
    uint startSlot,
    IEnumerable<ShaderResourceView> shaderResourceViews
)
Visual Basic
Public Sub SetShaderResources ( _
    startSlot As UInteger, _
    shaderResourceViews As IEnumerable(Of ShaderResourceView) _
)
Visual C++
public:
void SetShaderResources(
    unsigned int startSlot,
    IEnumerable<ShaderResourceView^>^ shaderResourceViews
)

Parameters

startSlot
Type: System..::..UInt32
shaderResourceViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


VertexShaderPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Properties
VertexShaderPipelineStage Class See Also Send Feedback

The VertexShaderPipelineStage type exposes the following members.

Properties

 | Name | Description
Public property | Shader | Gets or sets the vertex shader currently set on the device. Passing in null disables the shader for this pipeline stage. (Also see DirectX SDK: ID3D10Device::VSGetShader, ID3D10Device::VSSetShader)

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..Shader Property
VertexShaderPipelineStage Class See Also Send Feedback
Gets or sets the vertex shader currently set on the device. Passing in null disables the shader for this pipeline stage.

(Also see DirectX SDK: ID3D10Device::VSGetShader, ID3D10Device::VSSetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShader Shader { get; set; }
Visual Basic
Public Property Shader As VertexShader
    Get
    Set
Visual C++
public:
property VertexShader^ Shader {
    VertexShader^ get ();
    void set (VertexShader^ value);
}

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


View Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
View Class
Members See Also Send Feedback
A view interface specifies the parts of a resource the pipeline can access during rendering.

(Also see DirectX SDK: ID3D10View)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class View : DeviceChild
Visual Basic
Public Class View _
    Inherits DeviceChild
Visual C++
public ref class View : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..DepthStencilView
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..RenderTargetView
Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..ShaderResourceView

See Also

View Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


View Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
View Members
View Class Properties See Also Send Feedback

The View type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource)

See Also

View Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


View Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D10DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D10View::GetResource)

See Also

View Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Resource Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
View..::..Resource Property
View Class See Also Send Feedback
Get the resource that is accessed through this view.

(Also see DirectX SDK: ID3D10View::GetResource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DResource Resource { get; }
Visual Basic
Public ReadOnly Property Resource As D3DResource
    Get
Visual C++
public:
property D3DResource^ Resource {
    D3DResource^ get ();
}

See Also

View Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Viewport Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Structure
Members See Also Send Feedback
Defines the dimensions of a viewport.

(Also see DirectX SDK: D3D10_VIEWPORT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Viewport
Visual Basic
Public Structure Viewport
Visual C++
public value class Viewport

See Also

Viewport Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Viewport Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Members
Viewport Structure Methods Operators Properties See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Height | Height of the viewport. Must be between 0 and 16383. (Also see DirectX SDK: D3D10_VIEWPORT.Height)
Public property | MaxDepth | Maximum depth of the viewport. Must be between 0 and 1. (Also see DirectX SDK: D3D10_VIEWPORT.MaxDepth)
Public property | MinDepth | Minimum depth of the viewport. Must be between 0 and 1. (Also see DirectX SDK: D3D10_VIEWPORT.MinDepth)
Public property | TopLeftX | X position of the left hand side of the viewport. Must be between -16384 and 16383. (Also see DirectX SDK: D3D10_VIEWPORT.TopLeftX)
Public property | TopLeftY | Y position of the top of the viewport. Must be between -16384 and 16383. (Also see DirectX SDK: D3D10_VIEWPORT.TopLeftY)
Public property | Width | Width of the viewport. Must be between 0 and 16383. (Also see DirectX SDK: D3D10_VIEWPORT.Width)

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Viewport Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Methods
Viewport Structure See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Equals Method
Viewport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..GetHashCode Method
Viewport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Viewport Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Operators
Viewport Structure See Also Send Feedback

The Viewport type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Equality Operator
Viewport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Viewport viewport1,
    Viewport viewport2
)
Visual Basic
Public Shared Operator = ( _
    viewport1 As Viewport, _
    viewport2 As Viewport _
) As Boolean
Visual C++
public:
static bool operator ==(
    Viewport viewport1,
    Viewport viewport2
)

Parameters

viewport1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Viewport
viewport2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Viewport

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Inequality Operator
Viewport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Viewport viewport1,
    Viewport viewport2
)
Visual Basic
Public Shared Operator <> ( _
    viewport1 As Viewport, _
    viewport2 As Viewport _
) As Boolean
Visual C++
public:
static bool operator !=(
    Viewport viewport1,
    Viewport viewport2
)

Parameters

viewport1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Viewport
viewport2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..Viewport

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Viewport Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Properties
Viewport Structure See Also Send Feedback

The Viewport type exposes the following members.

Properties

 | Name | Description
Public property | Height | Height of the viewport. Must be between 0 and 16383. (Also see DirectX SDK: D3D10_VIEWPORT.Height)
Public property | MaxDepth | Maximum depth of the viewport. Must be between 0 and 1. (Also see DirectX SDK: D3D10_VIEWPORT.MaxDepth)
Public property | MinDepth | Minimum depth of the viewport. Must be between 0 and 1. (Also see DirectX SDK: D3D10_VIEWPORT.MinDepth)
Public property | TopLeftX | X position of the left hand side of the viewport. Must be between -16384 and 16383. (Also see DirectX SDK: D3D10_VIEWPORT.TopLeftX)
Public property | TopLeftY | Y position of the top of the viewport. Must be between -16384 and 16383. (Also see DirectX SDK: D3D10_VIEWPORT.TopLeftY)
Public property | Width | Width of the viewport. Must be between 0 and 16383. (Also see DirectX SDK: D3D10_VIEWPORT.Width)

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Height Property
Viewport Structure See Also Send Feedback
Height of the viewport. Must be between 0 and 16383.

(Also see DirectX SDK: D3D10_VIEWPORT.Height)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MaxDepth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..MaxDepth Property
Viewport Structure See Also Send Feedback
Maximum depth of the viewport. Must be between 0 and 1.

(Also see DirectX SDK: D3D10_VIEWPORT.MaxDepth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MaxDepth { get; set; }
Visual Basic
Public Property MaxDepth As Single
    Get
    Set
Visual C++
public:
property float MaxDepth {
    float get ();
    void set (float value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


MinDepth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..MinDepth Property
Viewport Structure See Also Send Feedback
Minimum depth of the viewport. Must be between 0 and 1.

(Also see DirectX SDK: D3D10_VIEWPORT.MinDepth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MinDepth { get; set; }
Visual Basic
Public Property MinDepth As Single
    Get
    Set
Visual C++
public:
property float MinDepth {
    float get ();
    void set (float value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TopLeftX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..TopLeftX Property
Viewport Structure See Also Send Feedback
X position of the left hand side of the viewport. Must be between -16384 and 16383.

(Also see DirectX SDK: D3D10_VIEWPORT.TopLeftX)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int TopLeftX { get; set; }
Visual Basic
Public Property TopLeftX As Integer
    Get
    Set
Visual C++
public:
property int TopLeftX {
    int get ();
    void set (int value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


TopLeftY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..TopLeftY Property
Viewport Structure See Also Send Feedback
Y position of the top of the viewport. Must be between -16384 and 16383.

(Also see DirectX SDK: D3D10_VIEWPORT.TopLeftY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int TopLeftY { get; set; }
Visual Basic
Public Property TopLeftY As Integer
    Get
    Set
Visual C++
public:
property int TopLeftY {
    int get ();
    void set (int value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Width Property
Viewport Structure See Also Send Feedback
Width of the viewport. Must be between 0 and 16383.

(Also see DirectX SDK: D3D10_VIEWPORT.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D10
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D10 Namespace


Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Send Feedback
Direct3D 11.0 APIs and Types.

Classes

 | Class | Description
Public class | Asynchronous | This class encapsulates methods for retrieving data from the GPU asynchronously. (Also see DirectX SDK: ID3D11Asynchronous)
Public class | BlendState | This blend-state interface accesses blending state for the output-merger stage. (Also see DirectX SDK: ID3D11BlendState)
Public class | ClassInstance | This class encapsulates an HLSL class. (Also see DirectX SDK: ID3D11ClassInstance)
Public class | ClassLinkage | This class encapsulates an HLSL dynamic linkage. (Also see DirectX SDK: ID3D11ClassLinkage)
Public class | CommandList | The CommandList interface encapsulates a collection of graphics commands for play back. (Also see DirectX SDK: ID3D11CommandList)
Public class | ComputeShader | A compute-shader class manages an executable program (a compute shader) that controls the compute-shader stage. (Also see DirectX SDK: ID3D11ComputeShader)
Public class | ComputeShaderPipelineStage | Compute Shader pipeline stage.
Public class | CounterData | This class encapsulates the data returned by the D3DDevice.CheckCounter method. (Also see DirectX SDK: ID3D11Device.CheckCounter)
Public class | D3DBuffer | Allows acccess to a buffer resource, which is unstructured memory. Buffers typically store vertex or index data. (Also see DirectX SDK: ID3D11Buffer)
Public class | D3DCounter | This class encapsulates methods for measuring GPU performance. (Also see DirectX SDK: ID3D11Counter)
Public class | D3DDebug | A debug interface controls debug settings, validates pipeline state and can only be used if the debug layer is turned on. (Also see DirectX SDK: ID3D11Debug)
Public class | D3DDevice | The device interface represents a virtual Direct3D 11 adapter; it is used to perform rendering and create resources. To create a D3DDevice instance, use one of the static factory method overloads: CreateDevice() or CreateDeviceAndSwapChain(). (Also see DirectX SDK: ID3D11Device)
Public class | D3DPredicate | A predicate interface determines whether geometry should be processed depending on the results of a previous draw call. (Also see DirectX SDK: ID3D11Predicate)
Public class | D3DQuery | A query interface queries information from the GPU. (Also see DirectX SDK: ID3D11Query)
Public class | D3DResource | A resource interface provides common actions on all resources. (Also see DirectX SDK: ID3D11Resource)
Public class | DepthStencilState | A depth-stencil-state interface accesses depth-stencil state which sets up the depth-stencil test for the output-merger stage. (Also see DirectX SDK: ID3D11DepthStencilState)
Public class | DepthStencilView | A depth-stencil-view interface accesses a texture resource during depth-stencil testing. (Also see DirectX SDK: ID3D11DepthStencilView)
Public class | DeviceChild | A device-child interface accesses data used by a device. (Also see DirectX SDK: ID3D11DeviceChild)
Public class | DeviceContext | The DeviceContext interface represents a device context which generates rendering commands. (Also see DirectX SDK: ID3D11DeviceContext)
Public class | DomainShader | A domain-shader class manages an executable program (a domain shader) that controls the domain-shader stage. (Also see DirectX SDK: ID3D11DomainShader)
Public class | DomainShaderPipelineStage | Domain Shader pipeline stage.
Public class | GeometryShader | A geometry-shader class manages an executable program (a geometry shader) that controls the geometry-shader stage. (Also see DirectX SDK: ID3D11GeometryShader)
Public class | GeometryShaderPipelineStage | Geometry Shader pipeline stage.
Public class | HullShader | A hull-shader class manages an executable program (a hull shader) that controls the hull-shader stage. (Also see DirectX SDK: ID3D11HullShader)
Public class | HullShaderPipelineStage | Hull Shader pipeline stage.
Public class | InfoQueue | An information-queue interface stores, retrieves, and filters debug messages. The queue consists of a message queue, an optional storage filter stack, and a optional retrieval filter stack. (Also see DirectX SDK: ID3D11InfoQueue)
Public class | InputAssemblerPipelineStage | InputAssembler pipeline stage.
Public class | InputLayout | An input-layout interface accesses the input data for the input-assembler stage. (Also see DirectX SDK: ID3D11InputLayout)
Public class | OutputMergerBlendState | Stores the blend state, including blend factors and mask, for the merger pipeline stage
Public class | OutputMergerPipelineStage | OutputMerger pipeline stage.
Public class | OutputMergerRenderTargets | Stores the render targets for a merger pipeline stage
Public class | PipelineStage | A pipeline stage. base class for all pipline stage related classes.
Public class | PixelShader | A pixel-shader class manages an executable program (a pixel shader) that controls the pixel-shader stage. (Also see DirectX SDK: ID3D11PixelShader)
Public class | PixelShaderPipelineStage | Pixel Shader pipeline stage.
Public class | RasterizerPipelineStage | Rasterizer pipeline stage.
Public class | RasterizerState | A rasterizer-state interface accesses rasterizer state for the rasterizer stage. (Also see DirectX SDK: ID3D11RasterizerState)
Public class | RenderTargetView | A render-target-view interface identifies the render-target subresources that can be accessed during rendering. (Also see DirectX SDK: ID3D11RenderTargetView)
Public class | SamplerState | A sampler-state interface accesses sampler state for a texture. (Also see DirectX SDK: ID3D11SamplerState)
Public class | ShaderResourceView | A shader-resource-view interface specifies the subresources a shader can access during rendering. Examples of shader resources include a constant buffer, a texture buffer, a texture or a sampler. (Also see DirectX SDK: ID3D11ShaderResourceView)
Public class | StreamOutputPipelineStage | StreamOutput pipeline stage.
Public class | SwitchToRef | A switch-to-reference interface enables an application to switch between a hardware and software device. (Also see DirectX SDK: ID3D11SwitchToRef)
Public class | Texture1D | A 1D texture interface accesses texel data, which is structured memory. (Also see DirectX SDK: ID3D11Texture1D)
Public class | Texture2D | A 2D texture interface manages texel data, which is structured memory. (Also see DirectX SDK: ID3D11Texture2D)
Public class | Texture3D | A 3D texture interface accesses texel data, which is structured memory. (Also see DirectX SDK: ID3D11Texture3D)
Public class | UnorderedAccessView | A view interface specifies the parts of a resource the pipeline can access during rendering. (Also see DirectX SDK: ID3D11UnorderedAccessView)
Public class | VertexShader | A vertex-shader class manages an executable program (a vertex shader) that controls the vertex-shader stage. (Also see DirectX SDK: ID3D11VertexShader)
Public class | VertexShaderPipelineStage | Vertex Shader pipeline stage.
Public class | View | A view specifies the parts of a resource the pipeline can access during rendering. (Also see DirectX SDK: ID3D11View)

Structures

 | Structure | Description
Public structure | BlendDescription | Describes the blend state. (Also see DirectX SDK: D3D11_BLEND_DESC)
Public structure | Box | Defines a 3D box. (Also see DirectX SDK: D3D11_BOX)
Public structure | BufferDescription | Describes a buffer resource. (Also see DirectX SDK: D3D11_BUFFER_DESC)
Public structure | BufferRenderTargetView | Specifies the elements in a buffer resource to use in a render-target view. (Also see DirectX SDK: D3D11_BUFFER_RTV)
Public structure | BufferShaderResourceView | Specifies the elements in a buffer resource to use in a shader-resource view. (Also see DirectX SDK: D3D11_BUFFER_SRV)
Public structure | BufferUnorderedAccessView | Describes a unordered-access buffer resource. (Also see DirectX SDK: D3D11_BUFFER_UAV)
Public structure | ClassInstanceDescription | Describes an HLSL class instance. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC)
Public structure | CounterDescription | Describes a counter. (Also see DirectX SDK: D3D11_COUNTER_DESC)
Public structure | CounterInformation | Information about the video card's performance counter capabilities. (Also see DirectX SDK: D3D11_COUNTER_INFO)
Public structure | DepthStencilDescription | Describes depth-stencil state. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC)
Public structure | DepthStencilOperationDescription | Stencil operations that can be performed based on the results of stencil test. (Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC)
Public structure | DepthStencilViewDescription | Specifies the subresources of a texture that are accessible from a depth-stencil view. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC)
Public structure | ExtendedBufferShaderResourceView | Describes a raw buffer resource. (Also see DirectX SDK: D3D11_BUFFEREX_SRV)
Public structure | FeatureDataD3D10XHardwareOptions | (Also see DirectX SDK: D3D11_FEATURE_DATA_D3D10_X_HARDWARE_OPTIONS)
Public structure | FeatureDataDoubles | (Also see DirectX SDK: D3D11_FEATURE_DATA_DOUBLES)
Public structure | FeatureDataFormatSupport | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT)
Public structure | FeatureDataFormatSupport2 | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT)
Public structure | FeatureDataThreading | Describes the multi-threading features that are supported by the current graphics driver. (Also see DirectX SDK: D3D11_FEATURE_DATA_THREADING)
Public structure | IndexBuffer | Stores the parameters required to get or set the current index buffer for a device.
Public structure | InputElementDescription | A description of a single element for the input-assembler stage. (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC)
Public structure | MappedSubresource | Provides access to subresource data. (Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE)
Public structure | Message | A debug message in the Information Queue. (Also see DirectX SDK: D3D11_MESSAGE)
Public structure | QueryDataPipelineStatistics | Query information about graphics-pipeline activity in between calls to DeviceContext.Begin and DeviceContext.End. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS)
Public structure | QueryDataStreamOutputStatistics | Query information about the amount of data streamed out to the stream-output buffers in between DeviceContext.Begin and DeviceContext.End. (Also see DirectX SDK: D3D11_QUERY_DATA_SO_STATISTICS)
Public structure | QueryDataTimestampDisjoint | Query information about the reliability of a timestamp query. (Also see DirectX SDK: D3D11_QUERY_DATA_TIMESTAMP_DISJOINT)
Public structure | QueryDescription | Describes a query. (Also see DirectX SDK: D3D11_QUERY_DESC)
Public structure | RasterizerDescription | Describes rasterizer state. (Also see DirectX SDK: D3D11_RASTERIZER_DESC)
Public structure | RenderTargetBlendDescription | Describes the blend state for a render target. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC)
Public structure | RenderTargetViewDescription | Specifies the subresources from a resource that are accessible using a render-target view. (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC)
Public structure | SamplerDescription | Describes a sampler state. (Also see DirectX SDK: D3D11_SAMPLER_DESC)
Public structure | ShaderAndClasses<(Of <(<'T>)>)> |
Public structure | ShaderResourceViewDescription | Describes a shader-resource view. (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC)
Public structure | StreamOutputDeclarationEntry | Description of a vertex element in a vertex buffer in an output slot. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY)
Public structure | SubresourceData | Specifies data for initializing a subresource. (Also see DirectX SDK: D3D11_SUBRESOURCE_DATA)
Public structure | Texture1DArrayDepthStencilView | Specifies the subresources from an array of 1D textures to use in a depth-stencil view. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV)
Public structure | Texture1DArrayRenderTargetView | Specifies the subresources from an array of 1D textures to use in a render-target view. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV)
Public structure | Texture1DArrayShaderResourceView | Specifies the subresources from an array of 1D textures to use in a shader-resource view. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV)
Public structure | Texture1DArrayUnorderedAccessView | Describes an array of unordered-access 1D texture resources. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV)
Public structure | Texture1DDepthStencilView | Specifies the subresource from a 1D texture that is accessable to a depth-stencil view. (Also see DirectX SDK: D3D11_TEX1D_DSV)
Public structure | Texture1DDescription | Describes a 1D texture. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC)
Public structure | Texture1DRenderTargetView | Specifies the subresource from a 1D texture to use in a render-target view. (Also see DirectX SDK: D3D11_TEX1D_RTV)
Public structure | Texture1DShaderResourceView | Specifies the subresource from a 1D texture to use in a shader-resource view. (Also see DirectX SDK: D3D11_TEX1D_SRV)
Public structure | Texture1DUnorderedAccessView | Describes a unordered-access 1D texture resource. (Also see DirectX SDK: D3D11_TEX1D_UAV)
Public structure | Texture2DArrayDepthStencilView | Specifies the subresources from an array 2D textures that are accessable to a depth-stencil view. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV)
Public structure | Texture2DArrayRenderTargetView | Specifies the subresources from an array of 2D textures to use in a render-target view. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV)
Public structure | Texture2DArrayShaderResourceView | Specifies the subresources from an array of 2D textures to use in a shader-resource view. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV)
Public structure | Texture2DArrayUnorderedAccessView | Describes an array of unordered-access 2D texture resources. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV)
Public structure | Texture2DDepthStencilView | Specifies the subresource from a 2D texture that is accessable to a depth-stencil view. (Also see DirectX SDK: D3D11_TEX2D_DSV)
Public structure | Texture2DDescription | Describes a 2D texture. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC)
Public structure | Texture2DMultisampleArrayDepthStencilView | Specifies the subresources from an array of multisampled 2D textures for a depth-stencil view. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_DSV)
Public structure | Texture2DMultisampleArrayRenderTargetView | Specifies the subresources from a an array of multisampled 2D textures to use in a render-target view. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_RTV)
Public structure | Texture2DMultisampleArrayShaderResourceView | Specifies the subresources from an array of multisampled 2D textures to use in a shader-resource view. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_SRV)
Public structure | Texture2DMultisampleDepthStencilView | Specifies the subresource from a multisampled 2D texture that is accessable to a depth-stencil view. (Also see DirectX SDK: D3D11_TEX2DMS_DSV)
Public structure | Texture2DMultisampleRenderTargetView | Specifies the subresource from a multisampled 2D texture to use in a render-target view. (Also see DirectX SDK: D3D11_TEX2DMS_RTV)
Public structure | Texture2DMultisampleShaderResourceView | Specifies the subresources from a multisampled 2D texture to use in a shader-resource view. (Also see DirectX SDK: D3D11_TEX2DMS_SRV)
Public structure | Texture2DRenderTargetView | Specifies the subresource from a 2D texture to use in a render-target view. (Also see DirectX SDK: D3D11_TEX2D_RTV)
Public structure | Texture2DShaderResourceView | Specifies the subresource from a 2D texture to use in a shader-resource view. (Also see DirectX SDK: D3D11_TEX2D_SRV)
Public structure | Texture2DUnorderedAccessView | Describes a unordered-access 2D texture resource. (Also see DirectX SDK: D3D11_TEX2D_UAV)
Public structure | Texture3DDescription | Describes a 3D texture. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC)
Public structure | Texture3DRenderTargetView | Specifies the subresources from a 3D texture to use in a render-target view. (Also see DirectX SDK: D3D11_TEX3D_RTV)
Public structure | Texture3DShaderResourceView | Specifies the subresources from a 3D texture to use in a shader-resource view. (Also see DirectX SDK: D3D11_TEX3D_SRV)
Public structure | Texture3DUnorderedAccessView | Describes a unordered-access 3D texture resource. (Also see DirectX SDK: D3D11_TEX3D_UAV)
Public structure | TextureCubeArrayShaderResourceView | Specifies the subresources from an array of cube textures to use in a shader-resource view. (Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV)
Public structure | TextureCubeShaderResourceView | Specifies the subresource from a cube texture to use in a shader-resource view. (Also see DirectX SDK: D3D11_TEXCUBE_SRV)
Public structure | UnorderedAccessViewDescription | Specifies the subresources from a resource that are accessible using an unordered-access view. (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC)
Public structure | VertexBuffer | Stores the parameters required to get or set a vertex buffer for a device.
Public structure | Viewport | Defines the dimensions of a viewport. (Also see DirectX SDK: D3D11_VIEWPORT)

Enumerations

 | Enumeration | Description
Public enumeration | AsyncGetDataOptions | Optional flags that control the behavior of Asynchronous.GetData. (Also see DirectX SDK: D3D11_ASYNC_GETDATA_FLAG)
Public enumeration | BindingOptions | Identifies how to bind a resource to the pipeline. (Also see DirectX SDK: D3D11_BIND_FLAG)
Public enumeration | Blend | Blend options. A blend option identifies the data source and an optional pre-blend operation. (Also see DirectX SDK: D3D11_BLEND)
Public enumeration | BlendOperation | RGB or alpha blending operation. (Also see DirectX SDK: D3D11_BLEND_OP)
Public enumeration | ClearOptions | Specifies the parts of the depth stencil to clear. (Also see DirectX SDK: D3D11_CLEAR_FLAG)
Public enumeration | ColorWriteEnableComponents | Identify which components of each pixel of a render target are writable during blending. (Also see DirectX SDK: D3D11_COLOR_WRITE_ENABLE)
Public enumeration | ComparisonFunction | Comparison options. (Also see DirectX SDK: D3D11_COMPARISON_FUNC)
Public enumeration | Counter | Options for performance counters. (Also see DirectX SDK: D3D11_COUNTER)
Public enumeration | CounterType | Data type of a performance counter. (Also see DirectX SDK: D3D11_COUNTER_TYPE)
Public enumeration | CpuAccessOptions | Specifies the types of CPU access allowed for a resource. (Also see DirectX SDK: D3D11_CPU_ACCESS_FLAG)
Public enumeration | CreateDeviceOptions | Describes parameters that are used to create a device. (Also see DirectX SDK: D3D11_CREATE_DEVICE_FLAG)
Public enumeration | CullMode | Indicates triangles facing a particular direction are not drawn. (Also see DirectX SDK: D3D11_CULL_MODE)
Public enumeration | DebugFeatures | Setting a feature-mask flag will cause a rendering-operation method to do some extra task when called.
Public enumeration | DepthStencilViewDimension | Specifies how to access a resource used in a depth-stencil view. (Also see DirectX SDK: D3D11_DSV_DIMENSION)
Public enumeration | DepthStencilViewOptions | Depth-stencil view options. (Also see DirectX SDK: D3D11_DSV_FLAG)
Public enumeration | DepthWriteMask | Identify the portion of a depth-stencil buffer for writing depth data. (Also see DirectX SDK: D3D11_DEPTH_WRITE_MASK)
Public enumeration | DeviceContextType | Device context options. (Also see DirectX SDK: D3D11_DEVICE_CONTEXT_TYPE)
Public enumeration | DriverType | Driver type options. (Also see DirectX SDK: D3D_DRIVER_TYPE)
Public enumeration | ExceptionErrors | Option(s) for raising an error to a non-continuable exception. (Also see DirectX SDK: D3D11_RAISE_FLAG)
Public enumeration | ExtendedBufferBindingOptions | Identifies how to bind a raw-buffer resource to the pipeline. (Also see DirectX SDK: D3D11_BUFFEREX_SRV_FLAG)
Public enumeration | ExtendedFormatSupportOptions | Unordered resource support options for a compute shader resource. (Also see DirectX SDK: D3D11_FORMAT_SUPPORT2)
Public enumeration | Feature | Direct3D 11 feature options. (Also see DirectX SDK: D3D11_FEATURE)
Public enumeration | FillMode | Determines the fill mode to use when rendering triangles. (Also see DirectX SDK: D3D11_FILL_MODE)
Public enumeration | Filter | Filtering options during texture sampling. (Also see DirectX SDK: D3D11_FILTER)
Public enumeration | FilterType | Types of magnification or minification sampler filters. (Also see DirectX SDK: D3D11_FILTER_TYPE)
Public enumeration | FormatSupportOptions | Which resources are supported for a given format and given device. (Also see DirectX SDK: D3D11_FORMAT_SUPPORT)
Public enumeration | InputClassification | Type of data contained in an input slot. (Also see DirectX SDK: D3D11_INPUT_CLASSIFICATION)
Public enumeration | LiveDeviceObjectsReportOptions | Options for the amount of information returned about live device objects. (Also see DirectX SDK: D3D11_RLDO_FLAGS)
Public enumeration | Map | Identifies a resource to be accessed for reading and writing by the CPU. Applications may combine one or more of these flags. (Also see DirectX SDK: D3D11_MAP)
Public enumeration | MapOptions | Specifies how the CPU should respond when Map is called on a resource being used by the GPU. (Also see DirectX SDK: D3D11_MAP_FLAG)
Public enumeration | MessageCategory | Categories of debug messages. This will identify the category of a message when retrieving a message with InfoQueue.GetMessage and when adding a message with InfoQueue.AddMessage. When creating an info queue filter, these values can be used to allow or deny any categories of messages to pass through the storage and retrieval filters. (Also see DirectX SDK: D3D11_MESSAGE_CATEGORY)
Public enumeration | MessageId | Debug messages for setting up an info-queue filter; use these messages to allow or deny message categories to pass through the storage and retrieval filters. These IDs are used by methods such as InfoQueue.GetMessage or InfoQueue.AddMessage. (Also see DirectX SDK: D3D11_MESSAGE_ID)
Public enumeration | MessageSeverity | Debug message severity levels for an information queue. (Also see DirectX SDK: D3D11_MESSAGE_SEVERITY)
Public enumeration | MiscellaneousQueryOptions | Flags that describe miscellaneous query behavior. (Also see DirectX SDK: D3D11_QUERY_MISC_FLAG)
Public enumeration | MiscellaneousResourceOptions | Identifies other, less common options for resources. (Also see DirectX SDK: D3D11_RESOURCE_MISC_FLAG)
Public enumeration | Primitive | Primitive type, which determines how the data that makes up object geometry is organized. (Also see DirectX SDK: D3D11_PRIMITIVE)
Public enumeration | PrimitiveTopology | How the pipeline interprets vertex data that is bound to the input-assembler stage. These primitive types determine how the vertex data is rendered on screen. (Also see DirectX SDK: D3D11_PRIMITIVE_TOPOLOGY)
Public enumeration | Query | D3DQuery types. (Also see DirectX SDK: D3D11_QUERY)
Public enumeration | RenderTargetViewDimension | These flags identify the type of resource that will be viewed as a render target. (Also see DirectX SDK: D3D11_RTV_DIMENSION)
Public enumeration | ResourceDimension | Identifies the type of resource being used. (Also see DirectX SDK: D3D11_RESOURCE_DIMENSION)
Public enumeration | ShaderResourceViewDimension | These flags identify the type of resource that will be viewed as a shader resource. (Also see DirectX SDK: D3D11_SRV_DIMENSION)
Public enumeration | StencilOperation | The stencil operations that can be performed during depth-stencil testing. (Also see DirectX SDK: D3D11_STENCIL_OP)
Public enumeration | StencilReadMask | A value that identifies a portion of the depth-stencil buffer for reading stencil data.
Public enumeration | StencilWriteMask | A value that identifies a portion of the depth-stencil buffer for writing stencil data.
Public enumeration | TextureAddressMode | Identify a technique for resolving texture coordinates that are outside of the boundaries of a texture. (Also see DirectX SDK: D3D11_TEXTURE_ADDRESS_MODE)
Public enumeration | TextureCubeFace | The different faces of a cube texture. (Also see DirectX SDK: D3D11_TEXTURECUBE_FACE)
Public enumeration | UnorderedAccessViewBufferOptions | Unordered-access-view buffer options. (Also see DirectX SDK: D3D11_BUFFER_UAV_FLAG)
Public enumeration | UnorderedAccessViewDimension | Unordered-access view options. (Also see DirectX SDK: D3D11_UAV_DIMENSION)
Public enumeration | Usage | Identifies expected resource use during rendering. The usage directly reflects whether a resource is accessible by the CPU and/or the GPU. (Also see DirectX SDK: D3D11_USAGE)


AsyncGetDataOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AsyncGetDataOptions Enumeration
See Also Send Feedback
Optional flags that control the behavior of Asynchronous.GetData.

(Also see DirectX SDK: D3D11_ASYNC_GETDATA_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum AsyncGetDataOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration AsyncGetDataOptions
Visual C++
[FlagsAttribute]
public enum class AsyncGetDataOptions

Members

Member name | Description
DoNotFlush |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Asynchronous Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous Class
Members See Also Send Feedback
This class encapsulates methods for retrieving data from the GPU asynchronously.

(Also see DirectX SDK: ID3D11Asynchronous)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Asynchronous : DeviceChild
Visual Basic
Public Class Asynchronous _
    Inherits DeviceChild
Visual C++
public ref class Asynchronous : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DCounter
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DQuery

See Also

Asynchronous Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Asynchronous Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous Members
Asynchronous Class Properties See Also Send Feedback

The Asynchronous type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling DeviceContext.GetData. (Also see DirectX SDK: ID3D11Asynchronous::GetDataSize)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Asynchronous Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous Properties
Asynchronous Class See Also Send Feedback

The Asynchronous type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling DeviceContext.GetData. (Also see DirectX SDK: ID3D11Asynchronous::GetDataSize)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DataSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Asynchronous..::..DataSize Property
Asynchronous Class See Also Send Feedback
Get the size of the data (in bytes) that is output when calling DeviceContext.GetData.

(Also see DirectX SDK: ID3D11Asynchronous::GetDataSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DataSize { get; }
Visual Basic
Public ReadOnly Property DataSize As UInteger
    Get
Visual C++
public:
property unsigned int DataSize {
    unsigned int get ();
}

See Also

Asynchronous Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BindingOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BindingOptions Enumeration
See Also Send Feedback
Identifies how to bind a resource to the pipeline.

(Also see DirectX SDK: D3D11_BIND_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum BindingOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration BindingOptions
Visual C++
[FlagsAttribute]
public enum class BindingOptions

Members

Member name | Description
UnorderedAccess |
DepthStencil |
RenderTarget |
StreamOutput |
ShaderResource |
IndexBuffer |
VertexBuffer |
None |
ConstantBuffer |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Blend Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Blend Enumeration
See Also Send Feedback
Blend options. A blend option identifies the data source and an optional pre-blend operation.

(Also see DirectX SDK: D3D11_BLEND)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Blend
Visual Basic
Public Enumeration Blend
Visual C++
public enum class Blend

Members

Member name | Description
InverseSource1Alpha |
Source1Alpha |
InverseSource1Color |
Source1Color |
InverseBlendFactor |
SourceAlphaSat |
InverseDestinationColor |
DestinationColor |
InverseDestinationAlpha |
DestinationAlpha |
InverseSourceAlpha |
SourceAlpha |
InverseSourceColor |
SourceColor |
One |
Undefined |
Zero |
BlendFactor |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription Structure
Members See Also Send Feedback
Describes the blend state.

(Also see DirectX SDK: D3D11_BLEND_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BlendDescription
Visual Basic
Public Structure BlendDescription
Visual C++
public value class BlendDescription

See Also

BlendDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription Members
BlendDescription Structure Properties See Also Send Feedback

The BlendDescription type exposes the following members.

Properties

 | Name | Description
Public property | AlphaToCoverageEnable | Determines whether or not to use alpha-to-coverage as a multisampling technique when setting a pixel to a rendertarget. (Also see DirectX SDK: D3D11_BLEND_DESC.AlphaToCoverageEnable)
Public property | IndependentBlendEnable | Set to TRUE to enable independent blending in simultaneous render targets. (Also see DirectX SDK: D3D11_BLEND_DESC.IndependentBlendEnable)
Public property | RenderTarget | A collection of render-target-blend descriptions (see RenderTargetBlendDescription); these correspond to the eight rendertargets that can be set to the output-merger stage at one time. (Also see DirectX SDK: D3D11_BLEND_DESC.RenderTarget)

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription Properties
BlendDescription Structure See Also Send Feedback

The BlendDescription type exposes the following members.

Properties

 | Name | Description
Public property | AlphaToCoverageEnable | Determines whether or not to use alpha-to-coverage as a multisampling technique when setting a pixel to a rendertarget. (Also see DirectX SDK: D3D11_BLEND_DESC.AlphaToCoverageEnable)
Public property | IndependentBlendEnable | Set to TRUE to enable independent blending in simultaneous render targets. (Also see DirectX SDK: D3D11_BLEND_DESC.IndependentBlendEnable)
Public property | RenderTarget | A collection of render-target-blend descriptions (see RenderTargetBlendDescription); these correspond to the eight rendertargets that can be set to the output-merger stage at one time. (Also see DirectX SDK: D3D11_BLEND_DESC.RenderTarget)

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


AlphaToCoverageEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..AlphaToCoverageEnable Property
BlendDescription Structure See Also Send Feedback
Determines whether or not to use alpha-to-coverage as a multisampling technique when setting a pixel to a rendertarget.

(Also see DirectX SDK: D3D11_BLEND_DESC.AlphaToCoverageEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool AlphaToCoverageEnable { get; set; }
Visual Basic
Public Property AlphaToCoverageEnable As Boolean
    Get
    Set
Visual C++
public:
property bool AlphaToCoverageEnable {
    bool get ();
    void set (bool value);
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IndependentBlendEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..IndependentBlendEnable Property
BlendDescription Structure See Also Send Feedback
Set to TRUE to enable independent blending in simultaneous render targets.

(Also see DirectX SDK: D3D11_BLEND_DESC.IndependentBlendEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IndependentBlendEnable { get; set; }
Visual Basic
Public Property IndependentBlendEnable As Boolean
    Get
    Set
Visual C++
public:
property bool IndependentBlendEnable {
    bool get ();
    void set (bool value);
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTarget Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendDescription..::..RenderTarget Property
BlendDescription Structure See Also Send Feedback
A collection of render-target-blend descriptions (see RenderTargetBlendDescription); these correspond to the eight rendertargets that can be set to the output-merger stage at one time.

(Also see DirectX SDK: D3D11_BLEND_DESC.RenderTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<RenderTargetBlendDescription> RenderTarget { get; }
Visual Basic
Public ReadOnly Property RenderTarget As IEnumerable(Of RenderTargetBlendDescription)
    Get
Visual C++
public:
property IEnumerable<RenderTargetBlendDescription>^ RenderTarget {
    IEnumerable<RenderTargetBlendDescription>^ get ();
}

See Also

BlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetBlendDescription


BlendOperation Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendOperation Enumeration
See Also Send Feedback
RGB or alpha blending operation.

(Also see DirectX SDK: D3D11_BLEND_OP)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum BlendOperation
Visual Basic
Public Enumeration BlendOperation
Visual C++
public enum class BlendOperation

Members

Member name | Description
ReverseSubtract |
Undefined |
Max |
Min |
Subtract |
Add |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState Class
Members See Also Send Feedback
This blend-state interface accesses blending state for the output-merger stage.

(Also see DirectX SDK: ID3D11BlendState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class BlendState : DeviceChild
Visual Basic
Public Class BlendState _
    Inherits DeviceChild
Visual C++
public ref class BlendState : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BlendState

See Also

BlendState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState Members
BlendState Class Properties See Also Send Feedback

The BlendState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the blend state description. (Also see DirectX SDK: ID3D11BlendState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState Properties
BlendState Class See Also Send Feedback

The BlendState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the blend state description. (Also see DirectX SDK: ID3D11BlendState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BlendState..::..Description Property
BlendState Class See Also Send Feedback
Get the blend state description.

(Also see DirectX SDK: ID3D11BlendState::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As BlendDescription
    Get
Visual C++
public:
property BlendDescription Description {
    BlendDescription get ();
}

See Also

BlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Box Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Structure
Members See Also Send Feedback
Defines a 3D box.

(Also see DirectX SDK: D3D11_BOX)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Box
Visual Basic
Public Structure Box
Visual C++
public value class Box

See Also

Box Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Box Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Members
Box Structure Methods Operators Properties See Also Send Feedback

The Box type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Back | The z position of the back of the box. (Also see DirectX SDK: D3D11_BOX.back)
Public property | Bottom | The y position of the bottom of the box. (Also see DirectX SDK: D3D11_BOX.bottom)
Public property | Front | The z position of the front of the box. (Also see DirectX SDK: D3D11_BOX.front)
Public property | Left | The x position of the left hand side of the box. (Also see DirectX SDK: D3D11_BOX.left)
Public property | Right | The x position of the right hand side of the box. (Also see DirectX SDK: D3D11_BOX.right)
Public property | Top | The y position of the top of the box. (Also see DirectX SDK: D3D11_BOX.top)

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Box Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Methods
Box Structure See Also Send Feedback

The Box type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Equals Method
Box Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..GetHashCode Method
Box Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Box Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Operators
Box Structure See Also Send Feedback

The Box type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Equality Operator
Box Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Box box1,
    Box box2
)
Visual Basic
Public Shared Operator = ( _
    box1 As Box, _
    box2 As Box _
) As Boolean
Visual C++
public:
static bool operator ==(
    Box box1,
    Box box2
)

Parameters

box1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Box
box2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Box

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Inequality Operator
Box Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Box box1,
    Box box2
)
Visual Basic
Public Shared Operator <> ( _
    box1 As Box, _
    box2 As Box _
) As Boolean
Visual C++
public:
static bool operator !=(
    Box box1,
    Box box2
)

Parameters

box1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Box
box2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Box

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Box Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box Properties
Box Structure See Also Send Feedback

The Box type exposes the following members.

Properties

 | Name | Description
Public property | Back | The z position of the back of the box. (Also see DirectX SDK: D3D11_BOX.back)
Public property | Bottom | The y position of the bottom of the box. (Also see DirectX SDK: D3D11_BOX.bottom)
Public property | Front | The z position of the front of the box. (Also see DirectX SDK: D3D11_BOX.front)
Public property | Left | The x position of the left hand side of the box. (Also see DirectX SDK: D3D11_BOX.left)
Public property | Right | The x position of the right hand side of the box. (Also see DirectX SDK: D3D11_BOX.right)
Public property | Top | The y position of the top of the box. (Also see DirectX SDK: D3D11_BOX.top)

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Back Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Back Property
Box Structure See Also Send Feedback
The z position of the back of the box.

(Also see DirectX SDK: D3D11_BOX.back)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Back { get; set; }
Visual Basic
Public Property Back As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Back {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Bottom Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Bottom Property
Box Structure See Also Send Feedback
The y position of the bottom of the box.

(Also see DirectX SDK: D3D11_BOX.bottom)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Bottom { get; set; }
Visual Basic
Public Property Bottom As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Bottom {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Front Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Front Property
Box Structure See Also Send Feedback
The z position of the front of the box.

(Also see DirectX SDK: D3D11_BOX.front)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Front { get; set; }
Visual Basic
Public Property Front As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Front {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Left Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Left Property
Box Structure See Also Send Feedback
The x position of the left hand side of the box.

(Also see DirectX SDK: D3D11_BOX.left)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Left { get; set; }
Visual Basic
Public Property Left As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Left {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Right Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Right Property
Box Structure See Also Send Feedback
The x position of the right hand side of the box.

(Also see DirectX SDK: D3D11_BOX.right)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Right { get; set; }
Visual Basic
Public Property Right As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Right {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Top Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Box..::..Top Property
Box Structure See Also Send Feedback
The y position of the top of the box.

(Also see DirectX SDK: D3D11_BOX.top)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Top { get; set; }
Visual Basic
Public Property Top As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Top {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Box Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Structure
Members See Also Send Feedback
Describes a buffer resource.

(Also see DirectX SDK: D3D11_BUFFER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BufferDescription
Visual Basic
Public Structure BufferDescription
Visual C++
public value class BufferDescription

See Also

BufferDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Members
BufferDescription Structure Methods Operators Properties See Also Send Feedback

The BufferDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BindingOptions | Identify how the buffer will be bound to the pipeline. Flags (see BindingOptions) can be combined with a logical OR. (Also see DirectX SDK: D3D11_BUFFER_DESC.BindFlags)
Public property | ByteWidth | Size of the buffer in bytes. (Also see DirectX SDK: D3D11_BUFFER_DESC.ByteWidth)
Public property | CpuAccessOptions | CPU access flags (see CpuAccessOptions) or 0 if no CPU access is necessary. Flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_BUFFER_DESC.CPUAccessFlags)
Public property | MiscellaneousResourceOptions | Miscellaneous flags (see MiscellaneousResourceOptions) or 0 if unused. Flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_BUFFER_DESC.MiscFlags)
Public property | StructureByteStride | The size of the structure (in bytes) when it represents a structured buffer. (Also see DirectX SDK: D3D11_BUFFER_DESC.StructureByteStride)
Public property | Usage | Identify how the buffer is expected to be read from and written to. Frequency of update is a key factor. The most common value is typically Usage_DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D11_BUFFER_DESC.Usage)

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Methods
BufferDescription Structure See Also Send Feedback

The BufferDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..Equals Method
BufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..GetHashCode Method
BufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Operators
BufferDescription Structure See Also Send Feedback

The BufferDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..Equality Operator
BufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BufferDescription bufferDescription1,
    BufferDescription bufferDescription2
)
Visual Basic
Public Shared Operator = ( _
    bufferDescription1 As BufferDescription, _
    bufferDescription2 As BufferDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    BufferDescription bufferDescription1,
    BufferDescription bufferDescription2
)

Parameters

bufferDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferDescription
bufferDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferDescription

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..Inequality Operator
BufferDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BufferDescription bufferDescription1,
    BufferDescription bufferDescription2
)
Visual Basic
Public Shared Operator <> ( _
    bufferDescription1 As BufferDescription, _
    bufferDescription2 As BufferDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    BufferDescription bufferDescription1,
    BufferDescription bufferDescription2
)

Parameters

bufferDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferDescription
bufferDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferDescription

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription Properties
BufferDescription Structure See Also Send Feedback

The BufferDescription type exposes the following members.

Properties

 | Name | Description
Public property | BindingOptions | Identify how the buffer will be bound to the pipeline. Flags (see BindingOptions) can be combined with a logical OR. (Also see DirectX SDK: D3D11_BUFFER_DESC.BindFlags)
Public property | ByteWidth | Size of the buffer in bytes. (Also see DirectX SDK: D3D11_BUFFER_DESC.ByteWidth)
Public property | CpuAccessOptions | CPU access flags (see CpuAccessOptions) or 0 if no CPU access is necessary. Flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_BUFFER_DESC.CPUAccessFlags)
Public property | MiscellaneousResourceOptions | Miscellaneous flags (see MiscellaneousResourceOptions) or 0 if unused. Flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_BUFFER_DESC.MiscFlags)
Public property | StructureByteStride | The size of the structure (in bytes) when it represents a structured buffer. (Also see DirectX SDK: D3D11_BUFFER_DESC.StructureByteStride)
Public property | Usage | Identify how the buffer is expected to be read from and written to. Frequency of update is a key factor. The most common value is typically Usage_DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D11_BUFFER_DESC.Usage)

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BindingOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..BindingOptions Property
BufferDescription Structure See Also Send Feedback
Identify how the buffer will be bound to the pipeline. Flags (see BindingOptions) can be combined with a logical OR.

(Also see DirectX SDK: D3D11_BUFFER_DESC.BindFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BindingOptions BindingOptions { get; set; }
Visual Basic
Public Property BindingOptions As BindingOptions
    Get
    Set
Visual C++
public:
property BindingOptions BindingOptions {
    BindingOptions get ();
    void set (BindingOptions value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BindingOptions


ByteWidth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..ByteWidth Property
BufferDescription Structure See Also Send Feedback
Size of the buffer in bytes.

(Also see DirectX SDK: D3D11_BUFFER_DESC.ByteWidth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ByteWidth { get; set; }
Visual Basic
Public Property ByteWidth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ByteWidth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CpuAccessOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..CpuAccessOptions Property
BufferDescription Structure See Also Send Feedback
CPU access flags (see CpuAccessOptions) or 0 if no CPU access is necessary. Flags can be combined with a logical OR.

(Also see DirectX SDK: D3D11_BUFFER_DESC.CPUAccessFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CpuAccessOptions CpuAccessOptions { get; set; }
Visual Basic
Public Property CpuAccessOptions As CpuAccessOptions
    Get
    Set
Visual C++
public:
property CpuAccessOptions CpuAccessOptions {
    CpuAccessOptions get ();
    void set (CpuAccessOptions value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
BufferDescription..::..CpuAccessOptions


MiscellaneousResourceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..MiscellaneousResourceOptions Property
BufferDescription Structure See Also Send Feedback
Miscellaneous flags (see MiscellaneousResourceOptions) or 0 if unused. Flags can be combined with a logical OR.

(Also see DirectX SDK: D3D11_BUFFER_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousResourceOptions MiscellaneousResourceOptions { get; set; }
Visual Basic
Public Property MiscellaneousResourceOptions As MiscellaneousResourceOptions
    Get
    Set
Visual C++
public:
property MiscellaneousResourceOptions MiscellaneousResourceOptions {
    MiscellaneousResourceOptions get ();
    void set (MiscellaneousResourceOptions value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
BufferDescription..::..MiscellaneousResourceOptions


StructureByteStride Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..StructureByteStride Property
BufferDescription Structure See Also Send Feedback
The size of the structure (in bytes) when it represents a structured buffer.

(Also see DirectX SDK: D3D11_BUFFER_DESC.StructureByteStride)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint StructureByteStride { get; set; }
Visual Basic
Public Property StructureByteStride As UInteger
    Get
    Set
Visual C++
public:
property unsigned int StructureByteStride {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Usage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferDescription..::..Usage Property
BufferDescription Structure See Also Send Feedback
Identify how the buffer is expected to be read from and written to. Frequency of update is a key factor. The most common value is typically Usage_DEFAULT; see Usage for all possible values.

(Also see DirectX SDK: D3D11_BUFFER_DESC.Usage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Usage Usage { get; set; }
Visual Basic
Public Property Usage As Usage
    Get
    Set
Visual C++
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

See Also

BufferDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Structure
Members See Also Send Feedback
Specifies the elements in a buffer resource to use in a render-target view.

(Also see DirectX SDK: D3D11_BUFFER_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BufferRenderTargetView
Visual Basic
Public Structure BufferRenderTargetView
Visual C++
public value class BufferRenderTargetView

See Also

BufferRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Members
BufferRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The BufferRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ElementOffset | Number of bytes between the beginning of the buffer and the first element to access. (Also see DirectX SDK: D3D11_BUFFER_RTV.ElementOffset)
Public property | ElementWidth | The width of each element (in bytes). This can be determined from the format stored in the render-target-view description. (Also see DirectX SDK: D3D11_BUFFER_RTV.ElementWidth)

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Methods
BufferRenderTargetView Structure See Also Send Feedback

The BufferRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..Equals Method
BufferRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..GetHashCode Method
BufferRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Operators
BufferRenderTargetView Structure See Also Send Feedback

The BufferRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..Equality Operator
BufferRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BufferRenderTargetView bufferRenderTargetView1,
    BufferRenderTargetView bufferRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    bufferRenderTargetView1 As BufferRenderTargetView, _
    bufferRenderTargetView2 As BufferRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    BufferRenderTargetView bufferRenderTargetView1,
    BufferRenderTargetView bufferRenderTargetView2
)

Parameters

bufferRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferRenderTargetView
bufferRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferRenderTargetView

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..Inequality Operator
BufferRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BufferRenderTargetView bufferRenderTargetView1,
    BufferRenderTargetView bufferRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    bufferRenderTargetView1 As BufferRenderTargetView, _
    bufferRenderTargetView2 As BufferRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    BufferRenderTargetView bufferRenderTargetView1,
    BufferRenderTargetView bufferRenderTargetView2
)

Parameters

bufferRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferRenderTargetView
bufferRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferRenderTargetView

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView Properties
BufferRenderTargetView Structure See Also Send Feedback

The BufferRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | ElementOffset | Number of bytes between the beginning of the buffer and the first element to access. (Also see DirectX SDK: D3D11_BUFFER_RTV.ElementOffset)
Public property | ElementWidth | The width of each element (in bytes). This can be determined from the format stored in the render-target-view description. (Also see DirectX SDK: D3D11_BUFFER_RTV.ElementWidth)

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ElementOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..ElementOffset Property
BufferRenderTargetView Structure See Also Send Feedback
Number of bytes between the beginning of the buffer and the first element to access.

(Also see DirectX SDK: D3D11_BUFFER_RTV.ElementOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementOffset { get; set; }
Visual Basic
Public Property ElementOffset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ElementWidth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferRenderTargetView..::..ElementWidth Property
BufferRenderTargetView Structure See Also Send Feedback
The width of each element (in bytes). This can be determined from the format stored in the render-target-view description.

(Also see DirectX SDK: D3D11_BUFFER_RTV.ElementWidth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementWidth { get; set; }
Visual Basic
Public Property ElementWidth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementWidth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Structure
Members See Also Send Feedback
Specifies the elements in a buffer resource to use in a shader-resource view.

(Also see DirectX SDK: D3D11_BUFFER_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BufferShaderResourceView
Visual Basic
Public Structure BufferShaderResourceView
Visual C++
public value class BufferShaderResourceView

See Also

BufferShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Members
BufferShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The BufferShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ElementOffset | The offset of the first element in the view to access, relative to element 0. (Also see DirectX SDK: D3D11_BUFFER_SRV.ElementOffset)
Public property | ElementWidth | The total number of elements in the view. (Also see DirectX SDK: D3D11_BUFFER_SRV.ElementWidth)

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Methods
BufferShaderResourceView Structure See Also Send Feedback

The BufferShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..Equals Method
BufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..GetHashCode Method
BufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Operators
BufferShaderResourceView Structure See Also Send Feedback

The BufferShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..Equality Operator
BufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BufferShaderResourceView bufferShaderResourceView1,
    BufferShaderResourceView bufferShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    bufferShaderResourceView1 As BufferShaderResourceView, _
    bufferShaderResourceView2 As BufferShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    BufferShaderResourceView bufferShaderResourceView1,
    BufferShaderResourceView bufferShaderResourceView2
)

Parameters

bufferShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferShaderResourceView
bufferShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferShaderResourceView

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..Inequality Operator
BufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BufferShaderResourceView bufferShaderResourceView1,
    BufferShaderResourceView bufferShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    bufferShaderResourceView1 As BufferShaderResourceView, _
    bufferShaderResourceView2 As BufferShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    BufferShaderResourceView bufferShaderResourceView1,
    BufferShaderResourceView bufferShaderResourceView2
)

Parameters

bufferShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferShaderResourceView
bufferShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferShaderResourceView

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView Properties
BufferShaderResourceView Structure See Also Send Feedback

The BufferShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | ElementOffset | The offset of the first element in the view to access, relative to element 0. (Also see DirectX SDK: D3D11_BUFFER_SRV.ElementOffset)
Public property | ElementWidth | The total number of elements in the view. (Also see DirectX SDK: D3D11_BUFFER_SRV.ElementWidth)

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ElementOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..ElementOffset Property
BufferShaderResourceView Structure See Also Send Feedback
The offset of the first element in the view to access, relative to element 0.

(Also see DirectX SDK: D3D11_BUFFER_SRV.ElementOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementOffset { get; set; }
Visual Basic
Public Property ElementOffset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ElementWidth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferShaderResourceView..::..ElementWidth Property
BufferShaderResourceView Structure See Also Send Feedback
The total number of elements in the view.

(Also see DirectX SDK: D3D11_BUFFER_SRV.ElementWidth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementWidth { get; set; }
Visual Basic
Public Property ElementWidth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementWidth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferUnorderedAccessView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView Structure
Members See Also Send Feedback
Describes a unordered-access buffer resource.

(Also see DirectX SDK: D3D11_BUFFER_UAV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BufferUnorderedAccessView
Visual Basic
Public Structure BufferUnorderedAccessView
Visual C++
public value class BufferUnorderedAccessView

See Also

BufferUnorderedAccessView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferUnorderedAccessView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView Members
BufferUnorderedAccessView Structure Methods Operators Properties See Also Send Feedback

The BufferUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BufferOptions | View options for the resource (see UnorderedAccessViewBufferOptions). (Also see DirectX SDK: D3D11_BUFFER_UAV.Flags)
Public property | ElementCount | The number of elements in the resource. (Also see DirectX SDK: D3D11_BUFFER_UAV.NumElements)
Public property | FirstElement | The zero-based index of the first element to be accessed. (Also see DirectX SDK: D3D11_BUFFER_UAV.FirstElement)

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferUnorderedAccessView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView Methods
BufferUnorderedAccessView Structure See Also Send Feedback

The BufferUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView..::..Equals Method
BufferUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView..::..GetHashCode Method
BufferUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferUnorderedAccessView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView Operators
BufferUnorderedAccessView Structure See Also Send Feedback

The BufferUnorderedAccessView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView..::..Equality Operator
BufferUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BufferUnorderedAccessView bufferUnorderedAccessView1,
    BufferUnorderedAccessView bufferUnorderedAccessView2
)
Visual Basic
Public Shared Operator = ( _
    bufferUnorderedAccessView1 As BufferUnorderedAccessView, _
    bufferUnorderedAccessView2 As BufferUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator ==(
    BufferUnorderedAccessView bufferUnorderedAccessView1,
    BufferUnorderedAccessView bufferUnorderedAccessView2
)

Parameters

bufferUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferUnorderedAccessView
bufferUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferUnorderedAccessView

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView..::..Inequality Operator
BufferUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BufferUnorderedAccessView bufferUnorderedAccessView1,
    BufferUnorderedAccessView bufferUnorderedAccessView2
)
Visual Basic
Public Shared Operator <> ( _
    bufferUnorderedAccessView1 As BufferUnorderedAccessView, _
    bufferUnorderedAccessView2 As BufferUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator !=(
    BufferUnorderedAccessView bufferUnorderedAccessView1,
    BufferUnorderedAccessView bufferUnorderedAccessView2
)

Parameters

bufferUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferUnorderedAccessView
bufferUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferUnorderedAccessView

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferUnorderedAccessView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView Properties
BufferUnorderedAccessView Structure See Also Send Feedback

The BufferUnorderedAccessView type exposes the following members.

Properties

 | Name | Description
Public property | BufferOptions | View options for the resource (see UnorderedAccessViewBufferOptions). (Also see DirectX SDK: D3D11_BUFFER_UAV.Flags)
Public property | ElementCount | The number of elements in the resource. (Also see DirectX SDK: D3D11_BUFFER_UAV.NumElements)
Public property | FirstElement | The zero-based index of the first element to be accessed. (Also see DirectX SDK: D3D11_BUFFER_UAV.FirstElement)

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BufferOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView..::..BufferOptions Property
BufferUnorderedAccessView Structure See Also Send Feedback
View options for the resource (see UnorderedAccessViewBufferOptions).

(Also see DirectX SDK: D3D11_BUFFER_UAV.Flags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public UnorderedAccessViewBufferOptions BufferOptions { get; set; }
Visual Basic
Public Property BufferOptions As UnorderedAccessViewBufferOptions
    Get
    Set
Visual C++
public:
property UnorderedAccessViewBufferOptions BufferOptions {
    UnorderedAccessViewBufferOptions get ();
    void set (UnorderedAccessViewBufferOptions value);
}

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..UnorderedAccessViewBufferOptions


ElementCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView..::..ElementCount Property
BufferUnorderedAccessView Structure See Also Send Feedback
The number of elements in the resource.

(Also see DirectX SDK: D3D11_BUFFER_UAV.NumElements)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementCount { get; set; }
Visual Basic
Public Property ElementCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstElement Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BufferUnorderedAccessView..::..FirstElement Property
BufferUnorderedAccessView Structure See Also Send Feedback
The zero-based index of the first element to be accessed.

(Also see DirectX SDK: D3D11_BUFFER_UAV.FirstElement)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstElement { get; set; }
Visual Basic
Public Property FirstElement As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstElement {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BufferUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassInstance Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstance Class
Members See Also Send Feedback
This class encapsulates an HLSL class.

(Also see DirectX SDK: ID3D11ClassInstance)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ClassInstance : DeviceChild
Visual Basic
Public Class ClassInstance _
    Inherits DeviceChild
Visual C++
public ref class ClassInstance : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassInstance

See Also

ClassInstance Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassInstance Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstance Members
ClassInstance Class Properties See Also Send Feedback

The ClassInstance type exposes the following members.

Properties

 | Name | Description
Public property | ClassLinkage | Gets the ClassLinkage object associated with the current HLSL class. (Also see DirectX SDK: ID3D11ClassInstance::GetClassLinkage)
Public property | Description | Gets a description of the current HLSL class. (Also see DirectX SDK: ID3D11ClassInstance::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | InstanceName | Gets the instance name of the current HLSL class. (Also see DirectX SDK: ID3D11ClassInstance::GetInstanceName)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | TypeName | Gets the type of the current HLSL class. (Also see DirectX SDK: ID3D11ClassInstance::GetTypeName)

See Also

ClassInstance Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassInstance Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstance Properties
ClassInstance Class See Also Send Feedback

The ClassInstance type exposes the following members.

Properties

 | Name | Description
Public property | ClassLinkage | Gets the ClassLinkage object associated with the current HLSL class. (Also see DirectX SDK: ID3D11ClassInstance::GetClassLinkage)
Public property | Description | Gets a description of the current HLSL class. (Also see DirectX SDK: ID3D11ClassInstance::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | InstanceName | Gets the instance name of the current HLSL class. (Also see DirectX SDK: ID3D11ClassInstance::GetInstanceName)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | TypeName | Gets the type of the current HLSL class. (Also see DirectX SDK: ID3D11ClassInstance::GetTypeName)

See Also

ClassInstance Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassLinkage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstance..::..ClassLinkage Property
ClassInstance Class See Also Send Feedback
Gets the ClassLinkage object associated with the current HLSL class.

(Also see DirectX SDK: ID3D11ClassInstance::GetClassLinkage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ClassLinkage ClassLinkage { get; }
Visual Basic
Public ReadOnly Property ClassLinkage As ClassLinkage
    Get
Visual C++
public:
property ClassLinkage^ ClassLinkage {
    ClassLinkage^ get ();
}

See Also

ClassInstance Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstance..::..Description Property
ClassInstance Class See Also Send Feedback
Gets a description of the current HLSL class.

(Also see DirectX SDK: ID3D11ClassInstance::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ClassInstanceDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As ClassInstanceDescription
    Get
Visual C++
public:
property ClassInstanceDescription Description {
    ClassInstanceDescription get ();
}

See Also

ClassInstance Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InstanceName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstance..::..InstanceName Property
ClassInstance Class See Also Send Feedback
Gets the instance name of the current HLSL class.

(Also see DirectX SDK: ID3D11ClassInstance::GetInstanceName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string InstanceName { get; }
Visual Basic
Public ReadOnly Property InstanceName As String
    Get
Visual C++
public:
property String^ InstanceName {
    String^ get ();
}

See Also

ClassInstance Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TypeName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstance..::..TypeName Property
ClassInstance Class See Also Send Feedback
Gets the type of the current HLSL class.

(Also see DirectX SDK: ID3D11ClassInstance::GetTypeName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get
Visual C++
public:
property String^ TypeName {
    String^ get ();
}

See Also

ClassInstance Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassInstanceDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription Structure
Members See Also Send Feedback
Describes an HLSL class instance.

(Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ClassInstanceDescription
Visual Basic
Public Structure ClassInstanceDescription
Visual C++
public value class ClassInstanceDescription

See Also

ClassInstanceDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassInstanceDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription Members
ClassInstanceDescription Structure Methods Operators Properties See Also Send Feedback

The ClassInstanceDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BaseConstantBufferOffset | The base constant buffer offset associated with an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.BaseConstantBufferOffset)
Public property | BaseSampler | The base sampler associated with an HLSL class; the default value is 15. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.BaseSampler)
Public property | BaseTexture | The base texture associated with an HLSL class; the default value is 127. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.BaseTexture)
Public property | ConstantBuffer | Describes the constant buffer associated with an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.ConstantBuffer)
Public property | Created | True if the class was created; the default value is false. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.Created)
Public property | InstanceId | The instance ID of an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.InstanceId)
Public property | InstanceIndex | The instance index of an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.InstanceIndex)
Public property | TypeId | The type ID of an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.TypeId)

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassInstanceDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription Methods
ClassInstanceDescription Structure See Also Send Feedback

The ClassInstanceDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..Equals Method
ClassInstanceDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..GetHashCode Method
ClassInstanceDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassInstanceDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription Operators
ClassInstanceDescription Structure See Also Send Feedback

The ClassInstanceDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..Equality Operator
ClassInstanceDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ClassInstanceDescription classInstanceDescription1,
    ClassInstanceDescription classInstanceDescription2
)
Visual Basic
Public Shared Operator = ( _
    classInstanceDescription1 As ClassInstanceDescription, _
    classInstanceDescription2 As ClassInstanceDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    ClassInstanceDescription classInstanceDescription1,
    ClassInstanceDescription classInstanceDescription2
)

Parameters

classInstanceDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassInstanceDescription
classInstanceDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassInstanceDescription

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..Inequality Operator
ClassInstanceDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ClassInstanceDescription classInstanceDescription1,
    ClassInstanceDescription classInstanceDescription2
)
Visual Basic
Public Shared Operator <> ( _
    classInstanceDescription1 As ClassInstanceDescription, _
    classInstanceDescription2 As ClassInstanceDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    ClassInstanceDescription classInstanceDescription1,
    ClassInstanceDescription classInstanceDescription2
)

Parameters

classInstanceDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassInstanceDescription
classInstanceDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassInstanceDescription

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassInstanceDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription Properties
ClassInstanceDescription Structure See Also Send Feedback

The ClassInstanceDescription type exposes the following members.

Properties

 | Name | Description
Public property | BaseConstantBufferOffset | The base constant buffer offset associated with an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.BaseConstantBufferOffset)
Public property | BaseSampler | The base sampler associated with an HLSL class; the default value is 15. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.BaseSampler)
Public property | BaseTexture | The base texture associated with an HLSL class; the default value is 127. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.BaseTexture)
Public property | ConstantBuffer | Describes the constant buffer associated with an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.ConstantBuffer)
Public property | Created | True if the class was created; the default value is false. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.Created)
Public property | InstanceId | The instance ID of an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.InstanceId)
Public property | InstanceIndex | The instance index of an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.InstanceIndex)
Public property | TypeId | The type ID of an HLSL class; the default value is 0. (Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.TypeId)

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BaseConstantBufferOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..BaseConstantBufferOffset Property
ClassInstanceDescription Structure See Also Send Feedback
The base constant buffer offset associated with an HLSL class; the default value is 0.

(Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.BaseConstantBufferOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BaseConstantBufferOffset { get; set; }
Visual Basic
Public Property BaseConstantBufferOffset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BaseConstantBufferOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BaseSampler Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..BaseSampler Property
ClassInstanceDescription Structure See Also Send Feedback
The base sampler associated with an HLSL class; the default value is 15.

(Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.BaseSampler)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BaseSampler { get; set; }
Visual Basic
Public Property BaseSampler As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BaseSampler {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BaseTexture Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..BaseTexture Property
ClassInstanceDescription Structure See Also Send Feedback
The base texture associated with an HLSL class; the default value is 127.

(Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.BaseTexture)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BaseTexture { get; set; }
Visual Basic
Public Property BaseTexture As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BaseTexture {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ConstantBuffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..ConstantBuffer Property
ClassInstanceDescription Structure See Also Send Feedback
Describes the constant buffer associated with an HLSL class; the default value is 0.

(Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.ConstantBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ConstantBuffer { get; set; }
Visual Basic
Public Property ConstantBuffer As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ConstantBuffer {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Created Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..Created Property
ClassInstanceDescription Structure See Also Send Feedback
True if the class was created; the default value is false.

(Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.Created)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool Created { get; set; }
Visual Basic
Public Property Created As Boolean
    Get
    Set
Visual C++
public:
property bool Created {
    bool get ();
    void set (bool value);
}

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InstanceId Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..InstanceId Property
ClassInstanceDescription Structure See Also Send Feedback
The instance ID of an HLSL class; the default value is 0.

(Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.InstanceId)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InstanceId { get; set; }
Visual Basic
Public Property InstanceId As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InstanceId {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InstanceIndex Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..InstanceIndex Property
ClassInstanceDescription Structure See Also Send Feedback
The instance index of an HLSL class; the default value is 0.

(Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.InstanceIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InstanceIndex { get; set; }
Visual Basic
Public Property InstanceIndex As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InstanceIndex {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TypeId Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassInstanceDescription..::..TypeId Property
ClassInstanceDescription Structure See Also Send Feedback
The type ID of an HLSL class; the default value is 0.

(Also see DirectX SDK: D3D11_CLASS_INSTANCE_DESC.TypeId)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TypeId { get; set; }
Visual Basic
Public Property TypeId As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TypeId {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ClassInstanceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassLinkage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassLinkage Class
Members See Also Send Feedback
This class encapsulates an HLSL dynamic linkage.

(Also see DirectX SDK: ID3D11ClassLinkage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ClassLinkage : DeviceChild
Visual Basic
Public Class ClassLinkage _
    Inherits DeviceChild
Visual C++
public ref class ClassLinkage : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage

See Also

ClassLinkage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassLinkage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassLinkage Members
ClassLinkage Class Methods Properties See Also Send Feedback

The ClassLinkage type exposes the following members.

Methods

 | Name | Description
Public method | CreateClassInstance | Initializes a class-instance object that represents an HLSL class instance. (Also see DirectX SDK: ID3D11ClassLinkage::CreateClassInstance)
Public method | GetClassInstance | Gets the class-instance object that represents the specified HLSL class. (Also see DirectX SDK: ID3D11ClassLinkage::GetClassInstance)

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ClassLinkage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassLinkage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassLinkage Methods
ClassLinkage Class See Also Send Feedback

The ClassLinkage type exposes the following members.

Methods

 | Name | Description
Public method | CreateClassInstance | Initializes a class-instance object that represents an HLSL class instance. (Also see DirectX SDK: ID3D11ClassLinkage::CreateClassInstance)
Public method | GetClassInstance | Gets the class-instance object that represents the specified HLSL class. (Also see DirectX SDK: ID3D11ClassLinkage::GetClassInstance)

See Also

ClassLinkage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateClassInstance Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassLinkage..::..CreateClassInstance Method
ClassLinkage Class See Also Send Feedback
Initializes a class-instance object that represents an HLSL class instance.

(Also see DirectX SDK: ID3D11ClassLinkage::CreateClassInstance)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ClassInstance CreateClassInstance(
    string classTypeName,
    uint constantBufferOffset,
    uint constantVectorOffset,
    uint textureOffset,
    uint samplerOffset
)
Visual Basic
Public Function CreateClassInstance ( _
    classTypeName As String, _
    constantBufferOffset As UInteger, _
    constantVectorOffset As UInteger, _
    textureOffset As UInteger, _
    samplerOffset As UInteger _
) As ClassInstance
Visual C++
public:
ClassInstance^ CreateClassInstance(
    String^ classTypeName,
    unsigned int constantBufferOffset,
    unsigned int constantVectorOffset,
    unsigned int textureOffset,
    unsigned int samplerOffset
)

Parameters

classTypeName
Type: System..::..String
The type name of a class to initialize.
constantBufferOffset
Type: System..::..UInt32
Identifies the constant buffer that contains the class data.
constantVectorOffset
Type: System..::..UInt32
The four-component vector offset from the start of the constant buffer where the class data will begin. Consequently, this is not a byte offset.
textureOffset
Type: System..::..UInt32
The texture slot for the first texture; there may be multiple textures following the offset.
samplerOffset
Type: System..::..UInt32
The sampler slot for the first sampler; there may be multiple samplers following the offset.

Return Value

A ClassInstance interface to initialize.

See Also

ClassLinkage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetClassInstance Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassLinkage..::..GetClassInstance Method
ClassLinkage Class See Also Send Feedback
Gets the class-instance object that represents the specified HLSL class.

(Also see DirectX SDK: ID3D11ClassLinkage::GetClassInstance)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ClassInstance GetClassInstance(
    string classInstanceName,
    uint instanceIndex
)
Visual Basic
Public Function GetClassInstance ( _
    classInstanceName As String, _
    instanceIndex As UInteger _
) As ClassInstance
Visual C++
public:
ClassInstance^ GetClassInstance(
    String^ classInstanceName,
    unsigned int instanceIndex
)

Parameters

classInstanceName
Type: System..::..String
The name of a class for which to get the class instance.
instanceIndex
Type: System..::..UInt32
The index of the class instance.

Return Value

The ClassInstance to initialize.

See Also

ClassLinkage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClassLinkage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClassLinkage Properties
ClassLinkage Class See Also Send Feedback

The ClassLinkage type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ClassLinkage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClearOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClearOptions Enumeration
See Also Send Feedback
Specifies the parts of the depth stencil to clear.

(Also see DirectX SDK: D3D11_CLEAR_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ClearOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration ClearOptions
Visual C++
[FlagsAttribute]
public enum class ClearOptions

Members

Member name | Description
Depth |
None |
Stencil |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ColorWriteEnableComponents Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorWriteEnableComponents Enumeration
See Also Send Feedback
Identify which components of each pixel of a render target are writable during blending.

(Also see DirectX SDK: D3D11_COLOR_WRITE_ENABLE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ColorWriteEnableComponents
Visual Basic
<FlagsAttribute> _
Public Enumeration ColorWriteEnableComponents
Visual C++
[FlagsAttribute]
public enum class ColorWriteEnableComponents

Members

Member name | Description
None |
All |
Alpha |
Blue |
Green |
Red |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CommandList Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CommandList Class
Members See Also Send Feedback
The CommandList interface encapsulates a collection of graphics commands for play back.

(Also see DirectX SDK: ID3D11CommandList)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class CommandList : DeviceChild
Visual Basic
Public Class CommandList _
    Inherits DeviceChild
Visual C++
public ref class CommandList : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CommandList

See Also

CommandList Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CommandList Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CommandList Members
CommandList Class Properties See Also Send Feedback

The CommandList type exposes the following members.

Properties

 | Name | Description
Public property | ContextOptions | Gets the initialization flags associated with the deferred context that created the command list. The context flag is reserved for future use and is always 0. (Also see DirectX SDK: ID3D11CommandList::GetContextFlags)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

CommandList Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CommandList Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CommandList Properties
CommandList Class See Also Send Feedback

The CommandList type exposes the following members.

Properties

 | Name | Description
Public property | ContextOptions | Gets the initialization flags associated with the deferred context that created the command list. The context flag is reserved for future use and is always 0. (Also see DirectX SDK: ID3D11CommandList::GetContextFlags)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

CommandList Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ContextOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CommandList..::..ContextOptions Property
CommandList Class See Also Send Feedback
Gets the initialization flags associated with the deferred context that created the command list. The context flag is reserved for future use and is always 0.

(Also see DirectX SDK: ID3D11CommandList::GetContextFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ContextOptions { get; }
Visual Basic
Public ReadOnly Property ContextOptions As UInteger
    Get
Visual C++
public:
property unsigned int ContextOptions {
    unsigned int get ();
}

See Also

CommandList Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComparisonFunction Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComparisonFunction Enumeration
See Also Send Feedback
Comparison options.

(Also see DirectX SDK: D3D11_COMPARISON_FUNC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ComparisonFunction
Visual Basic
Public Enumeration ComparisonFunction
Visual C++
public enum class ComparisonFunction

Members

Member name | Description
Always |
GreaterEqual |
NotEqual |
Greater |
LessEqual |
Equal |
Less |
Never |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComputeShader Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShader Class
Members See Also Send Feedback
A compute-shader class manages an executable program (a compute shader) that controls the compute-shader stage.

(Also see DirectX SDK: ID3D11ComputeShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ComputeShader : DeviceChild
Visual Basic
Public Class ComputeShader _
    Inherits DeviceChild
Visual C++
public ref class ComputeShader : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ComputeShader

See Also

ComputeShader Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComputeShader Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShader Members
ComputeShader Class Properties See Also Send Feedback

The ComputeShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ComputeShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComputeShader Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShader Properties
ComputeShader Class See Also Send Feedback

The ComputeShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ComputeShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComputeShaderPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage Class
Members See Also Send Feedback
Compute Shader pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ComputeShaderPipelineStage : PipelineStage
Visual Basic
Public Class ComputeShaderPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class ComputeShaderPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ComputeShaderPipelineStage

See Also

ComputeShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComputeShaderPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage Members
ComputeShaderPipelineStage Class Constructors Methods Properties See Also Send Feedback

The ComputeShaderPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | ComputeShaderPipelineStage |

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the compute-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::CSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the compute-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::CSGetSamplers)
Public method | GetShaderAndClasses | Get the compute shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::CSGetShader)
Public method | GetShaderResources | Get the compute-shader resources. (Also see DirectX SDK: ID3D11DeviceContext::CSGetShaderResources)
Public method | GetUnorderedAccessViews | Gets an array of views for an unordered resource. (Also see DirectX SDK: ID3D11DeviceContext::CSGetUnorderedAccessViews)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(ComputeShader>)>>)) |
Public method | SetShader(ComputeShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |
Public method | SetUnorderedAccessViews |

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Gets or sets the compute shader currently set on the device. (See ComputeShader). (Also see DirectX SDK: ID3D11DeviceContext::CSGetShader, ID3D11DeviceContext::CSSetShader)

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComputeShaderPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage Constructor
ComputeShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected ComputeShaderPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
ComputeShaderPipelineStage()

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComputeShaderPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage Methods
ComputeShaderPipelineStage Class See Also Send Feedback

The ComputeShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the compute-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::CSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the compute-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::CSGetSamplers)
Public method | GetShaderAndClasses | Get the compute shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::CSGetShader)
Public method | GetShaderResources | Get the compute-shader resources. (Also see DirectX SDK: ID3D11DeviceContext::CSGetShaderResources)
Public method | GetUnorderedAccessViews | Gets an array of views for an unordered resource. (Also see DirectX SDK: ID3D11DeviceContext::CSGetUnorderedAccessViews)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(ComputeShader>)>>)) |
Public method | SetShader(ComputeShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |
Public method | SetUnorderedAccessViews |

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..GetConstantBuffers Method
ComputeShaderPipelineStage Class See Also Send Feedback
Get the constant buffers used by the compute-shader stage.

(Also see DirectX SDK: ID3D11DeviceContext::CSGetConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetConstantBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetConstantBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetConstantBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin retrieving constant buffers from (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - 1).
bufferCount
Type: System..::..UInt32
Number of buffers to retrieve (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - startSlot).

Return Value

A collection of constant buffer objects (see D3DBuffer) to be returned by the method.

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


GetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..GetSamplers Method
ComputeShaderPipelineStage Class See Also Send Feedback
Get an array of sampler state objects from the compute-shader stage.

(Also see DirectX SDK: ID3D11DeviceContext::CSGetSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<SamplerState> GetSamplers(
    uint startSlot,
    uint samplerCount
)
Visual Basic
Public Function GetSamplers ( _
    startSlot As UInteger, _
    samplerCount As UInteger _
) As ReadOnlyCollection(Of SamplerState)
Visual C++
public:
ReadOnlyCollection<SamplerState^>^ GetSamplers(
    unsigned int startSlot,
    unsigned int samplerCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into a zero-based array to begin getting samplers from (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - 1).
samplerCount
Type: System..::..UInt32
Number of samplers to get from a device context. Each pipeline stage has a total of 16 sampler slots available (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - startSlot).

Return Value

A collection of sampler-state objects (see SamplerState).

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerState


GetShaderAndClasses Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..GetShaderAndClasses Method
ComputeShaderPipelineStage Class See Also Send Feedback
Get the compute shader currently set on the device.

(Also see DirectX SDK: ID3D11DeviceContext::CSGetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderAndClasses<ComputeShader> GetShaderAndClasses(
    uint classInstanceCount
)
Visual Basic
Public Function GetShaderAndClasses ( _
    classInstanceCount As UInteger _
) As ShaderAndClasses(Of ComputeShader)
Visual C++
public:
ShaderAndClasses<ComputeShader^> GetShaderAndClasses(
    unsigned int classInstanceCount
)

Parameters

classInstanceCount
Type: System..::..UInt32
The number of class-instances to retrieve.

Return Value

A ComputeShader object and its classes (see ComputeShader, ShaderAndClasses<(Of <(<'T>)>)>) , .

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ComputeShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses<(Of <(<'T>)>)>


GetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..GetShaderResources Method
ComputeShaderPipelineStage Class See Also Send Feedback
Get the compute-shader resources.

(Also see DirectX SDK: ID3D11DeviceContext::CSGetShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetShaderResources(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetShaderResources ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetShaderResources(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin getting shader resources from (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - 1).
viewCount
Type: System..::..UInt32
The number of resources to get from the device. Up to a maximum of 128 slots are available for shader resources (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - startSlot).

Return Value

A collection of shader resource view objects to be returned by the device.

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetUnorderedAccessViews Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..GetUnorderedAccessViews Method
ComputeShaderPipelineStage Class See Also Send Feedback
Gets an array of views for an unordered resource.

(Also see DirectX SDK: ID3D11DeviceContext::CSGetUnorderedAccessViews)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<UnorderedAccessView> GetUnorderedAccessViews(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetUnorderedAccessViews ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of UnorderedAccessView)
Visual C++
public:
ReadOnlyCollection<UnorderedAccessView^>^ GetUnorderedAccessViews(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index of the first element in the zero-based array to return (ranges from 0 to D3D11_PS_CS_UAV_REGISTER_COUNT - 1).
viewCount
Type: System..::..UInt32
Number of views to get (ranges from 0 to D3D11_PS_CS_UAV_REGISTER_COUNT - startSlot).

Return Value

A collection of Unorderd Access Views (see UnorderedAccessView) to get.

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..UnorderedAccessView


SetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..SetConstantBuffers Method
ComputeShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetConstantBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> constantBuffers
)
Visual Basic
Public Sub SetConstantBuffers ( _
    startSlot As UInteger, _
    constantBuffers As IEnumerable(Of D3DBuffer) _
)
Visual C++
public:
void SetConstantBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ constantBuffers
)

Parameters

startSlot
Type: System..::..UInt32
constantBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..SetSamplers Method
ComputeShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSamplers(
    uint startSlot,
    IEnumerable<SamplerState> samplers
)
Visual Basic
Public Sub SetSamplers ( _
    startSlot As UInteger, _
    samplers As IEnumerable(Of SamplerState) _
)
Visual C++
public:
void SetSamplers(
    unsigned int startSlot,
    IEnumerable<SamplerState^>^ samplers
)

Parameters

startSlot
Type: System..::..UInt32
samplers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SamplerState >)>)>

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..SetShader Method
ComputeShaderPipelineStage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetShader(ShaderAndClasses<(Of <<'(ComputeShader>)>>)) |
Public method | SetShader(ComputeShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |

See Also

ComputeShaderPipelineStage Class
ComputeShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (ShaderAndClasses(ComputeShader))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..SetShader Method (ShaderAndClasses<(Of <(<'ComputeShader>)>)>)
ComputeShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    ShaderAndClasses<ComputeShader> shaderAndClasses
)
Visual Basic
Public Sub SetShader ( _
    shaderAndClasses As ShaderAndClasses(Of ComputeShader) _
)
Visual C++
public:
void SetShader(
    ShaderAndClasses<ComputeShader^> shaderAndClasses
)

Parameters

shaderAndClasses
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses <(Of <(<' ComputeShader >)>)>

See Also

ComputeShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (ComputeShader, IEnumerable(ClassInstance))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..SetShader Method (ComputeShader, IEnumerable<(Of <(<'ClassInstance>)>)>)
ComputeShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    ComputeShader computeShader,
    IEnumerable<ClassInstance> classInstances
)
Visual Basic
Public Sub SetShader ( _
    computeShader As ComputeShader, _
    classInstances As IEnumerable(Of ClassInstance) _
)
Visual C++
public:
void SetShader(
    ComputeShader^ computeShader,
    IEnumerable<ClassInstance^>^ classInstances
)

Parameters

computeShader
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ComputeShader
classInstances
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ClassInstance >)>)>

See Also

ComputeShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..SetShaderResources Method
ComputeShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShaderResources(
    uint startSlot,
    IEnumerable<ShaderResourceView> shaderResourceViews
)
Visual Basic
Public Sub SetShaderResources ( _
    startSlot As UInteger, _
    shaderResourceViews As IEnumerable(Of ShaderResourceView) _
)
Visual C++
public:
void SetShaderResources(
    unsigned int startSlot,
    IEnumerable<ShaderResourceView^>^ shaderResourceViews
)

Parameters

startSlot
Type: System..::..UInt32
shaderResourceViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetUnorderedAccessViews Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..SetUnorderedAccessViews Method
ComputeShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetUnorderedAccessViews(
    uint startSlot,
    IEnumerable<UnorderedAccessView> unorderedAccessViews,
    uint[] initialCounts
)
Visual Basic
Public Sub SetUnorderedAccessViews ( _
    startSlot As UInteger, _
    unorderedAccessViews As IEnumerable(Of UnorderedAccessView), _
    initialCounts As UInteger() _
)
Visual C++
public:
void SetUnorderedAccessViews(
    unsigned int startSlot,
    IEnumerable<UnorderedAccessView^>^ unorderedAccessViews,
    array<unsigned int>^ initialCounts
)

Parameters

startSlot
Type: System..::..UInt32
unorderedAccessViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' UnorderedAccessView >)>)>
initialCounts
Type: array< System..::..UInt32 >[]()[][]

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComputeShaderPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage Properties
ComputeShaderPipelineStage Class See Also Send Feedback

The ComputeShaderPipelineStage type exposes the following members.

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Gets or sets the compute shader currently set on the device. (See ComputeShader). (Also see DirectX SDK: ID3D11DeviceContext::CSGetShader, ID3D11DeviceContext::CSSetShader)

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ComputeShaderPipelineStage..::..Shader Property
ComputeShaderPipelineStage Class See Also Send Feedback
Gets or sets the compute shader currently set on the device. (See ComputeShader).

(Also see DirectX SDK: ID3D11DeviceContext::CSGetShader, ID3D11DeviceContext::CSSetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComputeShader Shader { get; set; }
Visual Basic
Public Property Shader As ComputeShader
    Get
    Set
Visual C++
public:
property ComputeShader^ Shader {
    ComputeShader^ get ();
    void set (ComputeShader^ value);
}

See Also

ComputeShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ComputeShader


Counter Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Counter Enumeration
See Also Send Feedback
Options for performance counters.

(Also see DirectX SDK: D3D11_COUNTER)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Counter
Visual Basic
Public Enumeration Counter
Visual C++
public enum class Counter

Members

Member name | Description
DeviceDependent0 |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterData Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData Class
Members See Also Send Feedback
This class encapsulates the data returned by the D3DDevice.CheckCounter method.

(Also see DirectX SDK: ID3D11Device.CheckCounter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class CounterData
Visual Basic
Public Class CounterData
Visual C++
public ref class CounterData

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterData

See Also

CounterData Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterData Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData Members
CounterData Class Properties See Also Send Feedback

The CounterData type exposes the following members.

Properties

 | Name | Description
Public property | ActiveCounterCount |
Public property | CounterType |
Public property | Description |
Public property | Name |
Public property | Units |

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterData Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData Properties
CounterData Class See Also Send Feedback

The CounterData type exposes the following members.

Properties

 | Name | Description
Public property | ActiveCounterCount |
Public property | CounterType |
Public property | Description |
Public property | Name |
Public property | Units |

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ActiveCounterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..ActiveCounterCount Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int ActiveCounterCount { get; }
Visual Basic
Public ReadOnly Property ActiveCounterCount As Integer
    Get
Visual C++
public:
property int ActiveCounterCount {
    int get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..CounterType Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CounterType CounterType { get; }
Visual Basic
Public ReadOnly Property CounterType As CounterType
    Get
Visual C++
public:
property CounterType CounterType {
    CounterType get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..Description Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Name Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..Name Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Units Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterData..::..Units Property
CounterData Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Units { get; }
Visual Basic
Public ReadOnly Property Units As String
    Get
Visual C++
public:
property String^ Units {
    String^ get ();
}

See Also

CounterData Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Structure
Members See Also Send Feedback
Describes a counter.

(Also see DirectX SDK: D3D11_COUNTER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct CounterDescription
Visual Basic
Public Structure CounterDescription
Visual C++
public value class CounterDescription

See Also

CounterDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Members
CounterDescription Structure Methods Operators Properties See Also Send Feedback

The CounterDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Counter | Type of counter (see Counter). (Also see DirectX SDK: D3D11_COUNTER_DESC.Counter)
Public property | ReservedOptions | Reserved. (Also see DirectX SDK: D3D11_COUNTER_DESC.MiscFlags)

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Methods
CounterDescription Structure See Also Send Feedback

The CounterDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..Equals Method
CounterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..GetHashCode Method
CounterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Operators
CounterDescription Structure See Also Send Feedback

The CounterDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..Equality Operator
CounterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    CounterDescription counterDescription1,
    CounterDescription counterDescription2
)
Visual Basic
Public Shared Operator = ( _
    counterDescription1 As CounterDescription, _
    counterDescription2 As CounterDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    CounterDescription counterDescription1,
    CounterDescription counterDescription2
)

Parameters

counterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterDescription
counterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterDescription

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..Inequality Operator
CounterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    CounterDescription counterDescription1,
    CounterDescription counterDescription2
)
Visual Basic
Public Shared Operator <> ( _
    counterDescription1 As CounterDescription, _
    counterDescription2 As CounterDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    CounterDescription counterDescription1,
    CounterDescription counterDescription2
)

Parameters

counterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterDescription
counterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterDescription

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription Properties
CounterDescription Structure See Also Send Feedback

The CounterDescription type exposes the following members.

Properties

 | Name | Description
Public property | Counter | Type of counter (see Counter). (Also see DirectX SDK: D3D11_COUNTER_DESC.Counter)
Public property | ReservedOptions | Reserved. (Also see DirectX SDK: D3D11_COUNTER_DESC.MiscFlags)

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Counter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..Counter Property
CounterDescription Structure See Also Send Feedback
Type of counter (see Counter).

(Also see DirectX SDK: D3D11_COUNTER_DESC.Counter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Counter Counter { get; set; }
Visual Basic
Public Property Counter As Counter
    Get
    Set
Visual C++
public:
property Counter Counter {
    Counter get ();
    void set (Counter value);
}

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Counter


ReservedOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterDescription..::..ReservedOptions Property
CounterDescription Structure See Also Send Feedback
Reserved.

(Also see DirectX SDK: D3D11_COUNTER_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ReservedOptions { get; set; }
Visual Basic
Public Property ReservedOptions As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ReservedOptions {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

CounterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterInformation Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Structure
Members See Also Send Feedback
Information about the video card's performance counter capabilities.

(Also see DirectX SDK: D3D11_COUNTER_INFO)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct CounterInformation
Visual Basic
Public Structure CounterInformation
Visual C++
public value class CounterInformation

See Also

CounterInformation Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterInformation Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Members
CounterInformation Structure Methods Operators Properties See Also Send Feedback

The CounterInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | DetectableParallelUnitCount | Number of detectable parallel units that the counter is able to discern. Values are 1 ~ 4. Use DetectableParallelUnitCount to interpret the values of the VERTEX_PROCESSING, GEOMETRY_PROCESSING, PIXEL_PROCESSING, and OTHER_GPU_PROCESSING counters. (Also see DirectX SDK: D3D11_COUNTER_INFO.NumDetectableParallelUnits)
Public property | LastDeviceDependentCounter | Largest device-dependent counter ID that the device supports. If none are supported, this value will be 0. Otherwise it will be greater than or equal to DeviceDependent_0. (Also see DirectX SDK: D3D11_COUNTER_INFO.LastDeviceDependentCounter)
Public property | SimultaneousCounterCount | Number of counters that can be simultaneously supported. (Also see DirectX SDK: D3D11_COUNTER_INFO.NumSimultaneousCounters)

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterInformation Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Methods
CounterInformation Structure See Also Send Feedback

The CounterInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..Equals Method
CounterInformation Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..GetHashCode Method
CounterInformation Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterInformation Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Operators
CounterInformation Structure See Also Send Feedback

The CounterInformation type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..Equality Operator
CounterInformation Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    CounterInformation counterInformation1,
    CounterInformation counterInformation2
)
Visual Basic
Public Shared Operator = ( _
    counterInformation1 As CounterInformation, _
    counterInformation2 As CounterInformation _
) As Boolean
Visual C++
public:
static bool operator ==(
    CounterInformation counterInformation1,
    CounterInformation counterInformation2
)

Parameters

counterInformation1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterInformation
counterInformation2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterInformation

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..Inequality Operator
CounterInformation Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    CounterInformation counterInformation1,
    CounterInformation counterInformation2
)
Visual Basic
Public Shared Operator <> ( _
    counterInformation1 As CounterInformation, _
    counterInformation2 As CounterInformation _
) As Boolean
Visual C++
public:
static bool operator !=(
    CounterInformation counterInformation1,
    CounterInformation counterInformation2
)

Parameters

counterInformation1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterInformation
counterInformation2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterInformation

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterInformation Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation Properties
CounterInformation Structure See Also Send Feedback

The CounterInformation type exposes the following members.

Properties

 | Name | Description
Public property | DetectableParallelUnitCount | Number of detectable parallel units that the counter is able to discern. Values are 1 ~ 4. Use DetectableParallelUnitCount to interpret the values of the VERTEX_PROCESSING, GEOMETRY_PROCESSING, PIXEL_PROCESSING, and OTHER_GPU_PROCESSING counters. (Also see DirectX SDK: D3D11_COUNTER_INFO.NumDetectableParallelUnits)
Public property | LastDeviceDependentCounter | Largest device-dependent counter ID that the device supports. If none are supported, this value will be 0. Otherwise it will be greater than or equal to DeviceDependent_0. (Also see DirectX SDK: D3D11_COUNTER_INFO.LastDeviceDependentCounter)
Public property | SimultaneousCounterCount | Number of counters that can be simultaneously supported. (Also see DirectX SDK: D3D11_COUNTER_INFO.NumSimultaneousCounters)

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DetectableParallelUnitCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..DetectableParallelUnitCount Property
CounterInformation Structure See Also Send Feedback
Number of detectable parallel units that the counter is able to discern. Values are 1 ~ 4. Use DetectableParallelUnitCount to interpret the values of the VERTEX_PROCESSING, GEOMETRY_PROCESSING, PIXEL_PROCESSING, and OTHER_GPU_PROCESSING counters.

(Also see DirectX SDK: D3D11_COUNTER_INFO.NumDetectableParallelUnits)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte DetectableParallelUnitCount { get; set; }
Visual Basic
Public Property DetectableParallelUnitCount As Byte
    Get
    Set
Visual C++
public:
property unsigned char DetectableParallelUnitCount {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


LastDeviceDependentCounter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..LastDeviceDependentCounter Property
CounterInformation Structure See Also Send Feedback
Largest device-dependent counter ID that the device supports. If none are supported, this value will be 0. Otherwise it will be greater than or equal to DeviceDependent_0.

(Also see DirectX SDK: D3D11_COUNTER_INFO.LastDeviceDependentCounter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Counter LastDeviceDependentCounter { get; set; }
Visual Basic
Public Property LastDeviceDependentCounter As Counter
    Get
    Set
Visual C++
public:
property Counter LastDeviceDependentCounter {
    Counter get ();
    void set (Counter value);
}

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SimultaneousCounterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterInformation..::..SimultaneousCounterCount Property
CounterInformation Structure See Also Send Feedback
Number of counters that can be simultaneously supported.

(Also see DirectX SDK: D3D11_COUNTER_INFO.NumSimultaneousCounters)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SimultaneousCounterCount { get; set; }
Visual Basic
Public Property SimultaneousCounterCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SimultaneousCounterCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

CounterInformation Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CounterType Enumeration
See Also Send Feedback
Data type of a performance counter.

(Also see DirectX SDK: D3D11_COUNTER_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum CounterType
Visual Basic
Public Enumeration CounterType
Visual C++
public enum class CounterType

Members

Member name | Description
Float32 |
UInt64 |
UInt32 |
UInt16 |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CpuAccessOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CpuAccessOptions Enumeration
See Also Send Feedback
Specifies the types of CPU access allowed for a resource.

(Also see DirectX SDK: D3D11_CPU_ACCESS_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum CpuAccessOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration CpuAccessOptions
Visual C++
[FlagsAttribute]
public enum class CpuAccessOptions

Members

Member name | Description
None |
Read |
Write |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDeviceOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CreateDeviceOptions Enumeration
See Also Send Feedback
Describes parameters that are used to create a device.

(Also see DirectX SDK: D3D11_CREATE_DEVICE_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum CreateDeviceOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration CreateDeviceOptions
Visual C++
[FlagsAttribute]
public enum class CreateDeviceOptions

Members

Member name | Description
SupportBgra |
PreventInternalThreadingOptimizations |
SwitchToRef |
SingleThreaded |
None |
Debug |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CullMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
CullMode Enumeration
See Also Send Feedback
Indicates triangles facing a particular direction are not drawn.

(Also see DirectX SDK: D3D11_CULL_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum CullMode
Visual Basic
Public Enumeration CullMode
Visual C++
public enum class CullMode

Members

Member name | Description
Back |
Front |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DBuffer Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer Class
Members See Also Send Feedback
Allows acccess to a buffer resource, which is unstructured memory. Buffers typically store vertex or index data.

(Also see DirectX SDK: ID3D11Buffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DBuffer : D3DResource
Visual Basic
Public Class D3DBuffer _
    Inherits D3DResource
Visual C++
public ref class D3DBuffer : public D3DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer

See Also

D3DBuffer Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DBuffer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer Members
D3DBuffer Class Properties See Also Send Feedback

The D3DBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a buffer resource (see BufferDescription). (Also see DirectX SDK: ID3D11Buffer::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics.Surface1. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType) (Inherited from D3DResource.)

See Also

D3DBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DBuffer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer Properties
D3DBuffer Class See Also Send Feedback

The D3DBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a buffer resource (see BufferDescription). (Also see DirectX SDK: ID3D11Buffer::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics.Surface1. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType) (Inherited from D3DResource.)

See Also

D3DBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DBuffer..::..Description Property
D3DBuffer Class See Also Send Feedback
Get the properties of a buffer resource (see BufferDescription).

(Also see DirectX SDK: ID3D11Buffer::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BufferDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As BufferDescription
    Get
Visual C++
public:
property BufferDescription Description {
    BufferDescription get ();
}

See Also

D3DBuffer Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferDescription


D3DCounter Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DCounter Class
Members See Also Send Feedback
This class encapsulates methods for measuring GPU performance.

(Also see DirectX SDK: ID3D11Counter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DCounter : Asynchronous
Visual Basic
Public Class D3DCounter _
    Inherits Asynchronous
Visual C++
public ref class D3DCounter : public Asynchronous

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DCounter

See Also

D3DCounter Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DCounter Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DCounter Members
D3DCounter Class Properties See Also Send Feedback

The D3DCounter type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling DeviceContext.GetData. (Also see DirectX SDK: ID3D11Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get the counter description. (Also see DirectX SDK: ID3D11Counter::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D3DCounter Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DCounter Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DCounter Properties
D3DCounter Class See Also Send Feedback

The D3DCounter type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling DeviceContext.GetData. (Also see DirectX SDK: ID3D11Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get the counter description. (Also see DirectX SDK: ID3D11Counter::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D3DCounter Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DCounter..::..Description Property
D3DCounter Class See Also Send Feedback
Get the counter description.

(Also see DirectX SDK: ID3D11Counter::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CounterDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As CounterDescription
    Get
Visual C++
public:
property CounterDescription Description {
    CounterDescription get ();
}

See Also

D3DCounter Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DDebug Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug Class
Members See Also Send Feedback
A debug interface controls debug settings, validates pipeline state and can only be used if the debug layer is turned on.

(Also see DirectX SDK: ID3D11Debug)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DDebug : DirectUnknown
Visual Basic
Public Class D3DDebug _
    Inherits DirectUnknown
Visual C++
public ref class D3DDebug : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DDebug

See Also

D3DDebug Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DDebug Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug Members
D3DDebug Class Methods Properties See Also Send Feedback

The D3DDebug type exposes the following members.

Methods

 | Name | Description
Public method | ValidateContext | Check to see if the pipeline state is valid. (Also see DirectX SDK: ID3D11Debug::ValidateContext)

Properties

 | Name | Description
Public property | FeatureMask | Gets or sets a bitfield of flags that indicates which debug features are on or off. (Also see DirectX SDK: ID3D11Debug::GetFeatureMask)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PresentPerRenderOperationDelay | Gets or sets the number of milliseconds to sleep after SwapChain.Present is called. (Also see DirectX SDK: ID3D11Debug::GetPresentPerRenderOpDelay)
Public property | RuntimeSwapChain | Get or set the swap chain that the runtime will use for automatically calling SwapChain.Present. (Also see DirectX SDK: ID3D11Debug::GetSwapChain)

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DDebug Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug Methods
D3DDebug Class See Also Send Feedback

The D3DDebug type exposes the following members.

Methods

 | Name | Description
Public method | ValidateContext | Check to see if the pipeline state is valid. (Also see DirectX SDK: ID3D11Debug::ValidateContext)

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ValidateContext Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug..::..ValidateContext Method
D3DDebug Class See Also Send Feedback
Check to see if the pipeline state is valid.

(Also see DirectX SDK: ID3D11Debug::ValidateContext)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ValidateContext(
    DeviceContext context
)
Visual Basic
Public Sub ValidateContext ( _
    context As DeviceContext _
)
Visual C++
public:
void ValidateContext(
    DeviceContext^ context
)

Parameters

context
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceContext
The DeviceContext, that represents a device context.

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DDebug Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug Properties
D3DDebug Class See Also Send Feedback

The D3DDebug type exposes the following members.

Properties

 | Name | Description
Public property | FeatureMask | Gets or sets a bitfield of flags that indicates which debug features are on or off. (Also see DirectX SDK: ID3D11Debug::GetFeatureMask)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PresentPerRenderOperationDelay | Gets or sets the number of milliseconds to sleep after SwapChain.Present is called. (Also see DirectX SDK: ID3D11Debug::GetPresentPerRenderOpDelay)
Public property | RuntimeSwapChain | Get or set the swap chain that the runtime will use for automatically calling SwapChain.Present. (Also see DirectX SDK: ID3D11Debug::GetSwapChain)

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug..::..FeatureMask Property
D3DDebug Class See Also Send Feedback
Gets or sets a bitfield of flags that indicates which debug features are on or off.

(Also see DirectX SDK: ID3D11Debug::GetFeatureMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DebugFeatures FeatureMask { get; set; }
Visual Basic
Public Property FeatureMask As DebugFeatures
    Get
    Set
Visual C++
public:
property DebugFeatures FeatureMask {
    DebugFeatures get ();
    void set (DebugFeatures value);
}

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PresentPerRenderOperationDelay Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug..::..PresentPerRenderOperationDelay Property
D3DDebug Class See Also Send Feedback
Gets or sets the number of milliseconds to sleep after SwapChain.Present is called.

(Also see DirectX SDK: ID3D11Debug::GetPresentPerRenderOpDelay)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint PresentPerRenderOperationDelay { get; set; }
Visual Basic
Public Property PresentPerRenderOperationDelay As UInteger
    Get
    Set
Visual C++
public:
property unsigned int PresentPerRenderOperationDelay {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RuntimeSwapChain Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDebug..::..RuntimeSwapChain Property
D3DDebug Class See Also Send Feedback
Get or set the swap chain that the runtime will use for automatically calling SwapChain.Present.

(Also see DirectX SDK: ID3D11Debug::GetSwapChain)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwapChain RuntimeSwapChain { get; set; }
Visual Basic
Public Property RuntimeSwapChain As SwapChain
    Get
    Set
Visual C++
public:
property SwapChain^ RuntimeSwapChain {
    SwapChain^ get ();
    void set (SwapChain^ value);
}

See Also

D3DDebug Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DDevice Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice Class
Members See Also Send Feedback
The device interface represents a virtual Direct3D 11 adapter; it is used to perform rendering and create resources.

To create a D3DDevice instance, use one of the static factory method overloads: CreateDevice() or CreateDeviceAndSwapChain().

(Also see DirectX SDK: ID3D11Device)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DDevice : DirectUnknown
Visual Basic
Public Class D3DDevice _
    Inherits DirectUnknown
Visual C++
public ref class D3DDevice : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DDevice

See Also

D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DDevice Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice Members
D3DDevice Class Methods Properties See Also Send Feedback

The D3DDevice type exposes the following members.

Methods

 | Name | Description
Public method | CreateBlendState | Create a blend-state object that encapsules blend state for the output-merger stage. (Also see DirectX SDK: ID3D11Device::CreateBlendState)
Public method | CreateBuffer(BufferDescription) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). This method does not include initialization data. Use CreateBuffer(BufferDescription, SubresourceData) if you need to include initialization data. (Also see DirectX SDK: ID3D11Device::CreateBuffer)
Public method | CreateBuffer(BufferDescription, array<SubresourceData>[]()[][]) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). (Also see DirectX SDK: ID3D11Device::CreateBuffer)
Public method | CreateClassLinkage | TBD (Also see DirectX SDK: ID3D11Device::CreateClassLinkage)
Public method | CreateComputeShader(Stream) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateComputeShader(IntPtr, UInt32) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateComputeShader(Stream, ClassLinkage) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateComputeShader(IntPtr, UInt32, ClassLinkage) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateCounter | Create a counter object for measuring GPU performance. (Also see DirectX SDK: ID3D11Device::CreateCounter)
Public method | CreateDeferredContext | Creates a deferred context for play back of command lists. (Also see DirectX SDK: ID3D11Device::CreateDeferredContext)
Public method | CreateDepthStencilState | Create a depth-stencil state object that encapsulates depth-stencil test information for the output-merger stage. (Also see DirectX SDK: ID3D11Device::CreateDepthStencilState)
Public method | CreateDepthStencilView(D3DResource) | Create a depth-stencil view for accessing resource data that accesses mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D11Device::CreateDepthStencilView)
Public method | CreateDepthStencilView(D3DResource, DepthStencilViewDescription) | Create a depth-stencil view for accessing resource data. (Also see DirectX SDK: ID3D11Device::CreateDepthStencilView)
 | CreateDevice()()()() | Create a Direct3D 11.0 device using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D11CreateDevice() function)
 | CreateDevice(Adapter, DriverType, String, CreateDeviceOptions, array<FeatureLevel>[]()[][]) | Create a Direct3D 11.0 device. (Also see DirectX SDK: D3D11CreateDevice() function)
 | CreateDeviceAndSwapChain(IntPtr) | Create a Direct3D 11.0 device and a swap chain using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D11CreateDeviceAndSwapChain() function)
 | CreateDeviceAndSwapChain(Adapter, DriverType, String, CreateDeviceOptions, array<FeatureLevel>[]()[][], SwapChainDescription) | Create a Direct3D 11.0 device and a swap chain. (Also see DirectX SDK: D3D11CreateDeviceAndSwapChain() function)
Public method | CreateDomainShader(Stream) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateDomainShader(IntPtr, UInt32) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateDomainShader(Stream, ClassLinkage) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateDomainShader(IntPtr, UInt32, ClassLinkage) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateGeometryShader(Stream) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShader(IntPtr, UInt32) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShader(Stream, ClassLinkage) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShader(IntPtr, UInt32, ClassLinkage) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32) |
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32) |
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32, ClassLinkage) |
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32, ClassLinkage) |
Public method | CreateHullShader(Stream) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateHullShader(IntPtr, UInt32) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateHullShader(Stream, ClassLinkage) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateHullShader(IntPtr, UInt32, ClassLinkage) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), Stream) |
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), IntPtr, UInt32) |
Public method | CreatePixelShader(Stream) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePixelShader(IntPtr, UInt32) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePixelShader(Stream, ClassLinkage) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePixelShader(IntPtr, UInt32, ClassLinkage) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePredicate | Creates a predicate. (Also see DirectX SDK: ID3D11Device::CreatePredicate)
Public method | CreateQuery | This class encapsulates methods for querying information from the GPU. (Also see DirectX SDK: ID3D11Device::CreateQuery)
Public method | CreateRasterizerState | Create a rasterizer state object that tells the rasterizer stage how to behave. (Also see DirectX SDK: ID3D11Device::CreateRasterizerState)
Public method | CreateRenderTargetView(D3DResource) | Create a render-target view for accessing resource data in mipmap level 0. (Also see DirectX SDK: ID3D11Device::CreateRenderTargetView)
Public method | CreateRenderTargetView(D3DResource, RenderTargetViewDescription) | Create a render-target view for accessing resource data. (Also see DirectX SDK: ID3D11Device::CreateRenderTargetView)
Public method | CreateSamplerState | Create a sampler-state object that encapsulates sampling information for a texture. (Also see DirectX SDK: ID3D11Device::CreateSamplerState)
Public method | CreateShaderResourceView(D3DResource) | Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D11Device::CreateShaderResourceView)
Public method | CreateShaderResourceView(D3DResource, ShaderResourceViewDescription) | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D11Device::CreateShaderResourceView)
Public method | CreateTexture1D(Texture1DDescription) | Create an array of 1D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture1D)
Public method | CreateTexture1D(Texture1DDescription, array<SubresourceData>[]()[][]) | Create an array of 1D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture1D)
Public method | CreateTexture2D(Texture2DDescription) | Create an array of 2D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture2D)
Public method | CreateTexture2D(Texture2DDescription, array<SubresourceData>[]()[][]) | Create an array of 2D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture2D)
Public method | CreateTexture3D(Texture3DDescription) | Create a single 3D texture. (Also see DirectX SDK: ID3D11Device::CreateTexture3D)
Public method | CreateTexture3D(Texture3DDescription, array<SubresourceData>[]()[][]) | Create a single 3D texture. (Also see DirectX SDK: ID3D11Device::CreateTexture3D)
Public method | CreateUnorderedAccessView(D3DResource) | Create a view for accessing an unordered access resource. The view created accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D11Device::CreateUnorderedAccessView)
Public method | CreateUnorderedAccessView(D3DResource, UnorderedAccessViewDescription) | Create a view for accessing an unordered access resource. (Also see DirectX SDK: ID3D11Device::CreateUnorderedAccessView)
Public method | CreateVertexShader(Stream) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | CreateVertexShader(IntPtr, UInt32) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | CreateVertexShader(Stream, ClassLinkage) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | CreateVertexShader(IntPtr, UInt32, ClassLinkage) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | GetCounterData | Get the type, name, units of measure, and a description of an existing counter. (Also see DirectX SDK: ID3D11Device::CheckCounter)
Public method | GetFeatureDataFormatSupport | Gets information about the format features that are supported by the current graphics driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)
Public method | GetFeatureDataFormatSupport2 | Gets information about the extended format features that are supported by the current graphics driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)
Public method | GetFormatSupport | Get the support of a given format on the installed video device. (Also see DirectX SDK: ID3D11Device::CheckFormatSupport)
Public method | GetMultisampleQualityLevels | Get the number of quality levels available during multisampling. (Also see DirectX SDK: ID3D11Device::CheckMultisampleQualityLevels)
Public method | OpenSharedResource<(Of <<'(T>)>>) | Give a device access to a shared resource created on a different device. (Also see DirectX SDK: ID3D11Device::OpenSharedResource)

Properties

 | Name | Description
Public property | CounterInformation | Get a counter's information. (Also see DirectX SDK: ID3D11Device::CheckCounterInfo)
Public property | CreateDeviceOptions | Get the flags used during the call to create the device. (Also see DirectX SDK: ID3D11Device::GetCreationFlags)
Public property | Debug |
Public property | DeviceFeatureLevel | Gets the feature level of the hardware device. (Also see DirectX SDK: ID3D10Device1::GetFeatureLevel)
Public property | DeviceRemovedReason | Get the reason why the device was removed. (Also see DirectX SDK: ID3D11Device::GetDeviceRemovedReason)
Public property | ExceptionMode | Gets or Sets the exception-mode flags. (Also see DirectX SDK: ID3D11Device::GetExceptionMode, ID3D11Device::SetExceptionMode)
Public property | GraphicsDevice | Queries this device as a Graphics Device object.
Public property | GraphicsDevice1 |
Public property | ImmediateContext | Gets an immediate context which can record command lists. (Also see DirectX SDK: ID3D11Device::GetImmediateContext)
Public property | InfoQueue | Gets an information queue object that can retrieve, store and filter debug messages.
Public property | IsComputeShaderWithRawAndStructuredBuffersSupported | Gets whether or not compute shaders, along with raw and structured buffers, are supported by the driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)
Public property | IsDoubleSupported | Gets information about whether double-precision floating point is supported by the current graphics driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SwapChain |
Public property | SwitchToRef | Gets a switch-to-reference object that enables an application to switch between a hardware and software device.
Public property | ThreadingSupport | Gets information about the threading features that are supported by the current graphics driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DDevice Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice Methods
D3DDevice Class See Also Send Feedback

The D3DDevice type exposes the following members.

Methods

 | Name | Description
Public method | CreateBlendState | Create a blend-state object that encapsules blend state for the output-merger stage. (Also see DirectX SDK: ID3D11Device::CreateBlendState)
Public method | CreateBuffer(BufferDescription) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). This method does not include initialization data. Use CreateBuffer(BufferDescription, SubresourceData) if you need to include initialization data. (Also see DirectX SDK: ID3D11Device::CreateBuffer)
Public method | CreateBuffer(BufferDescription, array<SubresourceData>[]()[][]) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). (Also see DirectX SDK: ID3D11Device::CreateBuffer)
Public method | CreateClassLinkage | TBD (Also see DirectX SDK: ID3D11Device::CreateClassLinkage)
Public method | CreateComputeShader(Stream) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateComputeShader(IntPtr, UInt32) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateComputeShader(Stream, ClassLinkage) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateComputeShader(IntPtr, UInt32, ClassLinkage) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateCounter | Create a counter object for measuring GPU performance. (Also see DirectX SDK: ID3D11Device::CreateCounter)
Public method | CreateDeferredContext | Creates a deferred context for play back of command lists. (Also see DirectX SDK: ID3D11Device::CreateDeferredContext)
Public method | CreateDepthStencilState | Create a depth-stencil state object that encapsulates depth-stencil test information for the output-merger stage. (Also see DirectX SDK: ID3D11Device::CreateDepthStencilState)
Public method | CreateDepthStencilView(D3DResource) | Create a depth-stencil view for accessing resource data that accesses mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D11Device::CreateDepthStencilView)
Public method | CreateDepthStencilView(D3DResource, DepthStencilViewDescription) | Create a depth-stencil view for accessing resource data. (Also see DirectX SDK: ID3D11Device::CreateDepthStencilView)
 | CreateDevice()()()() | Create a Direct3D 11.0 device using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D11CreateDevice() function)
 | CreateDevice(Adapter, DriverType, String, CreateDeviceOptions, array<FeatureLevel>[]()[][]) | Create a Direct3D 11.0 device. (Also see DirectX SDK: D3D11CreateDevice() function)
 | CreateDeviceAndSwapChain(IntPtr) | Create a Direct3D 11.0 device and a swap chain using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D11CreateDeviceAndSwapChain() function)
 | CreateDeviceAndSwapChain(Adapter, DriverType, String, CreateDeviceOptions, array<FeatureLevel>[]()[][], SwapChainDescription) | Create a Direct3D 11.0 device and a swap chain. (Also see DirectX SDK: D3D11CreateDeviceAndSwapChain() function)
Public method | CreateDomainShader(Stream) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateDomainShader(IntPtr, UInt32) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateDomainShader(Stream, ClassLinkage) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateDomainShader(IntPtr, UInt32, ClassLinkage) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateGeometryShader(Stream) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShader(IntPtr, UInt32) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShader(Stream, ClassLinkage) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShader(IntPtr, UInt32, ClassLinkage) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32) |
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32) |
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32, ClassLinkage) |
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32, ClassLinkage) |
Public method | CreateHullShader(Stream) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateHullShader(IntPtr, UInt32) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateHullShader(Stream, ClassLinkage) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateHullShader(IntPtr, UInt32, ClassLinkage) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), Stream) |
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), IntPtr, UInt32) |
Public method | CreatePixelShader(Stream) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePixelShader(IntPtr, UInt32) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePixelShader(Stream, ClassLinkage) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePixelShader(IntPtr, UInt32, ClassLinkage) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePredicate | Creates a predicate. (Also see DirectX SDK: ID3D11Device::CreatePredicate)
Public method | CreateQuery | This class encapsulates methods for querying information from the GPU. (Also see DirectX SDK: ID3D11Device::CreateQuery)
Public method | CreateRasterizerState | Create a rasterizer state object that tells the rasterizer stage how to behave. (Also see DirectX SDK: ID3D11Device::CreateRasterizerState)
Public method | CreateRenderTargetView(D3DResource) | Create a render-target view for accessing resource data in mipmap level 0. (Also see DirectX SDK: ID3D11Device::CreateRenderTargetView)
Public method | CreateRenderTargetView(D3DResource, RenderTargetViewDescription) | Create a render-target view for accessing resource data. (Also see DirectX SDK: ID3D11Device::CreateRenderTargetView)
Public method | CreateSamplerState | Create a sampler-state object that encapsulates sampling information for a texture. (Also see DirectX SDK: ID3D11Device::CreateSamplerState)
Public method | CreateShaderResourceView(D3DResource) | Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D11Device::CreateShaderResourceView)
Public method | CreateShaderResourceView(D3DResource, ShaderResourceViewDescription) | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D11Device::CreateShaderResourceView)
Public method | CreateTexture1D(Texture1DDescription) | Create an array of 1D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture1D)
Public method | CreateTexture1D(Texture1DDescription, array<SubresourceData>[]()[][]) | Create an array of 1D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture1D)
Public method | CreateTexture2D(Texture2DDescription) | Create an array of 2D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture2D)
Public method | CreateTexture2D(Texture2DDescription, array<SubresourceData>[]()[][]) | Create an array of 2D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture2D)
Public method | CreateTexture3D(Texture3DDescription) | Create a single 3D texture. (Also see DirectX SDK: ID3D11Device::CreateTexture3D)
Public method | CreateTexture3D(Texture3DDescription, array<SubresourceData>[]()[][]) | Create a single 3D texture. (Also see DirectX SDK: ID3D11Device::CreateTexture3D)
Public method | CreateUnorderedAccessView(D3DResource) | Create a view for accessing an unordered access resource. The view created accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D11Device::CreateUnorderedAccessView)
Public method | CreateUnorderedAccessView(D3DResource, UnorderedAccessViewDescription) | Create a view for accessing an unordered access resource. (Also see DirectX SDK: ID3D11Device::CreateUnorderedAccessView)
Public method | CreateVertexShader(Stream) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | CreateVertexShader(IntPtr, UInt32) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | CreateVertexShader(Stream, ClassLinkage) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | CreateVertexShader(IntPtr, UInt32, ClassLinkage) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | GetCounterData | Get the type, name, units of measure, and a description of an existing counter. (Also see DirectX SDK: ID3D11Device::CheckCounter)
Public method | GetFeatureDataFormatSupport | Gets information about the format features that are supported by the current graphics driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)
Public method | GetFeatureDataFormatSupport2 | Gets information about the extended format features that are supported by the current graphics driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)
Public method | GetFormatSupport | Get the support of a given format on the installed video device. (Also see DirectX SDK: ID3D11Device::CheckFormatSupport)
Public method | GetMultisampleQualityLevels | Get the number of quality levels available during multisampling. (Also see DirectX SDK: ID3D11Device::CheckMultisampleQualityLevels)
Public method | OpenSharedResource<(Of <<'(T>)>>) | Give a device access to a shared resource created on a different device. (Also see DirectX SDK: ID3D11Device::OpenSharedResource)

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateBlendState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateBlendState Method
D3DDevice Class See Also Send Feedback
Create a blend-state object that encapsules blend state for the output-merger stage.

(Also see DirectX SDK: ID3D11Device::CreateBlendState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendState CreateBlendState(
    BlendDescription description
)
Visual Basic
Public Function CreateBlendState ( _
    description As BlendDescription _
) As BlendState
Visual C++
public:
BlendState^ CreateBlendState(
    BlendDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BlendDescription
A blend-state description (see BlendDescription).

Return Value

The blend-state object created (see BlendState).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BlendDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BlendState


CreateBuffer Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateBuffer Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateBuffer(BufferDescription) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). This method does not include initialization data. Use CreateBuffer(BufferDescription, SubresourceData) if you need to include initialization data. (Also see DirectX SDK: ID3D11Device::CreateBuffer)
Public method | CreateBuffer(BufferDescription, array<SubresourceData>[]()[][]) | Create a buffer (vertex buffer, index buffer, or shader-constant buffer). (Also see DirectX SDK: ID3D11Device::CreateBuffer)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateBuffer Method (BufferDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateBuffer Method (BufferDescription)
D3DDevice Class See Also Send Feedback
Create a buffer (vertex buffer, index buffer, or shader-constant buffer). This method does not include initialization data. Use CreateBuffer(BufferDescription, SubresourceData) if you need to include initialization data.

(Also see DirectX SDK: ID3D11Device::CreateBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer CreateBuffer(
    BufferDescription description
)
Visual Basic
Public Function CreateBuffer ( _
    description As BufferDescription _
) As D3DBuffer
Visual C++
public:
D3DBuffer^ CreateBuffer(
    BufferDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferDescription
A buffer description (see BufferDescription).

Return Value

The buffer created (see D3DBuffer).

See Also

D3DDevice Class
CreateBuffer Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


CreateBuffer Method (BufferDescription, SubresourceData[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateBuffer Method (BufferDescription, array<SubresourceData>[]()[][])
D3DDevice Class See Also Send Feedback
Create a buffer (vertex buffer, index buffer, or shader-constant buffer).

(Also see DirectX SDK: ID3D11Device::CreateBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer CreateBuffer(
    BufferDescription description,
    params SubresourceData[] initialData
)
Visual Basic
Public Function CreateBuffer ( _
    description As BufferDescription, _
    ParamArray initialData As SubresourceData() _
) As D3DBuffer
Visual C++
public:
D3DBuffer^ CreateBuffer(
    BufferDescription description,
    ... array<SubresourceData>^ initialData
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferDescription
A buffer description (see BufferDescription).
initialData
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SubresourceData >[]()[][]
Initialization data (see SubresourceData); Cannot be emmpty or null if the usage flag is Immutable).

Return Value

The buffer created (see D3DBuffer).

See Also

D3DDevice Class
CreateBuffer Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SubresourceData
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


CreateClassLinkage Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateClassLinkage Method
D3DDevice Class See Also Send Feedback
TBD

(Also see DirectX SDK: ID3D11Device::CreateClassLinkage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ClassLinkage CreateClassLinkage()
Visual Basic
Public Function CreateClassLinkage As ClassLinkage
Visual C++
public:
ClassLinkage^ CreateClassLinkage()

Return Value

A class-linkage object (see ClassLinkage).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage


CreateComputeShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateComputeShader Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateComputeShader(Stream) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateComputeShader(IntPtr, UInt32) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateComputeShader(Stream, ClassLinkage) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)
Public method | CreateComputeShader(IntPtr, UInt32, ClassLinkage) | Create a compute shader. (Also see DirectX SDK: ID3D11Device::CreateComputeShader)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateComputeShader Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateComputeShader Method (Stream)
D3DDevice Class See Also Send Feedback
Create a compute shader.

(Also see DirectX SDK: ID3D11Device::CreateComputeShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComputeShader CreateComputeShader(
    Stream stream
)
Visual Basic
Public Function CreateComputeShader ( _
    stream As Stream _
) As ComputeShader
Visual C++
public:
ComputeShader^ CreateComputeShader(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.

Return Value

A ComputeShader object

See Also

D3DDevice Class
CreateComputeShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateComputeShader Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateComputeShader Method (IntPtr, UInt32)
D3DDevice Class See Also Send Feedback
Create a compute shader.

(Also see DirectX SDK: ID3D11Device::CreateComputeShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComputeShader CreateComputeShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength
)
Visual Basic
Public Function CreateComputeShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger _
) As ComputeShader
Visual C++
public:
ComputeShader^ CreateComputeShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength
)

Parameters

shaderBytecode
Type: System..::..IntPtr
A compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of compiled shader code in bytes.

Return Value

A ComputeShader object

See Also

D3DDevice Class
CreateComputeShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateComputeShader Method (Stream, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateComputeShader Method (Stream, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a compute shader.

(Also see DirectX SDK: ID3D11Device::CreateComputeShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComputeShader CreateComputeShader(
    Stream stream,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateComputeShader ( _
    stream As Stream, _
    classLinkage As ClassLinkage _
) As ComputeShader
Visual C++
public:
ComputeShader^ CreateComputeShader(
    Stream^ stream,
    ClassLinkage^ classLinkage
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A ClassLinkage, which represents class linkage interface; the value can be null.

Return Value

A ComputeShader object

See Also

D3DDevice Class
CreateComputeShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateComputeShader Method (IntPtr, UInt32, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateComputeShader Method (IntPtr, UInt32, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a compute shader.

(Also see DirectX SDK: ID3D11Device::CreateComputeShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComputeShader CreateComputeShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateComputeShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger, _
    classLinkage As ClassLinkage _
) As ComputeShader
Visual C++
public:
ComputeShader^ CreateComputeShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength,
    ClassLinkage^ classLinkage
)

Parameters

shaderBytecode
Type: System..::..IntPtr
A compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of compiled shader code in bytes.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A ClassLinkage, which represents class linkage interface; the value can be null.

Return Value

A ComputeShader object

See Also

D3DDevice Class
CreateComputeShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateCounter Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateCounter Method
D3DDevice Class See Also Send Feedback
Create a counter object for measuring GPU performance.

(Also see DirectX SDK: ID3D11Device::CreateCounter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DCounter CreateCounter(
    CounterDescription description
)
Visual Basic
Public Function CreateCounter ( _
    description As CounterDescription _
) As D3DCounter
Visual C++
public:
D3DCounter^ CreateCounter(
    CounterDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterDescription
A counter description (see CounterDescription).

Return Value

A counter (see D3DCounter).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DCounter


CreateDeferredContext Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDeferredContext Method
D3DDevice Class See Also Send Feedback
Creates a deferred context for play back of command lists.

(Also see DirectX SDK: ID3D11Device::CreateDeferredContext)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DeviceContext CreateDeferredContext(
    uint contextOptions
)
Visual Basic
Public Function CreateDeferredContext ( _
    contextOptions As UInteger _
) As DeviceContext
Visual C++
public:
DeviceContext^ CreateDeferredContext(
    unsigned int contextOptions
)

Parameters

contextOptions
Type: System..::..UInt32
Reserved for future use. Pass 0.

Return Value

A DeviceContext object.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDepthStencilState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDepthStencilState Method
D3DDevice Class See Also Send Feedback
Create a depth-stencil state object that encapsulates depth-stencil test information for the output-merger stage.

(Also see DirectX SDK: ID3D11Device::CreateDepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilState CreateDepthStencilState(
    DepthStencilDescription description
)
Visual Basic
Public Function CreateDepthStencilState ( _
    description As DepthStencilDescription _
) As DepthStencilState
Visual C++
public:
DepthStencilState^ CreateDepthStencilState(
    DepthStencilDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilDescription
A depth-stencil state description (see DepthStencilDescription).

Return Value

A depth-stencil state object created (see DepthStencilState).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilState


CreateDepthStencilView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDepthStencilView Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDepthStencilView(D3DResource) | Create a depth-stencil view for accessing resource data that accesses mipmap level 0 of the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D11Device::CreateDepthStencilView)
Public method | CreateDepthStencilView(D3DResource, DepthStencilViewDescription) | Create a depth-stencil view for accessing resource data. (Also see DirectX SDK: ID3D11Device::CreateDepthStencilView)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDepthStencilView Method (D3DResource)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDepthStencilView Method (D3DResource)
D3DDevice Class See Also Send Feedback
Create a depth-stencil view for accessing resource data that accesses mipmap level 0 of the entire resource (using the format the resource was created with).

(Also see DirectX SDK: ID3D11Device::CreateDepthStencilView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilView CreateDepthStencilView(
    D3DResource resource
)
Visual Basic
Public Function CreateDepthStencilView ( _
    resource As D3DResource _
) As DepthStencilView
Visual C++
public:
DepthStencilView^ CreateDepthStencilView(
    D3DResource^ resource
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The resource that will serve as the depth-stencil surface. This resource must have been created with the DepthStencil flag.

Return Value

A DepthStencilView object.

See Also

D3DDevice Class
CreateDepthStencilView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDepthStencilView Method (D3DResource, DepthStencilViewDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDepthStencilView Method (D3DResource, DepthStencilViewDescription)
D3DDevice Class See Also Send Feedback
Create a depth-stencil view for accessing resource data.

(Also see DirectX SDK: ID3D11Device::CreateDepthStencilView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilView CreateDepthStencilView(
    D3DResource resource,
    DepthStencilViewDescription description
)
Visual Basic
Public Function CreateDepthStencilView ( _
    resource As D3DResource, _
    description As DepthStencilViewDescription _
) As DepthStencilView
Visual C++
public:
DepthStencilView^ CreateDepthStencilView(
    D3DResource^ resource,
    DepthStencilViewDescription description
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The resource that will serve as the depth-stencil surface. This resource must have been created with the DepthStencil flag.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilViewDescription
A depth-stencil-view description (see DepthStencilViewDescription).

Return Value

A DepthStencilView object.

See Also

D3DDevice Class
CreateDepthStencilView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilViewDescription


CreateDevice Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDevice Method
D3DDevice Class See Also Send Feedback

Overload List

Name | Description
CreateDevice()()()() | Create a Direct3D 11.0 device using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D11CreateDevice() function)
CreateDevice(Adapter, DriverType, String, CreateDeviceOptions, array<FeatureLevel>[]()[][]) | Create a Direct3D 11.0 device. (Also see DirectX SDK: D3D11CreateDevice() function)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDevice Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDevice Method
D3DDevice Class See Also Send Feedback
Create a Direct3D 11.0 device using the default hardware adapter and the most common settings.

(Also see DirectX SDK: D3D11CreateDevice() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice CreateDevice()
Visual Basic
Public Shared Function CreateDevice As D3DDevice
Visual C++
public:
static D3DDevice^ CreateDevice()

Return Value

The created Direct3D 11.0 Device

Remarks

If DirectX SDK environment variable is found, and the build is a Debug one, this method will attempt to use CreateDeviceOptions.Debug flag. This should allow using the InfoQueue object.

See Also

D3DDevice Class
CreateDevice Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDevice Method (Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDevice Method (Adapter, DriverType, String, CreateDeviceOptions, array<FeatureLevel>[]()[][])
D3DDevice Class See Also Send Feedback
Create a Direct3D 11.0 device.

(Also see DirectX SDK: D3D11CreateDevice() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice CreateDevice(
    Adapter adapter,
    DriverType driverType,
    string softwareRasterizerLibrary,
    CreateDeviceOptions options,
    FeatureLevel[] featureLevels
)
Visual Basic
Public Shared Function CreateDevice ( _
    adapter As Adapter, _
    driverType As DriverType, _
    softwareRasterizerLibrary As String, _
    options As CreateDeviceOptions, _
    featureLevels As FeatureLevel() _
) As D3DDevice
Visual C++
public:
static D3DDevice^ CreateDevice(
    Adapter^ adapter,
    DriverType driverType,
    String^ softwareRasterizerLibrary,
    CreateDeviceOptions options,
    array<FeatureLevel>^ featureLevels
)

Parameters

adapter
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter
An Adapter object. Can be null.
driverType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DriverType
The type of driver for the device.
softwareRasterizerLibrary
Type: System..::..String
A path for a DLL that implements a software rasterizer. Must be NULL if driverType is non-software.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CreateDeviceOptions
Device creation flags that enable API layers. These flags can be bitwise OR'd together.
featureLevels
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..FeatureLevel >[]()[][]
An array of FeatureLevels, which determine the order of feature levels to attempt to create. If set to null, the following array of feature levels will be used:
CopyC#
{
    FeatureLevel_11_0,
    FeatureLevel_10_1,
    FeatureLevel_10_0,
    FeatureLevel_9_3,
    FeatureLevel_9_2,
    FeatureLevel_9_1,
};

Return Value

The created Direct3D 11.0 Device

Remarks

By default, all Direct3D 11 calls are handled in a thread-safe way. By creating a single-threaded device (using CreateDeviceOptions.SingleThreaded), you disable thread-safe calling.

See Also

D3DDevice Class
CreateDevice Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDeviceAndSwapChain Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDeviceAndSwapChain Method
D3DDevice Class See Also Send Feedback

Overload List

Name | Description
CreateDeviceAndSwapChain(IntPtr) | Create a Direct3D 11.0 device and a swap chain using the default hardware adapter and the most common settings. (Also see DirectX SDK: D3D11CreateDeviceAndSwapChain() function)
CreateDeviceAndSwapChain(Adapter, DriverType, String, CreateDeviceOptions, array<FeatureLevel>[]()[][], SwapChainDescription) | Create a Direct3D 11.0 device and a swap chain. (Also see DirectX SDK: D3D11CreateDeviceAndSwapChain() function)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDeviceAndSwapChain Method (IntPtr)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDeviceAndSwapChain Method (IntPtr)
D3DDevice Class See Also Send Feedback
Create a Direct3D 11.0 device and a swap chain using the default hardware adapter and the most common settings.

(Also see DirectX SDK: D3D11CreateDeviceAndSwapChain() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice CreateDeviceAndSwapChain(
    IntPtr windowHandle
)
Visual Basic
Public Shared Function CreateDeviceAndSwapChain ( _
    windowHandle As IntPtr _
) As D3DDevice
Visual C++
public:
static D3DDevice^ CreateDeviceAndSwapChain(
    IntPtr windowHandle
)

Parameters

windowHandle
Type: System..::..IntPtr
The window handle to the output window.

Return Value

The created Direct3D 11.0 Device

Remarks

If DirectX SDK environment variable is found, and the build is a Debug one, this method will attempt to use CreateDeviceOptions.Debug flag. This should allow using the InfoQueue object. Retrieve the swap chain from the SwapChain property.

See Also

D3DDevice Class
CreateDeviceAndSwapChain Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDeviceAndSwapChain Method (Adapter, DriverType, String, CreateDeviceOptions, FeatureLevel[], SwapChainDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDeviceAndSwapChain Method (Adapter, DriverType, String, CreateDeviceOptions, array<FeatureLevel>[]()[][], SwapChainDescription)
D3DDevice Class See Also Send Feedback
Create a Direct3D 11.0 device and a swap chain.

(Also see DirectX SDK: D3D11CreateDeviceAndSwapChain() function)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static D3DDevice CreateDeviceAndSwapChain(
    Adapter adapter,
    DriverType driverType,
    string softwareRasterizerLibrary,
    CreateDeviceOptions options,
    FeatureLevel[] featureLevels,
    SwapChainDescription swapChainDescription
)
Visual Basic
Public Shared Function CreateDeviceAndSwapChain ( _
    adapter As Adapter, _
    driverType As DriverType, _
    softwareRasterizerLibrary As String, _
    options As CreateDeviceOptions, _
    featureLevels As FeatureLevel(), _
    swapChainDescription As SwapChainDescription _
) As D3DDevice
Visual C++
public:
static D3DDevice^ CreateDeviceAndSwapChain(
    Adapter^ adapter,
    DriverType driverType,
    String^ softwareRasterizerLibrary,
    CreateDeviceOptions options,
    array<FeatureLevel>^ featureLevels,
    SwapChainDescription swapChainDescription
)

Parameters

adapter
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter
An Adapter object. Can be null.
driverType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DriverType
The type of driver for the device.
softwareRasterizerLibrary
Type: System..::..String
A path to the DLL that implements a software rasterizer. Must be NULL if driverType is non-software.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CreateDeviceOptions
Device creation flags that enable API layers. These flags can be bitwise OR'd together.
featureLevels
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..FeatureLevel >[]()[][]
An array of FeatureLevels, which determine the order of feature levels to attempt to create. If set to null, the following array of feature levels will be used:
CopyC#
{
    FeatureLevel_11_0,
    FeatureLevel_10_1,
    FeatureLevel_10_0,
    FeatureLevel_9_3,
    FeatureLevel_9_2,
    FeatureLevel_9_1,
};
swapChainDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChainDescription
Description of the swap chain.

Return Value

The created Direct3D 11.0 Device

Remarks

By default, all Direct3D 11 calls are handled in a thread-safe way. By creating a single-threaded device (using CreateDeviceOptions.SingleThreaded), you disable thread-safe calling. Retrieve the swap chain from the SwapChain property.

See Also

D3DDevice Class
CreateDeviceAndSwapChain Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDomainShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDomainShader Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateDomainShader(Stream) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateDomainShader(IntPtr, UInt32) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateDomainShader(Stream, ClassLinkage) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)
Public method | CreateDomainShader(IntPtr, UInt32, ClassLinkage) | Create a domain shader. (Also see DirectX SDK: ID3D11Device::CreateDomainShader)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDomainShader Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDomainShader Method (Stream)
D3DDevice Class See Also Send Feedback
Create a domain shader.

(Also see DirectX SDK: ID3D11Device::CreateDomainShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DomainShader CreateDomainShader(
    Stream stream
)
Visual Basic
Public Function CreateDomainShader ( _
    stream As Stream _
) As DomainShader
Visual C++
public:
DomainShader^ CreateDomainShader(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.

Return Value

A DomainShader object.

See Also

D3DDevice Class
CreateDomainShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDomainShader Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDomainShader Method (IntPtr, UInt32)
D3DDevice Class See Also Send Feedback
Create a domain shader.

(Also see DirectX SDK: ID3D11Device::CreateDomainShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DomainShader CreateDomainShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength
)
Visual Basic
Public Function CreateDomainShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger _
) As DomainShader
Visual C++
public:
DomainShader^ CreateDomainShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength
)

Parameters

shaderBytecode
Type: System..::..IntPtr
A compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of compiled shader code in bytes.

Return Value

A DomainShader object.

See Also

D3DDevice Class
CreateDomainShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDomainShader Method (Stream, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDomainShader Method (Stream, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a domain shader.

(Also see DirectX SDK: ID3D11Device::CreateDomainShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DomainShader CreateDomainShader(
    Stream stream,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateDomainShader ( _
    stream As Stream, _
    classLinkage As ClassLinkage _
) As DomainShader
Visual C++
public:
DomainShader^ CreateDomainShader(
    Stream^ stream,
    ClassLinkage^ classLinkage
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A class linkage object (see ClassLinkage); the value can be null.

Return Value

A DomainShader object.

See Also

D3DDevice Class
CreateDomainShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage


CreateDomainShader Method (IntPtr, UInt32, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDomainShader Method (IntPtr, UInt32, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a domain shader.

(Also see DirectX SDK: ID3D11Device::CreateDomainShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DomainShader CreateDomainShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateDomainShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger, _
    classLinkage As ClassLinkage _
) As DomainShader
Visual C++
public:
DomainShader^ CreateDomainShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength,
    ClassLinkage^ classLinkage
)

Parameters

shaderBytecode
Type: System..::..IntPtr
A compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of compiled shader code in bytes.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A class linkage object (see ClassLinkage); the value can be null.

Return Value

A DomainShader object.

See Also

D3DDevice Class
CreateDomainShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage


CreateGeometryShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShader Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateGeometryShader(Stream) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShader(IntPtr, UInt32) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShader(Stream, ClassLinkage) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)
Public method | CreateGeometryShader(IntPtr, UInt32, ClassLinkage) | Create a geometry shader. (Also see DirectX SDK: ID3D11Device::CreateGeometryShader)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateGeometryShader Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShader Method (Stream)
D3DDevice Class See Also Send Feedback
Create a geometry shader.

(Also see DirectX SDK: ID3D11Device::CreateGeometryShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShader(
    Stream stream
)
Visual Basic
Public Function CreateGeometryShader ( _
    stream As Stream _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShader(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.

Return Value

A GeometryShader object.

See Also

D3DDevice Class
CreateGeometryShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateGeometryShader Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShader Method (IntPtr, UInt32)
D3DDevice Class See Also Send Feedback
Create a geometry shader.

(Also see DirectX SDK: ID3D11Device::CreateGeometryShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength
)
Visual Basic
Public Function CreateGeometryShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength
)

Parameters

shaderBytecode
Type: System..::..IntPtr
The compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of compiled shader code in bytes.

Return Value

A GeometryShader object.

See Also

D3DDevice Class
CreateGeometryShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateGeometryShader Method (Stream, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShader Method (Stream, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a geometry shader.

(Also see DirectX SDK: ID3D11Device::CreateGeometryShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShader(
    Stream stream,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateGeometryShader ( _
    stream As Stream, _
    classLinkage As ClassLinkage _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShader(
    Stream^ stream,
    ClassLinkage^ classLinkage
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A class linkage object (see ClassLinkage); the value can be null.

Return Value

A GeometryShader object.

See Also

D3DDevice Class
CreateGeometryShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage


CreateGeometryShader Method (IntPtr, UInt32, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShader Method (IntPtr, UInt32, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a geometry shader.

(Also see DirectX SDK: ID3D11Device::CreateGeometryShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateGeometryShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger, _
    classLinkage As ClassLinkage _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength,
    ClassLinkage^ classLinkage
)

Parameters

shaderBytecode
Type: System..::..IntPtr
The compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of compiled shader code in bytes.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A class linkage object (see ClassLinkage); the value can be null.

Return Value

A GeometryShader object.

See Also

D3DDevice Class
CreateGeometryShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage


CreateGeometryShaderWithStreamOutput Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShaderWithStreamOutput Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32) |
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32) |
Public method | CreateGeometryShaderWithStreamOutput(Stream, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32, ClassLinkage) |
Public method | CreateGeometryShaderWithStreamOutput(IntPtr, UInt32, IEnumerable<(Of <<'(StreamOutputDeclarationEntry>)>>), array<UInt32>[]()[][], UInt32, ClassLinkage) |

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateGeometryShaderWithStreamOutput Method (Stream, IEnumerable(StreamOutputDeclarationEntry), UInt32[], UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShaderWithStreamOutput Method (Stream, IEnumerable<(Of <(<'StreamOutputDeclarationEntry>)>)>, array<UInt32>[]()[][], UInt32)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShaderWithStreamOutput(
    Stream shaderStream,
    IEnumerable<StreamOutputDeclarationEntry> streamOutputDeclarations,
    uint[] bufferStrides,
    uint rasterizedStream
)
Visual Basic
Public Function CreateGeometryShaderWithStreamOutput ( _
    shaderStream As Stream, _
    streamOutputDeclarations As IEnumerable(Of StreamOutputDeclarationEntry), _
    bufferStrides As UInteger(), _
    rasterizedStream As UInteger _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShaderWithStreamOutput(
    Stream^ shaderStream,
    IEnumerable<StreamOutputDeclarationEntry>^ streamOutputDeclarations,
    array<unsigned int>^ bufferStrides,
    unsigned int rasterizedStream
)

Parameters

shaderStream
Type: System.IO..::..Stream
streamOutputDeclarations
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' StreamOutputDeclarationEntry >)>)>
bufferStrides
Type: array< System..::..UInt32 >[]()[][]
rasterizedStream
Type: System..::..UInt32

See Also

D3DDevice Class
CreateGeometryShaderWithStreamOutput Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateGeometryShaderWithStreamOutput Method (IntPtr, UInt32, IEnumerable(StreamOutputDeclarationEntry), UInt32[], UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShaderWithStreamOutput Method (IntPtr, UInt32, IEnumerable<(Of <(<'StreamOutputDeclarationEntry>)>)>, array<UInt32>[]()[][], UInt32)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShaderWithStreamOutput(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength,
    IEnumerable<StreamOutputDeclarationEntry> streamOutputDeclarations,
    uint[] bufferStrides,
    uint rasterizedStream
)
Visual Basic
Public Function CreateGeometryShaderWithStreamOutput ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger, _
    streamOutputDeclarations As IEnumerable(Of StreamOutputDeclarationEntry), _
    bufferStrides As UInteger(), _
    rasterizedStream As UInteger _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShaderWithStreamOutput(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength,
    IEnumerable<StreamOutputDeclarationEntry>^ streamOutputDeclarations,
    array<unsigned int>^ bufferStrides,
    unsigned int rasterizedStream
)

Parameters

shaderBytecode
Type: System..::..IntPtr
shaderBytecodeLength
Type: System..::..UInt32
streamOutputDeclarations
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' StreamOutputDeclarationEntry >)>)>
bufferStrides
Type: array< System..::..UInt32 >[]()[][]
rasterizedStream
Type: System..::..UInt32

See Also

D3DDevice Class
CreateGeometryShaderWithStreamOutput Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateGeometryShaderWithStreamOutput Method (Stream, IEnumerable(StreamOutputDeclarationEntry), UInt32[], UInt32, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShaderWithStreamOutput Method (Stream, IEnumerable<(Of <(<'StreamOutputDeclarationEntry>)>)>, array<UInt32>[]()[][], UInt32, ClassLinkage)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShaderWithStreamOutput(
    Stream shaderStream,
    IEnumerable<StreamOutputDeclarationEntry> streamOutputDeclarations,
    uint[] bufferStrides,
    uint rasterizedStream,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateGeometryShaderWithStreamOutput ( _
    shaderStream As Stream, _
    streamOutputDeclarations As IEnumerable(Of StreamOutputDeclarationEntry), _
    bufferStrides As UInteger(), _
    rasterizedStream As UInteger, _
    classLinkage As ClassLinkage _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShaderWithStreamOutput(
    Stream^ shaderStream,
    IEnumerable<StreamOutputDeclarationEntry>^ streamOutputDeclarations,
    array<unsigned int>^ bufferStrides,
    unsigned int rasterizedStream,
    ClassLinkage^ classLinkage
)

Parameters

shaderStream
Type: System.IO..::..Stream
streamOutputDeclarations
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' StreamOutputDeclarationEntry >)>)>
bufferStrides
Type: array< System..::..UInt32 >[]()[][]
rasterizedStream
Type: System..::..UInt32
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage

See Also

D3DDevice Class
CreateGeometryShaderWithStreamOutput Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateGeometryShaderWithStreamOutput Method (IntPtr, UInt32, IEnumerable(StreamOutputDeclarationEntry), UInt32[], UInt32, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateGeometryShaderWithStreamOutput Method (IntPtr, UInt32, IEnumerable<(Of <(<'StreamOutputDeclarationEntry>)>)>, array<UInt32>[]()[][], UInt32, ClassLinkage)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader CreateGeometryShaderWithStreamOutput(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength,
    IEnumerable<StreamOutputDeclarationEntry> streamOutputDeclarations,
    uint[] bufferStrides,
    uint rasterizedStream,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateGeometryShaderWithStreamOutput ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger, _
    streamOutputDeclarations As IEnumerable(Of StreamOutputDeclarationEntry), _
    bufferStrides As UInteger(), _
    rasterizedStream As UInteger, _
    classLinkage As ClassLinkage _
) As GeometryShader
Visual C++
public:
GeometryShader^ CreateGeometryShaderWithStreamOutput(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength,
    IEnumerable<StreamOutputDeclarationEntry>^ streamOutputDeclarations,
    array<unsigned int>^ bufferStrides,
    unsigned int rasterizedStream,
    ClassLinkage^ classLinkage
)

Parameters

shaderBytecode
Type: System..::..IntPtr
shaderBytecodeLength
Type: System..::..UInt32
streamOutputDeclarations
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' StreamOutputDeclarationEntry >)>)>
bufferStrides
Type: array< System..::..UInt32 >[]()[][]
rasterizedStream
Type: System..::..UInt32
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage

See Also

D3DDevice Class
CreateGeometryShaderWithStreamOutput Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateHullShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateHullShader Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateHullShader(Stream) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateHullShader(IntPtr, UInt32) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateHullShader(Stream, ClassLinkage) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)
Public method | CreateHullShader(IntPtr, UInt32, ClassLinkage) | Create a hull shader. (Also see DirectX SDK: ID3D11Device::CreateHullShader)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateHullShader Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateHullShader Method (Stream)
D3DDevice Class See Also Send Feedback
Create a hull shader.

(Also see DirectX SDK: ID3D11Device::CreateHullShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HullShader CreateHullShader(
    Stream stream
)
Visual Basic
Public Function CreateHullShader ( _
    stream As Stream _
) As HullShader
Visual C++
public:
HullShader^ CreateHullShader(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.

Return Value

A hull-shader object (see HullShader).

See Also

D3DDevice Class
CreateHullShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShader


CreateHullShader Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateHullShader Method (IntPtr, UInt32)
D3DDevice Class See Also Send Feedback
Create a hull shader.

(Also see DirectX SDK: ID3D11Device::CreateHullShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HullShader CreateHullShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength
)
Visual Basic
Public Function CreateHullShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger _
) As HullShader
Visual C++
public:
HullShader^ CreateHullShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength
)

Parameters

shaderBytecode
Type: System..::..IntPtr
A compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of compiled shader code in bytes.

Return Value

A hull-shader object (see HullShader).

See Also

D3DDevice Class
CreateHullShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShader


CreateHullShader Method (Stream, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateHullShader Method (Stream, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a hull shader.

(Also see DirectX SDK: ID3D11Device::CreateHullShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HullShader CreateHullShader(
    Stream stream,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateHullShader ( _
    stream As Stream, _
    classLinkage As ClassLinkage _
) As HullShader
Visual C++
public:
HullShader^ CreateHullShader(
    Stream^ stream,
    ClassLinkage^ classLinkage
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A class linkage object (see ClassLinkage); the value can be null.

Return Value

A hull-shader object (see HullShader).

See Also

D3DDevice Class
CreateHullShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShader


CreateHullShader Method (IntPtr, UInt32, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateHullShader Method (IntPtr, UInt32, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a hull shader.

(Also see DirectX SDK: ID3D11Device::CreateHullShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HullShader CreateHullShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateHullShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger, _
    classLinkage As ClassLinkage _
) As HullShader
Visual C++
public:
HullShader^ CreateHullShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength,
    ClassLinkage^ classLinkage
)

Parameters

shaderBytecode
Type: System..::..IntPtr
A compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
Size of compiled shader code in bytes.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A class linkage object (see ClassLinkage); the value can be null.

Return Value

A hull-shader object (see HullShader).

See Also

D3DDevice Class
CreateHullShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShader


CreateInputLayout Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateInputLayout Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), Stream) |
Public method | CreateInputLayout(IEnumerable<(Of <<'(InputElementDescription>)>>), IntPtr, UInt32) |

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateInputLayout Method (IEnumerable(InputElementDescription), Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateInputLayout Method (IEnumerable<(Of <(<'InputElementDescription>)>)>, Stream)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputLayout CreateInputLayout(
    IEnumerable<InputElementDescription> inputElementDescriptions,
    Stream stream
)
Visual Basic
Public Function CreateInputLayout ( _
    inputElementDescriptions As IEnumerable(Of InputElementDescription), _
    stream As Stream _
) As InputLayout
Visual C++
public:
InputLayout^ CreateInputLayout(
    IEnumerable<InputElementDescription>^ inputElementDescriptions,
    Stream^ stream
)

Parameters

inputElementDescriptions
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' InputElementDescription >)>)>
stream
Type: System.IO..::..Stream

See Also

D3DDevice Class
CreateInputLayout Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateInputLayout Method (IEnumerable(InputElementDescription), IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateInputLayout Method (IEnumerable<(Of <(<'InputElementDescription>)>)>, IntPtr, UInt32)
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputLayout CreateInputLayout(
    IEnumerable<InputElementDescription> inputElementDescriptions,
    IntPtr shaderBytecodeWithInputSignature,
    uint shaderBytecodeWithInputSignatureSize
)
Visual Basic
Public Function CreateInputLayout ( _
    inputElementDescriptions As IEnumerable(Of InputElementDescription), _
    shaderBytecodeWithInputSignature As IntPtr, _
    shaderBytecodeWithInputSignatureSize As UInteger _
) As InputLayout
Visual C++
public:
InputLayout^ CreateInputLayout(
    IEnumerable<InputElementDescription>^ inputElementDescriptions,
    IntPtr shaderBytecodeWithInputSignature,
    unsigned int shaderBytecodeWithInputSignatureSize
)

Parameters

inputElementDescriptions
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' InputElementDescription >)>)>
shaderBytecodeWithInputSignature
Type: System..::..IntPtr
shaderBytecodeWithInputSignatureSize
Type: System..::..UInt32

See Also

D3DDevice Class
CreateInputLayout Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreatePixelShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePixelShader Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreatePixelShader(Stream) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePixelShader(IntPtr, UInt32) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePixelShader(Stream, ClassLinkage) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)
Public method | CreatePixelShader(IntPtr, UInt32, ClassLinkage) | Create a pixel shader. (Also see DirectX SDK: ID3D11Device::CreatePixelShader)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreatePixelShader Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePixelShader Method (Stream)
D3DDevice Class See Also Send Feedback
Create a pixel shader.

(Also see DirectX SDK: ID3D11Device::CreatePixelShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShader CreatePixelShader(
    Stream stream
)
Visual Basic
Public Function CreatePixelShader ( _
    stream As Stream _
) As PixelShader
Visual C++
public:
PixelShader^ CreatePixelShader(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.

Return Value

A PixelShader object.

See Also

D3DDevice Class
CreatePixelShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreatePixelShader Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePixelShader Method (IntPtr, UInt32)
D3DDevice Class See Also Send Feedback
Create a pixel shader.

(Also see DirectX SDK: ID3D11Device::CreatePixelShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShader CreatePixelShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength
)
Visual Basic
Public Function CreatePixelShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger _
) As PixelShader
Visual C++
public:
PixelShader^ CreatePixelShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength
)

Parameters

shaderBytecode
Type: System..::..IntPtr
The compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
The compiled shader. The compiled shader code contains a input signature which is validated against the array of elements.

Return Value

A PixelShader object.

See Also

D3DDevice Class
CreatePixelShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreatePixelShader Method (Stream, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePixelShader Method (Stream, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a pixel shader.

(Also see DirectX SDK: ID3D11Device::CreatePixelShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShader CreatePixelShader(
    Stream stream,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreatePixelShader ( _
    stream As Stream, _
    classLinkage As ClassLinkage _
) As PixelShader
Visual C++
public:
PixelShader^ CreatePixelShader(
    Stream^ stream,
    ClassLinkage^ classLinkage
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
(optional) A class linkage interface (see ClassLinkage); the value can be null.

Return Value

A PixelShader object.

See Also

D3DDevice Class
CreatePixelShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage


CreatePixelShader Method (IntPtr, UInt32, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePixelShader Method (IntPtr, UInt32, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a pixel shader.

(Also see DirectX SDK: ID3D11Device::CreatePixelShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShader CreatePixelShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreatePixelShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger, _
    classLinkage As ClassLinkage _
) As PixelShader
Visual C++
public:
PixelShader^ CreatePixelShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength,
    ClassLinkage^ classLinkage
)

Parameters

shaderBytecode
Type: System..::..IntPtr
The compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
The compiled shader. The compiled shader code contains a input signature which is validated against the array of elements.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
(optional) A class linkage interface (see ClassLinkage); the value can be null.

Return Value

A PixelShader object.

See Also

D3DDevice Class
CreatePixelShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage


CreatePredicate Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreatePredicate Method
D3DDevice Class See Also Send Feedback
Creates a predicate.

(Also see DirectX SDK: ID3D11Device::CreatePredicate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DPredicate CreatePredicate(
    QueryDescription predicateDescription
)
Visual Basic
Public Function CreatePredicate ( _
    predicateDescription As QueryDescription _
) As D3DPredicate
Visual C++
public:
D3DPredicate^ CreatePredicate(
    QueryDescription predicateDescription
)

Parameters

predicateDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDescription
A query description where the type of query must be a StreamOutputOverflowPredicate or OcclusionPredicate (see QueryDescription).

Return Value

A predicate object (see D3DPredicate).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DPredicate


CreateQuery Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateQuery Method
D3DDevice Class See Also Send Feedback
This class encapsulates methods for querying information from the GPU.

(Also see DirectX SDK: ID3D11Device::CreateQuery)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DQuery CreateQuery(
    QueryDescription description
)
Visual Basic
Public Function CreateQuery ( _
    description As QueryDescription _
) As D3DQuery
Visual C++
public:
D3DQuery^ CreateQuery(
    QueryDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDescription
A query description (see QueryDescription).

Return Value

The query object created (see D3DQuery).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DQuery


CreateRasterizerState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateRasterizerState Method
D3DDevice Class See Also Send Feedback
Create a rasterizer state object that tells the rasterizer stage how to behave.

(Also see DirectX SDK: ID3D11Device::CreateRasterizerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerState CreateRasterizerState(
    RasterizerDescription description
)
Visual Basic
Public Function CreateRasterizerState ( _
    description As RasterizerDescription _
) As RasterizerState
Visual C++
public:
RasterizerState^ CreateRasterizerState(
    RasterizerDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerDescription
A rasterizer state description (see RasterizerDescription).

Return Value

A rasterizer state object (see RasterizerState).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerState


CreateRenderTargetView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateRenderTargetView Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRenderTargetView(D3DResource) | Create a render-target view for accessing resource data in mipmap level 0. (Also see DirectX SDK: ID3D11Device::CreateRenderTargetView)
Public method | CreateRenderTargetView(D3DResource, RenderTargetViewDescription) | Create a render-target view for accessing resource data. (Also see DirectX SDK: ID3D11Device::CreateRenderTargetView)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateRenderTargetView Method (D3DResource)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateRenderTargetView Method (D3DResource)
D3DDevice Class See Also Send Feedback
Create a render-target view for accessing resource data in mipmap level 0.

(Also see DirectX SDK: ID3D11Device::CreateRenderTargetView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetView CreateRenderTargetView(
    D3DResource resource
)
Visual Basic
Public Function CreateRenderTargetView ( _
    resource As D3DResource _
) As RenderTargetView
Visual C++
public:
RenderTargetView^ CreateRenderTargetView(
    D3DResource^ resource
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
A D3DResource which represents a render target. This resource must have been created with the RenderTarget flag.

Return Value

A RenderTargetView.

See Also

D3DDevice Class
CreateRenderTargetView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateRenderTargetView Method (D3DResource, RenderTargetViewDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateRenderTargetView Method (D3DResource, RenderTargetViewDescription)
D3DDevice Class See Also Send Feedback
Create a render-target view for accessing resource data.

(Also see DirectX SDK: ID3D11Device::CreateRenderTargetView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetView CreateRenderTargetView(
    D3DResource resource,
    RenderTargetViewDescription description
)
Visual Basic
Public Function CreateRenderTargetView ( _
    resource As D3DResource, _
    description As RenderTargetViewDescription _
) As RenderTargetView
Visual C++
public:
RenderTargetView^ CreateRenderTargetView(
    D3DResource^ resource,
    RenderTargetViewDescription description
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
A D3DResource which represents a render target. This resource must have been created with the RenderTarget flag.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetViewDescription
A RenderTargetViewDescription which represents a render-target-view description. Set this parameter to NULL to create a view that accesses all of the subresources in mipmap level 0.

Return Value

A RenderTargetView.

See Also

D3DDevice Class
CreateRenderTargetView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateSamplerState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateSamplerState Method
D3DDevice Class See Also Send Feedback
Create a sampler-state object that encapsulates sampling information for a texture.

(Also see DirectX SDK: ID3D11Device::CreateSamplerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SamplerState CreateSamplerState(
    SamplerDescription description
)
Visual Basic
Public Function CreateSamplerState ( _
    description As SamplerDescription _
) As SamplerState
Visual C++
public:
SamplerState^ CreateSamplerState(
    SamplerDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerDescription
A sampler state description (see SamplerDescription).

Return Value

The sampler state object created (see SamplerState).

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerState


CreateShaderResourceView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateShaderResourceView Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateShaderResourceView(D3DResource) | Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D11Device::CreateShaderResourceView)
Public method | CreateShaderResourceView(D3DResource, ShaderResourceViewDescription) | Create a shader-resource view for accessing data in a resource. (Also see DirectX SDK: ID3D11Device::CreateShaderResourceView)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateShaderResourceView Method (D3DResource)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateShaderResourceView Method (D3DResource)
D3DDevice Class See Also Send Feedback
Create a shader-resource view for accessing data in a resource. It accesses the entire resource (using the format the resource was created with).

(Also see DirectX SDK: ID3D11Device::CreateShaderResourceView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceView CreateShaderResourceView(
    D3DResource resource
)
Visual Basic
Public Function CreateShaderResourceView ( _
    resource As D3DResource _
) As ShaderResourceView
Visual C++
public:
ShaderResourceView^ CreateShaderResourceView(
    D3DResource^ resource
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The resource that will serve as input to a shader. This resource must have been created with the ShaderResource flag.

Return Value

A ShaderResourceView.

See Also

D3DDevice Class
CreateShaderResourceView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateShaderResourceView Method (D3DResource, ShaderResourceViewDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateShaderResourceView Method (D3DResource, ShaderResourceViewDescription)
D3DDevice Class See Also Send Feedback
Create a shader-resource view for accessing data in a resource.

(Also see DirectX SDK: ID3D11Device::CreateShaderResourceView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceView CreateShaderResourceView(
    D3DResource resource,
    ShaderResourceViewDescription description
)
Visual Basic
Public Function CreateShaderResourceView ( _
    resource As D3DResource, _
    description As ShaderResourceViewDescription _
) As ShaderResourceView
Visual C++
public:
ShaderResourceView^ CreateShaderResourceView(
    D3DResource^ resource,
    ShaderResourceViewDescription description
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The resource that will serve as input to a shader. This resource must have been created with the ShaderResource flag.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderResourceViewDescription
A shader-resource-view description (see ShaderResourceViewDescription). Set this parameter to NULL to create a view that accesses the entire resource (using the format the resource was created with).

Return Value

A ShaderResourceView.

See Also

D3DDevice Class
CreateShaderResourceView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderResourceViewDescription


CreateTexture1D Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture1D Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTexture1D(Texture1DDescription) | Create an array of 1D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture1D)
Public method | CreateTexture1D(Texture1DDescription, array<SubresourceData>[]()[][]) | Create an array of 1D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture1D)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateTexture1D Method (Texture1DDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture1D Method (Texture1DDescription)
D3DDevice Class See Also Send Feedback
Create an array of 1D textures.

(Also see DirectX SDK: ID3D11Device::CreateTexture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1D CreateTexture1D(
    Texture1DDescription description
)
Visual Basic
Public Function CreateTexture1D ( _
    description As Texture1DDescription _
) As Texture1D
Visual C++
public:
Texture1D^ CreateTexture1D(
    Texture1DDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDescription
A 1D texture description (see Texture1DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.

Return Value

Address of the created texture (see Texture1D).

See Also

D3DDevice Class
CreateTexture1D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1D


CreateTexture1D Method (Texture1DDescription, SubresourceData[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture1D Method (Texture1DDescription, array<SubresourceData>[]()[][])
D3DDevice Class See Also Send Feedback
Create an array of 1D textures.

(Also see DirectX SDK: ID3D11Device::CreateTexture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1D CreateTexture1D(
    Texture1DDescription description,
    params SubresourceData[] initialData
)
Visual Basic
Public Function CreateTexture1D ( _
    description As Texture1DDescription, _
    ParamArray initialData As SubresourceData() _
) As Texture1D
Visual C++
public:
Texture1D^ CreateTexture1D(
    Texture1DDescription description,
    ... array<SubresourceData>^ initialData
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDescription
A 1D texture description (see Texture1DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.
initialData
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SubresourceData >[]()[][]
Subresource descriptions (see SubresourceData); one for each subresource. Applications may not specify NULL for initialData when creating IMMUTABLE resources (see Usage). If the resource is multisampled, pInitialData must be NULL because multisampled resources cannot be initialized with data when they are created.

Return Value

The created texture (see Texture1D).

See Also

D3DDevice Class
CreateTexture1D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SubresourceData
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1D


CreateTexture2D Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture2D Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTexture2D(Texture2DDescription) | Create an array of 2D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture2D)
Public method | CreateTexture2D(Texture2DDescription, array<SubresourceData>[]()[][]) | Create an array of 2D textures. (Also see DirectX SDK: ID3D11Device::CreateTexture2D)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateTexture2D Method (Texture2DDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture2D Method (Texture2DDescription)
D3DDevice Class See Also Send Feedback
Create an array of 2D textures.

(Also see DirectX SDK: ID3D11Device::CreateTexture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2D CreateTexture2D(
    Texture2DDescription description
)
Visual Basic
Public Function CreateTexture2D ( _
    description As Texture2DDescription _
) As Texture2D
Visual C++
public:
Texture2D^ CreateTexture2D(
    Texture2DDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDescription
A 2D texture description (see Texture2DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.

Return Value

The created texture (see Texture2D).

See Also

D3DDevice Class
CreateTexture2D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2D


CreateTexture2D Method (Texture2DDescription, SubresourceData[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture2D Method (Texture2DDescription, array<SubresourceData>[]()[][])
D3DDevice Class See Also Send Feedback
Create an array of 2D textures.

(Also see DirectX SDK: ID3D11Device::CreateTexture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2D CreateTexture2D(
    Texture2DDescription description,
    params SubresourceData[] initialData
)
Visual Basic
Public Function CreateTexture2D ( _
    description As Texture2DDescription, _
    ParamArray initialData As SubresourceData() _
) As Texture2D
Visual C++
public:
Texture2D^ CreateTexture2D(
    Texture2DDescription description,
    ... array<SubresourceData>^ initialData
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDescription
A 2D texture description (see Texture2DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.
initialData
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SubresourceData >[]()[][]
Subresource descriptions (see SubresourceData); one for each subresource. Applications may not specify NULL for pInitialData when creating IMMUTABLE resources (see Usage). If the resource is multisampled, pInitialData must be NULL because multisampled resources cannot be initialized with data when they are created.

Return Value

The created texture (see Texture2D).

See Also

D3DDevice Class
CreateTexture2D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SubresourceData
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2D


CreateTexture3D Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture3D Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTexture3D(Texture3DDescription) | Create a single 3D texture. (Also see DirectX SDK: ID3D11Device::CreateTexture3D)
Public method | CreateTexture3D(Texture3DDescription, array<SubresourceData>[]()[][]) | Create a single 3D texture. (Also see DirectX SDK: ID3D11Device::CreateTexture3D)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateTexture3D Method (Texture3DDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture3D Method (Texture3DDescription)
D3DDevice Class See Also Send Feedback
Create a single 3D texture.

(Also see DirectX SDK: ID3D11Device::CreateTexture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3D CreateTexture3D(
    Texture3DDescription description
)
Visual Basic
Public Function CreateTexture3D ( _
    description As Texture3DDescription _
) As Texture3D
Visual C++
public:
Texture3D^ CreateTexture3D(
    Texture3DDescription description
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DDescription
A 3D texture description (see Texture3DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.

Return Value

Address of the created texture (see Texture3D).

See Also

D3DDevice Class
CreateTexture3D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3D


CreateTexture3D Method (Texture3DDescription, SubresourceData[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateTexture3D Method (Texture3DDescription, array<SubresourceData>[]()[][])
D3DDevice Class See Also Send Feedback
Create a single 3D texture.

(Also see DirectX SDK: ID3D11Device::CreateTexture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3D CreateTexture3D(
    Texture3DDescription description,
    params SubresourceData[] initialData
)
Visual Basic
Public Function CreateTexture3D ( _
    description As Texture3DDescription, _
    ParamArray initialData As SubresourceData() _
) As Texture3D
Visual C++
public:
Texture3D^ CreateTexture3D(
    Texture3DDescription description,
    ... array<SubresourceData>^ initialData
)

Parameters

description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DDescription
A 3D texture description (see Texture3DDescription). To create a typeless resource that can be interpreted at runtime into different, compatible formats, specify a typeless format in the texture description. To generate mipmap levels automatically, set the number of mipmap levels to 0.
initialData
Type: array< Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SubresourceData >[]()[][]
Subresource descriptions (see SubresourceData); one for each subresource. Applications may not specify NULL for pInitialData when creating IMMUTABLE resources (see Usage). If the resource is multisampled, pInitialData must be NULL because multisampled resources cannot be initialized with data when they are created.

Return Value

Address of the created texture (see Texture3D).

See Also

D3DDevice Class
CreateTexture3D Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DDescription
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SubresourceData
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3D


CreateUnorderedAccessView Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateUnorderedAccessView Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateUnorderedAccessView(D3DResource) | Create a view for accessing an unordered access resource. The view created accesses the entire resource (using the format the resource was created with). (Also see DirectX SDK: ID3D11Device::CreateUnorderedAccessView)
Public method | CreateUnorderedAccessView(D3DResource, UnorderedAccessViewDescription) | Create a view for accessing an unordered access resource. (Also see DirectX SDK: ID3D11Device::CreateUnorderedAccessView)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateUnorderedAccessView Method (D3DResource)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateUnorderedAccessView Method (D3DResource)
D3DDevice Class See Also Send Feedback
Create a view for accessing an unordered access resource. The view created accesses the entire resource (using the format the resource was created with).

(Also see DirectX SDK: ID3D11Device::CreateUnorderedAccessView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public UnorderedAccessView CreateUnorderedAccessView(
    D3DResource resource
)
Visual Basic
Public Function CreateUnorderedAccessView ( _
    resource As D3DResource _
) As UnorderedAccessView
Visual C++
public:
UnorderedAccessView^ CreateUnorderedAccessView(
    D3DResource^ resource
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
An D3DResource that represents a resources that will be serve as an input to a shader.

Return Value

An UnorderedAccessView object that represents an unordered access view.

See Also

D3DDevice Class
CreateUnorderedAccessView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateUnorderedAccessView Method (D3DResource, UnorderedAccessViewDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateUnorderedAccessView Method (D3DResource, UnorderedAccessViewDescription)
D3DDevice Class See Also Send Feedback
Create a view for accessing an unordered access resource.

(Also see DirectX SDK: ID3D11Device::CreateUnorderedAccessView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public UnorderedAccessView CreateUnorderedAccessView(
    D3DResource resource,
    UnorderedAccessViewDescription description
)
Visual Basic
Public Function CreateUnorderedAccessView ( _
    resource As D3DResource, _
    description As UnorderedAccessViewDescription _
) As UnorderedAccessView
Visual C++
public:
UnorderedAccessView^ CreateUnorderedAccessView(
    D3DResource^ resource,
    UnorderedAccessViewDescription description
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
An D3DResource that represents a resources that will be serve as an input to a shader.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..UnorderedAccessViewDescription
An UnorderedAccessViewDescription that represents a shader-resource-view description.

Return Value

An UnorderedAccessView object that represents an unordered access view.

See Also

D3DDevice Class
CreateUnorderedAccessView Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateVertexShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateVertexShader Method
D3DDevice Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateVertexShader(Stream) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | CreateVertexShader(IntPtr, UInt32) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | CreateVertexShader(Stream, ClassLinkage) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)
Public method | CreateVertexShader(IntPtr, UInt32, ClassLinkage) | Create a vertex-shader object from a compiled shader. (Also see DirectX SDK: ID3D11Device::CreateVertexShader)

See Also

D3DDevice Class
D3DDevice Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateVertexShader Method (Stream)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateVertexShader Method (Stream)
D3DDevice Class See Also Send Feedback
Create a vertex-shader object from a compiled shader.

(Also see DirectX SDK: ID3D11Device::CreateVertexShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShader CreateVertexShader(
    Stream stream
)
Visual Basic
Public Function CreateVertexShader ( _
    stream As Stream _
) As VertexShader
Visual C++
public:
VertexShader^ CreateVertexShader(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream

Return Value

A VertexShader object.

See Also

D3DDevice Class
CreateVertexShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateVertexShader Method (IntPtr, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateVertexShader Method (IntPtr, UInt32)
D3DDevice Class See Also Send Feedback
Create a vertex-shader object from a compiled shader.

(Also see DirectX SDK: ID3D11Device::CreateVertexShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShader CreateVertexShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength
)
Visual Basic
Public Function CreateVertexShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger _
) As VertexShader
Visual C++
public:
VertexShader^ CreateVertexShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength
)

Parameters

shaderBytecode
Type: System..::..IntPtr
The compiled shader length in bytes.
shaderBytecodeLength
Type: System..::..UInt32
The compiled shader. The compiled shader code contains a input signature which is validated against the array of elements.

Return Value

A VertexShader object.

See Also

D3DDevice Class
CreateVertexShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateVertexShader Method (Stream, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateVertexShader Method (Stream, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a vertex-shader object from a compiled shader.

(Also see DirectX SDK: ID3D11Device::CreateVertexShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShader CreateVertexShader(
    Stream stream,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateVertexShader ( _
    stream As Stream, _
    classLinkage As ClassLinkage _
) As VertexShader
Visual C++
public:
VertexShader^ CreateVertexShader(
    Stream^ stream,
    ClassLinkage^ classLinkage
)

Parameters

stream
Type: System.IO..::..Stream
Stream to load compiled shader bytes from.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A class linkage interface (see ClassLinkage); the value can be null.

Return Value

A VertexShader object.

See Also

D3DDevice Class
CreateVertexShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage


CreateVertexShader Method (IntPtr, UInt32, ClassLinkage)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateVertexShader Method (IntPtr, UInt32, ClassLinkage)
D3DDevice Class See Also Send Feedback
Create a vertex-shader object from a compiled shader.

(Also see DirectX SDK: ID3D11Device::CreateVertexShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShader CreateVertexShader(
    IntPtr shaderBytecode,
    uint shaderBytecodeLength,
    ClassLinkage classLinkage
)
Visual Basic
Public Function CreateVertexShader ( _
    shaderBytecode As IntPtr, _
    shaderBytecodeLength As UInteger, _
    classLinkage As ClassLinkage _
) As VertexShader
Visual C++
public:
VertexShader^ CreateVertexShader(
    IntPtr shaderBytecode,
    unsigned int shaderBytecodeLength,
    ClassLinkage^ classLinkage
)

Parameters

shaderBytecode
Type: System..::..IntPtr
The compiled shader.
shaderBytecodeLength
Type: System..::..UInt32
The compiled shader length in bytes. The compiled shader code contains a input signature which is validated against the array of elements.
classLinkage
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
A class linkage interface (see ClassLinkage); the value can be null.

Return Value

A VertexShader object.

See Also

D3DDevice Class
CreateVertexShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage


GetCounterData Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GetCounterData Method
D3DDevice Class See Also Send Feedback
Get the type, name, units of measure, and a description of an existing counter.

(Also see DirectX SDK: ID3D11Device::CheckCounter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CounterData GetCounterData(
    CounterDescription counterDescription
)
Visual Basic
Public Function GetCounterData ( _
    counterDescription As CounterDescription _
) As CounterData
Visual C++
public:
CounterData^ GetCounterData(
    CounterDescription counterDescription
)

Parameters

counterDescription
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterDescription
A counter description (see CounterDescription). Specifies which counter information is to be retrieved about.

Return Value

A CheckCounterData object containing the values associated with the counter

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CounterDescription


GetFeatureDataFormatSupport Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GetFeatureDataFormatSupport Method
D3DDevice Class See Also Send Feedback
Gets information about the format features that are supported by the current graphics driver.

(Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FeatureDataFormatSupport GetFeatureDataFormatSupport(
    Format format
)
Visual Basic
Public Function GetFeatureDataFormatSupport ( _
    format As Format _
) As FeatureDataFormatSupport
Visual C++
public:
FeatureDataFormatSupport GetFeatureDataFormatSupport(
    Format format
)

Parameters

format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
The Graphics.Format value for which to check feature support.

Return Value

A FeatureDataFormatSupport value indicating features supported for the given format.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetFeatureDataFormatSupport2 Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GetFeatureDataFormatSupport2 Method
D3DDevice Class See Also Send Feedback
Gets information about the extended format features that are supported by the current graphics driver.

(Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FeatureDataFormatSupport2 GetFeatureDataFormatSupport2(
    Format format
)
Visual Basic
Public Function GetFeatureDataFormatSupport2 ( _
    format As Format _
) As FeatureDataFormatSupport2
Visual C++
public:
FeatureDataFormatSupport2 GetFeatureDataFormatSupport2(
    Format format
)

Parameters

format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
The Graphics.Format value for which to check extended feature support.

Return Value

A FeatureDataFormatSupport2 value indicating extended features supported for the given format.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetFormatSupport Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GetFormatSupport Method
D3DDevice Class See Also Send Feedback
Get the support of a given format on the installed video device.

(Also see DirectX SDK: ID3D11Device::CheckFormatSupport)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FormatSupportOptions GetFormatSupport(
    Format format
)
Visual Basic
Public Function GetFormatSupport ( _
    format As Format _
) As FormatSupportOptions
Visual C++
public:
FormatSupportOptions GetFormatSupport(
    Format format
)

Parameters

format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
A Format enumeration that describes a format for which to check for support.

Return Value

A FormatSupportOptions enumeration values describing how the specified format is supported on the installed device. The values are ORed together.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetMultisampleQualityLevels Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GetMultisampleQualityLevels Method
D3DDevice Class See Also Send Feedback
Get the number of quality levels available during multisampling.

(Also see DirectX SDK: ID3D11Device::CheckMultisampleQualityLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint GetMultisampleQualityLevels(
    Format format,
    uint sampleCount
)
Visual Basic
Public Function GetMultisampleQualityLevels ( _
    format As Format, _
    sampleCount As UInteger _
) As UInteger
Visual C++
public:
unsigned int GetMultisampleQualityLevels(
    Format format,
    unsigned int sampleCount
)

Parameters

format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
The texture format. See Format.
sampleCount
Type: System..::..UInt32
The number of samples during multisampling.

Return Value

Number of quality levels supported by the adapter.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OpenSharedResource(T) Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..OpenSharedResource<(Of <(<'T>)>)> Method
D3DDevice Class See Also Send Feedback
Give a device access to a shared resource created on a different device.

(Also see DirectX SDK: ID3D11Device::OpenSharedResource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public T OpenSharedResource<T>(
    IntPtr resource
)
where T : DirectUnknown
Visual Basic
Public Function OpenSharedResource(Of T As DirectUnknown) ( _
    resource As IntPtr _
) As T
Visual C++
public:
generic<typename T>
where T : DirectUnknown
T OpenSharedResource(
    IntPtr resource
)

Parameters

resource
Type: System..::..IntPtr
The resource handle.

Type Parameters

T
The type of this shared resource. Must be GraphicsObject

Return Value

The requested resource using the given type.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DDevice Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice Properties
D3DDevice Class See Also Send Feedback

The D3DDevice type exposes the following members.

Properties

 | Name | Description
Public property | CounterInformation | Get a counter's information. (Also see DirectX SDK: ID3D11Device::CheckCounterInfo)
Public property | CreateDeviceOptions | Get the flags used during the call to create the device. (Also see DirectX SDK: ID3D11Device::GetCreationFlags)
Public property | Debug |
Public property | DeviceFeatureLevel | Gets the feature level of the hardware device. (Also see DirectX SDK: ID3D10Device1::GetFeatureLevel)
Public property | DeviceRemovedReason | Get the reason why the device was removed. (Also see DirectX SDK: ID3D11Device::GetDeviceRemovedReason)
Public property | ExceptionMode | Gets or Sets the exception-mode flags. (Also see DirectX SDK: ID3D11Device::GetExceptionMode, ID3D11Device::SetExceptionMode)
Public property | GraphicsDevice | Queries this device as a Graphics Device object.
Public property | GraphicsDevice1 |
Public property | ImmediateContext | Gets an immediate context which can record command lists. (Also see DirectX SDK: ID3D11Device::GetImmediateContext)
Public property | InfoQueue | Gets an information queue object that can retrieve, store and filter debug messages.
Public property | IsComputeShaderWithRawAndStructuredBuffersSupported | Gets whether or not compute shaders, along with raw and structured buffers, are supported by the driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)
Public property | IsDoubleSupported | Gets information about whether double-precision floating point is supported by the current graphics driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SwapChain |
Public property | SwitchToRef | Gets a switch-to-reference object that enables an application to switch between a hardware and software device.
Public property | ThreadingSupport | Gets information about the threading features that are supported by the current graphics driver. (Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CounterInformation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CounterInformation Property
D3DDevice Class See Also Send Feedback
Get a counter's information.

(Also see DirectX SDK: ID3D11Device::CheckCounterInfo)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CounterInformation CounterInformation { get; }
Visual Basic
Public ReadOnly Property CounterInformation As CounterInformation
    Get
Visual C++
public:
property CounterInformation CounterInformation {
    CounterInformation get ();
}

Return Value

The counter information.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CreateDeviceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..CreateDeviceOptions Property
D3DDevice Class See Also Send Feedback
Get the flags used during the call to create the device.

(Also see DirectX SDK: ID3D11Device::GetCreationFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CreateDeviceOptions CreateDeviceOptions { get; }
Visual Basic
Public ReadOnly Property CreateDeviceOptions As CreateDeviceOptions
    Get
Visual C++
public:
property CreateDeviceOptions CreateDeviceOptions {
    CreateDeviceOptions get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Debug Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..Debug Property
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DDebug Debug { get; }
Visual Basic
Public ReadOnly Property Debug As D3DDebug
    Get
Visual C++
public:
property D3DDebug^ Debug {
    D3DDebug^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceFeatureLevel Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..DeviceFeatureLevel Property
D3DDevice Class See Also Send Feedback
Gets the feature level of the hardware device.

(Also see DirectX SDK: ID3D10Device1::GetFeatureLevel)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FeatureLevel DeviceFeatureLevel { get; }
Visual Basic
Public ReadOnly Property DeviceFeatureLevel As FeatureLevel
    Get
Visual C++
public:
property FeatureLevel DeviceFeatureLevel {
    FeatureLevel get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceRemovedReason Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..DeviceRemovedReason Property
D3DDevice Class See Also Send Feedback
Get the reason why the device was removed.

(Also see DirectX SDK: ID3D11Device::GetDeviceRemovedReason)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ErrorCode DeviceRemovedReason { get; }
Visual Basic
Public ReadOnly Property DeviceRemovedReason As ErrorCode
    Get
Visual C++
public:
property ErrorCode DeviceRemovedReason {
    ErrorCode get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExceptionMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..ExceptionMode Property
D3DDevice Class See Also Send Feedback
Gets or Sets the exception-mode flags.

(Also see DirectX SDK: ID3D11Device::GetExceptionMode, ID3D11Device::SetExceptionMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExceptionErrors ExceptionMode { get; set; }
Visual Basic
Public Property ExceptionMode As ExceptionErrors
    Get
    Set
Visual C++
public:
property ExceptionErrors ExceptionMode {
    ExceptionErrors get ();
    void set (ExceptionErrors value);
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GraphicsDevice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GraphicsDevice Property
D3DDevice Class See Also Send Feedback
Queries this device as a Graphics Device object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Device GraphicsDevice { get; }
Visual Basic
Public ReadOnly Property GraphicsDevice As Device
    Get
Visual C++
public:
property Device^ GraphicsDevice {
    Device^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GraphicsDevice1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..GraphicsDevice1 Property
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Device1 GraphicsDevice1 { get; }
Visual Basic
Public ReadOnly Property GraphicsDevice1 As Device1
    Get
Visual C++
public:
property Device1^ GraphicsDevice1 {
    Device1^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ImmediateContext Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..ImmediateContext Property
D3DDevice Class See Also Send Feedback
Gets an immediate context which can record command lists.

(Also see DirectX SDK: ID3D11Device::GetImmediateContext)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DeviceContext ImmediateContext { get; }
Visual Basic
Public ReadOnly Property ImmediateContext As DeviceContext
    Get
Visual C++
public:
property DeviceContext^ ImmediateContext {
    DeviceContext^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InfoQueue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..InfoQueue Property
D3DDevice Class See Also Send Feedback
Gets an information queue object that can retrieve, store and filter debug messages.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InfoQueue InfoQueue { get; }
Visual Basic
Public ReadOnly Property InfoQueue As InfoQueue
    Get
Visual C++
public:
property InfoQueue^ InfoQueue {
    InfoQueue^ get ();
}

Return Value

An InfoQueue (information queue) object.

Remarks

Can only be obtained if the device was created using Debug flag. Otherwise, throws an exception.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IsComputeShaderWithRawAndStructuredBuffersSupported Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..IsComputeShaderWithRawAndStructuredBuffersSupported Property
D3DDevice Class See Also Send Feedback
Gets whether or not compute shaders, along with raw and structured buffers, are supported by the driver.

(Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsComputeShaderWithRawAndStructuredBuffersSupported { get; }
Visual Basic
Public ReadOnly Property IsComputeShaderWithRawAndStructuredBuffersSupported As Boolean
    Get
Visual C++
public:
property bool IsComputeShaderWithRawAndStructuredBuffersSupported {
    bool get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IsDoubleSupported Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..IsDoubleSupported Property
D3DDevice Class See Also Send Feedback
Gets information about whether double-precision floating point is supported by the current graphics driver.

(Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsDoubleSupported { get; }
Visual Basic
Public ReadOnly Property IsDoubleSupported As Boolean
    Get
Visual C++
public:
property bool IsDoubleSupported {
    bool get ();
}

Return Value

True if driver supports double-precision floating point. Otherwise, returns false.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SwapChain Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..SwapChain Property
D3DDevice Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwapChain SwapChain { get; }
Visual Basic
Public ReadOnly Property SwapChain As SwapChain
    Get
Visual C++
public:
property SwapChain^ SwapChain {
    SwapChain^ get ();
}

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SwitchToRef Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..SwitchToRef Property
D3DDevice Class See Also Send Feedback
Gets a switch-to-reference object that enables an application to switch between a hardware and software device.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwitchToRef SwitchToRef { get; }
Visual Basic
Public ReadOnly Property SwitchToRef As SwitchToRef
    Get
Visual C++
public:
property SwitchToRef^ SwitchToRef {
    SwitchToRef^ get ();
}

Return Value

A SwitchToRef (switch-to-reference) object.

Remarks

Can only be obtained if the device was created using CreateDeviceOptions.SwitchToRef flag. Otherwise, throws an exception.

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ThreadingSupport Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DDevice..::..ThreadingSupport Property
D3DDevice Class See Also Send Feedback
Gets information about the threading features that are supported by the current graphics driver.

(Also see DirectX SDK: ID3D11Device::CheckFeatureSupport)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FeatureDataThreading ThreadingSupport { get; }
Visual Basic
Public ReadOnly Property ThreadingSupport As FeatureDataThreading
    Get
Visual C++
public:
property FeatureDataThreading ThreadingSupport {
    FeatureDataThreading get ();
}

Return Value

FeatureDataThreading value containing feature support for threading

See Also

D3DDevice Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DPredicate Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate Class
Members See Also Send Feedback
A predicate interface determines whether geometry should be processed depending on the results of a previous draw call.

(Also see DirectX SDK: ID3D11Predicate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DPredicate : D3DQuery
Visual Basic
Public Class D3DPredicate _
    Inherits D3DQuery
Visual C++
public ref class D3DPredicate : public D3DQuery

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DQuery
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DPredicate

See Also

D3DPredicate Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DPredicate Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate Members
D3DPredicate Class Properties See Also Send Feedback

The D3DPredicate type exposes the following members.

Properties

 | Name | Description
Public property | Context |
Public property | DataSize | Get the size of the data (in bytes) that is output when calling DeviceContext.GetData. (Also see DirectX SDK: ID3D11Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a query description. (Also see DirectX SDK: ID3D11Query::GetDesc) (Inherited from D3DQuery.)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | WhenTrue |

See Also

D3DPredicate Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DPredicate Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate Properties
D3DPredicate Class See Also Send Feedback

The D3DPredicate type exposes the following members.

Properties

 | Name | Description
Public property | Context |
Public property | DataSize | Get the size of the data (in bytes) that is output when calling DeviceContext.GetData. (Also see DirectX SDK: ID3D11Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a query description. (Also see DirectX SDK: ID3D11Query::GetDesc) (Inherited from D3DQuery.)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | WhenTrue |

See Also

D3DPredicate Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Context Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate..::..Context Property
D3DPredicate Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DeviceContext Context { get; set; }
Visual Basic
Public Property Context As DeviceContext
    Get
    Set
Visual C++
public:
property DeviceContext^ Context {
    DeviceContext^ get ();
    void set (DeviceContext^ value);
}

See Also

D3DPredicate Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


WhenTrue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DPredicate..::..WhenTrue Property
D3DPredicate Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool WhenTrue { get; set; }
Visual Basic
Public Property WhenTrue As Boolean
    Get
    Set
Visual C++
public:
property bool WhenTrue {
    bool get ();
    void set (bool value);
}

See Also

D3DPredicate Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DQuery Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DQuery Class
Members See Also Send Feedback
A query interface queries information from the GPU.

(Also see DirectX SDK: ID3D11Query)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DQuery : Asynchronous
Visual Basic
Public Class D3DQuery _
    Inherits Asynchronous
Visual C++
public ref class D3DQuery : public Asynchronous

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DQuery
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DPredicate

See Also

D3DQuery Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DQuery Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DQuery Members
D3DQuery Class Properties See Also Send Feedback

The D3DQuery type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling DeviceContext.GetData. (Also see DirectX SDK: ID3D11Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a query description. (Also see DirectX SDK: ID3D11Query::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D3DQuery Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DQuery Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DQuery Properties
D3DQuery Class See Also Send Feedback

The D3DQuery type exposes the following members.

Properties

 | Name | Description
Public property | DataSize | Get the size of the data (in bytes) that is output when calling DeviceContext.GetData. (Also see DirectX SDK: ID3D11Asynchronous::GetDataSize) (Inherited from Asynchronous.)
Public property | Description | Get a query description. (Also see DirectX SDK: ID3D11Query::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

D3DQuery Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DQuery..::..Description Property
D3DQuery Class See Also Send Feedback
Get a query description.

(Also see DirectX SDK: ID3D11Query::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public QueryDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As QueryDescription
    Get
Visual C++
public:
property QueryDescription Description {
    QueryDescription get ();
}

See Also

D3DQuery Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DResource Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource Class
Members See Also Send Feedback
A resource interface provides common actions on all resources.

(Also see DirectX SDK: ID3D11Resource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class D3DResource : DeviceChild
Visual Basic
Public Class D3DResource _
    Inherits DeviceChild
Visual C++
public ref class D3DResource : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1D
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2D
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3D

See Also

D3DResource Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DResource Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource Members
D3DResource Class Properties See Also Send Feedback

The D3DResource type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority)
Public property | GraphicsSurface | Get associated Graphics surface.
Public property | GraphicsSurface1 | Get associated Graphics.Surface1.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType)

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


D3DResource Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource Properties
D3DResource Class See Also Send Feedback

The D3DResource type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority)
Public property | GraphicsSurface | Get associated Graphics surface.
Public property | GraphicsSurface1 | Get associated Graphics.Surface1.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType)

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


EvictionPriority Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource..::..EvictionPriority Property
D3DResource Class See Also Send Feedback
Gets or sets the eviction priority of a resource.

(Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint EvictionPriority { get; set; }
Visual Basic
Public Property EvictionPriority As UInteger
    Get
    Set
Visual C++
public:
property unsigned int EvictionPriority {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GraphicsSurface Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource..::..GraphicsSurface Property
D3DResource Class See Also Send Feedback
Get associated Graphics surface.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Surface GraphicsSurface { get; }
Visual Basic
Public ReadOnly Property GraphicsSurface As Surface
    Get
Visual C++
public:
property Surface^ GraphicsSurface {
    Surface^ get ();
}

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GraphicsSurface1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource..::..GraphicsSurface1 Property
D3DResource Class See Also Send Feedback
Get associated Graphics.Surface1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Surface1 GraphicsSurface1 { get; }
Visual Basic
Public ReadOnly Property GraphicsSurface1 As Surface1
    Get
Visual C++
public:
property Surface1^ GraphicsSurface1 {
    Surface1^ get ();
}

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ResourceDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
D3DResource..::..ResourceDimension Property
D3DResource Class See Also Send Feedback
Get the type of the resource.

(Also see DirectX SDK: ID3D11Resource::GetType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ResourceDimension ResourceDimension { get; }
Visual Basic
Public ReadOnly Property ResourceDimension As ResourceDimension
    Get
Visual C++
public:
property ResourceDimension ResourceDimension {
    ResourceDimension get ();
}

See Also

D3DResource Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DebugFeatures Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DebugFeatures Enumeration
See Also Send Feedback
Setting a feature-mask flag will cause a rendering-operation method to do some extra task when called.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum DebugFeatures
Visual Basic
<FlagsAttribute> _
Public Enumeration DebugFeatures
Visual C++
[FlagsAttribute]
public enum class DebugFeatures

Members

Member name | Description
PresentPerRenderOperation |
FlushPerRenderOperation |
FinishPerRenderOperation |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Structure
Members See Also Send Feedback
Describes depth-stencil state.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct DepthStencilDescription
Visual Basic
Public Structure DepthStencilDescription
Visual C++
public value class DepthStencilDescription

See Also

DepthStencilDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Members
DepthStencilDescription Structure Methods Operators Properties See Also Send Feedback

The DepthStencilDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BackFace | Identify how to use the results of the depth test and the stencil test for pixels whose surface normal is facing away from the camera (see DepthStencilOperationDescription). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.BackFace)
Public property | DepthEnable | Enable depth testing. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.DepthEnable)
Public property | DepthFunction | A function that compares depth data against existing depth data. The function options are listed in ComparisonFunction. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.DepthFunc)
Public property | DepthWriteMask | Identify a portion of the depth-stencil buffer that can be modified by depth data (see DepthWriteMask). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.DepthWriteMask)
Public property | FrontFace | Identify how to use the results of the depth test and the stencil test for pixels whose surface normal is facing towards the camera (see DepthStencilOperationDescription). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.FrontFace)
Public property | StencilEnable | Enable stencil testing. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.StencilEnable)
Public property | StencilReadMask | Identify a portion of the depth-stencil buffer for reading stencil data. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.StencilReadMask)
Public property | StencilWriteMask | Identify a portion of the depth-stencil buffer for writing stencil data. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.StencilWriteMask)

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Methods
DepthStencilDescription Structure See Also Send Feedback

The DepthStencilDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..Equals Method
DepthStencilDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..GetHashCode Method
DepthStencilDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Operators
DepthStencilDescription Structure See Also Send Feedback

The DepthStencilDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..Equality Operator
DepthStencilDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    DepthStencilDescription depthStencilDescription1,
    DepthStencilDescription depthStencilDescription2
)
Visual Basic
Public Shared Operator = ( _
    depthStencilDescription1 As DepthStencilDescription, _
    depthStencilDescription2 As DepthStencilDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    DepthStencilDescription depthStencilDescription1,
    DepthStencilDescription depthStencilDescription2
)

Parameters

depthStencilDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilDescription
depthStencilDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilDescription

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..Inequality Operator
DepthStencilDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    DepthStencilDescription depthStencilDescription1,
    DepthStencilDescription depthStencilDescription2
)
Visual Basic
Public Shared Operator <> ( _
    depthStencilDescription1 As DepthStencilDescription, _
    depthStencilDescription2 As DepthStencilDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    DepthStencilDescription depthStencilDescription1,
    DepthStencilDescription depthStencilDescription2
)

Parameters

depthStencilDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilDescription
depthStencilDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilDescription

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription Properties
DepthStencilDescription Structure See Also Send Feedback

The DepthStencilDescription type exposes the following members.

Properties

 | Name | Description
Public property | BackFace | Identify how to use the results of the depth test and the stencil test for pixels whose surface normal is facing away from the camera (see DepthStencilOperationDescription). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.BackFace)
Public property | DepthEnable | Enable depth testing. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.DepthEnable)
Public property | DepthFunction | A function that compares depth data against existing depth data. The function options are listed in ComparisonFunction. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.DepthFunc)
Public property | DepthWriteMask | Identify a portion of the depth-stencil buffer that can be modified by depth data (see DepthWriteMask). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.DepthWriteMask)
Public property | FrontFace | Identify how to use the results of the depth test and the stencil test for pixels whose surface normal is facing towards the camera (see DepthStencilOperationDescription). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.FrontFace)
Public property | StencilEnable | Enable stencil testing. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.StencilEnable)
Public property | StencilReadMask | Identify a portion of the depth-stencil buffer for reading stencil data. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.StencilReadMask)
Public property | StencilWriteMask | Identify a portion of the depth-stencil buffer for writing stencil data. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.StencilWriteMask)

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BackFace Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..BackFace Property
DepthStencilDescription Structure See Also Send Feedback
Identify how to use the results of the depth test and the stencil test for pixels whose surface normal is facing away from the camera (see DepthStencilOperationDescription).

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.BackFace)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilOperationDescription BackFace { get; set; }
Visual Basic
Public Property BackFace As DepthStencilOperationDescription
    Get
    Set
Visual C++
public:
property DepthStencilOperationDescription BackFace {
    DepthStencilOperationDescription get ();
    void set (DepthStencilOperationDescription value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilOperationDescription


DepthEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..DepthEnable Property
DepthStencilDescription Structure See Also Send Feedback
Enable depth testing.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.DepthEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool DepthEnable { get; set; }
Visual Basic
Public Property DepthEnable As Boolean
    Get
    Set
Visual C++
public:
property bool DepthEnable {
    bool get ();
    void set (bool value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthFunction Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..DepthFunction Property
DepthStencilDescription Structure See Also Send Feedback
A function that compares depth data against existing depth data. The function options are listed in ComparisonFunction.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.DepthFunc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComparisonFunction DepthFunction { get; set; }
Visual Basic
Public Property DepthFunction As ComparisonFunction
    Get
    Set
Visual C++
public:
property ComparisonFunction DepthFunction {
    ComparisonFunction get ();
    void set (ComparisonFunction value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthWriteMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..DepthWriteMask Property
DepthStencilDescription Structure See Also Send Feedback
Identify a portion of the depth-stencil buffer that can be modified by depth data (see DepthWriteMask).

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.DepthWriteMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthWriteMask DepthWriteMask { get; set; }
Visual Basic
Public Property DepthWriteMask As DepthWriteMask
    Get
    Set
Visual C++
public:
property DepthWriteMask DepthWriteMask {
    DepthWriteMask get ();
    void set (DepthWriteMask value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
DepthStencilDescription..::..DepthWriteMask


FrontFace Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..FrontFace Property
DepthStencilDescription Structure See Also Send Feedback
Identify how to use the results of the depth test and the stencil test for pixels whose surface normal is facing towards the camera (see DepthStencilOperationDescription).

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.FrontFace)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilOperationDescription FrontFace { get; set; }
Visual Basic
Public Property FrontFace As DepthStencilOperationDescription
    Get
    Set
Visual C++
public:
property DepthStencilOperationDescription FrontFace {
    DepthStencilOperationDescription get ();
    void set (DepthStencilOperationDescription value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilOperationDescription


StencilEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..StencilEnable Property
DepthStencilDescription Structure See Also Send Feedback
Enable stencil testing.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.StencilEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool StencilEnable { get; set; }
Visual Basic
Public Property StencilEnable As Boolean
    Get
    Set
Visual C++
public:
property bool StencilEnable {
    bool get ();
    void set (bool value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StencilReadMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..StencilReadMask Property
DepthStencilDescription Structure See Also Send Feedback
Identify a portion of the depth-stencil buffer for reading stencil data.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.StencilReadMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilReadMask StencilReadMask { get; set; }
Visual Basic
Public Property StencilReadMask As StencilReadMask
    Get
    Set
Visual C++
public:
property StencilReadMask StencilReadMask {
    StencilReadMask get ();
    void set (StencilReadMask value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StencilWriteMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilDescription..::..StencilWriteMask Property
DepthStencilDescription Structure See Also Send Feedback
Identify a portion of the depth-stencil buffer for writing stencil data.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_DESC.StencilWriteMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilWriteMask StencilWriteMask { get; set; }
Visual Basic
Public Property StencilWriteMask As StencilWriteMask
    Get
    Set
Visual C++
public:
property StencilWriteMask StencilWriteMask {
    StencilWriteMask get ();
    void set (StencilWriteMask value);
}

See Also

DepthStencilDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilOperationDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Structure
Members See Also Send Feedback
Stencil operations that can be performed based on the results of stencil test.

(Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct DepthStencilOperationDescription
Visual Basic
Public Structure DepthStencilOperationDescription
Visual C++
public value class DepthStencilOperationDescription

See Also

DepthStencilOperationDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilOperationDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Members
DepthStencilOperationDescription Structure Constructors Methods Operators Properties See Also Send Feedback

The DepthStencilOperationDescription type exposes the following members.

Constructors

 | Name | Description
Public method | DepthStencilOperationDescription |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | StencilDepthFailOperation | The stencil operation to perform when stencil testing passes and depth testing fails. (Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilDepthFailOp)
Public property | StencilFailOperation | The stencil operation to perform when stencil testing fails. (Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilFailOp)
Public property | StencilFunction | A function that compares stencil data against existing stencil data. The function options are listed in ComparisonFunction. (Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilFunc)
Public property | StencilPassOperation | The stencil operation to perform when stencil testing and depth testing both pass. (Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilPassOp)

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilOperationDescription Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Constructor
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilOperationDescription(
    D3D11_DEPTH_STENCILOP_DESC* desc
)
Visual Basic
Visual Basic does not support APIs that consume or return unsafe types.
Visual C++
public:
DepthStencilOperationDescription(
    D3D11_DEPTH_STENCILOP_DESC* desc
)

Parameters

desc
Type: D3D11_DEPTH_STENCILOP_DESC IsImplicitlyDereferenced*

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilOperationDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Methods
DepthStencilOperationDescription Structure See Also Send Feedback

The DepthStencilOperationDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..Equals Method
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..GetHashCode Method
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilOperationDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Operators
DepthStencilOperationDescription Structure See Also Send Feedback

The DepthStencilOperationDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..Equality Operator
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    DepthStencilOperationDescription depthStencilOperationDescription1,
    DepthStencilOperationDescription depthStencilOperationDescription2
)
Visual Basic
Public Shared Operator = ( _
    depthStencilOperationDescription1 As DepthStencilOperationDescription, _
    depthStencilOperationDescription2 As DepthStencilOperationDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    DepthStencilOperationDescription depthStencilOperationDescription1,
    DepthStencilOperationDescription depthStencilOperationDescription2
)

Parameters

depthStencilOperationDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilOperationDescription
depthStencilOperationDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilOperationDescription

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..Inequality Operator
DepthStencilOperationDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    DepthStencilOperationDescription depthStencilOperationDescription1,
    DepthStencilOperationDescription depthStencilOperationDescription2
)
Visual Basic
Public Shared Operator <> ( _
    depthStencilOperationDescription1 As DepthStencilOperationDescription, _
    depthStencilOperationDescription2 As DepthStencilOperationDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    DepthStencilOperationDescription depthStencilOperationDescription1,
    DepthStencilOperationDescription depthStencilOperationDescription2
)

Parameters

depthStencilOperationDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilOperationDescription
depthStencilOperationDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilOperationDescription

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilOperationDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription Properties
DepthStencilOperationDescription Structure See Also Send Feedback

The DepthStencilOperationDescription type exposes the following members.

Properties

 | Name | Description
Public property | StencilDepthFailOperation | The stencil operation to perform when stencil testing passes and depth testing fails. (Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilDepthFailOp)
Public property | StencilFailOperation | The stencil operation to perform when stencil testing fails. (Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilFailOp)
Public property | StencilFunction | A function that compares stencil data against existing stencil data. The function options are listed in ComparisonFunction. (Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilFunc)
Public property | StencilPassOperation | The stencil operation to perform when stencil testing and depth testing both pass. (Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilPassOp)

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StencilDepthFailOperation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..StencilDepthFailOperation Property
DepthStencilOperationDescription Structure See Also Send Feedback
The stencil operation to perform when stencil testing passes and depth testing fails.

(Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilDepthFailOp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilOperation StencilDepthFailOperation { get; set; }
Visual Basic
Public Property StencilDepthFailOperation As StencilOperation
    Get
    Set
Visual C++
public:
property StencilOperation StencilDepthFailOperation {
    StencilOperation get ();
    void set (StencilOperation value);
}

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StencilFailOperation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..StencilFailOperation Property
DepthStencilOperationDescription Structure See Also Send Feedback
The stencil operation to perform when stencil testing fails.

(Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilFailOp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilOperation StencilFailOperation { get; set; }
Visual Basic
Public Property StencilFailOperation As StencilOperation
    Get
    Set
Visual C++
public:
property StencilOperation StencilFailOperation {
    StencilOperation get ();
    void set (StencilOperation value);
}

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StencilFunction Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..StencilFunction Property
DepthStencilOperationDescription Structure See Also Send Feedback
A function that compares stencil data against existing stencil data. The function options are listed in ComparisonFunction.

(Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilFunc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComparisonFunction StencilFunction { get; set; }
Visual Basic
Public Property StencilFunction As ComparisonFunction
    Get
    Set
Visual C++
public:
property ComparisonFunction StencilFunction {
    ComparisonFunction get ();
    void set (ComparisonFunction value);
}

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StencilPassOperation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilOperationDescription..::..StencilPassOperation Property
DepthStencilOperationDescription Structure See Also Send Feedback
The stencil operation to perform when stencil testing and depth testing both pass.

(Also see DirectX SDK: D3D11_DEPTH_STENCILOP_DESC.StencilPassOp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StencilOperation StencilPassOperation { get; set; }
Visual Basic
Public Property StencilPassOperation As StencilOperation
    Get
    Set
Visual C++
public:
property StencilOperation StencilPassOperation {
    StencilOperation get ();
    void set (StencilOperation value);
}

See Also

DepthStencilOperationDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilState Class
Members See Also Send Feedback
A depth-stencil-state interface accesses depth-stencil state which sets up the depth-stencil test for the output-merger stage.

(Also see DirectX SDK: ID3D11DepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DepthStencilState : DeviceChild
Visual Basic
Public Class DepthStencilState _
    Inherits DeviceChild
Visual C++
public ref class DepthStencilState : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilState

See Also

DepthStencilState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilState Members
DepthStencilState Class Properties See Also Send Feedback

The DepthStencilState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the depth-stencil state. (Also see DirectX SDK: ID3D11DepthStencilState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DepthStencilState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilState Properties
DepthStencilState Class See Also Send Feedback

The DepthStencilState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the depth-stencil state. (Also see DirectX SDK: ID3D11DepthStencilState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DepthStencilState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilState..::..Description Property
DepthStencilState Class See Also Send Feedback
Get the depth-stencil state.

(Also see DirectX SDK: ID3D11DepthStencilState::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As DepthStencilDescription
    Get
Visual C++
public:
property DepthStencilDescription Description {
    DepthStencilDescription get ();
}

See Also

DepthStencilState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilView Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilView Class
Members See Also Send Feedback
A depth-stencil-view interface accesses a texture resource during depth-stencil testing.

(Also see DirectX SDK: ID3D11DepthStencilView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DepthStencilView : View
Visual Basic
Public Class DepthStencilView _
    Inherits View
Visual C++
public ref class DepthStencilView : public View

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilView

See Also

DepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilView Members
DepthStencilView Class Properties See Also Send Feedback

The DepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the depth-stencil view. (Also see DirectX SDK: ID3D11DepthStencilView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource) (Inherited from View.)

See Also

DepthStencilView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilView Properties
DepthStencilView Class See Also Send Feedback

The DepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the depth-stencil view. (Also see DirectX SDK: ID3D11DepthStencilView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource) (Inherited from View.)

See Also

DepthStencilView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilView..::..Description Property
DepthStencilView Class See Also Send Feedback
Get the depth-stencil view.

(Also see DirectX SDK: ID3D11DepthStencilView::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilViewDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As DepthStencilViewDescription
    Get
Visual C++
public:
property DepthStencilViewDescription Description {
    DepthStencilViewDescription get ();
}

See Also

DepthStencilView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilViewDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription Structure
Members See Also Send Feedback
Specifies the subresources of a texture that are accessible from a depth-stencil view.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct DepthStencilViewDescription
Visual Basic
Public Structure DepthStencilViewDescription
Visual C++
public value class DepthStencilViewDescription

See Also

DepthStencilViewDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilViewDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription Members
DepthStencilViewDescription Structure Properties See Also Send Feedback

The DepthStencilViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Format | Resource data format (see Format). See remarks for allowable formats. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Format)
Public property | Options | A value that describes whether the texture is read only. Pass 0 to specify that it is not read only; otherwise, pass one of the members of the DepthStencilViewOptions enumerated type. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Flags)
Public property | Texture1D | Specifies a 1D texture subresource (see Texture1DDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies an array of 1D texture subresources (see Texture1DArrayDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies a 2D texture subresource (see Texture2DDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies an array of 2D texture subresources (see Texture2DArrayDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | Specifies a multisampled 2D texture (see Texture2DMultisampleDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2DMS)
Public property | Texture2DMultisampleArray | Specifies an array of multisampled 2D textures (see Texture2DMultisampleArrayDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2DMSArray)
Public property | ViewDimension | Type of resource (see DepthStencilViewDimension). Specifies how a depth-stencil resource will be accessed; the value is stored in the union in this structure. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.ViewDimension)

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilViewDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription Properties
DepthStencilViewDescription Structure See Also Send Feedback

The DepthStencilViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Format | Resource data format (see Format). See remarks for allowable formats. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Format)
Public property | Options | A value that describes whether the texture is read only. Pass 0 to specify that it is not read only; otherwise, pass one of the members of the DepthStencilViewOptions enumerated type. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Flags)
Public property | Texture1D | Specifies a 1D texture subresource (see Texture1DDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies an array of 1D texture subresources (see Texture1DArrayDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies a 2D texture subresource (see Texture2DDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies an array of 2D texture subresources (see Texture2DArrayDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | Specifies a multisampled 2D texture (see Texture2DMultisampleDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2DMS)
Public property | Texture2DMultisampleArray | Specifies an array of multisampled 2D textures (see Texture2DMultisampleArrayDepthStencilView). (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2DMSArray)
Public property | ViewDimension | Type of resource (see DepthStencilViewDimension). Specifies how a depth-stencil resource will be accessed; the value is stored in the union in this structure. (Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.ViewDimension)

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Format Property
DepthStencilViewDescription Structure See Also Send Feedback
Resource data format (see Format). See remarks for allowable formats.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
DepthStencilViewDescription..::..Format


Options Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Options Property
DepthStencilViewDescription Structure See Also Send Feedback
A value that describes whether the texture is read only. Pass 0 to specify that it is not read only; otherwise, pass one of the members of the DepthStencilViewOptions enumerated type.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Flags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilViewOptions Options { get; set; }
Visual Basic
Public Property Options As DepthStencilViewOptions
    Get
    Set
Visual C++
public:
property DepthStencilViewOptions Options {
    DepthStencilViewOptions get ();
    void set (DepthStencilViewOptions value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture1D Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies a 1D texture subresource (see Texture1DDepthStencilView).

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DDepthStencilView Texture1D { get; set; }
Visual Basic
Public Property Texture1D As Texture1DDepthStencilView
    Get
    Set
Visual C++
public:
property Texture1DDepthStencilView Texture1D {
    Texture1DDepthStencilView get ();
    void set (Texture1DDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDepthStencilView


Texture1DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture1DArray Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies an array of 1D texture subresources (see Texture1DArrayDepthStencilView).

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture1DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DArrayDepthStencilView Texture1DArray { get; set; }
Visual Basic
Public Property Texture1DArray As Texture1DArrayDepthStencilView
    Get
    Set
Visual C++
public:
property Texture1DArrayDepthStencilView Texture1DArray {
    Texture1DArrayDepthStencilView get ();
    void set (Texture1DArrayDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayDepthStencilView


Texture2D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture2D Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies a 2D texture subresource (see Texture2DDepthStencilView).

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DDepthStencilView Texture2D { get; set; }
Visual Basic
Public Property Texture2D As Texture2DDepthStencilView
    Get
    Set
Visual C++
public:
property Texture2DDepthStencilView Texture2D {
    Texture2DDepthStencilView get ();
    void set (Texture2DDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDepthStencilView


Texture2DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture2DArray Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies an array of 2D texture subresources (see Texture2DArrayDepthStencilView).

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DArrayDepthStencilView Texture2DArray { get; set; }
Visual Basic
Public Property Texture2DArray As Texture2DArrayDepthStencilView
    Get
    Set
Visual C++
public:
property Texture2DArrayDepthStencilView Texture2DArray {
    Texture2DArrayDepthStencilView get ();
    void set (Texture2DArrayDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayDepthStencilView


Texture2DMultisample Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture2DMultisample Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies a multisampled 2D texture (see Texture2DMultisampleDepthStencilView).

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2DMS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleDepthStencilView Texture2DMultisample { get; set; }
Visual Basic
Public Property Texture2DMultisample As Texture2DMultisampleDepthStencilView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleDepthStencilView Texture2DMultisample {
    Texture2DMultisampleDepthStencilView get ();
    void set (Texture2DMultisampleDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleDepthStencilView


Texture2DMultisampleArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..Texture2DMultisampleArray Property
DepthStencilViewDescription Structure See Also Send Feedback
Specifies an array of multisampled 2D textures (see Texture2DMultisampleArrayDepthStencilView).

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.Texture2DMSArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleArrayDepthStencilView Texture2DMultisampleArray { get; set; }
Visual Basic
Public Property Texture2DMultisampleArray As Texture2DMultisampleArrayDepthStencilView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleArrayDepthStencilView Texture2DMultisampleArray {
    Texture2DMultisampleArrayDepthStencilView get ();
    void set (Texture2DMultisampleArrayDepthStencilView value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayDepthStencilView


ViewDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDescription..::..ViewDimension Property
DepthStencilViewDescription Structure See Also Send Feedback
Type of resource (see DepthStencilViewDimension). Specifies how a depth-stencil resource will be accessed; the value is stored in the union in this structure.

(Also see DirectX SDK: D3D11_DEPTH_STENCIL_VIEW_DESC.ViewDimension)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilViewDimension ViewDimension { get; set; }
Visual Basic
Public Property ViewDimension As DepthStencilViewDimension
    Get
    Set
Visual C++
public:
property DepthStencilViewDimension ViewDimension {
    DepthStencilViewDimension get ();
    void set (DepthStencilViewDimension value);
}

See Also

DepthStencilViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilViewDimension


DepthStencilViewDimension Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewDimension Enumeration
See Also Send Feedback
Specifies how to access a resource used in a depth-stencil view.

(Also see DirectX SDK: D3D11_DSV_DIMENSION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DepthStencilViewDimension
Visual Basic
Public Enumeration DepthStencilViewDimension
Visual C++
public enum class DepthStencilViewDimension

Members

Member name | Description
Texture2DMultisampleArray |
Texture2DMultisample |
Texture2DArray |
Texture2D |
Texture1DArray |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilViewOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthStencilViewOptions Enumeration
See Also Send Feedback
Depth-stencil view options.

(Also see DirectX SDK: D3D11_DSV_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum DepthStencilViewOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration DepthStencilViewOptions
Visual C++
[FlagsAttribute]
public enum class DepthStencilViewOptions

Members

Member name | Description
ReadOnlyStencil |
ReadOnlyDepth |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthWriteMask Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DepthWriteMask Enumeration
See Also Send Feedback
Identify the portion of a depth-stencil buffer for writing depth data.

(Also see DirectX SDK: D3D11_DEPTH_WRITE_MASK)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DepthWriteMask
Visual Basic
Public Enumeration DepthWriteMask
Visual C++
public enum class DepthWriteMask

Members

Member name | Description
None |
Enabled |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceChild Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceChild Class
Members See Also Send Feedback
A device-child interface accesses data used by a device.

(Also see DirectX SDK: ID3D11DeviceChild)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DeviceChild : DirectUnknown
Visual Basic
Public Class DeviceChild _
    Inherits DirectUnknown
Visual C++
public ref class DeviceChild : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Asynchronous
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BlendState
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassInstance
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClassLinkage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CommandList
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ComputeShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilState
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceContext
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DomainShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..GeometryShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InputLayout
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PixelShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerState
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerState
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..View

See Also

DeviceChild Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceChild Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceChild Members
DeviceChild Class Properties See Also Send Feedback

The DeviceChild type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DeviceChild Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceChild Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceChild Properties
DeviceChild Class See Also Send Feedback

The DeviceChild type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DeviceChild Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Device Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceChild..::..Device Property
DeviceChild Class See Also Send Feedback
Get the device that created this object.

(Also see DirectX SDK: ID3D11DeviceChild::GetDevice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DDevice Device { get; }
Visual Basic
Public ReadOnly Property Device As D3DDevice
    Get
Visual C++
public:
property D3DDevice^ Device {
    D3DDevice^ get ();
}

See Also

DeviceChild Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceContext Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext Class
Members See Also Send Feedback
The DeviceContext interface represents a device context which generates rendering commands.

(Also see DirectX SDK: ID3D11DeviceContext)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DeviceContext : DeviceChild
Visual Basic
Public Class DeviceContext _
    Inherits DeviceChild
Visual C++
public ref class DeviceContext : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceContext

See Also

DeviceContext Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceContext Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext Members
DeviceContext Class Methods Properties See Also Send Feedback

The DeviceContext type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Mark the beginning of a series of commands. (Also see DirectX SDK: ID3D11DeviceContext::Begin)
Public method | ClearDepthStencilView | Clears the depth-stencil resource. (Also see DirectX SDK: ID3D11DeviceContext::ClearDepthStencilView)
Public method | ClearRenderTargetView | Set all the elements in a render target to one value. (Also see DirectX SDK: ID3D11DeviceContext::ClearRenderTargetView)
Public method | ClearState | Restore all default settings. (Also see DirectX SDK: ID3D11DeviceContext::ClearState)
Public method | ClearUnorderedAccessViewFloat | Clears an unordered access resource with a float value. (Also see DirectX SDK: ID3D11DeviceContext::ClearUnorderedAccessViewFloat)
Public method | ClearUnorderedAccessViewUInt32 | Clears an unordered access resource with bit-precise values. (Also see DirectX SDK: ID3D11DeviceContext::ClearUnorderedAccessViewUint)
Public method | CopyResource | Copy the entire contents of the source resource to the destination resource using the GPU. (Also see DirectX SDK: ID3D11DeviceContext::CopyResource)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32) | Copy a region from a source resource to a destination resource. Because the source box is not defined by this function, the entire source subresource is copied. (Also see DirectX SDK: ID3D11DeviceContext::CopySubresourceRegion)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box) | Copy a region from a source resource to a destination resource. (Also see DirectX SDK: ID3D11DeviceContext::CopySubresourceRegion)
Public method | Dispatch | Execute a command list from a thread group. (Also see DirectX SDK: ID3D11DeviceContext::Dispatch)
Public method | DispatchIndirect | Execute a command list to draw GPU-generated primitives over one of more thread groups. (Also see DirectX SDK: ID3D11DeviceContext::DispatchIndirect)
Public method | Draw | Draw non-indexed, non-instanced primitives. (Also see DirectX SDK: ID3D11DeviceContext::Draw)
Public method | DrawAuto | Draw geometry of an unknown size. (Also see DirectX SDK: ID3D11DeviceContext::DrawAuto)
Public method | DrawIndexed | Draw indexed, non-instanced primitives. (Also see DirectX SDK: ID3D11DeviceContext::DrawIndexed)
Public method | DrawIndexedInstanced | Draw indexed, instanced primitives. (Also see DirectX SDK: ID3D11DeviceContext::DrawIndexedInstanced)
Public method | DrawIndexedInstancedIndirect | Draw indexed, instanced, GPU-generated primitives. (Also see DirectX SDK: ID3D11DeviceContext::DrawIndexedInstancedIndirect)
Public method | DrawInstanced | Draw non-indexed, instanced primitives. (Also see DirectX SDK: ID3D11DeviceContext::DrawInstanced)
Public method | DrawInstancedIndirect | Draw instances, GPU-generated primitives (Also see DirectX SDK: ID3D11DeviceContext::DrawInstancedIndirect)
Public method | End | Mark the end of a series of commands. (Also see DirectX SDK: ID3D11DeviceContext::End)
Public method | ExecuteCommandList | Queues commands from a command list onto a device. (Also see DirectX SDK: ID3D11DeviceContext::ExecuteCommandList)
Public method | FinishCommandList | Create a command list and record graphics commands into it. (Also see DirectX SDK: ID3D11DeviceContext::FinishCommandList)
Public method | Flush | Send queued-up commands in the command buffer to the GPU. (Also see DirectX SDK: ID3D11DeviceContext::Flush)
Public method | GenerateMips | Generate mipmaps for the given shader resource. (Also see DirectX SDK: ID3D11DeviceContext::GenerateMips)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D11DeviceContext::GetData)
Public method | GetResourceMinimumLevelOfDetail | Gets the minimum level-of-detail (LOD). (Also see DirectX SDK: ID3D11DeviceContext::GetResourceMinLOD)
Public method | Map | Get the data contained in a subresource, and deny the GPU access to that subresource. (Also see DirectX SDK: ID3D11DeviceContext::Map)
Public method | ResolveSubresource | Copy a multisampled resource into a non-multisampled resource. (Also see DirectX SDK: ID3D11DeviceContext::ResolveSubresource)
Public method | SetPredication | Set a rendering predicate. (Also see DirectX SDK: ID3D11DeviceContext::SetPredication)
Public method | SetResourceMinimumLevelOfDetail | Sets the minimum level-of-detail (LOD). (Also see DirectX SDK: ID3D11DeviceContext::SetResourceMinLOD)
Public method | Unmap | Invalidate the resource and re-enable the GPU's access to that resource. (Also see DirectX SDK: ID3D11DeviceContext::Unmap)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32) | The CPU copies data from memory to a subresource created in non-mappable memory. A destination box is not defined by this method, so the data is written to the destination subresource with no offset. (Also see DirectX SDK: ID3D11DeviceContext::UpdateSubresource)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32, Box) | The CPU copies data from memory to a subresource created in non-mappable memory. (Also see DirectX SDK: ID3D11DeviceContext::UpdateSubresource)

Properties

 | Name | Description
Public property | ContextOptions | Gets the initialization flags associated with the current deferred context. (Also see DirectX SDK: ID3D11DeviceContext::GetContextFlags)
Public property | CS | Get the associated compute shader pipelines tage object.
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | DeviceContextType | Gets the type of device context. (Also see DirectX SDK: ID3D11DeviceContext::GetType)
Public property | DS | Get the associated domain shader pipeline stage object.
Public property | GS | Get the associated geometry shader pipeline stage object.
Public property | HS | Get the associated hull shader pipeline stage object.
Public property | IA | Get the associated input assembler pipeline stage object.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | OM | Get the associated output merger pipeline stage object.
Public property | Predication | Get the rendering predicate state. (Also see DirectX SDK: ID3D11DeviceContext::GetPredication)
Public property | PS | Get the associated pixel shader pipeline stage object.
Public property | RS | Get the associated rasterizer pipeline stage object.
Public property | SO | Get the associated stream output pipeline stage object.
Public property | VS | Get the associated vertex shader pipeline stage object.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceContext Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext Methods
DeviceContext Class See Also Send Feedback

The DeviceContext type exposes the following members.

Methods

 | Name | Description
Public method | Begin | Mark the beginning of a series of commands. (Also see DirectX SDK: ID3D11DeviceContext::Begin)
Public method | ClearDepthStencilView | Clears the depth-stencil resource. (Also see DirectX SDK: ID3D11DeviceContext::ClearDepthStencilView)
Public method | ClearRenderTargetView | Set all the elements in a render target to one value. (Also see DirectX SDK: ID3D11DeviceContext::ClearRenderTargetView)
Public method | ClearState | Restore all default settings. (Also see DirectX SDK: ID3D11DeviceContext::ClearState)
Public method | ClearUnorderedAccessViewFloat | Clears an unordered access resource with a float value. (Also see DirectX SDK: ID3D11DeviceContext::ClearUnorderedAccessViewFloat)
Public method | ClearUnorderedAccessViewUInt32 | Clears an unordered access resource with bit-precise values. (Also see DirectX SDK: ID3D11DeviceContext::ClearUnorderedAccessViewUint)
Public method | CopyResource | Copy the entire contents of the source resource to the destination resource using the GPU. (Also see DirectX SDK: ID3D11DeviceContext::CopyResource)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32) | Copy a region from a source resource to a destination resource. Because the source box is not defined by this function, the entire source subresource is copied. (Also see DirectX SDK: ID3D11DeviceContext::CopySubresourceRegion)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box) | Copy a region from a source resource to a destination resource. (Also see DirectX SDK: ID3D11DeviceContext::CopySubresourceRegion)
Public method | Dispatch | Execute a command list from a thread group. (Also see DirectX SDK: ID3D11DeviceContext::Dispatch)
Public method | DispatchIndirect | Execute a command list to draw GPU-generated primitives over one of more thread groups. (Also see DirectX SDK: ID3D11DeviceContext::DispatchIndirect)
Public method | Draw | Draw non-indexed, non-instanced primitives. (Also see DirectX SDK: ID3D11DeviceContext::Draw)
Public method | DrawAuto | Draw geometry of an unknown size. (Also see DirectX SDK: ID3D11DeviceContext::DrawAuto)
Public method | DrawIndexed | Draw indexed, non-instanced primitives. (Also see DirectX SDK: ID3D11DeviceContext::DrawIndexed)
Public method | DrawIndexedInstanced | Draw indexed, instanced primitives. (Also see DirectX SDK: ID3D11DeviceContext::DrawIndexedInstanced)
Public method | DrawIndexedInstancedIndirect | Draw indexed, instanced, GPU-generated primitives. (Also see DirectX SDK: ID3D11DeviceContext::DrawIndexedInstancedIndirect)
Public method | DrawInstanced | Draw non-indexed, instanced primitives. (Also see DirectX SDK: ID3D11DeviceContext::DrawInstanced)
Public method | DrawInstancedIndirect | Draw instances, GPU-generated primitives (Also see DirectX SDK: ID3D11DeviceContext::DrawInstancedIndirect)
Public method | End | Mark the end of a series of commands. (Also see DirectX SDK: ID3D11DeviceContext::End)
Public method | ExecuteCommandList | Queues commands from a command list onto a device. (Also see DirectX SDK: ID3D11DeviceContext::ExecuteCommandList)
Public method | FinishCommandList | Create a command list and record graphics commands into it. (Also see DirectX SDK: ID3D11DeviceContext::FinishCommandList)
Public method | Flush | Send queued-up commands in the command buffer to the GPU. (Also see DirectX SDK: ID3D11DeviceContext::Flush)
Public method | GenerateMips | Generate mipmaps for the given shader resource. (Also see DirectX SDK: ID3D11DeviceContext::GenerateMips)
Public method | GetData | Get data from the GPU asynchronously. (Also see DirectX SDK: ID3D11DeviceContext::GetData)
Public method | GetResourceMinimumLevelOfDetail | Gets the minimum level-of-detail (LOD). (Also see DirectX SDK: ID3D11DeviceContext::GetResourceMinLOD)
Public method | Map | Get the data contained in a subresource, and deny the GPU access to that subresource. (Also see DirectX SDK: ID3D11DeviceContext::Map)
Public method | ResolveSubresource | Copy a multisampled resource into a non-multisampled resource. (Also see DirectX SDK: ID3D11DeviceContext::ResolveSubresource)
Public method | SetPredication | Set a rendering predicate. (Also see DirectX SDK: ID3D11DeviceContext::SetPredication)
Public method | SetResourceMinimumLevelOfDetail | Sets the minimum level-of-detail (LOD). (Also see DirectX SDK: ID3D11DeviceContext::SetResourceMinLOD)
Public method | Unmap | Invalidate the resource and re-enable the GPU's access to that resource. (Also see DirectX SDK: ID3D11DeviceContext::Unmap)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32) | The CPU copies data from memory to a subresource created in non-mappable memory. A destination box is not defined by this method, so the data is written to the destination subresource with no offset. (Also see DirectX SDK: ID3D11DeviceContext::UpdateSubresource)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32, Box) | The CPU copies data from memory to a subresource created in non-mappable memory. (Also see DirectX SDK: ID3D11DeviceContext::UpdateSubresource)

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Begin Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..Begin Method
DeviceContext Class See Also Send Feedback
Mark the beginning of a series of commands.

(Also see DirectX SDK: ID3D11DeviceContext::Begin)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Begin(
    Asynchronous asyncData
)
Visual Basic
Public Sub Begin ( _
    asyncData As Asynchronous _
)
Visual C++
public:
void Begin(
    Asynchronous^ asyncData
)

Parameters

asyncData
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Asynchronous
A Asynchronous object.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClearDepthStencilView Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..ClearDepthStencilView Method
DeviceContext Class See Also Send Feedback
Clears the depth-stencil resource.

(Also see DirectX SDK: ID3D11DeviceContext::ClearDepthStencilView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearDepthStencilView(
    DepthStencilView depthStencilView,
    ClearOptions clearOptions,
    float depth,
    byte stencil
)
Visual Basic
Public Sub ClearDepthStencilView ( _
    depthStencilView As DepthStencilView, _
    clearOptions As ClearOptions, _
    depth As Single, _
    stencil As Byte _
)
Visual C++
public:
void ClearDepthStencilView(
    DepthStencilView^ depthStencilView,
    ClearOptions clearOptions,
    float depth,
    unsigned char stencil
)

Parameters

depthStencilView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilView
Pointer to the depth stencil to be cleared.
clearOptions
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClearOptions
Identify the type of data to clear (see ClearOptions).
depth
Type: System..::..Single
Clear the depth buffer with this value. This value will be clamped between 0 and 1.
stencil
Type: System..::..Byte
Clear the stencil buffer with this value.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ClearOptions


ClearRenderTargetView Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..ClearRenderTargetView Method
DeviceContext Class See Also Send Feedback
Set all the elements in a render target to one value.

(Also see DirectX SDK: ID3D11DeviceContext::ClearRenderTargetView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearRenderTargetView(
    RenderTargetView renderTargetView,
    ColorRgba colorRgba
)
Visual Basic
Public Sub ClearRenderTargetView ( _
    renderTargetView As RenderTargetView, _
    colorRgba As ColorRgba _
)
Visual C++
public:
void ClearRenderTargetView(
    RenderTargetView^ renderTargetView,
    ColorRgba colorRgba
)

Parameters

renderTargetView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetView
Pointer to the rendertarget.
colorRgba
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgba
The color to fill the render target with.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClearState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..ClearState Method
DeviceContext Class See Also Send Feedback
Restore all default settings.

(Also see DirectX SDK: ID3D11DeviceContext::ClearState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearState()
Visual Basic
Public Sub ClearState
Visual C++
public:
void ClearState()

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClearUnorderedAccessViewFloat Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..ClearUnorderedAccessViewFloat Method
DeviceContext Class See Also Send Feedback
Clears an unordered access resource with a float value.

(Also see DirectX SDK: ID3D11DeviceContext::ClearUnorderedAccessViewFloat)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearUnorderedAccessViewFloat(
    UnorderedAccessView unorderedAccessView,
    float[] values
)
Visual Basic
Public Sub ClearUnorderedAccessViewFloat ( _
    unorderedAccessView As UnorderedAccessView, _
    values As Single() _
)
Visual C++
public:
void ClearUnorderedAccessViewFloat(
    UnorderedAccessView^ unorderedAccessView,
    array<float>^ values
)

Parameters

unorderedAccessView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..UnorderedAccessView
Pointer to the Unordered Access View.
values
Type: array< System..::..Single >[]()[][]
A 4-component array that contains the values.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ClearUnorderedAccessViewUInt32 Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..ClearUnorderedAccessViewUInt32 Method
DeviceContext Class See Also Send Feedback
Clears an unordered access resource with bit-precise values.

(Also see DirectX SDK: ID3D11DeviceContext::ClearUnorderedAccessViewUint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearUnorderedAccessViewUInt32(
    UnorderedAccessView unorderedAccessView,
    uint[] values
)
Visual Basic
Public Sub ClearUnorderedAccessViewUInt32 ( _
    unorderedAccessView As UnorderedAccessView, _
    values As UInteger() _
)
Visual C++
public:
void ClearUnorderedAccessViewUInt32(
    UnorderedAccessView^ unorderedAccessView,
    array<unsigned int>^ values
)

Parameters

unorderedAccessView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..UnorderedAccessView
Pointer to the Unordered Access View.
values
Type: array< System..::..UInt32 >[]()[][]
A 4-component array that contains the values.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CopyResource Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..CopyResource Method
DeviceContext Class See Also Send Feedback
Copy the entire contents of the source resource to the destination resource using the GPU.

(Also see DirectX SDK: ID3D11DeviceContext::CopyResource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopyResource(
    D3DResource destinationResource,
    D3DResource sourceResource
)
Visual Basic
Public Sub CopyResource ( _
    destinationResource As D3DResource, _
    sourceResource As D3DResource _
)
Visual C++
public:
void CopyResource(
    D3DResource^ destinationResource,
    D3DResource^ sourceResource
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The destination resource (see D3DResource).
sourceResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The source resource (see D3DResource).

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource


CopySubresourceRegion Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..CopySubresourceRegion Method
DeviceContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32) | Copy a region from a source resource to a destination resource. Because the source box is not defined by this function, the entire source subresource is copied. (Also see DirectX SDK: ID3D11DeviceContext::CopySubresourceRegion)
Public method | CopySubresourceRegion(D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box) | Copy a region from a source resource to a destination resource. (Also see DirectX SDK: ID3D11DeviceContext::CopySubresourceRegion)

See Also

DeviceContext Class
DeviceContext Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CopySubresourceRegion Method (D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..CopySubresourceRegion Method (D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32)
DeviceContext Class See Also Send Feedback
Copy a region from a source resource to a destination resource. Because the source box is not defined by this function, the entire source subresource is copied.

(Also see DirectX SDK: ID3D11DeviceContext::CopySubresourceRegion)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopySubresourceRegion(
    D3DResource destinationResource,
    uint destinationSubresource,
    uint destinationX,
    uint destinationY,
    uint destinationZ,
    D3DResource sourceResource,
    uint sourceSubresource
)
Visual Basic
Public Sub CopySubresourceRegion ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    destinationX As UInteger, _
    destinationY As UInteger, _
    destinationZ As UInteger, _
    sourceResource As D3DResource, _
    sourceSubresource As UInteger _
)
Visual C++
public:
void CopySubresourceRegion(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    unsigned int destinationX,
    unsigned int destinationY,
    unsigned int destinationZ,
    D3DResource^ sourceResource,
    unsigned int sourceSubresource
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The destination resource (see D3DResource).
destinationSubresource
Type: System..::..UInt32
Destination subresource index.
destinationX
Type: System..::..UInt32
The x offset between the source box location and the destination location.
destinationY
Type: System..::..UInt32
The y offset between the source box location and the destination location. For a 1D subresource, this must be zero.
destinationZ
Type: System..::..UInt32
The z offset between the source box location and the destination location. For a 1D or 2D subresource, this must be zero.
sourceResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The source resource (see D3DResource).
sourceSubresource
Type: System..::..UInt32
Source subresource index.

See Also

DeviceContext Class
CopySubresourceRegion Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource


CopySubresourceRegion Method (D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..CopySubresourceRegion Method (D3DResource, UInt32, UInt32, UInt32, UInt32, D3DResource, UInt32, Box)
DeviceContext Class See Also Send Feedback
Copy a region from a source resource to a destination resource.

(Also see DirectX SDK: ID3D11DeviceContext::CopySubresourceRegion)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void CopySubresourceRegion(
    D3DResource destinationResource,
    uint destinationSubresource,
    uint destinationX,
    uint destinationY,
    uint destinationZ,
    D3DResource sourceResource,
    uint sourceSubresource,
    Box sourceBox
)
Visual Basic
Public Sub CopySubresourceRegion ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    destinationX As UInteger, _
    destinationY As UInteger, _
    destinationZ As UInteger, _
    sourceResource As D3DResource, _
    sourceSubresource As UInteger, _
    sourceBox As Box _
)
Visual C++
public:
void CopySubresourceRegion(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    unsigned int destinationX,
    unsigned int destinationY,
    unsigned int destinationZ,
    D3DResource^ sourceResource,
    unsigned int sourceSubresource,
    Box sourceBox
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The destination resource (see D3DResource).
destinationSubresource
Type: System..::..UInt32
Destination subresource index.
destinationX
Type: System..::..UInt32
The x offset between the source box location and the destination location.
destinationY
Type: System..::..UInt32
The y offset between the source box location and the destination location. For a 1D subresource, this must be zero.
destinationZ
Type: System..::..UInt32
The z offset between the source box location and the destination location. For a 1D or 2D subresource, this must be zero.
sourceResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The source resource (see D3DResource).
sourceSubresource
Type: System..::..UInt32
Source subresource index.
sourceBox
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Box
A 3D box (see Box) that defines the source subresources that can be copied. The box must fit within the source resource.

See Also

DeviceContext Class
CopySubresourceRegion Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Box


Dispatch Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..Dispatch Method
DeviceContext Class See Also Send Feedback
Execute a command list from a thread group.

(Also see DirectX SDK: ID3D11DeviceContext::Dispatch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Dispatch(
    uint threadGroupCountX,
    uint threadGroupCountY,
    uint threadGroupCountZ
)
Visual Basic
Public Sub Dispatch ( _
    threadGroupCountX As UInteger, _
    threadGroupCountY As UInteger, _
    threadGroupCountZ As UInteger _
)
Visual C++
public:
void Dispatch(
    unsigned int threadGroupCountX,
    unsigned int threadGroupCountY,
    unsigned int threadGroupCountZ
)

Parameters

threadGroupCountX
Type: System..::..UInt32
The index of the thread in the x direction.
threadGroupCountY
Type: System..::..UInt32
The index of the thread in the y direction.
threadGroupCountZ
Type: System..::..UInt32
The index of the thread in the z direction.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DispatchIndirect Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..DispatchIndirect Method
DeviceContext Class See Also Send Feedback
Execute a command list to draw GPU-generated primitives over one of more thread groups.

(Also see DirectX SDK: ID3D11DeviceContext::DispatchIndirect)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DispatchIndirect(
    D3DBuffer bufferForArgs,
    uint alignedOffsetForArgs
)
Visual Basic
Public Sub DispatchIndirect ( _
    bufferForArgs As D3DBuffer, _
    alignedOffsetForArgs As UInteger _
)
Visual C++
public:
void DispatchIndirect(
    D3DBuffer^ bufferForArgs,
    unsigned int alignedOffsetForArgs
)

Parameters

bufferForArgs
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer
A D3DBuffer, which must be loaded with data that matches the argument list for DeviceContext.Dispatch.
alignedOffsetForArgs
Type: System..::..UInt32
A byte-aligned offset between the start of the buffer and the arguments.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Draw Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..Draw Method
DeviceContext Class See Also Send Feedback
Draw non-indexed, non-instanced primitives.

(Also see DirectX SDK: ID3D11DeviceContext::Draw)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Draw(
    uint vertexCount,
    uint startVertexLocation
)
Visual Basic
Public Sub Draw ( _
    vertexCount As UInteger, _
    startVertexLocation As UInteger _
)
Visual C++
public:
void Draw(
    unsigned int vertexCount,
    unsigned int startVertexLocation
)

Parameters

vertexCount
Type: System..::..UInt32
Number of vertices to draw.
startVertexLocation
Type: System..::..UInt32
Index of the first vertex, which is usually an offset in a vertex buffer; it could also be used as the first vertex id generated for a shader parameter marked with the SV_TargetId system-value semantic.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DrawAuto Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..DrawAuto Method
DeviceContext Class See Also Send Feedback
Draw geometry of an unknown size.

(Also see DirectX SDK: ID3D11DeviceContext::DrawAuto)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawAuto()
Visual Basic
Public Sub DrawAuto
Visual C++
public:
void DrawAuto()

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DrawIndexed Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..DrawIndexed Method
DeviceContext Class See Also Send Feedback
Draw indexed, non-instanced primitives.

(Also see DirectX SDK: ID3D11DeviceContext::DrawIndexed)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawIndexed(
    uint indexCount,
    uint startIndexLocation,
    int baseVertexLocation
)
Visual Basic
Public Sub DrawIndexed ( _
    indexCount As UInteger, _
    startIndexLocation As UInteger, _
    baseVertexLocation As Integer _
)
Visual C++
public:
void DrawIndexed(
    unsigned int indexCount,
    unsigned int startIndexLocation,
    int baseVertexLocation
)

Parameters

indexCount
Type: System..::..UInt32
Number of indices to draw.
startIndexLocation
Type: System..::..UInt32
The location of the first index read by the GPU from the index buffer.
baseVertexLocation
Type: System..::..Int32
A value added to each index before reading a vertex from the vertex buffer.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DrawIndexedInstanced Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..DrawIndexedInstanced Method
DeviceContext Class See Also Send Feedback
Draw indexed, instanced primitives.

(Also see DirectX SDK: ID3D11DeviceContext::DrawIndexedInstanced)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawIndexedInstanced(
    uint indexCountPerInstance,
    uint instanceCount,
    uint startIndexLocation,
    int baseVertexLocation,
    uint startInstanceLocation
)
Visual Basic
Public Sub DrawIndexedInstanced ( _
    indexCountPerInstance As UInteger, _
    instanceCount As UInteger, _
    startIndexLocation As UInteger, _
    baseVertexLocation As Integer, _
    startInstanceLocation As UInteger _
)
Visual C++
public:
void DrawIndexedInstanced(
    unsigned int indexCountPerInstance,
    unsigned int instanceCount,
    unsigned int startIndexLocation,
    int baseVertexLocation,
    unsigned int startInstanceLocation
)

Parameters

indexCountPerInstance
Type: System..::..UInt32
Number of indices read from the index buffer for each instance.
instanceCount
Type: System..::..UInt32
Number of instances to draw.
startIndexLocation
Type: System..::..UInt32
The location of the first index read by the GPU from the index buffer.
baseVertexLocation
Type: System..::..Int32
A value added to each index before reading a vertex from the vertex buffer.
startInstanceLocation
Type: System..::..UInt32
A value added to each index before reading per-instance data from a vertex buffer.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DrawIndexedInstancedIndirect Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..DrawIndexedInstancedIndirect Method
DeviceContext Class See Also Send Feedback
Draw indexed, instanced, GPU-generated primitives.

(Also see DirectX SDK: ID3D11DeviceContext::DrawIndexedInstancedIndirect)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawIndexedInstancedIndirect(
    D3DBuffer bufferForArgs,
    uint offset
)
Visual Basic
Public Sub DrawIndexedInstancedIndirect ( _
    bufferForArgs As D3DBuffer, _
    offset As UInteger _
)
Visual C++
public:
void DrawIndexedInstancedIndirect(
    D3DBuffer^ bufferForArgs,
    unsigned int offset
)

Parameters

bufferForArgs
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer
A pointer to a D3DBuffer, which is a buffer containing the GPU generated primitives.
offset
Type: System..::..UInt32
Offset into bufferForArgs to the start of the GPU-generated primitives

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DrawInstanced Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..DrawInstanced Method
DeviceContext Class See Also Send Feedback
Draw non-indexed, instanced primitives.

(Also see DirectX SDK: ID3D11DeviceContext::DrawInstanced)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawInstanced(
    uint vertexCountPerInstance,
    uint instanceCount,
    uint startVertexLocation,
    uint startInstanceLocation
)
Visual Basic
Public Sub DrawInstanced ( _
    vertexCountPerInstance As UInteger, _
    instanceCount As UInteger, _
    startVertexLocation As UInteger, _
    startInstanceLocation As UInteger _
)
Visual C++
public:
void DrawInstanced(
    unsigned int vertexCountPerInstance,
    unsigned int instanceCount,
    unsigned int startVertexLocation,
    unsigned int startInstanceLocation
)

Parameters

vertexCountPerInstance
Type: System..::..UInt32
Number of vertices to draw.
instanceCount
Type: System..::..UInt32
Number of instances to draw.
startVertexLocation
Type: System..::..UInt32
Index of the first vertex.
startInstanceLocation
Type: System..::..UInt32
A value added to each index before reading per-instance data from a vertex buffer.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DrawInstancedIndirect Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..DrawInstancedIndirect Method
DeviceContext Class See Also Send Feedback
Draw instances, GPU-generated primitives

(Also see DirectX SDK: ID3D11DeviceContext::DrawInstancedIndirect)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void DrawInstancedIndirect(
    D3DBuffer bufferForArgs,
    uint offset
)
Visual Basic
Public Sub DrawInstancedIndirect ( _
    bufferForArgs As D3DBuffer, _
    offset As UInteger _
)
Visual C++
public:
void DrawInstancedIndirect(
    D3DBuffer^ bufferForArgs,
    unsigned int offset
)

Parameters

bufferForArgs
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer
A pointer to a D3DBuffer, which is a buffer containing the GPU-generated primitives
offset
Type: System..::..UInt32
Offset in bufferForArgs to the start of the GPU-generated primitives

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


End Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..End Method
DeviceContext Class See Also Send Feedback
Mark the end of a series of commands.

(Also see DirectX SDK: ID3D11DeviceContext::End)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void End(
    Asynchronous async
)
Visual Basic
Public Sub End ( _
    async As Asynchronous _
)
Visual C++
public:
void End(
    Asynchronous^ async
)

Parameters

async
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Asynchronous
An Asynchronous object.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExecuteCommandList Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..ExecuteCommandList Method
DeviceContext Class See Also Send Feedback
Queues commands from a command list onto a device.

(Also see DirectX SDK: ID3D11DeviceContext::ExecuteCommandList)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ExecuteCommandList(
    CommandList commandList,
    bool restoreContextState
)
Visual Basic
Public Sub ExecuteCommandList ( _
    commandList As CommandList, _
    restoreContextState As Boolean _
)
Visual C++
public:
void ExecuteCommandList(
    CommandList^ commandList,
    bool restoreContextState
)

Parameters

commandList
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..CommandList
A CommandList interface that encapsulates a command list.
restoreContextState
Type: System..::..Boolean
A Boolean flag that determines whether the immediate context state is saved (prior) and restored (after) the execution of a command list. Use TRUE to indicate that the runtime needs to save and restore the state, which will cause lower performance. Use FALSE to indicate that no state shall be saved or restored, which causes the immediate context to return to its default state after the command list executes.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FinishCommandList Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..FinishCommandList Method
DeviceContext Class See Also Send Feedback
Create a command list and record graphics commands into it.

(Also see DirectX SDK: ID3D11DeviceContext::FinishCommandList)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CommandList FinishCommandList(
    bool restoreDeferredContextState
)
Visual Basic
Public Function FinishCommandList ( _
    restoreDeferredContextState As Boolean _
) As CommandList
Visual C++
public:
CommandList^ FinishCommandList(
    bool restoreDeferredContextState
)

Parameters

restoreDeferredContextState
Type: System..::..Boolean
A Boolean flag that determines whether the immediate context state is saved (prior) and restored (after) the execution of a command list. Use TRUE to indicate that the runtime needs to save and restore the state, which will cause lower performance. Use FALSE to indicate that no state shall be saved or restored, which causes the immediate context to return to its default state after the command list executes.

Return Value

A CommandList instance initialized with the recorded command list information.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Flush Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..Flush Method
DeviceContext Class See Also Send Feedback
Send queued-up commands in the command buffer to the GPU.

(Also see DirectX SDK: ID3D11DeviceContext::Flush)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Flush()
Visual Basic
Public Sub Flush
Visual C++
public:
void Flush()

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GenerateMips Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..GenerateMips Method
DeviceContext Class See Also Send Feedback
Generate mipmaps for the given shader resource.

(Also see DirectX SDK: ID3D11DeviceContext::GenerateMips)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void GenerateMips(
    ShaderResourceView shaderResourceView
)
Visual Basic
Public Sub GenerateMips ( _
    shaderResourceView As ShaderResourceView _
)
Visual C++
public:
void GenerateMips(
    ShaderResourceView^ shaderResourceView
)

Parameters

shaderResourceView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderResourceView
An ShaderResourceView interface that represents the shader resource.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetData Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..GetData Method
DeviceContext Class See Also Send Feedback
Get data from the GPU asynchronously.

(Also see DirectX SDK: ID3D11DeviceContext::GetData)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void GetData(
    Asynchronous asyncData,
    IntPtr data,
    uint dataSize,
    AsyncGetDataOptions options
)
Visual Basic
Public Sub GetData ( _
    asyncData As Asynchronous, _
    data As IntPtr, _
    dataSize As UInteger, _
    options As AsyncGetDataOptions _
)
Visual C++
public:
void GetData(
    Asynchronous^ asyncData,
    IntPtr data,
    unsigned int dataSize,
    AsyncGetDataOptions options
)

Parameters

asyncData
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Asynchronous
A Asynchronous object.
data
Type: System..::..IntPtr
Address of memory that will receive the data. If NULL, GetData will be used only to check status. The type of data output depends on the type of asynchronous object. See Remarks.
dataSize
Type: System..::..UInt32
Size of the data to retrieve or 0. Must be 0 when pData is NULL.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..AsyncGetDataOptions
Optional flags. Can be 0 or any combination of the flags enumerated by AsyncGetDataOptions.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetResourceMinimumLevelOfDetail Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..GetResourceMinimumLevelOfDetail Method
DeviceContext Class See Also Send Feedback
Gets the minimum level-of-detail (LOD).

(Also see DirectX SDK: ID3D11DeviceContext::GetResourceMinLOD)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float GetResourceMinimumLevelOfDetail(
    D3DResource resource
)
Visual Basic
Public Function GetResourceMinimumLevelOfDetail ( _
    resource As D3DResource _
) As Single
Visual C++
public:
float GetResourceMinimumLevelOfDetail(
    D3DResource^ resource
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
A D3DResource which represents the resource.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Map Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..Map Method
DeviceContext Class See Also Send Feedback
Get the data contained in a subresource, and deny the GPU access to that subresource.

(Also see DirectX SDK: ID3D11DeviceContext::Map)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MappedSubresource Map(
    D3DResource resource,
    uint subresource,
    Map mapType,
    MapOptions mapOptions
)
Visual Basic
Public Function Map ( _
    resource As D3DResource, _
    subresource As UInteger, _
    mapType As Map, _
    mapOptions As MapOptions _
) As MappedSubresource
Visual C++
public:
MappedSubresource Map(
    D3DResource^ resource,
    unsigned int subresource,
    Map mapType,
    MapOptions mapOptions
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
A D3DResource object.
subresource
Type: System..::..UInt32
Index number of the subresource.
mapType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Map
Specifies the CPU's read and write permissions for a resource. For possible values, see Map.
mapOptions
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MapOptions
Flag that specifies what the CPU should do when the GPU is busy. This flag is optional.

Return Value

The mapped subresource (see MappedSubresource).

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MappedSubresource


ResolveSubresource Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..ResolveSubresource Method
DeviceContext Class See Also Send Feedback
Copy a multisampled resource into a non-multisampled resource.

(Also see DirectX SDK: ID3D11DeviceContext::ResolveSubresource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ResolveSubresource(
    D3DResource destinationResource,
    uint destinationSubresource,
    D3DResource sourceResource,
    uint sourceSubresource,
    Format format
)
Visual Basic
Public Sub ResolveSubresource ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    sourceResource As D3DResource, _
    sourceSubresource As UInteger, _
    format As Format _
)
Visual C++
public:
void ResolveSubresource(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    D3DResource^ sourceResource,
    unsigned int sourceSubresource,
    Format format
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Destination resource. Must be a created with the Default flag and be single-sampled. See D3DResource.
destinationSubresource
Type: System..::..UInt32
A zero-based index, that identifies the destination subresource. Use D3D11CalcSubresource to calculate the index.
sourceResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Source resource. Must be multisampled.
sourceSubresource
Type: System..::..UInt32
>The source subresource of the source resource.
format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
A Format that indicates how the multisampled resource will be resolved to a single-sampled resource.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetPredication Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..SetPredication Method
DeviceContext Class See Also Send Feedback
Set a rendering predicate.

(Also see DirectX SDK: ID3D11DeviceContext::SetPredication)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetPredication(
    D3DPredicate predicate,
    bool predicateValue
)
Visual Basic
Public Sub SetPredication ( _
    predicate As D3DPredicate, _
    predicateValue As Boolean _
)
Visual C++
public:
void SetPredication(
    D3DPredicate^ predicate,
    bool predicateValue
)

Parameters

predicate
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DPredicate
A predicate (see D3DPredicate). A NULL value indicates "no" predication; in this case, the value of PredicateValue is irrelevent but will be preserved for DeviceContext.GetPredication.
predicateValue
Type: System..::..Boolean
If TRUE, rendering will be affected by when the predicate's conditions are met. If FALSE, rendering will be affected when the conditions are not met.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DPredicate


SetResourceMinimumLevelOfDetail Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..SetResourceMinimumLevelOfDetail Method
DeviceContext Class See Also Send Feedback
Sets the minimum level-of-detail (LOD).

(Also see DirectX SDK: ID3D11DeviceContext::SetResourceMinLOD)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetResourceMinimumLevelOfDetail(
    D3DResource resource,
    float minimum
)
Visual Basic
Public Sub SetResourceMinimumLevelOfDetail ( _
    resource As D3DResource, _
    minimum As Single _
)
Visual C++
public:
void SetResourceMinimumLevelOfDetail(
    D3DResource^ resource,
    float minimum
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
A D3DResource which represents the resource.
minimum
Type: System..::..Single
The level-of-detail, which ranges between 0 and 1.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Unmap Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..Unmap Method
DeviceContext Class See Also Send Feedback
Invalidate the resource and re-enable the GPU's access to that resource.

(Also see DirectX SDK: ID3D11DeviceContext::Unmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Unmap(
    D3DResource resource,
    uint subresource
)
Visual Basic
Public Sub Unmap ( _
    resource As D3DResource, _
    subresource As UInteger _
)
Visual C++
public:
void Unmap(
    D3DResource^ resource,
    unsigned int subresource
)

Parameters

resource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
A D3DResource object.
subresource
Type: System..::..UInt32
A subresource to be unmapped.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UpdateSubresource Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..UpdateSubresource Method
DeviceContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32) | The CPU copies data from memory to a subresource created in non-mappable memory. A destination box is not defined by this method, so the data is written to the destination subresource with no offset. (Also see DirectX SDK: ID3D11DeviceContext::UpdateSubresource)
Public method | UpdateSubresource(D3DResource, UInt32, IntPtr, UInt32, UInt32, Box) | The CPU copies data from memory to a subresource created in non-mappable memory. (Also see DirectX SDK: ID3D11DeviceContext::UpdateSubresource)

See Also

DeviceContext Class
DeviceContext Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UpdateSubresource Method (D3DResource, UInt32, IntPtr, UInt32, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..UpdateSubresource Method (D3DResource, UInt32, IntPtr, UInt32, UInt32)
DeviceContext Class See Also Send Feedback
The CPU copies data from memory to a subresource created in non-mappable memory. A destination box is not defined by this method, so the data is written to the destination subresource with no offset.

(Also see DirectX SDK: ID3D11DeviceContext::UpdateSubresource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void UpdateSubresource(
    D3DResource destinationResource,
    uint destinationSubresource,
    IntPtr sourceData,
    uint sourceRowPitch,
    uint sourceDepthPitch
)
Visual Basic
Public Sub UpdateSubresource ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    sourceData As IntPtr, _
    sourceRowPitch As UInteger, _
    sourceDepthPitch As UInteger _
)
Visual C++
public:
void UpdateSubresource(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    IntPtr sourceData,
    unsigned int sourceRowPitch,
    unsigned int sourceDepthPitch
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The destination resource (see D3DResource).
destinationSubresource
Type: System..::..UInt32
A zero-based index, that identifies the destination subresource. See D3D11CalcSubresource for more details.
sourceData
Type: System..::..IntPtr
The source data in memory.
sourceRowPitch
Type: System..::..UInt32
The size of one row of the source data.
sourceDepthPitch
Type: System..::..UInt32
The size of one depth slice of source data.

See Also

DeviceContext Class
UpdateSubresource Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource


UpdateSubresource Method (D3DResource, UInt32, IntPtr, UInt32, UInt32, Box)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..UpdateSubresource Method (D3DResource, UInt32, IntPtr, UInt32, UInt32, Box)
DeviceContext Class See Also Send Feedback
The CPU copies data from memory to a subresource created in non-mappable memory.

(Also see DirectX SDK: ID3D11DeviceContext::UpdateSubresource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void UpdateSubresource(
    D3DResource destinationResource,
    uint destinationSubresource,
    IntPtr sourceData,
    uint sourceRowPitch,
    uint sourceDepthPitch,
    Box destinationBox
)
Visual Basic
Public Sub UpdateSubresource ( _
    destinationResource As D3DResource, _
    destinationSubresource As UInteger, _
    sourceData As IntPtr, _
    sourceRowPitch As UInteger, _
    sourceDepthPitch As UInteger, _
    destinationBox As Box _
)
Visual C++
public:
void UpdateSubresource(
    D3DResource^ destinationResource,
    unsigned int destinationSubresource,
    IntPtr sourceData,
    unsigned int sourceRowPitch,
    unsigned int sourceDepthPitch,
    Box destinationBox
)

Parameters

destinationResource
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
The destination resource (see D3DResource).
destinationSubresource
Type: System..::..UInt32
A zero-based index, that identifies the destination subresource. See D3D11CalcSubresource for more details.
sourceData
Type: System..::..IntPtr
The source data in memory.
sourceRowPitch
Type: System..::..UInt32
The size of one row of the source data.
sourceDepthPitch
Type: System..::..UInt32
The size of one depth slice of source data.
destinationBox
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Box
A box that defines the portion of the destination subresource to copy the resource data into. Coordinates are in bytes for buffers and in texels for textures. The dimensions of the source must fit the destination (see Box).

See Also

DeviceContext Class
UpdateSubresource Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Box


DeviceContext Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext Properties
DeviceContext Class See Also Send Feedback

The DeviceContext type exposes the following members.

Properties

 | Name | Description
Public property | ContextOptions | Gets the initialization flags associated with the current deferred context. (Also see DirectX SDK: ID3D11DeviceContext::GetContextFlags)
Public property | CS | Get the associated compute shader pipelines tage object.
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | DeviceContextType | Gets the type of device context. (Also see DirectX SDK: ID3D11DeviceContext::GetType)
Public property | DS | Get the associated domain shader pipeline stage object.
Public property | GS | Get the associated geometry shader pipeline stage object.
Public property | HS | Get the associated hull shader pipeline stage object.
Public property | IA | Get the associated input assembler pipeline stage object.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | OM | Get the associated output merger pipeline stage object.
Public property | Predication | Get the rendering predicate state. (Also see DirectX SDK: ID3D11DeviceContext::GetPredication)
Public property | PS | Get the associated pixel shader pipeline stage object.
Public property | RS | Get the associated rasterizer pipeline stage object.
Public property | SO | Get the associated stream output pipeline stage object.
Public property | VS | Get the associated vertex shader pipeline stage object.

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ContextOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..ContextOptions Property
DeviceContext Class See Also Send Feedback
Gets the initialization flags associated with the current deferred context.

(Also see DirectX SDK: ID3D11DeviceContext::GetContextFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ContextOptions { get; }
Visual Basic
Public ReadOnly Property ContextOptions As UInteger
    Get
Visual C++
public:
property unsigned int ContextOptions {
    unsigned int get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..CS Property
DeviceContext Class See Also Send Feedback
Get the associated compute shader pipelines tage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComputeShaderPipelineStage CS { get; }
Visual Basic
Public ReadOnly Property CS As ComputeShaderPipelineStage
    Get
Visual C++
public:
property ComputeShaderPipelineStage^ CS {
    ComputeShaderPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceContextType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..DeviceContextType Property
DeviceContext Class See Also Send Feedback
Gets the type of device context.

(Also see DirectX SDK: ID3D11DeviceContext::GetType)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DeviceContextType DeviceContextType { get; }
Visual Basic
Public ReadOnly Property DeviceContextType As DeviceContextType
    Get
Visual C++
public:
property DeviceContextType DeviceContextType {
    DeviceContextType get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..DS Property
DeviceContext Class See Also Send Feedback
Get the associated domain shader pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DomainShaderPipelineStage DS { get; }
Visual Basic
Public ReadOnly Property DS As DomainShaderPipelineStage
    Get
Visual C++
public:
property DomainShaderPipelineStage^ DS {
    DomainShaderPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..GS Property
DeviceContext Class See Also Send Feedback
Get the associated geometry shader pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShaderPipelineStage GS { get; }
Visual Basic
Public ReadOnly Property GS As GeometryShaderPipelineStage
    Get
Visual C++
public:
property GeometryShaderPipelineStage^ GS {
    GeometryShaderPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


HS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..HS Property
DeviceContext Class See Also Send Feedback
Get the associated hull shader pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HullShaderPipelineStage HS { get; }
Visual Basic
Public ReadOnly Property HS As HullShaderPipelineStage
    Get
Visual C++
public:
property HullShaderPipelineStage^ HS {
    HullShaderPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IA Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..IA Property
DeviceContext Class See Also Send Feedback
Get the associated input assembler pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputAssemblerPipelineStage IA { get; }
Visual Basic
Public ReadOnly Property IA As InputAssemblerPipelineStage
    Get
Visual C++
public:
property InputAssemblerPipelineStage^ IA {
    InputAssemblerPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OM Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..OM Property
DeviceContext Class See Also Send Feedback
Get the associated output merger pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerPipelineStage OM { get; }
Visual Basic
Public ReadOnly Property OM As OutputMergerPipelineStage
    Get
Visual C++
public:
property OutputMergerPipelineStage^ OM {
    OutputMergerPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Predication Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..Predication Property
DeviceContext Class See Also Send Feedback
Get the rendering predicate state.

(Also see DirectX SDK: ID3D11DeviceContext::GetPredication)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DPredicate Predication { get; set; }
Visual Basic
Public Property Predication As D3DPredicate
    Get
    Set
Visual C++
public:
property D3DPredicate^ Predication {
    D3DPredicate^ get ();
    void set (D3DPredicate^ value);
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DPredicate


PS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..PS Property
DeviceContext Class See Also Send Feedback
Get the associated pixel shader pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShaderPipelineStage PS { get; }
Visual Basic
Public ReadOnly Property PS As PixelShaderPipelineStage
    Get
Visual C++
public:
property PixelShaderPipelineStage^ PS {
    PixelShaderPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..RS Property
DeviceContext Class See Also Send Feedback
Get the associated rasterizer pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerPipelineStage RS { get; }
Visual Basic
Public ReadOnly Property RS As RasterizerPipelineStage
    Get
Visual C++
public:
property RasterizerPipelineStage^ RS {
    RasterizerPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SO Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..SO Property
DeviceContext Class See Also Send Feedback
Get the associated stream output pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StreamOutputPipelineStage SO { get; }
Visual Basic
Public ReadOnly Property SO As StreamOutputPipelineStage
    Get
Visual C++
public:
property StreamOutputPipelineStage^ SO {
    StreamOutputPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VS Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContext..::..VS Property
DeviceContext Class See Also Send Feedback
Get the associated vertex shader pipeline stage object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShaderPipelineStage VS { get; }
Visual Basic
Public ReadOnly Property VS As VertexShaderPipelineStage
    Get
Visual C++
public:
property VertexShaderPipelineStage^ VS {
    VertexShaderPipelineStage^ get ();
}

See Also

DeviceContext Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeviceContextType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceContextType Enumeration
See Also Send Feedback
Device context options.

(Also see DirectX SDK: D3D11_DEVICE_CONTEXT_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DeviceContextType
Visual Basic
Public Enumeration DeviceContextType
Visual C++
public enum class DeviceContextType

Members

Member name | Description
Deferred |
Immediate |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DomainShader Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShader Class
Members See Also Send Feedback
A domain-shader class manages an executable program (a domain shader) that controls the domain-shader stage.

(Also see DirectX SDK: ID3D11DomainShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DomainShader : DeviceChild
Visual Basic
Public Class DomainShader _
    Inherits DeviceChild
Visual C++
public ref class DomainShader : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DomainShader

See Also

DomainShader Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DomainShader Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShader Members
DomainShader Class Properties See Also Send Feedback

The DomainShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DomainShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DomainShader Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShader Properties
DomainShader Class See Also Send Feedback

The DomainShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DomainShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DomainShaderPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage Class
Members See Also Send Feedback
Domain Shader pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DomainShaderPipelineStage : PipelineStage
Visual Basic
Public Class DomainShaderPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class DomainShaderPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DomainShaderPipelineStage

See Also

DomainShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DomainShaderPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage Members
DomainShaderPipelineStage Class Constructors Methods Properties See Also Send Feedback

The DomainShaderPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | DomainShaderPipelineStage |

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the domain-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::DSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the domain-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::DSGetSamplers)
Public method | GetShaderAndClasses | Get the domain shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::DSGetShader)
Public method | GetShaderResources | Get the domain-shader resources. (Also see DirectX SDK: ID3D11DeviceContext::DSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(DomainShader>)>>)) |
Public method | SetShader(DomainShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Get the domain shader currently set on the device. (See DomainShader) (Also see DirectX SDK: ID3D11DeviceContext::DSGetShader, ID3D11DeviceContext::DSSetShader) Passing in null disables the shader for this pipeline stage.

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DomainShaderPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage Constructor
DomainShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected DomainShaderPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
DomainShaderPipelineStage()

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DomainShaderPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage Methods
DomainShaderPipelineStage Class See Also Send Feedback

The DomainShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the domain-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::DSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the domain-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::DSGetSamplers)
Public method | GetShaderAndClasses | Get the domain shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::DSGetShader)
Public method | GetShaderResources | Get the domain-shader resources. (Also see DirectX SDK: ID3D11DeviceContext::DSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(DomainShader>)>>)) |
Public method | SetShader(DomainShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..GetConstantBuffers Method
DomainShaderPipelineStage Class See Also Send Feedback
Get the constant buffers used by the domain-shader stage.

(Also see DirectX SDK: ID3D11DeviceContext::DSGetConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetConstantBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetConstantBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetConstantBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin retrieving constant buffers from (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - 1).
bufferCount
Type: System..::..UInt32
Number of buffers to retrieve (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - startSlot).

Return Value

Collection of constant buffer objects (see D3DBuffer) to be returned by the method.

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


GetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..GetSamplers Method
DomainShaderPipelineStage Class See Also Send Feedback
Get an array of sampler state objects from the domain-shader stage.

(Also see DirectX SDK: ID3D11DeviceContext::DSGetSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<SamplerState> GetSamplers(
    uint startSlot,
    uint samplerCount
)
Visual Basic
Public Function GetSamplers ( _
    startSlot As UInteger, _
    samplerCount As UInteger _
) As ReadOnlyCollection(Of SamplerState)
Visual C++
public:
ReadOnlyCollection<SamplerState^>^ GetSamplers(
    unsigned int startSlot,
    unsigned int samplerCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into a zero-based array to begin getting samplers from (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - 1).
samplerCount
Type: System..::..UInt32
Number of samplers to get from a device context. Each pipeline stage has a total of 16 sampler slots available (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - startSlot).

Return Value

A collection of sampler-state objects (see SamplerState).

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerState


GetShaderAndClasses Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..GetShaderAndClasses Method
DomainShaderPipelineStage Class See Also Send Feedback
Get the domain shader currently set on the device.

(Also see DirectX SDK: ID3D11DeviceContext::DSGetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderAndClasses<DomainShader> GetShaderAndClasses(
    uint classInstanceCount
)
Visual Basic
Public Function GetShaderAndClasses ( _
    classInstanceCount As UInteger _
) As ShaderAndClasses(Of DomainShader)
Visual C++
public:
ShaderAndClasses<DomainShader^> GetShaderAndClasses(
    unsigned int classInstanceCount
)

Parameters

classInstanceCount
Type: System..::..UInt32
The number of class-instance elements requested.

Return Value

A DomainShader object and its classes (see DomainShader, ShaderAndClasses<(Of <(<'T>)>)>) , .

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DomainShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses<(Of <(<'T>)>)>


GetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..GetShaderResources Method
DomainShaderPipelineStage Class See Also Send Feedback
Get the domain-shader resources.

(Also see DirectX SDK: ID3D11DeviceContext::DSGetShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetShaderResources(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetShaderResources ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetShaderResources(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin getting shader resources from (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - 1).
viewCount
Type: System..::..UInt32
The number of resources to get from the device. Up to a maximum of 128 slots are available for shader resources (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - startSlot).

Return Value

A collection of shader resource view objects to be returned by the device.

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..SetConstantBuffers Method
DomainShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetConstantBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> constantBuffers
)
Visual Basic
Public Sub SetConstantBuffers ( _
    startSlot As UInteger, _
    constantBuffers As IEnumerable(Of D3DBuffer) _
)
Visual C++
public:
void SetConstantBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ constantBuffers
)

Parameters

startSlot
Type: System..::..UInt32
constantBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..SetSamplers Method
DomainShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSamplers(
    uint startSlot,
    IEnumerable<SamplerState> samplers
)
Visual Basic
Public Sub SetSamplers ( _
    startSlot As UInteger, _
    samplers As IEnumerable(Of SamplerState) _
)
Visual C++
public:
void SetSamplers(
    unsigned int startSlot,
    IEnumerable<SamplerState^>^ samplers
)

Parameters

startSlot
Type: System..::..UInt32
samplers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SamplerState >)>)>

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..SetShader Method
DomainShaderPipelineStage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetShader(ShaderAndClasses<(Of <<'(DomainShader>)>>)) |
Public method | SetShader(DomainShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |

See Also

DomainShaderPipelineStage Class
DomainShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (ShaderAndClasses(DomainShader))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..SetShader Method (ShaderAndClasses<(Of <(<'DomainShader>)>)>)
DomainShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    ShaderAndClasses<DomainShader> shaderAndClasses
)
Visual Basic
Public Sub SetShader ( _
    shaderAndClasses As ShaderAndClasses(Of DomainShader) _
)
Visual C++
public:
void SetShader(
    ShaderAndClasses<DomainShader^> shaderAndClasses
)

Parameters

shaderAndClasses
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses <(Of <(<' DomainShader >)>)>

See Also

DomainShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (DomainShader, IEnumerable(ClassInstance))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..SetShader Method (DomainShader, IEnumerable<(Of <(<'ClassInstance>)>)>)
DomainShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    DomainShader domainShader,
    IEnumerable<ClassInstance> classInstances
)
Visual Basic
Public Sub SetShader ( _
    domainShader As DomainShader, _
    classInstances As IEnumerable(Of ClassInstance) _
)
Visual C++
public:
void SetShader(
    DomainShader^ domainShader,
    IEnumerable<ClassInstance^>^ classInstances
)

Parameters

domainShader
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DomainShader
classInstances
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ClassInstance >)>)>

See Also

DomainShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..SetShaderResources Method
DomainShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShaderResources(
    uint startSlot,
    IEnumerable<ShaderResourceView> shaderResourceViews
)
Visual Basic
Public Sub SetShaderResources ( _
    startSlot As UInteger, _
    shaderResourceViews As IEnumerable(Of ShaderResourceView) _
)
Visual C++
public:
void SetShaderResources(
    unsigned int startSlot,
    IEnumerable<ShaderResourceView^>^ shaderResourceViews
)

Parameters

startSlot
Type: System..::..UInt32
shaderResourceViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DomainShaderPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage Properties
DomainShaderPipelineStage Class See Also Send Feedback

The DomainShaderPipelineStage type exposes the following members.

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Get the domain shader currently set on the device. (See DomainShader) (Also see DirectX SDK: ID3D11DeviceContext::DSGetShader, ID3D11DeviceContext::DSSetShader) Passing in null disables the shader for this pipeline stage.

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DomainShaderPipelineStage..::..Shader Property
DomainShaderPipelineStage Class See Also Send Feedback
Get the domain shader currently set on the device. (See DomainShader)

(Also see DirectX SDK: ID3D11DeviceContext::DSGetShader, ID3D11DeviceContext::DSSetShader)

Passing in null disables the shader for this pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DomainShader Shader { get; set; }
Visual Basic
Public Property Shader As DomainShader
    Get
    Set
Visual C++
public:
property DomainShader^ Shader {
    DomainShader^ get ();
    void set (DomainShader^ value);
}

See Also

DomainShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DomainShader


DriverType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DriverType Enumeration
See Also Send Feedback
Driver type options.

(Also see DirectX SDK: D3D_DRIVER_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DriverType
Visual Basic
Public Enumeration DriverType
Visual C++
public enum class DriverType

Members

Member name | Description
Warp |
Reference |
Hardware |
Software |
Null |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExceptionErrors Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExceptionErrors Enumeration
See Also Send Feedback
Option(s) for raising an error to a non-continuable exception.

(Also see DirectX SDK: D3D11_RAISE_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ExceptionErrors
Visual Basic
<FlagsAttribute> _
Public Enumeration ExceptionErrors
Visual C++
[FlagsAttribute]
public enum class ExceptionErrors

Members

Member name | Description
None |
DriverInternalError |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExtendedBufferBindingOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferBindingOptions Enumeration
See Also Send Feedback
Identifies how to bind a raw-buffer resource to the pipeline.

(Also see DirectX SDK: D3D11_BUFFEREX_SRV_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ExtendedBufferBindingOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration ExtendedBufferBindingOptions
Visual C++
[FlagsAttribute]
public enum class ExtendedBufferBindingOptions

Members

Member name | Description
Raw |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExtendedBufferShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView Structure
Members See Also Send Feedback
Describes a raw buffer resource.

(Also see DirectX SDK: D3D11_BUFFEREX_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ExtendedBufferShaderResourceView
Visual Basic
Public Structure ExtendedBufferShaderResourceView
Visual C++
public value class ExtendedBufferShaderResourceView

See Also

ExtendedBufferShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExtendedBufferShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView Members
ExtendedBufferShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The ExtendedBufferShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BindingOptions | Options for binding a raw buffer (see ExtendedBufferBindingOptions) (Also see DirectX SDK: D3D11_BUFFEREX_SRV.Flags)
Public property | ElementCount | The number of elements in the resource. (Also see DirectX SDK: D3D11_BUFFEREX_SRV.NumElements)
Public property | FirstElement | The index of the first element to be accessed by the view. (Also see DirectX SDK: D3D11_BUFFEREX_SRV.FirstElement)

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExtendedBufferShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView Methods
ExtendedBufferShaderResourceView Structure See Also Send Feedback

The ExtendedBufferShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView..::..Equals Method
ExtendedBufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView..::..GetHashCode Method
ExtendedBufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExtendedBufferShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView Operators
ExtendedBufferShaderResourceView Structure See Also Send Feedback

The ExtendedBufferShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView..::..Equality Operator
ExtendedBufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ExtendedBufferShaderResourceView extendedBufferShaderResourceView1,
    ExtendedBufferShaderResourceView extendedBufferShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    extendedBufferShaderResourceView1 As ExtendedBufferShaderResourceView, _
    extendedBufferShaderResourceView2 As ExtendedBufferShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    ExtendedBufferShaderResourceView extendedBufferShaderResourceView1,
    ExtendedBufferShaderResourceView extendedBufferShaderResourceView2
)

Parameters

extendedBufferShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ExtendedBufferShaderResourceView
extendedBufferShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ExtendedBufferShaderResourceView

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView..::..Inequality Operator
ExtendedBufferShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ExtendedBufferShaderResourceView extendedBufferShaderResourceView1,
    ExtendedBufferShaderResourceView extendedBufferShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    extendedBufferShaderResourceView1 As ExtendedBufferShaderResourceView, _
    extendedBufferShaderResourceView2 As ExtendedBufferShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    ExtendedBufferShaderResourceView extendedBufferShaderResourceView1,
    ExtendedBufferShaderResourceView extendedBufferShaderResourceView2
)

Parameters

extendedBufferShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ExtendedBufferShaderResourceView
extendedBufferShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ExtendedBufferShaderResourceView

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExtendedBufferShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView Properties
ExtendedBufferShaderResourceView Structure See Also Send Feedback

The ExtendedBufferShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | BindingOptions | Options for binding a raw buffer (see ExtendedBufferBindingOptions) (Also see DirectX SDK: D3D11_BUFFEREX_SRV.Flags)
Public property | ElementCount | The number of elements in the resource. (Also see DirectX SDK: D3D11_BUFFEREX_SRV.NumElements)
Public property | FirstElement | The index of the first element to be accessed by the view. (Also see DirectX SDK: D3D11_BUFFEREX_SRV.FirstElement)

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BindingOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView..::..BindingOptions Property
ExtendedBufferShaderResourceView Structure See Also Send Feedback
Options for binding a raw buffer (see ExtendedBufferBindingOptions)

(Also see DirectX SDK: D3D11_BUFFEREX_SRV.Flags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExtendedBufferBindingOptions BindingOptions { get; set; }
Visual Basic
Public Property BindingOptions As ExtendedBufferBindingOptions
    Get
    Set
Visual C++
public:
property ExtendedBufferBindingOptions BindingOptions {
    ExtendedBufferBindingOptions get ();
    void set (ExtendedBufferBindingOptions value);
}

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ExtendedBufferBindingOptions


ElementCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView..::..ElementCount Property
ExtendedBufferShaderResourceView Structure See Also Send Feedback
The number of elements in the resource.

(Also see DirectX SDK: D3D11_BUFFEREX_SRV.NumElements)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ElementCount { get; set; }
Visual Basic
Public Property ElementCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ElementCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstElement Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedBufferShaderResourceView..::..FirstElement Property
ExtendedBufferShaderResourceView Structure See Also Send Feedback
The index of the first element to be accessed by the view.

(Also see DirectX SDK: D3D11_BUFFEREX_SRV.FirstElement)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstElement { get; set; }
Visual Basic
Public Property FirstElement As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstElement {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ExtendedBufferShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ExtendedFormatSupportOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ExtendedFormatSupportOptions Enumeration
See Also Send Feedback
Unordered resource support options for a compute shader resource.

(Also see DirectX SDK: D3D11_FORMAT_SUPPORT2)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum ExtendedFormatSupportOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration ExtendedFormatSupportOptions
Visual C++
[FlagsAttribute]
public enum class ExtendedFormatSupportOptions

Members

Member name | Description
UnorderedAccessViewTypedStore |
UnorderedAccessViewTypedLoad |
UnorderedAccessViewAtomicUnsignedMinOrMax |
UnorderedAccessViewAtomicSignedMinOrMax |
UnorderedAccessViewAtomicExchange |
UnorderedAccessViewAtomicCompareStoreOrCompareExchange |
UnorderedAccessViewAtomicBitwiseOperations |
UnorderedAccessViewAtomicAdd |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Feature Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Feature Enumeration
See Also Send Feedback
Direct3D 11 feature options.

(Also see DirectX SDK: D3D11_FEATURE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Feature
Visual Basic
Public Enumeration Feature
Visual C++
public enum class Feature

Members

Member name | Description
D3D10XHardwareOptions |
ExtendedFormatSupport |
FormatSupport |
Doubles |
Threading |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataD3D10XHardwareOptions Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions Structure
Members See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_D3D10_X_HARDWARE_OPTIONS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct FeatureDataD3D10XHardwareOptions
Visual Basic
Public Structure FeatureDataD3D10XHardwareOptions
Visual C++
public value class FeatureDataD3D10XHardwareOptions

See Also

FeatureDataD3D10XHardwareOptions Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataD3D10XHardwareOptions Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions Members
FeatureDataD3D10XHardwareOptions Structure Methods Operators Properties See Also Send Feedback

The FeatureDataD3D10XHardwareOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ComputeShadersPlusRawAndStructuredBuffersViaShader4x | (Also see DirectX SDK: D3D11_FEATURE_DATA_D3D10_X_HARDWARE_OPTIONS.ComputeShaders_Plus_RawAndStructuredBuffers_Via_Shader_4_x)

See Also

FeatureDataD3D10XHardwareOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataD3D10XHardwareOptions Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions Methods
FeatureDataD3D10XHardwareOptions Structure See Also Send Feedback

The FeatureDataD3D10XHardwareOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

FeatureDataD3D10XHardwareOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions..::..Equals Method
FeatureDataD3D10XHardwareOptions Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

FeatureDataD3D10XHardwareOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions..::..GetHashCode Method
FeatureDataD3D10XHardwareOptions Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

FeatureDataD3D10XHardwareOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataD3D10XHardwareOptions Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions Operators
FeatureDataD3D10XHardwareOptions Structure See Also Send Feedback

The FeatureDataD3D10XHardwareOptions type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FeatureDataD3D10XHardwareOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions..::..Equality Operator
FeatureDataD3D10XHardwareOptions Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    FeatureDataD3D10XHardwareOptions featureDataHardwareOptions1,
    FeatureDataD3D10XHardwareOptions featureDataHardwareOptions2
)
Visual Basic
Public Shared Operator = ( _
    featureDataHardwareOptions1 As FeatureDataD3D10XHardwareOptions, _
    featureDataHardwareOptions2 As FeatureDataD3D10XHardwareOptions _
) As Boolean
Visual C++
public:
static bool operator ==(
    FeatureDataD3D10XHardwareOptions featureDataHardwareOptions1,
    FeatureDataD3D10XHardwareOptions featureDataHardwareOptions2
)

Parameters

featureDataHardwareOptions1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataD3D10XHardwareOptions
featureDataHardwareOptions2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataD3D10XHardwareOptions

See Also

FeatureDataD3D10XHardwareOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions..::..Inequality Operator
FeatureDataD3D10XHardwareOptions Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    FeatureDataD3D10XHardwareOptions featureDataHardwareOptions1,
    FeatureDataD3D10XHardwareOptions featureDataHardwareOptions2
)
Visual Basic
Public Shared Operator <> ( _
    featureDataHardwareOptions1 As FeatureDataD3D10XHardwareOptions, _
    featureDataHardwareOptions2 As FeatureDataD3D10XHardwareOptions _
) As Boolean
Visual C++
public:
static bool operator !=(
    FeatureDataD3D10XHardwareOptions featureDataHardwareOptions1,
    FeatureDataD3D10XHardwareOptions featureDataHardwareOptions2
)

Parameters

featureDataHardwareOptions1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataD3D10XHardwareOptions
featureDataHardwareOptions2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataD3D10XHardwareOptions

See Also

FeatureDataD3D10XHardwareOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataD3D10XHardwareOptions Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions Properties
FeatureDataD3D10XHardwareOptions Structure See Also Send Feedback

The FeatureDataD3D10XHardwareOptions type exposes the following members.

Properties

 | Name | Description
Public property | ComputeShadersPlusRawAndStructuredBuffersViaShader4x | (Also see DirectX SDK: D3D11_FEATURE_DATA_D3D10_X_HARDWARE_OPTIONS.ComputeShaders_Plus_RawAndStructuredBuffers_Via_Shader_4_x)

See Also

FeatureDataD3D10XHardwareOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComputeShadersPlusRawAndStructuredBuffersViaShader4x Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataD3D10XHardwareOptions..::..ComputeShadersPlusRawAndStructuredBuffersViaShader4x Property
FeatureDataD3D10XHardwareOptions Structure See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_D3D10_X_HARDWARE_OPTIONS.ComputeShaders_Plus_RawAndStructuredBuffers_Via_Shader_4_x)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool ComputeShadersPlusRawAndStructuredBuffersViaShader4x { get; set; }
Visual Basic
Public Property ComputeShadersPlusRawAndStructuredBuffersViaShader4x As Boolean
    Get
    Set
Visual C++
public:
property bool ComputeShadersPlusRawAndStructuredBuffersViaShader4x {
    bool get ();
    void set (bool value);
}

See Also

FeatureDataD3D10XHardwareOptions Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataDoubles Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles Structure
Members See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_DOUBLES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct FeatureDataDoubles
Visual Basic
Public Structure FeatureDataDoubles
Visual C++
public value class FeatureDataDoubles

See Also

FeatureDataDoubles Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataDoubles Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles Members
FeatureDataDoubles Structure Methods Operators Properties See Also Send Feedback

The FeatureDataDoubles type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | DoublePrecisionFloatShaderOperations | (Also see DirectX SDK: D3D11_FEATURE_DATA_DOUBLES.DoublePrecisionFloatShaderOps)

See Also

FeatureDataDoubles Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataDoubles Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles Methods
FeatureDataDoubles Structure See Also Send Feedback

The FeatureDataDoubles type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

FeatureDataDoubles Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles..::..Equals Method
FeatureDataDoubles Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

FeatureDataDoubles Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles..::..GetHashCode Method
FeatureDataDoubles Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

FeatureDataDoubles Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataDoubles Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles Operators
FeatureDataDoubles Structure See Also Send Feedback

The FeatureDataDoubles type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FeatureDataDoubles Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles..::..Equality Operator
FeatureDataDoubles Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    FeatureDataDoubles featureDataDoubles1,
    FeatureDataDoubles featureDataDoubles2
)
Visual Basic
Public Shared Operator = ( _
    featureDataDoubles1 As FeatureDataDoubles, _
    featureDataDoubles2 As FeatureDataDoubles _
) As Boolean
Visual C++
public:
static bool operator ==(
    FeatureDataDoubles featureDataDoubles1,
    FeatureDataDoubles featureDataDoubles2
)

Parameters

featureDataDoubles1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataDoubles
featureDataDoubles2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataDoubles

See Also

FeatureDataDoubles Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles..::..Inequality Operator
FeatureDataDoubles Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    FeatureDataDoubles featureDataDoubles1,
    FeatureDataDoubles featureDataDoubles2
)
Visual Basic
Public Shared Operator <> ( _
    featureDataDoubles1 As FeatureDataDoubles, _
    featureDataDoubles2 As FeatureDataDoubles _
) As Boolean
Visual C++
public:
static bool operator !=(
    FeatureDataDoubles featureDataDoubles1,
    FeatureDataDoubles featureDataDoubles2
)

Parameters

featureDataDoubles1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataDoubles
featureDataDoubles2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataDoubles

See Also

FeatureDataDoubles Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataDoubles Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles Properties
FeatureDataDoubles Structure See Also Send Feedback

The FeatureDataDoubles type exposes the following members.

Properties

 | Name | Description
Public property | DoublePrecisionFloatShaderOperations | (Also see DirectX SDK: D3D11_FEATURE_DATA_DOUBLES.DoublePrecisionFloatShaderOps)

See Also

FeatureDataDoubles Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DoublePrecisionFloatShaderOperations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataDoubles..::..DoublePrecisionFloatShaderOperations Property
FeatureDataDoubles Structure See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_DOUBLES.DoublePrecisionFloatShaderOps)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool DoublePrecisionFloatShaderOperations { get; set; }
Visual Basic
Public Property DoublePrecisionFloatShaderOperations As Boolean
    Get
    Set
Visual C++
public:
property bool DoublePrecisionFloatShaderOperations {
    bool get ();
    void set (bool value);
}

See Also

FeatureDataDoubles Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport Structure
Members See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct FeatureDataFormatSupport
Visual Basic
Public Structure FeatureDataFormatSupport
Visual C++
public value class FeatureDataFormatSupport

See Also

FeatureDataFormatSupport Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport Members
FeatureDataFormatSupport Structure Methods Operators Properties See Also Send Feedback

The FeatureDataFormatSupport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | InFormat | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT.InFormat)
Public property | OutFormatSupport | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT.OutFormatSupport)

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport Methods
FeatureDataFormatSupport Structure See Also Send Feedback

The FeatureDataFormatSupport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport..::..Equals Method
FeatureDataFormatSupport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport..::..GetHashCode Method
FeatureDataFormatSupport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport Operators
FeatureDataFormatSupport Structure See Also Send Feedback

The FeatureDataFormatSupport type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport..::..Equality Operator
FeatureDataFormatSupport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    FeatureDataFormatSupport featureDataFormatSupport1,
    FeatureDataFormatSupport featureDataFormatSupport2
)
Visual Basic
Public Shared Operator = ( _
    featureDataFormatSupport1 As FeatureDataFormatSupport, _
    featureDataFormatSupport2 As FeatureDataFormatSupport _
) As Boolean
Visual C++
public:
static bool operator ==(
    FeatureDataFormatSupport featureDataFormatSupport1,
    FeatureDataFormatSupport featureDataFormatSupport2
)

Parameters

featureDataFormatSupport1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataFormatSupport
featureDataFormatSupport2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataFormatSupport

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport..::..Inequality Operator
FeatureDataFormatSupport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    FeatureDataFormatSupport featureDataFormatSupport1,
    FeatureDataFormatSupport featureDataFormatSupport2
)
Visual Basic
Public Shared Operator <> ( _
    featureDataFormatSupport1 As FeatureDataFormatSupport, _
    featureDataFormatSupport2 As FeatureDataFormatSupport _
) As Boolean
Visual C++
public:
static bool operator !=(
    FeatureDataFormatSupport featureDataFormatSupport1,
    FeatureDataFormatSupport featureDataFormatSupport2
)

Parameters

featureDataFormatSupport1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataFormatSupport
featureDataFormatSupport2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataFormatSupport

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport Properties
FeatureDataFormatSupport Structure See Also Send Feedback

The FeatureDataFormatSupport type exposes the following members.

Properties

 | Name | Description
Public property | InFormat | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT.InFormat)
Public property | OutFormatSupport | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT.OutFormatSupport)

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InFormat Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport..::..InFormat Property
FeatureDataFormatSupport Structure See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT.InFormat)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format InFormat { get; set; }
Visual Basic
Public Property InFormat As Format
    Get
    Set
Visual C++
public:
property Format InFormat {
    Format get ();
    void set (Format value);
}

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutFormatSupport Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport..::..OutFormatSupport Property
FeatureDataFormatSupport Structure See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT.OutFormatSupport)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FormatSupportOptions OutFormatSupport { get; set; }
Visual Basic
Public Property OutFormatSupport As FormatSupportOptions
    Get
    Set
Visual C++
public:
property FormatSupportOptions OutFormatSupport {
    FormatSupportOptions get ();
    void set (FormatSupportOptions value);
}

See Also

FeatureDataFormatSupport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport2 Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2 Structure
Members See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct FeatureDataFormatSupport2
Visual Basic
Public Structure FeatureDataFormatSupport2
Visual C++
public value class FeatureDataFormatSupport2

See Also

FeatureDataFormatSupport2 Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport2 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2 Members
FeatureDataFormatSupport2 Structure Methods Operators Properties See Also Send Feedback

The FeatureDataFormatSupport2 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | InFormat | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT2.InFormat)
Public property | OutFormatSupport2 | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT2.OutFormatSupport2)

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport2 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2 Methods
FeatureDataFormatSupport2 Structure See Also Send Feedback

The FeatureDataFormatSupport2 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2..::..Equals Method
FeatureDataFormatSupport2 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2..::..GetHashCode Method
FeatureDataFormatSupport2 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport2 Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2 Operators
FeatureDataFormatSupport2 Structure See Also Send Feedback

The FeatureDataFormatSupport2 type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2..::..Equality Operator
FeatureDataFormatSupport2 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    FeatureDataFormatSupport2 featureDataFormatSupport1,
    FeatureDataFormatSupport2 featureDataFormatSupport2
)
Visual Basic
Public Shared Operator = ( _
    featureDataFormatSupport1 As FeatureDataFormatSupport2, _
    featureDataFormatSupport2 As FeatureDataFormatSupport2 _
) As Boolean
Visual C++
public:
static bool operator ==(
    FeatureDataFormatSupport2 featureDataFormatSupport1,
    FeatureDataFormatSupport2 featureDataFormatSupport2
)

Parameters

featureDataFormatSupport1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataFormatSupport2
featureDataFormatSupport2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataFormatSupport2

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2..::..Inequality Operator
FeatureDataFormatSupport2 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    FeatureDataFormatSupport2 featureDataFormatSupport1,
    FeatureDataFormatSupport2 featureDataFormatSupport2
)
Visual Basic
Public Shared Operator <> ( _
    featureDataFormatSupport1 As FeatureDataFormatSupport2, _
    featureDataFormatSupport2 As FeatureDataFormatSupport2 _
) As Boolean
Visual C++
public:
static bool operator !=(
    FeatureDataFormatSupport2 featureDataFormatSupport1,
    FeatureDataFormatSupport2 featureDataFormatSupport2
)

Parameters

featureDataFormatSupport1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataFormatSupport2
featureDataFormatSupport2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataFormatSupport2

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataFormatSupport2 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2 Properties
FeatureDataFormatSupport2 Structure See Also Send Feedback

The FeatureDataFormatSupport2 type exposes the following members.

Properties

 | Name | Description
Public property | InFormat | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT2.InFormat)
Public property | OutFormatSupport2 | (Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT2.OutFormatSupport2)

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InFormat Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2..::..InFormat Property
FeatureDataFormatSupport2 Structure See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT2.InFormat)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format InFormat { get; set; }
Visual Basic
Public Property InFormat As Format
    Get
    Set
Visual C++
public:
property Format InFormat {
    Format get ();
    void set (Format value);
}

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutFormatSupport2 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataFormatSupport2..::..OutFormatSupport2 Property
FeatureDataFormatSupport2 Structure See Also Send Feedback

(Also see DirectX SDK: D3D11_FEATURE_DATA_FORMAT_SUPPORT2.OutFormatSupport2)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExtendedFormatSupportOptions OutFormatSupport2 { get; set; }
Visual Basic
Public Property OutFormatSupport2 As ExtendedFormatSupportOptions
    Get
    Set
Visual C++
public:
property ExtendedFormatSupportOptions OutFormatSupport2 {
    ExtendedFormatSupportOptions get ();
    void set (ExtendedFormatSupportOptions value);
}

See Also

FeatureDataFormatSupport2 Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataThreading Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading Structure
Members See Also Send Feedback
Describes the multi-threading features that are supported by the current graphics driver.

(Also see DirectX SDK: D3D11_FEATURE_DATA_THREADING)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct FeatureDataThreading
Visual Basic
Public Structure FeatureDataThreading
Visual C++
public value class FeatureDataThreading

See Also

FeatureDataThreading Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataThreading Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading Members
FeatureDataThreading Structure Methods Operators Properties See Also Send Feedback

The FeatureDataThreading type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | DriverCommandLists | TRUE means command lists are supported by the current driver; FALSE means that the API will emulate deferred contexts and command lists with software. (Also see DirectX SDK: D3D11_FEATURE_DATA_THREADING.DriverCommandLists)
Public property | DriverConcurrentCreates | TRUE means resources can be created concurrently on multiple threads while drawing; FALSE means that the presence of coarse synchronization will prevent concurrency. (Also see DirectX SDK: D3D11_FEATURE_DATA_THREADING.DriverConcurrentCreates)

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataThreading Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading Methods
FeatureDataThreading Structure See Also Send Feedback

The FeatureDataThreading type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading..::..Equals Method
FeatureDataThreading Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading..::..GetHashCode Method
FeatureDataThreading Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataThreading Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading Operators
FeatureDataThreading Structure See Also Send Feedback

The FeatureDataThreading type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading..::..Equality Operator
FeatureDataThreading Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    FeatureDataThreading featureDataThreading1,
    FeatureDataThreading featureDataThreading2
)
Visual Basic
Public Shared Operator = ( _
    featureDataThreading1 As FeatureDataThreading, _
    featureDataThreading2 As FeatureDataThreading _
) As Boolean
Visual C++
public:
static bool operator ==(
    FeatureDataThreading featureDataThreading1,
    FeatureDataThreading featureDataThreading2
)

Parameters

featureDataThreading1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataThreading
featureDataThreading2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataThreading

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading..::..Inequality Operator
FeatureDataThreading Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    FeatureDataThreading featureDataThreading1,
    FeatureDataThreading featureDataThreading2
)
Visual Basic
Public Shared Operator <> ( _
    featureDataThreading1 As FeatureDataThreading, _
    featureDataThreading2 As FeatureDataThreading _
) As Boolean
Visual C++
public:
static bool operator !=(
    FeatureDataThreading featureDataThreading1,
    FeatureDataThreading featureDataThreading2
)

Parameters

featureDataThreading1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataThreading
featureDataThreading2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..FeatureDataThreading

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FeatureDataThreading Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading Properties
FeatureDataThreading Structure See Also Send Feedback

The FeatureDataThreading type exposes the following members.

Properties

 | Name | Description
Public property | DriverCommandLists | TRUE means command lists are supported by the current driver; FALSE means that the API will emulate deferred contexts and command lists with software. (Also see DirectX SDK: D3D11_FEATURE_DATA_THREADING.DriverCommandLists)
Public property | DriverConcurrentCreates | TRUE means resources can be created concurrently on multiple threads while drawing; FALSE means that the presence of coarse synchronization will prevent concurrency. (Also see DirectX SDK: D3D11_FEATURE_DATA_THREADING.DriverConcurrentCreates)

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DriverCommandLists Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading..::..DriverCommandLists Property
FeatureDataThreading Structure See Also Send Feedback
TRUE means command lists are supported by the current driver; FALSE means that the API will emulate deferred contexts and command lists with software.

(Also see DirectX SDK: D3D11_FEATURE_DATA_THREADING.DriverCommandLists)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool DriverCommandLists { get; set; }
Visual Basic
Public Property DriverCommandLists As Boolean
    Get
    Set
Visual C++
public:
property bool DriverCommandLists {
    bool get ();
    void set (bool value);
}

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DriverConcurrentCreates Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FeatureDataThreading..::..DriverConcurrentCreates Property
FeatureDataThreading Structure See Also Send Feedback
TRUE means resources can be created concurrently on multiple threads while drawing; FALSE means that the presence of coarse synchronization will prevent concurrency.

(Also see DirectX SDK: D3D11_FEATURE_DATA_THREADING.DriverConcurrentCreates)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool DriverConcurrentCreates { get; set; }
Visual Basic
Public Property DriverConcurrentCreates As Boolean
    Get
    Set
Visual C++
public:
property bool DriverConcurrentCreates {
    bool get ();
    void set (bool value);
}

See Also

FeatureDataThreading Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FillMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FillMode Enumeration
See Also Send Feedback
Determines the fill mode to use when rendering triangles.

(Also see DirectX SDK: D3D11_FILL_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FillMode
Visual Basic
Public Enumeration FillMode
Visual C++
public enum class FillMode

Members

Member name | Description
Solid |
Wireframe |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Filter Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Filter Enumeration
See Also Send Feedback
Filtering options during texture sampling.

(Also see DirectX SDK: D3D11_FILTER)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Filter
Visual Basic
Public Enumeration Filter
Visual C++
public enum class Filter

Members

Member name | Description
ComparisonAnisotropic |
ComparisonMinMagMipLinear |
ComparisonMinMagLinearMipPoint |
ComparisonMinLinearMagPointMipLinear |
ComparisonMinLinearMagMipPoint |
ComparisonMinPointMagMipLinear |
ComparisonMinPointMagLinearMipPoint |
ComparisonMinMagPointMipLinear |
ComparisonMinMagMipPoint |
Anisotropic |
MinMagMipLinear |
MinMagLinearMipPoint |
MinLinearMagPointMipLinear |
MinLinearMagMipPoint |
MinPointMagMipLinear |
MinPointMagLinearMipPoint |
MinMagPointMipLinear |
MinMagMipPoint |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FilterType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FilterType Enumeration
See Also Send Feedback
Types of magnification or minification sampler filters.

(Also see DirectX SDK: D3D11_FILTER_TYPE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FilterType
Visual Basic
Public Enumeration FilterType
Visual C++
public enum class FilterType

Members

Member name | Description
Linear |
Point |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FormatSupportOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatSupportOptions Enumeration
See Also Send Feedback
Which resources are supported for a given format and given device.

(Also see DirectX SDK: D3D11_FORMAT_SUPPORT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum FormatSupportOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration FormatSupportOptions
Visual C++
[FlagsAttribute]
public enum class FormatSupportOptions

Members

Member name | Description
ShaderGatherComparison |
TypedUnorderedAccessView |
BackBufferCast |
ShaderGather |
MultisampleLoad |
MultisampleRenderTarget |
CastWithinBitLayout |
Display |
MultisampleResolve |
CpuLockable |
DepthStencil |
Blendable |
RenderTarget |
MipMapAutoGeneration |
MipMap |
ShaderSampleMonoText |
ShaderSampleComparison |
ShaderSample |
ShaderLoad |
StreamOutputBuffer |
InputAssemblerIndexBuffer |
InputAssemblerVertexBuffer |
None |
Buffer |
TextureCube |
Texture3D |
Texture2D |
Texture1D |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShader Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShader Class
Members See Also Send Feedback
A geometry-shader class manages an executable program (a geometry shader) that controls the geometry-shader stage.

(Also see DirectX SDK: ID3D11GeometryShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GeometryShader : DeviceChild
Visual Basic
Public Class GeometryShader _
    Inherits DeviceChild
Visual C++
public ref class GeometryShader : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..GeometryShader

See Also

GeometryShader Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShader Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShader Members
GeometryShader Class Properties See Also Send Feedback

The GeometryShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GeometryShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShader Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShader Properties
GeometryShader Class See Also Send Feedback

The GeometryShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GeometryShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShaderPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage Class
Members See Also Send Feedback
Geometry Shader pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GeometryShaderPipelineStage : PipelineStage
Visual Basic
Public Class GeometryShaderPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class GeometryShaderPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..GeometryShaderPipelineStage

See Also

GeometryShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShaderPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage Members
GeometryShaderPipelineStage Class Constructors Methods Properties See Also Send Feedback

The GeometryShaderPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | GeometryShaderPipelineStage |

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the geometry shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::GSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the geometry shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::GSGetSamplers)
Public method | GetShaderAndClasses | Get the geometry shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::GSGetShader)
Public method | GetShaderResources | Get the geometry shader resources. (Also see DirectX SDK: ID3D11DeviceContext::GSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(GeometryShader>)>>)) |
Public method | SetShader(GeometryShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Get the geometry shader currently set on the device. (See GeometryShader) (Also see DirectX SDK: ID3D11DeviceContext::GSGetShader, ID3D11DeviceContext::GSSetShader)

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShaderPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage Constructor
GeometryShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected GeometryShaderPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
GeometryShaderPipelineStage()

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShaderPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage Methods
GeometryShaderPipelineStage Class See Also Send Feedback

The GeometryShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the geometry shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::GSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the geometry shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::GSGetSamplers)
Public method | GetShaderAndClasses | Get the geometry shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::GSGetShader)
Public method | GetShaderResources | Get the geometry shader resources. (Also see DirectX SDK: ID3D11DeviceContext::GSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(GeometryShader>)>>)) |
Public method | SetShader(GeometryShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..GetConstantBuffers Method
GeometryShaderPipelineStage Class See Also Send Feedback
Get the constant buffers used by the geometry shader pipeline stage.

(Also see DirectX SDK: ID3D11DeviceContext::GSGetConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetConstantBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetConstantBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetConstantBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin retrieving constant buffers from (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - 1).
bufferCount
Type: System..::..UInt32
Number of buffers to retrieve (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - startSlot).

Return Value

A collection of constant buffer objects (see D3DBuffer) to be returned by the method.

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


GetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..GetSamplers Method
GeometryShaderPipelineStage Class See Also Send Feedback
Get an array of sampler state objects from the geometry shader pipeline stage.

(Also see DirectX SDK: ID3D11DeviceContext::GSGetSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<SamplerState> GetSamplers(
    uint startSlot,
    uint samplerCount
)
Visual Basic
Public Function GetSamplers ( _
    startSlot As UInteger, _
    samplerCount As UInteger _
) As ReadOnlyCollection(Of SamplerState)
Visual C++
public:
ReadOnlyCollection<SamplerState^>^ GetSamplers(
    unsigned int startSlot,
    unsigned int samplerCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into a zero-based array to begin getting samplers from (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - 1).
samplerCount
Type: System..::..UInt32
Number of samplers to get from a device context. Each pipeline stage has a total of 16 sampler slots available (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - startSlot).

Return Value

A collection of sampler-state objects (see SamplerState).

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerState


GetShaderAndClasses Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..GetShaderAndClasses Method
GeometryShaderPipelineStage Class See Also Send Feedback
Get the geometry shader currently set on the device.

(Also see DirectX SDK: ID3D11DeviceContext::GSGetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderAndClasses<GeometryShader> GetShaderAndClasses(
    uint classInstanceCount
)
Visual Basic
Public Function GetShaderAndClasses ( _
    classInstanceCount As UInteger _
) As ShaderAndClasses(Of GeometryShader)
Visual C++
public:
ShaderAndClasses<GeometryShader^> GetShaderAndClasses(
    unsigned int classInstanceCount
)

Parameters

classInstanceCount
Type: System..::..UInt32
The number of class-instance elements requested.

Return Value

A GeometryShader object and its classes (see GeometryShader, ShaderAndClasses<(Of <(<'T>)>)>) , .

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..GeometryShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses<(Of <(<'T>)>)>


GetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..GetShaderResources Method
GeometryShaderPipelineStage Class See Also Send Feedback
Get the geometry shader resources.

(Also see DirectX SDK: ID3D11DeviceContext::GSGetShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetShaderResources(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetShaderResources ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetShaderResources(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin getting shader resources from (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - 1).
viewCount
Type: System..::..UInt32
The number of resources to request from the device. Up to a maximum of 128 slots are available for shader resources (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - startSlot).

Return Value

Collection of shader resource view objects to be returned by the device.

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..SetConstantBuffers Method
GeometryShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetConstantBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> constantBuffers
)
Visual Basic
Public Sub SetConstantBuffers ( _
    startSlot As UInteger, _
    constantBuffers As IEnumerable(Of D3DBuffer) _
)
Visual C++
public:
void SetConstantBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ constantBuffers
)

Parameters

startSlot
Type: System..::..UInt32
constantBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..SetSamplers Method
GeometryShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSamplers(
    uint startSlot,
    IEnumerable<SamplerState> samplers
)
Visual Basic
Public Sub SetSamplers ( _
    startSlot As UInteger, _
    samplers As IEnumerable(Of SamplerState) _
)
Visual C++
public:
void SetSamplers(
    unsigned int startSlot,
    IEnumerable<SamplerState^>^ samplers
)

Parameters

startSlot
Type: System..::..UInt32
samplers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SamplerState >)>)>

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..SetShader Method
GeometryShaderPipelineStage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetShader(ShaderAndClasses<(Of <<'(GeometryShader>)>>)) |
Public method | SetShader(GeometryShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |

See Also

GeometryShaderPipelineStage Class
GeometryShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (ShaderAndClasses(GeometryShader))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..SetShader Method (ShaderAndClasses<(Of <(<'GeometryShader>)>)>)
GeometryShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    ShaderAndClasses<GeometryShader> shaderAndClasses
)
Visual Basic
Public Sub SetShader ( _
    shaderAndClasses As ShaderAndClasses(Of GeometryShader) _
)
Visual C++
public:
void SetShader(
    ShaderAndClasses<GeometryShader^> shaderAndClasses
)

Parameters

shaderAndClasses
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses <(Of <(<' GeometryShader >)>)>

See Also

GeometryShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (GeometryShader, IEnumerable(ClassInstance))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..SetShader Method (GeometryShader, IEnumerable<(Of <(<'ClassInstance>)>)>)
GeometryShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    GeometryShader geometryShader,
    IEnumerable<ClassInstance> classInstances
)
Visual Basic
Public Sub SetShader ( _
    geometryShader As GeometryShader, _
    classInstances As IEnumerable(Of ClassInstance) _
)
Visual C++
public:
void SetShader(
    GeometryShader^ geometryShader,
    IEnumerable<ClassInstance^>^ classInstances
)

Parameters

geometryShader
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..GeometryShader
classInstances
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ClassInstance >)>)>

See Also

GeometryShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..SetShaderResources Method
GeometryShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShaderResources(
    uint startSlot,
    IEnumerable<ShaderResourceView> shaderResourceViews
)
Visual Basic
Public Sub SetShaderResources ( _
    startSlot As UInteger, _
    shaderResourceViews As IEnumerable(Of ShaderResourceView) _
)
Visual C++
public:
void SetShaderResources(
    unsigned int startSlot,
    IEnumerable<ShaderResourceView^>^ shaderResourceViews
)

Parameters

startSlot
Type: System..::..UInt32
shaderResourceViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShaderPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage Properties
GeometryShaderPipelineStage Class See Also Send Feedback

The GeometryShaderPipelineStage type exposes the following members.

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Get the geometry shader currently set on the device. (See GeometryShader) (Also see DirectX SDK: ID3D11DeviceContext::GSGetShader, ID3D11DeviceContext::GSSetShader)

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GeometryShaderPipelineStage..::..Shader Property
GeometryShaderPipelineStage Class See Also Send Feedback
Get the geometry shader currently set on the device. (See GeometryShader)

(Also see DirectX SDK: ID3D11DeviceContext::GSGetShader, ID3D11DeviceContext::GSSetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GeometryShader Shader { get; set; }
Visual Basic
Public Property Shader As GeometryShader
    Get
    Set
Visual C++
public:
property GeometryShader^ Shader {
    GeometryShader^ get ();
    void set (GeometryShader^ value);
}

See Also

GeometryShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..GeometryShader


HullShader Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShader Class
Members See Also Send Feedback
A hull-shader class manages an executable program (a hull shader) that controls the hull-shader stage.

(Also see DirectX SDK: ID3D11HullShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class HullShader : DeviceChild
Visual Basic
Public Class HullShader _
    Inherits DeviceChild
Visual C++
public ref class HullShader : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShader

See Also

HullShader Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


HullShader Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShader Members
HullShader Class Properties See Also Send Feedback

The HullShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

HullShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


HullShader Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShader Properties
HullShader Class See Also Send Feedback

The HullShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

HullShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


HullShaderPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage Class
Members See Also Send Feedback
Hull Shader pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class HullShaderPipelineStage : PipelineStage
Visual Basic
Public Class HullShaderPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class HullShaderPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShaderPipelineStage

See Also

HullShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


HullShaderPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage Members
HullShaderPipelineStage Class Constructors Methods Properties See Also Send Feedback

The HullShaderPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | HullShaderPipelineStage |

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the hull-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::HSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the hull-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::HSGetSamplers)
Public method | GetShaderAndClasses | Get the hull shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::HSGetShader)
Public method | GetShaderResources | Get the hull-shader resources. (Also see DirectX SDK: ID3D11DeviceContext::HSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(HullShader>)>>)) |
Public method | SetShader(HullShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Gets or sets the hull shader currently set on the device. (See GeometryShader) (Also see DirectX SDK: ID3D11DeviceContext::HSGetShader, ID3D11DeviceContext::HSSetShader) Setting this property to null disables the shader for this pipeline stage.

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


HullShaderPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage Constructor
HullShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected HullShaderPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
HullShaderPipelineStage()

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


HullShaderPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage Methods
HullShaderPipelineStage Class See Also Send Feedback

The HullShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the hull-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::HSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler state objects from the hull-shader stage. (Also see DirectX SDK: ID3D11DeviceContext::HSGetSamplers)
Public method | GetShaderAndClasses | Get the hull shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::HSGetShader)
Public method | GetShaderResources | Get the hull-shader resources. (Also see DirectX SDK: ID3D11DeviceContext::HSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(HullShader>)>>)) |
Public method | SetShader(HullShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..GetConstantBuffers Method
HullShaderPipelineStage Class See Also Send Feedback
Get the constant buffers used by the hull-shader stage.

(Also see DirectX SDK: ID3D11DeviceContext::HSGetConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetConstantBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetConstantBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetConstantBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin retrieving constant buffers from (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - 1).
bufferCount
Type: System..::..UInt32
Number of buffers to retrieve (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - startSlot).

Return Value

Collection of constant buffer objects (see D3DBuffer) to be returned by the method.

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


GetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..GetSamplers Method
HullShaderPipelineStage Class See Also Send Feedback
Get an array of sampler state objects from the hull-shader stage.

(Also see DirectX SDK: ID3D11DeviceContext::HSGetSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<SamplerState> GetSamplers(
    uint startSlot,
    uint samplerCount
)
Visual Basic
Public Function GetSamplers ( _
    startSlot As UInteger, _
    samplerCount As UInteger _
) As ReadOnlyCollection(Of SamplerState)
Visual C++
public:
ReadOnlyCollection<SamplerState^>^ GetSamplers(
    unsigned int startSlot,
    unsigned int samplerCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into a zero-based array to begin getting samplers from (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - 1).
samplerCount
Type: System..::..UInt32
Number of samplers to get from a device context. Each pipeline stage has a total of 16 sampler slots available (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - startSlot).

Return Value

A collection of sampler-state objects (see SamplerState).

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerState


GetShaderAndClasses Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..GetShaderAndClasses Method
HullShaderPipelineStage Class See Also Send Feedback
Get the hull shader currently set on the device.

(Also see DirectX SDK: ID3D11DeviceContext::HSGetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderAndClasses<HullShader> GetShaderAndClasses(
    uint classInstanceCount
)
Visual Basic
Public Function GetShaderAndClasses ( _
    classInstanceCount As UInteger _
) As ShaderAndClasses(Of HullShader)
Visual C++
public:
ShaderAndClasses<HullShader^> GetShaderAndClasses(
    unsigned int classInstanceCount
)

Parameters

classInstanceCount
Type: System..::..UInt32
The number of class-instance elements requested.

Return Value

A HullShader object and its classes (see HullShader, ShaderAndClasses<(Of <(<'T>)>)>) , .

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses<(Of <(<'T>)>)>


GetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..GetShaderResources Method
HullShaderPipelineStage Class See Also Send Feedback
Get the hull-shader resources.

(Also see DirectX SDK: ID3D11DeviceContext::HSGetShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetShaderResources(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetShaderResources ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetShaderResources(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin getting shader resources from (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - 1).
viewCount
Type: System..::..UInt32
The number of resources to get from the device. Up to a maximum of 128 slots are available for shader resources (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - startSlot).

Return Value

Collection of shader resource view objects to be returned by the device.

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..SetConstantBuffers Method
HullShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetConstantBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> constantBuffers
)
Visual Basic
Public Sub SetConstantBuffers ( _
    startSlot As UInteger, _
    constantBuffers As IEnumerable(Of D3DBuffer) _
)
Visual C++
public:
void SetConstantBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ constantBuffers
)

Parameters

startSlot
Type: System..::..UInt32
constantBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..SetSamplers Method
HullShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSamplers(
    uint startSlot,
    IEnumerable<SamplerState> samplers
)
Visual Basic
Public Sub SetSamplers ( _
    startSlot As UInteger, _
    samplers As IEnumerable(Of SamplerState) _
)
Visual C++
public:
void SetSamplers(
    unsigned int startSlot,
    IEnumerable<SamplerState^>^ samplers
)

Parameters

startSlot
Type: System..::..UInt32
samplers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SamplerState >)>)>

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..SetShader Method
HullShaderPipelineStage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetShader(ShaderAndClasses<(Of <<'(HullShader>)>>)) |
Public method | SetShader(HullShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |

See Also

HullShaderPipelineStage Class
HullShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (ShaderAndClasses(HullShader))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..SetShader Method (ShaderAndClasses<(Of <(<'HullShader>)>)>)
HullShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    ShaderAndClasses<HullShader> shaderAndClasses
)
Visual Basic
Public Sub SetShader ( _
    shaderAndClasses As ShaderAndClasses(Of HullShader) _
)
Visual C++
public:
void SetShader(
    ShaderAndClasses<HullShader^> shaderAndClasses
)

Parameters

shaderAndClasses
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses <(Of <(<' HullShader >)>)>

See Also

HullShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (HullShader, IEnumerable(ClassInstance))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..SetShader Method (HullShader, IEnumerable<(Of <(<'ClassInstance>)>)>)
HullShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    HullShader shader,
    IEnumerable<ClassInstance> classInstances
)
Visual Basic
Public Sub SetShader ( _
    shader As HullShader, _
    classInstances As IEnumerable(Of ClassInstance) _
)
Visual C++
public:
void SetShader(
    HullShader^ shader,
    IEnumerable<ClassInstance^>^ classInstances
)

Parameters

shader
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShader
classInstances
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ClassInstance >)>)>

See Also

HullShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..SetShaderResources Method
HullShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShaderResources(
    uint startSlot,
    IEnumerable<ShaderResourceView> shaderResourceViews
)
Visual Basic
Public Sub SetShaderResources ( _
    startSlot As UInteger, _
    shaderResourceViews As IEnumerable(Of ShaderResourceView) _
)
Visual C++
public:
void SetShaderResources(
    unsigned int startSlot,
    IEnumerable<ShaderResourceView^>^ shaderResourceViews
)

Parameters

startSlot
Type: System..::..UInt32
shaderResourceViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


HullShaderPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage Properties
HullShaderPipelineStage Class See Also Send Feedback

The HullShaderPipelineStage type exposes the following members.

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Gets or sets the hull shader currently set on the device. (See GeometryShader) (Also see DirectX SDK: ID3D11DeviceContext::HSGetShader, ID3D11DeviceContext::HSSetShader) Setting this property to null disables the shader for this pipeline stage.

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HullShaderPipelineStage..::..Shader Property
HullShaderPipelineStage Class See Also Send Feedback
Gets or sets the hull shader currently set on the device. (See GeometryShader)

(Also see DirectX SDK: ID3D11DeviceContext::HSGetShader, ID3D11DeviceContext::HSSetShader)

Setting this property to null disables the shader for this pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HullShader Shader { get; set; }
Visual Basic
Public Property Shader As HullShader
    Get
    Set
Visual C++
public:
property HullShader^ Shader {
    HullShader^ get ();
    void set (HullShader^ value);
}

See Also

HullShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..GeometryShader


IndexBuffer Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Structure
Members See Also Send Feedback
Stores the parameters required to get or set the current index buffer for a device.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct IndexBuffer
Visual Basic
Public Structure IndexBuffer
Visual C++
public value class IndexBuffer

See Also

IndexBuffer Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IndexBuffer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Members
IndexBuffer Structure Constructors Methods Operators Properties See Also Send Feedback

The IndexBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | IndexBuffer | Constructor.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Buffer |
Public property | Format |
Public property | Offset |

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IndexBuffer Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Constructor
IndexBuffer Structure See Also Send Feedback
Constructor.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IndexBuffer(
    D3DBuffer buffer,
    Format format,
    uint offset
)
Visual Basic
Public Sub New ( _
    buffer As D3DBuffer, _
    format As Format, _
    offset As UInteger _
)
Visual C++
public:
IndexBuffer(
    D3DBuffer^ buffer,
    Format format,
    unsigned int offset
)

Parameters

buffer
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer
A D3DBuffer object, that contains indices. The index buffer must have been created with the indexBuffer flag.
format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
A Format that specifies the format of the data in the index buffer. The only formats allowed for index buffer data are 16-bit (Format_R16_UINT) and 32-bit (Format_R32_UINT) integers.
offset
Type: System..::..UInt32
Offset (in bytes) from the start of the index buffer to the first index to use.

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IndexBuffer Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Methods
IndexBuffer Structure See Also Send Feedback

The IndexBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Equals Method
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..GetHashCode Method
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IndexBuffer Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Operators
IndexBuffer Structure See Also Send Feedback

The IndexBuffer type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Equality Operator
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    IndexBuffer buffer1,
    IndexBuffer buffer2
)
Visual Basic
Public Shared Operator = ( _
    buffer1 As IndexBuffer, _
    buffer2 As IndexBuffer _
) As Boolean
Visual C++
public:
static bool operator ==(
    IndexBuffer buffer1,
    IndexBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..IndexBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..IndexBuffer

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Inequality Operator
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    IndexBuffer buffer1,
    IndexBuffer buffer2
)
Visual Basic
Public Shared Operator <> ( _
    buffer1 As IndexBuffer, _
    buffer2 As IndexBuffer _
) As Boolean
Visual C++
public:
static bool operator !=(
    IndexBuffer buffer1,
    IndexBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..IndexBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..IndexBuffer

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IndexBuffer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer Properties
IndexBuffer Structure See Also Send Feedback

The IndexBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Buffer |
Public property | Format |
Public property | Offset |

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Buffer Property
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer Buffer { get; }
Visual Basic
Public ReadOnly Property Buffer As D3DBuffer
    Get
Visual C++
public:
property D3DBuffer^ Buffer {
    D3DBuffer^ get ();
}

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Format Property
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; }
Visual Basic
Public ReadOnly Property Format As Format
    Get
Visual C++
public:
property Format Format {
    Format get ();
}

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Offset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
IndexBuffer..::..Offset Property
IndexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Offset { get; }
Visual Basic
Public ReadOnly Property Offset As UInteger
    Get
Visual C++
public:
property unsigned int Offset {
    unsigned int get ();
}

See Also

IndexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InfoQueue Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue Class
Members See Also Send Feedback
An information-queue interface stores, retrieves, and filters debug messages. The queue consists of a message queue, an optional storage filter stack, and a optional retrieval filter stack.

(Also see DirectX SDK: ID3D11InfoQueue)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class InfoQueue : DirectUnknown
Visual Basic
Public Class InfoQueue _
    Inherits DirectUnknown
Visual C++
public ref class InfoQueue : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InfoQueue

See Also

InfoQueue Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InfoQueue Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue Members
InfoQueue Class Methods Properties See Also Send Feedback

The InfoQueue type exposes the following members.

Methods

 | Name | Description
Public method | AddApplicationMessage | Add a user-defined message to the message queue and send that message to debug output. (Also see DirectX SDK: ID3D11InfoQueue::AddApplicationMessage)
Public method | AddMessage | Add a debug message to the message queue and send that message to debug output. (Also see DirectX SDK: ID3D11InfoQueue::AddMessage)
Public method | ClearStoredMessages | Clear all messages from the message queue. (Also see DirectX SDK: ID3D11InfoQueue::ClearStoredMessages)
Public method | GetBreakOnCategory | Get a message category to break on when a message with that category passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetBreakOnCategory)
Public method | GetBreakOnId | Get a message identifier to break on when a message with that identifier passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetBreakOnID)
Public method | GetBreakOnSeverity | Get a message severity level to break on when a message with that severity level passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetBreakOnSeverity)
Public method | GetMessage | Get a message from the message queue. (Also see DirectX SDK: ID3D11InfoQueue::GetMessage)
Public method | SetBreakOnCategory | Set a message category to break on when a message with that category passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::SetBreakOnCategory)
Public method | SetBreakOnId | Set a message identifier to break on when a message with that identifier passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::SetBreakOnID)
Public method | SetBreakOnSeverity | Set a message severity level to break on when a message with that severity level passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::SetBreakOnSeverity)
Public method | TryGetMessage | Try to get a message from the message queue. (Also see DirectX SDK: ID3D11InfoQueue::GetMessage)

Properties

 | Name | Description
Public property | AllowedByStorageFilterCount | Get the number of messages that were allowed to pass through a storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetNumMessagesAllowedByStorageFilter)
Public property | DeniedByStorageFilterCount | Get the number of messages that were denied passage through a storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetNumMessagesDeniedByStorageFilter)
Public property | DiscardedByMessageCountLimitCount | Get the number of messages that were discarded due to the message count limit. (Also see DirectX SDK: ID3D11InfoQueue::GetNumMessagesDiscardedByMessageCountLimit)
Public property | MessageCountLimit | Get or set the maximum number of messages that can be added to the message queue. (Also see DirectX SDK: ID3D11InfoQueue::GetMessageCountLimit)
Public property | MuteDebugOutput | Get or set a boolean that turns the debug output on or off. (Also see DirectX SDK: ID3D11InfoQueue::GetMuteDebugOutput)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | StoredAllowedByRetrievalFilterCount | Get the number of messages that are able to pass through a retrieval filter. (Also see DirectX SDK: ID3D11InfoQueue::GetNumStoredMessagesAllowedByRetrievalFilter)
Public property | StoredCount | Get the number of messages currently stored in the message queue. (Also see DirectX SDK: ID3D11InfoQueue::GetNumStoredMessages)

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InfoQueue Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue Methods
InfoQueue Class See Also Send Feedback

The InfoQueue type exposes the following members.

Methods

 | Name | Description
Public method | AddApplicationMessage | Add a user-defined message to the message queue and send that message to debug output. (Also see DirectX SDK: ID3D11InfoQueue::AddApplicationMessage)
Public method | AddMessage | Add a debug message to the message queue and send that message to debug output. (Also see DirectX SDK: ID3D11InfoQueue::AddMessage)
Public method | ClearStoredMessages | Clear all messages from the message queue. (Also see DirectX SDK: ID3D11InfoQueue::ClearStoredMessages)
Public method | GetBreakOnCategory | Get a message category to break on when a message with that category passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetBreakOnCategory)
Public method | GetBreakOnId | Get a message identifier to break on when a message with that identifier passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetBreakOnID)
Public method | GetBreakOnSeverity | Get a message severity level to break on when a message with that severity level passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetBreakOnSeverity)
Public method | GetMessage | Get a message from the message queue. (Also see DirectX SDK: ID3D11InfoQueue::GetMessage)
Public method | SetBreakOnCategory | Set a message category to break on when a message with that category passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::SetBreakOnCategory)
Public method | SetBreakOnId | Set a message identifier to break on when a message with that identifier passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::SetBreakOnID)
Public method | SetBreakOnSeverity | Set a message severity level to break on when a message with that severity level passes through the storage filter. (Also see DirectX SDK: ID3D11InfoQueue::SetBreakOnSeverity)
Public method | TryGetMessage | Try to get a message from the message queue. (Also see DirectX SDK: ID3D11InfoQueue::GetMessage)

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


AddApplicationMessage Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..AddApplicationMessage Method
InfoQueue Class See Also Send Feedback
Add a user-defined message to the message queue and send that message to debug output.

(Also see DirectX SDK: ID3D11InfoQueue::AddApplicationMessage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void AddApplicationMessage(
    MessageSeverity severity,
    string description
)
Visual Basic
Public Sub AddApplicationMessage ( _
    severity As MessageSeverity, _
    description As String _
)
Visual C++
public:
void AddApplicationMessage(
    MessageSeverity severity,
    String^ description
)

Parameters

severity
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageSeverity
Severity of a message (see MessageSeverity).
description
Type: System..::..String
Message string.

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageSeverity


AddMessage Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..AddMessage Method
InfoQueue Class See Also Send Feedback
Add a debug message to the message queue and send that message to debug output.

(Also see DirectX SDK: ID3D11InfoQueue::AddMessage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void AddMessage(
    MessageCategory category,
    MessageSeverity severity,
    MessageId id,
    string description
)
Visual Basic
Public Sub AddMessage ( _
    category As MessageCategory, _
    severity As MessageSeverity, _
    id As MessageId, _
    description As String _
)
Visual C++
public:
void AddMessage(
    MessageCategory category,
    MessageSeverity severity,
    MessageId id,
    String^ description
)

Parameters

category
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageCategory
Category of a message (see MessageCategory).
severity
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageSeverity
Severity of a message (see MessageSeverity).
id
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageId
Unique identifier of a message (see MessageId).
description
Type: System..::..String
User-defined message.

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageCategory
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageSeverity
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageId


ClearStoredMessages Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..ClearStoredMessages Method
InfoQueue Class See Also Send Feedback
Clear all messages from the message queue.

(Also see DirectX SDK: ID3D11InfoQueue::ClearStoredMessages)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ClearStoredMessages()
Visual Basic
Public Sub ClearStoredMessages
Visual C++
public:
void ClearStoredMessages()

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetBreakOnCategory Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..GetBreakOnCategory Method
InfoQueue Class See Also Send Feedback
Get a message category to break on when a message with that category passes through the storage filter.

(Also see DirectX SDK: ID3D11InfoQueue::GetBreakOnCategory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool GetBreakOnCategory(
    MessageCategory category
)
Visual Basic
Public Function GetBreakOnCategory ( _
    category As MessageCategory _
) As Boolean
Visual C++
public:
bool GetBreakOnCategory(
    MessageCategory category
)

Parameters

category
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageCategory
Message category to break on (see MessageCategory).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageCategory


GetBreakOnId Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..GetBreakOnId Method
InfoQueue Class See Also Send Feedback
Get a message identifier to break on when a message with that identifier passes through the storage filter.

(Also see DirectX SDK: ID3D11InfoQueue::GetBreakOnID)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool GetBreakOnId(
    MessageId id
)
Visual Basic
Public Function GetBreakOnId ( _
    id As MessageId _
) As Boolean
Visual C++
public:
bool GetBreakOnId(
    MessageId id
)

Parameters

id
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageId
Message identifier to break on (see MessageId).

Return Value

Whether this breaking condition is turned on or off (true for on, false for off).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageId


GetBreakOnSeverity Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..GetBreakOnSeverity Method
InfoQueue Class See Also Send Feedback
Get a message severity level to break on when a message with that severity level passes through the storage filter.

(Also see DirectX SDK: ID3D11InfoQueue::GetBreakOnSeverity)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool GetBreakOnSeverity(
    MessageSeverity severity
)
Visual Basic
Public Function GetBreakOnSeverity ( _
    severity As MessageSeverity _
) As Boolean
Visual C++
public:
bool GetBreakOnSeverity(
    MessageSeverity severity
)

Parameters

severity
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageSeverity
Message severity level to break on (see MessageSeverity).

Return Value

Whether this breaking condition is turned on or off (true for on, false for off).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageSeverity


GetMessage Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..GetMessage Method
InfoQueue Class See Also Send Feedback
Get a message from the message queue.

(Also see DirectX SDK: ID3D11InfoQueue::GetMessage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Message GetMessage(
    ulong messageIndex
)
Visual Basic
Public Function GetMessage ( _
    messageIndex As ULong _
) As Message
Visual C++
public:
Message GetMessage(
    unsigned long long messageIndex
)

Parameters

messageIndex
Type: System..::..UInt64
Index into message queue after an optional retrieval filter has been applied. This can be between 0 and the number of messages in the message queue that pass through the retrieval filter (which can be obtained with GetNumStoredMessagesAllowedByRetrievalFilter(). 0 is the message at the front of the message queue.

Return Value

Returned message (see Message).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Message


SetBreakOnCategory Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..SetBreakOnCategory Method
InfoQueue Class See Also Send Feedback
Set a message category to break on when a message with that category passes through the storage filter.

(Also see DirectX SDK: ID3D11InfoQueue::SetBreakOnCategory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetBreakOnCategory(
    MessageCategory category,
    bool enable
)
Visual Basic
Public Sub SetBreakOnCategory ( _
    category As MessageCategory, _
    enable As Boolean _
)
Visual C++
public:
void SetBreakOnCategory(
    MessageCategory category,
    bool enable
)

Parameters

category
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageCategory
Message category to break on (see MessageCategory).
enable
Type: System..::..Boolean
Turns this breaking condition on or off (true for on, false for off).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageCategory


SetBreakOnId Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..SetBreakOnId Method
InfoQueue Class See Also Send Feedback
Set a message identifier to break on when a message with that identifier passes through the storage filter.

(Also see DirectX SDK: ID3D11InfoQueue::SetBreakOnID)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetBreakOnId(
    MessageId id,
    bool enable
)
Visual Basic
Public Sub SetBreakOnId ( _
    id As MessageId, _
    enable As Boolean _
)
Visual C++
public:
void SetBreakOnId(
    MessageId id,
    bool enable
)

Parameters

id
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageId
Message identifier to break on (see MessageId).
enable
Type: System..::..Boolean
Turns this breaking condition on or off (true for on, false for off).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageId


SetBreakOnSeverity Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..SetBreakOnSeverity Method
InfoQueue Class See Also Send Feedback
Set a message severity level to break on when a message with that severity level passes through the storage filter.

(Also see DirectX SDK: ID3D11InfoQueue::SetBreakOnSeverity)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetBreakOnSeverity(
    MessageSeverity severity,
    bool enable
)
Visual Basic
Public Sub SetBreakOnSeverity ( _
    severity As MessageSeverity, _
    enable As Boolean _
)
Visual C++
public:
void SetBreakOnSeverity(
    MessageSeverity severity,
    bool enable
)

Parameters

severity
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..MessageSeverity
A MessageSeverity, which represents a message severity level to break on.
enable
Type: System..::..Boolean
Turns this breaking condition on or off (true for on, false for off).

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TryGetMessage Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..TryGetMessage Method
InfoQueue Class See Also Send Feedback
Try to get a message from the message queue.

(Also see DirectX SDK: ID3D11InfoQueue::GetMessage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool TryGetMessage(
    ulong messageIndex,
    out Message message
)
Visual Basic
Public Function TryGetMessage ( _
    messageIndex As ULong, _
    <OutAttribute> ByRef message As Message _
) As Boolean
Visual C++
public:
bool TryGetMessage(
    unsigned long long messageIndex,
    [OutAttribute] Message% message
)

Parameters

messageIndex
Type: System..::..UInt64
Index into message queue after an optional retrieval filter has been applied. This can be between 0 and the number of messages in the message queue that pass through the retrieval filter (which can be obtained with GetNumStoredMessagesAllowedByRetrievalFilter(). Index 0 is the message at the front of the message queue.
message
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Message %
Returned message (see Message).

Return Value

True if successful; false otherwise.

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Message


InfoQueue Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue Properties
InfoQueue Class See Also Send Feedback

The InfoQueue type exposes the following members.

Properties

 | Name | Description
Public property | AllowedByStorageFilterCount | Get the number of messages that were allowed to pass through a storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetNumMessagesAllowedByStorageFilter)
Public property | DeniedByStorageFilterCount | Get the number of messages that were denied passage through a storage filter. (Also see DirectX SDK: ID3D11InfoQueue::GetNumMessagesDeniedByStorageFilter)
Public property | DiscardedByMessageCountLimitCount | Get the number of messages that were discarded due to the message count limit. (Also see DirectX SDK: ID3D11InfoQueue::GetNumMessagesDiscardedByMessageCountLimit)
Public property | MessageCountLimit | Get or set the maximum number of messages that can be added to the message queue. (Also see DirectX SDK: ID3D11InfoQueue::GetMessageCountLimit)
Public property | MuteDebugOutput | Get or set a boolean that turns the debug output on or off. (Also see DirectX SDK: ID3D11InfoQueue::GetMuteDebugOutput)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | StoredAllowedByRetrievalFilterCount | Get the number of messages that are able to pass through a retrieval filter. (Also see DirectX SDK: ID3D11InfoQueue::GetNumStoredMessagesAllowedByRetrievalFilter)
Public property | StoredCount | Get the number of messages currently stored in the message queue. (Also see DirectX SDK: ID3D11InfoQueue::GetNumStoredMessages)

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


AllowedByStorageFilterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..AllowedByStorageFilterCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages that were allowed to pass through a storage filter.

(Also see DirectX SDK: ID3D11InfoQueue::GetNumMessagesAllowedByStorageFilter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong AllowedByStorageFilterCount { get; }
Visual Basic
Public ReadOnly Property AllowedByStorageFilterCount As ULong
    Get
Visual C++
public:
property unsigned long long AllowedByStorageFilterCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DeniedByStorageFilterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..DeniedByStorageFilterCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages that were denied passage through a storage filter.

(Also see DirectX SDK: ID3D11InfoQueue::GetNumMessagesDeniedByStorageFilter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong DeniedByStorageFilterCount { get; }
Visual Basic
Public ReadOnly Property DeniedByStorageFilterCount As ULong
    Get
Visual C++
public:
property unsigned long long DeniedByStorageFilterCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DiscardedByMessageCountLimitCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..DiscardedByMessageCountLimitCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages that were discarded due to the message count limit.

(Also see DirectX SDK: ID3D11InfoQueue::GetNumMessagesDiscardedByMessageCountLimit)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong DiscardedByMessageCountLimitCount { get; }
Visual Basic
Public ReadOnly Property DiscardedByMessageCountLimitCount As ULong
    Get
Visual C++
public:
property unsigned long long DiscardedByMessageCountLimitCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MessageCountLimit Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..MessageCountLimit Property
InfoQueue Class See Also Send Feedback
Get or set the maximum number of messages that can be added to the message queue.

(Also see DirectX SDK: ID3D11InfoQueue::GetMessageCountLimit)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong MessageCountLimit { get; set; }
Visual Basic
Public Property MessageCountLimit As ULong
    Get
    Set
Visual C++
public:
property unsigned long long MessageCountLimit {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MuteDebugOutput Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..MuteDebugOutput Property
InfoQueue Class See Also Send Feedback
Get or set a boolean that turns the debug output on or off.

(Also see DirectX SDK: ID3D11InfoQueue::GetMuteDebugOutput)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool MuteDebugOutput { get; set; }
Visual Basic
Public Property MuteDebugOutput As Boolean
    Get
    Set
Visual C++
public:
property bool MuteDebugOutput {
    bool get ();
    void set (bool value);
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StoredAllowedByRetrievalFilterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..StoredAllowedByRetrievalFilterCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages that are able to pass through a retrieval filter.

(Also see DirectX SDK: ID3D11InfoQueue::GetNumStoredMessagesAllowedByRetrievalFilter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong StoredAllowedByRetrievalFilterCount { get; }
Visual Basic
Public ReadOnly Property StoredAllowedByRetrievalFilterCount As ULong
    Get
Visual C++
public:
property unsigned long long StoredAllowedByRetrievalFilterCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StoredCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InfoQueue..::..StoredCount Property
InfoQueue Class See Also Send Feedback
Get the number of messages currently stored in the message queue.

(Also see DirectX SDK: ID3D11InfoQueue::GetNumStoredMessages)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong StoredCount { get; }
Visual Basic
Public ReadOnly Property StoredCount As ULong
    Get
Visual C++
public:
property unsigned long long StoredCount {
    unsigned long long get ();
}

See Also

InfoQueue Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputAssemblerPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage Class
Members See Also Send Feedback
InputAssembler pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class InputAssemblerPipelineStage : PipelineStage
Visual Basic
Public Class InputAssemblerPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class InputAssemblerPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InputAssemblerPipelineStage

See Also

InputAssemblerPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputAssemblerPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage Members
InputAssemblerPipelineStage Class Constructors Methods Properties See Also Send Feedback

The InputAssemblerPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | InputAssemblerPipelineStage |

Methods

 | Name | Description
Public method | GetVertexBuffers | Get the vertex buffers bound to the input-assembler stage. (Also see DirectX SDK: ID3D11DeviceContext::IAGetVertexBuffers)
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(VertexBuffer>)>>)) |
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(D3DBuffer>)>>), array<UInt32>[]()[][], array<UInt32>[]()[][]) |

Properties

 | Name | Description
Public property | IndexBuffer | Gets or sets the index buffer that is bound to the input-assembler stage. (Also see DirectX SDK: ID3D11DeviceContext::IAGetIndexBuffer)
Public property | InputLayout | Gets or sets the input-layout object that is bound to the input-assembler stage. (See InputLayout) (Also see DirectX SDK: ID3D11DeviceContext::IAGetInputLayout, ID3D11DeviceContext::IASetInputLayout)
Protected property | Parent | (Inherited from PipelineStage.)
Public property | PrimitiveTopology | Get information about the primitive type, and data order that describes input data for the input assembler stage. (See PrimitiveTopology). (Also see DirectX SDK: ID3D11DeviceContext::IAGetPrimitiveTopology, ID3D11DeviceContext::IASetPrimitiveTopology)

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputAssemblerPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage Constructor
InputAssemblerPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected InputAssemblerPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
InputAssemblerPipelineStage()

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputAssemblerPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage Methods
InputAssemblerPipelineStage Class See Also Send Feedback

The InputAssemblerPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetVertexBuffers | Get the vertex buffers bound to the input-assembler stage. (Also see DirectX SDK: ID3D11DeviceContext::IAGetVertexBuffers)
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(VertexBuffer>)>>)) |
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(D3DBuffer>)>>), array<UInt32>[]()[][], array<UInt32>[]()[][]) |

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetVertexBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..GetVertexBuffers Method
InputAssemblerPipelineStage Class See Also Send Feedback
Get the vertex buffers bound to the input-assembler stage.

(Also see DirectX SDK: ID3D11DeviceContext::IAGetVertexBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<VertexBuffer> GetVertexBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetVertexBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of VertexBuffer)
Visual C++
public:
ReadOnlyCollection<VertexBuffer>^ GetVertexBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
The input slot of the first vertex buffer to get. The first vertex buffer is explicitly bound to the start slot; this causes each additional vertex buffer in the array to be implicitly bound to each subsequent input slot. There are 16 input slots.
bufferCount
Type: System..::..UInt32
The number of vertex buffers to get starting at the offset. The number of buffers (plus the starting slot) cannot exceed the total number of IA-stage input slots.

Return Value

A collection of vertex buffers returned by the method (see VertexBuffer).

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexBuffer


SetVertexBuffers Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..SetVertexBuffers Method
InputAssemblerPipelineStage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(VertexBuffer>)>>)) |
Public method | SetVertexBuffers(UInt32, IEnumerable<(Of <<'(D3DBuffer>)>>), array<UInt32>[]()[][], array<UInt32>[]()[][]) |

See Also

InputAssemblerPipelineStage Class
InputAssemblerPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetVertexBuffers Method (UInt32, IEnumerable(VertexBuffer))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..SetVertexBuffers Method (UInt32, IEnumerable<(Of <(<'VertexBuffer>)>)>)
InputAssemblerPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetVertexBuffers(
    uint startSlot,
    IEnumerable<VertexBuffer> vertexBuffers
)
Visual Basic
Public Sub SetVertexBuffers ( _
    startSlot As UInteger, _
    vertexBuffers As IEnumerable(Of VertexBuffer) _
)
Visual C++
public:
void SetVertexBuffers(
    unsigned int startSlot,
    IEnumerable<VertexBuffer>^ vertexBuffers
)

Parameters

startSlot
Type: System..::..UInt32
vertexBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' VertexBuffer >)>)>

See Also

InputAssemblerPipelineStage Class
SetVertexBuffers Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetVertexBuffers Method (UInt32, IEnumerable(D3DBuffer), UInt32[], UInt32[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..SetVertexBuffers Method (UInt32, IEnumerable<(Of <(<'D3DBuffer>)>)>, array<UInt32>[]()[][], array<UInt32>[]()[][])
InputAssemblerPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetVertexBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> vertexBuffers,
    uint[] strides,
    uint[] offsets
)
Visual Basic
Public Sub SetVertexBuffers ( _
    startSlot As UInteger, _
    vertexBuffers As IEnumerable(Of D3DBuffer), _
    strides As UInteger(), _
    offsets As UInteger() _
)
Visual C++
public:
void SetVertexBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ vertexBuffers,
    array<unsigned int>^ strides,
    array<unsigned int>^ offsets
)

Parameters

startSlot
Type: System..::..UInt32
vertexBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>
strides
Type: array< System..::..UInt32 >[]()[][]
offsets
Type: array< System..::..UInt32 >[]()[][]

See Also

InputAssemblerPipelineStage Class
SetVertexBuffers Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputAssemblerPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage Properties
InputAssemblerPipelineStage Class See Also Send Feedback

The InputAssemblerPipelineStage type exposes the following members.

Properties

 | Name | Description
Public property | IndexBuffer | Gets or sets the index buffer that is bound to the input-assembler stage. (Also see DirectX SDK: ID3D11DeviceContext::IAGetIndexBuffer)
Public property | InputLayout | Gets or sets the input-layout object that is bound to the input-assembler stage. (See InputLayout) (Also see DirectX SDK: ID3D11DeviceContext::IAGetInputLayout, ID3D11DeviceContext::IASetInputLayout)
Protected property | Parent | (Inherited from PipelineStage.)
Public property | PrimitiveTopology | Get information about the primitive type, and data order that describes input data for the input assembler stage. (See PrimitiveTopology). (Also see DirectX SDK: ID3D11DeviceContext::IAGetPrimitiveTopology, ID3D11DeviceContext::IASetPrimitiveTopology)

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


IndexBuffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..IndexBuffer Property
InputAssemblerPipelineStage Class See Also Send Feedback
Gets or sets the index buffer that is bound to the input-assembler stage.

(Also see DirectX SDK: ID3D11DeviceContext::IAGetIndexBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IndexBuffer IndexBuffer { get; set; }
Visual Basic
Public Property IndexBuffer As IndexBuffer
    Get
    Set
Visual C++
public:
property IndexBuffer IndexBuffer {
    IndexBuffer get ();
    void set (IndexBuffer value);
}

Remarks

Setting this property using a buffer that is currently bound for writing (i.e. bound to the stream output pipeline stage) will effectively bind null instead because a buffer cannot be bound as both an input and an output at the same time.

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputLayout Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..InputLayout Property
InputAssemblerPipelineStage Class See Also Send Feedback
Gets or sets the input-layout object that is bound to the input-assembler stage. (See InputLayout)

(Also see DirectX SDK: ID3D11DeviceContext::IAGetInputLayout, ID3D11DeviceContext::IASetInputLayout)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputLayout InputLayout { get; set; }
Visual Basic
Public Property InputLayout As InputLayout
    Get
    Set
Visual C++
public:
property InputLayout^ InputLayout {
    InputLayout^ get ();
    void set (InputLayout^ value);
}

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
InputAssemblerPipelineStage..::..InputLayout


PrimitiveTopology Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputAssemblerPipelineStage..::..PrimitiveTopology Property
InputAssemblerPipelineStage Class See Also Send Feedback
Get information about the primitive type, and data order that describes input data for the input assembler stage. (See PrimitiveTopology).

(Also see DirectX SDK: ID3D11DeviceContext::IAGetPrimitiveTopology, ID3D11DeviceContext::IASetPrimitiveTopology)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PrimitiveTopology PrimitiveTopology { get; set; }
Visual Basic
Public Property PrimitiveTopology As PrimitiveTopology
    Get
    Set
Visual C++
public:
property PrimitiveTopology PrimitiveTopology {
    PrimitiveTopology get ();
    void set (PrimitiveTopology value);
}

See Also

InputAssemblerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
InputAssemblerPipelineStage..::..PrimitiveTopology


InputClassification Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputClassification Enumeration
See Also Send Feedback
Type of data contained in an input slot.

(Also see DirectX SDK: D3D11_INPUT_CLASSIFICATION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum InputClassification
Visual Basic
Public Enumeration InputClassification
Visual C++
public enum class InputClassification

Members

Member name | Description
PerInstanceData |
PerVertexData |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputElementDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Structure
Members See Also Send Feedback
A description of a single element for the input-assembler stage.

(Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct InputElementDescription
Visual Basic
Public Structure InputElementDescription
Visual C++
public value class InputElementDescription

See Also

InputElementDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputElementDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Members
InputElementDescription Structure Methods Operators Properties See Also Send Feedback

The InputElementDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AlignedByteOffset | Optional. Offset (in bytes) between each element. Use D3D11_APPEND_ALIGNED_ELEMENT for convenience to define the current element directly after the previous one, including any packing if necessary. (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.AlignedByteOffset)
Public property | Format | The data type of the element data. See Format. (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.Format)
Public property | InputSlot | An integer value that identifies the input-assembler (see input slot). Valid values are between 0 and 15, defined in D3D11.h. (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.InputSlot)
Public property | InputSlotClass | Identifies the input data class for a single input slot (see InputClassification). (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.InputSlotClass)
Public property | InstanceDataStepRate | The number of instances to draw using the same per-instance data before advancing in the buffer by one element. This value must be 0 for an element that contains per-vertex data (the slot class is set to PerVertexData). (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.InstanceDataStepRate)
Public property | SemanticIndex | The semantic index for the element. A semantic index modifies a semantic, with an integer index number. A semantic index is only needed in a case where there is more than one element with the same semantic. For example, a 4x4 matrix would have four components each with the semantic name matrix, however each of the four component would have different semantic indices (0, 1, 2, and 3). (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.SemanticIndex)
Public property | SemanticName | The HLSL semantic associated with this element in a shader input-signature. (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.SemanticName)

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputElementDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Methods
InputElementDescription Structure See Also Send Feedback

The InputElementDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..Equals Method
InputElementDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..GetHashCode Method
InputElementDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputElementDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Operators
InputElementDescription Structure See Also Send Feedback

The InputElementDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..Equality Operator
InputElementDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    InputElementDescription inputElementDescription1,
    InputElementDescription inputElementDescription2
)
Visual Basic
Public Shared Operator = ( _
    inputElementDescription1 As InputElementDescription, _
    inputElementDescription2 As InputElementDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    InputElementDescription inputElementDescription1,
    InputElementDescription inputElementDescription2
)

Parameters

inputElementDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InputElementDescription
inputElementDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InputElementDescription

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..Inequality Operator
InputElementDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    InputElementDescription inputElementDescription1,
    InputElementDescription inputElementDescription2
)
Visual Basic
Public Shared Operator <> ( _
    inputElementDescription1 As InputElementDescription, _
    inputElementDescription2 As InputElementDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    InputElementDescription inputElementDescription1,
    InputElementDescription inputElementDescription2
)

Parameters

inputElementDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InputElementDescription
inputElementDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InputElementDescription

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputElementDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription Properties
InputElementDescription Structure See Also Send Feedback

The InputElementDescription type exposes the following members.

Properties

 | Name | Description
Public property | AlignedByteOffset | Optional. Offset (in bytes) between each element. Use D3D11_APPEND_ALIGNED_ELEMENT for convenience to define the current element directly after the previous one, including any packing if necessary. (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.AlignedByteOffset)
Public property | Format | The data type of the element data. See Format. (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.Format)
Public property | InputSlot | An integer value that identifies the input-assembler (see input slot). Valid values are between 0 and 15, defined in D3D11.h. (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.InputSlot)
Public property | InputSlotClass | Identifies the input data class for a single input slot (see InputClassification). (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.InputSlotClass)
Public property | InstanceDataStepRate | The number of instances to draw using the same per-instance data before advancing in the buffer by one element. This value must be 0 for an element that contains per-vertex data (the slot class is set to PerVertexData). (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.InstanceDataStepRate)
Public property | SemanticIndex | The semantic index for the element. A semantic index modifies a semantic, with an integer index number. A semantic index is only needed in a case where there is more than one element with the same semantic. For example, a 4x4 matrix would have four components each with the semantic name matrix, however each of the four component would have different semantic indices (0, 1, 2, and 3). (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.SemanticIndex)
Public property | SemanticName | The HLSL semantic associated with this element in a shader input-signature. (Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.SemanticName)

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


AlignedByteOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..AlignedByteOffset Property
InputElementDescription Structure See Also Send Feedback
Optional. Offset (in bytes) between each element. Use D3D11_APPEND_ALIGNED_ELEMENT for convenience to define the current element directly after the previous one, including any packing if necessary.

(Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.AlignedByteOffset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint AlignedByteOffset { get; set; }
Visual Basic
Public Property AlignedByteOffset As UInteger
    Get
    Set
Visual C++
public:
property unsigned int AlignedByteOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..Format Property
InputElementDescription Structure See Also Send Feedback
The data type of the element data. See Format.

(Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputSlot Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..InputSlot Property
InputElementDescription Structure See Also Send Feedback
An integer value that identifies the input-assembler (see input slot). Valid values are between 0 and 15, defined in D3D11.h.

(Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.InputSlot)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InputSlot { get; set; }
Visual Basic
Public Property InputSlot As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InputSlot {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputSlotClass Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..InputSlotClass Property
InputElementDescription Structure See Also Send Feedback
Identifies the input data class for a single input slot (see InputClassification).

(Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.InputSlotClass)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InputClassification InputSlotClass { get; set; }
Visual Basic
Public Property InputSlotClass As InputClassification
    Get
    Set
Visual C++
public:
property InputClassification InputSlotClass {
    InputClassification get ();
    void set (InputClassification value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InputClassification


InstanceDataStepRate Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..InstanceDataStepRate Property
InputElementDescription Structure See Also Send Feedback
The number of instances to draw using the same per-instance data before advancing in the buffer by one element. This value must be 0 for an element that contains per-vertex data (the slot class is set to PerVertexData).

(Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.InstanceDataStepRate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint InstanceDataStepRate { get; set; }
Visual Basic
Public Property InstanceDataStepRate As UInteger
    Get
    Set
Visual C++
public:
property unsigned int InstanceDataStepRate {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SemanticIndex Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..SemanticIndex Property
InputElementDescription Structure See Also Send Feedback
The semantic index for the element. A semantic index modifies a semantic, with an integer index number. A semantic index is only needed in a case where there is more than one element with the same semantic. For example, a 4x4 matrix would have four components each with the semantic name matrix, however each of the four component would have different semantic indices (0, 1, 2, and 3).

(Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.SemanticIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SemanticIndex { get; set; }
Visual Basic
Public Property SemanticIndex As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SemanticIndex {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SemanticName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputElementDescription..::..SemanticName Property
InputElementDescription Structure See Also Send Feedback
The HLSL semantic associated with this element in a shader input-signature.

(Also see DirectX SDK: D3D11_INPUT_ELEMENT_DESC.SemanticName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string SemanticName { get; set; }
Visual Basic
Public Property SemanticName As String
    Get
    Set
Visual C++
public:
property String^ SemanticName {
    String^ get ();
    void set (String^ value);
}

See Also

InputElementDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputLayout Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputLayout Class
Members See Also Send Feedback
An input-layout interface accesses the input data for the input-assembler stage.

(Also see DirectX SDK: ID3D11InputLayout)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class InputLayout : DeviceChild
Visual Basic
Public Class InputLayout _
    Inherits DeviceChild
Visual C++
public ref class InputLayout : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InputLayout

See Also

InputLayout Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputLayout Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputLayout Members
InputLayout Class Properties See Also Send Feedback

The InputLayout type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

InputLayout Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputLayout Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InputLayout Properties
InputLayout Class See Also Send Feedback

The InputLayout type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

InputLayout Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


LiveDeviceObjectsReportOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LiveDeviceObjectsReportOptions Enumeration
See Also Send Feedback
Options for the amount of information returned about live device objects.

(Also see DirectX SDK: D3D11_RLDO_FLAGS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum LiveDeviceObjectsReportOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration LiveDeviceObjectsReportOptions
Visual C++
[FlagsAttribute]
public enum class LiveDeviceObjectsReportOptions

Members

Member name | Description
Detail |
Summary |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Map Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Map Enumeration
See Also Send Feedback
Identifies a resource to be accessed for reading and writing by the CPU. Applications may combine one or more of these flags.

(Also see DirectX SDK: D3D11_MAP)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Map
Visual Basic
Public Enumeration Map
Visual C++
public enum class Map

Members

Member name | Description
WriteNoOverwrite |
WriteDiscard |
ReadWrite |
Write |
Read |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MapOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MapOptions Enumeration
See Also Send Feedback
Specifies how the CPU should respond when Map is called on a resource being used by the GPU.

(Also see DirectX SDK: D3D11_MAP_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum MapOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration MapOptions
Visual C++
[FlagsAttribute]
public enum class MapOptions

Members

Member name | Description
DoNotWait |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MappedSubresource Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedSubresource Structure
Members See Also Send Feedback
Provides access to subresource data.

(Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct MappedSubresource
Visual Basic
Public Structure MappedSubresource
Visual C++
public value class MappedSubresource

See Also

MappedSubresource Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MappedSubresource Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedSubresource Members
MappedSubresource Structure Properties See Also Send Feedback

The MappedSubresource type exposes the following members.

Properties

 | Name | Description
Public property | Data | Pointer to the data. (Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE.pData)
Public property | DepthPitch | The depth pitch, or width, or physical size (in bytes)of the data. (Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE.DepthPitch)
Public property | RowPitch | The row pitch, or width, or physical size (in bytes) of the data. (Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE.RowPitch)

See Also

MappedSubresource Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MappedSubresource Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedSubresource Properties
MappedSubresource Structure See Also Send Feedback

The MappedSubresource type exposes the following members.

Properties

 | Name | Description
Public property | Data | Pointer to the data. (Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE.pData)
Public property | DepthPitch | The depth pitch, or width, or physical size (in bytes)of the data. (Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE.DepthPitch)
Public property | RowPitch | The row pitch, or width, or physical size (in bytes) of the data. (Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE.RowPitch)

See Also

MappedSubresource Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Data Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedSubresource..::..Data Property
MappedSubresource Structure See Also Send Feedback
Pointer to the data.

(Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE.pData)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr Data { get; set; }
Visual Basic
Public Property Data As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr Data {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

MappedSubresource Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthPitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedSubresource..::..DepthPitch Property
MappedSubresource Structure See Also Send Feedback
The depth pitch, or width, or physical size (in bytes)of the data.

(Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE.DepthPitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DepthPitch { get; set; }
Visual Basic
Public Property DepthPitch As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DepthPitch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

MappedSubresource Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RowPitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedSubresource..::..RowPitch Property
MappedSubresource Structure See Also Send Feedback
The row pitch, or width, or physical size (in bytes) of the data.

(Also see DirectX SDK: D3D11_MAPPED_SUBRESOURCE.RowPitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint RowPitch { get; set; }
Visual Basic
Public Property RowPitch As UInteger
    Get
    Set
Visual C++
public:
property unsigned int RowPitch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

MappedSubresource Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Message Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Structure
Members See Also Send Feedback
A debug message in the Information Queue.

(Also see DirectX SDK: D3D11_MESSAGE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Message
Visual Basic
Public Structure Message
Visual C++
public value class Message

See Also

Message Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Message Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Members
Message Structure Methods Operators Properties See Also Send Feedback

The Message type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Category | The category of the message. See MessageCategory. (Also see DirectX SDK: D3D11_MESSAGE.Category)
Public property | Description | The message string. (Also see DirectX SDK: D3D11_MESSAGE.pDescription)
Public property | Id | The ID of the message. See MessageId. (Also see DirectX SDK: D3D11_MESSAGE.ID)
Public property | Severity | The severity of the message. See MessageSeverity. (Also see DirectX SDK: D3D11_MESSAGE.Severity)

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Message Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Methods
Message Structure See Also Send Feedback

The Message type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Equals Method
Message Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..GetHashCode Method
Message Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Message Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Operators
Message Structure See Also Send Feedback

The Message type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Equality Operator
Message Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Message message1,
    Message message2
)
Visual Basic
Public Shared Operator = ( _
    message1 As Message, _
    message2 As Message _
) As Boolean
Visual C++
public:
static bool operator ==(
    Message message1,
    Message message2
)

Parameters

message1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Message
message2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Message

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Inequality Operator
Message Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Message message1,
    Message message2
)
Visual Basic
Public Shared Operator <> ( _
    message1 As Message, _
    message2 As Message _
) As Boolean
Visual C++
public:
static bool operator !=(
    Message message1,
    Message message2
)

Parameters

message1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Message
message2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Message

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Message Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message Properties
Message Structure See Also Send Feedback

The Message type exposes the following members.

Properties

 | Name | Description
Public property | Category | The category of the message. See MessageCategory. (Also see DirectX SDK: D3D11_MESSAGE.Category)
Public property | Description | The message string. (Also see DirectX SDK: D3D11_MESSAGE.pDescription)
Public property | Id | The ID of the message. See MessageId. (Also see DirectX SDK: D3D11_MESSAGE.ID)
Public property | Severity | The severity of the message. See MessageSeverity. (Also see DirectX SDK: D3D11_MESSAGE.Severity)

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Category Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Category Property
Message Structure See Also Send Feedback
The category of the message. See MessageCategory.

(Also see DirectX SDK: D3D11_MESSAGE.Category)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MessageCategory Category { get; set; }
Visual Basic
Public Property Category As MessageCategory
    Get
    Set
Visual C++
public:
property MessageCategory Category {
    MessageCategory get ();
    void set (MessageCategory value);
}

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Description Property
Message Structure See Also Send Feedback
The message string.

(Also see DirectX SDK: D3D11_MESSAGE.pDescription)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Id Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Id Property
Message Structure See Also Send Feedback
The ID of the message. See MessageId.

(Also see DirectX SDK: D3D11_MESSAGE.ID)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MessageId Id { get; set; }
Visual Basic
Public Property Id As MessageId
    Get
    Set
Visual C++
public:
property MessageId Id {
    MessageId get ();
    void set (MessageId value);
}

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Severity Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Message..::..Severity Property
Message Structure See Also Send Feedback
The severity of the message. See MessageSeverity.

(Also see DirectX SDK: D3D11_MESSAGE.Severity)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MessageSeverity Severity { get; set; }
Visual Basic
Public Property Severity As MessageSeverity
    Get
    Set
Visual C++
public:
property MessageSeverity Severity {
    MessageSeverity get ();
    void set (MessageSeverity value);
}

See Also

Message Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MessageCategory Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MessageCategory Enumeration
See Also Send Feedback
Categories of debug messages. This will identify the category of a message when retrieving a message with InfoQueue.GetMessage and when adding a message with InfoQueue.AddMessage. When creating an info queue filter, these values can be used to allow or deny any categories of messages to pass through the storage and retrieval filters.

(Also see DirectX SDK: D3D11_MESSAGE_CATEGORY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum MessageCategory
Visual Basic
Public Enumeration MessageCategory
Visual C++
public enum class MessageCategory

Members

Member name | Description
Execution |
ResourceManipulation |
StateGetting |
StateSetting |
StateCreation |
Compilation |
Cleanup |
Initialization |
Miscellaneous |
ApplicationDefined |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MessageId Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MessageId Enumeration
See Also Send Feedback
Debug messages for setting up an info-queue filter; use these messages to allow or deny message categories to pass through the storage and retrieval filters. These IDs are used by methods such as InfoQueue.GetMessage or InfoQueue.AddMessage.

(Also see DirectX SDK: D3D11_MESSAGE_ID)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum MessageId
Visual Basic
Public Enumeration MessageId
Visual C++
public enum class MessageId

Members

Member name | Description
CreateInputLayoutTooManyElements |
CreateInputLayoutOutOfMemory |
CreateDepthStencilViewOutOfMemoryReturn |
CreateDepthStencilViewInvalidArgReturn |
CreateDepthStencilViewTooManyObjects |
CreateDepthStencilViewInvalidResource |
CreateDepthStencilViewInvalidDimensions |
CreateDepthStencilViewInvalidFormat |
CreateDepthStencilViewInvalidDesc |
CreateDepthStencilViewUnrecognizedFormat |
CreateRenderTargetViewOutOfMemoryReturn |
CreateRenderTargetViewInvalidArgReturn |
CreateRenderTargetViewTooManyObjects |
CreateRenderTargetViewInvalidResource |
CreateRenderTargetViewInvalidDimensions |
CreateRenderTargetViewInvalidFormat |
CreateRenderTargetViewInvalidDesc |
CreateRenderTargetViewUnsupportedFormat |
CreateRenderTargetViewUnrecognizedFormat |
CreateShaderResourceViewOutOfMemoryReturn |
CreateShaderResourceViewInvalidArgReturn |
CreateShaderResourceViewTooManyObjects |
CreateShaderResourceViewInvalidResource |
CreateShaderResourceViewInvalidDimensions |
CreateShaderResourceViewInvalidFormat |
CreateShaderResourceViewInvalidDesc |
CreateShaderResourceViewUnrecognizedFormat |
CreateTexture3DLargeAllocation |
CreateTexture3DNullDesc |
CreateTexture3DOutOfMemoryReturn |
CreateTexture3DInvalidArgReturn |
CreateTexture3DInvalidMiscFlags |
CreateTexture3DInvalidMipLevels |
CreateTexture3DInvalidDimensions |
CreateTexture3DInvalidInitialData |
CreateTexture3DInvalidBindFlags |
CreateTexture3DInvalidCpuAccessFlags |
CreateTexture3DUnrecognizedMiscFlags |
CreateTexture3DUnrecognizedCpuAccessFlags |
CreateTexture3DUnrecognizedBindFlags |
CreateTexture3DUnrecognizedUsage |
CreateTexture3DInvalidSamples |
CreateTexture3DUnsupportedFormat |
CreateTexture3DUnrecognizedFormat |
CreateTexture2DLargeAllocation |
CreateTexture2DNullDesc |
CreateTexture2DOutOfMemoryReturn |
CreateTexture2DInvalidArgReturn |
CreateTexture2DInvalidMiscFlags |
CreateTexture2DInvalidMipLevels |
CreateTexture2DInvalidDimensions |
CreateTexture2DInvalidInitialData |
CreateTexture2DInvalidBindFlags |
CreateTexture2DInvalidCpuAccessFlags |
CreateTexture2DUnrecognizedMiscFlags |
CreateTexture2DUnrecognizedCpuAccessFlags |
CreateTexture2DUnrecognizedBindFlags |
CreateTexture2DUnrecognizedUsage |
CreateTexture2DInvalidSamples |
CreateTexture2DUnsupportedFormat |
CreateTexture2DUnrecognizedFormat |
CreateTexture1DLargeAllocation |
CreateTexture1DNullDesc |
CreateTexture1DOutOfMemoryReturn |
CreateTexture1DInvalidArgReturn |
CreateTexture1DInvalidMiscFlags |
CreateTexture1DInvalidMipLevels |
CreateTexture1DInvalidDimensions |
CreateTexture1DInvalidInitialData |
CreateTexture1DInvalidBindFlags |
CreateTexture1DInvalidCpuAccessFlags |
CreateTexture1DUnrecognizedMiscFlags |
CreateTexture1DUnrecognizedCpuAccessFlags |
CreateTexture1DUnrecognizedBindFlags |
CreateTexture1DUnrecognizedUsage |
CreateTexture1DInvalidSamples |
CreateTexture1DUnsupportedFormat |
CreateTexture1DUnrecognizedFormat |
CreateBufferLargeAllocation |
CreateBufferInvalidConstantBufferBindings |
CreateBufferNullDesc |
CreateBufferOutOfMemoryReturn |
CreateBufferInvalidArgReturn |
CreateBufferInvalidMiscFlags |
CreateBufferInvalidMipLevels |
CreateBufferInvalidDimensions |
CreateBufferInvalidInitialData |
CreateBufferInvalidBindFlags |
CreateBufferInvalidCpuAccessFlags |
CreateBufferUnrecognizedMiscFlags |
CreateBufferUnrecognizedCpuAccessFlags |
CreateBufferUnrecognizedBindFlags |
CreateBufferUnrecognizedUsage |
CreateBufferInvalidSamples |
CreateBufferUnrecognizedFormat |
SetPrivateDataOutOfMemory |
SetPrivateDataChangingParams |
SetPrivateDataInvalidFlags |
SetPrivateDataInvalidIUnknown |
SetPrivateDataInvalidFreeData |
GetPrivateDataMoreData |
SetPredicationUnbindDeletingObject |
OMSetRenderTargetsUnbindDeletingObject |
OMSetDepthStencilStateUnbindDeletingObject |
OMSetBlendStateUnbindDeletingObject |
RSSetStateUnbindDeletingObject |
PSSetSamplersUnbindDeletingObject |
PSSetConstantBuffersUnbindDeletingObject |
PSSetShaderResourcesUnbindDeletingObject |
PSSetShaderUnbindDeletingObject |
SOSetTargetsUnbindDeletingObject |
GSSetSamplersUnbindDeletingObject |
GSSetConstantBuffersUnbindDeletingObject |
GSSetShaderResourcesUnbindDeletingObject |
GSSetShaderUnbindDeletingObject |
VSSetSamplersUnbindDeletingObject |
VSSetConstantBuffersUnbindDeletingObject |
VSSetShaderResourcesUnbindDeletingObject |
VSSetShaderUnbindDeletingObject |
IASetIndexBufferUnbindDeletingObject |
IASetVertexBuffersUnbindDeletingObject |
IASetInputLayoutUnbindDeletingObject |
MessageReportingOutOfMemory |
CorruptedMultithreading |
CorruptedParameter15 |
CorruptedParameter14 |
CorruptedParameter13 |
CorruptedParameter12 |
CorruptedParameter11 |
CorruptedParameter10 |
CorruptedParameter9 |
CorruptedParameter8 |
CorruptedParameter7 |
CorruptedParameter6 |
CorruptedParameter5 |
CorruptedParameter4 |
CorruptedParameter3 |
CorruptedParameter2 |
CorruptedParameter1 |
CorruptedThis |
StringFromApplication |
DeviceSOSetTargetsHazard |
DeviceOMSetRenderTargetsHazard |
DevicePSSetConstantBuffersHazard |
DevicePSSetShaderResourcesHazard |
DeviceGSSetConstantBuffersHazard |
DeviceGSSetShaderResourcesHazard |
DeviceVSSetConstantBuffersHazard |
DeviceVSSetShaderResourcesHazard |
DeviceIASetIndexBufferHazard |
DeviceIASetVertexBuffersHazard |
DeviceDrawResourceFormatGatherUnsupported |
DeviceDrawPSOutputTypeMismatch |
QueryGetDataInvalidCall |
QueryGetDataInvalidFlags |
QueryGetDataInvalidDataSize |
QueryEndWithoutBegin |
QueryEndAbandoningPreviousResults |
PredicateEndDuringPredication |
QueryBeginAbandoningPreviousResults |
QueryBeginDuplicate |
PredicateBeginDuringPredication |
QueryBeginUnsupported |
SetPredicationInvalidPredicateState |
CheckCounterUnsupportedWellKnownCounter |
CheckCounterOutOfRangeCounter |
CreateCounterNullDesc |
CreateCounterNonexclusiveReturn |
CreateCounterOutOfMemoryReturn |
CreateCounterUnsupportedWellKnownCounter |
CreateCounterSimultaneousActiveCountersExhausted |
CreateCounterOutOfRangeCounter |
CreatePredicateOutOfMemoryReturn |
CreateQueryOutOfMemoryReturn |
ShaderResourceViewGetDescLegacy |
BlendStateGetDescLegacy |
CreateInputLayoutTypeMismatch |
DeviceDrawSamplerMismatch |
DeviceSetTextFilterSizeInvalidDimensions |
OMSetRenderTargetsInvalidView |
DeviceRSSetViewportsDenormFlush |
CreateGeometryShaderWithStreamOutputTrailingDigitInSemantic |
CreateInputLayoutTrailingDigitInSemantic |
DeviceDrawViewportNotSet |
DeviceOpenSharedResourceBadInterfaceReturn |
DeviceOpenSharedResourceOutOfMemoryReturn |
DeviceOpenSharedResourceInvalidArgReturn |
DeviceRemovalProcessNotAtFault |
DeviceRemovalProcessPossiblyAtFault |
DeviceRemovalProcessAtFault |
DeviceDrawOMDualSourceBlendingCanOnlyHaveRenderTargetZero |
DeviceDrawOMRenderTargetDoesNotSupportBlending |
DeviceDrawSoStrideLargerThanBuffer |
DeviceDrawSoTargetsBoundWithoutSource |
DeviceDrawResourceMultisampleUnsupported |
DeviceDrawResourceFormatSampleCUnsupported |
DeviceDrawResourceFormatSampleUnsupported |
DeviceDrawResourceFormatLDUnsupported |
DeviceDrawOutputStreamOffsetUnaligned |
DeviceDrawIndexOffsetUnaligned |
DeviceDrawVertexStrideUnaligned |
DeviceDrawVertexOffsetUnaligned |
DeviceDrawInvalidPrimitiveTopology |
DeviceDrawBoundResourceMapped |
DeviceDrawOutputStreamNotSet |
DeviceDrawPositionNotPresent |
DeviceDrawResourceReturnTypeMismatch |
DeviceDrawGSInputPrimitiveMismatch |
DeviceDrawIndexBufferTooSmall |
DeviceDrawIndexBufferFormatInvalid |
DeviceDrawIndexBufferNotSet |
DeviceDrawVertexBufferTooSmall |
DeviceDrawVertexBufferStrideTooSmall |
DeviceDrawViewDimensionMismatch |
DeviceDrawShaderResourceViewNotSet |
DeviceDrawSamplerNotSet |
DeviceDrawConstantBufferTooSmall |
DeviceDrawConstantBufferNotSet |
DeviceDrawInputLayoutNotSet |
DeviceDrawVertexBufferNotSet |
DeviceShaderLinkageNeverWrittenAlwaysReads |
DeviceShaderLinkageSystemValue |
DeviceShaderLinkageRegisterMask |
DeviceShaderLinkageComponentType |
DeviceShaderLinkageRegisterIndex |
DeviceShaderLinkageSemanticNameNotFound |
DeviceDrawVertexShaderNotSet |
DeviceDrawIndexedInstancedIndexPosOverflow |
DeviceDrawIndexedInstancedInstancePosOverflow |
DeviceDrawInstancedInstancePosOverflow |
DeviceDrawInstancedVertexPosOverflow |
DeviceDrawIndexedIndexPosOverflow |
DeviceDrawVertexPosOverflow |
RefInfo |
RefOutOfMemory |
RefProblemParsingShader |
RefAccessingIndexableTempOutOfRange |
RefHardwareException |
RefKernelModeDriverException |
RefUserModeDriverException |
RefThreadingMode |
RefSimulatingInfinitelyFastHardware |
SetExceptionModeDeviceRemovedReturn |
SetExceptionModeInvalidArgReturn |
SetExceptionModeUnrecognizedFlags |
CheckMultisampleQualityLevelsFormatDeprecated |
CheckFormatSupportFormatDeprecated |
Texture3DUnmapNotMapped |
Texture3DUnmapInvalidSubresource |
Texture3DMapDeviceRemovedReturn |
Texture3DMapAlreadyMapped |
Texture3DMapInvalidFlags |
Texture3DMapInvalidSubresource |
Texture3DMapInvalidMapType |
Texture2DUnmapNotMapped |
Texture2DUnmapInvalidSubresource |
Texture2DMapDeviceRemovedReturn |
Texture2DMapAlreadyMapped |
Texture2DMapInvalidFlags |
Texture2DMapInvalidSubresource |
Texture2DMapInvalidMapType |
Texture1DUnmapNotMapped |
Texture1DUnmapInvalidSubresource |
Texture1DMapDeviceRemovedReturn |
Texture1DMapAlreadyMapped |
Texture1DMapInvalidFlags |
Texture1DMapInvalidSubresource |
Texture1DMapInvalidMapType |
BufferUnmapNotMapped |
BufferMapDeviceRemovedReturn |
BufferMapAlreadyMapped |
BufferMapInvalidFlags |
BufferMapInvalidMapType |
DeviceResolveSubresourceFormatInvalid |
DeviceResolveSubresourceSourceSubresourceInvalid |
DeviceResolveSubresourceSourceInvalid |
DeviceResolveSubresourceDestinationSubresourceInvalid |
DeviceResolveSubresourceDestinationInvalid |
UpdateSubresourceInvalidDestinationState |
UpdateSubresourceInvalidDestinationBox |
UpdateSubresourceInvalidDestinationSubresource |
CopyResourceInvalidSourceState |
CopyResourceInvalidDestinationState |
CopyResourceInvalidSource |
CopySubresourceRegionInvalidSourceState |
CopySubresourceRegionInvalidDestinationState |
CopySubresourceRegionInvalidSource |
CopySubresourceRegionInvalidSourceBox |
CopySubresourceRegionInvalidSourceSubresource |
CopySubresourceRegionInvalidDestinationSubresource |
DeviceGenerateMipsResourceInvalid |
DeviceRSGetScissorRectsRectsEmpty |
DeviceRSGetViewportsViewportsEmpty |
DevicePSGetSamplersSamplersEmpty |
DevicePSGetConstantBuffersBuffersEmpty |
DevicePSGetShaderResourcesViewsEmpty |
DeviceSoGetTargetsBuffersEmpty |
DeviceGSGetSamplersSamplersEmpty |
DeviceGSGetConstantBuffersBuffersEmpty |
DeviceGSGetShaderResourcesViewsEmpty |
DeviceVSGetSamplersSamplersEmpty |
DeviceVSGetConstantBuffersBuffersEmpty |
DeviceVSGetShaderResourcesViewsEmpty |
DeviceIAGetVertexBuffersBuffersEmpty |
ClearDepthStencilViewInvalid |
ClearDepthStencilViewDenormFlush |
ClearRenderTargetViewDenormFlush |
DeviceRSSetScissorRectsInvalidScissor |
DeviceRSSetViewportsInvalidViewport |
DevicePSSetSamplersSamplersEmpty |
DevicePSSetConstantBuffersBuffersEmpty |
PSSetConstantBuffersInvalidBuffer |
DevicePSSetShaderResourcesViewsEmpty |
DeviceSoSetTargetsOffsetUnaligned |
SoSetTargetsInvalidBuffer |
DeviceGSSetSamplersSamplersEmpty |
DeviceGSSetConstantBuffersBuffersEmpty |
GSSetConstantBuffersInvalidBuffer |
DeviceGSSetShaderResourcesViewsEmpty |
DeviceVSSetSamplersSamplersEmpty |
DeviceVSSetConstantBuffersBuffersEmpty |
VSSetConstantBuffersInvalidBuffer |
DeviceVSSetShaderResourcesViewsEmpty |
DeviceIASetIndexBufferOffsetUnaligned |
DeviceIASetIndexBufferOffsetTooLarge |
DeviceIASetIndexBufferFormatInvalid |
IASetIndexBufferInvalidBuffer |
DeviceIASetVertexBuffersBuffersEmpty |
DeviceIASetVertexBuffersOffsetTooLarge |
IASetVertexBuffersInvalidBuffer |
DeviceIASetPrimitiveTopologyTopologyUndefined |
DeviceIASetPrimitiveTopologyTopologyUnrecognized |
CreateQueryOrPredicateNullDesc |
CreateQueryOrPredicateUnexpectedMiscFlag |
CreateQueryOrPredicateInvalidMiscFlags |
CreateQueryOrPredicateInvalidQuery |
CreateSamplerStateNullDesc |
CreateSamplerStateTooManyObjects |
CreateSamplerStateInvalidMaxLod |
CreateSamplerStateInvalidMinLod |
CreateSamplerStateInvalidComparisonFunc |
CreateSamplerStateInvalidMaxAnisotropy |
CreateSamplerStateInvalidMipLodBias |
CreateSamplerStateInvalidAddressW |
CreateSamplerStateInvalidAddressV |
CreateSamplerStateInvalidAddressU |
CreateSamplerStateInvalidFilter |
CreateBlendStateNullDesc |
CreateBlendStateTooManyObjects |
CreateBlendStateInvalidRenderTargetWriteMask |
CreateBlendStateInvalidBlendOperationAlpha |
CreateBlendStateInvalidDestinationBlendAlpha |
CreateBlendStateInvalidSourceBlendAlpha |
CreateBlendStateInvalidBlendOperation |
CreateBlendStateInvalidDestinationBlend |
CreateBlendStateInvalidSourceBlend |
CreateDepthStencilStateNullDesc |
CreateDepthStencilStateTooManyObjects |
CreateDepthStencilStateInvalidBackFaceStencilFunc |
CreateDepthStencilStateInvalidBackFaceStencilPassOperation |
CreateDepthStencilStateInvalidBackFaceStencilZFailOperation |
CreateDepthStencilStateInvalidBackFaceStencilFailOperation |
CreateDepthStencilStateInvalidFrontFaceStencilFunc |
CreateDepthStencilStateInvalidFrontFaceStencilPassOperation |
CreateDepthStencilStateInvalidFrontFaceStencilZFailOperation |
CreateDepthStencilStateInvalidFrontFaceStencilFailOperation |
CreateDepthStencilStateInvalidDepthFunc |
CreateDepthStencilStateInvalidDepthWriteMask |
CreateRasterizerStateNullDesc |
CreateRasterizerStateTooManyObjects |
CreateRasterizerStateInvalidSlopeScaledDepthBias |
CreateRasterizerStateInvalidDepthBiasClamp |
CreateRasterizerStateInvalidCullMode |
CreateRasterizerStateInvalidFillMode |
CreatePixelShaderInvalidShaderType |
CreatePixelShaderInvalidShaderBytecode |
CreatePixelShaderOutOfMemory |
CreateGeometryShaderWithStreamOutputMissingOutputSignature |
CreateGeometryShaderWithStreamOutputDeclTooComplex |
CreateGeometryShaderWithStreamOutputCannotHaveOnlyGaps |
CreateGeometryShaderWithStreamOutputMaskMismatch |
CreateGeometryShaderWithStreamOutputMissingSemantic |
CreateGeometryShaderWithStreamOutputInvalidOutputStreamStride |
CreateGeometryShaderWithStreamOutputRepeatedOutput |
CreateGeometryShaderWithStreamOutputInvalidGapDefinition |
CreateGeometryShaderWithStreamOutputInvalidStartComponentAndComponentCount |
CreateGeometryShaderWithStreamOutputInvalidComponentCount |
CreateGeometryShaderWithStreamOutputOnlyOneElementPerSlot |
CreateGeometryShaderWithStreamOutputInvalidOutputSlot |
CreateGeometryShaderWithStreamOutputOutputSlot0Expected |
CreateGeometryShaderWithStreamOutputExpectedDecl |
CreateGeometryShaderWithStreamOutputUnexpectedDecl |
CreateGeometryShaderWithStreamOutputOutputStreamStrideUnused |
CreateGeometryShaderWithStreamOutputInvalidNumEntries |
CreateGeometryShaderWithStreamOutputInvalidShaderType |
CreateGeometryShaderWithStreamOutputInvalidShaderBytecode |
CreateGeometryShaderWithStreamOutputOutOfMemory |
CreateGeometryShaderInvalidShaderType |
CreateGeometryShaderInvalidShaderBytecode |
CreateGeometryShaderOutOfMemory |
CreateVertexShaderInvalidShaderType |
CreateVertexShaderInvalidShaderBytecode |
CreateVertexShaderOutOfMemory |
CreateInputLayoutNullDesc |
CreateInputLayoutMissingElement |
CreateInputLayoutNullSemantic |
CreateInputLayoutUnparsableInputSignature |
CreateInputLayoutDuplicateSemantic |
CreateInputLayoutInvalidAlignment |
CreateInputLayoutInvalidStepRateChange |
CreateInputLayoutInvalidSlotClassChange |
CreateInputLayoutStepRateSlotClassMismatch |
CreateInputLayoutInvalidInputSlotClass |
CreateInputLayoutInvalidSlot |
CreateInputLayoutIncompatibleFormat |
CreateInputLayoutInvalidFormat |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MessageSeverity Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MessageSeverity Enumeration
See Also Send Feedback
Debug message severity levels for an information queue.

(Also see DirectX SDK: D3D11_MESSAGE_SEVERITY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum MessageSeverity
Visual Basic
Public Enumeration MessageSeverity
Visual C++
public enum class MessageSeverity

Members

Member name | Description
Info |
Warning |
Error |
Corruption |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MiscellaneousQueryOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MiscellaneousQueryOptions Enumeration
See Also Send Feedback
Flags that describe miscellaneous query behavior.

(Also see DirectX SDK: D3D11_QUERY_MISC_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum MiscellaneousQueryOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration MiscellaneousQueryOptions
Visual C++
[FlagsAttribute]
public enum class MiscellaneousQueryOptions

Members

Member name | Description
None |
PredicateHint |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MiscellaneousResourceOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MiscellaneousResourceOptions Enumeration
See Also Send Feedback
Identifies other, less common options for resources.

(Also see DirectX SDK: D3D11_RESOURCE_MISC_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum MiscellaneousResourceOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration MiscellaneousResourceOptions
Visual C++
[FlagsAttribute]
public enum class MiscellaneousResourceOptions

Members

Member name | Description
GdiCompatible |
None |
SharedKeyedMutex |
ResourceClamp |
BufferStructured |
BufferAllowRawViews |
DrawIndirectArgs |
TextureCube |
Shared |
GenerateMips |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerBlendState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Class
Members See Also Send Feedback
Stores the blend state, including blend factors and mask, for the merger pipeline stage

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class OutputMergerBlendState
Visual Basic
Public Class OutputMergerBlendState
Visual C++
public ref class OutputMergerBlendState

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..OutputMergerBlendState

See Also

OutputMergerBlendState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerBlendState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Members
OutputMergerBlendState Class Constructors Properties See Also Send Feedback

The OutputMergerBlendState type exposes the following members.

Constructors

 | Name | Description
Public method | OutputMergerBlendState()()()() |
Public method | OutputMergerBlendState(BlendState) |
Public method | OutputMergerBlendState(BlendState, ColorRgba, UInt32) |

Properties

 | Name | Description
Public property | BlendFactor | Gets the blend factors for this merger pipeline stage blend state
Public property | BlendState | Gets the BlendState object for this merger pipeline stage blend state
Public property | SampleMask | Gets the sample mask for this merger pipeline stage blend state

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerBlendState Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Constructor
OutputMergerBlendState Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OutputMergerBlendState()()()() |
Public method | OutputMergerBlendState(BlendState) |
Public method | OutputMergerBlendState(BlendState, ColorRgba, UInt32) |

See Also

OutputMergerBlendState Class
OutputMergerBlendState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerBlendState Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Constructor
OutputMergerBlendState Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerBlendState()
Visual Basic
Public Sub New
Visual C++
public:
OutputMergerBlendState()

See Also

OutputMergerBlendState Class
OutputMergerBlendState Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerBlendState Constructor (BlendState)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Constructor (BlendState)
OutputMergerBlendState Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerBlendState(
    BlendState blendState
)
Visual Basic
Public Sub New ( _
    blendState As BlendState _
)
Visual C++
public:
OutputMergerBlendState(
    BlendState^ blendState
)

Parameters

blendState
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BlendState

See Also

OutputMergerBlendState Class
OutputMergerBlendState Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerBlendState Constructor (BlendState, ColorRgba, UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Constructor (BlendState, ColorRgba, UInt32)
OutputMergerBlendState Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerBlendState(
    BlendState blendState,
    ColorRgba blendFactor,
    uint sampleMask
)
Visual Basic
Public Sub New ( _
    blendState As BlendState, _
    blendFactor As ColorRgba, _
    sampleMask As UInteger _
)
Visual C++
public:
OutputMergerBlendState(
    BlendState^ blendState,
    ColorRgba blendFactor,
    unsigned int sampleMask
)

Parameters

blendState
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BlendState
blendFactor
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgba
sampleMask
Type: System..::..UInt32

See Also

OutputMergerBlendState Class
OutputMergerBlendState Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerBlendState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState Properties
OutputMergerBlendState Class See Also Send Feedback

The OutputMergerBlendState type exposes the following members.

Properties

 | Name | Description
Public property | BlendFactor | Gets the blend factors for this merger pipeline stage blend state
Public property | BlendState | Gets the BlendState object for this merger pipeline stage blend state
Public property | SampleMask | Gets the sample mask for this merger pipeline stage blend state

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendFactor Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState..::..BlendFactor Property
OutputMergerBlendState Class See Also Send Feedback
Gets the blend factors for this merger pipeline stage blend state

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgba BlendFactor { get; }
Visual Basic
Public ReadOnly Property BlendFactor As ColorRgba
    Get
Visual C++
public:
property ColorRgba BlendFactor {
    ColorRgba get ();
}

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendState Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState..::..BlendState Property
OutputMergerBlendState Class See Also Send Feedback
Gets the BlendState object for this merger pipeline stage blend state

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendState BlendState { get; }
Visual Basic
Public ReadOnly Property BlendState As BlendState
    Get
Visual C++
public:
property BlendState^ BlendState {
    BlendState^ get ();
}

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SampleMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerBlendState..::..SampleMask Property
OutputMergerBlendState Class See Also Send Feedback
Gets the sample mask for this merger pipeline stage blend state

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SampleMask { get; }
Visual Basic
Public ReadOnly Property SampleMask As UInteger
    Get
Visual C++
public:
property unsigned int SampleMask {
    unsigned int get ();
}

See Also

OutputMergerBlendState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage Class
Members See Also Send Feedback
OutputMerger pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class OutputMergerPipelineStage : PipelineStage
Visual Basic
Public Class OutputMergerPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class OutputMergerPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..OutputMergerPipelineStage

See Also

OutputMergerPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage Members
OutputMergerPipelineStage Class Constructors Methods Properties See Also Send Feedback

The OutputMergerPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | OutputMergerPipelineStage |

Methods

 | Name | Description
Public method | GetDepthStencilStateAndReferenceValue | Gets the depth-stencil state of the output-merger stage. (Also see DirectX SDK: ID3D11DeviceContext::OMGetDepthStencilState)
Public method | SetDepthStencilStateAndReferenceValue | Sets the depth-stencil state of the output-merger stage with a reference value. (Also see DirectX SDK: ID3D11DeviceContext::OMSetDepthStencilState)

Properties

 | Name | Description
Public property | BlendState | Get or sets the blend state of the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetBlendState, ID3D10Device::OMSetBlendState)
Public property | DepthStencilState | Gets the depth-stencil state of the output-merger stage. (Also see DirectX SDK: ID3D11DeviceContext::OMGetDepthStencilState)
Public property | DepthStencilView | Get the depth stencil view bound to the output-merger stage. (Also see DirectX SDK: ID3D11DeviceContext::OMGetRenderTargets)
Protected property | Parent | (Inherited from PipelineStage.)
Public property | RenderTargets |

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage Constructor
OutputMergerPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected OutputMergerPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
OutputMergerPipelineStage()

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage Methods
OutputMergerPipelineStage Class See Also Send Feedback

The OutputMergerPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetDepthStencilStateAndReferenceValue | Gets the depth-stencil state of the output-merger stage. (Also see DirectX SDK: ID3D11DeviceContext::OMGetDepthStencilState)
Public method | SetDepthStencilStateAndReferenceValue | Sets the depth-stencil state of the output-merger stage with a reference value. (Also see DirectX SDK: ID3D11DeviceContext::OMSetDepthStencilState)

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetDepthStencilStateAndReferenceValue Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..GetDepthStencilStateAndReferenceValue Method
OutputMergerPipelineStage Class See Also Send Feedback
Gets the depth-stencil state of the output-merger stage.

(Also see DirectX SDK: ID3D11DeviceContext::OMGetDepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilState GetDepthStencilStateAndReferenceValue(
    out uint stencilRef
)
Visual Basic
Public Function GetDepthStencilStateAndReferenceValue ( _
    <OutAttribute> ByRef stencilRef As UInteger _
) As DepthStencilState
Visual C++
public:
DepthStencilState^ GetDepthStencilStateAndReferenceValue(
    [OutAttribute] unsigned int% stencilRef
)

Parameters

stencilRef
Type: System..::..UInt32 %
The stencil reference value used in the depth-stencil test.

Return Value

A depth-stencil state object (see DepthStencilState) to be filled with information from the device.

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
OutputMergerPipelineStage..::..DepthStencilState


SetDepthStencilStateAndReferenceValue Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..SetDepthStencilStateAndReferenceValue Method
OutputMergerPipelineStage Class See Also Send Feedback
Sets the depth-stencil state of the output-merger stage with a reference value.

(Also see DirectX SDK: ID3D11DeviceContext::OMSetDepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetDepthStencilStateAndReferenceValue(
    DepthStencilState depthStencilState,
    uint stencilRef
)
Visual Basic
Public Sub SetDepthStencilStateAndReferenceValue ( _
    depthStencilState As DepthStencilState, _
    stencilRef As UInteger _
)
Visual C++
public:
void SetDepthStencilStateAndReferenceValue(
    DepthStencilState^ depthStencilState,
    unsigned int stencilRef
)

Parameters

depthStencilState
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilState
A depth-stencil state interface (see DepthStencilState) to bind to the device. Set this to NULL to use the default state listed in DepthStencilDescription.
stencilRef
Type: System..::..UInt32
Reference value to perform against when doing a depth-stencil test.

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
OutputMergerPipelineStage..::..DepthStencilState


OutputMergerPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage Properties
OutputMergerPipelineStage Class See Also Send Feedback

The OutputMergerPipelineStage type exposes the following members.

Properties

 | Name | Description
Public property | BlendState | Get or sets the blend state of the output-merger stage. (Also see DirectX SDK: ID3D10Device::OMGetBlendState, ID3D10Device::OMSetBlendState)
Public property | DepthStencilState | Gets the depth-stencil state of the output-merger stage. (Also see DirectX SDK: ID3D11DeviceContext::OMGetDepthStencilState)
Public property | DepthStencilView | Get the depth stencil view bound to the output-merger stage. (Also see DirectX SDK: ID3D11DeviceContext::OMGetRenderTargets)
Protected property | Parent | (Inherited from PipelineStage.)
Public property | RenderTargets |

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendState Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..BlendState Property
OutputMergerPipelineStage Class See Also Send Feedback
Get or sets the blend state of the output-merger stage.

(Also see DirectX SDK: ID3D10Device::OMGetBlendState, ID3D10Device::OMSetBlendState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerBlendState BlendState { get; set; }
Visual Basic
Public Property BlendState As OutputMergerBlendState
    Get
    Set
Visual C++
public:
property OutputMergerBlendState^ BlendState {
    OutputMergerBlendState^ get ();
    void set (OutputMergerBlendState^ value);
}

Remarks

If OutputMergerBlendState.BlendState is null, the default blending state will be set. See the DX SDK (ID3D10Device::OMSetBlendState) for more details about the default blending state.

A sample mask determines which samples get updated in all the active render targets. The mapping of bits in a sample mask to samples in a multisample render target is the responsibility of an individual application. A sample mask is always applied; it is independent of whether multisampling is enabled, and does not depend on whether an application uses multisample render targets.

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilState Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..DepthStencilState Property
OutputMergerPipelineStage Class See Also Send Feedback
Gets the depth-stencil state of the output-merger stage.

(Also see DirectX SDK: ID3D11DeviceContext::OMGetDepthStencilState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilState DepthStencilState { get; }
Visual Basic
Public ReadOnly Property DepthStencilState As DepthStencilState
    Get
Visual C++
public:
property DepthStencilState^ DepthStencilState {
    DepthStencilState^ get ();
}

Return Value

A depth-stencil state object (see DepthStencilState) to be filled with information from the device.

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
OutputMergerPipelineStage..::..DepthStencilState


DepthStencilView Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..DepthStencilView Property
OutputMergerPipelineStage Class See Also Send Feedback
Get the depth stencil view bound to the output-merger stage.

(Also see DirectX SDK: ID3D11DeviceContext::OMGetRenderTargets)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilView DepthStencilView { get; }
Visual Basic
Public ReadOnly Property DepthStencilView As DepthStencilView
    Get
Visual C++
public:
property DepthStencilView^ DepthStencilView {
    DepthStencilView^ get ();
}

Return Value

The depth-stencil view bound to the output-merger stage.

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargets Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerPipelineStage..::..RenderTargets Property
OutputMergerPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets RenderTargets { get; set; }
Visual Basic
Public Property RenderTargets As OutputMergerRenderTargets
    Get
    Set
Visual C++
public:
property OutputMergerRenderTargets^ RenderTargets {
    OutputMergerRenderTargets^ get ();
    void set (OutputMergerRenderTargets^ value);
}

See Also

OutputMergerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerRenderTargets Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Class
Members See Also Send Feedback
Stores the render targets for a merger pipeline stage

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class OutputMergerRenderTargets
Visual Basic
Public Class OutputMergerRenderTargets
Visual C++
public ref class OutputMergerRenderTargets

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..OutputMergerRenderTargets

See Also

OutputMergerRenderTargets Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerRenderTargets Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Members
OutputMergerRenderTargets Class Constructors Properties See Also Send Feedback

The OutputMergerRenderTargets type exposes the following members.

Constructors

 | Name | Description
Public method | OutputMergerRenderTargets(DepthStencilView) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>)) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>), DepthStencilView) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>), DepthStencilView, UInt32, IEnumerable<(Of <<'(UnorderedAccessView>)>>)) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>), DepthStencilView, UInt32, IEnumerable<(Of <<'(UnorderedAccessView>)>>), IEnumerable<(Of <<'(UInt32>)>>)) |

Properties

 | Name | Description
Public property | DepthStencilView |
Public property | InitialCounts |
Public property | RenderTargetViews |
Public property | UnorderedAccessViews |
Public property | UnorderedViewStartSlot |

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerRenderTargets Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor
OutputMergerRenderTargets Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OutputMergerRenderTargets(DepthStencilView) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>)) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>), DepthStencilView) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>), DepthStencilView, UInt32, IEnumerable<(Of <<'(UnorderedAccessView>)>>)) |
Public method | OutputMergerRenderTargets(IEnumerable<(Of <<'(RenderTargetView>)>>), DepthStencilView, UInt32, IEnumerable<(Of <<'(UnorderedAccessView>)>>), IEnumerable<(Of <<'(UInt32>)>>)) |

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerRenderTargets Constructor (DepthStencilView)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor (DepthStencilView)
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets(
    DepthStencilView depthStencilView
)
Visual Basic
Public Sub New ( _
    depthStencilView As DepthStencilView _
)
Visual C++
public:
OutputMergerRenderTargets(
    DepthStencilView^ depthStencilView
)

Parameters

depthStencilView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilView

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerRenderTargets Constructor (IEnumerable(RenderTargetView))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor (IEnumerable<(Of <(<'RenderTargetView>)>)>)
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets(
    IEnumerable<RenderTargetView> renderTargetViews
)
Visual Basic
Public Sub New ( _
    renderTargetViews As IEnumerable(Of RenderTargetView) _
)
Visual C++
public:
OutputMergerRenderTargets(
    IEnumerable<RenderTargetView^>^ renderTargetViews
)

Parameters

renderTargetViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RenderTargetView >)>)>

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerRenderTargets Constructor (IEnumerable(RenderTargetView), DepthStencilView)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor (IEnumerable<(Of <(<'RenderTargetView>)>)>, DepthStencilView)
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets(
    IEnumerable<RenderTargetView> renderTargetViews,
    DepthStencilView depthStencilView
)
Visual Basic
Public Sub New ( _
    renderTargetViews As IEnumerable(Of RenderTargetView), _
    depthStencilView As DepthStencilView _
)
Visual C++
public:
OutputMergerRenderTargets(
    IEnumerable<RenderTargetView^>^ renderTargetViews,
    DepthStencilView^ depthStencilView
)

Parameters

renderTargetViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RenderTargetView >)>)>
depthStencilView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilView

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerRenderTargets Constructor (IEnumerable(RenderTargetView), DepthStencilView, UInt32, IEnumerable(UnorderedAccessView))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor (IEnumerable<(Of <(<'RenderTargetView>)>)>, DepthStencilView, UInt32, IEnumerable<(Of <(<'UnorderedAccessView>)>)>)
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets(
    IEnumerable<RenderTargetView> renderTargetViews,
    DepthStencilView depthStencilView,
    uint viewStartSlot,
    IEnumerable<UnorderedAccessView> unorderedAccessViews
)
Visual Basic
Public Sub New ( _
    renderTargetViews As IEnumerable(Of RenderTargetView), _
    depthStencilView As DepthStencilView, _
    viewStartSlot As UInteger, _
    unorderedAccessViews As IEnumerable(Of UnorderedAccessView) _
)
Visual C++
public:
OutputMergerRenderTargets(
    IEnumerable<RenderTargetView^>^ renderTargetViews,
    DepthStencilView^ depthStencilView,
    unsigned int viewStartSlot,
    IEnumerable<UnorderedAccessView^>^ unorderedAccessViews
)

Parameters

renderTargetViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RenderTargetView >)>)>
depthStencilView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilView
viewStartSlot
Type: System..::..UInt32
unorderedAccessViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' UnorderedAccessView >)>)>

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerRenderTargets Constructor (IEnumerable(RenderTargetView), DepthStencilView, UInt32, IEnumerable(UnorderedAccessView), IEnumerable(UInt32))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Constructor (IEnumerable<(Of <(<'RenderTargetView>)>)>, DepthStencilView, UInt32, IEnumerable<(Of <(<'UnorderedAccessView>)>)>, IEnumerable<(Of <(<'UInt32>)>)>)
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputMergerRenderTargets(
    IEnumerable<RenderTargetView> renderTargetViews,
    DepthStencilView depthStencilView,
    uint viewStartSlot,
    IEnumerable<UnorderedAccessView> unorderedAccessViews,
    IEnumerable<uint> initialCounts
)
Visual Basic
Public Sub New ( _
    renderTargetViews As IEnumerable(Of RenderTargetView), _
    depthStencilView As DepthStencilView, _
    viewStartSlot As UInteger, _
    unorderedAccessViews As IEnumerable(Of UnorderedAccessView), _
    initialCounts As IEnumerable(Of UInteger) _
)
Visual C++
public:
OutputMergerRenderTargets(
    IEnumerable<RenderTargetView^>^ renderTargetViews,
    DepthStencilView^ depthStencilView,
    unsigned int viewStartSlot,
    IEnumerable<UnorderedAccessView^>^ unorderedAccessViews,
    IEnumerable<unsigned int>^ initialCounts
)

Parameters

renderTargetViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' RenderTargetView >)>)>
depthStencilView
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilView
viewStartSlot
Type: System..::..UInt32
unorderedAccessViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' UnorderedAccessView >)>)>
initialCounts
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' UInt32 >)>)>

See Also

OutputMergerRenderTargets Class
OutputMergerRenderTargets Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputMergerRenderTargets Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets Properties
OutputMergerRenderTargets Class See Also Send Feedback

The OutputMergerRenderTargets type exposes the following members.

Properties

 | Name | Description
Public property | DepthStencilView |
Public property | InitialCounts |
Public property | RenderTargetViews |
Public property | UnorderedAccessViews |
Public property | UnorderedViewStartSlot |

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthStencilView Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets..::..DepthStencilView Property
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public DepthStencilView DepthStencilView { get; }
Visual Basic
Public ReadOnly Property DepthStencilView As DepthStencilView
    Get
Visual C++
public:
property DepthStencilView^ DepthStencilView {
    DepthStencilView^ get ();
}

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InitialCounts Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets..::..InitialCounts Property
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<uint> InitialCounts { get; }
Visual Basic
Public ReadOnly Property InitialCounts As ReadOnlyCollection(Of UInteger)
    Get
Visual C++
public:
property ReadOnlyCollection<unsigned int>^ InitialCounts {
    ReadOnlyCollection<unsigned int>^ get ();
}

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetViews Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets..::..RenderTargetViews Property
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<RenderTargetView> RenderTargetViews { get; }
Visual Basic
Public ReadOnly Property RenderTargetViews As ReadOnlyCollection(Of RenderTargetView)
    Get
Visual C++
public:
property ReadOnlyCollection<RenderTargetView^>^ RenderTargetViews {
    ReadOnlyCollection<RenderTargetView^>^ get ();
}

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnorderedAccessViews Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets..::..UnorderedAccessViews Property
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<UnorderedAccessView> UnorderedAccessViews { get; }
Visual Basic
Public ReadOnly Property UnorderedAccessViews As ReadOnlyCollection(Of UnorderedAccessView)
    Get
Visual C++
public:
property ReadOnlyCollection<UnorderedAccessView^>^ UnorderedAccessViews {
    ReadOnlyCollection<UnorderedAccessView^>^ get ();
}

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnorderedViewStartSlot Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputMergerRenderTargets..::..UnorderedViewStartSlot Property
OutputMergerRenderTargets Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint UnorderedViewStartSlot { get; }
Visual Basic
Public ReadOnly Property UnorderedViewStartSlot As UInteger
    Get
Visual C++
public:
property unsigned int UnorderedViewStartSlot {
    unsigned int get ();
}

See Also

OutputMergerRenderTargets Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PipelineStage Class
Members See Also Send Feedback
A pipeline stage. base class for all pipline stage related classes.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public abstract class PipelineStage
Visual Basic
Public MustInherit Class PipelineStage
Visual C++
public ref class PipelineStage abstract

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ComputeShaderPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DomainShaderPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..GeometryShaderPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..HullShaderPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..InputAssemblerPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..OutputMergerPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PixelShaderPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..StreamOutputPipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexShaderPipelineStage

See Also

PipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PipelineStage Members
PipelineStage Class Constructors Properties See Also Send Feedback

The PipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | PipelineStage |

Properties

 | Name | Description
Protected property | Parent |

See Also

PipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PipelineStage Constructor
PipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected PipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
PipelineStage()

See Also

PipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PipelineStage Properties
PipelineStage Class See Also Send Feedback

The PipelineStage type exposes the following members.

Properties

 | Name | Description
Protected property | Parent |

See Also

PipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Parent Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PipelineStage..::..Parent Property
PipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected DeviceContext Parent { get; }
Visual Basic
Protected ReadOnly Property Parent As DeviceContext
    Get
Visual C++
protected:
property DeviceContext^ Parent {
    DeviceContext^ get ();
}

See Also

PipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PixelShader Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShader Class
Members See Also Send Feedback
A pixel-shader class manages an executable program (a pixel shader) that controls the pixel-shader stage.

(Also see DirectX SDK: ID3D11PixelShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class PixelShader : DeviceChild
Visual Basic
Public Class PixelShader _
    Inherits DeviceChild
Visual C++
public ref class PixelShader : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PixelShader

See Also

PixelShader Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PixelShader Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShader Members
PixelShader Class Properties See Also Send Feedback

The PixelShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

PixelShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PixelShader Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShader Properties
PixelShader Class See Also Send Feedback

The PixelShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

PixelShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PixelShaderPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Class
Members See Also Send Feedback
Pixel Shader pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class PixelShaderPipelineStage : PipelineStage
Visual Basic
Public Class PixelShaderPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class PixelShaderPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PixelShaderPipelineStage

See Also

PixelShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PixelShaderPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Members
PixelShaderPipelineStage Class Constructors Methods Properties See Also Send Feedback

The PixelShaderPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | PixelShaderPipelineStage |

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the pixel shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::PSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler states from the pixel shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::PSGetSamplers)
Public method | GetShaderAndClasses | Get the pixel shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::PSGetShader)
Public method | GetShaderResources | Get the pixel shader resources. (Also see DirectX SDK: ID3D11DeviceContext::PSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(PixelShader>)>>)) |
Public method | SetShader(PixelShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Gets or sets the pixel shader currently set on the device. (See PixelShader). (Also see DirectX SDK: ID3D11DeviceContext::PSGetShader, ID3D11DeviceContext::PSSetShader) Passing in null disables the shader for this pipeline stage.

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PixelShaderPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Constructor
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected PixelShaderPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
PixelShaderPipelineStage()

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PixelShaderPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Methods
PixelShaderPipelineStage Class See Also Send Feedback

The PixelShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the pixel shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::PSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler states from the pixel shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::PSGetSamplers)
Public method | GetShaderAndClasses | Get the pixel shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::PSGetShader)
Public method | GetShaderResources | Get the pixel shader resources. (Also see DirectX SDK: ID3D11DeviceContext::PSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(PixelShader>)>>)) |
Public method | SetShader(PixelShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..GetConstantBuffers Method
PixelShaderPipelineStage Class See Also Send Feedback
Get the constant buffers used by the pixel shader pipeline stage.

(Also see DirectX SDK: ID3D11DeviceContext::PSGetConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetConstantBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetConstantBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetConstantBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin retrieving constant buffers from (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - 1).
bufferCount
Type: System..::..UInt32
Number of buffers to retrieve (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - startSlot).

Return Value

Collection of constant buffer objects (see D3DBuffer) to be returned by the method.

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


GetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..GetSamplers Method
PixelShaderPipelineStage Class See Also Send Feedback
Get an array of sampler states from the pixel shader pipeline stage.

(Also see DirectX SDK: ID3D11DeviceContext::PSGetSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<SamplerState> GetSamplers(
    uint startSlot,
    uint samplerCount
)
Visual Basic
Public Function GetSamplers ( _
    startSlot As UInteger, _
    samplerCount As UInteger _
) As ReadOnlyCollection(Of SamplerState)
Visual C++
public:
ReadOnlyCollection<SamplerState^>^ GetSamplers(
    unsigned int startSlot,
    unsigned int samplerCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into a zero-based array to begin getting samplers from (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - 1).
samplerCount
Type: System..::..UInt32
Number of samplers to get from a device context. Each pipeline stage has a total of 16 sampler slots available (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - startSlot).

Return Value

Collection of sampler-state objects (see SamplerState) to be returned by the device.

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerState


GetShaderAndClasses Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..GetShaderAndClasses Method
PixelShaderPipelineStage Class See Also Send Feedback
Get the pixel shader currently set on the device.

(Also see DirectX SDK: ID3D11DeviceContext::PSGetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderAndClasses<PixelShader> GetShaderAndClasses(
    uint classInstanceCount
)
Visual Basic
Public Function GetShaderAndClasses ( _
    classInstanceCount As UInteger _
) As ShaderAndClasses(Of PixelShader)
Visual C++
public:
ShaderAndClasses<PixelShader^> GetShaderAndClasses(
    unsigned int classInstanceCount
)

Parameters

classInstanceCount
Type: System..::..UInt32
The number of class-instance elements in the array.

Return Value

A PixelShader object and its classes (see PixelShader, ShaderAndClasses<(Of <(<'T>)>)>) , .

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PixelShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses<(Of <(<'T>)>)>


GetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..GetShaderResources Method
PixelShaderPipelineStage Class See Also Send Feedback
Get the pixel shader resources.

(Also see DirectX SDK: ID3D11DeviceContext::PSGetShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetShaderResources(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetShaderResources ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetShaderResources(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin getting shader resources from (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - 1).
viewCount
Type: System..::..UInt32
The number of resources to get from the device. Up to a maximum of 128 slots are available for shader resources (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - startSlot).

Return Value

Collection of shader resource view objects to be returned by the device.

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..SetConstantBuffers Method
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetConstantBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> constantBuffers
)
Visual Basic
Public Sub SetConstantBuffers ( _
    startSlot As UInteger, _
    constantBuffers As IEnumerable(Of D3DBuffer) _
)
Visual C++
public:
void SetConstantBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ constantBuffers
)

Parameters

startSlot
Type: System..::..UInt32
constantBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..SetSamplers Method
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSamplers(
    uint startSlot,
    IEnumerable<SamplerState> samplers
)
Visual Basic
Public Sub SetSamplers ( _
    startSlot As UInteger, _
    samplers As IEnumerable(Of SamplerState) _
)
Visual C++
public:
void SetSamplers(
    unsigned int startSlot,
    IEnumerable<SamplerState^>^ samplers
)

Parameters

startSlot
Type: System..::..UInt32
samplers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SamplerState >)>)>

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..SetShader Method
PixelShaderPipelineStage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetShader(ShaderAndClasses<(Of <<'(PixelShader>)>>)) |
Public method | SetShader(PixelShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |

See Also

PixelShaderPipelineStage Class
PixelShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (ShaderAndClasses(PixelShader))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..SetShader Method (ShaderAndClasses<(Of <(<'PixelShader>)>)>)
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    ShaderAndClasses<PixelShader> shaderAndClasses
)
Visual Basic
Public Sub SetShader ( _
    shaderAndClasses As ShaderAndClasses(Of PixelShader) _
)
Visual C++
public:
void SetShader(
    ShaderAndClasses<PixelShader^> shaderAndClasses
)

Parameters

shaderAndClasses
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses <(Of <(<' PixelShader >)>)>

See Also

PixelShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (PixelShader, IEnumerable(ClassInstance))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..SetShader Method (PixelShader, IEnumerable<(Of <(<'ClassInstance>)>)>)
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    PixelShader pixelShader,
    IEnumerable<ClassInstance> classInstances
)
Visual Basic
Public Sub SetShader ( _
    pixelShader As PixelShader, _
    classInstances As IEnumerable(Of ClassInstance) _
)
Visual C++
public:
void SetShader(
    PixelShader^ pixelShader,
    IEnumerable<ClassInstance^>^ classInstances
)

Parameters

pixelShader
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PixelShader
classInstances
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ClassInstance >)>)>

See Also

PixelShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..SetShaderResources Method
PixelShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShaderResources(
    uint startSlot,
    IEnumerable<ShaderResourceView> shaderResourceViews
)
Visual Basic
Public Sub SetShaderResources ( _
    startSlot As UInteger, _
    shaderResourceViews As IEnumerable(Of ShaderResourceView) _
)
Visual C++
public:
void SetShaderResources(
    unsigned int startSlot,
    IEnumerable<ShaderResourceView^>^ shaderResourceViews
)

Parameters

startSlot
Type: System..::..UInt32
shaderResourceViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PixelShaderPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage Properties
PixelShaderPipelineStage Class See Also Send Feedback

The PixelShaderPipelineStage type exposes the following members.

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Gets or sets the pixel shader currently set on the device. (See PixelShader). (Also see DirectX SDK: ID3D11DeviceContext::PSGetShader, ID3D11DeviceContext::PSSetShader) Passing in null disables the shader for this pipeline stage.

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelShaderPipelineStage..::..Shader Property
PixelShaderPipelineStage Class See Also Send Feedback
Gets or sets the pixel shader currently set on the device. (See PixelShader).

(Also see DirectX SDK: ID3D11DeviceContext::PSGetShader, ID3D11DeviceContext::PSSetShader)

Passing in null disables the shader for this pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelShader Shader { get; set; }
Visual Basic
Public Property Shader As PixelShader
    Get
    Set
Visual C++
public:
property PixelShader^ Shader {
    PixelShader^ get ();
    void set (PixelShader^ value);
}

See Also

PixelShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PixelShader


Primitive Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Primitive Enumeration
See Also Send Feedback
Primitive type, which determines how the data that makes up object geometry is organized.

(Also see DirectX SDK: D3D11_PRIMITIVE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Primitive
Visual Basic
Public Enumeration Primitive
Visual C++
public enum class Primitive

Members

Member name | Description
Primitive32AsControlPointPatch |
Primitive31AsControlPointPatch |
Primitive30AsControlPointPatch |
Primitive29AsControlPointPatch |
Primitive28AsControlPointPatch |
Primitive27AsControlPointPatch |
Primitive26AsControlPointPatch |
Primitive25AsControlPointPatch |
Primitive24AsControlPointPatch |
Primitive23AsControlPointPatch |
Primitive22AsControlPointPatch |
Primitive21AsControlPointPatch |
Primitive20AsControlPointPatch |
Primitive19AsControlPointPatch |
Primitive18AsControlPointPatch |
Primitive17AsControlPointPatch |
Primitive16AsControlPointPatch |
Primitive15AsControlPointPatch |
Primitive14AsControlPointPatch |
Primitive13AsControlPointPatch |
Primitive12AsControlPointPatch |
Primitive11AsControlPointPatch |
Primitive10AsControlPointPatch |
Primitive9AsControlPointPatch |
Primitive8AsControlPointPatch |
Primitive7AsControlPointPatch |
Primitive6AsControlPointPatch |
Primitive5AsControlPointPatch |
Primitive4AsControlPointPatch |
Primitive3AsControlPointPatch |
Primitive2AsControlPointPatch |
Primitive1AsControlPointPatch |
TriangleAdjacency |
LineAdjacency |
Triangle |
Undefined |
Point |
Line |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PrimitiveTopology Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PrimitiveTopology Enumeration
See Also Send Feedback
How the pipeline interprets vertex data that is bound to the input-assembler stage. These primitive types determine how the vertex data is rendered on screen.

(Also see DirectX SDK: D3D11_PRIMITIVE_TOPOLOGY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum PrimitiveTopology
Visual Basic
Public Enumeration PrimitiveTopology
Visual C++
public enum class PrimitiveTopology

Members

Member name | Description
Undefined |
PrimitiveTopology32AsControlPointPatchList |
PrimitiveTopology31AsControlPointPatchList |
PrimitiveTopology30AsControlPointPatchList |
PrimitiveTopology29AsControlPointPatchList |
PrimitiveTopology28AsControlPointPatchList |
PrimitiveTopology27AsControlPointPatchList |
PrimitiveTopology26AsControlPointPatchList |
PrimitiveTopology25AsControlPointPatchList |
PrimitiveTopology24AsControlPointPatchList |
PrimitiveTopology23AsControlPointPatchList |
PrimitiveTopology22AsControlPointPatchList |
PrimitiveTopology21AsControlPointPatchList |
PrimitiveTopology20AsControlPointPatchList |
PrimitiveTopology19AsControlPointPatchList |
PrimitiveTopology18AsControlPointPatchList |
PrimitiveTopology17AsControlPointPatchList |
PrimitiveTopology16AsControlPointPatchList |
PrimitiveTopology15AsControlPointPatchList |
PrimitiveTopology14AsControlPointPatchList |
PrimitiveTopology13AsControlPointPatchList |
PrimitiveTopology12AsControlPointPatchList |
PrimitiveTopology11AsControlPointPatchList |
PrimitiveTopology10AsControlPointPatchList |
PrimitiveTopology9AsControlPointPatchList |
PrimitiveTopology8AsControlPointPatchList |
PrimitiveTopology7AsControlPointPatchList |
PrimitiveTopology6AsControlPointPatchList |
PrimitiveTopology5AsControlPointPatchList |
PrimitiveTopology4AsControlPointPatchList |
PrimitiveTopology3AsControlPointPatchList |
PrimitiveTopology2AsControlPointPatchList |
PrimitiveTopology1AsControlPointPatchList |
TriangleStripAdjacency |
TriangleListAdjacency |
LineStripAdjacency |
LineListAdjacency |
TriangleStrip |
TriangleList |
LineStrip |
LineList |
PointList |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Query Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Query Enumeration
See Also Send Feedback
D3DQuery types.

(Also see DirectX SDK: D3D11_QUERY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Query
Visual Basic
Public Enumeration Query
Visual C++
public enum class Query

Members

Member name | Description
StreamOutputOverflowPredicateStream3 |
StreamOutputStatisticsStream3 |
StreamOutputOverflowPredicateStream2 |
StreamOutputStatisticsStream2 |
StreamOutputOverflowPredicateStream1 |
StreamOutputStatisticsStream1 |
StreamOutputOverflowPredicateStream0 |
StreamOutputStatisticsStream0 |
StreamOutputOverflowPredicate |
StreamOutputStatistics |
OcclusionPredicate |
PipelineStatistics |
TimestampDisjoint |
Timestamp |
Occlusion |
Event |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataPipelineStatistics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Structure
Members See Also Send Feedback
Query information about graphics-pipeline activity in between calls to DeviceContext.Begin and DeviceContext.End.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct QueryDataPipelineStatistics
Visual Basic
Public Structure QueryDataPipelineStatistics
Visual C++
public value class QueryDataPipelineStatistics

See Also

QueryDataPipelineStatistics Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataPipelineStatistics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Members
QueryDataPipelineStatistics Structure Methods Operators Properties See Also Send Feedback

The QueryDataPipelineStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | CInvocations | Number of primitives that were sent to the rasterizer. When the rasterizer is disabled, this will not increment. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.CInvocations)
Public property | CPrimitives | Number of primitives that were rendered. This may be larger or smaller than CInvocations because after a primitive is clipped sometimes it is either broken up into more than one primitive or completely culled. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.CPrimitives)
Public property | DomainShaderInvocations | Number of times a domain shader was invoked. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.DSInvocations)
Public property | GeometryShaderInvocations | Number of times a geometry shader was invoked. When the geometry shader is set to NULL, this statistic may or may not increment depending on the hardware manufacturer. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.GSInvocations)
Public property | GeometryShaderPrimitives | Number of primitives output by a geometry shader. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.GSPrimitives)
Public property | HullShaderInvocations | Number of times a hull shader was invoked. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.HSInvocations)
Public property | InputAssemblerPrimitives | Number of primitives read by the input assembler. This number can be different depending on the primitive topology used. For example, a triangle strip with 6 vertices will produce 4 triangles, however a triangle list with 6 vertices will produce 2 triangles. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.IAPrimitives)
Public property | InputAssemblerVertices |
Public property | PixelShaderInvocations | Number of times a pixel shader was invoked. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.PSInvocations)
Public property | VertexShaderInvocations | Number of times a vertex shader was invoked. Direct3D invokes the vertex shader once per vertex. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.VSInvocations)

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataPipelineStatistics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Methods
QueryDataPipelineStatistics Structure See Also Send Feedback

The QueryDataPipelineStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..Equals Method
QueryDataPipelineStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..GetHashCode Method
QueryDataPipelineStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataPipelineStatistics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Operators
QueryDataPipelineStatistics Structure See Also Send Feedback

The QueryDataPipelineStatistics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..Equality Operator
QueryDataPipelineStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    QueryDataPipelineStatistics queryDataPipelineStatistics1,
    QueryDataPipelineStatistics queryDataPipelineStatistics2
)
Visual Basic
Public Shared Operator = ( _
    queryDataPipelineStatistics1 As QueryDataPipelineStatistics, _
    queryDataPipelineStatistics2 As QueryDataPipelineStatistics _
) As Boolean
Visual C++
public:
static bool operator ==(
    QueryDataPipelineStatistics queryDataPipelineStatistics1,
    QueryDataPipelineStatistics queryDataPipelineStatistics2
)

Parameters

queryDataPipelineStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataPipelineStatistics
queryDataPipelineStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataPipelineStatistics

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..Inequality Operator
QueryDataPipelineStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    QueryDataPipelineStatistics queryDataPipelineStatistics1,
    QueryDataPipelineStatistics queryDataPipelineStatistics2
)
Visual Basic
Public Shared Operator <> ( _
    queryDataPipelineStatistics1 As QueryDataPipelineStatistics, _
    queryDataPipelineStatistics2 As QueryDataPipelineStatistics _
) As Boolean
Visual C++
public:
static bool operator !=(
    QueryDataPipelineStatistics queryDataPipelineStatistics1,
    QueryDataPipelineStatistics queryDataPipelineStatistics2
)

Parameters

queryDataPipelineStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataPipelineStatistics
queryDataPipelineStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataPipelineStatistics

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataPipelineStatistics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics Properties
QueryDataPipelineStatistics Structure See Also Send Feedback

The QueryDataPipelineStatistics type exposes the following members.

Properties

 | Name | Description
Public property | CInvocations | Number of primitives that were sent to the rasterizer. When the rasterizer is disabled, this will not increment. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.CInvocations)
Public property | CPrimitives | Number of primitives that were rendered. This may be larger or smaller than CInvocations because after a primitive is clipped sometimes it is either broken up into more than one primitive or completely culled. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.CPrimitives)
Public property | DomainShaderInvocations | Number of times a domain shader was invoked. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.DSInvocations)
Public property | GeometryShaderInvocations | Number of times a geometry shader was invoked. When the geometry shader is set to NULL, this statistic may or may not increment depending on the hardware manufacturer. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.GSInvocations)
Public property | GeometryShaderPrimitives | Number of primitives output by a geometry shader. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.GSPrimitives)
Public property | HullShaderInvocations | Number of times a hull shader was invoked. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.HSInvocations)
Public property | InputAssemblerPrimitives | Number of primitives read by the input assembler. This number can be different depending on the primitive topology used. For example, a triangle strip with 6 vertices will produce 4 triangles, however a triangle list with 6 vertices will produce 2 triangles. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.IAPrimitives)
Public property | InputAssemblerVertices |
Public property | PixelShaderInvocations | Number of times a pixel shader was invoked. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.PSInvocations)
Public property | VertexShaderInvocations | Number of times a vertex shader was invoked. Direct3D invokes the vertex shader once per vertex. (Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.VSInvocations)

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..CInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of primitives that were sent to the rasterizer. When the rasterizer is disabled, this will not increment.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.CInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong CInvocations { get; set; }
Visual Basic
Public Property CInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long CInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CPrimitives Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..CPrimitives Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of primitives that were rendered. This may be larger or smaller than CInvocations because after a primitive is clipped sometimes it is either broken up into more than one primitive or completely culled.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.CPrimitives)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong CPrimitives { get; set; }
Visual Basic
Public Property CPrimitives As ULong
    Get
    Set
Visual C++
public:
property unsigned long long CPrimitives {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DomainShaderInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..DomainShaderInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of times a domain shader was invoked.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.DSInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong DomainShaderInvocations { get; set; }
Visual Basic
Public Property DomainShaderInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long DomainShaderInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShaderInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..GeometryShaderInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of times a geometry shader was invoked. When the geometry shader is set to NULL, this statistic may or may not increment depending on the hardware manufacturer.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.GSInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong GeometryShaderInvocations { get; set; }
Visual Basic
Public Property GeometryShaderInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long GeometryShaderInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GeometryShaderPrimitives Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..GeometryShaderPrimitives Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of primitives output by a geometry shader.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.GSPrimitives)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong GeometryShaderPrimitives { get; set; }
Visual Basic
Public Property GeometryShaderPrimitives As ULong
    Get
    Set
Visual C++
public:
property unsigned long long GeometryShaderPrimitives {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


HullShaderInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..HullShaderInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of times a hull shader was invoked.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.HSInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong HullShaderInvocations { get; set; }
Visual Basic
Public Property HullShaderInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long HullShaderInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputAssemblerPrimitives Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..InputAssemblerPrimitives Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of primitives read by the input assembler. This number can be different depending on the primitive topology used. For example, a triangle strip with 6 vertices will produce 4 triangles, however a triangle list with 6 vertices will produce 2 triangles.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.IAPrimitives)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong InputAssemblerPrimitives { get; set; }
Visual Basic
Public Property InputAssemblerPrimitives As ULong
    Get
    Set
Visual C++
public:
property unsigned long long InputAssemblerPrimitives {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


InputAssemblerVertices Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..InputAssemblerVertices Property
QueryDataPipelineStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong InputAssemblerVertices { get; set; }
Visual Basic
Public Property InputAssemblerVertices As ULong
    Get
    Set
Visual C++
public:
property unsigned long long InputAssemblerVertices {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PixelShaderInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..PixelShaderInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of times a pixel shader was invoked.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.PSInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong PixelShaderInvocations { get; set; }
Visual Basic
Public Property PixelShaderInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long PixelShaderInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexShaderInvocations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataPipelineStatistics..::..VertexShaderInvocations Property
QueryDataPipelineStatistics Structure See Also Send Feedback
Number of times a vertex shader was invoked. Direct3D invokes the vertex shader once per vertex.

(Also see DirectX SDK: D3D11_QUERY_DATA_PIPELINE_STATISTICS.VSInvocations)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong VertexShaderInvocations { get; set; }
Visual Basic
Public Property VertexShaderInvocations As ULong
    Get
    Set
Visual C++
public:
property unsigned long long VertexShaderInvocations {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataPipelineStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataStreamOutputStatistics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Structure
Members See Also Send Feedback
Query information about the amount of data streamed out to the stream-output buffers in between DeviceContext.Begin and DeviceContext.End.

(Also see DirectX SDK: D3D11_QUERY_DATA_SO_STATISTICS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct QueryDataStreamOutputStatistics
Visual Basic
Public Structure QueryDataStreamOutputStatistics
Visual C++
public value class QueryDataStreamOutputStatistics

See Also

QueryDataStreamOutputStatistics Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataStreamOutputStatistics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Members
QueryDataStreamOutputStatistics Structure Methods Operators Properties See Also Send Feedback

The QueryDataStreamOutputStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | PrimitivesStorageNeeded | Number of primitives that would have been written to the stream-output buffers if there had been enough space for them all. (Also see DirectX SDK: D3D11_QUERY_DATA_SO_STATISTICS.PrimitivesStorageNeeded)
Public property | PrimitiveWrittenCount | Number of primitives (that is, points, lines, and triangles) written to the stream-output buffers. (Also see DirectX SDK: D3D11_QUERY_DATA_SO_STATISTICS.NumPrimitivesWritten)

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataStreamOutputStatistics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Methods
QueryDataStreamOutputStatistics Structure See Also Send Feedback

The QueryDataStreamOutputStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..Equals Method
QueryDataStreamOutputStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..GetHashCode Method
QueryDataStreamOutputStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataStreamOutputStatistics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Operators
QueryDataStreamOutputStatistics Structure See Also Send Feedback

The QueryDataStreamOutputStatistics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..Equality Operator
QueryDataStreamOutputStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics1,
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics2
)
Visual Basic
Public Shared Operator = ( _
    queryDataStreamOutputStatistics1 As QueryDataStreamOutputStatistics, _
    queryDataStreamOutputStatistics2 As QueryDataStreamOutputStatistics _
) As Boolean
Visual C++
public:
static bool operator ==(
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics1,
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics2
)

Parameters

queryDataStreamOutputStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataStreamOutputStatistics
queryDataStreamOutputStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataStreamOutputStatistics

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..Inequality Operator
QueryDataStreamOutputStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics1,
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics2
)
Visual Basic
Public Shared Operator <> ( _
    queryDataStreamOutputStatistics1 As QueryDataStreamOutputStatistics, _
    queryDataStreamOutputStatistics2 As QueryDataStreamOutputStatistics _
) As Boolean
Visual C++
public:
static bool operator !=(
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics1,
    QueryDataStreamOutputStatistics queryDataStreamOutputStatistics2
)

Parameters

queryDataStreamOutputStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataStreamOutputStatistics
queryDataStreamOutputStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataStreamOutputStatistics

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataStreamOutputStatistics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics Properties
QueryDataStreamOutputStatistics Structure See Also Send Feedback

The QueryDataStreamOutputStatistics type exposes the following members.

Properties

 | Name | Description
Public property | PrimitivesStorageNeeded | Number of primitives that would have been written to the stream-output buffers if there had been enough space for them all. (Also see DirectX SDK: D3D11_QUERY_DATA_SO_STATISTICS.PrimitivesStorageNeeded)
Public property | PrimitiveWrittenCount | Number of primitives (that is, points, lines, and triangles) written to the stream-output buffers. (Also see DirectX SDK: D3D11_QUERY_DATA_SO_STATISTICS.NumPrimitivesWritten)

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PrimitivesStorageNeeded Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..PrimitivesStorageNeeded Property
QueryDataStreamOutputStatistics Structure See Also Send Feedback
Number of primitives that would have been written to the stream-output buffers if there had been enough space for them all.

(Also see DirectX SDK: D3D11_QUERY_DATA_SO_STATISTICS.PrimitivesStorageNeeded)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong PrimitivesStorageNeeded { get; set; }
Visual Basic
Public Property PrimitivesStorageNeeded As ULong
    Get
    Set
Visual C++
public:
property unsigned long long PrimitivesStorageNeeded {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


PrimitiveWrittenCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataStreamOutputStatistics..::..PrimitiveWrittenCount Property
QueryDataStreamOutputStatistics Structure See Also Send Feedback
Number of primitives (that is, points, lines, and triangles) written to the stream-output buffers.

(Also see DirectX SDK: D3D11_QUERY_DATA_SO_STATISTICS.NumPrimitivesWritten)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong PrimitiveWrittenCount { get; set; }
Visual Basic
Public Property PrimitiveWrittenCount As ULong
    Get
    Set
Visual C++
public:
property unsigned long long PrimitiveWrittenCount {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataStreamOutputStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataTimestampDisjoint Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Structure
Members See Also Send Feedback
Query information about the reliability of a timestamp query.

(Also see DirectX SDK: D3D11_QUERY_DATA_TIMESTAMP_DISJOINT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct QueryDataTimestampDisjoint
Visual Basic
Public Structure QueryDataTimestampDisjoint
Visual C++
public value class QueryDataTimestampDisjoint

See Also

QueryDataTimestampDisjoint Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataTimestampDisjoint Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Members
QueryDataTimestampDisjoint Structure Methods Operators Properties See Also Send Feedback

The QueryDataTimestampDisjoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Disjoint | If this is TRUE, something occurred in between the query's DeviceContext.Begin and DeviceContext.End calls that caused the timestamp counter to become discontinuous or disjoint, such as unplugging the AC chord on a laptop, overheating, or throttling up/down due to laptop savings events. The timestamp returned by DeviceContext.GetData for a timestamp query is only reliable if Disjoint is FALSE. (Also see DirectX SDK: D3D11_QUERY_DATA_TIMESTAMP_DISJOINT.Disjoint)
Public property | Frequency | How frequently the GPU counter increments in Hz. (Also see DirectX SDK: D3D11_QUERY_DATA_TIMESTAMP_DISJOINT.Frequency)

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataTimestampDisjoint Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Methods
QueryDataTimestampDisjoint Structure See Also Send Feedback

The QueryDataTimestampDisjoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Equals Method
QueryDataTimestampDisjoint Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..GetHashCode Method
QueryDataTimestampDisjoint Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataTimestampDisjoint Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Operators
QueryDataTimestampDisjoint Structure See Also Send Feedback

The QueryDataTimestampDisjoint type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Equality Operator
QueryDataTimestampDisjoint Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    QueryDataTimestampDisjoint queryDataTimestampDisjoint1,
    QueryDataTimestampDisjoint queryDataTimestampDisjoint2
)
Visual Basic
Public Shared Operator = ( _
    queryDataTimestampDisjoint1 As QueryDataTimestampDisjoint, _
    queryDataTimestampDisjoint2 As QueryDataTimestampDisjoint _
) As Boolean
Visual C++
public:
static bool operator ==(
    QueryDataTimestampDisjoint queryDataTimestampDisjoint1,
    QueryDataTimestampDisjoint queryDataTimestampDisjoint2
)

Parameters

queryDataTimestampDisjoint1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataTimestampDisjoint
queryDataTimestampDisjoint2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataTimestampDisjoint

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Inequality Operator
QueryDataTimestampDisjoint Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    QueryDataTimestampDisjoint queryDataTimestampDisjoint1,
    QueryDataTimestampDisjoint queryDataTimestampDisjoint2
)
Visual Basic
Public Shared Operator <> ( _
    queryDataTimestampDisjoint1 As QueryDataTimestampDisjoint, _
    queryDataTimestampDisjoint2 As QueryDataTimestampDisjoint _
) As Boolean
Visual C++
public:
static bool operator !=(
    QueryDataTimestampDisjoint queryDataTimestampDisjoint1,
    QueryDataTimestampDisjoint queryDataTimestampDisjoint2
)

Parameters

queryDataTimestampDisjoint1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataTimestampDisjoint
queryDataTimestampDisjoint2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDataTimestampDisjoint

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDataTimestampDisjoint Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint Properties
QueryDataTimestampDisjoint Structure See Also Send Feedback

The QueryDataTimestampDisjoint type exposes the following members.

Properties

 | Name | Description
Public property | Disjoint | If this is TRUE, something occurred in between the query's DeviceContext.Begin and DeviceContext.End calls that caused the timestamp counter to become discontinuous or disjoint, such as unplugging the AC chord on a laptop, overheating, or throttling up/down due to laptop savings events. The timestamp returned by DeviceContext.GetData for a timestamp query is only reliable if Disjoint is FALSE. (Also see DirectX SDK: D3D11_QUERY_DATA_TIMESTAMP_DISJOINT.Disjoint)
Public property | Frequency | How frequently the GPU counter increments in Hz. (Also see DirectX SDK: D3D11_QUERY_DATA_TIMESTAMP_DISJOINT.Frequency)

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Disjoint Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Disjoint Property
QueryDataTimestampDisjoint Structure See Also Send Feedback
If this is TRUE, something occurred in between the query's DeviceContext.Begin and DeviceContext.End calls that caused the timestamp counter to become discontinuous or disjoint, such as unplugging the AC chord on a laptop, overheating, or throttling up/down due to laptop savings events. The timestamp returned by DeviceContext.GetData for a timestamp query is only reliable if Disjoint is FALSE.

(Also see DirectX SDK: D3D11_QUERY_DATA_TIMESTAMP_DISJOINT.Disjoint)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool Disjoint { get; set; }
Visual Basic
Public Property Disjoint As Boolean
    Get
    Set
Visual C++
public:
property bool Disjoint {
    bool get ();
    void set (bool value);
}

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Frequency Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDataTimestampDisjoint..::..Frequency Property
QueryDataTimestampDisjoint Structure See Also Send Feedback
How frequently the GPU counter increments in Hz.

(Also see DirectX SDK: D3D11_QUERY_DATA_TIMESTAMP_DISJOINT.Frequency)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ulong Frequency { get; set; }
Visual Basic
Public Property Frequency As ULong
    Get
    Set
Visual C++
public:
property unsigned long long Frequency {
    unsigned long long get ();
    void set (unsigned long long value);
}

See Also

QueryDataTimestampDisjoint Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Structure
Members See Also Send Feedback
Describes a query.

(Also see DirectX SDK: D3D11_QUERY_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct QueryDescription
Visual Basic
Public Structure QueryDescription
Visual C++
public value class QueryDescription

See Also

QueryDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Members
QueryDescription Structure Methods Operators Properties See Also Send Feedback

The QueryDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MiscellaneousQueryOptions | Miscellaneous flags (see MiscellaneousQueryOptions). (Also see DirectX SDK: D3D11_QUERY_DESC.MiscFlags)
Public property | Query | Type of query. (Also see DirectX SDK: D3D11_QUERY_DESC.D3DQuery)

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Methods
QueryDescription Structure See Also Send Feedback

The QueryDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..Equals Method
QueryDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..GetHashCode Method
QueryDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Operators
QueryDescription Structure See Also Send Feedback

The QueryDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..Equality Operator
QueryDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    QueryDescription queryDescription1,
    QueryDescription queryDescription2
)
Visual Basic
Public Shared Operator = ( _
    queryDescription1 As QueryDescription, _
    queryDescription2 As QueryDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    QueryDescription queryDescription1,
    QueryDescription queryDescription2
)

Parameters

queryDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDescription
queryDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDescription

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..Inequality Operator
QueryDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    QueryDescription queryDescription1,
    QueryDescription queryDescription2
)
Visual Basic
Public Shared Operator <> ( _
    queryDescription1 As QueryDescription, _
    queryDescription2 As QueryDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    QueryDescription queryDescription1,
    QueryDescription queryDescription2
)

Parameters

queryDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDescription
queryDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..QueryDescription

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


QueryDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription Properties
QueryDescription Structure See Also Send Feedback

The QueryDescription type exposes the following members.

Properties

 | Name | Description
Public property | MiscellaneousQueryOptions | Miscellaneous flags (see MiscellaneousQueryOptions). (Also see DirectX SDK: D3D11_QUERY_DESC.MiscFlags)
Public property | Query | Type of query. (Also see DirectX SDK: D3D11_QUERY_DESC.D3DQuery)

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MiscellaneousQueryOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..MiscellaneousQueryOptions Property
QueryDescription Structure See Also Send Feedback
Miscellaneous flags (see MiscellaneousQueryOptions).

(Also see DirectX SDK: D3D11_QUERY_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousQueryOptions MiscellaneousQueryOptions { get; set; }
Visual Basic
Public Property MiscellaneousQueryOptions As MiscellaneousQueryOptions
    Get
    Set
Visual C++
public:
property MiscellaneousQueryOptions MiscellaneousQueryOptions {
    MiscellaneousQueryOptions get ();
    void set (MiscellaneousQueryOptions value);
}

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
QueryDescription..::..MiscellaneousQueryOptions


Query Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
QueryDescription..::..Query Property
QueryDescription Structure See Also Send Feedback
Type of query.

(Also see DirectX SDK: D3D11_QUERY_DESC.D3DQuery)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Query Query { get; set; }
Visual Basic
Public Property Query As Query
    Get
    Set
Visual C++
public:
property Query Query {
    Query get ();
    void set (Query value);
}

See Also

QueryDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Structure
Members See Also Send Feedback
Describes rasterizer state.

(Also see DirectX SDK: D3D11_RASTERIZER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RasterizerDescription
Visual Basic
Public Structure RasterizerDescription
Visual C++
public value class RasterizerDescription

See Also

RasterizerDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Members
RasterizerDescription Structure Methods Operators Properties See Also Send Feedback

The RasterizerDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AntiAliasedLineEnable | Enable line antialiasing; only applies if doing line drawing and MultisampleEnable is false. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.AntialiasedLineEnable)
Public property | CullMode | Indicates triangles facing the specified direction are not drawn (see CullMode). (Also see DirectX SDK: D3D11_RASTERIZER_DESC.CullMode)
Public property | DepthBias | Depth value added to a given pixel. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.DepthBias)
Public property | DepthBiasClamp | Maximum depth bias of a pixel. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.DepthBiasClamp)
Public property | DepthClipEnable | Enable clipping based on distance. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.DepthClipEnable)
Public property | FillMode | Determines the fill mode to use when rendering (see FillMode). (Also see DirectX SDK: D3D11_RASTERIZER_DESC.FillMode)
Public property | FrontCounterclockwise | Determines if a triangle is front- or back-facing. If this parameter is true, then a triangle will be considered front-facing if its vertices are counter-clockwise on the render target and considered back-facing if they are clockwise. If this parameter is false then the opposite is true. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.FrontCounterClockwise)
Public property | MultisampleEnable | Enable multisample antialiasing. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.MultisampleEnable)
Public property | ScissorEnable | Enable scissor-rectangle culling. All pixels ouside an active scissor rectangle are culled. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.ScissorEnable)
Public property | SlopeScaledDepthBias | Scalar on a given pixel's slope. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.SlopeScaledDepthBias)

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Methods
RasterizerDescription Structure See Also Send Feedback

The RasterizerDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..Equals Method
RasterizerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..GetHashCode Method
RasterizerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Operators
RasterizerDescription Structure See Also Send Feedback

The RasterizerDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..Equality Operator
RasterizerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    RasterizerDescription rasterizerDescription1,
    RasterizerDescription rasterizerDescription2
)
Visual Basic
Public Shared Operator = ( _
    rasterizerDescription1 As RasterizerDescription, _
    rasterizerDescription2 As RasterizerDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    RasterizerDescription rasterizerDescription1,
    RasterizerDescription rasterizerDescription2
)

Parameters

rasterizerDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerDescription
rasterizerDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerDescription

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..Inequality Operator
RasterizerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    RasterizerDescription rasterizerDescription1,
    RasterizerDescription rasterizerDescription2
)
Visual Basic
Public Shared Operator <> ( _
    rasterizerDescription1 As RasterizerDescription, _
    rasterizerDescription2 As RasterizerDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    RasterizerDescription rasterizerDescription1,
    RasterizerDescription rasterizerDescription2
)

Parameters

rasterizerDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerDescription
rasterizerDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerDescription

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription Properties
RasterizerDescription Structure See Also Send Feedback

The RasterizerDescription type exposes the following members.

Properties

 | Name | Description
Public property | AntiAliasedLineEnable | Enable line antialiasing; only applies if doing line drawing and MultisampleEnable is false. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.AntialiasedLineEnable)
Public property | CullMode | Indicates triangles facing the specified direction are not drawn (see CullMode). (Also see DirectX SDK: D3D11_RASTERIZER_DESC.CullMode)
Public property | DepthBias | Depth value added to a given pixel. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.DepthBias)
Public property | DepthBiasClamp | Maximum depth bias of a pixel. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.DepthBiasClamp)
Public property | DepthClipEnable | Enable clipping based on distance. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.DepthClipEnable)
Public property | FillMode | Determines the fill mode to use when rendering (see FillMode). (Also see DirectX SDK: D3D11_RASTERIZER_DESC.FillMode)
Public property | FrontCounterclockwise | Determines if a triangle is front- or back-facing. If this parameter is true, then a triangle will be considered front-facing if its vertices are counter-clockwise on the render target and considered back-facing if they are clockwise. If this parameter is false then the opposite is true. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.FrontCounterClockwise)
Public property | MultisampleEnable | Enable multisample antialiasing. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.MultisampleEnable)
Public property | ScissorEnable | Enable scissor-rectangle culling. All pixels ouside an active scissor rectangle are culled. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.ScissorEnable)
Public property | SlopeScaledDepthBias | Scalar on a given pixel's slope. (Also see DirectX SDK: D3D11_RASTERIZER_DESC.SlopeScaledDepthBias)

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


AntiAliasedLineEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..AntiAliasedLineEnable Property
RasterizerDescription Structure See Also Send Feedback
Enable line antialiasing; only applies if doing line drawing and MultisampleEnable is false.

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.AntialiasedLineEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool AntiAliasedLineEnable { get; set; }
Visual Basic
Public Property AntiAliasedLineEnable As Boolean
    Get
    Set
Visual C++
public:
property bool AntiAliasedLineEnable {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CullMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..CullMode Property
RasterizerDescription Structure See Also Send Feedback
Indicates triangles facing the specified direction are not drawn (see CullMode).

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.CullMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CullMode CullMode { get; set; }
Visual Basic
Public Property CullMode As CullMode
    Get
    Set
Visual C++
public:
property CullMode CullMode {
    CullMode get ();
    void set (CullMode value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
RasterizerDescription..::..CullMode


DepthBias Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..DepthBias Property
RasterizerDescription Structure See Also Send Feedback
Depth value added to a given pixel.

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.DepthBias)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int DepthBias { get; set; }
Visual Basic
Public Property DepthBias As Integer
    Get
    Set
Visual C++
public:
property int DepthBias {
    int get ();
    void set (int value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthBiasClamp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..DepthBiasClamp Property
RasterizerDescription Structure See Also Send Feedback
Maximum depth bias of a pixel.

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.DepthBiasClamp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float DepthBiasClamp { get; set; }
Visual Basic
Public Property DepthBiasClamp As Single
    Get
    Set
Visual C++
public:
property float DepthBiasClamp {
    float get ();
    void set (float value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DepthClipEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..DepthClipEnable Property
RasterizerDescription Structure See Also Send Feedback
Enable clipping based on distance.

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.DepthClipEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool DepthClipEnable { get; set; }
Visual Basic
Public Property DepthClipEnable As Boolean
    Get
    Set
Visual C++
public:
property bool DepthClipEnable {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FillMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..FillMode Property
RasterizerDescription Structure See Also Send Feedback
Determines the fill mode to use when rendering (see FillMode).

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.FillMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FillMode FillMode { get; set; }
Visual Basic
Public Property FillMode As FillMode
    Get
    Set
Visual C++
public:
property FillMode FillMode {
    FillMode get ();
    void set (FillMode value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
RasterizerDescription..::..FillMode


FrontCounterclockwise Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..FrontCounterclockwise Property
RasterizerDescription Structure See Also Send Feedback
Determines if a triangle is front- or back-facing. If this parameter is true, then a triangle will be considered front-facing if its vertices are counter-clockwise on the render target and considered back-facing if they are clockwise. If this parameter is false then the opposite is true.

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.FrontCounterClockwise)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool FrontCounterclockwise { get; set; }
Visual Basic
Public Property FrontCounterclockwise As Boolean
    Get
    Set
Visual C++
public:
property bool FrontCounterclockwise {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MultisampleEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..MultisampleEnable Property
RasterizerDescription Structure See Also Send Feedback
Enable multisample antialiasing.

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.MultisampleEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool MultisampleEnable { get; set; }
Visual Basic
Public Property MultisampleEnable As Boolean
    Get
    Set
Visual C++
public:
property bool MultisampleEnable {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ScissorEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..ScissorEnable Property
RasterizerDescription Structure See Also Send Feedback
Enable scissor-rectangle culling. All pixels ouside an active scissor rectangle are culled.

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.ScissorEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool ScissorEnable { get; set; }
Visual Basic
Public Property ScissorEnable As Boolean
    Get
    Set
Visual C++
public:
property bool ScissorEnable {
    bool get ();
    void set (bool value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SlopeScaledDepthBias Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerDescription..::..SlopeScaledDepthBias Property
RasterizerDescription Structure See Also Send Feedback
Scalar on a given pixel's slope.

(Also see DirectX SDK: D3D11_RASTERIZER_DESC.SlopeScaledDepthBias)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float SlopeScaledDepthBias { get; set; }
Visual Basic
Public Property SlopeScaledDepthBias As Single
    Get
    Set
Visual C++
public:
property float SlopeScaledDepthBias {
    float get ();
    void set (float value);
}

See Also

RasterizerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Class
Members See Also Send Feedback
Rasterizer pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RasterizerPipelineStage : PipelineStage
Visual Basic
Public Class RasterizerPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class RasterizerPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerPipelineStage

See Also

RasterizerPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Members
RasterizerPipelineStage Class Constructors Methods Properties See Also Send Feedback

The RasterizerPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | RasterizerPipelineStage |

Methods

 | Name | Description
Public method | BoundedGetScissorRects | Get the collection of scissor rectangles bound to the rasterizer stage. (Also see DirectX SDK: ID3D11DeviceContext::RSGetScissorRects)
Public method | BoundedGetViewports | Get the array of viewports bound to the rasterizer stage (Also see DirectX SDK: ID3D11DeviceContext::RSGetViewports)

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | ScissorRects | Gets or sets an array of scissor rectangles bound the rasterizer stage. (See D3DRect). (Also see DirectX SDK: ID3D11DeviceContext::RSGetScissorRects, ID3D11DeviceContext::RSSetScissorRects)
Public property | State | Gets or sets the rasterizer state of the rasterizer stage of the pipeline. (See RasterizerState). (Also see DirectX SDK: ID3D11DeviceContext::RSGetState, ID3D11DeviceContext::RSSetState)
Public property | Viewports | Bind an array of viewports to the rasterizer stage of the pipeline. (Also see DirectX SDK: ID3D11DeviceContext::RSSetViewports)

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Constructor
RasterizerPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected RasterizerPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
RasterizerPipelineStage()

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Methods
RasterizerPipelineStage Class See Also Send Feedback

The RasterizerPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | BoundedGetScissorRects | Get the collection of scissor rectangles bound to the rasterizer stage. (Also see DirectX SDK: ID3D11DeviceContext::RSGetScissorRects)
Public method | BoundedGetViewports | Get the array of viewports bound to the rasterizer stage (Also see DirectX SDK: ID3D11DeviceContext::RSGetViewports)

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BoundedGetScissorRects Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..BoundedGetScissorRects Method
RasterizerPipelineStage Class See Also Send Feedback
Get the collection of scissor rectangles bound to the rasterizer stage.

(Also see DirectX SDK: ID3D11DeviceContext::RSGetScissorRects)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<D3DRect> BoundedGetScissorRects(
    uint maxNumberOfRects
)
Visual Basic
Public Function BoundedGetScissorRects ( _
    maxNumberOfRects As UInteger _
) As IEnumerable(Of D3DRect)
Visual C++
public:
IEnumerable<D3DRect>^ BoundedGetScissorRects(
    unsigned int maxNumberOfRects
)

Parameters

maxNumberOfRects
Type: System..::..UInt32

Return Value

A collection of scissor rectangles (see D3DRect). If maximumNumberOfRects is greater than the number of scissor rects currently bound, then the collection will be trimmed to contain only the currently bound.

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..D3DRect


BoundedGetViewports Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..BoundedGetViewports Method
RasterizerPipelineStage Class See Also Send Feedback
Get the array of viewports bound to the rasterizer stage

(Also see DirectX SDK: ID3D11DeviceContext::RSGetViewports)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<Viewport> BoundedGetViewports(
    uint maxNumberOfViewports
)
Visual Basic
Public Function BoundedGetViewports ( _
    maxNumberOfViewports As UInteger _
) As IEnumerable(Of Viewport)
Visual C++
public:
IEnumerable<Viewport>^ BoundedGetViewports(
    unsigned int maxNumberOfViewports
)

Parameters

maxNumberOfViewports
Type: System..::..UInt32
The input specifies the maximum number of viewports (ranges from 0 to D3D11_VIEWPORT_AND_SCISSORRECT_OBJECT_COUNT_PER_PIPELINE) to retrieve, the output contains the actual number of viewports returned.

Return Value

A collection of Viewport structures that are bound to the device. If the number of viewports (in maxNumberOfViewports) is greater than the actual number of viewports currently bound, then the collection will be trimmed to contain only the currently bound. See the structure page for details about how the viewport size is dependent on the device feature level which has changed between Direct3D 11 and Direct3D 10.

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage Properties
RasterizerPipelineStage Class See Also Send Feedback

The RasterizerPipelineStage type exposes the following members.

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | ScissorRects | Gets or sets an array of scissor rectangles bound the rasterizer stage. (See D3DRect). (Also see DirectX SDK: ID3D11DeviceContext::RSGetScissorRects, ID3D11DeviceContext::RSSetScissorRects)
Public property | State | Gets or sets the rasterizer state of the rasterizer stage of the pipeline. (See RasterizerState). (Also see DirectX SDK: ID3D11DeviceContext::RSGetState, ID3D11DeviceContext::RSSetState)
Public property | Viewports | Bind an array of viewports to the rasterizer stage of the pipeline. (Also see DirectX SDK: ID3D11DeviceContext::RSSetViewports)

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ScissorRects Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..ScissorRects Property
RasterizerPipelineStage Class See Also Send Feedback
Gets or sets an array of scissor rectangles bound the rasterizer stage. (See D3DRect).

(Also see DirectX SDK: ID3D11DeviceContext::RSGetScissorRects, ID3D11DeviceContext::RSSetScissorRects)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<D3DRect> ScissorRects { get; set; }
Visual Basic
Public Property ScissorRects As IEnumerable(Of D3DRect)
    Get
    Set
Visual C++
public:
property IEnumerable<D3DRect>^ ScissorRects {
    IEnumerable<D3DRect>^ get ();
    void set (IEnumerable<D3DRect>^ value);
}

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..D3DRect


State Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..State Property
RasterizerPipelineStage Class See Also Send Feedback
Gets or sets the rasterizer state of the rasterizer stage of the pipeline. (See RasterizerState).

(Also see DirectX SDK: ID3D11DeviceContext::RSGetState, ID3D11DeviceContext::RSSetState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerState State { get; set; }
Visual Basic
Public Property State As RasterizerState
    Get
    Set
Visual C++
public:
property RasterizerState^ State {
    RasterizerState^ get ();
    void set (RasterizerState^ value);
}

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerState


Viewports Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerPipelineStage..::..Viewports Property
RasterizerPipelineStage Class See Also Send Feedback
Bind an array of viewports to the rasterizer stage of the pipeline.

(Also see DirectX SDK: ID3D11DeviceContext::RSSetViewports)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<Viewport> Viewports { get; set; }
Visual Basic
Public Property Viewports As IEnumerable(Of Viewport)
    Get
    Set
Visual C++
public:
property IEnumerable<Viewport>^ Viewports {
    IEnumerable<Viewport>^ get ();
    void set (IEnumerable<Viewport>^ value);
}

See Also

RasterizerPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerState Class
Members See Also Send Feedback
A rasterizer-state interface accesses rasterizer state for the rasterizer stage.

(Also see DirectX SDK: ID3D11RasterizerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RasterizerState : DeviceChild
Visual Basic
Public Class RasterizerState _
    Inherits DeviceChild
Visual C++
public ref class RasterizerState : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RasterizerState

See Also

RasterizerState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerState Members
RasterizerState Class Properties See Also Send Feedback

The RasterizerState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a rasterizer-state object. (Also see DirectX SDK: ID3D11RasterizerState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

RasterizerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RasterizerState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerState Properties
RasterizerState Class See Also Send Feedback

The RasterizerState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a rasterizer-state object. (Also see DirectX SDK: ID3D11RasterizerState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

RasterizerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RasterizerState..::..Description Property
RasterizerState Class See Also Send Feedback
Get the properties of a rasterizer-state object.

(Also see DirectX SDK: ID3D11RasterizerState::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RasterizerDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As RasterizerDescription
    Get
Visual C++
public:
property RasterizerDescription Description {
    RasterizerDescription get ();
}

See Also

RasterizerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetBlendDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription Structure
Members See Also Send Feedback
Describes the blend state for a render target.

(Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RenderTargetBlendDescription
Visual Basic
Public Structure RenderTargetBlendDescription
Visual C++
public value class RenderTargetBlendDescription

See Also

RenderTargetBlendDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetBlendDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription Members
RenderTargetBlendDescription Structure Methods Operators Properties See Also Send Feedback

The RenderTargetBlendDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BlendEnable | Enable (or disable) blending. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.BlendEnable)
Public property | BlendOperation | This blend operation defines how to combine the RGB data sources. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.BlendOp)
Public property | BlendOperationAlpha | This blend operation defines how to combine the alpha data sources. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.BlendOpAlpha)
Public property | DestinationBlend | This blend option specifies the second RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.DestBlend)
Public property | DestinationBlendAlpha | This blend option specifies the second alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.DestBlendAlpha)
Public property | RenderTargetWriteMask | A write mask. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.RenderTargetWriteMask)
Public property | SourceBlend | This blend option specifies the first RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.SrcBlend)
Public property | SourceBlendAlpha | This blend option specifies the first alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.SrcBlendAlpha)

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetBlendDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription Methods
RenderTargetBlendDescription Structure See Also Send Feedback

The RenderTargetBlendDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..Equals Method
RenderTargetBlendDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..GetHashCode Method
RenderTargetBlendDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetBlendDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription Operators
RenderTargetBlendDescription Structure See Also Send Feedback

The RenderTargetBlendDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..Equality Operator
RenderTargetBlendDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    RenderTargetBlendDescription renderTargetBlendDescription1,
    RenderTargetBlendDescription renderTargetBlendDescription2
)
Visual Basic
Public Shared Operator = ( _
    renderTargetBlendDescription1 As RenderTargetBlendDescription, _
    renderTargetBlendDescription2 As RenderTargetBlendDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    RenderTargetBlendDescription renderTargetBlendDescription1,
    RenderTargetBlendDescription renderTargetBlendDescription2
)

Parameters

renderTargetBlendDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetBlendDescription
renderTargetBlendDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetBlendDescription

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..Inequality Operator
RenderTargetBlendDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    RenderTargetBlendDescription renderTargetBlendDescription1,
    RenderTargetBlendDescription renderTargetBlendDescription2
)
Visual Basic
Public Shared Operator <> ( _
    renderTargetBlendDescription1 As RenderTargetBlendDescription, _
    renderTargetBlendDescription2 As RenderTargetBlendDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    RenderTargetBlendDescription renderTargetBlendDescription1,
    RenderTargetBlendDescription renderTargetBlendDescription2
)

Parameters

renderTargetBlendDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetBlendDescription
renderTargetBlendDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetBlendDescription

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetBlendDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription Properties
RenderTargetBlendDescription Structure See Also Send Feedback

The RenderTargetBlendDescription type exposes the following members.

Properties

 | Name | Description
Public property | BlendEnable | Enable (or disable) blending. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.BlendEnable)
Public property | BlendOperation | This blend operation defines how to combine the RGB data sources. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.BlendOp)
Public property | BlendOperationAlpha | This blend operation defines how to combine the alpha data sources. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.BlendOpAlpha)
Public property | DestinationBlend | This blend option specifies the second RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.DestBlend)
Public property | DestinationBlendAlpha | This blend option specifies the second alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.DestBlendAlpha)
Public property | RenderTargetWriteMask | A write mask. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.RenderTargetWriteMask)
Public property | SourceBlend | This blend option specifies the first RGB data source and includes an optional pre-blend operation. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.SrcBlend)
Public property | SourceBlendAlpha | This blend option specifies the first alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed. (Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.SrcBlendAlpha)

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendEnable Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..BlendEnable Property
RenderTargetBlendDescription Structure See Also Send Feedback
Enable (or disable) blending.

(Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.BlendEnable)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool BlendEnable { get; set; }
Visual Basic
Public Property BlendEnable As Boolean
    Get
    Set
Visual C++
public:
property bool BlendEnable {
    bool get ();
    void set (bool value);
}

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendOperation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..BlendOperation Property
RenderTargetBlendDescription Structure See Also Send Feedback
This blend operation defines how to combine the RGB data sources.

(Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.BlendOp)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendOperation BlendOperation { get; set; }
Visual Basic
Public Property BlendOperation As BlendOperation
    Get
    Set
Visual C++
public:
property BlendOperation BlendOperation {
    BlendOperation get ();
    void set (BlendOperation value);
}

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BlendOperationAlpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..BlendOperationAlpha Property
RenderTargetBlendDescription Structure See Also Send Feedback
This blend operation defines how to combine the alpha data sources.

(Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.BlendOpAlpha)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BlendOperation BlendOperationAlpha { get; set; }
Visual Basic
Public Property BlendOperationAlpha As BlendOperation
    Get
    Set
Visual C++
public:
property BlendOperation BlendOperationAlpha {
    BlendOperation get ();
    void set (BlendOperation value);
}

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DestinationBlend Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..DestinationBlend Property
RenderTargetBlendDescription Structure See Also Send Feedback
This blend option specifies the second RGB data source and includes an optional pre-blend operation.

(Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.DestBlend)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend DestinationBlend { get; set; }
Visual Basic
Public Property DestinationBlend As Blend
    Get
    Set
Visual C++
public:
property Blend DestinationBlend {
    Blend get ();
    void set (Blend value);
}

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


DestinationBlendAlpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..DestinationBlendAlpha Property
RenderTargetBlendDescription Structure See Also Send Feedback
This blend option specifies the second alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed.

(Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.DestBlendAlpha)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend DestinationBlendAlpha { get; set; }
Visual Basic
Public Property DestinationBlendAlpha As Blend
    Get
    Set
Visual C++
public:
property Blend DestinationBlendAlpha {
    Blend get ();
    void set (Blend value);
}

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetWriteMask Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..RenderTargetWriteMask Property
RenderTargetBlendDescription Structure See Also Send Feedback
A write mask.

(Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.RenderTargetWriteMask)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorWriteEnableComponents RenderTargetWriteMask { get; set; }
Visual Basic
Public Property RenderTargetWriteMask As ColorWriteEnableComponents
    Get
    Set
Visual C++
public:
property ColorWriteEnableComponents RenderTargetWriteMask {
    ColorWriteEnableComponents get ();
    void set (ColorWriteEnableComponents value);
}

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SourceBlend Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..SourceBlend Property
RenderTargetBlendDescription Structure See Also Send Feedback
This blend option specifies the first RGB data source and includes an optional pre-blend operation.

(Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.SrcBlend)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend SourceBlend { get; set; }
Visual Basic
Public Property SourceBlend As Blend
    Get
    Set
Visual C++
public:
property Blend SourceBlend {
    Blend get ();
    void set (Blend value);
}

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SourceBlendAlpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetBlendDescription..::..SourceBlendAlpha Property
RenderTargetBlendDescription Structure See Also Send Feedback
This blend option specifies the first alpha data source and includes an optional pre-blend operation. Blend options that end in _COLOR are not allowed.

(Also see DirectX SDK: D3D11_RENDER_TARGET_BLEND_DESC.SrcBlendAlpha)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Blend SourceBlendAlpha { get; set; }
Visual Basic
Public Property SourceBlendAlpha As Blend
    Get
    Set
Visual C++
public:
property Blend SourceBlendAlpha {
    Blend get ();
    void set (Blend value);
}

See Also

RenderTargetBlendDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetView Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetView Class
Members See Also Send Feedback
A render-target-view interface identifies the render-target subresources that can be accessed during rendering.

(Also see DirectX SDK: ID3D11RenderTargetView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RenderTargetView : View
Visual Basic
Public Class RenderTargetView _
    Inherits View
Visual C++
public ref class RenderTargetView : public View

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetView

See Also

RenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetView Members
RenderTargetView Class Properties See Also Send Feedback

The RenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a render target view. (Also see DirectX SDK: ID3D11RenderTargetView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource) (Inherited from View.)

See Also

RenderTargetView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetView Properties
RenderTargetView Class See Also Send Feedback

The RenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of a render target view. (Also see DirectX SDK: ID3D11RenderTargetView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource) (Inherited from View.)

See Also

RenderTargetView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetView..::..Description Property
RenderTargetView Class See Also Send Feedback
Get the properties of a render target view.

(Also see DirectX SDK: ID3D11RenderTargetView::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetViewDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As RenderTargetViewDescription
    Get
Visual C++
public:
property RenderTargetViewDescription Description {
    RenderTargetViewDescription get ();
}

See Also

RenderTargetView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetViewDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription Structure
Members See Also Send Feedback
Specifies the subresources from a resource that are accessible using a render-target view.

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct RenderTargetViewDescription
Visual Basic
Public Structure RenderTargetViewDescription
Visual C++
public value class RenderTargetViewDescription

See Also

RenderTargetViewDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetViewDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription Members
RenderTargetViewDescription Structure Properties See Also Send Feedback

The RenderTargetViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | Specifies which buffer elements can be accessed (see BufferRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Buffer)
Public property | Format | The data format (see Format). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Format)
Public property | Texture1D | Specifies the subresources in a 1D texture that can be accessed (see Texture1DRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies the subresources in a 1D texture array that can be accessed (see Texture1DArrayRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies the subresources in a 2D texture that can be accessed (see Texture2DRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies the subresources in a 2D texture array that can be accessed (see Texture2DArrayRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | Specifies a single subresource because a multisampled 2D texture only contains one subresource (see Texture2DMultisampleRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2DMS)
Public property | Texture2DMultisampleArray | Specifies the subresources in a multisampled 2D texture array that can be accessed (see Texture2DMultisampleArrayRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2DMSArray)
Public property | Texture3D | Specifies subresources in a 3D texture that can be accessed (see Texture3DRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture3D)
Public property | ViewDimension | The resource type (see RenderTargetViewDimension), which specifies how the render-target resource will be accessed. (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.ViewDimension)

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


RenderTargetViewDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription Properties
RenderTargetViewDescription Structure See Also Send Feedback

The RenderTargetViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | Specifies which buffer elements can be accessed (see BufferRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Buffer)
Public property | Format | The data format (see Format). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Format)
Public property | Texture1D | Specifies the subresources in a 1D texture that can be accessed (see Texture1DRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies the subresources in a 1D texture array that can be accessed (see Texture1DArrayRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies the subresources in a 2D texture that can be accessed (see Texture2DRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies the subresources in a 2D texture array that can be accessed (see Texture2DArrayRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | Specifies a single subresource because a multisampled 2D texture only contains one subresource (see Texture2DMultisampleRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2DMS)
Public property | Texture2DMultisampleArray | Specifies the subresources in a multisampled 2D texture array that can be accessed (see Texture2DMultisampleArrayRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2DMSArray)
Public property | Texture3D | Specifies subresources in a 3D texture that can be accessed (see Texture3DRenderTargetView). (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture3D)
Public property | ViewDimension | The resource type (see RenderTargetViewDimension), which specifies how the render-target resource will be accessed. (Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.ViewDimension)

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Buffer Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies which buffer elements can be accessed (see BufferRenderTargetView).

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Buffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BufferRenderTargetView Buffer { get; set; }
Visual Basic
Public Property Buffer As BufferRenderTargetView
    Get
    Set
Visual C++
public:
property BufferRenderTargetView Buffer {
    BufferRenderTargetView get ();
    void set (BufferRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferRenderTargetView


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Format Property
RenderTargetViewDescription Structure See Also Send Feedback
The data format (see Format).

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
RenderTargetViewDescription..::..Format


Texture1D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture1D Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a 1D texture that can be accessed (see Texture1DRenderTargetView).

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DRenderTargetView Texture1D { get; set; }
Visual Basic
Public Property Texture1D As Texture1DRenderTargetView
    Get
    Set
Visual C++
public:
property Texture1DRenderTargetView Texture1D {
    Texture1DRenderTargetView get ();
    void set (Texture1DRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DRenderTargetView


Texture1DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture1DArray Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a 1D texture array that can be accessed (see Texture1DArrayRenderTargetView).

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture1DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DArrayRenderTargetView Texture1DArray { get; set; }
Visual Basic
Public Property Texture1DArray As Texture1DArrayRenderTargetView
    Get
    Set
Visual C++
public:
property Texture1DArrayRenderTargetView Texture1DArray {
    Texture1DArrayRenderTargetView get ();
    void set (Texture1DArrayRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayRenderTargetView


Texture2D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture2D Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a 2D texture that can be accessed (see Texture2DRenderTargetView).

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DRenderTargetView Texture2D { get; set; }
Visual Basic
Public Property Texture2D As Texture2DRenderTargetView
    Get
    Set
Visual C++
public:
property Texture2DRenderTargetView Texture2D {
    Texture2DRenderTargetView get ();
    void set (Texture2DRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DRenderTargetView


Texture2DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture2DArray Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a 2D texture array that can be accessed (see Texture2DArrayRenderTargetView).

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DArrayRenderTargetView Texture2DArray { get; set; }
Visual Basic
Public Property Texture2DArray As Texture2DArrayRenderTargetView
    Get
    Set
Visual C++
public:
property Texture2DArrayRenderTargetView Texture2DArray {
    Texture2DArrayRenderTargetView get ();
    void set (Texture2DArrayRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayRenderTargetView


Texture2DMultisample Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture2DMultisample Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies a single subresource because a multisampled 2D texture only contains one subresource (see Texture2DMultisampleRenderTargetView).

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2DMS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleRenderTargetView Texture2DMultisample { get; set; }
Visual Basic
Public Property Texture2DMultisample As Texture2DMultisampleRenderTargetView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleRenderTargetView Texture2DMultisample {
    Texture2DMultisampleRenderTargetView get ();
    void set (Texture2DMultisampleRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleRenderTargetView


Texture2DMultisampleArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture2DMultisampleArray Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies the subresources in a multisampled 2D texture array that can be accessed (see Texture2DMultisampleArrayRenderTargetView).

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture2DMSArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleArrayRenderTargetView Texture2DMultisampleArray { get; set; }
Visual Basic
Public Property Texture2DMultisampleArray As Texture2DMultisampleArrayRenderTargetView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleArrayRenderTargetView Texture2DMultisampleArray {
    Texture2DMultisampleArrayRenderTargetView get ();
    void set (Texture2DMultisampleArrayRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayRenderTargetView


Texture3D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..Texture3D Property
RenderTargetViewDescription Structure See Also Send Feedback
Specifies subresources in a 3D texture that can be accessed (see Texture3DRenderTargetView).

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.Texture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3DRenderTargetView Texture3D { get; set; }
Visual Basic
Public Property Texture3D As Texture3DRenderTargetView
    Get
    Set
Visual C++
public:
property Texture3DRenderTargetView Texture3D {
    Texture3DRenderTargetView get ();
    void set (Texture3DRenderTargetView value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DRenderTargetView


ViewDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDescription..::..ViewDimension Property
RenderTargetViewDescription Structure See Also Send Feedback
The resource type (see RenderTargetViewDimension), which specifies how the render-target resource will be accessed.

(Also see DirectX SDK: D3D11_RENDER_TARGET_VIEW_DESC.ViewDimension)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderTargetViewDimension ViewDimension { get; set; }
Visual Basic
Public Property ViewDimension As RenderTargetViewDimension
    Get
    Set
Visual C++
public:
property RenderTargetViewDimension ViewDimension {
    RenderTargetViewDimension get ();
    void set (RenderTargetViewDimension value);
}

See Also

RenderTargetViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetViewDimension


RenderTargetViewDimension Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderTargetViewDimension Enumeration
See Also Send Feedback
These flags identify the type of resource that will be viewed as a render target.

(Also see DirectX SDK: D3D11_RTV_DIMENSION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum RenderTargetViewDimension
Visual Basic
Public Enumeration RenderTargetViewDimension
Visual C++
public enum class RenderTargetViewDimension

Members

Member name | Description
Texture2DMultisampleArray |
Texture2DMultisample |
Buffer |
Texture3D |
Texture2DArray |
Texture2D |
Texture1DArray |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ResourceDimension Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ResourceDimension Enumeration
See Also Send Feedback
Identifies the type of resource being used.

(Also see DirectX SDK: D3D11_RESOURCE_DIMENSION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ResourceDimension
Visual Basic
Public Enumeration ResourceDimension
Visual C++
public enum class ResourceDimension

Members

Member name | Description
Buffer |
Texture3D |
Texture2D |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SamplerDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Structure
Members See Also Send Feedback
Describes a sampler state.

(Also see DirectX SDK: D3D11_SAMPLER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SamplerDescription
Visual Basic
Public Structure SamplerDescription
Visual C++
public value class SamplerDescription

See Also

SamplerDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SamplerDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Members
SamplerDescription Structure Methods Operators Properties See Also Send Feedback

The SamplerDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AddressU | Method to use for resolving a u texture coordinate that is outside the 0 to 1 range (see TextureAddressMode). (Also see DirectX SDK: D3D11_SAMPLER_DESC.AddressU)
Public property | AddressV | Method to use for resolving a v texture coordinate that is outside the 0 to 1 range. (Also see DirectX SDK: D3D11_SAMPLER_DESC.AddressV)
Public property | AddressW | Method to use for resolving a w texture coordinate that is outside the 0 to 1 range. (Also see DirectX SDK: D3D11_SAMPLER_DESC.AddressW)
Public property | BorderColor | Border color to use if Border is specified for AddressU, AddressV, or AddressW. Range must be between 0.0 and 1.0 inclusive. (Also see DirectX SDK: D3D11_SAMPLER_DESC.BorderColor)
Public property | ComparisonFunction | A function that compares sampled data against existing sampled data. The function options are listed in ComparisonFunction. (Also see DirectX SDK: D3D11_SAMPLER_DESC.ComparisonFunction)
Public property | Filter | Filtering method to use when sampling a texture (see Filter). (Also see DirectX SDK: D3D11_SAMPLER_DESC.Filter)
Public property | MaxAnisotropy | Clamping value used if Anisotropic or ComparisonAnisotropic is specified in Filter. Valid values are between 1 and 16. (Also see DirectX SDK: D3D11_SAMPLER_DESC.MaxAnisotropy)
Public property | MaximumLevelOfDetail | Upper end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. This value must be greater than or equal to MinimumLevelOfDetail. To have no upper limit on LOD set this to a large value such as D3D11_FLOAT32_MAX. (Also see DirectX SDK: D3D11_SAMPLER_DESC.MaxLOD)
Public property | MinimumLevelOfDetail | Lower end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. (Also see DirectX SDK: D3D11_SAMPLER_DESC.MinLOD)
Public property | MipLevelOfDetailBias | offset from the calculated mipmap level. For example, if Direct3D calculates that a texture should be sampled at mipmap level 3 and MipLevelOfDetailBias is 2, then the texture will be sampled at mipmap level 5. (Also see DirectX SDK: D3D11_SAMPLER_DESC.MipLODBias)

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SamplerDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Methods
SamplerDescription Structure See Also Send Feedback

The SamplerDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..Equals Method
SamplerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..GetHashCode Method
SamplerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SamplerDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Operators
SamplerDescription Structure See Also Send Feedback

The SamplerDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..Equality Operator
SamplerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    SamplerDescription samplerDescription1,
    SamplerDescription samplerDescription2
)
Visual Basic
Public Shared Operator = ( _
    samplerDescription1 As SamplerDescription, _
    samplerDescription2 As SamplerDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    SamplerDescription samplerDescription1,
    SamplerDescription samplerDescription2
)

Parameters

samplerDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerDescription
samplerDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerDescription

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..Inequality Operator
SamplerDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    SamplerDescription samplerDescription1,
    SamplerDescription samplerDescription2
)
Visual Basic
Public Shared Operator <> ( _
    samplerDescription1 As SamplerDescription, _
    samplerDescription2 As SamplerDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    SamplerDescription samplerDescription1,
    SamplerDescription samplerDescription2
)

Parameters

samplerDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerDescription
samplerDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerDescription

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SamplerDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription Properties
SamplerDescription Structure See Also Send Feedback

The SamplerDescription type exposes the following members.

Properties

 | Name | Description
Public property | AddressU | Method to use for resolving a u texture coordinate that is outside the 0 to 1 range (see TextureAddressMode). (Also see DirectX SDK: D3D11_SAMPLER_DESC.AddressU)
Public property | AddressV | Method to use for resolving a v texture coordinate that is outside the 0 to 1 range. (Also see DirectX SDK: D3D11_SAMPLER_DESC.AddressV)
Public property | AddressW | Method to use for resolving a w texture coordinate that is outside the 0 to 1 range. (Also see DirectX SDK: D3D11_SAMPLER_DESC.AddressW)
Public property | BorderColor | Border color to use if Border is specified for AddressU, AddressV, or AddressW. Range must be between 0.0 and 1.0 inclusive. (Also see DirectX SDK: D3D11_SAMPLER_DESC.BorderColor)
Public property | ComparisonFunction | A function that compares sampled data against existing sampled data. The function options are listed in ComparisonFunction. (Also see DirectX SDK: D3D11_SAMPLER_DESC.ComparisonFunction)
Public property | Filter | Filtering method to use when sampling a texture (see Filter). (Also see DirectX SDK: D3D11_SAMPLER_DESC.Filter)
Public property | MaxAnisotropy | Clamping value used if Anisotropic or ComparisonAnisotropic is specified in Filter. Valid values are between 1 and 16. (Also see DirectX SDK: D3D11_SAMPLER_DESC.MaxAnisotropy)
Public property | MaximumLevelOfDetail | Upper end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. This value must be greater than or equal to MinimumLevelOfDetail. To have no upper limit on LOD set this to a large value such as D3D11_FLOAT32_MAX. (Also see DirectX SDK: D3D11_SAMPLER_DESC.MaxLOD)
Public property | MinimumLevelOfDetail | Lower end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. (Also see DirectX SDK: D3D11_SAMPLER_DESC.MinLOD)
Public property | MipLevelOfDetailBias | offset from the calculated mipmap level. For example, if Direct3D calculates that a texture should be sampled at mipmap level 3 and MipLevelOfDetailBias is 2, then the texture will be sampled at mipmap level 5. (Also see DirectX SDK: D3D11_SAMPLER_DESC.MipLODBias)

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


AddressU Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..AddressU Property
SamplerDescription Structure See Also Send Feedback
Method to use for resolving a u texture coordinate that is outside the 0 to 1 range (see TextureAddressMode).

(Also see DirectX SDK: D3D11_SAMPLER_DESC.AddressU)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureAddressMode AddressU { get; set; }
Visual Basic
Public Property AddressU As TextureAddressMode
    Get
    Set
Visual C++
public:
property TextureAddressMode AddressU {
    TextureAddressMode get ();
    void set (TextureAddressMode value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureAddressMode


AddressV Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..AddressV Property
SamplerDescription Structure See Also Send Feedback
Method to use for resolving a v texture coordinate that is outside the 0 to 1 range.

(Also see DirectX SDK: D3D11_SAMPLER_DESC.AddressV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureAddressMode AddressV { get; set; }
Visual Basic
Public Property AddressV As TextureAddressMode
    Get
    Set
Visual C++
public:
property TextureAddressMode AddressV {
    TextureAddressMode get ();
    void set (TextureAddressMode value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


AddressW Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..AddressW Property
SamplerDescription Structure See Also Send Feedback
Method to use for resolving a w texture coordinate that is outside the 0 to 1 range.

(Also see DirectX SDK: D3D11_SAMPLER_DESC.AddressW)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureAddressMode AddressW { get; set; }
Visual Basic
Public Property AddressW As TextureAddressMode
    Get
    Set
Visual C++
public:
property TextureAddressMode AddressW {
    TextureAddressMode get ();
    void set (TextureAddressMode value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BorderColor Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..BorderColor Property
SamplerDescription Structure See Also Send Feedback
Border color to use if Border is specified for AddressU, AddressV, or AddressW. Range must be between 0.0 and 1.0 inclusive.

(Also see DirectX SDK: D3D11_SAMPLER_DESC.BorderColor)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgba BorderColor { get; set; }
Visual Basic
Public Property BorderColor As ColorRgba
    Get
    Set
Visual C++
public:
property ColorRgba BorderColor {
    ColorRgba get ();
    void set (ColorRgba value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComparisonFunction Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..ComparisonFunction Property
SamplerDescription Structure See Also Send Feedback
A function that compares sampled data against existing sampled data. The function options are listed in ComparisonFunction.

(Also see DirectX SDK: D3D11_SAMPLER_DESC.ComparisonFunction)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ComparisonFunction ComparisonFunction { get; set; }
Visual Basic
Public Property ComparisonFunction As ComparisonFunction
    Get
    Set
Visual C++
public:
property ComparisonFunction ComparisonFunction {
    ComparisonFunction get ();
    void set (ComparisonFunction value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Filter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..Filter Property
SamplerDescription Structure See Also Send Feedback
Filtering method to use when sampling a texture (see Filter).

(Also see DirectX SDK: D3D11_SAMPLER_DESC.Filter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Filter Filter { get; set; }
Visual Basic
Public Property Filter As Filter
    Get
    Set
Visual C++
public:
property Filter Filter {
    Filter get ();
    void set (Filter value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
SamplerDescription..::..Filter


MaxAnisotropy Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..MaxAnisotropy Property
SamplerDescription Structure See Also Send Feedback
Clamping value used if Anisotropic or ComparisonAnisotropic is specified in Filter. Valid values are between 1 and 16.

(Also see DirectX SDK: D3D11_SAMPLER_DESC.MaxAnisotropy)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MaxAnisotropy { get; set; }
Visual Basic
Public Property MaxAnisotropy As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MaxAnisotropy {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MaximumLevelOfDetail Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..MaximumLevelOfDetail Property
SamplerDescription Structure See Also Send Feedback
Upper end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed. This value must be greater than or equal to MinimumLevelOfDetail. To have no upper limit on LOD set this to a large value such as D3D11_FLOAT32_MAX.

(Also see DirectX SDK: D3D11_SAMPLER_DESC.MaxLOD)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MaximumLevelOfDetail { get; set; }
Visual Basic
Public Property MaximumLevelOfDetail As Single
    Get
    Set
Visual C++
public:
property float MaximumLevelOfDetail {
    float get ();
    void set (float value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MinimumLevelOfDetail Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..MinimumLevelOfDetail Property
SamplerDescription Structure See Also Send Feedback
Lower end of the mipmap range to clamp access to, where 0 is the largest and most detailed mipmap level and any level higher than that is less detailed.

(Also see DirectX SDK: D3D11_SAMPLER_DESC.MinLOD)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MinimumLevelOfDetail { get; set; }
Visual Basic
Public Property MinimumLevelOfDetail As Single
    Get
    Set
Visual C++
public:
property float MinimumLevelOfDetail {
    float get ();
    void set (float value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevelOfDetailBias Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerDescription..::..MipLevelOfDetailBias Property
SamplerDescription Structure See Also Send Feedback
offset from the calculated mipmap level. For example, if Direct3D calculates that a texture should be sampled at mipmap level 3 and MipLevelOfDetailBias is 2, then the texture will be sampled at mipmap level 5.

(Also see DirectX SDK: D3D11_SAMPLER_DESC.MipLODBias)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MipLevelOfDetailBias { get; set; }
Visual Basic
Public Property MipLevelOfDetailBias As Single
    Get
    Set
Visual C++
public:
property float MipLevelOfDetailBias {
    float get ();
    void set (float value);
}

See Also

SamplerDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SamplerState Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerState Class
Members See Also Send Feedback
A sampler-state interface accesses sampler state for a texture.

(Also see DirectX SDK: ID3D11SamplerState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class SamplerState : DeviceChild
Visual Basic
Public Class SamplerState _
    Inherits DeviceChild
Visual C++
public ref class SamplerState : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerState

See Also

SamplerState Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SamplerState Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerState Members
SamplerState Class Properties See Also Send Feedback

The SamplerState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the sampler state. (Also see DirectX SDK: ID3D11SamplerState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

SamplerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SamplerState Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerState Properties
SamplerState Class See Also Send Feedback

The SamplerState type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the sampler state. (Also see DirectX SDK: ID3D11SamplerState::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

SamplerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SamplerState..::..Description Property
SamplerState Class See Also Send Feedback
Get the sampler state.

(Also see DirectX SDK: ID3D11SamplerState::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SamplerDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As SamplerDescription
    Get
Visual C++
public:
property SamplerDescription Description {
    SamplerDescription get ();
}

See Also

SamplerState Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderAndClasses(T) Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderAndClasses<(Of <(<'T>)>)> Structure
Members See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ShaderAndClasses<T>
where T : class
Visual Basic
Public Structure ShaderAndClasses(Of T As Class)
Visual C++
generic<typename T>
where T : ref class
public value class ShaderAndClasses

Type Parameters

T

See Also

ShaderAndClasses<(Of <(<'T>)>)> Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderAndClasses(T) Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderAndClasses<(Of <(<'T>)>)> Members
ShaderAndClasses<(Of <(<'T>)>)> Structure Constructors Properties See Also Send Feedback

The ShaderAndClasses<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | ShaderAndClasses<(Of <(<'T>)>)>(T, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | ShaderAndClasses<(Of <(<'T>)>)>(T, ReadOnlyCollection<(Of <<'(ClassInstance>)>>)) |

Properties

 | Name | Description
Public property | Classes |
Public property | Shader |

See Also

ShaderAndClasses<(Of <(<'T>)>)> Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderAndClasses(T) Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderAndClasses<(Of <(<'T>)>)> Constructor
ShaderAndClasses<(Of <(<'T>)>)> Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ShaderAndClasses<(Of <(<'T>)>)>(T, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | ShaderAndClasses<(Of <(<'T>)>)>(T, ReadOnlyCollection<(Of <<'(ClassInstance>)>>)) |

See Also

ShaderAndClasses<(Of <(<'T>)>)> Structure
ShaderAndClasses<(Of <(<'T>)>)> Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderAndClasses(T) Constructor (T, IEnumerable(ClassInstance))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderAndClasses<(Of <(<'T>)>)> Constructor (T, IEnumerable<(Of <(<'ClassInstance>)>)>)
ShaderAndClasses<(Of <(<'T>)>)> Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderAndClasses(
    T shader,
    IEnumerable<ClassInstance> instanceEnum
)
Visual Basic
Public Sub New ( _
    shader As T, _
    instanceEnum As IEnumerable(Of ClassInstance) _
)
Visual C++
public:
ShaderAndClasses(
    T shader,
    IEnumerable<ClassInstance^>^ instanceEnum
)

Parameters

shader
Type: T
instanceEnum
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ClassInstance >)>)>

See Also

ShaderAndClasses<(Of <(<'T>)>)> Structure
ShaderAndClasses<(Of <(<'T>)>)> Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderAndClasses(T) Constructor (T, ReadOnlyCollection(ClassInstance))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderAndClasses<(Of <(<'T>)>)> Constructor (T, ReadOnlyCollection<(Of <(<'ClassInstance>)>)>)
ShaderAndClasses<(Of <(<'T>)>)> Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderAndClasses(
    T shader,
    ReadOnlyCollection<ClassInstance> instanceCollection
)
Visual Basic
Public Sub New ( _
    shader As T, _
    instanceCollection As ReadOnlyCollection(Of ClassInstance) _
)
Visual C++
public:
ShaderAndClasses(
    T shader,
    ReadOnlyCollection<ClassInstance^>^ instanceCollection
)

Parameters

shader
Type: T
instanceCollection
Type: System.Collections.ObjectModel..::..ReadOnlyCollection <(Of <(<' ClassInstance >)>)>

See Also

ShaderAndClasses<(Of <(<'T>)>)> Structure
ShaderAndClasses<(Of <(<'T>)>)> Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderAndClasses(T) Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderAndClasses<(Of <(<'T>)>)> Properties
ShaderAndClasses<(Of <(<'T>)>)> Structure See Also Send Feedback

The ShaderAndClasses<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Classes |
Public property | Shader |

See Also

ShaderAndClasses<(Of <(<'T>)>)> Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Classes Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderAndClasses<(Of <(<'T>)>)>..::..Classes Property
ShaderAndClasses<(Of <(<'T>)>)> Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ClassInstance> Classes { get; }
Visual Basic
Public ReadOnly Property Classes As ReadOnlyCollection(Of ClassInstance)
    Get
Visual C++
public:
property ReadOnlyCollection<ClassInstance^>^ Classes {
    ReadOnlyCollection<ClassInstance^>^ get ();
}

See Also

ShaderAndClasses<(Of <(<'T>)>)> Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderAndClasses<(Of <(<'T>)>)>..::..Shader Property
ShaderAndClasses<(Of <(<'T>)>)> Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public T Shader { get; }
Visual Basic
Public ReadOnly Property Shader As T
    Get
Visual C++
public:
property T Shader {
    T get ();
}

See Also

ShaderAndClasses<(Of <(<'T>)>)> Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderResourceView Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView Class
Members See Also Send Feedback
A shader-resource-view interface specifies the subresources a shader can access during rendering. Examples of shader resources include a constant buffer, a texture buffer, a texture or a sampler.

(Also see DirectX SDK: ID3D11ShaderResourceView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ShaderResourceView : View
Visual Basic
Public Class ShaderResourceView _
    Inherits View
Visual C++
public ref class ShaderResourceView : public View

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderResourceView

See Also

ShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView Members
ShaderResourceView Class Properties See Also Send Feedback

The ShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the shader resource view's description. (Also see DirectX SDK: ID3D11ShaderResourceView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource) (Inherited from View.)

See Also

ShaderResourceView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView Properties
ShaderResourceView Class See Also Send Feedback

The ShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the shader resource view's description. (Also see DirectX SDK: ID3D11ShaderResourceView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource) (Inherited from View.)

See Also

ShaderResourceView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceView..::..Description Property
ShaderResourceView Class See Also Send Feedback
Get the shader resource view's description.

(Also see DirectX SDK: ID3D11ShaderResourceView::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceViewDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As ShaderResourceViewDescription
    Get
Visual C++
public:
property ShaderResourceViewDescription Description {
    ShaderResourceViewDescription get ();
}

See Also

ShaderResourceView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderResourceViewDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription Structure
Members See Also Send Feedback
Describes a shader-resource view.

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ShaderResourceViewDescription
Visual Basic
Public Structure ShaderResourceViewDescription
Visual C++
public value class ShaderResourceViewDescription

See Also

ShaderResourceViewDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderResourceViewDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription Members
ShaderResourceViewDescription Structure Properties See Also Send Feedback

The ShaderResourceViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | View the resource as a buffer using information from a shader-resource view (see BufferShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Buffer)
Public property | ExtendedBuffer | View the resource as an extended buffer using information from a shader-resource view (see ExtendedBufferShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.BufferEx)
Public property | Format | A Format specifying the viewing format. (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Format)
Public property | Texture1D | View the resource as a 1D texture using information from a shader-resource view (see Texture1DShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture1D)
Public property | Texture1DArray | View the resource as a 1D-texture array using information from a shader-resource view (see Texture1DArrayShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture1DArray)
Public property | Texture2D | View the resource as a 2D-texture using information from a shader-resource view (see Texture2DShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2D)
Public property | Texture2DArray | View the resource as a 2D-texture array using information from a shader-resource view (see Texture2DArrayShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | View the resource as a 2D-multisampled texture using information from a shader-resource view (see Texture2DMultisampleShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2DMultisample)
Public property | Texture2DMultisampleArray | View the resource as a 2D-multisampled-texture array using information from a shader-resource view (see Texture2DMultisampleArrayShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2DMSArray)
Public property | Texture3D | View the resource as a 3D texture using information from a shader-resource view (see Texture3DShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture3D)
Public property | TextureCube | View the resource as a 3D-cube texture using information from a shader-resource view (see TextureCubeShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.TextureCube)
Public property | TextureCubeArray | View the resource as a 3D-cube-texture array using information from a shader-resource view (see TextureCubeArrayShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.TextureCubeArray)
Public property | ViewDimension | The resource type of the view. See ShaderResourceViewDimension. This should be the same as the resource type of the underlying resource. This parameter also determines which _SRV to use in the union below. (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.ViewDimension)

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderResourceViewDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription Properties
ShaderResourceViewDescription Structure See Also Send Feedback

The ShaderResourceViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | View the resource as a buffer using information from a shader-resource view (see BufferShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Buffer)
Public property | ExtendedBuffer | View the resource as an extended buffer using information from a shader-resource view (see ExtendedBufferShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.BufferEx)
Public property | Format | A Format specifying the viewing format. (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Format)
Public property | Texture1D | View the resource as a 1D texture using information from a shader-resource view (see Texture1DShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture1D)
Public property | Texture1DArray | View the resource as a 1D-texture array using information from a shader-resource view (see Texture1DArrayShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture1DArray)
Public property | Texture2D | View the resource as a 2D-texture using information from a shader-resource view (see Texture2DShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2D)
Public property | Texture2DArray | View the resource as a 2D-texture array using information from a shader-resource view (see Texture2DArrayShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2DArray)
Public property | Texture2DMultisample | View the resource as a 2D-multisampled texture using information from a shader-resource view (see Texture2DMultisampleShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2DMultisample)
Public property | Texture2DMultisampleArray | View the resource as a 2D-multisampled-texture array using information from a shader-resource view (see Texture2DMultisampleArrayShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2DMSArray)
Public property | Texture3D | View the resource as a 3D texture using information from a shader-resource view (see Texture3DShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture3D)
Public property | TextureCube | View the resource as a 3D-cube texture using information from a shader-resource view (see TextureCubeShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.TextureCube)
Public property | TextureCubeArray | View the resource as a 3D-cube-texture array using information from a shader-resource view (see TextureCubeArrayShaderResourceView). (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.TextureCubeArray)
Public property | ViewDimension | The resource type of the view. See ShaderResourceViewDimension. This should be the same as the resource type of the underlying resource. This parameter also determines which _SRV to use in the union below. (Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.ViewDimension)

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Buffer Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a buffer using information from a shader-resource view (see BufferShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Buffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BufferShaderResourceView Buffer { get; set; }
Visual Basic
Public Property Buffer As BufferShaderResourceView
    Get
    Set
Visual C++
public:
property BufferShaderResourceView Buffer {
    BufferShaderResourceView get ();
    void set (BufferShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferShaderResourceView


ExtendedBuffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..ExtendedBuffer Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as an extended buffer using information from a shader-resource view (see ExtendedBufferShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.BufferEx)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ExtendedBufferShaderResourceView ExtendedBuffer { get; set; }
Visual Basic
Public Property ExtendedBuffer As ExtendedBufferShaderResourceView
    Get
    Set
Visual C++
public:
property ExtendedBufferShaderResourceView ExtendedBuffer {
    ExtendedBufferShaderResourceView get ();
    void set (ExtendedBufferShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ExtendedBufferShaderResourceView


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Format Property
ShaderResourceViewDescription Structure See Also Send Feedback
A Format specifying the viewing format.

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture1D Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 1D texture using information from a shader-resource view (see Texture1DShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DShaderResourceView Texture1D { get; set; }
Visual Basic
Public Property Texture1D As Texture1DShaderResourceView
    Get
    Set
Visual C++
public:
property Texture1DShaderResourceView Texture1D {
    Texture1DShaderResourceView get ();
    void set (Texture1DShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DShaderResourceView


Texture1DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture1DArray Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 1D-texture array using information from a shader-resource view (see Texture1DArrayShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture1DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DArrayShaderResourceView Texture1DArray { get; set; }
Visual Basic
Public Property Texture1DArray As Texture1DArrayShaderResourceView
    Get
    Set
Visual C++
public:
property Texture1DArrayShaderResourceView Texture1DArray {
    Texture1DArrayShaderResourceView get ();
    void set (Texture1DArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayShaderResourceView


Texture2D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture2D Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 2D-texture using information from a shader-resource view (see Texture2DShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DShaderResourceView Texture2D { get; set; }
Visual Basic
Public Property Texture2D As Texture2DShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DShaderResourceView Texture2D {
    Texture2DShaderResourceView get ();
    void set (Texture2DShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DShaderResourceView


Texture2DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture2DArray Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 2D-texture array using information from a shader-resource view (see Texture2DArrayShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DArrayShaderResourceView Texture2DArray { get; set; }
Visual Basic
Public Property Texture2DArray As Texture2DArrayShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DArrayShaderResourceView Texture2DArray {
    Texture2DArrayShaderResourceView get ();
    void set (Texture2DArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayShaderResourceView


Texture2DMultisample Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture2DMultisample Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 2D-multisampled texture using information from a shader-resource view (see Texture2DMultisampleShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2DMultisample)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleShaderResourceView Texture2DMultisample { get; set; }
Visual Basic
Public Property Texture2DMultisample As Texture2DMultisampleShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleShaderResourceView Texture2DMultisample {
    Texture2DMultisampleShaderResourceView get ();
    void set (Texture2DMultisampleShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleShaderResourceView


Texture2DMultisampleArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture2DMultisampleArray Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 2D-multisampled-texture array using information from a shader-resource view (see Texture2DMultisampleArrayShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture2DMSArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DMultisampleArrayShaderResourceView Texture2DMultisampleArray { get; set; }
Visual Basic
Public Property Texture2DMultisampleArray As Texture2DMultisampleArrayShaderResourceView
    Get
    Set
Visual C++
public:
property Texture2DMultisampleArrayShaderResourceView Texture2DMultisampleArray {
    Texture2DMultisampleArrayShaderResourceView get ();
    void set (Texture2DMultisampleArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayShaderResourceView


Texture3D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..Texture3D Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 3D texture using information from a shader-resource view (see Texture3DShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.Texture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3DShaderResourceView Texture3D { get; set; }
Visual Basic
Public Property Texture3D As Texture3DShaderResourceView
    Get
    Set
Visual C++
public:
property Texture3DShaderResourceView Texture3D {
    Texture3DShaderResourceView get ();
    void set (Texture3DShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DShaderResourceView


TextureCube Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..TextureCube Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 3D-cube texture using information from a shader-resource view (see TextureCubeShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.TextureCube)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureCubeShaderResourceView TextureCube { get; set; }
Visual Basic
Public Property TextureCube As TextureCubeShaderResourceView
    Get
    Set
Visual C++
public:
property TextureCubeShaderResourceView TextureCube {
    TextureCubeShaderResourceView get ();
    void set (TextureCubeShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeShaderResourceView


TextureCubeArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..TextureCubeArray Property
ShaderResourceViewDescription Structure See Also Send Feedback
View the resource as a 3D-cube-texture array using information from a shader-resource view (see TextureCubeArrayShaderResourceView).

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.TextureCubeArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextureCubeArrayShaderResourceView TextureCubeArray { get; set; }
Visual Basic
Public Property TextureCubeArray As TextureCubeArrayShaderResourceView
    Get
    Set
Visual C++
public:
property TextureCubeArrayShaderResourceView TextureCubeArray {
    TextureCubeArrayShaderResourceView get ();
    void set (TextureCubeArrayShaderResourceView value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeArrayShaderResourceView


ViewDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDescription..::..ViewDimension Property
ShaderResourceViewDescription Structure See Also Send Feedback
The resource type of the view. See ShaderResourceViewDimension. This should be the same as the resource type of the underlying resource. This parameter also determines which _SRV to use in the union below.

(Also see DirectX SDK: D3D11_SHADER_RESOURCE_VIEW_DESC.ViewDimension)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderResourceViewDimension ViewDimension { get; set; }
Visual Basic
Public Property ViewDimension As ShaderResourceViewDimension
    Get
    Set
Visual C++
public:
property ShaderResourceViewDimension ViewDimension {
    ShaderResourceViewDimension get ();
    void set (ShaderResourceViewDimension value);
}

See Also

ShaderResourceViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ShaderResourceViewDimension Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ShaderResourceViewDimension Enumeration
See Also Send Feedback
These flags identify the type of resource that will be viewed as a shader resource.

(Also see DirectX SDK: D3D11_SRV_DIMENSION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ShaderResourceViewDimension
Visual Basic
Public Enumeration ShaderResourceViewDimension
Visual C++
public enum class ShaderResourceViewDimension

Members

Member name | Description
Texture2DMultisampleArray |
Texture2DMultisample |
ExtendedBuffer |
TextureCubeArray |
Buffer |
TextureCube |
Texture3D |
Texture2DArray |
Texture2D |
Texture1DArray |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StencilOperation Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StencilOperation Enumeration
See Also Send Feedback
The stencil operations that can be performed during depth-stencil testing.

(Also see DirectX SDK: D3D11_STENCIL_OP)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum StencilOperation
Visual Basic
Public Enumeration StencilOperation
Visual C++
public enum class StencilOperation

Members

Member name | Description
Invert |
Replace |
Zero |
Decrement |
Increment |
DecrementSat |
IncrementSat |
Keep |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StencilReadMask Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StencilReadMask Enumeration
See Also Send Feedback
A value that identifies a portion of the depth-stencil buffer for reading stencil data.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum StencilReadMask
Visual Basic
Public Enumeration StencilReadMask
Visual C++
public enum class StencilReadMask

Members

Member name | Description
None |
All |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StencilWriteMask Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StencilWriteMask Enumeration
See Also Send Feedback
A value that identifies a portion of the depth-stencil buffer for writing stencil data.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum StencilWriteMask
Visual Basic
Public Enumeration StencilWriteMask
Visual C++
public enum class StencilWriteMask

Members

Member name | Description
None |
All |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputDeclarationEntry Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Structure
Members See Also Send Feedback
Description of a vertex element in a vertex buffer in an output slot.

(Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct StreamOutputDeclarationEntry
Visual Basic
Public Structure StreamOutputDeclarationEntry
Visual C++
public value class StreamOutputDeclarationEntry

See Also

StreamOutputDeclarationEntry Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputDeclarationEntry Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Members
StreamOutputDeclarationEntry Structure Methods Operators Properties See Also Send Feedback

The StreamOutputDeclarationEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ComponentCount | The number of components of the entry to write out to. Valid values are 1 ~ 4. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.ComponentCount)
Public property | OutputSlot | The output slot that contains the vertex buffer that contains this output entry. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.OutputSlot)
Public property | SemanticIndex | Output element's zero-based index. Should be used if, for example, you have more than one texture coordinate stored in each vertex. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.SemanticIndex)
Public property | SemanticName | Type of output element; possible values include: "POSITION", "NORMAL", or "TEXCOORD0". (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.SemanticName)
Public property | StartComponent | Which component of the entry to begin writing out to. Valid values are 0 ~ 3. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.StartComponent)
Public property | StreamIndex | Zero-based, stream index. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.Stream)

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputDeclarationEntry Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Methods
StreamOutputDeclarationEntry Structure See Also Send Feedback

The StreamOutputDeclarationEntry type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..Equals Method
StreamOutputDeclarationEntry Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..GetHashCode Method
StreamOutputDeclarationEntry Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputDeclarationEntry Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Operators
StreamOutputDeclarationEntry Structure See Also Send Feedback

The StreamOutputDeclarationEntry type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..Equality Operator
StreamOutputDeclarationEntry Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    StreamOutputDeclarationEntry streamOutputDeclarationEntry1,
    StreamOutputDeclarationEntry streamOutputDeclarationEntry2
)
Visual Basic
Public Shared Operator = ( _
    streamOutputDeclarationEntry1 As StreamOutputDeclarationEntry, _
    streamOutputDeclarationEntry2 As StreamOutputDeclarationEntry _
) As Boolean
Visual C++
public:
static bool operator ==(
    StreamOutputDeclarationEntry streamOutputDeclarationEntry1,
    StreamOutputDeclarationEntry streamOutputDeclarationEntry2
)

Parameters

streamOutputDeclarationEntry1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..StreamOutputDeclarationEntry
streamOutputDeclarationEntry2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..StreamOutputDeclarationEntry

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..Inequality Operator
StreamOutputDeclarationEntry Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    StreamOutputDeclarationEntry streamOutputDeclarationEntry1,
    StreamOutputDeclarationEntry streamOutputDeclarationEntry2
)
Visual Basic
Public Shared Operator <> ( _
    streamOutputDeclarationEntry1 As StreamOutputDeclarationEntry, _
    streamOutputDeclarationEntry2 As StreamOutputDeclarationEntry _
) As Boolean
Visual C++
public:
static bool operator !=(
    StreamOutputDeclarationEntry streamOutputDeclarationEntry1,
    StreamOutputDeclarationEntry streamOutputDeclarationEntry2
)

Parameters

streamOutputDeclarationEntry1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..StreamOutputDeclarationEntry
streamOutputDeclarationEntry2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..StreamOutputDeclarationEntry

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputDeclarationEntry Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry Properties
StreamOutputDeclarationEntry Structure See Also Send Feedback

The StreamOutputDeclarationEntry type exposes the following members.

Properties

 | Name | Description
Public property | ComponentCount | The number of components of the entry to write out to. Valid values are 1 ~ 4. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.ComponentCount)
Public property | OutputSlot | The output slot that contains the vertex buffer that contains this output entry. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.OutputSlot)
Public property | SemanticIndex | Output element's zero-based index. Should be used if, for example, you have more than one texture coordinate stored in each vertex. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.SemanticIndex)
Public property | SemanticName | Type of output element; possible values include: "POSITION", "NORMAL", or "TEXCOORD0". (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.SemanticName)
Public property | StartComponent | Which component of the entry to begin writing out to. Valid values are 0 ~ 3. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.StartComponent)
Public property | StreamIndex | Zero-based, stream index. (Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.Stream)

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ComponentCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..ComponentCount Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
The number of components of the entry to write out to. Valid values are 1 ~ 4. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2.

(Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.ComponentCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte ComponentCount { get; set; }
Visual Basic
Public Property ComponentCount As Byte
    Get
    Set
Visual C++
public:
property unsigned char ComponentCount {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


OutputSlot Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..OutputSlot Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
The output slot that contains the vertex buffer that contains this output entry.

(Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.OutputSlot)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte OutputSlot { get; set; }
Visual Basic
Public Property OutputSlot As Byte
    Get
    Set
Visual C++
public:
property unsigned char OutputSlot {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SemanticIndex Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..SemanticIndex Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
Output element's zero-based index. Should be used if, for example, you have more than one texture coordinate stored in each vertex.

(Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.SemanticIndex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SemanticIndex { get; set; }
Visual Basic
Public Property SemanticIndex As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SemanticIndex {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SemanticName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..SemanticName Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
Type of output element; possible values include: "POSITION", "NORMAL", or "TEXCOORD0".

(Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.SemanticName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string SemanticName { get; set; }
Visual Basic
Public Property SemanticName As String
    Get
    Set
Visual C++
public:
property String^ SemanticName {
    String^ get ();
    void set (String^ value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StartComponent Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..StartComponent Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
Which component of the entry to begin writing out to. Valid values are 0 ~ 3. For example, if you only wish to output to the y and z components of a position, then StartComponent should be 1 and ComponentCount should be 2.

(Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.StartComponent)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte StartComponent { get; set; }
Visual Basic
Public Property StartComponent As Byte
    Get
    Set
Visual C++
public:
property unsigned char StartComponent {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamIndex Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputDeclarationEntry..::..StreamIndex Property
StreamOutputDeclarationEntry Structure See Also Send Feedback
Zero-based, stream index.

(Also see DirectX SDK: D3D11_SO_DECLARATION_ENTRY.Stream)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint StreamIndex { get; set; }
Visual Basic
Public Property StreamIndex As UInteger
    Get
    Set
Visual C++
public:
property unsigned int StreamIndex {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

StreamOutputDeclarationEntry Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage Class
Members See Also Send Feedback
StreamOutput pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class StreamOutputPipelineStage : PipelineStage
Visual Basic
Public Class StreamOutputPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class StreamOutputPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..StreamOutputPipelineStage

See Also

StreamOutputPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage Members
StreamOutputPipelineStage Class Constructors Methods Properties See Also Send Feedback

The StreamOutputPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | StreamOutputPipelineStage |

Methods

 | Name | Description
Public method | GetTargets | Get the target output buffers for the stream-output stage of the pipeline. (Also see DirectX SDK: ID3D11DeviceContext::SOGetTargets)
Public method | SetTargets |

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage Constructor
StreamOutputPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected StreamOutputPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
StreamOutputPipelineStage()

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage Methods
StreamOutputPipelineStage Class See Also Send Feedback

The StreamOutputPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetTargets | Get the target output buffers for the stream-output stage of the pipeline. (Also see DirectX SDK: ID3D11DeviceContext::SOGetTargets)
Public method | SetTargets |

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetTargets Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage..::..GetTargets Method
StreamOutputPipelineStage Class See Also Send Feedback
Get the target output buffers for the stream-output stage of the pipeline.

(Also see DirectX SDK: ID3D11DeviceContext::SOGetTargets)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetTargets(
    uint bufferCount
)
Visual Basic
Public Function GetTargets ( _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetTargets(
    unsigned int bufferCount
)

Parameters

bufferCount
Type: System..::..UInt32
Number of buffers to get.

Return Value

A collection of output buffers (see D3DBuffer) to be retrieved from the device.

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


SetTargets Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage..::..SetTargets Method
StreamOutputPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetTargets(
    IEnumerable<D3DBuffer> targets,
    uint[] offsets
)
Visual Basic
Public Sub SetTargets ( _
    targets As IEnumerable(Of D3DBuffer), _
    offsets As UInteger() _
)
Visual C++
public:
void SetTargets(
    IEnumerable<D3DBuffer^>^ targets,
    array<unsigned int>^ offsets
)

Parameters

targets
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>
offsets
Type: array< System..::..UInt32 >[]()[][]

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


StreamOutputPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamOutputPipelineStage Properties
StreamOutputPipelineStage Class See Also Send Feedback

The StreamOutputPipelineStage type exposes the following members.

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)

See Also

StreamOutputPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SubresourceData Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData Structure
Members See Also Send Feedback
Specifies data for initializing a subresource.

(Also see DirectX SDK: D3D11_SUBRESOURCE_DATA)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SubresourceData
Visual Basic
Public Structure SubresourceData
Visual C++
public value class SubresourceData

See Also

SubresourceData Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SubresourceData Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData Members
SubresourceData Structure Properties See Also Send Feedback

The SubresourceData type exposes the following members.

Properties

 | Name | Description
Public property | SystemMemory | Pointer to the initialization data. (Also see DirectX SDK: D3D11_SUBRESOURCE_DATA.pSysMem)
Public property | SystemMemoryPitch | Pitch of the memory (in bytes). System-memory pitch is used only for 2D and 3D texture data as it is has no meaning for the other resource types. (Also see DirectX SDK: D3D11_SUBRESOURCE_DATA.SysMemPitch)
Public property | SystemMemorySlicePitch | Size of one depth level (in bytes). System-memory-slice pitch is only used for 3D texture data as it has no meaning for the other resource types. (Also see DirectX SDK: D3D11_SUBRESOURCE_DATA.SysMemSlicePitch)

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SubresourceData Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData Properties
SubresourceData Structure See Also Send Feedback

The SubresourceData type exposes the following members.

Properties

 | Name | Description
Public property | SystemMemory | Pointer to the initialization data. (Also see DirectX SDK: D3D11_SUBRESOURCE_DATA.pSysMem)
Public property | SystemMemoryPitch | Pitch of the memory (in bytes). System-memory pitch is used only for 2D and 3D texture data as it is has no meaning for the other resource types. (Also see DirectX SDK: D3D11_SUBRESOURCE_DATA.SysMemPitch)
Public property | SystemMemorySlicePitch | Size of one depth level (in bytes). System-memory-slice pitch is only used for 3D texture data as it has no meaning for the other resource types. (Also see DirectX SDK: D3D11_SUBRESOURCE_DATA.SysMemSlicePitch)

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SystemMemory Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData..::..SystemMemory Property
SubresourceData Structure See Also Send Feedback
Pointer to the initialization data.

(Also see DirectX SDK: D3D11_SUBRESOURCE_DATA.pSysMem)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr SystemMemory { get; set; }
Visual Basic
Public Property SystemMemory As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr SystemMemory {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SystemMemoryPitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData..::..SystemMemoryPitch Property
SubresourceData Structure See Also Send Feedback
Pitch of the memory (in bytes). System-memory pitch is used only for 2D and 3D texture data as it is has no meaning for the other resource types.

(Also see DirectX SDK: D3D11_SUBRESOURCE_DATA.SysMemPitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SystemMemoryPitch { get; set; }
Visual Basic
Public Property SystemMemoryPitch As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SystemMemoryPitch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SystemMemorySlicePitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SubresourceData..::..SystemMemorySlicePitch Property
SubresourceData Structure See Also Send Feedback
Size of one depth level (in bytes). System-memory-slice pitch is only used for 3D texture data as it has no meaning for the other resource types.

(Also see DirectX SDK: D3D11_SUBRESOURCE_DATA.SysMemSlicePitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SystemMemorySlicePitch { get; set; }
Visual Basic
Public Property SystemMemorySlicePitch As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SystemMemorySlicePitch {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SubresourceData Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SwitchToRef Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwitchToRef Class
Members See Also Send Feedback
A switch-to-reference interface enables an application to switch between a hardware and software device.

(Also see DirectX SDK: ID3D11SwitchToRef)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class SwitchToRef : DirectUnknown
Visual Basic
Public Class SwitchToRef _
    Inherits DirectUnknown
Visual C++
public ref class SwitchToRef : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SwitchToRef

See Also

SwitchToRef Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SwitchToRef Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwitchToRef Members
SwitchToRef Class Properties See Also Send Feedback

The SwitchToRef type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | UseRef | Get or sets a boolean value that indicates the type of device being used. Set this property to true to change to a software device or to false to change to a hardware device. (Also see DirectX SDK: ID3D10SwitchToRef::GetUseRef, ID3D10SwitchToRef::SetUseRef)

See Also

SwitchToRef Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SwitchToRef Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwitchToRef Properties
SwitchToRef Class See Also Send Feedback

The SwitchToRef type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | UseRef | Get or sets a boolean value that indicates the type of device being used. Set this property to true to change to a software device or to false to change to a hardware device. (Also see DirectX SDK: ID3D10SwitchToRef::GetUseRef, ID3D10SwitchToRef::SetUseRef)

See Also

SwitchToRef Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UseRef Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwitchToRef..::..UseRef Property
SwitchToRef Class See Also Send Feedback
Get or sets a boolean value that indicates the type of device being used. Set this property to true to change to a software device or to false to change to a hardware device.

(Also see DirectX SDK: ID3D10SwitchToRef::GetUseRef, ID3D10SwitchToRef::SetUseRef)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool UseRef { get; set; }
Visual Basic
Public Property UseRef As Boolean
    Get
    Set
Visual C++
public:
property bool UseRef {
    bool get ();
    void set (bool value);
}

See Also

SwitchToRef Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1D Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D Class
Members See Also Send Feedback
A 1D texture interface accesses texel data, which is structured memory.

(Also see DirectX SDK: ID3D11Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Texture1D : D3DResource
Visual Basic
Public Class Texture1D _
    Inherits D3DResource
Visual C++
public ref class Texture1D : public D3DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1D

See Also

Texture1D Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1D Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D Members
Texture1D Class Properties See Also Send Feedback

The Texture1D type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D11Texture1D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics.Surface1. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType) (Inherited from D3DResource.)

See Also

Texture1D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1D Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D Properties
Texture1D Class See Also Send Feedback

The Texture1D type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D11Texture1D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics.Surface1. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType) (Inherited from D3DResource.)

See Also

Texture1D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1D..::..Description Property
Texture1D Class See Also Send Feedback
Get the properties of the texture resource.

(Also see DirectX SDK: ID3D11Texture1D::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As Texture1DDescription
    Get
Visual C++
public:
property Texture1DDescription Description {
    Texture1DDescription get ();
}

See Also

Texture1D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresources from an array of 1D textures to use in a depth-stencil view.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DArrayDepthStencilView
Visual Basic
Public Structure Texture1DArrayDepthStencilView
Visual C++
public value class Texture1DArrayDepthStencilView

See Also

Texture1DArrayDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Members
Texture1DArrayDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture1DArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV.FirstArraySlice)
Public property | MipSlice | The index of the first mipmap level to use. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV.MipSlice)

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Methods
Texture1DArrayDepthStencilView Structure See Also Send Feedback

The Texture1DArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..Equals Method
Texture1DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..GetHashCode Method
Texture1DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Operators
Texture1DArrayDepthStencilView Structure See Also Send Feedback

The Texture1DArrayDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..Equality Operator
Texture1DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture1DArrayDepthStencilView textureArrayDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayDepthStencilView1 As Texture1DArrayDepthStencilView, _
    textureArrayDepthStencilView2 As Texture1DArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture1DArrayDepthStencilView textureArrayDepthStencilView2
)

Parameters

textureArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayDepthStencilView
textureArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayDepthStencilView

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..Inequality Operator
Texture1DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture1DArrayDepthStencilView textureArrayDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayDepthStencilView1 As Texture1DArrayDepthStencilView, _
    textureArrayDepthStencilView2 As Texture1DArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture1DArrayDepthStencilView textureArrayDepthStencilView2
)

Parameters

textureArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayDepthStencilView
textureArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayDepthStencilView

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView Properties
Texture1DArrayDepthStencilView Structure See Also Send Feedback

The Texture1DArrayDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV.FirstArraySlice)
Public property | MipSlice | The index of the first mipmap level to use. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV.MipSlice)

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..ArraySize Property
Texture1DArrayDepthStencilView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..FirstArraySlice Property
Texture1DArrayDepthStencilView Structure See Also Send Feedback
The index of the first texture to use in an array of textures.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayDepthStencilView..::..MipSlice Property
Texture1DArrayDepthStencilView Structure See Also Send Feedback
The index of the first mipmap level to use.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_DSV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresources from an array of 1D textures to use in a render-target view.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DArrayRenderTargetView
Visual Basic
Public Structure Texture1DArrayRenderTargetView
Visual C++
public value class Texture1DArrayRenderTargetView

See Also

Texture1DArrayRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Members
Texture1DArrayRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture1DArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV.FirstArraySlice)
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV.MipSlice)

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Methods
Texture1DArrayRenderTargetView Structure See Also Send Feedback

The Texture1DArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..Equals Method
Texture1DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..GetHashCode Method
Texture1DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Operators
Texture1DArrayRenderTargetView Structure See Also Send Feedback

The Texture1DArrayRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..Equality Operator
Texture1DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture1DArrayRenderTargetView textureArrayRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayRenderTargetView1 As Texture1DArrayRenderTargetView, _
    textureArrayRenderTargetView2 As Texture1DArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture1DArrayRenderTargetView textureArrayRenderTargetView2
)

Parameters

textureArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayRenderTargetView
textureArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayRenderTargetView

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..Inequality Operator
Texture1DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture1DArrayRenderTargetView textureArrayRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayRenderTargetView1 As Texture1DArrayRenderTargetView, _
    textureArrayRenderTargetView2 As Texture1DArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture1DArrayRenderTargetView textureArrayRenderTargetView2
)

Parameters

textureArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayRenderTargetView
textureArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayRenderTargetView

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView Properties
Texture1DArrayRenderTargetView Structure See Also Send Feedback

The Texture1DArrayRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV.FirstArraySlice)
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV.MipSlice)

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..ArraySize Property
Texture1DArrayRenderTargetView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..FirstArraySlice Property
Texture1DArrayRenderTargetView Structure See Also Send Feedback
The index of the first texture to use in an array of textures.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayRenderTargetView..::..MipSlice Property
Texture1DArrayRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use mip slice.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresources from an array of 1D textures to use in a shader-resource view.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DArrayShaderResourceView
Visual Basic
Public Structure Texture1DArrayShaderResourceView
Visual C++
public value class Texture1DArrayShaderResourceView

See Also

Texture1DArrayShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Members
Texture1DArrayShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture1DArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.FirstArraySlice)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.MostDetailedMip)

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Methods
Texture1DArrayShaderResourceView Structure See Also Send Feedback

The Texture1DArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..Equals Method
Texture1DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..GetHashCode Method
Texture1DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Operators
Texture1DArrayShaderResourceView Structure See Also Send Feedback

The Texture1DArrayShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..Equality Operator
Texture1DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture1DArrayShaderResourceView textureArrayShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayShaderResourceView1 As Texture1DArrayShaderResourceView, _
    textureArrayShaderResourceView2 As Texture1DArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture1DArrayShaderResourceView textureArrayShaderResourceView2
)

Parameters

textureArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayShaderResourceView
textureArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayShaderResourceView

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..Inequality Operator
Texture1DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture1DArrayShaderResourceView textureArrayShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayShaderResourceView1 As Texture1DArrayShaderResourceView, _
    textureArrayShaderResourceView2 As Texture1DArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture1DArrayShaderResourceView textureArrayShaderResourceView2
)

Parameters

textureArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayShaderResourceView
textureArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayShaderResourceView

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView Properties
Texture1DArrayShaderResourceView Structure See Also Send Feedback

The Texture1DArrayShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.FirstArraySlice)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.MostDetailedMip)

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..ArraySize Property
Texture1DArrayShaderResourceView Structure See Also Send Feedback
Number of textures in the array.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..FirstArraySlice Property
Texture1DArrayShaderResourceView Structure See Also Send Feedback
The index of the first texture to use in an array of textures.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..MipLevels Property
Texture1DArrayShaderResourceView Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayShaderResourceView..::..MostDetailedMip Property
Texture1DArrayShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayUnorderedAccessView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView Structure
Members See Also Send Feedback
Describes an array of unordered-access 1D texture resources.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DArrayUnorderedAccessView
Visual Basic
Public Structure Texture1DArrayUnorderedAccessView
Visual C++
public value class Texture1DArrayUnorderedAccessView

See Also

Texture1DArrayUnorderedAccessView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayUnorderedAccessView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView Members
Texture1DArrayUnorderedAccessView Structure Methods Operators Properties See Also Send Feedback

The Texture1DArrayUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | The number of slices in the array. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV.ArraySize)
Public property | FirstArraySlice | The zero-based index of the first array slice to be accessed. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV.FirstArraySlice)
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV.MipSlice)

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayUnorderedAccessView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView Methods
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback

The Texture1DArrayUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView..::..Equals Method
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView..::..GetHashCode Method
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayUnorderedAccessView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView Operators
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback

The Texture1DArrayUnorderedAccessView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView..::..Equality Operator
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DArrayUnorderedAccessView textureArrayUnorderedAccessView1,
    Texture1DArrayUnorderedAccessView textureArrayUnorderedAccessView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayUnorderedAccessView1 As Texture1DArrayUnorderedAccessView, _
    textureArrayUnorderedAccessView2 As Texture1DArrayUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DArrayUnorderedAccessView textureArrayUnorderedAccessView1,
    Texture1DArrayUnorderedAccessView textureArrayUnorderedAccessView2
)

Parameters

textureArrayUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayUnorderedAccessView
textureArrayUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayUnorderedAccessView

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView..::..Inequality Operator
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DArrayUnorderedAccessView textureArrayUnorderedAccessView1,
    Texture1DArrayUnorderedAccessView textureArrayUnorderedAccessView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayUnorderedAccessView1 As Texture1DArrayUnorderedAccessView, _
    textureArrayUnorderedAccessView2 As Texture1DArrayUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DArrayUnorderedAccessView textureArrayUnorderedAccessView1,
    Texture1DArrayUnorderedAccessView textureArrayUnorderedAccessView2
)

Parameters

textureArrayUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayUnorderedAccessView
textureArrayUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayUnorderedAccessView

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DArrayUnorderedAccessView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView Properties
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback

The Texture1DArrayUnorderedAccessView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | The number of slices in the array. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV.ArraySize)
Public property | FirstArraySlice | The zero-based index of the first array slice to be accessed. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV.FirstArraySlice)
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV.MipSlice)

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView..::..ArraySize Property
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback
The number of slices in the array.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView..::..FirstArraySlice Property
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback
The zero-based index of the first array slice to be accessed.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DArrayUnorderedAccessView..::..MipSlice Property
Texture1DArrayUnorderedAccessView Structure See Also Send Feedback
The mipmap slice index.

(Also see DirectX SDK: D3D11_TEX1D_ARRAY_UAV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresource from a 1D texture that is accessable to a depth-stencil view.

(Also see DirectX SDK: D3D11_TEX1D_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DDepthStencilView
Visual Basic
Public Structure Texture1DDepthStencilView
Visual C++
public value class Texture1DDepthStencilView

See Also

Texture1DDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Members
Texture1DDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture1DDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The index of the first mipmap level to use. (Also see DirectX SDK: D3D11_TEX1D_DSV.MipSlice)

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Methods
Texture1DDepthStencilView Structure See Also Send Feedback

The Texture1DDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..Equals Method
Texture1DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..GetHashCode Method
Texture1DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Operators
Texture1DDepthStencilView Structure See Also Send Feedback

The Texture1DDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..Equality Operator
Texture1DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DDepthStencilView textureDepthStencilView1,
    Texture1DDepthStencilView textureDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureDepthStencilView1 As Texture1DDepthStencilView, _
    textureDepthStencilView2 As Texture1DDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DDepthStencilView textureDepthStencilView1,
    Texture1DDepthStencilView textureDepthStencilView2
)

Parameters

textureDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDepthStencilView
textureDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDepthStencilView

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..Inequality Operator
Texture1DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DDepthStencilView textureDepthStencilView1,
    Texture1DDepthStencilView textureDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureDepthStencilView1 As Texture1DDepthStencilView, _
    textureDepthStencilView2 As Texture1DDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DDepthStencilView textureDepthStencilView1,
    Texture1DDepthStencilView textureDepthStencilView2
)

Parameters

textureDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDepthStencilView
textureDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDepthStencilView

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView Properties
Texture1DDepthStencilView Structure See Also Send Feedback

The Texture1DDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The index of the first mipmap level to use. (Also see DirectX SDK: D3D11_TEX1D_DSV.MipSlice)

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDepthStencilView..::..MipSlice Property
Texture1DDepthStencilView Structure See Also Send Feedback
The index of the first mipmap level to use.

(Also see DirectX SDK: D3D11_TEX1D_DSV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Structure
Members See Also Send Feedback
Describes a 1D texture.

(Also see DirectX SDK: D3D11_TEXTURE1D_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DDescription
Visual Basic
Public Structure Texture1DDescription
Visual C++
public value class Texture1DDescription

See Also

Texture1DDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Members
Texture1DDescription Structure Methods Operators Properties See Also Send Feedback

The Texture1DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.ArraySize)
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. For a 1D texture, the allowable values are: ShaderResource, RenderTarget and DepthStencil. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.CPUAccessFlags)
Public property | Format | Texture format (see Format). (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.Format)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.MiscFlags)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.Usage)
Public property | Width | Texture width (in texels). (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.Width)

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Methods
Texture1DDescription Structure See Also Send Feedback

The Texture1DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Equals Method
Texture1DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..GetHashCode Method
Texture1DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Operators
Texture1DDescription Structure See Also Send Feedback

The Texture1DDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Equality Operator
Texture1DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DDescription textureDescription1,
    Texture1DDescription textureDescription2
)
Visual Basic
Public Shared Operator = ( _
    textureDescription1 As Texture1DDescription, _
    textureDescription2 As Texture1DDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DDescription textureDescription1,
    Texture1DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDescription

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Inequality Operator
Texture1DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DDescription textureDescription1,
    Texture1DDescription textureDescription2
)
Visual Basic
Public Shared Operator <> ( _
    textureDescription1 As Texture1DDescription, _
    textureDescription2 As Texture1DDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DDescription textureDescription1,
    Texture1DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DDescription

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription Properties
Texture1DDescription Structure See Also Send Feedback

The Texture1DDescription type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.ArraySize)
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. For a 1D texture, the allowable values are: ShaderResource, RenderTarget and DepthStencil. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.CPUAccessFlags)
Public property | Format | Texture format (see Format). (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.Format)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.MiscFlags)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.Usage)
Public property | Width | Texture width (in texels). (Also see DirectX SDK: D3D11_TEXTURE1D_DESC.Width)

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..ArraySize Property
Texture1DDescription Structure See Also Send Feedback
Number of textures in the array.

(Also see DirectX SDK: D3D11_TEXTURE1D_DESC.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BindingOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..BindingOptions Property
Texture1DDescription Structure See Also Send Feedback
Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. For a 1D texture, the allowable values are: ShaderResource, RenderTarget and DepthStencil.

(Also see DirectX SDK: D3D11_TEXTURE1D_DESC.BindFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BindingOptions BindingOptions { get; set; }
Visual Basic
Public Property BindingOptions As BindingOptions
    Get
    Set
Visual C++
public:
property BindingOptions BindingOptions {
    BindingOptions get ();
    void set (BindingOptions value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BindingOptions


CpuAccessOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..CpuAccessOptions Property
Texture1DDescription Structure See Also Send Feedback
Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D11_TEXTURE1D_DESC.CPUAccessFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CpuAccessOptions CpuAccessOptions { get; set; }
Visual Basic
Public Property CpuAccessOptions As CpuAccessOptions
    Get
    Set
Visual C++
public:
property CpuAccessOptions CpuAccessOptions {
    CpuAccessOptions get ();
    void set (CpuAccessOptions value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Texture1DDescription..::..CpuAccessOptions


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Format Property
Texture1DDescription Structure See Also Send Feedback
Texture format (see Format).

(Also see DirectX SDK: D3D11_TEXTURE1D_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Texture1DDescription..::..Format


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..MipLevels Property
Texture1DDescription Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. Use 1 for a multisampled texture; or 0 to generate a full set of subtextures.

(Also see DirectX SDK: D3D11_TEXTURE1D_DESC.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MiscellaneousResourceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..MiscellaneousResourceOptions Property
Texture1DDescription Structure See Also Send Feedback
Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D11_TEXTURE1D_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousResourceOptions MiscellaneousResourceOptions { get; set; }
Visual Basic
Public Property MiscellaneousResourceOptions As MiscellaneousResourceOptions
    Get
    Set
Visual C++
public:
property MiscellaneousResourceOptions MiscellaneousResourceOptions {
    MiscellaneousResourceOptions get ();
    void set (MiscellaneousResourceOptions value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Texture1DDescription..::..MiscellaneousResourceOptions


Usage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Usage Property
Texture1DDescription Structure See Also Send Feedback
Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values.

(Also see DirectX SDK: D3D11_TEXTURE1D_DESC.Usage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Usage Usage { get; set; }
Visual Basic
Public Property Usage As Usage
    Get
    Set
Visual C++
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DDescription..::..Width Property
Texture1DDescription Structure See Also Send Feedback
Texture width (in texels).

(Also see DirectX SDK: D3D11_TEXTURE1D_DESC.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource from a 1D texture to use in a render-target view.

(Also see DirectX SDK: D3D11_TEX1D_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DRenderTargetView
Visual Basic
Public Structure Texture1DRenderTargetView
Visual C++
public value class Texture1DRenderTargetView

See Also

Texture1DRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Members
Texture1DRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture1DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX1D_RTV.MipSlice)

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Methods
Texture1DRenderTargetView Structure See Also Send Feedback

The Texture1DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..Equals Method
Texture1DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..GetHashCode Method
Texture1DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Operators
Texture1DRenderTargetView Structure See Also Send Feedback

The Texture1DRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..Equality Operator
Texture1DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DRenderTargetView textureRenderTargetView1,
    Texture1DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureRenderTargetView1 As Texture1DRenderTargetView, _
    textureRenderTargetView2 As Texture1DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DRenderTargetView textureRenderTargetView1,
    Texture1DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DRenderTargetView

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..Inequality Operator
Texture1DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DRenderTargetView textureRenderTargetView1,
    Texture1DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureRenderTargetView1 As Texture1DRenderTargetView, _
    textureRenderTargetView2 As Texture1DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DRenderTargetView textureRenderTargetView1,
    Texture1DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DRenderTargetView

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView Properties
Texture1DRenderTargetView Structure See Also Send Feedback

The Texture1DRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX1D_RTV.MipSlice)

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DRenderTargetView..::..MipSlice Property
Texture1DRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use mip slice.

(Also see DirectX SDK: D3D11_TEX1D_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource from a 1D texture to use in a shader-resource view.

(Also see DirectX SDK: D3D11_TEX1D_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DShaderResourceView
Visual Basic
Public Structure Texture1DShaderResourceView
Visual C++
public value class Texture1DShaderResourceView

See Also

Texture1DShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Members
Texture1DShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture1DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX1D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX1D_SRV.MostDetailedMip)

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Methods
Texture1DShaderResourceView Structure See Also Send Feedback

The Texture1DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..Equals Method
Texture1DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..GetHashCode Method
Texture1DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Operators
Texture1DShaderResourceView Structure See Also Send Feedback

The Texture1DShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..Equality Operator
Texture1DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DShaderResourceView textureShaderResourceView1,
    Texture1DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureShaderResourceView1 As Texture1DShaderResourceView, _
    textureShaderResourceView2 As Texture1DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DShaderResourceView textureShaderResourceView1,
    Texture1DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DShaderResourceView

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..Inequality Operator
Texture1DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DShaderResourceView textureShaderResourceView1,
    Texture1DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureShaderResourceView1 As Texture1DShaderResourceView, _
    textureShaderResourceView2 As Texture1DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DShaderResourceView textureShaderResourceView1,
    Texture1DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DShaderResourceView

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView Properties
Texture1DShaderResourceView Structure See Also Send Feedback

The Texture1DShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX1D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX1D_SRV.MostDetailedMip)

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..MipLevels Property
Texture1DShaderResourceView Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView.

(Also see DirectX SDK: D3D11_TEX1D_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DShaderResourceView..::..MostDetailedMip Property
Texture1DShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D11_TEX1D_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DUnorderedAccessView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView Structure
Members See Also Send Feedback
Describes a unordered-access 1D texture resource.

(Also see DirectX SDK: D3D11_TEX1D_UAV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture1DUnorderedAccessView
Visual Basic
Public Structure Texture1DUnorderedAccessView
Visual C++
public value class Texture1DUnorderedAccessView

See Also

Texture1DUnorderedAccessView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DUnorderedAccessView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView Members
Texture1DUnorderedAccessView Structure Methods Operators Properties See Also Send Feedback

The Texture1DUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX1D_UAV.MipSlice)

See Also

Texture1DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DUnorderedAccessView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView Methods
Texture1DUnorderedAccessView Structure See Also Send Feedback

The Texture1DUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture1DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView..::..Equals Method
Texture1DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture1DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView..::..GetHashCode Method
Texture1DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture1DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DUnorderedAccessView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView Operators
Texture1DUnorderedAccessView Structure See Also Send Feedback

The Texture1DUnorderedAccessView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture1DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView..::..Equality Operator
Texture1DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture1DUnorderedAccessView textureUnorderedAccessView1,
    Texture1DUnorderedAccessView textureUnorderedAccessView2
)
Visual Basic
Public Shared Operator = ( _
    textureUnorderedAccessView1 As Texture1DUnorderedAccessView, _
    textureUnorderedAccessView2 As Texture1DUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture1DUnorderedAccessView textureUnorderedAccessView1,
    Texture1DUnorderedAccessView textureUnorderedAccessView2
)

Parameters

textureUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DUnorderedAccessView
textureUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DUnorderedAccessView

See Also

Texture1DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView..::..Inequality Operator
Texture1DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture1DUnorderedAccessView textureUnorderedAccessView1,
    Texture1DUnorderedAccessView textureUnorderedAccessView2
)
Visual Basic
Public Shared Operator <> ( _
    textureUnorderedAccessView1 As Texture1DUnorderedAccessView, _
    textureUnorderedAccessView2 As Texture1DUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture1DUnorderedAccessView textureUnorderedAccessView1,
    Texture1DUnorderedAccessView textureUnorderedAccessView2
)

Parameters

textureUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DUnorderedAccessView
textureUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DUnorderedAccessView

See Also

Texture1DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture1DUnorderedAccessView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView Properties
Texture1DUnorderedAccessView Structure See Also Send Feedback

The Texture1DUnorderedAccessView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX1D_UAV.MipSlice)

See Also

Texture1DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture1DUnorderedAccessView..::..MipSlice Property
Texture1DUnorderedAccessView Structure See Also Send Feedback
The mipmap slice index.

(Also see DirectX SDK: D3D11_TEX1D_UAV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture1DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2D Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D Class
Members See Also Send Feedback
A 2D texture interface manages texel data, which is structured memory.

(Also see DirectX SDK: ID3D11Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Texture2D : D3DResource
Visual Basic
Public Class Texture2D _
    Inherits D3DResource
Visual C++
public ref class Texture2D : public D3DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2D

See Also

Texture2D Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2D Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D Members
Texture2D Class Properties See Also Send Feedback

The Texture2D type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D11Texture2D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics.Surface1. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType) (Inherited from D3DResource.)

See Also

Texture2D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2D Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D Properties
Texture2D Class See Also Send Feedback

The Texture2D type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D11Texture2D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics.Surface1. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType) (Inherited from D3DResource.)

See Also

Texture2D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2D..::..Description Property
Texture2D Class See Also Send Feedback
Get the properties of the texture resource.

(Also see DirectX SDK: ID3D11Texture2D::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As Texture2DDescription
    Get
Visual C++
public:
property Texture2DDescription Description {
    Texture2DDescription get ();
}

See Also

Texture2D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresources from an array 2D textures that are accessable to a depth-stencil view.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DArrayDepthStencilView
Visual Basic
Public Structure Texture2DArrayDepthStencilView
Visual C++
public value class Texture2DArrayDepthStencilView

See Also

Texture2DArrayDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Members
Texture2DArrayDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture2DArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV.FirstArraySlice)
Public property | MipSlice | The index of the first mipmap level to use. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV.MipSlice)

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Methods
Texture2DArrayDepthStencilView Structure See Also Send Feedback

The Texture2DArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..Equals Method
Texture2DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..GetHashCode Method
Texture2DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Operators
Texture2DArrayDepthStencilView Structure See Also Send Feedback

The Texture2DArrayDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..Equality Operator
Texture2DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture2DArrayDepthStencilView textureArrayDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayDepthStencilView1 As Texture2DArrayDepthStencilView, _
    textureArrayDepthStencilView2 As Texture2DArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture2DArrayDepthStencilView textureArrayDepthStencilView2
)

Parameters

textureArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayDepthStencilView
textureArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayDepthStencilView

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..Inequality Operator
Texture2DArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture2DArrayDepthStencilView textureArrayDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayDepthStencilView1 As Texture2DArrayDepthStencilView, _
    textureArrayDepthStencilView2 As Texture2DArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DArrayDepthStencilView textureArrayDepthStencilView1,
    Texture2DArrayDepthStencilView textureArrayDepthStencilView2
)

Parameters

textureArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayDepthStencilView
textureArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayDepthStencilView

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView Properties
Texture2DArrayDepthStencilView Structure See Also Send Feedback

The Texture2DArrayDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV.FirstArraySlice)
Public property | MipSlice | The index of the first mipmap level to use. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV.MipSlice)

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..ArraySize Property
Texture2DArrayDepthStencilView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..FirstArraySlice Property
Texture2DArrayDepthStencilView Structure See Also Send Feedback
The index of the first texture to use in an array of textures.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayDepthStencilView..::..MipSlice Property
Texture2DArrayDepthStencilView Structure See Also Send Feedback
The index of the first mipmap level to use.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_DSV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresources from an array of 2D textures to use in a render-target view.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DArrayRenderTargetView
Visual Basic
Public Structure Texture2DArrayRenderTargetView
Visual C++
public value class Texture2DArrayRenderTargetView

See Also

Texture2DArrayRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Members
Texture2DArrayRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture2DArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array to use in the render target view, starting from FirstArraySlice. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV.FirstArraySlice)
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV.MipSlice)

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Methods
Texture2DArrayRenderTargetView Structure See Also Send Feedback

The Texture2DArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..Equals Method
Texture2DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..GetHashCode Method
Texture2DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Operators
Texture2DArrayRenderTargetView Structure See Also Send Feedback

The Texture2DArrayRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..Equality Operator
Texture2DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture2DArrayRenderTargetView textureArrayRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayRenderTargetView1 As Texture2DArrayRenderTargetView, _
    textureArrayRenderTargetView2 As Texture2DArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture2DArrayRenderTargetView textureArrayRenderTargetView2
)

Parameters

textureArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayRenderTargetView
textureArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayRenderTargetView

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..Inequality Operator
Texture2DArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture2DArrayRenderTargetView textureArrayRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayRenderTargetView1 As Texture2DArrayRenderTargetView, _
    textureArrayRenderTargetView2 As Texture2DArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DArrayRenderTargetView textureArrayRenderTargetView1,
    Texture2DArrayRenderTargetView textureArrayRenderTargetView2
)

Parameters

textureArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayRenderTargetView
textureArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayRenderTargetView

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView Properties
Texture2DArrayRenderTargetView Structure See Also Send Feedback

The Texture2DArrayRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array to use in the render target view, starting from FirstArraySlice. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV.FirstArraySlice)
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV.MipSlice)

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..ArraySize Property
Texture2DArrayRenderTargetView Structure See Also Send Feedback
Number of textures in the array to use in the render target view, starting from FirstArraySlice.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..FirstArraySlice Property
Texture2DArrayRenderTargetView Structure See Also Send Feedback
The index of the first texture to use in an array of textures.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayRenderTargetView..::..MipSlice Property
Texture2DArrayRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use mip slice.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresources from an array of 2D textures to use in a shader-resource view.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DArrayShaderResourceView
Visual Basic
Public Structure Texture2DArrayShaderResourceView
Visual C++
public value class Texture2DArrayShaderResourceView

See Also

Texture2DArrayShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Members
Texture2DArrayShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture2DArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.FirstArraySlice)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.MostDetailedMip)

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Methods
Texture2DArrayShaderResourceView Structure See Also Send Feedback

The Texture2DArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..Equals Method
Texture2DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..GetHashCode Method
Texture2DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Operators
Texture2DArrayShaderResourceView Structure See Also Send Feedback

The Texture2DArrayShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..Equality Operator
Texture2DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture2DArrayShaderResourceView textureArrayShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayShaderResourceView1 As Texture2DArrayShaderResourceView, _
    textureArrayShaderResourceView2 As Texture2DArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture2DArrayShaderResourceView textureArrayShaderResourceView2
)

Parameters

textureArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayShaderResourceView
textureArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayShaderResourceView

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..Inequality Operator
Texture2DArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture2DArrayShaderResourceView textureArrayShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayShaderResourceView1 As Texture2DArrayShaderResourceView, _
    textureArrayShaderResourceView2 As Texture2DArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DArrayShaderResourceView textureArrayShaderResourceView1,
    Texture2DArrayShaderResourceView textureArrayShaderResourceView2
)

Parameters

textureArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayShaderResourceView
textureArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayShaderResourceView

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView Properties
Texture2DArrayShaderResourceView Structure See Also Send Feedback

The Texture2DArrayShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the array. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.FirstArraySlice)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.MostDetailedMip)

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..ArraySize Property
Texture2DArrayShaderResourceView Structure See Also Send Feedback
Number of textures in the array.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..FirstArraySlice Property
Texture2DArrayShaderResourceView Structure See Also Send Feedback
The index of the first texture to use in an array of textures.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..MipLevels Property
Texture2DArrayShaderResourceView Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayShaderResourceView..::..MostDetailedMip Property
Texture2DArrayShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayUnorderedAccessView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView Structure
Members See Also Send Feedback
Describes an array of unordered-access 2D texture resources.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DArrayUnorderedAccessView
Visual Basic
Public Structure Texture2DArrayUnorderedAccessView
Visual C++
public value class Texture2DArrayUnorderedAccessView

See Also

Texture2DArrayUnorderedAccessView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayUnorderedAccessView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView Members
Texture2DArrayUnorderedAccessView Structure Methods Operators Properties See Also Send Feedback

The Texture2DArrayUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | The number of slices in the array. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV.ArraySize)
Public property | FirstArraySlice | The zero-based index of the first array slice to be accessed. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV.FirstArraySlice)
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV.MipSlice)

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayUnorderedAccessView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView Methods
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback

The Texture2DArrayUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView..::..Equals Method
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView..::..GetHashCode Method
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayUnorderedAccessView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView Operators
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback

The Texture2DArrayUnorderedAccessView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView..::..Equality Operator
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DArrayUnorderedAccessView textureArrayUnorderedAccessView1,
    Texture2DArrayUnorderedAccessView textureArrayUnorderedAccessView2
)
Visual Basic
Public Shared Operator = ( _
    textureArrayUnorderedAccessView1 As Texture2DArrayUnorderedAccessView, _
    textureArrayUnorderedAccessView2 As Texture2DArrayUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DArrayUnorderedAccessView textureArrayUnorderedAccessView1,
    Texture2DArrayUnorderedAccessView textureArrayUnorderedAccessView2
)

Parameters

textureArrayUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayUnorderedAccessView
textureArrayUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayUnorderedAccessView

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView..::..Inequality Operator
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DArrayUnorderedAccessView textureArrayUnorderedAccessView1,
    Texture2DArrayUnorderedAccessView textureArrayUnorderedAccessView2
)
Visual Basic
Public Shared Operator <> ( _
    textureArrayUnorderedAccessView1 As Texture2DArrayUnorderedAccessView, _
    textureArrayUnorderedAccessView2 As Texture2DArrayUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DArrayUnorderedAccessView textureArrayUnorderedAccessView1,
    Texture2DArrayUnorderedAccessView textureArrayUnorderedAccessView2
)

Parameters

textureArrayUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayUnorderedAccessView
textureArrayUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayUnorderedAccessView

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DArrayUnorderedAccessView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView Properties
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback

The Texture2DArrayUnorderedAccessView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | The number of slices in the array. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV.ArraySize)
Public property | FirstArraySlice | The zero-based index of the first array slice to be accessed. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV.FirstArraySlice)
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV.MipSlice)

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView..::..ArraySize Property
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback
The number of slices in the array.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView..::..FirstArraySlice Property
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback
The zero-based index of the first array slice to be accessed.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DArrayUnorderedAccessView..::..MipSlice Property
Texture2DArrayUnorderedAccessView Structure See Also Send Feedback
The mipmap slice index.

(Also see DirectX SDK: D3D11_TEX2D_ARRAY_UAV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DArrayUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresource from a 2D texture that is accessable to a depth-stencil view.

(Also see DirectX SDK: D3D11_TEX2D_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DDepthStencilView
Visual Basic
Public Structure Texture2DDepthStencilView
Visual C++
public value class Texture2DDepthStencilView

See Also

Texture2DDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Members
Texture2DDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture2DDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The index of the first mipmap level to use. (Also see DirectX SDK: D3D11_TEX2D_DSV.MipSlice)

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Methods
Texture2DDepthStencilView Structure See Also Send Feedback

The Texture2DDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..Equals Method
Texture2DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..GetHashCode Method
Texture2DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Operators
Texture2DDepthStencilView Structure See Also Send Feedback

The Texture2DDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..Equality Operator
Texture2DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DDepthStencilView textureDepthStencilView1,
    Texture2DDepthStencilView textureDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureDepthStencilView1 As Texture2DDepthStencilView, _
    textureDepthStencilView2 As Texture2DDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DDepthStencilView textureDepthStencilView1,
    Texture2DDepthStencilView textureDepthStencilView2
)

Parameters

textureDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDepthStencilView
textureDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDepthStencilView

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..Inequality Operator
Texture2DDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DDepthStencilView textureDepthStencilView1,
    Texture2DDepthStencilView textureDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureDepthStencilView1 As Texture2DDepthStencilView, _
    textureDepthStencilView2 As Texture2DDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DDepthStencilView textureDepthStencilView1,
    Texture2DDepthStencilView textureDepthStencilView2
)

Parameters

textureDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDepthStencilView
textureDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDepthStencilView

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView Properties
Texture2DDepthStencilView Structure See Also Send Feedback

The Texture2DDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The index of the first mipmap level to use. (Also see DirectX SDK: D3D11_TEX2D_DSV.MipSlice)

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDepthStencilView..::..MipSlice Property
Texture2DDepthStencilView Structure See Also Send Feedback
The index of the first mipmap level to use.

(Also see DirectX SDK: D3D11_TEX2D_DSV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Structure
Members See Also Send Feedback
Describes a 2D texture.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DDescription
Visual Basic
Public Structure Texture2DDescription
Visual C++
public value class Texture2DDescription

See Also

Texture2DDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Members
Texture2DDescription Structure Methods Operators Properties See Also Send Feedback

The Texture2DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the texture array. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.ArraySize)
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.CPUAccessFlags)
Public property | Format | Texture format (see Format). (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Format)
Public property | Height | Texture height (in texels). See Remarks. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Height)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.MiscFlags)
Public property | SampleDescription | Structure that specifies multisampling parameters for the texture. See SampleDescription. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.SampleDesc)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Usage)
Public property | Width | Texture width (in texels). See Remarks. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Width)

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Methods
Texture2DDescription Structure See Also Send Feedback

The Texture2DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Equals Method
Texture2DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..GetHashCode Method
Texture2DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Operators
Texture2DDescription Structure See Also Send Feedback

The Texture2DDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Equality Operator
Texture2DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DDescription textureDescription1,
    Texture2DDescription textureDescription2
)
Visual Basic
Public Shared Operator = ( _
    textureDescription1 As Texture2DDescription, _
    textureDescription2 As Texture2DDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DDescription textureDescription1,
    Texture2DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDescription

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Inequality Operator
Texture2DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DDescription textureDescription1,
    Texture2DDescription textureDescription2
)
Visual Basic
Public Shared Operator <> ( _
    textureDescription1 As Texture2DDescription, _
    textureDescription2 As Texture2DDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DDescription textureDescription1,
    Texture2DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DDescription

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription Properties
Texture2DDescription Structure See Also Send Feedback

The Texture2DDescription type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures in the texture array. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.ArraySize)
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.CPUAccessFlags)
Public property | Format | Texture format (see Format). (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Format)
Public property | Height | Texture height (in texels). See Remarks. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Height)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.MiscFlags)
Public property | SampleDescription | Structure that specifies multisampling parameters for the texture. See SampleDescription. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.SampleDesc)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Usage)
Public property | Width | Texture width (in texels). See Remarks. (Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Width)

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..ArraySize Property
Texture2DDescription Structure See Also Send Feedback
Number of textures in the texture array.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BindingOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..BindingOptions Property
Texture2DDescription Structure See Also Send Feedback
Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.BindFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BindingOptions BindingOptions { get; set; }
Visual Basic
Public Property BindingOptions As BindingOptions
    Get
    Set
Visual C++
public:
property BindingOptions BindingOptions {
    BindingOptions get ();
    void set (BindingOptions value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BindingOptions


CpuAccessOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..CpuAccessOptions Property
Texture2DDescription Structure See Also Send Feedback
Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.CPUAccessFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CpuAccessOptions CpuAccessOptions { get; set; }
Visual Basic
Public Property CpuAccessOptions As CpuAccessOptions
    Get
    Set
Visual C++
public:
property CpuAccessOptions CpuAccessOptions {
    CpuAccessOptions get ();
    void set (CpuAccessOptions value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Texture2DDescription..::..CpuAccessOptions


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Format Property
Texture2DDescription Structure See Also Send Feedback
Texture format (see Format).

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Texture2DDescription..::..Format


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Height Property
Texture2DDescription Structure See Also Send Feedback
Texture height (in texels). See Remarks.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Height)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..MipLevels Property
Texture2DDescription Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. Use 1 for a multisampled texture; or 0 to generate a full set of subtextures.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MiscellaneousResourceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..MiscellaneousResourceOptions Property
Texture2DDescription Structure See Also Send Feedback
Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousResourceOptions MiscellaneousResourceOptions { get; set; }
Visual Basic
Public Property MiscellaneousResourceOptions As MiscellaneousResourceOptions
    Get
    Set
Visual C++
public:
property MiscellaneousResourceOptions MiscellaneousResourceOptions {
    MiscellaneousResourceOptions get ();
    void set (MiscellaneousResourceOptions value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Texture2DDescription..::..MiscellaneousResourceOptions


SampleDescription Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..SampleDescription Property
Texture2DDescription Structure See Also Send Feedback
Structure that specifies multisampling parameters for the texture. See SampleDescription.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.SampleDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SampleDescription SampleDescription { get; set; }
Visual Basic
Public Property SampleDescription As SampleDescription
    Get
    Set
Visual C++
public:
property SampleDescription SampleDescription {
    SampleDescription get ();
    void set (SampleDescription value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Usage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Usage Property
Texture2DDescription Structure See Also Send Feedback
Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Usage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Usage Usage { get; set; }
Visual Basic
Public Property Usage As Usage
    Get
    Set
Visual C++
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DDescription..::..Width Property
Texture2DDescription Structure See Also Send Feedback
Texture width (in texels). See Remarks.

(Also see DirectX SDK: D3D11_TEXTURE2D_DESC.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresources from an array of multisampled 2D textures for a depth-stencil view.

(Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleArrayDepthStencilView
Visual Basic
Public Structure Texture2DMultisampleArrayDepthStencilView
Visual C++
public value class Texture2DMultisampleArrayDepthStencilView

See Also

Texture2DMultisampleArrayDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Members
Texture2DMultisampleArrayDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_DSV.FirstArraySlice)

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Methods
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleArrayDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..Equals Method
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..GetHashCode Method
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Operators
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleArrayDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..Equality Operator
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView1,
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleArrayDepthStencilView1 As Texture2DMultisampleArrayDepthStencilView, _
    textureMultisampleArrayDepthStencilView2 As Texture2DMultisampleArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView1,
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView2
)

Parameters

textureMultisampleArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayDepthStencilView
textureMultisampleArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayDepthStencilView

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..Inequality Operator
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView1,
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleArrayDepthStencilView1 As Texture2DMultisampleArrayDepthStencilView, _
    textureMultisampleArrayDepthStencilView2 As Texture2DMultisampleArrayDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView1,
    Texture2DMultisampleArrayDepthStencilView textureMultisampleArrayDepthStencilView2
)

Parameters

textureMultisampleArrayDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayDepthStencilView
textureMultisampleArrayDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayDepthStencilView

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView Properties
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleArrayDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_DSV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_DSV.FirstArraySlice)

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..ArraySize Property
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_DSV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayDepthStencilView..::..FirstArraySlice Property
Texture2DMultisampleArrayDepthStencilView Structure See Also Send Feedback
The index of the first texture to use in an array of textures.

(Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_DSV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresources from a an array of multisampled 2D textures to use in a render-target view.

(Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleArrayRenderTargetView
Visual Basic
Public Structure Texture2DMultisampleArrayRenderTargetView
Visual C++
public value class Texture2DMultisampleArrayRenderTargetView

See Also

Texture2DMultisampleArrayRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Members
Texture2DMultisampleArrayRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_RTV.FirstArraySlice)

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Methods
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleArrayRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..Equals Method
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..GetHashCode Method
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Operators
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleArrayRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..Equality Operator
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView1,
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleArrayRenderTargetView1 As Texture2DMultisampleArrayRenderTargetView, _
    textureMultisampleArrayRenderTargetView2 As Texture2DMultisampleArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView1,
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView2
)

Parameters

textureMultisampleArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayRenderTargetView
textureMultisampleArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayRenderTargetView

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..Inequality Operator
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView1,
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleArrayRenderTargetView1 As Texture2DMultisampleArrayRenderTargetView, _
    textureMultisampleArrayRenderTargetView2 As Texture2DMultisampleArrayRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView1,
    Texture2DMultisampleArrayRenderTargetView textureMultisampleArrayRenderTargetView2
)

Parameters

textureMultisampleArrayRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayRenderTargetView
textureMultisampleArrayRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayRenderTargetView

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView Properties
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleArrayRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_RTV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_RTV.FirstArraySlice)

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..ArraySize Property
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_RTV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayRenderTargetView..::..FirstArraySlice Property
Texture2DMultisampleArrayRenderTargetView Structure See Also Send Feedback
The index of the first texture to use in an array of textures.

(Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_RTV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresources from an array of multisampled 2D textures to use in a shader-resource view.

(Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleArrayShaderResourceView
Visual Basic
Public Structure Texture2DMultisampleArrayShaderResourceView
Visual C++
public value class Texture2DMultisampleArrayShaderResourceView

See Also

Texture2DMultisampleArrayShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Members
Texture2DMultisampleArrayShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_SRV.FirstArraySlice)

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Methods
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..Equals Method
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..GetHashCode Method
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Operators
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleArrayShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..Equality Operator
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView1,
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleArrayShaderResourceView1 As Texture2DMultisampleArrayShaderResourceView, _
    textureMultisampleArrayShaderResourceView2 As Texture2DMultisampleArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView1,
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView2
)

Parameters

textureMultisampleArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayShaderResourceView
textureMultisampleArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayShaderResourceView

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..Inequality Operator
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView1,
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleArrayShaderResourceView1 As Texture2DMultisampleArrayShaderResourceView, _
    textureMultisampleArrayShaderResourceView2 As Texture2DMultisampleArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView1,
    Texture2DMultisampleArrayShaderResourceView textureMultisampleArrayShaderResourceView2
)

Parameters

textureMultisampleArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayShaderResourceView
textureMultisampleArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleArrayShaderResourceView

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleArrayShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView Properties
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleArrayShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | ArraySize | Number of textures to use. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_SRV.ArraySize)
Public property | FirstArraySlice | The index of the first texture to use in an array of textures. (Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_SRV.FirstArraySlice)

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


ArraySize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..ArraySize Property
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback
Number of textures to use.

(Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_SRV.ArraySize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint ArraySize { get; set; }
Visual Basic
Public Property ArraySize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int ArraySize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstArraySlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleArrayShaderResourceView..::..FirstArraySlice Property
Texture2DMultisampleArrayShaderResourceView Structure See Also Send Feedback
The index of the first texture to use in an array of textures.

(Also see DirectX SDK: D3D11_TEX2DMS_ARRAY_SRV.FirstArraySlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstArraySlice { get; set; }
Visual Basic
Public Property FirstArraySlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstArraySlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleDepthStencilView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Structure
Members See Also Send Feedback
Specifies the subresource from a multisampled 2D texture that is accessable to a depth-stencil view.

(Also see DirectX SDK: D3D11_TEX2DMS_DSV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleDepthStencilView
Visual Basic
Public Structure Texture2DMultisampleDepthStencilView
Visual C++
public value class Texture2DMultisampleDepthStencilView

See Also

Texture2DMultisampleDepthStencilView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleDepthStencilView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Members
Texture2DMultisampleDepthStencilView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | UnusedField | Unused. (Also see DirectX SDK: D3D11_TEX2DMS_DSV.UnusedField_NothingToDefine)

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleDepthStencilView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Methods
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleDepthStencilView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..Equals Method
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..GetHashCode Method
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleDepthStencilView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Operators
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleDepthStencilView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..Equality Operator
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView1,
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleDepthStencilView1 As Texture2DMultisampleDepthStencilView, _
    textureMultisampleDepthStencilView2 As Texture2DMultisampleDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView1,
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView2
)

Parameters

textureMultisampleDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleDepthStencilView
textureMultisampleDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleDepthStencilView

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..Inequality Operator
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView1,
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleDepthStencilView1 As Texture2DMultisampleDepthStencilView, _
    textureMultisampleDepthStencilView2 As Texture2DMultisampleDepthStencilView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView1,
    Texture2DMultisampleDepthStencilView textureMultisampleDepthStencilView2
)

Parameters

textureMultisampleDepthStencilView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleDepthStencilView
textureMultisampleDepthStencilView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleDepthStencilView

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleDepthStencilView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView Properties
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback

The Texture2DMultisampleDepthStencilView type exposes the following members.

Properties

 | Name | Description
Public property | UnusedField | Unused. (Also see DirectX SDK: D3D11_TEX2DMS_DSV.UnusedField_NothingToDefine)

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnusedField Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleDepthStencilView..::..UnusedField Property
Texture2DMultisampleDepthStencilView Structure See Also Send Feedback
Unused.

(Also see DirectX SDK: D3D11_TEX2DMS_DSV.UnusedField_NothingToDefine)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint UnusedField { get; set; }
Visual Basic
Public Property UnusedField As UInteger
    Get
    Set
Visual C++
public:
property unsigned int UnusedField {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleDepthStencilView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource from a multisampled 2D texture to use in a render-target view.

(Also see DirectX SDK: D3D11_TEX2DMS_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleRenderTargetView
Visual Basic
Public Structure Texture2DMultisampleRenderTargetView
Visual C++
public value class Texture2DMultisampleRenderTargetView

See Also

Texture2DMultisampleRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Members
Texture2DMultisampleRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | UnusedField | Integer of any value. (Also see DirectX SDK: D3D11_TEX2DMS_RTV.UnusedField_NothingToDefine)

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Methods
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..Equals Method
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..GetHashCode Method
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Operators
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..Equality Operator
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView1,
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleRenderTargetView1 As Texture2DMultisampleRenderTargetView, _
    textureMultisampleRenderTargetView2 As Texture2DMultisampleRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView1,
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView2
)

Parameters

textureMultisampleRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleRenderTargetView
textureMultisampleRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleRenderTargetView

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..Inequality Operator
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView1,
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleRenderTargetView1 As Texture2DMultisampleRenderTargetView, _
    textureMultisampleRenderTargetView2 As Texture2DMultisampleRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView1,
    Texture2DMultisampleRenderTargetView textureMultisampleRenderTargetView2
)

Parameters

textureMultisampleRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleRenderTargetView
textureMultisampleRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleRenderTargetView

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView Properties
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback

The Texture2DMultisampleRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | UnusedField | Integer of any value. (Also see DirectX SDK: D3D11_TEX2DMS_RTV.UnusedField_NothingToDefine)

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnusedField Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleRenderTargetView..::..UnusedField Property
Texture2DMultisampleRenderTargetView Structure See Also Send Feedback
Integer of any value.

(Also see DirectX SDK: D3D11_TEX2DMS_RTV.UnusedField_NothingToDefine)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint UnusedField { get; set; }
Visual Basic
Public Property UnusedField As UInteger
    Get
    Set
Visual C++
public:
property unsigned int UnusedField {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresources from a multisampled 2D texture to use in a shader-resource view.

(Also see DirectX SDK: D3D11_TEX2DMS_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DMultisampleShaderResourceView
Visual Basic
Public Structure Texture2DMultisampleShaderResourceView
Visual C++
public value class Texture2DMultisampleShaderResourceView

See Also

Texture2DMultisampleShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Members
Texture2DMultisampleShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture2DMultisampleShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | UnusedField | Integer of any value. (Also see DirectX SDK: D3D11_TEX2DMS_SRV.UnusedField_NothingToDefine)

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Methods
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..Equals Method
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..GetHashCode Method
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Operators
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..Equality Operator
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView1,
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureMultisampleShaderResourceView1 As Texture2DMultisampleShaderResourceView, _
    textureMultisampleShaderResourceView2 As Texture2DMultisampleShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView1,
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView2
)

Parameters

textureMultisampleShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleShaderResourceView
textureMultisampleShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleShaderResourceView

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..Inequality Operator
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView1,
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureMultisampleShaderResourceView1 As Texture2DMultisampleShaderResourceView, _
    textureMultisampleShaderResourceView2 As Texture2DMultisampleShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView1,
    Texture2DMultisampleShaderResourceView textureMultisampleShaderResourceView2
)

Parameters

textureMultisampleShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleShaderResourceView
textureMultisampleShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DMultisampleShaderResourceView

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DMultisampleShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView Properties
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback

The Texture2DMultisampleShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | UnusedField | Integer of any value. (Also see DirectX SDK: D3D11_TEX2DMS_SRV.UnusedField_NothingToDefine)

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnusedField Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DMultisampleShaderResourceView..::..UnusedField Property
Texture2DMultisampleShaderResourceView Structure See Also Send Feedback
Integer of any value.

(Also see DirectX SDK: D3D11_TEX2DMS_SRV.UnusedField_NothingToDefine)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint UnusedField { get; set; }
Visual Basic
Public Property UnusedField As UInteger
    Get
    Set
Visual C++
public:
property unsigned int UnusedField {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DMultisampleShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresource from a 2D texture to use in a render-target view.

(Also see DirectX SDK: D3D11_TEX2D_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DRenderTargetView
Visual Basic
Public Structure Texture2DRenderTargetView
Visual C++
public value class Texture2DRenderTargetView

See Also

Texture2DRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Members
Texture2DRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture2DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX2D_RTV.MipSlice)

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Methods
Texture2DRenderTargetView Structure See Also Send Feedback

The Texture2DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..Equals Method
Texture2DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..GetHashCode Method
Texture2DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Operators
Texture2DRenderTargetView Structure See Also Send Feedback

The Texture2DRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..Equality Operator
Texture2DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DRenderTargetView textureRenderTargetView1,
    Texture2DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureRenderTargetView1 As Texture2DRenderTargetView, _
    textureRenderTargetView2 As Texture2DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DRenderTargetView textureRenderTargetView1,
    Texture2DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DRenderTargetView

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..Inequality Operator
Texture2DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DRenderTargetView textureRenderTargetView1,
    Texture2DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureRenderTargetView1 As Texture2DRenderTargetView, _
    textureRenderTargetView2 As Texture2DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DRenderTargetView textureRenderTargetView1,
    Texture2DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DRenderTargetView

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView Properties
Texture2DRenderTargetView Structure See Also Send Feedback

The Texture2DRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX2D_RTV.MipSlice)

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DRenderTargetView..::..MipSlice Property
Texture2DRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use mip slice.

(Also see DirectX SDK: D3D11_TEX2D_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource from a 2D texture to use in a shader-resource view.

(Also see DirectX SDK: D3D11_TEX2D_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DShaderResourceView
Visual Basic
Public Structure Texture2DShaderResourceView
Visual C++
public value class Texture2DShaderResourceView

See Also

Texture2DShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Members
Texture2DShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture2DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX2D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX2D_SRV.MostDetailedMip)

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Methods
Texture2DShaderResourceView Structure See Also Send Feedback

The Texture2DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..Equals Method
Texture2DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..GetHashCode Method
Texture2DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Operators
Texture2DShaderResourceView Structure See Also Send Feedback

The Texture2DShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..Equality Operator
Texture2DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DShaderResourceView textureShaderResourceView1,
    Texture2DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureShaderResourceView1 As Texture2DShaderResourceView, _
    textureShaderResourceView2 As Texture2DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DShaderResourceView textureShaderResourceView1,
    Texture2DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DShaderResourceView

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..Inequality Operator
Texture2DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DShaderResourceView textureShaderResourceView1,
    Texture2DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureShaderResourceView1 As Texture2DShaderResourceView, _
    textureShaderResourceView2 As Texture2DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DShaderResourceView textureShaderResourceView1,
    Texture2DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DShaderResourceView

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView Properties
Texture2DShaderResourceView Structure See Also Send Feedback

The Texture2DShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX2D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX2D_SRV.MostDetailedMip)

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..MipLevels Property
Texture2DShaderResourceView Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView.

(Also see DirectX SDK: D3D11_TEX2D_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DShaderResourceView..::..MostDetailedMip Property
Texture2DShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D11_TEX2D_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DUnorderedAccessView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView Structure
Members See Also Send Feedback
Describes a unordered-access 2D texture resource.

(Also see DirectX SDK: D3D11_TEX2D_UAV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture2DUnorderedAccessView
Visual Basic
Public Structure Texture2DUnorderedAccessView
Visual C++
public value class Texture2DUnorderedAccessView

See Also

Texture2DUnorderedAccessView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DUnorderedAccessView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView Members
Texture2DUnorderedAccessView Structure Methods Operators Properties See Also Send Feedback

The Texture2DUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX2D_UAV.MipSlice)

See Also

Texture2DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DUnorderedAccessView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView Methods
Texture2DUnorderedAccessView Structure See Also Send Feedback

The Texture2DUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture2DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView..::..Equals Method
Texture2DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture2DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView..::..GetHashCode Method
Texture2DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture2DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DUnorderedAccessView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView Operators
Texture2DUnorderedAccessView Structure See Also Send Feedback

The Texture2DUnorderedAccessView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture2DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView..::..Equality Operator
Texture2DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture2DUnorderedAccessView textureUnorderedAccessView1,
    Texture2DUnorderedAccessView textureUnorderedAccessView2
)
Visual Basic
Public Shared Operator = ( _
    textureUnorderedAccessView1 As Texture2DUnorderedAccessView, _
    textureUnorderedAccessView2 As Texture2DUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture2DUnorderedAccessView textureUnorderedAccessView1,
    Texture2DUnorderedAccessView textureUnorderedAccessView2
)

Parameters

textureUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DUnorderedAccessView
textureUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DUnorderedAccessView

See Also

Texture2DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView..::..Inequality Operator
Texture2DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture2DUnorderedAccessView textureUnorderedAccessView1,
    Texture2DUnorderedAccessView textureUnorderedAccessView2
)
Visual Basic
Public Shared Operator <> ( _
    textureUnorderedAccessView1 As Texture2DUnorderedAccessView, _
    textureUnorderedAccessView2 As Texture2DUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture2DUnorderedAccessView textureUnorderedAccessView1,
    Texture2DUnorderedAccessView textureUnorderedAccessView2
)

Parameters

textureUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DUnorderedAccessView
textureUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DUnorderedAccessView

See Also

Texture2DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture2DUnorderedAccessView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView Properties
Texture2DUnorderedAccessView Structure See Also Send Feedback

The Texture2DUnorderedAccessView type exposes the following members.

Properties

 | Name | Description
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX2D_UAV.MipSlice)

See Also

Texture2DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture2DUnorderedAccessView..::..MipSlice Property
Texture2DUnorderedAccessView Structure See Also Send Feedback
The mipmap slice index.

(Also see DirectX SDK: D3D11_TEX2D_UAV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture2DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3D Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D Class
Members See Also Send Feedback
A 3D texture interface accesses texel data, which is structured memory.

(Also see DirectX SDK: ID3D11Texture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Texture3D : D3DResource
Visual Basic
Public Class Texture3D _
    Inherits D3DResource
Visual C++
public ref class Texture3D : public D3DResource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DResource
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3D

See Also

Texture3D Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3D Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D Members
Texture3D Class Properties See Also Send Feedback

The Texture3D type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D11Texture3D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics.Surface1. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType) (Inherited from D3DResource.)

See Also

Texture3D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3D Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D Properties
Texture3D Class See Also Send Feedback

The Texture3D type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get the properties of the texture resource. (Also see DirectX SDK: ID3D11Texture3D::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | EvictionPriority | Gets or sets the eviction priority of a resource. (Also see DirectX SDK: ID3D11Resource::GetEvictionPriority, ID3D11Resource::SetEvictionPriority) (Inherited from D3DResource.)
Public property | GraphicsSurface | Get associated Graphics surface. (Inherited from D3DResource.)
Public property | GraphicsSurface1 | Get associated Graphics.Surface1. (Inherited from D3DResource.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ResourceDimension | Get the type of the resource. (Also see DirectX SDK: ID3D11Resource::GetType) (Inherited from D3DResource.)

See Also

Texture3D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3D..::..Description Property
Texture3D Class See Also Send Feedback
Get the properties of the texture resource.

(Also see DirectX SDK: ID3D11Texture3D::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3DDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As Texture3DDescription
    Get
Visual C++
public:
property Texture3DDescription Description {
    Texture3DDescription get ();
}

See Also

Texture3D Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Structure
Members See Also Send Feedback
Describes a 3D texture.

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture3DDescription
Visual Basic
Public Structure Texture3DDescription
Visual C++
public value class Texture3DDescription

See Also

Texture3DDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Members
Texture3DDescription Structure Methods Operators Properties See Also Send Feedback

The Texture3DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.CPUAccessFlags)
Public property | Depth | Texture depth (in texels) (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Depth)
Public property | Format | Texture format (see Format). (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Format)
Public property | Height | Texture height (in texels). See Remarks. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Height)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.MiscFlags)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Usage)
Public property | Width | Texture width (in texels). See Remarks. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Width)

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Methods
Texture3DDescription Structure See Also Send Feedback

The Texture3DDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Equals Method
Texture3DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..GetHashCode Method
Texture3DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Operators
Texture3DDescription Structure See Also Send Feedback

The Texture3DDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Equality Operator
Texture3DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture3DDescription textureDescription1,
    Texture3DDescription textureDescription2
)
Visual Basic
Public Shared Operator = ( _
    textureDescription1 As Texture3DDescription, _
    textureDescription2 As Texture3DDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture3DDescription textureDescription1,
    Texture3DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DDescription

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Inequality Operator
Texture3DDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture3DDescription textureDescription1,
    Texture3DDescription textureDescription2
)
Visual Basic
Public Shared Operator <> ( _
    textureDescription1 As Texture3DDescription, _
    textureDescription2 As Texture3DDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture3DDescription textureDescription1,
    Texture3DDescription textureDescription2
)

Parameters

textureDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DDescription
textureDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DDescription

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription Properties
Texture3DDescription Structure See Also Send Feedback

The Texture3DDescription type exposes the following members.

Properties

 | Name | Description
Public property | BindingOptions | Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.BindFlags)
Public property | CpuAccessOptions | Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.CPUAccessFlags)
Public property | Depth | Texture depth (in texels) (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Depth)
Public property | Format | Texture format (see Format). (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Format)
Public property | Height | Texture height (in texels). See Remarks. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Height)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. Use 1 for a multisampled texture; or 0 to generate a full set of subtextures. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.MipLevels)
Public property | MiscellaneousResourceOptions | Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.MiscFlags)
Public property | Usage | Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Usage)
Public property | Width | Texture width (in texels). See Remarks. (Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Width)

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


BindingOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..BindingOptions Property
Texture3DDescription Structure See Also Send Feedback
Flags (see BindingOptions) for binding to pipeline stages. The flags can be combined by a logical OR.

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC.BindFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BindingOptions BindingOptions { get; set; }
Visual Basic
Public Property BindingOptions As BindingOptions
    Get
    Set
Visual C++
public:
property BindingOptions BindingOptions {
    BindingOptions get ();
    void set (BindingOptions value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BindingOptions


CpuAccessOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..CpuAccessOptions Property
Texture3DDescription Structure See Also Send Feedback
Flags (see CpuAccessOptions) to specify the types of CPU access allowed. Use 0 if CPU access is not required. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC.CPUAccessFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CpuAccessOptions CpuAccessOptions { get; set; }
Visual Basic
Public Property CpuAccessOptions As CpuAccessOptions
    Get
    Set
Visual C++
public:
property CpuAccessOptions CpuAccessOptions {
    CpuAccessOptions get ();
    void set (CpuAccessOptions value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Texture3DDescription..::..CpuAccessOptions


Depth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Depth Property
Texture3DDescription Structure See Also Send Feedback
Texture depth (in texels)

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Depth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Depth { get; set; }
Visual Basic
Public Property Depth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Depth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Format Property
Texture3DDescription Structure See Also Send Feedback
Texture format (see Format).

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Texture3DDescription..::..Format


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Height Property
Texture3DDescription Structure See Also Send Feedback
Texture height (in texels). See Remarks.

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Height)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..MipLevels Property
Texture3DDescription Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. Use 1 for a multisampled texture; or 0 to generate a full set of subtextures.

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MiscellaneousResourceOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..MiscellaneousResourceOptions Property
Texture3DDescription Structure See Also Send Feedback
Flags (see MiscellaneousResourceOptions) that identifies other, less common resource options. Use 0 if none of these flags apply. These flags can be combined with a logical OR.

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC.MiscFlags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MiscellaneousResourceOptions MiscellaneousResourceOptions { get; set; }
Visual Basic
Public Property MiscellaneousResourceOptions As MiscellaneousResourceOptions
    Get
    Set
Visual C++
public:
property MiscellaneousResourceOptions MiscellaneousResourceOptions {
    MiscellaneousResourceOptions get ();
    void set (MiscellaneousResourceOptions value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Texture3DDescription..::..MiscellaneousResourceOptions


Usage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Usage Property
Texture3DDescription Structure See Also Send Feedback
Value that identifies how the texture is to be read from and written to. The most common value is Usage-DEFAULT; see Usage for all possible values.

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Usage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Usage Usage { get; set; }
Visual Basic
Public Property Usage As Usage
    Get
    Set
Visual C++
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DDescription..::..Width Property
Texture3DDescription Structure See Also Send Feedback
Texture width (in texels). See Remarks.

(Also see DirectX SDK: D3D11_TEXTURE3D_DESC.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DRenderTargetView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Structure
Members See Also Send Feedback
Specifies the subresources from a 3D texture to use in a render-target view.

(Also see DirectX SDK: D3D11_TEX3D_RTV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture3DRenderTargetView
Visual Basic
Public Structure Texture3DRenderTargetView
Visual C++
public value class Texture3DRenderTargetView

See Also

Texture3DRenderTargetView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DRenderTargetView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Members
Texture3DRenderTargetView Structure Methods Operators Properties See Also Send Feedback

The Texture3DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | FirstWSlice | First depth level to use. (Also see DirectX SDK: D3D11_TEX3D_RTV.FirstWSlice)
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX3D_RTV.MipSlice)
Public property | WSize | Number of depth levels to use in the render-target view, starting from FirstWSlice. A value of -1 indicates all of the slices along the w axis, starting from FirstWSlice. (Also see DirectX SDK: D3D11_TEX3D_RTV.WSize)

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DRenderTargetView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Methods
Texture3DRenderTargetView Structure See Also Send Feedback

The Texture3DRenderTargetView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..Equals Method
Texture3DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..GetHashCode Method
Texture3DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DRenderTargetView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Operators
Texture3DRenderTargetView Structure See Also Send Feedback

The Texture3DRenderTargetView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..Equality Operator
Texture3DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture3DRenderTargetView textureRenderTargetView1,
    Texture3DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator = ( _
    textureRenderTargetView1 As Texture3DRenderTargetView, _
    textureRenderTargetView2 As Texture3DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture3DRenderTargetView textureRenderTargetView1,
    Texture3DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DRenderTargetView

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..Inequality Operator
Texture3DRenderTargetView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture3DRenderTargetView textureRenderTargetView1,
    Texture3DRenderTargetView textureRenderTargetView2
)
Visual Basic
Public Shared Operator <> ( _
    textureRenderTargetView1 As Texture3DRenderTargetView, _
    textureRenderTargetView2 As Texture3DRenderTargetView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture3DRenderTargetView textureRenderTargetView1,
    Texture3DRenderTargetView textureRenderTargetView2
)

Parameters

textureRenderTargetView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DRenderTargetView
textureRenderTargetView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DRenderTargetView

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DRenderTargetView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView Properties
Texture3DRenderTargetView Structure See Also Send Feedback

The Texture3DRenderTargetView type exposes the following members.

Properties

 | Name | Description
Public property | FirstWSlice | First depth level to use. (Also see DirectX SDK: D3D11_TEX3D_RTV.FirstWSlice)
Public property | MipSlice | The index of the mipmap level to use mip slice. (Also see DirectX SDK: D3D11_TEX3D_RTV.MipSlice)
Public property | WSize | Number of depth levels to use in the render-target view, starting from FirstWSlice. A value of -1 indicates all of the slices along the w axis, starting from FirstWSlice. (Also see DirectX SDK: D3D11_TEX3D_RTV.WSize)

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstWSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..FirstWSlice Property
Texture3DRenderTargetView Structure See Also Send Feedback
First depth level to use.

(Also see DirectX SDK: D3D11_TEX3D_RTV.FirstWSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstWSlice { get; set; }
Visual Basic
Public Property FirstWSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstWSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..MipSlice Property
Texture3DRenderTargetView Structure See Also Send Feedback
The index of the mipmap level to use mip slice.

(Also see DirectX SDK: D3D11_TEX3D_RTV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


WSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DRenderTargetView..::..WSize Property
Texture3DRenderTargetView Structure See Also Send Feedback
Number of depth levels to use in the render-target view, starting from FirstWSlice. A value of -1 indicates all of the slices along the w axis, starting from FirstWSlice.

(Also see DirectX SDK: D3D11_TEX3D_RTV.WSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint WSize { get; set; }
Visual Basic
Public Property WSize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int WSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DRenderTargetView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresources from a 3D texture to use in a shader-resource view.

(Also see DirectX SDK: D3D11_TEX3D_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture3DShaderResourceView
Visual Basic
Public Structure Texture3DShaderResourceView
Visual C++
public value class Texture3DShaderResourceView

See Also

Texture3DShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Members
Texture3DShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The Texture3DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX3D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX3D_SRV.MostDetailedMip)

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Methods
Texture3DShaderResourceView Structure See Also Send Feedback

The Texture3DShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..Equals Method
Texture3DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..GetHashCode Method
Texture3DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Operators
Texture3DShaderResourceView Structure See Also Send Feedback

The Texture3DShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..Equality Operator
Texture3DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture3DShaderResourceView textureShaderResourceView1,
    Texture3DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureShaderResourceView1 As Texture3DShaderResourceView, _
    textureShaderResourceView2 As Texture3DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture3DShaderResourceView textureShaderResourceView1,
    Texture3DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DShaderResourceView

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..Inequality Operator
Texture3DShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture3DShaderResourceView textureShaderResourceView1,
    Texture3DShaderResourceView textureShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureShaderResourceView1 As Texture3DShaderResourceView, _
    textureShaderResourceView2 As Texture3DShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture3DShaderResourceView textureShaderResourceView1,
    Texture3DShaderResourceView textureShaderResourceView2
)

Parameters

textureShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DShaderResourceView
textureShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DShaderResourceView

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView Properties
Texture3DShaderResourceView Structure See Also Send Feedback

The Texture3DShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEX3D_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEX3D_SRV.MostDetailedMip)

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..MipLevels Property
Texture3DShaderResourceView Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView.

(Also see DirectX SDK: D3D11_TEX3D_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DShaderResourceView..::..MostDetailedMip Property
Texture3DShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D11_TEX3D_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DUnorderedAccessView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView Structure
Members See Also Send Feedback
Describes a unordered-access 3D texture resource.

(Also see DirectX SDK: D3D11_TEX3D_UAV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Texture3DUnorderedAccessView
Visual Basic
Public Structure Texture3DUnorderedAccessView
Visual C++
public value class Texture3DUnorderedAccessView

See Also

Texture3DUnorderedAccessView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DUnorderedAccessView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView Members
Texture3DUnorderedAccessView Structure Methods Operators Properties See Also Send Feedback

The Texture3DUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | FirstWSlice | The zero-based index of the first depth slice to be accessed. (Also see DirectX SDK: D3D11_TEX3D_UAV.FirstWSlice)
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX3D_UAV.MipSlice)
Public property | WSize | The number of depth slices. (Also see DirectX SDK: D3D11_TEX3D_UAV.WSize)

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DUnorderedAccessView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView Methods
Texture3DUnorderedAccessView Structure See Also Send Feedback

The Texture3DUnorderedAccessView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView..::..Equals Method
Texture3DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView..::..GetHashCode Method
Texture3DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DUnorderedAccessView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView Operators
Texture3DUnorderedAccessView Structure See Also Send Feedback

The Texture3DUnorderedAccessView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView..::..Equality Operator
Texture3DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Texture3DUnorderedAccessView textureUnorderedAccessView1,
    Texture3DUnorderedAccessView textureUnorderedAccessView2
)
Visual Basic
Public Shared Operator = ( _
    textureUnorderedAccessView1 As Texture3DUnorderedAccessView, _
    textureUnorderedAccessView2 As Texture3DUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator ==(
    Texture3DUnorderedAccessView textureUnorderedAccessView1,
    Texture3DUnorderedAccessView textureUnorderedAccessView2
)

Parameters

textureUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DUnorderedAccessView
textureUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DUnorderedAccessView

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView..::..Inequality Operator
Texture3DUnorderedAccessView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Texture3DUnorderedAccessView textureUnorderedAccessView1,
    Texture3DUnorderedAccessView textureUnorderedAccessView2
)
Visual Basic
Public Shared Operator <> ( _
    textureUnorderedAccessView1 As Texture3DUnorderedAccessView, _
    textureUnorderedAccessView2 As Texture3DUnorderedAccessView _
) As Boolean
Visual C++
public:
static bool operator !=(
    Texture3DUnorderedAccessView textureUnorderedAccessView1,
    Texture3DUnorderedAccessView textureUnorderedAccessView2
)

Parameters

textureUnorderedAccessView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DUnorderedAccessView
textureUnorderedAccessView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DUnorderedAccessView

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Texture3DUnorderedAccessView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView Properties
Texture3DUnorderedAccessView Structure See Also Send Feedback

The Texture3DUnorderedAccessView type exposes the following members.

Properties

 | Name | Description
Public property | FirstWSlice | The zero-based index of the first depth slice to be accessed. (Also see DirectX SDK: D3D11_TEX3D_UAV.FirstWSlice)
Public property | MipSlice | The mipmap slice index. (Also see DirectX SDK: D3D11_TEX3D_UAV.MipSlice)
Public property | WSize | The number of depth slices. (Also see DirectX SDK: D3D11_TEX3D_UAV.WSize)

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


FirstWSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView..::..FirstWSlice Property
Texture3DUnorderedAccessView Structure See Also Send Feedback
The zero-based index of the first depth slice to be accessed.

(Also see DirectX SDK: D3D11_TEX3D_UAV.FirstWSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FirstWSlice { get; set; }
Visual Basic
Public Property FirstWSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int FirstWSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipSlice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView..::..MipSlice Property
Texture3DUnorderedAccessView Structure See Also Send Feedback
The mipmap slice index.

(Also see DirectX SDK: D3D11_TEX3D_UAV.MipSlice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipSlice { get; set; }
Visual Basic
Public Property MipSlice As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipSlice {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


WSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Texture3DUnorderedAccessView..::..WSize Property
Texture3DUnorderedAccessView Structure See Also Send Feedback
The number of depth slices.

(Also see DirectX SDK: D3D11_TEX3D_UAV.WSize)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint WSize { get; set; }
Visual Basic
Public Property WSize As UInteger
    Get
    Set
Visual C++
public:
property unsigned int WSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Texture3DUnorderedAccessView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureAddressMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureAddressMode Enumeration
See Also Send Feedback
Identify a technique for resolving texture coordinates that are outside of the boundaries of a texture.

(Also see DirectX SDK: D3D11_TEXTURE_ADDRESS_MODE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum TextureAddressMode
Visual Basic
Public Enumeration TextureAddressMode
Visual C++
public enum class TextureAddressMode

Members

Member name | Description
MirrorOnce |
Border |
Clamp |
Mirror |
Wrap |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeArrayShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresources from an array of cube textures to use in a shader-resource view.

(Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct TextureCubeArrayShaderResourceView
Visual Basic
Public Structure TextureCubeArrayShaderResourceView
Visual C++
public value class TextureCubeArrayShaderResourceView

See Also

TextureCubeArrayShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeArrayShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView Members
TextureCubeArrayShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The TextureCubeArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | CubeCount | Number of cube textures in the array. (Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.NumCubes)
Public property | First2DArrayFace | Index of the first 2D texture to use. (Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.First2DArrayFace)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.MostDetailedMip)

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeArrayShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView Methods
TextureCubeArrayShaderResourceView Structure See Also Send Feedback

The TextureCubeArrayShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView..::..Equals Method
TextureCubeArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView..::..GetHashCode Method
TextureCubeArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeArrayShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView Operators
TextureCubeArrayShaderResourceView Structure See Also Send Feedback

The TextureCubeArrayShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView..::..Equality Operator
TextureCubeArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    TextureCubeArrayShaderResourceView textureCubeArrayShaderResourceView1,
    TextureCubeArrayShaderResourceView textureCubeArrayShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureCubeArrayShaderResourceView1 As TextureCubeArrayShaderResourceView, _
    textureCubeArrayShaderResourceView2 As TextureCubeArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    TextureCubeArrayShaderResourceView textureCubeArrayShaderResourceView1,
    TextureCubeArrayShaderResourceView textureCubeArrayShaderResourceView2
)

Parameters

textureCubeArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeArrayShaderResourceView
textureCubeArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeArrayShaderResourceView

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView..::..Inequality Operator
TextureCubeArrayShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    TextureCubeArrayShaderResourceView textureCubeArrayShaderResourceView1,
    TextureCubeArrayShaderResourceView textureCubeArrayShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureCubeArrayShaderResourceView1 As TextureCubeArrayShaderResourceView, _
    textureCubeArrayShaderResourceView2 As TextureCubeArrayShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    TextureCubeArrayShaderResourceView textureCubeArrayShaderResourceView1,
    TextureCubeArrayShaderResourceView textureCubeArrayShaderResourceView2
)

Parameters

textureCubeArrayShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeArrayShaderResourceView
textureCubeArrayShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeArrayShaderResourceView

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeArrayShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView Properties
TextureCubeArrayShaderResourceView Structure See Also Send Feedback

The TextureCubeArrayShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | CubeCount | Number of cube textures in the array. (Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.NumCubes)
Public property | First2DArrayFace | Index of the first 2D texture to use. (Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.First2DArrayFace)
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.MostDetailedMip)

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


CubeCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView..::..CubeCount Property
TextureCubeArrayShaderResourceView Structure See Also Send Feedback
Number of cube textures in the array.

(Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.NumCubes)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint CubeCount { get; set; }
Visual Basic
Public Property CubeCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int CubeCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


First2DArrayFace Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView..::..First2DArrayFace Property
TextureCubeArrayShaderResourceView Structure See Also Send Feedback
Index of the first 2D texture to use.

(Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.First2DArrayFace)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint First2DArrayFace { get; set; }
Visual Basic
Public Property First2DArrayFace As UInteger
    Get
    Set
Visual C++
public:
property unsigned int First2DArrayFace {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView..::..MipLevels Property
TextureCubeArrayShaderResourceView Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView.

(Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeArrayShaderResourceView..::..MostDetailedMip Property
TextureCubeArrayShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D11_TEXCUBE_ARRAY_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeArrayShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeFace Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeFace Enumeration
See Also Send Feedback
The different faces of a cube texture.

(Also see DirectX SDK: D3D11_TEXTURECUBE_FACE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum TextureCubeFace
Visual Basic
Public Enumeration TextureCubeFace
Visual C++
public enum class TextureCubeFace

Members

Member name | Description
NegativeZ |
PositiveZ |
NegativeY |
PositiveY |
NegativeX |
PositiveX |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeShaderResourceView Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Structure
Members See Also Send Feedback
Specifies the subresource from a cube texture to use in a shader-resource view.

(Also see DirectX SDK: D3D11_TEXCUBE_SRV)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct TextureCubeShaderResourceView
Visual Basic
Public Structure TextureCubeShaderResourceView
Visual C++
public value class TextureCubeShaderResourceView

See Also

TextureCubeShaderResourceView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeShaderResourceView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Members
TextureCubeShaderResourceView Structure Methods Operators Properties See Also Send Feedback

The TextureCubeShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEXCUBE_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEXCUBE_SRV.MostDetailedMip)

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeShaderResourceView Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Methods
TextureCubeShaderResourceView Structure See Also Send Feedback

The TextureCubeShaderResourceView type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..Equals Method
TextureCubeShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..GetHashCode Method
TextureCubeShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeShaderResourceView Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Operators
TextureCubeShaderResourceView Structure See Also Send Feedback

The TextureCubeShaderResourceView type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..Equality Operator
TextureCubeShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    TextureCubeShaderResourceView textureCubeShaderResourceView1,
    TextureCubeShaderResourceView textureCubeShaderResourceView2
)
Visual Basic
Public Shared Operator = ( _
    textureCubeShaderResourceView1 As TextureCubeShaderResourceView, _
    textureCubeShaderResourceView2 As TextureCubeShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator ==(
    TextureCubeShaderResourceView textureCubeShaderResourceView1,
    TextureCubeShaderResourceView textureCubeShaderResourceView2
)

Parameters

textureCubeShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeShaderResourceView
textureCubeShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeShaderResourceView

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..Inequality Operator
TextureCubeShaderResourceView Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    TextureCubeShaderResourceView textureCubeShaderResourceView1,
    TextureCubeShaderResourceView textureCubeShaderResourceView2
)
Visual Basic
Public Shared Operator <> ( _
    textureCubeShaderResourceView1 As TextureCubeShaderResourceView, _
    textureCubeShaderResourceView2 As TextureCubeShaderResourceView _
) As Boolean
Visual C++
public:
static bool operator !=(
    TextureCubeShaderResourceView textureCubeShaderResourceView1,
    TextureCubeShaderResourceView textureCubeShaderResourceView2
)

Parameters

textureCubeShaderResourceView1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeShaderResourceView
textureCubeShaderResourceView2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..TextureCubeShaderResourceView

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TextureCubeShaderResourceView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView Properties
TextureCubeShaderResourceView Structure See Also Send Feedback

The TextureCubeShaderResourceView type exposes the following members.

Properties

 | Name | Description
Public property | MipLevels | The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView. (Also see DirectX SDK: D3D11_TEXCUBE_SRV.MipLevels)
Public property | MostDetailedMip | Index of the most detailed mipmap level to use; this number is between 0 and MipLevels. (Also see DirectX SDK: D3D11_TEXCUBE_SRV.MostDetailedMip)

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MipLevels Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..MipLevels Property
TextureCubeShaderResourceView Structure See Also Send Feedback
The maximum number of mipmap levels in the texture. See the remarks in Texture1DShaderResourceView.

(Also see DirectX SDK: D3D11_TEXCUBE_SRV.MipLevels)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MipLevels { get; set; }
Visual Basic
Public Property MipLevels As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MipLevels {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MostDetailedMip Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextureCubeShaderResourceView..::..MostDetailedMip Property
TextureCubeShaderResourceView Structure See Also Send Feedback
Index of the most detailed mipmap level to use; this number is between 0 and MipLevels.

(Also see DirectX SDK: D3D11_TEXCUBE_SRV.MostDetailedMip)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MostDetailedMip { get; set; }
Visual Basic
Public Property MostDetailedMip As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MostDetailedMip {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextureCubeShaderResourceView Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnorderedAccessView Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessView Class
Members See Also Send Feedback
A view interface specifies the parts of a resource the pipeline can access during rendering.

(Also see DirectX SDK: ID3D11UnorderedAccessView)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class UnorderedAccessView : View
Visual Basic
Public Class UnorderedAccessView _
    Inherits View
Visual C++
public ref class UnorderedAccessView : public View

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..UnorderedAccessView

See Also

UnorderedAccessView Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnorderedAccessView Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessView Members
UnorderedAccessView Class Properties See Also Send Feedback

The UnorderedAccessView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get a description of the resource. (Also see DirectX SDK: ID3D11UnorderedAccessView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource) (Inherited from View.)

See Also

UnorderedAccessView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnorderedAccessView Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessView Properties
UnorderedAccessView Class See Also Send Feedback

The UnorderedAccessView type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get a description of the resource. (Also see DirectX SDK: ID3D11UnorderedAccessView::GetDesc)
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource) (Inherited from View.)

See Also

UnorderedAccessView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessView..::..Description Property
UnorderedAccessView Class See Also Send Feedback
Get a description of the resource.

(Also see DirectX SDK: ID3D11UnorderedAccessView::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public UnorderedAccessViewDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As UnorderedAccessViewDescription
    Get
Visual C++
public:
property UnorderedAccessViewDescription Description {
    UnorderedAccessViewDescription get ();
}

See Also

UnorderedAccessView Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnorderedAccessViewBufferOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewBufferOptions Enumeration
See Also Send Feedback
Unordered-access-view buffer options.

(Also see DirectX SDK: D3D11_BUFFER_UAV_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum UnorderedAccessViewBufferOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration UnorderedAccessViewBufferOptions
Visual C++
[FlagsAttribute]
public enum class UnorderedAccessViewBufferOptions

Members

Member name | Description
Append |
Raw |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnorderedAccessViewDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription Structure
Members See Also Send Feedback
Specifies the subresources from a resource that are accessible using an unordered-access view.

(Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct UnorderedAccessViewDescription
Visual Basic
Public Structure UnorderedAccessViewDescription
Visual C++
public value class UnorderedAccessViewDescription

See Also

UnorderedAccessViewDescription Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnorderedAccessViewDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription Members
UnorderedAccessViewDescription Structure Properties See Also Send Feedback

The UnorderedAccessViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | Specifies which buffer elements can be accessed (see BufferUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Buffer)
Public property | Format | The data format (see Format). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Format)
Public property | Texture1D | Specifies the subresources in a 1D texture that can be accessed (see Texture1DUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies the subresources in a 1D texture array that can be accessed (see Texture1DArrayUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies the subresources in a 2D texture that can be accessed (see Texture2DUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies the subresources in a 2D texture array that can be accessed (see Texture2DArrayUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture2DArray)
Public property | Texture3D | Specifies subresources in a 3D texture that can be accessed (see Texture3DUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture3D)
Public property | ViewDimension | The resource type (see UnorderedAccessViewDimension), which specifies how the resource will be accessed. (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.ViewDimension)

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


UnorderedAccessViewDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription Properties
UnorderedAccessViewDescription Structure See Also Send Feedback

The UnorderedAccessViewDescription type exposes the following members.

Properties

 | Name | Description
Public property | Buffer | Specifies which buffer elements can be accessed (see BufferUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Buffer)
Public property | Format | The data format (see Format). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Format)
Public property | Texture1D | Specifies the subresources in a 1D texture that can be accessed (see Texture1DUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture1D)
Public property | Texture1DArray | Specifies the subresources in a 1D texture array that can be accessed (see Texture1DArrayUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture1DArray)
Public property | Texture2D | Specifies the subresources in a 2D texture that can be accessed (see Texture2DUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture2D)
Public property | Texture2DArray | Specifies the subresources in a 2D texture array that can be accessed (see Texture2DArrayUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture2DArray)
Public property | Texture3D | Specifies subresources in a 3D texture that can be accessed (see Texture3DUnorderedAccessView). (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture3D)
Public property | ViewDimension | The resource type (see UnorderedAccessViewDimension), which specifies how the resource will be accessed. (Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.ViewDimension)

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription..::..Buffer Property
UnorderedAccessViewDescription Structure See Also Send Feedback
Specifies which buffer elements can be accessed (see BufferUnorderedAccessView).

(Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Buffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BufferUnorderedAccessView Buffer { get; set; }
Visual Basic
Public Property Buffer As BufferUnorderedAccessView
    Get
    Set
Visual C++
public:
property BufferUnorderedAccessView Buffer {
    BufferUnorderedAccessView get ();
    void set (BufferUnorderedAccessView value);
}

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..BufferUnorderedAccessView


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription..::..Format Property
UnorderedAccessViewDescription Structure See Also Send Feedback
The data format (see Format).

(Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
UnorderedAccessViewDescription..::..Format


Texture1D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription..::..Texture1D Property
UnorderedAccessViewDescription Structure See Also Send Feedback
Specifies the subresources in a 1D texture that can be accessed (see Texture1DUnorderedAccessView).

(Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture1D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DUnorderedAccessView Texture1D { get; set; }
Visual Basic
Public Property Texture1D As Texture1DUnorderedAccessView
    Get
    Set
Visual C++
public:
property Texture1DUnorderedAccessView Texture1D {
    Texture1DUnorderedAccessView get ();
    void set (Texture1DUnorderedAccessView value);
}

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DUnorderedAccessView


Texture1DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription..::..Texture1DArray Property
UnorderedAccessViewDescription Structure See Also Send Feedback
Specifies the subresources in a 1D texture array that can be accessed (see Texture1DArrayUnorderedAccessView).

(Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture1DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture1DArrayUnorderedAccessView Texture1DArray { get; set; }
Visual Basic
Public Property Texture1DArray As Texture1DArrayUnorderedAccessView
    Get
    Set
Visual C++
public:
property Texture1DArrayUnorderedAccessView Texture1DArray {
    Texture1DArrayUnorderedAccessView get ();
    void set (Texture1DArrayUnorderedAccessView value);
}

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture1DArrayUnorderedAccessView


Texture2D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription..::..Texture2D Property
UnorderedAccessViewDescription Structure See Also Send Feedback
Specifies the subresources in a 2D texture that can be accessed (see Texture2DUnorderedAccessView).

(Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture2D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DUnorderedAccessView Texture2D { get; set; }
Visual Basic
Public Property Texture2D As Texture2DUnorderedAccessView
    Get
    Set
Visual C++
public:
property Texture2DUnorderedAccessView Texture2D {
    Texture2DUnorderedAccessView get ();
    void set (Texture2DUnorderedAccessView value);
}

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DUnorderedAccessView


Texture2DArray Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription..::..Texture2DArray Property
UnorderedAccessViewDescription Structure See Also Send Feedback
Specifies the subresources in a 2D texture array that can be accessed (see Texture2DArrayUnorderedAccessView).

(Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture2DArray)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture2DArrayUnorderedAccessView Texture2DArray { get; set; }
Visual Basic
Public Property Texture2DArray As Texture2DArrayUnorderedAccessView
    Get
    Set
Visual C++
public:
property Texture2DArrayUnorderedAccessView Texture2DArray {
    Texture2DArrayUnorderedAccessView get ();
    void set (Texture2DArrayUnorderedAccessView value);
}

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture2DArrayUnorderedAccessView


Texture3D Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription..::..Texture3D Property
UnorderedAccessViewDescription Structure See Also Send Feedback
Specifies subresources in a 3D texture that can be accessed (see Texture3DUnorderedAccessView).

(Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.Texture3D)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Texture3DUnorderedAccessView Texture3D { get; set; }
Visual Basic
Public Property Texture3D As Texture3DUnorderedAccessView
    Get
    Set
Visual C++
public:
property Texture3DUnorderedAccessView Texture3D {
    Texture3DUnorderedAccessView get ();
    void set (Texture3DUnorderedAccessView value);
}

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Texture3DUnorderedAccessView


ViewDimension Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDescription..::..ViewDimension Property
UnorderedAccessViewDescription Structure See Also Send Feedback
The resource type (see UnorderedAccessViewDimension), which specifies how the resource will be accessed.

(Also see DirectX SDK: D3D11_UNORDERED_ACCESS_VIEW_DESC.ViewDimension)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public UnorderedAccessViewDimension ViewDimension { get; set; }
Visual Basic
Public Property ViewDimension As UnorderedAccessViewDimension
    Get
    Set
Visual C++
public:
property UnorderedAccessViewDimension ViewDimension {
    UnorderedAccessViewDimension get ();
    void set (UnorderedAccessViewDimension value);
}

See Also

UnorderedAccessViewDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..UnorderedAccessViewDimension


UnorderedAccessViewDimension Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UnorderedAccessViewDimension Enumeration
See Also Send Feedback
Unordered-access view options.

(Also see DirectX SDK: D3D11_UAV_DIMENSION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum UnorderedAccessViewDimension
Visual Basic
Public Enumeration UnorderedAccessViewDimension
Visual C++
public enum class UnorderedAccessViewDimension

Members

Member name | Description
Buffer |
Texture3D |
Texture2DArray |
Texture2D |
Texture1DArray |
Texture1D |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Usage Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Usage Enumeration
See Also Send Feedback
Identifies expected resource use during rendering. The usage directly reflects whether a resource is accessible by the CPU and/or the GPU.

(Also see DirectX SDK: D3D11_USAGE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Usage
Visual Basic
Public Enumeration Usage
Visual C++
public enum class Usage

Members

Member name | Description
Staging |
Dynamic |
Immutable |
Default |

See Also

Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexBuffer Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Structure
Members See Also Send Feedback
Stores the parameters required to get or set a vertex buffer for a device.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct VertexBuffer
Visual Basic
Public Structure VertexBuffer
Visual C++
public value class VertexBuffer

See Also

VertexBuffer Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexBuffer Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Members
VertexBuffer Structure Constructors Methods Operators Properties See Also Send Feedback

The VertexBuffer type exposes the following members.

Constructors

 | Name | Description
Public method | VertexBuffer |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Buffer |
Public property | Offset |
Public property | Stride |

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexBuffer Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Constructor
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexBuffer(
    D3DBuffer buffer,
    uint stride,
    uint offset
)
Visual Basic
Public Sub New ( _
    buffer As D3DBuffer, _
    stride As UInteger, _
    offset As UInteger _
)
Visual C++
public:
VertexBuffer(
    D3DBuffer^ buffer,
    unsigned int stride,
    unsigned int offset
)

Parameters

buffer
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer
A vertex buffer (see D3DBuffer). The vertex buffer must have been created with the VertexBuffer flag.
stride
Type: System..::..UInt32
The stride value. This is the size (in bytes) of the elements that are to be used from the vertex buffer.
offset
Type: System..::..UInt32
The offset value. This is the number of bytes between the first element of the vertex buffer and the first element that will be used.

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


VertexBuffer Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Methods
VertexBuffer Structure See Also Send Feedback

The VertexBuffer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Equals Method
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..GetHashCode Method
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexBuffer Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Operators
VertexBuffer Structure See Also Send Feedback

The VertexBuffer type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Equality Operator
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    VertexBuffer buffer1,
    VertexBuffer buffer2
)
Visual Basic
Public Shared Operator = ( _
    buffer1 As VertexBuffer, _
    buffer2 As VertexBuffer _
) As Boolean
Visual C++
public:
static bool operator ==(
    VertexBuffer buffer1,
    VertexBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexBuffer

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Inequality Operator
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    VertexBuffer buffer1,
    VertexBuffer buffer2
)
Visual Basic
Public Shared Operator <> ( _
    buffer1 As VertexBuffer, _
    buffer2 As VertexBuffer _
) As Boolean
Visual C++
public:
static bool operator !=(
    VertexBuffer buffer1,
    VertexBuffer buffer2
)

Parameters

buffer1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexBuffer
buffer2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexBuffer

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexBuffer Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer Properties
VertexBuffer Structure See Also Send Feedback

The VertexBuffer type exposes the following members.

Properties

 | Name | Description
Public property | Buffer |
Public property | Offset |
Public property | Stride |

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Buffer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Buffer Property
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DBuffer Buffer { get; }
Visual Basic
Public ReadOnly Property Buffer As D3DBuffer
    Get
Visual C++
public:
property D3DBuffer^ Buffer {
    D3DBuffer^ get ();
}

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Offset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Offset Property
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Offset { get; }
Visual Basic
Public ReadOnly Property Offset As UInteger
    Get
Visual C++
public:
property unsigned int Offset {
    unsigned int get ();
}

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Stride Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexBuffer..::..Stride Property
VertexBuffer Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Stride { get; }
Visual Basic
Public ReadOnly Property Stride As UInteger
    Get
Visual C++
public:
property unsigned int Stride {
    unsigned int get ();
}

See Also

VertexBuffer Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexShader Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShader Class
Members See Also Send Feedback
A vertex-shader class manages an executable program (a vertex shader) that controls the vertex-shader stage.

(Also see DirectX SDK: ID3D11VertexShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class VertexShader : DeviceChild
Visual Basic
Public Class VertexShader _
    Inherits DeviceChild
Visual C++
public ref class VertexShader : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexShader

See Also

VertexShader Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexShader Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShader Members
VertexShader Class Properties See Also Send Feedback

The VertexShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

VertexShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexShader Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShader Properties
VertexShader Class See Also Send Feedback

The VertexShader type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

VertexShader Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexShaderPipelineStage Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Class
Members See Also Send Feedback
Vertex Shader pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class VertexShaderPipelineStage : PipelineStage
Visual Basic
Public Class VertexShaderPipelineStage _
    Inherits PipelineStage
Visual C++
public ref class VertexShaderPipelineStage : public PipelineStage

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..PipelineStage
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexShaderPipelineStage

See Also

VertexShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexShaderPipelineStage Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Members
VertexShaderPipelineStage Class Constructors Methods Properties See Also Send Feedback

The VertexShaderPipelineStage type exposes the following members.

Constructors

 | Name | Description
Protected method | VertexShaderPipelineStage |

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the vertex shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::VSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler states from the vertex shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::VSGetSamplers)
Public method | GetShaderAndClasses | Get the vertex shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::VSGetShader)
Public method | GetShaderResources | Get the vertex shader resources. (Also see DirectX SDK: ID3D11DeviceContext::VSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(VertexShader>)>>)) |
Public method | SetShader(VertexShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Get the vertex shader currently set on the device. (See VertexShader). (Also see DirectX SDK: ID3D11DeviceContext::VSGetShader, ID3D11DeviceContext::VSSetShader) Passing in null disables the shader for this pipeline stage.

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexShaderPipelineStage Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Constructor
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected VertexShaderPipelineStage()
Visual Basic
Protected Sub New
Visual C++
protected:
VertexShaderPipelineStage()

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexShaderPipelineStage Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Methods
VertexShaderPipelineStage Class See Also Send Feedback

The VertexShaderPipelineStage type exposes the following members.

Methods

 | Name | Description
Public method | GetConstantBuffers | Get the constant buffers used by the vertex shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::VSGetConstantBuffers)
Public method | GetSamplers | Get an array of sampler states from the vertex shader pipeline stage. (Also see DirectX SDK: ID3D11DeviceContext::VSGetSamplers)
Public method | GetShaderAndClasses | Get the vertex shader currently set on the device. (Also see DirectX SDK: ID3D11DeviceContext::VSGetShader)
Public method | GetShaderResources | Get the vertex shader resources. (Also see DirectX SDK: ID3D11DeviceContext::VSGetShaderResources)
Public method | SetConstantBuffers |
Public method | SetSamplers |
Public method | SetShader(ShaderAndClasses<(Of <<'(VertexShader>)>>)) |
Public method | SetShader(VertexShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |
Public method | SetShaderResources |

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..GetConstantBuffers Method
VertexShaderPipelineStage Class See Also Send Feedback
Get the constant buffers used by the vertex shader pipeline stage.

(Also see DirectX SDK: ID3D11DeviceContext::VSGetConstantBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<D3DBuffer> GetConstantBuffers(
    uint startSlot,
    uint bufferCount
)
Visual Basic
Public Function GetConstantBuffers ( _
    startSlot As UInteger, _
    bufferCount As UInteger _
) As ReadOnlyCollection(Of D3DBuffer)
Visual C++
public:
ReadOnlyCollection<D3DBuffer^>^ GetConstantBuffers(
    unsigned int startSlot,
    unsigned int bufferCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin retrieving constant buffers from (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - 1).
bufferCount
Type: System..::..UInt32
Number of buffers to retrieve (ranges from 0 to D3D11_COMMONSHADER_CONSTANT_BUFFER_API_SLOT_COUNT - startSlot).

Return Value

Collection of constant buffer objects (see D3DBuffer) to be returned by the method.

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DBuffer


GetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..GetSamplers Method
VertexShaderPipelineStage Class See Also Send Feedback
Get an array of sampler states from the vertex shader pipeline stage.

(Also see DirectX SDK: ID3D11DeviceContext::VSGetSamplers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<SamplerState> GetSamplers(
    uint startSlot,
    uint samplerCount
)
Visual Basic
Public Function GetSamplers ( _
    startSlot As UInteger, _
    samplerCount As UInteger _
) As ReadOnlyCollection(Of SamplerState)
Visual C++
public:
ReadOnlyCollection<SamplerState^>^ GetSamplers(
    unsigned int startSlot,
    unsigned int samplerCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into a zero-based array to begin getting samplers from (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - 1).
samplerCount
Type: System..::..UInt32
Number of samplers to get from a device context. Each pipeline stage has a total of 16 sampler slots available (ranges from 0 to D3D11_COMMONSHADER_SAMPLER_SLOT_COUNT - startSlot).

Return Value

Collection of sampler-state objects (see SamplerState) to be returned by the device.

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..SamplerState


GetShaderAndClasses Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..GetShaderAndClasses Method
VertexShaderPipelineStage Class See Also Send Feedback
Get the vertex shader currently set on the device.

(Also see DirectX SDK: ID3D11DeviceContext::VSGetShader)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ShaderAndClasses<VertexShader> GetShaderAndClasses(
    uint classInstanceCount
)
Visual Basic
Public Function GetShaderAndClasses ( _
    classInstanceCount As UInteger _
) As ShaderAndClasses(Of VertexShader)
Visual C++
public:
ShaderAndClasses<VertexShader^> GetShaderAndClasses(
    unsigned int classInstanceCount
)

Parameters

classInstanceCount
Type: System..::..UInt32
The number of class-instance elements requested.

Return Value

A VertexShader object and its classes (see VertexShader, ShaderAndClasses<(Of <(<'T>)>)>) , .

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexShader
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses<(Of <(<'T>)>)>


GetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..GetShaderResources Method
VertexShaderPipelineStage Class See Also Send Feedback
Get the vertex shader resources.

(Also see DirectX SDK: ID3D11DeviceContext::VSGetShaderResources)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<ShaderResourceView> GetShaderResources(
    uint startSlot,
    uint viewCount
)
Visual Basic
Public Function GetShaderResources ( _
    startSlot As UInteger, _
    viewCount As UInteger _
) As ReadOnlyCollection(Of ShaderResourceView)
Visual C++
public:
ReadOnlyCollection<ShaderResourceView^>^ GetShaderResources(
    unsigned int startSlot,
    unsigned int viewCount
)

Parameters

startSlot
Type: System..::..UInt32
Index into the device's zero-based array to begin getting shader resources from (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - 1).
viewCount
Type: System..::..UInt32
The number of resources to get from the device. Up to a maximum of 128 slots are available for shader resources (ranges from 0 to D3D11_COMMONSHADER_INPUT_RESOURCE_SLOT_COUNT - startSlot).

Return Value

Collection of shader resource views to be returned by the device.

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetConstantBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..SetConstantBuffers Method
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetConstantBuffers(
    uint startSlot,
    IEnumerable<D3DBuffer> constantBuffers
)
Visual Basic
Public Sub SetConstantBuffers ( _
    startSlot As UInteger, _
    constantBuffers As IEnumerable(Of D3DBuffer) _
)
Visual C++
public:
void SetConstantBuffers(
    unsigned int startSlot,
    IEnumerable<D3DBuffer^>^ constantBuffers
)

Parameters

startSlot
Type: System..::..UInt32
constantBuffers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' D3DBuffer >)>)>

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetSamplers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..SetSamplers Method
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetSamplers(
    uint startSlot,
    IEnumerable<SamplerState> samplers
)
Visual Basic
Public Sub SetSamplers ( _
    startSlot As UInteger, _
    samplers As IEnumerable(Of SamplerState) _
)
Visual C++
public:
void SetSamplers(
    unsigned int startSlot,
    IEnumerable<SamplerState^>^ samplers
)

Parameters

startSlot
Type: System..::..UInt32
samplers
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' SamplerState >)>)>

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..SetShader Method
VertexShaderPipelineStage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetShader(ShaderAndClasses<(Of <<'(VertexShader>)>>)) |
Public method | SetShader(VertexShader, IEnumerable<(Of <<'(ClassInstance>)>>)) |

See Also

VertexShaderPipelineStage Class
VertexShaderPipelineStage Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (ShaderAndClasses(VertexShader))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..SetShader Method (ShaderAndClasses<(Of <(<'VertexShader>)>)>)
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    ShaderAndClasses<VertexShader> shaderAndClasses
)
Visual Basic
Public Sub SetShader ( _
    shaderAndClasses As ShaderAndClasses(Of VertexShader) _
)
Visual C++
public:
void SetShader(
    ShaderAndClasses<VertexShader^> shaderAndClasses
)

Parameters

shaderAndClasses
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderAndClasses <(Of <(<' VertexShader >)>)>

See Also

VertexShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShader Method (VertexShader, IEnumerable(ClassInstance))

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..SetShader Method (VertexShader, IEnumerable<(Of <(<'ClassInstance>)>)>)
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShader(
    VertexShader vertexShader,
    IEnumerable<ClassInstance> classInstances
)
Visual Basic
Public Sub SetShader ( _
    vertexShader As VertexShader, _
    classInstances As IEnumerable(Of ClassInstance) _
)
Visual C++
public:
void SetShader(
    VertexShader^ vertexShader,
    IEnumerable<ClassInstance^>^ classInstances
)

Parameters

vertexShader
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexShader
classInstances
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ClassInstance >)>)>

See Also

VertexShaderPipelineStage Class
SetShader Overload
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


SetShaderResources Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..SetShaderResources Method
VertexShaderPipelineStage Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetShaderResources(
    uint startSlot,
    IEnumerable<ShaderResourceView> shaderResourceViews
)
Visual Basic
Public Sub SetShaderResources ( _
    startSlot As UInteger, _
    shaderResourceViews As IEnumerable(Of ShaderResourceView) _
)
Visual C++
public:
void SetShaderResources(
    unsigned int startSlot,
    IEnumerable<ShaderResourceView^>^ shaderResourceViews
)

Parameters

startSlot
Type: System..::..UInt32
shaderResourceViews
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' ShaderResourceView >)>)>

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


VertexShaderPipelineStage Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage Properties
VertexShaderPipelineStage Class See Also Send Feedback

The VertexShaderPipelineStage type exposes the following members.

Properties

 | Name | Description
Protected property | Parent | (Inherited from PipelineStage.)
Public property | Shader | Get the vertex shader currently set on the device. (See VertexShader). (Also see DirectX SDK: ID3D11DeviceContext::VSGetShader, ID3D11DeviceContext::VSSetShader) Passing in null disables the shader for this pipeline stage.

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Shader Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
VertexShaderPipelineStage..::..Shader Property
VertexShaderPipelineStage Class See Also Send Feedback
Get the vertex shader currently set on the device. (See VertexShader).

(Also see DirectX SDK: ID3D11DeviceContext::VSGetShader, ID3D11DeviceContext::VSSetShader)

Passing in null disables the shader for this pipeline stage.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public VertexShader Shader { get; set; }
Visual Basic
Public Property Shader As VertexShader
    Get
    Set
Visual C++
public:
property VertexShader^ Shader {
    VertexShader^ get ();
    void set (VertexShader^ value);
}

See Also

VertexShaderPipelineStage Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..VertexShader


View Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
View Class
Members See Also Send Feedback
A view specifies the parts of a resource the pipeline can access during rendering.

(Also see DirectX SDK: ID3D11View)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class View : DeviceChild
Visual Basic
Public Class View _
    Inherits DeviceChild
Visual C++
public ref class View : public DeviceChild

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DeviceChild
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..View
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..DepthStencilView
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..RenderTargetView
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..ShaderResourceView
Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..UnorderedAccessView

See Also

View Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


View Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
View Members
View Class Properties See Also Send Feedback

The View type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource)

See Also

View Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


View Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

 | Name | Description
Public property | Device | Get the device that created this object. (Also see DirectX SDK: ID3D11DeviceChild::GetDevice) (Inherited from DeviceChild.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Resource | Get the resource that is accessed through this view. (Also see DirectX SDK: ID3D11View::GetResource)

See Also

View Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Resource Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
View..::..Resource Property
View Class See Also Send Feedback
Get the resource that is accessed through this view.

(Also see DirectX SDK: ID3D11View::GetResource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DResource Resource { get; }
Visual Basic
Public ReadOnly Property Resource As D3DResource
    Get
Visual C++
public:
property D3DResource^ Resource {
    D3DResource^ get ();
}

See Also

View Class
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Viewport Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Structure
Members See Also Send Feedback
Defines the dimensions of a viewport.

(Also see DirectX SDK: D3D11_VIEWPORT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Viewport
Visual Basic
Public Structure Viewport
Visual C++
public value class Viewport

See Also

Viewport Members
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Viewport Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Members
Viewport Structure Methods Operators Properties See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Height | Height of the viewport. (Also see DirectX SDK: D3D11_VIEWPORT.Height)
Public property | MaxDepth | Maximum depth of the viewport. Ranges between 0 and 1. (Also see DirectX SDK: D3D11_VIEWPORT.MaxDepth)
Public property | MinDepth | Minimum depth of the viewport. Ranges between 0 and 1. (Also see DirectX SDK: D3D11_VIEWPORT.MinDepth)
Public property | TopLeftX | X position of the left hand side of the viewport. Ranges between D3D11_VIEWPORT_BOUNDS_MIN and D3D11_VIEWPORT_BOUNDS_MAX. (Also see DirectX SDK: D3D11_VIEWPORT.TopLeftX)
Public property | TopLeftY | Y position of the top of the viewport. Ranges between D3D11_VIEWPORT_BOUNDS_MIN and D3D11_VIEWPORT_BOUNDS_MAX. (Also see DirectX SDK: D3D11_VIEWPORT.TopLeftY)
Public property | Width | Width of the viewport. (Also see DirectX SDK: D3D11_VIEWPORT.Width)

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Viewport Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Methods
Viewport Structure See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Equals Method
Viewport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..GetHashCode Method
Viewport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Viewport Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Operators
Viewport Structure See Also Send Feedback

The Viewport type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Equality Operator
Viewport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Viewport viewport1,
    Viewport viewport2
)
Visual Basic
Public Shared Operator = ( _
    viewport1 As Viewport, _
    viewport2 As Viewport _
) As Boolean
Visual C++
public:
static bool operator ==(
    Viewport viewport1,
    Viewport viewport2
)

Parameters

viewport1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Viewport
viewport2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Viewport

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Inequality Operator
Viewport Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Viewport viewport1,
    Viewport viewport2
)
Visual Basic
Public Shared Operator <> ( _
    viewport1 As Viewport, _
    viewport2 As Viewport _
) As Boolean
Visual C++
public:
static bool operator !=(
    Viewport viewport1,
    Viewport viewport2
)

Parameters

viewport1
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Viewport
viewport2
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..Viewport

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Viewport Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport Properties
Viewport Structure See Also Send Feedback

The Viewport type exposes the following members.

Properties

 | Name | Description
Public property | Height | Height of the viewport. (Also see DirectX SDK: D3D11_VIEWPORT.Height)
Public property | MaxDepth | Maximum depth of the viewport. Ranges between 0 and 1. (Also see DirectX SDK: D3D11_VIEWPORT.MaxDepth)
Public property | MinDepth | Minimum depth of the viewport. Ranges between 0 and 1. (Also see DirectX SDK: D3D11_VIEWPORT.MinDepth)
Public property | TopLeftX | X position of the left hand side of the viewport. Ranges between D3D11_VIEWPORT_BOUNDS_MIN and D3D11_VIEWPORT_BOUNDS_MAX. (Also see DirectX SDK: D3D11_VIEWPORT.TopLeftX)
Public property | TopLeftY | Y position of the top of the viewport. Ranges between D3D11_VIEWPORT_BOUNDS_MIN and D3D11_VIEWPORT_BOUNDS_MAX. (Also see DirectX SDK: D3D11_VIEWPORT.TopLeftY)
Public property | Width | Width of the viewport. (Also see DirectX SDK: D3D11_VIEWPORT.Width)

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Height Property
Viewport Structure See Also Send Feedback
Height of the viewport.

(Also see DirectX SDK: D3D11_VIEWPORT.Height)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MaxDepth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..MaxDepth Property
Viewport Structure See Also Send Feedback
Maximum depth of the viewport. Ranges between 0 and 1.

(Also see DirectX SDK: D3D11_VIEWPORT.MaxDepth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MaxDepth { get; set; }
Visual Basic
Public Property MaxDepth As Single
    Get
    Set
Visual C++
public:
property float MaxDepth {
    float get ();
    void set (float value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


MinDepth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..MinDepth Property
Viewport Structure See Also Send Feedback
Minimum depth of the viewport. Ranges between 0 and 1.

(Also see DirectX SDK: D3D11_VIEWPORT.MinDepth)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MinDepth { get; set; }
Visual Basic
Public Property MinDepth As Single
    Get
    Set
Visual C++
public:
property float MinDepth {
    float get ();
    void set (float value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TopLeftX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..TopLeftX Property
Viewport Structure See Also Send Feedback
X position of the left hand side of the viewport. Ranges between D3D11_VIEWPORT_BOUNDS_MIN and D3D11_VIEWPORT_BOUNDS_MAX.

(Also see DirectX SDK: D3D11_VIEWPORT.TopLeftX)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float TopLeftX { get; set; }
Visual Basic
Public Property TopLeftX As Single
    Get
    Set
Visual C++
public:
property float TopLeftX {
    float get ();
    void set (float value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


TopLeftY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..TopLeftY Property
Viewport Structure See Also Send Feedback
Y position of the top of the viewport. Ranges between D3D11_VIEWPORT_BOUNDS_MIN and D3D11_VIEWPORT_BOUNDS_MAX.

(Also see DirectX SDK: D3D11_VIEWPORT.TopLeftY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float TopLeftY { get; set; }
Visual Basic
Public Property TopLeftY As Single
    Get
    Set
Visual C++
public:
property float TopLeftY {
    float get ();
    void set (float value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Viewport..::..Width Property
Viewport Structure See Also Send Feedback
Width of the viewport.

(Also see DirectX SDK: D3D11_VIEWPORT.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Direct3D11
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

Viewport Structure
Microsoft.WindowsAPICodePack.DirectX.Direct3D11 Namespace


Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace
Send Feedback
DirectWrite APIs and Types.

Classes

 | Class | Description
Public class | DWriteFactory | The root factory interface for all DWrite objects. (Also see DirectX SDK: IDWriteFactory)
Public class | Font | The Font represents a physical font in a font collection. (Also see DirectX SDK: IDWriteFont)
Public class | FontFace | Represents an absolute reference to a font face. It contains font face type, appropriate file references and face identification data. Various font data such as metrics, names and glyph outlines is obtained from FontFace.
Public class | FontFamily | The FontFamily represents a set of fonts that share the same design but are differentiated by weight, stretch, and style. (Also see DirectX SDK: IDWriteFontFamily)
Public class | FontFamilyCollection | A collection of FontFamily Objects. A FontFamily represents a set of fonts that share the same design but are differentiated by weight, stretch, and style. FontFamily (Also see DirectX SDK: IDWriteFontFamily)
Public class | InlineObject | Wraps an inline graphic. (Also see DirectX SDK: IDWriteInlineObject)
Public class | RenderingParams | Represents text rendering settings such as ClearType level, enhanced contrast, and gamma correction for glyph rasterization and filtering. (Also see DirectX SDK: IDWriteRenderingParams)
Public class | TextFormat | The format of text used for text layout purpose. (Also see DirectX SDK: IDWriteTextFormat)
Public class | TextLayout | Represents a block of text after it has been fully analyzed and formatted. All coordinates are in device independent pixels (DIPs). (Also see DirectX SDK: IDWriteTextLayout)
Public class | TypographySettingCollection | Represents a collection of OpenType font typography settings (FontFeature). (Also see DirectX SDK: IDWriteTypography)

Structures

 | Structure | Description
Public structure | ClusterMetrics | Contains information about a glyph cluster.
Public structure | FontFeature | The FontFeature structure specifies properties used to identify and execute typographic feature in the font.
Public structure | FontMetrics | Specifies the metrics of a font face that are applicable to all glyphs within the font face.
Public structure | GlyphMetrics | The GlyphMetrics structure specifies the metrics of an individual glyph. The units depend on how the metrics are obtained.
Public structure | GlyphOffset | Optional adjustment to a glyph's position. An glyph offset changes the position of a glyph without affecting the pen position. Offsets are in logical, pre-transform units.
Public structure | GlyphRun | Contains the information needed by renderers to draw glyph runs. All coordinates are in device independent pixels (DIPs).
Public structure | HitTestInfo |
Public structure | HitTestMetrics | Geometry enclosing of text positions.
Public structure | InlineObjectMetrics | Properties describing the geometric measurement of an application-defined inline object.
Public structure | LineMetrics | Contains information about a formatted line of text.
Public structure | LineSpacing | Line spacing parameters.
Public structure | OverhangMetrics | Holds information about how much any visible pixels (in DIPs) overshoot each side of the layout or inline objects.
Public structure | TextMetrics | Overall metrics associated with text after layout. All coordinates are in device independent pixels (DIPs).
Public structure | TextRange | Specifies a range of text positions where format is applied.
Public structure | TextRangeOf<(Of <(<'T>)>)> |
Public structure | Trimming | Specifies the trimming option for text overflowing the layout box.
Public structure | TrimmingWithSign |

Interfaces

 | Interface | Description
Public interface | ICustomInlineObject | Wraps an application defined inline graphic, allowing DWrite to query metrics as if it was a glyph inline with the text. (Also see DirectX SDK: IDWriteInlineObject)

Enumerations

 | Enumeration | Description
Public enumeration | BreakCondition | Condition at the edges of inline object or text used to determine line-breaking behavior.
Public enumeration | DWriteFactoryType | Specifies the type of DirectWrite factory object. DirectWrite factory contains internal state such as font loader registration and cached font data. In most cases it is recommended to use the shared factory object, because it allows multiple components that use DirectWrite to share internal DirectWrite state and reduce memory usage. However, there are cases when it is desirable to reduce the impact of a component, such as a plug-in from an untrusted source, on the rest of the process by sandboxing and isolating it from the rest of the process components. In such cases, it is recommended to use an isolated factory for the sandboxed component.
Public enumeration | FlowDirection | Direction for how lines of text are placed relative to one another.
Public enumeration | FontFaceType | The file format of a complete font face. Font formats that consist of multiple files, e.g. Type 1 .PFM and .PFB, have a single enum entry.
Public enumeration | FontFeatureTag | Typographic feature of text supplied by the font.
Public enumeration | FontFileType | The type of a font represented by a single font file. Font formats that consist of multiple files, e.g. Type 1 .PFM and .PFB, have separate enum values for each of the file type.
Public enumeration | FontSimulations | Specifies algorithmic style simulations to be applied to the font face. Bold and oblique simulations can be combined via bitwise OR operation.
Public enumeration | FontStretch | The font stretch enumeration describes relative change from the normal aspect ratio as specified by a font designer for the glyphs in a font. Values less than 1 or greater than 9 are considered to be invalid, and they are rejected by font API functions.
Public enumeration | FontStyle | The font style enumeration describes the slope style of a font face, such as Normal, Italic or Oblique. Values other than the ones defined in the enumeration are considered to be invalid, and they are rejected by font API functions.
Public enumeration | FontWeight | The font weight enumeration describes common values for degree of blackness or thickness of strokes of characters in a font. Font weight values less than 1 or greater than 999 are considered to be invalid, and they are rejected by font API functions.
Public enumeration | InformationalStringId | The informational string enumeration identifies a string in a font.
Public enumeration | LineSpacingMethod | The method used for line spacing in layout.
Public enumeration | MeasuringMode | The measuring method used for text layout.
Public enumeration | ParagraphAlignment | Alignment of paragraph text along the flow direction axis relative to the flow's beginning and ending edge of the layout box.
Public enumeration | PixelGeometry | Represents the internal structure of a device pixel (i.e., the physical arrangement of red, green, and blue color components) that is assumed for purposes of rendering text.
Public enumeration | ReadingDirection | Direction for how reading progresses.
Public enumeration | RenderingMode | Represents a method of rendering glyphs.
Public enumeration | TextAlignment | Alignment of paragraph text along the reading direction axis relative to the leading and trailing edge of the layout box.
Public enumeration | TrimmingGranularity | Text granularity used to trim text overflowing the layout box.
Public enumeration | WordWrapping | Word wrapping in multiline paragraph.


BreakCondition Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BreakCondition Enumeration
See Also Send Feedback
Condition at the edges of inline object or text used to determine line-breaking behavior.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum BreakCondition
Visual Basic
Public Enumeration BreakCondition
Visual C++
public enum class BreakCondition

Members

Member name | Description
MustBreak |
MayNotBreak |
CanBreak |
Neutral |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ClusterMetrics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics Structure
Members See Also Send Feedback
Contains information about a glyph cluster.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ClusterMetrics
Visual Basic
Public Structure ClusterMetrics
Visual C++
public value class ClusterMetrics

See Also

ClusterMetrics Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ClusterMetrics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics Members
ClusterMetrics Structure Constructors Methods Operators Properties See Also Send Feedback

The ClusterMetrics type exposes the following members.

Constructors

 | Name | Description
Public method | ClusterMetrics | Constructor for ClusterMetrics

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | CanWrapLineAfter | Indicate whether line can be broken right after the cluster.
Public property | IsNewline | Indicate whether the cluster corresponds to a newline character.
Public property | IsRightToLeft | Indicate whether the cluster is read from right to left.
Public property | IsSoftHyphen | Indicate whether the cluster corresponds to soft hyphen character.
Public property | IsWhitespace | Indicate whether the cluster corresponds to whitespace character.
Public property | Length | The number of text positions in the cluster.
Public property | Width | The total advance width of all glyphs in the cluster.

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ClusterMetrics Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics Constructor
ClusterMetrics Structure See Also Send Feedback
Constructor for ClusterMetrics

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ClusterMetrics(
    float width,
    ushort length,
    bool canWrapLineAfter,
    bool isWhitespace,
    bool isNewline,
    bool isSoftHyphen,
    bool isRightToLeft
)
Visual Basic
Public Sub New ( _
    width As Single, _
    length As UShort, _
    canWrapLineAfter As Boolean, _
    isWhitespace As Boolean, _
    isNewline As Boolean, _
    isSoftHyphen As Boolean, _
    isRightToLeft As Boolean _
)
Visual C++
public:
ClusterMetrics(
    float width,
    unsigned short length,
    bool canWrapLineAfter,
    bool isWhitespace,
    bool isNewline,
    bool isSoftHyphen,
    bool isRightToLeft
)

Parameters

width
Type: System..::..Single
length
Type: System..::..UInt16
canWrapLineAfter
Type: System..::..Boolean
isWhitespace
Type: System..::..Boolean
isNewline
Type: System..::..Boolean
isSoftHyphen
Type: System..::..Boolean
isRightToLeft
Type: System..::..Boolean

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ClusterMetrics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics Methods
ClusterMetrics Structure See Also Send Feedback

The ClusterMetrics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..Equals Method
ClusterMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..GetHashCode Method
ClusterMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ClusterMetrics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics Operators
ClusterMetrics Structure See Also Send Feedback

The ClusterMetrics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..Equality Operator
ClusterMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ClusterMetrics clusterMetrics1,
    ClusterMetrics clusterMetrics2
)
Visual Basic
Public Shared Operator = ( _
    clusterMetrics1 As ClusterMetrics, _
    clusterMetrics2 As ClusterMetrics _
) As Boolean
Visual C++
public:
static bool operator ==(
    ClusterMetrics clusterMetrics1,
    ClusterMetrics clusterMetrics2
)

Parameters

clusterMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..ClusterMetrics
clusterMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..ClusterMetrics

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..Inequality Operator
ClusterMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ClusterMetrics clusterMetrics1,
    ClusterMetrics clusterMetrics2
)
Visual Basic
Public Shared Operator <> ( _
    clusterMetrics1 As ClusterMetrics, _
    clusterMetrics2 As ClusterMetrics _
) As Boolean
Visual C++
public:
static bool operator !=(
    ClusterMetrics clusterMetrics1,
    ClusterMetrics clusterMetrics2
)

Parameters

clusterMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..ClusterMetrics
clusterMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..ClusterMetrics

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ClusterMetrics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics Properties
ClusterMetrics Structure See Also Send Feedback

The ClusterMetrics type exposes the following members.

Properties

 | Name | Description
Public property | CanWrapLineAfter | Indicate whether line can be broken right after the cluster.
Public property | IsNewline | Indicate whether the cluster corresponds to a newline character.
Public property | IsRightToLeft | Indicate whether the cluster is read from right to left.
Public property | IsSoftHyphen | Indicate whether the cluster corresponds to soft hyphen character.
Public property | IsWhitespace | Indicate whether the cluster corresponds to whitespace character.
Public property | Length | The number of text positions in the cluster.
Public property | Width | The total advance width of all glyphs in the cluster.

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CanWrapLineAfter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..CanWrapLineAfter Property
ClusterMetrics Structure See Also Send Feedback
Indicate whether line can be broken right after the cluster.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool CanWrapLineAfter { get; set; }
Visual Basic
Public Property CanWrapLineAfter As Boolean
    Get
    Set
Visual C++
public:
property bool CanWrapLineAfter {
    bool get ();
    void set (bool value);
}

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsNewline Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..IsNewline Property
ClusterMetrics Structure See Also Send Feedback
Indicate whether the cluster corresponds to a newline character.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsNewline { get; set; }
Visual Basic
Public Property IsNewline As Boolean
    Get
    Set
Visual C++
public:
property bool IsNewline {
    bool get ();
    void set (bool value);
}

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsRightToLeft Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..IsRightToLeft Property
ClusterMetrics Structure See Also Send Feedback
Indicate whether the cluster is read from right to left.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsRightToLeft { get; set; }
Visual Basic
Public Property IsRightToLeft As Boolean
    Get
    Set
Visual C++
public:
property bool IsRightToLeft {
    bool get ();
    void set (bool value);
}

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsSoftHyphen Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..IsSoftHyphen Property
ClusterMetrics Structure See Also Send Feedback
Indicate whether the cluster corresponds to soft hyphen character.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsSoftHyphen { get; set; }
Visual Basic
Public Property IsSoftHyphen As Boolean
    Get
    Set
Visual C++
public:
property bool IsSoftHyphen {
    bool get ();
    void set (bool value);
}

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsWhitespace Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..IsWhitespace Property
ClusterMetrics Structure See Also Send Feedback
Indicate whether the cluster corresponds to whitespace character.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsWhitespace { get; set; }
Visual Basic
Public Property IsWhitespace As Boolean
    Get
    Set
Visual C++
public:
property bool IsWhitespace {
    bool get ();
    void set (bool value);
}

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Length Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..Length Property
ClusterMetrics Structure See Also Send Feedback
The number of text positions in the cluster.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort Length { get; set; }
Visual Basic
Public Property Length As UShort
    Get
    Set
Visual C++
public:
property unsigned short Length {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ClusterMetrics..::..Width Property
ClusterMetrics Structure See Also Send Feedback
The total advance width of all glyphs in the cluster.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

ClusterMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


DWriteFactory Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory Class
Members See Also Send Feedback
The root factory interface for all DWrite objects.

(Also see DirectX SDK: IDWriteFactory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DWriteFactory : DirectUnknown
Visual Basic
Public Class DWriteFactory _
    Inherits DirectUnknown
Visual C++
public ref class DWriteFactory : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..DWriteFactory

See Also

DWriteFactory Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


DWriteFactory Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory Members
DWriteFactory Class Methods Properties See Also Send Feedback

The DWriteFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateCustomRenderingParams | Creates a rendering parameters object with the specified properties.
Public method | CreateEllipsisTrimmingSign | The application may call this function to create an inline object for trimming, using an ellipsis as the omission sign. The ellipsis will be created using the current settings of the format, including base font, style, and any effects. Alternate omission signs can be created by the application by implementing ICustomInlineObject.
 | CreateFactory()()()() | Creates a DirectWrite factory object that is used for subsequent creation of individual DirectWrite objects. This method uses Shared FactoryType. (Also see DirectX SDK: DWriteCreateFactory)
 | CreateFactory(DWriteFactoryType) | Creates a DirectWrite factory object that is used for subsequent creation of individual DirectWrite objects. (Also see DirectX SDK: DWriteCreateFactory)
Public method | CreateFontFaceFromFontFile(String) | Creates a font face from a given TrueType font file. This method will load only a TrueType font file with no font simulations applied.
Public method | CreateFontFaceFromFontFile(String, FontFaceType, UInt32, FontSimulations) | Creates a font face from a given a font file.
Public method | CreateGdiCompatibleTextLayout(String, TextFormat, Single, Single, Single, Boolean) | CreateGdiCompatibleTextLayout takes a string, format, and associated constraints and produces and object representing the result formatted for a particular display resolution and measuring method. The resulting text layout should only be used for the intended resolution, and for cases where text scalability is desired, CreateTextLayout should be used instead.
Public method | CreateGdiCompatibleTextLayout(String, TextFormat, Single, Single, Single, Boolean, Matrix3x2F) | CreateGdiCompatibleTextLayout takes a string, format, and associated constraints and produces and object representing the result formatted for a particular display resolution and measuring method. The resulting text layout should only be used for the intended resolution, and for cases where text scalability is desired, CreateTextLayout should be used instead.
Public method | CreateMonitorRenderingParams | Creates a rendering parameters object with default settings for the specified monitor.
Public method | CreateRenderingParams | Creates a rendering parameters object with default settings for the primary monitor.
Public method | CreateTextFormat(String, Single) | Create a text format object used for text layout using default font weight, style and stretch.
Public method | CreateTextFormat(String, Single, FontWeight, FontStyle, FontStretch) | Create a text format object used for text layout
Public method | CreateTextFormat(String, Single, FontWeight, FontStyle, FontStretch, CultureInfo) | Create a text format object used for text layout.
Public method | CreateTextLayout | CreateTextLayout takes a string, format, and associated constraints and produces and object representing the fully analyzed and formatted result.
Public method | CreateTypography | Creates a typography object used in conjunction with text format for text layout.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SystemFontFamilyCollection | Gets a font family collection representing the set of installed fonts.

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


DWriteFactory Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory Methods
DWriteFactory Class See Also Send Feedback

The DWriteFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateCustomRenderingParams | Creates a rendering parameters object with the specified properties.
Public method | CreateEllipsisTrimmingSign | The application may call this function to create an inline object for trimming, using an ellipsis as the omission sign. The ellipsis will be created using the current settings of the format, including base font, style, and any effects. Alternate omission signs can be created by the application by implementing ICustomInlineObject.
 | CreateFactory()()()() | Creates a DirectWrite factory object that is used for subsequent creation of individual DirectWrite objects. This method uses Shared FactoryType. (Also see DirectX SDK: DWriteCreateFactory)
 | CreateFactory(DWriteFactoryType) | Creates a DirectWrite factory object that is used for subsequent creation of individual DirectWrite objects. (Also see DirectX SDK: DWriteCreateFactory)
Public method | CreateFontFaceFromFontFile(String) | Creates a font face from a given TrueType font file. This method will load only a TrueType font file with no font simulations applied.
Public method | CreateFontFaceFromFontFile(String, FontFaceType, UInt32, FontSimulations) | Creates a font face from a given a font file.
Public method | CreateGdiCompatibleTextLayout(String, TextFormat, Single, Single, Single, Boolean) | CreateGdiCompatibleTextLayout takes a string, format, and associated constraints and produces and object representing the result formatted for a particular display resolution and measuring method. The resulting text layout should only be used for the intended resolution, and for cases where text scalability is desired, CreateTextLayout should be used instead.
Public method | CreateGdiCompatibleTextLayout(String, TextFormat, Single, Single, Single, Boolean, Matrix3x2F) | CreateGdiCompatibleTextLayout takes a string, format, and associated constraints and produces and object representing the result formatted for a particular display resolution and measuring method. The resulting text layout should only be used for the intended resolution, and for cases where text scalability is desired, CreateTextLayout should be used instead.
Public method | CreateMonitorRenderingParams | Creates a rendering parameters object with default settings for the specified monitor.
Public method | CreateRenderingParams | Creates a rendering parameters object with default settings for the primary monitor.
Public method | CreateTextFormat(String, Single) | Create a text format object used for text layout using default font weight, style and stretch.
Public method | CreateTextFormat(String, Single, FontWeight, FontStyle, FontStretch) | Create a text format object used for text layout
Public method | CreateTextFormat(String, Single, FontWeight, FontStyle, FontStretch, CultureInfo) | Create a text format object used for text layout.
Public method | CreateTextLayout | CreateTextLayout takes a string, format, and associated constraints and produces and object representing the fully analyzed and formatted result.
Public method | CreateTypography | Creates a typography object used in conjunction with text format for text layout.

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateCustomRenderingParams Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateCustomRenderingParams Method
DWriteFactory Class See Also Send Feedback
Creates a rendering parameters object with the specified properties.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderingParams CreateCustomRenderingParams(
    float gamma,
    float enhancedContrast,
    float clearTypeLevel,
    PixelGeometry pixelGeometry,
    RenderingMode renderingMode
)
Visual Basic
Public Function CreateCustomRenderingParams ( _
    gamma As Single, _
    enhancedContrast As Single, _
    clearTypeLevel As Single, _
    pixelGeometry As PixelGeometry, _
    renderingMode As RenderingMode _
) As RenderingParams
Visual C++
public:
RenderingParams^ CreateCustomRenderingParams(
    float gamma,
    float enhancedContrast,
    float clearTypeLevel,
    PixelGeometry pixelGeometry,
    RenderingMode renderingMode
)

Parameters

gamma
Type: System..::..Single
The gamma value used for gamma correction, which must be greater than zero and cannot exceed 256.
enhancedContrast
Type: System..::..Single
The amount of contrast enhancement, zero or greater.
clearTypeLevel
Type: System..::..Single
The degree of ClearType level, from 0.0f (no ClearType) to 1.0f (full ClearType).
pixelGeometry
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..PixelGeometry
The geometry of a device pixel.
renderingMode
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..RenderingMode
Method of rendering glyphs. In most cases, this should be Default to automatically use an appropriate mode.

Return Value

The newly created rendering parameters object, or NULL in case of failure.

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateEllipsisTrimmingSign Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateEllipsisTrimmingSign Method
DWriteFactory Class See Also Send Feedback
The application may call this function to create an inline object for trimming, using an ellipsis as the omission sign. The ellipsis will be created using the current settings of the format, including base font, style, and any effects. Alternate omission signs can be created by the application by implementing ICustomInlineObject.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InlineObject CreateEllipsisTrimmingSign(
    TextFormat textFormat
)
Visual Basic
Public Function CreateEllipsisTrimmingSign ( _
    textFormat As TextFormat _
) As InlineObject
Visual C++
public:
InlineObject^ CreateEllipsisTrimmingSign(
    TextFormat^ textFormat
)

Parameters

textFormat
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
The format to use for settings.

Return Value

Created omission sign.

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateFactory Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateFactory Method
DWriteFactory Class See Also Send Feedback

Overload List

Name | Description
CreateFactory()()()() | Creates a DirectWrite factory object that is used for subsequent creation of individual DirectWrite objects. This method uses Shared FactoryType. (Also see DirectX SDK: DWriteCreateFactory)
CreateFactory(DWriteFactoryType) | Creates a DirectWrite factory object that is used for subsequent creation of individual DirectWrite objects. (Also see DirectX SDK: DWriteCreateFactory)

See Also

DWriteFactory Class
DWriteFactory Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateFactory Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateFactory Method
DWriteFactory Class See Also Send Feedback
Creates a DirectWrite factory object that is used for subsequent creation of individual DirectWrite objects. This method uses Shared FactoryType.

(Also see DirectX SDK: DWriteCreateFactory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static DWriteFactory CreateFactory()
Visual Basic
Public Shared Function CreateFactory As DWriteFactory
Visual C++
public:
static DWriteFactory^ CreateFactory()

Return Value

The newly created DirectWrite factory object

See Also

DWriteFactory Class
CreateFactory Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateFactory Method (DWriteFactoryType)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateFactory Method (DWriteFactoryType)
DWriteFactory Class See Also Send Feedback
Creates a DirectWrite factory object that is used for subsequent creation of individual DirectWrite objects.

(Also see DirectX SDK: DWriteCreateFactory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static DWriteFactory CreateFactory(
    DWriteFactoryType factoryType
)
Visual Basic
Public Shared Function CreateFactory ( _
    factoryType As DWriteFactoryType _
) As DWriteFactory
Visual C++
public:
static DWriteFactory^ CreateFactory(
    DWriteFactoryType factoryType
)

Parameters

factoryType
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..DWriteFactoryType
Specifies whether the factory object will be shared or isolated.

Return Value

The newly created DirectWrite factory object

See Also

DWriteFactory Class
CreateFactory Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateFontFaceFromFontFile Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateFontFaceFromFontFile Method
DWriteFactory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateFontFaceFromFontFile(String) | Creates a font face from a given TrueType font file. This method will load only a TrueType font file with no font simulations applied.
Public method | CreateFontFaceFromFontFile(String, FontFaceType, UInt32, FontSimulations) | Creates a font face from a given a font file.

See Also

DWriteFactory Class
DWriteFactory Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateFontFaceFromFontFile Method (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateFontFaceFromFontFile Method (String)
DWriteFactory Class See Also Send Feedback
Creates a font face from a given TrueType font file. This method will load only a TrueType font file with no font simulations applied.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFace CreateFontFaceFromFontFile(
    string fontFileName
)
Visual Basic
Public Function CreateFontFaceFromFontFile ( _
    fontFileName As String _
) As FontFace
Visual C++
public:
FontFace^ CreateFontFaceFromFontFile(
    String^ fontFileName
)

Parameters

fontFileName
Type: System..::..String
The input font file.

Return Value

A FontFace object.

See Also

DWriteFactory Class
CreateFontFaceFromFontFile Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateFontFaceFromFontFile Method (String, FontFaceType, UInt32, FontSimulations)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateFontFaceFromFontFile Method (String, FontFaceType, UInt32, FontSimulations)
DWriteFactory Class See Also Send Feedback
Creates a font face from a given a font file.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFace CreateFontFaceFromFontFile(
    string fontFileName,
    FontFaceType fontFaceType,
    uint faceIndex,
    FontSimulations faceSimulations
)
Visual Basic
Public Function CreateFontFaceFromFontFile ( _
    fontFileName As String, _
    fontFaceType As FontFaceType, _
    faceIndex As UInteger, _
    faceSimulations As FontSimulations _
) As FontFace
Visual C++
public:
FontFace^ CreateFontFaceFromFontFile(
    String^ fontFileName,
    FontFaceType fontFaceType,
    unsigned int faceIndex,
    FontSimulations faceSimulations
)

Parameters

fontFileName
Type: System..::..String
The input font file.
fontFaceType
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFaceType
The file format of the font face.
faceIndex
Type: System..::..UInt32
The zero based index of a font face in cases when the font files contain a collection of font faces. If the font files contain a single face, this value should be zero.
faceSimulations
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontSimulations
Font face simulation flags for algorithmic emboldening and italicization.

Return Value

A FontFace object.

See Also

DWriteFactory Class
CreateFontFaceFromFontFile Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateGdiCompatibleTextLayout Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateGdiCompatibleTextLayout Method
DWriteFactory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateGdiCompatibleTextLayout(String, TextFormat, Single, Single, Single, Boolean) | CreateGdiCompatibleTextLayout takes a string, format, and associated constraints and produces and object representing the result formatted for a particular display resolution and measuring method. The resulting text layout should only be used for the intended resolution, and for cases where text scalability is desired, CreateTextLayout should be used instead.
Public method | CreateGdiCompatibleTextLayout(String, TextFormat, Single, Single, Single, Boolean, Matrix3x2F) | CreateGdiCompatibleTextLayout takes a string, format, and associated constraints and produces and object representing the result formatted for a particular display resolution and measuring method. The resulting text layout should only be used for the intended resolution, and for cases where text scalability is desired, CreateTextLayout should be used instead.

See Also

DWriteFactory Class
DWriteFactory Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateGdiCompatibleTextLayout Method (String, TextFormat, Single, Single, Single, Boolean)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateGdiCompatibleTextLayout Method (String, TextFormat, Single, Single, Single, Boolean)
DWriteFactory Class See Also Send Feedback
CreateGdiCompatibleTextLayout takes a string, format, and associated constraints and produces and object representing the result formatted for a particular display resolution and measuring method. The resulting text layout should only be used for the intended resolution, and for cases where text scalability is desired, CreateTextLayout should be used instead.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextLayout CreateGdiCompatibleTextLayout(
    string text,
    TextFormat textFormat,
    float layoutWidth,
    float layoutHeight,
    float pixelsPerDip,
    bool useGdiNatural
)
Visual Basic
Public Function CreateGdiCompatibleTextLayout ( _
    text As String, _
    textFormat As TextFormat, _
    layoutWidth As Single, _
    layoutHeight As Single, _
    pixelsPerDip As Single, _
    useGdiNatural As Boolean _
) As TextLayout
Visual C++
public:
TextLayout^ CreateGdiCompatibleTextLayout(
    String^ text,
    TextFormat^ textFormat,
    float layoutWidth,
    float layoutHeight,
    float pixelsPerDip,
    bool useGdiNatural
)

Parameters

text
Type: System..::..String
The characters to layout.
textFormat
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
The format to apply to the string.
layoutWidth
Type: System..::..Single
Width of the layout box.
layoutHeight
Type: System..::..Single
Height of the layout box.
pixelsPerDip
Type: System..::..Single
Number of physical pixels per DIP. For example, if rendering onto a 96 DPI device then pixelsPerDip is 1. If rendering onto a 120 DPI device then pixelsPerDip is 120/96.
useGdiNatural
Type: System..::..Boolean
When set to False, instructs the text layout to use the same metrics as GDI aliased text. When set to True, instructs the text layout to use the same metrics as text measured by GDI using a font created with CleartypeNaturalQuality.

Return Value

The resultant TextLayout object.

See Also

DWriteFactory Class
CreateGdiCompatibleTextLayout Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateGdiCompatibleTextLayout Method (String, TextFormat, Single, Single, Single, Boolean, Matrix3x2F)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateGdiCompatibleTextLayout Method (String, TextFormat, Single, Single, Single, Boolean, Matrix3x2F)
DWriteFactory Class See Also Send Feedback
CreateGdiCompatibleTextLayout takes a string, format, and associated constraints and produces and object representing the result formatted for a particular display resolution and measuring method. The resulting text layout should only be used for the intended resolution, and for cases where text scalability is desired, CreateTextLayout should be used instead.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextLayout CreateGdiCompatibleTextLayout(
    string text,
    TextFormat textFormat,
    float layoutWidth,
    float layoutHeight,
    float pixelsPerDip,
    bool useGdiNatural,
    Matrix3x2F transform
)
Visual Basic
Public Function CreateGdiCompatibleTextLayout ( _
    text As String, _
    textFormat As TextFormat, _
    layoutWidth As Single, _
    layoutHeight As Single, _
    pixelsPerDip As Single, _
    useGdiNatural As Boolean, _
    transform As Matrix3x2F _
) As TextLayout
Visual C++
public:
TextLayout^ CreateGdiCompatibleTextLayout(
    String^ text,
    TextFormat^ textFormat,
    float layoutWidth,
    float layoutHeight,
    float pixelsPerDip,
    bool useGdiNatural,
    Matrix3x2F transform
)

Parameters

text
Type: System..::..String
The characters to layout.
textFormat
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
The format to apply to the string.
layoutWidth
Type: System..::..Single
Width of the layout box.
layoutHeight
Type: System..::..Single
Height of the layout box.
pixelsPerDip
Type: System..::..Single
Number of physical pixels per DIP. For example, if rendering onto a 96 DPI device then pixelsPerDip is 1. If rendering onto a 120 DPI device then pixelsPerDip is 120/96.
useGdiNatural
Type: System..::..Boolean
When set to False, instructs the text layout to use the same metrics as GDI aliased text. When set to True, instructs the text layout to use the same metrics as text measured by GDI using a font created with NaturalQuality.
transform
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Matrix3x2F
Transform applied to the glyphs and their positions. This transform is applied after the scaling specified the font size and pixelsPerDip.

Return Value

The resultant TextLayout object.

See Also

DWriteFactory Class
CreateGdiCompatibleTextLayout Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateMonitorRenderingParams Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateMonitorRenderingParams Method
DWriteFactory Class See Also Send Feedback
Creates a rendering parameters object with default settings for the specified monitor.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderingParams CreateMonitorRenderingParams(
    IntPtr monitorHandle
)
Visual Basic
Public Function CreateMonitorRenderingParams ( _
    monitorHandle As IntPtr _
) As RenderingParams
Visual C++
public:
RenderingParams^ CreateMonitorRenderingParams(
    IntPtr monitorHandle
)

Parameters

monitorHandle
Type: System..::..IntPtr
A handle for the specified monitor.

Return Value

The newly created rendering parameters object, or NULL in case of failure.

Remarks

To obtain a handle to a monitor use Graphics Output.Description property or Win32 MonitorFromWindow() API to obtain a handle for the desired monitor.

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateRenderingParams Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateRenderingParams Method
DWriteFactory Class See Also Send Feedback
Creates a rendering parameters object with default settings for the primary monitor.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderingParams CreateRenderingParams()
Visual Basic
Public Function CreateRenderingParams As RenderingParams
Visual C++
public:
RenderingParams^ CreateRenderingParams()

Return Value

The newly created rendering parameters object, or NULL in case of failure.

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateTextFormat Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateTextFormat Method
DWriteFactory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTextFormat(String, Single) | Create a text format object used for text layout using default font weight, style and stretch.
Public method | CreateTextFormat(String, Single, FontWeight, FontStyle, FontStretch) | Create a text format object used for text layout
Public method | CreateTextFormat(String, Single, FontWeight, FontStyle, FontStretch, CultureInfo) | Create a text format object used for text layout.

See Also

DWriteFactory Class
DWriteFactory Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateTextFormat Method (String, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateTextFormat Method (String, Single)
DWriteFactory Class See Also Send Feedback
Create a text format object used for text layout using default font weight, style and stretch.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextFormat CreateTextFormat(
    string fontFamilyName,
    float fontSize
)
Visual Basic
Public Function CreateTextFormat ( _
    fontFamilyName As String, _
    fontSize As Single _
) As TextFormat
Visual C++
public:
TextFormat^ CreateTextFormat(
    String^ fontFamilyName,
    float fontSize
)

Parameters

fontFamilyName
Type: System..::..String
Name of the font family
fontSize
Type: System..::..Single
Logical size of the font in DIP units. A DIP ("device-independent pixel") equals 1/96 inch.

Return Value

Newly created text format object, or null in case of failure.

See Also

DWriteFactory Class
CreateTextFormat Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateTextFormat Method (String, Single, FontWeight, FontStyle, FontStretch)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateTextFormat Method (String, Single, FontWeight, FontStyle, FontStretch)
DWriteFactory Class See Also Send Feedback
Create a text format object used for text layout

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextFormat CreateTextFormat(
    string fontFamilyName,
    float fontSize,
    FontWeight fontWeight,
    FontStyle fontStyle,
    FontStretch fontStretch
)
Visual Basic
Public Function CreateTextFormat ( _
    fontFamilyName As String, _
    fontSize As Single, _
    fontWeight As FontWeight, _
    fontStyle As FontStyle, _
    fontStretch As FontStretch _
) As TextFormat
Visual C++
public:
TextFormat^ CreateTextFormat(
    String^ fontFamilyName,
    float fontSize,
    FontWeight fontWeight,
    FontStyle fontStyle,
    FontStretch fontStretch
)

Parameters

fontFamilyName
Type: System..::..String
Name of the font family
fontSize
Type: System..::..Single
Logical size of the font in DIP units. A DIP ("device-independent pixel") equals 1/96 inch.
fontWeight
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontWeight
Font weight
fontStyle
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontStyle
Font style
fontStretch
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontStretch
Font stretch

Return Value

Newly created text format object, or null in case of failure.

See Also

DWriteFactory Class
CreateTextFormat Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateTextFormat Method (String, Single, FontWeight, FontStyle, FontStretch, CultureInfo)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateTextFormat Method (String, Single, FontWeight, FontStyle, FontStretch, CultureInfo)
DWriteFactory Class See Also Send Feedback
Create a text format object used for text layout.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextFormat CreateTextFormat(
    string fontFamilyName,
    float fontSize,
    FontWeight fontWeight,
    FontStyle fontStyle,
    FontStretch fontStretch,
    CultureInfo cultureInfo
)
Visual Basic
Public Function CreateTextFormat ( _
    fontFamilyName As String, _
    fontSize As Single, _
    fontWeight As FontWeight, _
    fontStyle As FontStyle, _
    fontStretch As FontStretch, _
    cultureInfo As CultureInfo _
) As TextFormat
Visual C++
public:
TextFormat^ CreateTextFormat(
    String^ fontFamilyName,
    float fontSize,
    FontWeight fontWeight,
    FontStyle fontStyle,
    FontStretch fontStretch,
    CultureInfo^ cultureInfo
)

Parameters

fontFamilyName
Type: System..::..String
Name of the font family
fontSize
Type: System..::..Single
Logical size of the font in DIP units. A DIP ("device-independent pixel") equals 1/96 inch.
fontWeight
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontWeight
Font weight
fontStyle
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontStyle
Font style
fontStretch
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontStretch
Font stretch
cultureInfo
Type: System.Globalization..::..CultureInfo
Culture info

Return Value

Newly created text format object, or null in case of failure.

See Also

DWriteFactory Class
CreateTextFormat Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateTextLayout Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateTextLayout Method
DWriteFactory Class See Also Send Feedback
CreateTextLayout takes a string, format, and associated constraints and produces and object representing the fully analyzed and formatted result.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextLayout CreateTextLayout(
    string text,
    TextFormat textFormat,
    float maxWidth,
    float maxHeight
)
Visual Basic
Public Function CreateTextLayout ( _
    text As String, _
    textFormat As TextFormat, _
    maxWidth As Single, _
    maxHeight As Single _
) As TextLayout
Visual C++
public:
TextLayout^ CreateTextLayout(
    String^ text,
    TextFormat^ textFormat,
    float maxWidth,
    float maxHeight
)

Parameters

text
Type: System..::..String
Characters to layout.
textFormat
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
The format to apply to the string.
maxWidth
Type: System..::..Single
Width of the layout box.
maxHeight
Type: System..::..Single
Height of the layout box.

Return Value

The resultant TextLayout object.

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateTypography Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..CreateTypography Method
DWriteFactory Class See Also Send Feedback
Creates a typography object used in conjunction with text format for text layout.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TypographySettingCollection CreateTypography()
Visual Basic
Public Function CreateTypography As TypographySettingCollection
Visual C++
public:
TypographySettingCollection^ CreateTypography()

Return Value

A TypographySettingCollection object.

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


DWriteFactory Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory Properties
DWriteFactory Class See Also Send Feedback

The DWriteFactory type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SystemFontFamilyCollection | Gets a font family collection representing the set of installed fonts.

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SystemFontFamilyCollection Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactory..::..SystemFontFamilyCollection Property
DWriteFactory Class See Also Send Feedback
Gets a font family collection representing the set of installed fonts.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFamilyCollection SystemFontFamilyCollection { get; }
Visual Basic
Public ReadOnly Property SystemFontFamilyCollection As FontFamilyCollection
    Get
Visual C++
public:
property FontFamilyCollection^ SystemFontFamilyCollection {
    FontFamilyCollection^ get ();
}

See Also

DWriteFactory Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


DWriteFactoryType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DWriteFactoryType Enumeration
See Also Send Feedback
Specifies the type of DirectWrite factory object. DirectWrite factory contains internal state such as font loader registration and cached font data. In most cases it is recommended to use the shared factory object, because it allows multiple components that use DirectWrite to share internal DirectWrite state and reduce memory usage. However, there are cases when it is desirable to reduce the impact of a component, such as a plug-in from an untrusted source, on the rest of the process by sandboxing and isolating it from the rest of the process components. In such cases, it is recommended to use an isolated factory for the sandboxed component.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DWriteFactoryType
Visual Basic
Public Enumeration DWriteFactoryType
Visual C++
public enum class DWriteFactoryType

Members

Member name | Description
Isolated |
Shared |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FlowDirection Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FlowDirection Enumeration
See Also Send Feedback
Direction for how lines of text are placed relative to one another.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FlowDirection
Visual Basic
Public Enumeration FlowDirection
Visual C++
public enum class FlowDirection

Members

Member name | Description
TopToBottom |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Font Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font Class
Members See Also Send Feedback
The Font represents a physical font in a font collection.

(Also see DirectX SDK: IDWriteFont)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Font : DirectUnknown
Visual Basic
Public Class Font _
    Inherits DirectUnknown
Visual C++
public ref class Font : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..Font

See Also

Font Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Font Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font Members
Font Class Methods Properties See Also Send Feedback

The Font type exposes the following members.

Methods

 | Name | Description
Public method | CreateFontFace | Creates a font face object for the font.
Public method | GetInformationalStrings | Gets a dictionary containing the specified informational strings, indexed by culture.
Public method | HasCharacter(Char) | Determines whether the font supports the specified character.
Public method | HasCharacter(UInt32) | Determines whether the font supports the specified character.

Properties

 | Name | Description
Public property | FaceNames | Gets localized face names for the font (e.g., Regular or Bold), indexed by culture.
Public property | FontFamily | Gets the font family to which the specified font belongs.
Public property | IsSymbolFont | Returns TRUE if the font is a symbol font or FALSE if not.
Public property | Metrics | Gets the metrics for the font.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Simulations | Gets a value that indicates what simulation are applied to the specified font.
Public property | Stretch | Gets the stretch (aka. width) of the specified font.
Public property | Style | Gets the style (aka. slope) of the specified font.
Public property | Weight | Gets the weight of the specified font.

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Font Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font Methods
Font Class See Also Send Feedback

The Font type exposes the following members.

Methods

 | Name | Description
Public method | CreateFontFace | Creates a font face object for the font.
Public method | GetInformationalStrings | Gets a dictionary containing the specified informational strings, indexed by culture.
Public method | HasCharacter(Char) | Determines whether the font supports the specified character.
Public method | HasCharacter(UInt32) | Determines whether the font supports the specified character.

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CreateFontFace Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..CreateFontFace Method
Font Class See Also Send Feedback
Creates a font face object for the font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFace CreateFontFace()
Visual Basic
Public Function CreateFontFace As FontFace
Visual C++
public:
FontFace^ CreateFontFace()

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetInformationalStrings Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..GetInformationalStrings Method
Font Class See Also Send Feedback
Gets a dictionary containing the specified informational strings, indexed by culture.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IDictionary<CultureInfo, string> GetInformationalStrings(
    InformationalStringId informationalStringId
)
Visual Basic
Public Function GetInformationalStrings ( _
    informationalStringId As InformationalStringId _
) As IDictionary(Of CultureInfo, String)
Visual C++
public:
IDictionary<CultureInfo^, String^>^ GetInformationalStrings(
    InformationalStringId informationalStringId
)

Parameters

informationalStringId
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..InformationalStringId
Identifies the string to get.

Return Value

A dictionary containing the specified informational strings, indexed by culture. If the font does not contain the specified string, the returned dictionary is null.

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HasCharacter Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..HasCharacter Method
Font Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HasCharacter(Char) | Determines whether the font supports the specified character.
Public method | HasCharacter(UInt32) | Determines whether the font supports the specified character.

See Also

Font Class
Font Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HasCharacter Method (Char)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..HasCharacter Method (Char)
Font Class See Also Send Feedback
Determines whether the font supports the specified character.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool HasCharacter(
    char character
)
Visual Basic
Public Function HasCharacter ( _
    character As Char _
) As Boolean
Visual C++
public:
bool HasCharacter(
    wchar_t character
)

Parameters

character
Type: System..::..Char
That Unicode character.

Return Value

True if the font supports the specified character or False if not.

See Also

Font Class
HasCharacter Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HasCharacter Method (UInt32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..HasCharacter Method (UInt32)
Font Class See Also Send Feedback
Determines whether the font supports the specified character.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool HasCharacter(
    uint unicodeValue
)
Visual Basic
Public Function HasCharacter ( _
    unicodeValue As UInteger _
) As Boolean
Visual C++
public:
bool HasCharacter(
    unsigned int unicodeValue
)

Parameters

unicodeValue
Type: System..::..UInt32
Unicode (UCS-4) character value.

Return Value

True if the font supports the specified character or False if not.

See Also

Font Class
HasCharacter Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Font Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font Properties
Font Class See Also Send Feedback

The Font type exposes the following members.

Properties

 | Name | Description
Public property | FaceNames | Gets localized face names for the font (e.g., Regular or Bold), indexed by culture.
Public property | FontFamily | Gets the font family to which the specified font belongs.
Public property | IsSymbolFont | Returns TRUE if the font is a symbol font or FALSE if not.
Public property | Metrics | Gets the metrics for the font.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Simulations | Gets a value that indicates what simulation are applied to the specified font.
Public property | Stretch | Gets the stretch (aka. width) of the specified font.
Public property | Style | Gets the style (aka. slope) of the specified font.
Public property | Weight | Gets the weight of the specified font.

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FaceNames Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..FaceNames Property
Font Class See Also Send Feedback
Gets localized face names for the font (e.g., Regular or Bold), indexed by culture.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IDictionary<CultureInfo, string> FaceNames { get; }
Visual Basic
Public ReadOnly Property FaceNames As IDictionary(Of CultureInfo, String)
    Get
Visual C++
public:
property IDictionary<CultureInfo^, String^>^ FaceNames {
    IDictionary<CultureInfo^, String^>^ get ();
}

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamily Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..FontFamily Property
Font Class See Also Send Feedback
Gets the font family to which the specified font belongs.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic
Public ReadOnly Property FontFamily As FontFamily
    Get
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
}

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsSymbolFont Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..IsSymbolFont Property
Font Class See Also Send Feedback
Returns TRUE if the font is a symbol font or FALSE if not.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsSymbolFont { get; }
Visual Basic
Public ReadOnly Property IsSymbolFont As Boolean
    Get
Visual C++
public:
property bool IsSymbolFont {
    bool get ();
}

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Metrics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..Metrics Property
Font Class See Also Send Feedback
Gets the metrics for the font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontMetrics Metrics { get; }
Visual Basic
Public ReadOnly Property Metrics As FontMetrics
    Get
Visual C++
public:
property FontMetrics Metrics {
    FontMetrics get ();
}

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Simulations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..Simulations Property
Font Class See Also Send Feedback
Gets a value that indicates what simulation are applied to the specified font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontSimulations Simulations { get; }
Visual Basic
Public ReadOnly Property Simulations As FontSimulations
    Get
Visual C++
public:
property FontSimulations Simulations {
    FontSimulations get ();
}

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Stretch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..Stretch Property
Font Class See Also Send Feedback
Gets the stretch (aka. width) of the specified font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontStretch Stretch { get; }
Visual Basic
Public ReadOnly Property Stretch As FontStretch
    Get
Visual C++
public:
property FontStretch Stretch {
    FontStretch get ();
}

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Style Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..Style Property
Font Class See Also Send Feedback
Gets the style (aka. slope) of the specified font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontStyle Style { get; }
Visual Basic
Public ReadOnly Property Style As FontStyle
    Get
Visual C++
public:
property FontStyle Style {
    FontStyle get ();
}

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Weight Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Font..::..Weight Property
Font Class See Also Send Feedback
Gets the weight of the specified font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontWeight Weight { get; }
Visual Basic
Public ReadOnly Property Weight As FontWeight
    Get
Visual C++
public:
property FontWeight Weight {
    FontWeight get ();
}

See Also

Font Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFace Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace Class
Members See Also Send Feedback
Represents an absolute reference to a font face. It contains font face type, appropriate file references and face identification data. Various font data such as metrics, names and glyph outlines is obtained from FontFace.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class FontFace : DirectUnknown
Visual Basic
Public Class FontFace _
    Inherits DirectUnknown
Visual C++
public ref class FontFace : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFace

See Also

FontFace Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFace Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace Members
FontFace Class Methods Properties See Also Send Feedback

The FontFace type exposes the following members.

Methods

 | Name | Description
Public method | GetDesignGlyphMetrics(array<UInt16>[]()[][]) | Obtains ideal glyph metrics in font design units. Design glyphs metrics are used for glyph positioning. This function assume Sideways is false.
Public method | GetDesignGlyphMetrics(array<UInt16>[]()[][], Int32) | Obtains ideal glyph metrics in font design units. Design glyphs metrics are used for glyph positioning.
Public method | GetGlyphIndexes(array<Char>[]()[][]) | Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.
Public method | GetGlyphIndexes(String) | Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.
Public method | GetGlyphIndexes(array<UInt32>[]()[][]) | Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.

Properties

 | Name | Description
Public property | FaceType | The file format type of a font face.
Public property | GlyphCount | The number of glyphs in the font face.
Public property | Index | The zero-based index of the font face in its font file or files. If the font files contain a single face, the return value is zero.
Public property | IsSymbolFont | Determines whether the font is a symbol font.
Public property | Metrics | Obtains design units and common metrics for the font face. These metrics are applicable to all the glyphs within a fontface and are used by applications for layout calculations.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Simulations | The algorithmic style simulation flags of a font face.

See Also

FontFace Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFace Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace Methods
FontFace Class See Also Send Feedback

Methods

 | Name | Description
Public method | GetDesignGlyphMetrics(array<UInt16>[]()[][]) | Obtains ideal glyph metrics in font design units. Design glyphs metrics are used for glyph positioning. This function assume Sideways is false.
Public method | GetDesignGlyphMetrics(array<UInt16>[]()[][], Int32) | Obtains ideal glyph metrics in font design units. Design glyphs metrics are used for glyph positioning.
Public method | GetGlyphIndexes(array<Char>[]()[][]) | Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.
Public method | GetGlyphIndexes(String) | Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.
Public method | GetGlyphIndexes(array<UInt32>[]()[][]) | Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.

See Also

FontFace Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetDesignGlyphMetrics Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..GetDesignGlyphMetrics Method
FontFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDesignGlyphMetrics(array<UInt16>[]()[][]) | Obtains ideal glyph metrics in font design units. Design glyphs metrics are used for glyph positioning. This function assume Sideways is false.
Public method | GetDesignGlyphMetrics(array<UInt16>[]()[][], Int32) | Obtains ideal glyph metrics in font design units. Design glyphs metrics are used for glyph positioning.

See Also

FontFace Class
FontFace Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetDesignGlyphMetrics Method (UInt16[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..GetDesignGlyphMetrics Method (array<UInt16>[]()[][])
FontFace Class See Also Send Feedback
Obtains ideal glyph metrics in font design units. Design glyphs metrics are used for glyph positioning. This function assume Sideways is false.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GlyphMetrics[] GetDesignGlyphMetrics(
    ushort[] glyphIndexes
)
Visual Basic
Public Function GetDesignGlyphMetrics ( _
    glyphIndexes As UShort() _
) As GlyphMetrics()
Visual C++
public:
array<GlyphMetrics>^ GetDesignGlyphMetrics(
    array<unsigned short>^ glyphIndexes
)

Parameters

glyphIndexes
Type: array< System..::..UInt16 >[]()[][]
An array of glyph indices to compute the metrics for.

Return Value

Array of GlyphMetrics structures filled by this function. The metrics returned by this function are in font design units.

See Also

FontFace Class
GetDesignGlyphMetrics Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetDesignGlyphMetrics Method (UInt16[], Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..GetDesignGlyphMetrics Method (array<UInt16>[]()[][], Int32)
FontFace Class See Also Send Feedback
Obtains ideal glyph metrics in font design units. Design glyphs metrics are used for glyph positioning.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GlyphMetrics[] GetDesignGlyphMetrics(
    ushort[] glyphIndexes,
    int isSideways
)
Visual Basic
Public Function GetDesignGlyphMetrics ( _
    glyphIndexes As UShort(), _
    isSideways As Integer _
) As GlyphMetrics()
Visual C++
public:
array<GlyphMetrics>^ GetDesignGlyphMetrics(
    array<unsigned short>^ glyphIndexes,
    int isSideways
)

Parameters

glyphIndexes
Type: array< System..::..UInt16 >[]()[][]
An array of glyph indices to compute the metrics for.
isSideways
Type: System..::..Int32
Indicates whether the font is being used in a sideways run. This can affect the glyph metrics if the font has oblique simulation because sideways oblique simulation differs from non-sideways oblique simulation.

Return Value

Array of GlyphMetrics structures filled by this function. The metrics returned by this function are in font design units.

See Also

FontFace Class
GetDesignGlyphMetrics Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetGlyphIndexes Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..GetGlyphIndexes Method
FontFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetGlyphIndexes(array<Char>[]()[][]) | Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.
Public method | GetGlyphIndexes(String) | Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.
Public method | GetGlyphIndexes(array<UInt32>[]()[][]) | Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.

See Also

FontFace Class
FontFace Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetGlyphIndexes Method (Char[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..GetGlyphIndexes Method (array<Char>[]()[][])
FontFace Class See Also Send Feedback
Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort[] GetGlyphIndexes(
    char[] characterArray
)
Visual Basic
Public Function GetGlyphIndexes ( _
    characterArray As Char() _
) As UShort()
Visual C++
public:
array<unsigned short>^ GetGlyphIndexes(
    array<wchar_t>^ characterArray
)

Parameters

characterArray
Type: array< System..::..Char >[]()[][]
An array of characters to obtain nominal glyph indices from.

Return Value

Array of nominal glyph indices filled by this function.

See Also

FontFace Class
GetGlyphIndexes Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetGlyphIndexes Method (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..GetGlyphIndexes Method (String)
FontFace Class See Also Send Feedback
Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort[] GetGlyphIndexes(
    string text
)
Visual Basic
Public Function GetGlyphIndexes ( _
    text As String _
) As UShort()
Visual C++
public:
array<unsigned short>^ GetGlyphIndexes(
    String^ text
)

Parameters

text
Type: System..::..String
The string to obtain nominal glyph indices for its characters.

Return Value

Array of nominal glyph indices filled by this function.

See Also

FontFace Class
GetGlyphIndexes Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetGlyphIndexes Method (UInt32[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..GetGlyphIndexes Method (array<UInt32>[]()[][])
FontFace Class See Also Send Feedback
Returns the nominal mapping of UCS4 Unicode code points to glyph indices as defined by the font 'CMAP' table. Note that this mapping is primarily provided for line layout engines built on top of the physical font API. Because of OpenType glyph substitution and line layout character substitution, the nominal conversion does not always correspond to how a Unicode string will map to glyph indices when rendering using a particular font face. Also, note that Unicode Variant Selectors provide for alternate mappings for character to glyph. This call will always return the default variant.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort[] GetGlyphIndexes(
    uint[] codePoints
)
Visual Basic
Public Function GetGlyphIndexes ( _
    codePoints As UInteger() _
) As UShort()
Visual C++
public:
array<unsigned short>^ GetGlyphIndexes(
    array<unsigned int>^ codePoints
)

Parameters

codePoints
Type: array< System..::..UInt32 >[]()[][]
An array of USC4 code points to obtain nominal glyph indices from.

Return Value

Array of nominal glyph indices filled by this function.

See Also

FontFace Class
GetGlyphIndexes Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFace Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace Properties
FontFace Class See Also Send Feedback

The FontFace type exposes the following members.

Properties

 | Name | Description
Public property | FaceType | The file format type of a font face.
Public property | GlyphCount | The number of glyphs in the font face.
Public property | Index | The zero-based index of the font face in its font file or files. If the font files contain a single face, the return value is zero.
Public property | IsSymbolFont | Determines whether the font is a symbol font.
Public property | Metrics | Obtains design units and common metrics for the font face. These metrics are applicable to all the glyphs within a fontface and are used by applications for layout calculations.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Simulations | The algorithmic style simulation flags of a font face.

See Also

FontFace Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FaceType Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..FaceType Property
FontFace Class See Also Send Feedback
The file format type of a font face.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFaceType FaceType { get; }
Visual Basic
Public ReadOnly Property FaceType As FontFaceType
    Get
Visual C++
public:
property FontFaceType FaceType {
    FontFaceType get ();
}

See Also

FontFace Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..GlyphCount Property
FontFace Class See Also Send Feedback
The number of glyphs in the font face.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort GlyphCount { get; }
Visual Basic
Public ReadOnly Property GlyphCount As UShort
    Get
Visual C++
public:
property unsigned short GlyphCount {
    unsigned short get ();
}

See Also

FontFace Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Index Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..Index Property
FontFace Class See Also Send Feedback
The zero-based index of the font face in its font file or files. If the font files contain a single face, the return value is zero.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Index { get; }
Visual Basic
Public ReadOnly Property Index As UInteger
    Get
Visual C++
public:
property unsigned int Index {
    unsigned int get ();
}

See Also

FontFace Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsSymbolFont Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..IsSymbolFont Property
FontFace Class See Also Send Feedback
Determines whether the font is a symbol font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsSymbolFont { get; }
Visual Basic
Public ReadOnly Property IsSymbolFont As Boolean
    Get
Visual C++
public:
property bool IsSymbolFont {
    bool get ();
}

See Also

FontFace Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Metrics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..Metrics Property
FontFace Class See Also Send Feedback
Obtains design units and common metrics for the font face. These metrics are applicable to all the glyphs within a fontface and are used by applications for layout calculations.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontMetrics Metrics { get; }
Visual Basic
Public ReadOnly Property Metrics As FontMetrics
    Get
Visual C++
public:
property FontMetrics Metrics {
    FontMetrics get ();
}

See Also

FontFace Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Simulations Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFace..::..Simulations Property
FontFace Class See Also Send Feedback
The algorithmic style simulation flags of a font face.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontSimulations Simulations { get; }
Visual Basic
Public ReadOnly Property Simulations As FontSimulations
    Get
Visual C++
public:
property FontSimulations Simulations {
    FontSimulations get ();
}

See Also

FontFace Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFaceType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFaceType Enumeration
See Also Send Feedback
The file format of a complete font face. Font formats that consist of multiple files, e.g. Type 1 .PFM and .PFB, have a single enum entry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FontFaceType
Visual Basic
Public Enumeration FontFaceType
Visual C++
public enum class FontFaceType

Members

Member name | Description
Bitmap |
Type1 |
TrueTypeCollection |
TrueType |
CompactFontFormat |
Unknown |
Vector |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamily Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamily Class
Members See Also Send Feedback
The FontFamily represents a set of fonts that share the same design but are differentiated by weight, stretch, and style.

(Also see DirectX SDK: IDWriteFontFamily)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class FontFamily : DirectUnknown
Visual Basic
Public Class FontFamily _
    Inherits DirectUnknown
Visual C++
public ref class FontFamily : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamily

See Also

FontFamily Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamily Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamily Members
FontFamily Class Methods Properties See Also Send Feedback

The FontFamily type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides DirectUnknownDispose(Boolean).)

Properties

 | Name | Description
Public property | FamilyNames | Gets the family names for the font family, indexed by culture info.
Public property | Fonts | Gets the collection of Fonts of this family.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

FontFamily Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamily Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamily Methods
FontFamily Class See Also Send Feedback

The FontFamily type exposes the following members.

Methods

 | Name | Description
Protected method | Dispose | (Overrides DirectUnknownDispose(Boolean).)

See Also

FontFamily Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Dispose Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamily..::..Dispose Method
FontFamily Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool
) override

Parameters

Type: System..::..Boolean

See Also

FontFamily Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamily Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamily Properties
FontFamily Class See Also Send Feedback

The FontFamily type exposes the following members.

Properties

 | Name | Description
Public property | FamilyNames | Gets the family names for the font family, indexed by culture info.
Public property | Fonts | Gets the collection of Fonts of this family.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

FontFamily Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FamilyNames Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamily..::..FamilyNames Property
FontFamily Class See Also Send Feedback
Gets the family names for the font family, indexed by culture info.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IDictionary<CultureInfo, string> FamilyNames { get; }
Visual Basic
Public ReadOnly Property FamilyNames As IDictionary(Of CultureInfo, String)
    Get
Visual C++
public:
property IDictionary<CultureInfo^, String^>^ FamilyNames {
    IDictionary<CultureInfo^, String^>^ get ();
}

See Also

FontFamily Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Fonts Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamily..::..Fonts Property
FontFamily Class See Also Send Feedback
Gets the collection of Fonts of this family.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<Font> Fonts { get; }
Visual Basic
Public ReadOnly Property Fonts As ReadOnlyCollection(Of Font)
    Get
Visual C++
public:
property ReadOnlyCollection<Font^>^ Fonts {
    ReadOnlyCollection<Font^>^ get ();
}

See Also

FontFamily Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamilyCollection Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection Class
Members See Also Send Feedback
A collection of FontFamily Objects. A FontFamily represents a set of fonts that share the same design but are differentiated by weight, stretch, and style. FontFamily

(Also see DirectX SDK: IDWriteFontFamily)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class FontFamilyCollection : DirectUnknown,
    IList<FontFamily>
Visual Basic
Public Class FontFamilyCollection _
    Inherits DirectUnknown _
    Implements IList(Of FontFamily)
Visual C++
public ref class FontFamilyCollection : public DirectUnknown,
    IList<FontFamily^>

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamilyCollection

See Also

FontFamilyCollection Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamilyCollection Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection Members
FontFamilyCollection Class Methods Properties See Also Send Feedback

The FontFamilyCollection type exposes the following members.

Methods

 | Name | Description
Protected method | Add |
Protected method | Clear |
Public method | Contains(String) | Determines whether the collection contains a given font family name.
Public method | Contains(FontFamily) | Retrives the index in the collection of a given font family.
Protected method | CopyTo |
Protected method | Dispose | (Overrides DirectUnknownDispose(Boolean).)
Protected method | GetEnumerator |
Public method | GetGenericEnumerator |
Public method | IndexOf(String) | Retrives the index in the collection of a given font family given its name.
Public method | IndexOf(FontFamily) | Determines whether the collection contains a given font family.
Protected method | Insert |
Protected method | Remove |
Protected method | RemoveAt |

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | IsReadOnly | Determines whether the collection is read only. Returns True.
Public property | Item | Gets the font family at the specified index.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamilyCollection Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection Methods
FontFamilyCollection Class See Also Send Feedback

The FontFamilyCollection type exposes the following members.

Methods

 | Name | Description
Protected method | Add |
Protected method | Clear |
Public method | Contains(String) | Determines whether the collection contains a given font family name.
Public method | Contains(FontFamily) | Retrives the index in the collection of a given font family.
Protected method | CopyTo |
Protected method | Dispose | (Overrides DirectUnknownDispose(Boolean).)
Protected method | GetEnumerator |
Public method | GetGenericEnumerator |
Public method | IndexOf(String) | Retrives the index in the collection of a given font family given its name.
Public method | IndexOf(FontFamily) | Determines whether the collection contains a given font family.
Protected method | Insert |
Protected method | Remove |
Protected method | RemoveAt |

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Add Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Add Method
FontFamilyCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Add(
    FontFamily item
)
Visual Basic
Protected Overridable Sub Add ( _
    item As FontFamily _
)
Visual C++
protected:
virtual void Add(
    FontFamily^ item
)

Parameters

item
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamily

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Clear Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Clear Method
FontFamilyCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Clear()
Visual Basic
Protected Overridable Sub Clear
Visual C++
protected:
virtual void Clear()

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Contains Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Contains Method
FontFamilyCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(String) | Determines whether the collection contains a given font family name.
Public method | Contains(FontFamily) | Retrives the index in the collection of a given font family.

See Also

FontFamilyCollection Class
FontFamilyCollection Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Contains Method (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Contains Method (String)
FontFamilyCollection Class See Also Send Feedback
Determines whether the collection contains a given font family name.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool Contains(
    string fontFamilyName
)
Visual Basic
Public Function Contains ( _
    fontFamilyName As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ fontFamilyName
)

Parameters

fontFamilyName
Type: System..::..String
Name of the font family. The name is not case-sensitive but must otherwise exactly match a family name in the collection.

Return Value

True if the font family is found, otherwise false.

See Also

FontFamilyCollection Class
Contains Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Contains Method (FontFamily)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Contains Method (FontFamily)
FontFamilyCollection Class See Also Send Feedback
Retrives the index in the collection of a given font family.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual bool Contains(
    FontFamily item
)
Visual Basic
Public Overridable Function Contains ( _
    item As FontFamily _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FontFamily^ item
)

Parameters

item
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamily
The font family.

Return Value

The zero based index in the collection for this font family, or -1 if the font family is not found.

See Also

FontFamilyCollection Class
Contains Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CopyTo Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..CopyTo Method
FontFamilyCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void CopyTo(
    FontFamily[] fontFamilyArray,
    int arrayIndex
)
Visual Basic
Protected Overridable Sub CopyTo ( _
    fontFamilyArray As FontFamily(), _
    arrayIndex As Integer _
)
Visual C++
protected:
virtual void CopyTo(
    array<FontFamily^>^ fontFamilyArray,
    int arrayIndex
)

Parameters

fontFamilyArray
Type: array< Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamily >[]()[][]
arrayIndex
Type: System..::..Int32

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Dispose Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Dispose Method
FontFamilyCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected override void Dispose(
    bool
)
Visual Basic
Protected Overrides Sub Dispose ( _
     As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool
) override

Parameters

Type: System..::..Boolean

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetEnumerator Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..GetEnumerator Method
FontFamilyCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual IEnumerator GetEnumerator()
Visual Basic
Protected Overridable Function GetEnumerator As IEnumerator
Visual C++
protected:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetGenericEnumerator Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..GetGenericEnumerator Method
FontFamilyCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual IEnumerator<FontFamily> GetGenericEnumerator()
Visual Basic
Public Overridable Function GetGenericEnumerator As IEnumerator(Of FontFamily)
Visual C++
public:
virtual IEnumerator<FontFamily^>^ GetGenericEnumerator()

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IndexOf Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..IndexOf Method
FontFamilyCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(String) | Retrives the index in the collection of a given font family given its name.
Public method | IndexOf(FontFamily) | Determines whether the collection contains a given font family.

See Also

FontFamilyCollection Class
FontFamilyCollection Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IndexOf Method (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..IndexOf Method (String)
FontFamilyCollection Class See Also Send Feedback
Retrives the index in the collection of a given font family given its name.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int IndexOf(
    string fontFamilyName
)
Visual Basic
Public Function IndexOf ( _
    fontFamilyName As String _
) As Integer
Visual C++
public:
int IndexOf(
    String^ fontFamilyName
)

Parameters

fontFamilyName
Type: System..::..String
Name of the font family. The name is not case-sensitive but must otherwise exactly match a family name in the collection.

Return Value

The zero based index in the collection for this font family, or -1 if the font family is not found.

See Also

FontFamilyCollection Class
IndexOf Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IndexOf Method (FontFamily)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..IndexOf Method (FontFamily)
FontFamilyCollection Class See Also Send Feedback
Determines whether the collection contains a given font family.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual int IndexOf(
    FontFamily item
)
Visual Basic
Public Overridable Function IndexOf ( _
    item As FontFamily _
) As Integer
Visual C++
public:
virtual int IndexOf(
    FontFamily^ item
)

Parameters

item
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamily
The font family to compare with.

Return Value

True if the font family is found, otherwise false.

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

FontFamilyCollection Class
IndexOf Overload
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Insert Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Insert Method
FontFamilyCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Insert(
    int index,
    FontFamily item
)
Visual Basic
Protected Overridable Sub Insert ( _
    index As Integer, _
    item As FontFamily _
)
Visual C++
protected:
virtual void Insert(
    int index,
    FontFamily^ item
)

Parameters

index
Type: System..::..Int32
item
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamily

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Remove Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Remove Method
FontFamilyCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual bool Remove(
    FontFamily item
)
Visual Basic
Protected Overridable Function Remove ( _
    item As FontFamily _
) As Boolean
Visual C++
protected:
virtual bool Remove(
    FontFamily^ item
)

Parameters

item
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFamily

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


RemoveAt Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..RemoveAt Method
FontFamilyCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void RemoveAt(
    int index
)
Visual Basic
Protected Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
protected:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamilyCollection Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection Properties
FontFamilyCollection Class See Also Send Feedback

The FontFamilyCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the collection.
Public property | IsReadOnly | Determines whether the collection is read only. Returns True.
Public property | Item | Gets the font family at the specified index.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Count Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Count Property
FontFamilyCollection Class See Also Send Feedback
Gets the number of elements contained in the collection.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsReadOnly Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..IsReadOnly Property
FontFamilyCollection Class See Also Send Feedback
Determines whether the collection is read only. Returns True.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Item Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFamilyCollection..::..Item Property
FontFamilyCollection Class See Also Send Feedback
Gets the font family at the specified index.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual FontFamily this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As FontFamily
    Get
    Set
Visual C++
public:
virtual property FontFamily^ default[int index] {
    FontFamily^ get (int index);
    void set (int index, FontFamily^ value);
}

Parameters

index
Type: System..::..Int32

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

FontFamilyCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFeature Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature Structure
Members See Also Send Feedback
The FontFeature structure specifies properties used to identify and execute typographic feature in the font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct FontFeature
Visual Basic
Public Structure FontFeature
Visual C++
public value class FontFeature

Remarks

A non-zero value generally enables the feature execution, while the zero value disables it. A feature requiring a selector uses this value to indicate the selector index.

The OpenType standard provides access to typographic features available in the font by means of a feature tag with the associated parameters. The OpenType feature tag is a 4-byte identifier of the registered name of a feature. For example, the â€˜kernâ€™ feature name tag is used to identify the â€˜Kerningâ€™ feature in OpenType font. Similarly, the OpenType feature tag for â€˜Standard Ligaturesâ€™ and â€˜Fractionsâ€™ is â€˜ligaâ€™ and â€˜fracâ€™ respectively. Since a single run can be associated with more than one typographic features, the Text String API accepts typographic settings for a run as a list of features and are executed in the order they are specified.

The value of the Tag member represents the OpenType name tag of the feature, while the param value represents additional parameter for the execution of the feature referred by the tag member. Both nameTag and param are stored as little endian, the same convention followed by GDI. Most features treat the Param value as a binary value that indicates whether to turn the execution of the feature on or off, with it being off by default in the majority of cases. Some features, however, treat this value as an integral value representing the integer index to the list of alternate results it may produce during the execution; for instance, the feature â€˜Stylistic Alternatesâ€™ or â€˜saltâ€™ uses the param value as an index to the list of alternate substituting glyphs it could produce for a specified glyph.

See Also

FontFeature Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFeature Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature Members
FontFeature Structure Constructors Methods Operators Properties See Also Send Feedback

The FontFeature type exposes the following members.

Constructors

 | Name | Description
Public method | FontFeature | Constructor for FontFeature

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | NameTag | The feature OpenType name identifier.
Public property | Parameter | Execution parameter of the feature.

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFeature Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature Constructor
FontFeature Structure See Also Send Feedback
Constructor for FontFeature

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFeature(
    FontFeatureTag nameTag,
    uint parameter
)
Visual Basic
Public Sub New ( _
    nameTag As FontFeatureTag, _
    parameter As UInteger _
)
Visual C++
public:
FontFeature(
    FontFeatureTag nameTag,
    unsigned int parameter
)

Parameters

nameTag
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeatureTag
parameter
Type: System..::..UInt32

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFeature Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature Methods
FontFeature Structure See Also Send Feedback

The FontFeature type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature..::..Equals Method
FontFeature Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature..::..GetHashCode Method
FontFeature Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFeature Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature Operators
FontFeature Structure See Also Send Feedback

The FontFeature type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature..::..Equality Operator
FontFeature Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    FontFeature fontFeature1,
    FontFeature fontFeature2
)
Visual Basic
Public Shared Operator = ( _
    fontFeature1 As FontFeature, _
    fontFeature2 As FontFeature _
) As Boolean
Visual C++
public:
static bool operator ==(
    FontFeature fontFeature1,
    FontFeature fontFeature2
)

Parameters

fontFeature1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature
fontFeature2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature..::..Inequality Operator
FontFeature Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    FontFeature fontFeature1,
    FontFeature fontFeature2
)
Visual Basic
Public Shared Operator <> ( _
    fontFeature1 As FontFeature, _
    fontFeature2 As FontFeature _
) As Boolean
Visual C++
public:
static bool operator !=(
    FontFeature fontFeature1,
    FontFeature fontFeature2
)

Parameters

fontFeature1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature
fontFeature2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFeature Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature Properties
FontFeature Structure See Also Send Feedback

The FontFeature type exposes the following members.

Properties

 | Name | Description
Public property | NameTag | The feature OpenType name identifier.
Public property | Parameter | Execution parameter of the feature.

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


NameTag Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature..::..NameTag Property
FontFeature Structure See Also Send Feedback
The feature OpenType name identifier.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFeatureTag NameTag { get; set; }
Visual Basic
Public Property NameTag As FontFeatureTag
    Get
    Set
Visual C++
public:
property FontFeatureTag NameTag {
    FontFeatureTag get ();
    void set (FontFeatureTag value);
}

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Parameter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeature..::..Parameter Property
FontFeature Structure See Also Send Feedback
Execution parameter of the feature.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Parameter { get; set; }
Visual Basic
Public Property Parameter As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Parameter {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The parameter should be non-zero to enable the feature. Once enabled, a feature can't be disabled again within the same range. Features requiring a selector use this value to indicate the selector index.

See Also

FontFeature Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFeatureTag Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFeatureTag Enumeration
See Also Send Feedback
Typographic feature of text supplied by the font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FontFeatureTag
Visual Basic
Public Enumeration FontFeatureTag
Visual C++
public enum class FontFeatureTag

Members

Member name | Description
SlashedZero |
Unicase |
ThirdWidths |
TraditionalForms |
TabularFigures |
TraditionalNameForms |
Titling |
Swash |
Superscript |
Subscript |
StylisticSet20 |
StylisticSet19 |
StylisticSet18 |
StylisticSet17 |
StylisticSet16 |
StylisticSet15 |
StylisticSet14 |
StylisticSet13 |
StylisticSet12 |
StylisticSet11 |
StylisticSet10 |
StylisticSet09 |
StylisticSet08 |
StylisticSet07 |
StylisticSet06 |
StylisticSet05 |
StylisticSet04 |
StylisticSet03 |
StylisticSet02 |
StylisticSet01 |
SimplifiedForms |
SmallCapitals |
ScientificInferiors |
StylisticAlternates |
RubyNotationForms |
RequiredLigatures |
QuarterWidths |
ProportionalWidths |
ProportionalFigures |
PetiteCapitals |
ProportionalAlternateWidth |
Ordinals |
OldStyleFigures |
NLCKanjiForms |
AlternateAnnotationForms |
MarkToMarkPositioning |
MathematicalGreek |
MarkPositioning |
LocalizedForms |
LiningFigures |
StandardLigatures |
Kerning |
Jis90Forms |
Jis83Forms |
Jis78Forms |
Jis04Forms |
HojoKanjiForms |
HalfWidth |
HistoricalLigatures |
HorizontalKanaAlternates |
HistoricalForms |
AlternateHalfWidth |
HalantForms |
HalfForms |
FullWidth |
Fractions |
ExpertForms |
DiscretionaryLigatures |
CursivePositioning |
ContextualSwash |
CapitalSpacing |
ContextualLigatures |
GlyphCompositionDecomposition |
CaseSensitiveForms |
ContextualAlternates |
SmallCapitalsFromCapitals |
PetiteCapitalsFromCapitals |
AlternativeFractions |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFileType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontFileType Enumeration
See Also Send Feedback
The type of a font represented by a single font file. Font formats that consist of multiple files, e.g. Type 1 .PFM and .PFB, have separate enum values for each of the file type.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FontFileType
Visual Basic
Public Enumeration FontFileType
Visual C++
public enum class FontFileType

Members

Member name | Description
Bitmap |
Type1PrinterFontBinary |
Type1PrinterFontMetric |
TrueTypeCollection |
TrueType |
CompactFontFormat |
Vector |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontMetrics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics Structure
Members See Also Send Feedback
Specifies the metrics of a font face that are applicable to all glyphs within the font face.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct FontMetrics
Visual Basic
Public Structure FontMetrics
Visual C++
public value class FontMetrics

See Also

FontMetrics Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontMetrics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics Members
FontMetrics Structure Constructors Methods Operators Properties See Also Send Feedback

The FontMetrics type exposes the following members.

Constructors

 | Name | Description
Public method | FontMetrics | Constructor for FontMetrics

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Ascent | Ascent value of the font face in font design units. Ascent is the distance from the top of font character alignment box to English baseline.
Public property | CapHeight | Cap height value of the font face in font design units. Cap height is the distance from English baseline to the top of a typical English capital. Capital "H" is often used as a reference character for the purpose of calculating the cap height value.
Public property | Descent | Descent value of the font face in font design units. Descent is the distance from the bottom of font character alignment box to English baseline.
Public property | DesignUnitsPerEm | The number of font design units per em unit. Font files use their own coordinate system of font design units. A font design unit is the smallest measurable unit in the em square, an imaginary square that is used to size and align glyphs. The concept of em square is used as a reference scale factor when defining font size and device transformation semantics. The size of one em square is also commonly used to compute the paragraph identation value.
Public property | LineGap | Line gap in font design units. Recommended additional white space to add between lines to improve legibility. The recommended line spacing (baseline-to-baseline distance) is thus the sum of ascent, descent, and lineGap. The line gap is usually positive or zero but can be negative, in which case the recommended line spacing is less than the height of the character alignment box.
Public property | StrikethroughPosition | The strikethrough position value of the font face in font design units. Strikethrough position is the position of strikethrough relative to the English baseline. The value is usually made positive in order to place the strikethrough above the baseline.
Public property | StrikethroughThickness | The suggested strikethrough thickness value of the font face in font design units.
Public property | UnderlinePosition | The underline position value of the font face in font design units. Underline position is the position of underline relative to the English baseline. The value is usually made negative in order to place the underline below the baseline.
Public property | UnderlineThickness | The suggested underline thickness value of the font face in font design units.
Public property | XHeight | x-height value of the font face in font design units. x-height is the distance from English baseline to the top of lowercase letter "x", or a similar lowercase character.

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontMetrics Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics Constructor
FontMetrics Structure See Also Send Feedback
Constructor for FontMetrics

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontMetrics(
    ushort designUnitsPerEm,
    ushort ascent,
    ushort descent,
    short lineGap,
    ushort capHeight,
    ushort xHeight,
    short underlinePosition,
    ushort underlineThickness,
    short strikethroughPosition,
    ushort strikethroughThickness
)
Visual Basic
Public Sub New ( _
    designUnitsPerEm As UShort, _
    ascent As UShort, _
    descent As UShort, _
    lineGap As Short, _
    capHeight As UShort, _
    xHeight As UShort, _
    underlinePosition As Short, _
    underlineThickness As UShort, _
    strikethroughPosition As Short, _
    strikethroughThickness As UShort _
)
Visual C++
public:
FontMetrics(
    unsigned short designUnitsPerEm,
    unsigned short ascent,
    unsigned short descent,
    short lineGap,
    unsigned short capHeight,
    unsigned short xHeight,
    short underlinePosition,
    unsigned short underlineThickness,
    short strikethroughPosition,
    unsigned short strikethroughThickness
)

Parameters

designUnitsPerEm
Type: System..::..UInt16
ascent
Type: System..::..UInt16
descent
Type: System..::..UInt16
lineGap
Type: System..::..Int16
capHeight
Type: System..::..UInt16
xHeight
Type: System..::..UInt16
underlinePosition
Type: System..::..Int16
underlineThickness
Type: System..::..UInt16
strikethroughPosition
Type: System..::..Int16
strikethroughThickness
Type: System..::..UInt16

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontMetrics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics Methods
FontMetrics Structure See Also Send Feedback

The FontMetrics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..Equals Method
FontMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..GetHashCode Method
FontMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontMetrics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics Operators
FontMetrics Structure See Also Send Feedback

The FontMetrics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..Equality Operator
FontMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    FontMetrics fontMetrics1,
    FontMetrics fontMetrics2
)
Visual Basic
Public Shared Operator = ( _
    fontMetrics1 As FontMetrics, _
    fontMetrics2 As FontMetrics _
) As Boolean
Visual C++
public:
static bool operator ==(
    FontMetrics fontMetrics1,
    FontMetrics fontMetrics2
)

Parameters

fontMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontMetrics
fontMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontMetrics

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..Inequality Operator
FontMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    FontMetrics fontMetrics1,
    FontMetrics fontMetrics2
)
Visual Basic
Public Shared Operator <> ( _
    fontMetrics1 As FontMetrics, _
    fontMetrics2 As FontMetrics _
) As Boolean
Visual C++
public:
static bool operator !=(
    FontMetrics fontMetrics1,
    FontMetrics fontMetrics2
)

Parameters

fontMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontMetrics
fontMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontMetrics

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontMetrics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics Properties
FontMetrics Structure See Also Send Feedback

The FontMetrics type exposes the following members.

Properties

 | Name | Description
Public property | Ascent | Ascent value of the font face in font design units. Ascent is the distance from the top of font character alignment box to English baseline.
Public property | CapHeight | Cap height value of the font face in font design units. Cap height is the distance from English baseline to the top of a typical English capital. Capital "H" is often used as a reference character for the purpose of calculating the cap height value.
Public property | Descent | Descent value of the font face in font design units. Descent is the distance from the bottom of font character alignment box to English baseline.
Public property | DesignUnitsPerEm | The number of font design units per em unit. Font files use their own coordinate system of font design units. A font design unit is the smallest measurable unit in the em square, an imaginary square that is used to size and align glyphs. The concept of em square is used as a reference scale factor when defining font size and device transformation semantics. The size of one em square is also commonly used to compute the paragraph identation value.
Public property | LineGap | Line gap in font design units. Recommended additional white space to add between lines to improve legibility. The recommended line spacing (baseline-to-baseline distance) is thus the sum of ascent, descent, and lineGap. The line gap is usually positive or zero but can be negative, in which case the recommended line spacing is less than the height of the character alignment box.
Public property | StrikethroughPosition | The strikethrough position value of the font face in font design units. Strikethrough position is the position of strikethrough relative to the English baseline. The value is usually made positive in order to place the strikethrough above the baseline.
Public property | StrikethroughThickness | The suggested strikethrough thickness value of the font face in font design units.
Public property | UnderlinePosition | The underline position value of the font face in font design units. Underline position is the position of underline relative to the English baseline. The value is usually made negative in order to place the underline below the baseline.
Public property | UnderlineThickness | The suggested underline thickness value of the font face in font design units.
Public property | XHeight | x-height value of the font face in font design units. x-height is the distance from English baseline to the top of lowercase letter "x", or a similar lowercase character.

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Ascent Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..Ascent Property
FontMetrics Structure See Also Send Feedback
Ascent value of the font face in font design units. Ascent is the distance from the top of font character alignment box to English baseline.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort Ascent { get; set; }
Visual Basic
Public Property Ascent As UShort
    Get
    Set
Visual C++
public:
property unsigned short Ascent {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CapHeight Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..CapHeight Property
FontMetrics Structure See Also Send Feedback
Cap height value of the font face in font design units. Cap height is the distance from English baseline to the top of a typical English capital. Capital "H" is often used as a reference character for the purpose of calculating the cap height value.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort CapHeight { get; set; }
Visual Basic
Public Property CapHeight As UShort
    Get
    Set
Visual C++
public:
property unsigned short CapHeight {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Descent Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..Descent Property
FontMetrics Structure See Also Send Feedback
Descent value of the font face in font design units. Descent is the distance from the bottom of font character alignment box to English baseline.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort Descent { get; set; }
Visual Basic
Public Property Descent As UShort
    Get
    Set
Visual C++
public:
property unsigned short Descent {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


DesignUnitsPerEm Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..DesignUnitsPerEm Property
FontMetrics Structure See Also Send Feedback
The number of font design units per em unit. Font files use their own coordinate system of font design units. A font design unit is the smallest measurable unit in the em square, an imaginary square that is used to size and align glyphs. The concept of em square is used as a reference scale factor when defining font size and device transformation semantics. The size of one em square is also commonly used to compute the paragraph identation value.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort DesignUnitsPerEm { get; set; }
Visual Basic
Public Property DesignUnitsPerEm As UShort
    Get
    Set
Visual C++
public:
property unsigned short DesignUnitsPerEm {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineGap Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..LineGap Property
FontMetrics Structure See Also Send Feedback
Line gap in font design units. Recommended additional white space to add between lines to improve legibility. The recommended line spacing (baseline-to-baseline distance) is thus the sum of ascent, descent, and lineGap. The line gap is usually positive or zero but can be negative, in which case the recommended line spacing is less than the height of the character alignment box.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public short LineGap { get; set; }
Visual Basic
Public Property LineGap As Short
    Get
    Set
Visual C++
public:
property short LineGap {
    short get ();
    void set (short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


StrikethroughPosition Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..StrikethroughPosition Property
FontMetrics Structure See Also Send Feedback
The strikethrough position value of the font face in font design units. Strikethrough position is the position of strikethrough relative to the English baseline. The value is usually made positive in order to place the strikethrough above the baseline.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public short StrikethroughPosition { get; set; }
Visual Basic
Public Property StrikethroughPosition As Short
    Get
    Set
Visual C++
public:
property short StrikethroughPosition {
    short get ();
    void set (short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


StrikethroughThickness Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..StrikethroughThickness Property
FontMetrics Structure See Also Send Feedback
The suggested strikethrough thickness value of the font face in font design units.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort StrikethroughThickness { get; set; }
Visual Basic
Public Property StrikethroughThickness As UShort
    Get
    Set
Visual C++
public:
property unsigned short StrikethroughThickness {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


UnderlinePosition Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..UnderlinePosition Property
FontMetrics Structure See Also Send Feedback
The underline position value of the font face in font design units. Underline position is the position of underline relative to the English baseline. The value is usually made negative in order to place the underline below the baseline.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public short UnderlinePosition { get; set; }
Visual Basic
Public Property UnderlinePosition As Short
    Get
    Set
Visual C++
public:
property short UnderlinePosition {
    short get ();
    void set (short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


UnderlineThickness Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..UnderlineThickness Property
FontMetrics Structure See Also Send Feedback
The suggested underline thickness value of the font face in font design units.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort UnderlineThickness { get; set; }
Visual Basic
Public Property UnderlineThickness As UShort
    Get
    Set
Visual C++
public:
property unsigned short UnderlineThickness {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


XHeight Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontMetrics..::..XHeight Property
FontMetrics Structure See Also Send Feedback
x-height value of the font face in font design units. x-height is the distance from English baseline to the top of lowercase letter "x", or a similar lowercase character.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ushort XHeight { get; set; }
Visual Basic
Public Property XHeight As UShort
    Get
    Set
Visual C++
public:
property unsigned short XHeight {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

FontMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontSimulations Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontSimulations Enumeration
See Also Send Feedback
Specifies algorithmic style simulations to be applied to the font face. Bold and oblique simulations can be combined via bitwise OR operation.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum FontSimulations
Visual Basic
<FlagsAttribute> _
Public Enumeration FontSimulations
Visual C++
[FlagsAttribute]
public enum class FontSimulations

Members

Member name | Description
None |
Oblique |
Bold |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontStretch Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontStretch Enumeration
See Also Send Feedback
The font stretch enumeration describes relative change from the normal aspect ratio as specified by a font designer for the glyphs in a font. Values less than 1 or greater than 9 are considered to be invalid, and they are rejected by font API functions.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FontStretch
Visual Basic
Public Enumeration FontStretch
Visual C++
public enum class FontStretch

Members

Member name | Description
Normal |
Undefined |
UltraExpanded |
ExtraExpanded |
Expanded |
SemiExpanded |
Medium |
SemiCondensed |
Condensed |
ExtraCondensed |
UltraCondensed |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontStyle Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontStyle Enumeration
See Also Send Feedback
The font style enumeration describes the slope style of a font face, such as Normal, Italic or Oblique. Values other than the ones defined in the enumeration are considered to be invalid, and they are rejected by font API functions.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FontStyle
Visual Basic
Public Enumeration FontStyle
Visual C++
public enum class FontStyle

Members

Member name | Description
Normal |
Italic |
Oblique |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontWeight Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FontWeight Enumeration
See Also Send Feedback
The font weight enumeration describes common values for degree of blackness or thickness of strokes of characters in a font. Font weight values less than 1 or greater than 999 are considered to be invalid, and they are rejected by font API functions.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum FontWeight
Visual Basic
Public Enumeration FontWeight
Visual C++
public enum class FontWeight

Members

Member name | Description
Normal |
UltraBlack |
ExtraBlack |
Heavy |
Black |
UltraBold |
ExtraBold |
Bold |
SemiBold |
DemiBold |
Medium |
Regular |
Light |
UltraLight |
ExtraLight |
Thin |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphMetrics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics Structure
Members See Also Send Feedback
The GlyphMetrics structure specifies the metrics of an individual glyph. The units depend on how the metrics are obtained.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct GlyphMetrics
Visual Basic
Public Structure GlyphMetrics
Visual C++
public value class GlyphMetrics

See Also

GlyphMetrics Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphMetrics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics Members
GlyphMetrics Structure Methods Operators Properties See Also Send Feedback

The GlyphMetrics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AdvanceHeight | Specifies the Y offset from the vertical origin of the current glyph to the vertical origin of the next glyph when writing vertically. (Note that the term "origin" by itself denotes the horizontal origin. The vertical origin is different. Its Y coordinate is specified by verticalOriginY value, and its X coordinate is half the advanceWidth to the right of the horizontal origin).
Public property | AdvanceWidth | Specifies the X offset from the origin of the current glyph to the origin of the next glyph when writing horizontally.
Public property | BottomSideBearing | Specifies the vertical distance from the black box's bottom edge to the advance height. Positive when the bottom edge of the black box is within the layout box. Negative when the bottom edge of black box overhangs the layout box.
Public property | LeftSideBearing | Specifies the X offset from the glyph origin to the left edge of the black box. The glyph origin is the current horizontal writing position. A negative value means the black box extends to the left of the origin (often true for lowercase italic 'f').
Public property | RightSideBearing | Specifies the X offset from the right edge of the black box to the origin of the next glyph when writing horizontally. The value is negative when the right edge of the black box overhangs the layout box.
Public property | TopSideBearing | Specifies the vertical offset from the vertical origin to the top of the black box. Thus, a positive value adds whitespace whereas a negative value means the glyph overhangs the top of the layout box.
Public property | VerticalOriginY | Specifies the Y coordinate of a glyph's vertical origin, in the font's design coordinate system. The y coordinate of a glyph's vertical origin is the sum of the glyph's top side bearing and the top (i.e. yMax) of the glyph's bounding box.

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphMetrics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics Methods
GlyphMetrics Structure See Also Send Feedback

The GlyphMetrics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..Equals Method
GlyphMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..GetHashCode Method
GlyphMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphMetrics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics Operators
GlyphMetrics Structure See Also Send Feedback

The GlyphMetrics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..Equality Operator
GlyphMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    GlyphMetrics glyphMetrics1,
    GlyphMetrics glyphMetrics2
)
Visual Basic
Public Shared Operator = ( _
    glyphMetrics1 As GlyphMetrics, _
    glyphMetrics2 As GlyphMetrics _
) As Boolean
Visual C++
public:
static bool operator ==(
    GlyphMetrics glyphMetrics1,
    GlyphMetrics glyphMetrics2
)

Parameters

glyphMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphMetrics
glyphMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphMetrics

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..Inequality Operator
GlyphMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    GlyphMetrics glyphMetrics1,
    GlyphMetrics glyphMetrics2
)
Visual Basic
Public Shared Operator <> ( _
    glyphMetrics1 As GlyphMetrics, _
    glyphMetrics2 As GlyphMetrics _
) As Boolean
Visual C++
public:
static bool operator !=(
    GlyphMetrics glyphMetrics1,
    GlyphMetrics glyphMetrics2
)

Parameters

glyphMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphMetrics
glyphMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphMetrics

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphMetrics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics Properties
GlyphMetrics Structure See Also Send Feedback

The GlyphMetrics type exposes the following members.

Properties

 | Name | Description
Public property | AdvanceHeight | Specifies the Y offset from the vertical origin of the current glyph to the vertical origin of the next glyph when writing vertically. (Note that the term "origin" by itself denotes the horizontal origin. The vertical origin is different. Its Y coordinate is specified by verticalOriginY value, and its X coordinate is half the advanceWidth to the right of the horizontal origin).
Public property | AdvanceWidth | Specifies the X offset from the origin of the current glyph to the origin of the next glyph when writing horizontally.
Public property | BottomSideBearing | Specifies the vertical distance from the black box's bottom edge to the advance height. Positive when the bottom edge of the black box is within the layout box. Negative when the bottom edge of black box overhangs the layout box.
Public property | LeftSideBearing | Specifies the X offset from the glyph origin to the left edge of the black box. The glyph origin is the current horizontal writing position. A negative value means the black box extends to the left of the origin (often true for lowercase italic 'f').
Public property | RightSideBearing | Specifies the X offset from the right edge of the black box to the origin of the next glyph when writing horizontally. The value is negative when the right edge of the black box overhangs the layout box.
Public property | TopSideBearing | Specifies the vertical offset from the vertical origin to the top of the black box. Thus, a positive value adds whitespace whereas a negative value means the glyph overhangs the top of the layout box.
Public property | VerticalOriginY | Specifies the Y coordinate of a glyph's vertical origin, in the font's design coordinate system. The y coordinate of a glyph's vertical origin is the sum of the glyph's top side bearing and the top (i.e. yMax) of the glyph's bounding box.

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


AdvanceHeight Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..AdvanceHeight Property
GlyphMetrics Structure See Also Send Feedback
Specifies the Y offset from the vertical origin of the current glyph to the vertical origin of the next glyph when writing vertically. (Note that the term "origin" by itself denotes the horizontal origin. The vertical origin is different. Its Y coordinate is specified by verticalOriginY value, and its X coordinate is half the advanceWidth to the right of the horizontal origin).

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint AdvanceHeight { get; set; }
Visual Basic
Public Property AdvanceHeight As UInteger
    Get
    Set
Visual C++
public:
property unsigned int AdvanceHeight {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


AdvanceWidth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..AdvanceWidth Property
GlyphMetrics Structure See Also Send Feedback
Specifies the X offset from the origin of the current glyph to the origin of the next glyph when writing horizontally.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint AdvanceWidth { get; set; }
Visual Basic
Public Property AdvanceWidth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int AdvanceWidth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


BottomSideBearing Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..BottomSideBearing Property
GlyphMetrics Structure See Also Send Feedback
Specifies the vertical distance from the black box's bottom edge to the advance height. Positive when the bottom edge of the black box is within the layout box. Negative when the bottom edge of black box overhangs the layout box.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int BottomSideBearing { get; set; }
Visual Basic
Public Property BottomSideBearing As Integer
    Get
    Set
Visual C++
public:
property int BottomSideBearing {
    int get ();
    void set (int value);
}

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LeftSideBearing Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..LeftSideBearing Property
GlyphMetrics Structure See Also Send Feedback
Specifies the X offset from the glyph origin to the left edge of the black box. The glyph origin is the current horizontal writing position. A negative value means the black box extends to the left of the origin (often true for lowercase italic 'f').

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int LeftSideBearing { get; set; }
Visual Basic
Public Property LeftSideBearing As Integer
    Get
    Set
Visual C++
public:
property int LeftSideBearing {
    int get ();
    void set (int value);
}

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


RightSideBearing Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..RightSideBearing Property
GlyphMetrics Structure See Also Send Feedback
Specifies the X offset from the right edge of the black box to the origin of the next glyph when writing horizontally. The value is negative when the right edge of the black box overhangs the layout box.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int RightSideBearing { get; set; }
Visual Basic
Public Property RightSideBearing As Integer
    Get
    Set
Visual C++
public:
property int RightSideBearing {
    int get ();
    void set (int value);
}

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TopSideBearing Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..TopSideBearing Property
GlyphMetrics Structure See Also Send Feedback
Specifies the vertical offset from the vertical origin to the top of the black box. Thus, a positive value adds whitespace whereas a negative value means the glyph overhangs the top of the layout box.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int TopSideBearing { get; set; }
Visual Basic
Public Property TopSideBearing As Integer
    Get
    Set
Visual C++
public:
property int TopSideBearing {
    int get ();
    void set (int value);
}

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


VerticalOriginY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphMetrics..::..VerticalOriginY Property
GlyphMetrics Structure See Also Send Feedback
Specifies the Y coordinate of a glyph's vertical origin, in the font's design coordinate system. The y coordinate of a glyph's vertical origin is the sum of the glyph's top side bearing and the top (i.e. yMax) of the glyph's bounding box.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int VerticalOriginY { get; set; }
Visual Basic
Public Property VerticalOriginY As Integer
    Get
    Set
Visual C++
public:
property int VerticalOriginY {
    int get ();
    void set (int value);
}

See Also

GlyphMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphOffset Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset Structure
Members See Also Send Feedback
Optional adjustment to a glyph's position. An glyph offset changes the position of a glyph without affecting the pen position. Offsets are in logical, pre-transform units.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct GlyphOffset
Visual Basic
Public Structure GlyphOffset
Visual C++
public value class GlyphOffset

See Also

GlyphOffset Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphOffset Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset Members
GlyphOffset Structure Constructors Methods Operators Properties See Also Send Feedback

The GlyphOffset type exposes the following members.

Constructors

 | Name | Description
Public method | GlyphOffset | Constructor for FontFeature

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AdvanceOffset | Offset in the advance direction of the run. A positive advance offset moves the glyph to the right (in pre-transform coordinates) if the run is left-to-right or to the left if the run is right-to-left.
Public property | AscenderOffset | Offset in the ascent direction, i.e., the direction ascenders point. A positive ascender offset moves the glyph up (in pre-transform coordinates).

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphOffset Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset Constructor
GlyphOffset Structure See Also Send Feedback
Constructor for FontFeature

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GlyphOffset(
    float advanceOffset,
    float ascenderOffset
)
Visual Basic
Public Sub New ( _
    advanceOffset As Single, _
    ascenderOffset As Single _
)
Visual C++
public:
GlyphOffset(
    float advanceOffset,
    float ascenderOffset
)

Parameters

advanceOffset
Type: System..::..Single
ascenderOffset
Type: System..::..Single

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphOffset Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset Methods
GlyphOffset Structure See Also Send Feedback

The GlyphOffset type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset..::..Equals Method
GlyphOffset Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset..::..GetHashCode Method
GlyphOffset Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphOffset Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset Operators
GlyphOffset Structure See Also Send Feedback

The GlyphOffset type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset..::..Equality Operator
GlyphOffset Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    GlyphOffset glyphOffset1,
    GlyphOffset glyphOffset2
)
Visual Basic
Public Shared Operator = ( _
    glyphOffset1 As GlyphOffset, _
    glyphOffset2 As GlyphOffset _
) As Boolean
Visual C++
public:
static bool operator ==(
    GlyphOffset glyphOffset1,
    GlyphOffset glyphOffset2
)

Parameters

glyphOffset1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphOffset
glyphOffset2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphOffset

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset..::..Inequality Operator
GlyphOffset Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    GlyphOffset glyphOffset1,
    GlyphOffset glyphOffset2
)
Visual Basic
Public Shared Operator <> ( _
    glyphOffset1 As GlyphOffset, _
    glyphOffset2 As GlyphOffset _
) As Boolean
Visual C++
public:
static bool operator !=(
    GlyphOffset glyphOffset1,
    GlyphOffset glyphOffset2
)

Parameters

glyphOffset1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphOffset
glyphOffset2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..GlyphOffset

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphOffset Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset Properties
GlyphOffset Structure See Also Send Feedback

The GlyphOffset type exposes the following members.

Properties

 | Name | Description
Public property | AdvanceOffset | Offset in the advance direction of the run. A positive advance offset moves the glyph to the right (in pre-transform coordinates) if the run is left-to-right or to the left if the run is right-to-left.
Public property | AscenderOffset | Offset in the ascent direction, i.e., the direction ascenders point. A positive ascender offset moves the glyph up (in pre-transform coordinates).

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


AdvanceOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset..::..AdvanceOffset Property
GlyphOffset Structure See Also Send Feedback
Offset in the advance direction of the run. A positive advance offset moves the glyph to the right (in pre-transform coordinates) if the run is left-to-right or to the left if the run is right-to-left.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float AdvanceOffset { get; set; }
Visual Basic
Public Property AdvanceOffset As Single
    Get
    Set
Visual C++
public:
property float AdvanceOffset {
    float get ();
    void set (float value);
}

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


AscenderOffset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphOffset..::..AscenderOffset Property
GlyphOffset Structure See Also Send Feedback
Offset in the ascent direction, i.e., the direction ascenders point. A positive ascender offset moves the glyph up (in pre-transform coordinates).

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float AscenderOffset { get; set; }
Visual Basic
Public Property AscenderOffset As Single
    Get
    Set
Visual C++
public:
property float AscenderOffset {
    float get ();
    void set (float value);
}

See Also

GlyphOffset Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphRun Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun Structure
Members See Also Send Feedback
Contains the information needed by renderers to draw glyph runs. All coordinates are in device independent pixels (DIPs).

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct GlyphRun
Visual Basic
Public Structure GlyphRun
Visual C++
public value class GlyphRun

See Also

GlyphRun Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphRun Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun Members
GlyphRun Structure Properties See Also Send Feedback

The GlyphRun type exposes the following members.

Properties

 | Name | Description
Public property | BidiLevel | The implicit resolved bidi level of the run. Odd levels indicate right-to-left languages like Hebrew and Arabic, while even levels indicate left-to-right languages like English and Japanese (when written horizontally). For right-to-left languages, the text origin is on the right, and text should be drawn to the left.
Public property | FontEmSize | Logical size of the font in DIPs, not points (equals 1/96 inch).
Public property | FontFace | The physical font face to draw with.
Public property | GlyphAdvances | Glyph advance widths.
Public property | GlyphIndexes | The indices to render.
Public property | GlyphOffsets | Glyph offsets.
Public property | IsSideways | If true, specifies that glyphs are rotated 90 degrees to the left and vertical metrics are used. Vertical writing is achieved by specifying isSideways = true and rotating the entire run 90 degrees to the right via a rotate transform.

See Also

GlyphRun Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphRun Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun Properties
GlyphRun Structure See Also Send Feedback

The GlyphRun type exposes the following members.

Properties

 | Name | Description
Public property | BidiLevel | The implicit resolved bidi level of the run. Odd levels indicate right-to-left languages like Hebrew and Arabic, while even levels indicate left-to-right languages like English and Japanese (when written horizontally). For right-to-left languages, the text origin is on the right, and text should be drawn to the left.
Public property | FontEmSize | Logical size of the font in DIPs, not points (equals 1/96 inch).
Public property | FontFace | The physical font face to draw with.
Public property | GlyphAdvances | Glyph advance widths.
Public property | GlyphIndexes | The indices to render.
Public property | GlyphOffsets | Glyph offsets.
Public property | IsSideways | If true, specifies that glyphs are rotated 90 degrees to the left and vertical metrics are used. Vertical writing is achieved by specifying isSideways = true and rotating the entire run 90 degrees to the right via a rotate transform.

See Also

GlyphRun Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


BidiLevel Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun..::..BidiLevel Property
GlyphRun Structure See Also Send Feedback
The implicit resolved bidi level of the run. Odd levels indicate right-to-left languages like Hebrew and Arabic, while even levels indicate left-to-right languages like English and Japanese (when written horizontally). For right-to-left languages, the text origin is on the right, and text should be drawn to the left.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BidiLevel { get; set; }
Visual Basic
Public Property BidiLevel As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BidiLevel {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

GlyphRun Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontEmSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun..::..FontEmSize Property
GlyphRun Structure See Also Send Feedback
Logical size of the font in DIPs, not points (equals 1/96 inch).

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float FontEmSize { get; set; }
Visual Basic
Public Property FontEmSize As Single
    Get
    Set
Visual C++
public:
property float FontEmSize {
    float get ();
    void set (float value);
}

See Also

GlyphRun Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFace Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun..::..FontFace Property
GlyphRun Structure See Also Send Feedback
The physical font face to draw with.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFace FontFace { get; set; }
Visual Basic
Public Property FontFace As FontFace
    Get
    Set
Visual C++
public:
property FontFace^ FontFace {
    FontFace^ get ();
    void set (FontFace^ value);
}

See Also

GlyphRun Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphAdvances Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun..::..GlyphAdvances Property
GlyphRun Structure See Also Send Feedback
Glyph advance widths.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<float> GlyphAdvances { get; set; }
Visual Basic
Public Property GlyphAdvances As IEnumerable(Of Single)
    Get
    Set
Visual C++
public:
property IEnumerable<float>^ GlyphAdvances {
    IEnumerable<float>^ get ();
    void set (IEnumerable<float>^ value);
}

See Also

GlyphRun Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphIndexes Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun..::..GlyphIndexes Property
GlyphRun Structure See Also Send Feedback
The indices to render.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<ushort> GlyphIndexes { get; set; }
Visual Basic
Public Property GlyphIndexes As IEnumerable(Of UShort)
    Get
    Set
Visual C++
public:
property IEnumerable<unsigned short>^ GlyphIndexes {
    IEnumerable<unsigned short>^ get ();
    void set (IEnumerable<unsigned short>^ value);
}

See Also

GlyphRun Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GlyphOffsets Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun..::..GlyphOffsets Property
GlyphRun Structure See Also Send Feedback
Glyph offsets.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<GlyphOffset> GlyphOffsets { get; set; }
Visual Basic
Public Property GlyphOffsets As IEnumerable(Of GlyphOffset)
    Get
    Set
Visual C++
public:
property IEnumerable<GlyphOffset>^ GlyphOffsets {
    IEnumerable<GlyphOffset>^ get ();
    void set (IEnumerable<GlyphOffset>^ value);
}

See Also

GlyphRun Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsSideways Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GlyphRun..::..IsSideways Property
GlyphRun Structure See Also Send Feedback
If true, specifies that glyphs are rotated 90 degrees to the left and vertical metrics are used. Vertical writing is achieved by specifying isSideways = true and rotating the entire run 90 degrees to the right via a rotate transform.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsSideways { get; set; }
Visual Basic
Public Property IsSideways As Boolean
    Get
    Set
Visual C++
public:
property bool IsSideways {
    bool get ();
    void set (bool value);
}

See Also

GlyphRun Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestInfo Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo Structure
Members See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct HitTestInfo
Visual Basic
Public Structure HitTestInfo
Visual C++
public value class HitTestInfo

See Also

HitTestInfo Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestInfo Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo Members
HitTestInfo Structure Methods Operators Properties See Also Send Feedback

The HitTestInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | IsInside | Indicates whether or not the hit-test location is actually inside the nearest text geometry. If this property is false, the IsTrailing property will indicate to which edge of the nearest geometry the hit-test location is located.
Public property | IsTrailing | Indicates whether the hit-test location is at the leading or the trailing side of the character. When the IsInside value is false, this value indicates where the hit-test location is relative to the text position as described by the Metrics property.
Public property | Location |
Public property | Metrics |

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestInfo Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo Methods
HitTestInfo Structure See Also Send Feedback

The HitTestInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo..::..Equals Method
HitTestInfo Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo..::..GetHashCode Method
HitTestInfo Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestInfo Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo Operators
HitTestInfo Structure See Also Send Feedback

The HitTestInfo type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo..::..Equality Operator
HitTestInfo Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    HitTestInfo info1,
    HitTestInfo info2
)
Visual Basic
Public Shared Operator = ( _
    info1 As HitTestInfo, _
    info2 As HitTestInfo _
) As Boolean
Visual C++
public:
static bool operator ==(
    HitTestInfo info1,
    HitTestInfo info2
)

Parameters

info1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..HitTestInfo
info2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..HitTestInfo

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo..::..Inequality Operator
HitTestInfo Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    HitTestInfo info1,
    HitTestInfo info2
)
Visual Basic
Public Shared Operator <> ( _
    info1 As HitTestInfo, _
    info2 As HitTestInfo _
) As Boolean
Visual C++
public:
static bool operator !=(
    HitTestInfo info1,
    HitTestInfo info2
)

Parameters

info1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..HitTestInfo
info2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..HitTestInfo

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestInfo Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo Properties
HitTestInfo Structure See Also Send Feedback

The HitTestInfo type exposes the following members.

Properties

 | Name | Description
Public property | IsInside | Indicates whether or not the hit-test location is actually inside the nearest text geometry. If this property is false, the IsTrailing property will indicate to which edge of the nearest geometry the hit-test location is located.
Public property | IsTrailing | Indicates whether the hit-test location is at the leading or the trailing side of the character. When the IsInside value is false, this value indicates where the hit-test location is relative to the text position as described by the Metrics property.
Public property | Location |
Public property | Metrics |

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsInside Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo..::..IsInside Property
HitTestInfo Structure See Also Send Feedback
Indicates whether or not the hit-test location is actually inside the nearest text geometry. If this property is false, the IsTrailing property will indicate to which edge of the nearest geometry the hit-test location is located.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsInside { get; }
Visual Basic
Public ReadOnly Property IsInside As Boolean
    Get
Visual C++
public:
property bool IsInside {
    bool get ();
}

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsTrailing Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo..::..IsTrailing Property
HitTestInfo Structure See Also Send Feedback
Indicates whether the hit-test location is at the leading or the trailing side of the character. When the IsInside value is false, this value indicates where the hit-test location is relative to the text position as described by the Metrics property.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsTrailing { get; }
Visual Basic
Public ReadOnly Property IsTrailing As Boolean
    Get
Visual C++
public:
property bool IsTrailing {
    bool get ();
}

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Location Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo..::..Location Property
HitTestInfo Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Point2F Location { get; }
Visual Basic
Public ReadOnly Property Location As Point2F
    Get
Visual C++
public:
property Point2F Location {
    Point2F get ();
}

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Metrics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestInfo..::..Metrics Property
HitTestInfo Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HitTestMetrics Metrics { get; }
Visual Basic
Public ReadOnly Property Metrics As HitTestMetrics
    Get
Visual C++
public:
property HitTestMetrics Metrics {
    HitTestMetrics get ();
}

See Also

HitTestInfo Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestMetrics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics Structure
Members See Also Send Feedback
Geometry enclosing of text positions.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct HitTestMetrics
Visual Basic
Public Structure HitTestMetrics
Visual C++
public value class HitTestMetrics

See Also

HitTestMetrics Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestMetrics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics Members
HitTestMetrics Structure Constructors Methods Operators Properties See Also Send Feedback

The HitTestMetrics type exposes the following members.

Constructors

 | Name | Description
Public method | HitTestMetrics | Constructor for HitTestMetrics

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BidiLevel | Bidi level of text positions enclosed within the geometry.
Public property | Height | Geometry's height.
Public property | IsText | Geometry encloses text?
Public property | IsTrimmed | Range is trimmed.
Public property | Left | Left position of the top-left coordinate of the geometry.
Public property | Length | Number of text positions within the geometry.
Public property | TextPosition | First text position within the geometry.
Public property | Top | Top position of the top-left coordinate of the geometry.
Public property | Width | Geometry's width.

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestMetrics Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics Constructor
HitTestMetrics Structure See Also Send Feedback
Constructor for HitTestMetrics

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HitTestMetrics(
    uint textPosition,
    uint length,
    float left,
    float top,
    float width,
    float height,
    uint bidirectionalLevel,
    bool isText,
    bool isTrimmed
)
Visual Basic
Public Sub New ( _
    textPosition As UInteger, _
    length As UInteger, _
    left As Single, _
    top As Single, _
    width As Single, _
    height As Single, _
    bidirectionalLevel As UInteger, _
    isText As Boolean, _
    isTrimmed As Boolean _
)
Visual C++
public:
HitTestMetrics(
    unsigned int textPosition,
    unsigned int length,
    float left,
    float top,
    float width,
    float height,
    unsigned int bidirectionalLevel,
    bool isText,
    bool isTrimmed
)

Parameters

textPosition
Type: System..::..UInt32
length
Type: System..::..UInt32
left
Type: System..::..Single
top
Type: System..::..Single
width
Type: System..::..Single
height
Type: System..::..Single
bidirectionalLevel
Type: System..::..UInt32
isText
Type: System..::..Boolean
isTrimmed
Type: System..::..Boolean

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestMetrics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics Methods
HitTestMetrics Structure See Also Send Feedback

The HitTestMetrics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..Equals Method
HitTestMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..GetHashCode Method
HitTestMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestMetrics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics Operators
HitTestMetrics Structure See Also Send Feedback

The HitTestMetrics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..Equality Operator
HitTestMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    HitTestMetrics hitTestMetrics1,
    HitTestMetrics hitTestMetrics2
)
Visual Basic
Public Shared Operator = ( _
    hitTestMetrics1 As HitTestMetrics, _
    hitTestMetrics2 As HitTestMetrics _
) As Boolean
Visual C++
public:
static bool operator ==(
    HitTestMetrics hitTestMetrics1,
    HitTestMetrics hitTestMetrics2
)

Parameters

hitTestMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..HitTestMetrics
hitTestMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..HitTestMetrics

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..Inequality Operator
HitTestMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    HitTestMetrics hitTestMetrics1,
    HitTestMetrics hitTestMetrics2
)
Visual Basic
Public Shared Operator <> ( _
    hitTestMetrics1 As HitTestMetrics, _
    hitTestMetrics2 As HitTestMetrics _
) As Boolean
Visual C++
public:
static bool operator !=(
    HitTestMetrics hitTestMetrics1,
    HitTestMetrics hitTestMetrics2
)

Parameters

hitTestMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..HitTestMetrics
hitTestMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..HitTestMetrics

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestMetrics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics Properties
HitTestMetrics Structure See Also Send Feedback

The HitTestMetrics type exposes the following members.

Properties

 | Name | Description
Public property | BidiLevel | Bidi level of text positions enclosed within the geometry.
Public property | Height | Geometry's height.
Public property | IsText | Geometry encloses text?
Public property | IsTrimmed | Range is trimmed.
Public property | Left | Left position of the top-left coordinate of the geometry.
Public property | Length | Number of text positions within the geometry.
Public property | TextPosition | First text position within the geometry.
Public property | Top | Top position of the top-left coordinate of the geometry.
Public property | Width | Geometry's width.

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


BidiLevel Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..BidiLevel Property
HitTestMetrics Structure See Also Send Feedback
Bidi level of text positions enclosed within the geometry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BidiLevel { get; set; }
Visual Basic
Public Property BidiLevel As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BidiLevel {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..Height Property
HitTestMetrics Structure See Also Send Feedback
Geometry's height.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsText Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..IsText Property
HitTestMetrics Structure See Also Send Feedback
Geometry encloses text?

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsText { get; set; }
Visual Basic
Public Property IsText As Boolean
    Get
    Set
Visual C++
public:
property bool IsText {
    bool get ();
    void set (bool value);
}

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsTrimmed Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..IsTrimmed Property
HitTestMetrics Structure See Also Send Feedback
Range is trimmed.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsTrimmed { get; set; }
Visual Basic
Public Property IsTrimmed As Boolean
    Get
    Set
Visual C++
public:
property bool IsTrimmed {
    bool get ();
    void set (bool value);
}

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Left Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..Left Property
HitTestMetrics Structure See Also Send Feedback
Left position of the top-left coordinate of the geometry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Left { get; set; }
Visual Basic
Public Property Left As Single
    Get
    Set
Visual C++
public:
property float Left {
    float get ();
    void set (float value);
}

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Length Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..Length Property
HitTestMetrics Structure See Also Send Feedback
Number of text positions within the geometry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Length { get; set; }
Visual Basic
Public Property Length As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextPosition Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..TextPosition Property
HitTestMetrics Structure See Also Send Feedback
First text position within the geometry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TextPosition { get; set; }
Visual Basic
Public Property TextPosition As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TextPosition {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Top Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..Top Property
HitTestMetrics Structure See Also Send Feedback
Top position of the top-left coordinate of the geometry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Top { get; set; }
Visual Basic
Public Property Top As Single
    Get
    Set
Visual C++
public:
property float Top {
    float get ();
    void set (float value);
}

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
HitTestMetrics..::..Width Property
HitTestMetrics Structure See Also Send Feedback
Geometry's width.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

HitTestMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ICustomInlineObject Interface

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ICustomInlineObject Interface
Members See Also Send Feedback
Wraps an application defined inline graphic, allowing DWrite to query metrics as if it was a glyph inline with the text.

(Also see DirectX SDK: IDWriteInlineObject)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public interface ICustomInlineObject
Visual Basic
Public Interface ICustomInlineObject
Visual C++
public interface class ICustomInlineObject

See Also

ICustomInlineObject Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ICustomInlineObject Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ICustomInlineObject Members
ICustomInlineObject Interface Methods Properties See Also Send Feedback

The ICustomInlineObject type exposes the following members.

Methods

 | Name | Description
Public method | Draw | The application implemented rendering callback (IDWriteTextRenderer::DrawInlineObject) can use this to draw the inline object without needing to cast or query the object type. The text layout does not call this method directly.

Properties

 | Name | Description
Public property | BreakConditionAfter | Layout uses this to determine the line breaking behavior of the inline object amidst the text. Should return the line-breaking condition between the object and the content immediately following it.
Public property | BreakConditionBefore | Layout uses this to determine the line breaking behavior of the inline object amidst the text. Should return the line-breaking condition between the object and the content immediately preceding it.
Public property | Metrics | TextLayout calls this callback function to get the measurement of the inline object.
Public property | OverhangMetrics | TextLayout calls this callback function to get the visible extents (in DIPs) of the inline object. In the case of a simple bitmap, with no padding and no overhang, all the overhangs will simply be zeroes.

See Also

ICustomInlineObject Interface
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ICustomInlineObject Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ICustomInlineObject Methods
ICustomInlineObject Interface See Also Send Feedback

The ICustomInlineObject type exposes the following members.

Methods

 | Name | Description
Public method | Draw | The application implemented rendering callback (IDWriteTextRenderer::DrawInlineObject) can use this to draw the inline object without needing to cast or query the object type. The text layout does not call this method directly.

See Also

ICustomInlineObject Interface
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Draw Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ICustomInlineObject..::..Draw Method
ICustomInlineObject Interface See Also Send Feedback
The application implemented rendering callback (IDWriteTextRenderer::DrawInlineObject) can use this to draw the inline object without needing to cast or query the object type. The text layout does not call this method directly.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
void Draw(
    float originX,
    float originY,
    bool isSideways,
    bool isRightToLeft,
    Brush clientDrawingEffect
)
Visual Basic
Sub Draw ( _
    originX As Single, _
    originY As Single, _
    isSideways As Boolean, _
    isRightToLeft As Boolean, _
    clientDrawingEffect As Brush _
)
Visual C++
void Draw(
    float originX,
    float originY,
    bool isSideways,
    bool isRightToLeft,
    Brush^ clientDrawingEffect
)

Parameters

originX
Type: System..::..Single
X-coordinate at the top-left corner of the inline object.
originY
Type: System..::..Single
Y-coordinate at the top-left corner of the inline object.
isSideways
Type: System..::..Boolean
The object should be drawn on its side.
isRightToLeft
Type: System..::..Boolean
The object is in an right-to-left context and should be drawn flipped.
clientDrawingEffect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Brush
The drawing effect. This is usually a foreground brush.

See Also

ICustomInlineObject Interface
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ICustomInlineObject Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ICustomInlineObject Properties
ICustomInlineObject Interface See Also Send Feedback

The ICustomInlineObject type exposes the following members.

Properties

 | Name | Description
Public property | BreakConditionAfter | Layout uses this to determine the line breaking behavior of the inline object amidst the text. Should return the line-breaking condition between the object and the content immediately following it.
Public property | BreakConditionBefore | Layout uses this to determine the line breaking behavior of the inline object amidst the text. Should return the line-breaking condition between the object and the content immediately preceding it.
Public property | Metrics | TextLayout calls this callback function to get the measurement of the inline object.
Public property | OverhangMetrics | TextLayout calls this callback function to get the visible extents (in DIPs) of the inline object. In the case of a simple bitmap, with no padding and no overhang, all the overhangs will simply be zeroes.

See Also

ICustomInlineObject Interface
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


BreakConditionAfter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ICustomInlineObject..::..BreakConditionAfter Property
ICustomInlineObject Interface See Also Send Feedback
Layout uses this to determine the line breaking behavior of the inline object amidst the text. Should return the line-breaking condition between the object and the content immediately following it.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
BreakCondition BreakConditionAfter { get; }
Visual Basic
ReadOnly Property BreakConditionAfter As BreakCondition
    Get
Visual C++
property BreakCondition BreakConditionAfter {
    BreakCondition get ();
}

See Also

ICustomInlineObject Interface
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


BreakConditionBefore Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ICustomInlineObject..::..BreakConditionBefore Property
ICustomInlineObject Interface See Also Send Feedback
Layout uses this to determine the line breaking behavior of the inline object amidst the text. Should return the line-breaking condition between the object and the content immediately preceding it.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
BreakCondition BreakConditionBefore { get; }
Visual Basic
ReadOnly Property BreakConditionBefore As BreakCondition
    Get
Visual C++
property BreakCondition BreakConditionBefore {
    BreakCondition get ();
}

See Also

ICustomInlineObject Interface
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Metrics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ICustomInlineObject..::..Metrics Property
ICustomInlineObject Interface See Also Send Feedback
TextLayout calls this callback function to get the measurement of the inline object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
InlineObjectMetrics Metrics { get; }
Visual Basic
ReadOnly Property Metrics As InlineObjectMetrics
    Get
Visual C++
property InlineObjectMetrics Metrics {
    InlineObjectMetrics get ();
}

See Also

ICustomInlineObject Interface
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


OverhangMetrics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ICustomInlineObject..::..OverhangMetrics Property
ICustomInlineObject Interface See Also Send Feedback
TextLayout calls this callback function to get the visible extents (in DIPs) of the inline object. In the case of a simple bitmap, with no padding and no overhang, all the overhangs will simply be zeroes.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
OverhangMetrics OverhangMetrics { get; }
Visual Basic
ReadOnly Property OverhangMetrics As OverhangMetrics
    Get
Visual C++
property OverhangMetrics OverhangMetrics {
    OverhangMetrics get ();
}

Remarks

The overhangs should be returned relative to the reported size of the object (InlineObjectMetrics width/height), and should not be baseline adjusted. If you have an image that is actually 100x100 DIPs, but you want it slightly inset (perhaps it has a glow) by 20 DIPs on each side, you would return a width/height of 60x60 and four overhangs of 20 DIPs.

See Also

ICustomInlineObject Interface
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InformationalStringId Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InformationalStringId Enumeration
See Also Send Feedback
The informational string enumeration identifies a string in a font.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum InformationalStringId
Visual Basic
Public Enumeration InformationalStringId
Visual C++
public enum class InformationalStringId

Members

Member name | Description
None |
SampleText |
PreferredSubfamilyNames |
PreferredFamilyNames |
Win32SubfamilyNames |
Win32FamilyNames |
LicenseInfoUrl |
LicenseDescription |
FontVendorUrl |
Description |
DesignerUrl |
Designer |
Manufacturer |
Trademark |
VersionStrings |
CopyrightNotice |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InlineObject Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObject Class
Members See Also Send Feedback
Wraps an inline graphic.

(Also see DirectX SDK: IDWriteInlineObject)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class InlineObject : DirectUnknown,
    ICustomInlineObject
Visual Basic
Public Class InlineObject _
    Inherits DirectUnknown _
    Implements ICustomInlineObject
Visual C++
public ref class InlineObject : public DirectUnknown,
    ICustomInlineObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..InlineObject

See Also

InlineObject Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InlineObject Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObject Members
InlineObject Class Properties See Also Send Feedback

The InlineObject type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

InlineObject Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InlineObject Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObject Properties
InlineObject Class See Also Send Feedback

The InlineObject type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

InlineObject Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InlineObjectMetrics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics Structure
Members See Also Send Feedback
Properties describing the geometric measurement of an application-defined inline object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct InlineObjectMetrics
Visual Basic
Public Structure InlineObjectMetrics
Visual C++
public value class InlineObjectMetrics

See Also

InlineObjectMetrics Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InlineObjectMetrics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics Members
InlineObjectMetrics Structure Constructors Methods Operators Properties See Also Send Feedback

The InlineObjectMetrics type exposes the following members.

Constructors

 | Name | Description
Public method | InlineObjectMetrics | Constructor for InlineObjectMetrics

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Baseline | Distance from the top of the object to the baseline where it is lined up with the adjacent text. If the baseline is at the bottom, baseline simply equals height.
Public property | Height | Height of the inline object as measured from top to bottom.
Public property | SupportsSideways | Flag indicating whether the object is to be placed upright or alongside the text baseline for vertical text.
Public property | Width | Width of the inline object.

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InlineObjectMetrics Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics Constructor
InlineObjectMetrics Structure See Also Send Feedback
Constructor for InlineObjectMetrics

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public InlineObjectMetrics(
    float width,
    float height,
    float baseline,
    bool supportsSideways
)
Visual Basic
Public Sub New ( _
    width As Single, _
    height As Single, _
    baseline As Single, _
    supportsSideways As Boolean _
)
Visual C++
public:
InlineObjectMetrics(
    float width,
    float height,
    float baseline,
    bool supportsSideways
)

Parameters

width
Type: System..::..Single
height
Type: System..::..Single
baseline
Type: System..::..Single
supportsSideways
Type: System..::..Boolean

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InlineObjectMetrics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics Methods
InlineObjectMetrics Structure See Also Send Feedback

The InlineObjectMetrics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics..::..Equals Method
InlineObjectMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics..::..GetHashCode Method
InlineObjectMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InlineObjectMetrics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics Operators
InlineObjectMetrics Structure See Also Send Feedback

The InlineObjectMetrics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics..::..Equality Operator
InlineObjectMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    InlineObjectMetrics inlineObjectMetrics1,
    InlineObjectMetrics inlineObjectMetrics2
)
Visual Basic
Public Shared Operator = ( _
    inlineObjectMetrics1 As InlineObjectMetrics, _
    inlineObjectMetrics2 As InlineObjectMetrics _
) As Boolean
Visual C++
public:
static bool operator ==(
    InlineObjectMetrics inlineObjectMetrics1,
    InlineObjectMetrics inlineObjectMetrics2
)

Parameters

inlineObjectMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..InlineObjectMetrics
inlineObjectMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..InlineObjectMetrics

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics..::..Inequality Operator
InlineObjectMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    InlineObjectMetrics inlineObjectMetrics1,
    InlineObjectMetrics inlineObjectMetrics2
)
Visual Basic
Public Shared Operator <> ( _
    inlineObjectMetrics1 As InlineObjectMetrics, _
    inlineObjectMetrics2 As InlineObjectMetrics _
) As Boolean
Visual C++
public:
static bool operator !=(
    InlineObjectMetrics inlineObjectMetrics1,
    InlineObjectMetrics inlineObjectMetrics2
)

Parameters

inlineObjectMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..InlineObjectMetrics
inlineObjectMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..InlineObjectMetrics

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


InlineObjectMetrics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics Properties
InlineObjectMetrics Structure See Also Send Feedback

The InlineObjectMetrics type exposes the following members.

Properties

 | Name | Description
Public property | Baseline | Distance from the top of the object to the baseline where it is lined up with the adjacent text. If the baseline is at the bottom, baseline simply equals height.
Public property | Height | Height of the inline object as measured from top to bottom.
Public property | SupportsSideways | Flag indicating whether the object is to be placed upright or alongside the text baseline for vertical text.
Public property | Width | Width of the inline object.

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Baseline Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics..::..Baseline Property
InlineObjectMetrics Structure See Also Send Feedback
Distance from the top of the object to the baseline where it is lined up with the adjacent text. If the baseline is at the bottom, baseline simply equals height.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Baseline { get; set; }
Visual Basic
Public Property Baseline As Single
    Get
    Set
Visual C++
public:
property float Baseline {
    float get ();
    void set (float value);
}

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics..::..Height Property
InlineObjectMetrics Structure See Also Send Feedback
Height of the inline object as measured from top to bottom.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SupportsSideways Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics..::..SupportsSideways Property
InlineObjectMetrics Structure See Also Send Feedback
Flag indicating whether the object is to be placed upright or alongside the text baseline for vertical text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool SupportsSideways { get; set; }
Visual Basic
Public Property SupportsSideways As Boolean
    Get
    Set
Visual C++
public:
property bool SupportsSideways {
    bool get ();
    void set (bool value);
}

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
InlineObjectMetrics..::..Width Property
InlineObjectMetrics Structure See Also Send Feedback
Width of the inline object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

InlineObjectMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineMetrics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics Structure
Members See Also Send Feedback
Contains information about a formatted line of text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct LineMetrics
Visual Basic
Public Structure LineMetrics
Visual C++
public value class LineMetrics

See Also

LineMetrics Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineMetrics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics Members
LineMetrics Structure Constructors Methods Operators Properties See Also Send Feedback

The LineMetrics type exposes the following members.

Constructors

 | Name | Description
Public method | LineMetrics | Constructor for LineMetrics

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Baseline | Distance from the top of the line to its baseline.
Public property | Height | Height of the line as measured from top to bottom.
Public property | IsTrimmed | The line is trimmed.
Public property | Length | The number of total text positions in the line. This includes any trailing whitespace and newline characters.
Public property | NewlineLength | The number of characters in the newline sequence at the end of the line. If the count is zero, then the line was either wrapped or it is the end of the text.
Public property | TrailingWhitespaceLength | The number of whitespace positions at the end of the line. Newline sequences are considered whitespace.

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineMetrics Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics Constructor
LineMetrics Structure See Also Send Feedback
Constructor for LineMetrics

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LineMetrics(
    uint length,
    uint trailingWhitespaceLength,
    uint newlineLength,
    float height,
    float baseline,
    bool isTrimmed
)
Visual Basic
Public Sub New ( _
    length As UInteger, _
    trailingWhitespaceLength As UInteger, _
    newlineLength As UInteger, _
    height As Single, _
    baseline As Single, _
    isTrimmed As Boolean _
)
Visual C++
public:
LineMetrics(
    unsigned int length,
    unsigned int trailingWhitespaceLength,
    unsigned int newlineLength,
    float height,
    float baseline,
    bool isTrimmed
)

Parameters

length
Type: System..::..UInt32
trailingWhitespaceLength
Type: System..::..UInt32
newlineLength
Type: System..::..UInt32
height
Type: System..::..Single
baseline
Type: System..::..Single
isTrimmed
Type: System..::..Boolean

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineMetrics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics Methods
LineMetrics Structure See Also Send Feedback

The LineMetrics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..Equals Method
LineMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..GetHashCode Method
LineMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineMetrics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics Operators
LineMetrics Structure See Also Send Feedback

The LineMetrics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..Equality Operator
LineMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    LineMetrics lineMetrics1,
    LineMetrics lineMetrics2
)
Visual Basic
Public Shared Operator = ( _
    lineMetrics1 As LineMetrics, _
    lineMetrics2 As LineMetrics _
) As Boolean
Visual C++
public:
static bool operator ==(
    LineMetrics lineMetrics1,
    LineMetrics lineMetrics2
)

Parameters

lineMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..LineMetrics
lineMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..LineMetrics

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..Inequality Operator
LineMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    LineMetrics lineMetrics1,
    LineMetrics lineMetrics2
)
Visual Basic
Public Shared Operator <> ( _
    lineMetrics1 As LineMetrics, _
    lineMetrics2 As LineMetrics _
) As Boolean
Visual C++
public:
static bool operator !=(
    LineMetrics lineMetrics1,
    LineMetrics lineMetrics2
)

Parameters

lineMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..LineMetrics
lineMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..LineMetrics

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineMetrics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics Properties
LineMetrics Structure See Also Send Feedback

The LineMetrics type exposes the following members.

Properties

 | Name | Description
Public property | Baseline | Distance from the top of the line to its baseline.
Public property | Height | Height of the line as measured from top to bottom.
Public property | IsTrimmed | The line is trimmed.
Public property | Length | The number of total text positions in the line. This includes any trailing whitespace and newline characters.
Public property | NewlineLength | The number of characters in the newline sequence at the end of the line. If the count is zero, then the line was either wrapped or it is the end of the text.
Public property | TrailingWhitespaceLength | The number of whitespace positions at the end of the line. Newline sequences are considered whitespace.

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Baseline Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..Baseline Property
LineMetrics Structure See Also Send Feedback
Distance from the top of the line to its baseline.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Baseline { get; set; }
Visual Basic
Public Property Baseline As Single
    Get
    Set
Visual C++
public:
property float Baseline {
    float get ();
    void set (float value);
}

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..Height Property
LineMetrics Structure See Also Send Feedback
Height of the line as measured from top to bottom.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsTrimmed Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..IsTrimmed Property
LineMetrics Structure See Also Send Feedback
The line is trimmed.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsTrimmed { get; set; }
Visual Basic
Public Property IsTrimmed As Boolean
    Get
    Set
Visual C++
public:
property bool IsTrimmed {
    bool get ();
    void set (bool value);
}

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Length Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..Length Property
LineMetrics Structure See Also Send Feedback
The number of total text positions in the line. This includes any trailing whitespace and newline characters.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Length { get; set; }
Visual Basic
Public Property Length As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


NewlineLength Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..NewlineLength Property
LineMetrics Structure See Also Send Feedback
The number of characters in the newline sequence at the end of the line. If the count is zero, then the line was either wrapped or it is the end of the text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint NewlineLength { get; set; }
Visual Basic
Public Property NewlineLength As UInteger
    Get
    Set
Visual C++
public:
property unsigned int NewlineLength {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TrailingWhitespaceLength Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineMetrics..::..TrailingWhitespaceLength Property
LineMetrics Structure See Also Send Feedback
The number of whitespace positions at the end of the line. Newline sequences are considered whitespace.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint TrailingWhitespaceLength { get; set; }
Visual Basic
Public Property TrailingWhitespaceLength As UInteger
    Get
    Set
Visual C++
public:
property unsigned int TrailingWhitespaceLength {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

LineMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineSpacing Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing Structure
Members See Also Send Feedback
Line spacing parameters.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct LineSpacing
Visual Basic
Public Structure LineSpacing
Visual C++
public value class LineSpacing

Remarks

For the default line spacing method, spacing depends solely on the content. For uniform line spacing, the given line height will override the content.

See Also

LineSpacing Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineSpacing Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing Members
LineSpacing Structure Constructors Methods Operators Properties See Also Send Feedback

The LineSpacing type exposes the following members.

Constructors

 | Name | Description
Public method | LineSpacing | Constructor for LineSpacing

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Baseline | Distance from top of line to baseline. A reasonable ratio to Height is 80%.
Public property | Height | The line height, or rather distance between one baseline to another.
Public property | LineSpacingMethod | How line height is determined.

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineSpacing Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing Constructor
LineSpacing Structure See Also Send Feedback
Constructor for LineSpacing

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LineSpacing(
    LineSpacingMethod lineSpacingMethod,
    float height,
    float baseline
)
Visual Basic
Public Sub New ( _
    lineSpacingMethod As LineSpacingMethod, _
    height As Single, _
    baseline As Single _
)
Visual C++
public:
LineSpacing(
    LineSpacingMethod lineSpacingMethod,
    float height,
    float baseline
)

Parameters

lineSpacingMethod
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..LineSpacingMethod
Initializes the LineSpaceingMethod field.
height
Type: System..::..Single
Initializes the Height field.
baseline
Type: System..::..Single
Initializes the Baseline field.

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineSpacing Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing Methods
LineSpacing Structure See Also Send Feedback

The LineSpacing type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing..::..Equals Method
LineSpacing Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing..::..GetHashCode Method
LineSpacing Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineSpacing Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing Operators
LineSpacing Structure See Also Send Feedback

The LineSpacing type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing..::..Equality Operator
LineSpacing Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    LineSpacing lineSpacing1,
    LineSpacing lineSpacing2
)
Visual Basic
Public Shared Operator = ( _
    lineSpacing1 As LineSpacing, _
    lineSpacing2 As LineSpacing _
) As Boolean
Visual C++
public:
static bool operator ==(
    LineSpacing lineSpacing1,
    LineSpacing lineSpacing2
)

Parameters

lineSpacing1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..LineSpacing
lineSpacing2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..LineSpacing

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing..::..Inequality Operator
LineSpacing Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    LineSpacing lineSpacing1,
    LineSpacing lineSpacing2
)
Visual Basic
Public Shared Operator <> ( _
    lineSpacing1 As LineSpacing, _
    lineSpacing2 As LineSpacing _
) As Boolean
Visual C++
public:
static bool operator !=(
    LineSpacing lineSpacing1,
    LineSpacing lineSpacing2
)

Parameters

lineSpacing1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..LineSpacing
lineSpacing2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..LineSpacing

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineSpacing Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing Properties
LineSpacing Structure See Also Send Feedback

The LineSpacing type exposes the following members.

Properties

 | Name | Description
Public property | Baseline | Distance from top of line to baseline. A reasonable ratio to Height is 80%.
Public property | Height | The line height, or rather distance between one baseline to another.
Public property | LineSpacingMethod | How line height is determined.

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Baseline Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing..::..Baseline Property
LineSpacing Structure See Also Send Feedback
Distance from top of line to baseline. A reasonable ratio to Height is 80%.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Baseline { get; set; }
Visual Basic
Public Property Baseline As Single
    Get
    Set
Visual C++
public:
property float Baseline {
    float get ();
    void set (float value);
}

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing..::..Height Property
LineSpacing Structure See Also Send Feedback
The line height, or rather distance between one baseline to another.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineSpacingMethod Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacing..::..LineSpacingMethod Property
LineSpacing Structure See Also Send Feedback
How line height is determined.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LineSpacingMethod LineSpacingMethod { get; set; }
Visual Basic
Public Property LineSpacingMethod As LineSpacingMethod
    Get
    Set
Visual C++
public:
property LineSpacingMethod LineSpacingMethod {
    LineSpacingMethod get ();
    void set (LineSpacingMethod value);
}

See Also

LineSpacing Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineSpacingMethod Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
LineSpacingMethod Enumeration
See Also Send Feedback
The method used for line spacing in layout.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum LineSpacingMethod
Visual Basic
Public Enumeration LineSpacingMethod
Visual C++
public enum class LineSpacingMethod

Members

Member name | Description
Uniform |
Default |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


MeasuringMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MeasuringMode Enumeration
See Also Send Feedback
The measuring method used for text layout.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum MeasuringMode
Visual Basic
Public Enumeration MeasuringMode
Visual C++
public enum class MeasuringMode

Members

Member name | Description
GdiNatural |
GdiClassic |
Natural |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


OverhangMetrics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics Structure
Members See Also Send Feedback
Holds information about how much any visible pixels (in DIPs) overshoot each side of the layout or inline objects.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct OverhangMetrics
Visual Basic
Public Structure OverhangMetrics
Visual C++
public value class OverhangMetrics

Remarks

Positive overhangs indicate that the visible area extends outside the layout box or inline object, while negative values mean there is whitespace inside. The returned values are unaffected by rendering transforms or pixel snapping. Additionally, they may not exactly match final target's pixel bounds after applying grid fitting and hinting.

See Also

OverhangMetrics Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


OverhangMetrics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics Members
OverhangMetrics Structure Constructors Methods Operators Properties See Also Send Feedback

The OverhangMetrics type exposes the following members.

Constructors

 | Name | Description
Public method | OverhangMetrics | Constructor for OverhangMetrics

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Bottom | The distance from the bottom-most visible DIP to its bottom alignment edge.
Public property | Left | The distance from the left-most visible DIP to its left alignment edge.
Public property | Right | The distance from the right-most visible DIP to its right alignment edge.
Public property | Top | The distance from the top-most visible DIP to its top alignment edge.

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


OverhangMetrics Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics Constructor
OverhangMetrics Structure See Also Send Feedback
Constructor for OverhangMetrics

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OverhangMetrics(
    float left,
    float top,
    float right,
    float bottom
)
Visual Basic
Public Sub New ( _
    left As Single, _
    top As Single, _
    right As Single, _
    bottom As Single _
)
Visual C++
public:
OverhangMetrics(
    float left,
    float top,
    float right,
    float bottom
)

Parameters

left
Type: System..::..Single
top
Type: System..::..Single
right
Type: System..::..Single
bottom
Type: System..::..Single

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


OverhangMetrics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics Methods
OverhangMetrics Structure See Also Send Feedback

The OverhangMetrics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics..::..Equals Method
OverhangMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics..::..GetHashCode Method
OverhangMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


OverhangMetrics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics Operators
OverhangMetrics Structure See Also Send Feedback

The OverhangMetrics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics..::..Equality Operator
OverhangMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    OverhangMetrics overhangMetrics1,
    OverhangMetrics overhangMetrics2
)
Visual Basic
Public Shared Operator = ( _
    overhangMetrics1 As OverhangMetrics, _
    overhangMetrics2 As OverhangMetrics _
) As Boolean
Visual C++
public:
static bool operator ==(
    OverhangMetrics overhangMetrics1,
    OverhangMetrics overhangMetrics2
)

Parameters

overhangMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..OverhangMetrics
overhangMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..OverhangMetrics

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics..::..Inequality Operator
OverhangMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    OverhangMetrics overhangMetrics1,
    OverhangMetrics overhangMetrics2
)
Visual Basic
Public Shared Operator <> ( _
    overhangMetrics1 As OverhangMetrics, _
    overhangMetrics2 As OverhangMetrics _
) As Boolean
Visual C++
public:
static bool operator !=(
    OverhangMetrics overhangMetrics1,
    OverhangMetrics overhangMetrics2
)

Parameters

overhangMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..OverhangMetrics
overhangMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..OverhangMetrics

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


OverhangMetrics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics Properties
OverhangMetrics Structure See Also Send Feedback

The OverhangMetrics type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | The distance from the bottom-most visible DIP to its bottom alignment edge.
Public property | Left | The distance from the left-most visible DIP to its left alignment edge.
Public property | Right | The distance from the right-most visible DIP to its right alignment edge.
Public property | Top | The distance from the top-most visible DIP to its top alignment edge.

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Bottom Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics..::..Bottom Property
OverhangMetrics Structure See Also Send Feedback
The distance from the bottom-most visible DIP to its bottom alignment edge.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Bottom { get; set; }
Visual Basic
Public Property Bottom As Single
    Get
    Set
Visual C++
public:
property float Bottom {
    float get ();
    void set (float value);
}

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Left Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics..::..Left Property
OverhangMetrics Structure See Also Send Feedback
The distance from the left-most visible DIP to its left alignment edge.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Left { get; set; }
Visual Basic
Public Property Left As Single
    Get
    Set
Visual C++
public:
property float Left {
    float get ();
    void set (float value);
}

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Right Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics..::..Right Property
OverhangMetrics Structure See Also Send Feedback
The distance from the right-most visible DIP to its right alignment edge.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Right { get; set; }
Visual Basic
Public Property Right As Single
    Get
    Set
Visual C++
public:
property float Right {
    float get ();
    void set (float value);
}

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Top Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OverhangMetrics..::..Top Property
OverhangMetrics Structure See Also Send Feedback
The distance from the top-most visible DIP to its top alignment edge.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Top { get; set; }
Visual Basic
Public Property Top As Single
    Get
    Set
Visual C++
public:
property float Top {
    float get ();
    void set (float value);
}

See Also

OverhangMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ParagraphAlignment Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ParagraphAlignment Enumeration
See Also Send Feedback
Alignment of paragraph text along the flow direction axis relative to the flow's beginning and ending edge of the layout box.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ParagraphAlignment
Visual Basic
Public Enumeration ParagraphAlignment
Visual C++
public enum class ParagraphAlignment

Members

Member name | Description
Center |
Far |
Near |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


PixelGeometry Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelGeometry Enumeration
See Also Send Feedback
Represents the internal structure of a device pixel (i.e., the physical arrangement of red, green, and blue color components) that is assumed for purposes of rendering text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum PixelGeometry
Visual Basic
Public Enumeration PixelGeometry
Visual C++
public enum class PixelGeometry

Members

Member name | Description
Bgr |
Rgb |
Flat |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ReadingDirection Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ReadingDirection Enumeration
See Also Send Feedback
Direction for how reading progresses.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ReadingDirection
Visual Basic
Public Enumeration ReadingDirection
Visual C++
public enum class ReadingDirection

Members

Member name | Description
RightToLeft |
LeftToRight |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


RenderingMode Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderingMode Enumeration
See Also Send Feedback
Represents a method of rendering glyphs.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum RenderingMode
Visual Basic
Public Enumeration RenderingMode
Visual C++
public enum class RenderingMode

Members

Member name | Description
Outline |
ClearTypeNaturalSymmetric |
ClearTypeNatural |
ClearTypeGdiNatural |
ClearTypeGdiClassic |
Aliased |
Default |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


RenderingParams Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderingParams Class
Members See Also Send Feedback
Represents text rendering settings such as ClearType level, enhanced contrast, and gamma correction for glyph rasterization and filtering.

(Also see DirectX SDK: IDWriteRenderingParams)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class RenderingParams : DirectUnknown
Visual Basic
Public Class RenderingParams _
    Inherits DirectUnknown
Visual C++
public ref class RenderingParams : public DirectUnknown

Remarks

Create a rendering params object by classing one of DWriteFactory's RenderingParam creation methods: CreateRenderingParams()()()(), CreateMonitorRenderingParams(IntPtr), or CreateCustomRenderingParams(Single, Single, Single, PixelGeometry, RenderingMode)

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..RenderingParams

See Also

RenderingParams Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


RenderingParams Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderingParams Members
RenderingParams Class Properties See Also Send Feedback

The RenderingParams type exposes the following members.

Properties

 | Name | Description
Public property | ClearTypeLevel | Gets the ClearType level. Valid values range from 0.0f (no ClearType) to 1.0f (full ClearType).
Public property | EnhancedContrast | Gets the amount of contrast enhancement. Valid values are greater than or equal to zero.
Public property | Gamma | Gets the gamma value used for gamma correction. Valid values must be greater than zero and cannot exceed 256.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelGeometry | Gets the pixel geometry.
Public property | RenderingMode | Gets the rendering mode.

See Also

RenderingParams Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


RenderingParams Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderingParams Properties
RenderingParams Class See Also Send Feedback

The RenderingParams type exposes the following members.

Properties

 | Name | Description
Public property | ClearTypeLevel | Gets the ClearType level. Valid values range from 0.0f (no ClearType) to 1.0f (full ClearType).
Public property | EnhancedContrast | Gets the amount of contrast enhancement. Valid values are greater than or equal to zero.
Public property | Gamma | Gets the gamma value used for gamma correction. Valid values must be greater than zero and cannot exceed 256.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelGeometry | Gets the pixel geometry.
Public property | RenderingMode | Gets the rendering mode.

See Also

RenderingParams Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ClearTypeLevel Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderingParams..::..ClearTypeLevel Property
RenderingParams Class See Also Send Feedback
Gets the ClearType level. Valid values range from 0.0f (no ClearType) to 1.0f (full ClearType).

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float ClearTypeLevel { get; }
Visual Basic
Public ReadOnly Property ClearTypeLevel As Single
    Get
Visual C++
public:
property float ClearTypeLevel {
    float get ();
}

See Also

RenderingParams Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


EnhancedContrast Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderingParams..::..EnhancedContrast Property
RenderingParams Class See Also Send Feedback
Gets the amount of contrast enhancement. Valid values are greater than or equal to zero.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float EnhancedContrast { get; }
Visual Basic
Public ReadOnly Property EnhancedContrast As Single
    Get
Visual C++
public:
property float EnhancedContrast {
    float get ();
}

See Also

RenderingParams Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Gamma Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderingParams..::..Gamma Property
RenderingParams Class See Also Send Feedback
Gets the gamma value used for gamma correction. Valid values must be greater than zero and cannot exceed 256.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Gamma { get; }
Visual Basic
Public ReadOnly Property Gamma As Single
    Get
Visual C++
public:
property float Gamma {
    float get ();
}

See Also

RenderingParams Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


PixelGeometry Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderingParams..::..PixelGeometry Property
RenderingParams Class See Also Send Feedback
Gets the pixel geometry.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public PixelGeometry PixelGeometry { get; }
Visual Basic
Public ReadOnly Property PixelGeometry As PixelGeometry
    Get
Visual C++
public:
property PixelGeometry PixelGeometry {
    PixelGeometry get ();
}

See Also

RenderingParams Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


RenderingMode Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
RenderingParams..::..RenderingMode Property
RenderingParams Class See Also Send Feedback
Gets the rendering mode.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public RenderingMode RenderingMode { get; }
Visual Basic
Public ReadOnly Property RenderingMode As RenderingMode
    Get
Visual C++
public:
property RenderingMode RenderingMode {
    RenderingMode get ();
}

See Also

RenderingParams Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextAlignment Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextAlignment Enumeration
See Also Send Feedback
Alignment of paragraph text along the reading direction axis relative to the leading and trailing edge of the layout box.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum TextAlignment
Visual Basic
Public Enumeration TextAlignment
Visual C++
public enum class TextAlignment

Members

Member name | Description
Center |
Trailing |
Leading |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextFormat Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat Class
Members See Also Send Feedback
The format of text used for text layout purpose.

(Also see DirectX SDK: IDWriteTextFormat)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class TextFormat : DirectUnknown
Visual Basic
Public Class TextFormat _
    Inherits DirectUnknown
Visual C++
public ref class TextFormat : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextLayout

See Also

TextFormat Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextFormat Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat Members
TextFormat Class Properties See Also Send Feedback

The TextFormat type exposes the following members.

Properties

 | Name | Description
Public property | CultureInfo | Get the CultureInfo for this object.
Public property | FlowDirection | Get or Set paragraph flow direction.
Public property | FontFamilyName |
Public property | FontSize | Get the font em height.
Public property | FontStretch | Get the font stretch.
Public property | FontStyle | Get the font style.
Public property | FontWeight | Get the font weight.
Public property | IncrementalTabStop | Set incremental tab stop position.
Public property | LineSpacing | Get or Set line spacing.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ParagraphAlignment | Get or Set alignment option of paragraph relative to layout box's top and bottom edge.
Public property | ReadingDirection | Get or Set paragraph reading direction.
Public property | TextAlignment | Get or Set alignment option of text relative to layout box's leading and trailing edge.
Public property | Trimming | Gets or sets trimming options.
Public property | TrimmingWithSign | Gets and sets trimming options for text overflowing the layout width, including the trimming sign object.
Public property | WordWrapping | Get or Set word wrapping option.

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextFormat Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat Properties
TextFormat Class See Also Send Feedback

The TextFormat type exposes the following members.

Properties

 | Name | Description
Public property | CultureInfo | Get the CultureInfo for this object.
Public property | FlowDirection | Get or Set paragraph flow direction.
Public property | FontFamilyName |
Public property | FontSize | Get the font em height.
Public property | FontStretch | Get the font stretch.
Public property | FontStyle | Get the font style.
Public property | FontWeight | Get the font weight.
Public property | IncrementalTabStop | Set incremental tab stop position.
Public property | LineSpacing | Get or Set line spacing.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | ParagraphAlignment | Get or Set alignment option of paragraph relative to layout box's top and bottom edge.
Public property | ReadingDirection | Get or Set paragraph reading direction.
Public property | TextAlignment | Get or Set alignment option of text relative to layout box's leading and trailing edge.
Public property | Trimming | Gets or sets trimming options.
Public property | TrimmingWithSign | Gets and sets trimming options for text overflowing the layout width, including the trimming sign object.
Public property | WordWrapping | Get or Set word wrapping option.

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CultureInfo Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..CultureInfo Property
TextFormat Class See Also Send Feedback
Get the CultureInfo for this object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CultureInfo CultureInfo { get; }
Visual Basic
Public ReadOnly Property CultureInfo As CultureInfo
    Get
Visual C++
public:
property CultureInfo^ CultureInfo {
    CultureInfo^ get ();
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FlowDirection Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..FlowDirection Property
TextFormat Class See Also Send Feedback
Get or Set paragraph flow direction.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FlowDirection FlowDirection { get; set; }
Visual Basic
Public Property FlowDirection As FlowDirection
    Get
    Set
Visual C++
public:
property FlowDirection FlowDirection {
    FlowDirection get ();
    void set (FlowDirection value);
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontFamilyName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..FontFamilyName Property
TextFormat Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string FontFamilyName { get; }
Visual Basic
Public ReadOnly Property FontFamilyName As String
    Get
Visual C++
public:
property String^ FontFamilyName {
    String^ get ();
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..FontSize Property
TextFormat Class See Also Send Feedback
Get the font em height.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float FontSize { get; }
Visual Basic
Public ReadOnly Property FontSize As Single
    Get
Visual C++
public:
property float FontSize {
    float get ();
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontStretch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..FontStretch Property
TextFormat Class See Also Send Feedback
Get the font stretch.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontStretch FontStretch { get; }
Visual Basic
Public ReadOnly Property FontStretch As FontStretch
    Get
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontStyle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..FontStyle Property
TextFormat Class See Also Send Feedback
Get the font style.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontStyle FontStyle { get; }
Visual Basic
Public ReadOnly Property FontStyle As FontStyle
    Get
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


FontWeight Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..FontWeight Property
TextFormat Class See Also Send Feedback
Get the font weight.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontWeight FontWeight { get; }
Visual Basic
Public ReadOnly Property FontWeight As FontWeight
    Get
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IncrementalTabStop Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..IncrementalTabStop Property
TextFormat Class See Also Send Feedback
Set incremental tab stop position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float IncrementalTabStop { get; set; }
Visual Basic
Public Property IncrementalTabStop As Single
    Get
    Set
Visual C++
public:
property float IncrementalTabStop {
    float get ();
    void set (float value);
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineSpacing Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..LineSpacing Property
TextFormat Class See Also Send Feedback
Get or Set line spacing.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public LineSpacing LineSpacing { get; set; }
Visual Basic
Public Property LineSpacing As LineSpacing
    Get
    Set
Visual C++
public:
property LineSpacing LineSpacing {
    LineSpacing get ();
    void set (LineSpacing value);
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ParagraphAlignment Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..ParagraphAlignment Property
TextFormat Class See Also Send Feedback
Get or Set alignment option of paragraph relative to layout box's top and bottom edge.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ParagraphAlignment ParagraphAlignment { get; set; }
Visual Basic
Public Property ParagraphAlignment As ParagraphAlignment
    Get
    Set
Visual C++
public:
property ParagraphAlignment ParagraphAlignment {
    ParagraphAlignment get ();
    void set (ParagraphAlignment value);
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ReadingDirection Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..ReadingDirection Property
TextFormat Class See Also Send Feedback
Get or Set paragraph reading direction.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadingDirection ReadingDirection { get; set; }
Visual Basic
Public Property ReadingDirection As ReadingDirection
    Get
    Set
Visual C++
public:
property ReadingDirection ReadingDirection {
    ReadingDirection get ();
    void set (ReadingDirection value);
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextAlignment Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..TextAlignment Property
TextFormat Class See Also Send Feedback
Get or Set alignment option of text relative to layout box's leading and trailing edge.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As TextAlignment
    Get
    Set
Visual C++
public:
property TextAlignment TextAlignment {
    TextAlignment get ();
    void set (TextAlignment value);
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Trimming Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..Trimming Property
TextFormat Class See Also Send Feedback
Gets or sets trimming options.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Trimming Trimming { get; set; }
Visual Basic
Public Property Trimming As Trimming
    Get
    Set
Visual C++
public:
property Trimming Trimming {
    Trimming get ();
    void set (Trimming value);
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TrimmingWithSign Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..TrimmingWithSign Property
TextFormat Class See Also Send Feedback
Gets and sets trimming options for text overflowing the layout width, including the trimming sign object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TrimmingWithSign TrimmingWithSign { get; set; }
Visual Basic
Public Property TrimmingWithSign As TrimmingWithSign
    Get
    Set
Visual C++
public:
property TrimmingWithSign TrimmingWithSign {
    TrimmingWithSign get ();
    void set (TrimmingWithSign value);
}

Return Value

Text trimming options.

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


WordWrapping Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextFormat..::..WordWrapping Property
TextFormat Class See Also Send Feedback
Get or Set word wrapping option.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public WordWrapping WordWrapping { get; set; }
Visual Basic
Public Property WordWrapping As WordWrapping
    Get
    Set
Visual C++
public:
property WordWrapping WordWrapping {
    WordWrapping get ();
    void set (WordWrapping value);
}

See Also

TextFormat Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextLayout Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout Class
Members See Also Send Feedback
Represents a block of text after it has been fully analyzed and formatted.

All coordinates are in device independent pixels (DIPs).

(Also see DirectX SDK: IDWriteTextLayout)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class TextLayout : TextFormat
Visual Basic
Public Class TextLayout _
    Inherits TextFormat
Visual C++
public ref class TextLayout : public TextFormat

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextFormat
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextLayout

See Also

TextLayout Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextLayout Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout Members
TextLayout Class Methods Properties See Also Send Feedback

The TextLayout type exposes the following members.

Methods

 | Name | Description
Public method | DetermineMinWidth | Determines the minimum possible width the layout can be set to without emergency breaking between the characters of whole words.
Public method | GetCultureInfo | Get the culture info for the given position.
Public method | GetCultureInfoForRange | Gets the culture information for the given position and text range for identically-formatted text.
Public method | GetFontCollection | Gets the font family collection used for the given position.
Public method | GetFontCollectionForRange | Gets the font family collection used for the given position and text range for identically-formatted text.
Public method | GetFontFamilyName | Get the font family name for the given position.
Public method | GetFontFamilyNameForRange | Gets the font family name for the given position and text range for identically-formatted text.
Public method | GetFontSize | Get the font em height for the given position.
Public method | GetFontSizeForRange | Gets the font height for the given position and text range for identically-formatted text.
Public method | GetFontStretch | Get the font stretch for the given position.
Public method | GetFontStretchForRange | Gets the font stretch for the given position and text range for identically-formatted text.
Public method | GetFontStyle | Get the font style for the given position.
Public method | GetFontStyleForRange | Gets the font style for the given position and text range for identically-formatted text.
Public method | GetFontWeight | Get the font weight for the given position.
Public method | GetFontWeightForRange | Gets the font weight for the given position and text range for identically-formatted text.
Public method | GetStrikethrough | Get the strikethrough presence for the given position.
Public method | GetStrikethroughForRange | Gets the strikethrough property for the given position and text range for identically-formatted text.
Public method | GetTypography | Gets the typography setting of the text at the specified position.
Public method | GetTypographyForRange | Gets the typography setting for the given position and text range for identically-formatted text.
Public method | GetUnderline | Get the underline presence for the given position.
Public method | GetUnderlineForRange | Gets the underline presence for the given position and text range for identically-formatted text.
Public method | HitTestPoint | Given a coordinate (in DIPs) relative to the top-left of the layout box, this returns the corresponding hit-test metrics of the text string where the hit-test has occurred. This is useful for mapping mouse clicks to caret positions. When the given coordinate is outside the text string, the function sets the output value *isInside to false but returns the nearest character position.
Public method | HitTestTextPosition | Given a text position and whether the caret is on the leading or trailing edge of that position, this returns the corresponding coordinate (in DIPs) relative to the top-left of the layout box. This is most useful for drawing the caret's current position, but it could also be used to anchor an IME to the typed text or attach a floating menu near the point of interest. It may also be used to programmatically obtain the geometry of a particular text position for UI automation.
Public method | HitTestTextRange | The application calls this function to get a set of hit-test metrics corresponding to a range of text positions. The main usage for this is to draw highlighted selection of the text string.
Public method | SetCultureInfo | Set CultureInfo.
Public method | SetFontFamilyName | Set font family name.
Public method | SetFontSize | Set font em height.
Public method | SetFontStretch | Set font stretch.
Public method | SetFontStyle | Set font style.
Public method | SetFontWeight | Set font weight.
Public method | SetInlineObject | Set a custom inline object.
Public method | SetStrikethrough | Set strikethrough.
Public method | SetTypography | Sets font typography features for text within a specified text range.
Public method | SetUnderline | Set underline.

Properties

 | Name | Description
Public property | ClusterMetrics | Retrieves logical properties and measurements of each glyph cluster.
Public property | CultureInfo | Get the CultureInfo for this object. (Inherited from TextFormat.)
Public property | FlowDirection | Get or Set paragraph flow direction. (Inherited from TextFormat.)
Public property | FontFamilyName | (Inherited from TextFormat.)
Public property | FontSize | Get the font em height. (Inherited from TextFormat.)
Public property | FontStretch | Get the font stretch. (Inherited from TextFormat.)
Public property | FontStyle | Get the font style. (Inherited from TextFormat.)
Public property | FontWeight | Get the font weight. (Inherited from TextFormat.)
Public property | IncrementalTabStop | Set incremental tab stop position. (Inherited from TextFormat.)
Public property | LineMetrics | Retrieves the information about each individual text line of the text string.
Public property | LineSpacing | Get or Set line spacing. (Inherited from TextFormat.)
Public property | MaxHeight | Get or set layout maximum height
Public property | MaxWidth | Get or set layout maximum width
Public property | Metrics | Retrieves overall metrics for the formatted string.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | OverhangMetrics | GetOverhangMetrics returns the overhangs (in DIPs) of the layout and all objects contained in it, including text glyphs and inline objects.
Public property | ParagraphAlignment | Get or Set alignment option of paragraph relative to layout box's top and bottom edge. (Inherited from TextFormat.)
Public property | ReadingDirection | Get or Set paragraph reading direction. (Inherited from TextFormat.)
Public property | Text | The text that was used to create this TextLayout.
Public property | TextAlignment | Get or Set alignment option of text relative to layout box's leading and trailing edge. (Inherited from TextFormat.)
Public property | Trimming | Gets or sets trimming options. (Inherited from TextFormat.)
Public property | TrimmingWithSign | Gets and sets trimming options for text overflowing the layout width, including the trimming sign object. (Inherited from TextFormat.)
Public property | WordWrapping | Get or Set word wrapping option. (Inherited from TextFormat.)

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextLayout Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout Methods
TextLayout Class See Also Send Feedback

The TextLayout type exposes the following members.

Methods

 | Name | Description
Public method | DetermineMinWidth | Determines the minimum possible width the layout can be set to without emergency breaking between the characters of whole words.
Public method | GetCultureInfo | Get the culture info for the given position.
Public method | GetCultureInfoForRange | Gets the culture information for the given position and text range for identically-formatted text.
Public method | GetFontCollection | Gets the font family collection used for the given position.
Public method | GetFontCollectionForRange | Gets the font family collection used for the given position and text range for identically-formatted text.
Public method | GetFontFamilyName | Get the font family name for the given position.
Public method | GetFontFamilyNameForRange | Gets the font family name for the given position and text range for identically-formatted text.
Public method | GetFontSize | Get the font em height for the given position.
Public method | GetFontSizeForRange | Gets the font height for the given position and text range for identically-formatted text.
Public method | GetFontStretch | Get the font stretch for the given position.
Public method | GetFontStretchForRange | Gets the font stretch for the given position and text range for identically-formatted text.
Public method | GetFontStyle | Get the font style for the given position.
Public method | GetFontStyleForRange | Gets the font style for the given position and text range for identically-formatted text.
Public method | GetFontWeight | Get the font weight for the given position.
Public method | GetFontWeightForRange | Gets the font weight for the given position and text range for identically-formatted text.
Public method | GetStrikethrough | Get the strikethrough presence for the given position.
Public method | GetStrikethroughForRange | Gets the strikethrough property for the given position and text range for identically-formatted text.
Public method | GetTypography | Gets the typography setting of the text at the specified position.
Public method | GetTypographyForRange | Gets the typography setting for the given position and text range for identically-formatted text.
Public method | GetUnderline | Get the underline presence for the given position.
Public method | GetUnderlineForRange | Gets the underline presence for the given position and text range for identically-formatted text.
Public method | HitTestPoint | Given a coordinate (in DIPs) relative to the top-left of the layout box, this returns the corresponding hit-test metrics of the text string where the hit-test has occurred. This is useful for mapping mouse clicks to caret positions. When the given coordinate is outside the text string, the function sets the output value *isInside to false but returns the nearest character position.
Public method | HitTestTextPosition | Given a text position and whether the caret is on the leading or trailing edge of that position, this returns the corresponding coordinate (in DIPs) relative to the top-left of the layout box. This is most useful for drawing the caret's current position, but it could also be used to anchor an IME to the typed text or attach a floating menu near the point of interest. It may also be used to programmatically obtain the geometry of a particular text position for UI automation.
Public method | HitTestTextRange | The application calls this function to get a set of hit-test metrics corresponding to a range of text positions. The main usage for this is to draw highlighted selection of the text string.
Public method | SetCultureInfo | Set CultureInfo.
Public method | SetFontFamilyName | Set font family name.
Public method | SetFontSize | Set font em height.
Public method | SetFontStretch | Set font stretch.
Public method | SetFontStyle | Set font style.
Public method | SetFontWeight | Set font weight.
Public method | SetInlineObject | Set a custom inline object.
Public method | SetStrikethrough | Set strikethrough.
Public method | SetTypography | Sets font typography features for text within a specified text range.
Public method | SetUnderline | Set underline.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


DetermineMinWidth Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..DetermineMinWidth Method
TextLayout Class See Also Send Feedback
Determines the minimum possible width the layout can be set to without emergency breaking between the characters of whole words.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float DetermineMinWidth()
Visual Basic
Public Function DetermineMinWidth As Single
Visual C++
public:
float DetermineMinWidth()

Return Value

Minimum width.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetCultureInfo Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetCultureInfo Method
TextLayout Class See Also Send Feedback
Get the culture info for the given position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public CultureInfo GetCultureInfo(
    uint currentPosition
)
Visual Basic
Public Function GetCultureInfo ( _
    currentPosition As UInteger _
) As CultureInfo
Visual C++
public:
CultureInfo^ GetCultureInfo(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The current text position.

Return Value

The current culture info.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetCultureInfoForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetCultureInfoForRange Method
TextLayout Class See Also Send Feedback
Gets the culture information for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<CultureInfo> GetCultureInfoForRange(
    uint currentPosition
)
Visual Basic
Public Function GetCultureInfoForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of CultureInfo)
Visual C++
public:
TextRangeOf<CultureInfo^> GetCultureInfoForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve culture information.

Return Value

The culture information for the given position, and the range of text having exactly the same formatting, including culture, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontCollection Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontCollection Method
TextLayout Class See Also Send Feedback
Gets the font family collection used for the given position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontFamilyCollection GetFontCollection(
    uint currentPosition
)
Visual Basic
Public Function GetFontCollection ( _
    currentPosition As UInteger _
) As FontFamilyCollection
Visual C++
public:
FontFamilyCollection^ GetFontCollection(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve the font family collection.

Return Value

The font family collection for the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontCollectionForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontCollectionForRange Method
TextLayout Class See Also Send Feedback
Gets the font family collection used for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<FontFamilyCollection> GetFontCollectionForRange(
    uint currentPosition
)
Visual Basic
Public Function GetFontCollectionForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of FontFamilyCollection)
Visual C++
public:
TextRangeOf<FontFamilyCollection^> GetFontCollectionForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve the font family collection.

Return Value

The font family collection for the given position, and the range of text having exactly the same formatting, include font family collection, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontFamilyName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontFamilyName Method
TextLayout Class See Also Send Feedback
Get the font family name for the given position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string GetFontFamilyName(
    uint currentPosition
)
Visual Basic
Public Function GetFontFamilyName ( _
    currentPosition As UInteger _
) As String
Visual C++
public:
String^ GetFontFamilyName(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The current text position.

Return Value

The current font family name

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontFamilyNameForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontFamilyNameForRange Method
TextLayout Class See Also Send Feedback
Gets the font family name for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<string> GetFontFamilyNameForRange(
    uint currentPosition
)
Visual Basic
Public Function GetFontFamilyNameForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of String)
Visual C++
public:
TextRangeOf<String^> GetFontFamilyNameForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve the font family name.

Return Value

The font family name for the given position, and the range of text having exactly the same formatting, include font family name, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontSize Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontSize Method
TextLayout Class See Also Send Feedback
Get the font em height for the given position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float GetFontSize(
    uint currentPosition
)
Visual Basic
Public Function GetFontSize ( _
    currentPosition As UInteger _
) As Single
Visual C++
public:
float GetFontSize(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The current text position.

Return Value

The current font em height.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontSizeForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontSizeForRange Method
TextLayout Class See Also Send Feedback
Gets the font height for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<float> GetFontSizeForRange(
    uint currentPosition
)
Visual Basic
Public Function GetFontSizeForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of Single)
Visual C++
public:
TextRangeOf<float> GetFontSizeForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve the font height.

Return Value

The font height for the given position, and the range of text having exactly the same formatting, including font height, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontStretch Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontStretch Method
TextLayout Class See Also Send Feedback
Get the font stretch for the given position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontStretch GetFontStretch(
    uint currentPosition
)
Visual Basic
Public Function GetFontStretch ( _
    currentPosition As UInteger _
) As FontStretch
Visual C++
public:
FontStretch GetFontStretch(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The current text position.

Return Value

The current font stretch.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontStretchForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontStretchForRange Method
TextLayout Class See Also Send Feedback
Gets the font stretch for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<FontStretch> GetFontStretchForRange(
    uint currentPosition
)
Visual Basic
Public Function GetFontStretchForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of FontStretch)
Visual C++
public:
TextRangeOf<FontStretch> GetFontStretchForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve the font stretch.

Return Value

The font stretch for the given position, and the range of text having exactly the same formatting, including font stretch, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontStyle Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontStyle Method
TextLayout Class See Also Send Feedback
Get the font style for the given position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontStyle GetFontStyle(
    uint currentPosition
)
Visual Basic
Public Function GetFontStyle ( _
    currentPosition As UInteger _
) As FontStyle
Visual C++
public:
FontStyle GetFontStyle(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The current text position.

Return Value

The current font style.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontStyleForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontStyleForRange Method
TextLayout Class See Also Send Feedback
Gets the font style for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<FontStyle> GetFontStyleForRange(
    uint currentPosition
)
Visual Basic
Public Function GetFontStyleForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of FontStyle)
Visual C++
public:
TextRangeOf<FontStyle> GetFontStyleForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve font style.

Return Value

The font style for the given position, and the range of text having exactly the same formatting, including font style, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontWeight Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontWeight Method
TextLayout Class See Also Send Feedback
Get the font weight for the given position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FontWeight GetFontWeight(
    uint currentPosition
)
Visual Basic
Public Function GetFontWeight ( _
    currentPosition As UInteger _
) As FontWeight
Visual C++
public:
FontWeight GetFontWeight(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The current text position.

Return Value

The current font weight

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetFontWeightForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetFontWeightForRange Method
TextLayout Class See Also Send Feedback
Gets the font weight for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<FontWeight> GetFontWeightForRange(
    uint currentPosition
)
Visual Basic
Public Function GetFontWeightForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of FontWeight)
Visual C++
public:
TextRangeOf<FontWeight> GetFontWeightForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve font weight.

Return Value

The font weight for the given position, and the range of text having exactly the same formatting, including font weight, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetStrikethrough Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetStrikethrough Method
TextLayout Class See Also Send Feedback
Get the strikethrough presence for the given position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool GetStrikethrough(
    uint currentPosition
)
Visual Basic
Public Function GetStrikethrough ( _
    currentPosition As UInteger _
) As Boolean
Visual C++
public:
bool GetStrikethrough(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The current text position.

Return Value

The Boolean flag indicates whether text has strikethrough.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetStrikethroughForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetStrikethroughForRange Method
TextLayout Class See Also Send Feedback
Gets the strikethrough property for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<bool> GetStrikethroughForRange(
    uint currentPosition
)
Visual Basic
Public Function GetStrikethroughForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of Boolean)
Visual C++
public:
TextRangeOf<bool> GetStrikethroughForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve the strikethrough property.

Return Value

The strikethrough property for the given position, and the range of text having exactly the same formatting, including the strikethrough property value, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetTypography Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetTypography Method
TextLayout Class See Also Send Feedback
Gets the typography setting of the text at the specified position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TypographySettingCollection GetTypography(
    uint currentPosition
)
Visual Basic
Public Function GetTypography ( _
    currentPosition As UInteger _
) As TypographySettingCollection
Visual C++
public:
TypographySettingCollection^ GetTypography(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The current text position.

Return Value

The current typography collection, or null if no typography has been set.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetTypographyForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetTypographyForRange Method
TextLayout Class See Also Send Feedback
Gets the typography setting for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<TypographySettingCollection> GetTypographyForRange(
    uint currentPosition
)
Visual Basic
Public Function GetTypographyForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of TypographySettingCollection)
Visual C++
public:
TextRangeOf<TypographySettingCollection^> GetTypographyForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve the typography setting.

Return Value

The typography setting for the given position, and the range of text having exactly the same formatting, including typography setting, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetUnderline Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetUnderline Method
TextLayout Class See Also Send Feedback
Get the underline presence for the given position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool GetUnderline(
    uint currentPosition
)
Visual Basic
Public Function GetUnderline ( _
    currentPosition As UInteger _
) As Boolean
Visual C++
public:
bool GetUnderline(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The current text position.

Return Value

The Boolean flag indicates whether text is underlined.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetUnderlineForRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..GetUnderlineForRange Method
TextLayout Class See Also Send Feedback
Gets the underline presence for the given position and text range for identically-formatted text.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf<bool> GetUnderlineForRange(
    uint currentPosition
)
Visual Basic
Public Function GetUnderlineForRange ( _
    currentPosition As UInteger _
) As TextRangeOf(Of Boolean)
Visual C++
public:
TextRangeOf<bool> GetUnderlineForRange(
    unsigned int currentPosition
)

Parameters

currentPosition
Type: System..::..UInt32
The text position for which to retrieve the underline presence.

Return Value

The underline presence for the given position, and the range of text having exactly the same formatting, including underline presence, as the given position.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestPoint Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..HitTestPoint Method
TextLayout Class See Also Send Feedback
Given a coordinate (in DIPs) relative to the top-left of the layout box, this returns the corresponding hit-test metrics of the text string where the hit-test has occurred. This is useful for mapping mouse clicks to caret positions. When the given coordinate is outside the text string, the function sets the output value *isInside to false but returns the nearest character position.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HitTestInfo HitTestPoint(
    Point2F location
)
Visual Basic
Public Function HitTestPoint ( _
    location As Point2F _
) As HitTestInfo
Visual C++
public:
HitTestInfo HitTestPoint(
    Point2F location
)

Parameters

location
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..Point2F
The coordinates of the location to hit-test, relative to the top-left location of the layout box.

Return Value

A HitTestInfo value that includes the output geometry containing or nearest the hit-test location, and flags providing more information about the location tested.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestTextPosition Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..HitTestTextPosition Method
TextLayout Class See Also Send Feedback
Given a text position and whether the caret is on the leading or trailing edge of that position, this returns the corresponding coordinate (in DIPs) relative to the top-left of the layout box. This is most useful for drawing the caret's current position, but it could also be used to anchor an IME to the typed text or attach a floating menu near the point of interest. It may also be used to programmatically obtain the geometry of a particular text position for UI automation.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HitTestInfo HitTestTextPosition(
    uint textPosition,
    bool isTrailingHit
)
Visual Basic
Public Function HitTestTextPosition ( _
    textPosition As UInteger, _
    isTrailingHit As Boolean _
) As HitTestInfo
Visual C++
public:
HitTestInfo HitTestTextPosition(
    unsigned int textPosition,
    bool isTrailingHit
)

Parameters

textPosition
Type: System..::..UInt32
Text position to get the coordinate of.
isTrailingHit
Type: System..::..Boolean
Flag indicating whether the location is of the leading or the trailing side of the specified text position.

Return Value

A HitTestInfo value that includes the output geometry containing the given text position, and the coordinates of the given text position.

Remarks

When drawing a caret at the returned X,Y, it should should be centered on X and drawn from the Y coordinate down. The height will be the size of the hit-tested text (which can vary in size within a line). Reading direction also affects which side of the character the caret is drawn. However, the returned X coordinate will be correct for either case. You can get a text length back that is larger than a single character. This happens for complex scripts when multiple characters form a single cluster, when diacritics join their base character, or when you test a surrogate pair.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


HitTestTextRange Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..HitTestTextRange Method
TextLayout Class See Also Send Feedback
The application calls this function to get a set of hit-test metrics corresponding to a range of text positions. The main usage for this is to draw highlighted selection of the text string.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public HitTestMetrics[] HitTestTextRange(
    uint textPosition,
    uint textLength,
    float originX,
    float originY
)
Visual Basic
Public Function HitTestTextRange ( _
    textPosition As UInteger, _
    textLength As UInteger, _
    originX As Single, _
    originY As Single _
) As HitTestMetrics()
Visual C++
public:
array<HitTestMetrics>^ HitTestTextRange(
    unsigned int textPosition,
    unsigned int textLength,
    float originX,
    float originY
)

Parameters

textPosition
Type: System..::..UInt32
First text position of the specified range.
textLength
Type: System..::..UInt32
Number of positions of the specified range.
originX
Type: System..::..Single
Offset of the X origin (left of the layout box) which is added to each of the hit-test metrics returned.
originY
Type: System..::..Single
Offset of the Y origin (top of the layout box) which is added to each of the hit-test metrics returned.

Return Value

Aarray of the output geometry fully enclosing the specified position range.

Remarks

There are no gaps in the returned metrics. While there could be visual gaps, depending on bidi ordering, each range is contiguous and reports all the text, including any hidden characters and trimmed text. The height of each returned range will be the same within each line, regardless of how the font sizes vary.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetCultureInfo Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetCultureInfo Method
TextLayout Class See Also Send Feedback
Set CultureInfo.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetCultureInfo(
    CultureInfo cultureInfo,
    TextRange textRange
)
Visual Basic
Public Sub SetCultureInfo ( _
    cultureInfo As CultureInfo, _
    textRange As TextRange _
)
Visual C++
public:
void SetCultureInfo(
    CultureInfo^ cultureInfo,
    TextRange textRange
)

Parameters

cultureInfo
Type: System.Globalization..::..CultureInfo
Culture Info
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetFontFamilyName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetFontFamilyName Method
TextLayout Class See Also Send Feedback
Set font family name.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetFontFamilyName(
    string fontFamilyName,
    TextRange textRange
)
Visual Basic
Public Sub SetFontFamilyName ( _
    fontFamilyName As String, _
    textRange As TextRange _
)
Visual C++
public:
void SetFontFamilyName(
    String^ fontFamilyName,
    TextRange textRange
)

Parameters

fontFamilyName
Type: System..::..String
Font family name
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetFontSize Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetFontSize Method
TextLayout Class See Also Send Feedback
Set font em height.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetFontSize(
    float fontSize,
    TextRange textRange
)
Visual Basic
Public Sub SetFontSize ( _
    fontSize As Single, _
    textRange As TextRange _
)
Visual C++
public:
void SetFontSize(
    float fontSize,
    TextRange textRange
)

Parameters

fontSize
Type: System..::..Single
Font em height
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetFontStretch Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetFontStretch Method
TextLayout Class See Also Send Feedback
Set font stretch.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetFontStretch(
    FontStretch fontStretch,
    TextRange textRange
)
Visual Basic
Public Sub SetFontStretch ( _
    fontStretch As FontStretch, _
    textRange As TextRange _
)
Visual C++
public:
void SetFontStretch(
    FontStretch fontStretch,
    TextRange textRange
)

Parameters

fontStretch
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontStretch
font stretch
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetFontStyle Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetFontStyle Method
TextLayout Class See Also Send Feedback
Set font style.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetFontStyle(
    FontStyle fontStyle,
    TextRange textRange
)
Visual Basic
Public Sub SetFontStyle ( _
    fontStyle As FontStyle, _
    textRange As TextRange _
)
Visual C++
public:
void SetFontStyle(
    FontStyle fontStyle,
    TextRange textRange
)

Parameters

fontStyle
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontStyle
Font style
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetFontWeight Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetFontWeight Method
TextLayout Class See Also Send Feedback
Set font weight.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetFontWeight(
    FontWeight fontWeight,
    TextRange textRange
)
Visual Basic
Public Sub SetFontWeight ( _
    fontWeight As FontWeight, _
    textRange As TextRange _
)
Visual C++
public:
void SetFontWeight(
    FontWeight fontWeight,
    TextRange textRange
)

Parameters

fontWeight
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontWeight
Font weight
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetInlineObject Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetInlineObject Method
TextLayout Class See Also Send Feedback
Set a custom inline object.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetInlineObject(
    ICustomInlineObject inlineObject,
    TextRange textRange
)
Visual Basic
Public Sub SetInlineObject ( _
    inlineObject As ICustomInlineObject, _
    textRange As TextRange _
)
Visual C++
public:
void SetInlineObject(
    ICustomInlineObject^ inlineObject,
    TextRange textRange
)

Parameters

inlineObject
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..ICustomInlineObject
An application-implemented inline object.
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

Remarks

This inline object applies to the specified range and will be passed back to the application via the DrawInlineObject callback when the range is drawn. Any text in that range will be suppressed.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetStrikethrough Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetStrikethrough Method
TextLayout Class See Also Send Feedback
Set strikethrough.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetStrikethrough(
    bool hasStrikethrough,
    TextRange textRange
)
Visual Basic
Public Sub SetStrikethrough ( _
    hasStrikethrough As Boolean, _
    textRange As TextRange _
)
Visual C++
public:
void SetStrikethrough(
    bool hasStrikethrough,
    TextRange textRange
)

Parameters

hasStrikethrough
Type: System..::..Boolean
The Boolean flag indicates whether strikethrough takes place
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetTypography Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetTypography Method
TextLayout Class See Also Send Feedback
Sets font typography features for text within a specified text range.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetTypography(
    TypographySettingCollection typography,
    TextRange textRange
)
Visual Basic
Public Sub SetTypography ( _
    typography As TypographySettingCollection, _
    textRange As TextRange _
)
Visual C++
public:
void SetTypography(
    TypographySettingCollection^ typography,
    TextRange textRange
)

Parameters

typography
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TypographySettingCollection
Font typography settings collection.
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


SetUnderline Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..SetUnderline Method
TextLayout Class See Also Send Feedback
Set underline.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetUnderline(
    bool hasUnderline,
    TextRange textRange
)
Visual Basic
Public Sub SetUnderline ( _
    hasUnderline As Boolean, _
    textRange As TextRange _
)
Visual C++
public:
void SetUnderline(
    bool hasUnderline,
    TextRange textRange
)

Parameters

hasUnderline
Type: System..::..Boolean
The Boolean flag indicates whether underline takes place
textRange
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
Text range to which this change applies.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextLayout Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout Properties
TextLayout Class See Also Send Feedback

The TextLayout type exposes the following members.

Properties

 | Name | Description
Public property | ClusterMetrics | Retrieves logical properties and measurements of each glyph cluster.
Public property | CultureInfo | Get the CultureInfo for this object. (Inherited from TextFormat.)
Public property | FlowDirection | Get or Set paragraph flow direction. (Inherited from TextFormat.)
Public property | FontFamilyName | (Inherited from TextFormat.)
Public property | FontSize | Get the font em height. (Inherited from TextFormat.)
Public property | FontStretch | Get the font stretch. (Inherited from TextFormat.)
Public property | FontStyle | Get the font style. (Inherited from TextFormat.)
Public property | FontWeight | Get the font weight. (Inherited from TextFormat.)
Public property | IncrementalTabStop | Set incremental tab stop position. (Inherited from TextFormat.)
Public property | LineMetrics | Retrieves the information about each individual text line of the text string.
Public property | LineSpacing | Get or Set line spacing. (Inherited from TextFormat.)
Public property | MaxHeight | Get or set layout maximum height
Public property | MaxWidth | Get or set layout maximum width
Public property | Metrics | Retrieves overall metrics for the formatted string.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | OverhangMetrics | GetOverhangMetrics returns the overhangs (in DIPs) of the layout and all objects contained in it, including text glyphs and inline objects.
Public property | ParagraphAlignment | Get or Set alignment option of paragraph relative to layout box's top and bottom edge. (Inherited from TextFormat.)
Public property | ReadingDirection | Get or Set paragraph reading direction. (Inherited from TextFormat.)
Public property | Text | The text that was used to create this TextLayout.
Public property | TextAlignment | Get or Set alignment option of text relative to layout box's leading and trailing edge. (Inherited from TextFormat.)
Public property | Trimming | Gets or sets trimming options. (Inherited from TextFormat.)
Public property | TrimmingWithSign | Gets and sets trimming options for text overflowing the layout width, including the trimming sign object. (Inherited from TextFormat.)
Public property | WordWrapping | Get or Set word wrapping option. (Inherited from TextFormat.)

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


ClusterMetrics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..ClusterMetrics Property
TextLayout Class See Also Send Feedback
Retrieves logical properties and measurements of each glyph cluster.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<ClusterMetrics> ClusterMetrics { get; }
Visual Basic
Public ReadOnly Property ClusterMetrics As IEnumerable(Of ClusterMetrics)
    Get
Visual C++
public:
property IEnumerable<ClusterMetrics>^ ClusterMetrics {
    IEnumerable<ClusterMetrics>^ get ();
}

Return Value

Array of Cluster Metrics such as line-break or total advance width, for each glyph cluster.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineMetrics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..LineMetrics Property
TextLayout Class See Also Send Feedback
Retrieves the information about each individual text line of the text string.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<LineMetrics> LineMetrics { get; }
Visual Basic
Public ReadOnly Property LineMetrics As IEnumerable(Of LineMetrics)
    Get
Visual C++
public:
property IEnumerable<LineMetrics>^ LineMetrics {
    IEnumerable<LineMetrics>^ get ();
}

Return Value

Properties of each line.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


MaxHeight Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..MaxHeight Property
TextLayout Class See Also Send Feedback
Get or set layout maximum height

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MaxHeight { get; set; }
Visual Basic
Public Property MaxHeight As Single
    Get
    Set
Visual C++
public:
property float MaxHeight {
    float get ();
    void set (float value);
}

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


MaxWidth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..MaxWidth Property
TextLayout Class See Also Send Feedback
Get or set layout maximum width

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MaxWidth { get; set; }
Visual Basic
Public Property MaxWidth As Single
    Get
    Set
Visual C++
public:
property float MaxWidth {
    float get ();
    void set (float value);
}

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Metrics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..Metrics Property
TextLayout Class See Also Send Feedback
Retrieves overall metrics for the formatted string.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextMetrics Metrics { get; }
Visual Basic
Public ReadOnly Property Metrics As TextMetrics
    Get
Visual C++
public:
property TextMetrics Metrics {
    TextMetrics get ();
}

Remarks

Drawing effects like underline and strikethrough do not contribute to the text size, which is essentially the sum of advance widths and line heights. Additionally, visible swashes and other graphic adornments may extend outside the returned width and height.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


OverhangMetrics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..OverhangMetrics Property
TextLayout Class See Also Send Feedback
GetOverhangMetrics returns the overhangs (in DIPs) of the layout and all objects contained in it, including text glyphs and inline objects.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OverhangMetrics OverhangMetrics { get; }
Visual Basic
Public ReadOnly Property OverhangMetrics As OverhangMetrics
    Get
Visual C++
public:
property OverhangMetrics OverhangMetrics {
    OverhangMetrics get ();
}

Remarks

Any underline and strikethrough do not contribute to the black box determination, since these are actually drawn by the renderer, which is allowed to draw them in any variety of styles.

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Text Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextLayout..::..Text Property
TextLayout Class See Also Send Feedback
The text that was used to create this TextLayout.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

TextLayout Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextMetrics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics Structure
Members See Also Send Feedback
Overall metrics associated with text after layout. All coordinates are in device independent pixels (DIPs).

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct TextMetrics
Visual Basic
Public Structure TextMetrics
Visual C++
public value class TextMetrics

See Also

TextMetrics Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextMetrics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics Members
TextMetrics Structure Constructors Methods Operators Properties See Also Send Feedback

The TextMetrics type exposes the following members.

Constructors

 | Name | Description
Public method | TextMetrics | Constructor for TextMetrics

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Height | The height of the formatted text. The height of an empty string is determined by the size of the default font's line height.
Public property | LayoutHeight | Initial height given to the layout. Depending on the length of the text, it may be larger or smaller than the text content height.
Public property | LayoutWidth | Initial width given to the layout. Depending on whether the text was wrapped or not, it can be either larger or smaller than the text content width.
Public property | Left | Left-most point of formatted text relative to layout box (excluding any glyph overhang).
Public property | LineCount | Total number of lines.
Public property | MaxBidirectionalReorderingDepth | The maximum reordering count of any line of text, used to calculate the most number of hit-testing boxes needed. If the layout has no bidirectional text or no text at all, the minimum level is 1.
Public property | Top | Top-most point of formatted text relative to layout box (excluding any glyph overhang).
Public property | Width | The width of the formatted text ignoring trailing whitespace at the end of each line.
Public property | WidthIncludingTrailingWhitespace | The width of the formatted text taking into account the trailing whitespace at the end of each line.

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextMetrics Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics Constructor
TextMetrics Structure See Also Send Feedback
Constructor for TextMetrics

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextMetrics(
    float left,
    float top,
    float width,
    float widthIncludingTrailingWhitespace,
    float height,
    float layoutWidth,
    float layoutHeight,
    uint maxBidirectionalReorderingDepth,
    uint lineCount
)
Visual Basic
Public Sub New ( _
    left As Single, _
    top As Single, _
    width As Single, _
    widthIncludingTrailingWhitespace As Single, _
    height As Single, _
    layoutWidth As Single, _
    layoutHeight As Single, _
    maxBidirectionalReorderingDepth As UInteger, _
    lineCount As UInteger _
)
Visual C++
public:
TextMetrics(
    float left,
    float top,
    float width,
    float widthIncludingTrailingWhitespace,
    float height,
    float layoutWidth,
    float layoutHeight,
    unsigned int maxBidirectionalReorderingDepth,
    unsigned int lineCount
)

Parameters

left
Type: System..::..Single
top
Type: System..::..Single
width
Type: System..::..Single
widthIncludingTrailingWhitespace
Type: System..::..Single
height
Type: System..::..Single
layoutWidth
Type: System..::..Single
layoutHeight
Type: System..::..Single
maxBidirectionalReorderingDepth
Type: System..::..UInt32
lineCount
Type: System..::..UInt32

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextMetrics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics Methods
TextMetrics Structure See Also Send Feedback

The TextMetrics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..Equals Method
TextMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..GetHashCode Method
TextMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextMetrics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics Operators
TextMetrics Structure See Also Send Feedback

The TextMetrics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..Equality Operator
TextMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    TextMetrics textMetrics1,
    TextMetrics textMetrics2
)
Visual Basic
Public Shared Operator = ( _
    textMetrics1 As TextMetrics, _
    textMetrics2 As TextMetrics _
) As Boolean
Visual C++
public:
static bool operator ==(
    TextMetrics textMetrics1,
    TextMetrics textMetrics2
)

Parameters

textMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextMetrics
textMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextMetrics

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..Inequality Operator
TextMetrics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    TextMetrics textMetrics1,
    TextMetrics textMetrics2
)
Visual Basic
Public Shared Operator <> ( _
    textMetrics1 As TextMetrics, _
    textMetrics2 As TextMetrics _
) As Boolean
Visual C++
public:
static bool operator !=(
    TextMetrics textMetrics1,
    TextMetrics textMetrics2
)

Parameters

textMetrics1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextMetrics
textMetrics2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextMetrics

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextMetrics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics Properties
TextMetrics Structure See Also Send Feedback

The TextMetrics type exposes the following members.

Properties

 | Name | Description
Public property | Height | The height of the formatted text. The height of an empty string is determined by the size of the default font's line height.
Public property | LayoutHeight | Initial height given to the layout. Depending on the length of the text, it may be larger or smaller than the text content height.
Public property | LayoutWidth | Initial width given to the layout. Depending on whether the text was wrapped or not, it can be either larger or smaller than the text content width.
Public property | Left | Left-most point of formatted text relative to layout box (excluding any glyph overhang).
Public property | LineCount | Total number of lines.
Public property | MaxBidirectionalReorderingDepth | The maximum reordering count of any line of text, used to calculate the most number of hit-testing boxes needed. If the layout has no bidirectional text or no text at all, the minimum level is 1.
Public property | Top | Top-most point of formatted text relative to layout box (excluding any glyph overhang).
Public property | Width | The width of the formatted text ignoring trailing whitespace at the end of each line.
Public property | WidthIncludingTrailingWhitespace | The width of the formatted text taking into account the trailing whitespace at the end of each line.

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..Height Property
TextMetrics Structure See Also Send Feedback
The height of the formatted text. The height of an empty string is determined by the size of the default font's line height.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Height { get; set; }
Visual Basic
Public Property Height As Single
    Get
    Set
Visual C++
public:
property float Height {
    float get ();
    void set (float value);
}

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LayoutHeight Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..LayoutHeight Property
TextMetrics Structure See Also Send Feedback
Initial height given to the layout. Depending on the length of the text, it may be larger or smaller than the text content height.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float LayoutHeight { get; set; }
Visual Basic
Public Property LayoutHeight As Single
    Get
    Set
Visual C++
public:
property float LayoutHeight {
    float get ();
    void set (float value);
}

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LayoutWidth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..LayoutWidth Property
TextMetrics Structure See Also Send Feedback
Initial width given to the layout. Depending on whether the text was wrapped or not, it can be either larger or smaller than the text content width.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float LayoutWidth { get; set; }
Visual Basic
Public Property LayoutWidth As Single
    Get
    Set
Visual C++
public:
property float LayoutWidth {
    float get ();
    void set (float value);
}

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Left Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..Left Property
TextMetrics Structure See Also Send Feedback
Left-most point of formatted text relative to layout box (excluding any glyph overhang).

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Left { get; set; }
Visual Basic
Public Property Left As Single
    Get
    Set
Visual C++
public:
property float Left {
    float get ();
    void set (float value);
}

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


LineCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..LineCount Property
TextMetrics Structure See Also Send Feedback
Total number of lines.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint LineCount { get; set; }
Visual Basic
Public Property LineCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int LineCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


MaxBidirectionalReorderingDepth Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..MaxBidirectionalReorderingDepth Property
TextMetrics Structure See Also Send Feedback
The maximum reordering count of any line of text, used to calculate the most number of hit-testing boxes needed. If the layout has no bidirectional text or no text at all, the minimum level is 1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MaxBidirectionalReorderingDepth { get; set; }
Visual Basic
Public Property MaxBidirectionalReorderingDepth As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MaxBidirectionalReorderingDepth {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Top Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..Top Property
TextMetrics Structure See Also Send Feedback
Top-most point of formatted text relative to layout box (excluding any glyph overhang).

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Top { get; set; }
Visual Basic
Public Property Top As Single
    Get
    Set
Visual C++
public:
property float Top {
    float get ();
    void set (float value);
}

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..Width Property
TextMetrics Structure See Also Send Feedback
The width of the formatted text ignoring trailing whitespace at the end of each line.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Width { get; set; }
Visual Basic
Public Property Width As Single
    Get
    Set
Visual C++
public:
property float Width {
    float get ();
    void set (float value);
}

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


WidthIncludingTrailingWhitespace Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextMetrics..::..WidthIncludingTrailingWhitespace Property
TextMetrics Structure See Also Send Feedback
The width of the formatted text taking into account the trailing whitespace at the end of each line.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float WidthIncludingTrailingWhitespace { get; set; }
Visual Basic
Public Property WidthIncludingTrailingWhitespace As Single
    Get
    Set
Visual C++
public:
property float WidthIncludingTrailingWhitespace {
    float get ();
    void set (float value);
}

See Also

TextMetrics Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRange Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange Structure
Members See Also Send Feedback
Specifies a range of text positions where format is applied.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct TextRange
Visual Basic
Public Structure TextRange
Visual C++
public value class TextRange

See Also

TextRange Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRange Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange Members
TextRange Structure Constructors Methods Operators Properties See Also Send Feedback

The TextRange type exposes the following members.

Constructors

 | Name | Description
Public method | TextRange | Constructor for TextRange

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Length | The number of text positions in the range.
Public property | StartPosition | The start text position of the range.

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRange Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange Constructor
TextRange Structure See Also Send Feedback
Constructor for TextRange

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRange(
    uint startPosition,
    uint length
)
Visual Basic
Public Sub New ( _
    startPosition As UInteger, _
    length As UInteger _
)
Visual C++
public:
TextRange(
    unsigned int startPosition,
    unsigned int length
)

Parameters

startPosition
Type: System..::..UInt32
length
Type: System..::..UInt32

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRange Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange Methods
TextRange Structure See Also Send Feedback

The TextRange type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange..::..Equals Method
TextRange Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange..::..GetHashCode Method
TextRange Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRange Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange Operators
TextRange Structure See Also Send Feedback

The TextRange type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange..::..Equality Operator
TextRange Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    TextRange textRange1,
    TextRange textRange2
)
Visual Basic
Public Shared Operator = ( _
    textRange1 As TextRange, _
    textRange2 As TextRange _
) As Boolean
Visual C++
public:
static bool operator ==(
    TextRange textRange1,
    TextRange textRange2
)

Parameters

textRange1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
textRange2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange..::..Inequality Operator
TextRange Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    TextRange textRange1,
    TextRange textRange2
)
Visual Basic
Public Shared Operator <> ( _
    textRange1 As TextRange, _
    textRange2 As TextRange _
) As Boolean
Visual C++
public:
static bool operator !=(
    TextRange textRange1,
    TextRange textRange2
)

Parameters

textRange1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
textRange2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRange Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange Properties
TextRange Structure See Also Send Feedback

The TextRange type exposes the following members.

Properties

 | Name | Description
Public property | Length | The number of text positions in the range.
Public property | StartPosition | The start text position of the range.

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Length Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange..::..Length Property
TextRange Structure See Also Send Feedback
The number of text positions in the range.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Length { get; set; }
Visual Basic
Public Property Length As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


StartPosition Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRange..::..StartPosition Property
TextRange Structure See Also Send Feedback
The start text position of the range.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint StartPosition { get; set; }
Visual Basic
Public Property StartPosition As UInteger
    Get
    Set
Visual C++
public:
property unsigned int StartPosition {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

TextRange Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRangeOf(T) Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRangeOf<(Of <(<'T>)>)> Structure
Members See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct TextRangeOf<T>
Visual Basic
Public Structure TextRangeOf(Of T)
Visual C++
generic<typename T>
public value class TextRangeOf

Type Parameters

T

See Also

TextRangeOf<(Of <(<'T>)>)> Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRangeOf(T) Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRangeOf<(Of <(<'T>)>)> Members
TextRangeOf<(Of <(<'T>)>)> Structure Constructors Properties See Also Send Feedback

The TextRangeOf<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | TextRangeOf<(Of <(<'T>)>)> |

Properties

 | Name | Description
Public property | TextRange |
Public property | Value |

See Also

TextRangeOf<(Of <(<'T>)>)> Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRangeOf(T) Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRangeOf<(Of <(<'T>)>)> Constructor
TextRangeOf<(Of <(<'T>)>)> Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRangeOf(
    TextRange range,
    T value
)
Visual Basic
Public Sub New ( _
    range As TextRange, _
    value As T _
)
Visual C++
public:
TextRangeOf(
    TextRange range,
    T value
)

Parameters

range
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TextRange
value
Type: T

See Also

TextRangeOf<(Of <(<'T>)>)> Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRangeOf(T) Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRangeOf<(Of <(<'T>)>)> Properties
TextRangeOf<(Of <(<'T>)>)> Structure See Also Send Feedback

The TextRangeOf<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | TextRange |
Public property | Value |

See Also

TextRangeOf<(Of <(<'T>)>)> Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TextRange Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRangeOf<(Of <(<'T>)>)>..::..TextRange Property
TextRangeOf<(Of <(<'T>)>)> Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TextRange TextRange { get; }
Visual Basic
Public ReadOnly Property TextRange As TextRange
    Get
Visual C++
public:
property TextRange TextRange {
    TextRange get ();
}

See Also

TextRangeOf<(Of <(<'T>)>)> Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Value Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TextRangeOf<(Of <(<'T>)>)>..::..Value Property
TextRangeOf<(Of <(<'T>)>)> Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public T Value { get; }
Visual Basic
Public ReadOnly Property Value As T
    Get
Visual C++
public:
property T Value {
    T get ();
}

See Also

TextRangeOf<(Of <(<'T>)>)> Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Trimming Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming Structure
Members See Also Send Feedback
Specifies the trimming option for text overflowing the layout box.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Trimming
Visual Basic
Public Structure Trimming
Visual C++
public value class Trimming

See Also

Trimming Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Trimming Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming Members
Trimming Structure Constructors Methods Operators Properties See Also Send Feedback

The Trimming type exposes the following members.

Constructors

 | Name | Description
Public method | Trimming | Constructor for Trimming

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Delimiter | Character code used as the delimiter signaling the beginning of the portion of text to be preserved, most useful for path ellipsis, where the delimeter would be a slash.
Public property | DelimiterCount | How many occurences of the delimiter to step back.
Public property | Granularity | Text granularity of which trimming applies.

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Trimming Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming Constructor
Trimming Structure See Also Send Feedback
Constructor for Trimming

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Trimming(
    TrimmingGranularity granularity,
    uint delimiter,
    uint delimiterCount
)
Visual Basic
Public Sub New ( _
    granularity As TrimmingGranularity, _
    delimiter As UInteger, _
    delimiterCount As UInteger _
)
Visual C++
public:
Trimming(
    TrimmingGranularity granularity,
    unsigned int delimiter,
    unsigned int delimiterCount
)

Parameters

granularity
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TrimmingGranularity
delimiter
Type: System..::..UInt32
delimiterCount
Type: System..::..UInt32

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Trimming Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming Methods
Trimming Structure See Also Send Feedback

The Trimming type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming..::..Equals Method
Trimming Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming..::..GetHashCode Method
Trimming Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Trimming Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming Operators
Trimming Structure See Also Send Feedback

The Trimming type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming..::..Equality Operator
Trimming Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Trimming trimming1,
    Trimming trimming2
)
Visual Basic
Public Shared Operator = ( _
    trimming1 As Trimming, _
    trimming2 As Trimming _
) As Boolean
Visual C++
public:
static bool operator ==(
    Trimming trimming1,
    Trimming trimming2
)

Parameters

trimming1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..Trimming
trimming2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..Trimming

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming..::..Inequality Operator
Trimming Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Trimming trimming1,
    Trimming trimming2
)
Visual Basic
Public Shared Operator <> ( _
    trimming1 As Trimming, _
    trimming2 As Trimming _
) As Boolean
Visual C++
public:
static bool operator !=(
    Trimming trimming1,
    Trimming trimming2
)

Parameters

trimming1
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..Trimming
trimming2
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..Trimming

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Trimming Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming Properties
Trimming Structure See Also Send Feedback

The Trimming type exposes the following members.

Properties

 | Name | Description
Public property | Delimiter | Character code used as the delimiter signaling the beginning of the portion of text to be preserved, most useful for path ellipsis, where the delimeter would be a slash.
Public property | DelimiterCount | How many occurences of the delimiter to step back.
Public property | Granularity | Text granularity of which trimming applies.

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Delimiter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming..::..Delimiter Property
Trimming Structure See Also Send Feedback
Character code used as the delimiter signaling the beginning of the portion of text to be preserved, most useful for path ellipsis, where the delimeter would be a slash.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Delimiter { get; set; }
Visual Basic
Public Property Delimiter As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Delimiter {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


DelimiterCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming..::..DelimiterCount Property
Trimming Structure See Also Send Feedback
How many occurences of the delimiter to step back.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DelimiterCount { get; set; }
Visual Basic
Public Property DelimiterCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DelimiterCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Granularity Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Trimming..::..Granularity Property
Trimming Structure See Also Send Feedback
Text granularity of which trimming applies.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TrimmingGranularity Granularity { get; set; }
Visual Basic
Public Property Granularity As TrimmingGranularity
    Get
    Set
Visual C++
public:
property TrimmingGranularity Granularity {
    TrimmingGranularity get ();
    void set (TrimmingGranularity value);
}

See Also

Trimming Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TrimmingGranularity Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TrimmingGranularity Enumeration
See Also Send Feedback
Text granularity used to trim text overflowing the layout box.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum TrimmingGranularity
Visual Basic
Public Enumeration TrimmingGranularity
Visual C++
public enum class TrimmingGranularity

Members

Member name | Description
None |
Word |
Character |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TrimmingWithSign Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TrimmingWithSign Structure
Members See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct TrimmingWithSign
Visual Basic
Public Structure TrimmingWithSign
Visual C++
public value class TrimmingWithSign

See Also

TrimmingWithSign Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TrimmingWithSign Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TrimmingWithSign Members
TrimmingWithSign Structure Constructors Properties See Also Send Feedback

The TrimmingWithSign type exposes the following members.

Constructors

 | Name | Description
Public method | TrimmingWithSign | Constructor.

Properties

 | Name | Description
Public property | Sign |
Public property | Trimming |

See Also

TrimmingWithSign Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TrimmingWithSign Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TrimmingWithSign Constructor
TrimmingWithSign Structure See Also Send Feedback
Constructor.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public TrimmingWithSign(
    Trimming trimming,
    ICustomInlineObject sign
)
Visual Basic
Public Sub New ( _
    trimming As Trimming, _
    sign As ICustomInlineObject _
)
Visual C++
public:
TrimmingWithSign(
    Trimming trimming,
    ICustomInlineObject^ sign
)

Parameters

trimming
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..Trimming
The trimming options.
sign
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..ICustomInlineObject
An inline object to use as the sign that trimming as occurred.

Remarks

Any inline object can be used for the trimming sign, but DWriteFactory.CreateEllipsisTrimmingSign provides a typical ellipsis symbol. Trimming is also useful vertically for hiding partial lines.

See Also

TrimmingWithSign Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TrimmingWithSign Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TrimmingWithSign Properties
TrimmingWithSign Structure See Also Send Feedback

The TrimmingWithSign type exposes the following members.

Properties

 | Name | Description
Public property | Sign |
Public property | Trimming |

See Also

TrimmingWithSign Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Sign Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TrimmingWithSign..::..Sign Property
TrimmingWithSign Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ICustomInlineObject Sign { get; }
Visual Basic
Public ReadOnly Property Sign As ICustomInlineObject
    Get
Visual C++
public:
property ICustomInlineObject^ Sign {
    ICustomInlineObject^ get ();
}

See Also

TrimmingWithSign Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Trimming Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TrimmingWithSign..::..Trimming Property
TrimmingWithSign Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Trimming Trimming { get; }
Visual Basic
Public ReadOnly Property Trimming As Trimming
    Get
Visual C++
public:
property Trimming Trimming {
    Trimming get ();
}

See Also

TrimmingWithSign Structure
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TypographySettingCollection Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection Class
Members See Also Send Feedback
Represents a collection of OpenType font typography settings (FontFeature).

(Also see DirectX SDK: IDWriteTypography)

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class TypographySettingCollection : DirectUnknown,
    IList<FontFeature>
Visual Basic
Public Class TypographySettingCollection _
    Inherits DirectUnknown _
    Implements IList(Of FontFeature)
Visual C++
public ref class TypographySettingCollection : public DirectUnknown,
    IList<FontFeature>

Remarks

Once an OpenType font feature setting has been added, it cannot be removed from the collection.

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..TypographySettingCollection

See Also

TypographySettingCollection Members
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TypographySettingCollection Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection Members
TypographySettingCollection Class Methods Properties See Also Send Feedback

The TypographySettingCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an OpenType font feature.
Protected method | Clear |
Protected method | Contains |
Protected method | CopyTo |
Public method | GetEnumerator | Gets the enumerator for this collection.
Public method | GetGenericEnumerator |
Protected method | IndexOf |
Protected method | Insert |
Protected method | Remove |
Protected method | RemoveAt |

Properties

 | Name | Description
Public property | Count | Get the number of font features in the collection.
Public property | IsReadOnly | Determines if the collection is readonly.
Public property | Item | Gets the font feature at the specified index.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TypographySettingCollection Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection Methods
TypographySettingCollection Class See Also Send Feedback

The TypographySettingCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an OpenType font feature.
Protected method | Clear |
Protected method | Contains |
Protected method | CopyTo |
Public method | GetEnumerator | Gets the enumerator for this collection.
Public method | GetGenericEnumerator |
Protected method | IndexOf |
Protected method | Insert |
Protected method | Remove |
Protected method | RemoveAt |

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Add Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..Add Method
TypographySettingCollection Class See Also Send Feedback
Adds an OpenType font feature.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual void Add(
    FontFeature feature
)
Visual Basic
Public Overridable Sub Add ( _
    feature As FontFeature _
)
Visual C++
public:
virtual void Add(
    FontFeature feature
)

Parameters

feature
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature
Font feature to add to the collection.

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Clear Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..Clear Method
TypographySettingCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Clear()
Visual Basic
Protected Overridable Sub Clear
Visual C++
protected:
virtual void Clear()

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Contains Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..Contains Method
TypographySettingCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual bool Contains(
    FontFeature item
)
Visual Basic
Protected Overridable Function Contains ( _
    item As FontFeature _
) As Boolean
Visual C++
protected:
virtual bool Contains(
    FontFeature item
)

Parameters

item
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


CopyTo Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..CopyTo Method
TypographySettingCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void CopyTo(
    FontFeature[] fontFeatureArray,
    int arrayIndex
)
Visual Basic
Protected Overridable Sub CopyTo ( _
    fontFeatureArray As FontFeature(), _
    arrayIndex As Integer _
)
Visual C++
protected:
virtual void CopyTo(
    array<FontFeature>^ fontFeatureArray,
    int arrayIndex
)

Parameters

fontFeatureArray
Type: array< Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature >[]()[][]
arrayIndex
Type: System..::..Int32

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetEnumerator Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..GetEnumerator Method
TypographySettingCollection Class See Also Send Feedback
Gets the enumerator for this collection.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


GetGenericEnumerator Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..GetGenericEnumerator Method
TypographySettingCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual IEnumerator<FontFeature> GetGenericEnumerator()
Visual Basic
Public Overridable Function GetGenericEnumerator As IEnumerator(Of FontFeature)
Visual C++
public:
virtual IEnumerator<FontFeature>^ GetGenericEnumerator()

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IndexOf Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..IndexOf Method
TypographySettingCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual int IndexOf(
    FontFeature item
)
Visual Basic
Protected Overridable Function IndexOf ( _
    item As FontFeature _
) As Integer
Visual C++
protected:
virtual int IndexOf(
    FontFeature item
)

Parameters

item
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Insert Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..Insert Method
TypographySettingCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Insert(
    int index,
    FontFeature item
)
Visual Basic
Protected Overridable Sub Insert ( _
    index As Integer, _
    item As FontFeature _
)
Visual C++
protected:
virtual void Insert(
    int index,
    FontFeature item
)

Parameters

index
Type: System..::..Int32
item
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Remove Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..Remove Method
TypographySettingCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual bool Remove(
    FontFeature item
)
Visual Basic
Protected Overridable Function Remove ( _
    item As FontFeature _
) As Boolean
Visual C++
protected:
virtual bool Remove(
    FontFeature item
)

Parameters

item
Type: Microsoft.WindowsAPICodePack.DirectX.DirectWrite..::..FontFeature

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


RemoveAt Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..RemoveAt Method
TypographySettingCollection Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void RemoveAt(
    int index
)
Visual Basic
Protected Overridable Sub RemoveAt ( _
    index As Integer _
)
Visual C++
protected:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: System..::..Int32

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


TypographySettingCollection Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection Properties
TypographySettingCollection Class See Also Send Feedback

The TypographySettingCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Get the number of font features in the collection.
Public property | IsReadOnly | Determines if the collection is readonly.
Public property | Item | Gets the font feature at the specified index.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Count Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..Count Property
TypographySettingCollection Class See Also Send Feedback
Get the number of font features in the collection.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual int Count { get; }
Visual Basic
Public Overridable ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get ();
}

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


IsReadOnly Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..IsReadOnly Property
TypographySettingCollection Class See Also Send Feedback
Determines if the collection is readonly.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Item Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
TypographySettingCollection..::..Item Property
TypographySettingCollection Class See Also Send Feedback
Gets the font feature at the specified index.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public virtual FontFeature this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As FontFeature
    Get
    Set
Visual C++
public:
virtual property FontFeature default[int index] {
    FontFeature get (int index);
    void set (int index, FontFeature value);
}

Parameters

index
Type: System..::..Int32

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

TypographySettingCollection Class
Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


WordWrapping Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
WordWrapping Enumeration
See Also Send Feedback
Word wrapping in multiline paragraph.

Namespace: Microsoft.WindowsAPICodePack.DirectX.DirectWrite
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum WordWrapping
Visual Basic
Public Enumeration WordWrapping
Visual C++
public enum class WordWrapping

Members

Member name | Description
NoWrap |
Wrap |

See Also

Microsoft.WindowsAPICodePack.DirectX.DirectWrite Namespace


Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Send Feedback

Classes

 | Class | Description
Public class | Adapter | The Adapter interface represents a display sub-system (including one or more GPU's, DACs and video memory). (Also see DirectX SDK: IDXGIAdapter)
Public class | Adapter1 | The Adapter1 interface represents a display sub-system (including one or more GPU's, DACs and video memory). (Also see DirectX SDK: IDXGIAdapter1)
Public class | Device | Implements a derived class for Graphics objects that produce image data. (Also see DirectX SDK: IDXGIDevice)
Public class | Device1 | Implements a derived class for Graphics 1.1 objects that produce image data. (Also see DirectX SDK: IDXGIDevice1)
Public class | DeviceSubObject | Inherited from objects that are tied to the device so that they can retrieve it. (Also see DirectX SDK: IDXGIDeviceSubObject)
Public class | Factory | Implements methods for generating Graphics objects (which handle fullscreen transitions). (Also see DirectX SDK: IDXGIFactory)
Public class | Factory1 | The Factory1 interface implements methods for generating Graphics objects. (Also see DirectX SDK: IDXGIFactory1)
Public class | GraphicsException | An exception thrown by Graphics.
Public class | GraphicsObject | An GraphicsObject is the base for all Graphics classes. (Also see DirectX SDK: IDXGIObject)
Public class | KeyedMutex | Represents a keyed mutex, which allows exclusive access to a shared resource that is used by multiple devices. (Also see DirectX SDK: IDXGIKeyedMutex)
Public class | Output | An Output interface represents an adapter output (such as a monitor). (Also see DirectX SDK: IDXGIOutput)
Public class | Resource | An Resource interface allows resource sharing and identifies the memory that a resource resides in. (Also see DirectX SDK: IDXGIResource)
Public class | Surface | An Surface interface implements methods for image-data objects. (Also see DirectX SDK: IDXGISurface)
Public class | Surface1 | The Surface1 interface extends the Surface by adding support for rendering to a Graphics interface using GDI. (Also see DirectX SDK: IDXGISurface1)
Public class | SwapChain | An SwapChain interface implements one or more surfaces for storing rendered data before presenting it to an output. (Also see DirectX SDK: IDXGISwapChain)

Structures

 | Structure | Description
Public structure | AdapterDescription | Describes an adapter (or video card) by using Graphics 1.0. (Also see DirectX SDK: DXGI_ADAPTER_DESC)
Public structure | AdapterDescription1 | Describes an adapter (or video card) using Graphics 1.1. (Also see DirectX SDK: DXGI_ADAPTER_DESC1)
Public structure | AdapterDriverVersion |
Public structure | ColorRgb | Represents an RGB color. (Also see DirectX SDK: DXGI_RGB)
Public structure | ColorRgba | Represents an RGBA color.
Public structure | FrameStatistics | Describes timing and presentation statistics for a frame. (Also see DirectX SDK: DXGI_FRAME_STATISTICS)
Public structure | GammaControl | Controls the settings of a gamma curve. (Also see DirectX SDK: DXGI_GAMMA_CONTROL)
Public structure | GammaControlCapabilities | Controls the gamma capabilities of an adapter. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES)
Public structure | Luid | A Luid is a 64-bit value guaranteed to be unique only on the system on which it was generated. The uniqueness of a locally unique identifier (LUID) is guaranteed only until the system is restarted. An LUID is not for direct manipulation. Applications are to use functions and structures to manipulate Luid values.
Public structure | MappedRect | A mapped rectangle used for accessing a surface. (Also see DirectX SDK: DXGI_MAPPED_RECT)
Public structure | ModeDescription | Describes a display mode. (Also see DirectX SDK: DXGI_MODE_DESC)
Public structure | MonitorInfo | Describes a monitor. (Also see Windows SDK: MONITORINFOEX)
Public structure | OutputDescription | Describes an output or physical connection between the adapter (video card) and a device. (Also see DirectX SDK: DXGI_OUTPUT_DESC)
Public structure | Rational | Represents a rational number. (Also see DirectX SDK: DXGI_RATIONAL)
Public structure | SampleDescription | Describes multi-sampling parameters for a resource. (Also see DirectX SDK: DXGI_SAMPLE_DESC)
Public structure | SharedResource | Represents a handle to a shared resource. (Also see DirectX SDK: DXGI_SHARED_RESOURCE)
Public structure | SurfaceDescription | Describes a surface. (Also see DirectX SDK: DXGI_SURFACE_DESC)
Public structure | SwapChainDescription | Describes a swap chain. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC)

Enumerations

 | Enumeration | Description
Public enumeration | AdapterOptions | Identifies if an adapter is local or remote. (Also see DirectX SDK: DXGI_ADAPTER_FLAG)
Public enumeration | Format | Resource data formats which includes fully-typed and typeless formats. There is a collection of format modifiers at the bottom of the page, that more fully describes each format type. (Also see DirectX SDK: DXGI_FORMAT)
Public enumeration | MakeWindowAssociationOptions | Flags for making window association with a surface.
Public enumeration | MapOptions | CPU read-write flags. These flags can be combined with a logical OR.
Public enumeration | ModeRotation | Flags that indicate how the back buffers should be rotated to fit the physical rotation of a monitor. (Also see DirectX SDK: DXGI_MODE_ROTATION)
Public enumeration | ModeScaling | Flags indicating how an image is stretched to fit a given monitor's resolution. (Also see DirectX SDK: DXGI_MODE_SCALING)
Public enumeration | ModeScanlineOrder | Flags indicating the method the raster uses to create an image on a surface. (Also see DirectX SDK: DXGI_MODE_SCANLINE_ORDER)
Public enumeration | NonDefaultModes | Options for enumerating display modes. (Also see DirectX SDK: DXGI_ENUM_MODES)
Public enumeration | PresentOptions | Options for presenting frames to the output. (Also see DirectX SDK: DXGI_PRESENT)
Public enumeration | Residency | Flags indicating the memory location of a resource. (Also see DirectX SDK: DXGI_RESIDENCY)
Public enumeration | ResourcePriority | Resource Priorities.
Public enumeration | SwapChainOptions | Options for swap-chain behavior. (Also see DirectX SDK: DXGI_SWAP_CHAIN_FLAG)
Public enumeration | SwapEffect | Options for handling pixels in a display surface after calling SwapChain.Present. (Also see DirectX SDK: DXGI_SWAP_EFFECT)
Public enumeration | UsageOptions | Flags for surface and resource creation options. (Also see DirectX SDK: DXGI_USAGE)


Adapter Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter Class
Members See Also Send Feedback
The Adapter interface represents a display sub-system (including one or more GPU's, DACs and video memory).

(Also see DirectX SDK: IDXGIAdapter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Adapter : GraphicsObject
Visual Basic
Public Class Adapter _
    Inherits GraphicsObject
Visual C++
public ref class Adapter : public GraphicsObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter1

See Also

Adapter Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapter Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter Members
Adapter Class Methods Properties See Also Send Feedback

The Adapter type exposes the following members.

Methods

 | Name | Description
Public method | CheckDeviceSupport | Checks to see if a device interface type for a graphics component is supported by the system. (Also see DirectX SDK: IDXGIAdapter::CheckInterfaceSupport)
Public method | GetOutput | Get an adapter (video card) output. (Also see DirectX SDK: IDXGIAdapter::EnumOutputs)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)

Properties

 | Name | Description
Public property | Description | Gets a DXGI 1.0 description of an adapter (or video card). (Also see DirectX SDK: IDXGIAdapter::GetDesc)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Outputs | Get a read-only collection of all adapter (video card) outputs available. (Also see DirectX SDK: IDXGIAdapter::EnumOutputs)

See Also

Adapter Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapter Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter Methods
Adapter Class See Also Send Feedback

The Adapter type exposes the following members.

Methods

 | Name | Description
Public method | CheckDeviceSupport | Checks to see if a device interface type for a graphics component is supported by the system. (Also see DirectX SDK: IDXGIAdapter::CheckInterfaceSupport)
Public method | GetOutput | Get an adapter (video card) output. (Also see DirectX SDK: IDXGIAdapter::EnumOutputs)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)

See Also

Adapter Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


CheckDeviceSupport Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter..::..CheckDeviceSupport Method
Adapter Class See Also Send Feedback
Checks to see if a device interface type for a graphics component is supported by the system.

(Also see DirectX SDK: IDXGIAdapter::CheckInterfaceSupport)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Nullable<AdapterDriverVersion> CheckDeviceSupport(
    DeviceType deviceType
)
Visual Basic
Public Function CheckDeviceSupport ( _
    deviceType As DeviceType _
) As Nullable(Of AdapterDriverVersion)
Visual C++
public:
Nullable<AdapterDriverVersion> CheckDeviceSupport(
    DeviceType deviceType
)

Parameters

deviceType
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..DeviceType
The device support checked.

Return Value

An AdapterDriverVersion value containing the major and minor driver version numbers, if the device type is supported for the adapter. Otherwise, null.

See Also

Adapter Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetOutput Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter..::..GetOutput Method
Adapter Class See Also Send Feedback
Get an adapter (video card) output.

(Also see DirectX SDK: IDXGIAdapter::EnumOutputs)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Output GetOutput(
    uint index
)
Visual Basic
Public Function GetOutput ( _
    index As UInteger _
) As Output
Visual C++
public:
Output^ GetOutput(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
The index of the output requested.

Return Value

An Output object

See Also

Adapter Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapter Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter Properties
Adapter Class See Also Send Feedback

The Adapter type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a DXGI 1.0 description of an adapter (or video card). (Also see DirectX SDK: IDXGIAdapter::GetDesc)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Outputs | Get a read-only collection of all adapter (video card) outputs available. (Also see DirectX SDK: IDXGIAdapter::EnumOutputs)

See Also

Adapter Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter..::..Description Property
Adapter Class See Also Send Feedback
Gets a DXGI 1.0 description of an adapter (or video card).

(Also see DirectX SDK: IDXGIAdapter::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public AdapterDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As AdapterDescription
    Get
Visual C++
public:
property AdapterDescription Description {
    AdapterDescription get ();
}

See Also

Adapter Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Outputs Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter..::..Outputs Property
Adapter Class See Also Send Feedback
Get a read-only collection of all adapter (video card) outputs available.

(Also see DirectX SDK: IDXGIAdapter::EnumOutputs)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<Output> Outputs { get; }
Visual Basic
Public ReadOnly Property Outputs As ReadOnlyCollection(Of Output)
    Get
Visual C++
public:
property ReadOnlyCollection<Output^>^ Outputs {
    ReadOnlyCollection<Output^>^ get ();
}

See Also

Adapter Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapter1 Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter1 Class
Members See Also Send Feedback
The Adapter1 interface represents a display sub-system (including one or more GPU's, DACs and video memory).

(Also see DirectX SDK: IDXGIAdapter1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Adapter1 : Adapter
Visual Basic
Public Class Adapter1 _
    Inherits Adapter
Visual C++
public ref class Adapter1 : public Adapter

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter1

See Also

Adapter1 Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapter1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter1 Members
Adapter1 Class Methods Properties See Also Send Feedback

The Adapter1 type exposes the following members.

Methods

 | Name | Description
Public method | CheckDeviceSupport | Checks to see if a device interface type for a graphics component is supported by the system. (Also see DirectX SDK: IDXGIAdapter::CheckInterfaceSupport) (Inherited from Adapter.)
Public method | GetOutput | Get an adapter (video card) output. (Also see DirectX SDK: IDXGIAdapter::EnumOutputs) (Inherited from Adapter.)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)

Properties

 | Name | Description
Public property | Description | Gets a DXGI 1.0 description of an adapter (or video card). (Also see DirectX SDK: IDXGIAdapter::GetDesc) (Inherited from Adapter.)
Public property | Description1 | Gets a DXGI 1.1 description of a local or remote adapter (or video card). (Also see DirectX SDK: IDXGIAdapter1::GetDesc1)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Outputs | Get a read-only collection of all adapter (video card) outputs available. (Also see DirectX SDK: IDXGIAdapter::EnumOutputs) (Inherited from Adapter.)

See Also

Adapter1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapter1 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter1 Methods
Adapter1 Class See Also Send Feedback

The Adapter1 type exposes the following members.

Methods

 | Name | Description
Public method | CheckDeviceSupport | Checks to see if a device interface type for a graphics component is supported by the system. (Also see DirectX SDK: IDXGIAdapter::CheckInterfaceSupport) (Inherited from Adapter.)
Public method | GetOutput | Get an adapter (video card) output. (Also see DirectX SDK: IDXGIAdapter::EnumOutputs) (Inherited from Adapter.)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)

See Also

Adapter1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapter1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter1 Properties
Adapter1 Class See Also Send Feedback

The Adapter1 type exposes the following members.

Properties

 | Name | Description
Public property | Description | Gets a DXGI 1.0 description of an adapter (or video card). (Also see DirectX SDK: IDXGIAdapter::GetDesc) (Inherited from Adapter.)
Public property | Description1 | Gets a DXGI 1.1 description of a local or remote adapter (or video card). (Also see DirectX SDK: IDXGIAdapter1::GetDesc1)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | Outputs | Get a read-only collection of all adapter (video card) outputs available. (Also see DirectX SDK: IDXGIAdapter::EnumOutputs) (Inherited from Adapter.)

See Also

Adapter1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Description1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Adapter1..::..Description1 Property
Adapter1 Class See Also Send Feedback
Gets a DXGI 1.1 description of a local or remote adapter (or video card).

(Also see DirectX SDK: IDXGIAdapter1::GetDesc1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public AdapterDescription1 Description1 { get; }
Visual Basic
Public ReadOnly Property Description1 As AdapterDescription1
    Get
Visual C++
public:
property AdapterDescription1 Description1 {
    AdapterDescription1 get ();
}

See Also

Adapter1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription Structure
Members See Also Send Feedback
Describes an adapter (or video card) by using Graphics 1.0.

(Also see DirectX SDK: DXGI_ADAPTER_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct AdapterDescription
Visual Basic
Public Structure AdapterDescription
Visual C++
public value class AdapterDescription

See Also

AdapterDescription Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription Members
AdapterDescription Structure Methods Operators Properties See Also Send Feedback

The AdapterDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AdapterLuid | A unique value that identifies the adapter. See LUID for a definition of the structure. LUID is defined in dxgi.h. (Also see DirectX SDK: DXGI_ADAPTER_DESC.AdapterLuid)
Public property | DedicatedSystemMemory | The number of bytes of dedicated system memory that are not shared with the GPU. This memory is allocated from available system memory at boot time. (Also see DirectX SDK: DXGI_ADAPTER_DESC.DedicatedSystemMemory)
Public property | DedicatedVideoMemory | The number of bytes of dedicated video memory that are not shared with the CPU. (Also see DirectX SDK: DXGI_ADAPTER_DESC.DedicatedVideoMemory)
Public property | Description | A string that contains the adapter description. (Also see DirectX SDK: DXGI_ADAPTER_DESC.Description)
Public property | DeviceId | The PCI ID of the hardware device. (Also see DirectX SDK: DXGI_ADAPTER_DESC.DeviceId)
Public property | Revision | The PCI ID of the revision number of the adapter. (Also see DirectX SDK: DXGI_ADAPTER_DESC.Revision)
Public property | SharedSystemMemory | The number of bytes of shared system memory. This is the maximum value of system memory that may be consumed by the adapter during operation. Any incidental memory consumed by the driver as it manages and uses video memory is additional. (Also see DirectX SDK: DXGI_ADAPTER_DESC.SharedSystemMemory)
Public property | SubSysId | The PCI ID of the sub system. (Also see DirectX SDK: DXGI_ADAPTER_DESC.SubSysId)
Public property | VendorId | The PCI ID of the hardware vendor. (Also see DirectX SDK: DXGI_ADAPTER_DESC.VendorId)

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription Methods
AdapterDescription Structure See Also Send Feedback

The AdapterDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..Equals Method
AdapterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..GetHashCode Method
AdapterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription Operators
AdapterDescription Structure See Also Send Feedback

The AdapterDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..Equality Operator
AdapterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    AdapterDescription adapterDescription1,
    AdapterDescription adapterDescription2
)
Visual Basic
Public Shared Operator = ( _
    adapterDescription1 As AdapterDescription, _
    adapterDescription2 As AdapterDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    AdapterDescription adapterDescription1,
    AdapterDescription adapterDescription2
)

Parameters

adapterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDescription
adapterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDescription

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..Inequality Operator
AdapterDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    AdapterDescription adapterDescription1,
    AdapterDescription adapterDescription2
)
Visual Basic
Public Shared Operator <> ( _
    adapterDescription1 As AdapterDescription, _
    adapterDescription2 As AdapterDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    AdapterDescription adapterDescription1,
    AdapterDescription adapterDescription2
)

Parameters

adapterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDescription
adapterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDescription

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription Properties
AdapterDescription Structure See Also Send Feedback

The AdapterDescription type exposes the following members.

Properties

 | Name | Description
Public property | AdapterLuid | A unique value that identifies the adapter. See LUID for a definition of the structure. LUID is defined in dxgi.h. (Also see DirectX SDK: DXGI_ADAPTER_DESC.AdapterLuid)
Public property | DedicatedSystemMemory | The number of bytes of dedicated system memory that are not shared with the GPU. This memory is allocated from available system memory at boot time. (Also see DirectX SDK: DXGI_ADAPTER_DESC.DedicatedSystemMemory)
Public property | DedicatedVideoMemory | The number of bytes of dedicated video memory that are not shared with the CPU. (Also see DirectX SDK: DXGI_ADAPTER_DESC.DedicatedVideoMemory)
Public property | Description | A string that contains the adapter description. (Also see DirectX SDK: DXGI_ADAPTER_DESC.Description)
Public property | DeviceId | The PCI ID of the hardware device. (Also see DirectX SDK: DXGI_ADAPTER_DESC.DeviceId)
Public property | Revision | The PCI ID of the revision number of the adapter. (Also see DirectX SDK: DXGI_ADAPTER_DESC.Revision)
Public property | SharedSystemMemory | The number of bytes of shared system memory. This is the maximum value of system memory that may be consumed by the adapter during operation. Any incidental memory consumed by the driver as it manages and uses video memory is additional. (Also see DirectX SDK: DXGI_ADAPTER_DESC.SharedSystemMemory)
Public property | SubSysId | The PCI ID of the sub system. (Also see DirectX SDK: DXGI_ADAPTER_DESC.SubSysId)
Public property | VendorId | The PCI ID of the hardware vendor. (Also see DirectX SDK: DXGI_ADAPTER_DESC.VendorId)

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterLuid Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..AdapterLuid Property
AdapterDescription Structure See Also Send Feedback
A unique value that identifies the adapter. See LUID for a definition of the structure. LUID is defined in dxgi.h.

(Also see DirectX SDK: DXGI_ADAPTER_DESC.AdapterLuid)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Luid AdapterLuid { get; set; }
Visual Basic
Public Property AdapterLuid As Luid
    Get
    Set
Visual C++
public:
property Luid AdapterLuid {
    Luid get ();
    void set (Luid value);
}

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DedicatedSystemMemory Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..DedicatedSystemMemory Property
AdapterDescription Structure See Also Send Feedback
The number of bytes of dedicated system memory that are not shared with the GPU. This memory is allocated from available system memory at boot time.

(Also see DirectX SDK: DXGI_ADAPTER_DESC.DedicatedSystemMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DedicatedSystemMemory { get; set; }
Visual Basic
Public Property DedicatedSystemMemory As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DedicatedSystemMemory {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DedicatedVideoMemory Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..DedicatedVideoMemory Property
AdapterDescription Structure See Also Send Feedback
The number of bytes of dedicated video memory that are not shared with the CPU.

(Also see DirectX SDK: DXGI_ADAPTER_DESC.DedicatedVideoMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DedicatedVideoMemory { get; set; }
Visual Basic
Public Property DedicatedVideoMemory As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DedicatedVideoMemory {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..Description Property
AdapterDescription Structure See Also Send Feedback
A string that contains the adapter description.

(Also see DirectX SDK: DXGI_ADAPTER_DESC.Description)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DeviceId Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..DeviceId Property
AdapterDescription Structure See Also Send Feedback
The PCI ID of the hardware device.

(Also see DirectX SDK: DXGI_ADAPTER_DESC.DeviceId)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DeviceId { get; set; }
Visual Basic
Public Property DeviceId As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DeviceId {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Revision Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..Revision Property
AdapterDescription Structure See Also Send Feedback
The PCI ID of the revision number of the adapter.

(Also see DirectX SDK: DXGI_ADAPTER_DESC.Revision)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Revision { get; set; }
Visual Basic
Public Property Revision As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Revision {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SharedSystemMemory Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..SharedSystemMemory Property
AdapterDescription Structure See Also Send Feedback
The number of bytes of shared system memory. This is the maximum value of system memory that may be consumed by the adapter during operation. Any incidental memory consumed by the driver as it manages and uses video memory is additional.

(Also see DirectX SDK: DXGI_ADAPTER_DESC.SharedSystemMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SharedSystemMemory { get; set; }
Visual Basic
Public Property SharedSystemMemory As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SharedSystemMemory {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SubSysId Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..SubSysId Property
AdapterDescription Structure See Also Send Feedback
The PCI ID of the sub system.

(Also see DirectX SDK: DXGI_ADAPTER_DESC.SubSysId)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SubSysId { get; set; }
Visual Basic
Public Property SubSysId As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SubSysId {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


VendorId Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription..::..VendorId Property
AdapterDescription Structure See Also Send Feedback
The PCI ID of the hardware vendor.

(Also see DirectX SDK: DXGI_ADAPTER_DESC.VendorId)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint VendorId { get; set; }
Visual Basic
Public Property VendorId As UInteger
    Get
    Set
Visual C++
public:
property unsigned int VendorId {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription1 Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1 Structure
Members See Also Send Feedback
Describes an adapter (or video card) using Graphics 1.1.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct AdapterDescription1
Visual Basic
Public Structure AdapterDescription1
Visual C++
public value class AdapterDescription1

See Also

AdapterDescription1 Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1 Members
AdapterDescription1 Structure Methods Operators Properties See Also Send Feedback

The AdapterDescription1 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | AdapterLuid | A unique value that identifies the adapter. See LUID for a definition of the structure. LUID is defined in dxgi.h. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.AdapterLuid)
Public property | DedicatedSystemMemory | The number of bytes of dedicated system memory that are not shared with the GPU. This memory is allocated from available system memory at boot time. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.DedicatedSystemMemory)
Public property | DedicatedVideoMemory | The number of bytes of dedicated video memory that are not shared with the CPU. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.DedicatedVideoMemory)
Public property | Description | A string that contains the adapter description. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.Description)
Public property | DeviceId | The PCI ID of the hardware device. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.DeviceId)
Public property | Options | A member of the AdapterOptions enumerated type that describes the adapter type. The AdapterOptions Remote flag specifies that the adapter is a remote adapter. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.Flags)
Public property | Revision | The PCI ID of the revision number of the adapter. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.Revision)
Public property | SharedSystemMemory | The number of bytes of shared system memory. This is the maximum value of system memory that may be consumed by the adapter during operation. Any incidental memory consumed by the driver as it manages and uses video memory is additional. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.SharedSystemMemory)
Public property | SubSysId | The PCI ID of the sub system. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.SubSysId)
Public property | VendorId | The PCI ID of the hardware vendor. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.VendorId)

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription1 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1 Methods
AdapterDescription1 Structure See Also Send Feedback

The AdapterDescription1 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..Equals Method
AdapterDescription1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..GetHashCode Method
AdapterDescription1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription1 Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1 Operators
AdapterDescription1 Structure See Also Send Feedback

The AdapterDescription1 type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..Equality Operator
AdapterDescription1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    AdapterDescription1 adapterDescription1,
    AdapterDescription1 adapterDescription2
)
Visual Basic
Public Shared Operator = ( _
    adapterDescription1 As AdapterDescription1, _
    adapterDescription2 As AdapterDescription1 _
) As Boolean
Visual C++
public:
static bool operator ==(
    AdapterDescription1 adapterDescription1,
    AdapterDescription1 adapterDescription2
)

Parameters

adapterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDescription1
adapterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDescription1

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..Inequality Operator
AdapterDescription1 Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    AdapterDescription1 adapterDescription1,
    AdapterDescription1 adapterDescription2
)
Visual Basic
Public Shared Operator <> ( _
    adapterDescription1 As AdapterDescription1, _
    adapterDescription2 As AdapterDescription1 _
) As Boolean
Visual C++
public:
static bool operator !=(
    AdapterDescription1 adapterDescription1,
    AdapterDescription1 adapterDescription2
)

Parameters

adapterDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDescription1
adapterDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDescription1

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDescription1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1 Properties
AdapterDescription1 Structure See Also Send Feedback

The AdapterDescription1 type exposes the following members.

Properties

 | Name | Description
Public property | AdapterLuid | A unique value that identifies the adapter. See LUID for a definition of the structure. LUID is defined in dxgi.h. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.AdapterLuid)
Public property | DedicatedSystemMemory | The number of bytes of dedicated system memory that are not shared with the GPU. This memory is allocated from available system memory at boot time. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.DedicatedSystemMemory)
Public property | DedicatedVideoMemory | The number of bytes of dedicated video memory that are not shared with the CPU. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.DedicatedVideoMemory)
Public property | Description | A string that contains the adapter description. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.Description)
Public property | DeviceId | The PCI ID of the hardware device. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.DeviceId)
Public property | Options | A member of the AdapterOptions enumerated type that describes the adapter type. The AdapterOptions Remote flag specifies that the adapter is a remote adapter. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.Flags)
Public property | Revision | The PCI ID of the revision number of the adapter. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.Revision)
Public property | SharedSystemMemory | The number of bytes of shared system memory. This is the maximum value of system memory that may be consumed by the adapter during operation. Any incidental memory consumed by the driver as it manages and uses video memory is additional. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.SharedSystemMemory)
Public property | SubSysId | The PCI ID of the sub system. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.SubSysId)
Public property | VendorId | The PCI ID of the hardware vendor. (Also see DirectX SDK: DXGI_ADAPTER_DESC1.VendorId)

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterLuid Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..AdapterLuid Property
AdapterDescription1 Structure See Also Send Feedback
A unique value that identifies the adapter. See LUID for a definition of the structure. LUID is defined in dxgi.h.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.AdapterLuid)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Luid AdapterLuid { get; set; }
Visual Basic
Public Property AdapterLuid As Luid
    Get
    Set
Visual C++
public:
property Luid AdapterLuid {
    Luid get ();
    void set (Luid value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DedicatedSystemMemory Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..DedicatedSystemMemory Property
AdapterDescription1 Structure See Also Send Feedback
The number of bytes of dedicated system memory that are not shared with the GPU. This memory is allocated from available system memory at boot time.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.DedicatedSystemMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DedicatedSystemMemory { get; set; }
Visual Basic
Public Property DedicatedSystemMemory As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DedicatedSystemMemory {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DedicatedVideoMemory Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..DedicatedVideoMemory Property
AdapterDescription1 Structure See Also Send Feedback
The number of bytes of dedicated video memory that are not shared with the CPU.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.DedicatedVideoMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DedicatedVideoMemory { get; set; }
Visual Basic
Public Property DedicatedVideoMemory As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DedicatedVideoMemory {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..Description Property
AdapterDescription1 Structure See Also Send Feedback
A string that contains the adapter description.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.Description)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DeviceId Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..DeviceId Property
AdapterDescription1 Structure See Also Send Feedback
The PCI ID of the hardware device.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.DeviceId)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DeviceId { get; set; }
Visual Basic
Public Property DeviceId As UInteger
    Get
    Set
Visual C++
public:
property unsigned int DeviceId {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Options Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..Options Property
AdapterDescription1 Structure See Also Send Feedback
A member of the AdapterOptions enumerated type that describes the adapter type. The AdapterOptions Remote flag specifies that the adapter is a remote adapter.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.Flags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public AdapterOptions Options { get; set; }
Visual Basic
Public Property Options As AdapterOptions
    Get
    Set
Visual C++
public:
property AdapterOptions Options {
    AdapterOptions get ();
    void set (AdapterOptions value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Revision Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..Revision Property
AdapterDescription1 Structure See Also Send Feedback
The PCI ID of the revision number of the adapter.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.Revision)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Revision { get; set; }
Visual Basic
Public Property Revision As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Revision {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SharedSystemMemory Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..SharedSystemMemory Property
AdapterDescription1 Structure See Also Send Feedback
The number of bytes of shared system memory. This is the maximum value of system memory that may be consumed by the adapter during operation. Any incidental memory consumed by the driver as it manages and uses video memory is additional.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.SharedSystemMemory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SharedSystemMemory { get; set; }
Visual Basic
Public Property SharedSystemMemory As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SharedSystemMemory {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SubSysId Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..SubSysId Property
AdapterDescription1 Structure See Also Send Feedback
The PCI ID of the sub system.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.SubSysId)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SubSysId { get; set; }
Visual Basic
Public Property SubSysId As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SubSysId {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


VendorId Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDescription1..::..VendorId Property
AdapterDescription1 Structure See Also Send Feedback
The PCI ID of the hardware vendor.

(Also see DirectX SDK: DXGI_ADAPTER_DESC1.VendorId)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint VendorId { get; set; }
Visual Basic
Public Property VendorId As UInteger
    Get
    Set
Visual C++
public:
property unsigned int VendorId {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

AdapterDescription1 Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDriverVersion Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion Structure
Members See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct AdapterDriverVersion
Visual Basic
Public Structure AdapterDriverVersion
Visual C++
public value class AdapterDriverVersion

See Also

AdapterDriverVersion Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDriverVersion Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion Members
AdapterDriverVersion Structure Methods Operators Properties See Also Send Feedback

The AdapterDriverVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Major |
Public property | Minor |

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDriverVersion Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion Methods
AdapterDriverVersion Structure See Also Send Feedback

The AdapterDriverVersion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion..::..Equals Method
AdapterDriverVersion Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion..::..GetHashCode Method
AdapterDriverVersion Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDriverVersion Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion Operators
AdapterDriverVersion Structure See Also Send Feedback

The AdapterDriverVersion type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion..::..Equality Operator
AdapterDriverVersion Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    AdapterDriverVersion version1,
    AdapterDriverVersion version2
)
Visual Basic
Public Shared Operator = ( _
    version1 As AdapterDriverVersion, _
    version2 As AdapterDriverVersion _
) As Boolean
Visual C++
public:
static bool operator ==(
    AdapterDriverVersion version1,
    AdapterDriverVersion version2
)

Parameters

version1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDriverVersion
version2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDriverVersion

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion..::..Inequality Operator
AdapterDriverVersion Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    AdapterDriverVersion version1,
    AdapterDriverVersion version2
)
Visual Basic
Public Shared Operator <> ( _
    version1 As AdapterDriverVersion, _
    version2 As AdapterDriverVersion _
) As Boolean
Visual C++
public:
static bool operator !=(
    AdapterDriverVersion version1,
    AdapterDriverVersion version2
)

Parameters

version1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDriverVersion
version2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..AdapterDriverVersion

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterDriverVersion Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion Properties
AdapterDriverVersion Structure See Also Send Feedback

The AdapterDriverVersion type exposes the following members.

Properties

 | Name | Description
Public property | Major |
Public property | Minor |

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Major Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion..::..Major Property
AdapterDriverVersion Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Major { get; }
Visual Basic
Public ReadOnly Property Major As Integer
    Get
Visual C++
public:
property int Major {
    int get ();
}

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Minor Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterDriverVersion..::..Minor Property
AdapterDriverVersion Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Minor { get; }
Visual Basic
Public ReadOnly Property Minor As Integer
    Get
Visual C++
public:
property int Minor {
    int get ();
}

See Also

AdapterDriverVersion Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AdapterOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
AdapterOptions Enumeration
See Also Send Feedback
Identifies if an adapter is local or remote.

(Also see DirectX SDK: DXGI_ADAPTER_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum AdapterOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration AdapterOptions
Visual C++
[FlagsAttribute]
public enum class AdapterOptions

Members

Member name | Description
None |
Remote |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgb Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb Structure
Members See Also Send Feedback
Represents an RGB color.

(Also see DirectX SDK: DXGI_RGB)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ColorRgb
Visual Basic
Public Structure ColorRgb
Visual C++
public value class ColorRgb

See Also

ColorRgb Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgb Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb Members
ColorRgb Structure Constructors Methods Operators Properties See Also Send Feedback

The ColorRgb type exposes the following members.

Constructors

 | Name | Description
Public method | ColorRgb |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Blue | A value representing the color of the blue component. The range of this value is between 0 and 1. (Also see DirectX SDK: DXGI_RGB.Blue)
Public property | Green | A value representing the color of the green component. The range of this value is between 0 and 1. (Also see DirectX SDK: DXGI_RGB.Green)
Public property | Red | A value representing the color of the red component. The range of this value is between 0 and 1. (Also see DirectX SDK: DXGI_RGB.Red)

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgb Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb Constructor
ColorRgb Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgb(
    float red,
    float green,
    float blue
)
Visual Basic
Public Sub New ( _
    red As Single, _
    green As Single, _
    blue As Single _
)
Visual C++
public:
ColorRgb(
    float red,
    float green,
    float blue
)

Parameters

red
Type: System..::..Single
green
Type: System..::..Single
blue
Type: System..::..Single

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgb Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb Methods
ColorRgb Structure See Also Send Feedback

The ColorRgb type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb..::..Equals Method
ColorRgb Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb..::..GetHashCode Method
ColorRgb Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgb Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb Operators
ColorRgb Structure See Also Send Feedback

The ColorRgb type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb..::..Equality Operator
ColorRgb Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ColorRgb color1,
    ColorRgb color2
)
Visual Basic
Public Shared Operator = ( _
    color1 As ColorRgb, _
    color2 As ColorRgb _
) As Boolean
Visual C++
public:
static bool operator ==(
    ColorRgb color1,
    ColorRgb color2
)

Parameters

color1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgb
color2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgb

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb..::..Inequality Operator
ColorRgb Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ColorRgb color1,
    ColorRgb color2
)
Visual Basic
Public Shared Operator <> ( _
    color1 As ColorRgb, _
    color2 As ColorRgb _
) As Boolean
Visual C++
public:
static bool operator !=(
    ColorRgb color1,
    ColorRgb color2
)

Parameters

color1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgb
color2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgb

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgb Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb Properties
ColorRgb Structure See Also Send Feedback

The ColorRgb type exposes the following members.

Properties

 | Name | Description
Public property | Blue | A value representing the color of the blue component. The range of this value is between 0 and 1. (Also see DirectX SDK: DXGI_RGB.Blue)
Public property | Green | A value representing the color of the green component. The range of this value is between 0 and 1. (Also see DirectX SDK: DXGI_RGB.Green)
Public property | Red | A value representing the color of the red component. The range of this value is between 0 and 1. (Also see DirectX SDK: DXGI_RGB.Red)

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Blue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb..::..Blue Property
ColorRgb Structure See Also Send Feedback
A value representing the color of the blue component. The range of this value is between 0 and 1.

(Also see DirectX SDK: DXGI_RGB.Blue)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Blue { get; set; }
Visual Basic
Public Property Blue As Single
    Get
    Set
Visual C++
public:
property float Blue {
    float get ();
    void set (float value);
}

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Green Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb..::..Green Property
ColorRgb Structure See Also Send Feedback
A value representing the color of the green component. The range of this value is between 0 and 1.

(Also see DirectX SDK: DXGI_RGB.Green)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Green { get; set; }
Visual Basic
Public Property Green As Single
    Get
    Set
Visual C++
public:
property float Green {
    float get ();
    void set (float value);
}

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Red Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgb..::..Red Property
ColorRgb Structure See Also Send Feedback
A value representing the color of the red component. The range of this value is between 0 and 1.

(Also see DirectX SDK: DXGI_RGB.Red)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Red { get; set; }
Visual Basic
Public Property Red As Single
    Get
    Set
Visual C++
public:
property float Red {
    float get ();
    void set (float value);
}

See Also

ColorRgb Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Structure
Members See Also Send Feedback
Represents an RGBA color.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ColorRgba
Visual Basic
Public Structure ColorRgba
Visual C++
public value class ColorRgba

See Also

ColorRgba Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Members
ColorRgba Structure Constructors Methods Operators Properties See Also Send Feedback

The ColorRgba type exposes the following members.

Constructors

 | Name | Description
Public method | ColorRgba(array<Single>[]()[][]) |
Public method | ColorRgba(ColorF) |
Public method | ColorRgba(ColorF, Single) |
Public method | ColorRgba(Single, Single, Single, Single) |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Alpha | A value representing the alpha channel component. The range of this value is between 0 and 1.
Public property | Blue | A value representing the color of the blue component. The range of this value is between 0 and 1.
Public property | Green | A value representing the color of the green component. The range of this value is between 0 and 1.
Public property | Red | A value representing the color of the red component. The range of this value is between 0 and 1.

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Constructor
ColorRgba Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorRgba(array<Single>[]()[][]) |
Public method | ColorRgba(ColorF) |
Public method | ColorRgba(ColorF, Single) |
Public method | ColorRgba(Single, Single, Single, Single) |

See Also

ColorRgba Structure
ColorRgba Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Constructor (Single[])

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Constructor (array<Single>[]()[][])
ColorRgba Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgba(
    float[] rgbaColors
)
Visual Basic
Public Sub New ( _
    rgbaColors As Single() _
)
Visual C++
public:
ColorRgba(
    array<float>^ rgbaColors
)

Parameters

rgbaColors
Type: array< System..::..Single >[]()[][]

See Also

ColorRgba Structure
ColorRgba Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Constructor (ColorF)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Constructor (ColorF)
ColorRgba Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgba(
    ColorF color
)
Visual Basic
Public Sub New ( _
    color As ColorF _
)
Visual C++
public:
ColorRgba(
    ColorF color
)

Parameters

color
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF

See Also

ColorRgba Structure
ColorRgba Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Constructor (ColorF, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Constructor (ColorF, Single)
ColorRgba Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgba(
    ColorF color,
    float alpha
)
Visual Basic
Public Sub New ( _
    color As ColorF, _
    alpha As Single _
)
Visual C++
public:
ColorRgba(
    ColorF color,
    float alpha
)

Parameters

color
Type: Microsoft.WindowsAPICodePack.DirectX.Direct2D1..::..ColorF
alpha
Type: System..::..Single

See Also

ColorRgba Structure
ColorRgba Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Constructor (Single, Single, Single, Single)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Constructor (Single, Single, Single, Single)
ColorRgba Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgba(
    float red,
    float green,
    float blue,
    float alpha
)
Visual Basic
Public Sub New ( _
    red As Single, _
    green As Single, _
    blue As Single, _
    alpha As Single _
)
Visual C++
public:
ColorRgba(
    float red,
    float green,
    float blue,
    float alpha
)

Parameters

red
Type: System..::..Single
green
Type: System..::..Single
blue
Type: System..::..Single
alpha
Type: System..::..Single

See Also

ColorRgba Structure
ColorRgba Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Methods
ColorRgba Structure See Also Send Feedback

The ColorRgba type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba..::..Equals Method
ColorRgba Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba..::..GetHashCode Method
ColorRgba Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Operators
ColorRgba Structure See Also Send Feedback

The ColorRgba type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba..::..Equality Operator
ColorRgba Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ColorRgba color1,
    ColorRgba color2
)
Visual Basic
Public Shared Operator = ( _
    color1 As ColorRgba, _
    color2 As ColorRgba _
) As Boolean
Visual C++
public:
static bool operator ==(
    ColorRgba color1,
    ColorRgba color2
)

Parameters

color1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgba
color2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgba

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba..::..Inequality Operator
ColorRgba Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ColorRgba color1,
    ColorRgba color2
)
Visual Basic
Public Shared Operator <> ( _
    color1 As ColorRgba, _
    color2 As ColorRgba _
) As Boolean
Visual C++
public:
static bool operator !=(
    ColorRgba color1,
    ColorRgba color2
)

Parameters

color1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgba
color2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ColorRgba

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ColorRgba Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba Properties
ColorRgba Structure See Also Send Feedback

The ColorRgba type exposes the following members.

Properties

 | Name | Description
Public property | Alpha | A value representing the alpha channel component. The range of this value is between 0 and 1.
Public property | Blue | A value representing the color of the blue component. The range of this value is between 0 and 1.
Public property | Green | A value representing the color of the green component. The range of this value is between 0 and 1.
Public property | Red | A value representing the color of the red component. The range of this value is between 0 and 1.

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Alpha Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba..::..Alpha Property
ColorRgba Structure See Also Send Feedback
A value representing the alpha channel component. The range of this value is between 0 and 1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Alpha { get; set; }
Visual Basic
Public Property Alpha As Single
    Get
    Set
Visual C++
public:
property float Alpha {
    float get ();
    void set (float value);
}

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Blue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba..::..Blue Property
ColorRgba Structure See Also Send Feedback
A value representing the color of the blue component. The range of this value is between 0 and 1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Blue { get; set; }
Visual Basic
Public Property Blue As Single
    Get
    Set
Visual C++
public:
property float Blue {
    float get ();
    void set (float value);
}

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Green Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba..::..Green Property
ColorRgba Structure See Also Send Feedback
A value representing the color of the green component. The range of this value is between 0 and 1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Green { get; set; }
Visual Basic
Public Property Green As Single
    Get
    Set
Visual C++
public:
property float Green {
    float get ();
    void set (float value);
}

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Red Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ColorRgba..::..Red Property
ColorRgba Structure See Also Send Feedback
A value representing the color of the red component. The range of this value is between 0 and 1.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float Red { get; set; }
Visual Basic
Public Property Red As Single
    Get
    Set
Visual C++
public:
property float Red {
    float get ();
    void set (float value);
}

See Also

ColorRgba Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Device Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device Class
Members See Also Send Feedback
Implements a derived class for Graphics objects that produce image data.

(Also see DirectX SDK: IDXGIDevice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Device : GraphicsObject
Visual Basic
Public Class Device _
    Inherits GraphicsObject
Visual C++
public ref class Device : public GraphicsObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Device
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Device1

See Also

Device Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Device Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device Members
Device Class Methods Properties See Also Send Feedback

The Device type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | QueryResourceResidency |

Properties

 | Name | Description
Public property | Adapter | Returns the adapter for the specified device. (Also see DirectX SDK: IDXGIDevice::GetAdapter)
Public property | GpuThreadPriority | Sets or Gets the GPU thread priority. (Also see DirectX SDK: IDXGIDevice::GetGPUThreadPriority and IDXGIDevice::SetGPUThreadPriority)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Device Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Device Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device Methods
Device Class See Also Send Feedback

The Device type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | QueryResourceResidency |

See Also

Device Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


QueryResourceResidency Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device..::..QueryResourceResidency Method
Device Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Residency[] QueryResourceResidency(
    IEnumerable<Resource> resources
)
Visual Basic
Public Function QueryResourceResidency ( _
    resources As IEnumerable(Of Resource) _
) As Residency()
Visual C++
public:
array<Residency>^ QueryResourceResidency(
    IEnumerable<Resource^>^ resources
)

Parameters

resources
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' Resource >)>)>

See Also

Device Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Device Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device Properties
Device Class See Also Send Feedback

The Device type exposes the following members.

Properties

 | Name | Description
Public property | Adapter | Returns the adapter for the specified device. (Also see DirectX SDK: IDXGIDevice::GetAdapter)
Public property | GpuThreadPriority | Sets or Gets the GPU thread priority. (Also see DirectX SDK: IDXGIDevice::GetGPUThreadPriority and IDXGIDevice::SetGPUThreadPriority)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Device Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapter Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device..::..Adapter Property
Device Class See Also Send Feedback
Returns the adapter for the specified device.

(Also see DirectX SDK: IDXGIDevice::GetAdapter)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Adapter Adapter { get; }
Visual Basic
Public ReadOnly Property Adapter As Adapter
    Get
Visual C++
public:
property Adapter^ Adapter {
    Adapter^ get ();
}

See Also

Device Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GpuThreadPriority Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device..::..GpuThreadPriority Property
Device Class See Also Send Feedback
Sets or Gets the GPU thread priority.

(Also see DirectX SDK: IDXGIDevice::GetGPUThreadPriority and IDXGIDevice::SetGPUThreadPriority)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int GpuThreadPriority { get; set; }
Visual Basic
Public Property GpuThreadPriority As Integer
    Get
    Set
Visual C++
public:
property int GpuThreadPriority {
    int get ();
    void set (int value);
}

See Also

Device Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Device1 Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device1 Class
Members See Also Send Feedback
Implements a derived class for Graphics 1.1 objects that produce image data.

(Also see DirectX SDK: IDXGIDevice1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Device1 : Device
Visual Basic
Public Class Device1 _
    Inherits Device
Visual C++
public ref class Device1 : public Device

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Device
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Device1

See Also

Device1 Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Device1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device1 Members
Device1 Class Methods Properties See Also Send Feedback

The Device1 type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | QueryResourceResidency | (Inherited from Device.)

Properties

 | Name | Description
Public property | Adapter | Returns the adapter for the specified device. (Also see DirectX SDK: IDXGIDevice::GetAdapter) (Inherited from Device.)
Public property | GpuThreadPriority | Sets or Gets the GPU thread priority. (Also see DirectX SDK: IDXGIDevice::GetGPUThreadPriority and IDXGIDevice::SetGPUThreadPriority) (Inherited from Device.)
Public property | MaximumFrameLatency | Gets or sets the number of frames that the system is allowed to queue for rendering. (Also see DirectX SDK: IDXGIDevice1::GetMaximumFrameLatency, IDXGIDevice1::SetMaximumFrameLatency)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Device1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Device1 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device1 Methods
Device1 Class See Also Send Feedback

The Device1 type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | QueryResourceResidency | (Inherited from Device.)

See Also

Device1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Device1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device1 Properties
Device1 Class See Also Send Feedback

The Device1 type exposes the following members.

Properties

 | Name | Description
Public property | Adapter | Returns the adapter for the specified device. (Also see DirectX SDK: IDXGIDevice::GetAdapter) (Inherited from Device.)
Public property | GpuThreadPriority | Sets or Gets the GPU thread priority. (Also see DirectX SDK: IDXGIDevice::GetGPUThreadPriority and IDXGIDevice::SetGPUThreadPriority) (Inherited from Device.)
Public property | MaximumFrameLatency | Gets or sets the number of frames that the system is allowed to queue for rendering. (Also see DirectX SDK: IDXGIDevice1::GetMaximumFrameLatency, IDXGIDevice1::SetMaximumFrameLatency)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Device1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MaximumFrameLatency Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Device1..::..MaximumFrameLatency Property
Device1 Class See Also Send Feedback
Gets or sets the number of frames that the system is allowed to queue for rendering.

(Also see DirectX SDK: IDXGIDevice1::GetMaximumFrameLatency, IDXGIDevice1::SetMaximumFrameLatency)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint MaximumFrameLatency { get; set; }
Visual Basic
Public Property MaximumFrameLatency As UInteger
    Get
    Set
Visual C++
public:
property unsigned int MaximumFrameLatency {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Device1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DeviceSubObject Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceSubObject Class
Members See Also Send Feedback
Inherited from objects that are tied to the device so that they can retrieve it.

(Also see DirectX SDK: IDXGIDeviceSubObject)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class DeviceSubObject : GraphicsObject
Visual Basic
Public Class DeviceSubObject _
    Inherits GraphicsObject
Visual C++
public ref class DeviceSubObject : public GraphicsObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..DeviceSubObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..KeyedMutex
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Resource
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChain

See Also

DeviceSubObject Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DeviceSubObject Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceSubObject Members
DeviceSubObject Class Methods Properties See Also Send Feedback

The DeviceSubObject type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DeviceSubObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DeviceSubObject Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceSubObject Methods
DeviceSubObject Class See Also Send Feedback

The DeviceSubObject type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)

See Also

DeviceSubObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DeviceSubObject Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceSubObject Properties
DeviceSubObject Class See Also Send Feedback

The DeviceSubObject type exposes the following members.

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

DeviceSubObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AsDirect3D10Device Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceSubObject..::..AsDirect3D10Device Property
DeviceSubObject Class See Also Send Feedback
Retrieves the device as Direct3D 10 device.

(Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DDevice AsDirect3D10Device { get; }
Visual Basic
Public ReadOnly Property AsDirect3D10Device As D3DDevice
    Get
Visual C++
public:
property D3DDevice^ AsDirect3D10Device {
    D3DDevice^ get ();
}

Return Value

A Direct3D 10 Device.

See Also

DeviceSubObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AsDirect3D10Device1 Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceSubObject..::..AsDirect3D10Device1 Property
DeviceSubObject Class See Also Send Feedback
Retrieves the device as Direct3D 10.1 device.

(Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DDevice1 AsDirect3D10Device1 { get; }
Visual Basic
Public ReadOnly Property AsDirect3D10Device1 As D3DDevice1
    Get
Visual C++
public:
property D3DDevice1^ AsDirect3D10Device1 {
    D3DDevice1^ get ();
}

Return Value

A Direct3D 10.1 Device.

See Also

DeviceSubObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AsDirect3D11Device Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceSubObject..::..AsDirect3D11Device Property
DeviceSubObject Class See Also Send Feedback
Retrieves the device as Direct3D 11 device.

(Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DDevice AsDirect3D11Device { get; }
Visual Basic
Public ReadOnly Property AsDirect3D11Device As D3DDevice
    Get
Visual C++
public:
property D3DDevice^ AsDirect3D11Device {
    D3DDevice^ get ();
}

Return Value

A Direct3D 11 Device.

See Also

DeviceSubObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AsGraphicsDevice Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DeviceSubObject..::..AsGraphicsDevice Property
DeviceSubObject Class See Also Send Feedback
Retrieves the device as Graphics device.

(Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Device AsGraphicsDevice { get; }
Visual Basic
Public ReadOnly Property AsGraphicsDevice As Device
    Get
Visual C++
public:
property Device^ AsGraphicsDevice {
    Device^ get ();
}

See Also

DeviceSubObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Factory Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory Class
Members See Also Send Feedback
Implements methods for generating Graphics objects (which handle fullscreen transitions).

(Also see DirectX SDK: IDXGIFactory)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Factory : GraphicsObject
Visual Basic
Public Class Factory _
    Inherits GraphicsObject
Visual C++
public ref class Factory : public GraphicsObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Factory
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Factory1

See Also

Factory Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Factory Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory Members
Factory Class Methods Properties See Also Send Feedback

The Factory type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a Graphics 1.0 factory that generates objects used to enumerate and specify video graphics settings. (Also see DirectX SDK: CreateDXGIFactory() Function.)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | MakeWindowAssociation | Allows Graphics to monitor an application's message queue for the alt-enter key sequence (which causes the application to switch from windowed to fullscreen or vice versa). (Also see DirectX SDK: IDXGIFactory::MakeWindowAssociation)

Properties

 | Name | Description
Public property | Adapters | Enumerates the adapters (video cards). (Also see DirectX SDK: IDXGIFactory::EnumAdapters)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | WindowAssociation | Get the window through which the user controls the transition to and from fullscreen. (Also see DirectX SDK: IDXGIFactory::GetWindowAssociation)

See Also

Factory Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Factory Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory Methods
Factory Class See Also Send Feedback

The Factory type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a Graphics 1.0 factory that generates objects used to enumerate and specify video graphics settings. (Also see DirectX SDK: CreateDXGIFactory() Function.)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | MakeWindowAssociation | Allows Graphics to monitor an application's message queue for the alt-enter key sequence (which causes the application to switch from windowed to fullscreen or vice versa). (Also see DirectX SDK: IDXGIFactory::MakeWindowAssociation)

See Also

Factory Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Create Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory..::..Create Method
Factory Class See Also Send Feedback
Creates a Graphics 1.0 factory that generates objects used to enumerate and specify video graphics settings.

(Also see DirectX SDK: CreateDXGIFactory() Function.)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Factory Create()
Visual Basic
Public Shared Function Create As Factory
Visual C++
public:
static Factory^ Create()

Return Value

Factory Object.

See Also

Factory Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


CreateSwapChain Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory..::..CreateSwapChain Method
Factory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain)

See Also

Factory Class
Factory Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


CreateSwapChain Method (D3DDevice, SwapChainDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory..::..CreateSwapChain Method (D3DDevice, SwapChainDescription)
Factory Class See Also Send Feedback
Creates a swap chain.

(Also see DirectX SDK: IDXGIFactory::CreateSwapChain)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwapChain CreateSwapChain(
    D3DDevice device,
    SwapChainDescription description
)
Visual Basic
Public Function CreateSwapChain ( _
    device As D3DDevice, _
    description As SwapChainDescription _
) As SwapChain
Visual C++
public:
SwapChain^ CreateSwapChain(
    D3DDevice^ device,
    SwapChainDescription description
)

Parameters

device
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDevice
The device that will write 2D images to the swap chain.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChainDescription
The swap-chain description (see SwapChainDescription). This parameter cannot be NULL.

See Also

Factory Class
CreateSwapChain Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChainDescription
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChain


CreateSwapChain Method (D3DDevice, SwapChainDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory..::..CreateSwapChain Method (D3DDevice, SwapChainDescription)
Factory Class See Also Send Feedback
Creates a swap chain.

(Also see DirectX SDK: IDXGIFactory::CreateSwapChain)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwapChain CreateSwapChain(
    D3DDevice device,
    SwapChainDescription description
)
Visual Basic
Public Function CreateSwapChain ( _
    device As D3DDevice, _
    description As SwapChainDescription _
) As SwapChain
Visual C++
public:
SwapChain^ CreateSwapChain(
    D3DDevice^ device,
    SwapChainDescription description
)

Parameters

device
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DDevice
The device that will write 2D images to the swap chain.
description
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChainDescription
The swap-chain description (see SwapChainDescription). This parameter cannot be NULL.

See Also

Factory Class
CreateSwapChain Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChainDescription
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChain


MakeWindowAssociation Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory..::..MakeWindowAssociation Method
Factory Class See Also Send Feedback
Allows Graphics to monitor an application's message queue for the alt-enter key sequence (which causes the application to switch from windowed to fullscreen or vice versa).

(Also see DirectX SDK: IDXGIFactory::MakeWindowAssociation)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void MakeWindowAssociation(
    IntPtr windowHandle,
    MakeWindowAssociationOptions options
)
Visual Basic
Public Sub MakeWindowAssociation ( _
    windowHandle As IntPtr, _
    options As MakeWindowAssociationOptions _
)
Visual C++
public:
void MakeWindowAssociation(
    IntPtr windowHandle,
    MakeWindowAssociationOptions options
)

Parameters

windowHandle
Type: System..::..IntPtr
The handle of the window that is to be monitored. This parameter can be NULL; but only if the flags are also 0.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..MakeWindowAssociationOptions
One or more of the MakeWindowAssociation flags.

See Also

Factory Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Factory Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory Properties
Factory Class See Also Send Feedback

The Factory type exposes the following members.

Properties

 | Name | Description
Public property | Adapters | Enumerates the adapters (video cards). (Also see DirectX SDK: IDXGIFactory::EnumAdapters)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | WindowAssociation | Get the window through which the user controls the transition to and from fullscreen. (Also see DirectX SDK: IDXGIFactory::GetWindowAssociation)

See Also

Factory Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapters Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory..::..Adapters Property
Factory Class See Also Send Feedback
Enumerates the adapters (video cards).

(Also see DirectX SDK: IDXGIFactory::EnumAdapters)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<Adapter> Adapters { get; }
Visual Basic
Public ReadOnly Property Adapters As ReadOnlyCollection(Of Adapter)
    Get
Visual C++
public:
property ReadOnlyCollection<Adapter^>^ Adapters {
    ReadOnlyCollection<Adapter^>^ get ();
}

Remarks

Note that if the set of installed adapters changes, the adapter collection returned by this factory instance is stale. To get the current collection of adapters, a new factory instance must be created.

See Also

Factory Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


WindowAssociation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory..::..WindowAssociation Property
Factory Class See Also Send Feedback
Get the window through which the user controls the transition to and from fullscreen.

(Also see DirectX SDK: IDXGIFactory::GetWindowAssociation)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr WindowAssociation { get; }
Visual Basic
Public ReadOnly Property WindowAssociation As IntPtr
    Get
Visual C++
public:
property IntPtr WindowAssociation {
    IntPtr get ();
}

See Also

Factory Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Factory1 Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory1 Class
Members See Also Send Feedback
The Factory1 interface implements methods for generating Graphics objects.

(Also see DirectX SDK: IDXGIFactory1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Factory1 : Factory
Visual Basic
Public Class Factory1 _
    Inherits Factory
Visual C++
public ref class Factory1 : public Factory

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Factory
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Factory1

See Also

Factory1 Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Factory1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory1 Members
Factory1 Class Methods Properties See Also Send Feedback

The Factory1 type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a Graphics 1.1 factory that generates objects used to enumerate and specify video graphics settings. (Also see DirectX SDK: CreateDXGIFactory1() Function.)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain) (Inherited from Factory.)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain) (Inherited from Factory.)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | MakeWindowAssociation | Allows Graphics to monitor an application's message queue for the alt-enter key sequence (which causes the application to switch from windowed to fullscreen or vice versa). (Also see DirectX SDK: IDXGIFactory::MakeWindowAssociation) (Inherited from Factory.)

Properties

 | Name | Description
Public property | Adapters | Enumerates both local and remote adapters (video cards). (Also see DirectX SDK: IDXGIFactory1::EnumAdapters1)
Public property | IsCurrent | Informs application the possible need to re-enumerate adapters -- new adapter(s) have become available, current adapter(s) become unavailable. Called by Direct3D 10.1 Command Remoting applications to handle Remote Desktop Services session transitions. (Also see DirectX SDK: IDXGIFactory1::IsCurrent)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | WindowAssociation | Get the window through which the user controls the transition to and from fullscreen. (Also see DirectX SDK: IDXGIFactory::GetWindowAssociation) (Inherited from Factory.)

See Also

Factory1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Factory1 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory1 Methods
Factory1 Class See Also Send Feedback

The Factory1 type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a Graphics 1.1 factory that generates objects used to enumerate and specify video graphics settings. (Also see DirectX SDK: CreateDXGIFactory1() Function.)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain) (Inherited from Factory.)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain) (Inherited from Factory.)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | MakeWindowAssociation | Allows Graphics to monitor an application's message queue for the alt-enter key sequence (which causes the application to switch from windowed to fullscreen or vice versa). (Also see DirectX SDK: IDXGIFactory::MakeWindowAssociation) (Inherited from Factory.)

See Also

Factory1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Create Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory1..::..Create Method
Factory1 Class See Also Send Feedback
Creates a Graphics 1.1 factory that generates objects used to enumerate and specify video graphics settings.

(Also see DirectX SDK: CreateDXGIFactory1() Function.)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Factory1 Create()
Visual Basic
Public Shared Function Create As Factory1
Visual C++
public:
static Factory1^ Create()

Return Value

Factory1 Object.

See Also

Factory1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


CreateSwapChain Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory1..::..CreateSwapChain Method
Factory1 Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain) (Inherited from Factory.)
Public method | CreateSwapChain(D3DDevice, SwapChainDescription) | Creates a swap chain. (Also see DirectX SDK: IDXGIFactory::CreateSwapChain) (Inherited from Factory.)

See Also

Factory1 Class
Factory1 Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Factory1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory1 Properties
Factory1 Class See Also Send Feedback

The Factory1 type exposes the following members.

Properties

 | Name | Description
Public property | Adapters | Enumerates both local and remote adapters (video cards). (Also see DirectX SDK: IDXGIFactory1::EnumAdapters1)
Public property | IsCurrent | Informs application the possible need to re-enumerate adapters -- new adapter(s) have become available, current adapter(s) become unavailable. Called by Direct3D 10.1 Command Remoting applications to handle Remote Desktop Services session transitions. (Also see DirectX SDK: IDXGIFactory1::IsCurrent)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | WindowAssociation | Get the window through which the user controls the transition to and from fullscreen. (Also see DirectX SDK: IDXGIFactory::GetWindowAssociation) (Inherited from Factory.)

See Also

Factory1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Adapters Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory1..::..Adapters Property
Factory1 Class See Also Send Feedback
Enumerates both local and remote adapters (video cards).

(Also see DirectX SDK: IDXGIFactory1::EnumAdapters1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ReadOnlyCollection<Adapter1> Adapters { get; }
Visual Basic
Public ReadOnly Property Adapters As ReadOnlyCollection(Of Adapter1)
    Get
Visual C++
public:
property ReadOnlyCollection<Adapter1^>^ Adapters {
    ReadOnlyCollection<Adapter1^>^ get ();
}

Remarks

Note that if the IsCurrent property returns false, the adapter collection returned by this factory instance is stale. To get the current collection of adapters, a new factory instance must be created.

See Also

Factory1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


IsCurrent Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Factory1..::..IsCurrent Property
Factory1 Class See Also Send Feedback
Informs application the possible need to re-enumerate adapters -- new adapter(s) have become available, current adapter(s) become unavailable. Called by Direct3D 10.1 Command Remoting applications to handle Remote Desktop Services session transitions.

(Also see DirectX SDK: IDXGIFactory1::IsCurrent)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsCurrent { get; }
Visual Basic
Public ReadOnly Property IsCurrent As Boolean
    Get
Visual C++
public:
property bool IsCurrent {
    bool get ();
}

See Also

Factory1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Format Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Format Enumeration
See Also Send Feedback
Resource data formats which includes fully-typed and typeless formats. There is a collection of format modifiers at the bottom of the page, that more fully describes each format type.

(Also see DirectX SDK: DXGI_FORMAT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Format
Visual Basic
Public Enumeration Format
Visual C++
public enum class Format

Members

Member name | Description
BlockCompression7UNormSrgb |
BlockCompression7UNorm |
BlockCompression7Typeless |
BlockCompression6HSignedFloat16 |
BlockCompression6HUnsignedFloat16 |
BlockCompression6HTypeless |
B8G8R8X8UNormSrgb |
B8G8R8X8Typeless |
B8G8R8A8UNormSrgb |
B8G8R8A8Typeless |
R10G10B10XRBiasA2UNorm |
B8G8R8X8UNorm |
B8G8R8A8UNorm |
B5G5R5A1UNorm |
B5G6R5UNorm |
BC5SNorm |
BC5UNorm |
BC5Typeless |
BC4SNorm |
BC4UNorm |
BC4Typeless |
BC3UNormSrgb |
BC3UNorm |
BC3Typeless |
BC2UNormSrgb |
BC2UNorm |
BC2Typeless |
BC1UNormSrgb |
BC1UNorm |
BC1Typeless |
G8R8G8B8UNorm |
R8G8B8G8UNorm |
R9G9B9E5SharedExp |
R1UNorm |
A8UNorm |
R8SInt |
R8SNorm |
R8UInt |
R8UNorm |
R8Typeless |
R16SInt |
R16SNorm |
R16UInt |
R16UNorm |
D16UNorm |
R16Float |
R16Typeless |
R8G8SInt |
R8G8SNorm |
R8G8UInt |
R8G8UNorm |
R8G8Typeless |
X24TypelessG8UInt |
R24UNormX8Typeless |
D24UNormS8UInt |
R24G8Typeless |
R32SInt |
R32UInt |
R32Float |
D32Float |
R32Typeless |
R16G16SInt |
R16G16SNorm |
R16G16UInt |
R16G16UNorm |
R16G16Float |
R16G16Typeless |
R8G8B8A8SInt |
R8G8B8A8SNorm |
R8G8B8A8UInt |
R8G8B8A8UNormSrgb |
R8G8B8A8UNorm |
R8G8B8A8Typeless |
R11G11B10Float |
R10G10B10A2UInt |
R10G10B10A2UNorm |
R10G10B10A2Typeless |
X32TypelessG8X24UInt |
R32FloatX8X24Typeless |
D32FloatS8X24UInt |
R32G8X24Typeless |
R32G32SInt |
R32G32UInt |
R32G32Float |
R32G32Typeless |
R16G16B16A16SInt |
R16G16B16A16SNorm |
R16G16B16A16UInt |
R16G16B16A16UNorm |
R16G16B16A16Float |
R16G16B16A16Typeless |
R32G32B32SInt |
R32G32B32UInt |
R32G32B32Float |
R32G32B32Typeless |
R32G32B32A32SInt |
R32G32B32A32UInt |
R32G32B32A32Float |
R32G32B32A32Typeless |
Unknown |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FrameStatistics Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics Structure
Members See Also Send Feedback
Describes timing and presentation statistics for a frame.

(Also see DirectX SDK: DXGI_FRAME_STATISTICS)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct FrameStatistics
Visual Basic
Public Structure FrameStatistics
Visual C++
public value class FrameStatistics

See Also

FrameStatistics Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FrameStatistics Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics Members
FrameStatistics Structure Methods Operators Properties See Also Send Feedback

The FrameStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | PresentCount | A value representing the running total count of times that an image has been presented to the monitor since the computer booted. Note that the number of times that an image has been presented to the monitor is not necessarily the same as the number of times that SwapChain.Present has been called. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.PresentCount)
Public property | PresentRefreshCount | A value representing the running total count of v-blanks that have happened since the computer booted. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.PresentRefreshCount)
Public property | SyncGpuTime | Reserved. Always returns 0. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.SyncGPUTime)
Public property | SyncQueryPerformanceCounterTime | A value representing the high-resolution performance counter timer. This value is that same as the value returned by the QueryPerformanceCounter function. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.SyncQPCTime)
Public property | SyncRefreshCount | A value representing the running total count of v-blanks that have happened since the computer booted. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.SyncRefreshCount)

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FrameStatistics Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics Methods
FrameStatistics Structure See Also Send Feedback

The FrameStatistics type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics..::..Equals Method
FrameStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics..::..GetHashCode Method
FrameStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FrameStatistics Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics Operators
FrameStatistics Structure See Also Send Feedback

The FrameStatistics type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics..::..Equality Operator
FrameStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    FrameStatistics frameStatistics1,
    FrameStatistics frameStatistics2
)
Visual Basic
Public Shared Operator = ( _
    frameStatistics1 As FrameStatistics, _
    frameStatistics2 As FrameStatistics _
) As Boolean
Visual C++
public:
static bool operator ==(
    FrameStatistics frameStatistics1,
    FrameStatistics frameStatistics2
)

Parameters

frameStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..FrameStatistics
frameStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..FrameStatistics

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics..::..Inequality Operator
FrameStatistics Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    FrameStatistics frameStatistics1,
    FrameStatistics frameStatistics2
)
Visual Basic
Public Shared Operator <> ( _
    frameStatistics1 As FrameStatistics, _
    frameStatistics2 As FrameStatistics _
) As Boolean
Visual C++
public:
static bool operator !=(
    FrameStatistics frameStatistics1,
    FrameStatistics frameStatistics2
)

Parameters

frameStatistics1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..FrameStatistics
frameStatistics2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..FrameStatistics

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FrameStatistics Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics Properties
FrameStatistics Structure See Also Send Feedback

The FrameStatistics type exposes the following members.

Properties

 | Name | Description
Public property | PresentCount | A value representing the running total count of times that an image has been presented to the monitor since the computer booted. Note that the number of times that an image has been presented to the monitor is not necessarily the same as the number of times that SwapChain.Present has been called. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.PresentCount)
Public property | PresentRefreshCount | A value representing the running total count of v-blanks that have happened since the computer booted. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.PresentRefreshCount)
Public property | SyncGpuTime | Reserved. Always returns 0. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.SyncGPUTime)
Public property | SyncQueryPerformanceCounterTime | A value representing the high-resolution performance counter timer. This value is that same as the value returned by the QueryPerformanceCounter function. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.SyncQPCTime)
Public property | SyncRefreshCount | A value representing the running total count of v-blanks that have happened since the computer booted. (Also see DirectX SDK: DXGI_FRAME_STATISTICS.SyncRefreshCount)

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


PresentCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics..::..PresentCount Property
FrameStatistics Structure See Also Send Feedback
A value representing the running total count of times that an image has been presented to the monitor since the computer booted. Note that the number of times that an image has been presented to the monitor is not necessarily the same as the number of times that SwapChain.Present has been called.

(Also see DirectX SDK: DXGI_FRAME_STATISTICS.PresentCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint PresentCount { get; set; }
Visual Basic
Public Property PresentCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int PresentCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


PresentRefreshCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics..::..PresentRefreshCount Property
FrameStatistics Structure See Also Send Feedback
A value representing the running total count of v-blanks that have happened since the computer booted.

(Also see DirectX SDK: DXGI_FRAME_STATISTICS.PresentRefreshCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint PresentRefreshCount { get; set; }
Visual Basic
Public Property PresentRefreshCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int PresentRefreshCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SyncGpuTime Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics..::..SyncGpuTime Property
FrameStatistics Structure See Also Send Feedback
Reserved. Always returns 0.

(Also see DirectX SDK: DXGI_FRAME_STATISTICS.SyncGPUTime)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public long SyncGpuTime { get; set; }
Visual Basic
Public Property SyncGpuTime As Long
    Get
    Set
Visual C++
public:
property long long SyncGpuTime {
    long long get ();
    void set (long long value);
}

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SyncQueryPerformanceCounterTime Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics..::..SyncQueryPerformanceCounterTime Property
FrameStatistics Structure See Also Send Feedback
A value representing the high-resolution performance counter timer. This value is that same as the value returned by the QueryPerformanceCounter function.

(Also see DirectX SDK: DXGI_FRAME_STATISTICS.SyncQPCTime)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public long SyncQueryPerformanceCounterTime { get; set; }
Visual Basic
Public Property SyncQueryPerformanceCounterTime As Long
    Get
    Set
Visual C++
public:
property long long SyncQueryPerformanceCounterTime {
    long long get ();
    void set (long long value);
}

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SyncRefreshCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FrameStatistics..::..SyncRefreshCount Property
FrameStatistics Structure See Also Send Feedback
A value representing the running total count of v-blanks that have happened since the computer booted.

(Also see DirectX SDK: DXGI_FRAME_STATISTICS.SyncRefreshCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint SyncRefreshCount { get; set; }
Visual Basic
Public Property SyncRefreshCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int SyncRefreshCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

FrameStatistics Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaControl Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControl Structure
Members See Also Send Feedback
Controls the settings of a gamma curve.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct GammaControl
Visual Basic
Public Structure GammaControl
Visual C++
public value class GammaControl

See Also

GammaControl Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaControl Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControl Members
GammaControl Structure Properties See Also Send Feedback

The GammaControl type exposes the following members.

Properties

 | Name | Description
Public property | GammaCurve | A collection of ColorRGB structures that control the points of a gamma curve. (Also see DirectX SDK: DXGI_GAMMA_CONTROL.GammaCurve)
Public property | Offset | A ColorRGB structure with offset values that are applied to the rgb values before being sent to the gamma look up table. (Also see DirectX SDK: DXGI_GAMMA_CONTROL.offset)
Public property | Scale | A ColorRGB structure with scalar values that are applied to rgb values before being sent to the gamma look up table. (Also see DirectX SDK: DXGI_GAMMA_CONTROL.Scale)

See Also

GammaControl Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaControl Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControl Properties
GammaControl Structure See Also Send Feedback

The GammaControl type exposes the following members.

Properties

 | Name | Description
Public property | GammaCurve | A collection of ColorRGB structures that control the points of a gamma curve. (Also see DirectX SDK: DXGI_GAMMA_CONTROL.GammaCurve)
Public property | Offset | A ColorRGB structure with offset values that are applied to the rgb values before being sent to the gamma look up table. (Also see DirectX SDK: DXGI_GAMMA_CONTROL.offset)
Public property | Scale | A ColorRGB structure with scalar values that are applied to rgb values before being sent to the gamma look up table. (Also see DirectX SDK: DXGI_GAMMA_CONTROL.Scale)

See Also

GammaControl Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaCurve Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControl..::..GammaCurve Property
GammaControl Structure See Also Send Feedback
A collection of ColorRGB structures that control the points of a gamma curve.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL.GammaCurve)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<ColorRgb> GammaCurve { get; }
Visual Basic
Public ReadOnly Property GammaCurve As IEnumerable(Of ColorRgb)
    Get
Visual C++
public:
property IEnumerable<ColorRgb>^ GammaCurve {
    IEnumerable<ColorRgb>^ get ();
}

See Also

GammaControl Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Offset Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControl..::..Offset Property
GammaControl Structure See Also Send Feedback
A ColorRGB structure with offset values that are applied to the rgb values before being sent to the gamma look up table.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL.offset)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgb Offset { get; set; }
Visual Basic
Public Property Offset As ColorRgb
    Get
    Set
Visual C++
public:
property ColorRgb Offset {
    ColorRgb get ();
    void set (ColorRgb value);
}

See Also

GammaControl Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Scale Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControl..::..Scale Property
GammaControl Structure See Also Send Feedback
A ColorRGB structure with scalar values that are applied to rgb values before being sent to the gamma look up table.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL.Scale)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ColorRgb Scale { get; set; }
Visual Basic
Public Property Scale As ColorRgb
    Get
    Set
Visual C++
public:
property ColorRgb Scale {
    ColorRgb get ();
    void set (ColorRgb value);
}

See Also

GammaControl Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaControlCapabilities Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControlCapabilities Structure
Members See Also Send Feedback
Controls the gamma capabilities of an adapter.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct GammaControlCapabilities
Visual Basic
Public Structure GammaControlCapabilities
Visual C++
public value class GammaControlCapabilities

See Also

GammaControlCapabilities Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaControlCapabilities Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControlCapabilities Members
GammaControlCapabilities Structure Properties See Also Send Feedback

The GammaControlCapabilities type exposes the following members.

Properties

 | Name | Description
Public property | ControlPointPositions | A collection of values describing control points; the maximum length of control points is 1025. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.ControlPointPositions)
Public property | GammaControlPointCount | A value describing the number of control points in the array. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.NumGammaControlPoints)
Public property | MaxConvertedValue | A value describing the maximum range of the control-point positions. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.MaxConvertedValue)
Public property | MinConvertedValue | A value describing the minimum range of the control-point positions. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.MinConvertedValue)
Public property | ScaleAndOffsetSupported | True if scaling and offset operations are supported during gamma correction; otherwise, false. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.ScaleAndOffsetSupported)

See Also

GammaControlCapabilities Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaControlCapabilities Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControlCapabilities Properties
GammaControlCapabilities Structure See Also Send Feedback

The GammaControlCapabilities type exposes the following members.

Properties

 | Name | Description
Public property | ControlPointPositions | A collection of values describing control points; the maximum length of control points is 1025. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.ControlPointPositions)
Public property | GammaControlPointCount | A value describing the number of control points in the array. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.NumGammaControlPoints)
Public property | MaxConvertedValue | A value describing the maximum range of the control-point positions. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.MaxConvertedValue)
Public property | MinConvertedValue | A value describing the minimum range of the control-point positions. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.MinConvertedValue)
Public property | ScaleAndOffsetSupported | True if scaling and offset operations are supported during gamma correction; otherwise, false. (Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.ScaleAndOffsetSupported)

See Also

GammaControlCapabilities Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ControlPointPositions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControlCapabilities..::..ControlPointPositions Property
GammaControlCapabilities Structure See Also Send Feedback
A collection of values describing control points; the maximum length of control points is 1025.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.ControlPointPositions)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IEnumerable<float> ControlPointPositions { get; }
Visual Basic
Public ReadOnly Property ControlPointPositions As IEnumerable(Of Single)
    Get
Visual C++
public:
property IEnumerable<float>^ ControlPointPositions {
    IEnumerable<float>^ get ();
}

See Also

GammaControlCapabilities Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaControlPointCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControlCapabilities..::..GammaControlPointCount Property
GammaControlCapabilities Structure See Also Send Feedback
A value describing the number of control points in the array.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.NumGammaControlPoints)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint GammaControlPointCount { get; set; }
Visual Basic
Public Property GammaControlPointCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int GammaControlPointCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

GammaControlCapabilities Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MaxConvertedValue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControlCapabilities..::..MaxConvertedValue Property
GammaControlCapabilities Structure See Also Send Feedback
A value describing the maximum range of the control-point positions.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.MaxConvertedValue)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MaxConvertedValue { get; set; }
Visual Basic
Public Property MaxConvertedValue As Single
    Get
    Set
Visual C++
public:
property float MaxConvertedValue {
    float get ();
    void set (float value);
}

See Also

GammaControlCapabilities Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MinConvertedValue Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControlCapabilities..::..MinConvertedValue Property
GammaControlCapabilities Structure See Also Send Feedback
A value describing the minimum range of the control-point positions.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.MinConvertedValue)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public float MinConvertedValue { get; set; }
Visual Basic
Public Property MinConvertedValue As Single
    Get
    Set
Visual C++
public:
property float MinConvertedValue {
    float get ();
    void set (float value);
}

See Also

GammaControlCapabilities Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ScaleAndOffsetSupported Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GammaControlCapabilities..::..ScaleAndOffsetSupported Property
GammaControlCapabilities Structure See Also Send Feedback
True if scaling and offset operations are supported during gamma correction; otherwise, false.

(Also see DirectX SDK: DXGI_GAMMA_CONTROL_CAPABILITIES.ScaleAndOffsetSupported)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool ScaleAndOffsetSupported { get; set; }
Visual Basic
Public Property ScaleAndOffsetSupported As Boolean
    Get
    Set
Visual C++
public:
property bool ScaleAndOffsetSupported {
    bool get ();
    void set (bool value);
}

See Also

GammaControlCapabilities Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Class
Members See Also Send Feedback
An exception thrown by Graphics.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GraphicsException : DirectXException
Visual Basic
Public Class GraphicsException _
    Inherits DirectXException
Visual C++
public ref class GraphicsException : public DirectXException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Microsoft.WindowsAPICodePack.DirectX..::..DirectXException
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsException

See Also

GraphicsException Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Members
GraphicsException Class Constructors Properties See Also Send Feedback

The GraphicsException type exposes the following members.

Constructors

 | Name | Description
Public method | GraphicsException()()()() |
Public method | GraphicsException(Int32) |
Public method | GraphicsException(String) |
Protected method | GraphicsException(SerializationInfo, StreamingContext) |
Public method | GraphicsException(String, Exception) |
Public method | GraphicsException(String, Int32) |
Protected method | GraphicsException(SerializationInfo, StreamingContext, Int32) |
Public method | GraphicsException(String, Exception, Int32) |

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API (Inherited from DirectXException.)

See Also

GraphicsException Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Constructor
GraphicsException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GraphicsException()()()() |
Public method | GraphicsException(Int32) |
Public method | GraphicsException(String) |
Protected method | GraphicsException(SerializationInfo, StreamingContext) |
Public method | GraphicsException(String, Exception) |
Public method | GraphicsException(String, Int32) |
Protected method | GraphicsException(SerializationInfo, StreamingContext, Int32) |
Public method | GraphicsException(String, Exception, Int32) |

See Also

GraphicsException Class
GraphicsException Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Constructor
GraphicsException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GraphicsException()
Visual Basic
Public Sub New
Visual C++
public:
GraphicsException()

See Also

GraphicsException Class
GraphicsException Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Constructor (Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Constructor (Int32)
GraphicsException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GraphicsException(
    int hr
)
Visual Basic
Public Sub New ( _
    hr As Integer _
)
Visual C++
public:
GraphicsException(
    int hr
)

Parameters

hr
Type: System..::..Int32

See Also

GraphicsException Class
GraphicsException Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Constructor (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Constructor (String)
GraphicsException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GraphicsException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
GraphicsException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

GraphicsException Class
GraphicsException Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Constructor (SerializationInfo, StreamingContext)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Constructor (SerializationInfo, StreamingContext)
GraphicsException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected GraphicsException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
GraphicsException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext

See Also

GraphicsException Class
GraphicsException Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Constructor (String, Exception)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Constructor (String, Exception)
GraphicsException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GraphicsException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
GraphicsException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception

See Also

GraphicsException Class
GraphicsException Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Constructor (String, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Constructor (String, Int32)
GraphicsException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GraphicsException(
    string message,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    hr As Integer _
)
Visual C++
public:
GraphicsException(
    String^ message,
    int hr
)

Parameters

message
Type: System..::..String
hr
Type: System..::..Int32

See Also

GraphicsException Class
GraphicsException Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Constructor (SerializationInfo, StreamingContext, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Constructor (SerializationInfo, StreamingContext, Int32)
GraphicsException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected GraphicsException(
    SerializationInfo info,
    StreamingContext context,
    int hr
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext, _
    hr As Integer _
)
Visual C++
protected:
GraphicsException(
    SerializationInfo^ info,
    StreamingContext context,
    int hr
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext
hr
Type: System..::..Int32

See Also

GraphicsException Class
GraphicsException Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Constructor (String, Exception, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Constructor (String, Exception, Int32)
GraphicsException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GraphicsException(
    string message,
    Exception innerException,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception, _
    hr As Integer _
)
Visual C++
public:
GraphicsException(
    String^ message,
    Exception^ innerException,
    int hr
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception
hr
Type: System..::..Int32

See Also

GraphicsException Class
GraphicsException Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsException Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsException Properties
GraphicsException Class See Also Send Feedback

The GraphicsException type exposes the following members.

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API (Inherited from DirectXException.)

See Also

GraphicsException Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsObject Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsObject Class
Members See Also Send Feedback
An GraphicsObject is the base for all Graphics classes.

(Also see DirectX SDK: IDXGIObject)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class GraphicsObject : DirectUnknown
Visual Basic
Public Class GraphicsObject _
    Inherits DirectUnknown
Visual C++
public ref class GraphicsObject : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Adapter
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Device
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..DeviceSubObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Factory
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Output

See Also

GraphicsObject Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsObject Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsObject Members
GraphicsObject Class Methods Properties See Also Send Feedback

The GraphicsObject type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent)

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GraphicsObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsObject Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsObject Methods
GraphicsObject Class See Also Send Feedback

The GraphicsObject type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent)

See Also

GraphicsObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetParent(T) Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsObject..::..GetParent<(Of <(<'T>)>)> Method
GraphicsObject Class See Also Send Feedback
Gets the parent of this object.

(Also see DirectX SDK: IDXGIObject::GetParent)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public T GetParent<T>()
where T : GraphicsObject
Visual Basic
Public Function GetParent(Of T As GraphicsObject) As T
Visual C++
public:
generic<typename T>
where T : GraphicsObject
T GetParent()

Type Parameters

T
The type of the parent object requested. This type has to be a GraphicsObject or a subtype.

Return Value

The parent object. Or null if this object does not have a parent.

See Also

GraphicsObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GraphicsObject Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
GraphicsObject Properties
GraphicsObject Class See Also Send Feedback

The GraphicsObject type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

GraphicsObject Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


KeyedMutex Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
KeyedMutex Class
Members See Also Send Feedback
Represents a keyed mutex, which allows exclusive access to a shared resource that is used by multiple devices.

(Also see DirectX SDK: IDXGIKeyedMutex)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class KeyedMutex : DeviceSubObject
Visual Basic
Public Class KeyedMutex _
    Inherits DeviceSubObject
Visual C++
public ref class KeyedMutex : public DeviceSubObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..DeviceSubObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..KeyedMutex

See Also

KeyedMutex Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


KeyedMutex Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
KeyedMutex Members
KeyedMutex Class Methods Properties See Also Send Feedback

The KeyedMutex type exposes the following members.

Methods

 | Name | Description
Public method | AcquireSync | Using a key, acquires exclusive rendering access to a shared resource. (Also see DirectX SDK: IDXGIKeyedMutex::AcquireSync)
 | FromResource |
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | ReleaseSync | Using a key, releases exclusive rendering access to a shared resource (Also see DirectX SDK: IDXGIKeyedMutex::ReleaseSync)

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

KeyedMutex Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


KeyedMutex Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
KeyedMutex Methods
KeyedMutex Class See Also Send Feedback

The KeyedMutex type exposes the following members.

Methods

 | Name | Description
Public method | AcquireSync | Using a key, acquires exclusive rendering access to a shared resource. (Also see DirectX SDK: IDXGIKeyedMutex::AcquireSync)
 | FromResource |
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | ReleaseSync | Using a key, releases exclusive rendering access to a shared resource (Also see DirectX SDK: IDXGIKeyedMutex::ReleaseSync)

See Also

KeyedMutex Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AcquireSync Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
KeyedMutex..::..AcquireSync Method
KeyedMutex Class See Also Send Feedback
Using a key, acquires exclusive rendering access to a shared resource.

(Also see DirectX SDK: IDXGIKeyedMutex::AcquireSync)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void AcquireSync(
    ulong key,
    uint milliseconds
)
Visual Basic
Public Sub AcquireSync ( _
    key As ULong, _
    milliseconds As UInteger _
)
Visual C++
public:
void AcquireSync(
    unsigned long long key,
    unsigned int milliseconds
)

Parameters

key
Type: System..::..UInt64
A value that indicates which device to give access to. This method will succeed when the device that currently owns the surface calls the KeyedMutex.ReleaseSync method using the same value. This value can be any UINT64 value.
milliseconds
Type: System..::..UInt32
The time-out interval, in milliseconds. This method will return if the interval elapses, and the keyed mutex has not been released using the specified Key. If this value is set to zero, the AcquireSync method will test to see if the keyed mutex has been released and returns immediately. If this value is set to INFINITE, the time-out interval will never elapse.

See Also

KeyedMutex Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FromResource Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
KeyedMutex..::..FromResource Method
KeyedMutex Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static KeyedMutex FromResource(
    DirectUnknown unknown
)
Visual Basic
Public Shared Function FromResource ( _
    unknown As DirectUnknown _
) As KeyedMutex
Visual C++
public:
static KeyedMutex^ FromResource(
    DirectUnknown^ unknown
)

Parameters

unknown
Type: Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown

See Also

KeyedMutex Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ReleaseSync Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
KeyedMutex..::..ReleaseSync Method
KeyedMutex Class See Also Send Feedback
Using a key, releases exclusive rendering access to a shared resource

(Also see DirectX SDK: IDXGIKeyedMutex::ReleaseSync)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ReleaseSync(
    ulong key
)
Visual Basic
Public Sub ReleaseSync ( _
    key As ULong _
)
Visual C++
public:
void ReleaseSync(
    unsigned long long key
)

Parameters

key
Type: System..::..UInt64
A value that indicates which device to give access to. This method will succeed when the device that currently owns the surface calls the KeyedMutex.ReleaseSync method using the same value. This value can be any UINT64 value.

See Also

KeyedMutex Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


KeyedMutex Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
KeyedMutex Properties
KeyedMutex Class See Also Send Feedback

The KeyedMutex type exposes the following members.

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

KeyedMutex Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Luid Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid Structure
Members See Also Send Feedback
A Luid is a 64-bit value guaranteed to be unique only on the system on which it was generated. The uniqueness of a locally unique identifier (LUID) is guaranteed only until the system is restarted. An LUID is not for direct manipulation. Applications are to use functions and structures to manipulate Luid values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Luid
Visual Basic
Public Structure Luid
Visual C++
public value class Luid

See Also

Luid Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Luid Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid Members
Luid Structure Methods Operators Properties See Also Send Feedback

The Luid type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | HighPart | High order bits. (Also see DirectX SDK: LUID.HighPart)
Public property | LowPart | Low order bits. (Also see DirectX SDK: LUID.LowPart)

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Luid Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid Methods
Luid Structure See Also Send Feedback

The Luid type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid..::..Equals Method
Luid Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid..::..GetHashCode Method
Luid Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Luid Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid Operators
Luid Structure See Also Send Feedback

The Luid type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid..::..Equality Operator
Luid Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Luid luid1,
    Luid luid2
)
Visual Basic
Public Shared Operator = ( _
    luid1 As Luid, _
    luid2 As Luid _
) As Boolean
Visual C++
public:
static bool operator ==(
    Luid luid1,
    Luid luid2
)

Parameters

luid1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Luid
luid2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Luid

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid..::..Inequality Operator
Luid Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Luid luid1,
    Luid luid2
)
Visual Basic
Public Shared Operator <> ( _
    luid1 As Luid, _
    luid2 As Luid _
) As Boolean
Visual C++
public:
static bool operator !=(
    Luid luid1,
    Luid luid2
)

Parameters

luid1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Luid
luid2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Luid

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Luid Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid Properties
Luid Structure See Also Send Feedback

The Luid type exposes the following members.

Properties

 | Name | Description
Public property | HighPart | High order bits. (Also see DirectX SDK: LUID.HighPart)
Public property | LowPart | Low order bits. (Also see DirectX SDK: LUID.LowPart)

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


HighPart Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid..::..HighPart Property
Luid Structure See Also Send Feedback
High order bits.

(Also see DirectX SDK: LUID.HighPart)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int HighPart { get; set; }
Visual Basic
Public Property HighPart As Integer
    Get
    Set
Visual C++
public:
property int HighPart {
    int get ();
    void set (int value);
}

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


LowPart Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Luid..::..LowPart Property
Luid Structure See Also Send Feedback
Low order bits.

(Also see DirectX SDK: LUID.LowPart)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int LowPart { get; set; }
Visual Basic
Public Property LowPart As Integer
    Get
    Set
Visual C++
public:
property int LowPart {
    int get ();
    void set (int value);
}

See Also

Luid Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MakeWindowAssociationOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MakeWindowAssociationOptions Enumeration
See Also Send Feedback
Flags for making window association with a surface.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum MakeWindowAssociationOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration MakeWindowAssociationOptions
Visual C++
[FlagsAttribute]
public enum class MakeWindowAssociationOptions

Members

Member name | Description
NoPrintScreen |
NoAltEnter |
NoWindowChanges |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MapOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MapOptions Enumeration
See Also Send Feedback
CPU read-write flags. These flags can be combined with a logical OR.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum MapOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration MapOptions
Visual C++
[FlagsAttribute]
public enum class MapOptions

Members

Member name | Description
None |
Discard |
Write |
Read |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MappedRect Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedRect Structure
Members See Also Send Feedback
A mapped rectangle used for accessing a surface.

(Also see DirectX SDK: DXGI_MAPPED_RECT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct MappedRect
Visual Basic
Public Structure MappedRect
Visual C++
public value class MappedRect

See Also

MappedRect Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MappedRect Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedRect Members
MappedRect Structure Properties See Also Send Feedback

The MappedRect type exposes the following members.

Properties

 | Name | Description
Public property | Bits | The image buffer of the surface. (Also see DirectX SDK: DXGI_MAPPED_RECT.pBits)
Public property | Pitch | A value describing the width of the surface. (Also see DirectX SDK: DXGI_MAPPED_RECT.Pitch)

See Also

MappedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MappedRect Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedRect Properties
MappedRect Structure See Also Send Feedback

The MappedRect type exposes the following members.

Properties

 | Name | Description
Public property | Bits | The image buffer of the surface. (Also see DirectX SDK: DXGI_MAPPED_RECT.pBits)
Public property | Pitch | A value describing the width of the surface. (Also see DirectX SDK: DXGI_MAPPED_RECT.Pitch)

See Also

MappedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Bits Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedRect..::..Bits Property
MappedRect Structure See Also Send Feedback
The image buffer of the surface.

(Also see DirectX SDK: DXGI_MAPPED_RECT.pBits)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr Bits { get; set; }
Visual Basic
Public Property Bits As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr Bits {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

MappedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Pitch Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MappedRect..::..Pitch Property
MappedRect Structure See Also Send Feedback
A value describing the width of the surface.

(Also see DirectX SDK: DXGI_MAPPED_RECT.Pitch)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Pitch { get; set; }
Visual Basic
Public Property Pitch As Integer
    Get
    Set
Visual C++
public:
property int Pitch {
    int get ();
    void set (int value);
}

See Also

MappedRect Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription Structure
Members See Also Send Feedback
Describes a display mode.

(Also see DirectX SDK: DXGI_MODE_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct ModeDescription
Visual Basic
Public Structure ModeDescription
Visual C++
public value class ModeDescription

See Also

ModeDescription Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription Members
ModeDescription Structure Constructors Methods Operators Properties See Also Send Feedback

The ModeDescription type exposes the following members.

Constructors

 | Name | Description
Public method | ModeDescription(UInt32, UInt32, Format, Rational) |
Public method | ModeDescription(UInt32, UInt32, Format, Rational, ModeScanlineOrder, ModeScaling) |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Format | A Format structure describing the display format. (Also see DirectX SDK: DXGI_MODE_DESC.Format)
Public property | Height | A value describing the resolution height. (Also see DirectX SDK: DXGI_MODE_DESC.Height)
Public property | RefreshRate | A Rational structure describing the refresh rate in hertz (Also see DirectX SDK: DXGI_MODE_DESC.RefreshRate)
Public property | Scaling | A member of the ModeScaling enumerated type describing the scaling mode. (Also see DirectX SDK: DXGI_MODE_DESC.Scaling)
Public property | ScanlineOrdering | A member of the ModeScanlineOrder enumerated type describing the scanline drawing mode. (Also see DirectX SDK: DXGI_MODE_DESC.ScanlineOrdering)
Public property | Width | A value describing the resolution width. (Also see DirectX SDK: DXGI_MODE_DESC.Width)

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeDescription Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription Constructor
ModeDescription Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ModeDescription(UInt32, UInt32, Format, Rational) |
Public method | ModeDescription(UInt32, UInt32, Format, Rational, ModeScanlineOrder, ModeScaling) |

See Also

ModeDescription Structure
ModeDescription Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeDescription Constructor (UInt32, UInt32, Format, Rational)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription Constructor (UInt32, UInt32, Format, Rational)
ModeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeDescription(
    uint width,
    uint height,
    Format format,
    Rational refreshRate
)
Visual Basic
Public Sub New ( _
    width As UInteger, _
    height As UInteger, _
    format As Format, _
    refreshRate As Rational _
)
Visual C++
public:
ModeDescription(
    unsigned int width,
    unsigned int height,
    Format format,
    Rational refreshRate
)

Parameters

width
Type: System..::..UInt32
height
Type: System..::..UInt32
format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
refreshRate
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Rational

See Also

ModeDescription Structure
ModeDescription Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeDescription Constructor (UInt32, UInt32, Format, Rational, ModeScanlineOrder, ModeScaling)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription Constructor (UInt32, UInt32, Format, Rational, ModeScanlineOrder, ModeScaling)
ModeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeDescription(
    uint width,
    uint height,
    Format format,
    Rational refreshRate,
    ModeScanlineOrder scanlineOrder,
    ModeScaling scaling
)
Visual Basic
Public Sub New ( _
    width As UInteger, _
    height As UInteger, _
    format As Format, _
    refreshRate As Rational, _
    scanlineOrder As ModeScanlineOrder, _
    scaling As ModeScaling _
)
Visual C++
public:
ModeDescription(
    unsigned int width,
    unsigned int height,
    Format format,
    Rational refreshRate,
    ModeScanlineOrder scanlineOrder,
    ModeScaling scaling
)

Parameters

width
Type: System..::..UInt32
height
Type: System..::..UInt32
format
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
refreshRate
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Rational
scanlineOrder
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeScanlineOrder
scaling
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeScaling

See Also

ModeDescription Structure
ModeDescription Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription Methods
ModeDescription Structure See Also Send Feedback

The ModeDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..Equals Method
ModeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..GetHashCode Method
ModeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription Operators
ModeDescription Structure See Also Send Feedback

The ModeDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..Equality Operator
ModeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    ModeDescription modeDescription1,
    ModeDescription modeDescription2
)
Visual Basic
Public Shared Operator = ( _
    modeDescription1 As ModeDescription, _
    modeDescription2 As ModeDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    ModeDescription modeDescription1,
    ModeDescription modeDescription2
)

Parameters

modeDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription
modeDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..Inequality Operator
ModeDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    ModeDescription modeDescription1,
    ModeDescription modeDescription2
)
Visual Basic
Public Shared Operator <> ( _
    modeDescription1 As ModeDescription, _
    modeDescription2 As ModeDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    ModeDescription modeDescription1,
    ModeDescription modeDescription2
)

Parameters

modeDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription
modeDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription Properties
ModeDescription Structure See Also Send Feedback

The ModeDescription type exposes the following members.

Properties

 | Name | Description
Public property | Format | A Format structure describing the display format. (Also see DirectX SDK: DXGI_MODE_DESC.Format)
Public property | Height | A value describing the resolution height. (Also see DirectX SDK: DXGI_MODE_DESC.Height)
Public property | RefreshRate | A Rational structure describing the refresh rate in hertz (Also see DirectX SDK: DXGI_MODE_DESC.RefreshRate)
Public property | Scaling | A member of the ModeScaling enumerated type describing the scaling mode. (Also see DirectX SDK: DXGI_MODE_DESC.Scaling)
Public property | ScanlineOrdering | A member of the ModeScanlineOrder enumerated type describing the scanline drawing mode. (Also see DirectX SDK: DXGI_MODE_DESC.ScanlineOrdering)
Public property | Width | A value describing the resolution width. (Also see DirectX SDK: DXGI_MODE_DESC.Width)

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..Format Property
ModeDescription Structure See Also Send Feedback
A Format structure describing the display format.

(Also see DirectX SDK: DXGI_MODE_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..Height Property
ModeDescription Structure See Also Send Feedback
A value describing the resolution height.

(Also see DirectX SDK: DXGI_MODE_DESC.Height)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


RefreshRate Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..RefreshRate Property
ModeDescription Structure See Also Send Feedback
A Rational structure describing the refresh rate in hertz

(Also see DirectX SDK: DXGI_MODE_DESC.RefreshRate)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Rational RefreshRate { get; set; }
Visual Basic
Public Property RefreshRate As Rational
    Get
    Set
Visual C++
public:
property Rational RefreshRate {
    Rational get ();
    void set (Rational value);
}

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Scaling Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..Scaling Property
ModeDescription Structure See Also Send Feedback
A member of the ModeScaling enumerated type describing the scaling mode.

(Also see DirectX SDK: DXGI_MODE_DESC.Scaling)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeScaling Scaling { get; set; }
Visual Basic
Public Property Scaling As ModeScaling
    Get
    Set
Visual C++
public:
property ModeScaling Scaling {
    ModeScaling get ();
    void set (ModeScaling value);
}

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ScanlineOrdering Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..ScanlineOrdering Property
ModeDescription Structure See Also Send Feedback
A member of the ModeScanlineOrder enumerated type describing the scanline drawing mode.

(Also see DirectX SDK: DXGI_MODE_DESC.ScanlineOrdering)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeScanlineOrder ScanlineOrdering { get; set; }
Visual Basic
Public Property ScanlineOrdering As ModeScanlineOrder
    Get
    Set
Visual C++
public:
property ModeScanlineOrder ScanlineOrdering {
    ModeScanlineOrder get ();
    void set (ModeScanlineOrder value);
}

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeDescription..::..Width Property
ModeDescription Structure See Also Send Feedback
A value describing the resolution width.

(Also see DirectX SDK: DXGI_MODE_DESC.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ModeDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeRotation Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeRotation Enumeration
See Also Send Feedback
Flags that indicate how the back buffers should be rotated to fit the physical rotation of a monitor.

(Also see DirectX SDK: DXGI_MODE_ROTATION)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ModeRotation
Visual Basic
Public Enumeration ModeRotation
Visual C++
public enum class ModeRotation

Members

Member name | Description
Rotate270 |
Rotate180 |
Rotate90 |
Identity |
Unspecified |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeScaling Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeScaling Enumeration
See Also Send Feedback
Flags indicating how an image is stretched to fit a given monitor's resolution.

(Also see DirectX SDK: DXGI_MODE_SCALING)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ModeScaling
Visual Basic
Public Enumeration ModeScaling
Visual C++
public enum class ModeScaling

Members

Member name | Description
Stretched |
Centered |
Unspecified |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ModeScanlineOrder Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ModeScanlineOrder Enumeration
See Also Send Feedback
Flags indicating the method the raster uses to create an image on a surface.

(Also see DirectX SDK: DXGI_MODE_SCANLINE_ORDER)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ModeScanlineOrder
Visual Basic
Public Enumeration ModeScanlineOrder
Visual C++
public enum class ModeScanlineOrder

Members

Member name | Description
LowerFieldFirst |
UpperFieldFirst |
Progressive |
Unspecified |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MonitorInfo Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MonitorInfo Structure
Members See Also Send Feedback
Describes a monitor.

(Also see Windows SDK: MONITORINFOEX)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct MonitorInfo
Visual Basic
Public Structure MonitorInfo
Visual C++
public value class MonitorInfo

See Also

MonitorInfo Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MonitorInfo Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MonitorInfo Members
MonitorInfo Structure Properties See Also Send Feedback

The MonitorInfo type exposes the following members.

Properties

 | Name | Description
Public property | IsPrimaryMonitor | Indicates if this is the primary monitor
Public property | MonitorCoordinates | Specifies the display monitor rectangle, expressed in virtual-screen coordinates. Note that if the monitor is not the primary display monitor, some of the rectangle's coordinates may be negative values.
Public property | MonitorHandle | Handle to this monitor
Public property | WorkCoordinates | Specifies the work area rectangle of the display monitor that can be used by applications, expressed in virtual-screen coordinates. Windows uses this rectangle to maximize an application on the monitor. The rest of the area in MonitorRect contains system windows such as the task bar and side bars. Note that if the monitor is not the primary display monitor, some of the rectangle's coordinates may be negative values.

See Also

MonitorInfo Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MonitorInfo Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MonitorInfo Properties
MonitorInfo Structure See Also Send Feedback

The MonitorInfo type exposes the following members.

Properties

 | Name | Description
Public property | IsPrimaryMonitor | Indicates if this is the primary monitor
Public property | MonitorCoordinates | Specifies the display monitor rectangle, expressed in virtual-screen coordinates. Note that if the monitor is not the primary display monitor, some of the rectangle's coordinates may be negative values.
Public property | MonitorHandle | Handle to this monitor
Public property | WorkCoordinates | Specifies the work area rectangle of the display monitor that can be used by applications, expressed in virtual-screen coordinates. Windows uses this rectangle to maximize an application on the monitor. The rest of the area in MonitorRect contains system windows such as the task bar and side bars. Note that if the monitor is not the primary display monitor, some of the rectangle's coordinates may be negative values.

See Also

MonitorInfo Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


IsPrimaryMonitor Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MonitorInfo..::..IsPrimaryMonitor Property
MonitorInfo Structure See Also Send Feedback
Indicates if this is the primary monitor

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsPrimaryMonitor { get; set; }
Visual Basic
Public Property IsPrimaryMonitor As Boolean
    Get
    Set
Visual C++
public:
property bool IsPrimaryMonitor {
    bool get ();
    void set (bool value);
}

See Also

MonitorInfo Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MonitorCoordinates Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MonitorInfo..::..MonitorCoordinates Property
MonitorInfo Structure See Also Send Feedback
Specifies the display monitor rectangle, expressed in virtual-screen coordinates. Note that if the monitor is not the primary display monitor, some of the rectangle's coordinates may be negative values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DRect MonitorCoordinates { get; set; }
Visual Basic
Public Property MonitorCoordinates As D3DRect
    Get
    Set
Visual C++
public:
property D3DRect MonitorCoordinates {
    D3DRect get ();
    void set (D3DRect value);
}

See Also

MonitorInfo Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


MonitorHandle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MonitorInfo..::..MonitorHandle Property
MonitorInfo Structure See Also Send Feedback
Handle to this monitor

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr MonitorHandle { get; set; }
Visual Basic
Public Property MonitorHandle As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr MonitorHandle {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

MonitorInfo Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


WorkCoordinates Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
MonitorInfo..::..WorkCoordinates Property
MonitorInfo Structure See Also Send Feedback
Specifies the work area rectangle of the display monitor that can be used by applications, expressed in virtual-screen coordinates. Windows uses this rectangle to maximize an application on the monitor. The rest of the area in MonitorRect contains system windows such as the task bar and side bars. Note that if the monitor is not the primary display monitor, some of the rectangle's coordinates may be negative values.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DRect WorkCoordinates { get; set; }
Visual Basic
Public Property WorkCoordinates As D3DRect
    Get
    Set
Visual C++
public:
property D3DRect WorkCoordinates {
    D3DRect get ();
    void set (D3DRect value);
}

See Also

MonitorInfo Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


NonDefaultModes Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
NonDefaultModes Enumeration
See Also Send Feedback
Options for enumerating display modes.

(Also see DirectX SDK: DXGI_ENUM_MODES)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum NonDefaultModes
Visual Basic
<FlagsAttribute> _
Public Enumeration NonDefaultModes
Visual C++
[FlagsAttribute]
public enum class NonDefaultModes

Members

Member name | Description
Scaling |
None |
Interlaced |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Output Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output Class
Members See Also Send Feedback
An Output interface represents an adapter output (such as a monitor).

(Also see DirectX SDK: IDXGIOutput)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Output : GraphicsObject
Visual Basic
Public Class Output _
    Inherits GraphicsObject
Visual C++
public ref class Output : public GraphicsObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Output

See Also

Output Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Output Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output Members
Output Class Methods Properties See Also Send Feedback

The Output type exposes the following members.

Methods

 | Name | Description
Public method | FindClosestMatchingMode(ModeDescription) | Find the display mode that most closely matches the requested display mode. (Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)
Public method | FindClosestMatchingMode(ModeDescription, D3DDevice) | Find the display mode that most closely matches the requested display mode for a given Direct3D Device. (Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)
Public method | FindClosestMatchingMode(ModeDescription, D3DDevice) | Find the display mode that most closely matches the requested display mode for a given Direct3D Device. (Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)
Public method | GetDisplayModeList | Gets the display modes that match the requested format and other input options. (Also see DirectX SDK: IDXGIOutput::GetDisplayModeList)
Public method | GetDisplaySurfaceData | Get a copy of the current display surface. (Also see DirectX SDK: IDXGIOutput::GetDisplaySurfaceData)
Public method | GetNumberOfDisplayModes | Gets the display modes that match the requested format and other input options. (Also see DirectX SDK: IDXGIOutput::GetDisplayModeList)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | ReleaseOwnership | Release ownership of the output. (Also see DirectX SDK: IDXGIOutput::ReleaseOwnership)
Public method | SetDisplaySurface | Change the display mode. (Also see DirectX SDK: IDXGIOutput::SetDisplaySurface)
Public method | TakeOwnership(D3DDevice, Boolean) | Take ownership of an output. (Also see DirectX SDK: IDXGIOutput::TakeOwnership)
Public method | TakeOwnership(D3DDevice, Boolean) | Take ownership of an output. (Also see DirectX SDK: IDXGIOutput::TakeOwnership)
Public method | TakeOwnership(Device, Boolean) | Take ownership of an output. (Also see DirectX SDK: IDXGIOutput::TakeOwnership)
Public method | WaitForVBlank | Cause the thread to wait at this call until the next vertical blank occurs. (Also see DirectX SDK: IDXGIOutput::WaitForVBlank)

Properties

 | Name | Description
Public property | Description | Get a description of the output. (Also see DirectX SDK: IDXGIOutput::GetDesc)
Public property | GammaControl | Gets or sets the gamma control settings. (Also see DirectX SDK: IDXGIOutput::GetGammaControl, IDXGIOutput::SetGammaControl)
Public property | GammaControlCapabilities | Get a description of the gamma-control capabilities. (Also see DirectX SDK: IDXGIOutput::GetGammaControlCapabilities)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | RenderedFrameStatistics | Get statistics about recently rendered frames. (Also see DirectX SDK: IDXGIOutput::GetFrameStatistics)

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Output Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output Methods
Output Class See Also Send Feedback

The Output type exposes the following members.

Methods

 | Name | Description
Public method | FindClosestMatchingMode(ModeDescription) | Find the display mode that most closely matches the requested display mode. (Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)
Public method | FindClosestMatchingMode(ModeDescription, D3DDevice) | Find the display mode that most closely matches the requested display mode for a given Direct3D Device. (Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)
Public method | FindClosestMatchingMode(ModeDescription, D3DDevice) | Find the display mode that most closely matches the requested display mode for a given Direct3D Device. (Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)
Public method | GetDisplayModeList | Gets the display modes that match the requested format and other input options. (Also see DirectX SDK: IDXGIOutput::GetDisplayModeList)
Public method | GetDisplaySurfaceData | Get a copy of the current display surface. (Also see DirectX SDK: IDXGIOutput::GetDisplaySurfaceData)
Public method | GetNumberOfDisplayModes | Gets the display modes that match the requested format and other input options. (Also see DirectX SDK: IDXGIOutput::GetDisplayModeList)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | ReleaseOwnership | Release ownership of the output. (Also see DirectX SDK: IDXGIOutput::ReleaseOwnership)
Public method | SetDisplaySurface | Change the display mode. (Also see DirectX SDK: IDXGIOutput::SetDisplaySurface)
Public method | TakeOwnership(D3DDevice, Boolean) | Take ownership of an output. (Also see DirectX SDK: IDXGIOutput::TakeOwnership)
Public method | TakeOwnership(D3DDevice, Boolean) | Take ownership of an output. (Also see DirectX SDK: IDXGIOutput::TakeOwnership)
Public method | TakeOwnership(Device, Boolean) | Take ownership of an output. (Also see DirectX SDK: IDXGIOutput::TakeOwnership)
Public method | WaitForVBlank | Cause the thread to wait at this call until the next vertical blank occurs. (Also see DirectX SDK: IDXGIOutput::WaitForVBlank)

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FindClosestMatchingMode Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..FindClosestMatchingMode Method
Output Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindClosestMatchingMode(ModeDescription) | Find the display mode that most closely matches the requested display mode. (Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)
Public method | FindClosestMatchingMode(ModeDescription, D3DDevice) | Find the display mode that most closely matches the requested display mode for a given Direct3D Device. (Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)
Public method | FindClosestMatchingMode(ModeDescription, D3DDevice) | Find the display mode that most closely matches the requested display mode for a given Direct3D Device. (Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)

See Also

Output Class
Output Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FindClosestMatchingMode Method (ModeDescription)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..FindClosestMatchingMode Method (ModeDescription)
Output Class See Also Send Feedback
Find the display mode that most closely matches the requested display mode.

(Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeDescription FindClosestMatchingMode(
    ModeDescription modeToMatch
)
Visual Basic
Public Function FindClosestMatchingMode ( _
    modeToMatch As ModeDescription _
) As ModeDescription
Visual C++
public:
ModeDescription FindClosestMatchingMode(
    ModeDescription modeToMatch
)

Parameters

modeToMatch
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription
The desired display mode (see ModeDescription). Members of ModeDescription can be unspecified indicating no preference for that member. A value of 0 for Width or Height indicates the value is unspecified. If either Width or Height are 0 both must be 0. A numerator and denominator of 0 in RefreshRate indicate it is unspecified. Other members of ModeDescription have enumeration values indicating the member is unspecified. Format cannot be UNKNOWN.

Return Value

The mode that most closely matches ModeToMatch.

See Also

Output Class
FindClosestMatchingMode Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription


FindClosestMatchingMode Method (ModeDescription, D3DDevice)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..FindClosestMatchingMode Method (ModeDescription, D3DDevice)
Output Class See Also Send Feedback
Find the display mode that most closely matches the requested display mode for a given Direct3D Device.

(Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeDescription FindClosestMatchingMode(
    ModeDescription modeToMatch,
    D3DDevice concernedDevice
)
Visual Basic
Public Function FindClosestMatchingMode ( _
    modeToMatch As ModeDescription, _
    concernedDevice As D3DDevice _
) As ModeDescription
Visual C++
public:
ModeDescription FindClosestMatchingMode(
    ModeDescription modeToMatch,
    D3DDevice^ concernedDevice
)

Parameters

modeToMatch
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription
The desired display mode (see ModeDescription). Members of ModeDescription can be unspecified indicating no preference for that member. A value of 0 for Width or Height indicates the value is unspecified. If either Width or Height are 0 both must be 0. A numerator and denominator of 0 in RefreshRate indicate it is unspecified. Other members of ModeDescription have enumeration values indicating the member is unspecified. If pConnectedDevice is null, Format cannot be UNKNOWN.
concernedDevice
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDevice
The Direct3D device object. If this parameter is NULL, only modes whose format matches that of pModeToMatch will be returned; otherwise, only those formats that are supported for scan-out by the device are returned.

Return Value

The mode that most closely matches ModeToMatch.

See Also

Output Class
FindClosestMatchingMode Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription


FindClosestMatchingMode Method (ModeDescription, D3DDevice)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..FindClosestMatchingMode Method (ModeDescription, D3DDevice)
Output Class See Also Send Feedback
Find the display mode that most closely matches the requested display mode for a given Direct3D Device.

(Also see DirectX SDK: IDXGIOutput::FindClosestMatchingMode)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeDescription FindClosestMatchingMode(
    ModeDescription modeToMatch,
    D3DDevice concernedDevice
)
Visual Basic
Public Function FindClosestMatchingMode ( _
    modeToMatch As ModeDescription, _
    concernedDevice As D3DDevice _
) As ModeDescription
Visual C++
public:
ModeDescription FindClosestMatchingMode(
    ModeDescription modeToMatch,
    D3DDevice^ concernedDevice
)

Parameters

modeToMatch
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription
The desired display mode (see ModeDescription). Members of ModeDescription can be unspecified indicating no preference for that member. A value of 0 for Width or Height indicates the value is unspecified. If either Width or Height are 0 both must be 0. A numerator and denominator of 0 in RefreshRate indicate it is unspecified. Other members of ModeDescription have enumeration values indicating the member is unspecified. If pConnectedDevice is null, Format cannot be UNKNOWN.
concernedDevice
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DDevice
The Direct3D device object. If this parameter is NULL, only modes whose format matches that of pModeToMatch will be returned; otherwise, only those formats that are supported for scan-out by the device are returned.

Return Value

The mode that most closely matches ModeToMatch.

See Also

Output Class
FindClosestMatchingMode Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription


GetDisplayModeList Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..GetDisplayModeList Method
Output Class See Also Send Feedback
Gets the display modes that match the requested format and other input options.

(Also see DirectX SDK: IDXGIOutput::GetDisplayModeList)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeDescription[] GetDisplayModeList(
    Format colorFormat,
    NonDefaultModes modes
)
Visual Basic
Public Function GetDisplayModeList ( _
    colorFormat As Format, _
    modes As NonDefaultModes _
) As ModeDescription()
Visual C++
public:
array<ModeDescription>^ GetDisplayModeList(
    Format colorFormat,
    NonDefaultModes modes
)

Parameters

colorFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
The color format (see Format).
modes
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..NonDefaultModes
Options for modes to include (see NonDefaultModes). NonDefaultModes.Scaling needs to be specified to expose the display modes that require scaling. Centered modes, requiring no scaling and corresponding directly to the display output, are enumerated by default.

Return Value

An aray of display modes (see ModeDescription) or null if no modes were found.

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..NonDefaultModes
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription


GetDisplaySurfaceData Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..GetDisplaySurfaceData Method
Output Class See Also Send Feedback
Get a copy of the current display surface.

(Also see DirectX SDK: IDXGIOutput::GetDisplaySurfaceData)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void GetDisplaySurfaceData(
    Surface destination
)
Visual Basic
Public Sub GetDisplaySurfaceData ( _
    destination As Surface _
)
Visual C++
public:
void GetDisplaySurfaceData(
    Surface^ destination
)

Parameters

destination
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface
A destination surface (see Surface).

Remarks

GetDisplaySurfaceData can only be called when an output is in full-screen mode. If the method succeeds, the destination surface will be filled and its reference count incremented.

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface


GetNumberOfDisplayModes Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..GetNumberOfDisplayModes Method
Output Class See Also Send Feedback
Gets the display modes that match the requested format and other input options.

(Also see DirectX SDK: IDXGIOutput::GetDisplayModeList)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint GetNumberOfDisplayModes(
    Format colorFormat,
    NonDefaultModes modes
)
Visual Basic
Public Function GetNumberOfDisplayModes ( _
    colorFormat As Format, _
    modes As NonDefaultModes _
) As UInteger
Visual C++
public:
unsigned int GetNumberOfDisplayModes(
    Format colorFormat,
    NonDefaultModes modes
)

Parameters

colorFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
The color format (see Format).
modes
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..NonDefaultModes
Options for modes to include (see NonDefaultModes). NonDefaultModes.Scaling needs to be specified to expose the display modes that require scaling. Centered modes, requiring no scaling and corresponding directly to the display output, are enumerated by default.

Return Value

The number of display modes (see ModeDescription) that matches the format and options.

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..NonDefaultModes
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription


ReleaseOwnership Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..ReleaseOwnership Method
Output Class See Also Send Feedback
Release ownership of the output.

(Also see DirectX SDK: IDXGIOutput::ReleaseOwnership)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ReleaseOwnership()
Visual Basic
Public Sub ReleaseOwnership
Visual C++
public:
void ReleaseOwnership()

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SetDisplaySurface Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..SetDisplaySurface Method
Output Class See Also Send Feedback
Change the display mode.

(Also see DirectX SDK: IDXGIOutput::SetDisplaySurface)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetDisplaySurface(
    Surface surface
)
Visual Basic
Public Sub SetDisplaySurface ( _
    surface As Surface _
)
Visual C++
public:
void SetDisplaySurface(
    Surface^ surface
)

Parameters

surface
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface
A surface (see Surface) used for rendering an image to the screen. The surface must have been created with as a back buffer (DXGI_USAGE_BACKBUFFER).

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface


TakeOwnership Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..TakeOwnership Method
Output Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TakeOwnership(D3DDevice, Boolean) | Take ownership of an output. (Also see DirectX SDK: IDXGIOutput::TakeOwnership)
Public method | TakeOwnership(D3DDevice, Boolean) | Take ownership of an output. (Also see DirectX SDK: IDXGIOutput::TakeOwnership)
Public method | TakeOwnership(Device, Boolean) | Take ownership of an output. (Also see DirectX SDK: IDXGIOutput::TakeOwnership)

See Also

Output Class
Output Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


TakeOwnership Method (D3DDevice, Boolean)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..TakeOwnership Method (D3DDevice, Boolean)
Output Class See Also Send Feedback
Take ownership of an output.

(Also see DirectX SDK: IDXGIOutput::TakeOwnership)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void TakeOwnership(
    D3DDevice device,
    bool exclusive
)
Visual Basic
Public Sub TakeOwnership ( _
    device As D3DDevice, _
    exclusive As Boolean _
)
Visual C++
public:
void TakeOwnership(
    D3DDevice^ device,
    bool exclusive
)

Parameters

device
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D10..::..D3DDevice
A Direct3D 10 Device.
exclusive
Type: System..::..Boolean
Set to TRUE to enable other threads or applications to take ownership of the device; otherwise set to FALSE.

See Also

Output Class
TakeOwnership Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


TakeOwnership Method (D3DDevice, Boolean)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..TakeOwnership Method (D3DDevice, Boolean)
Output Class See Also Send Feedback
Take ownership of an output.

(Also see DirectX SDK: IDXGIOutput::TakeOwnership)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void TakeOwnership(
    D3DDevice device,
    bool exclusive
)
Visual Basic
Public Sub TakeOwnership ( _
    device As D3DDevice, _
    exclusive As Boolean _
)
Visual C++
public:
void TakeOwnership(
    D3DDevice^ device,
    bool exclusive
)

Parameters

device
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D11..::..D3DDevice
A Direct3D 11 Device.
exclusive
Type: System..::..Boolean
Set to TRUE to enable other threads or applications to take ownership of the device; otherwise set to FALSE.

See Also

Output Class
TakeOwnership Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


TakeOwnership Method (Device, Boolean)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..TakeOwnership Method (Device, Boolean)
Output Class See Also Send Feedback
Take ownership of an output.

(Also see DirectX SDK: IDXGIOutput::TakeOwnership)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void TakeOwnership(
    Device device,
    bool exclusive
)
Visual Basic
Public Sub TakeOwnership ( _
    device As Device, _
    exclusive As Boolean _
)
Visual C++
public:
void TakeOwnership(
    Device^ device,
    bool exclusive
)

Parameters

device
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Device
A Graphics Device.
exclusive
Type: System..::..Boolean
Set to TRUE to enable other threads or applications to take ownership of the device; otherwise set to FALSE.

See Also

Output Class
TakeOwnership Overload
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


WaitForVBlank Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..WaitForVBlank Method
Output Class See Also Send Feedback
Cause the thread to wait at this call until the next vertical blank occurs.

(Also see DirectX SDK: IDXGIOutput::WaitForVBlank)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void WaitForVBlank()
Visual Basic
Public Sub WaitForVBlank
Visual C++
public:
void WaitForVBlank()

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Output Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output Properties
Output Class See Also Send Feedback

The Output type exposes the following members.

Properties

 | Name | Description
Public property | Description | Get a description of the output. (Also see DirectX SDK: IDXGIOutput::GetDesc)
Public property | GammaControl | Gets or sets the gamma control settings. (Also see DirectX SDK: IDXGIOutput::GetGammaControl, IDXGIOutput::SetGammaControl)
Public property | GammaControlCapabilities | Get a description of the gamma-control capabilities. (Also see DirectX SDK: IDXGIOutput::GetGammaControlCapabilities)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | RenderedFrameStatistics | Get statistics about recently rendered frames. (Also see DirectX SDK: IDXGIOutput::GetFrameStatistics)

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..Description Property
Output Class See Also Send Feedback
Get a description of the output.

(Also see DirectX SDK: IDXGIOutput::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public OutputDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As OutputDescription
    Get
Visual C++
public:
property OutputDescription Description {
    OutputDescription get ();
}

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaControl Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..GammaControl Property
Output Class See Also Send Feedback
Gets or sets the gamma control settings.

(Also see DirectX SDK: IDXGIOutput::GetGammaControl, IDXGIOutput::SetGammaControl)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GammaControl GammaControl { get; set; }
Visual Basic
Public Property GammaControl As GammaControl
    Get
    Set
Visual C++
public:
property GammaControl GammaControl {
    GammaControl get ();
    void set (GammaControl value);
}

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GammaControlCapabilities Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..GammaControlCapabilities Property
Output Class See Also Send Feedback
Get a description of the gamma-control capabilities.

(Also see DirectX SDK: IDXGIOutput::GetGammaControlCapabilities)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public GammaControlCapabilities GammaControlCapabilities { get; }
Visual Basic
Public ReadOnly Property GammaControlCapabilities As GammaControlCapabilities
    Get
Visual C++
public:
property GammaControlCapabilities GammaControlCapabilities {
    GammaControlCapabilities get ();
}

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


RenderedFrameStatistics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Output..::..RenderedFrameStatistics Property
Output Class See Also Send Feedback
Get statistics about recently rendered frames.

(Also see DirectX SDK: IDXGIOutput::GetFrameStatistics)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FrameStatistics RenderedFrameStatistics { get; }
Visual Basic
Public ReadOnly Property RenderedFrameStatistics As FrameStatistics
    Get
Visual C++
public:
property FrameStatistics RenderedFrameStatistics {
    FrameStatistics get ();
}

See Also

Output Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


OutputDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputDescription Structure
Members See Also Send Feedback
Describes an output or physical connection between the adapter (video card) and a device.

(Also see DirectX SDK: DXGI_OUTPUT_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct OutputDescription
Visual Basic
Public Structure OutputDescription
Visual C++
public value class OutputDescription

See Also

OutputDescription Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


OutputDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputDescription Members
OutputDescription Structure Properties See Also Send Feedback

The OutputDescription type exposes the following members.

Properties

 | Name | Description
Public property | AttachedToDesktop | True if the output is attached to the desktop; otherwise, false. (Also see DirectX SDK: DXGI_OUTPUT_DESC.AttachedToDesktop)
Public property | DesktopCoordinates | A RECT structure containing the bounds of the output in desktop coordinates. (Also see DirectX SDK: DXGI_OUTPUT_DESC.DesktopCoordinates)
Public property | DeviceName | A string that contains the name of the output device. (Also see DirectX SDK: DXGI_OUTPUT_DESC.DeviceName)
Public property | Monitor | An HMONITOR handle that represents the display monitor. For more information, see HMONITOR and the Device Context. (Also see DirectX SDK: DXGI_OUTPUT_DESC.Monitor)
Public property | Rotation | A member of the ModeRotation enumerated type describing on how an image is rotated by the output. (Also see DirectX SDK: DXGI_OUTPUT_DESC.Rotation)

See Also

OutputDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


OutputDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputDescription Properties
OutputDescription Structure See Also Send Feedback

The OutputDescription type exposes the following members.

Properties

 | Name | Description
Public property | AttachedToDesktop | True if the output is attached to the desktop; otherwise, false. (Also see DirectX SDK: DXGI_OUTPUT_DESC.AttachedToDesktop)
Public property | DesktopCoordinates | A RECT structure containing the bounds of the output in desktop coordinates. (Also see DirectX SDK: DXGI_OUTPUT_DESC.DesktopCoordinates)
Public property | DeviceName | A string that contains the name of the output device. (Also see DirectX SDK: DXGI_OUTPUT_DESC.DeviceName)
Public property | Monitor | An HMONITOR handle that represents the display monitor. For more information, see HMONITOR and the Device Context. (Also see DirectX SDK: DXGI_OUTPUT_DESC.Monitor)
Public property | Rotation | A member of the ModeRotation enumerated type describing on how an image is rotated by the output. (Also see DirectX SDK: DXGI_OUTPUT_DESC.Rotation)

See Also

OutputDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


AttachedToDesktop Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputDescription..::..AttachedToDesktop Property
OutputDescription Structure See Also Send Feedback
True if the output is attached to the desktop; otherwise, false.

(Also see DirectX SDK: DXGI_OUTPUT_DESC.AttachedToDesktop)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool AttachedToDesktop { get; set; }
Visual Basic
Public Property AttachedToDesktop As Boolean
    Get
    Set
Visual C++
public:
property bool AttachedToDesktop {
    bool get ();
    void set (bool value);
}

See Also

OutputDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DesktopCoordinates Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputDescription..::..DesktopCoordinates Property
OutputDescription Structure See Also Send Feedback
A RECT structure containing the bounds of the output in desktop coordinates.

(Also see DirectX SDK: DXGI_OUTPUT_DESC.DesktopCoordinates)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public D3DRect DesktopCoordinates { get; set; }
Visual Basic
Public Property DesktopCoordinates As D3DRect
    Get
    Set
Visual C++
public:
property D3DRect DesktopCoordinates {
    D3DRect get ();
    void set (D3DRect value);
}

See Also

OutputDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


DeviceName Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputDescription..::..DeviceName Property
OutputDescription Structure See Also Send Feedback
A string that contains the name of the output device.

(Also see DirectX SDK: DXGI_OUTPUT_DESC.DeviceName)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public string DeviceName { get; set; }
Visual Basic
Public Property DeviceName As String
    Get
    Set
Visual C++
public:
property String^ DeviceName {
    String^ get ();
    void set (String^ value);
}

See Also

OutputDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Monitor Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputDescription..::..Monitor Property
OutputDescription Structure See Also Send Feedback
An HMONITOR handle that represents the display monitor. For more information, see HMONITOR and the Device Context.

(Also see DirectX SDK: DXGI_OUTPUT_DESC.Monitor)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MonitorInfo Monitor { get; set; }
Visual Basic
Public Property Monitor As MonitorInfo
    Get
    Set
Visual C++
public:
property MonitorInfo Monitor {
    MonitorInfo get ();
    void set (MonitorInfo value);
}

See Also

OutputDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Rotation Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
OutputDescription..::..Rotation Property
OutputDescription Structure See Also Send Feedback
A member of the ModeRotation enumerated type describing on how an image is rotated by the output.

(Also see DirectX SDK: DXGI_OUTPUT_DESC.Rotation)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeRotation Rotation { get; set; }
Visual Basic
Public Property Rotation As ModeRotation
    Get
    Set
Visual C++
public:
property ModeRotation Rotation {
    ModeRotation get ();
    void set (ModeRotation value);
}

See Also

OutputDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


PresentOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PresentOptions Enumeration
See Also Send Feedback
Options for presenting frames to the output.

(Also see DirectX SDK: DXGI_PRESENT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum PresentOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration PresentOptions
Visual C++
[FlagsAttribute]
public enum class PresentOptions

Members

Member name | Description
None |
Test |
DoNotRestart |
DoNotSequence |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Rational Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational Structure
Members See Also Send Feedback
Represents a rational number.

(Also see DirectX SDK: DXGI_RATIONAL)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct Rational
Visual Basic
Public Structure Rational
Visual C++
public value class Rational

See Also

Rational Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Rational Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational Members
Rational Structure Constructors Methods Operators Properties See Also Send Feedback

The Rational type exposes the following members.

Constructors

 | Name | Description
Public method | Rational |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Denominator | An unsigned integer value representing the bottom of the rational number. (Also see DirectX SDK: DXGI_RATIONAL.Denominator)
Public property | Numerator | An unsigned integer value representing the top of the rational number. (Also see DirectX SDK: DXGI_RATIONAL.Numerator)

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Rational Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational Constructor
Rational Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Rational(
    uint numerator,
    uint denominator
)
Visual Basic
Public Sub New ( _
    numerator As UInteger, _
    denominator As UInteger _
)
Visual C++
public:
Rational(
    unsigned int numerator,
    unsigned int denominator
)

Parameters

numerator
Type: System..::..UInt32
denominator
Type: System..::..UInt32

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Rational Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational Methods
Rational Structure See Also Send Feedback

The Rational type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational..::..Equals Method
Rational Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational..::..GetHashCode Method
Rational Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Rational Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational Operators
Rational Structure See Also Send Feedback

The Rational type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational..::..Equality Operator
Rational Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    Rational rational1,
    Rational rational2
)
Visual Basic
Public Shared Operator = ( _
    rational1 As Rational, _
    rational2 As Rational _
) As Boolean
Visual C++
public:
static bool operator ==(
    Rational rational1,
    Rational rational2
)

Parameters

rational1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Rational
rational2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Rational

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational..::..Inequality Operator
Rational Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    Rational rational1,
    Rational rational2
)
Visual Basic
Public Shared Operator <> ( _
    rational1 As Rational, _
    rational2 As Rational _
) As Boolean
Visual C++
public:
static bool operator !=(
    Rational rational1,
    Rational rational2
)

Parameters

rational1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Rational
rational2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Rational

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Rational Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational Properties
Rational Structure See Also Send Feedback

The Rational type exposes the following members.

Properties

 | Name | Description
Public property | Denominator | An unsigned integer value representing the bottom of the rational number. (Also see DirectX SDK: DXGI_RATIONAL.Denominator)
Public property | Numerator | An unsigned integer value representing the top of the rational number. (Also see DirectX SDK: DXGI_RATIONAL.Numerator)

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Denominator Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational..::..Denominator Property
Rational Structure See Also Send Feedback
An unsigned integer value representing the bottom of the rational number.

(Also see DirectX SDK: DXGI_RATIONAL.Denominator)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Denominator { get; set; }
Visual Basic
Public Property Denominator As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Denominator {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Numerator Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Rational..::..Numerator Property
Rational Structure See Also Send Feedback
An unsigned integer value representing the top of the rational number.

(Also see DirectX SDK: DXGI_RATIONAL.Numerator)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Numerator { get; set; }
Visual Basic
Public Property Numerator As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Numerator {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Rational Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Residency Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Residency Enumeration
See Also Send Feedback
Flags indicating the memory location of a resource.

(Also see DirectX SDK: DXGI_RESIDENCY)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum Residency
Visual Basic
Public Enumeration Residency
Visual C++
public enum class Residency

Members

Member name | Description
EvictedToDisk |
ResidentInSharedMemory |
FullyResident |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Resource Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Resource Class
Members See Also Send Feedback
An Resource interface allows resource sharing and identifies the memory that a resource resides in.

(Also see DirectX SDK: IDXGIResource)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Resource : DeviceSubObject
Visual Basic
Public Class Resource _
    Inherits DeviceSubObject
Visual C++
public ref class Resource : public DeviceSubObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..DeviceSubObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Resource

See Also

Resource Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Resource Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Resource Members
Resource Class Methods Properties See Also Send Feedback

The Resource type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | EvictionPriority | The priority for evicting the resource from memory (Also see DirectX SDK: IDXGIResource::GetEvictionPriority)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SharedHandle | Get the handle to a shared resource. The returned handle can be used to open the resource using different Direct3D devices. (Also see DirectX SDK: IDXGIResource::GetSharedHandle)
Public property | UsageOptions | Get the expected resource usage. (Also see DirectX SDK: IDXGIResource::GetUsage)

See Also

Resource Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Resource Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Resource Methods
Resource Class See Also Send Feedback

The Resource type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)

See Also

Resource Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Resource Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Resource Properties
Resource Class See Also Send Feedback

The Resource type exposes the following members.

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | EvictionPriority | The priority for evicting the resource from memory (Also see DirectX SDK: IDXGIResource::GetEvictionPriority)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | SharedHandle | Get the handle to a shared resource. The returned handle can be used to open the resource using different Direct3D devices. (Also see DirectX SDK: IDXGIResource::GetSharedHandle)
Public property | UsageOptions | Get the expected resource usage. (Also see DirectX SDK: IDXGIResource::GetUsage)

See Also

Resource Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


EvictionPriority Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Resource..::..EvictionPriority Property
Resource Class See Also Send Feedback
The priority for evicting the resource from memory

(Also see DirectX SDK: IDXGIResource::GetEvictionPriority)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ResourcePriority EvictionPriority { get; set; }
Visual Basic
Public Property EvictionPriority As ResourcePriority
    Get
    Set
Visual C++
public:
property ResourcePriority EvictionPriority {
    ResourcePriority get ();
    void set (ResourcePriority value);
}

See Also

Resource Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SharedHandle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Resource..::..SharedHandle Property
Resource Class See Also Send Feedback
Get the handle to a shared resource. The returned handle can be used to open the resource using different Direct3D devices.

(Also see DirectX SDK: IDXGIResource::GetSharedHandle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr SharedHandle { get; }
Visual Basic
Public ReadOnly Property SharedHandle As IntPtr
    Get
Visual C++
public:
property IntPtr SharedHandle {
    IntPtr get ();
}

See Also

Resource Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


UsageOptions Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Resource..::..UsageOptions Property
Resource Class See Also Send Feedback
Get the expected resource usage.

(Also see DirectX SDK: IDXGIResource::GetUsage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public UsageOptions UsageOptions { get; }
Visual Basic
Public ReadOnly Property UsageOptions As UsageOptions
    Get
Visual C++
public:
property UsageOptions UsageOptions {
    UsageOptions get ();
}

See Also

Resource Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Resource..::..UsageOptions


ResourcePriority Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ResourcePriority Enumeration
See Also Send Feedback
Resource Priorities.

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum ResourcePriority
Visual Basic
Public Enumeration ResourcePriority
Visual C++
public enum class ResourcePriority

Members

Member name | Description
Maximum |
High |
Normal |
Low |
Minimum |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SampleDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription Structure
Members See Also Send Feedback
Describes multi-sampling parameters for a resource.

(Also see DirectX SDK: DXGI_SAMPLE_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SampleDescription
Visual Basic
Public Structure SampleDescription
Visual C++
public value class SampleDescription

See Also

SampleDescription Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SampleDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription Members
SampleDescription Structure Constructors Methods Operators Properties See Also Send Feedback

The SampleDescription type exposes the following members.

Constructors

 | Name | Description
Public method | SampleDescription |

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Count | The number of multisamples per pixel. (Also see DirectX SDK: DXGI_SAMPLE_DESC.Count)
Public property | Quality | The image quality level. The higher the quality, the lower the performance. The valid range is between zero and one less than the level returned by Device.CheckMultisampleQualityLevels. (Also see DirectX SDK: DXGI_SAMPLE_DESC.Quality)

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SampleDescription Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription Constructor
SampleDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SampleDescription(
    uint count,
    uint quality
)
Visual Basic
Public Sub New ( _
    count As UInteger, _
    quality As UInteger _
)
Visual C++
public:
SampleDescription(
    unsigned int count,
    unsigned int quality
)

Parameters

count
Type: System..::..UInt32
quality
Type: System..::..UInt32

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SampleDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription Methods
SampleDescription Structure See Also Send Feedback

The SampleDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription..::..Equals Method
SampleDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription..::..GetHashCode Method
SampleDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SampleDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription Operators
SampleDescription Structure See Also Send Feedback

The SampleDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription..::..Equality Operator
SampleDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    SampleDescription sampleDescription1,
    SampleDescription sampleDescription2
)
Visual Basic
Public Shared Operator = ( _
    sampleDescription1 As SampleDescription, _
    sampleDescription2 As SampleDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    SampleDescription sampleDescription1,
    SampleDescription sampleDescription2
)

Parameters

sampleDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SampleDescription
sampleDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SampleDescription

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription..::..Inequality Operator
SampleDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    SampleDescription sampleDescription1,
    SampleDescription sampleDescription2
)
Visual Basic
Public Shared Operator <> ( _
    sampleDescription1 As SampleDescription, _
    sampleDescription2 As SampleDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    SampleDescription sampleDescription1,
    SampleDescription sampleDescription2
)

Parameters

sampleDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SampleDescription
sampleDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SampleDescription

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SampleDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription Properties
SampleDescription Structure See Also Send Feedback

The SampleDescription type exposes the following members.

Properties

 | Name | Description
Public property | Count | The number of multisamples per pixel. (Also see DirectX SDK: DXGI_SAMPLE_DESC.Count)
Public property | Quality | The image quality level. The higher the quality, the lower the performance. The valid range is between zero and one less than the level returned by Device.CheckMultisampleQualityLevels. (Also see DirectX SDK: DXGI_SAMPLE_DESC.Quality)

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Count Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription..::..Count Property
SampleDescription Structure See Also Send Feedback
The number of multisamples per pixel.

(Also see DirectX SDK: DXGI_SAMPLE_DESC.Count)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Count { get; set; }
Visual Basic
Public Property Count As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Count {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Quality Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SampleDescription..::..Quality Property
SampleDescription Structure See Also Send Feedback
The image quality level. The higher the quality, the lower the performance. The valid range is between zero and one less than the level returned by Device.CheckMultisampleQualityLevels.

(Also see DirectX SDK: DXGI_SAMPLE_DESC.Quality)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Quality { get; set; }
Visual Basic
Public Property Quality As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Quality {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SampleDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SharedResource Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SharedResource Structure
Members See Also Send Feedback
Represents a handle to a shared resource.

(Also see DirectX SDK: DXGI_SHARED_RESOURCE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SharedResource
Visual Basic
Public Structure SharedResource
Visual C++
public value class SharedResource

See Also

SharedResource Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SharedResource Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SharedResource Members
SharedResource Structure Properties See Also Send Feedback

The SharedResource type exposes the following members.

Properties

 | Name | Description
Public property | Handle | A handle to a shared resource. (Also see DirectX SDK: DXGI_SHARED_RESOURCE.Handle)

See Also

SharedResource Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SharedResource Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SharedResource Properties
SharedResource Structure See Also Send Feedback

The SharedResource type exposes the following members.

Properties

 | Name | Description
Public property | Handle | A handle to a shared resource. (Also see DirectX SDK: DXGI_SHARED_RESOURCE.Handle)

See Also

SharedResource Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Handle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SharedResource..::..Handle Property
SharedResource Structure See Also Send Feedback
A handle to a shared resource.

(Also see DirectX SDK: DXGI_SHARED_RESOURCE.Handle)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr Handle { get; set; }
Visual Basic
Public Property Handle As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr Handle {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

SharedResource Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Surface Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface Class
Members See Also Send Feedback
An Surface interface implements methods for image-data objects.

(Also see DirectX SDK: IDXGISurface)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Surface : DeviceSubObject
Visual Basic
Public Class Surface _
    Inherits DeviceSubObject
Visual C++
public ref class Surface : public DeviceSubObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..DeviceSubObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface1

See Also

Surface Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Surface Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface Members
Surface Class Methods Properties See Also Send Feedback

The Surface type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | Map | Get the data contained in the surface, and deny GPU access to the surface. (Also see DirectX SDK: IDXGISurface::Map)
Public method | Unmap | Invalidate the pointer to the surface retrieved by Surface.Map and re-enable GPU access to the resource. (Also see DirectX SDK: IDXGISurface::Unmap)

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | Description | Get a description of the surface. (Also see DirectX SDK: IDXGISurface::GetDesc)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Surface Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Surface Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface Methods
Surface Class See Also Send Feedback

The Surface type exposes the following members.

Methods

 | Name | Description
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | Map | Get the data contained in the surface, and deny GPU access to the surface. (Also see DirectX SDK: IDXGISurface::Map)
Public method | Unmap | Invalidate the pointer to the surface retrieved by Surface.Map and re-enable GPU access to the resource. (Also see DirectX SDK: IDXGISurface::Unmap)

See Also

Surface Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Map Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface..::..Map Method
Surface Class See Also Send Feedback
Get the data contained in the surface, and deny GPU access to the surface.

(Also see DirectX SDK: IDXGISurface::Map)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public MappedRect Map(
    MapOptions options
)
Visual Basic
Public Function Map ( _
    options As MapOptions _
) As MappedRect
Visual C++
public:
MappedRect Map(
    MapOptions options
)

Parameters

options
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..MapOptions
CPU read-write flags. These flags can be combined with a logical OR.

Return Value

The surface data (see MappedRect).

See Also

Surface Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..MappedRect


Unmap Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface..::..Unmap Method
Surface Class See Also Send Feedback
Invalidate the pointer to the surface retrieved by Surface.Map and re-enable GPU access to the resource.

(Also see DirectX SDK: IDXGISurface::Unmap)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Unmap()
Visual Basic
Public Sub Unmap
Visual C++
public:
void Unmap()

See Also

Surface Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Surface Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface Properties
Surface Class See Also Send Feedback

The Surface type exposes the following members.

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | Description | Get a description of the surface. (Also see DirectX SDK: IDXGISurface::GetDesc)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Surface Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface..::..Description Property
Surface Class See Also Send Feedback
Get a description of the surface.

(Also see DirectX SDK: IDXGISurface::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SurfaceDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As SurfaceDescription
    Get
Visual C++
public:
property SurfaceDescription Description {
    SurfaceDescription get ();
}

See Also

Surface Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Surface1 Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface1 Class
Members See Also Send Feedback
The Surface1 interface extends the Surface by adding support for rendering to a Graphics interface using GDI.

(Also see DirectX SDK: IDXGISurface1)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class Surface1 : Surface
Visual Basic
Public Class Surface1 _
    Inherits Surface
Visual C++
public ref class Surface1 : public Surface

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..DeviceSubObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Surface1

See Also

Surface1 Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Surface1 Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface1 Members
Surface1 Class Methods Properties See Also Send Feedback

The Surface1 type exposes the following members.

Methods

 | Name | Description
Public method | GetDC | Returns a device context (DC) that allows you to render to a Graphics surface using GDI. (Also see DirectX SDK: IDXGISurface1::GetDC)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | Map | Get the data contained in the surface, and deny GPU access to the surface. (Also see DirectX SDK: IDXGISurface::Map) (Inherited from Surface.)
Public method | ReleaseDC | Releases the GDI device context (DC) associated with the current surface and allows rendering using Direct3D. (Also see DirectX SDK: IDXGISurface1::ReleaseDC)
Public method | Unmap | Invalidate the pointer to the surface retrieved by Surface.Map and re-enable GPU access to the resource. (Also see DirectX SDK: IDXGISurface::Unmap) (Inherited from Surface.)

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | Description | Get a description of the surface. (Also see DirectX SDK: IDXGISurface::GetDesc) (Inherited from Surface.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Surface1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Surface1 Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface1 Methods
Surface1 Class See Also Send Feedback

The Surface1 type exposes the following members.

Methods

 | Name | Description
Public method | GetDC | Returns a device context (DC) that allows you to render to a Graphics surface using GDI. (Also see DirectX SDK: IDXGISurface1::GetDC)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | Map | Get the data contained in the surface, and deny GPU access to the surface. (Also see DirectX SDK: IDXGISurface::Map) (Inherited from Surface.)
Public method | ReleaseDC | Releases the GDI device context (DC) associated with the current surface and allows rendering using Direct3D. (Also see DirectX SDK: IDXGISurface1::ReleaseDC)
Public method | Unmap | Invalidate the pointer to the surface retrieved by Surface.Map and re-enable GPU access to the resource. (Also see DirectX SDK: IDXGISurface::Unmap) (Inherited from Surface.)

See Also

Surface1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetDC Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface1..::..GetDC Method
Surface1 Class See Also Send Feedback
Returns a device context (DC) that allows you to render to a Graphics surface using GDI.

(Also see DirectX SDK: IDXGISurface1::GetDC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr GetDC(
    bool discard
)
Visual Basic
Public Function GetDC ( _
    discard As Boolean _
) As IntPtr
Visual C++
public:
IntPtr GetDC(
    bool discard
)

Parameters

discard
Type: System..::..Boolean
If true the application will not preserve any rendering with GDI; otherwise, false. If false, any previous rendering to the device context will be preserved. This flag is ideal for simply reading the device context and not doing any rendering to the surface.

Return Value

A HDC handle that represents the current device context for GDI rendering.

See Also

Surface1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ReleaseDC Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface1..::..ReleaseDC Method
Surface1 Class See Also Send Feedback
Releases the GDI device context (DC) associated with the current surface and allows rendering using Direct3D.

(Also see DirectX SDK: IDXGISurface1::ReleaseDC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ReleaseDC(
    D3DRect dirtyRect
)
Visual Basic
Public Sub ReleaseDC ( _
    dirtyRect As D3DRect _
)
Visual C++
public:
void ReleaseDC(
    D3DRect dirtyRect
)

Parameters

dirtyRect
Type: Microsoft.WindowsAPICodePack.DirectX.Direct3D..::..D3DRect
A RECT structure that identifies the dirty region of the surface. A dirty region is any part of the surface that you have used for GDI rendering and that you want to preserve. This is used as a performance hint to graphics subsystem in certain scenarios. Do not use this parameter to restrict rendering to the specified rectangular region. Passing in NULL causes the whole surface to be considered dirty. Otherwise the area specified by the RECT will be used as a performance hint to indicate what areas have been manipulated by GDI rendering.

See Also

Surface1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Surface1 Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Surface1 Properties
Surface1 Class See Also Send Feedback

The Surface1 type exposes the following members.

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | Description | Get a description of the surface. (Also see DirectX SDK: IDXGISurface::GetDesc) (Inherited from Surface.)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

Surface1 Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SurfaceDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription Structure
Members See Also Send Feedback
Describes a surface.

(Also see DirectX SDK: DXGI_SURFACE_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SurfaceDescription
Visual Basic
Public Structure SurfaceDescription
Visual C++
public value class SurfaceDescription

See Also

SurfaceDescription Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SurfaceDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription Members
SurfaceDescription Structure Methods Operators Properties See Also Send Feedback

The SurfaceDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Format | A member of the Format enumerated type that describes the surface format. (Also see DirectX SDK: DXGI_SURFACE_DESC.Format)
Public property | Height | A value describing the surface height. (Also see DirectX SDK: DXGI_SURFACE_DESC.Height)
Public property | SampleDescription | A member of the SampleDescription structure that describes multi-sampling parameters for the surface. (Also see DirectX SDK: DXGI_SURFACE_DESC.SampleDesc)
Public property | Width | A value describing the surface width. (Also see DirectX SDK: DXGI_SURFACE_DESC.Width)

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SurfaceDescription Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription Methods
SurfaceDescription Structure See Also Send Feedback

The SurfaceDescription type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription..::..Equals Method
SurfaceDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription..::..GetHashCode Method
SurfaceDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SurfaceDescription Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription Operators
SurfaceDescription Structure See Also Send Feedback

The SurfaceDescription type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription..::..Equality Operator
SurfaceDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    SurfaceDescription surfaceDescription1,
    SurfaceDescription surfaceDescription2
)
Visual Basic
Public Shared Operator = ( _
    surfaceDescription1 As SurfaceDescription, _
    surfaceDescription2 As SurfaceDescription _
) As Boolean
Visual C++
public:
static bool operator ==(
    SurfaceDescription surfaceDescription1,
    SurfaceDescription surfaceDescription2
)

Parameters

surfaceDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SurfaceDescription
surfaceDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SurfaceDescription

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription..::..Inequality Operator
SurfaceDescription Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    SurfaceDescription surfaceDescription1,
    SurfaceDescription surfaceDescription2
)
Visual Basic
Public Shared Operator <> ( _
    surfaceDescription1 As SurfaceDescription, _
    surfaceDescription2 As SurfaceDescription _
) As Boolean
Visual C++
public:
static bool operator !=(
    SurfaceDescription surfaceDescription1,
    SurfaceDescription surfaceDescription2
)

Parameters

surfaceDescription1
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SurfaceDescription
surfaceDescription2
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SurfaceDescription

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SurfaceDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription Properties
SurfaceDescription Structure See Also Send Feedback

The SurfaceDescription type exposes the following members.

Properties

 | Name | Description
Public property | Format | A member of the Format enumerated type that describes the surface format. (Also see DirectX SDK: DXGI_SURFACE_DESC.Format)
Public property | Height | A value describing the surface height. (Also see DirectX SDK: DXGI_SURFACE_DESC.Height)
Public property | SampleDescription | A member of the SampleDescription structure that describes multi-sampling parameters for the surface. (Also see DirectX SDK: DXGI_SURFACE_DESC.SampleDesc)
Public property | Width | A value describing the surface width. (Also see DirectX SDK: DXGI_SURFACE_DESC.Width)

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Format Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription..::..Format Property
SurfaceDescription Structure See Also Send Feedback
A member of the Format enumerated type that describes the surface format.

(Also see DirectX SDK: DXGI_SURFACE_DESC.Format)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Format Format { get; set; }
Visual Basic
Public Property Format As Format
    Get
    Set
Visual C++
public:
property Format Format {
    Format get ();
    void set (Format value);
}

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription..::..Height Property
SurfaceDescription Structure See Also Send Feedback
A value describing the surface height.

(Also see DirectX SDK: DXGI_SURFACE_DESC.Height)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SampleDescription Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription..::..SampleDescription Property
SurfaceDescription Structure See Also Send Feedback
A member of the SampleDescription structure that describes multi-sampling parameters for the surface.

(Also see DirectX SDK: DXGI_SURFACE_DESC.SampleDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SampleDescription SampleDescription { get; set; }
Visual Basic
Public Property SampleDescription As SampleDescription
    Get
    Set
Visual C++
public:
property SampleDescription SampleDescription {
    SampleDescription get ();
    void set (SampleDescription value);
}

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SurfaceDescription..::..Width Property
SurfaceDescription Structure See Also Send Feedback
A value describing the surface width.

(Also see DirectX SDK: DXGI_SURFACE_DESC.Width)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SurfaceDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapChain Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain Class
Members See Also Send Feedback
An SwapChain interface implements one or more surfaces for storing rendered data before presenting it to an output.

(Also see DirectX SDK: IDXGISwapChain)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class SwapChain : DeviceSubObject
Visual Basic
Public Class SwapChain _
    Inherits DeviceSubObject
Visual C++
public ref class SwapChain : public DeviceSubObject

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..GraphicsObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..DeviceSubObject
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChain

See Also

SwapChain Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapChain Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain Members
SwapChain Class Methods Properties See Also Send Feedback

The SwapChain type exposes the following members.

Methods

 | Name | Description
Public method | GetBuffer<(Of <<'(T>)>>) | Access one of the swap-chain back buffers. (Also see DirectX SDK: IDXGISwapChain::GetBuffer)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | Present | Present a rendered image to the user. This method can throw exceptions if the Swap Chain is unable to present. TryPresent() method should be used instead when exceptions can impact performance. (Also see DirectX SDK: IDXGISwapChain::Present)
Public method | ResizeBuffers | Change the swap chain's back buffer size, format, and number of buffers. This should be called when the application window is resized. (Also see DirectX SDK: IDXGISwapChain::ResizeBuffers)
Public method | ResizeTarget | Resize the output target. (Also see DirectX SDK: IDXGISwapChain::ResizeTarget)
Public method | SetFullScreenState | Set the display mode to windowed or full-screen. (Also see DirectX SDK: IDXGISwapChain::SetFullscreenState)
Public method | TryPresent | Try to present a rendered image to the user. No exceptions will be thrown by this method. (Also see DirectX SDK: IDXGISwapChain::Present)
Public method | TryResizeBuffers | Change the swap chain's back buffer size, format, and number of buffers. This should be called when the application window is resized. This method will not throw exceptions, but will return a bool indicating success or failure. The errorCode output value can also be used to track the error type. (Also see DirectX SDK: IDXGISwapChain::ResizeBuffers)

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | ContainingOutput | Get the output (the display monitor) that contains the majority of the client area of the target window. (Also see DirectX SDK: IDXGISwapChain::GetContainingOutput)
Public property | Description | Get a description of the swap chain. (Also see DirectX SDK: IDXGISwapChain::GetDesc)
Public property | FrameStatistics | Get performance statistics about the last render frame. (Also see DirectX SDK: IDXGISwapChain::GetFrameStatistics)
Public property | FullScreenOutput | Gets the Output object associated with full-screen mode. (Also see DirectX SDK: IDXGISwapChain::GetFullscreenState)
Public property | IsFullScreen | Sets or get the swap chain in full screen. Graphics will choose the output based on the swap-chain's device and the output window's placement. (Also see DirectX SDK: IDXGISwapChain::GetFullscreenState)
Public property | LastPresentCount | Get the number of times SwapChain.Present has been called. (Also see DirectX SDK: IDXGISwapChain::GetLastPresentCount)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapChain Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain Methods
SwapChain Class See Also Send Feedback

The SwapChain type exposes the following members.

Methods

 | Name | Description
Public method | GetBuffer<(Of <<'(T>)>>) | Access one of the swap-chain back buffers. (Also see DirectX SDK: IDXGISwapChain::GetBuffer)
Public method | GetParent<(Of <<'(T>)>>) | Gets the parent of this object. (Also see DirectX SDK: IDXGIObject::GetParent) (Inherited from GraphicsObject.)
Public method | Present | Present a rendered image to the user. This method can throw exceptions if the Swap Chain is unable to present. TryPresent() method should be used instead when exceptions can impact performance. (Also see DirectX SDK: IDXGISwapChain::Present)
Public method | ResizeBuffers | Change the swap chain's back buffer size, format, and number of buffers. This should be called when the application window is resized. (Also see DirectX SDK: IDXGISwapChain::ResizeBuffers)
Public method | ResizeTarget | Resize the output target. (Also see DirectX SDK: IDXGISwapChain::ResizeTarget)
Public method | SetFullScreenState | Set the display mode to windowed or full-screen. (Also see DirectX SDK: IDXGISwapChain::SetFullscreenState)
Public method | TryPresent | Try to present a rendered image to the user. No exceptions will be thrown by this method. (Also see DirectX SDK: IDXGISwapChain::Present)
Public method | TryResizeBuffers | Change the swap chain's back buffer size, format, and number of buffers. This should be called when the application window is resized. This method will not throw exceptions, but will return a bool indicating success or failure. The errorCode output value can also be used to track the error type. (Also see DirectX SDK: IDXGISwapChain::ResizeBuffers)

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


GetBuffer(T) Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..GetBuffer<(Of <(<'T>)>)> Method
SwapChain Class See Also Send Feedback
Access one of the swap-chain back buffers.

(Also see DirectX SDK: IDXGISwapChain::GetBuffer)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public T GetBuffer<T>(
    uint bufferIndex
)
where T : DirectUnknown
Visual Basic
Public Function GetBuffer(Of T As DirectUnknown) ( _
    bufferIndex As UInteger _
) As T
Visual C++
public:
generic<typename T>
where T : DirectUnknown
T GetBuffer(
    unsigned int bufferIndex
)

Parameters

bufferIndex
Type: System..::..UInt32
A zero-based buffer index. If the swap effect is not Sequential, this method only has access to the first buffer; for this case, set the index to zero.

Type Parameters

T
The type of the buffer object. Must inherit from DirectUnknown.

Return Value

The back-buffer object.

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Present Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..Present Method
SwapChain Class See Also Send Feedback
Present a rendered image to the user. This method can throw exceptions if the Swap Chain is unable to present. TryPresent() method should be used instead when exceptions can impact performance.

(Also see DirectX SDK: IDXGISwapChain::Present)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Present(
    uint syncInterval,
    PresentOptions options
)
Visual Basic
Public Sub Present ( _
    syncInterval As UInteger, _
    options As PresentOptions _
)
Visual C++
public:
void Present(
    unsigned int syncInterval,
    PresentOptions options
)

Parameters

syncInterval
Type: System..::..UInt32
If the update region straddles more than one output (each represented by Output), the synchronization will be performed to the output that contains the largest subrectangle of the target window's client area.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..PresentOptions
An integer value that contains swap-chain presentation options (see Present(UInt32, PresentOptions)).

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
SwapChain..::..Present(UInt32, PresentOptions)


ResizeBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..ResizeBuffers Method
SwapChain Class See Also Send Feedback
Change the swap chain's back buffer size, format, and number of buffers. This should be called when the application window is resized.

(Also see DirectX SDK: IDXGISwapChain::ResizeBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ResizeBuffers(
    uint bufferCount,
    uint width,
    uint height,
    Format newFormat,
    SwapChainOptions options
)
Visual Basic
Public Sub ResizeBuffers ( _
    bufferCount As UInteger, _
    width As UInteger, _
    height As UInteger, _
    newFormat As Format, _
    options As SwapChainOptions _
)
Visual C++
public:
void ResizeBuffers(
    unsigned int bufferCount,
    unsigned int width,
    unsigned int height,
    Format newFormat,
    SwapChainOptions options
)

Parameters

bufferCount
Type: System..::..UInt32
The number of buffers in the swap chain (including all back and front buffers). This can be different from the number of buffers the swap chain was created with.
width
Type: System..::..UInt32
New width of the back buffer. If 0 is specified the width of the client area of the target window will be used.
height
Type: System..::..UInt32
New height of the back buffer. If 0 is specified the height of the client area of the target window will be used.
newFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
The new format of the back buffer.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChainOptions
Flags that indicate how the swap chain will function.

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ResizeTarget Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..ResizeTarget Method
SwapChain Class See Also Send Feedback
Resize the output target.

(Also see DirectX SDK: IDXGISwapChain::ResizeTarget)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void ResizeTarget(
    ModeDescription newTargetParameters
)
Visual Basic
Public Sub ResizeTarget ( _
    newTargetParameters As ModeDescription _
)
Visual C++
public:
void ResizeTarget(
    ModeDescription newTargetParameters
)

Parameters

newTargetParameters
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription
The mode description (see ModeDescription), which specifies the new width, height, format and refresh rate of the target. If the format is UNKNOWN, the existing format will be used. Using UNKNOWN is only recommended when the swap chain is in full-screen mode as this method is not thread safe.

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..ModeDescription


SetFullScreenState Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..SetFullScreenState Method
SwapChain Class See Also Send Feedback
Set the display mode to windowed or full-screen.

(Also see DirectX SDK: IDXGISwapChain::SetFullscreenState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SetFullScreenState(
    bool isFullScreen,
    Output target
)
Visual Basic
Public Sub SetFullScreenState ( _
    isFullScreen As Boolean, _
    target As Output _
)
Visual C++
public:
void SetFullScreenState(
    bool isFullScreen,
    Output^ target
)

Parameters

isFullScreen
Type: System..::..Boolean
Use True for full-screen, False for windowed.
target
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Output
If the current display mode is full-screen, this parameter must be the output target (see Output) that contains the swap chain; otherwise, this parameter is ignored. If you set this parameter to Null, Graphics will choose the output based on the swap-chain's device and the output window's placement.

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Output


TryPresent Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..TryPresent Method
SwapChain Class See Also Send Feedback
Try to present a rendered image to the user. No exceptions will be thrown by this method.

(Also see DirectX SDK: IDXGISwapChain::Present)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool TryPresent(
    uint syncInterval,
    PresentOptions options,
    out ErrorCode error
)
Visual Basic
Public Function TryPresent ( _
    syncInterval As UInteger, _
    options As PresentOptions, _
    <OutAttribute> ByRef error As ErrorCode _
) As Boolean
Visual C++
public:
bool TryPresent(
    unsigned int syncInterval,
    PresentOptions options,
    [OutAttribute] ErrorCode% error
)

Parameters

syncInterval
Type: System..::..UInt32
If the update region straddles more than one output (each represented by Output), the synchronization will be performed to the output that contains the largest subrectangle of the target window's client area.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..PresentOptions
An integer value that contains swap-chain presentation options (see Present(UInt32, PresentOptions)).
error
Type: Microsoft.WindowsAPICodePack.DirectX..::..ErrorCode %
An error code indicating Present error if unsuccessful.

Return Value

False if unsuccessful; True otherwise.

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace
SwapChain..::..Present(UInt32, PresentOptions)


TryResizeBuffers Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..TryResizeBuffers Method
SwapChain Class See Also Send Feedback
Change the swap chain's back buffer size, format, and number of buffers. This should be called when the application window is resized. This method will not throw exceptions, but will return a bool indicating success or failure. The errorCode output value can also be used to track the error type.

(Also see DirectX SDK: IDXGISwapChain::ResizeBuffers)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool TryResizeBuffers(
    uint bufferCount,
    uint width,
    uint height,
    Format newFormat,
    SwapChainOptions options,
    out ErrorCode errorCode
)
Visual Basic
Public Function TryResizeBuffers ( _
    bufferCount As UInteger, _
    width As UInteger, _
    height As UInteger, _
    newFormat As Format, _
    options As SwapChainOptions, _
    <OutAttribute> ByRef errorCode As ErrorCode _
) As Boolean
Visual C++
public:
bool TryResizeBuffers(
    unsigned int bufferCount,
    unsigned int width,
    unsigned int height,
    Format newFormat,
    SwapChainOptions options,
    [OutAttribute] ErrorCode% errorCode
)

Parameters

bufferCount
Type: System..::..UInt32
The number of buffers in the swap chain (including all back and front buffers). This can be different from the number of buffers the swap chain was created with.
width
Type: System..::..UInt32
New width of the back buffer. If 0 is specified the width of the client area of the target window will be used.
height
Type: System..::..UInt32
New height of the back buffer. If 0 is specified the height of the client area of the target window will be used.
newFormat
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..Format
The new format of the back buffer.
options
Type: Microsoft.WindowsAPICodePack.DirectX.Graphics..::..SwapChainOptions
Flags that indicate how the swap chain will function.
errorCode
Type: Microsoft.WindowsAPICodePack.DirectX..::..ErrorCode %
Returned error code.

Return Value

True if successful, false otherwise.

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapChain Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain Properties
SwapChain Class See Also Send Feedback

The SwapChain type exposes the following members.

Properties

 | Name | Description
Public property | AsDirect3D10Device | Retrieves the device as Direct3D 10 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D10Device1 | Retrieves the device as Direct3D 10.1 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsDirect3D11Device | Retrieves the device as Direct3D 11 device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | AsGraphicsDevice | Retrieves the device as Graphics device. (Also see DirectX SDK: IDXGIDeviceSubObject::GetDevice) (Inherited from DeviceSubObject.)
Public property | ContainingOutput | Get the output (the display monitor) that contains the majority of the client area of the target window. (Also see DirectX SDK: IDXGISwapChain::GetContainingOutput)
Public property | Description | Get a description of the swap chain. (Also see DirectX SDK: IDXGISwapChain::GetDesc)
Public property | FrameStatistics | Get performance statistics about the last render frame. (Also see DirectX SDK: IDXGISwapChain::GetFrameStatistics)
Public property | FullScreenOutput | Gets the Output object associated with full-screen mode. (Also see DirectX SDK: IDXGISwapChain::GetFullscreenState)
Public property | IsFullScreen | Sets or get the swap chain in full screen. Graphics will choose the output based on the swap-chain's device and the output window's placement. (Also see DirectX SDK: IDXGISwapChain::GetFullscreenState)
Public property | LastPresentCount | Get the number of times SwapChain.Present has been called. (Also see DirectX SDK: IDXGISwapChain::GetLastPresentCount)
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


ContainingOutput Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..ContainingOutput Property
SwapChain Class See Also Send Feedback
Get the output (the display monitor) that contains the majority of the client area of the target window.

(Also see DirectX SDK: IDXGISwapChain::GetContainingOutput)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Output ContainingOutput { get; }
Visual Basic
Public ReadOnly Property ContainingOutput As Output
    Get
Visual C++
public:
property Output^ ContainingOutput {
    Output^ get ();
}

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Description Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..Description Property
SwapChain Class See Also Send Feedback
Get a description of the swap chain.

(Also see DirectX SDK: IDXGISwapChain::GetDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwapChainDescription Description { get; }
Visual Basic
Public ReadOnly Property Description As SwapChainDescription
    Get
Visual C++
public:
property SwapChainDescription Description {
    SwapChainDescription get ();
}

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FrameStatistics Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..FrameStatistics Property
SwapChain Class See Also Send Feedback
Get performance statistics about the last render frame.

(Also see DirectX SDK: IDXGISwapChain::GetFrameStatistics)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FrameStatistics FrameStatistics { get; }
Visual Basic
Public ReadOnly Property FrameStatistics As FrameStatistics
    Get
Visual C++
public:
property FrameStatistics FrameStatistics {
    FrameStatistics get ();
}

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


FullScreenOutput Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..FullScreenOutput Property
SwapChain Class See Also Send Feedback
Gets the Output object associated with full-screen mode.

(Also see DirectX SDK: IDXGISwapChain::GetFullscreenState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Output FullScreenOutput { get; }
Visual Basic
Public ReadOnly Property FullScreenOutput As Output
    Get
Visual C++
public:
property Output^ FullScreenOutput {
    Output^ get ();
}

Return Value

If the swap chain is in full-screen mode, returns the output target. Otherwise, null.

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


IsFullScreen Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..IsFullScreen Property
SwapChain Class See Also Send Feedback
Sets or get the swap chain in full screen. Graphics will choose the output based on the swap-chain's device and the output window's placement.

(Also see DirectX SDK: IDXGISwapChain::GetFullscreenState)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool IsFullScreen { get; set; }
Visual Basic
Public Property IsFullScreen As Boolean
    Get
    Set
Visual C++
public:
property bool IsFullScreen {
    bool get ();
    void set (bool value);
}

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


LastPresentCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChain..::..LastPresentCount Property
SwapChain Class See Also Send Feedback
Get the number of times SwapChain.Present has been called.

(Also see DirectX SDK: IDXGISwapChain::GetLastPresentCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint LastPresentCount { get; }
Visual Basic
Public ReadOnly Property LastPresentCount As UInteger
    Get
Visual C++
public:
property unsigned int LastPresentCount {
    unsigned int get ();
}

See Also

SwapChain Class
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapChainDescription Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription Structure
Members See Also Send Feedback
Describes a swap chain.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct SwapChainDescription
Visual Basic
Public Structure SwapChainDescription
Visual C++
public value class SwapChainDescription

See Also

SwapChainDescription Members
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapChainDescription Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription Members
SwapChainDescription Structure Properties See Also Send Feedback

The SwapChainDescription type exposes the following members.

Properties

 | Name | Description
Public property | BufferCount | A value that describes the number of buffers in the swap chain, including the front buffer. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.BufferCount)
Public property | BufferDescription | A ModeDescription structure describing the backbuffer display mode. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.BufferDesc)
Public property | BufferUsage | A member of the UsageOptions enumerated type describing the surface usage and CPU access options for the back buffer. The back buffer can be used for shader input or render-target output. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.BufferUsage)
Public property | Options | A member of the SwapChainOptions enumerated type that describes options for swap-chain behavior. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.Flags)
Public property | OutputWindowHandle | An HWND handle to the output window. This member must a valid window handle. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.OutputWindow)
Public property | SampleDescription | A SampleDescription structure describing multi-sampling parameters. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.SampleDesc)
Public property | SwapEffect | A member of the SwapEffect enumerated type that describes options for handling the contents of the presentation buffer after presenting a surface. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.SwapEffect)
Public property | Windowed | True if the output is in windowed mode; otherwise, false. For more information, see Factory.CreateSwapChain. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.Windowed)

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapChainDescription Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription Properties
SwapChainDescription Structure See Also Send Feedback

The SwapChainDescription type exposes the following members.

Properties

 | Name | Description
Public property | BufferCount | A value that describes the number of buffers in the swap chain, including the front buffer. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.BufferCount)
Public property | BufferDescription | A ModeDescription structure describing the backbuffer display mode. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.BufferDesc)
Public property | BufferUsage | A member of the UsageOptions enumerated type describing the surface usage and CPU access options for the back buffer. The back buffer can be used for shader input or render-target output. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.BufferUsage)
Public property | Options | A member of the SwapChainOptions enumerated type that describes options for swap-chain behavior. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.Flags)
Public property | OutputWindowHandle | An HWND handle to the output window. This member must a valid window handle. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.OutputWindow)
Public property | SampleDescription | A SampleDescription structure describing multi-sampling parameters. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.SampleDesc)
Public property | SwapEffect | A member of the SwapEffect enumerated type that describes options for handling the contents of the presentation buffer after presenting a surface. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.SwapEffect)
Public property | Windowed | True if the output is in windowed mode; otherwise, false. For more information, see Factory.CreateSwapChain. (Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.Windowed)

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


BufferCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription..::..BufferCount Property
SwapChainDescription Structure See Also Send Feedback
A value that describes the number of buffers in the swap chain, including the front buffer.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.BufferCount)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint BufferCount { get; set; }
Visual Basic
Public Property BufferCount As UInteger
    Get
    Set
Visual C++
public:
property unsigned int BufferCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


BufferDescription Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription..::..BufferDescription Property
SwapChainDescription Structure See Also Send Feedback
A ModeDescription structure describing the backbuffer display mode.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.BufferDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ModeDescription BufferDescription { get; set; }
Visual Basic
Public Property BufferDescription As ModeDescription
    Get
    Set
Visual C++
public:
property ModeDescription BufferDescription {
    ModeDescription get ();
    void set (ModeDescription value);
}

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


BufferUsage Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription..::..BufferUsage Property
SwapChainDescription Structure See Also Send Feedback
A member of the UsageOptions enumerated type describing the surface usage and CPU access options for the back buffer. The back buffer can be used for shader input or render-target output.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.BufferUsage)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public UsageOptions BufferUsage { get; set; }
Visual Basic
Public Property BufferUsage As UsageOptions
    Get
    Set
Visual C++
public:
property UsageOptions BufferUsage {
    UsageOptions get ();
    void set (UsageOptions value);
}

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Options Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription..::..Options Property
SwapChainDescription Structure See Also Send Feedback
A member of the SwapChainOptions enumerated type that describes options for swap-chain behavior.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.Flags)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwapChainOptions Options { get; set; }
Visual Basic
Public Property Options As SwapChainOptions
    Get
    Set
Visual C++
public:
property SwapChainOptions Options {
    SwapChainOptions get ();
    void set (SwapChainOptions value);
}

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


OutputWindowHandle Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription..::..OutputWindowHandle Property
SwapChainDescription Structure See Also Send Feedback
An HWND handle to the output window. This member must a valid window handle.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.OutputWindow)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr OutputWindowHandle { get; set; }
Visual Basic
Public Property OutputWindowHandle As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr OutputWindowHandle {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SampleDescription Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription..::..SampleDescription Property
SwapChainDescription Structure See Also Send Feedback
A SampleDescription structure describing multi-sampling parameters.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.SampleDesc)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SampleDescription SampleDescription { get; set; }
Visual Basic
Public Property SampleDescription As SampleDescription
    Get
    Set
Visual C++
public:
property SampleDescription SampleDescription {
    SampleDescription get ();
    void set (SampleDescription value);
}

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapEffect Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription..::..SwapEffect Property
SwapChainDescription Structure See Also Send Feedback
A member of the SwapEffect enumerated type that describes options for handling the contents of the presentation buffer after presenting a surface.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.SwapEffect)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public SwapEffect SwapEffect { get; set; }
Visual Basic
Public Property SwapEffect As SwapEffect
    Get
    Set
Visual C++
public:
property SwapEffect SwapEffect {
    SwapEffect get ();
    void set (SwapEffect value);
}

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Windowed Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainDescription..::..Windowed Property
SwapChainDescription Structure See Also Send Feedback
True if the output is in windowed mode; otherwise, false. For more information, see Factory.CreateSwapChain.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_DESC.Windowed)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public bool Windowed { get; set; }
Visual Basic
Public Property Windowed As Boolean
    Get
    Set
Visual C++
public:
property bool Windowed {
    bool get ();
    void set (bool value);
}

See Also

SwapChainDescription Structure
Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapChainOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapChainOptions Enumeration
See Also Send Feedback
Options for swap-chain behavior.

(Also see DirectX SDK: DXGI_SWAP_CHAIN_FLAG)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum SwapChainOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration SwapChainOptions
Visual C++
[FlagsAttribute]
public enum class SwapChainOptions

Members

Member name | Description
GdiCompatible |
AllowModeSwitch |
NonPrerotated |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


SwapEffect Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
SwapEffect Enumeration
See Also Send Feedback
Options for handling pixels in a display surface after calling SwapChain.Present.

(Also see DirectX SDK: DXGI_SWAP_EFFECT)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum SwapEffect
Visual Basic
Public Enumeration SwapEffect
Visual C++
public enum class SwapEffect

Members

Member name | Description
Sequential |
Discard |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


UsageOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
UsageOptions Enumeration
See Also Send Feedback
Flags for surface and resource creation options.

(Also see DirectX SDK: DXGI_USAGE)

Namespace: Microsoft.WindowsAPICodePack.DirectX.Graphics
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum UsageOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration UsageOptions
Visual C++
[FlagsAttribute]
public enum class UsageOptions

Members

Member name | Description
None |
Shared |
ShaderInput |
RenderTargetOutput |
ReadOnly |
DiscardOnPresent |
BackBuffer |

See Also

Microsoft.WindowsAPICodePack.DirectX.Graphics Namespace


Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace
Send Feedback
Windows Imaging Component (WIC) APIs and Types.

Classes

 | Class | Description
Public class | BitmapDecoder | Exposes methods that represent a decoder. Provides access to a decoder's frames. (Also see IWICBitmapDecoder interface)
Public class | BitmapFrameDecode | Defines methods for decoding individual image frames of an encoded file. (Also see IWICBitmapFrameDecode interface)
Public class | BitmapSource | Exposes methods that refers to a source from which pixels are retrieved, but cannot be written back to. (Also see IWICBitmapSource interface)
Public class | ContainerFormats | Container formats supported by the Windows Imaging Component.
Public class | FormatConverter | Exposes methods that represent a pixel format converter. This class provides the means of converting from one pixel format to another, handling dithering and halftoning to indexed formats, palette translation and alpha thresholding. (Also see IWICFormatConverter interface)
Public class | ImagingBitmap | Defines methods that add the concept of writeability and static in-memory representations of bitmaps to WICBitmapSource. (Also see IWICBitmap interface)
Public class | ImagingBitmapLock | Defines methods that add the concept of writeability and static in-memory representations of bitmaps to WICBitmapSource. (Also see IWICBitmap interface)
Public class | ImagingException | An exception thrown by a WIC (Windows Imaging Component) method.
Public class | ImagingFactory | Exposes methods used to create components for the Microsoft Windows Imaging Component (WIC) such as decoders, encoders and pixel format converters. (Also see IWICImagingFactory interface)
Public class | PixelFormats | A listing of pixel formats supported by the Windows Imaging Component.
Public class | StreamWrapper | This is an object that provides a managed System.IO.Stream object with a COM IStream implementation.

Structures

 | Structure | Description
Public structure | BitmapRectangle | Describes a rectangle of bitmap data.
Public structure | BitmapResolution | Describes dots per inch resolution of the bitmap.
Public structure | BitmapSize | Describes size of the bitmap.

Enumerations

 | Enumeration | Description
Public enumeration | BitmapCreateCacheOption | Specifies the desired cache usage for a ImagingBitmap.
Public enumeration | BitmapDitherType | Specifies the type of dither algorithm to apply when converting between image formats. (Also see WICBitmapDitherType Enumerated Type)
Public enumeration | BitmapLockOptions | Specifies access to a ImagingBitmap.
Public enumeration | BitmapPaletteType | Specifies the type of palette used for an indexed image format. (Also see WICBitmapPaletteType Enumerated Type)
Public enumeration | DecodeMetadataCacheOption | Specifies image decode options. (Also see WICDecodeOptions Enumerated Type)
Public enumeration | DesiredAccess | Describes the reading mode for WICImagingFactory.CreateDecoderFromFilename


BitmapCreateCacheOption Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapCreateCacheOption Enumeration
See Also Send Feedback
Specifies the desired cache usage for a ImagingBitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum BitmapCreateCacheOption
Visual Basic
Public Enumeration BitmapCreateCacheOption
Visual C++
public enum class BitmapCreateCacheOption

Members

Member name | Description
CacheOnLoad |
CacheOnDemand |
NoCache |

See Also

Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapDecoder Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapDecoder Class
Members See Also Send Feedback
Exposes methods that represent a decoder. Provides access to a decoder's frames.

(Also see IWICBitmapDecoder interface)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class BitmapDecoder : DirectUnknown
Visual Basic
Public Class BitmapDecoder _
    Inherits DirectUnknown
Visual C++
public ref class BitmapDecoder : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapDecoder

See Also

BitmapDecoder Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapDecoder Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapDecoder Members
BitmapDecoder Class Methods Properties See Also Send Feedback

The BitmapDecoder type exposes the following members.

Methods

 | Name | Description
Public method | GetFrame | Retrieves the specified frame of the image.

Properties

 | Name | Description
Public property | FrameCount | The total number of frames in the image.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BitmapDecoder Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapDecoder Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapDecoder Methods
BitmapDecoder Class See Also Send Feedback

The BitmapDecoder type exposes the following members.

Methods

 | Name | Description
Public method | GetFrame | Retrieves the specified frame of the image.

See Also

BitmapDecoder Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


GetFrame Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapDecoder..::..GetFrame Method
BitmapDecoder Class See Also Send Feedback
Retrieves the specified frame of the image.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapFrameDecode GetFrame(
    uint index
)
Visual Basic
Public Function GetFrame ( _
    index As UInteger _
) As BitmapFrameDecode
Visual C++
public:
BitmapFrameDecode^ GetFrame(
    unsigned int index
)

Parameters

index
Type: System..::..UInt32
The particular frame to retrieve.

See Also

BitmapDecoder Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapDecoder Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapDecoder Properties
BitmapDecoder Class See Also Send Feedback

The BitmapDecoder type exposes the following members.

Properties

 | Name | Description
Public property | FrameCount | The total number of frames in the image.
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BitmapDecoder Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FrameCount Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapDecoder..::..FrameCount Property
BitmapDecoder Class See Also Send Feedback
The total number of frames in the image.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint FrameCount { get; }
Visual Basic
Public ReadOnly Property FrameCount As UInteger
    Get
Visual C++
public:
property unsigned int FrameCount {
    unsigned int get ();
}

See Also

BitmapDecoder Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapDitherType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapDitherType Enumeration
See Also Send Feedback
Specifies the type of dither algorithm to apply when converting between image formats.

(Also see WICBitmapDitherType Enumerated Type)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum BitmapDitherType
Visual Basic
Public Enumeration BitmapDitherType
Visual C++
public enum class BitmapDitherType

Members

Member name | Description
ErrorDiffusion |
DualSpiral8x8 |
DualSpiral4x4 |
Spiral8x8 |
Spiral4x4 |
Ordered16x16 |
Ordered8x8 |
Ordered4x4 |
Solid |
None |

See Also

Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapFrameDecode Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapFrameDecode Class
Members See Also Send Feedback
Defines methods for decoding individual image frames of an encoded file.

(Also see IWICBitmapFrameDecode interface)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class BitmapFrameDecode : DirectUnknown
Visual Basic
Public Class BitmapFrameDecode _
    Inherits DirectUnknown
Visual C++
public ref class BitmapFrameDecode : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapFrameDecode

See Also

BitmapFrameDecode Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapFrameDecode Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapFrameDecode Members
BitmapFrameDecode Class Methods Properties See Also Send Feedback

The BitmapFrameDecode type exposes the following members.

Methods

 | Name | Description
Public method | ToBitmapSource | Returns the BitmapSource of a particular BitmapFrameDecode.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BitmapFrameDecode Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapFrameDecode Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapFrameDecode Methods
BitmapFrameDecode Class See Also Send Feedback

The BitmapFrameDecode type exposes the following members.

Methods

 | Name | Description
Public method | ToBitmapSource | Returns the BitmapSource of a particular BitmapFrameDecode.

See Also

BitmapFrameDecode Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ToBitmapSource Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapFrameDecode..::..ToBitmapSource Method
BitmapFrameDecode Class See Also Send Feedback
Returns the BitmapSource of a particular BitmapFrameDecode.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapSource ToBitmapSource()
Visual Basic
Public Function ToBitmapSource As BitmapSource
Visual C++
public:
BitmapSource^ ToBitmapSource()

See Also

BitmapFrameDecode Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapFrameDecode Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapFrameDecode Properties
BitmapFrameDecode Class See Also Send Feedback

The BitmapFrameDecode type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

BitmapFrameDecode Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapLockOptions Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapLockOptions Enumeration
See Also Send Feedback
Specifies access to a ImagingBitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum BitmapLockOptions
Visual Basic
<FlagsAttribute> _
Public Enumeration BitmapLockOptions
Visual C++
[FlagsAttribute]
public enum class BitmapLockOptions

Members

Member name | Description
Write |
Read |

See Also

Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapPaletteType Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapPaletteType Enumeration
See Also Send Feedback
Specifies the type of palette used for an indexed image format.

(Also see WICBitmapPaletteType Enumerated Type)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum BitmapPaletteType
Visual Basic
Public Enumeration BitmapPaletteType
Visual C++
public enum class BitmapPaletteType

Members

Member name | Description
FixedGray256 |
FixedGray16 |
FixedGray4 |
FixedHalftone256 |
FixedHalftone252 |
FixedWebPalette |
FixedHalftone216 |
FixedHalftone125 |
FixedHalftone64 |
FixedHalftone27 |
FixedHalftone8 |
FixedBW |
MedianCut |
Custom |

See Also

Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapRectangle Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle Structure
Members See Also Send Feedback
Describes a rectangle of bitmap data.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BitmapRectangle
Visual Basic
Public Structure BitmapRectangle
Visual C++
public value class BitmapRectangle

See Also

BitmapRectangle Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapRectangle Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle Members
BitmapRectangle Structure Constructors Methods Operators Properties See Also Send Feedback

The BitmapRectangle type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapRectangle | Constructor.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Height | The height of the rectangle.
Public property | Width | The width of the rectangle.
Public property | X | The horizontal component of the top left corner of the rectangle.
Public property | Y | The vertical component of the top left corner of the rectangle.

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapRectangle Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle Constructor
BitmapRectangle Structure See Also Send Feedback
Constructor.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapRectangle(
    int x,
    int y,
    int width,
    int height
)
Visual Basic
Public Sub New ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
BitmapRectangle(
    int x,
    int y,
    int width,
    int height
)

Parameters

x
Type: System..::..Int32
y
Type: System..::..Int32
width
Type: System..::..Int32
height
Type: System..::..Int32

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapRectangle Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle Methods
BitmapRectangle Structure See Also Send Feedback

The BitmapRectangle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle..::..Equals Method
BitmapRectangle Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle..::..GetHashCode Method
BitmapRectangle Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapRectangle Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle Operators
BitmapRectangle Structure See Also Send Feedback

The BitmapRectangle type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle..::..Equality Operator
BitmapRectangle Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BitmapRectangle bitmapRectangle1,
    BitmapRectangle bitmapRectangle2
)
Visual Basic
Public Shared Operator = ( _
    bitmapRectangle1 As BitmapRectangle, _
    bitmapRectangle2 As BitmapRectangle _
) As Boolean
Visual C++
public:
static bool operator ==(
    BitmapRectangle bitmapRectangle1,
    BitmapRectangle bitmapRectangle2
)

Parameters

bitmapRectangle1
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapRectangle
bitmapRectangle2
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapRectangle

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle..::..Inequality Operator
BitmapRectangle Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BitmapRectangle bitmapRectangle1,
    BitmapRectangle bitmapRectangle2
)
Visual Basic
Public Shared Operator <> ( _
    bitmapRectangle1 As BitmapRectangle, _
    bitmapRectangle2 As BitmapRectangle _
) As Boolean
Visual C++
public:
static bool operator !=(
    BitmapRectangle bitmapRectangle1,
    BitmapRectangle bitmapRectangle2
)

Parameters

bitmapRectangle1
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapRectangle
bitmapRectangle2
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapRectangle

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapRectangle Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle Properties
BitmapRectangle Structure See Also Send Feedback

The BitmapRectangle type exposes the following members.

Properties

 | Name | Description
Public property | Height | The height of the rectangle.
Public property | Width | The width of the rectangle.
Public property | X | The horizontal component of the top left corner of the rectangle.
Public property | Y | The vertical component of the top left corner of the rectangle.

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle..::..Height Property
BitmapRectangle Structure See Also Send Feedback
The height of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle..::..Width Property
BitmapRectangle Structure See Also Send Feedback
The width of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


X Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle..::..X Property
BitmapRectangle Structure See Also Send Feedback
The horizontal component of the top left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int X { get; set; }
Visual Basic
Public Property X As Integer
    Get
    Set
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Y Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapRectangle..::..Y Property
BitmapRectangle Structure See Also Send Feedback
The vertical component of the top left corner of the rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public int Y { get; set; }
Visual Basic
Public Property Y As Integer
    Get
    Set
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

BitmapRectangle Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapResolution Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution Structure
Members See Also Send Feedback
Describes dots per inch resolution of the bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BitmapResolution
Visual Basic
Public Structure BitmapResolution
Visual C++
public value class BitmapResolution

See Also

BitmapResolution Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapResolution Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution Members
BitmapResolution Structure Constructors Methods Operators Properties See Also Send Feedback

The BitmapResolution type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapResolution | Constructor

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | DpiX | The horizontal resolution of the bitmap.
Public property | DpiY | The vertical resolution of the bitmap.

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapResolution Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution Constructor
BitmapResolution Structure See Also Send Feedback
Constructor

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapResolution(
    double dpiX,
    double dpiY
)
Visual Basic
Public Sub New ( _
    dpiX As Double, _
    dpiY As Double _
)
Visual C++
public:
BitmapResolution(
    double dpiX,
    double dpiY
)

Parameters

dpiX
Type: System..::..Double
dpiY
Type: System..::..Double

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapResolution Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution Methods
BitmapResolution Structure See Also Send Feedback

The BitmapResolution type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution..::..Equals Method
BitmapResolution Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution..::..GetHashCode Method
BitmapResolution Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapResolution Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution Operators
BitmapResolution Structure See Also Send Feedback

The BitmapResolution type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution..::..Equality Operator
BitmapResolution Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BitmapResolution bitmapResolution1,
    BitmapResolution bitmapResolution2
)
Visual Basic
Public Shared Operator = ( _
    bitmapResolution1 As BitmapResolution, _
    bitmapResolution2 As BitmapResolution _
) As Boolean
Visual C++
public:
static bool operator ==(
    BitmapResolution bitmapResolution1,
    BitmapResolution bitmapResolution2
)

Parameters

bitmapResolution1
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapResolution
bitmapResolution2
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapResolution

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution..::..Inequality Operator
BitmapResolution Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BitmapResolution bitmapResolution1,
    BitmapResolution bitmapResolution2
)
Visual Basic
Public Shared Operator <> ( _
    bitmapResolution1 As BitmapResolution, _
    bitmapResolution2 As BitmapResolution _
) As Boolean
Visual C++
public:
static bool operator !=(
    BitmapResolution bitmapResolution1,
    BitmapResolution bitmapResolution2
)

Parameters

bitmapResolution1
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapResolution
bitmapResolution2
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapResolution

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapResolution Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution Properties
BitmapResolution Structure See Also Send Feedback

The BitmapResolution type exposes the following members.

Properties

 | Name | Description
Public property | DpiX | The horizontal resolution of the bitmap.
Public property | DpiY | The vertical resolution of the bitmap.

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


DpiX Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution..::..DpiX Property
BitmapResolution Structure See Also Send Feedback
The horizontal resolution of the bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public double DpiX { get; set; }
Visual Basic
Public Property DpiX As Double
    Get
    Set
Visual C++
public:
property double DpiX {
    double get ();
    void set (double value);
}

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


DpiY Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapResolution..::..DpiY Property
BitmapResolution Structure See Also Send Feedback
The vertical resolution of the bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public double DpiY { get; set; }
Visual Basic
Public Property DpiY As Double
    Get
    Set
Visual C++
public:
property double DpiY {
    double get ();
    void set (double value);
}

See Also

BitmapResolution Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSize Structure

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize Structure
Members See Also Send Feedback
Describes size of the bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public struct BitmapSize
Visual Basic
Public Structure BitmapSize
Visual C++
public value class BitmapSize

See Also

BitmapSize Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSize Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize Members
BitmapSize Structure Constructors Methods Operators Properties See Also Send Feedback

The BitmapSize type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapSize | Constructor

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Height | The height of the bitmap in pixels.
Public property | Width | The width of the bitmap in pixels.

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSize Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize Constructor
BitmapSize Structure See Also Send Feedback
Constructor

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapSize(
    uint width,
    uint height
)
Visual Basic
Public Sub New ( _
    width As UInteger, _
    height As UInteger _
)
Visual C++
public:
BitmapSize(
    unsigned int width,
    unsigned int height
)

Parameters

width
Type: System..::..UInt32
height
Type: System..::..UInt32

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSize Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize Methods
BitmapSize Structure See Also Send Feedback

The BitmapSize type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Equals Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize..::..Equals Method
BitmapSize Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed bool Equals(
    Object obj
)
Visual Basic
Public Overrides NotOverridable Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override sealed

Parameters

obj
Type: System..::..Object

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


GetHashCode Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize..::..GetHashCode Method
BitmapSize Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public override sealed int GetHashCode()
Visual Basic
Public Overrides NotOverridable Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override sealed

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSize Operators

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize Operators
BitmapSize Structure See Also Send Feedback

The BitmapSize type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Equality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize..::..Equality Operator
BitmapSize Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator ==(
    BitmapSize bitmapSize1,
    BitmapSize bitmapSize2
)
Visual Basic
Public Shared Operator = ( _
    bitmapSize1 As BitmapSize, _
    bitmapSize2 As BitmapSize _
) As Boolean
Visual C++
public:
static bool operator ==(
    BitmapSize bitmapSize1,
    BitmapSize bitmapSize2
)

Parameters

bitmapSize1
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSize
bitmapSize2
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSize

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Inequality Operator

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize..::..Inequality Operator
BitmapSize Structure See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static bool operator !=(
    BitmapSize bitmapSize1,
    BitmapSize bitmapSize2
)
Visual Basic
Public Shared Operator <> ( _
    bitmapSize1 As BitmapSize, _
    bitmapSize2 As BitmapSize _
) As Boolean
Visual C++
public:
static bool operator !=(
    BitmapSize bitmapSize1,
    BitmapSize bitmapSize2
)

Parameters

bitmapSize1
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSize
bitmapSize2
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSize

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSize Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize Properties
BitmapSize Structure See Also Send Feedback

The BitmapSize type exposes the following members.

Properties

 | Name | Description
Public property | Height | The height of the bitmap in pixels.
Public property | Width | The width of the bitmap in pixels.

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Height Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize..::..Height Property
BitmapSize Structure See Also Send Feedback
The height of the bitmap in pixels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Height { get; set; }
Visual Basic
Public Property Height As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Height {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Width Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSize..::..Width Property
BitmapSize Structure See Also Send Feedback
The width of the bitmap in pixels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Width { get; set; }
Visual Basic
Public Property Width As UInteger
    Get
    Set
Visual C++
public:
property unsigned int Width {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BitmapSize Structure
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSource Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource Class
Members See Also Send Feedback
Exposes methods that refers to a source from which pixels are retrieved, but cannot be written back to.

(Also see IWICBitmapSource interface)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class BitmapSource : DirectUnknown
Visual Basic
Public Class BitmapSource _
    Inherits DirectUnknown
Visual C++
public ref class BitmapSource : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSource
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingBitmap

See Also

BitmapSource Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSource Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource Members
BitmapSource Class Methods Properties See Also Send Feedback

The BitmapSource type exposes the following members.

Methods

 | Name | Description
Public method | CopyPixels()()()() | Instructs the object to produce pixels using the entire bitmap.
Public method | CopyPixels(BitmapRectangle) | Instructs the object to produce pixels.
Public method | CopyPixelsToMemory()()()() | Instructs the object to produce pixels using the entire bitmap. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal()
Public method | CopyPixelsToMemory(BitmapRectangle) | Instructs the object to produce pixels. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal()

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Retrieves the pixel format the pixels are stored in.
Public property | Resolution | Retrieves the sampling rate between pixels and physical world measurements.
Public property | Size | Retrieves the pixel width and height of the bitmap.

See Also

BitmapSource Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSource Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource Methods
BitmapSource Class See Also Send Feedback

Methods

 | Name | Description
Public method | CopyPixels()()()() | Instructs the object to produce pixels using the entire bitmap.
Public method | CopyPixels(BitmapRectangle) | Instructs the object to produce pixels.
Public method | CopyPixelsToMemory()()()() | Instructs the object to produce pixels using the entire bitmap. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal()
Public method | CopyPixelsToMemory(BitmapRectangle) | Instructs the object to produce pixels. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal()

See Also

BitmapSource Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixels Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource..::..CopyPixels Method
BitmapSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyPixels()()()() | Instructs the object to produce pixels using the entire bitmap.
Public method | CopyPixels(BitmapRectangle) | Instructs the object to produce pixels.

See Also

BitmapSource Class
BitmapSource Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixels Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource..::..CopyPixels Method
BitmapSource Class See Also Send Feedback
Instructs the object to produce pixels using the entire bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte[] CopyPixels()
Visual Basic
Public Function CopyPixels As Byte()
Visual C++
public:
array<unsigned char>^ CopyPixels()

Return Value

An array of the pixel data.

See Also

BitmapSource Class
CopyPixels Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixels Method (BitmapRectangle)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource..::..CopyPixels Method (BitmapRectangle)
BitmapSource Class See Also Send Feedback
Instructs the object to produce pixels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte[] CopyPixels(
    BitmapRectangle rectangle
)
Visual Basic
Public Function CopyPixels ( _
    rectangle As BitmapRectangle _
) As Byte()
Visual C++
public:
array<unsigned char>^ CopyPixels(
    BitmapRectangle rectangle
)

Parameters

rectangle
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapRectangle
The rectangle to copy. A null value specifies the entire bitmap.

Return Value

An array of the pixel data.

See Also

BitmapSource Class
CopyPixels Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixelsToMemory Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource..::..CopyPixelsToMemory Method
BitmapSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyPixelsToMemory()()()() | Instructs the object to produce pixels using the entire bitmap. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal()
Public method | CopyPixelsToMemory(BitmapRectangle) | Instructs the object to produce pixels. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal()

See Also

BitmapSource Class
BitmapSource Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixelsToMemory Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource..::..CopyPixelsToMemory Method
BitmapSource Class See Also Send Feedback
Instructs the object to produce pixels using the entire bitmap.

Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal()

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr CopyPixelsToMemory()
Visual Basic
Public Function CopyPixelsToMemory As IntPtr
Visual C++
public:
IntPtr CopyPixelsToMemory()

Return Value

A pointer to pixel data in memory.

See Also

BitmapSource Class
CopyPixelsToMemory Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixelsToMemory Method (BitmapRectangle)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource..::..CopyPixelsToMemory Method (BitmapRectangle)
BitmapSource Class See Also Send Feedback
Instructs the object to produce pixels.

Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal()

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr CopyPixelsToMemory(
    BitmapRectangle rectangle
)
Visual Basic
Public Function CopyPixelsToMemory ( _
    rectangle As BitmapRectangle _
) As IntPtr
Visual C++
public:
IntPtr CopyPixelsToMemory(
    BitmapRectangle rectangle
)

Parameters

rectangle
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapRectangle
The rectangle to copy. A null value specifies the entire bitmap.

Return Value

A pointer to pixel data in memory.

See Also

BitmapSource Class
CopyPixelsToMemory Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BitmapSource Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource Properties
BitmapSource Class See Also Send Feedback

The BitmapSource type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Retrieves the pixel format the pixels are stored in.
Public property | Resolution | Retrieves the sampling rate between pixels and physical world measurements.
Public property | Size | Retrieves the pixel width and height of the bitmap.

See Also

BitmapSource Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


PixelFormat Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource..::..PixelFormat Property
BitmapSource Class See Also Send Feedback
Retrieves the pixel format the pixels are stored in.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Guid PixelFormat { get; }
Visual Basic
Public ReadOnly Property PixelFormat As Guid
    Get
Visual C++
public:
property Guid PixelFormat {
    Guid get ();
}

See Also

BitmapSource Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Resolution Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource..::..Resolution Property
BitmapSource Class See Also Send Feedback
Retrieves the sampling rate between pixels and physical world measurements.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapResolution Resolution { get; }
Visual Basic
Public ReadOnly Property Resolution As BitmapResolution
    Get
Visual C++
public:
property BitmapResolution Resolution {
    BitmapResolution get ();
}

See Also

BitmapSource Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Size Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
BitmapSource..::..Size Property
BitmapSource Class See Also Send Feedback
Retrieves the pixel width and height of the bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapSize Size { get; }
Visual Basic
Public ReadOnly Property Size As BitmapSize
    Get
Visual C++
public:
property BitmapSize Size {
    BitmapSize get ();
}

See Also

BitmapSource Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ContainerFormats Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats Class
Members See Also Send Feedback
Container formats supported by the Windows Imaging Component.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public sealed class ContainerFormats
Visual Basic
Public NotInheritable Class ContainerFormats
Visual C++
public ref class ContainerFormats sealed

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ContainerFormats

See Also

ContainerFormats Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ContainerFormats Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats Members
ContainerFormats Class Properties See Also Send Feedback

The ContainerFormats type exposes the following members.

Properties

Name | Description
Bmp | The BMP container format GUID.
Gif | The GIF container format GUID.
Ico | The ICO container format GUID.
Jpeg | The JPEG container format GUID.
Png | The PNG container format GUID.
Tiff | The TIFF container format GUID.
Wmp | The HD Photo container format GUID.

See Also

ContainerFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ContainerFormats Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats Properties
ContainerFormats Class See Also Send Feedback

The ContainerFormats type exposes the following members.

Properties

Name | Description
Bmp | The BMP container format GUID.
Gif | The GIF container format GUID.
Ico | The ICO container format GUID.
Jpeg | The JPEG container format GUID.
Png | The PNG container format GUID.
Tiff | The TIFF container format GUID.
Wmp | The HD Photo container format GUID.

See Also

ContainerFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Bmp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats..::..Bmp Property
ContainerFormats Class See Also Send Feedback
The BMP container format GUID.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Bmp { get; }
Visual Basic
Public Shared ReadOnly Property Bmp As Guid
    Get
Visual C++
public:
static property Guid Bmp {
    Guid get ();
}

See Also

ContainerFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Gif Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats..::..Gif Property
ContainerFormats Class See Also Send Feedback
The GIF container format GUID.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Gif { get; }
Visual Basic
Public Shared ReadOnly Property Gif As Guid
    Get
Visual C++
public:
static property Guid Gif {
    Guid get ();
}

See Also

ContainerFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Ico Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats..::..Ico Property
ContainerFormats Class See Also Send Feedback
The ICO container format GUID.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Ico { get; }
Visual Basic
Public Shared ReadOnly Property Ico As Guid
    Get
Visual C++
public:
static property Guid Ico {
    Guid get ();
}

See Also

ContainerFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Jpeg Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats..::..Jpeg Property
ContainerFormats Class See Also Send Feedback
The JPEG container format GUID.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Jpeg { get; }
Visual Basic
Public Shared ReadOnly Property Jpeg As Guid
    Get
Visual C++
public:
static property Guid Jpeg {
    Guid get ();
}

See Also

ContainerFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Png Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats..::..Png Property
ContainerFormats Class See Also Send Feedback
The PNG container format GUID.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Png { get; }
Visual Basic
Public Shared ReadOnly Property Png As Guid
    Get
Visual C++
public:
static property Guid Png {
    Guid get ();
}

See Also

ContainerFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Tiff Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats..::..Tiff Property
ContainerFormats Class See Also Send Feedback
The TIFF container format GUID.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Tiff { get; }
Visual Basic
Public Shared ReadOnly Property Tiff As Guid
    Get
Visual C++
public:
static property Guid Tiff {
    Guid get ();
}

See Also

ContainerFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Wmp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ContainerFormats..::..Wmp Property
ContainerFormats Class See Also Send Feedback
The HD Photo container format GUID.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Wmp { get; }
Visual Basic
Public Shared ReadOnly Property Wmp As Guid
    Get
Visual C++
public:
static property Guid Wmp {
    Guid get ();
}

See Also

ContainerFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


DecodeMetadataCacheOption Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DecodeMetadataCacheOption Enumeration
See Also Send Feedback
Specifies image decode options.

(Also see WICDecodeOptions Enumerated Type)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public enum DecodeMetadataCacheOption
Visual Basic
Public Enumeration DecodeMetadataCacheOption
Visual C++
public enum class DecodeMetadataCacheOption

Members

Member name | Description
OnLoad |
OnDemand |

See Also

Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


DesiredAccess Enumeration

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
DesiredAccess Enumeration
See Also Send Feedback
Describes the reading mode for WICImagingFactory.CreateDecoderFromFilename

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
[FlagsAttribute]
public enum DesiredAccess
Visual Basic
<FlagsAttribute> _
Public Enumeration DesiredAccess
Visual C++
[FlagsAttribute]
public enum class DesiredAccess

Members

Member name | Description
Write |
Read |

See Also

Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FormatConverter Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter Class
Members See Also Send Feedback
Exposes methods that represent a pixel format converter. This class provides the means of converting from one pixel format to another, handling dithering and halftoning to indexed formats, palette translation and alpha thresholding.

(Also see IWICFormatConverter interface)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class FormatConverter : DirectUnknown
Visual Basic
Public Class FormatConverter _
    Inherits DirectUnknown
Visual C++
public ref class FormatConverter : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..FormatConverter

See Also

FormatConverter Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FormatConverter Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter Members
FormatConverter Class Methods Properties See Also Send Feedback

The FormatConverter type exposes the following members.

Methods

 | Name | Description
Public method | CopyPixels | Instructs the object to produce pixels.
Public method | CopyPixelsToMemory | Instructs the object to produce pixels. Application is responsible for freeing the memory when the IntPtr is no longer needed by calling Marshal.FreeHGlobal().
Public method | Initialize | Initializes the format converter.
Public method | ToBitmapSource | Returns the BitmapSource of a particular FormatConverter.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Retrieves the pixel format the pixels are stored in.
Public property | Resolution | Retrieves the sampling rate between pixels and physical world measurements.
Public property | Size | Retrieves the pixel width and height of the bitmap.

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FormatConverter Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter Methods
FormatConverter Class See Also Send Feedback

The FormatConverter type exposes the following members.

Methods

 | Name | Description
Public method | CopyPixels | Instructs the object to produce pixels.
Public method | CopyPixelsToMemory | Instructs the object to produce pixels. Application is responsible for freeing the memory when the IntPtr is no longer needed by calling Marshal.FreeHGlobal().
Public method | Initialize | Initializes the format converter.
Public method | ToBitmapSource | Returns the BitmapSource of a particular FormatConverter.

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixels Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter..::..CopyPixels Method
FormatConverter Class See Also Send Feedback
Instructs the object to produce pixels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte[] CopyPixels()
Visual Basic
Public Function CopyPixels As Byte()
Visual C++
public:
array<unsigned char>^ CopyPixels()

Return Value

An array of the pixel data.

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixelsToMemory Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter..::..CopyPixelsToMemory Method
FormatConverter Class See Also Send Feedback
Instructs the object to produce pixels.

Application is responsible for freeing the memory when the IntPtr is no longer needed by calling Marshal.FreeHGlobal().

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr CopyPixelsToMemory()
Visual Basic
Public Function CopyPixelsToMemory As IntPtr
Visual C++
public:
IntPtr CopyPixelsToMemory()

Return Value

A pointer to the pixel data in memory.

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Initialize Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter..::..Initialize Method
FormatConverter Class See Also Send Feedback
Initializes the format converter.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void Initialize(
    BitmapSource source,
    Guid destinationFormat,
    BitmapDitherType ditherType,
    BitmapPaletteType paletteType
)
Visual Basic
Public Sub Initialize ( _
    source As BitmapSource, _
    destinationFormat As Guid, _
    ditherType As BitmapDitherType, _
    paletteType As BitmapPaletteType _
)
Visual C++
public:
void Initialize(
    BitmapSource^ source,
    Guid destinationFormat,
    BitmapDitherType ditherType,
    BitmapPaletteType paletteType
)

Parameters

source
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSource
The input bitmap to convert
destinationFormat
Type: System..::..Guid
The destination pixel format.
ditherType
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapDitherType
The BitmapDitherType used for conversion.
paletteType
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapPaletteType
The palette translation type to use for conversion.

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ToBitmapSource Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter..::..ToBitmapSource Method
FormatConverter Class See Also Send Feedback
Returns the BitmapSource of a particular FormatConverter.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapSource ToBitmapSource()
Visual Basic
Public Function ToBitmapSource As BitmapSource
Visual C++
public:
BitmapSource^ ToBitmapSource()

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FormatConverter Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter Properties
FormatConverter Class See Also Send Feedback

The FormatConverter type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Retrieves the pixel format the pixels are stored in.
Public property | Resolution | Retrieves the sampling rate between pixels and physical world measurements.
Public property | Size | Retrieves the pixel width and height of the bitmap.

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


PixelFormat Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter..::..PixelFormat Property
FormatConverter Class See Also Send Feedback
Retrieves the pixel format the pixels are stored in.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Guid PixelFormat { get; }
Visual Basic
Public ReadOnly Property PixelFormat As Guid
    Get
Visual C++
public:
property Guid PixelFormat {
    Guid get ();
}

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Resolution Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter..::..Resolution Property
FormatConverter Class See Also Send Feedback
Retrieves the sampling rate between pixels and physical world measurements.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapResolution Resolution { get; }
Visual Basic
Public ReadOnly Property Resolution As BitmapResolution
    Get
Visual C++
public:
property BitmapResolution Resolution {
    BitmapResolution get ();
}

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Size Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
FormatConverter..::..Size Property
FormatConverter Class See Also Send Feedback
Retrieves the pixel width and height of the bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapSize Size { get; }
Visual Basic
Public ReadOnly Property Size As BitmapSize
    Get
Visual C++
public:
property BitmapSize Size {
    BitmapSize get ();
}

See Also

FormatConverter Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingBitmap Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmap Class
Members See Also Send Feedback
Defines methods that add the concept of writeability and static in-memory representations of bitmaps to WICBitmapSource.

(Also see IWICBitmap interface)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ImagingBitmap : BitmapSource
Visual Basic
Public Class ImagingBitmap _
    Inherits BitmapSource
Visual C++
public ref class ImagingBitmap : public BitmapSource

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapSource
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingBitmap

See Also

ImagingBitmap Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingBitmap Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmap Members
ImagingBitmap Class Methods Properties See Also Send Feedback

The ImagingBitmap type exposes the following members.

Methods

 | Name | Description
Public method | CopyPixels()()()() | Instructs the object to produce pixels using the entire bitmap. (Inherited from BitmapSource.)
Public method | CopyPixels(BitmapRectangle) | Instructs the object to produce pixels. (Inherited from BitmapSource.)
Public method | CopyPixelsToMemory()()()() | Instructs the object to produce pixels using the entire bitmap. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal() (Inherited from BitmapSource.)
Public method | CopyPixelsToMemory(BitmapRectangle) | Instructs the object to produce pixels. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal() (Inherited from BitmapSource.)
Public method | Lock | Provides locked access to a rectangular area of the bitmap.
Public method | SaveToFile | Save the bitmap to a file given a container format.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Retrieves the pixel format the pixels are stored in. (Inherited from BitmapSource.)
Public property | Resolution | Gets or sets the physical resolution of the image.
Public property | Size | Retrieves the pixel width and height of the bitmap. (Inherited from BitmapSource.)

See Also

ImagingBitmap Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingBitmap Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmap Methods
ImagingBitmap Class See Also Send Feedback

The ImagingBitmap type exposes the following members.

Methods

 | Name | Description
Public method | CopyPixels()()()() | Instructs the object to produce pixels using the entire bitmap. (Inherited from BitmapSource.)
Public method | CopyPixels(BitmapRectangle) | Instructs the object to produce pixels. (Inherited from BitmapSource.)
Public method | CopyPixelsToMemory()()()() | Instructs the object to produce pixels using the entire bitmap. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal() (Inherited from BitmapSource.)
Public method | CopyPixelsToMemory(BitmapRectangle) | Instructs the object to produce pixels. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal() (Inherited from BitmapSource.)
Public method | Lock | Provides locked access to a rectangular area of the bitmap.
Public method | SaveToFile | Save the bitmap to a file given a container format.

See Also

ImagingBitmap Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixels Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmap..::..CopyPixels Method
ImagingBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyPixels()()()() | Instructs the object to produce pixels using the entire bitmap. (Inherited from BitmapSource.)
Public method | CopyPixels(BitmapRectangle) | Instructs the object to produce pixels. (Inherited from BitmapSource.)

See Also

ImagingBitmap Class
ImagingBitmap Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyPixelsToMemory Method

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmap..::..CopyPixelsToMemory Method
ImagingBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyPixelsToMemory()()()() | Instructs the object to produce pixels using the entire bitmap. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal() (Inherited from BitmapSource.)
Public method | CopyPixelsToMemory(BitmapRectangle) | Instructs the object to produce pixels. Application is responsible for freeing the memory when the IntPtr is no longer needed by using Marshal.FreeHGlobal() (Inherited from BitmapSource.)

See Also

ImagingBitmap Class
ImagingBitmap Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Lock Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmap..::..Lock Method
ImagingBitmap Class See Also Send Feedback
Provides locked access to a rectangular area of the bitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ImagingBitmapLock Lock(
    BitmapRectangle lockRectangle,
    BitmapLockOptions options
)
Visual Basic
Public Function Lock ( _
    lockRectangle As BitmapRectangle, _
    options As BitmapLockOptions _
) As ImagingBitmapLock
Visual C++
public:
ImagingBitmapLock^ Lock(
    BitmapRectangle lockRectangle,
    BitmapLockOptions options
)

Parameters

lockRectangle
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapRectangle
The rectangle to be accessed.
options
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapLockOptions
The access mode you wish to obtain for the lock. This is a bitwise combination of BitmapLockOptions for read, write, or read and write access.

Return Value

A ImagingBitmapLock object that represents locked memory location.

Remarks

Locks are exclusive for writing but can be shared for reading. You cannot call BitmapSource.CopyPixels() while the ImagingBitmap is locked for writing. Doing so will return an error, since locks are exclusive.

See Also

ImagingBitmap Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SaveToFile Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmap..::..SaveToFile Method
ImagingBitmap Class See Also Send Feedback
Save the bitmap to a file given a container format.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public void SaveToFile(
    ImagingFactory imagingFactory,
    Guid containerFormat,
    string fileName
)
Visual Basic
Public Sub SaveToFile ( _
    imagingFactory As ImagingFactory, _
    containerFormat As Guid, _
    fileName As String _
)
Visual C++
public:
void SaveToFile(
    ImagingFactory^ imagingFactory,
    Guid containerFormat,
    String^ fileName
)

Parameters

imagingFactory
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingFactory
The imaging factory that created this bitmap.
containerFormat
Type: System..::..Guid
One of the predefined container formats in ContainerFormats to use when creating the bitmap.
fileName
Type: System..::..String
The file path to save to.If the file already exists, it will be overwritten

See Also

ImagingBitmap Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingBitmap Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmap Properties
ImagingBitmap Class See Also Send Feedback

The ImagingBitmap type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Retrieves the pixel format the pixels are stored in. (Inherited from BitmapSource.)
Public property | Resolution | Gets or sets the physical resolution of the image.
Public property | Size | Retrieves the pixel width and height of the bitmap. (Inherited from BitmapSource.)

See Also

ImagingBitmap Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Resolution Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmap..::..Resolution Property
ImagingBitmap Class See Also Send Feedback
Gets or sets the physical resolution of the image.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapResolution Resolution { get; set; }
Visual Basic
Public Property Resolution As BitmapResolution
    Get
    Set
Visual C++
public:
property BitmapResolution Resolution {
    BitmapResolution get ();
    void set (BitmapResolution value);
}

See Also

ImagingBitmap Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingBitmapLock Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock Class
Members See Also Send Feedback
Defines methods that add the concept of writeability and static in-memory representations of bitmaps to WICBitmapSource.

(Also see IWICBitmap interface)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ImagingBitmapLock : DirectUnknown
Visual Basic
Public Class ImagingBitmapLock _
    Inherits DirectUnknown
Visual C++
public ref class ImagingBitmapLock : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingBitmapLock

See Also

ImagingBitmapLock Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingBitmapLock Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock Members
ImagingBitmapLock Class Methods Properties See Also Send Feedback

The ImagingBitmapLock type exposes the following members.

Methods

 | Name | Description
Public method | CopyData | Retrieves a copy of the buffer data.

Properties

 | Name | Description
Public property | DataPointer | Gets the pointer to the top left pixel in the locked rectangle.
Public property | DataSize | Gets the size of the locked data buffer
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Gets the pixel format of for the locked area of pixels. This can be used to compute the number of bytes-per-pixel in the locked area.
Public property | Size | Retrieves the pixel width and height of the locked rectangle.
Public property | Stride | Provides access to the stride value for the memory.

See Also

ImagingBitmapLock Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingBitmapLock Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock Methods
ImagingBitmapLock Class See Also Send Feedback

The ImagingBitmapLock type exposes the following members.

Methods

 | Name | Description
Public method | CopyData | Retrieves a copy of the buffer data.

See Also

ImagingBitmapLock Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyData Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock..::..CopyData Method
ImagingBitmapLock Class See Also Send Feedback
Retrieves a copy of the buffer data.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public byte[] CopyData()
Visual Basic
Public Function CopyData As Byte()
Visual C++
public:
array<unsigned char>^ CopyData()

Return Value

A byte array containing the buffer data.

See Also

ImagingBitmapLock Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingBitmapLock Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock Properties
ImagingBitmapLock Class See Also Send Feedback

The ImagingBitmapLock type exposes the following members.

Properties

 | Name | Description
Public property | DataPointer | Gets the pointer to the top left pixel in the locked rectangle.
Public property | DataSize | Gets the size of the locked data buffer
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)
Public property | PixelFormat | Gets the pixel format of for the locked area of pixels. This can be used to compute the number of bytes-per-pixel in the locked area.
Public property | Size | Retrieves the pixel width and height of the locked rectangle.
Public property | Stride | Provides access to the stride value for the memory.

See Also

ImagingBitmapLock Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


DataPointer Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock..::..DataPointer Property
ImagingBitmapLock Class See Also Send Feedback
Gets the pointer to the top left pixel in the locked rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public IntPtr DataPointer { get; }
Visual Basic
Public ReadOnly Property DataPointer As IntPtr
    Get
Visual C++
public:
property IntPtr DataPointer {
    IntPtr get ();
}

Remarks

The pointer provided by this property should not be used outside of the lifetime of the lock itself. DataPointer is not available in multi-threaded apartment applications.

See Also

ImagingBitmapLock Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


DataSize Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock..::..DataSize Property
ImagingBitmapLock Class See Also Send Feedback
Gets the size of the locked data buffer

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint DataSize { get; }
Visual Basic
Public ReadOnly Property DataSize As UInteger
    Get
Visual C++
public:
property unsigned int DataSize {
    unsigned int get ();
}

Remarks

DataSize is not available in multi-threaded apartment applications.

See Also

ImagingBitmapLock Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


PixelFormat Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock..::..PixelFormat Property
ImagingBitmapLock Class See Also Send Feedback
Gets the pixel format of for the locked area of pixels. This can be used to compute the number of bytes-per-pixel in the locked area.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public Guid PixelFormat { get; }
Visual Basic
Public ReadOnly Property PixelFormat As Guid
    Get
Visual C++
public:
property Guid PixelFormat {
    Guid get ();
}

See Also

ImagingBitmapLock Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Size Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock..::..Size Property
ImagingBitmapLock Class See Also Send Feedback
Retrieves the pixel width and height of the locked rectangle.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapSize Size { get; }
Visual Basic
Public ReadOnly Property Size As BitmapSize
    Get
Visual C++
public:
property BitmapSize Size {
    BitmapSize get ();
}

See Also

ImagingBitmapLock Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Stride Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingBitmapLock..::..Stride Property
ImagingBitmapLock Class See Also Send Feedback
Provides access to the stride value for the memory.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public uint Stride { get; }
Visual Basic
Public ReadOnly Property Stride As UInteger
    Get
Visual C++
public:
property unsigned int Stride {
    unsigned int get ();
}

Remarks

Note the stride value is specific to the IWICBitmapLock, not the bitmap. For example, two consecutive locks on the same rectangle of a bitmap may return different pointers and stride values, depending on internal implementation.

See Also

ImagingBitmapLock Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Class
Members See Also Send Feedback
An exception thrown by a WIC (Windows Imaging Component) method.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ImagingException : DirectXException
Visual Basic
Public Class ImagingException _
    Inherits DirectXException
Visual C++
public ref class ImagingException : public DirectXException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Microsoft.WindowsAPICodePack.DirectX..::..DirectXException
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingException

See Also

ImagingException Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Members
ImagingException Class Constructors Properties See Also Send Feedback

The ImagingException type exposes the following members.

Constructors

 | Name | Description
Public method | ImagingException()()()() |
Public method | ImagingException(Int32) |
Public method | ImagingException(String) |
Protected method | ImagingException(SerializationInfo, StreamingContext) |
Public method | ImagingException(String, Exception) |
Public method | ImagingException(String, Int32) |
Protected method | ImagingException(SerializationInfo, StreamingContext, Int32) |
Public method | ImagingException(String, Exception, Int32) |

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API (Inherited from DirectXException.)

See Also

ImagingException Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Constructor

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Constructor
ImagingException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImagingException()()()() |
Public method | ImagingException(Int32) |
Public method | ImagingException(String) |
Protected method | ImagingException(SerializationInfo, StreamingContext) |
Public method | ImagingException(String, Exception) |
Public method | ImagingException(String, Int32) |
Protected method | ImagingException(SerializationInfo, StreamingContext, Int32) |
Public method | ImagingException(String, Exception, Int32) |

See Also

ImagingException Class
ImagingException Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Constructor
ImagingException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ImagingException()
Visual Basic
Public Sub New
Visual C++
public:
ImagingException()

See Also

ImagingException Class
ImagingException Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Constructor (Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Constructor (Int32)
ImagingException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ImagingException(
    int hr
)
Visual Basic
Public Sub New ( _
    hr As Integer _
)
Visual C++
public:
ImagingException(
    int hr
)

Parameters

hr
Type: System..::..Int32

See Also

ImagingException Class
ImagingException Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Constructor (String)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Constructor (String)
ImagingException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ImagingException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ImagingException(
    String^ message
)

Parameters

message
Type: System..::..String

See Also

ImagingException Class
ImagingException Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Constructor (SerializationInfo, StreamingContext)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Constructor (SerializationInfo, StreamingContext)
ImagingException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected ImagingException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
protected:
ImagingException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext

See Also

ImagingException Class
ImagingException Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Constructor (String, Exception)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Constructor (String, Exception)
ImagingException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ImagingException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ImagingException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception

See Also

ImagingException Class
ImagingException Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Constructor (String, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Constructor (String, Int32)
ImagingException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ImagingException(
    string message,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    hr As Integer _
)
Visual C++
public:
ImagingException(
    String^ message,
    int hr
)

Parameters

message
Type: System..::..String
hr
Type: System..::..Int32

See Also

ImagingException Class
ImagingException Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Constructor (SerializationInfo, StreamingContext, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Constructor (SerializationInfo, StreamingContext, Int32)
ImagingException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected ImagingException(
    SerializationInfo info,
    StreamingContext context,
    int hr
)
Visual Basic
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext, _
    hr As Integer _
)
Visual C++
protected:
ImagingException(
    SerializationInfo^ info,
    StreamingContext context,
    int hr
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext
hr
Type: System..::..Int32

See Also

ImagingException Class
ImagingException Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Constructor (String, Exception, Int32)

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Constructor (String, Exception, Int32)
ImagingException Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ImagingException(
    string message,
    Exception innerException,
    int hr
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception, _
    hr As Integer _
)
Visual C++
public:
ImagingException(
    String^ message,
    Exception^ innerException,
    int hr
)

Parameters

message
Type: System..::..String
innerException
Type: System..::..Exception
hr
Type: System..::..Int32

See Also

ImagingException Class
ImagingException Overload
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingException Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingException Properties
ImagingException Class See Also Send Feedback

The ImagingException type exposes the following members.

Properties

 | Name | Description
Public property | ErrorCode | The error code returned by a DirectX API (Inherited from DirectXException.)

See Also

ImagingException Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingFactory Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingFactory Class
Members See Also Send Feedback
Exposes methods used to create components for the Microsoft Windows Imaging Component (WIC) such as decoders, encoders and pixel format converters.

(Also see IWICImagingFactory interface)

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class ImagingFactory : DirectUnknown
Visual Basic
Public Class ImagingFactory _
    Inherits DirectUnknown
Visual C++
public ref class ImagingFactory : public DirectUnknown

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX..::..DirectUnknown
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..ImagingFactory

See Also

ImagingFactory Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingFactory Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingFactory Members
ImagingFactory Class Methods Properties See Also Send Feedback

The ImagingFactory type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new ImagingFactory
Public method | CreateDecoderFromFileName | Creates a new instance of the WICBitmapDecoder class based on the given file.
Public method | CreateDecoderFromStream | Creates a new instance of the WICBitmapDecoder class based on the given data stream.
Public method | CreateFormatConverter | Creates a new instance of the FormatConverter class.
Public method | CreateImagingBitmap | Creates an empty ImagingBitmap.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ImagingFactory Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingFactory Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingFactory Methods
ImagingFactory Class See Also Send Feedback

The ImagingFactory type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new ImagingFactory
Public method | CreateDecoderFromFileName | Creates a new instance of the WICBitmapDecoder class based on the given file.
Public method | CreateDecoderFromStream | Creates a new instance of the WICBitmapDecoder class based on the given data stream.
Public method | CreateFormatConverter | Creates a new instance of the FormatConverter class.
Public method | CreateImagingBitmap | Creates an empty ImagingBitmap.

See Also

ImagingFactory Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Create Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingFactory..::..Create Method
ImagingFactory Class See Also Send Feedback
Creates a new ImagingFactory

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static ImagingFactory Create()
Visual Basic
Public Shared Function Create As ImagingFactory
Visual C++
public:
static ImagingFactory^ Create()

See Also

ImagingFactory Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CreateDecoderFromFileName Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingFactory..::..CreateDecoderFromFileName Method
ImagingFactory Class See Also Send Feedback
Creates a new instance of the WICBitmapDecoder class based on the given file.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapDecoder CreateDecoderFromFileName(
    string path,
    DesiredAccess access,
    DecodeMetadataCacheOption options
)
Visual Basic
Public Function CreateDecoderFromFileName ( _
    path As String, _
    access As DesiredAccess, _
    options As DecodeMetadataCacheOption _
) As BitmapDecoder
Visual C++
public:
BitmapDecoder^ CreateDecoderFromFileName(
    String^ path,
    DesiredAccess access,
    DecodeMetadataCacheOption options
)

Parameters

path
Type: System..::..String
The path to the file to create or open.
access
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..DesiredAccess
The access to the file object, which can be read, write, or both.
options
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..DecodeMetadataCacheOption
The DecodeMetadataCacheOption to use when creating the decoder.

Return Value

A new Instance of the WICBitmapDecoder class.

See Also

ImagingFactory Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CreateDecoderFromStream Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingFactory..::..CreateDecoderFromStream Method
ImagingFactory Class See Also Send Feedback
Creates a new instance of the WICBitmapDecoder class based on the given data stream.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public BitmapDecoder CreateDecoderFromStream(
    Stream stream,
    DecodeMetadataCacheOption options
)
Visual Basic
Public Function CreateDecoderFromStream ( _
    stream As Stream, _
    options As DecodeMetadataCacheOption _
) As BitmapDecoder
Visual C++
public:
BitmapDecoder^ CreateDecoderFromStream(
    Stream^ stream,
    DecodeMetadataCacheOption options
)

Parameters

stream
Type: System.IO..::..Stream
A stream containing the image data to read.
options
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..DecodeMetadataCacheOption
The DecodeMetadataCacheOption to use when creating the decoder.

Return Value

A new Instance of the BitmapDecoder class.

See Also

ImagingFactory Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CreateFormatConverter Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingFactory..::..CreateFormatConverter Method
ImagingFactory Class See Also Send Feedback
Creates a new instance of the FormatConverter class.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public FormatConverter CreateFormatConverter()
Visual Basic
Public Function CreateFormatConverter As FormatConverter
Visual C++
public:
FormatConverter^ CreateFormatConverter()

Return Value

A new Instance of the FormatConverter class.

See Also

ImagingFactory Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CreateImagingBitmap Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingFactory..::..CreateImagingBitmap Method
ImagingFactory Class See Also Send Feedback
Creates an empty ImagingBitmap.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public ImagingBitmap CreateImagingBitmap(
    uint width,
    uint height,
    Guid pixelFormat,
    BitmapCreateCacheOption cacheOption
)
Visual Basic
Public Function CreateImagingBitmap ( _
    width As UInteger, _
    height As UInteger, _
    pixelFormat As Guid, _
    cacheOption As BitmapCreateCacheOption _
) As ImagingBitmap
Visual C++
public:
ImagingBitmap^ CreateImagingBitmap(
    unsigned int width,
    unsigned int height,
    Guid pixelFormat,
    BitmapCreateCacheOption cacheOption
)

Parameters

width
Type: System..::..UInt32
The width of the bitmap.
height
Type: System..::..UInt32
The height of the bitmap.
pixelFormat
Type: System..::..Guid
One of the predefined pixel formats in PixelFormats to use when creating the bitmap.
cacheOption
Type: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..BitmapCreateCacheOption
The bitmap cache creation option.

Return Value

A new Instance of ImagingBitmap.

See Also

ImagingFactory Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ImagingFactory Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
ImagingFactory Properties
ImagingFactory Class See Also Send Feedback

The ImagingFactory type exposes the following members.

Properties

 | Name | Description
Public property | NativeInterface | Get the internal native pointer for the wrapped IUnknown Interface (Inherited from DirectUnknown.)

See Also

ImagingFactory Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


PixelFormats Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats Class
Members See Also Send Feedback
A listing of pixel formats supported by the Windows Imaging Component.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public sealed class PixelFormats
Visual Basic
Public NotInheritable Class PixelFormats
Visual C++
public ref class PixelFormats sealed

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..PixelFormats

See Also

PixelFormats Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


PixelFormats Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats Members
PixelFormats Class Properties See Also Send Feedback

The PixelFormats type exposes the following members.

Properties

Name | Description
Bgr10101032Bpp | Channel Count = 3, Bits Per Channel = 10, Bits Per Pixel = 32, Storage Type = uint Color-channel data crosses byte boundaries.
Bgr24Bpp | Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 24, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.
Bgr32Bpp | Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.
Bgr55516Bpp | Channel Count = 3, Bits Per Channel = 5, Bits Per Pixel = 16, Storage Type = uint Color-channel data crosses byte boundaries.
Bgr56516Bpp | Channel Count = 3, Bits Per Channel = 5(B)/6(G)/5(R), Bits Per Pixel = 16, Storage Type = uint Color-channel data crosses byte boundaries.
Bgra32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
BlackWhite | Channel Count = 1, Bits Per Channel = 1, Bits Per Pixel = 1, Storage Type = uint Color data represents shades of gray.
Cmyk32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), and black(K) channels.
Cmyk64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), and black(K) channels.
CmykAlpha40Bpp | Channel Count = 5, Bits Per Channel = 8, Bits Per Pixel = 40, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), black(K), and alpha channels.
CmykAlpha80Bpp | Channel Count = 5, Bits Per Channel = 16, Bits Per Pixel = 80, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), black(K), and alpha channels.
DoNotCare | A pixel format used when the actual pixelformat is unimportant to an image operation.
EightChannel128Bpp | Channel Count = 8, Bits Per Channel = 16, Bits Per Pixel = 128, Storage Type = uint
EightChannel64Bpp | Channel Count = 8, Bits Per Channel = 8, Bits Per Pixel = 64, Storage Type = uint
EightChannelAlpha144Bpp | Channel Count = 9, Bits Per Channel = 16, Bits Per Pixel = 144, Storage Type = uint
EightChannelAlpha72Bpp | Channel Count = 9, Bits Per Channel = 8, Bits Per Pixel = 72, Storage Type = uint
FiveChannel40Bpp | Channel Count = 5, Bits Per Channel = 8, Bits Per Pixel = 40, Storage Type = uint
FiveChannel80Bpp | Channel Count = 5, Bits Per Channel = 16, Bits Per Pixel = 80, Storage Type = uint
FiveChannelAlpha48Bpp | Channel Count = 6, Bits Per Channel = 8, Bits Per Pixel = 48, Storage Type = uint
FiveChannelAlpha96Bpp | Channel Count = 6, Bits Per Channel = 16, Bits Per Pixel = 96, Storage Type = uint
FourChannel32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint
FourChannel64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint
FourChannelAlpha40Bpp | Channel Count = 5, Bits Per Channel = 8, Bits Per Pixel = 40, Storage Type = uint
FourChannelAlpha80Bpp | Channel Count = 5, Bits Per Channel = 16, Bits Per Pixel = 80, Storage Type = uint
Gray16Bpp | Channel Count = 1, Bits Per Channel = 16, Bits Per Pixel = 16, Storage Type = uint Color data represents shades of gray.
Gray2Bpp | Channel Count = 1, Bits Per Channel = 2, Bits Per Pixel = 2, Storage Type = uint Color data represents shades of gray.
Gray4Bpp | Channel Count = 1, Bits Per Channel = 4, Bits Per Pixel = 4, Storage Type = uint Color data represents shades of gray.
Gray8Bpp | Channel Count = 1, Bits Per Channel = 8, Bits Per Pixel = 8, Storage Type = uint Color data represents shades of gray.
GrayFixedPoint16Bpp | Channel Count = 1, Bits Per Channel = 16, Bits Per Pixel = 16, Storage Type = FixedPoint Color data represents shades of gray.
GrayFixedPoint32Bpp | Channel Count = 1, Bits Per Channel = 32, Bits Per Pixel = 32, Storage Type = FixedPoint Color data represents shades of gray.
GrayFloat32Bpp | Channel Count = 1, Bits Per Channel = 32, Bits Per Pixel = 32, Storage Type = float Color data represents shades of gray.
GrayHalf16Bpp | Channel Count = 1, Bits Per Channel = 16, Bits Per Pixel = 16, Storage Type = float Color data represents shades of gray.
Indexed1Bpp | Channel Count = 1, Bits Per Channel = 1, Bits Per Pixel = 1, Storage Type = uint The value for each pixel is an index into a color palette.
Indexed2Bpp | Channel Count = 1, Bits Per Channel = 2, Bits Per Pixel = 2, Storage Type = uint The value for each pixel is an index into a color palette.
Indexed4Bpp | Channel Count = 1, Bits Per Channel = 4, Bits Per Pixel = 4, Storage Type = uint The value for each pixel is an index into a color palette.
Indexed8Bpp | Channel Count = 1, Bits Per Channel = 8, Bits Per Pixel = 8, Storage Type = uint The value for each pixel is an index into a color palette.
Pbgra32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
Prgba32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels. RGB channels premultiplied with alpha.
Prgba64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels. RGB channels premultiplied with alpha.
PrgbaFloat128Bpp | Channel Count = 4, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = float Color data is separated into red(R), green(G), blue(B), and alpha(A) channels. RGB channels premultiplied with alpha.
Rgb24Bpp | Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 24, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.
Rgb48Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.
Rgba32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
Rgba64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
RgbaFixedPoint128Bpp | Channel Count = 4, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = Fixed Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
RgbaFixedPoint64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = Fixed Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
RgbaFloat128Bpp | Channel Count = 4, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = float Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
RgbaHalf64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = float Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
Rgbe32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and exponent(E) channels. This format has an additional byte for shared exponent information. This provides additional floating-point precision without the additional memory needed for a true floating-point format.
RgbFixedPoint128Bpp | Channel Count = 3, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.
RgbFixedPoint48Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.
RgbFixedPoint64Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.
RgbFixedPoint96Bpp | Channel Count = 3, Bits Per Channel = 32, Bits Per Pixel = 96, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.
RgbFloat128Bpp | Channel Count = 3, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = float Color data is separated into red(R), green(G), and blue(B) channels.
RgbHalf48Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = float Color data is separated into red(R), green(G), and blue(B) channels.
RgbHalf64Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = float Color data is separated into red(R), green(G), and blue(B) channels.
SevenChannel112Bpp | Channel Count = 7, Bits Per Channel = 16, Bits Per Pixel = 112, Storage Type = uint
SevenChannel56Bpp | Channel Count = 7, Bits Per Channel = 8, Bits Per Pixel = 56, Storage Type = uint
SevenChannelAlpha128Bpp | Channel Count = 8, Bits Per Channel = 16, Bits Per Pixel = 128, Storage Type = uint
SevenChannelAlpha64Bpp | Channel Count = 8, Bits Per Channel = 8, Bits Per Pixel = 64, Storage Type = uint
SixChannel48Bpp | Channel Count = 6, Bits Per Channel = 8, Bits Per Pixel = 48, Storage Type = uint
SixChannel96Bpp | Channel Count = 6, Bits Per Channel = 16, Bits Per Pixel = 96, Storage Type = uint
SixChannelAlpha112Bpp | Channel Count = 7, Bits Per Channel = 16, Bits Per Pixel = 112, Storage Type = uint
SixChannelAlpha56Bpp | Channel Count = 7, Bits Per Channel = 8, Bits Per Pixel = 56, Storage Type = uint
ThreeChannel24Bpp | Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 24, Storage Type = uint
ThreeChannel48Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = uint
ThreeChannelAlpha32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint
ThreeChannelAlpha64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


PixelFormats Properties

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats Properties
PixelFormats Class See Also Send Feedback

The PixelFormats type exposes the following members.

Properties

Name | Description
Bgr10101032Bpp | Channel Count = 3, Bits Per Channel = 10, Bits Per Pixel = 32, Storage Type = uint Color-channel data crosses byte boundaries.
Bgr24Bpp | Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 24, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.
Bgr32Bpp | Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.
Bgr55516Bpp | Channel Count = 3, Bits Per Channel = 5, Bits Per Pixel = 16, Storage Type = uint Color-channel data crosses byte boundaries.
Bgr56516Bpp | Channel Count = 3, Bits Per Channel = 5(B)/6(G)/5(R), Bits Per Pixel = 16, Storage Type = uint Color-channel data crosses byte boundaries.
Bgra32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
BlackWhite | Channel Count = 1, Bits Per Channel = 1, Bits Per Pixel = 1, Storage Type = uint Color data represents shades of gray.
Cmyk32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), and black(K) channels.
Cmyk64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), and black(K) channels.
CmykAlpha40Bpp | Channel Count = 5, Bits Per Channel = 8, Bits Per Pixel = 40, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), black(K), and alpha channels.
CmykAlpha80Bpp | Channel Count = 5, Bits Per Channel = 16, Bits Per Pixel = 80, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), black(K), and alpha channels.
DoNotCare | A pixel format used when the actual pixelformat is unimportant to an image operation.
EightChannel128Bpp | Channel Count = 8, Bits Per Channel = 16, Bits Per Pixel = 128, Storage Type = uint
EightChannel64Bpp | Channel Count = 8, Bits Per Channel = 8, Bits Per Pixel = 64, Storage Type = uint
EightChannelAlpha144Bpp | Channel Count = 9, Bits Per Channel = 16, Bits Per Pixel = 144, Storage Type = uint
EightChannelAlpha72Bpp | Channel Count = 9, Bits Per Channel = 8, Bits Per Pixel = 72, Storage Type = uint
FiveChannel40Bpp | Channel Count = 5, Bits Per Channel = 8, Bits Per Pixel = 40, Storage Type = uint
FiveChannel80Bpp | Channel Count = 5, Bits Per Channel = 16, Bits Per Pixel = 80, Storage Type = uint
FiveChannelAlpha48Bpp | Channel Count = 6, Bits Per Channel = 8, Bits Per Pixel = 48, Storage Type = uint
FiveChannelAlpha96Bpp | Channel Count = 6, Bits Per Channel = 16, Bits Per Pixel = 96, Storage Type = uint
FourChannel32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint
FourChannel64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint
FourChannelAlpha40Bpp | Channel Count = 5, Bits Per Channel = 8, Bits Per Pixel = 40, Storage Type = uint
FourChannelAlpha80Bpp | Channel Count = 5, Bits Per Channel = 16, Bits Per Pixel = 80, Storage Type = uint
Gray16Bpp | Channel Count = 1, Bits Per Channel = 16, Bits Per Pixel = 16, Storage Type = uint Color data represents shades of gray.
Gray2Bpp | Channel Count = 1, Bits Per Channel = 2, Bits Per Pixel = 2, Storage Type = uint Color data represents shades of gray.
Gray4Bpp | Channel Count = 1, Bits Per Channel = 4, Bits Per Pixel = 4, Storage Type = uint Color data represents shades of gray.
Gray8Bpp | Channel Count = 1, Bits Per Channel = 8, Bits Per Pixel = 8, Storage Type = uint Color data represents shades of gray.
GrayFixedPoint16Bpp | Channel Count = 1, Bits Per Channel = 16, Bits Per Pixel = 16, Storage Type = FixedPoint Color data represents shades of gray.
GrayFixedPoint32Bpp | Channel Count = 1, Bits Per Channel = 32, Bits Per Pixel = 32, Storage Type = FixedPoint Color data represents shades of gray.
GrayFloat32Bpp | Channel Count = 1, Bits Per Channel = 32, Bits Per Pixel = 32, Storage Type = float Color data represents shades of gray.
GrayHalf16Bpp | Channel Count = 1, Bits Per Channel = 16, Bits Per Pixel = 16, Storage Type = float Color data represents shades of gray.
Indexed1Bpp | Channel Count = 1, Bits Per Channel = 1, Bits Per Pixel = 1, Storage Type = uint The value for each pixel is an index into a color palette.
Indexed2Bpp | Channel Count = 1, Bits Per Channel = 2, Bits Per Pixel = 2, Storage Type = uint The value for each pixel is an index into a color palette.
Indexed4Bpp | Channel Count = 1, Bits Per Channel = 4, Bits Per Pixel = 4, Storage Type = uint The value for each pixel is an index into a color palette.
Indexed8Bpp | Channel Count = 1, Bits Per Channel = 8, Bits Per Pixel = 8, Storage Type = uint The value for each pixel is an index into a color palette.
Pbgra32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
Prgba32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels. RGB channels premultiplied with alpha.
Prgba64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels. RGB channels premultiplied with alpha.
PrgbaFloat128Bpp | Channel Count = 4, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = float Color data is separated into red(R), green(G), blue(B), and alpha(A) channels. RGB channels premultiplied with alpha.
Rgb24Bpp | Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 24, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.
Rgb48Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.
Rgba32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
Rgba64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
RgbaFixedPoint128Bpp | Channel Count = 4, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = Fixed Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
RgbaFixedPoint64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = Fixed Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
RgbaFloat128Bpp | Channel Count = 4, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = float Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
RgbaHalf64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = float Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.
Rgbe32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and exponent(E) channels. This format has an additional byte for shared exponent information. This provides additional floating-point precision without the additional memory needed for a true floating-point format.
RgbFixedPoint128Bpp | Channel Count = 3, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.
RgbFixedPoint48Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.
RgbFixedPoint64Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.
RgbFixedPoint96Bpp | Channel Count = 3, Bits Per Channel = 32, Bits Per Pixel = 96, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.
RgbFloat128Bpp | Channel Count = 3, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = float Color data is separated into red(R), green(G), and blue(B) channels.
RgbHalf48Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = float Color data is separated into red(R), green(G), and blue(B) channels.
RgbHalf64Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = float Color data is separated into red(R), green(G), and blue(B) channels.
SevenChannel112Bpp | Channel Count = 7, Bits Per Channel = 16, Bits Per Pixel = 112, Storage Type = uint
SevenChannel56Bpp | Channel Count = 7, Bits Per Channel = 8, Bits Per Pixel = 56, Storage Type = uint
SevenChannelAlpha128Bpp | Channel Count = 8, Bits Per Channel = 16, Bits Per Pixel = 128, Storage Type = uint
SevenChannelAlpha64Bpp | Channel Count = 8, Bits Per Channel = 8, Bits Per Pixel = 64, Storage Type = uint
SixChannel48Bpp | Channel Count = 6, Bits Per Channel = 8, Bits Per Pixel = 48, Storage Type = uint
SixChannel96Bpp | Channel Count = 6, Bits Per Channel = 16, Bits Per Pixel = 96, Storage Type = uint
SixChannelAlpha112Bpp | Channel Count = 7, Bits Per Channel = 16, Bits Per Pixel = 112, Storage Type = uint
SixChannelAlpha56Bpp | Channel Count = 7, Bits Per Channel = 8, Bits Per Pixel = 56, Storage Type = uint
ThreeChannel24Bpp | Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 24, Storage Type = uint
ThreeChannel48Bpp | Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = uint
ThreeChannelAlpha32Bpp | Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint
ThreeChannelAlpha64Bpp | Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Bgr10101032Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Bgr10101032Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 10, Bits Per Pixel = 32, Storage Type = uint Color-channel data crosses byte boundaries.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Bgr10101032Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Bgr10101032Bpp As Guid
    Get
Visual C++
public:
static property Guid Bgr10101032Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Bgr24Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Bgr24Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 24, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Bgr24Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Bgr24Bpp As Guid
    Get
Visual C++
public:
static property Guid Bgr24Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Bgr32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Bgr32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Bgr32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Bgr32Bpp As Guid
    Get
Visual C++
public:
static property Guid Bgr32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Bgr55516Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Bgr55516Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 5, Bits Per Pixel = 16, Storage Type = uint Color-channel data crosses byte boundaries.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Bgr55516Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Bgr55516Bpp As Guid
    Get
Visual C++
public:
static property Guid Bgr55516Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Bgr56516Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Bgr56516Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 5(B)/6(G)/5(R), Bits Per Pixel = 16, Storage Type = uint Color-channel data crosses byte boundaries.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Bgr56516Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Bgr56516Bpp As Guid
    Get
Visual C++
public:
static property Guid Bgr56516Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Bgra32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Bgra32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Bgra32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Bgra32Bpp As Guid
    Get
Visual C++
public:
static property Guid Bgra32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


BlackWhite Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..BlackWhite Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 1, Bits Per Pixel = 1, Storage Type = uint Color data represents shades of gray.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid BlackWhite { get; }
Visual Basic
Public Shared ReadOnly Property BlackWhite As Guid
    Get
Visual C++
public:
static property Guid BlackWhite {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Cmyk32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Cmyk32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), and black(K) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Cmyk32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Cmyk32Bpp As Guid
    Get
Visual C++
public:
static property Guid Cmyk32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Cmyk64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Cmyk64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), and black(K) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Cmyk64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Cmyk64Bpp As Guid
    Get
Visual C++
public:
static property Guid Cmyk64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CmykAlpha40Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..CmykAlpha40Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 5, Bits Per Channel = 8, Bits Per Pixel = 40, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), black(K), and alpha channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid CmykAlpha40Bpp { get; }
Visual Basic
Public Shared ReadOnly Property CmykAlpha40Bpp As Guid
    Get
Visual C++
public:
static property Guid CmykAlpha40Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CmykAlpha80Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..CmykAlpha80Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 5, Bits Per Channel = 16, Bits Per Pixel = 80, Storage Type = Fixed Color data is separated into cyan(C), magenta(M), yellow(Y), black(K), and alpha channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid CmykAlpha80Bpp { get; }
Visual Basic
Public Shared ReadOnly Property CmykAlpha80Bpp As Guid
    Get
Visual C++
public:
static property Guid CmykAlpha80Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


DoNotCare Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..DoNotCare Property
PixelFormats Class See Also Send Feedback
A pixel format used when the actual pixelformat is unimportant to an image operation.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid DoNotCare { get; }
Visual Basic
Public Shared ReadOnly Property DoNotCare As Guid
    Get
Visual C++
public:
static property Guid DoNotCare {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


EightChannel128Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..EightChannel128Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 8, Bits Per Channel = 16, Bits Per Pixel = 128, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid EightChannel128Bpp { get; }
Visual Basic
Public Shared ReadOnly Property EightChannel128Bpp As Guid
    Get
Visual C++
public:
static property Guid EightChannel128Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


EightChannel64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..EightChannel64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 8, Bits Per Channel = 8, Bits Per Pixel = 64, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid EightChannel64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property EightChannel64Bpp As Guid
    Get
Visual C++
public:
static property Guid EightChannel64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


EightChannelAlpha144Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..EightChannelAlpha144Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 9, Bits Per Channel = 16, Bits Per Pixel = 144, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid EightChannelAlpha144Bpp { get; }
Visual Basic
Public Shared ReadOnly Property EightChannelAlpha144Bpp As Guid
    Get
Visual C++
public:
static property Guid EightChannelAlpha144Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


EightChannelAlpha72Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..EightChannelAlpha72Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 9, Bits Per Channel = 8, Bits Per Pixel = 72, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid EightChannelAlpha72Bpp { get; }
Visual Basic
Public Shared ReadOnly Property EightChannelAlpha72Bpp As Guid
    Get
Visual C++
public:
static property Guid EightChannelAlpha72Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FiveChannel40Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..FiveChannel40Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 5, Bits Per Channel = 8, Bits Per Pixel = 40, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid FiveChannel40Bpp { get; }
Visual Basic
Public Shared ReadOnly Property FiveChannel40Bpp As Guid
    Get
Visual C++
public:
static property Guid FiveChannel40Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FiveChannel80Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..FiveChannel80Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 5, Bits Per Channel = 16, Bits Per Pixel = 80, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid FiveChannel80Bpp { get; }
Visual Basic
Public Shared ReadOnly Property FiveChannel80Bpp As Guid
    Get
Visual C++
public:
static property Guid FiveChannel80Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FiveChannelAlpha48Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..FiveChannelAlpha48Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 6, Bits Per Channel = 8, Bits Per Pixel = 48, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid FiveChannelAlpha48Bpp { get; }
Visual Basic
Public Shared ReadOnly Property FiveChannelAlpha48Bpp As Guid
    Get
Visual C++
public:
static property Guid FiveChannelAlpha48Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FiveChannelAlpha96Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..FiveChannelAlpha96Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 6, Bits Per Channel = 16, Bits Per Pixel = 96, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid FiveChannelAlpha96Bpp { get; }
Visual Basic
Public Shared ReadOnly Property FiveChannelAlpha96Bpp As Guid
    Get
Visual C++
public:
static property Guid FiveChannelAlpha96Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FourChannel32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..FourChannel32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid FourChannel32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property FourChannel32Bpp As Guid
    Get
Visual C++
public:
static property Guid FourChannel32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FourChannel64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..FourChannel64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid FourChannel64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property FourChannel64Bpp As Guid
    Get
Visual C++
public:
static property Guid FourChannel64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FourChannelAlpha40Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..FourChannelAlpha40Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 5, Bits Per Channel = 8, Bits Per Pixel = 40, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid FourChannelAlpha40Bpp { get; }
Visual Basic
Public Shared ReadOnly Property FourChannelAlpha40Bpp As Guid
    Get
Visual C++
public:
static property Guid FourChannelAlpha40Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


FourChannelAlpha80Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..FourChannelAlpha80Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 5, Bits Per Channel = 16, Bits Per Pixel = 80, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid FourChannelAlpha80Bpp { get; }
Visual Basic
Public Shared ReadOnly Property FourChannelAlpha80Bpp As Guid
    Get
Visual C++
public:
static property Guid FourChannelAlpha80Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Gray16Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Gray16Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 16, Bits Per Pixel = 16, Storage Type = uint Color data represents shades of gray.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Gray16Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Gray16Bpp As Guid
    Get
Visual C++
public:
static property Guid Gray16Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Gray2Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Gray2Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 2, Bits Per Pixel = 2, Storage Type = uint Color data represents shades of gray.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Gray2Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Gray2Bpp As Guid
    Get
Visual C++
public:
static property Guid Gray2Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Gray4Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Gray4Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 4, Bits Per Pixel = 4, Storage Type = uint Color data represents shades of gray.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Gray4Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Gray4Bpp As Guid
    Get
Visual C++
public:
static property Guid Gray4Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Gray8Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Gray8Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 8, Bits Per Pixel = 8, Storage Type = uint Color data represents shades of gray.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Gray8Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Gray8Bpp As Guid
    Get
Visual C++
public:
static property Guid Gray8Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


GrayFixedPoint16Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..GrayFixedPoint16Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 16, Bits Per Pixel = 16, Storage Type = FixedPoint Color data represents shades of gray.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid GrayFixedPoint16Bpp { get; }
Visual Basic
Public Shared ReadOnly Property GrayFixedPoint16Bpp As Guid
    Get
Visual C++
public:
static property Guid GrayFixedPoint16Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


GrayFixedPoint32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..GrayFixedPoint32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 32, Bits Per Pixel = 32, Storage Type = FixedPoint Color data represents shades of gray.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid GrayFixedPoint32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property GrayFixedPoint32Bpp As Guid
    Get
Visual C++
public:
static property Guid GrayFixedPoint32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


GrayFloat32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..GrayFloat32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 32, Bits Per Pixel = 32, Storage Type = float Color data represents shades of gray.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid GrayFloat32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property GrayFloat32Bpp As Guid
    Get
Visual C++
public:
static property Guid GrayFloat32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


GrayHalf16Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..GrayHalf16Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 16, Bits Per Pixel = 16, Storage Type = float Color data represents shades of gray.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid GrayHalf16Bpp { get; }
Visual Basic
Public Shared ReadOnly Property GrayHalf16Bpp As Guid
    Get
Visual C++
public:
static property Guid GrayHalf16Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Indexed1Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Indexed1Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 1, Bits Per Pixel = 1, Storage Type = uint The value for each pixel is an index into a color palette.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Indexed1Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Indexed1Bpp As Guid
    Get
Visual C++
public:
static property Guid Indexed1Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Indexed2Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Indexed2Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 2, Bits Per Pixel = 2, Storage Type = uint The value for each pixel is an index into a color palette.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Indexed2Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Indexed2Bpp As Guid
    Get
Visual C++
public:
static property Guid Indexed2Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Indexed4Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Indexed4Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 4, Bits Per Pixel = 4, Storage Type = uint The value for each pixel is an index into a color palette.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Indexed4Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Indexed4Bpp As Guid
    Get
Visual C++
public:
static property Guid Indexed4Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Indexed8Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Indexed8Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 1, Bits Per Channel = 8, Bits Per Pixel = 8, Storage Type = uint The value for each pixel is an index into a color palette.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Indexed8Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Indexed8Bpp As Guid
    Get
Visual C++
public:
static property Guid Indexed8Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Pbgra32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Pbgra32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Pbgra32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Pbgra32Bpp As Guid
    Get
Visual C++
public:
static property Guid Pbgra32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Prgba32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Prgba32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels. RGB channels premultiplied with alpha.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Prgba32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Prgba32Bpp As Guid
    Get
Visual C++
public:
static property Guid Prgba32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Prgba64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Prgba64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels. RGB channels premultiplied with alpha.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Prgba64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Prgba64Bpp As Guid
    Get
Visual C++
public:
static property Guid Prgba64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


PrgbaFloat128Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..PrgbaFloat128Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = float Color data is separated into red(R), green(G), blue(B), and alpha(A) channels. RGB channels premultiplied with alpha.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid PrgbaFloat128Bpp { get; }
Visual Basic
Public Shared ReadOnly Property PrgbaFloat128Bpp As Guid
    Get
Visual C++
public:
static property Guid PrgbaFloat128Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Rgb24Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Rgb24Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 24, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Rgb24Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Rgb24Bpp As Guid
    Get
Visual C++
public:
static property Guid Rgb24Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Rgb48Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Rgb48Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = uint Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Rgb48Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Rgb48Bpp As Guid
    Get
Visual C++
public:
static property Guid Rgb48Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Rgba32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Rgba32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Rgba32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Rgba32Bpp As Guid
    Get
Visual C++
public:
static property Guid Rgba32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Rgba64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Rgba64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Rgba64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Rgba64Bpp As Guid
    Get
Visual C++
public:
static property Guid Rgba64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbaFixedPoint128Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbaFixedPoint128Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = Fixed Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbaFixedPoint128Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbaFixedPoint128Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbaFixedPoint128Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbaFixedPoint64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbaFixedPoint64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = Fixed Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbaFixedPoint64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbaFixedPoint64Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbaFixedPoint64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbaFloat128Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbaFloat128Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = float Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbaFloat128Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbaFloat128Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbaFloat128Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbaHalf64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbaHalf64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = float Color data is separated into red(R), green(G), blue(B), and alpha(A) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbaHalf64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbaHalf64Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbaHalf64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Rgbe32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..Rgbe32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint Color data is separated into red(R), green(G), blue(B), and exponent(E) channels. This format has an additional byte for shared exponent information. This provides additional floating-point precision without the additional memory needed for a true floating-point format.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid Rgbe32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property Rgbe32Bpp As Guid
    Get
Visual C++
public:
static property Guid Rgbe32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbFixedPoint128Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbFixedPoint128Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbFixedPoint128Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbFixedPoint128Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbFixedPoint128Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbFixedPoint48Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbFixedPoint48Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbFixedPoint48Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbFixedPoint48Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbFixedPoint48Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbFixedPoint64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbFixedPoint64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbFixedPoint64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbFixedPoint64Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbFixedPoint64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbFixedPoint96Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbFixedPoint96Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 32, Bits Per Pixel = 96, Storage Type = Fixed Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbFixedPoint96Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbFixedPoint96Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbFixedPoint96Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbFloat128Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbFloat128Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 32, Bits Per Pixel = 128, Storage Type = float Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbFloat128Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbFloat128Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbFloat128Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbHalf48Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbHalf48Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = float Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbHalf48Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbHalf48Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbHalf48Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


RgbHalf64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..RgbHalf64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = float Color data is separated into red(R), green(G), and blue(B) channels.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid RgbHalf64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property RgbHalf64Bpp As Guid
    Get
Visual C++
public:
static property Guid RgbHalf64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SevenChannel112Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..SevenChannel112Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 7, Bits Per Channel = 16, Bits Per Pixel = 112, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid SevenChannel112Bpp { get; }
Visual Basic
Public Shared ReadOnly Property SevenChannel112Bpp As Guid
    Get
Visual C++
public:
static property Guid SevenChannel112Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SevenChannel56Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..SevenChannel56Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 7, Bits Per Channel = 8, Bits Per Pixel = 56, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid SevenChannel56Bpp { get; }
Visual Basic
Public Shared ReadOnly Property SevenChannel56Bpp As Guid
    Get
Visual C++
public:
static property Guid SevenChannel56Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SevenChannelAlpha128Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..SevenChannelAlpha128Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 8, Bits Per Channel = 16, Bits Per Pixel = 128, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid SevenChannelAlpha128Bpp { get; }
Visual Basic
Public Shared ReadOnly Property SevenChannelAlpha128Bpp As Guid
    Get
Visual C++
public:
static property Guid SevenChannelAlpha128Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SevenChannelAlpha64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..SevenChannelAlpha64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 8, Bits Per Channel = 8, Bits Per Pixel = 64, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid SevenChannelAlpha64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property SevenChannelAlpha64Bpp As Guid
    Get
Visual C++
public:
static property Guid SevenChannelAlpha64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SixChannel48Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..SixChannel48Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 6, Bits Per Channel = 8, Bits Per Pixel = 48, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid SixChannel48Bpp { get; }
Visual Basic
Public Shared ReadOnly Property SixChannel48Bpp As Guid
    Get
Visual C++
public:
static property Guid SixChannel48Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SixChannel96Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..SixChannel96Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 6, Bits Per Channel = 16, Bits Per Pixel = 96, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid SixChannel96Bpp { get; }
Visual Basic
Public Shared ReadOnly Property SixChannel96Bpp As Guid
    Get
Visual C++
public:
static property Guid SixChannel96Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SixChannelAlpha112Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..SixChannelAlpha112Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 7, Bits Per Channel = 16, Bits Per Pixel = 112, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid SixChannelAlpha112Bpp { get; }
Visual Basic
Public Shared ReadOnly Property SixChannelAlpha112Bpp As Guid
    Get
Visual C++
public:
static property Guid SixChannelAlpha112Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SixChannelAlpha56Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..SixChannelAlpha56Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 7, Bits Per Channel = 8, Bits Per Pixel = 56, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid SixChannelAlpha56Bpp { get; }
Visual Basic
Public Shared ReadOnly Property SixChannelAlpha56Bpp As Guid
    Get
Visual C++
public:
static property Guid SixChannelAlpha56Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ThreeChannel24Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..ThreeChannel24Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 8, Bits Per Pixel = 24, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid ThreeChannel24Bpp { get; }
Visual Basic
Public Shared ReadOnly Property ThreeChannel24Bpp As Guid
    Get
Visual C++
public:
static property Guid ThreeChannel24Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ThreeChannel48Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..ThreeChannel48Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 3, Bits Per Channel = 16, Bits Per Pixel = 48, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid ThreeChannel48Bpp { get; }
Visual Basic
Public Shared ReadOnly Property ThreeChannel48Bpp As Guid
    Get
Visual C++
public:
static property Guid ThreeChannel48Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ThreeChannelAlpha32Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..ThreeChannelAlpha32Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 8, Bits Per Pixel = 32, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid ThreeChannelAlpha32Bpp { get; }
Visual Basic
Public Shared ReadOnly Property ThreeChannelAlpha32Bpp As Guid
    Get
Visual C++
public:
static property Guid ThreeChannelAlpha32Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


ThreeChannelAlpha64Bpp Property

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
PixelFormats..::..ThreeChannelAlpha64Bpp Property
PixelFormats Class See Also Send Feedback
Channel Count = 4, Bits Per Channel = 16, Bits Per Pixel = 64, Storage Type = uint

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public static Guid ThreeChannelAlpha64Bpp { get; }
Visual Basic
Public Shared ReadOnly Property ThreeChannelAlpha64Bpp As Guid
    Get
Visual C++
public:
static property Guid ThreeChannelAlpha64Bpp {
    Guid get ();
}

See Also

PixelFormats Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


StreamWrapper Class

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper Class
Members See Also Send Feedback
This is an object that provides a managed System.IO.Stream object with a COM IStream implementation.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public class StreamWrapper : IStream
Visual Basic
Public Class StreamWrapper _
    Implements IStream
Visual C++
public ref class StreamWrapper : IStream

Inheritance Hierarchy

System..::..Object
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent..::..StreamWrapper

See Also

StreamWrapper Members
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


StreamWrapper Members

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper Members
StreamWrapper Class Constructors Methods See Also Send Feedback

The StreamWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | StreamWrapper | Creates an StreamWrapper for the specified stream.

Methods

 | Name | Description
Protected method | Clone |
Protected method | Commit |
Protected method | CopyTo |
Protected method | LockRegion |
Protected method | Read |
Protected method | Revert |
Protected method | Seek |
Protected method | SetSize |
Protected method | Stat |
Protected method | UnlockRegion |
Protected method | Write |

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


StreamWrapper Constructor

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper Constructor
StreamWrapper Class See Also Send Feedback
Creates an StreamWrapper for the specified stream.

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
public StreamWrapper(
    Stream stream
)
Visual Basic
Public Sub New ( _
    stream As Stream _
)
Visual C++
public:
StreamWrapper(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream to wrap.

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


StreamWrapper Methods

[image] [image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper Methods
StreamWrapper Class See Also Send Feedback

The StreamWrapper type exposes the following members.

Methods

 | Name | Description
Protected method | Clone |
Protected method | Commit |
Protected method | CopyTo |
Protected method | LockRegion |
Protected method | Read |
Protected method | Revert |
Protected method | Seek |
Protected method | SetSize |
Protected method | Stat |
Protected method | UnlockRegion |
Protected method | Write |

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Clone Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..Clone Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Clone(
    ref IStream ppstm
)
Visual Basic
Protected Overridable Sub Clone ( _
    ByRef ppstm As IStream _
)
Visual C++
protected:
virtual void Clone(
    IStream^% ppstm
)

Parameters

ppstm
Type: System.Runtime.InteropServices.ComTypes..::..IStream %

Implements

IStream..::..Clone(IStream%)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Commit Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..Commit Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Commit(
    int grfCommitFlags
)
Visual Basic
Protected Overridable Sub Commit ( _
    grfCommitFlags As Integer _
)
Visual C++
protected:
virtual void Commit(
    int grfCommitFlags
)

Parameters

grfCommitFlags
Type: System..::..Int32

Implements

IStream..::..Commit(Int32)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


CopyTo Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..CopyTo Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void CopyTo(
    IStream pstm,
    long cb,
    IntPtr pcbRead,
    IntPtr pcbWritten
)
Visual Basic
Protected Overridable Sub CopyTo ( _
    pstm As IStream, _
    cb As Long, _
    pcbRead As IntPtr, _
    pcbWritten As IntPtr _
)
Visual C++
protected:
virtual void CopyTo(
    IStream^ pstm,
    long long cb,
    IntPtr pcbRead,
    IntPtr pcbWritten
)

Parameters

pstm
Type: System.Runtime.InteropServices.ComTypes..::..IStream
cb
Type: System..::..Int64
pcbRead
Type: System..::..IntPtr
pcbWritten
Type: System..::..IntPtr

Implements

IStream..::..CopyTo(IStream, Int64, IntPtr, IntPtr)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


LockRegion Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..LockRegion Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void LockRegion(
    long libOffset,
    long cb,
    int dwLockType
)
Visual Basic
Protected Overridable Sub LockRegion ( _
    libOffset As Long, _
    cb As Long, _
    dwLockType As Integer _
)
Visual C++
protected:
virtual void LockRegion(
    long long libOffset,
    long long cb,
    int dwLockType
)

Parameters

libOffset
Type: System..::..Int64
cb
Type: System..::..Int64
dwLockType
Type: System..::..Int32

Implements

IStream..::..LockRegion(Int64, Int64, Int32)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Read Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..Read Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Read(
    byte[] pv,
    int cb,
    IntPtr pcbRead
)
Visual Basic
Protected Overridable Sub Read ( _
    pv As Byte(), _
    cb As Integer, _
    pcbRead As IntPtr _
)
Visual C++
protected:
virtual void Read(
    array<unsigned char>^ pv,
    int cb,
    IntPtr pcbRead
)

Parameters

pv
Type: array< System..::..Byte >[]()[][]
cb
Type: System..::..Int32
pcbRead
Type: System..::..IntPtr

Implements

IStream..::..Read(array<Byte>[]()[][], Int32, IntPtr)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Revert Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..Revert Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Revert()
Visual Basic
Protected Overridable Sub Revert
Visual C++
protected:
virtual void Revert()

Implements

IStream..::..Revert()()()()

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Seek Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..Seek Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Seek(
    long dlibMove,
    int dwOrigin,
    IntPtr plibNewPosition
)
Visual Basic
Protected Overridable Sub Seek ( _
    dlibMove As Long, _
    dwOrigin As Integer, _
    plibNewPosition As IntPtr _
)
Visual C++
protected:
virtual void Seek(
    long long dlibMove,
    int dwOrigin,
    IntPtr plibNewPosition
)

Parameters

dlibMove
Type: System..::..Int64
dwOrigin
Type: System..::..Int32
plibNewPosition
Type: System..::..IntPtr

Implements

IStream..::..Seek(Int64, Int32, IntPtr)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


SetSize Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..SetSize Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void SetSize(
    long libNewSize
)
Visual Basic
Protected Overridable Sub SetSize ( _
    libNewSize As Long _
)
Visual C++
protected:
virtual void SetSize(
    long long libNewSize
)

Parameters

libNewSize
Type: System..::..Int64

Implements

IStream..::..SetSize(Int64)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Stat Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..Stat Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Stat(
    ref STATSTG pstatstg,
    int grfStatFlag
)
Visual Basic
Protected Overridable Sub Stat ( _
    ByRef pstatstg As STATSTG, _
    grfStatFlag As Integer _
)
Visual C++
protected:
virtual void Stat(
    STATSTG% pstatstg,
    int grfStatFlag
)

Parameters

pstatstg
Type: System.Runtime.InteropServices.ComTypes..::..STATSTG %
grfStatFlag
Type: System..::..Int32

Implements

IStream..::..Stat(STATSTG%, Int32)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


UnlockRegion Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..UnlockRegion Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void UnlockRegion(
    long libOffset,
    long cb,
    int dwLockType
)
Visual Basic
Protected Overridable Sub UnlockRegion ( _
    libOffset As Long, _
    cb As Long, _
    dwLockType As Integer _
)
Visual C++
protected:
virtual void UnlockRegion(
    long long libOffset,
    long long cb,
    int dwLockType
)

Parameters

libOffset
Type: System..::..Int64
cb
Type: System..::..Int64
dwLockType
Type: System..::..Int32

Implements

IStream..::..UnlockRegion(Int64, Int64, Int32)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace


Write Method

[image]

Windows® API Code Pack for Microsoft® .NET Framework - DirectX Documentation
StreamWrapper..::..Write Method
StreamWrapper Class See Also Send Feedback

Namespace: Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent
Assembly: Microsoft.WindowsAPICodePack.DirectX (in Microsoft.WindowsAPICodePack.DirectX.dll) Version: 1.1.0.0 (1.1.0.0)

Syntax

C#
protected virtual void Write(
    byte[] pv,
    int cb,
    IntPtr pcbWritten
)
Visual Basic
Protected Overridable Sub Write ( _
    pv As Byte(), _
    cb As Integer, _
    pcbWritten As IntPtr _
)
Visual C++
protected:
virtual void Write(
    array<unsigned char>^ pv,
    int cb,
    IntPtr pcbWritten
)

Parameters

pv
Type: array< System..::..Byte >[]()[][]
cb
Type: System..::..Int32
pcbWritten
Type: System..::..IntPtr

Implements

IStream..::..Write(array<Byte>[]()[][], Int32, IntPtr)

See Also

StreamWrapper Class
Microsoft.WindowsAPICodePack.DirectX.WindowsImagingComponent Namespace